Opened 6 years ago

Closed 5 years ago

#1766 closed defect (done)

HL shouldn't crash if the Hive Job Manager can't deserialize a job

Reported by: ascheibe Owned by: ascheibe
Priority: medium Milestone: HeuristicLab 3.3.7
Component: Hive.Client Version: 3.3.7
Keywords: Cc:

Description

The exception should be caught and a dialog with the needed assembly versions should be displayed.

Change History (5)

comment:1 Changed 6 years ago by ascheibe

r7409 fixed crash when the hive job manager can't deserialize a task

comment:2 Changed 6 years ago by ascheibe

  • Status changed from new to accepted

comment:3 Changed 6 years ago by ascheibe

  • Owner changed from ascheibe to mkommend
  • Status changed from accepted to reviewing

If deserialization fails, the standard HL error dialog is shown. It includes the persistence exception so you can see what the problem is. Note that all exceptions are also written to the log, so you can also have a look at the log view for more details.

comment:4 Changed 5 years ago by mkommend

  • Owner changed from mkommend to ascheibe
  • Status changed from reviewing to readytorelease

Thanks for correcting this issue. The exception dialog as well as the log information work fine.

comment:5 Changed 5 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.