Opened 6 years ago

Closed 3 years ago

#1758 closed feature request (done)

Change Dataset of RegressionModel

Reported by: sforsten Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.10
Component: Problems.DataAnalysis Version: 3.3.9
Keywords: Cc:

Description

A new button will be added in the RegressionSolutionView to import a new data set to a regression model to easily test models with different data set.

The new data sets will be checked if they fit the model, before they are applied.

The import will be able to load .hl files with problem data or problems, where they problem data of the Problem is loaded.

Change History (37)

comment:1 Changed 6 years ago by sforsten

  • Status changed from new to accepted
  • Summary changed from Change Dataset of Model to Change Dataset of RegressionModel

comment:2 Changed 6 years ago by sforsten

  • Version changed from 3.3.6 to branch

comment:3 Changed 6 years ago by sforsten

r7338: first version to change the data set in a model has been implemented

comment:4 Changed 6 years ago by sforsten

r7347:

  • Bug fix in ItemCollectionView: Content events are deregistered in Dispose method
  • Bug fix in ItemCollectionView: Item events are deregistered in OnContentChanged method
  • small changes in RegressionSolutionView

comment:5 Changed 6 years ago by sforsten

r7399:

  • implemented SetEnabledStateOfControls in RegressionSolutionView
  • fixed bug in NamedDataAnalysisSolutionView (If OnContentChanged creates a new DataAnalysisSolutionView, it sets Locked and ReadOnly as it is set in the current view.)

comment:6 Changed 6 years ago by sforsten

r7404:

  • branch has been adjusted
  • bug fix in DataAnalysisSolutionView

comment:7 Changed 6 years ago by sforsten

  • Owner changed from sforsten to mkommend
  • Status changed from accepted to reviewing

comment:8 Changed 6 years ago by mkommend

r7468: Minor code improvements (variable naming, return conditions).

comment:9 Changed 6 years ago by mkommend

  • Owner changed from mkommend to sforsten
  • Status changed from reviewing to assigned

Please look over the changes made in r7468. Additionally the import method should be separated from the reaction to the button click and a new method should be implemented which checks if the model can handle the loaded ProblemData.

comment:10 Changed 6 years ago by sforsten

  • Owner changed from sforsten to mkommend
  • Status changed from assigned to reviewing

r7487: changes according to mkommend's reviewing comments have been made and catch blocks now only catch specific exceptions

comment:11 Changed 5 years ago by mkommend

  • Version changed from branch to 3.3.7

comment:12 Changed 5 years ago by mkommend

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.7
  • Version changed from 3.3.7 to branch

comment:13 Changed 5 years ago by sforsten

r8032:

  • merged trunk r7330:8022 into branch
  • importButton shows a message, if clicked and it can't be used

comment:14 Changed 5 years ago by mkommend

  • Status changed from reviewing to readytorelease

comment:15 Changed 5 years ago by mkommend

  • Status changed from readytorelease to reviewing

comment:16 Changed 5 years ago by gkronber

  • Milestone HeuristicLab 3.3.7 deleted

This ticket contains only branch changes and will not be included in milestone 3.3.7.

comment:17 Changed 5 years ago by sforsten

r8513: merged r8023:8509 from trunk to branch to make it useable again

comment:18 Changed 5 years ago by sforsten

r8591: merged r8510:8590 from trunk to branch

comment:19 Changed 4 years ago by mkommend

  • Milestone set to HeuristicLab 3.3.x Backlog

comment:20 Changed 4 years ago by mkommend

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.10
  • Status changed from reviewing to assigned
  • Version changed from branch to 3.3.9

This ticket is rather outdated and contains modification which were applied already on the trunk. As the functionality is still important, I will extract the relevant changes and apply them directly at the trunk.

The changes above are obsolete and need not be reviewed.

comment:21 Changed 4 years ago by mkommend

  • Status changed from assigned to accepted

comment:22 Changed 4 years ago by mkommend

r10173: Extended the drap and drop functionality of DataAnalysisSolutionViews to allow dropping the problem itself in addition to the problem data.

comment:23 Changed 4 years ago by mkommend

r10174: Added check of target and inputvariables of dropped ProblemData.

comment:24 Changed 4 years ago by mkommend

  • Owner changed from mkommend to abeham
  • Status changed from accepted to reviewing

r10175: Added button to load new data into data analysis solutions.

comment:25 Changed 4 years ago by mkommend

r10176: Corrected plugin dependencies of "HeuristicLab.Problems.DataAnalysis.Views".

comment:26 Changed 4 years ago by mkommend

Please review r10173, r10174, r10175, and r10176.

comment:27 Changed 4 years ago by mkommend

The branch "ChangeDatasetOfRegressionModel" can be deleted when this ticket is ready to release.

comment:28 follow-up: Changed 4 years ago by abeham

  • Owner changed from abeham to mkommend
  • Status changed from reviewing to assigned
  • "Load Data" is not really a good indicator of what this action will be doing. It creates a new solution and doesn't alter the current solution as one might expect when clicking "Load Data". There is little indication why I should use and click this.
  • Load Data should also consider that there is a ProblemData inside a saved data analysis solution. I first tried to load the data from a stored solution and got an error that there is no problem data.
  • I think it's too generic to open ".hl" files. It's not clear to the user what kind of file can be opened or not. Would it also be feasible to use the instance importer to open files?
  • The solutions gets a really long name if this feature is used: "GaussianProcessRegressionSolution with loaded problem data (System.Windows.Forms.OpenFileDialog: Title: Load new ProblemData or Problem..., FileName: C:\Users\somepath\ProblemData.hl)". Put some of this in the description and simplify the name. For example try to use load data in this view one more time, the name gets longer and longer.
  • When one uses Drag and Drop to use new problem data, the name doesn't get changed. It potentially still says "with loaded problem data ..."
  • It seems the Simplify button is one pixel less in height than the other buttons
  • The Details text of the GroupBox is rather close to the "Load Data" button. Also it's kind of strange to have Simplify and Load Data on the left and the Export Button on the right and none of them have any icons. For solutions that are not simplifyable the layout has even more gaps.
  • When I load an entirely different data set it only shows that the target variable is different, not the also the inputs are not compatible because CheckCompatibilityOfProblemData ignores errors in base classes when it finds and error itself.
  • Not part of this ticket, but it's not clear what "Export" does until I clicked it and I saw that it creates an Excel file. Is it possible to add an Excel icon to this button? Also I think it's not really an "Export", but rather some kind of "continue analysing in Excel" feature. Technically it may be seen as an export though.

comment:29 Changed 3 years ago by mkommend

r10540: Reimplemented functionality to load new problem data to data analysis solution and redesigned the according views.

  • Added setter for the target variable of regression and classification problem data.
  • Added functionality to check the compatibility of problem data.
  • Added functionality to adjust the properties of a problem data.
  • Added flowLayoutPanel with according buttons for loading a new problem data, simplifying and exporting data analysis solutions.
  • TradingProblemData currently throws a NotSupportedException when the properties should be adjusted.

comment:30 Changed 3 years ago by mkommend

r10541: Updated button tooltips.

comment:31 Changed 3 years ago by mkommend

r10543: Corrected plugin dependencies in views plugins.

comment:32 Changed 3 years ago by mkommend

r10545: Added icons to simplifier buttons (simplify, optimize).

comment:33 in reply to: ↑ 28 Changed 3 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from assigned to reviewing

Replying to abeham:

  • I think it's too generic to open ".hl" files. It's not clear to the user what kind of file can be opened or not. Would it also be feasible to use the instance importer to open files?

It is not feasible to reuse the instance importer, because otherwise the problem has to be configured again. IMHO loading HL files is fine.

All other review comments have been addressed in the previous commits.

comment:34 Changed 3 years ago by gkronber

Reviewed r10173:10176 and r10540, r10541, r10543, and r10545.

comment:35 Changed 3 years ago by gkronber

r11031: made appropriate changes to the problem data classes for trading and time series prognosis

comment:36 Changed 3 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to readytorelease

Please review if r11031 is ok with you. Other than that I think this ticket is ready for release.

comment:37 Changed 3 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed

r11144: Merged r10173:10176 and r10540, r10541, r10543, r10545 and r11031 into stable.

Note: See TracTickets for help on using tickets.