Free cookie consent management tool by TermsFeed Policy Generator

Changes between Version 4 and Version 5 of ReviewHeuristicLab3.3.0CodeCore


Ignore:
Timestamp:
04/09/10 14:11:33 (15 years ago)
Author:
mkommend
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • ReviewHeuristicLab3.3.0CodeCore

    v4 v5  
    2020 * '''Engine''': A better name for the method {{{public void Initialize()}}} (line 166) and the according event handler should be chosen. Initialized suggests that the method should only be called once after the creation of an instance. A solution would be to make the {{{Initialize}}} method private and a public {{{Reset}}} method which calls the {{{Initialize}}} method.
    2121   * swagner: Renamed `Initialize` to `Prepare` and `Initialized` to `Prepared` in r2790.
     22 * '''Engine''': Currently the elapsed execution time is calculated by subtracting `DateTime.Now` - lastUpdated. IMHO using the `StopWatch` class would be more appropriate for this task.
    2223
    2324 * '''!ExecutionContext''': The {{{private IOperator op;}}} should be renamed to operator to match the corresponding property.