Opened 22 months ago

Closed 18 months ago

Last modified 16 months ago

#2984 closed defect (worksforme)

Exception in StringValueMatrix when trying to mark all columns in a row with Crtl+Shift+Right

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone:
Component: Core.Views Version:
Keywords: Cc:

Description

Reproduce:

  1. Open estimated values view for a regression solution
  2. Click top-left cell and Ctrl+Shift+Right
System.NullReferenceException: Object reference not set to an instance of an object.
   at HeuristicLab.Data.Views.StringConvertibleMatrixView.dataGridView_SelectionChanged(Object sender, EventArgs e) in C:\reps\hl-core\trunk\HeuristicLab.Data.Views\3.3\StringConvertibleMatrixView.cs:line 557
   at System.Windows.Forms.DataGridView.OnSelectionChanged(EventArgs e)
   at System.Windows.Forms.DataGridView.FlushSelectionChanged()
   at System.Windows.Forms.DataGridView.ProcessRightKeyPrivate(Keys keyData)
   at System.Windows.Forms.DataGridView.ProcessDataGridViewKey(KeyEventArgs e)
   at System.Windows.Forms.DataGridView.OnKeyDown(KeyEventArgs e)
   at System.Windows.Forms.Control.ProcessKeyEventArgs(Message& m)
   at System.Windows.Forms.DataGridView.ProcessKeyEventArgs(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Change History (3)

comment:1 Changed 18 months ago by abeham

  • Owner set to gkronber
  • Status changed from new to assigned

Failed to reproduce the error, it works fine when using LR in its default settings and default problem. Please confirm or update the steps to reproduce the error.

comment:2 Changed 18 months ago by gkronber

  • Resolution set to worksforme
  • Status changed from assigned to closed

Could not reproduce this problem.

comment:3 Changed 16 months ago by abeham

  • Milestone HeuristicLab 3.3.16 deleted
Note: See TracTickets for help on using tickets.