Microsoft Chart Control for .NET Framework

Microsoft Chart Controls
Microsoft Chart Control for .NET Framework

The Microsoft Chart Control for .NET Framework provides rich data visualization for developers. It enables you to create ASP.NET pages or Windows Forms applications with simple, intuitive, and visually compelling charts for complex statistical or financial analysis.

Chart Control for .NET Framework enables you to add robust charting abilities to your applications with little effort. It is a fully managed .NET Framework component and has been specifically designed for use with Microsoft Visual Studio 2008.

For examples of how to use Chart Control for .NET Framework, download the samples on Codeplex. Also, to access community content, go to the Chart Control Forum.

Chart Control for .NET Framework has the following key features:

  • Visual Studio design time support.

  • 25 distinct chart types.

  • 3D support for most chart types

  • 3D customization, including perspective, lighting, rotation, border skins, anti-aliasing, transparencies, isometric projections, shadows, and more.

  • Unlimited number of chart areas.

  • Automatic and manual layout and alignment management.

  • Automatic and manual scaling.

  • Logarithmic scaling for any base.

  • Fully customizable legends.

  • Intelligent data label positioning.

  • Chart annotations, scale breaks, interlaced strip lines, drill-down charts, tool tips, data labels, and more.

  • Zooming and scrolling. (Windows Forms)

  • Data binding.

  • Data copying, merging, splitting, sorting, searching, grouping, and filtering.

  • Data exporting.

  • Binary and XML serialization.

  • Empty data point handling.

  • Unlimited number of data series and data points.

  • Support for dates, times, currency, and more.

  • More than 50 financial and statistical formulas for data analysis and transformation.

  • Real-time chart manipulation.

  • Post-paint and pre-paint events.

  • Support for AJAX click events.

  • State management. (ASP.NET)

  • Binary streaming. (ASP.NET)

  • Animated frame rate control. (ASP.NET)

In This Section

Installation (Chart Control for .NET Framework)

Chart Control for .NET Framework is an add-in to Visual Studio 2008. It is integrated with the Toolbox window for a drag-and-drop interface that is consistent with the Visual Studio interface. This topic shows how to install the Chart control into your Visual Studio environment.

Custom Attributes (Chart Control for .NET Framework)

In addition to the rich property set that is available at design time, the Chart control also includes custom attributes unique to each chart type. These custom attributes extend the properties in the Chart control and enables you to further dictate the look and feel that are specific to each chart type.

Security Best Practices (Chart Control for .NET Framework)

When working with the Chart control in ASP.NET applications, you must pay special care to security. This topic provides information on best practices in building secure ASP.NET applications with the Chart control.

Class Library

The API for the Chart control is a feature rich, fully programmable tool set. If you are working in ASP.NET applications, see System.Web.UI.DataVisualization.Charting. If you are working in Windows Forms applications, see System.Windows.Forms.DataVisualization.Charting.


Installation (Chart Control for .NET Framework)

Microsoft Chart Controls
Installation (Chart Control for .NET Framework) |
 | See Also
Microsoft Chart Control for .NET Framework >

The Microsoft Chart Control for .NET Framework is an add-on for Microsoft Visual Studio 2008.

Installation Prerequisites

Make sure your environment meets the following requirements before installing the Chart Control for .NET Framework.

  • Visual Studio 2008 Service Pack 1 (SP1)

  • Microsoft .NET Framework version 3.5 SP1

Installing the Chart Control for .NET Framework

To install the Chart Control for .NET Framework

  1. Download the installation packages for Microsoft Chart Control for .NET Framework from the Microsoft .

  2. To install the Chart control library, double-click the MSChart.exe file.

  3. To install the Visual Studio add-on, double-click the MSChart_VisualStudioAddOn.exe file.

  4. After installation completes, start Visual Studio 2008 and open a project.

  5. In the design view, open the Toolbox.

  6. From the Data section, drag a Chart control to the design area.

    If you cannot see the Chart control in the Toolbox window, right click in the Toolbox window, select Choose Items to open the Choose Toolbox Items dialog, and then select the following namespaces in the .NET Framekwork Components tab:

    • System.Web.UI.DataVisualization.Charting

    • System.Windows.Forms.DataVisualization.Charting

    Note To find the Chart control more easily in the Toolbox, hide the inactive controls. To do this, right-click the Toolbox, and clear Show All item.

See Also

Reference

System.Web.UI.DataVisualization.Charting
System.Windows.Forms.DataVisualization.Charting

Concepts

Custom Attributes (Chart Control for .NET Framework)

Other Resources

Microsoft Chart Control for .NET Framework

© 2008 Microsoft Corporation. All rights reserved.


Custom Attributes (Chart Control for .NET Framework)

Microsoft Chart Controls
Custom Attributes (Chart Control for .NET Framework) |
 | See Also
Microsoft Chart Control for .NET Framework >

Each chart type in Chart Control for .NET Framework contains a set of custom attributes. Custom attributes enable you to customize the look and feel of your chart. They are implemented using the CustomAttributes property of both the Series objects and their associated DataPoint objects.

For more information about these objects in ASP.NET, see Series and DataPoint.

For more information about these objects for Windows Forms, see Series and DataPoint.

Chart control custom attributes have the following characteristics:

  • Depending on the chart type, you can set applicable custom attributes to the chart's Series objects or their associated DataPoint objects, or both. If a custom attribute is applicable to both the chart's Series and DataPoint objects, any custom attribute that is set for a series is applied to all data points contained within that series.

  • Custom attributes that apply to DataPoint objects have a higher priority than those that apply to Series objects. If the same custom attribute is set for a Series object and one of its DataPoint objects, the setting for the DataPoint object takes precedence.

  • Custom attribute names are case-sensitive.

  • Custom attribute values are strings.

  • If a custom attribute's value contains a comma, each comma must be preceded by an escape '\' character.

For more information about each custom attribute, including examples, see Custom Attributes List (Chart Control for .NET Framework).

Accessing Custom Attributes

Custom attributes are not visible in the Properties window of Visual Studio. To access them programmatically, you do not need to specify the CustomAttributes property. Simply add an indexer to the Series or DataPoint object and use the name of the custom attribute as the index to get and set the particular name-value pair. This method enables you to access only that particular custom attribute.

For example, the following code accesses the Exploded custom attribute in a pie chart's DataPoint object and sets it to True, and then checks its value:

Copy Code
' Explode the first pie slice
Chart1.Series("Default").Points(0)("Exploded") = "True"
…
' Check if the the first pie slice is still exploded
If Chart1.Series("Default").Points(0)("Exploded") = "True"
    ' Do something
End If
// Explode the first pie slice
Chart1.Series["Default"].Points[0]["Exploded"] = "True"
…
// Check if the the first pie slice is still exploded
if (Chart1.Series["Default"].Points[0]["Exploded"] == "True")
{
    //Do something
}

See Also

Concepts

Custom Attributes List (Chart Control for .NET Framework)


Custom Attributes List (Chart Control for .NET Framework)

Microsoft Chart Controls
Custom Attributes List (Chart Control for .NET Framework) |
 | See Also
Microsoft Chart Control for .NET Framework > Custom Attributes (Chart Control for .NET Framework) >

The following table lists all the custom attributes for Chart Control for .NET Framework and their details. The Chart Types column shows the chart types to which each custom attribute applies. The Chart Elements column shows the type of objects for which the custom attribute can be set.

Custom Attribute Description Chart Types Chart Elements Value Range Default 2D, 3D Notes

3DLabelLineSize

Gets or sets the 3D label line size as a percentage of the default size.

Pie, Doughnut

Series

30 – 200

100

3D

It represents the amount of space reserved for drawing the line that connects a slice to a label drawn outside of the chart (see PieLabelStyle custom attribute).

AreaDrawingStyle

Gets or sets the plotting area shape of Radar and Polar charts.

Polar, Radar, Rose

Series

Circle, Polygon

Circle

2D, 3D

ArrowSize

Sets the relative size of the arrowhead used in line segments that join labels to their data points.

Pie, Doughnut

Series, DataPoint

1.0 – 10.0

1.0

2D, 3D

This custom attribute only applies when PieLabelStyle is set to Outside.

ArrowsType

Sets the type of arrowhead to use for line segments that join labels to their data points.

Pie, Doughnut

Series, DataPoint

None, Triangle, Sharp Triangle, Lines

None

2D, 3D

This custom attribute only applies when PieLabelStyle is set to Outside.

BarLabelStyle

Gets or sets the data point label placement.

Bar, Gantt

Series, DataPoint

Outside, Left, Right, Center

Outside

2D, 3D

BoxPlotPercentile

Gets or sets the percentile value of the box of the Box chart.

Box

Series

0 – 50

25

2D, 3D

BoxPlotSeries

Gets or sets the name of the series to be used as the data source for the Box chart.

Box

Series

Name of any existing series

2D, 3D

The named series must exist. Otherwise, an exception will be thrown.

More than one series can be specified by separating each series with the semicolon (;) character. This will create a single box plot data point for each series.

BoxPlotShowAverage

Gets or sets a textual Boolean value that indicates whether to display the average value for the Box chart.

Box

Series

True, False

True

2D, 3D

Specify True to display the average value. Otherwise, specify False.

BoxPlotShowMedian

Gets or sets a textual Boolean value that indicates whether to display the median value for the Box chart.

Box

Series

True, False

True

2D, 3D

Specify True to display the median value. Otherwise, specify False.

BoxPlotShowUnusualValues

Gets or sets a textual Boolean value that indicates whether the unusual values value for the Box chart will be shown.

Box

Series

True, False

True

2D, 3D

The attribute will only work if the BoxPlotSeries attribute is set.

BoxPlotWhiskerPercentile

Gets or sets the percentile value of the whiskers of the Box chart.

Box

Series

0 – 50

10

2D, 3D

BoxSize

Gets or sets the Renko or Point and Figure box size as either a percentage or a fixed value.

Renko, Point and Figure

Series

Any valid numeric or percentage value

4%

2D, 3D

BubbleMaxSize

Gets or sets the maximum size of the bubble radius as a percentage of the chart area size.

Bubble

Series

0 – 100

15

2D, 3D

BubbleMinSize

Gets or sets the minimum size of the bubble radius as a percentage of the chart area size.

Bubble

Series

0 – 100

3

2D, 3D

BubbleScaleMax

Gets or sets the bubble size that will be used as the maximum, which is a percentage of the chart area that is set by BubbleMaxSize.

Bubble

Series

0 – 100

15

2D, 3D

If set to Auto, the largest plotted bubble will be displayed using the maximum size.

BubbleScaleMin

Gets or sets the bubble size that will be used as the minimum, which is a percentage of the chart area that is set by BubbleMinSize.

Bubble

Series

0 – 100

3

2D, 3D

If set to Auto, the smallest plotted bubble will be displayed using the minimum size.

BubbleUseSizeForLabel

Gets or sets a Boolean value that indicates whether to use the bubble size as the data point label.

Bubble

Series

True, False

False

2D, 3D

Specify True to use the bubble size as the data point label. Otherwise, specify False.

CalloutLineColor

Gets or sets the CalloutLineColor for the data point labels of Funnel or Pyramid charts.

Funnel, Pyramid

Series, DataPoint

Any named Color, ARGB or RGB value.

Color.Empty

2D, 3D

This custom attribute only applies when the FunnelLabelStyle or PyramidLabelStyle is set to OutsideInColumn.

CollectedColor

Gets or sets the color of the collected pie or doughnut slice.

Pie, Doughnut

Series

Any named Color, ARGB or RGB value.

Color.Empty

2D, 3D

This custom attribute only applies when a CollectedThreshold value is set.

CollectedLabel

Gets or sets the label of the collected pie slice.

Pie, Doughnut

Series

2D, 3D

This custom attribute only applies when CollectedThreshold is set.

CollectedLegendText

Gets or sets the legend text of the collected pie slice.

Pie, Doughnut

Series

2D, 3D

This custom attribute only applies when CollectedThreshold is set.

CollectedSliceExploded

Gets or sets a Boolean value that indicates whether the collected pie slice will be shown as exploded.

Pie, Doughnut

Series

True, False

True

2D, 3D

This custom attribute only applies when CollectedThreshold is set.

CollectedThreshold

Gets or sets the threshold value for collecting small pie slices.

Pie, Doughnut

Series

Any double between 0 to 100 if CollectedThresholdUsePercent is true, otherwise any double > 0

0

2D, 3D

This custom attribute can be set as a percentage of the total series values or as a simple value, based on the CollectedThresholdUsePercent attribute.

Note:
There must be at least two points below the threshold value in order for the chart to collect pie slices.

CollectedThresholdUsePercent

Gets or sets a Boolean value that indicates whether to use the collected threshold value as percentage.

Pie, Doughnut

Series

True, False

True

2D, 3D

If set to True, data points will be collected based on values in percent below CollectedThreshold. If set to False, data points will be collected based on the actual values below CollectedThreshold.

CollectedToolTip

Gets or sets the tooltip of the collected pie slice.

Pie, Doughnut

Series

2D, 3D

This custom attribute only applies when CollectedThreshold is set.

DoughnutRadius

Gets or sets the radius of the Doughnut chart.

Doughnut

Series

0 – 100

60

2D, 3D

The value of this attribute indicates the percentage of the overall radius of the chart that will be used for the Doughnut center hole. For example, if DoughnutRadius is set to 100, the doughnut hole will not exist, therefore, the chart will look like a Pie chart. The larger the value of DoughnutRadius, the smaller the doughnut hole of the chart.

DrawingStyle

Gets or sets the data point drawing style (shape) of one or more data points.

Bar, Column, Stacked Bar, 100% Stacked Bar, Stacked Column, 100% Stacked Column, Gantt, RangeColumn

Series, DataPoint

Cylinder, Emboss, LightToDark, Wedge, Default

Default

2D, 3D

EmptyPointValue

Gets or sets the value to be used for empty points.

Point, Bubble, Line, Spline, StepLine, Column, RangeColumn, Gantt, Radar, Range, SplineRange, Polar, Area, SplineArea, Bar

Series, DataPoint

Average, Zero

Average

2D, 3D

This property determines how an empty point is treated when the chart is drawn. If a value of Average is used, the chart is drawn as though a point exists, and has a value of the average of the two adjacent points. If Zero is used, the chart is drawn as though a point exists with a zero value.

ErrorBarCenterMarkerStyle

Gets or sets the appearance of the marker at the center value of the error bar.

Error Bar

Series, DataPoint

None, Line, Square, Circle, Diamond, Triangle, Cross, Star4, Star5, Star6, Star10

None

2D, 3D

ErrorBarSeries

Gets or sets the name of the series to be used as the data source for the Error Bar chart calculations.

Error Bar

Series

Name of any existing series.

2D, 3D

The named series must exist otherwise an exception will be thrown.

ErrorBarStyle

Gets or sets the visibility of the Upper and Lower Error values.

Error Bar

Series, DataPoint

Both, UpperError, LowerError

Both

2D, 3D

ErrorBarType

Gets or sets a value that defines how the Upper and Lower Error values are calculated for the center values of the ErrorBarSeries.

Error Bar

Series

FixedValue, Percentage, StandardDeviation, StandardError

2D, 3D

This attribute accepts a formula name with and optional parameter enclosed in parentheses.

FixedValue - The error value is a fixed value defined by a required parameter (for example, FixedValue(15)).Percentage - Errors are calculated as a percentage of the data point center value with an optional parameter. If a parameter is not specified, a 10% error will be used for upper and lower errors (For example, Percentage(10)).StandardDeviation - The error values are determined by applying a standard deviation calculation on the center values in the error bar series with an optional parameter. A supplied parameter (1,2,3, … n) defines the number of standard deviations to use. By default, if a parameter is not provided, a standard deviation of 1 is used. (for example, StandardDeviation(3)).StandardError - Error values are found by applying standard error calculations on the center values in the error bar series with an optional parameter. The supplied parameter (1,2,3, … n) defines the number of standard errors to use. If none is provided, the default value of 1 is used (for example, StandardError(2)).

Exploded

Gets or sets a textual Boolean value that indicates whether the Pie or Doughnut data point is exploded.

Pie, Doughnut

DataPoint

True, False

False

2D, 3D

Funnel3DDrawingStyle

Gets or sets the Funnel chart 3D drawing style.

Funnel

Series

CircularBase, SquareBase

SquareBase

3D

This attribute only applies when the ChartArea.Area3DStyle.Enable3D property must is set to true.

Funnel3DRotationAngle

Gets or sets the Funnel chart 3D rotation angle.

Funnel

Series

-10 – 10

5

3D

This attribute only applies when the ChartArea.Area3DStyle.Enable3D property must is set to true.

FunnelInsideLabelAlignment

Gets or sets the Funnel chart data point label placement when the FunnelLabelStyle is set to Inside.

Funnel

Series, DataPoint

Center, Top, Bottom

Center

2D, 3D

This attribute only applies when the FunnelLabelStyle is set to Inside.

FunnelLabelStyle

Gets or sets the Funnel chart data point label style.

Funnel

Series, DataPoint

Inside, Outside, OutsideInColumn, Disabled

OutsideInColumn

2D, 3D

If the label is not set to Disabled, the attributes FunnelInsideLabelAlignment and FunnelOutsideLabelPlacement are used to specify additional positioning rules.

FunnelMinPointHeight

Gets or sets minimum height of a Funnel chart data point measured in relative coordinates.

Funnel

Series

0 – 100

0

2D, 3D

Any point that would typically be drawn smaller than the amount specified by this attribute is drawn using this value instead. This feature eliminates the occurrence of very thin slices, which may be difficult or impossible to see when displayed in your chart.

FunnelNeckHeight

Gets or sets the Funnel chart neck height.

Funnel

Series

0 – 100

5

2D, 3D

This attribute only applies when the FunnelStyle attribute is set to YIsHeight.

FunnelNeckWidth

Gets or sets the Funnel chart neck width.

Funnel

Series

0 – 100

5

2D, 3D

This attribute only applies when the FunnelStyle attribute is set to YIsWidth.

FunnelOutsideLabelPlacement

Gets or sets the Funnel chart data point label placement when the FunnelLabelStyle is set to Outside or OutsideInColumn.

Funnel

Series, DataPoint

Right, Left

Right

2D, 3D

This attribute only applies when the FunnelLabelStyle is set to Outside or OutsideInColumn.

FunnelPointGap

Gets or sets the gap size between the points of a Funnel chart measured in relative coordinates.

Funnel

Series

0 – 100

0

2D, 3D

The maximum gap size is limited by the number of points.

FunnelStyle

Gets or sets the Funnel chart style.

Funnel

Series

YIsWidth, YIsHeight

YIsHeight

2D, 3D

InnerRadius

Gets or sets the radius of the circular gap in the center of the chart.

Rose, Stacked Rose

Series

0 – 20

0

2D, 3D

The value of this attribute indicates the percentage of the overall chart image that will be used to set the radius of a hole, called a gap, that will appear at the center of the chart. For example, if InnerRadius is set to 5, the radius of the center gap will represent 5% of the total width and height of the chart image. The larger the value of InnerRadius, the larger the radius of the gap in the center of the chart.

LabelsHorizontalLineSize

Gets or sets the size of the horizontal segment of the callout line.

Pie, Doughnut

Series, DataPoint

0 – 100

1

2D

This attribute only applies when the PieLabelStyle is set to Outside.

For 3D charts, see 3DLabelLineSize.

LabelsRadialLineSize

Gets or sets the size of the radial segment of the callout line.

Pie, Doughnut

Series, DataPoint

0 – 100

1

2D

This attribute only applies when the PieLabelStyle is set to Outside.

For 3D charts, see 3DLabelLineSize.

LabelStyle

Gets or sets the label position of the data point.

Point, Column, Bubble, Line, Spline, StepLine, Area, SplineArea, Range, SplineRange, Radar, Polar

Series, DataPoint

Auto, Top, Bottom, Right, Left, TopLeft, TopRight, BottomLeft, BottomRight, Center

Auto

2D, 3D

LabelValueType

Gets or sets the Y value to use as the data point label.

Stock, CandleStick

Series, DataPoint

High, Low, Open, Close

Close

2D, 3D

LineTension

Gets or sets the line tension for the drawing of curves.

Spline, SplineArea, SplineRange

Series

0 – 2

0.8

2D, 3D

A curve with LineTension set to zero (0) will have the appearance of a Line chart.

MaxPixelPointWidth

Gets or sets the maximum width of the data point in pixels.

Bar, CandleStick, Column, StackedBar, StackedBar100, StackedColumn, StackedColumn100, Stock, BoxPlot, ErrorBar, Gantt, RangeColumn

Series

Any integer > 0

0

2D, 3D

MinimumRelativePieSize

Gets or sets the minimum Pie or Doughnut sizel.

Pie, Doughnut

Series

10 – 70

30

2D, 3D

When used with outside labeling (see PieLabelStyle), this attribute controls the minimum acceptable pie size as a percentage the chart area size. This will prevent the pie from becoming too small due to labels dominating the chart area.

MinPixelPointWidth

Gets or sets the minimum data point width in pixels.

Bar, CandleStick, Column, StackedBar, StackedBar100, StackedColumn, StackedColumn100, Stock, BoxPlot, ErrorBar, Gantt, RangeColumn

Series

Any integer > 0

0

2D, 3D

This attribute causes data points to be more visible. This is especially useful when plotting a large data set, which makes data points indistinguishable.

NumberOfLinesInBreak

Gets or sets the number of lines to use in a Three Line Break chart.

Three Line Break

Series

Any integer > 0

3

2D, 3D

OpenCloseStyle

Gets or sets the marker style for open and close values.

Stock, Candlestick

Series, DataPoint

Triangle, Line, Candlestick

Line

2D, 3D

PieDrawingStyle

Gets or sets the data point drawing style (shape) of one or more data points.

Pie, Doughnut

Series

Default, SoftEdge, Concave

2D

PieLabelOffset

Gets or sets the offset for labels.

Pie, Doughnut

Series, DataPoint

X:Y, where both X and Y are integers > 0.

2D, 3D

This attribute value is set using a string that contains relative X and Y coordinates separated by a colon (:), and can be set for a series as well as individual data points.

PieLabelStyle

Gets or sets the data point label position.

Pie, Doughnut

Series, DataPoint

Disabled, Inside, Outside, Ellipse

Inside

2D, 3D

If a label is displayed outside the pie, the color of the connecting line is set by the BorderColor property by default, but it can also be controlled the PieLineColor custom attribute.

PieLineColor

Gets or sets the color of the radial and horizontal segments of the callout lines.

Pie, Doughnut

Series, DataPoint

Any named Color, ARGB or RGB value.

Color.Black

2D, 3D

This attribute only applies when PieLabelStyle is set to Outside.

PieStartAngle

Defines the location of the first pie or doughnut slice (for example, data point).

Pie, Doughnut

Series

0 – 360

90

2D, 3D

PixelPointDepth

Gets or sets the 3D Series depth in pixels.

Area, Bar, Bubble, CandleStick, Column, Line, Point, Spline, SplineArea, StackedArea, StackedArea100, StackedBar, StackedBar100, StackedColumn, StackedColumn100, StepLine, Stock, ThreeLineBreak, BoxPlot, ErrorBar, Gantt, Kagi, PointAndFigure, Range, RangeColumn, Renko, SplineRange, FastLine™

Series

Any integer > 0

0

3D

PixelPointGapDepth

Gets or sets the 3D gap depth in pixels.

Area, Bar, Bubble, CandleStick, Column, Line, Point, Spline, SplineArea, StackedArea, StackedArea100, StackedBar, StackedBar100, StackedColumn, StackedColumn100, StepLine, Stock, ThreeLineBreak, BoxPlot, ErrorBar, Gantt, Kagi, PointAndFigure, Range, RangeColumn, Renko, SplineRange, FastLine™

Series

Any integer > 0

0

3D

In 3D charts, the gap depth defines the amount of space between each plotted series.

PixelPointWidth

Gets or sets the data point width in pixels.

Bar, CandleStick, Column, StackedBar, StackedBar100, StackedColumn, StackedColumn100, Stock, BoxPlot, ErrorBar, Gantt, RangeColumn

Series

Any integer > 0

0

2D, 3D

PointWidth

Gets or sets the relative data point width.

Bar, CandleStick, Column, StackedBar, StackedBar100, StackedColumn, StackedColumn100, Stock, BoxPlot, ErrorBar, Gantt, RangeColumn

Series

0 – 2

0.8

2D, 3D

PolarDrawingStyle

Gets or sets the Polar chart drawing style.

Polar

Series

Line, Marker

Line

2D, 3D

PriceDownColor

Gets or sets the data point color to use to indicate a decreasing trend.

Candlestick

Series, DataPoint

Any named Color, ARGB or RGB value.

Color.Empty

2D, 3D

A price is considered decreasing when the Close value is less than its Open value.

PriceUpColor

Gets or sets the data point color to use to indicate an increasing trend.

Candlestick, Point and Figure, Renko, Kagi, Three Line Break

Series, DataPoint for CandleStick charts. Otherwise only Series objects.

Any named Color, ARGB or RGB value.

Color.Empty

2D, 3D

A price is considered increasing when the Close value is greater than its Open value.

ProportionalSymbols

Gets or sets a value that indicates that the Point and Figure chart should attempt to draw the X and O values proportionally.

Point and Figure

Series

True, False

True

2D, 3D

Pyramid3DDrawingStyle

Gets or sets the 3D drawing style of the Pyramid chart.

Pyramid

Series

CircularBase, SquareBase

SquareBase

3D

This custom attribute only applies when the property ChartArea.Area3DStyle.Enable3D is set to true.

Pyramid3DRotationAngle

Gets or sets the 3D rotation angle of the Pyramid chart.

Pyramid

Series

-10 – 10

5

3D

This custom attribute only applies when the property ChartArea.Area3DStyle.Enable3D is set to true.

PyramidInsideLabelAlignment

Gets or sets the Pyramid chart data point label placement when the PyramidLabelStyle is set to Inside.

Pyramid

Series, DataPoint

Center, Top, Bottom

Center

2D, 3D

This attribute is applicable only when the PyramidLabelStyle is set to Inside.

PyramidLabelStyle

Gets or sets the Pyramid chart data point label style.

Pyramid

Series, DataPoint

Inside, Outside, OutsideInColumn, Disabled

OutsideInColumn

2D, 3D

PyramidMinPointHeight

Gets or sets minimum height of a data point measured in relative coordinates.

Pyramid

Series

0 – 100

0

2D, 3D

The Pyramid chart uses this attribute's value as the displayed height of any data point with a value less than it. This eliminates very thin slices.

PyramidOutsideLabelPlacement

Gets or sets the data point label placement when the PyramidLabelStyle is set to Outside or OutsideInColumn.

Pyramid

Series, DataPoint

Right, Left

Right

2D, 3D

This attribute only applies when the PyramidLabelStyle is set to Outside or OutsideInColumn.

PyramidPointGap

Gets or sets the gap size between the points of a Pyramid chart measured in relative coordinates.

Pyramid

Series

0 – 100

0

2D, 3D

PyramidValueType

Gets or sets a value that determines whether the data point value represents a linear height or the surface of the segment.

Pyramid

Series

Linear, Surface

Linear

2D, 3D

RadarDrawingStyle

Gets or sets the Radar chart drawing style.

Radar, Rose

Series

Area, Line, Marker

Area

2D, 3D

ReversalAmount

Gets or sets the reversal amount for the chart.

Point and Figure, Kagi

Series

A positive number or percentage (eg. 1.2 or 4%)

3%

2D, 3D

When used with the Kagi chart, this custom attribute defines when a new Kagi line should be drawn.

This value may be a percentage or fixed amount. When used with the Point and Figure chart, ReversalAmount defines a custom reversal amount for the chart in box sizes.

RoseDrawingStyle

Gets or sets the Rose chart drawing style.

Rose

Series, DataPoint

Area, Line

Area

2D, 3D

RoseSectorAngle

Sets the sector angle of the rose chart in integer degrees.

Rose

Series

0 – 360

Calculated by dividing 360 by the number of datapoints.

2D, 3D

ShowMarkerLines

Gets or sets a Boolean value that indicates whether marker lines are displayed when rendered in 3D.

Line, Spline, StepLine, Area, SplineArea, Range, SplineRange

Series, DataPoint

True, False

False

3D

ShowOpenClose

Gets or sets a Boolean value that indicates whether markers for open can close prices are displayed.

Stock

Series, DataPoint

Both, Open, Close

Both

2D, 3D

StackedGroupName

Gets or sets the stacked group name.

StackedBar, StackedBar100, StackedColumn, and StackedColumn100.

Series

2D, 3D

To place multiple series in the same stacked group, assign the same name to them.

To show multiple stacks, assign different names to multiple series.

UsedYValue

Gets or sets the zero based index of the Y value to use to plot the Kagi, Renko, or Three Line Break chart.

Kagi, Renko, Three Line Break

Series

0, 1, 2, 3, n

0

2D, 3D

0 - The First DataPoint Y Value.

1 - The Second DataPoint Y Value.

2 - The Third DataPoint Y Value.

3 - The Fourth DataPoint Y Value.

n - The nth DataPoint Y Value.

UsedYValueHigh

Gets or sets the zero-based index of the high Y value to use plot the Point and Figure chart.

Point and Figure

Series

0, 1, 2, 3, n

0

2D, 3D

0 - The First DataPoint Y Value.

1 - The Second DataPoint Y Value.

2 - The Third DataPoint Y Value.

3 - The Fourth DataPoint Y Value.

n - The nth DataPoint Y Value.

UsedYValueLow

Gets or sets the zero-based index of the low Y value to use plot the Point and Figure chart.

Point and Figure

Series

0, 1, 2, 3, n

0

2D, 3D

0 - The First DataPoint Y Value.

1 - The Second DataPoint Y Value.

2 - The Third DataPoint Y Value.

3 - The Fourth DataPoint Y Value.

n - The nth DataPoint Y Value.

TooltipOffset

Specifies whether to display the data point, as well as its related tooltip, at index 0.

Spline, Area, SplineArea

Series

Auto, True, False

Auto

2D

See Also

Concepts

Custom Attributes (Chart Control for .NET Framework)


Security Best Practices (Chart Control for .NET Framework)

Microsoft Chart Controls
Security Best Practices (Chart Control for .NET Framework) |
 | See Also
Microsoft Chart Control for .NET Framework >

This topic describes best practices for security when using the Chart control in your ASP.NET applications.

Input and Data Validation When Loading Images

The Chart control provides built-in abilities to replace many of the existing chart elements with an embedded image. When you are loading these images into the Chart control, you must set the path of these images to locations contained from within the virtual root; otherwise an exception is thrown.

The Chart control does not contain any built-in security features to prevent an end user from loading images from untrusted locations within the virtual root. For this reason, if you give an end user the ability to specify an image location, you must validate the user input to ensure that the images are contained in a trusted source. You should also secure images by separating them, so that your end users cannot see charts from other users who have different privileges.

Input and Data Validation When Loading Data From an External Source

The Chart control does not validate data or template files that are loaded from an external source. It is your responsibility as the developer to ensure that the files are referenced from a trusted location.

Other Security Considerations

It is recommended that you use the following techniques to secure your ASP.NET application:

  • Secure Sockets Layer (SSL)

  • Session

  • Authentication

  • Cookies

See Also

Other Resources

Microsoft Chart Control for .NET Framework


Class Library

Namespaces

Namespace
System.Web.UI.DataVisualization.Charting
System.Windows.Forms.DataVisualization.Charting


System.Web.UI.DataVisualization.Charting Namespace

The System.Web.UI.DataVisualization.Charting namespace contains methods and properties for the Chart Web server control.

Classes

Class | Description
Annotation | Defines properties and methods common to all annotations. This is an abstract class.
AnnotationCollection | Stores chart annotation objects.
AnnotationGroup | Represents a group of annotations.
AnnotationPathPoint |
AnnotationPathPointCollection | Represents a collection of PolylineAnnotation or PolygonAnnotation path points, which can be accessed using the GraphicPathPoints property.
AnnotationSmartLabelStyle | Stores the smart label properties of an annotation.
AnovaResult | Represents the results of an ANOVA statistical test.
ArrowAnnotation | Represents an arrow annotation.
Axis | Provides methods and properties that manage axes in the Chart control.
AxisScaleBreakStyle | Represents a scale break on the Y-axis of the chart.
AxisScaleView | Represents a scaled view of the chart.
Border3DAnnotation | Represents an annotation with a 3D border.
BorderSkin | Represents the drawing properties of the 3D border skin.
CalloutAnnotation | Represents a callout annotation.
Chart | Serves as the root class of the Chart control.
ChartArea | Represents a chart area on the chart image.
ChartArea3DStyle | Manages the display attributes for three-dimensional (3D) chart areas.
ChartAreaCollection | Represents a collection of ChartArea objects.
ChartElement | Base class for all the chart elements. The ChartElement class represents the most basic element of the chart element hierarchy.
ChartElementCollection | Represents the base class for all chart element collections.
ChartElementOutline | Represents an array of marker points and the outline path used for visual object selection in the chart.
ChartGraphics | Provides numerous conversion functions and exposes a GDI+ Graphics object.
ChartHttpHandler | Processes HTTP web requests using a custom HTTP handler; handles chart images.
ChartHttpHandlerSettings | Provides attributes that can be used to write a custom HTTP handler for storing temporary image files.
ChartNamedElement | Represents the base class for most chart elements. Chart elements such as series, chart areas, and legends must have unique names, and reuse the unique name generation and validation logic provided by the ChartNamedElementCollection class.
ChartNamedElementCollection | Represents the base class for all collections of named chart elements. Performs name management and enforces the uniqueness of the names.
ChartPaintEventArgs | Provides data for the paint events of the Chart control.
ChartSerializer | Enables serialization of the Chart control.
CustomizeLegendEventArgs | Provides data for the CustomizeLegend event of the Chart control.
CustomizeMapAreasEventArgs | Provides data for the CustomizeMapAreas event of the Chart control.
CustomLabel | Represents a custom label for an axis.
CustomLabelsCollection | Represents a collection of CustomLabel objects.
CustomProperties | For internal use only.
DataFormula | Provides properties and methods to prepare series data for technical analysis, apply formulas on the series data and prepare output data to be displayed as a chart. The actual calculations are performed in the StatisticFormula class.
DataManipulator | Performs data manipulation operations at run time. This class is exposed by the DataManipulator property of the root Chart object.
DataPoint | Represents a data point that is stored in the DataPointCollection class.
DataPointCollection | Represents a collection of DataPoint objects.
DataPointComparer | Compares data points.
DataPointCustomProperties | Defines custom properties that are common to data points, series and empty points.
ElementPosition | Represents the base class for many visual elements of the chart such as the legend, title, and chart areas. Defines the position of the chart element in relative coordinates, which range from (0,0) to (100,100).
EllipseAnnotation | Represents an ellipse annotation.
FormatNumberEventArgs | Represents the event arguments of the localized number-formatting event.
FTestResult | Stores results of the FTest statistical methods.
Grid | Provides methods and properties that manage the major and minor grids of Axis objects.
HitTestResult | Represents the results of a hit test.
HorizontalLineAnnotation | Represents a horizontal line annotation.
ImageAnnotation | Represents an image annotation.
LabelStyle | Provides properties that define the visual appearance of the axis labels.
Legend | Represents the legend for the chart image.
LegendCell | Represents a legend cell in a legend item.
LegendCellCollection | Stores legend cells in a LegendCellCollection object.
LegendCellColumn | Represents a cell column in a legend, which is used to extend the functionality of the default legend.
LegendCellColumnCollection | Stores LegendCellColumn objects, which are applied to default legend items.
LegendCollection | Represents a collection of Legend objects.
LegendItem | Represents a legend item, which is stored in the LegendItemsCollection class.
LegendItemsCollection | Represents a collection of LegendItem objects.
LineAnnotation | Represents a line annotation.
MapArea | Represents a map area.
MapAreasCollection | Represents a collection of MapArea objects.
Margins | Represents the margins for various chart elements.
NamedImage | Represents named images, which are stored in the NamedImagesCollection.
NamedImagesCollection | Represents a collection of NamedImage objects.
Point3D | Represents the coordinates of a three-dimensional (3D) data point. This class is used when performing custom drawing with 3D charts.
PolygonAnnotation | Represents a polygon annotation.
PolylineAnnotation | Represents a polyline annotation.
RectangleAnnotation | Represents a rectangle annotation.
Series | Stores data points and series attributes.
SeriesCollection | Represents a collection of Series objects.
SmartLabelStyle | Provides methods and properties used to perform intelligent, rule-based data point label positioning to resolve overlapping data point label issues.
StatisticFormula | Calculates statistical formulas.
StripLine | Represents the strip lines on a chart.
StripLinesCollection | Represents a collection of StripLine objects.
TextAnnotation | Represents a text annotation.
TickMark | Represents the major and minor tick marks along an axis.
Title | Represents a title for the entire chart image.
TitleCollection | Represents a collection of Title objects.
TTestResult | Stores the results of a T Test statistical formula.
VerticalLineAnnotation | Represents a vertical line annotation.
ZTestResult | Stores the results of a Z Test statistical formula.

Interfaces

Interface | Description
IChartMapArea | Common interface for all chart elements that support image maps.
IChartStorageHandler | Defines methods to manage rendered chart images stored in an external medium.
IDataPointFilter | Exposes the FilterDataPoint method, which allows Series data to be custom filtered.

Enumerations

Enumeration | Description
AntiAliasingStyles | Specifies the anti-aliasing options for the chart.
AreaAlignmentOrientations | Specifies the alignment orientation of a chart area.
AreaAlignmentStyles | Specifies the alignment styles of chart areas.
ArrowStyle | Specifies styles for an arrow annotation.
AxisArrowStyle | Specifies the axis arrow styles.
AxisEnabled | Specifies the state of an axis.
AxisName | Specifies the name of an axis.
AxisType | Specifies the axis type for the X and Y-axes of a Series.
BorderSkinStyle | Specifies a style for the border skin of a chart.
BreakLineStyle | Specifies line styles for axis scale breaks.
CalloutStyle | Represents the available callout styles. Applicable only to callout annotations.
ChartColorPalette | Specifies a palette when setting a Palette property.
ChartDashStyle | Specifies a line style.
ChartElementType | Specifies a chart element type.
ChartHatchStyle | Specifies a hatching style for a chart element.
ChartHttpHandlerStorageType | Specifies a storage type for chart images.
ChartImageAlignmentStyle | Specifies the image alignment for a chart background image.
ChartImageFormat | Specifies the image type for the chart.
ChartImageType | Specifies the image type for the chart.
ChartImageWrapMode | Specifies the drawing mode for a background image.
ChartValueType | Specifies value types for various chart properties.
CompareMethod | Specifies the type of comparison to be used when filtering data. This enumeration is used by the Filter method definitions in the DataManipulator class that take the CompareMethod argument.
DateRangeType | Specifies a date/time interval that determines the ranges that will be filtered when you invoke one of the Filter method definitionsfound in the DataManipulator class.
DateTimeIntervalType | Specifies an interval type.
Docking | Specifies where a chart element, such as a legend or title, will be docked on the chart.
FinancialFormula | Specifies a financial formula.
GradientStyle | Specifies a gradient style to be used for a chart element.
GridTickTypes | Specifies the options for displaying a grid line or a tick mark for a custom label.
ImageStorageMode | Specifies the mode of storing chart images.
IntervalAutoMode | Specifies the automatic axis interval mode.
IntervalType | Specifies an interval type.
LabelAlignmentStyles | Specifies a label alignment when SmartLabelStyle is used.
LabelAutoFitStyles | Specifies style changes that can automatically be made to a label when the LabelAutoFitStyle property is used.
LabelCalloutStyle | Specifies the type of leader line that should be drawn from the point to the label.
LabelMarkStyle | Specifies a mark for custom labels.
LabelOutsidePlotAreaStyle | Specifies the degree to which a label can be drawn outside a plotting area.
LegendCellColumnType | Specifies a legend cell column type.
LegendCellType | Specifies a legend cell type.
LegendImageStyle | Specifies the style to apply to the symbol for a legend item.
LegendItemOrder | Specifies the order in which items are added to the legend.
LegendSeparatorStyle | Specifies the styles for legend separator lines.
LegendStyle | Specifies the legend style.
LegendTableStyle | Specifies the legend table style.
LightStyle | Specifies a lighting style for a three-dimensional (3D) chart area.
LineAnchorCapStyle | Specifies the shape—that is, the anchor cap—to draw on the point end of the label callout line.
MapAreaShape | Specifies the shape of a map area.
MarkerStyle | Specifies a style for markers.
PointSortOrder | Indicates whether the sort order for data point values is ascending or descending.
RenderType | Specifies how the image of the chart will be rendered.
SerializationContents | Specifies the type of chart content to be serialized.
SerializationFormat | Represents the formatting type to use when the chart is serialized.
SeriesChartType | Specifies a chart type for a Series.
StartFromZero | Indicates whether an axis segment should start from zero when a scale break is used.
TextAntiAliasingQuality | Specifies the quality of the anti-aliasing to be used with the TextAntiAliasingQuality property.
TextOrientation | Specifies text orientation in a chart element.
TextStyle | Specifies text drawing styles.
TickMarkStyle | Specifies a tick mark style when setting the TickMarkStyle property of a TickMark object.


Annotation Class

Annotation Class |
 | See Also Members

Defines properties and methods common to all annotations. This is an abstract class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public MustInherit Class Annotation
    Inherits ChartNamedElement
    Implements IChartMapArea
public abstract class Annotation : ChartNamedElement, IChartMapArea
public ref class Annotation abstract : public ChartNamedElement, IChartMapArea
public abstract class Annotation extends ChartNamedElement implements IChartMapArea
public abstract class Annotation extends ChartNamedElement implements IChartMapArea

Remarks

Annotations are commonly used to comment or elaborate on chart elements such as data points. Annotations can also be used to draw custom shapes.

By default, annotations are positioned using relative coordinates, with (0,0) representing the top-left corner, and (100,100) representing the bottom-right corner of the chart image. It is also possible to switch from this relative coordinate system to a system that uses axis values. With an axis coordinate system, X and Y, which represent the position of the top-left corner of an annotation, are set using X axis and Y axis values, instead of values that range from 0-100.

There are two ways to use axis values when you specify the position and size of an annotation:

  • Set the AxisX, AxisY or both of these annotation properties to the AxisX and AxisY property values of a ChartArea object.

  • Use the AnchorDataPoint property to anchor the annotation to a data point. In this case, its positioning is automatically calculated.

All annotations are derived from the Annotation class, which can be used to set attributes common to all Annotation objects, such as color, position, anchoring and so forth.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation Members

Annotation Members |
 | See Also Methods Properties Constructors

Defines properties and methods common to all annotations. This is an abstract class.

The following tables list the members exposed by the Annotation type.

Protected Constructors

Name | Description
Annotation | Initializes a new instance of the Annotation class. This is the default constructor and should not be used.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored.
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only.
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation.
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored.
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored.
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only.
AnnotationType | Gets or sets the type name of an annotation. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached.
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only.
AxisY | Gets or sets the Y axis to which an annotation is attached.
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only.
BackColor | Gets or sets the color of an annotation background.
BackGradientStyle | Gets or sets the gradient style of an annotation background.
BackHatchStyle | Gets or sets the hatching style of an annotation background.
BackSecondaryColor | Gets or sets the secondary color of an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped.
Font | Gets or sets the font to use for the text of an annotation.
ForeColor | Gets or sets the text color of an annotation.
Height | Gets or sets the height of an annotation.
IsSelected | Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation.
LineDashStyle | Gets or sets the line style of an annotation.
LineWidth | Gets or sets the line width of an annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation.
Name | Overridden. Gets or sets the unique name of an annotation.
PostBackValue | Gets or sets the postback value which can be processed on the Click event.
Right | Gets or sets the right boundary position of an annotation.
ShadowColor | Gets or sets the color of an annotation's shadow.
ShadowOffset | Gets or sets the size of an annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation.
Url | Gets or sets the URL of an annotation.
Visible | Gets or sets a flag that specifies whether an annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation.
X | Gets or sets the X coordinate of an annotation.
Y | Gets or sets the Y coordinate of the annotation.
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only.
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations.
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size.
SendToBack | Sends an annotation to the back of all the annotations.
SetAnchor | Overloaded.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Annotation Class
System.Web.UI.DataVisualization.Charting Namespace


Annotation Constructor

Annotation Constructor |
 | See Also

Initializes a new instance of the Annotation class. This is the default constructor and should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Sub New
protected Annotation ()
protected:
Annotation ()
protected Annotation ()
protected function Annotation ()

Remarks

Annotation is an abstract class and cannot be created directly. To create a new annotation object, use constructors of classes such as LineAnnotation or RectangleAnnotation.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation Methods

Annotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations.
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size.
SendToBack | Sends an annotation to the back of all the annotations.
SetAnchor | Overloaded.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Annotation Class
System.Web.UI.DataVisualization.Charting Namespace


Annotation.BringToFront Method

Annotation.BringToFront Method |
 | See Also

Brings an annotation to the front of all annotations.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub BringToFront
public virtual void BringToFront ()
public:
virtual void BringToFront ()
public void BringToFront ()
public function BringToFront ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Dispose Method

Annotation.Dispose Method |
 | See Also

Overload List

Name | Description
Annotation.Dispose () | (inherited from Dispose )
Annotation.Dispose (Boolean) | Releases unmanaged resources and, optionally, managed resources.

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Dispose Method (Boolean)

Annotation.Dispose Method (Boolean) |
 | See Also

Releases unmanaged resources and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.ResizeToContent Method

Annotation.ResizeToContent Method |
 | See Also

Resizes an annotation according to its content size.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub ResizeToContent
public virtual void ResizeToContent ()
public:
virtual void ResizeToContent ()
public void ResizeToContent ()
public function ResizeToContent ()

Remarks

Sets the annotation width and height to fit the specified text.

This method applies to TextAnnotation, RectangleAnnotation, EllipseAnnotation and CalloutAnnotation objects only.

Note:
This method requires that the annotation be added to the AnnotationCollection to function correctly.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.SendToBack Method

Annotation.SendToBack Method |
 | See Also

Sends an annotation to the back of all the annotations.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub SendToBack
public virtual void SendToBack ()
public:
virtual void SendToBack ()
public void SendToBack ()
public function SendToBack ()

Remarks

Sends an annotation to the back of all the annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.SetAnchor Method

Annotation.SetAnchor Method |
 | See Also

Overload List

Name | Description
Annotation.SetAnchor (DataPoint) | Anchors an annotation to the specified data point.
Annotation.SetAnchor (DataPoint, DataPoint) | Anchors an annotation to two data points.

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.SetAnchor Method (DataPoint)

Annotation.SetAnchor Method (DataPoint) |
 | See Also

Anchors an annotation to the specified data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SetAnchor ( _
    dataPoint As DataPoint _
)
public void SetAnchor (
    DataPoint dataPoint
)
public:
void SetAnchor (
    DataPoint^ dataPoint
)
public void SetAnchor (
    DataPoint dataPoint
)
public function SetAnchor (
    dataPoint : DataPoint
)

Parameters

dataPoint

The DataPoint to which the annotation will be anchored.

Remarks

Anchors an annotation to the specified data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.SetAnchor Method (DataPoint, DataPoint)

Annotation.SetAnchor Method (DataPoint, DataPoint) |
 | See Also

Anchors an annotation to two data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SetAnchor ( _
    dataPoint1 As DataPoint, _
    dataPoint2 As DataPoint _
)
public void SetAnchor (
    DataPoint dataPoint1,
    DataPoint dataPoint2
)
public:
void SetAnchor (
    DataPoint^ dataPoint1,
    DataPoint^ dataPoint2
)
public void SetAnchor (
    DataPoint dataPoint1,
    DataPoint dataPoint2
)
public function SetAnchor (
    dataPoint1 : DataPoint,
    dataPoint2 : DataPoint
)

Parameters

dataPoint1

The first anchor DataPoint.

dataPoint2

The second anchor DataPoint.

Remarks

Anchors an annotation's top-left and bottom-right corners to the specified data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation Properties

Annotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored.
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only.
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation.
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored.
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored.
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only.
AnnotationType | Gets or sets the type name of an annotation. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached.
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only.
AxisY | Gets or sets the Y axis to which an annotation is attached.
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only.
BackColor | Gets or sets the color of an annotation background.
BackGradientStyle | Gets or sets the gradient style of an annotation background.
BackHatchStyle | Gets or sets the hatching style of an annotation background.
BackSecondaryColor | Gets or sets the secondary color of an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped.
Font | Gets or sets the font to use for the text of an annotation.
ForeColor | Gets or sets the text color of an annotation.
Height | Gets or sets the height of an annotation.
IsSelected | Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation.
LineDashStyle | Gets or sets the line style of an annotation.
LineWidth | Gets or sets the line width of an annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation.
Name | Overridden. Gets or sets the unique name of an annotation.
PostBackValue | Gets or sets the postback value which can be processed on the Click event.
Right | Gets or sets the right boundary position of an annotation.
ShadowColor | Gets or sets the color of an annotation's shadow.
ShadowOffset | Gets or sets the size of an annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation.
Url | Gets or sets the URL of an annotation.
Visible | Gets or sets a flag that specifies whether an annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation.
X | Gets or sets the X coordinate of an annotation.
Y | Gets or sets the Y coordinate of the annotation.
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only.

See Also

Reference

Annotation Class
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Alignment Property

Annotation.Alignment Property |
 | See Also

Gets or sets the content alignment of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Alignment As ContentAlignment
public virtual ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the content alignment.

Remarks

This property is used to align text for the Alignment property to align text for TextAnnotation, RectangleAnnotation, EllipseAnnotation and CalloutAnnotation objects, and to align a non-scaled image inside an ImageAnnotation object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorAlignment Property

Annotation.AnchorAlignment Property |
 | See Also

Gets or sets the position alignment of an annotation to the anchor point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AnchorAlignment As ContentAlignment
public virtual ContentAlignment AnchorAlignment { get; set; }
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public function get AnchorAlignment () : ContentAlignment

public function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the alignment of the annotation to the anchor point.

Remarks

The annotation must be anchored by either using the AnchorDataPoint property, or by setting the AnchorX and AnchorY properties. Its X and Y properties must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorDataPoint Property

Annotation.AnchorDataPoint Property |
 | See Also

Gets or sets the data point to which an annotation is anchored.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property AnchorDataPoint As DataPoint
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual DataPoint AnchorDataPoint { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property DataPoint^ AnchorDataPoint {
    DataPoint^ get ();
    void set (DataPoint^ value);
}
/** @property */
public DataPoint get_AnchorDataPoint ()

/** @property */
public void set_AnchorDataPoint (DataPoint value)

public function get AnchorDataPoint () : DataPoint

public function set AnchorDataPoint (value : DataPoint)

Property Value

A DataPoint object to which an annotation is anchored.

Remarks

The annotation is anchored to the X and Y values of the specified data point, and automatically uses the same axes coordinates as the data point.

To automatically position the annotation relative to the anchor point, make sure its X and Y properties are set to NaN. The AnchorAlignment property can be used to change the annotation's automatic position alignment to the anchor point. The AnchorOffsetX and AnchorOffsetY properties can be used to add extra spacing.

When you use this property, make sure the AnchorX and AnchorY properties are set to NaN, as they have precedence.

Set this value to null to disable annotation anchoring to a data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorDataPointName Property

Annotation.AnchorDataPointName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of a data point to which an annotation is anchored. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property AnchorDataPointName As String
[BrowsableAttribute(false)]
public virtual string AnchorDataPointName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AnchorDataPointName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AnchorDataPointName ()

/** @property */
public void set_AnchorDataPointName (String value)

public function get AnchorDataPointName () : String

public function set AnchorDataPointName (value : String)

Property Value

A string value that represents the name of the data point that an annotation is anchored to.

Remarks

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorOffsetX Property

Annotation.AnchorOffsetX Property |
 | See Also

Gets or sets the offset from the anchor point for the X position of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AnchorOffsetX As Double
public virtual double AnchorOffsetX { get; set; }
public:
virtual property double AnchorOffsetX {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorOffsetX ()

/** @property */
public void set_AnchorOffsetX (double value)

public function get AnchorOffsetX () : double

public function set AnchorOffsetX (value : double)

Property Value

A double value that represents the offset of the X position from the anchor point.

Remarks

The annotation must be anchored using either the AnchorDataPoint or the AnchorX property, and its X property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorOffsetY Property

Annotation.AnchorOffsetY Property |
 | See Also

Gets or sets the offset from the anchor point for the Y position of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AnchorOffsetY As Double
public virtual double AnchorOffsetY { get; set; }
public:
virtual property double AnchorOffsetY {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorOffsetY ()

/** @property */
public void set_AnchorOffsetY (double value)

public function get AnchorOffsetY () : double

public function set AnchorOffsetY (value : double)

Property Value

A double value that represents the offset of the Y position from the anchor point.

Remarks

The annotation must be anchored using either the AnchorDataPoint or AnchorY property, and its Y property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorX Property

Annotation.AnchorX Property |
 | See Also

Gets or sets the X coordinate to which the annotation is anchored.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AnchorX As Double
public virtual double AnchorX { get; set; }
public:
virtual property double AnchorX {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorX ()

/** @property */
public void set_AnchorX (double value)

public function get AnchorX () : double

public function set AnchorX (value : double)

Property Value

A double value that represents the X coordinate to which an annotation is anchored.

Remarks

The annotation is anchored to the X coordinate and is specified in relative chart or axes coordinates, depending on the AxisX property value.

To automatically position an annotation relative to an anchor point, make sure its X property is set to NaN. The AnchorAlignment property can be used to change the automatic position alignment of the annotation to the anchor point. The AnchorOffsetX and AnchorOffsetY properties may be used to add extra spacing.

This property has a higher priority than the AnchorDataPoint property.

Set this value to NaN to disable annotation anchoring to the value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnchorY Property

Annotation.AnchorY Property |
 | See Also

Gets or sets the Y coordinate to which the annotation is anchored.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AnchorY As Double
public virtual double AnchorY { get; set; }
public:
virtual property double AnchorY {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorY ()

/** @property */
public void set_AnchorY (double value)

public function get AnchorY () : double

public function set AnchorY (value : double)

Property Value

A double value that represents the Y coordinate an annotation is anchored to.

Remarks

The annotation is anchored to the Y coordinate and is specified in relative chart or axes coordinates, depending on the AxisX property value.

To automatically position an annotation relative to an anchor point make sure its Y property is set to NaN. The AnchorAlignment property can be used to change the automatic position alignment of the annotation to the anchor point. The AnchorOffsetX and AnchorOffsetY properties may be used to add extra spacing.

This property has a higher priority than the AnchorDataPoint property.

Set this value to NaN to disable annotation anchoring to the value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnnotationGroup Property

Annotation.AnnotationGroup Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the group, if any, to which the annotation belongs. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property AnnotationGroup As AnnotationGroup
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public AnnotationGroup AnnotationGroup { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property AnnotationGroup^ AnnotationGroup {
    AnnotationGroup^ get ();
}
/** @property */
public AnnotationGroup get_AnnotationGroup ()

public function get AnnotationGroup () : AnnotationGroup

Remarks

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AnnotationType Property

Annotation.AnnotationType Property |
 | See Also

Gets or sets the type name of an annotation. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public MustOverride ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public abstract string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () abstract;
}
/** @property */
public abstract String get_AnnotationType ()

public abstract function get AnnotationType () : String

Remarks

This property is used to get the name of each annotation type, for example, Line, Rectangle, Ellipse, and so forth. This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AxisX Property

Annotation.AxisX Property |
 | See Also

Gets or sets the X axis to which an annotation is attached.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property AxisX As Axis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Axis AxisX { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Axis^ AxisX {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisX ()

/** @property */
public void set_AxisX (Axis value)

public function get AxisX () : Axis

public function set AxisX (value : Axis)

Property Value

An Axis object to which the annotation is attached.

Remarks

When an annotation is attached to an axis, its X position is always specified in axes coordinates. To also define the size of an annotation in axes coordinates, make sure the IsSizeAlwaysRelative property is set to false.

Set this value to null to disable attachment to the axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AxisXName Property

Annotation.AxisXName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of the X axis to which an annotation is attached. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property AxisXName As String
[BrowsableAttribute(false)]
public virtual string AxisXName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AxisXName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AxisXName ()

/** @property */
public void set_AxisXName (String value)

public function get AxisXName () : String

public function set AxisXName (value : String)

Property Value

A string value that represents the name of the X axis which an annotation is attached to.

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AxisY Property

Annotation.AxisY Property |
 | See Also

Gets or sets the Y axis to which an annotation is attached.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property AxisY As Axis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Axis AxisY { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Axis^ AxisY {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisY ()

/** @property */
public void set_AxisY (Axis value)

public function get AxisY () : Axis

public function set AxisY (value : Axis)

Property Value

An Axis object to which this annotation is attached.

Remarks

When an annotation is attached to an axis, its Y position is always specified in axes coordinates. To also define the size of an annotation in axes coordinates, make sure the IsSizeAlwaysRelative property is set to false.

Set to null to disable annotation attachment to an axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.AxisYName Property

Annotation.AxisYName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of the Y axis which an annotation is attached to. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property AxisYName As String
[BrowsableAttribute(false)]
public virtual string AxisYName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AxisYName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AxisYName ()

/** @property */
public void set_AxisYName (String value)

public function get AxisYName () : String

public function set AxisYName (value : String)

Property Value

A string value that represents the name of the Y axis that an annotation is attached to.

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.BackColor Property

Annotation.BackColor Property |
 | See Also

Gets or sets the color of an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property BackColor As Color
public virtual Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value used to draw an annotation background.

Remarks

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.BackGradientStyle Property

Annotation.BackGradientStyle Property |
 | See Also

Gets or sets the gradient style of an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property BackGradientStyle As GradientStyle
public virtual GradientStyle BackGradientStyle { get; set; }
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw an annotation background.

Remarks

Two colors are used to draw the gradients, BackColor and BackSecondaryColor.

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.BackHatchStyle Property

Annotation.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property BackHatchStyle As ChartHatchStyle
public virtual ChartHatchStyle BackHatchStyle { get; set; }
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the background.

Remarks

Two colors are used to draw the hatching, BackColor and BackSecondaryColor.

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.BackSecondaryColor Property

Annotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property BackSecondaryColor As Color
public virtual Color BackSecondaryColor { get; set; }
public:
virtual property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw an annotation background with hatching or gradient fill.

Remarks

The secondary color is used with the BackColor when BackHatchStyle or BackGradientStyle is used.

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Bottom Property

Annotation.Bottom Property |
 | See Also

Gets or sets the bottom boundary of an annotation position.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property Bottom As Double
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual double Bottom { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property double Bottom {
    double get ();
    void set (double value);
}
/** @property */
public double get_Bottom ()

/** @property */
public void set_Bottom (double value)

public function get Bottom () : double

public function set Bottom (value : double)

Property Value

A double value that represents the position of the bottom boundary of an annotation.

Remarks

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX and AxisY properties and set the IsSizeAlwaysRelative property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.ClipToChartArea Property

Annotation.ClipToChartArea Property |
 | See Also

Gets or sets the name of the chart area to which an annotation is clipped.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ClipToChartArea As String
public virtual string ClipToChartArea { get; set; }
public:
virtual property String^ ClipToChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ClipToChartArea ()

/** @property */
public void set_ClipToChartArea (String value)

public function get ClipToChartArea () : String

public function set ClipToChartArea (value : String)

Property Value

A string that represents the name of an existing chart area.

Remarks

If the chart area name is specified, an annotation will only be drawn inside the plotting area of the chart area specified. All parts of the annotation outside of the plotting area will be clipped.

To disable chart area clipping, set the property to Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Font Property

Annotation.Font Property |
 | See Also

Gets or sets the font to use for the text of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Font As Font
public virtual Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object used to draw the annotation text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.ForeColor Property

Annotation.ForeColor Property |
 | See Also

Gets or sets the text color of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ForeColor As Color
public virtual Color ForeColor { get; set; }
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value used for the text color of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Height Property

Annotation.Height Property |
 | See Also

Gets or sets the height of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Height As Double
public virtual double Height { get; set; }
public:
virtual property double Height {
    double get ();
    void set (double value);
}
/** @property */
public double get_Height ()

/** @property */
public void set_Height (double value)

public function get Height () : double

public function set Height (value : double)

Property Value

A double value that represents the height of an annotation.

Remarks

The height of an annotation can be a negative value, in which case the annotation orientation is switched.

Annotation width can be in relative chart coordinates or in axes coordinates. Chart relative coordinates are used by default.

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX or AxisY properties and set the IsSizeAlwaysRelative property to false.

Set the width to NaN to achieve automatic size calculation for annotations with text. The size will automatically be calculated based on the annotation text and font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.IsSelected Property

Annotation.IsSelected Property |
 | See Also

Gets or sets a flag that determines if an annotation is selected.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property IsSelected As Boolean
[BrowsableAttribute(false)]
public virtual bool IsSelected { get; set; }
[BrowsableAttribute(false)]
public:
virtual property bool IsSelected {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSelected ()

/** @property */
public void set_IsSelected (boolean value)

public function get IsSelected () : boolean

public function set IsSelected (value : boolean)

Property Value

True if the annotation is selected, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.IsSizeAlwaysRelative Property

Annotation.IsSizeAlwaysRelative Property |
 | See Also

Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property IsSizeAlwaysRelative As Boolean
public virtual bool IsSizeAlwaysRelative { get; set; }
public:
virtual property bool IsSizeAlwaysRelative {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSizeAlwaysRelative ()

/** @property */
public void set_IsSizeAlwaysRelative (boolean value)

public function get IsSizeAlwaysRelative () : boolean

public function set IsSizeAlwaysRelative (value : boolean)

Property Value

True if the Width and Height of an annotation are always expressed in relative chart coordinates, otherwise false.

Remarks

The height and width of an annotation may be set in relative chart or in axes coordinates. Relative chart coordinates are the default.

To express the size of an annotation in axes coordinates, set the IsSizeAlwaysRelative property to false. Then anchor the annotation to a data point or set the AxisX and AxisY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.LineColor Property

Annotation.LineColor Property |
 | See Also

Gets or sets the line color of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property LineColor As Color
public virtual Color LineColor { get; set; }
public:
virtual property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color value used to draw an annotation's line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.LineDashStyle Property

Annotation.LineDashStyle Property |
 | See Also

Gets or sets the line style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property LineDashStyle As ChartDashStyle
public virtual ChartDashStyle LineDashStyle { get; set; }
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value used to draw the line style of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.LineWidth Property

Annotation.LineWidth Property |
 | See Also

Gets or sets the line width of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property LineWidth As Integer
public virtual int LineWidth { get; set; }
public:
virtual property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that defines the line width, in pixels, of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.MapAreaAttributes Property

Annotation.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MapAreaAttributes As String
public virtual string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MapAreaAttributes ()

/** @property */
public void set_MapAreaAttributes (String value)

public function get MapAreaAttributes () : String

public function set MapAreaAttributes (value : String)

Property Value

A string value.

Remarks

This string will be added to the attributes of the image map generated for the annotation.

Special keywords can be used when an annotation is anchored to a data point using the AnchorDataPoint property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Name Property

Annotation.Name Property |
 | See Also

Gets or sets the unique name of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string that represents the unique name of the annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.PostBackValue Property

Annotation.PostBackValue Property |
 | See Also

Gets or sets the postback value which can be processed on the Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that is passed to the Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Right Property

Annotation.Right Property |
 | See Also

Gets or sets the right boundary position of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property Right As Double
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual double Right { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property double Right {
    double get ();
    void set (double value);
}
/** @property */
public double get_Right ()

/** @property */
public void set_Right (double value)

public function get Right () : double

public function set Right (value : double)

Property Value

A double value that represents the position of the right boundary of an annotation.

Remarks

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX or AxisY properties and set the IsSizeAlwaysRelative property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.ShadowColor Property

Annotation.ShadowColor Property |
 | See Also

Gets or sets the color of an annotation's shadow.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ShadowColor As Color
public virtual Color ShadowColor { get; set; }
public:
virtual property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value used to draw the annotation shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.ShadowOffset Property

Annotation.ShadowOffset Property |
 | See Also

Gets or sets the size of an annotation's shadow.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ShadowOffset As Integer
public virtual int ShadowOffset { get; set; }
public:
virtual property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the size of the shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.SmartLabelStyle Property

Annotation.SmartLabelStyle Property |
 | See Also

Gets or sets the smart label style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Property SmartLabelStyle As AnnotationSmartLabelStyle
[BrowsableAttribute(true)]
public AnnotationSmartLabelStyle SmartLabelStyle { get; set; }
[BrowsableAttribute(true)]
public:
property AnnotationSmartLabelStyle^ SmartLabelStyle {
    AnnotationSmartLabelStyle^ get ();
    void set (AnnotationSmartLabelStyle^ value);
}
/** @property */
public AnnotationSmartLabelStyle get_SmartLabelStyle ()

/** @property */
public void set_SmartLabelStyle (AnnotationSmartLabelStyle value)

public function get SmartLabelStyle () : AnnotationSmartLabelStyle

public function set SmartLabelStyle (value : AnnotationSmartLabelStyle)

Property Value

An AnnotationSmartLabelStyle object that represents an annotation's smart labels style properties.

Remarks

Smart labels are used to prevent an annotation from overlapping the data point labels and other annotations.

Note:
Data point labels must also have smart labels enabled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.TextStyle Property

Annotation.TextStyle Property |
 | See Also

Gets or sets the text style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property TextStyle As TextStyle
public virtual TextStyle TextStyle { get; set; }
public:
virtual property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public function get TextStyle () : TextStyle

public function set TextStyle (value : TextStyle)

Property Value

A TextStyle value used to draw the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.ToolTip Property

Annotation.ToolTip Property |
 | See Also

Gets or sets the tooltip text for an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ToolTip As String
public virtual string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value.

Remarks

Special keywords can be used in the text when an annotation is anchored to a data point using the AnchorDataPoint property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Url Property

Annotation.Url Property |
 | See Also

Gets or sets the URL of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Url As String
public virtual string Url { get; set; }
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Url ()

/** @property */
public void set_Url (String value)

public function get Url () : String

public function set Url (value : String)

Property Value

A string value.

Remarks

Special keywords can be used when an annotation is anchored to a data point using the AnchorDataPoint property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Visible Property

Annotation.Visible Property |
 | See Also

Gets or sets a flag that specifies whether an annotation is visible.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Visible As Boolean
public virtual bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public function get Visible () : boolean

public function set Visible (value : boolean)

Property Value

True if the annotation is visible; otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Width Property

Annotation.Width Property |
 | See Also

Gets or sets the width, in pixels, of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Width As Double
public virtual double Width { get; set; }
public:
virtual property double Width {
    double get ();
    void set (double value);
}
/** @property */
public double get_Width ()

/** @property */
public void set_Width (double value)

public function get Width () : double

public function set Width (value : double)

Property Value

A double value that represents the width of an annotation.

Remarks

For more information, see the Height property description.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.X Property

Annotation.X Property |
 | See Also

Gets or sets the X coordinate of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property X As Double
public virtual double X { get; set; }
public:
virtual property double X {
    double get ();
    void set (double value);
}
/** @property */
public double get_X ()

/** @property */
public void set_X (double value)

public function get X () : double

public function set X (value : double)

Property Value

A double value that represents the X coordinate position of the annotation.

Remarks

The X coordinate of an annotation is specified in relative chart coordinates or in axes coordinates. Relative chart coordinates are used by default.

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX and AxisY properties.

Set the X position to NaN to automatically calculate position when the annotation has been anchored using the AnchorDataPoint property or the AnchorX and AnchorY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.Y Property

Annotation.Y Property |
 | See Also

Gets or sets the Y coordinate of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Y As Double
public virtual double Y { get; set; }
public:
virtual property double Y {
    double get ();
    void set (double value);
}
/** @property */
public double get_Y ()

/** @property */
public void set_Y (double value)

public function get Y () : double

public function set Y (value : double)

Property Value

A double value that represents the Y coordinate of an annotation's position.

Remarks

The Y coordinate of an annotation is specified in relative chart coordinates or in axes coordinates. Relative chart coordinates are used by default.

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX or AxisY properties.

Set the Y position to NaN to automatically calculate the position when the annotation has been anchored using the AnchorDataPoint property or the AnchorX and AnchorY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation.YAxisName Property

Annotation.YAxisName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of the Y axis to which an annotation is attached. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property YAxisName As String
[BrowsableAttribute(false)]
public virtual string YAxisName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ YAxisName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_YAxisName ()

/** @property */
public void set_YAxisName (String value)

public function get YAxisName () : String

public function set YAxisName (value : String)

Property Value

A string value that represents the name of the Y axis which an annotation is attached to.

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationCollection Class

AnnotationCollection Class |
 | See Also Members

Stores chart annotation objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AnnotationCollection
    Inherits ChartNamedElementCollection(Of Annotation)
public class AnnotationCollection : ChartNamedElementCollection<Annotation>
public ref class AnnotationCollection : public ChartNamedElementCollection<Annotation^>
public class AnnotationCollection extends ChartNamedElementCollection<Annotation>
public class AnnotationCollection extends ChartNamedElementCollection<Annotation>

Remarks

All chart annotations are stored in this collection.

This class includes methods to add, insert, iterate through and remove annotations from the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.AnnotationCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationCollection Members

AnnotationCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Stores chart annotation objects.

The following tables list the members exposed by the AnnotationCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Overridden. Finds an annotation in the collection by name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

AnnotationCollection Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationCollection Methods

AnnotationCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Overridden. Finds an annotation in the collection by name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

AnnotationCollection Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationCollection.FindByName Method

AnnotationCollection.FindByName Method |
 | See Also

Finds an annotation in the collection by name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function FindByName ( _
    name As String _
) As Annotation
public override Annotation FindByName (
    string name
)
public:
virtual Annotation^ FindByName (
    String^ name
) override
public Annotation FindByName (
    String name
)
public override function FindByName (
    name : String
) : Annotation

Parameters

name

The name of the annotation to find.

Return Value

An Annotation object, or null if the object does not exist.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationCollection Properties

AnnotationCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

AnnotationCollection Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup Class

AnnotationGroup Class |
 | See Also Members

Represents a group of annotations.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AnnotationGroup
    Inherits Annotation
public class AnnotationGroup : Annotation
public ref class AnnotationGroup : public Annotation
public class AnnotationGroup extends Annotation
public class AnnotationGroup extends Annotation

Remarks

The AnnotationGroup class represents a collection of annotations. This class can be used to manipulate annotations relative to each other.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.AnnotationGroup

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup Members

AnnotationGroup Members |
 | See Also Constructors Methods Properties

Represents a group of annotations.

The following tables list the members exposed by the AnnotationGroup type.

Public Constructors

Name | Description
AnnotationGroup | Initializes a new instance of the AnnotationGroup class.
Top

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the content alignment of an annotation.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
Annotations | Gets the collection of annotations in the group.
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the background of an annotation.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Overridden. Gets or sets the name of the chart area to which the annotation is clipped.
Font | Overridden. Gets or sets the font to use for the text of an annotation.
ForeColor | Overridden. Gets or sets the text color for an annotation.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsSelected | Overridden. Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Overridden. Gets or sets the line color of the annotation.
LineDashStyle | Overridden. Gets or sets the line style of the annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of the annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Overridden. Gets or sets the color of the annotation's shadow.
ShadowOffset | Overridden. Gets or sets the size of the annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Overridden. Gets or sets a flag that indicates whether the annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationGroup Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup Constructor

AnnotationGroup Constructor |
 | See Also

Initializes a new instance of the AnnotationGroup class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public AnnotationGroup ()
public:
AnnotationGroup ()
public AnnotationGroup ()
public function AnnotationGroup ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup Methods

AnnotationGroup Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationGroup Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.Dispose Method

AnnotationGroup.Dispose Method |
 | See Also

Overload List

Name | Description
AnnotationGroup.Dispose () | (inherited from Dispose )
AnnotationGroup.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.Dispose Method (Boolean)

AnnotationGroup.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup Properties

AnnotationGroup Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the content alignment of an annotation.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
Annotations | Gets the collection of annotations in the group.
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the background of an annotation.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Overridden. Gets or sets the name of the chart area to which the annotation is clipped.
Font | Overridden. Gets or sets the font to use for the text of an annotation.
ForeColor | Overridden. Gets or sets the text color for an annotation.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsSelected | Overridden. Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Overridden. Gets or sets the line color of the annotation.
LineDashStyle | Overridden. Gets or sets the line style of the annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of the annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Overridden. Gets or sets the color of the annotation's shadow.
ShadowOffset | Overridden. Gets or sets the size of the annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Overridden. Gets or sets a flag that indicates whether the annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

AnnotationGroup Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.Alignment Property

AnnotationGroup.Alignment Property |
 | See Also

Gets or sets the content alignment of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Alignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment Alignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the content alignment of an annotation.

Remarks

This property is used to align text for TextAnnotation, RectangleAnnotation, EllipseAnnotation and CalloutAnnotation objects, and to align a nonscaled image inside an ImageAnnotation object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.Annotations Property

AnnotationGroup.Annotations Property |
 | See Also

Gets the collection of annotations in the group.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Annotations As AnnotationCollection
public AnnotationCollection Annotations { get; }
public:
property AnnotationCollection^ Annotations {
    AnnotationCollection^ get ();
}
/** @property */
public AnnotationCollection get_Annotations ()

public function get Annotations () : AnnotationCollection

Property Value

An AnnotationCollection object.

Remarks

Note that the coordinates of all annotations in the group are relative to the group annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.AnnotationType Property

AnnotationGroup.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This property is used to get the name of each annotation type, for example. Line, Rectangle, Ellipse, and so forth. This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.BackColor Property

AnnotationGroup.BackColor Property |
 | See Also

Gets or sets the background color of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value used for the background of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.BackGradientStyle Property

AnnotationGroup.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw the background of an annotation.

Remarks

Two colors are used to draw the gradient, BackColor and BackSecondaryColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.BackHatchStyle Property

AnnotationGroup.BackHatchStyle Property |
 | See Also

Gets or sets the hatch style of an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the background of an annotation.

Remarks

Two colors are used to draw the hatching, BackColor and BackSecondaryColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.BackSecondaryColor Property

AnnotationGroup.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for the background of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw the background with hatching or gradient fill.

Remarks

A secondary color is used with BackColor when BackHatchStyle or BackGradientStyle are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.ClipToChartArea Property

AnnotationGroup.ClipToChartArea Property |
 | See Also

Gets or sets the name of the chart area to which the annotation is clipped.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ClipToChartArea As String
[BrowsableAttribute(false)]
public override string ClipToChartArea { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ ClipToChartArea {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_ClipToChartArea ()

/** @property */
public void set_ClipToChartArea (String value)

public override function get ClipToChartArea () : String

public override function set ClipToChartArea (value : String)

Property Value

A string that represents the name of an existing chart area.

Remarks

If a chart area name is specified, the annotation will only be drawn inside the plotting area of that chart area. All parts of the annotation outside of the plotting area will be clipped.

To disable chart area clipping, set this property to NaN or an empty string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.Font Property

AnnotationGroup.Font Property |
 | See Also

Gets or sets the font to use for the text of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object used for the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.ForeColor Property

AnnotationGroup.ForeColor Property |
 | See Also

Gets or sets the text color for an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value used for the text color of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.IsSelected Property

AnnotationGroup.IsSelected Property |
 | See Also

Gets or sets a flag that determines if an annotation is selected.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property IsSelected As Boolean
[BrowsableAttribute(false)]
public override bool IsSelected { get; set; }
[BrowsableAttribute(false)]
public:
virtual property bool IsSelected {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_IsSelected ()

/** @property */
public void set_IsSelected (boolean value)

public override function get IsSelected () : boolean

public override function set IsSelected (value : boolean)

Property Value

True if the annotation is selected, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.IsSizeAlwaysRelative Property

AnnotationGroup.IsSizeAlwaysRelative Property |
 | See Also

Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property IsSizeAlwaysRelative As Boolean
public override bool IsSizeAlwaysRelative { get; set; }
public:
virtual property bool IsSizeAlwaysRelative {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_IsSizeAlwaysRelative ()

/** @property */
public void set_IsSizeAlwaysRelative (boolean value)

public override function get IsSizeAlwaysRelative () : boolean

public override function set IsSizeAlwaysRelative (value : boolean)

Property Value

True if the Width and Height of an annotation are always in chart relative coordinates, otherwise false.

Remarks

The height and width of an annotation may be set in relative chart or in axes coordinates. By default, relative chart coordinates are used.

To use axes coordinates, set the IsSizeAlwaysRelative property to false. Then either anchor the annotation to a data point or set the AxisX or AxisY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.LineColor Property

AnnotationGroup.LineColor Property |
 | See Also

Gets or sets the line color of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(false)]
public override Color LineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value used to draw an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.LineDashStyle Property

AnnotationGroup.LineDashStyle Property |
 | See Also

Gets or sets the line style of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value used to draw an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.LineWidth Property

AnnotationGroup.LineWidth Property |
 | See Also

Gets or sets the line width, in pixels, of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(false)]
public override int LineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value defining the width, in pixels, of an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.ShadowColor Property

AnnotationGroup.ShadowColor Property |
 | See Also

Gets or sets the color of the annotation's shadow.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ShadowColor As Color
[BrowsableAttribute(false)]
public override Color ShadowColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ShadowColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public override function get ShadowColor () : Color

public override function set ShadowColor (value : Color)

Property Value

A Color value used to draw the shadow of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.ShadowOffset Property

AnnotationGroup.ShadowOffset Property |
 | See Also

Gets or sets the size of the annotation's shadow.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ShadowOffset As Integer
[BrowsableAttribute(false)]
public override int ShadowOffset { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int ShadowOffset {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public override function get ShadowOffset () : int

public override function set ShadowOffset (value : int)

Property Value

An integer value that represents the offset between an annotation and its shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.TextStyle Property

AnnotationGroup.TextStyle Property |
 | See Also

Gets or sets the text style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle value used to draw the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationGroup.Visible Property

AnnotationGroup.Visible Property |
 | See Also

Gets or sets a flag that indicates whether the annotation is visible.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Visible As Boolean
public override bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public override function get Visible () : boolean

public override function set Visible (value : boolean)

Property Value

True if the annotation is visible, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Class

AnnotationPathPoint Class |
 | See Also Members

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AnnotationPathPoint
    Inherits ChartElement

public class AnnotationPathPoint : ChartElement

public ref class AnnotationPathPoint : public ChartElement

public class AnnotationPathPoint extends ChartElement

public class AnnotationPathPoint extends ChartElement

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.AnnotationPathPoint

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Members

AnnotationPathPoint Members |
 | See Also Constructors Methods Properties

The following tables list the members exposed by the AnnotationPathPoint type.

Public Constructors

Name | Description
AnnotationPathPoint | Overloaded. Initializes a new instance of the AnnotationPathPoint class.
Top

Public Properties

Name | Description
Name | Gets the name for the path point of an annotation.
PointType | Gets or sets the type for the path point of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
X | Gets or sets the X coordinate for the path point of an annotation.
Y | Gets or sets the Y coordinate for the path point of an annotation.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationPathPoint Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Constructor

AnnotationPathPoint Constructor |
 | See Also

Initializes a new instance of the AnnotationPathPoint class.

Overload List

Name | Description
AnnotationPathPoint () | Initializes a new instance of the AnnotationPathPoint class.
AnnotationPathPoint (Single, Single) | Initializes a new instance of the AnnotationPathPoint class with the specified x and y values.
AnnotationPathPoint (Single, Single, Byte) | Initializes a new instance of the AnnotationPathPoint class with the specified x, y and point type values.

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Constructor ()

AnnotationPathPoint Constructor () |
 | See Also

Initializes a new instance of the AnnotationPathPoint class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public AnnotationPathPoint ()
public:
AnnotationPathPoint ()
public AnnotationPathPoint ()
public function AnnotationPathPoint ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Constructor (Single, Single)

AnnotationPathPoint Constructor (Single, Single) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified x and y values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    x As Single, _
    y As Single _
)
public AnnotationPathPoint (
    float x,
    float y
)
public:
AnnotationPathPoint (
    float x,
    float y
)
public AnnotationPathPoint (
    float x,
    float y
)
public function AnnotationPathPoint (
    x : float,
    y : float
)

Parameters

x

Point X-value.

y

Point Y-value.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Constructor (Single, Single, Byte)

AnnotationPathPoint Constructor (Single, Single, Byte) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified x, y and point type values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    x As Single, _
    y As Single, _
    type As Byte _
)
public AnnotationPathPoint (
    float x,
    float y,
    byte type
)
public:
AnnotationPathPoint (
    float x,
    float y,
    unsigned char type
)
public AnnotationPathPoint (
    float x,
    float y,
    byte type
)
public function AnnotationPathPoint (
    x : float,
    y : float,
    type : byte
)

Parameters

x

Point X-value.

y

Point Y-value.

type

Point type.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Methods

AnnotationPathPoint Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationPathPoint Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint Properties

AnnotationPathPoint Properties |
 | See Also

Public Properties

Name | Description
Name | Gets the name for the path point of an annotation.
PointType | Gets or sets the type for the path point of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
X | Gets or sets the X coordinate for the path point of an annotation.
Y | Gets or sets the Y coordinate for the path point of an annotation.

See Also

Reference

AnnotationPathPoint Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint.Name Property

AnnotationPathPoint.Name Property |
 | See Also

Gets the name for the path point of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property Name As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string Name { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Property Value

A string value that represents the name of the path point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint.PointType Property

AnnotationPathPoint.PointType Property |
 | See Also

Gets or sets the type for the path point of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property PointType As Byte
[BrowsableAttribute(false)]
public byte PointType { get; set; }
[BrowsableAttribute(false)]
public:
property unsigned char PointType {
    unsigned char get ();
    void set (unsigned char value);
}
/** @property */
public byte get_PointType ()

/** @property */
public void set_PointType (byte value)

public function get PointType () : byte

public function set PointType (value : byte)

Property Value

A byte value.

Remarks

See the PathPointType enumeration for more details.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint.X Property

AnnotationPathPoint.X Property |
 | See Also

Gets or sets the X coordinate for the path point of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Property X As Single
[BrowsableAttribute(true)]
public float X { get; set; }
[BrowsableAttribute(true)]
public:
property float X {
    float get ();
    void set (float value);
}
/** @property */
public float get_X ()

/** @property */
public void set_X (float value)

public function get X () : float

public function set X (value : float)

Property Value

A float that represents the X value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPoint.Y Property

AnnotationPathPoint.Y Property |
 | See Also

Gets or sets the Y coordinate for the path point of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Property Y As Single
[BrowsableAttribute(true)]
public float Y { get; set; }
[BrowsableAttribute(true)]
public:
property float Y {
    float get ();
    void set (float value);
}
/** @property */
public float get_Y ()

/** @property */
public void set_Y (float value)

public function get Y () : float

public function set Y (value : float)

Property Value

A float that represents the Y value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection Class

AnnotationPathPointCollection Class |
 | See Also Members

Represents a collection of PolylineAnnotation or PolygonAnnotation path points, which can be accessed using the GraphicPathPoints property.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AnnotationPathPointCollection
    Inherits ChartElementCollection(Of AnnotationPathPoint)
public class AnnotationPathPointCollection : ChartElementCollection<AnnotationPathPoint>
public ref class AnnotationPathPointCollection : public ChartElementCollection<AnnotationPathPoint^>
public class AnnotationPathPointCollection extends ChartElementCollection<AnnotationPathPoint>
public class AnnotationPathPointCollection extends ChartElementCollection<AnnotationPathPoint>

Remarks

This collection is used at design time only, and employs serialization to expose the shape of a polyline or polygon annotation, using their respective GraphicPathPoints collection properties.

At run time, use the GraphicsPath property to set the path of a PolylineAnnotation or PolygonAnnotation.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.AnnotationPathPointCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection Members

AnnotationPathPointCollection Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

Represents a collection of PolylineAnnotation or PolygonAnnotation path points, which can be accessed using the GraphicPathPoints property.

The following tables list the members exposed by the AnnotationPathPointCollection type.

Public Constructors

Name | Description
AnnotationPathPointCollection | Initializes a new instance of the AnnotationPathPointCollection class with the specified polyline annotation.
Top

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Overridden. Forces the invalidation of the chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

AnnotationPathPointCollection Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection Constructor

AnnotationPathPointCollection Constructor |
 | See Also

Initializes a new instance of the AnnotationPathPointCollection class with the specified polyline annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    annotation As PolylineAnnotation _
)
public AnnotationPathPointCollection (
    PolylineAnnotation annotation
)
public:
AnnotationPathPointCollection (
    PolylineAnnotation^ annotation
)
public AnnotationPathPointCollection (
    PolylineAnnotation annotation
)
public function AnnotationPathPointCollection (
    annotation : PolylineAnnotation
)

Parameters

annotation

A polyline annotation.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection Methods

AnnotationPathPointCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Overridden. Forces the invalidation of the chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

AnnotationPathPointCollection Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection.Dispose Method

AnnotationPathPointCollection.Dispose Method |
 | See Also

Overload List

Name | Description
AnnotationPathPointCollection.Dispose () | (inherited from Dispose )
AnnotationPathPointCollection.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection.Dispose Method (Boolean)

AnnotationPathPointCollection.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection.Invalidate Method

AnnotationPathPointCollection.Invalidate Method |
 | See Also

Forces the invalidation of the chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Sub Invalidate
public override void Invalidate ()
public:
virtual void Invalidate () override
public void Invalidate ()
public override function Invalidate ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationPathPointCollection Properties

AnnotationPathPointCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

AnnotationPathPointCollection Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Class

AnnotationSmartLabelStyle Class |
 | See Also Members

Stores the smart label properties of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AnnotationSmartLabelStyle
    Inherits SmartLabelStyle
public class AnnotationSmartLabelStyle : SmartLabelStyle
public ref class AnnotationSmartLabelStyle : public SmartLabelStyle
public class AnnotationSmartLabelStyle extends SmartLabelStyle
public class AnnotationSmartLabelStyle extends SmartLabelStyle

Remarks

This class is derived from the SmartLabelStyle class used for Series objects.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.SmartLabelStyle
System.Web.UI.DataVisualization.Charting.AnnotationSmartLabelStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Members

AnnotationSmartLabelStyle Members |
 | See Also Constructors Methods Properties

Stores the smart label properties of an annotation.

The following tables list the members exposed by the AnnotationSmartLabelStyle type.

Public Constructors

Name | Description
AnnotationSmartLabelStyle | Overloaded.
Top

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area. (inherited from SmartLabelStyle)
CalloutBackColor | Overridden. Gets or sets the back color of the label callout. This property is only applicable when the CalloutStyle property is set to a value of Box.
CalloutLineAnchorCapStyle | Overridden. Gets or sets the anchor cap style for the label callout line.
CalloutLineColor | Overridden. Gets or sets the color of the label callout line.
CalloutLineDashStyle | Overridden. Gets or sets the style of the label callout line.
CalloutLineWidth | Overridden. Gets or sets the width of the label callout line.
CalloutStyle | Overridden. Gets or sets the callout style of the repositioned smart labels.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled. (inherited from SmartLabelStyle)
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker. (inherited from SmartLabelStyle)
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden. (inherited from SmartLabelStyle)
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle)
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle)
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved. (inherited from SmartLabelStyle)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationSmartLabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Constructor

AnnotationSmartLabelStyle Constructor |
 | See Also

Overload List

Name | Description
AnnotationSmartLabelStyle () | Initializes a new instance of the AnnotationSmartLabelStyle class.
AnnotationSmartLabelStyle (Object) | Initializes a new instance of the AnnotationSmartLabelStyle class with the specified chart element.

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Constructor ()

AnnotationSmartLabelStyle Constructor () |
 | See Also

Initializes a new instance of the AnnotationSmartLabelStyle class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public AnnotationSmartLabelStyle ()
public:
AnnotationSmartLabelStyle ()
public AnnotationSmartLabelStyle ()
public function AnnotationSmartLabelStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Constructor (Object)

AnnotationSmartLabelStyle Constructor (Object) |
 | See Also

Initializes a new instance of the AnnotationSmartLabelStyle class with the specified chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    chartElement As Object _
)
public AnnotationSmartLabelStyle (
    Object chartElement
)
public:
AnnotationSmartLabelStyle (
    Object^ chartElement
)
public AnnotationSmartLabelStyle (
    Object chartElement
)
public function AnnotationSmartLabelStyle (
    chartElement : Object
)

Parameters

chartElement

Chart element that this style belongs to.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Methods

AnnotationSmartLabelStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationSmartLabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle Properties

AnnotationSmartLabelStyle Properties |
 | See Also

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area. (inherited from SmartLabelStyle )
CalloutBackColor | Overridden. Gets or sets the back color of the label callout. This property is only applicable when the CalloutStyle property is set to a value of Box.
CalloutLineAnchorCapStyle | Overridden. Gets or sets the anchor cap style for the label callout line.
CalloutLineColor | Overridden. Gets or sets the color of the label callout line.
CalloutLineDashStyle | Overridden. Gets or sets the style of the label callout line.
CalloutLineWidth | Overridden. Gets or sets the width of the label callout line.
CalloutStyle | Overridden. Gets or sets the callout style of the repositioned smart labels.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled. (inherited from SmartLabelStyle )
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker. (inherited from SmartLabelStyle )
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden. (inherited from SmartLabelStyle )
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle )
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle )
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved. (inherited from SmartLabelStyle )

See Also

Reference

AnnotationSmartLabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle.CalloutBackColor Property

AnnotationSmartLabelStyle.CalloutBackColor Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the back color of the label callout. This property is only applicable when the CalloutStyle property is set to a value of Box.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutBackColor As Color
[BrowsableAttribute(false)]
public override Color CalloutBackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color CalloutBackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_CalloutBackColor ()

/** @property */
public void set_CalloutBackColor (Color value)

public override function get CalloutBackColor () : Color

public override function set CalloutBackColor (value : Color)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle.CalloutLineAnchorCapStyle Property

AnnotationSmartLabelStyle.CalloutLineAnchorCapStyle Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the anchor cap style for the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineAnchorCapStyle As LineAnchorCapStyle
[BrowsableAttribute(false)]
public override LineAnchorCapStyle CalloutLineAnchorCapStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LineAnchorCapStyle CalloutLineAnchorCapStyle {
    LineAnchorCapStyle get () override;
    void set (LineAnchorCapStyle value) override;
}
/** @property */
public LineAnchorCapStyle get_CalloutLineAnchorCapStyle ()

/** @property */
public void set_CalloutLineAnchorCapStyle (LineAnchorCapStyle value)

public override function get CalloutLineAnchorCapStyle () : LineAnchorCapStyle

public override function set CalloutLineAnchorCapStyle (value : LineAnchorCapStyle)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle.CalloutLineColor Property

AnnotationSmartLabelStyle.CalloutLineColor Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the color of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineColor As Color
[BrowsableAttribute(false)]
public override Color CalloutLineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color CalloutLineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_CalloutLineColor ()

/** @property */
public void set_CalloutLineColor (Color value)

public override function get CalloutLineColor () : Color

public override function set CalloutLineColor (value : Color)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle.CalloutLineDashStyle Property

AnnotationSmartLabelStyle.CalloutLineDashStyle Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the style of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle CalloutLineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle CalloutLineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_CalloutLineDashStyle ()

/** @property */
public void set_CalloutLineDashStyle (ChartDashStyle value)

public override function get CalloutLineDashStyle () : ChartDashStyle

public override function set CalloutLineDashStyle (value : ChartDashStyle)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle.CalloutLineWidth Property

AnnotationSmartLabelStyle.CalloutLineWidth Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the width of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineWidth As Integer
[BrowsableAttribute(false)]
public override int CalloutLineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int CalloutLineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CalloutLineWidth ()

/** @property */
public void set_CalloutLineWidth (int value)

public override function get CalloutLineWidth () : int

public override function set CalloutLineWidth (value : int)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnnotationSmartLabelStyle.CalloutStyle Property

AnnotationSmartLabelStyle.CalloutStyle Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the callout style of the repositioned smart labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutStyle As LabelCalloutStyle
[BrowsableAttribute(false)]
public override LabelCalloutStyle CalloutStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LabelCalloutStyle CalloutStyle {
    LabelCalloutStyle get () override;
    void set (LabelCalloutStyle value) override;
}
/** @property */
public LabelCalloutStyle get_CalloutStyle ()

/** @property */
public void set_CalloutStyle (LabelCalloutStyle value)

public override function get CalloutStyle () : LabelCalloutStyle

public override function set CalloutStyle (value : LabelCalloutStyle)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult Class

AnovaResult Class |
 | See Also Members

Represents the results of an ANOVA statistical test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AnovaResult
public class AnovaResult
public ref class AnovaResult
public class AnovaResult
public class AnovaResult

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.AnovaResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult Members

AnovaResult Members |
 | See Also Constructors Methods Properties

Represents the results of an ANOVA statistical test.

The following tables list the members exposed by the AnovaResult type.

Public Constructors

Name | Description
AnovaResult | Initializes a new instance of the AnovaResult class.
Top

Public Properties

Name | Description
DegreeOfFreedomBetweenGroups | Gets the degree of freedom between groups.
DegreeOfFreedomTotal | Gets the total degree of freedom.
DegreeOfFreedomWithinGroups | Gets the degree of freedom within groups.
FCriticalValue | Gets the F-critical value.
FRatio | Gets the F ratio.
MeanSquareVarianceBetweenGroups | Gets the mean square variance between groups.
MeanSquareVarianceWithinGroups | Gets the mean square variance within groups.
SumOfSquaresBetweenGroups | Gets the sum of the squares between groups.
SumOfSquaresTotal | Gets the total sum of the squares.
SumOfSquaresWithinGroups | Gets the sum of the squares within groups.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnovaResult Class
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult Constructor

AnovaResult Constructor |
 | See Also

Initializes a new instance of the AnovaResult class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public AnovaResult ()
public:
AnovaResult ()
public AnovaResult ()
public function AnovaResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult Methods

AnovaResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnovaResult Class
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult Properties

AnovaResult Properties |
 | See Also

Public Properties

Name | Description
DegreeOfFreedomBetweenGroups | Gets the degree of freedom between groups.
DegreeOfFreedomTotal | Gets the total degree of freedom.
DegreeOfFreedomWithinGroups | Gets the degree of freedom within groups.
FCriticalValue | Gets the F-critical value.
FRatio | Gets the F ratio.
MeanSquareVarianceBetweenGroups | Gets the mean square variance between groups.
MeanSquareVarianceWithinGroups | Gets the mean square variance within groups.
SumOfSquaresBetweenGroups | Gets the sum of the squares between groups.
SumOfSquaresTotal | Gets the total sum of the squares.
SumOfSquaresWithinGroups | Gets the sum of the squares within groups.

See Also

Reference

AnovaResult Class
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.DegreeOfFreedomBetweenGroups Property

AnovaResult.DegreeOfFreedomBetweenGroups Property |
 | See Also

Gets the degree of freedom between groups.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedomBetweenGroups As Double
public double DegreeOfFreedomBetweenGroups { get; }
public:
property double DegreeOfFreedomBetweenGroups {
    double get ();
}
/** @property */
public double get_DegreeOfFreedomBetweenGroups ()

public function get DegreeOfFreedomBetweenGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.DegreeOfFreedomTotal Property

AnovaResult.DegreeOfFreedomTotal Property |
 | See Also

Gets the total degree of freedom.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedomTotal As Double
public double DegreeOfFreedomTotal { get; }
public:
property double DegreeOfFreedomTotal {
    double get ();
}
/** @property */
public double get_DegreeOfFreedomTotal ()

public function get DegreeOfFreedomTotal () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.DegreeOfFreedomWithinGroups Property

AnovaResult.DegreeOfFreedomWithinGroups Property |
 | See Also

Gets the degree of freedom within groups.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedomWithinGroups As Double
public double DegreeOfFreedomWithinGroups { get; }
public:
property double DegreeOfFreedomWithinGroups {
    double get ();
}
/** @property */
public double get_DegreeOfFreedomWithinGroups ()

public function get DegreeOfFreedomWithinGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.FCriticalValue Property

AnovaResult.FCriticalValue Property |
 | See Also

Gets the F-critical value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FCriticalValue As Double
public double FCriticalValue { get; }
public:
property double FCriticalValue {
    double get ();
}
/** @property */
public double get_FCriticalValue ()

public function get FCriticalValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.FRatio Property

AnovaResult.FRatio Property |
 | See Also

Gets the F ratio.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FRatio As Double
public double FRatio { get; }
public:
property double FRatio {
    double get ();
}
/** @property */
public double get_FRatio ()

public function get FRatio () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.MeanSquareVarianceBetweenGroups Property

AnovaResult.MeanSquareVarianceBetweenGroups Property |
 | See Also

Gets the mean square variance between groups.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property MeanSquareVarianceBetweenGroups As Double
public double MeanSquareVarianceBetweenGroups { get; }
public:
property double MeanSquareVarianceBetweenGroups {
    double get ();
}
/** @property */
public double get_MeanSquareVarianceBetweenGroups ()

public function get MeanSquareVarianceBetweenGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.MeanSquareVarianceWithinGroups Property

AnovaResult.MeanSquareVarianceWithinGroups Property |
 | See Also

Gets the mean square variance within groups.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property MeanSquareVarianceWithinGroups As Double
public double MeanSquareVarianceWithinGroups { get; }
public:
property double MeanSquareVarianceWithinGroups {
    double get ();
}
/** @property */
public double get_MeanSquareVarianceWithinGroups ()

public function get MeanSquareVarianceWithinGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.SumOfSquaresBetweenGroups Property

AnovaResult.SumOfSquaresBetweenGroups Property |
 | See Also

Gets the sum of the squares between groups.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SumOfSquaresBetweenGroups As Double
public double SumOfSquaresBetweenGroups { get; }
public:
property double SumOfSquaresBetweenGroups {
    double get ();
}
/** @property */
public double get_SumOfSquaresBetweenGroups ()

public function get SumOfSquaresBetweenGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.SumOfSquaresTotal Property

AnovaResult.SumOfSquaresTotal Property |
 | See Also

Gets the total sum of the squares.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SumOfSquaresTotal As Double
public double SumOfSquaresTotal { get; }
public:
property double SumOfSquaresTotal {
    double get ();
}
/** @property */
public double get_SumOfSquaresTotal ()

public function get SumOfSquaresTotal () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AnovaResult.SumOfSquaresWithinGroups Property

AnovaResult.SumOfSquaresWithinGroups Property |
 | See Also

Gets the sum of the squares within groups.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SumOfSquaresWithinGroups As Double
public double SumOfSquaresWithinGroups { get; }
public:
property double SumOfSquaresWithinGroups {
    double get ();
}
/** @property */
public double get_SumOfSquaresWithinGroups ()

public function get SumOfSquaresWithinGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members
System.Web.UI.DataVisualization.Charting Namespace


AntiAliasingStyles Enumeration

AntiAliasingStyles Enumeration |
 | See Also

Specifies the anti-aliasing options for the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AntiAliasingStyles
public enum AntiAliasingStyles
public enum class AntiAliasingStyles
public enum AntiAliasingStyles
public enum AntiAliasingStyles

Members

Member name | Description
All | Use anti-aliasing for text and graphics.
Graphics | Use anti-aliasing when drawing graphics primitives such as circles or rectangles.
None | Do not use anti-aliasing.
Text | Use anti-aliasing when drawing text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


AreaAlignmentOrientations Enumeration

AreaAlignmentOrientations Enumeration |
 | See Also

Specifies the alignment orientation of a chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AreaAlignmentOrientations
public enum AreaAlignmentOrientations
public enum class AreaAlignmentOrientations
public enum AreaAlignmentOrientations
public enum AreaAlignmentOrientations

Members

Member name | Description
All | Chart areas are aligned horizontally and vertically.
Horizontal | Chart areas are aligned horizontally.
None | Chart areas are not automatically aligned.
Vertical | Chart areas are aligned vertically.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


AreaAlignmentStyles Enumeration

AreaAlignmentStyles Enumeration |
 | See Also

Specifies the alignment styles of chart areas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AreaAlignmentStyles
public enum AreaAlignmentStyles
public enum class AreaAlignmentStyles
public enum AreaAlignmentStyles
public enum AreaAlignmentStyles

Members

Member name | Description
All | Chart areas are aligned using all values.
AxesView | Chart areas are aligned using their axis scale views.
None | Chart areas are not automatically aligned.
PlotPosition | Chart areas are aligned by their inner plot position.
Position | Chart areas are aligned by the chart area position.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation Class

ArrowAnnotation Class |
 | See Also Members

Represents an arrow annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ArrowAnnotation
    Inherits Annotation
public class ArrowAnnotation : Annotation
public ref class ArrowAnnotation : public Annotation
public class ArrowAnnotation extends Annotation
public class ArrowAnnotation extends Annotation

Remarks

Arrow annotations can be used to connect to points on the chart or to highlight a single chart area.

Different arrow styles and sizes can be applied to the annotation.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.ArrowAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation Members

ArrowAnnotation Members |
 | See Also Constructors Methods Properties

Represents an arrow annotation.

The following tables list the members exposed by the ArrowAnnotation type.

Public Constructors

Name | Description
ArrowAnnotation | Initializes a new instance of the ArrowAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AnchorAlignment | Overridden. Gets or sets the position alignment of the annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the name of the annotation type. For internal use, should not be used.
ArrowSize | Gets or sets an arrow size, in pixels.
ArrowStyle | Gets or sets the arrow style.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Gets or sets the color of an annotation background. (inherited from Annotation)
BackGradientStyle | Gets or sets the gradient style of an annotation background. (inherited from Annotation)
BackHatchStyle | Gets or sets the hatching style of an annotation background. (inherited from Annotation)
BackSecondaryColor | Gets or sets the secondary color of an annotation background. (inherited from Annotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font to use for the text of an annotation. (inherited from Annotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ArrowAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation Constructor

ArrowAnnotation Constructor |
 | See Also

Initializes a new instance of the ArrowAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ArrowAnnotation ()
public:
ArrowAnnotation ()
public ArrowAnnotation ()
public function ArrowAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation Methods

ArrowAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ArrowAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation Properties

ArrowAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AnchorAlignment | Overridden. Gets or sets the position alignment of the annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the name of the annotation type. For internal use, should not be used.
ArrowSize | Gets or sets an arrow size, in pixels.
ArrowStyle | Gets or sets the arrow style.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Gets or sets the color of an annotation background. (inherited from Annotation )
BackGradientStyle | Gets or sets the gradient style of an annotation background. (inherited from Annotation )
BackHatchStyle | Gets or sets the hatching style of an annotation background. (inherited from Annotation )
BackSecondaryColor | Gets or sets the secondary color of an annotation background. (inherited from Annotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font to use for the text of an annotation. (inherited from Annotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

ArrowAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation.AnchorAlignment Property

ArrowAnnotation.AnchorAlignment Property |
 | See Also

Gets or sets the position alignment of the annotation to the anchor point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property AnchorAlignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment AnchorAlignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public override function get AnchorAlignment () : ContentAlignment

public override function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the alignment of the annotation to the anchor point.

Remarks

The annotation must be anchored using either AnchorDataPoint, or the AnchorX and AnchorY properties.

Its X and Y properties must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation.AnnotationType Property

ArrowAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the name of the annotation type. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Property Value

A string value that represents the name of the annotation type.

Remarks

Gets the name of each annotation type such as Line, Rectangle, Ellipse, and so forth.

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation.ArrowSize Property

ArrowAnnotation.ArrowSize Property |
 | See Also

Gets or sets an arrow size, in pixels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ArrowSize As Integer
public virtual int ArrowSize { get; set; }
public:
virtual property int ArrowSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_ArrowSize ()

/** @property */
public void set_ArrowSize (int value)

public function get ArrowSize () : int

public function set ArrowSize (value : int)

Property Value

An integer value that represents arrow size—that is, its thickness—in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ArrowAnnotation.ArrowStyle Property

ArrowAnnotation.ArrowStyle Property |
 | See Also

Gets or sets the arrow style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ArrowStyle As ArrowStyle
public virtual ArrowStyle ArrowStyle { get; set; }
public:
virtual property ArrowStyle ArrowStyle {
    ArrowStyle get ();
    void set (ArrowStyle value);
}
/** @property */
public ArrowStyle get_ArrowStyle ()

/** @property */
public void set_ArrowStyle (ArrowStyle value)

public function get ArrowStyle () : ArrowStyle

public function set ArrowStyle (value : ArrowStyle)

Property Value

The ArrowStyle of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ArrowStyle Enumeration

ArrowStyle Enumeration |
 | See Also

Specifies styles for an arrow annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ArrowStyle
public enum ArrowStyle
public enum class ArrowStyle
public enum ArrowStyle
public enum ArrowStyle

Members

Member name | Description
DoubleArrow | An arrow that points in two directions.
Simple | A simple one-pointed arrow.
Tailed | An arrow with a tail.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Axis Class

Axis Class |
 | See Also Members

Provides methods and properties that manage axes in the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Axis
    Inherits ChartNamedElement
    Implements IChartMapArea
public class Axis : ChartNamedElement, IChartMapArea
public ref class Axis : public ChartNamedElement, IChartMapArea
public class Axis extends ChartNamedElement implements IChartMapArea
public class Axis extends ChartNamedElement implements IChartMapArea

Remarks

This class encapsulates all the functionality for axes in the Chart control, and is exposed by the AxisX, AxisY, AxisX2 and AxisY2 properties of ChartArea objects.

For all charts—except bar, stacked bar, pie and doughnut—the primary and secondary axes are as follows:

Axis Type | Description
Primary X-Axis | Bottom horizontal axis.
Secondary X-Axis | Top horizontal axis.
Primary Y-Axis | Left vertical axis.
Secondary Y-Axis | Right vertical axis.

Bar and stacked-bar charts have their axes rotated 90 degrees clockwise, so the primary X axis for these two chart types is the left-vertical axis.

Note There can be only one set of axes—two vertical and two horizontal—for each ChartArea object.

The Axis class also contains several methods that can be used to convert axis values to absolute pixel coordinates, which are useful for 2D custom drawing, or to relative coordinates, which are useful for 3D custom drawing. Absolute and relative coordinates can also be converted to axis values.

The following are the most important axis elements exposed by the Axis class:

Axis Element | Description
Axis Labels | The labels of an axis, and their associated properties.
Grid Lines | The major and minor grid lines of an axis.
Tick Marks | The major and minor tick marks of an axis.
Strip Lines | Strip lines.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Axis

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis Members

Axis Members |
 | See Also Constructors Methods Properties

Provides methods and properties that manage axes in the Chart control.

The following tables list the members exposed by the Axis type.

Public Constructors

Name | Description
Axis | Overloaded.
Top

Public Properties

Name | Description
ArrowStyle | Gets or sets the arrow style of a 2D axis; this style is not applied to 3D chart areas.
AxisName | Gets the name of the axis, which can be either X, Y, X2 or Y2. For internal use only.
Crossing | Gets or sets the location at which an axis is crossed by its associated axis.
CustomLabels | Gets a CustomLabelsCollection object used to store CustomLabel objects.
Enabled | Gets or sets a value that indicates whether an axis is enabled.
InterlacedColor | Gets or sets the color of interlaced strip lines.
Interval | Gets or sets the interval of an axis.
IntervalAutoMode | Gets or sets a flag that determines if a fixed number of intervals is used on the axis, or if the number of intervals depends on the axis size.
IntervalOffset | Gets or sets the interval offset of an axis.
IntervalOffsetType | Gets or sets the interval offset type of an axis.
IntervalType | Gets or sets the interval type of an axis.
IsInterlaced | Gets or sets a flag that determines if interlaced strip lines are displayed for an axis.
IsLabelAutoFit | Gets or sets a flag that determines whether axis labels are automatically fitted.
IsLogarithmic | Gets or sets a flag which indicates whether the axis is logarithmic. Zeros or negative data values are not allowed on logarithmic charts.
IsMarginVisible | Gets or sets a flag that determines whether an axis margin will be used.
IsMarksNextToAxis | Gets or sets a flag that determines whether tick marks and axis labels move with an axis if the crossing point of an axis changes.
IsReversed | Gets or sets a flag which indicates whether the axis is reversed.
IsStartedFromZero | Gets or sets a flag which indicates whether the minimum value of the axis will be automatically set to zero if all data point values are positive. If there are negative data point values, the minimum value of the data points will be used.
LabelAutoFitMaxFontSize | Gets or sets the maximum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitMinFontSize | Gets or sets the minimum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitStyle | Gets or sets the allowable label changes that can be made to enable the label to be fit along an axis.
LabelStyle | Gets or sets the LabelStyle properties of an axis.
LineColor | Gets or sets the line color of an axis.
LineDashStyle | Gets or sets the line style of an axis.
LineWidth | Gets or sets the line width of an axis, in pixels.
LogarithmBase | Gets or sets a value for the logarithm base for the logarithmic axis.
MajorGrid | Gets or sets a Grid object used to set the major grid line properties for an axis.
MajorTickMark | Gets or sets a TickMark object used to set the major tick mark properties of an axis.
MapAreaAttributes | Gets or sets the map area attributes of an axis.
Maximum | Gets or sets the maximum value of an axis.
Minimum | Gets or sets the minimum value of an axis.
MinorGrid | Gets or sets a Grid object used to specify the minor grid lines attributes of an axis.
MinorTickMark | Gets or sets a TickMark object used to set the minor tick mark properties of an axis.
Name | Overridden. Gets or sets the name of the axis.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
ScaleBreakStyle | Gets or sets the axis automatic scale break style.
ScaleView | Gets or sets the view of an axis.
StripLines | Gets a StripLinesCollection collection object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextOrientation | Gets or sets the orientation of the text in the axis title.
Title | Gets or sets the title of the axis.
TitleAlignment | Gets or sets the alignment of an axis title.
TitleFont | Gets or sets the title font properties of an axis.
TitleForeColor | Gets or sets the text color of an axis title.
ToolTip | Gets or sets the tooltip used for the axis.
Url | Gets or sets the URL target of the axis.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetPosition | Converts an axis value to a relative position (0-100%). If an axis is logarithmic, the value is converted to a linear scale.
GetType | (inherited from Object )
PixelPositionToValue | Converts an absolute pixel position along an axis to an axis value. This method only works in paint events.
PositionToValue | Converts a relative coordinate along an axis to an axis value. This method only works in paint events.
ReferenceEquals | (inherited from Object )
RoundAxisValues | Automatically rounds axis values.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
ValueToPixelPosition | Converts an axis value to an absolute coordinate along an axis. Measured in pixels. This method only works in paint events.
ValueToPosition | Converts an axis value to its relative position (0-100%). If an axis has a logarithmic scale, the value is converted to a linear scale. This method only works in paint events.
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Axis Class
System.Web.UI.DataVisualization.Charting Namespace


Axis Constructor

Axis Constructor |
 | See Also

Overload List

Name | Description
Axis () | Initializes a new instance of the Axis class.
Axis (ChartArea, AxisName) | Initializes a new instance of the Axis class with the specified ChartArea and axisTypeName values.

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis Constructor ()

Axis Constructor () |
 | See Also

Initializes a new instance of the Axis class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Axis ()
public:
Axis ()
public Axis ()
public function Axis ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis Constructor (ChartArea, AxisName)

Axis Constructor (ChartArea, AxisName) |
 | See Also

Initializes a new instance of the Axis class with the specified ChartArea and axisTypeName values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    chartArea As ChartArea, _
    axisTypeName As AxisName _
)
public Axis (
    ChartArea chartArea,
    AxisName axisTypeName
)
public:
Axis (
    ChartArea^ chartArea,
    AxisName axisTypeName
)
public Axis (
    ChartArea chartArea,
    AxisName axisTypeName
)
public function Axis (
    chartArea : ChartArea,
    axisTypeName : AxisName
)

Parameters

chartArea
axisTypeName

The axis name.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis Methods

Axis Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetPosition | Converts an axis value to a relative position (0-100%). If an axis is logarithmic, the value is converted to a linear scale.
GetType | (inherited from Object )
PixelPositionToValue | Converts an absolute pixel position along an axis to an axis value. This method only works in paint events.
PositionToValue | Converts a relative coordinate along an axis to an axis value. This method only works in paint events.
ReferenceEquals | (inherited from Object )
RoundAxisValues | Automatically rounds axis values.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )
ValueToPixelPosition | Converts an axis value to an absolute coordinate along an axis. Measured in pixels. This method only works in paint events.
ValueToPosition | Converts an axis value to its relative position (0-100%). If an axis has a logarithmic scale, the value is converted to a linear scale. This method only works in paint events.

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Axis Class
System.Web.UI.DataVisualization.Charting Namespace


Axis.Dispose Method

Axis.Dispose Method |
 | See Also

Overload List

Name | Description
Axis.Dispose () | (inherited from Dispose )
Axis.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Dispose Method (Boolean)

Axis.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.GetPosition Method

Axis.GetPosition Method |
 | See Also

Converts an axis value to a relative position (0-100%). If an axis is logarithmic, the value is converted to a linear scale.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetPosition ( _
    axisValue As Double _
) As Double
public double GetPosition (
    double axisValue
)
public:
double GetPosition (
    double axisValue
)
public double GetPosition (
    double axisValue
)
public function GetPosition (
    axisValue : double
) : double

Parameters

axisValue

The axis value.

Return Value

A double value that represents the relative position (0-100%).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.PixelPositionToValue Method

Axis.PixelPositionToValue Method |
 | See Also

Converts an absolute pixel position along an axis to an axis value. This method only works in paint events.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function PixelPositionToValue ( _
    position As Double _
) As Double
public double PixelPositionToValue (
    double position
)
public:
double PixelPositionToValue (
    double position
)
public double PixelPositionToValue (
    double position
)
public function PixelPositionToValue (
    position : double
) : double

Parameters

position

The pixel position.

Return Value

A double value that represents the axis value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.PositionToValue Method

Axis.PositionToValue Method |
 | See Also

Converts a relative coordinate along an axis to an axis value. This method only works in paint events.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function PositionToValue ( _
    position As Double _
) As Double
public double PositionToValue (
    double position
)
public:
double PositionToValue (
    double position
)
public double PositionToValue (
    double position
)
public function PositionToValue (
    position : double
) : double

Parameters

position

The relative position (0-100%).

Return Value

A double value that represents the axis value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.RoundAxisValues Method

Axis.RoundAxisValues Method |
 | See Also

Automatically rounds axis values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub RoundAxisValues
public void RoundAxisValues ()
public:
void RoundAxisValues ()
public void RoundAxisValues ()
public function RoundAxisValues ()

Remarks

Call the RoundAxisValues method to round the values of an axis. Note that the interval used for the axis will not be changed when this method is called. This method is only supported for the X and X2 axes. The Y and Y2 axes values are rounded by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.ValueToPixelPosition Method

Axis.ValueToPixelPosition Method |
 | See Also

Converts an axis value to an absolute coordinate along an axis. Measured in pixels. This method only works in paint events.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ValueToPixelPosition ( _
    axisValue As Double _
) As Double
public double ValueToPixelPosition (
    double axisValue
)
public:
double ValueToPixelPosition (
    double axisValue
)
public double ValueToPixelPosition (
    double axisValue
)
public function ValueToPixelPosition (
    axisValue : double
) : double

Parameters

axisValue

The axis value.

Return Value

A double value that represents the pixel position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.ValueToPosition Method

Axis.ValueToPosition Method |
 | See Also

Converts an axis value to its relative position (0-100%). If an axis has a logarithmic scale, the value is converted to a linear scale. This method only works in paint events.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ValueToPosition ( _
    axisValue As Double _
) As Double
public double ValueToPosition (
    double axisValue
)
public:
double ValueToPosition (
    double axisValue
)
public double ValueToPosition (
    double axisValue
)
public function ValueToPosition (
    axisValue : double
) : double

Parameters

axisValue

The axis value.

Return Value

A double value that represents the relative position (0-100%).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis Properties

Axis Properties |
 | See Also

Public Properties

Name | Description
ArrowStyle | Gets or sets the arrow style of a 2D axis; this style is not applied to 3D chart areas.
AxisName | Gets the name of the axis, which can be either X, Y, X2 or Y2. For internal use only.
Crossing | Gets or sets the location at which an axis is crossed by its associated axis.
CustomLabels | Gets a CustomLabelsCollection object used to store CustomLabel objects.
Enabled | Gets or sets a value that indicates whether an axis is enabled.
InterlacedColor | Gets or sets the color of interlaced strip lines.
Interval | Gets or sets the interval of an axis.
IntervalAutoMode | Gets or sets a flag that determines if a fixed number of intervals is used on the axis, or if the number of intervals depends on the axis size.
IntervalOffset | Gets or sets the interval offset of an axis.
IntervalOffsetType | Gets or sets the interval offset type of an axis.
IntervalType | Gets or sets the interval type of an axis.
IsInterlaced | Gets or sets a flag that determines if interlaced strip lines are displayed for an axis.
IsLabelAutoFit | Gets or sets a flag that determines whether axis labels are automatically fitted.
IsLogarithmic | Gets or sets a flag which indicates whether the axis is logarithmic. Zeros or negative data values are not allowed on logarithmic charts.
IsMarginVisible | Gets or sets a flag that determines whether an axis margin will be used.
IsMarksNextToAxis | Gets or sets a flag that determines whether tick marks and axis labels move with an axis if the crossing point of an axis changes.
IsReversed | Gets or sets a flag which indicates whether the axis is reversed.
IsStartedFromZero | Gets or sets a flag which indicates whether the minimum value of the axis will be automatically set to zero if all data point values are positive. If there are negative data point values, the minimum value of the data points will be used.
LabelAutoFitMaxFontSize | Gets or sets the maximum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitMinFontSize | Gets or sets the minimum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitStyle | Gets or sets the allowable label changes that can be made to enable the label to be fit along an axis.
LabelStyle | Gets or sets the LabelStyle properties of an axis.
LineColor | Gets or sets the line color of an axis.
LineDashStyle | Gets or sets the line style of an axis.
LineWidth | Gets or sets the line width of an axis, in pixels.
LogarithmBase | Gets or sets a value for the logarithm base for the logarithmic axis.
MajorGrid | Gets or sets a Grid object used to set the major grid line properties for an axis.
MajorTickMark | Gets or sets a TickMark object used to set the major tick mark properties of an axis.
MapAreaAttributes | Gets or sets the map area attributes of an axis.
Maximum | Gets or sets the maximum value of an axis.
Minimum | Gets or sets the minimum value of an axis.
MinorGrid | Gets or sets a Grid object used to specify the minor grid lines attributes of an axis.
MinorTickMark | Gets or sets a TickMark object used to set the minor tick mark properties of an axis.
Name | Overridden. Gets or sets the name of the axis.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
ScaleBreakStyle | Gets or sets the axis automatic scale break style.
ScaleView | Gets or sets the view of an axis.
StripLines | Gets a StripLinesCollection collection object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextOrientation | Gets or sets the orientation of the text in the axis title.
Title | Gets or sets the title of the axis.
TitleAlignment | Gets or sets the alignment of an axis title.
TitleFont | Gets or sets the title font properties of an axis.
TitleForeColor | Gets or sets the text color of an axis title.
ToolTip | Gets or sets the tooltip used for the axis.
Url | Gets or sets the URL target of the axis.

See Also

Reference

Axis Class
System.Web.UI.DataVisualization.Charting Namespace


Axis.ArrowStyle Property

Axis.ArrowStyle Property |
 | See Also

Gets or sets the arrow style of a 2D axis; this style is not applied to 3D chart areas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ArrowStyle As AxisArrowStyle
public AxisArrowStyle ArrowStyle { get; set; }
public:
property AxisArrowStyle ArrowStyle {
    AxisArrowStyle get ();
    void set (AxisArrowStyle value);
}
/** @property */
public AxisArrowStyle get_ArrowStyle ()

/** @property */
public void set_ArrowStyle (AxisArrowStyle value)

public function get ArrowStyle () : AxisArrowStyle

public function set ArrowStyle (value : AxisArrowStyle)

Property Value

An AxisArrowStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.AxisName Property

Axis.AxisName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the name of the axis, which can be either X, Y, X2 or Y2. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable ReadOnly Property AxisName As AxisName
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual AxisName AxisName { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property AxisName AxisName {
    AxisName get ();
}
/** @property */
public AxisName get_AxisName ()

public function get AxisName () : AxisName

Property Value

An AxisName enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Crossing Property

Axis.Crossing Property |
 | See Also

Gets or sets the location at which an axis is crossed by its associated axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Crossing As Double
public virtual double Crossing { get; set; }
public:
virtual property double Crossing {
    double get ();
    void set (double value);
}
/** @property */
public double get_Crossing ()

/** @property */
public void set_Crossing (double value)

public function get Crossing () : double

public function set Crossing (value : double)

Property Value

A double value that represents where an axis is crossed by its associated axis. The default value is NaN.

Remarks

Setting this property for a primary axis will determine where the other primary axis crosses it, and similarly setting it for a secondary axis will determine where the other secondary axis crosses it. For example, setting the Crossing property of the primary X-axis determines where the primary Y-axis will cross it.

Four modes can be used for the Crossing property of an axis:

  • "Auto", which means that the crossing value will be set to the minimum or maximum value for the relevant axis. If the axis is primary, the value will be its minimum value, if the axis is secondary it will its maximum value. To set to "Auto" at run time, use a NaN value.

  • "Minimum", which means the crossing value of the axis will be its minimum value. To set to "Minimum" at run-time use a MinValue value.

  • "Maximum", which means the crossing value of the axis will be its maximum value. To set to "Maximum" at run-time use a MaxValue value.

  • A specified double value that is between the minimum and maximum values for the relevant axis. If the crossing value is less then minimum value, or the crossing value is greater than maximum value, an exception will be thrown.

When a non-default crossing value is used, the labels and tick marks of the axis may or may not follow the crossing axis, depending on the IsMarksNextToAxis property setting. By default they will move with the crossing axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.CustomLabels Property

Axis.CustomLabels Property |
 | See Also

Gets a CustomLabelsCollection object used to store CustomLabel objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property CustomLabels As CustomLabelsCollection
public CustomLabelsCollection CustomLabels { get; }
public:
property CustomLabelsCollection^ CustomLabels {
    CustomLabelsCollection^ get ();
}
/** @property */
public CustomLabelsCollection get_CustomLabels ()

public function get CustomLabels () : CustomLabelsCollection

Property Value

A CustomLabelsCollection object.

Remarks

Use this property to add or remove custom labels for an axis. Using CustomLabel objects enables the developer to arbitrarily set the text for axis labels.

Only custom labels can be used in the second row of labels. Also, if a custom label is used in the first label row, then all labels in this first row must be custom labels.

Labels can also be set from the data points, or generated automatically from the axis scale.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Enabled Property

Axis.Enabled Property |
 | See Also

Gets or sets a value that indicates whether an axis is enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As AxisEnabled
public AxisEnabled Enabled { get; set; }
public:
property AxisEnabled Enabled {
    AxisEnabled get ();
    void set (AxisEnabled value);
}
/** @property */
public AxisEnabled get_Enabled ()

/** @property */
public void set_Enabled (AxisEnabled value)

public function get Enabled () : AxisEnabled

public function set Enabled (value : AxisEnabled)

Property Value

An AxisEnabled enumeration value. The default value is Auto.

Remarks

If an axis is disabled, the axis, along with its attributes (tick marks, strip lines, labels, and so forth), will not be displayed.

If an axis is enabled, the axis, along with all its attributes (tick marks, strip lines, labels, and so forth), will be displayed regardless of whether or not it is being used to plot a Series.

If a value of Auto is used, an axis may or may not be displayed, depending on whether it is being used to plot a Series. The axes that are used to plot data are determined by the XAxisType and YAxisType property settings.

Note:
If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto, but the axis is not being used to plot data; the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.InterlacedColor Property

Axis.InterlacedColor Property |
 | See Also

Gets or sets the color of interlaced strip lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property InterlacedColor As Color
public Color InterlacedColor { get; set; }
public:
property Color InterlacedColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_InterlacedColor ()

/** @property */
public void set_InterlacedColor (Color value)

public function get InterlacedColor () : Color

public function set InterlacedColor (value : Color)

Property Value

A Color object that represents the color of interlaced strip lines.

Remarks

Use this property to specify the color of interlaced strip lines that are displayed when you invoke the InterlacedColor property.

To specify the border color of the interlaced strip lines, you must display the strips using the StripLines collection property instead of the InterlacedColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Interval Property

Axis.Interval Property |
 | See Also

Gets or sets the interval of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value that represents the interval of an axis. The default value is "Auto", which is represented by a value of zero (0).

Remarks

This property determines how often the labels and major tick marks and grid lines associated with the axis are drawn if the Interval property value of a label, tick mark, or grid line is set to NaN, which signifies that it is not set.

The Interval property of a major tick mark, grid line or label of the axis has priority over the Interval property setting of the Axis object.

A value of zero represents an "Auto" value. This Interval property cannot be set to NaN. If you assign this property a value of NaN, a value of zero will be used instead.

Note The minor grid lines and tick marks of an axis never use this property for their interval.

The interval type of the axis is determined by the IntervalType property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IntervalAutoMode Property

Axis.IntervalAutoMode Property |
 | See Also

Gets or sets a flag that determines if a fixed number of intervals is used on the axis, or if the number of intervals depends on the axis size.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalAutoMode As IntervalAutoMode
public IntervalAutoMode IntervalAutoMode { get; set; }
public:
property IntervalAutoMode IntervalAutoMode {
    IntervalAutoMode get ();
    void set (IntervalAutoMode value);
}
/** @property */
public IntervalAutoMode get_IntervalAutoMode ()

/** @property */
public void set_IntervalAutoMode (IntervalAutoMode value)

public function get IntervalAutoMode () : IntervalAutoMode

public function set IntervalAutoMode (value : IntervalAutoMode)

Property Value

An IntervalAutoMode enumeration value. The default value is FixedCount.

Remarks

When the Interval property is set to "Auto", the IntervalAutoMode property determines how many intervals should be calculated. If your chart is resized or redrawn often, you can set the IntervalAutoMode property to VariableCount, in which case the chart will dynamically calculate axis intervals. This is especially useful in situations where the chart intervals are displayed differently, depending on their data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IntervalOffset Property

Axis.IntervalOffset Property |
 | See Also

Gets or sets the interval offset of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the interval offset of an axis. The default value is "Auto", which is represented by a value of zero (0).

Remarks

The IntervalOffset property determines the interval offset of an axis. This value is used as the interval offset of an axis' labels and the major tick marks and grid lines associated with the axis if the IntervalOffset property value of the labels, tick marks, or grid lines is not set, which is represented by a value of NaN.

The IntervalOffset property of the tick marks, labels and grid lines of an axis has priority over the IntervalOffset property setting of the Axis object.

A value of zero represents an "Auto" value. Also, Interval cannot be set to not set (that is, a NaN). If you assign NaN, a value of "Auto"—that is, a value of zero—will be used instead.

Note The minor grid lines and tick marks of an axis never use this property for their interval offset.

The interval offset type of the axis is determined by the IntervalOffsetType property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IntervalOffsetType Property

Axis.IntervalOffsetType Property |
 | See Also

Gets or sets the interval offset type of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType that represents the interval offset type of an axis. The default value is Auto.

Remarks

This property determines the interval offset type of an axis, and is used for the interval offset type of an axis' labels, and major tick marks or grid lines if the axis element's own IntervalOffsetType property value is set to NotSet.

Setting this property to NotSet will result in a value of Auto being used (only the axis elements such as major grid lines, etc. can be set to NotSet).

Note:
The minor grid lines and tick marks of an axis never use this property for their interval offset type.

The interval of the axis is determined by the IntervalOffset property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IntervalType Property

Axis.IntervalType Property |
 | See Also

Gets or sets the interval type of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType that represents the interval type of an axis. The default value is Auto.

Remarks

This property determines the interval type of an axis, and is used for the interval type of an axis' labels, major tick marks, or major grid lines if the axis element's own IntervalType property value is set to NotSet.

Setting this property to NotSet will result in a value of Auto being used. Only the axis elements, such as grid lines, can be set to NotSet.

Note The minor grid lines and tick marks of an axis never use this property for their interval type.

The interval of the axis is determined by the Interval property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsInterlaced Property

Axis.IsInterlaced Property |
 | See Also

Gets or sets a flag that determines if interlaced strip lines are displayed for an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsInterlaced As Boolean
public bool IsInterlaced { get; set; }
public:
property bool IsInterlaced {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsInterlaced ()

/** @property */
public void set_IsInterlaced (boolean value)

public function get IsInterlaced () : boolean

public function set IsInterlaced (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsLabelAutoFit Property

Axis.IsLabelAutoFit Property |
 | See Also

Gets or sets a flag that determines whether axis labels are automatically fitted.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsLabelAutoFit As Boolean
public bool IsLabelAutoFit { get; set; }
public:
property bool IsLabelAutoFit {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsLabelAutoFit ()

/** @property */
public void set_IsLabelAutoFit (boolean value)

public function get IsLabelAutoFit () : boolean

public function set IsLabelAutoFit (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsLogarithmic Property

Axis.IsLogarithmic Property |
 | See Also

Gets or sets a flag which indicates whether the axis is logarithmic. Zeros or negative data values are not allowed on logarithmic charts.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsLogarithmic As Boolean
public bool IsLogarithmic { get; set; }
public:
property bool IsLogarithmic {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsLogarithmic ()

/** @property */
public void set_IsLogarithmic (boolean value)

public function get IsLogarithmic () : boolean

public function set IsLogarithmic (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsMarginVisible Property

Axis.IsMarginVisible Property |
 | See Also

Gets or sets a flag that determines whether an axis margin will be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsMarginVisible As Boolean
public bool IsMarginVisible { get; set; }
public:
property bool IsMarginVisible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMarginVisible ()

/** @property */
public void set_IsMarginVisible (boolean value)

public function get IsMarginVisible () : boolean

public function set IsMarginVisible (value : boolean)

Property Value

True if a space is added between the first or last data point and the border of chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsMarksNextToAxis Property

Axis.IsMarksNextToAxis Property |
 | See Also

Gets or sets a flag that determines whether tick marks and axis labels move with an axis if the crossing point of an axis changes.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property IsMarksNextToAxis As Boolean
public virtual bool IsMarksNextToAxis { get; set; }
public:
virtual property bool IsMarksNextToAxis {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMarksNextToAxis ()

/** @property */
public void set_IsMarksNextToAxis (boolean value)

public function get IsMarksNextToAxis () : boolean

public function set IsMarksNextToAxis (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsReversed Property

Axis.IsReversed Property |
 | See Also

Gets or sets a flag which indicates whether the axis is reversed.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsReversed As Boolean
public bool IsReversed { get; set; }
public:
property bool IsReversed {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsReversed ()

/** @property */
public void set_IsReversed (boolean value)

public function get IsReversed () : boolean

public function set IsReversed (value : boolean)

Remarks

If set to reversed, the values on the axis are in reversed sort order and the direction of values on the axis is flipped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.IsStartedFromZero Property

Axis.IsStartedFromZero Property |
 | See Also

Gets or sets a flag which indicates whether the minimum value of the axis will be automatically set to zero if all data point values are positive. If there are negative data point values, the minimum value of the data points will be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsStartedFromZero As Boolean
public bool IsStartedFromZero { get; set; }
public:
property bool IsStartedFromZero {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsStartedFromZero ()

/** @property */
public void set_IsStartedFromZero (boolean value)

public function get IsStartedFromZero () : boolean

public function set IsStartedFromZero (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LabelAutoFitMaxFontSize Property

Axis.LabelAutoFitMaxFontSize Property |
 | See Also

Gets or sets the maximum font size that can be used by the label auto-fitting algorithm.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelAutoFitMaxFontSize As Integer
public int LabelAutoFitMaxFontSize { get; set; }
public:
property int LabelAutoFitMaxFontSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelAutoFitMaxFontSize ()

/** @property */
public void set_LabelAutoFitMaxFontSize (int value)

public function get LabelAutoFitMaxFontSize () : int

public function set LabelAutoFitMaxFontSize (value : int)

Property Value

An integer value.

Remarks

The font size cannot be less than 5.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LabelAutoFitMinFontSize Property

Axis.LabelAutoFitMinFontSize Property |
 | See Also

Gets or sets the minimum font size that can be used by the label auto-fitting algorithm.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelAutoFitMinFontSize As Integer
public int LabelAutoFitMinFontSize { get; set; }
public:
property int LabelAutoFitMinFontSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelAutoFitMinFontSize ()

/** @property */
public void set_LabelAutoFitMinFontSize (int value)

public function get LabelAutoFitMinFontSize () : int

public function set LabelAutoFitMinFontSize (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LabelAutoFitStyle Property

Axis.LabelAutoFitStyle Property |
 | See Also

Gets or sets the allowable label changes that can be made to enable the label to be fit along an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelAutoFitStyle As LabelAutoFitStyles
public LabelAutoFitStyles LabelAutoFitStyle { get; set; }
public:
property LabelAutoFitStyles LabelAutoFitStyle {
    LabelAutoFitStyles get ();
    void set (LabelAutoFitStyles value);
}
/** @property */
public LabelAutoFitStyles get_LabelAutoFitStyle ()

/** @property */
public void set_LabelAutoFitStyle (LabelAutoFitStyles value)

public function get LabelAutoFitStyle () : LabelAutoFitStyles

public function set LabelAutoFitStyle (value : LabelAutoFitStyles)

Property Value

A LabelAutoFitStyles enumeration value.

Remarks

The IsLabelAutoFit property must be set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LabelStyle Property

Axis.LabelStyle Property |
 | See Also

Gets or sets the LabelStyle properties of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelStyle As LabelStyle
public LabelStyle LabelStyle { get; set; }
public:
property LabelStyle^ LabelStyle {
    LabelStyle^ get ();
    void set (LabelStyle^ value);
}
/** @property */
public LabelStyle get_LabelStyle ()

/** @property */
public void set_LabelStyle (LabelStyle value)

public function get LabelStyle () : LabelStyle

public function set LabelStyle (value : LabelStyle)

Property Value

A LabelStyle object, which defines the axis label style.

Remarks

Use this property to specify the style, formatting, and so forth, of axis labels.

If the IsLabelAutoFit property is true, the font size, font angle and the use of offset labels are determined automatically. If you set any one of the LabelStyle.Font.Size, Angle or IsStaggered properties, the IsLabelAutoFit property will be set to false.

Note that if a format that consists of a date without a time is used for labels, and the DateTime data point values that are used specify times, the times will affect the positions of the data points, even though they are not displayed due to the label formatting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LineColor Property

Axis.LineColor Property |
 | See Also

Gets or sets the line color of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color object that represents the line color used to draw the axis. The default is Black.

Remarks

Use the LineColor property to specify the line color of an axis.

Note If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto. In this case, the axis is not being used to plot data, and the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LineDashStyle Property

Axis.LineDashStyle Property |
 | See Also

Gets or sets the line style of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Remarks

The LineDashStyle property determines the line style used for an axis. The line can be solid, dotted, and so forth.

Note If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto. In this case, the axis is not being used to plot data, and the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LineWidth Property

Axis.LineWidth Property |
 | See Also

Gets or sets the line width of an axis, in pixels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that represents the width of an axis line. The default value is one (1) pixel.

Remarks

The LineWidth property gets or sets the width of an axis line, in pixels. If the width is set to zero (0), the line will not be displayed.

Note If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto. In this case, the axis is not being used to plot data, and the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.LogarithmBase Property

Axis.LogarithmBase Property |
 | See Also

Gets or sets a value for the logarithm base for the logarithmic axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LogarithmBase As Double
public double LogarithmBase { get; set; }
public:
property double LogarithmBase {
    double get ();
    void set (double value);
}
/** @property */
public double get_LogarithmBase ()

/** @property */
public void set_LogarithmBase (double value)

public function get LogarithmBase () : double

public function set LogarithmBase (value : double)

Property Value

A double value. The default value is base 10.

Remarks

This property only has an effect when the IsLogarithmic property is set to true.

Note that this property is only applicable to value axes, which are used to plot data. Setting this property for a categorical axis will result in an exception being thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.MajorGrid Property

Axis.MajorGrid Property |
 | See Also

Gets or sets a Grid object used to set the major grid line properties for an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MajorGrid As Grid
public Grid MajorGrid { get; set; }
public:
property Grid^ MajorGrid {
    Grid^ get ();
    void set (Grid^ value);
}
/** @property */
public Grid get_MajorGrid ()

/** @property */
public void set_MajorGrid (Grid value)

public function get MajorGrid () : Grid

public function set MajorGrid (value : Grid)

Property Value

A Grid object used to get or set the major grid properties of an axis.

Remarks

Major grid lines are always drawn in conjunction with a data point. That is, they will occur at the same point along an axis as a data point, for categorical axis tick marks. For value axes, major grid lines by default are drawn wherever labels occur.

You can use this property to change major grid line frequency, color, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.MajorTickMark Property

Axis.MajorTickMark Property |
 | See Also

Gets or sets a TickMark object used to set the major tick mark properties of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MajorTickMark As TickMark
public TickMark MajorTickMark { get; set; }
public:
property TickMark^ MajorTickMark {
    TickMark^ get ();
    void set (TickMark^ value);
}
/** @property */
public TickMark get_MajorTickMark ()

/** @property */
public void set_MajorTickMark (TickMark value)

public function get MajorTickMark () : TickMark

public function set MajorTickMark (value : TickMark)

Property Value

A TickMark object used to set the properties of a major tick mark of an axis.

Remarks

Major tick marks are always drawn in conjunction with a data point. Categorical axis tick marks will occur at the same point along an axis as a data point. For value axes, major tick marks are drawn by default wherever labels occur.

You can use this property to change the major tick mark properties such as frequency, color, or size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.MapAreaAttributes Property

Axis.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value.

Remarks

A client side image map will automatically be created if you set the MapAreaAttributes property.

A map area will be created with the attribute string appended to the <MAP> tag that corresponds to the Axis object for which this property is set.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Maximum Property

Axis.Maximum Property |
 | See Also

Gets or sets the maximum value of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Maximum As Double
public double Maximum { get; set; }
public:
property double Maximum {
    double get ();
    void set (double value);
}
/** @property */
public double get_Maximum ()

/** @property */
public void set_Maximum (double value)

public function get Maximum () : double

public function set Maximum (value : double)

Property Value

A double value that represents the maximum value of an axis. The default value is NaN.

Remarks

To automatically round the maximum and minimum axis values call the RoundAxisValues method. The Maximum value must be greater than the Minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Minimum Property

Axis.Minimum Property |
 | See Also

Gets or sets the minimum value of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Minimum As Double
public double Minimum { get; set; }
public:
property double Minimum {
    double get ();
    void set (double value);
}
/** @property */
public double get_Minimum ()

/** @property */
public void set_Minimum (double value)

public function get Minimum () : double

public function set Minimum (value : double)

Property Value

A double value that represents the minimum value of an axis. The default value is NaN.

Remarks

Note that if you set this value explicitly, the X-values of data elements must be taken into account. If all data points have X-values of zero, the Chart control will assume the first data point occurs at zero. Also, if the Minimum value is explicitly set, the IsStartedFromZero property will be ignored. The Minimum value must be less than the Maximum value.

To automatically round the maximum and minimum axis values. call the RoundAxisValues method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.MinorGrid Property

Axis.MinorGrid Property |
 | See Also

Gets or sets a Grid object used to specify the minor grid lines attributes of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MinorGrid As Grid
public Grid MinorGrid { get; set; }
public:
property Grid^ MinorGrid {
    Grid^ get ();
    void set (Grid^ value);
}
/** @property */
public Grid get_MinorGrid ()

/** @property */
public void set_MinorGrid (Grid value)

public function get MinorGrid () : Grid

public function set MinorGrid (value : Grid)

Property Value

A Grid object used to get or set the attributes of the minor grid lines of an axis.

Remarks

Minor grid lines are drawn in between the major grid lines.

Use this property to change the attributes of a minor grid line, such as frequency, color, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.MinorTickMark Property

Axis.MinorTickMark Property |
 | See Also

Gets or sets a TickMark object used to set the minor tick mark properties of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MinorTickMark As TickMark
public TickMark MinorTickMark { get; set; }
public:
property TickMark^ MinorTickMark {
    TickMark^ get ();
    void set (TickMark^ value);
}
/** @property */
public TickMark get_MinorTickMark ()

/** @property */
public void set_MinorTickMark (TickMark value)

public function get MinorTickMark () : TickMark

public function set MinorTickMark (value : TickMark)

Property Value

A TickMark object used for the minor tick mark properties of an axis.

Remarks

Minor tick marks should be drawn between major tick marks, where labels usually occur.

Use this property to change the minor tick mark frequency, color, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Name Property

Axis.Name Property |
 | See Also

Gets or sets the name of the axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string Name { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.PostBackValue Property

Axis.PostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.ScaleBreakStyle Property

Axis.ScaleBreakStyle Property |
 | See Also

Gets or sets the axis automatic scale break style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ScaleBreakStyle As AxisScaleBreakStyle
public virtual AxisScaleBreakStyle ScaleBreakStyle { get; set; }
public:
virtual property AxisScaleBreakStyle^ ScaleBreakStyle {
    AxisScaleBreakStyle^ get ();
    void set (AxisScaleBreakStyle^ value);
}
/** @property */
public AxisScaleBreakStyle get_ScaleBreakStyle ()

/** @property */
public void set_ScaleBreakStyle (AxisScaleBreakStyle value)

public function get ScaleBreakStyle () : AxisScaleBreakStyle

public function set ScaleBreakStyle (value : AxisScaleBreakStyle)

Property Value

An AxisScaleBreakStyle object, which represents a scale break on the chart axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.ScaleView Property

Axis.ScaleView Property |
 | See Also

Gets or sets the view of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ScaleView As AxisScaleView
public AxisScaleView ScaleView { get; set; }
public:
property AxisScaleView^ ScaleView {
    AxisScaleView^ get ();
    void set (AxisScaleView^ value);
}
/** @property */
public AxisScaleView get_ScaleView ()

/** @property */
public void set_ScaleView (AxisScaleView value)

public function get ScaleView () : AxisScaleView

public function set ScaleView (value : AxisScaleView)

Property Value

An AxisScaleView object, which represents the scale view of an axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.StripLines Property

Axis.StripLines Property |
 | See Also

Gets a StripLinesCollection collection object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property StripLines As StripLinesCollection
public StripLinesCollection StripLines { get; }
public:
property StripLinesCollection^ StripLines {
    StripLinesCollection^ get ();
}
/** @property */
public StripLinesCollection get_StripLines ()

public function get StripLines () : StripLinesCollection

Property Value

A StripLinesCollection collection object, which stores all StripLine objects for an axis.

Remarks

Strip lines are used to draw rectangular strips across a ChartArea object, and are always drawn across the entire <A href="">area.

These strip lines are not related to the grid lines.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.TextOrientation Property

Axis.TextOrientation Property |
 | See Also

Gets or sets the orientation of the text in the axis title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextOrientation As TextOrientation
public TextOrientation TextOrientation { get; set; }
public:
property TextOrientation TextOrientation {
    TextOrientation get ();
    void set (TextOrientation value);
}
/** @property */
public TextOrientation get_TextOrientation ()

/** @property */
public void set_TextOrientation (TextOrientation value)

public function get TextOrientation () : TextOrientation

public function set TextOrientation (value : TextOrientation)

Property Value

A TextOrientation enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Title Property

Axis.Title Property |
 | See Also

Gets or sets the title of the axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Title As String
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Title ()

/** @property */
public void set_Title (String value)

public function get Title () : String

public function set Title (value : String)

Property Value

A string value that represents the title of the axis.

Remarks

Gets or sets the title of the axis.

You can set the font properties of the title using the TitleFont property.

You can set the color of the title using the TitleForeColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.TitleAlignment Property

Axis.TitleAlignment Property |
 | See Also

Gets or sets the alignment of an axis title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleAlignment As StringAlignment
public StringAlignment TitleAlignment { get; set; }
public:
property StringAlignment TitleAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TitleAlignment ()

/** @property */
public void set_TitleAlignment (StringAlignment value)

public function get TitleAlignment () : StringAlignment

public function set TitleAlignment (value : StringAlignment)

Property Value

A StringAlignment enumeration value.

Remarks

Possible alignment values are Center, Far, and Near. A value of Far equates to an alignment to the top or the right, depending on the orientation of the axis or strip line. In the same manner, a value of Near equates to an alignment to the bottom or the right.

If you want more control over the positioning of an axis title, you must perform custom drawing using the PostPaint or PrePaint event.

You can further align and position the titles of StripLine objects by using their TextLineAlignment and TitleAngle properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.TitleFont Property

Axis.TitleFont Property |
 | See Also

Gets or sets the title font properties of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleFont As Font
public Font TitleFont { get; set; }
public:
property Font^ TitleFont {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_TitleFont ()

/** @property */
public void set_TitleFont (Font value)

public function get TitleFont () : Font

public function set TitleFont (value : Font)

Property Value

A Font object used for the font properties of a title.

Remarks

Gets or sets title font properties such as face or size.

To set font properties at run time, a new Font object must be created. Any attempt to change the properties of the current Font object at run time will result in a compilation error.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.TitleForeColor Property

Axis.TitleForeColor Property |
 | See Also

Gets or sets the text color of an axis title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleForeColor As Color
public Color TitleForeColor { get; set; }
public:
property Color TitleForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleForeColor ()

/** @property */
public void set_TitleForeColor (Color value)

public function get TitleForeColor () : Color

public function set TitleForeColor (value : Color)

Property Value

A Color structure. The default color is Black.

Remarks

Gets or sets the text color of an Axis object title.

You can use any valid ARGB (alpha, red, green, blue) color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.ToolTip Property

Axis.ToolTip Property |
 | See Also

Gets or sets the tooltip used for the axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


Axis.Url Property

Axis.Url Property |
 | See Also

Gets or sets the URL target of the axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value that represents the URL.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members
System.Web.UI.DataVisualization.Charting Namespace


AxisArrowStyle Enumeration

AxisArrowStyle Enumeration |
 | See Also

Specifies the axis arrow styles.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AxisArrowStyle
public enum AxisArrowStyle
public enum class AxisArrowStyle
public enum AxisArrowStyle
public enum AxisArrowStyle

Members

Member name | Description
Lines | A line-shaped arrow is used for the relevant axis.
None | No arrow is used for the relevant axis.
SharpTriangle | A sharp triangular arrow is used for the relevant axis.
Triangle | A triangular arrow is used for the relevant axis.

Remarks

The AxisArrowStyle enumeration represents the style for an axis arrow. If the ArrowStyle property is set to None, no arrow is displayed for an axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


AxisEnabled Enumeration

AxisEnabled Enumeration |
 | See Also

Specifies the state of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AxisEnabled
public enum AxisEnabled
public enum class AxisEnabled
public enum AxisEnabled
public enum AxisEnabled

Members

Member name | Description
Auto | The axis is only enabled if it used to plot a Series.
False | The axis is never enabled.
True | The axis is always enabled.

Remarks

The AxisEnabled enumeration is used with the Enabled property to enable or disable an axis.

If the Enabled property is set to Auto, an axis may or may not be displayed, depending on whether it is being used to plot a Series. The axes that are used to plot data for a series are determined by the XAxisType and YAxisType property settings.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


AxisName Enumeration

AxisName Enumeration |
 | See Also

Specifies the name of an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AxisName
public enum AxisName
public enum class AxisName
public enum AxisName
public enum AxisName

Members

Member name | Description
X | Primary X-axis.
X2 | Secondary X-axis.
Y | Primary Y-axis.
Y2 | Secondary Y-axis.

Remarks

The AxisName enumeration represents the four different axes that can be used for a chart.

Bar and stacked bar charts have their axes rotated 90 degrees clockwise. For example, the primary X-axis for these two charts is the left-vertical axis.

For all charts except bar, stacked bar, pie and doughnut charts, the primary and secondary axes are as follows:

Axis Type | Description
Primary X-Axis | Bottom horizontal axis.
Secondary X-Axis | Top horizontal axis.
Primary Y-Axis | Left vertical axis.
Secondary Y-Axis | Right vertical axis.

Bar and stacked bar charts have their axes rotated 90 degrees clockwise. For example, the primary X-axis for these two charts is the left-vertical axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle Class

AxisScaleBreakStyle Class |
 | See Also Example Members

Represents a scale break on the Y-axis of the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AxisScaleBreakStyle
public class AxisScaleBreakStyle
public ref class AxisScaleBreakStyle
public class AxisScaleBreakStyle
public class AxisScaleBreakStyle

Remarks

Scale breaks are intentional discontinuities on the Y-axis that are most often used to redistribute the data points in a series on a chart. This feature improves readability when there are large differences between the high and low values of the data in one series being plotted. Scale breaks are not drawn for differences between data in multiple series.

By default, scale breaks are disabled. You can enable scale breaks on the Y-axis by setting the Enabled property to true. To change the amount of vertical space of the scale break, you can specify a Spacing value. This is calculated as a percentage of the Y-axis scale.

You must have sufficient separation between ranges of data points in a single series to draw a scale break. By default, a scale break can be added only if there is a separation between the data ranges of at least 25% of the chart. If you enable a scale break but it does not appear, even though there is sufficient distance between the data ranges, you can set the CollapsibleSpaceThreshold property to a value less than 25.

Charts support up to five scale breaks per chart; however, the chart can become unreadable if you display more than one scale break. If you have more than two data ranges, consider using a different method for displaying this data. Use the MaxNumberOfBreaks property to reduce the number of scale breaks that can be displayed on the chart.

When a scale break is used, the Y-axis labels may become offset. To disable the label offset, set the IsStaggered property to false.

Scale breaks are not supported under any of the following conditions:

  • Pie, doughnut, funnel, pyramid, radial or any stacked chart types are used.

  • Custom intervals for labels, tick marks or grid lines are enabled.

  • The minimum or maximum value for the axis is set.

  • Custom labels are used.

  • A logarithmic Y-axis is specified.

  • Axis views on the Y-axis, which include scrolling and zooming, are used.

  • 3-D charts are used.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.AxisScaleBreakStyle

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle Members

AxisScaleBreakStyle Members |
 | See Also Constructors Methods Properties

Represents a scale break on the Y-axis of the chart.

The following tables list the members exposed by the AxisScaleBreakStyle type.

Public Constructors

Name | Description
AxisScaleBreakStyle | Initializes a new instance of the AxisScaleBreakStyle class.
Top

Public Properties

Name | Description
BreakLineStyle | Gets or sets the style of the break line that will be used to draw the scale break.
CollapsibleSpaceThreshold | Gets or sets the threshold of space on the chart at which scale breaks are drawn.
Enabled | Gets or sets a flag that indicates whether scale breaks are enabled.
LineColor | Gets or sets the color of the scale break line.
LineDashStyle | Gets or sets the style of the scale break line.
LineWidth | Gets or sets the width of the scale break line.
MaxNumberOfBreaks | Gets or sets the maximum number of scale breaks to be displayed on the chart.
Spacing | Gets or sets the spacing gap between the lines of the scale break. The spacing gap is represented as a percentage of the Y-axis.
StartFromZero | Gets or sets a StartFromZero enumeration value that indicates whether to start the scale break from zero.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AxisScaleBreakStyle Class
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle Constructor

AxisScaleBreakStyle Constructor |
 | See Also

Initializes a new instance of the AxisScaleBreakStyle class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public AxisScaleBreakStyle ()
public:
AxisScaleBreakStyle ()
public AxisScaleBreakStyle ()
public function AxisScaleBreakStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle Methods

AxisScaleBreakStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AxisScaleBreakStyle Class
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle Properties

AxisScaleBreakStyle Properties |
 | See Also

Public Properties

Name | Description
BreakLineStyle | Gets or sets the style of the break line that will be used to draw the scale break.
CollapsibleSpaceThreshold | Gets or sets the threshold of space on the chart at which scale breaks are drawn.
Enabled | Gets or sets a flag that indicates whether scale breaks are enabled.
LineColor | Gets or sets the color of the scale break line.
LineDashStyle | Gets or sets the style of the scale break line.
LineWidth | Gets or sets the width of the scale break line.
MaxNumberOfBreaks | Gets or sets the maximum number of scale breaks to be displayed on the chart.
Spacing | Gets or sets the spacing gap between the lines of the scale break. The spacing gap is represented as a percentage of the Y-axis.
StartFromZero | Gets or sets a StartFromZero enumeration value that indicates whether to start the scale break from zero.

See Also

Reference

AxisScaleBreakStyle Class
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.BreakLineStyle Property

AxisScaleBreakStyle.BreakLineStyle Property |
 | See Also Example

Gets or sets the style of the break line that will be used to draw the scale break.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BreakLineStyle As BreakLineStyle
public BreakLineStyle BreakLineStyle { get; set; }
public:
property BreakLineStyle BreakLineStyle {
    BreakLineStyle get ();
    void set (BreakLineStyle value);
}
/** @property */
public BreakLineStyle get_BreakLineStyle ()

/** @property */
public void set_BreakLineStyle (BreakLineStyle value)

public function get BreakLineStyle () : BreakLineStyle

public function set BreakLineStyle (value : BreakLineStyle)

Property Value

A BreakLineStyle enumeration value.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.CollapsibleSpaceThreshold Property

AxisScaleBreakStyle.CollapsibleSpaceThreshold Property |
 | See Also Example

Gets or sets the threshold of space on the chart at which scale breaks are drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property CollapsibleSpaceThreshold As Integer
public int CollapsibleSpaceThreshold { get; set; }
public:
property int CollapsibleSpaceThreshold {
    int get ();
    void set (int value);
}
/** @property */
public int get_CollapsibleSpaceThreshold ()

/** @property */
public void set_CollapsibleSpaceThreshold (int value)

public function get CollapsibleSpaceThreshold () : int

public function set CollapsibleSpaceThreshold (value : int)

Property Value

An integer value that specifies the threshold of space on the chart at which scale breaks are drawn.

Remarks

This property is measured as a percentage of the Y-axis scale. By default, its value is set to 25. This means that data points in a series that have a difference of at least 25% of the scale will be collapsed with a scale break.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.Enabled Property

AxisScaleBreakStyle.Enabled Property |
 | See Also Example

Gets or sets a flag that indicates whether scale breaks are enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

A Boolean value that specifies whether scale breaks are enabled.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.LineColor Property

AxisScaleBreakStyle.LineColor Property |
 | See Also Example

Gets or sets the color of the scale break line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color value that represents the color of the scale break line.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.LineDashStyle Property

AxisScaleBreakStyle.LineDashStyle Property |
 | See Also Example

Gets or sets the style of the scale break line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value that represents the style of the scale break line.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.LineWidth Property

AxisScaleBreakStyle.LineWidth Property |
 | See Also Example

Gets or sets the width of the scale break line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that represents the width of the scale break line.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.MaxNumberOfBreaks Property

AxisScaleBreakStyle.MaxNumberOfBreaks Property |
 | See Also Example

Gets or sets the maximum number of scale breaks to be displayed on the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MaxNumberOfBreaks As Integer
public int MaxNumberOfBreaks { get; set; }
public:
property int MaxNumberOfBreaks {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaxNumberOfBreaks ()

/** @property */
public void set_MaxNumberOfBreaks (int value)

public function get MaxNumberOfBreaks () : int

public function set MaxNumberOfBreaks (value : int)

Property Value

An integer value that represents the maximum number of scale breaks to be displayed on the chart.

Remarks

The Chart is capable of displaying up to five scale breaks.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.Spacing Property

AxisScaleBreakStyle.Spacing Property |
 | See Also Example

Gets or sets the spacing gap between the lines of the scale break. The spacing gap is represented as a percentage of the Y-axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Spacing As Double
public double Spacing { get; set; }
public:
property double Spacing {
    double get ();
    void set (double value);
}
/** @property */
public double get_Spacing ()

/** @property */
public void set_Spacing (double value)

public function get Spacing () : double

public function set Spacing (value : double)

Property Value

A double value that represents the spacing gap between the lines of the scale break.

Example

The following code example demonstrates how to set properties relating to the scale break. It is assumed that the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

' Add data to the chart
Private Sub AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = AutoBool.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

// Add data to the chart
private void AddChartData()
{
   chart1.Series["Default"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Default"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Default"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Default"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.StartFromZero = AutoBool.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of Y-axis).
    chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleBreakStyle.StartFromZero Property

AxisScaleBreakStyle.StartFromZero Property |
 | See Also Example

Gets or sets a StartFromZero enumeration value that indicates whether to start the scale break from zero.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property StartFromZero As StartFromZero
public StartFromZero StartFromZero { get; set; }
public:
property StartFromZero StartFromZero {
    StartFromZero get ();
    void set (StartFromZero value);
}
/** @property */
public StartFromZero get_StartFromZero ()

/** @property */
public void set_StartFromZero (StartFromZero value)

public function get StartFromZero () : StartFromZero

public function set StartFromZero (value : StartFromZero)

Property Value

A StartFromZero enumeration value that indicates whether to start the scale break from zero.

Remarks

If the StartFromZero property is set to Auto, the chart will automatically calculate whether to start the Y-axis scale minimum from the lowest value in the series or from zero.

Example

The following code example demonstrates how to enable and customize a scale break after the Chart control has been added to the design surface.

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function AddChartData()

    chart1.Series("Default").Points.Add(New DataPoint(1, 2))
    chart1.Series("Default").Points.Add(New DataPoint(2, 4))
    chart1.Series("Default").Points.Add(New DataPoint(3, 400000))
    chart1.Series("Default").Points.Add(New DataPoint(4, 3))

End Sub

Private Function AddScaleBreaks()

   ' Enable scale breaks.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.Enabled = True

   ' Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25

   ' Set the line width of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineWidth = 2

   ' Set the color of the scale break.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.LineColor = Color.Red

   ' If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas("Default").AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto

   ' Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
   chart1.ChartAreas["Default"].AxisY.ScaleBreakStyle.Spacing = 2;

End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void AddChartData()
{
   chart1.Series["Series1"].Points.Add(new DataPoint(1, 2));
   chart1.Series["Series1"].Points.Add(new DataPoint(2, 4));
   chart1.Series["Series1"].Points.Add(new DataPoint(3, 400000));
   chart1.Series["Series1"].Points.Add(new DataPoint(4, 3));
}

private void AddScaleBreaks()
{
   // Enable scale breaks.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Enabled = true;

   // Show scale break if more than 25% of the chart is empty space.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.CollapsibleSpaceThreshold = 25;

   // Set the line width of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineWidth = 2;

   // Set the color of the scale break.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.LineColor = Color.Red;

   // If all data points are significantly far from zero, the chart will calculate the scale minimum value.
   chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.StartFromZero = StartFromZero.Auto;

   // Set the spacing gap between the lines of the scale break (as a percentage of the Y-axis).
    chart1.ChartAreas["ChartArea1"].AxisY.ScaleBreakStyle.Spacing = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView Class

AxisScaleView Class |
 | See Also Members

Represents a scaled view of the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class AxisScaleView
public class AxisScaleView
public ref class AxisScaleView
public class AxisScaleView
public class AxisScaleView

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.AxisScaleView

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView Members

AxisScaleView Members |
 | See Also Constructors Methods Properties

Represents a scaled view of the chart.

The following tables list the members exposed by the AxisScaleView type.

Public Constructors

Name | Description
AxisScaleView | Initializes a new instance of the AxisScaleView class.
Top

Public Properties

Name | Description
IsZoomed | Gets a flag that indicates whether the axis is zoomed in.
Position | Gets or sets the position of the scale view.
Size | Gets or sets the size of the scale view.
SizeType | Gets or sets the unit of measurement of the Size property.
ViewMaximum | Gets the maximum axis value of a scale view.
ViewMinimum | Gets the minimum axis value of a data view.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AxisScaleView Class
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView Constructor

AxisScaleView Constructor |
 | See Also

Initializes a new instance of the AxisScaleView class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public AxisScaleView ()
public:
AxisScaleView ()
public AxisScaleView ()
public function AxisScaleView ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView Methods

AxisScaleView Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AxisScaleView Class
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView Properties

AxisScaleView Properties |
 | See Also

Public Properties

Name | Description
IsZoomed | Gets a flag that indicates whether the axis is zoomed in.
Position | Gets or sets the position of the scale view.
Size | Gets or sets the size of the scale view.
SizeType | Gets or sets the unit of measurement of the Size property.
ViewMaximum | Gets the maximum axis value of a scale view.
ViewMinimum | Gets the minimum axis value of a data view.

See Also

Reference

AxisScaleView Class
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView.IsZoomed Property

AxisScaleView.IsZoomed Property |
 | See Also

Gets a flag that indicates whether the axis is zoomed in.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property IsZoomed As Boolean
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsZoomed { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property bool IsZoomed {
    bool get ();
}
/** @property */
public boolean get_IsZoomed ()

public function get IsZoomed () : boolean

Property Value

True if the axis is zoomed in, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView.Position Property

AxisScaleView.Position Property |
 | See Also

Gets or sets the position of the scale view.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Position As Double
public double Position { get; set; }
public:
property double Position {
    double get ();
    void set (double value);
}
/** @property */
public double get_Position ()

/** @property */
public void set_Position (double value)

public function get Position () : double

public function set Position (value : double)

Property Value

A double that represents the position of the scale view.-

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView.Size Property

AxisScaleView.Size Property |
 | See Also

Gets or sets the size of the scale view.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Size As Double
public double Size { get; set; }
public:
property double Size {
    double get ();
    void set (double value);
}
/** @property */
public double get_Size ()

/** @property */
public void set_Size (double value)

public function get Size () : double

public function set Size (value : double)

Property Value

A double that represents the size of the scale view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView.SizeType Property

AxisScaleView.SizeType Property |
 | See Also

Gets or sets the unit of measurement of the Size property.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SizeType As DateTimeIntervalType
public DateTimeIntervalType SizeType { get; set; }
public:
property DateTimeIntervalType SizeType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_SizeType ()

/** @property */
public void set_SizeType (DateTimeIntervalType value)

public function get SizeType () : DateTimeIntervalType

public function set SizeType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView.ViewMaximum Property

AxisScaleView.ViewMaximum Property |
 | See Also

Gets the maximum axis value of a scale view.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property ViewMaximum As Double
[BrowsableAttribute(false)]
public double ViewMaximum { get; }
[BrowsableAttribute(false)]
public:
property double ViewMaximum {
    double get ();
}
/** @property */
public double get_ViewMaximum ()

public function get ViewMaximum () : double

Property Value

A double that represents the maximum axis value for the data view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisScaleView.ViewMinimum Property

AxisScaleView.ViewMinimum Property |
 | See Also

Gets the minimum axis value of a data view.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property ViewMinimum As Double
[BrowsableAttribute(false)]
public double ViewMinimum { get; }
[BrowsableAttribute(false)]
public:
property double ViewMinimum {
    double get ();
}
/** @property */
public double get_ViewMinimum ()

public function get ViewMinimum () : double

Property Value

A double that represents the minimum axis value for the data view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members
System.Web.UI.DataVisualization.Charting Namespace


AxisType Enumeration

AxisType Enumeration |
 | See Also

Specifies the axis type for the X and Y-axes of a Series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration AxisType
public enum AxisType
public enum class AxisType
public enum AxisType
public enum AxisType

Members

Member name | Description
Primary | Designates an axis as the primary axis.
Secondary | Designates an axis as the secondary axis.

Remarks

The AxisType enumeration represents the axis type used for the X and Y-axes of a Series.

A Series is plotted using two axes, with the exception of pie and doughnut charts. This enumeration is used in conjunction with the XAxisType and YAxisType properties to set the axes used for plotting the associated data points of the Series.

For all charts except for bar, stacked bar, pie and doughnut types, the primary and secondary axes are as follows:

Axis Type | Description
Primary X-Axis | Bottom horizontal axis.
Secondary X-Axis | Top horizontal axis.
Primary Y-Axis | Left vertical axis.
Secondary Y-Axis | Right vertical axis.

Bar and stacked-bar charts have their axes rotated 90 degrees clockwise. For example, the primary X-axis for these two charts is the left-vertical axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation Class

Border3DAnnotation Class |
 | See Also Members

Represents an annotation with a 3D border.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Border3DAnnotation
    Inherits RectangleAnnotation
public class Border3DAnnotation : RectangleAnnotation
public ref class Border3DAnnotation : public RectangleAnnotation
public class Border3DAnnotation extends RectangleAnnotation
public class Border3DAnnotation extends RectangleAnnotation

Remarks

A Border3D annotation can also display inner text.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.TextAnnotation
System.Web.UI.DataVisualization.Charting.RectangleAnnotation
System.Web.UI.DataVisualization.Charting.Border3DAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation Members

Border3DAnnotation Members |
 | See Also Constructors Methods Properties

Represents an annotation with a 3D border.

The following tables list the members exposed by the Border3DAnnotation type.

Public Constructors

Name | Description
Border3DAnnotation | Initializes a new instance of the Border3DAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation)
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation)
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation)
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation)
BorderSkin | Gets or sets the skin attributes of the 3D border.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation)
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Border3DAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation Constructor

Border3DAnnotation Constructor |
 | See Also

Initializes a new instance of the Border3DAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Border3DAnnotation ()
public:
Border3DAnnotation ()
public Border3DAnnotation ()
public function Border3DAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Class
Border3DAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation Methods

Border3DAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Border3DAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation Properties

Border3DAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation )
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation )
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation )
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation )
BorderSkin | Gets or sets the skin attributes of the 3D border.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation )
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

Border3DAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation.AnnotationType Property

Border3DAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the annotation type name. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type, such as Line, Rectangle, Ellipse, and so forth.

For internal use; should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Class
Border3DAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


Border3DAnnotation.BorderSkin Property

Border3DAnnotation.BorderSkin Property |
 | See Also

Gets or sets the skin attributes of the 3D border.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property BorderSkin As BorderSkin
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public BorderSkin BorderSkin { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property BorderSkin^ BorderSkin {
    BorderSkin^ get ();
    void set (BorderSkin^ value);
}
/** @property */
public BorderSkin get_BorderSkin ()

/** @property */
public void set_BorderSkin (BorderSkin value)

public function get BorderSkin () : BorderSkin

public function set BorderSkin (value : BorderSkin)

Property Value

A BorderSkin object, which determines the attributes of the 3D border.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Class
Border3DAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin Class

BorderSkin Class |
 | See Also Members

Represents the drawing properties of the 3D border skin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class BorderSkin
    Inherits ChartElement
public class BorderSkin : ChartElement
public ref class BorderSkin : public ChartElement
public class BorderSkin extends ChartElement
public class BorderSkin extends ChartElement

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.BorderSkin

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin Members

BorderSkin Members |
 | See Also Constructors Methods Properties

Represents the drawing properties of the 3D border skin.

The following tables list the members exposed by the BorderSkin type.

Public Constructors

Name | Description
BorderSkin | Initializes a new instance of the BorderSkin class.
Top

Public Properties

Name | Description
BackColor | Gets or sets the background color of a border skin frame.
BackGradientStyle | Gets or sets the background gradient style of a border skin frame.
BackHatchStyle | Gets or sets the background hatch style of a border skin frame.
BackImage | Gets or sets the background image of a border skin frame.
BackImageAlignment | Gets or sets the background image alignment of a border skin frame.
BackImageTransparentColor | Gets or sets a color that is replaced with a transparent color when the background image of a border skin frame is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a border skin frame.
BackSecondaryColor | Gets or sets the secondary background color of a border skin frame.
BorderColor | Gets or sets the border color of a border skin frame.
BorderDashStyle | Gets or sets the style of the border line of a border skin frame.
BorderWidth | Gets or sets the width of the border line of a border skin frame.
PageColor | Gets or sets the page color of a border skin.
SkinStyle | Gets or sets the style of a border skin.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

BorderSkin Class
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin Constructor

BorderSkin Constructor |
 | See Also

Initializes a new instance of the BorderSkin class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public BorderSkin ()
public:
BorderSkin ()
public BorderSkin ()
public function BorderSkin ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin Methods

BorderSkin Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

BorderSkin Class
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin Properties

BorderSkin Properties |
 | See Also

Public Properties

Name | Description
BackColor | Gets or sets the background color of a border skin frame.
BackGradientStyle | Gets or sets the background gradient style of a border skin frame.
BackHatchStyle | Gets or sets the background hatch style of a border skin frame.
BackImage | Gets or sets the background image of a border skin frame.
BackImageAlignment | Gets or sets the background image alignment of a border skin frame.
BackImageTransparentColor | Gets or sets a color that is replaced with a transparent color when the background image of a border skin frame is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a border skin frame.
BackSecondaryColor | Gets or sets the secondary background color of a border skin frame.
BorderColor | Gets or sets the border color of a border skin frame.
BorderDashStyle | Gets or sets the style of the border line of a border skin frame.
BorderWidth | Gets or sets the width of the border line of a border skin frame.
PageColor | Gets or sets the page color of a border skin.
SkinStyle | Gets or sets the style of a border skin.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

BorderSkin Class
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackColor Property

BorderSkin.BackColor Property |
 | See Also

Gets or sets the background color of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackGradientStyle Property

BorderSkin.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackHatchStyle Property

BorderSkin.BackHatchStyle Property |
 | See Also

Gets or sets the background hatch style of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackImage Property

BorderSkin.BackImage Property |
 | See Also

Gets or sets the background image of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackImageAlignment Property

BorderSkin.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value.

Remarks

The BackImageAlignment property is used by Unscaled drawing mode.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackImageTransparentColor Property

BorderSkin.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that is replaced with a transparent color when the background image of a border skin frame is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackImageWrapMode Property

BorderSkin.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BackSecondaryColor Property

BorderSkin.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary background color of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This color is combined with the primary background color, which is set with the BackColor property, when the BackHatchStyle and BackGradientStyle properties are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BorderColor Property

BorderSkin.BorderColor Property |
 | See Also

Gets or sets the border color of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BorderDashStyle Property

BorderSkin.BorderDashStyle Property |
 | See Also

Gets or sets the style of the border line of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.BorderWidth Property

BorderSkin.BorderWidth Property |
 | See Also

Gets or sets the width of the border line of a border skin frame.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.PageColor Property

BorderSkin.PageColor Property |
 | See Also

Gets or sets the page color of a border skin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PageColor As Color
public Color PageColor { get; set; }
public:
property Color PageColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_PageColor ()

/** @property */
public void set_PageColor (Color value)

public function get PageColor () : Color

public function set PageColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkin.SkinStyle Property

BorderSkin.SkinStyle Property |
 | See Also

Gets or sets the style of a border skin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SkinStyle As BorderSkinStyle
public BorderSkinStyle SkinStyle { get; set; }
public:
property BorderSkinStyle SkinStyle {
    BorderSkinStyle get ();
    void set (BorderSkinStyle value);
}
/** @property */
public BorderSkinStyle get_SkinStyle ()

/** @property */
public void set_SkinStyle (BorderSkinStyle value)

public function get SkinStyle () : BorderSkinStyle

public function set SkinStyle (value : BorderSkinStyle)

Property Value

A BorderSkinStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members
System.Web.UI.DataVisualization.Charting Namespace


BorderSkinStyle Enumeration

BorderSkinStyle Enumeration |
 | See Also

Specifies a style for the border skin of a chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration BorderSkinStyle
public enum BorderSkinStyle
public enum class BorderSkinStyle
public enum BorderSkinStyle
public enum BorderSkinStyle

Members

Member name | Description
Emboss | Use an embossed border skin.
FrameThin1 | Use a thin border skin with rounded corners.
FrameThin2 | Use a thin border skin with rounded top corners.
FrameThin3 | Use a thin border skin with square corners.
FrameThin4 | Use a thin border skin with square outside corners and rounded inside corners.
FrameThin5 | Use a thin border skin with rounded corners and screws.
FrameThin6 | Use a thin border skin with square inside corners and rounded outside corners.
FrameTitle1 | Use a border skin with rounded corners.
FrameTitle2 | Use a border skin with rounded top corners.
FrameTitle3 | Use a border skin with square corners.
FrameTitle4 | Use a border skin with rounded inside corners and square outside corners.
FrameTitle5 | Use a border skin with rounded corners and screws.
FrameTitle6 | Use a border skin with rounded outside corners and square inside corners.
FrameTitle7 | Use a border skin with rounded corners. No border on the right side.
FrameTitle8 | Use a border skin with rounded corners on top and bottom sides only.
None | No border skin is used.
Raised | Use a raised border skin.
Sunken | Use a sunken border skin.

Remarks

The BorderSkin class represents the style of the border skin used for a chart image. If you set the SkinStyle property to None, no skin will be used. This is the default value for the SkinStyle property.

Note:
The difference between the sets of border skin styles that use frames and follow either the naming convention FrameThin* or "FrameTitle*—for example, FrameThin1 or FrameTitle1—is the shape and thickness of their frames.

In addition, if you use one of the "FrameThin" style border skins, the title of the chart will not be displayed. However, if you use one of the "FrameTitle" style border skins, the title of the chart will appear in the top-horizontal part of the frame.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


BreakLineStyle Enumeration

BreakLineStyle Enumeration |
 | See Also

Specifies line styles for axis scale breaks.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration BreakLineStyle
public enum BreakLineStyle
public enum class BreakLineStyle
public enum BreakLineStyle
public enum BreakLineStyle

Members

Member name | Description
None | Scale break is not displayed.
Ragged | Scale break is displayed as a ragged line.
Straight | Scale break is displayed as a straight line.
Wave | Scale break is displayed as a wavy line.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation Class

CalloutAnnotation Class |
 | See Also Members

Represents a callout annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class CalloutAnnotation
    Inherits TextAnnotation
public class CalloutAnnotation : TextAnnotation
public ref class CalloutAnnotation : public TextAnnotation
public class CalloutAnnotation extends TextAnnotation
public class CalloutAnnotation extends TextAnnotation

Remarks

A callout annotation is the only annotation that draws a connection between the annotation position and the anchor point. This class can also display text and automatically calculate its required size.

Different callout styles are supported.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.TextAnnotation
System.Web.UI.DataVisualization.Charting.CalloutAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation Members

CalloutAnnotation Members |
 | See Also Constructors Methods Properties

Represents a callout annotation.

The following tables list the members exposed by the CalloutAnnotation type.

Public Constructors

Name | Description
CalloutAnnotation | Initializes a new instance of the CalloutAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AnchorAlignment | Overridden. Gets or sets the annotation position alignment to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Overridden. Gets or sets the offset that the X-position of the annotation has from the anchor point.
AnchorOffsetY | Overridden. Gets or sets the offset that the Y-position of the annotation has from the anchor point.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the annotation background gradient style.
BackHatchStyle | Overridden. Gets or sets the background hatch style of the annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
CalloutAnchorCap | Gets or sets the style for a callout line anchor cap.
CalloutStyle | Gets or sets the annotation callout style.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. Gets or sets the annotation line color.
LineDashStyle | Overridden. Gets or sets the annotation line style.
LineWidth | Overridden. Gets or sets the line width of the annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CalloutAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation Constructor

CalloutAnnotation Constructor |
 | See Also

Initializes a new instance of the CalloutAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public CalloutAnnotation ()
public:
CalloutAnnotation ()
public CalloutAnnotation ()
public function CalloutAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation Methods

CalloutAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CalloutAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation Properties

CalloutAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AnchorAlignment | Overridden. Gets or sets the annotation position alignment to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Overridden. Gets or sets the offset that the X-position of the annotation has from the anchor point.
AnchorOffsetY | Overridden. Gets or sets the offset that the Y-position of the annotation has from the anchor point.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the annotation background gradient style.
BackHatchStyle | Overridden. Gets or sets the background hatch style of the annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
CalloutAnchorCap | Gets or sets the style for a callout line anchor cap.
CalloutStyle | Gets or sets the annotation callout style.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. Gets or sets the annotation line color.
LineDashStyle | Overridden. Gets or sets the annotation line style.
LineWidth | Overridden. Gets or sets the line width of the annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

CalloutAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.AnchorAlignment Property

CalloutAnnotation.AnchorAlignment Property |
 | See Also

Gets or sets the annotation position alignment to the anchor point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property AnchorAlignment As ContentAlignment
public override ContentAlignment AnchorAlignment { get; set; }
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public override function get AnchorAlignment () : ContentAlignment

public override function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the annotation to the anchor point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.AnchorOffsetX Property

CalloutAnnotation.AnchorOffsetX Property |
 | See Also

Gets or sets the offset that the X-position of the annotation has from the anchor point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property AnchorOffsetX As Double
public override double AnchorOffsetX { get; set; }
public:
virtual property double AnchorOffsetX {
    double get () override;
    void set (double value) override;
}
/** @property */
public double get_AnchorOffsetX ()

/** @property */
public void set_AnchorOffsetX (double value)

public override function get AnchorOffsetX () : double

public override function set AnchorOffsetX (value : double)

Property Value

A double value that represents the offset of the annotation's X-position from the anchor point.

Remarks

The CalloutAnnotation must be anchored using either the AnchorDataPoint or the AnchorX property, and its X property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.AnchorOffsetY Property

CalloutAnnotation.AnchorOffsetY Property |
 | See Also

Gets or sets the offset that the Y-position of the annotation has from the anchor point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property AnchorOffsetY As Double
public override double AnchorOffsetY { get; set; }
public:
virtual property double AnchorOffsetY {
    double get () override;
    void set (double value) override;
}
/** @property */
public double get_AnchorOffsetY ()

/** @property */
public void set_AnchorOffsetY (double value)

public override function get AnchorOffsetY () : double

public override function set AnchorOffsetY (value : double)

Property Value

A double value that represents the offset of the annotation's Y-position from the anchor point.

Remarks

The CalloutAnnotation must be anchored using either the AnchorDataPoint or the AnchorY property, and its Y property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.AnnotationType Property

CalloutAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the annotation type name. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.BackColor Property

CalloutAnnotation.BackColor Property |
 | See Also

Gets or sets the background color of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(true)]
public override Color BackColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.BackGradientStyle Property

CalloutAnnotation.BackGradientStyle Property |
 | See Also

Gets or sets the annotation background gradient style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(true)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value used to draw the annotation background.

Remarks

Two colors are used to draw the gradient, and are set with the BackColor and BackSecondaryColor properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.BackHatchStyle Property

CalloutAnnotation.BackHatchStyle Property |
 | See Also

Gets or sets the background hatch style of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(true)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the annotation background.

Remarks

Two colors are used to draw the hatching, and are set with the BackColor and BackSecondaryColor properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.BackSecondaryColor Property

CalloutAnnotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for the annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(true)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color enumeration value used in conjunction with a primary color to draw the annotation background with hatching or gradient fill.

Remarks

This color is used with the BackColor property when the BackHatchStyle or BackGradientStyle properties are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.CalloutAnchorCap Property

CalloutAnnotation.CalloutAnchorCap Property |
 | See Also

Gets or sets the style for a callout line anchor cap.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutAnchorCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle CalloutAnchorCap { get; set; }
public:
virtual property LineAnchorCapStyle CalloutAnchorCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_CalloutAnchorCap ()

/** @property */
public void set_CalloutAnchorCap (LineAnchorCapStyle value)

public function get CalloutAnchorCap () : LineAnchorCapStyle

public function set CalloutAnchorCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value that represents the style to use for a callout line anchor cap.

Remarks

The CalloutAnchorCap property sets the style of the anchor cap for the line that connects the annotation with the anchor point. This property is only applicable when a SimpleLine or Borderline callout style is used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.CalloutStyle Property

CalloutAnnotation.CalloutStyle Property |
 | See Also

Gets or sets the annotation callout style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutStyle As CalloutStyle
public virtual CalloutStyle CalloutStyle { get; set; }
public:
virtual property CalloutStyle CalloutStyle {
    CalloutStyle get ();
    void set (CalloutStyle value);
}
/** @property */
public CalloutStyle get_CalloutStyle ()

/** @property */
public void set_CalloutStyle (CalloutStyle value)

public function get CalloutStyle () : CalloutStyle

public function set CalloutStyle (value : CalloutStyle)

Property Value

A CalloutStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.LineColor Property

CalloutAnnotation.LineColor Property |
 | See Also

Gets or sets the annotation line color.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(true)]
public override Color LineColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value used to draw the annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.LineDashStyle Property

CalloutAnnotation.LineDashStyle Property |
 | See Also

Gets or sets the annotation line style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(true)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value used to draw the annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutAnnotation.LineWidth Property

CalloutAnnotation.LineWidth Property |
 | See Also

Gets or sets the line width of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(true)]
public override int LineWidth { get; set; }
[BrowsableAttribute(true)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value that represents the annotation line width, in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


CalloutStyle Enumeration

CalloutStyle Enumeration |
 | See Also

Represents the available callout styles. Applicable only to callout annotations.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration CalloutStyle
public enum CalloutStyle
public enum class CalloutStyle
public enum CalloutStyle
public enum CalloutStyle

Members

Member name | Description
Borderline | A border is drawn around the callout text and a line points to the anchor point.
Cloud | Callout text is inside the cloud and smaller clouds point to the anchor point.
Ellipse | An ellipse is drawn around the callout text, which is connected to the anchor point.
Perspective | A perspective rectangle is drawn around the callout text, which is connected to the anchor point.
Rectangle | A rectangle is drawn around the callout text, which is connected to the anchor point.
RoundedRectangle | A rounded rectangle is drawn around the callout text, which is connected to the anchor point.
SimpleLine | Callout text is underlined and a line points to the anchor point.

Remarks

The CalloutStyle enumeration is used in conjunction with the CalloutStyle property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Chart Class

Chart Class |
 | See Also Members

Serves as the root class of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Chart
    Inherits DataBoundControl
    Implements IPostBackEventHandler
public class Chart : DataBoundControl, IPostBackEventHandler
public ref class Chart : public DataBoundControl, IPostBackEventHandler
public class Chart extends DataBoundControl implements IPostBackEventHandler
public class Chart extends DataBoundControl implements IPostBackEventHandler

Remarks

This class exposes all of the properties, methods and events of the Chart Web control.

Two important properties of the Chart class are the Series and ChartAreas properties, both of which are collection properties. The Series collection property stores Series objects, which are used to store data that is to be displayed, along with attributes of that data. The ChartAreas collection property stores ChartArea objects, which are primarily used to draw one or more charts using one set of axes.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.BaseDataBoundControl
System.Web.UI.WebControls.DataBoundControl
System.Web.UI.DataVisualization.Charting.Chart

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart Members

Chart Members |
 | See Also Constructors Events Methods Properties Explicit Interface Implementations

Serves as the root class of the Chart control.

The following tables list the members exposed by the Chart type.

Public Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.
Top

Public Properties (see also Protected Properties )

Name | Description
AccessKey | (inherited from WebControl )
AlternateText | Gets or sets the alternate text displayed in the Chart control when the chart image is unavailable.
Annotations | Stores the chart annotations.
AntiAliasing | Gets or sets a value that determines whether anti-aliasing is used when text and graphics are drawn.
AppRelativeTemplateSourceDirectory | (inherited from Control )
Attributes | (inherited from WebControl )
BackColor | Overridden. Gets or sets the background color of the Chart object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a Chart control. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of the Chart control.
BackImage | Gets or sets the background image of the Chart control.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets the color of the Chart control that will be displayed as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the Chart control.
BackSecondaryColor | Gets or sets the secondary color of the chart background.
BindingContainer | (inherited from Control )
BorderColor | Overridden. For internal use only.
BorderlineColor | Gets or sets the color of the entire chart image border.
BorderlineDashStyle | Gets or sets the style of the entire chart image border line.
BorderlineWidth | Gets or sets the width of the border line for the entire chart image.
BorderSkin | Gets or sets a BorderSkin object, which provides border skin functionality for the Chart control.
BorderStyle | Overridden. Gets or sets the border style of the Chart.
BorderWidth | Overridden. For internal use only.
BuildNumber | Gets the build number of the Chart control. This property is for internal use only.
ChartAreas | Gets a read-only ChartAreaCollection object that is used to store ChartArea objects.
ClientID | (inherited from Control )
Compression | Gets or sets the amount of compression for the chart image.
Controls | (inherited from Control )
ControlStyle | (inherited from WebControl )
ControlStyleCreated | (inherited from WebControl )
CssClass | (inherited from WebControl )
CurrentImageLocation | Gets the URL of the current image into which the Chart control will be rendered.
DataManipulator | Gets a DataManipulator object, which provides methods and properties that handle data.
DataMember | (inherited from DataBoundControl )
DataSource | Overridden. Gets or sets the data source for the Chart object.
DataSourceID | (inherited from DataBoundControl )
DescriptionUrl | Gets or sets the location of a detailed description of the Chart.
Enabled | (inherited from WebControl )
EnableTheming | (inherited from WebControl )
EnableViewState | Overridden. Gets or sets a flag that determines whether state management is enabled.
Font | Overridden. For internal use only.
ForeColor | Overridden. Gets or sets the text color of the Chart control.
HasAttributes | (inherited from WebControl )
Height | Overridden. Gets or sets the height of the entire chart image in pixels.
ID | (inherited from Control )
ImageLocation | Gets or sets the location where an image file is saved when ImageTag rendering is performed.
Images | Gets a NamedImagesCollection object, which stores NamedImage objects for the chart.
ImageStorageMode | Gets or sets the chart rendering type.
ImageType | Gets or sets the type of image into which the chart is rendered if ImageTag rendering is used.
IsMapAreaAttributesEncoded | Gets or sets a flag that determines whether map area attributes are encoded.
IsMapEnabled | Gets or sets a flag that determines whether client-side image maps are enabled.
IsSoftShadows | Gets or sets a flag that determines if a smooth gradient is applied when shadows are drawn.
Legends | Stores all Legend objects used by the Chart control.
MapAreas | Gets a MapAreasCollection object, which stores the map areas for the chart.
NamingContainer | (inherited from Control )
Page | (inherited from Control )
Palette | Gets or sets the palette for the Chart control.
PaletteCustomColors | Gets or sets an array of custom palette colors.
Parent | (inherited from Control )
RenderType | Gets or sets the rendering method used to display a chart image.
RightToLeft | Gets or sets a value that indicates whether the control should draw right-to-left for Right-to-Left (RTL) languages.
Serializer | Gets a ChartSerializer object, which is used for chart serialization.
Series | Gets a SeriesCollection object.
Site | (inherited from Control )
SkinID | (inherited from WebControl )
Style | (inherited from WebControl )
SuppressExceptions | Gets or sets a flag that determines whether noncritical exceptions should be suppressed.
TabIndex | (inherited from WebControl )
TemplateControl | (inherited from Control )
TemplateSourceDirectory | (inherited from Control )
TextAntiAliasingQuality | Gets or sets the TextAntiAliasingQuality type to use when applying anti-aliasing to text.
Titles | Stores all Title objects used by the Chart control.
ToolTip | (inherited from WebControl )
UniqueID | (inherited from Control )
ViewStateContent | Gets or sets a value that determines the view state to be persisted at the client.
ViewStateData | Gets or sets the user-defined view state of the control.
Visible | (inherited from Control )
Width | Overridden. Gets or sets the width of the entire chart image in pixels.
Top

Protected Properties

Name | Description
Adapter | (inherited from Control )
ChildControlsCreated | (inherited from Control )
ClientIDSeparator | (inherited from Control )
Context | (inherited from Control )
DesignMode | (inherited from Control )
Events | (inherited from Control )
HasChildViewState | (inherited from Control )
IdSeparator | (inherited from Control )
Initialized | (inherited from BaseDataBoundControl )
IsBoundUsingDataSourceID | (inherited from BaseDataBoundControl )
IsChildControlStateCleared | (inherited from Control )
IsEnabled | (inherited from WebControl )
IsTrackingViewState | (inherited from Control )
IsViewStateEnabled | (inherited from Control )
LoadViewStateByID | (inherited from Control )
RequiresDataBinding | (inherited from BaseDataBoundControl )
SelectArguments | (inherited from DataBoundControl )
TagKey | (inherited from WebControl )
TagName | (inherited from WebControl )
ViewState | (inherited from Control )
ViewStateIgnoresCase | (inherited from Control )
Top

Public Methods (see also Protected Methods )

Name | Description
AlignDataPointsByAxisLabel | Overloaded.
ApplyPaletteColors | Sets the automatically assigned series and data point colors, to allow programmatic access at run time.
ApplyStyle | (inherited from WebControl )
ApplyStyleSheetSkin | (inherited from Control )
CopyBaseAttributes | (inherited from WebControl )
DataBind | Overloaded. Overridden. Data binds the Chart control to a data source.
DataBindCrossTable | Overloaded.
DataBindTable | Overloaded.
Dispose | Overloaded. Overridden.
Equals | Overloaded. (inherited from Object )
FindControl | Overloaded. (inherited from Control )
Focus | (inherited from Control )
GetChartElementOutline | Returns the chart element outline.
GetHashCode | (inherited from Object )
GetHtmlImageMap | Returns the HTML image map of the currently rendered chart. One of the overloaded SaveImage methods in the Chart must be called before calling this method.
GetService | Returns the requested chart service.
GetType | (inherited from Object )
HasControls | (inherited from Control )
HitTest | Overloaded. Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.
LoadTemplate | Overloaded.
MergeStyle | (inherited from WebControl )
Paint | Draws the chart image in the graphics.
ReferenceEquals | (inherited from Object )
RenderBeginTag | (inherited from WebControl )
RenderControl | Overloaded. (inherited from Control )
RenderEndTag | (inherited from WebControl )
ResetAutoValues | Resets automatically calculated chart property values to "Auto".
ResolveClientUrl | (inherited from Control )
ResolveUrl | (inherited from Control )
SaveImage | Overloaded.
SaveXml | Saves the current state of the chart to an XML file. This method is mainly used for support purposes. The executing thread must have file write permission.
SetRenderMethodDelegate | (inherited from Control )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
AddAttributesToRender | (inherited from WebControl )
AddedControl | (inherited from Control )
AddParsedSubObject | (inherited from Control )
BuildProfileTree | (inherited from Control )
ClearChildControlState | (inherited from Control )
ClearChildState | (inherited from Control )
ClearChildViewState | (inherited from Control )
ConfirmInitState | (inherited from BaseDataBoundControl )
CreateChildControls | (inherited from Control )
CreateControlCollection | (inherited from Control )
CreateControlStyle | (inherited from WebControl )
CreateDataSourceSelectArguments | (inherited from DataBoundControl )
DataBind | Overloaded. (inherited from Control )
DataBindChildren | (inherited from Control )
Dispose | Overloaded.
EnsureChildControls | (inherited from Control )
EnsureDataBound | (inherited from BaseDataBoundControl )
EnsureID | (inherited from Control )
Finalize | (inherited from Object )
FindControl | Overloaded. (inherited from Control )
GetData | (inherited from DataBoundControl )
GetDataSource | (inherited from DataBoundControl )
GetDesignModeState | (inherited from Control )
HasEvents | (inherited from Control )
IsLiteralContent | (inherited from Control )
LoadControlState | (inherited from Control )
LoadViewState | Overridden. Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure | (inherited from Control )
MarkAsDataBound | (inherited from DataBoundControl )
MemberwiseClone | (inherited from Object )
OnBubbleEvent | (inherited from Control )
OnClick | Invokes delegates that were registered with the Click event.
OnCustomize | Occurs when all chart data is prepared to be customized before drawing.
OnCustomizeLegend | Occurs when all chart legend data is prepared to be customized before drawing.
OnCustomizeMapAreas | Occurs when chart image map data is prepared to be rendered.
OnDataBinding | (inherited from Control )
OnDataBound | (inherited from BaseDataBoundControl )
OnDataPropertyChanged | (inherited from DataBoundControl )
OnDataSourceViewChanged | (inherited from DataBoundControl )
OnFormatNumber | Converts a numeric value to a string.
OnInit | (inherited from BaseDataBoundControl )
OnLoad | (inherited from DataBoundControl )
OnPagePreLoad | (inherited from DataBoundControl )
OnPostPaint | Occurs when a chart element is painted.
OnPrePaint | Occurs when the chart element background is painted.
OnPreRender | (inherited from BaseDataBoundControl )
OnUnload | (inherited from Control )
OpenFile | (inherited from Control )
PerformDataBinding | Overridden. Data binds the specified data source to the Chart control.
PerformSelect | (inherited from DataBoundControl )
RaiseBubbleEvent | (inherited from Control )
RaisePostBackEvent | Raises events for the Chart control when a form is posted back to the server.
RemovedControl | (inherited from Control )
Render | Overridden. Renders the Chart control to the output parameter specified.
RenderChildren | (inherited from Control )
RenderContents | (inherited from WebControl )
RenderControl | Overloaded. (inherited from Control )
ResolveAdapter | (inherited from Control )
SaveControlState | (inherited from Control )
SaveViewState | Overridden. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
SetDesignModeState | (inherited from Control )
TrackViewState | (inherited from WebControl )
ValidateDataSource | Overridden. Verifies that a data-bound control can work with the object it will bind to.
Top

Public Events

Name | Description
Click | Occurs when the active image map area defined by PostBackValue on the Chart control is clicked.
Customize | Occurs just before the chart image is drawn. All chart data is available and all chart properties have been set.
CustomizeLegend | Occurs just before the chart legend is drawn. Use this event to customize the chart legend items.
CustomizeMapAreas | Occurs just before the chart image map is rendered. Use this event to customize the map areas items.
DataBinding | (inherited from Control )
DataBound | (inherited from BaseDataBoundControl )
Disposed | (inherited from Control )
FormatNumber | Called when a numeric value has to be converted to a string.
Init | (inherited from Control )
Load | (inherited from Control )
PostPaint | Occurs after chart element was drawn. This event is raised for elements such as ChartArea and Legend.
PrePaint | Occurs after the chart element backround is drawn. This event is raised for elements such as ChartArea and Legend.
PreRender | (inherited from Control )
Unload | (inherited from Control )
Top

Explicit Interface Implementations

Name | Description
System.Web.UI.IAttributeAccessor.GetAttribute | (inherited from WebControl )
System.Web.UI.IAttributeAccessor.SetAttribute | (inherited from WebControl )
System.Web.UI.IControlDesignerAccessor.GetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetOwnerControl | (inherited from Control )
System.Web.UI.IParserAccessor.AddParsedSubObject | (inherited from Control )
System.Web.UI.IPostBackEventHandler.RaisePostBackEvent |
System.Web.UI.IControlBuilderAccessor.ControlBuilder | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.UserData | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.DataBindings | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.HasDataBindings | (inherited from Control )
System.Web.UI.IExpressionsAccessor.Expressions | (inherited from Control )
System.Web.UI.IExpressionsAccessor.HasExpressions | (inherited from Control )
Top

See Also

Reference

Chart Class
System.Web.UI.DataVisualization.Charting Namespace


Chart Constructor

Chart Constructor |
 | See Also

Initializes a new instance of the Chart class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Chart ()
public:
Chart ()
public Chart ()
public function Chart ()

Remarks

You can use this constructor to create a new instance of the Chart class at run time.

However, for simplicity, it is recommended that you create a Chart instance at design time.

This is the root object of the Chart control.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart Methods

Chart Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
AlignDataPointsByAxisLabel | Overloaded.
ApplyPaletteColors | Sets the automatically assigned series and data point colors, to allow programmatic access at run time.
ApplyStyle | (inherited from WebControl )
ApplyStyleSheetSkin | (inherited from Control )
CopyBaseAttributes | (inherited from WebControl )
DataBind | Overloaded. Overridden. Data binds the Chart control to a data source.
DataBindCrossTable | Overloaded.
DataBindTable | Overloaded.
Dispose | Overloaded. Overridden.
Equals | Overloaded. (inherited from Object )
FindControl | Overloaded. (inherited from Control )
Focus | (inherited from Control )
GetChartElementOutline | Returns the chart element outline.
GetHashCode | (inherited from Object )
GetHtmlImageMap | Returns the HTML image map of the currently rendered chart. One of the overloaded SaveImage methods in the Chart must be called before calling this method.
GetService | Returns the requested chart service.
GetType | (inherited from Object )
HasControls | (inherited from Control )
HitTest | Overloaded. Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.
LoadTemplate | Overloaded.
MergeStyle | (inherited from WebControl )
Paint | Draws the chart image in the graphics.
ReferenceEquals | (inherited from Object )
RenderBeginTag | (inherited from WebControl )
RenderControl | Overloaded. (inherited from Control )
RenderEndTag | (inherited from WebControl )
ResetAutoValues | Resets automatically calculated chart property values to "Auto".
ResolveClientUrl | (inherited from Control )
ResolveUrl | (inherited from Control )
SaveImage | Overloaded.
SaveXml | Saves the current state of the chart to an XML file. This method is mainly used for support purposes. The executing thread must have file write permission.
SetRenderMethodDelegate | (inherited from Control )
ToString | (inherited from Object )

Protected Methods

Name | Description
AddAttributesToRender | (inherited from WebControl )
AddedControl | (inherited from Control )
AddParsedSubObject | (inherited from Control )
BuildProfileTree | (inherited from Control )
ClearChildControlState | (inherited from Control )
ClearChildState | (inherited from Control )
ClearChildViewState | (inherited from Control )
ConfirmInitState | (inherited from BaseDataBoundControl )
CreateChildControls | (inherited from Control )
CreateControlCollection | (inherited from Control )
CreateControlStyle | (inherited from WebControl )
CreateDataSourceSelectArguments | (inherited from DataBoundControl )
DataBind | Overloaded. (inherited from Control )
DataBindChildren | (inherited from Control )
Dispose | Overloaded.
EnsureChildControls | (inherited from Control )
EnsureDataBound | (inherited from BaseDataBoundControl )
EnsureID | (inherited from Control )
Finalize | (inherited from Object )
FindControl | Overloaded. (inherited from Control )
GetData | (inherited from DataBoundControl )
GetDataSource | (inherited from DataBoundControl )
GetDesignModeState | (inherited from Control )
HasEvents | (inherited from Control )
IsLiteralContent | (inherited from Control )
LoadControlState | (inherited from Control )
LoadViewState | Overridden. Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure | (inherited from Control )
MarkAsDataBound | (inherited from DataBoundControl )
MemberwiseClone | (inherited from Object )
OnBubbleEvent | (inherited from Control )
OnClick | Invokes delegates that were registered with the Click event.
OnCustomize | Occurs when all chart data is prepared to be customized before drawing.
OnCustomizeLegend | Occurs when all chart legend data is prepared to be customized before drawing.
OnCustomizeMapAreas | Occurs when chart image map data is prepared to be rendered.
OnDataBinding | (inherited from Control )
OnDataBound | (inherited from BaseDataBoundControl )
OnDataPropertyChanged | (inherited from DataBoundControl )
OnDataSourceViewChanged | (inherited from DataBoundControl )
OnFormatNumber | Converts a numeric value to a string.
OnInit | (inherited from BaseDataBoundControl )
OnLoad | (inherited from DataBoundControl )
OnPagePreLoad | (inherited from DataBoundControl )
OnPostPaint | Occurs when a chart element is painted.
OnPrePaint | Occurs when the chart element background is painted.
OnPreRender | (inherited from BaseDataBoundControl )
OnUnload | (inherited from Control )
OpenFile | (inherited from Control )
PerformDataBinding | Overridden. Data binds the specified data source to the Chart control.
PerformSelect | (inherited from DataBoundControl )
RaiseBubbleEvent | (inherited from Control )
RaisePostBackEvent | Raises events for the Chart control when a form is posted back to the server.
RemovedControl | (inherited from Control )
Render | Overridden. Renders the Chart control to the output parameter specified.
RenderChildren | (inherited from Control )
RenderContents | (inherited from WebControl )
RenderControl | Overloaded. (inherited from Control )
ResolveAdapter | (inherited from Control )
SaveControlState | (inherited from Control )
SaveViewState | Overridden. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
SetDesignModeState | (inherited from Control )
TrackViewState | (inherited from WebControl )
ValidateDataSource | Overridden. Verifies that a data-bound control can work with the object it will bind to.

Explicit Interface Implementations

Name | Description
System.Web.UI.IAttributeAccessor.GetAttribute | (inherited from WebControl )
System.Web.UI.IAttributeAccessor.SetAttribute | (inherited from WebControl )
System.Web.UI.IControlDesignerAccessor.GetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetOwnerControl | (inherited from Control )
System.Web.UI.IParserAccessor.AddParsedSubObject | (inherited from Control )
System.Web.UI.IPostBackEventHandler.RaisePostBackEvent |

See Also

Reference

Chart Class
System.Web.UI.DataVisualization.Charting Namespace


Chart.AlignDataPointsByAxisLabel Method

Chart.AlignDataPointsByAxisLabel Method |
 | See Also

Overload List

Name | Description
Chart.AlignDataPointsByAxisLabel () | Aligns data points along the X axis using their axis labels. Applicable when multiple series are indexed and their X-values are strings.
Chart.AlignDataPointsByAxisLabel (PointSortOrder) | Aligns data points using their axis labels. All series in the chart are aligned, using the specified sort order.
Chart.AlignDataPointsByAxisLabel (String) | Aligns data points from different series along the X axis using their axis labels. The specified series in the chart are aligned using an ascending sort order.
Chart.AlignDataPointsByAxisLabel (String, PointSortOrder) | Aligns data points using their axis labels.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.AlignDataPointsByAxisLabel Method ()

Chart.AlignDataPointsByAxisLabel Method () |
 | See Also

Aligns data points along the X axis using their axis labels. Applicable when multiple series are indexed and their X-values are strings.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel
public void AlignDataPointsByAxisLabel ()
public:
void AlignDataPointsByAxisLabel ()
public void AlignDataPointsByAxisLabel ()
public function AlignDataPointsByAxisLabel ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.AlignDataPointsByAxisLabel Method (PointSortOrder)

Chart.AlignDataPointsByAxisLabel Method (PointSortOrder) |
 | See Also

Aligns data points using their axis labels. All series in the chart are aligned, using the specified sort order.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel ( _
    sortingOrder As PointSortOrder _
)
public void AlignDataPointsByAxisLabel (
    PointSortOrder sortingOrder
)
public:
void AlignDataPointsByAxisLabel (
    PointSortOrder sortingOrder
)
public void AlignDataPointsByAxisLabel (
    PointSortOrder sortingOrder
)
public function AlignDataPointsByAxisLabel (
    sortingOrder : PointSortOrder
)

Parameters

sortingOrder

A PointSortOrder object that indicates if ascending or descending sort order is used on axis labels, which in turn determines the order by which points that previously occupied the same axis space are displayed.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.AlignDataPointsByAxisLabel Method (String)

Chart.AlignDataPointsByAxisLabel Method (String) |
 | See Also

Aligns data points from different series along the X axis using their axis labels. The specified series in the chart are aligned using an ascending sort order.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel ( _
    series As String _
)
public void AlignDataPointsByAxisLabel (
    string series
)
public:
void AlignDataPointsByAxisLabel (
    String^ series
)
public void AlignDataPointsByAxisLabel (
    String series
)
public function AlignDataPointsByAxisLabel (
    series : String
)

Parameters

series

A comma-separated list of series that will have their data points aligned to the X axis using the data point axis labels.

Remarks

This method is used to align data points from different series along the X axis using their axis labels, and is applicable when:

  • Multiple series are displayed and are indexed; that is, all data points have an XValue of 0, or the IsXValueIndexed property is true.

  • All data points have non-empty axis labels, which are unique to their Series. If they are not unique, an exception will be thrown.

This situation is very common when data-binding results in the creation of multiple series, and string values are used for X-axis values.

Two issues arise when multiple, indexed series are plotted, and the X-values are set using string values:

  • It cannot be guaranteed that data points from different series with the same string X-values will be plotted at the same index along the X axis.

  • Only the axis label for the data points in the first series will be displayed, even though data points from other series with the same index have axis labels too.

By default, points are plotted in the order in which they are stored in their series. To specify a sort order, use an AlignDataPointsByAxisLabel method overload that has a sortingOrder parameter.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.AlignDataPointsByAxisLabel Method (String, PointSortOrder)

Chart.AlignDataPointsByAxisLabel Method (String, PointSortOrder) |
 | See Also

Aligns data points using their axis labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel ( _
    series As String, _
    sortingOrder As PointSortOrder _
)
public void AlignDataPointsByAxisLabel (
    string series,
    PointSortOrder sortingOrder
)
public:
void AlignDataPointsByAxisLabel (
    String^ series,
    PointSortOrder sortingOrder
)
public void AlignDataPointsByAxisLabel (
    String series,
    PointSortOrder sortingOrder
)
public function AlignDataPointsByAxisLabel (
    series : String,
    sortingOrder : PointSortOrder
)

Parameters

series

A comma-separated list of series that should be aligned by axis label.

sortingOrder

A PointSortOrder enumeration value that determines if ascending or descending sort order is used on axis labels, which in turn determines the order by which points that previously occupied the same axis space are displayed.

Remarks

This method is used to align data points from different series along the X axis using their axis labels, and is applicable when:

  • Multiple series are displayed and are indexed; that is, all data points have an XValue of 0, or the IsXValueIndexed property is true.

  • All data points have non-empty axis labels, which are unique to their Series. If they are not unique, an exception will be thrown.

This situation is very common when data-binding results in the creation of multiple series, and string values are used for X-axis values.

Two issues arise when multiple, indexed series are plotted, and the X-values are set using string values:

  • It cannot be guaranteed that data points from different series with the same string X-values will be plotted at the same index along the X axis.

  • Only the axis label for the data points in the first series will be displayed, even though data points from other series with the same index have axis labels too.

By default, points are plotted in the order in which they are stored in their series. To specify a sort order, use an AlignDataPointsByAxisLabel method overload that has a sortingOrder parameter.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ApplyPaletteColors Method

Chart.ApplyPaletteColors Method |
 | See Also

Sets the automatically assigned series and data point colors, to allow programmatic access at run time.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub ApplyPaletteColors
public void ApplyPaletteColors ()
public:
void ApplyPaletteColors ()
public void ApplyPaletteColors ()
public function ApplyPaletteColors ()

Remarks

When the Chart colors are automatically assigned at run time, there is no way to know what the colors will be prior to the time when the chart rendered; the Color property of an automatically assigned value will return Empty at this time.

If you call the ApplyPaletteColors method, the colors for the series and the data points will be set, which allows for programmatic access.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBind Method

Chart.DataBind Method |
 | See Also

Data binds the Chart control to a data source.

Remarks

This method will bind the Chart control to the specified data source.

In cases where a data source is set to a chart and no other data operations are required, the DataBind method does not have to be explicitly called. In these cases, the Chart itself will data bind to the data source prior to being rendered.

Overload List

Name | Description
Chart.DataBind () | Data binds the Chart control to a data source.
Chart.DataBind (Boolean) | (inherited from DataBind )

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBind Method ()

Chart.DataBind Method () |
 | See Also

Data binds the Chart control to a data source.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Sub DataBind
public override void DataBind ()
public:
virtual void DataBind () override
public void DataBind ()
public override function DataBind ()

Remarks

In cases where a data source is set to a chart and no other data operations are required, the DataBind method does not have to be explicitly called. In these cases, the Chart itself will data bind to the data source prior to being rendered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBindCrossTable Method

Chart.DataBindCrossTable Method |
 | See Also

Overload List

Name | Description
Chart.DataBindCrossTable (IEnumerable, String, String, String, String) | Data binds a chart to the table, with one series created per unique value in a given column.
Chart.DataBindCrossTable (IEnumerable, String, String, String, String, PointSortOrder) | Data binds a chart to the table, with one series created per unique value in a given column.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String)

Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String) |
 | See Also

Data binds a chart to the table, with one series created per unique value in a given column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindCrossTable ( _
    dataSource As IEnumerable, _
    seriesGroupByField As String, _
    xField As String, _
    yFields As String, _
    otherFields As String _
)
public void DataBindCrossTable (
    IEnumerable dataSource,
    string seriesGroupByField,
    string xField,
    string yFields,
    string otherFields
)
public:
void DataBindCrossTable (
    IEnumerable^ dataSource,
    String^ seriesGroupByField,
    String^ xField,
    String^ yFields,
    String^ otherFields
)
public void DataBindCrossTable (
    IEnumerable dataSource,
    String seriesGroupByField,
    String xField,
    String yFields,
    String otherFields
)
public function DataBindCrossTable (
    dataSource : IEnumerable,
    seriesGroupByField : String,
    xField : String,
    yFields : String,
    otherFields : String
)

Parameters

dataSource

The data source.

seriesGroupByField

The name of the field used to group data into the series.

xField

Name of the field for X values.

yFields

A comma-separated list of name(s) of the field(s) for Y value(s).

otherFields

Other data point properties that can be bound.

Remarks

Series will be automatically added to the chart, depending on the number of unique values in the given seriesGroupByField column of the data source; in other words, the creation of series depends upon grouping of a column.

The data source can be a OleDbDataReader, SqlDataReader or a DataView object. Note that all collections that implement the IEnumerable interface can be used.

Other data point properties besides X and Y-values can be bound. The format is: PointProperty=Field[{Format}] [,PointProperty= Field[{Format}]]. For example:"Tooltip=Price{C1},Href=WebSiteName".

A list of these data point properties is as follows: AxisLabel, ToolTip, Url, PostBackValue, Label, LegendText, LegendToolTip and CustomProperties, which are the names of the custom properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String, PointSortOrder)

Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String, PointSortOrder) |
 | See Also

Data binds a chart to the table, with one series created per unique value in a given column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindCrossTable ( _
    dataSource As IEnumerable, _
    seriesGroupByField As String, _
    xField As String, _
    yFields As String, _
    otherFields As String, _
    sortingOrder As PointSortOrder _
)
public void DataBindCrossTable (
    IEnumerable dataSource,
    string seriesGroupByField,
    string xField,
    string yFields,
    string otherFields,
    PointSortOrder sortingOrder
)
public:
void DataBindCrossTable (
    IEnumerable^ dataSource,
    String^ seriesGroupByField,
    String^ xField,
    String^ yFields,
    String^ otherFields,
    PointSortOrder sortingOrder
)
public void DataBindCrossTable (
    IEnumerable dataSource,
    String seriesGroupByField,
    String xField,
    String yFields,
    String otherFields,
    PointSortOrder sortingOrder
)
public function DataBindCrossTable (
    dataSource : IEnumerable,
    seriesGroupByField : String,
    xField : String,
    yFields : String,
    otherFields : String,
    sortingOrder : PointSortOrder
)

Parameters

dataSource

The data source.

seriesGroupByField

The name of the field used to group data into the series.

xField

Name of the field for X values.

yFields

A comma-separated list of name(s) of the field(s) for Y value(s).

otherFields

Other data point properties that can be bound.

sortingOrder

Series will be sorted by group field values in the specified order.

Remarks

Series will be automatically added to the chart, depending on the number of unique values in the given seriesGroupByField column of the data source; in other words, the creation of series depends upon grouping of a column.

The data source can be a OleDbDataReader, SqlDataReader or a DataView object.

Note that all collections that implement the IEnumerable interface can be used.

Other data point properties besides X and Y-values can be bound. The format is: PointProperty=Field[{Format}] [,PointProperty= Field[{Format}]]. For example:"Tooltip=Price{C1},Href=WebSiteName".

A list of these data point properties is as follows: P:System.Web.UI.DataVisualization.Charting.DataPoint.AxisLabel, ToolTip, Url, Label, LegendText, LegendToolTip and CustomProperties, which are the names of the custom properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBindTable Method

Chart.DataBindTable Method |
 | See Also

Overload List

Name | Description
Chart.DataBindTable (IEnumerable) | Automatically creates and binds series data to the specified data table.
Chart.DataBindTable (IEnumerable, String) | Automatically creates and binds series data to the specified data table, and optionally populates X-values.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBindTable Method (IEnumerable)

Chart.DataBindTable Method (IEnumerable) |
 | See Also

Automatically creates and binds series data to the specified data table.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindTable ( _
    dataSource As IEnumerable _
)
public void DataBindTable (
    IEnumerable dataSource
)
public:
void DataBindTable (
    IEnumerable^ dataSource
)
public void DataBindTable (
    IEnumerable dataSource
)
public function DataBindTable (
    dataSource : IEnumerable
)

Parameters

dataSource

The data source, which can be any IEnumerable object.

Remarks

Each column of the table becomes a Y-value for a series, with one series per column.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataBindTable Method (IEnumerable, String)

Chart.DataBindTable Method (IEnumerable, String) |
 | See Also

Automatically creates and binds series data to the specified data table, and optionally populates X-values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindTable ( _
    dataSource As IEnumerable, _
    xField As String _
)
public void DataBindTable (
    IEnumerable dataSource,
    string xField
)
public:
void DataBindTable (
    IEnumerable^ dataSource,
    String^ xField
)
public void DataBindTable (
    IEnumerable dataSource,
    String xField
)
public function DataBindTable (
    dataSource : IEnumerable,
    xField : String
)

Parameters

dataSource

The data source, which can be any IEnumerable object.

xField

The name of the field used for the series X-values.

Remarks

Each column of the table becomes a Y-value for a series, with one series per column.

The series' X-value field can also be provided.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Dispose Method

Chart.Dispose Method |
 | See Also

Overload List

Name | Description
Chart.Dispose () | Disposes of the object, using the IDisposable interface.
Chart.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Dispose Method ()

Chart.Dispose Method () |
 | See Also

Disposes of the object, using the IDisposable interface.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides NotOverridable Sub Dispose
public override sealed void Dispose ()
public:
virtual void Dispose () override sealed
public final void Dispose ()
public override final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Dispose Method (Boolean)

Chart.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.GetChartElementOutline Method

Chart.GetChartElementOutline Method |
 | See Also

Returns the chart element outline.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetChartElementOutline ( _
    chartElement As Object, _
    elementType As ChartElementType _
) As ChartElementOutline
public ChartElementOutline GetChartElementOutline (
    Object chartElement,
    ChartElementType elementType
)
public:
ChartElementOutline^ GetChartElementOutline (
    Object^ chartElement,
    ChartElementType elementType
)
public ChartElementOutline GetChartElementOutline (
    Object chartElement,
    ChartElementType elementType
)
public function GetChartElementOutline (
    chartElement : Object,
    elementType : ChartElementType
) : ChartElementOutline

Parameters

chartElement

The chart element.

elementType

The type of element.

Return Value

A ChartElementOutline object that contains:

  • An array of points in absolute coordinates that can be used as outline markers around this chart element.

  • A GraphicsPath object for drawing an outline around this chart element.

Remarks

If the chartElement is not part of the chart, or the elementType cannot be combined with chartElement, the result will contain an empty array of marker points. The marker points are sorted clockwise.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.GetHtmlImageMap Method

Chart.GetHtmlImageMap Method |
 | See Also

Returns the HTML image map of the currently rendered chart. One of the overloaded SaveImage methods in the Chart must be called before calling this method.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetHtmlImageMap ( _
    name As String _
) As String
public string GetHtmlImageMap (
    string name
)
public:
String^ GetHtmlImageMap (
    String^ name
)
public String GetHtmlImageMap (
    String name
)
public function GetHtmlImageMap (
    name : String
) : String

Parameters

name

The name of the image map tag.

Return Value

A string value that represents the HTML image map.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.GetService Method

Chart.GetService Method |
 | See Also

Returns the requested chart service.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetService ( _
    serviceType As Type _
) As Object
public Object GetService (
    Type serviceType
)
public:
Object^ GetService (
    Type^ serviceType
)
public Object GetService (
    Type serviceType
)
public function GetService (
    serviceType : Type
) : Object

Parameters

serviceType

The type of requested chart service.

Return Value

An Object that represents the service type or null if the service cannot be found.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.HitTest Method

Chart.HitTest Method |
 | See Also

Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.

Remarks

Call this method to determine the chart element, if any, that is located at a specified point.

This method is often used in some mouse-related event—for example, MouseDown—to determine which chart element the end-user clicked. The X and Y mouse coordinates obtained from the event parameters are then used for the x and y parameter values of this method call.

The properties of the returned HitTestResult object can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Overload List

Name | Description
Chart.HitTest (Int32, Int32) | Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.
Chart.HitTest (Int32, Int32, Boolean) | Determines the chart element, if any, that is located at a point defined by given X and Y coordinates. Transparent elements can optionally be ignored.
Chart.HitTest (Int32, Int32, ChartElementType) | Determines whether a chart element of a given type is located at a point defined by the given X and Y coordinates.
Chart.HitTest (Int32, Int32, Boolean, ChartElementType[]) | Determines whether a chart element that is one of the specified types is located at a point defined by the given X and Y coordinates.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.HitTest Method (Int32, Int32)

Chart.HitTest Method (Int32, Int32) |
 | See Also

Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function HitTest ( _
    x As Integer, _
    y As Integer _
) As HitTestResult
public HitTestResult HitTest (
    int x,
    int y
)
public:
HitTestResult^ HitTest (
    int x,
    int y
)
public HitTestResult HitTest (
    int x,
    int y
)
public function HitTest (
    x : int,
    y : int
) : HitTestResult

Parameters

x

The X-coordinate value of the point the user clicked.

y

The Y-coordinate value of the point the user clicked.

Return Value

A HitTestResult object, which provides information concerning the chart element, if any, that is at the specified location.

Remarks

Call this method to determine the chart element, if any, which is located at a specified point.

Important:
In order for this method to work correctly, the IsMapEnabled property must be set to false.

This method can be used with the Click server-side event when you implement drilldown. However, it is highly recommended that you use client-side image maps for drilldown because of ease of use.

The properties of the returned HitTestResult object can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.HitTest Method (Int32, Int32, Boolean)

Chart.HitTest Method (Int32, Int32, Boolean) |
 | See Also

Determines the chart element, if any, that is located at a point defined by given X and Y coordinates. Transparent elements can optionally be ignored.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function HitTest ( _
    x As Integer, _
    y As Integer, _
    ignoreTransparent As Boolean _
) As HitTestResult
public HitTestResult HitTest (
    int x,
    int y,
    bool ignoreTransparent
)
public:
HitTestResult^ HitTest (
    int x,
    int y,
    bool ignoreTransparent
)
public HitTestResult HitTest (
    int x,
    int y,
    boolean ignoreTransparent
)
public function HitTest (
    x : int,
    y : int,
    ignoreTransparent : boolean
) : HitTestResult

Parameters

x

The X-coordinate value of the point the user clicked on.

y

The Y-coordinate value of the point the user clicked on.

ignoreTransparent

A flag that determines if transparent elements are ignored.

Return Value

A HitTestResult object, which provides information concerning the chart element, if any, that is at the specified location.

Remarks

Call this method to determine the chart element, if any, which is located at a specified point.

To ignore transparent elements, set the ignoreTransparent parameter to true.

Important:
In order for this method to work correctly, the IsMapEnabled property must be set to false.

This method can be used with the Click server-side event when you implement drilldown. However, it is highly recommended that you use client-side image maps for drilldown because of ease of use.

The properties of the returned HitTestResult object can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.HitTest Method (Int32, Int32, ChartElementType)

Chart.HitTest Method (Int32, Int32, ChartElementType) |
 | See Also

Determines whether a chart element of a given type is located at a point defined by the given X and Y coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function HitTest ( _
    x As Integer, _
    y As Integer, _
    requestedElement As ChartElementType _
) As HitTestResult
public HitTestResult HitTest (
    int x,
    int y,
    ChartElementType requestedElement
)
public:
HitTestResult^ HitTest (
    int x,
    int y,
    ChartElementType requestedElement
)
public HitTestResult HitTest (
    int x,
    int y,
    ChartElementType requestedElement
)
public function HitTest (
    x : int,
    y : int,
    requestedElement : ChartElementType
) : HitTestResult

Parameters

x

The X-coordinate value of the point the user clicked on.

y

The Y-coordinate value of the point the user clicked on.

requestedElement

A flag that determines the chart element type to be tested.

Return Value

A HitTestResult object that provides information about the chart element, if any, found at the specified location.

Remarks

Call this method to determine if a chart element of the given type is located at a specified point.

Important:
In order for this method to work correctly, the IsMapEnabled property must be set to false.

This method can be used with the Click server-side event when you implement drilldown. However, it is highly recommended that you use client-side image maps for drilldown because of ease of use.

The properties of the returned HitTestResult object can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.HitTest Method (Int32, Int32, Boolean, ChartElementType[])

Chart.HitTest Method (Int32, Int32, Boolean, ChartElementType[]) |
 | See Also

Determines whether a chart element that is one of the specified types is located at a point defined by the given X and Y coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function HitTest ( _
    x As Integer, _
    y As Integer, _
    ignoreTransparent As Boolean, _
    ParamArray requestedElement As ChartElementType() _
) As HitTestResult()
public HitTestResult[] HitTest (
    int x,
    int y,
    bool ignoreTransparent,
    params ChartElementType[] requestedElement
)
public:
array<HitTestResult^>^ HitTest (
    int x,
    int y,
    bool ignoreTransparent,
    ... array<ChartElementType>^ requestedElement
)
public HitTestResult[] HitTest (
    int x,
    int y,
    boolean ignoreTransparent,
    ChartElementType[] requestedElement
)
public function HitTest (
    x : int,
    y : int,
    ignoreTransparent : boolean,
    ... requestedElement : ChartElementType[]
) : HitTestResult[]

Parameters

x

The X-coordinate for the specified data point.

y

The Y-coordinate for the specified data point.

ignoreTransparent

A flag that indicates that transparent elements should be ignored.

requestedElement

An array of ChartElementType objects that specify the types to test for, in order to filter the result. If omitted, checking for element types will be ignored and all element types will be valid.

Return Value

An array of T:System.Web.UI.DataVisualization.Charting.HitTestResult objects that provides information about the chart element, if any, found at the specified location. The array contains at least one element, which can be Nothing. The objects in the result are sorted from the top to the bottom of different layers of control.

Remarks

Call this method to determine the gauge element, if any, which is located at a specified point. This method is often used in some mouse-related event, for example, MouseDown, to determine which gauge element the end-user clicked. The X and Y mouse coordinates obtained from the event parameters are then used for the X and Y parameter values of this method call.

The properties of the returned HitTestResult object can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.LoadTemplate Method

Chart.LoadTemplate Method |
 | See Also

Overload List

Name | Description
Chart.LoadTemplate (Stream) | Loads a template into the Chart control from an image stream.
Chart.LoadTemplate (String) | Loads a template with the specified filename from the disk.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.LoadTemplate Method (Stream)

Chart.LoadTemplate Method (Stream) |
 | See Also

Loads a template into the Chart control from an image stream.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub LoadTemplate ( _
    stream As Stream _
)
public void LoadTemplate (
    Stream stream
)
public:
void LoadTemplate (
    Stream^ stream
)
public void LoadTemplate (
    Stream stream
)
public function LoadTemplate (
    stream : Stream
)

Parameters

stream

The stream to load from.

Remarks

Use this method if you want to load a template from a stream, such as a memory stream, file stream, and so forth.

Make sure to set the IsTemplateMode property to true before saving the template with the Save method.

If a loaded template has two data series, the appearance properties of the series are applied sequentially to the chart. In other words, the first template series appearance properties are assigned to the first series of the chart, the second template series appearance properties are applied to the second series of the chart, then the first template series is used again for the third series of the chart, and so on. The same holds true for chart areas, and any other collections that have appearance properties.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.LoadTemplate Method (String)

Chart.LoadTemplate Method (String) |
 | See Also

Loads a template with the specified filename from the disk.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub LoadTemplate ( _
    name As String _
)
public void LoadTemplate (
    string name
)
public:
void LoadTemplate (
    String^ name
)
public void LoadTemplate (
    String name
)
public function LoadTemplate (
    name : String
)

Parameters

name

The file name of the template to load. You must specify the full path of the template to be loaded from the disk.

Remarks

The name parameter must use a full path, for example, C:\MyPic.jpg. Note that you must also specify the file extension.

This method loads a template from disk that was saved using the Save method.

Make sure to set the IsTemplateMode property to true before saving the template with the Save method.

If a loaded template has two data series, the appearance properties of the series are applied sequentially to the chart. In other words, the first template series appearance properties are assigned to the first series of the chart, the second template series appearance properties are applied to the second series of the chart, then the first template series is used again for the third series of the chart, and so on. The same holds true for chart areas, and any other collections that have appearance properties.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.LoadViewState Method

Chart.LoadViewState Method |
 | See Also

Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)
protected override void LoadViewState (
    Object savedState
)
protected:
virtual void LoadViewState (
    Object^ savedState
) override
protected void LoadViewState (
    Object savedState
)
protected override function LoadViewState (
    savedState : Object
)

Parameters

savedState

An Object that represents the control state to be restored.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnClick Method

Chart.OnClick Method |
 | See Also

Invokes delegates that were registered with the Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnClick ( _
    e As ImageMapEventArgs _
)
protected virtual void OnClick (
    ImageMapEventArgs e
)
protected:
virtual void OnClick (
    ImageMapEventArgs^ e
)
protected void OnClick (
    ImageMapEventArgs e
)
protected function OnClick (
    e : ImageMapEventArgs
)

Parameters

e

An ImageMapEventArgs object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnCustomize Method

Chart.OnCustomize Method |
 | See Also

Occurs when all chart data is prepared to be customized before drawing.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnCustomize ( _
    e As EventArgs _
)
protected virtual void OnCustomize (
    EventArgs e
)
protected:
virtual void OnCustomize (
    EventArgs^ e
)
protected void OnCustomize (
    EventArgs e
)
protected function OnCustomize (
    e : EventArgs
)

Parameters

e

The EventArgs object that contains the event data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnCustomizeLegend Method

Chart.OnCustomizeLegend Method |
 | See Also

Occurs when all chart legend data is prepared to be customized before drawing.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnCustomizeLegend ( _
    e As CustomizeLegendEventArgs _
)
protected virtual void OnCustomizeLegend (
    CustomizeLegendEventArgs e
)
protected:
virtual void OnCustomizeLegend (
    CustomizeLegendEventArgs^ e
)
protected void OnCustomizeLegend (
    CustomizeLegendEventArgs e
)
protected function OnCustomizeLegend (
    e : CustomizeLegendEventArgs
)

Parameters

e

A CustomizeLegendEventArgs object that contains the event data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnCustomizeMapAreas Method

Chart.OnCustomizeMapAreas Method |
 | See Also

Occurs when chart image map data is prepared to be rendered.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnCustomizeMapAreas ( _
    e As CustomizeMapAreasEventArgs _
)
protected virtual void OnCustomizeMapAreas (
    CustomizeMapAreasEventArgs e
)
protected:
virtual void OnCustomizeMapAreas (
    CustomizeMapAreasEventArgs^ e
)
protected void OnCustomizeMapAreas (
    CustomizeMapAreasEventArgs e
)
protected function OnCustomizeMapAreas (
    e : CustomizeMapAreasEventArgs
)

Parameters

e

The CustomizeMapAreasEventArgs object that contains the event data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnFormatNumber Method

Chart.OnFormatNumber Method |
 | See Also

Converts a numeric value to a string.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnFormatNumber ( _
    caller As Object, _
    e As FormatNumberEventArgs _
)
protected virtual void OnFormatNumber (
    Object caller,
    FormatNumberEventArgs e
)
protected:
virtual void OnFormatNumber (
    Object^ caller,
    FormatNumberEventArgs^ e
)
protected void OnFormatNumber (
    Object caller,
    FormatNumberEventArgs e
)
protected function OnFormatNumber (
    caller : Object,
    e : FormatNumberEventArgs
)

Parameters

caller

The event caller, which can be a chart image, a ChartArea or a Legend object.

e

A FormatNumberEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnPostPaint Method

Chart.OnPostPaint Method |
 | See Also

Occurs when a chart element is painted.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnPostPaint ( _
    e As ChartPaintEventArgs _
)
protected virtual void OnPostPaint (
    ChartPaintEventArgs e
)
protected:
virtual void OnPostPaint (
    ChartPaintEventArgs^ e
)
protected void OnPostPaint (
    ChartPaintEventArgs e
)
protected function OnPostPaint (
    e : ChartPaintEventArgs
)

Parameters

e

Event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.OnPrePaint Method

Chart.OnPrePaint Method |
 | See Also

Occurs when the chart element background is painted.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub OnPrePaint ( _
    e As ChartPaintEventArgs _
)
protected virtual void OnPrePaint (
    ChartPaintEventArgs e
)
protected:
virtual void OnPrePaint (
    ChartPaintEventArgs^ e
)
protected void OnPrePaint (
    ChartPaintEventArgs e
)
protected function OnPrePaint (
    e : ChartPaintEventArgs
)

Parameters

e

Event arguments.

Remarks

This event occurs just prior to a chart element being drawn, and is raised once for the chart image, and one time for each of the ChartArea, Legend, Series and DataPoint objects that exist within the chart image. Note that this event is not raised for Series and DataPoint objects for 3D charts.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Paint Method

Chart.Paint Method |
 | See Also

Draws the chart image in the graphics.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Paint ( _
    graphics As Graphics, _
    position As Rectangle _
)
public void Paint (
    Graphics graphics,
    Rectangle position
)
public:
void Paint (
    Graphics^ graphics,
    Rectangle position
)
public void Paint (
    Graphics graphics,
    Rectangle position
)
public function Paint (
    graphics : Graphics,
    position : Rectangle
)

Parameters

graphics

The graphics object in which to draw the chart image.

position

Position of the chart image in the graphics..

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.PerformDataBinding Method

Chart.PerformDataBinding Method |
 | See Also

Data binds the specified data source to the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub PerformDataBinding ( _
    data As IEnumerable _
)
protected override void PerformDataBinding (
    IEnumerable data
)
protected:
virtual void PerformDataBinding (
    IEnumerable^ data
) override
protected void PerformDataBinding (
    IEnumerable data
)
protected override function PerformDataBinding (
    data : IEnumerable
)

Parameters

data

An IEnumerable object that represents the data source.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.RaisePostBackEvent Method

Chart.RaisePostBackEvent Method |
 | See Also

Raises events for the Chart control when a form is posted back to the server.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub RaisePostBackEvent ( _
    eventArgument As String _
)
protected virtual void RaisePostBackEvent (
    string eventArgument
)
protected:
virtual void RaisePostBackEvent (
    String^ eventArgument
)
protected void RaisePostBackEvent (
    String eventArgument
)
protected function RaisePostBackEvent (
    eventArgument : String
)

Parameters

eventArgument

An event argument.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Render Method

Chart.Render Method |
 | See Also

Renders the Chart control to the output parameter specified.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Render ( _
    writer As HtmlTextWriter _
)
protected override void Render (
    HtmlTextWriter writer
)
protected:
virtual void Render (
    HtmlTextWriter^ writer
) override
protected void Render (
    HtmlTextWriter writer
)
protected override function Render (
    writer : HtmlTextWriter
)

Parameters

writer

An HtmlTextWriter object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ResetAutoValues Method

Chart.ResetAutoValues Method |
 | See Also

Resets automatically calculated chart property values to "Auto".

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub ResetAutoValues
public void ResetAutoValues ()
public:
void ResetAutoValues ()
public void ResetAutoValues ()
public function ResetAutoValues ()

Remarks

Several chart properties can be set to "Auto"—for example, Minimum; these properties are calculated prior to the chart being rendered. "Auto" is usually represented as a NaN value.

Call this method to reset these properties from their calculated value to "Auto" (NaN).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveImage Method

Chart.SaveImage Method |
 | See Also

Overload List

Name | Description
Chart.SaveImage (Stream) | Saves the chart image to the specified stream. The properties ImageType, Compression and other Chart control properties are used.
Chart.SaveImage (String) | Saves the chart image to the specified file. The properties ImageType, Compression and other Chart control properties are used.
Chart.SaveImage (Stream, ChartImageFormat) | Saves the chart image to the specified stream.
Chart.SaveImage (String, ChartImageFormat) | Saves a chart image to the file.

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveImage Method (Stream)

Chart.SaveImage Method (Stream) |
 | See Also

Saves the chart image to the specified stream. The properties ImageType, Compression and other Chart control properties are used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageStream As Stream _
)
public void SaveImage (
    Stream imageStream
)
public:
void SaveImage (
    Stream^ imageStream
)
public void SaveImage (
    Stream imageStream
)
public function SaveImage (
    imageStream : Stream
)

Parameters

imageStream

The image stream.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveImage Method (String)

Chart.SaveImage Method (String) |
 | See Also

Saves the chart image to the specified file. The properties ImageType, Compression and other Chart control properties are used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageFileName As String _
)
public void SaveImage (
    string imageFileName
)
public:
void SaveImage (
    String^ imageFileName
)
public void SaveImage (
    String imageFileName
)
public function SaveImage (
    imageFileName : String
)

Parameters

imageFileName

The image file name.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveImage Method (Stream, ChartImageFormat)

Chart.SaveImage Method (Stream, ChartImageFormat) |
 | See Also

Saves the chart image to the specified stream.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageStream As Stream, _
    format As ChartImageFormat _
)
public void SaveImage (
    Stream imageStream,
    ChartImageFormat format
)
public:
void SaveImage (
    Stream^ imageStream,
    ChartImageFormat format
)
public void SaveImage (
    Stream imageStream,
    ChartImageFormat format
)
public function SaveImage (
    imageStream : Stream,
    format : ChartImageFormat
)

Parameters

imageStream

The image stream.

format

The chart image format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveImage Method (String, ChartImageFormat)

Chart.SaveImage Method (String, ChartImageFormat) |
 | See Also

Saves a chart image to the file.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageFileName As String, _
    format As ChartImageFormat _
)
public void SaveImage (
    string imageFileName,
    ChartImageFormat format
)
public:
void SaveImage (
    String^ imageFileName,
    ChartImageFormat format
)
public void SaveImage (
    String imageFileName,
    ChartImageFormat format
)
public function SaveImage (
    imageFileName : String,
    format : ChartImageFormat
)

Parameters

imageFileName

The image file name.

format

The chart image format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveViewState Method

Chart.SaveViewState Method |
 | See Also

Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Function SaveViewState As Object
protected override Object SaveViewState ()
protected:
virtual Object^ SaveViewState () override
protected Object SaveViewState ()
protected override function SaveViewState () : Object

Return Value

An Object that represents the current view state for the server control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SaveXml Method

Chart.SaveXml Method |
 | See Also

Saves the current state of the chart to an XML file. This method is mainly used for support purposes. The executing thread must have file write permission.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SaveXml ( _
    name As String _
)
public void SaveXml (
    string name
)
public:
void SaveXml (
    String^ name
)
public void SaveXml (
    String name
)
public function SaveXml (
    name : String
)

Parameters

name

The file name to save.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent Method

Chart.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent Method |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Private Sub System.Web.UI.IPostBackEventHandler.RaisePostBackEvent ( _
    eventArgument As String _
) Implements IPostBackEventHandler.RaisePostBackEvent
void IPostBackEventHandler.RaisePostBackEvent (
    string eventArgument
)
private:
virtual void System.Web.UI.IPostBackEventHandler.RaisePostBackEvent (
    String^ eventArgument
) sealed = IPostBackEventHandler::RaisePostBackEvent
J# supports the use of explicit interface implementations, but not the declaration of new ones.
JScript supports the use of explicit interface implementations, but not the declarations of new ones.

Parameters

eventArgument

The event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ValidateDataSource Method

Chart.ValidateDataSource Method |
 | See Also

Verifies that a data-bound control can work with the object it will bind to.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub ValidateDataSource ( _
    dataSource As Object _
)
protected override void ValidateDataSource (
    Object dataSource
)
protected:
virtual void ValidateDataSource (
    Object^ dataSource
) override
protected void ValidateDataSource (
    Object dataSource
)
protected override function ValidateDataSource (
    dataSource : Object
)

Parameters

dataSource

The object to verify.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart Properties

Chart Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
AccessKey | (inherited from WebControl )
AlternateText | Gets or sets the alternate text displayed in the Chart control when the chart image is unavailable.
Annotations | Stores the chart annotations.
AntiAliasing | Gets or sets a value that determines whether anti-aliasing is used when text and graphics are drawn.
AppRelativeTemplateSourceDirectory | (inherited from Control )
Attributes | (inherited from WebControl )
BackColor | Overridden. Gets or sets the background color of the Chart object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a Chart control. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of the Chart control.
BackImage | Gets or sets the background image of the Chart control.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets the color of the Chart control that will be displayed as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the Chart control.
BackSecondaryColor | Gets or sets the secondary color of the chart background.
BindingContainer | (inherited from Control )
BorderColor | Overridden. For internal use only.
BorderlineColor | Gets or sets the color of the entire chart image border.
BorderlineDashStyle | Gets or sets the style of the entire chart image border line.
BorderlineWidth | Gets or sets the width of the border line for the entire chart image.
BorderSkin | Gets or sets a BorderSkin object, which provides border skin functionality for the Chart control.
BorderStyle | Overridden. Gets or sets the border style of the Chart.
BorderWidth | Overridden. For internal use only.
BuildNumber | Gets the build number of the Chart control. This property is for internal use only.
ChartAreas | Gets a read-only ChartAreaCollection object that is used to store ChartArea objects.
ClientID | (inherited from Control )
Compression | Gets or sets the amount of compression for the chart image.
Controls | (inherited from Control )
ControlStyle | (inherited from WebControl )
ControlStyleCreated | (inherited from WebControl )
CssClass | (inherited from WebControl )
CurrentImageLocation | Gets the URL of the current image into which the Chart control will be rendered.
DataManipulator | Gets a DataManipulator object, which provides methods and properties that handle data.
DataMember | (inherited from DataBoundControl )
DataSource | Overridden. Gets or sets the data source for the Chart object.
DataSourceID | (inherited from DataBoundControl )
DescriptionUrl | Gets or sets the location of a detailed description of the Chart.
Enabled | (inherited from WebControl )
EnableTheming | (inherited from WebControl )
EnableViewState | Overridden. Gets or sets a flag that determines whether state management is enabled.
Font | Overridden. For internal use only.
ForeColor | Overridden. Gets or sets the text color of the Chart control.
HasAttributes | (inherited from WebControl )
Height | Overridden. Gets or sets the height of the entire chart image in pixels.
ID | (inherited from Control )
ImageLocation | Gets or sets the location where an image file is saved when ImageTag rendering is performed.
Images | Gets a NamedImagesCollection object, which stores NamedImage objects for the chart.
ImageStorageMode | Gets or sets the chart rendering type.
ImageType | Gets or sets the type of image into which the chart is rendered if ImageTag rendering is used.
IsMapAreaAttributesEncoded | Gets or sets a flag that determines whether map area attributes are encoded.
IsMapEnabled | Gets or sets a flag that determines whether client-side image maps are enabled.
IsSoftShadows | Gets or sets a flag that determines if a smooth gradient is applied when shadows are drawn.
Legends | Stores all Legend objects used by the Chart control.
MapAreas | Gets a MapAreasCollection object, which stores the map areas for the chart.
NamingContainer | (inherited from Control )
Page | (inherited from Control )
Palette | Gets or sets the palette for the Chart control.
PaletteCustomColors | Gets or sets an array of custom palette colors.
Parent | (inherited from Control )
RenderType | Gets or sets the rendering method used to display a chart image.
RightToLeft | Gets or sets a value that indicates whether the control should draw right-to-left for Right-to-Left (RTL) languages.
Serializer | Gets a ChartSerializer object, which is used for chart serialization.
Series | Gets a SeriesCollection object.
Site | (inherited from Control )
SkinID | (inherited from WebControl )
Style | (inherited from WebControl )
SuppressExceptions | Gets or sets a flag that determines whether noncritical exceptions should be suppressed.
TabIndex | (inherited from WebControl )
TemplateControl | (inherited from Control )
TemplateSourceDirectory | (inherited from Control )
TextAntiAliasingQuality | Gets or sets the TextAntiAliasingQuality type to use when applying anti-aliasing to text.
Titles | Stores all Title objects used by the Chart control.
ToolTip | (inherited from WebControl )
UniqueID | (inherited from Control )
ViewStateContent | Gets or sets a value that determines the view state to be persisted at the client.
ViewStateData | Gets or sets the user-defined view state of the control.
Visible | (inherited from Control )
Width | Overridden. Gets or sets the width of the entire chart image in pixels.

Protected Properties

Name | Description
Adapter | (inherited from Control )
ChildControlsCreated | (inherited from Control )
ClientIDSeparator | (inherited from Control )
Context | (inherited from Control )
DesignMode | (inherited from Control )
Events | (inherited from Control )
HasChildViewState | (inherited from Control )
IdSeparator | (inherited from Control )
Initialized | (inherited from BaseDataBoundControl )
IsBoundUsingDataSourceID | (inherited from BaseDataBoundControl )
IsChildControlStateCleared | (inherited from Control )
IsEnabled | (inherited from WebControl )
IsTrackingViewState | (inherited from Control )
IsViewStateEnabled | (inherited from Control )
LoadViewStateByID | (inherited from Control )
RequiresDataBinding | (inherited from BaseDataBoundControl )
SelectArguments | (inherited from DataBoundControl )
TagKey | (inherited from WebControl )
TagName | (inherited from WebControl )
ViewState | (inherited from Control )
ViewStateIgnoresCase | (inherited from Control )

Explicit Interface Implementations

Name | Description
System.Web.UI.IControlBuilderAccessor.ControlBuilder | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.UserData | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.DataBindings | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.HasDataBindings | (inherited from Control )
System.Web.UI.IExpressionsAccessor.Expressions | (inherited from Control )
System.Web.UI.IExpressionsAccessor.HasExpressions | (inherited from Control )

See Also

Reference

Chart Class
System.Web.UI.DataVisualization.Charting Namespace


Chart.AlternateText Property

Chart.AlternateText Property |
 | See Also

Gets or sets the alternate text displayed in the Chart control when the chart image is unavailable.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<LocalizableAttribute(True)> _
Public Property AlternateText As String
[LocalizableAttribute(true)]
public string AlternateText { get; set; }
[LocalizableAttribute(true)]
public:
property String^ AlternateText {
    String^ get ();
    void set (String^ value);
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public String get_AlternateText ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public void set_AlternateText (String value)

CompilerGeneratedAttribute
public function get AlternateText () : String

CompilerGeneratedAttribute
public function set AlternateText (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Annotations Property

Chart.Annotations Property |
 | See Also

Stores the chart annotations.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Annotations As AnnotationCollection
public AnnotationCollection Annotations { get; }
public:
property AnnotationCollection^ Annotations {
    AnnotationCollection^ get ();
}
/** @property */
public AnnotationCollection get_Annotations ()

public function get Annotations () : AnnotationCollection

Property Value

An AnnotationCollection object that is used to store chart annotations.

Remarks

All of the chart annotations are stored in this collection property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.AntiAliasing Property

Chart.AntiAliasing Property |
 | See Also

Gets or sets a value that determines whether anti-aliasing is used when text and graphics are drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property AntiAliasing As AntiAliasingStyles
public AntiAliasingStyles AntiAliasing { get; set; }
public:
property AntiAliasingStyles AntiAliasing {
    AntiAliasingStyles get ();
    void set (AntiAliasingStyles value);
}
/** @property */
public AntiAliasingStyles get_AntiAliasing ()

/** @property */
public void set_AntiAliasing (AntiAliasingStyles value)

public function get AntiAliasing () : AntiAliasingStyles

public function set AntiAliasing (value : AntiAliasingStyles)

Property Value

An AntiAliasingStyles enumeration value.

Remarks

Anti-aliasing smoothens out "jagged edges" by padding pixels with intermediate colors, and is especially effective for smoothing out edges for charts that are not drawn as rectangles. For example, anti-aliasing is very effective for line charts and pie charts, but is not as effective for bar and column charts.

Anti-aliasing can be applied to text and/or graphics primitives such as rectangles, circles, and so forth.

Note that anti-aliasing will affect performance.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackColor Property

Chart.BackColor Property |
 | See Also

Gets or sets the background color of the Chart object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property BackColor As Color
public override Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value. The default color is System.Drawing.Color.White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value. Note that for the Chart object, the alpha component cannot be set to a value other than 255. This also means that, for the Chart object only, a Transparent value cannot be used.

The BackColor value will be the first color used if you are using gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the title. As a result, the background will be transparent.

The following table represents the Series types that support gradients:

Series Types | 2D | 3D
Bar | X | -
Box Plot | X | X
Bubble | - | -
Candle Stick | X | X
Column | X | X
Doughnut | X | -
Error Bar | - | -
Fast Line | - | -
Fast Point | - | -
Funnel | X | X
Gantt | X | -
Kagi | - | -
Line | - | -
Pie | X | -
Point | - | -
Point and Figure | X | -
Polar | - | -
Pyramid | X | X
Radar | X | X
Range Column | X | -
Renko | X | -
Spline | - | -
Spline Area Area | X | -
Spline Range | X | -
Stacked Area | X | -
Stacked Area 100 | X | -
Stacked Bar | X | -
Stacked Bar 100 | X | -
Stacked Column | X | -
Stacked Column 100 | X | -
Step Line | - | -
Stock | - | -
Three Line Break | X | -

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackGradientStyle Property

Chart.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a Chart control. Also determines whether a gradient is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a Chart control will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

Set the primary color of the chart background with the BackColor property.

Set the secondary color of the chart background with the BackSecondaryColor property.

Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackHatchStyle Property

Chart.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackImage Property

Chart.BackImage Property |
 | See Also

Gets or sets the background image of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default value is an empty string.

Remarks

This property defines a path to a background image for a Chart legend, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image can originate from any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackImageAlignment Property

Chart.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment used for the Unscaled drawing mode.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for the Chart control; it is only applied when the BackImageWrapMode property is set to Unscaled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackImageTransparentColor Property

Chart.BackImageTransparentColor Property |
 | See Also

Gets or sets the color of the Chart control that will be displayed as transparent.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent when the chart image is drawn. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackImageWrapMode Property

Chart.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

This property determines how the image is displayed, for example, tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the chart. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the chart.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BackSecondaryColor Property

Chart.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the chart background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value. The default value is Empty.

Remarks

The BackSecondaryColor property determines the secondary background color of many Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the chart.

To use gradient colors for the background of a chart:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderColor Property

Chart.BorderColor Property |
 | See Also

For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BorderColor As Color
[BrowsableAttribute(false)]
public override Color BorderColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BorderColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public override function get BorderColor () : Color

public override function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value.

Remarks

This property is for internal use only. Use BorderlineColor instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderlineColor Property

Chart.BorderlineColor Property |
 | See Also

Gets or sets the color of the entire chart image border.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderlineColor As Color
public Color BorderlineColor { get; set; }
public:
property Color BorderlineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderlineColor ()

/** @property */
public void set_BorderlineColor (Color value)

public function get BorderlineColor () : Color

public function set BorderlineColor (value : Color)

Property Value

A Color enumeration value. The default value is Empty.

Remarks

You can set this property to any valid ARGB value (alpha, red, green, blue value).

This property is similar to the BorderColor property, the only difference being that the BorderColor property is not available from the Properties Window at design time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderlineDashStyle Property

Chart.BorderlineDashStyle Property |
 | See Also

Gets or sets the style of the entire chart image border line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderlineDashStyle As ChartDashStyle
public ChartDashStyle BorderlineDashStyle { get; set; }
public:
property ChartDashStyle BorderlineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderlineDashStyle ()

/** @property */
public void set_BorderlineDashStyle (ChartDashStyle value)

public function get BorderlineDashStyle () : ChartDashStyle

public function set BorderlineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border line style of the chart image.

Remarks

This property determines the line style used for the chart image border line. The line can be solid, dotted, and so forth

For further style options, see the ChartDashStyle enumeration topic.

This property is similar to the BorderStyle property, the only difference being that the BorderStyle property is not available from the Properties Window at design time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderlineWidth Property

Chart.BorderlineWidth Property |
 | See Also

Gets or sets the width of the border line for the entire chart image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderlineWidth As Integer
public int BorderlineWidth { get; set; }
public:
property int BorderlineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderlineWidth ()

/** @property */
public void set_BorderlineWidth (int value)

public function get BorderlineWidth () : int

public function set BorderlineWidth (value : int)

Property Value

An integer value that determines the width of the chart image border line, in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderSkin Property

Chart.BorderSkin Property |
 | See Also

Gets or sets a BorderSkin object, which provides border skin functionality for the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property BorderSkin As BorderSkin
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public BorderSkin BorderSkin { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property BorderSkin^ BorderSkin {
    BorderSkin^ get ();
    void set (BorderSkin^ value);
}
/** @property */
public BorderSkin get_BorderSkin ()

/** @property */
public void set_BorderSkin (BorderSkin value)

public function get BorderSkin () : BorderSkin

public function set BorderSkin (value : BorderSkin)

Property Value

A BorderSkin object.

Remarks

Use this property to specify a border skin for the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderStyle Property

Chart.BorderStyle Property |
 | See Also

Gets or sets the border style of the Chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BorderStyle As BorderStyle
[BrowsableAttribute(false)]
public override BorderStyle BorderStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property BorderStyle BorderStyle {
    BorderStyle get () override;
    void set (BorderStyle value) override;
}
/** @property */
public BorderStyle get_BorderStyle ()

/** @property */
public void set_BorderStyle (BorderStyle value)

public override function get BorderStyle () : BorderStyle

public override function set BorderStyle (value : BorderStyle)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BorderWidth Property

Chart.BorderWidth Property |
 | See Also

For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BorderWidth As Unit
[BrowsableAttribute(false)]
public override Unit BorderWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Unit BorderWidth {
    Unit get () override;
    void set (Unit value) override;
}
/** @property */
public Unit get_BorderWidth ()

/** @property */
public void set_BorderWidth (Unit value)

public override function get BorderWidth () : Unit

public override function set BorderWidth (value : Unit)

Property Value

An integer value that determines the border width, in pixels, of the chart.

Remarks

This property is for internal use only. Use BorderlineWidth instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.BuildNumber Property

Chart.BuildNumber Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the build number of the Chart control. This property is for internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property BuildNumber As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string BuildNumber { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property String^ BuildNumber {
    String^ get ();
}
/** @property */
public String get_BuildNumber ()

public function get BuildNumber () : String

Remarks

This property is for internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ChartAreas Property

Chart.ChartAreas Property |
 | See Also

Gets a read-only ChartAreaCollection object that is used to store ChartArea objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ChartAreas As ChartAreaCollection
public ChartAreaCollection ChartAreas { get; }
public:
property ChartAreaCollection^ ChartAreas {
    ChartAreaCollection^ get ();
}
/** @property */
public ChartAreaCollection get_ChartAreas ()

public function get ChartAreas () : ChartAreaCollection

Property Value

A ChartAreaCollection object.

Remarks

This collection property lets you access the ChartAreaCollection object, which stores ChartArea objects and also provides methods and properties used to manipulate the collection.

ChartArea objects are used to plot one or more charts.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Compression Property

Chart.Compression Property |
 | See Also

Gets or sets the amount of compression for the chart image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Compression As Integer
public int Compression { get; set; }
public:
property int Compression {
    int get ();
    void set (int value);
}
/** @property */
public int get_Compression ()

/** @property */
public void set_Compression (int value)

public function get Compression () : int

public function set Compression (value : int)

Property Value

An integer that represents the amount of compression for the entire chart image.

Remarks

Compression is expressed as a percentage; for example, to use 50% compression, set this property to 50.

Compression is used for all rendering methods, as determined by the RenderType property, but only for JPEG images, which are specified by the Jpeg enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.CurrentImageLocation Property

Chart.CurrentImageLocation Property |
 | See Also

Gets the URL of the current image into which the Chart control will be rendered.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property CurrentImageLocation As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string CurrentImageLocation { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property String^ CurrentImageLocation {
    String^ get ();
}
/** @property */
public String get_CurrentImageLocation ()

public function get CurrentImageLocation () : String

Property Value

A string value that represents the URL of the current chart image.

Remarks

This property has no effect if ImageStorageMode is set to UseHttpHandler.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataManipulator Property

Chart.DataManipulator Property |
 | See Also

Gets a DataManipulator object, which provides methods and properties that handle data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property DataManipulator As DataManipulator
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public DataManipulator DataManipulator { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property DataManipulator^ DataManipulator {
    DataManipulator^ get ();
}
/** @property */
public DataManipulator get_DataManipulator ()

public function get DataManipulator () : DataManipulator

Property Value

A DataManipulator object.

Remarks

Use this property at run-time to:

  • Copy Y-values.

  • Filter data.

  • Group data.

  • Replace missing data with empty points.

  • Export data to a DataSet object.

  • Sort data.

  • Apply a financial formula to data.

Refer to the DataManipulator class overview for further details.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DataSource Property

Chart.DataSource Property |
 | See Also

Gets or sets the data source for the Chart object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property DataSource As Object
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override Object DataSource { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Object^ DataSource {
    Object^ get () override;
    void set (Object^ value) override;
}
/** @property */
public Object get_DataSource ()

/** @property */
public void set_DataSource (Object value)

public override function get DataSource () : Object

public override function set DataSource (value : Object)

Property Value

An Object that represents the data source for the Chart object.

Remarks

The data points in a series can be bound to a data source at any time using the DataSource property.

To force the chart to bind to the data source, call the DataBind method.

The following is a list of objects that you can use as the data source:

  • DataView

  • Data readers (SQL, OleDB)

  • DataSet

  • DataTable

  • Binding Source

  • IDataSource

  • Arrays

  • Lists

  • All Enumerable objects

  • SqlCommand / OleDbCommand (DataSource data-binding only)

  • SqlDataAdapter / OleDbDataAdapter (DataSource data-binding only)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.DescriptionUrl Property

Chart.DescriptionUrl Property |
 | See Also

Gets or sets the location of a detailed description of the Chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<UrlPropertyAttribute> _
<LocalizableAttribute(True)> _
Public Property DescriptionUrl As String
[UrlPropertyAttribute]
[LocalizableAttribute(true)]
public string DescriptionUrl { get; set; }
[UrlPropertyAttribute]
[LocalizableAttribute(true)]
public:
property String^ DescriptionUrl {
    String^ get ();
    void set (String^ value);
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public String get_DescriptionUrl ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public void set_DescriptionUrl (String value)

CompilerGeneratedAttribute
public function get DescriptionUrl () : String

CompilerGeneratedAttribute
public function set DescriptionUrl (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.EnableViewState Property

Chart.EnableViewState Property |
 | See Also

Gets or sets a flag that determines whether state management is enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property EnableViewState As Boolean
public override bool EnableViewState { get; set; }
public:
virtual property bool EnableViewState {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_EnableViewState ()

/** @property */
public void set_EnableViewState (boolean value)

public override function get EnableViewState () : boolean

public override function set EnableViewState (value : boolean)

Property Value

True if state management is enabled, otherwise false. The default value is false.

Remarks

Set this property to true to enable state management for the Chart control.

The view state that is saved is determined by either the ViewStateContent or ViewStateData properties.

Note:
This property must be set prior to the Page_Load (the Page_Init or the constructor will work) or it will have no effect.

For more information consult the Visual Studio documentation that discusses view state or state management.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Font Property

Chart.Font Property |
 | See Also

For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property Font As FontInfo
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override FontInfo Font { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property FontInfo^ Font {
    FontInfo^ get () override;
}
/** @property */
public FontInfo get_Font ()

public override function get Font () : FontInfo

Property Value

A Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ForeColor Property

Chart.ForeColor Property |
 | See Also

Gets or sets the text color of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to this class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Height Property

Chart.Height Property |
 | See Also

Gets or sets the height of the entire chart image in pixels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Height As Unit
public override Unit Height { get; set; }
public:
virtual property Unit Height {
    Unit get () override;
    void set (Unit value) override;
}
/** @property */
public Unit get_Height ()

/** @property */
public void set_Height (Unit value)

public override function get Height () : Unit

public override function set Height (value : Unit)

Property Value

A Unit value that represents the height, in pixels, of the entire chart image.

Remarks

Do not specify the value in percentage (%) or point (pt). Otherwise, an exception is thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ImageLocation Property

Chart.ImageLocation Property |
 | See Also

Gets or sets the location where an image file is saved when ImageTag rendering is performed.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageLocation As String
public string ImageLocation { get; set; }
public:
property String^ ImageLocation {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ImageLocation ()

/** @property */
public void set_ImageLocation (String value)

public function get ImageLocation () : String

public function set ImageLocation (value : String)

Property Value

A string value that represents the URL where the image file is saved on the server.

Remarks

This property has no effect if ImageStorageMode is set to UseHttpHandler.

When you render a chart image using the image tag method, a chart image is generated and then saved to disk at the server, in a format that is determined by the ChartImageType property.

The URL where the image file is saved can be either absolute or relative; the file extension that the image file has is determined by the ChartImageType property.

The image file can be hard-coded to always be one filename, or you can use the "#" sign to use either user identifiers (UIDs) or a specified number of uniquely named files, which is known as a Round Robin.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Images Property

Chart.Images Property |
 | See Also

Gets a NamedImagesCollection object, which stores NamedImage objects for the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Images As NamedImagesCollection
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public NamedImagesCollection Images { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property NamedImagesCollection^ Images {
    NamedImagesCollection^ get ();
}
/** @property */
public NamedImagesCollection get_Images ()

public function get Images () : NamedImagesCollection

Property Value

A NamedImagesCollection object.

Remarks

Use this property to add NamedImage objects to and remove NamedImage objects from the NamedImagesCollection object of the Chart. This collection property is available at run time only.

An image—that is, an object derived from type Image, such as Bitmap, that is created dynamically—can be stored in this collection, and then assigned at a later time to any image-related Chart property, such as BackImage.

When you assign a NamedImage object to an image-related property in the Chart class, use the name of the NamedImage object for the string value of the image-related property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ImageStorageMode Property

Chart.ImageStorageMode Property |
 | See Also

Gets or sets the chart rendering type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageStorageMode As ImageStorageMode
public ImageStorageMode ImageStorageMode { get; set; }
public:
property ImageStorageMode ImageStorageMode {
    ImageStorageMode get ();
    void set (ImageStorageMode value);
}
/** @property */
public ImageStorageMode get_ImageStorageMode ()

/** @property */
public void set_ImageStorageMode (ImageStorageMode value)

public function get ImageStorageMode () : ImageStorageMode

public function set ImageStorageMode (value : ImageStorageMode)

Property Value

An ImageStorageMode enumeration value.

Remarks

This property defines the type of storage used to render chart images. See ImageStorageMode for options.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ImageType Property

Chart.ImageType Property |
 | See Also

Gets or sets the type of image into which the chart is rendered if ImageTag rendering is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageType As ChartImageType
public ChartImageType ImageType { get; set; }
public:
property ChartImageType ImageType {
    ChartImageType get ();
    void set (ChartImageType value);
}
/** @property */
public ChartImageType get_ImageType ()

/** @property */
public void set_ImageType (ChartImageType value)

public function get ImageType () : ChartImageType

public function set ImageType (value : ChartImageType)

Property Value

A ChartImageType enumeration value. The default value is Jpeg.

Remarks

This property determines the type of image file that is used for rendering.

Possible file formats are Bmp, :System.Web.UI.DataVisualization.Charting.ChartImageType.Emf, Jpeg, and Png.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.IsMapAreaAttributesEncoded Property

Chart.IsMapAreaAttributesEncoded Property |
 | See Also

Gets or sets a flag that determines whether map area attributes are encoded.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsMapAreaAttributesEncoded As Boolean
public bool IsMapAreaAttributesEncoded { get; set; }
public:
property bool IsMapAreaAttributesEncoded {
    bool get ();
    void set (bool value);
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public boolean get_IsMapAreaAttributesEncoded ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public void set_IsMapAreaAttributesEncoded (boolean value)

CompilerGeneratedAttribute
public function get IsMapAreaAttributesEncoded () : boolean

CompilerGeneratedAttribute
public function set IsMapAreaAttributesEncoded (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.IsMapEnabled Property

Chart.IsMapEnabled Property |
 | See Also

Gets or sets a flag that determines whether client-side image maps are enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsMapEnabled As Boolean
public bool IsMapEnabled { get; set; }
public:
property bool IsMapEnabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMapEnabled ()

/** @property */
public void set_IsMapEnabled (boolean value)

public function get IsMapEnabled () : boolean

public function set IsMapEnabled (value : boolean)

Property Value

True if image maps are enabled, otherwise false. The default value is true.

Remarks

Setting this property to false will disable image maps. This will occur even under the following circumstances:

  • The Url, MapAreaAttributes, LabelMapAreaAttributes, LegendMapAreaAttributes or ToolTip property of a chart element is set.

  • A MapArea object has been added to the MapAreasCollection object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.IsSoftShadows Property

Chart.IsSoftShadows Property |
 | See Also

Gets or sets a flag that determines if a smooth gradient is applied when shadows are drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsSoftShadows As Boolean
public bool IsSoftShadows { get; set; }
public:
property bool IsSoftShadows {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSoftShadows ()

/** @property */
public void set_IsSoftShadows (boolean value)

public function get IsSoftShadows () : boolean

public function set IsSoftShadows (value : boolean)

Property Value

True if shadows are drawn using smoothing, false if they are not. The default value is true.

Remarks

If the value of the ShadowOffset property for a series, data point, chart area or legend is nonzero, a shadow will be applied using a color set by their ShadowColor property.

If the value of the IsSoftShadows property is true, a smooth gradient will be applied to the shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Legends Property

Chart.Legends Property |
 | See Also

Stores all Legend objects used by the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Legends As LegendCollection
public LegendCollection Legends { get; }
public:
property LegendCollection^ Legends {
    LegendCollection^ get ();
}
/** @property */
public LegendCollection get_Legends ()

public function get Legends () : LegendCollection

Property Value

A LegendCollection object.

Remarks

This collection property stores all Legend objects used by the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.MapAreas Property

Chart.MapAreas Property |
 | See Also

Gets a MapAreasCollection object, which stores the map areas for the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property MapAreas As MapAreasCollection
public MapAreasCollection MapAreas { get; }
public:
property MapAreasCollection^ MapAreas {
    MapAreasCollection^ get ();
}
/** @property */
public MapAreasCollection get_MapAreas ()

public function get MapAreas () : MapAreasCollection

Property Value

A MapAreasCollection object.

Remarks

Use this property at either design time or run time to add custom map areas to the chart. Custom map areas, unlike map areas that correspond to a chart element, have a user-defined shape and coordinates.

In order to use the chart as an image map, the IsMapEnabled property of the root Chart must be set to true, which is the default.

If you render the chart as a binary stream, a special technique must be used to implement client-side image maps.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Palette Property

Chart.Palette Property |
 | See Also

Gets or sets the palette for the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Palette As ChartColorPalette
public ChartColorPalette Palette { get; set; }
public:
property ChartColorPalette Palette {
    ChartColorPalette get ();
    void set (ChartColorPalette value);
}
/** @property */
public ChartColorPalette get_Palette ()

/** @property */
public void set_Palette (ChartColorPalette value)

public function get Palette () : ChartColorPalette

public function set Palette (value : ChartColorPalette)

Property Value

A ChartColorPalette enumeration value that determines the palette to be used.

Remarks

A palette is used to automatically assign colors to data elements if both of the following conditions have been met:

  • the data points themselves do not have colors assigned to them.

  • the data series that the data points belong to also does not have an assigned color.

If no series or data point colors are explicitly specified, the colors used depend on the chart type and the Chart object's palette or the palette of an associated series, if one is specified.

Note:
If the Palette property for both the Chart and Series objects is set to None, and no color is assigned to the relevant data series or data points, the data points will not be drawn, and will be displayed as "empty" areas.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.PaletteCustomColors Property

Chart.PaletteCustomColors Property |
 | See Also

Gets or sets an array of custom palette colors.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PaletteCustomColors As Color()
public Color[] PaletteCustomColors { get; set; }
public:
property array<Color>^ PaletteCustomColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}
/** @property */
public Color[] get_PaletteCustomColors ()

/** @property */
public void set_PaletteCustomColors (Color[] value)

public function get PaletteCustomColors () : Color[]

public function set PaletteCustomColors (value : Color[])

Property Value

An array of Color objects that represent the set of colors used for series on the chart.

Remarks

If you need more than 16 colors or you want to apply your own colors to the chart, you must define a custom palette. A custom palette let you add your own colors in the order you want them to appear on the chart. This type of palette is especially helpful if the number of series in your chart is unknown at design time.

This property has no effect when the Palette property is not set to System.Web.UI.DataVisualization.Charting.ChartColorPalette.None.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.RenderType Property

Chart.RenderType Property |
 | See Also

Gets or sets the rendering method used to display a chart image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property RenderType As RenderType
public RenderType RenderType { get; set; }
public:
property RenderType RenderType {
    RenderType get ();
    void set (RenderType value);
}
/** @property */
public RenderType get_RenderType ()

/** @property */
public void set_RenderType (RenderType value)

public function get RenderType () : RenderType

public function set RenderType (value : RenderType)

Property Value

A RenderType enumeration value.

Remarks

The following list describes the three ways in which a chart image can be rendered:

  • The ImageTag render type causes a temporary file to be saved to disk at the server. The chart is displayed at the client side using an <IMG> tag, with its SRC attribute set to the URL specified by the ImageLocation property.

  • If the BinaryStreaming render type is specified, there are no temporary image files at the server. Instead, the chart image is sent as a binary stream, and is displayed using an <IMG> tag with its SRC attribute set to another .aspx page that is responsible for generating the chart image.

  • A render type of ImageMap causes an image map to be created, but does not result in the display of an actual chart image. This option should only be taken when using an image map that has a render type of BinaryStreaming.

Note that you can control how temporary image files are saved to disk using the ImageLocation property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.RightToLeft Property

Chart.RightToLeft Property |
 | See Also

Gets or sets a value that indicates whether the control should draw right-to-left for Right-to-Left (RTL) languages.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<CategoryAttribute("Appearance")> _
Public Property RightToLeft As RightToLeft
[CategoryAttribute("Appearance")]
public RightToLeft RightToLeft { get; set; }
[CategoryAttribute(L"Appearance")]
public:
property RightToLeft RightToLeft {
    RightToLeft get ();
    void set (RightToLeft value);
}
/** @property */
public RightToLeft get_RightToLeft ()

/** @property */
public void set_RightToLeft (RightToLeft value)

public function get RightToLeft () : RightToLeft

public function set RightToLeft (value : RightToLeft)

Property Value

A RightToLeft enumeration value. The default value is No.

Remarks

This property affects the direction of legend color keys.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Serializer Property

Chart.Serializer Property |
 | See Also

Gets a ChartSerializer object, which is used for chart serialization.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Serializer As ChartSerializer
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ChartSerializer Serializer { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property ChartSerializer^ Serializer {
    ChartSerializer^ get ();
}
/** @property */
public ChartSerializer get_Serializer ()

public function get Serializer () : ChartSerializer

Property Value

A ChartSerializer object.

Remarks

Use this property at either design time or run time to serialize the chart.

For a detailed discussion of the ChartSerializer class, refer to the class overview.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Series Property

Chart.Series Property |
 | See Also

Gets a SeriesCollection object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Series As SeriesCollection
public SeriesCollection Series { get; }
public:
property SeriesCollection^ Series {
    SeriesCollection^ get ();
}
/** @property */
public SeriesCollection get_Series ()

public function get Series () : SeriesCollection

Property Value

A SeriesCollection object, which contains Series objects.

Remarks

This collection property allows you to access the SeriesCollection class, which stores Series objects and also provides methods and properties used to manipulate this collection.

Series objects store DataPoint objects, as well as data attributes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.SuppressExceptions Property

Chart.SuppressExceptions Property |
 | See Also

Gets or sets a flag that determines whether noncritical exceptions should be suppressed.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SuppressExceptions As Boolean
public bool SuppressExceptions { get; set; }
public:
property bool SuppressExceptions {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_SuppressExceptions ()

/** @property */
public void set_SuppressExceptions (boolean value)

public function get SuppressExceptions () : boolean

public function set SuppressExceptions (value : boolean)

Property Value

True if non-critical exceptions should be suppressed, otherwise false. The default value is false.

Remarks

If you set this property to true, non-critical exceptions will be suppressed.

When the Chart control cannot properly plot the chart using the data and other settings provided, an exception will be thrown. Although displaying exceptions is useful during application testing, they should not be shown when the application is released.

Note:
Setting this property to true may hide serious issues in the user application source code. This setting could also cause a chart image to be generated that might misrepresent your data. It is highly recommended that this mode be only used in Release builds.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.TextAntiAliasingQuality Property

Chart.TextAntiAliasingQuality Property |
 | See Also

Gets or sets the TextAntiAliasingQuality type to use when applying anti-aliasing to text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextAntiAliasingQuality As TextAntiAliasingQuality
public TextAntiAliasingQuality TextAntiAliasingQuality { get; set; }
public:
property TextAntiAliasingQuality TextAntiAliasingQuality {
    TextAntiAliasingQuality get ();
    void set (TextAntiAliasingQuality value);
}
/** @property */
public TextAntiAliasingQuality get_TextAntiAliasingQuality ()

/** @property */
public void set_TextAntiAliasingQuality (TextAntiAliasingQuality value)

public function get TextAntiAliasingQuality () : TextAntiAliasingQuality

public function set TextAntiAliasingQuality (value : TextAntiAliasingQuality)

Property Value

A TextAntiAliasingQuality enumeration value. The default value is High.

Remarks

If the anti-aliasing is applied to text, the Chart control will use this property to determine the type of textual anti-aliasing to apply.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Titles Property

Chart.Titles Property |
 | See Also

Stores all Title objects used by the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Titles As TitleCollection
public TitleCollection Titles { get; }
public:
property TitleCollection^ Titles {
    TitleCollection^ get ();
}
/** @property */
public TitleCollection get_Titles ()

public function get Titles () : TitleCollection

Property Value

A TitleCollection object.

Remarks

The Titles property stores all Title objects used by the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ViewStateContent Property

Chart.ViewStateContent Property |
 | See Also

Gets or sets a value that determines the view state to be persisted at the client.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ViewStateContent As SerializationContents
public SerializationContents ViewStateContent { get; set; }
public:
property SerializationContents ViewStateContent {
    SerializationContents get ();
    void set (SerializationContents value);
}
/** @property */
public SerializationContents get_ViewStateContent ()

/** @property */
public void set_ViewStateContent (SerializationContents value)

public function get ViewStateContent () : SerializationContents

public function set ViewStateContent (value : SerializationContents)

Property Value

A SerializationContents enumeration value that represents the view state. The default value is Default, which signifies that the view state will consist of all chart properties.

Remarks

Use this property to set the view state of the Chart control.

When you set this property, the view state is automatically saved by the Chart control, and is also loaded automatically when a postback occurs.

For greater flexibility, use the ViewStateData property for user-defined view state.

To enable state management, set the EnableViewState property to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.ViewStateData Property

Chart.ViewStateData Property |
 | See Also

Gets or sets the user-defined view state of the control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property ViewStateData As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string ViewStateData { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property String^ ViewStateData {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ViewStateData ()

/** @property */
public void set_ViewStateData (String value)

public function get ViewStateData () : String

public function set ViewStateData (value : String)

Property Value

A string value that represents the view state of the control, which is embedded in the Web document at the client.

Remarks

When you specify data to persist at the client, this property provides greater flexibility compared with the ViewStateContent property.

When the user-defined view state is implemented, it is up to the developer to set the view state, and to utilize the view state when a postback occurs.

The Save and Load methods of the ChartSerializer object can optionally be used to set the view state, as well as to load the view state when a postback occurs. See the sample code below for an example of this.

For simplicity, when you specify the chart state to be saved, use the ViewStateContent property, which can be set to data, visual appearance properties or both.

To enable state management, set the EnableViewState property to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Width Property

Chart.Width Property |
 | See Also

Gets or sets the width of the entire chart image in pixels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Width As Unit
public override Unit Width { get; set; }
public:
virtual property Unit Width {
    Unit get () override;
    void set (Unit value) override;
}
/** @property */
public Unit get_Width ()

/** @property */
public void set_Width (Unit value)

public override function get Width () : Unit

public override function set Width (value : Unit)

Property Value

A Unit value that represents the width, in pixels, of the entire chart image.

Remarks

Do not specify the value in percentage (%) or point (pt). Otherwise, an exception is thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart Events

Chart Events |
 | See Also

Public Events

Name | Description
Click | Occurs when the active image map area defined by PostBackValue on the Chart control is clicked.
Customize | Occurs just before the chart image is drawn. All chart data is available and all chart properties have been set.
CustomizeLegend | Occurs just before the chart legend is drawn. Use this event to customize the chart legend items.
CustomizeMapAreas | Occurs just before the chart image map is rendered. Use this event to customize the map areas items.
DataBinding | (inherited from Control )
DataBound | (inherited from BaseDataBoundControl )
Disposed | (inherited from Control )
FormatNumber | Called when a numeric value has to be converted to a string.
Init | (inherited from Control )
Load | (inherited from Control )
PostPaint | Occurs after chart element was drawn. This event is raised for elements such as ChartArea and Legend.
PrePaint | Occurs after the chart element backround is drawn. This event is raised for elements such as ChartArea and Legend.
PreRender | (inherited from Control )
Unload | (inherited from Control )

See Also

Reference

Chart Class
System.Web.UI.DataVisualization.Charting Namespace


Chart.Click Event

Chart.Click Event |
 | See Also

Occurs when the active image map area defined by PostBackValue on the Chart control is clicked.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event Click As ImageMapEventHandler
public event ImageMapEventHandler Click
public:
event ImageMapEventHandler^ Click {
    void add (ImageMapEventHandler^ value);
    void remove (ImageMapEventHandler^ value);
}
/** @event */
public void add_Click (ImageMapEventHandler value)

/** @event */
public void remove_Click (ImageMapEventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.Customize Event

Chart.Customize Event |
 | See Also

Occurs just before the chart image is drawn. All chart data is available and all chart properties have been set.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event Customize As EventHandler
public event EventHandler Customize
public:
event EventHandler^ Customize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
/** @event */
public void add_Customize (EventHandler value)

/** @event */
public void remove_Customize (EventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Remarks

This event has two unique features:

  • All chart data is available; that is, the series and their data points are populated. This is especially useful if data-binding is being used, because the data can be examined and the chart can be adjusted just prior to being drawn.

  • All chart properties have been set, including those properties that have been set to "Auto". In other words, "Auto" properties now store the automatically calculated values, and can be examined and modified prior to the chart being drawn. Examples are the Minimum and Maximum properties of the Axis class.

Use this event to modify or customize the chart image before it is drawn.

When changes are made to a chart area, such as to the axis scale, the chart area properties must be recalculated in order to render the chart correctly. To recalculate the chart, call the RecalculateAxesScale method after making modifications.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.CustomizeLegend Event

Chart.CustomizeLegend Event |
 | See Also

Occurs just before the chart legend is drawn. Use this event to customize the chart legend items.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event CustomizeLegend As EventHandler(Of CustomizeLegendEventArgs)
public event EventHandler<CustomizeLegendEventArgs> CustomizeLegend
public:
event EventHandler<CustomizeLegendEventArgs^>^ CustomizeLegend {
    void add (EventHandler<CustomizeLegendEventArgs^>^ value);
    void remove (EventHandler<CustomizeLegendEventArgs^>^ value);
}
/** @event */
public void add_CustomizeLegend (EventHandler<CustomizeLegendEventArgs> value)

/** @event */
public void remove_CustomizeLegend (EventHandler<CustomizeLegendEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Remarks

The CustomizeLegend event is primarily used to customize the legend just before it is drawn. Both default and custom legend items can be removed or modified, and custom items can also be added. In addition, the order of legend items can be changed.

The chart image can also be modified before being drawn by using the sender argument.

Note that a default legend item is an item that is created for either a data series or data point, but a custom legend item is not connected in any way to the chart data.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.CustomizeMapAreas Event

Chart.CustomizeMapAreas Event |
 | See Also

Occurs just before the chart image map is rendered. Use this event to customize the map areas items.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event CustomizeMapAreas As EventHandler(Of CustomizeMapAreasEventArgs)
public event EventHandler<CustomizeMapAreasEventArgs> CustomizeMapAreas
public:
event EventHandler<CustomizeMapAreasEventArgs^>^ CustomizeMapAreas {
    void add (EventHandler<CustomizeMapAreasEventArgs^>^ value);
    void remove (EventHandler<CustomizeMapAreasEventArgs^>^ value);
}
/** @event */
public void add_CustomizeMapAreas (EventHandler<CustomizeMapAreasEventArgs> value)

/** @event */
public void remove_CustomizeMapAreas (EventHandler<CustomizeMapAreasEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Remarks

The MapAreaItems property of the CustomizeMapAreasEventArgs class can be used to:

  • Delete or modify map items that have automatically been created for a chart object; any data point, series, legend item or strip line object that has a non-empty Url, MapAreaAttributes or ToolTip property will have an associated map area object.

  • Add custom map areas that have a user-defined shape and coordinates.

Note:
The sender argument of type Chart is read-only.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.FormatNumber Event

Chart.FormatNumber Event |
 | See Also

Called when a numeric value has to be converted to a string.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event FormatNumber As EventHandler(Of FormatNumberEventArgs)
public event EventHandler<FormatNumberEventArgs> FormatNumber
public:
event EventHandler<FormatNumberEventArgs^>^ FormatNumber {
    void add (EventHandler<FormatNumberEventArgs^>^ value);
    void remove (EventHandler<FormatNumberEventArgs^>^ value);
}
/** @event */
public void add_FormatNumber (EventHandler<FormatNumberEventArgs> value)

/** @event */
public void remove_FormatNumber (EventHandler<FormatNumberEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.PostPaint Event

Chart.PostPaint Event |
 | See Also

Occurs after chart element was drawn. This event is raised for elements such as ChartArea and Legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event PostPaint As EventHandler(Of ChartPaintEventArgs)
public event EventHandler<ChartPaintEventArgs> PostPaint
public:
event EventHandler<ChartPaintEventArgs^>^ PostPaint {
    void add (EventHandler<ChartPaintEventArgs^>^ value);
    void remove (EventHandler<ChartPaintEventArgs^>^ value);
}
/** @event */
public void add_PostPaint (EventHandler<ChartPaintEventArgs> value)

/** @event */
public void remove_PostPaint (EventHandler<ChartPaintEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


Chart.PrePaint Event

Chart.PrePaint Event |
 | See Also

Occurs after the chart element backround is drawn. This event is raised for elements such as ChartArea and Legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Event PrePaint As EventHandler(Of ChartPaintEventArgs)
public event EventHandler<ChartPaintEventArgs> PrePaint
public:
event EventHandler<ChartPaintEventArgs^>^ PrePaint {
    void add (EventHandler<ChartPaintEventArgs^>^ value);
    void remove (EventHandler<ChartPaintEventArgs^>^ value);
}
/** @event */
public void add_PrePaint (EventHandler<ChartPaintEventArgs> value)

/** @event */
public void remove_PrePaint (EventHandler<ChartPaintEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Class

ChartArea Class |
 | See Also Members

Represents a chart area on the chart image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartArea
    Inherits ChartNamedElement
public class ChartArea : ChartNamedElement
public ref class ChartArea : public ChartNamedElement
public class ChartArea extends ChartNamedElement
public class ChartArea extends ChartNamedElement

Remarks

Within any given chart, the inner plot position is the rectangular area, inside the x and y-axis lines, where the data points are drawn. The plot position is the rectangular area that encompasses the inner plot position, the tick marks, and the axis labels. The chart area is the rectangular region that encompasses the plot position, the tick marks, the axis labels and the axis titles on the chart.

A chart area is represented by a ChartArea class; ChartArea objects are stored in the ChartAreaCollection class.

The number of chart series that can be plotted in a chart area is unlimited.

A ChartArea object:

  • Uses one distinct inner plotting region.

  • Is used to plot one or more chart series.

  • Has primary and secondary x and y-axes, except for pie and doughnut chart types.

When you use Shape chart types, which includes pie, doughnut, funnel, pyramid, polar, and radar charts, the inner plotting position defines the size of the chart type shape. For example, when you increase the value of the InnerPlotPosition property on a pie chart, you will increase the radius of the pie shape.

For all other chart types, each chart area has two sets of X- and Y-axes, primary and secondary. To access properties related to these axes, use the AxisX, AxisX2, AxisY and AxisY2 properties. If you need to set a property that affects all axes on the chart, use the Axes property.

One or more series are associated with a chart area. The series has a ChartArea property that determines the chart area that each series belongs to. By default, the series is connected to the default chart area. To disable the display of a series, set the ChartArea property of that series to a zero-length string.

If another chart area is added to the chart, you can associate any series with the new chart area. In all Shape chart types, as well as bar and stacked bar chart types, each series must be plotted in a separate chart area. In all other chart types, multiple series can be combined in the same chart area.

A 3D chart is displayed on a chart area-by-chart area basis. You can use the Area3DStyle property to enable and customize your chart in 3D.

The chart area minimum and maximum will not be automatically recalculated if you add new data, so the chart will not automatically change axis sizes. You can require the chart area to recalculate these values by using the RecalculateAxesScale method.

To align multiple chart areas vertically, set the AlignmentOrientation property. To align multiple chart areas horizontally, you must first position the chart areas using the Position property, and then set the AlignmentOrientation property to Horizontal.

To suppress the display of a series, set the Series property of that series to a zero-length string.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.ChartArea

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Members

ChartArea Members |
 | See Also Constructors Methods Properties

Represents a chart area on the chart image.

The following tables list the members exposed by the ChartArea type.

Public Constructors

Name | Description
ChartArea | Overloaded.
Top

Public Properties

Name | Description
AlignmentOrientation | Gets or sets the alignment orientation of a chart area.
AlignmentStyle | Gets or sets the alignment style of the ChartArea.
AlignWithChartArea | Gets or sets the name of the ChartArea object to which this chart area should be aligned.
Area3DStyle | Gets or sets a ChartArea3DStyle object, which is used to implement 3D for all series in a chart area.
Axes | Gets or sets an array that represents all axes for a chart area.
AxisX | Gets or sets an Axis object that represents the primary X-axis.
AxisX2 | Gets or sets an Axis object that represents the secondary X-axis.
AxisY | Gets or sets an Axis object that represents the primary Y-axis.
AxisY2 | Gets or sets an Axis object that represents the secondary Y-axis.
BackColor | Gets or sets the background color of a ChartArea object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a chart area, and also determines whether or not a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a ChartArea object.
BackImage | Gets or sets the background image of a ChartArea object.
BackImageAlignment | Gets or sets the alignment of a ChartArea background image.
BackImageTransparentColor | Gets or sets the color of a ChartArea object background image that will be drawn as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a ChartArea object.
BackSecondaryColor | Gets or sets the secondary color for the background of a ChartArea object.
BorderColor | Gets or sets the border color of a ChartArea object.
BorderDashStyle | Gets or sets the border style of a ChartArea object.
BorderWidth | Gets or sets the border width of a ChartArea object.
InnerPlotPosition | Gets or sets an ElementPosition object, which defines the inner plot position of a chart area object.
IsSameFontSizeForAllAxes | Gets or sets a flag that determines if the labels of the relevant chart area axes are of equal size.
Name | Overridden. Gets or sets the unique name of a ChartArea object.
Position | Gets or sets an ElementPosition object that defines the position of a ChartArea object within the Chart.
ShadowColor | Gets or sets the shadow color of a ChartArea object.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a ChartArea object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Visible | Gets or sets a flag that determines if a chart area is visible.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetSeriesDepth | Returns the depth of a Series in a chart area.
GetSeriesZPosition | Returns the Z position of a series, which is useful for custom drawing.
GetType | (inherited from Object )
RecalculateAxesScale | Recalculates the properties of the chart area after changes have been made to the chart in the Customize event.
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
TransformPoints | Applies 3D transformations to an array of 3D points, which must be done before GDI+ drawing methods can be called.
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartArea Class
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Constructor

ChartArea Constructor |
 | See Also

Overload List

Name | Description
ChartArea () | Initializes a new instance of the ChartArea class.
ChartArea (String) | Initializes a new instance of the ChartArea class with the specified chart area name.

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Constructor ()

ChartArea Constructor () |
 | See Also

Initializes a new instance of the ChartArea class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ChartArea ()
public:
ChartArea ()
public ChartArea ()
public function ChartArea ()

Remarks

Use this constructor to create and initialize a new instance of the ChartArea class.

Note:
It is highly recommended that you use one of the Add or Insert methods of the ChartAreas collection property to add a chart area at run time.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Constructor (String)

ChartArea Constructor (String) |
 | See Also

Initializes a new instance of the ChartArea class with the specified chart area name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String _
)
public ChartArea (
    string name
)
public:
ChartArea (
    String^ name
)
public ChartArea (
    String name
)
public function ChartArea (
    name : String
)

Parameters

name

The name for the new ChartArea object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Methods

ChartArea Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetSeriesDepth | Returns the depth of a Series in a chart area.
GetSeriesZPosition | Returns the Z position of a series, which is useful for custom drawing.
GetType | (inherited from Object )
RecalculateAxesScale | Recalculates the properties of the chart area after changes have been made to the chart in the Customize event.
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )
TransformPoints | Applies 3D transformations to an array of 3D points, which must be done before GDI+ drawing methods can be called.

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartArea Class
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Dispose Method

ChartArea.Dispose Method |
 | See Also

Overload List

Name | Description
ChartArea.Dispose () | (inherited from Dispose )
ChartArea.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Dispose Method (Boolean)

ChartArea.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.GetSeriesDepth Method

ChartArea.GetSeriesDepth Method |
 | See Also

Returns the depth of a Series in a chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetSeriesDepth ( _
    series As Series _
) As Single
public float GetSeriesDepth (
    Series series
)
public:
float GetSeriesDepth (
    Series^ series
)
public float GetSeriesDepth (
    Series series
)
public function GetSeriesDepth (
    series : Series
) : float

Parameters

series

The Series for which the depth is retrieved.

Return Value

A float value that represents the depth of the specified Series, which is measured as a percentage of the chart area's depth.

Remarks

Call this method to get the depth of a specified series. The returned value is measured as a percentage of the chart area's depth, which is the same unit of measurement used in the Z property.

All series have a depth, regardless of their chart type. For example, even point and bubble series have a depth, even though the entire depth is not used to draw the points or bubbles.

The depth of a series can be used to determine a Z value for a point that is used in a custom drawing routine.

Note:
Any points used in custom 3D drawing must be transformed from relative 3D coordinates to relative 2D coordinates using the TransformPoints method.

To get relative X and Y-values from an axis, use the ValueToPosition method for both the X and Y axes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.GetSeriesZPosition Method

ChartArea.GetSeriesZPosition Method |
 | See Also

Returns the Z position of a series, which is useful for custom drawing.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetSeriesZPosition ( _
    series As Series _
) As Single
public float GetSeriesZPosition (
    Series series
)
public:
float GetSeriesZPosition (
    Series^ series
)
public float GetSeriesZPosition (
    Series series
)
public function GetSeriesZPosition (
    series : Series
) : float

Parameters

series

The Series for which the Z position is retrieved.

Return Value

A float value that represents the Z position of the specified series, which is measured as a percentage of the depth of a chart area.

Remarks

Call this method to get the Z position of a series. The Z position is measured from the back wall of the chart area to the center of a data series, and is represented as a percentage of the chart area's depth. For example, a series that is drawn halfway along the Z-axis has a Z position of 50.

The Z position of a series is normally used for a custom drawing routine.

Note:
Any points used in custom 3D drawing must be transformed from relative 3D coordinates to relative 2D coordinates using the TransformPoints method.

To get relative X and Y-values from an axis, use the ValueToPosition method for both the X and Y axes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.RecalculateAxesScale Method

ChartArea.RecalculateAxesScale Method |
 | See Also

Recalculates the properties of the chart area after changes have been made to the chart in the Customize event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub RecalculateAxesScale
public void RecalculateAxesScale ()
public:
void RecalculateAxesScale ()
public void RecalculateAxesScale ()
public function RecalculateAxesScale ()

Remarks

If you use the Customize event to make changes, it is sometimes necessary to recalculate chart area properties so that the chart is rendered correctly. For example, if an axis range is changed, the labels for that axis must be recalculated.

Call this method after you use the Customize event to make ANY changes to a chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.TransformPoints Method

ChartArea.TransformPoints Method |
 | See Also

Applies 3D transformations to an array of 3D points, which must be done before GDI+ drawing methods can be called.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub TransformPoints ( _
    points As Point3D() _
)
public void TransformPoints (
    Point3D[] points
)
public:
void TransformPoints (
    array<Point3D^>^ points
)
public void TransformPoints (
    Point3D[] points
)
public function TransformPoints (
    points : Point3D[]
)

Parameters

points

An array of 3D points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea Properties

ChartArea Properties |
 | See Also

Public Properties

Name | Description
AlignmentOrientation | Gets or sets the alignment orientation of a chart area.
AlignmentStyle | Gets or sets the alignment style of the ChartArea.
AlignWithChartArea | Gets or sets the name of the ChartArea object to which this chart area should be aligned.
Area3DStyle | Gets or sets a ChartArea3DStyle object, which is used to implement 3D for all series in a chart area.
Axes | Gets or sets an array that represents all axes for a chart area.
AxisX | Gets or sets an Axis object that represents the primary X-axis.
AxisX2 | Gets or sets an Axis object that represents the secondary X-axis.
AxisY | Gets or sets an Axis object that represents the primary Y-axis.
AxisY2 | Gets or sets an Axis object that represents the secondary Y-axis.
BackColor | Gets or sets the background color of a ChartArea object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a chart area, and also determines whether or not a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a ChartArea object.
BackImage | Gets or sets the background image of a ChartArea object.
BackImageAlignment | Gets or sets the alignment of a ChartArea background image.
BackImageTransparentColor | Gets or sets the color of a ChartArea object background image that will be drawn as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a ChartArea object.
BackSecondaryColor | Gets or sets the secondary color for the background of a ChartArea object.
BorderColor | Gets or sets the border color of a ChartArea object.
BorderDashStyle | Gets or sets the border style of a ChartArea object.
BorderWidth | Gets or sets the border width of a ChartArea object.
InnerPlotPosition | Gets or sets an ElementPosition object, which defines the inner plot position of a chart area object.
IsSameFontSizeForAllAxes | Gets or sets a flag that determines if the labels of the relevant chart area axes are of equal size.
Name | Overridden. Gets or sets the unique name of a ChartArea object.
Position | Gets or sets an ElementPosition object that defines the position of a ChartArea object within the Chart.
ShadowColor | Gets or sets the shadow color of a ChartArea object.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a ChartArea object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Visible | Gets or sets a flag that determines if a chart area is visible.

See Also

Reference

ChartArea Class
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AlignmentOrientation Property

ChartArea.AlignmentOrientation Property |
 | See Also

Gets or sets the alignment orientation of a chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property AlignmentOrientation As AreaAlignmentOrientations
public AreaAlignmentOrientations AlignmentOrientation { get; set; }
public:
property AreaAlignmentOrientations AlignmentOrientation {
    AreaAlignmentOrientations get ();
    void set (AreaAlignmentOrientations value);
}
/** @property */
public AreaAlignmentOrientations get_AlignmentOrientation ()

/** @property */
public void set_AlignmentOrientation (AreaAlignmentOrientations value)

public function get AlignmentOrientation () : AreaAlignmentOrientations

public function set AlignmentOrientation (value : AreaAlignmentOrientations)

Property Value

An AreaAlignmentOrientations enumeration value.

Remarks

Through the use of the AlignWithChartArea, AlignmentOrientation and AlignmentStyle properties, it is possible to align or synchronize two or more chart areas horizontally, vertically or both.

First, set the AlignWithChartArea property to the name of a ChartArea object. This chart area will then be aligned, based on the AlignmentStyle setting, which defines the alignment to use, and the AlignmentOrientation setting, which defines the elements of the chart area that should be used to set the alignment.

If the AlignWithChartArea property is not set, the chart area will not be aligned, regardless of the AlignmentStyle and AlignmentOrientation settings.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AlignmentStyle Property

ChartArea.AlignmentStyle Property |
 | See Also

Gets or sets the alignment style of the ChartArea.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property AlignmentStyle As AreaAlignmentStyles
public AreaAlignmentStyles AlignmentStyle { get; set; }
public:
property AreaAlignmentStyles AlignmentStyle {
    AreaAlignmentStyles get ();
    void set (AreaAlignmentStyles value);
}
/** @property */
public AreaAlignmentStyles get_AlignmentStyle ()

/** @property */
public void set_AlignmentStyle (AreaAlignmentStyles value)

public function get AlignmentStyle () : AreaAlignmentStyles

public function set AlignmentStyle (value : AreaAlignmentStyles)

Property Value

An AreaAlignmentStyles enumeration value that can represent either a single value or the bitwise-OR of multiple values that define the alignment to use.

Remarks

Use the AlignmentStyle property to align two or more chart areas horizontally, vertically or both. The alignment type is one of the following values, or a bitwise OR combination of the values below.

Member Name | Description
All | Chart areas are aligned using all values.
AxesView | Chart areas are aligned using the view of the specified ChartArea.
None | Chart areas are not automatically aligned.
Position | Chart areas are aligned with the Position of the chart area specified.
InnerPlotPosition | Chart areas are aligned with the InnerPlotPosition of the chart area specified.

If the AlignWithChartArea value is not set, the AlignmentStyle property will have no effect.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AlignWithChartArea Property

ChartArea.AlignWithChartArea Property |
 | See Also

Gets or sets the name of the ChartArea object to which this chart area should be aligned.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property AlignWithChartArea As String
public string AlignWithChartArea { get; set; }
public:
property String^ AlignWithChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AlignWithChartArea ()

/** @property */
public void set_AlignWithChartArea (String value)

public function get AlignWithChartArea () : String

public function set AlignWithChartArea (value : String)

Property Value

A string value that represents the name of a ChartArea object to which this chart area should be aligned. The default is the empty string.

Remarks

Through the use of the AlignWithChartArea, AlignmentOrientation and AlignmentStyle properties, it is possible to align or synchronize two or more chart areas horizontally, vertically or both.

First, set the AlignWithChartArea property to the name of a ChartArea object. This chart area will then be aligned, based on the AlignmentStyle setting, which defines the alignment to use, and the AlignmentOrientation setting, which defines the elements of the chart area that should be used to set the alignment.

If the AlignWithChartArea property is not set, the chart area will not be aligned, regardless of the AlignmentStyle and AlignmentOrientation settings.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Area3DStyle Property

ChartArea.Area3DStyle Property |
 | See Also

Gets or sets a ChartArea3DStyle object, which is used to implement 3D for all series in a chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property Area3DStyle As ChartArea3DStyle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ChartArea3DStyle Area3DStyle { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ChartArea3DStyle^ Area3DStyle {
    ChartArea3DStyle^ get ();
    void set (ChartArea3DStyle^ value);
}
/** @property */
public ChartArea3DStyle get_Area3DStyle ()

/** @property */
public void set_Area3DStyle (ChartArea3DStyle value)

public function get Area3DStyle () : ChartArea3DStyle

public function set Area3DStyle (value : ChartArea3DStyle)

Property Value

A ChartArea3DStyle object that implements 3D for all series plotted in a chart area.

Remarks

To enable or disable 3D for a chart area, set the Enable3D property.

When the chart is drawn in 3D, scale breaks are not supported on the axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Axes Property

ChartArea.Axes Property |
 | See Also

Gets or sets an array that represents all axes for a chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property Axes As Axis()
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Axis[] Axes { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property array<Axis^>^ Axes {
    array<Axis^>^ get ();
    void set (array<Axis^>^ value);
}
/** @property */
public Axis[] get_Axes ()

/** @property */
public void set_Axes (Axis[] value)

public function get Axes () : Axis[]

public function set Axes (value : Axis[])

Property Value

An array of Axis objects that represents all axes used by a chart area.

Remarks

The main purpose of this property is to provide access to the properties of the X, Y, X2 and Y2 axes at design time.

At run time, the axes for a chart area should be accessed using the individual axis properties, such as AxisX, AxisX2, and so forth.

If you decide to use this property at run time—for example, in an event—you can access an item in this array by specifying an AxisName enumeration member as the identifier.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AxisX Property

ChartArea.AxisX Property |
 | See Also

Gets or sets an Axis object that represents the primary X-axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property AxisX As Axis
[BrowsableAttribute(false)]
public Axis AxisX { get; set; }
[BrowsableAttribute(false)]
public:
property Axis^ AxisX {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisX ()

/** @property */
public void set_AxisX (Axis value)

public function get AxisX () : Axis

public function set AxisX (value : Axis)

Property Value

An Axis object that represents the primary X-axis.

Remarks

Use this property to manipulate the primary X-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AxisX2 Property

ChartArea.AxisX2 Property |
 | See Also

Gets or sets an Axis object that represents the secondary X-axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property AxisX2 As Axis
[BrowsableAttribute(false)]
public Axis AxisX2 { get; set; }
[BrowsableAttribute(false)]
public:
property Axis^ AxisX2 {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisX2 ()

/** @property */
public void set_AxisX2 (Axis value)

public function get AxisX2 () : Axis

public function set AxisX2 (value : Axis)

Property Value

An Axis object that represents the secondary X-axis.

Remarks

Use this property to manipulate the secondary X-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AxisY Property

ChartArea.AxisY Property |
 | See Also

Gets or sets an Axis object that represents the primary Y-axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property AxisY As Axis
[BrowsableAttribute(false)]
public Axis AxisY { get; set; }
[BrowsableAttribute(false)]
public:
property Axis^ AxisY {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisY ()

/** @property */
public void set_AxisY (Axis value)

public function get AxisY () : Axis

public function set AxisY (value : Axis)

Property Value

An Axis object that represents the primary Y-axis.

Remarks

Use this property to manipulate the primary Y-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.AxisY2 Property

ChartArea.AxisY2 Property |
 | See Also

Gets or sets an Axis object that represents the secondary Y-axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property AxisY2 As Axis
[BrowsableAttribute(false)]
public Axis AxisY2 { get; set; }
[BrowsableAttribute(false)]
public:
property Axis^ AxisY2 {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisY2 ()

/** @property */
public void set_AxisY2 (Axis value)

public function get AxisY2 () : Axis

public function set AxisY2 (value : Axis)

Property Value

An Axis object that represents the secondary Y-axis.

Remarks

Use this property to manipulate the secondary Y-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackColor Property

ChartArea.BackColor Property |
 | See Also

Gets or sets the background color of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value. The default color is White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

The BackColor value will be the first color used if you have specified gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the chart area. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackGradientStyle Property

ChartArea.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a chart area, and also determines whether or not a gradient is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a chart area will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

  • Set the primary color of the chart area background with the BackColor property.

  • Set the secondary color of the chart area background with the BackSecondaryColor property.

  • Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackHatchStyle Property

ChartArea.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note:
The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackImage Property

ChartArea.BackImage Property |
 | See Also

Gets or sets the background image of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default is an empty string.

Remarks

This property defines a path to a background image for a ChartArea, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image be any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackImageAlignment Property

ChartArea.BackImageAlignment Property |
 | See Also

Gets or sets the alignment of a ChartArea background image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for the chart area, and is only applied when the ChartImageWrapMode property is set to Unscaled.

For more information about the available alignments, see the ChartImageAlignmentStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackImageTransparentColor Property

ChartArea.BackImageTransparentColor Property |
 | See Also

Gets or sets the color of a ChartArea object background image that will be drawn as transparent.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackImageWrapMode Property

ChartArea.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

The BackImageWrapMode property determines how the image is displayed; the image can be tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the chart area. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the chart area.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BackSecondaryColor Property

ChartArea.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for the background of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value. The default value is Empty.

Remarks

This BackSecondaryColor property is one of several related properties that determine the secondary background color of Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the chart area.

To use gradient colors for the background of a chart area:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BorderColor Property

ChartArea.BorderColor Property |
 | See Also

Gets or sets the border color of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set the BorderColor property to any valid ARGB (alpha, red, green, blue) value.

Note:
For pie and doughnut charts, this property determines the color of radial and horizontal lines if data labels are drawn outside the pie or doughnut—that is, if the LabelStyle custom property is set to "Outside".

This property also determines the marker lines for 3D charts if the ShowMarkerLines custom property is set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BorderDashStyle Property

ChartArea.BorderDashStyle Property |
 | See Also

Gets or sets the border style of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the chart area.

Remarks

The BorderDashStyle property determines the line style to use for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.BorderWidth Property

ChartArea.BorderWidth Property |
 | See Also

Gets or sets the border width of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the chart area.

Remarks

Note that the BorderWidth property can also set the width of lines for line charts, custom legend items displayed with a line style, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.InnerPlotPosition Property

ChartArea.InnerPlotPosition Property |
 | See Also

Gets or sets an ElementPosition object, which defines the inner plot position of a chart area object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property InnerPlotPosition As ElementPosition
public ElementPosition InnerPlotPosition { get; set; }
public:
property ElementPosition^ InnerPlotPosition {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_InnerPlotPosition ()

/** @property */
public void set_InnerPlotPosition (ElementPosition value)

public function get InnerPlotPosition () : ElementPosition

public function set InnerPlotPosition (value : ElementPosition)

Property Value

An ElementPosition object, which defines the inner plot position of a ChartArea object.

Remarks

The InnerPlotPosition property defines the rectangle within a chart area element that is used for plotting data; it excludes tick marks, axis labels, and so forth.

The coordinates used for this property (0,0 to 100,100) are related to the ChartArea object, and not to the entire Chart.

The InnerPlotPosition property can be used to align multiple chart areas. However, if one chart area has tick marks and axis labels and another one does not, their axis lines cannot be aligned.

Important:
This property can also be used to change the size of charts, such as pie or doughnut, without changing the size of the generated chart image.

To change the position of an entire ChartArea object use the Position property instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.IsSameFontSizeForAllAxes Property

ChartArea.IsSameFontSizeForAllAxes Property |
 | See Also

Gets or sets a flag that determines if the labels of the relevant chart area axes are of equal size.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsSameFontSizeForAllAxes As Boolean
public bool IsSameFontSizeForAllAxes { get; set; }
public:
property bool IsSameFontSizeForAllAxes {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSameFontSizeForAllAxes ()

/** @property */
public void set_IsSameFontSizeForAllAxes (boolean value)

public function get IsSameFontSizeForAllAxes () : boolean

public function set IsSameFontSizeForAllAxes (value : boolean)

Property Value

True if all axes that have their IsLabelAutoFit property set to true will display their labels using the same font size, otherwise false.

Remarks

The font size is automatically calculated by the Chart control, with the largest size that fits being used.

This property applies to all chart area axes that have their IsLabelAutoFit property set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Name Property

ChartArea.Name Property |
 | See Also

Gets or sets the unique name of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the name of a ChartArea object.

Remarks

The name of a ChartArea object must be unique, otherwise an exception will be thrown.

This property can be used as the indexer when retrieving a ChartArea object from the ChartAreaCollection object.

If you set this property to a zero-length string. an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Position Property

ChartArea.Position Property |
 | See Also

Gets or sets an ElementPosition object that defines the position of a ChartArea object within the Chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Position As ElementPosition
public ElementPosition Position { get; set; }
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_Position ()

/** @property */
public void set_Position (ElementPosition value)

public function get Position () : ElementPosition

public function set Position (value : ElementPosition)

Property Value

An ElementPosition object that defines the position of a chart area object within the chart image.

Remarks

This property defines the position of a ChartArea object within the Chart, and includes tick marks, axis labels, and so forth.

The coordinates used for this property (0,0 to 100,100) are related to the entire chart image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.ShadowColor Property

ChartArea.ShadowColor Property |
 | See Also

Gets or sets the shadow color of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.ShadowOffset Property

ChartArea.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer that represents the shadow offset, in pixels, of the chart area.

Remarks

To implement shadowing, use a value other than zero (0). A positive value will result in a shadow that shifts down and to the right. A negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea.Visible Property

ChartArea.Visible Property |
 | See Also

Gets or sets a flag that determines if a chart area is visible.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Visible As Boolean
public virtual bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public function get Visible () : boolean

public function set Visible (value : boolean)

Property Value

True if the chart area is visible, otherwise false.

Remarks

When this flag is set to false, all series, legends, titles and annotation objects associated with the chart area will also be hidden.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Class

ChartArea3DStyle Class |
 | See Also Members

Manages the display attributes for three-dimensional (3D) chart areas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartArea3DStyle
public class ChartArea3DStyle
public ref class ChartArea3DStyle
public class ChartArea3DStyle
public class ChartArea3DStyle

Remarks

This class provides the styles for 3D chart areas, and is exposed using the Area3DStyle property.

To enable 3D for a chart area, set the Enable3D property to true. This causes 3D to be applied to all data series drawn in a chart area.

An isometric projection of a chart area can be displayed by setting the IsRightAngleAxes property to true, which is the default. Isometric views are not actually 3D, because the displayed angles of rotation may not match the actual angles of rotation around the vertical and horizontal axes. The actual angles are controlled using the Rotation and Inclination properties, respectively.

For more information about isometric projections, see the Remarks section of the IsRightAngleAxes property.

You can also use this class to:

  • Cluster bar and column chart data series using the IsClustered property.

  • Control the lighting effects using the LightStyle property.

  • Set the width of chart area walls using the WallWidth property.

  • Set the amount of perspective with the Perspective property.

  • Control the depth of data points and the distance between data rows using the PointDepth and PointGapDepth properties, respectively.

  • Rotate a chart area using the Inclination and Rotation properties.

To work with coordinates of 3D points, use the Point3D class.

When a chart is set to 3D, the following chart features are not valid:

  • Scale breaks

  • Gradients

  • Scrolling and zooming

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartArea3DStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Members

ChartArea3DStyle Members |
 | See Also Constructors Methods Properties

Manages the display attributes for three-dimensional (3D) chart areas.

The following tables list the members exposed by the ChartArea3DStyle type.

Public Constructors

Name | Description
ChartArea3DStyle | Overloaded.
Top

Public Properties

Name | Description
Enable3D | Gets or sets a flag that toggles the 3D on and off for a chart area.
Inclination | Gets or sets the angle of rotation around the horizontal axes for 3D chart areas.
IsClustered | Gets or sets a flag that determines whether data series for a bar or column chart are clustered; that is, displayed along distinct rows.
IsRightAngleAxes | Gets or sets a flag that determines whether a chart area is displayed using an isometric projection.
LightStyle | Gets or sets the type of lighting for a 3D chart area.
Perspective | Gets or sets the percent of perspective for a 3D chart area.
PointDepth | Gets or sets the depth of data points displayed in a 3D chart area.
PointGapDepth | Gets or sets the distance between series rows in a 3D chart area.
Rotation | Gets or sets the angle of rotation around the vertical axes for 3D chart areas.
WallWidth | Gets or sets the width of the walls displayed in a 3D chart area.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartArea3DStyle Class
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Constructor

ChartArea3DStyle Constructor |
 | See Also

Overload List

Name | Description
ChartArea3DStyle () | Initializes a new instance of the ChartArea3DStyle class.
ChartArea3DStyle (ChartArea) | Initializes a new instance of the ChartArea3DStyle class using the chartArea parameter.

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Constructor ()

ChartArea3DStyle Constructor () |
 | See Also

Initializes a new instance of the ChartArea3DStyle class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ChartArea3DStyle ()
public:
ChartArea3DStyle ()
public ChartArea3DStyle ()
public function ChartArea3DStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Constructor (ChartArea)

ChartArea3DStyle Constructor (ChartArea) |
 | See Also

Initializes a new instance of the ChartArea3DStyle class using the chartArea parameter.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    chartArea As ChartArea _
)
public ChartArea3DStyle (
    ChartArea chartArea
)
public:
ChartArea3DStyle (
    ChartArea^ chartArea
)
public ChartArea3DStyle (
    ChartArea chartArea
)
public function ChartArea3DStyle (
    chartArea : ChartArea
)

Parameters

chartArea

A ChartArea object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Methods

ChartArea3DStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartArea3DStyle Class
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle Properties

ChartArea3DStyle Properties |
 | See Also

Public Properties

Name | Description
Enable3D | Gets or sets a flag that toggles the 3D on and off for a chart area.
Inclination | Gets or sets the angle of rotation around the horizontal axes for 3D chart areas.
IsClustered | Gets or sets a flag that determines whether data series for a bar or column chart are clustered; that is, displayed along distinct rows.
IsRightAngleAxes | Gets or sets a flag that determines whether a chart area is displayed using an isometric projection.
LightStyle | Gets or sets the type of lighting for a 3D chart area.
Perspective | Gets or sets the percent of perspective for a 3D chart area.
PointDepth | Gets or sets the depth of data points displayed in a 3D chart area.
PointGapDepth | Gets or sets the distance between series rows in a 3D chart area.
Rotation | Gets or sets the angle of rotation around the vertical axes for 3D chart areas.
WallWidth | Gets or sets the width of the walls displayed in a 3D chart area.

See Also

Reference

ChartArea3DStyle Class
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.Enable3D Property

ChartArea3DStyle.Enable3D Property |
 | See Also

Gets or sets a flag that toggles the 3D on and off for a chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enable3D As Boolean
public bool Enable3D { get; set; }
public:
property bool Enable3D {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enable3D ()

/** @property */
public void set_Enable3D (boolean value)

public function get Enable3D () : boolean

public function set Enable3D (value : boolean)

Property Value

true the chart area is displayed using 3D, false if the chart area is displayed in 2D. The default value is false.

Remarks

Toggles the three-dimensional display of a chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.Inclination Property

ChartArea3DStyle.Inclination Property |
 | See Also

Gets or sets the angle of rotation around the horizontal axes for 3D chart areas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Inclination As Integer
public int Inclination { get; set; }
public:
property int Inclination {
    int get ();
    void set (int value);
}
/** @property */
public int get_Inclination ()

/** @property */
public void set_Inclination (int value)

public function get Inclination () : int

public function set Inclination (value : int)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.IsClustered Property

ChartArea3DStyle.IsClustered Property |
 | See Also

Gets or sets a flag that determines whether data series for a bar or column chart are clustered; that is, displayed along distinct rows.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsClustered As Boolean
public bool IsClustered { get; set; }
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsClustered ()

/** @property */
public void set_IsClustered (boolean value)

public function get IsClustered () : boolean

public function set IsClustered (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.IsRightAngleAxes Property

ChartArea3DStyle.IsRightAngleAxes Property |
 | See Also

Gets or sets a flag that determines whether a chart area is displayed using an isometric projection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsRightAngleAxes As Boolean
public bool IsRightAngleAxes { get; set; }
public:
property bool IsRightAngleAxes {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsRightAngleAxes ()

/** @property */
public void set_IsRightAngleAxes (boolean value)

public function get IsRightAngleAxes () : boolean

public function set IsRightAngleAxes (value : boolean)

Property Value

True if the chart area is displayed using an isometric projection, otherwise false.

Remarks

Isometric views are not actually 3D, because the displayed angles of rotation may not match the actual angles of rotation around the vertical and horizontal axes. The actual angles are controlled using the Rotation and Inclination properties, respectively.

Note the following points concerning isometric projection:

  • It is not "real" 3D. That is, the angle of rotation around axes doesn't use true rotational angles.

  • It is ideal for displaying 3D charts with some depth.

  • If your application allows end-users to rotate the charts, the rotation will not be smooth. In this case, using isometric views is not recommended.

  • With isometric projection, perspective is not supported.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.LightStyle Property

ChartArea3DStyle.LightStyle Property |
 | See Also

Gets or sets the type of lighting for a 3D chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LightStyle As LightStyle
public LightStyle LightStyle { get; set; }
public:
property LightStyle LightStyle {
    LightStyle get ();
    void set (LightStyle value);
}
/** @property */
public LightStyle get_LightStyle ()

/** @property */
public void set_LightStyle (LightStyle value)

public function get LightStyle () : LightStyle

public function set LightStyle (value : LightStyle)

Property Value

A LightStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.Perspective Property

ChartArea3DStyle.Perspective Property |
 | See Also

Gets or sets the percent of perspective for a 3D chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Perspective As Integer
public int Perspective { get; set; }
public:
property int Perspective {
    int get ();
    void set (int value);
}
/** @property */
public int get_Perspective ()

/** @property */
public void set_Perspective (int value)

public function get Perspective () : int

public function set Perspective (value : int)

Property Value

An integer value that represents the percent of perspective for a 3D chart area. The allowable range is 0-100 percent, and the default is zero (0) percent.

Remarks

A perspective projection of any set of parallel lines that are not parallel to the projection plane converges to a vanishing point.

If you set the Perspective property, the IsRightAngleAxes property will be automatically set to false, because these properties are mutually exclusive.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.PointDepth Property

ChartArea3DStyle.PointDepth Property |
 | See Also

Gets or sets the depth of data points displayed in a 3D chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PointDepth As Integer
public int PointDepth { get; set; }
public:
property int PointDepth {
    int get ();
    void set (int value);
}
/** @property */
public int get_PointDepth ()

/** @property */
public void set_PointDepth (int value)

public function get PointDepth () : int

public function set PointDepth (value : int)

Property Value

An integer value that represents the depth of data points. The allowable range is 0-1000 percent. The default is 100 percent.

Remarks

This property determines the depth of data points, and is represented as a percentage of the data point width.

The PointDepth property can be applied to the depth of bar, column, line, pie and spline chart data points only. If you set this property for other chart types (for example, bubble and point charts) that cannot have their point depths "stretched", it will reserve extra space for the data points, but will not increase their depth.

You can display the chart as an isometric projection by setting the IsRightAngleAxes property to true, which is the the default value. This will cause the point depth to appear to be more or less than the percentage set by this property, depending on the chart being displayed.

To control the spacing between rows of data, use the PointGapDepth property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.PointGapDepth Property

ChartArea3DStyle.PointGapDepth Property |
 | See Also

Gets or sets the distance between series rows in a 3D chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PointGapDepth As Integer
public int PointGapDepth { get; set; }
public:
property int PointGapDepth {
    int get ();
    void set (int value);
}
/** @property */
public int get_PointGapDepth ()

/** @property */
public void set_PointGapDepth (int value)

public function get PointGapDepth () : int

public function set PointGapDepth (value : int)

Property Value

An integer value that represents the distance between data rows (that is, the data series) in the 3D chart area. The allowable range is 0-1000 percent, and the default is 100 percent.

Remarks

This property determines the distance between data rows, with each row corresponding to a data series. The unit of measurement is expressed as a percentage of the distance between data points in one row.

Changing the gap between columns or bars for column and bar chart types using the PointWidth custom property will affect the PointGapDepth property value.

Set the IsRightAngleAxes property to true (the default value) to display the chart as an isometric projection. This will cause the point gap depth to appear to be more or less than the percentage set by this property, depending on the chart being displayed.

To control the depth of data points, use the PointDepth property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.Rotation Property

ChartArea3DStyle.Rotation Property |
 | See Also

Gets or sets the angle of rotation around the vertical axes for 3D chart areas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Rotation As Integer
public int Rotation { get; set; }
public:
property int Rotation {
    int get ();
    void set (int value);
}
/** @property */
public int get_Rotation ()

/** @property */
public void set_Rotation (int value)

public function get Rotation () : int

public function set Rotation (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartArea3DStyle.WallWidth Property

ChartArea3DStyle.WallWidth Property |
 | See Also

Gets or sets the width of the walls displayed in a 3D chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property WallWidth As Integer
public int WallWidth { get; set; }
public:
property int WallWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_WallWidth ()

/** @property */
public void set_WallWidth (int value)

public function get WallWidth () : int

public function set WallWidth (value : int)

Property Value

An integer value that represents the width, in pixels, of the walls displayed in a 3D chart area.

Remarks

This property determines the width of the walls (for example, the back wall, side walls, and so forth) that are displayed in 3D chart areas. The allowable range is 0-30 pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members
System.Web.UI.DataVisualization.Charting Namespace


ChartAreaCollection Class

ChartAreaCollection Class |
 | See Also Members

Represents a collection of ChartArea objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartAreaCollection
    Inherits ChartNamedElementCollection(Of ChartArea)
public class ChartAreaCollection : ChartNamedElementCollection<ChartArea>
public ref class ChartAreaCollection : public ChartNamedElementCollection<ChartArea^>
public class ChartAreaCollection extends ChartNamedElementCollection<ChartArea>
public class ChartAreaCollection extends ChartNamedElementCollection<ChartArea>

Remarks

The ChartAreaCollection class represents a collection of ChartArea objects, which in turn represent the chart areas that are displayed within the chart image.

This class is exposed as the ChartAreas property of the root Chart object.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.ChartAreaCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartAreaCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartAreaCollection Members

ChartAreaCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of ChartArea objects.

The following tables list the members exposed by the ChartAreaCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

ChartAreaCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartAreaCollection Methods

ChartAreaCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

ChartAreaCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartAreaCollection.Add Method

ChartAreaCollection.Add Method |
 | See Also

Overload List

Name | Description
ChartAreaCollection.Add (ChartArea) | (inherited from Add )
ChartAreaCollection.Add (String) | Adds a ChartArea object with the specified name to the collection.

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartAreaCollection.Add Method (String)

ChartAreaCollection.Add Method (String) |
 | See Also

Adds a ChartArea object with the specified name to the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As ChartArea
public ChartArea Add (
    string name
)
public:
ChartArea^ Add (
    String^ name
)
public ChartArea Add (
    String name
)
public function Add (
    name : String
) : ChartArea

Parameters

name

The name of the object to be added to the collection.

Return Value

A string value that represents a reference to the newly added object.

Remarks

Objects are always added as the last item in the collection.

The name argument specifies the Name property of the object being added.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartAreaCollection Properties

ChartAreaCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

ChartAreaCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartColorPalette Enumeration

ChartColorPalette Enumeration |
 | See Also

Specifies a palette when setting a Palette property.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartColorPalette
public enum ChartColorPalette
public enum class ChartColorPalette
public enum ChartColorPalette
public enum ChartColorPalette

Members

Member name | Description
Berry | Palette utilizes blues and purples.
Bright | Palette utilizes bright colors.
BrightPastel | Palette utilizes bright pastel colors.
Chocolate | Palette utilizes shades of brown.
EarthTones | Palette utilizes earth tone colors such as green and brown.
Excel | Palette utilizes Excel-style colors.
Fire | Palette utilizes red, orange and yellow colors.
Grayscale | Palette utilizes grayscale colors, that is, shades of black and white.
Light | Palette utilizes light colors.
None | No palette is used.
Pastel | Palette utilizes pastel colors.
SeaGreen | Palette utilizes colors that range from green to blue.
SemiTransparent | Palette utilizes semi-transparent colors.

Remarks

The ChartColorPalette enumeration represents the palettes to be used for the root Chart object and any Series objects.

If no colors are assigned to data points and their associated series, the default colors will be assigned to the data. For example:

  • If Palette is set to None, then the default palette is set to PaletteCustomColors or BrightPastel.

  • If.Palette is set to None, then the default palette for the chart is used (Palette).

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartDashStyle Enumeration

ChartDashStyle Enumeration |
 | See Also

Specifies a line style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartDashStyle
public enum ChartDashStyle
public enum class ChartDashStyle
public enum ChartDashStyle
public enum ChartDashStyle

Members

Member name | Description
Dash | A dashed line.
DashDot | A line with a repeating dash-dot pattern.
DashDotDot | A line a repeating dash-dot-dot pattern.
Dot | A line with a repeating dot pattern.
NotSet | The line style is not set.
Solid | A solid line.

Remarks

The ChartDashStyle enumeration represents a line style.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartElement Class

ChartElement Class |
 | See Also Members

Base class for all the chart elements. The ChartElement class represents the most basic element of the chart element hierarchy.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public MustInherit Class ChartElement
    Implements IDisposable
public abstract class ChartElement : IDisposable
public ref class ChartElement abstract : IDisposable
public abstract class ChartElement implements IDisposable
public abstract class ChartElement implements IDisposable

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement Members

ChartElement Members |
 | See Also Methods Properties Constructors

Base class for all the chart elements. The ChartElement class represents the most basic element of the chart element hierarchy.

The following tables list the members exposed by the ChartElement type.

Protected Constructors

Name | Description
ChartElement | Initializes a new instance of the ChartElement class.
Top

Public Properties

Name | Description
Tag | Gets or sets an object associated with this chart element.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns a hash function for a particular type.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string that represents the current Object.
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartElement Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElement Constructor

ChartElement Constructor |
 | See Also

Initializes a new instance of the ChartElement class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Sub New
protected ChartElement ()
protected:
ChartElement ()
protected ChartElement ()
protected function ChartElement ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement Methods

ChartElement Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns a hash function for a particular type.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string that represents the current Object.

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartElement Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.Dispose Method

ChartElement.Dispose Method |
 | See Also

Overload List

Name | Description
ChartElement.Dispose () |
ChartElement.Dispose (Boolean) |

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.Dispose Method ()

ChartElement.Dispose Method () |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Dispose

public void Dispose ()

public:
virtual void Dispose () sealed

public final void Dispose ()

public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.Dispose Method (Boolean)

ChartElement.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

protected virtual void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
)

protected void Dispose (
    boolean disposing
)

protected function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.Equals Method

ChartElement.Equals Method |
 | See Also

Overload List

Name | Description
ChartElement.Equals (Object) |
ChartElement.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.Equals Method (Object)

ChartElement.Equals Method (Object) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

public override bool Equals (
    Object obj
)

public:
virtual bool Equals (
    Object^ obj
) override

public boolean Equals (
    Object obj
)

public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.GetHashCode Method

ChartElement.GetHashCode Method |
 | See Also

Returns a hash function for a particular type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

An integer value that represents the hash code for the current Object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.ToString Method

ChartElement.ToString Method |
 | See Also

Returns a string that represents the current Object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Return Value

A string value that represents the current Object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement Properties

ChartElement Properties |
 | See Also

Public Properties

Name | Description
Tag | Gets or sets an object associated with this chart element.

See Also

Reference

ChartElement Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElement.Tag Property

ChartElement.Tag Property |
 | See Also

Gets or sets an object associated with this chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property Tag As Object
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Object Tag { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property Object^ Tag {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
/** @property */
public final Object get_Tag ()

/** @property */
public final void set_Tag (Object value)

public final function get Tag () : Object

public final function set Tag (value : Object)

Property Value

An Object associated with this chart element.

Remarks

The Tag property can be used to store additional data with this chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection Generic Class

ChartElementCollection Generic Class |
 | See Also Members

Represents the base class for all chart element collections.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public MustInherit Class ChartElementCollection(Of T As ChartElement)
    Inherits Collection(Of T)
    Implements IDisposable
public abstract class ChartElementCollection<T> : Collection<T>, IDisposable where T : ChartElement
generic<typename T> where T : ChartElement
public ref class ChartElementCollection abstract : public Collection<T>, IDisposable
J# supports the use of generic types and methods, but not the declaration of new ones.
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection Members

ChartElementCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents the base class for all chart element collections.

The following tables list the members exposed by the ChartElementCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Overridden. Removes all elements from the Collection.
Dispose | Overloaded.
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts an element into the Collection at the specified index location.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the element at the specified index location of the Collection.
SetItem | Overridden. Replaces the element at the specified index location.
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

ChartElementCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection Methods

ChartElementCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection.
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Overridden. Removes all elements from the Collection.
Dispose | Overloaded.
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts an element into the Collection at the specified index location.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the element at the specified index location of the Collection.
SetItem | Overridden. Replaces the element at the specified index location.

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

ChartElementCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.ClearItems Method

ChartElementCollection.ClearItems Method |
 | See Also

Removes all elements from the Collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub ClearItems
protected override void ClearItems ()
protected:
virtual void ClearItems () override
protected void ClearItems ()
protected override function ClearItems ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.Dispose Method

ChartElementCollection.Dispose Method |
 | See Also

Overload List

Name | Description
ChartElementCollection.Dispose () |
ChartElementCollection.Dispose (Boolean) |

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.Dispose Method ()

ChartElementCollection.Dispose Method () |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Dispose

public void Dispose ()

public:
virtual void Dispose () sealed

public final void Dispose ()

public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.Dispose Method (Boolean)

ChartElementCollection.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

protected virtual void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
)

protected void Dispose (
    boolean disposing
)

protected function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.InsertItem Method

ChartElementCollection.InsertItem Method |
 | See Also

Inserts an element into the Collection at the specified index location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)
protected override void InsertItem (
    int index,
    T item
)
protected:
virtual void InsertItem (
    int index,
    T item
) override
protected void InsertItem (
    int index,
    T item
)
protected override function InsertItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index location of the item will be inserted.

item

The object to insert. The value can be null for reference types.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.Invalidate Method

ChartElementCollection.Invalidate Method |
 | See Also

Forces the invalidation of the parent chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub Invalidate
public virtual void Invalidate ()
public:
virtual void Invalidate ()
public void Invalidate ()
public function Invalidate ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.RemoveItem Method

ChartElementCollection.RemoveItem Method |
 | See Also

Removes the element at the specified index location of the Collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
protected override void RemoveItem (
    int index
)
protected:
virtual void RemoveItem (
    int index
) override
protected void RemoveItem (
    int index
)
protected override function RemoveItem (
    index : int
)

Parameters

index

The zero-based index location of the element to remove.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.ResumeUpdates Method

ChartElementCollection.ResumeUpdates Method |
 | See Also

Resumes the invalidation of a chart element in the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub ResumeUpdates
public virtual void ResumeUpdates ()
public:
virtual void ResumeUpdates ()
public void ResumeUpdates ()
public function ResumeUpdates ()

Remarks

If you call the SuspendUpdates method several times, you will need to call the ResumeUpdates method an equal number of times.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.SetItem Method

ChartElementCollection.SetItem Method |
 | See Also

Replaces the element at the specified index location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)
protected override void SetItem (
    int index,
    T item
)
protected:
virtual void SetItem (
    int index,
    T item
) override
protected void SetItem (
    int index,
    T item
)
protected override function SetItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index location of the element to replace.

item

The new value for the element at the specified index location. The value can be null for reference types.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection.SuspendUpdates Method

ChartElementCollection.SuspendUpdates Method |
 | See Also

Suspends the invalidation of a chart element in the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub SuspendUpdates
public virtual void SuspendUpdates ()
public:
virtual void SuspendUpdates ()
public void SuspendUpdates ()
public function SuspendUpdates ()

Remarks

A call to the Invalidate method will have no effect after the SuspendUpdates method is called.

If you call the SuspendUpdates method several times, you will need to call the ResumeUpdates method an equal number of times.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementCollection Properties

ChartElementCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

ChartElementCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline Class

ChartElementOutline Class |
 | See Also Members

Represents an array of marker points and the outline path used for visual object selection in the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartElementOutline
    Implements IDisposable
public class ChartElementOutline : IDisposable
public ref class ChartElementOutline : IDisposable
public class ChartElementOutline implements IDisposable
public class ChartElementOutline implements IDisposable

Remarks

The value of the OutlinePath property can be null for complex objects or objects with two points or fewer.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElementOutline

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline Members

ChartElementOutline Members |
 | See Also Methods Properties

Represents an array of marker points and the outline path used for visual object selection in the chart.

The following tables list the members exposed by the ChartElementOutline type.

Public Properties

Name | Description
Markers | Gets or sets the markers.
OutlinePath | Gets or sets the outline path. The return value can be null for complex objects and objects with two points or fewer.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartElementOutline Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline Methods

ChartElementOutline Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartElementOutline Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline.Dispose Method

ChartElementOutline.Dispose Method |
 | See Also

Overload List

Name | Description
ChartElementOutline.Dispose () | Performs application-defined tasks that free, release, or reset unmanaged resources.
ChartElementOutline.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline.Dispose Method ()

ChartElementOutline.Dispose Method () |
 | See Also

Performs application-defined tasks that free, release, or reset unmanaged resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Dispose
public void Dispose ()
public:
virtual void Dispose () sealed
public final void Dispose ()
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline.Dispose Method (Boolean)

ChartElementOutline.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline Properties

ChartElementOutline Properties |
 | See Also

Public Properties

Name | Description
Markers | Gets or sets the markers.
OutlinePath | Gets or sets the outline path. The return value can be null for complex objects and objects with two points or fewer.

See Also

Reference

ChartElementOutline Class
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline.Markers Property

ChartElementOutline.Markers Property |
 | See Also

Gets or sets the markers.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Markers As ReadOnlyCollection(Of PointF)
public ReadOnlyCollection<PointF> Markers { get; }
public:
property ReadOnlyCollection<PointF>^ Markers {
    ReadOnlyCollection<PointF>^ get ();
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public ReadOnlyCollection<PointF> get_Markers ()

CompilerGeneratedAttribute
public function get Markers () : ReadOnlyCollection<PointF>

Property Value

An array of PointF values that represent the marker points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementOutline.OutlinePath Property

ChartElementOutline.OutlinePath Property |
 | See Also

Gets or sets the outline path. The return value can be null for complex objects and objects with two points or fewer.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property OutlinePath As GraphicsPath
public GraphicsPath OutlinePath { get; }
public:
property GraphicsPath^ OutlinePath {
    GraphicsPath^ get ();
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public GraphicsPath get_OutlinePath ()

CompilerGeneratedAttribute
public function get OutlinePath () : GraphicsPath

Property Value

A GraphicsPath that represents the outline path.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElementType Enumeration

ChartElementType Enumeration |
 | See Also

Specifies a chart element type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartElementType
public enum ChartElementType
public enum class ChartElementType
public enum ChartElementType
public enum ChartElementType

Members

Member name | Description
Annotation | Any object derived from the Annotation class.
Axis | An Axis object.
AxisLabelImage | An Axis label image.
AxisLabels | A LabelStyle object.
AxisTitle | An Axis title.
DataPoint | A DataPoint object.
DataPointLabel | A series DataPoint label.
Gridlines | Any major or minor grid line, either vertical or horizontal.
LegendArea | The area inside a Legend object. Does not include the space occupied by legend items.
LegendHeader | A Legend header.
LegendItem | A LegendItem object.
LegendTitle | A Legend title.
Nothing | No chart element.
PlottingArea | The plotting area, which is the chart area excluding axes, labels, and so on. Also excludes the regions that data points might occupy.
StripLines | A StripLine object.
TickMarks | Any major or minor TickMark object.
Title | The title of a Chart.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics Class

ChartGraphics Class |
 | See Also Members

Provides numerous conversion functions and exposes a GDI+ Graphics object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartGraphics
    Inherits ChartElement
public class ChartGraphics : ChartElement
public ref class ChartGraphics : public ChartElement
public class ChartGraphics extends ChartElement
public class ChartGraphics extends ChartElement

Remarks

This class provides numerous conversion functions and also exposes a GDI+ Graphics object. Note that when rendering as Scalable Vector Graphics (SVG), use of the Graphics object for custom drawing will not be included as part of the SVG document.

Note also that, by default, Graphics functions usually take absolute coordinates. Therefore the conversion methods of this class should be useful if you perform drawing operations.

A ChartGraphics object is exposed in the ChartGraphics property of the ChartPaintEventArgs class, which makes it easy to perform custom drawing in the PrePaint and PostPaint events.

Important:
If significant changes are made to the default behavior of the Graphics object, the chart image and its associated elements may be drawn erratically. For example, positioning may be altered. It is highly recommended that you become well acquainted with GDI+ before you make any significant changes to the properties of the Graphics object.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartGraphics

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics Members

ChartGraphics Members |
 | See Also Methods Properties

Provides numerous conversion functions and exposes a GDI+ Graphics object.

The following tables list the members exposed by the ChartGraphics type.

Public Properties

Name | Description
Graphics | Gets or sets a GDI+ Graphics object that can be used for drawing purposes.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetAbsolutePoint | Takes a PointF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteRectangle | Takes a RectangleF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteSize | Takes a SizeF object that uses relative coordinates and returns a SizeF object that uses absolute coordinates.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetPositionFromAxis | Takes a given axis value for a specified axis and returns the relative pixel value.
GetRelativePoint | Takes a PointF object that uses absolute coordinates and returns a PointF object that uses relative coordinates.
GetRelativeRectangle | Takes a RectangleF structure that is using absolute coordinates and returns a RectangleF object that uses relative coordinates.
GetRelativeSize | Takes a SizeF object in absolute coordinates and returns a SizeF object that uses relative coordinates.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartGraphics Class
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics Methods

ChartGraphics Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetAbsolutePoint | Takes a PointF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteRectangle | Takes a RectangleF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteSize | Takes a SizeF object that uses relative coordinates and returns a SizeF object that uses absolute coordinates.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetPositionFromAxis | Takes a given axis value for a specified axis and returns the relative pixel value.
GetRelativePoint | Takes a PointF object that uses absolute coordinates and returns a PointF object that uses relative coordinates.
GetRelativeRectangle | Takes a RectangleF structure that is using absolute coordinates and returns a RectangleF object that uses relative coordinates.
GetRelativeSize | Takes a SizeF object in absolute coordinates and returns a SizeF object that uses relative coordinates.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartGraphics Class
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.Dispose Method

ChartGraphics.Dispose Method |
 | See Also

Overload List

Name | Description
ChartGraphics.Dispose () | (inherited from Dispose )
ChartGraphics.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.Dispose Method (Boolean)

ChartGraphics.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetAbsolutePoint Method

ChartGraphics.GetAbsolutePoint Method |
 | See Also

Takes a PointF object and converts its relative coordinates to absolute coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetAbsolutePoint ( _
    point As PointF _
) As PointF
public PointF GetAbsolutePoint (
    PointF point
)
public:
PointF GetAbsolutePoint (
    PointF point
)
public PointF GetAbsolutePoint (
    PointF point
)
public function GetAbsolutePoint (
    point : PointF
) : PointF

Parameters

point

A PointF object in relative coordinates.

Return Value

A PointF object in absolute coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetAbsoluteRectangle Method

ChartGraphics.GetAbsoluteRectangle Method |
 | See Also

Takes a RectangleF object and converts its relative coordinates to absolute coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetAbsoluteRectangle ( _
    rectangle As RectangleF _
) As RectangleF
public RectangleF GetAbsoluteRectangle (
    RectangleF rectangle
)
public:
RectangleF GetAbsoluteRectangle (
    RectangleF rectangle
)
public RectangleF GetAbsoluteRectangle (
    RectangleF rectangle
)
public function GetAbsoluteRectangle (
    rectangle : RectangleF
) : RectangleF

Parameters

rectangle

A RectangleF object in relative coordinates.

Return Value

A RectangleF object in absolute coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetAbsoluteSize Method

ChartGraphics.GetAbsoluteSize Method |
 | See Also

Takes a SizeF object that uses relative coordinates and returns a SizeF object that uses absolute coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetAbsoluteSize ( _
    size As SizeF _
) As SizeF
public SizeF GetAbsoluteSize (
    SizeF size
)
public:
SizeF GetAbsoluteSize (
    SizeF size
)
public SizeF GetAbsoluteSize (
    SizeF size
)
public function GetAbsoluteSize (
    size : SizeF
) : SizeF

Parameters

size

A SizeF object in relative coordinates.

Return Value

A SizeF object in absolute coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetPositionFromAxis Method

ChartGraphics.GetPositionFromAxis Method |
 | See Also

Takes a given axis value for a specified axis and returns the relative pixel value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetPositionFromAxis ( _
    chartAreaName As String, _
    axis As AxisName, _
    axisValue As Double _
) As Double
public double GetPositionFromAxis (
    string chartAreaName,
    AxisName axis,
    double axisValue
)
public:
double GetPositionFromAxis (
    String^ chartAreaName,
    AxisName axis,
    double axisValue
)
public double GetPositionFromAxis (
    String chartAreaName,
    AxisName axis,
    double axisValue
)
public function GetPositionFromAxis (
    chartAreaName : String,
    axis : AxisName,
    axisValue : double
) : double

Parameters

chartAreaName

Chart area name.

axis

An AxisName enumeration value that identifies the relevant axis.

axisValue

The axis value to be converted to a relative pixel value.

Return Value

A string value that represents the converted axis value, in relative pixel coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetRelativePoint Method

ChartGraphics.GetRelativePoint Method |
 | See Also

Takes a PointF object that uses absolute coordinates and returns a PointF object that uses relative coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetRelativePoint ( _
    point As PointF _
) As PointF
public PointF GetRelativePoint (
    PointF point
)
public:
PointF GetRelativePoint (
    PointF point
)
public PointF GetRelativePoint (
    PointF point
)
public function GetRelativePoint (
    point : PointF
) : PointF

Parameters

point

A PointF object in absolute coordinates.

Return Value

A PointF object in relative coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetRelativeRectangle Method

ChartGraphics.GetRelativeRectangle Method |
 | See Also

Takes a RectangleF structure that is using absolute coordinates and returns a RectangleF object that uses relative coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetRelativeRectangle ( _
    rectangle As RectangleF _
) As RectangleF
public RectangleF GetRelativeRectangle (
    RectangleF rectangle
)
public:
RectangleF GetRelativeRectangle (
    RectangleF rectangle
)
public RectangleF GetRelativeRectangle (
    RectangleF rectangle
)
public function GetRelativeRectangle (
    rectangle : RectangleF
) : RectangleF

Parameters

rectangle

A RectangleF structure in absolute coordinates.

Return Value

A RectangleF structure in relative coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.GetRelativeSize Method

ChartGraphics.GetRelativeSize Method |
 | See Also

Takes a SizeF object in absolute coordinates and returns a SizeF object that uses relative coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetRelativeSize ( _
    size As SizeF _
) As SizeF
public SizeF GetRelativeSize (
    SizeF size
)
public:
SizeF GetRelativeSize (
    SizeF size
)
public SizeF GetRelativeSize (
    SizeF size
)
public function GetRelativeSize (
    size : SizeF
) : SizeF

Parameters

size

A SizeF object in absolute coordinates.

Return Value

A SizeF object in relative coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics Properties

ChartGraphics Properties |
 | See Also

Public Properties

Name | Description
Graphics | Gets or sets a GDI+ Graphics object that can be used for drawing purposes.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

ChartGraphics Class
System.Web.UI.DataVisualization.Charting Namespace


ChartGraphics.Graphics Property

ChartGraphics.Graphics Property |
 | See Also

Gets or sets a GDI+ Graphics object that can be used for drawing purposes.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Graphics As Graphics
public Graphics Graphics { get; set; }
public:
property Graphics^ Graphics {
    Graphics^ get ();
    void set (Graphics^ value);
}
/** @property */
public Graphics get_Graphics ()

/** @property */
public void set_Graphics (Graphics value)

public function get Graphics () : Graphics

public function set Graphics (value : Graphics)

Property Value

A Graphics object used for drawing.

Remarks

You can use this object property to perform any custom drawing that can be performed using GDI+.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHatchStyle Enumeration

ChartHatchStyle Enumeration |
 | See Also

Specifies a hatching style for a chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartHatchStyle
public enum ChartHatchStyle
public enum class ChartHatchStyle
public enum ChartHatchStyle
public enum ChartHatchStyle

Members

Member name | Description
BackwardDiagonal | Backward diagonal style.
Cross | Cross style.
DarkDownwardDiagonal | Dark downward diagonal style.
DarkHorizontal | Dark horizontal style.
DarkUpwardDiagonal | Dark upward diagonal style.
DarkVertical | Dark vertical style.
DashedDownwardDiagonal | Dashed downward diagonal style.
DashedHorizontal | Dashed horizontal style.
DashedUpwardDiagonal | Dashed upward diagonal style.
DashedVertical | Dashed vertical style.
DiagonalBrick | Diagonal brick style.
DiagonalCross | Diagonal cross style.
Divot | Divot style.
DottedDiamond | Dotted diamond style.
DottedGrid | Dotted grid style.
ForwardDiagonal | Forward diagonal style.
Horizontal | Horizontal style.
HorizontalBrick | Horizontal brick style.
LargeCheckerBoard | Large checker board style.
LargeConfetti | Large confetti style.
LargeGrid | Large grid style.
LightDownwardDiagonal | Light downward diagonal style.
LightHorizontal | Light horizontal style.
LightUpwardDiagonal | Light upward diagonal style.
LightVertical | Light vertical style.
NarrowHorizontal | Narrow horizontal style.
NarrowVertical | Narrow vertical style.
None | No hatching style.
OutlinedDiamond | Outlined diamond style.
Percent05 | Percent05 style.
Percent10 | Percent10 style.
Percent20 | Percent20 style.
Percent25 | Percent25 style.
Percent30 | Percent30 style.
Percent40 | Percent40 style.
Percent50 | Percent50 style.
Percent60 | Percent60 style.
Percent70 | Percent70 style.
Percent75 | Percent75 style.
Percent80 | Percent80 style.
Percent90 | Percent90 style.
Plaid | Plaid style.
Shingle | Shingle style.
SmallCheckerBoard | Small checker board style.
SmallConfetti | Small confetti style.
SmallGrid | Small grid style.
SolidDiamond | Solid diamond style.
Sphere | Sphere style.
Trellis | Trellis style.
Vertical | Vertical style.
Wave | Wave style.
Weave | Weave style.
WideDownwardDiagonal | Wide downward diagonal style.
WideUpwardDiagonal | Wide upward diagonal style.
ZigZag | Zigzag style.

Remarks

The ChartHatchStyle enumeration represents the hatching styles that can be used for numerous chart elements, such as the ChartArea, Legend, and so forth.

Setting the BackHatchStyle property of a chart element object to any member of this enumeration except None will cause the corresponding hatching style to be applied to the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler Class

ChartHttpHandler Class |
 | See Also Members

Processes HTTP web requests using a custom HTTP handler; handles chart images.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartHttpHandler
    Inherits Page
    Implements IRequiresSessionState, IHttpHandler
public class ChartHttpHandler : Page, IRequiresSessionState, IHttpHandler
public ref class ChartHttpHandler : public Page, IRequiresSessionState, IHttpHandler
public class ChartHttpHandler extends Page implements IRequiresSessionState, IHttpHandler
public class ChartHttpHandler extends Page implements IRequiresSessionState, IHttpHandler

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.TemplateControl
System.Web.UI.Page
System.Web.UI.DataVisualization.Charting.ChartHttpHandler

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandler Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler Members

ChartHttpHandler Members |
 | See Also Constructors Events Methods Properties Explicit Interface Implementations

Processes HTTP web requests using a custom HTTP handler; handles chart images.

The following tables list the members exposed by the ChartHttpHandler type.

Public Constructors

Name | Description
ChartHttpHandler | Initializes a new instance of the ChartHttpHandler class.
Top

Public Properties (see also Protected Properties )

Name | Description
Application | (inherited from Page )
AppRelativeTemplateSourceDirectory | (inherited from Control )
AppRelativeVirtualPath | (inherited from TemplateControl )
AsyncTimeout | (inherited from Page )
BindingContainer | (inherited from Control )
Buffer | (inherited from Page )
Cache | (inherited from Page )
ClientID | (inherited from Control )
ClientQueryString | (inherited from Page )
ClientScript | (inherited from Page )
ClientTarget | (inherited from Page )
CodePage | (inherited from Page )
ContentType | (inherited from Page )
Controls | (inherited from Control )
Culture | (inherited from Page )
EnableEventValidation | (inherited from Page )
EnableTheming | (inherited from TemplateControl )
EnableViewState | (inherited from Page )
EnableViewStateMac | (inherited from Page )
ErrorPage | (inherited from Page )
Form | (inherited from Page )
Header | (inherited from Page )
ID | (inherited from Page )
IdSeparator | (inherited from Page )
IsAsync | (inherited from Page )
IsCallback | (inherited from Page )
IsCrossPagePostBack | (inherited from Page )
IsPostBack | (inherited from Page )
IsReusable | Gets a value indicating whether another request can use the IHttpHandler object. (inherited from Page)
IsValid | (inherited from Page )
Items | (inherited from Page )
LCID | (inherited from Page )
MaintainScrollPositionOnPostBack | (inherited from Page )
Master | (inherited from Page )
MasterPageFile | (inherited from Page )
MaxPageStateFieldLength | (inherited from Page )
NamingContainer | (inherited from Control )
Page | (inherited from Control )
PageAdapter | (inherited from Page )
Parent | (inherited from Control )
PreviousPage | (inherited from Page )
Request | (inherited from Page )
Response | (inherited from Page )
ResponseEncoding | (inherited from Page )
Server | (inherited from Page )
Session | (inherited from Page )
Settings | Gets the chart image storage settings registered in the web.config file under the ChartHttpHandler key.
Site | (inherited from Control )
SkinID | (inherited from Control )
SmartNavigation | Obsolete. (inherited from Page )
StyleSheetTheme | (inherited from Page )
TemplateControl | (inherited from Control )
TemplateSourceDirectory | (inherited from Control )
Theme | (inherited from Page )
Title | (inherited from Page )
Trace | (inherited from Page )
TraceEnabled | (inherited from Page )
TraceModeValue | (inherited from Page )
UICulture | (inherited from Page )
UniqueID | (inherited from Control )
User | (inherited from Page )
Validators | (inherited from Page )
ViewStateEncryptionMode | (inherited from Page )
ViewStateUserKey | (inherited from Page )
Visible | (inherited from Page )
Top

Protected Properties

Name | Description
Adapter | (inherited from Control )
AspCompatMode | (inherited from Page )
AsyncMode | (inherited from Page )
AutoHandlers | Obsolete. (inherited from TemplateControl )
ChildControlsCreated | (inherited from Control )
ClientIDSeparator | (inherited from Control )
Context | (inherited from Page )
DesignMode | (inherited from Control )
Events | (inherited from Control )
FileDependencies | Obsolete. (inherited from Page )
HasChildViewState | (inherited from Control )
IsChildControlStateCleared | (inherited from Control )
IsTrackingViewState | (inherited from Control )
IsViewStateEnabled | (inherited from Control )
LoadViewStateByID | (inherited from Control )
PageStatePersister | (inherited from Page )
SupportAutoEvents | (inherited from TemplateControl )
TransactionMode | (inherited from Page )
UniqueFilePathSuffix | (inherited from Page )
ViewState | (inherited from Control )
ViewStateIgnoresCase | (inherited from Control )
Top

Public Methods (see also Protected Methods )

Name | Description
AddOnPreRenderCompleteAsync | Overloaded. (inherited from Page )
ApplyStyleSheetSkin | (inherited from Control )
CreateHtmlTextWriterFromType | (inherited from Page )
DataBind | Overloaded. (inherited from Control )
DesignerInitialize | (inherited from Page )
Dispose | (inherited from Control )
Equals | Overloaded. (inherited from Object )
ExecuteRegisteredAsyncTasks | (inherited from Page )
FindControl | Overloaded. (inherited from Page )
Focus | (inherited from Control )
GetDataItem | (inherited from Page )
GetHashCode | (inherited from Object )
GetPostBackClientEvent | Obsolete. (inherited from Page )
GetPostBackClientHyperlink | Obsolete. (inherited from Page )
GetPostBackEventReference | Overloaded. (inherited from Page )
GetType | (inherited from Object )
GetTypeHashCode | (inherited from Page )
GetValidators | (inherited from Page )
HasControls | (inherited from Control )
IsClientScriptBlockRegistered | Obsolete. (inherited from Page )
IsStartupScriptRegistered | Obsolete. (inherited from Page )
LoadControl | Overloaded. (inherited from TemplateControl )
LoadTemplate | (inherited from TemplateControl )
MapPath | (inherited from Page )
ParseControl | (inherited from TemplateControl )
ProcessRequest | Enables HTTP web requests to be processed by a custom HTTP handler that implements the IHttpHandler interface. (inherited from Page)
ReadStringResource | Overloaded. (inherited from TemplateControl )
ReferenceEquals | (inherited from Object )
RegisterArrayDeclaration | Obsolete. (inherited from Page )
RegisterAsyncTask | (inherited from Page )
RegisterClientScriptBlock | Obsolete. (inherited from Page )
RegisterHiddenField | Obsolete. (inherited from Page )
RegisterOnSubmitStatement | Obsolete. (inherited from Page )
RegisterRequiresControlState | (inherited from Page )
RegisterRequiresPostBack | (inherited from Page )
RegisterRequiresRaiseEvent | (inherited from Page )
RegisterRequiresViewStateEncryption | (inherited from Page )
RegisterStartupScript | Obsolete. (inherited from Page )
RegisterViewStateHandler | (inherited from Page )
RenderControl | Overloaded. (inherited from Control )
RequiresControlState | (inherited from Page )
ResolveClientUrl | (inherited from Control )
ResolveUrl | (inherited from Control )
SetFocus | Overloaded. (inherited from Page )
SetRenderMethodDelegate | (inherited from Control )
TestDeviceFilter | (inherited from TemplateControl )
ToString | (inherited from Object )
UnregisterRequiresControlState | (inherited from Page )
Validate | Overloaded. (inherited from Page )
VerifyRenderingInServerForm | (inherited from Page )
Top

Protected Methods

Name | Description
AddContentTemplate | (inherited from Page )
AddedControl | (inherited from Control )
AddParsedSubObject | (inherited from Control )
AddWrappedFileDependencies | (inherited from Page )
AspCompatBeginProcessRequest | (inherited from Page )
AspCompatEndProcessRequest | (inherited from Page )
AsyncPageBeginProcessRequest | (inherited from Page )
AsyncPageEndProcessRequest | (inherited from Page )
BuildProfileTree | (inherited from Control )
ClearChildControlState | (inherited from Control )
ClearChildState | (inherited from Control )
ClearChildViewState | (inherited from Control )
Construct | (inherited from TemplateControl )
CreateChildControls | (inherited from Control )
CreateControlCollection | (inherited from Control )
CreateHtmlTextWriter | (inherited from Page )
CreateResourceBasedLiteralControl | (inherited from TemplateControl )
DataBind | Overloaded. (inherited from Control )
DataBindChildren | (inherited from Control )
DeterminePostBackMode | (inherited from Page )
EnsureChildControls | (inherited from Control )
EnsureID | (inherited from Control )
Eval | Overloaded. (inherited from TemplateControl )
Finalize | (inherited from Object )
FindControl | Overloaded. (inherited from Control )
FrameworkInitialize | (inherited from Page )
GetDesignModeState | (inherited from Control )
GetGlobalResourceObject | Overloaded. (inherited from TemplateControl )
GetLocalResourceObject | Overloaded. (inherited from TemplateControl )
GetWrappedFileDependencies | (inherited from Page )
HasEvents | (inherited from Control )
InitializeCulture | (inherited from Page )
InitOutputCache | Overloaded. (inherited from Page )
IsLiteralContent | (inherited from Control )
LoadControlState | (inherited from Control )
LoadPageStateFromPersistenceMedium | (inherited from Page )
LoadViewState | (inherited from Control )
MapPathSecure | (inherited from Control )
MemberwiseClone | (inherited from Object )
OnAbortTransaction | (inherited from TemplateControl )
OnBubbleEvent | (inherited from Control )
OnCommitTransaction | (inherited from TemplateControl )
OnDataBinding | (inherited from Control )
OnError | (inherited from TemplateControl )
OnInit | (inherited from Page )
OnInitComplete | (inherited from Page )
OnLoad | (inherited from Control )
OnLoadComplete | (inherited from Page )
OnPreInit | (inherited from Page )
OnPreLoad | (inherited from Page )
OnPreRender | (inherited from Control )
OnPreRenderComplete | (inherited from Page )
OnSaveStateComplete | (inherited from Page )
OnUnload | (inherited from Control )
OpenFile | (inherited from Control )
RaiseBubbleEvent | (inherited from Control )
RaisePostBackEvent | (inherited from Page )
RemovedControl | (inherited from Control )
Render | (inherited from Page )
RenderChildren | (inherited from Control )
RenderControl | Overloaded. (inherited from Control )
ResolveAdapter | (inherited from Control )
SaveControlState | (inherited from Control )
SavePageStateToPersistenceMedium | (inherited from Page )
SaveViewState | (inherited from Control )
SetDesignModeState | (inherited from Control )
SetStringResourcePointer | (inherited from TemplateControl )
TrackViewState | (inherited from Control )
WriteUTF8ResourceString | (inherited from TemplateControl )
XPath | Overloaded. (inherited from TemplateControl )
XPathSelect | Overloaded. (inherited from TemplateControl )
Top

Public Events

Name | Description
AbortTransaction | (inherited from TemplateControl )
CommitTransaction | (inherited from TemplateControl )
DataBinding | (inherited from Control )
Disposed | (inherited from Control )
Error | (inherited from TemplateControl )
Init | (inherited from Control )
InitComplete | (inherited from Page )
Load | (inherited from Control )
LoadComplete | (inherited from Page )
PreInit | (inherited from Page )
PreLoad | (inherited from Page )
PreRender | (inherited from Control )
PreRenderComplete | (inherited from Page )
SaveStateComplete | (inherited from Page )
Unload | (inherited from Control )
Top

Explicit Interface Implementations

Name | Description
System.Web.IHttpHandler.ProcessRequest |
System.Web.UI.IControlDesignerAccessor.GetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetOwnerControl | (inherited from Control )
System.Web.UI.IFilterResolutionService.CompareFilters | (inherited from TemplateControl )
System.Web.UI.IFilterResolutionService.EvaluateFilter | (inherited from TemplateControl )
System.Web.UI.IParserAccessor.AddParsedSubObject | (inherited from Control )
System.Web.IHttpHandler.IsReusable |
System.Web.UI.IControlBuilderAccessor.ControlBuilder | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.UserData | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.DataBindings | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.HasDataBindings | (inherited from Control )
System.Web.UI.IExpressionsAccessor.Expressions | (inherited from Control )
System.Web.UI.IExpressionsAccessor.HasExpressions | (inherited from Control )
Top

See Also

Reference

ChartHttpHandler Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler Constructor

ChartHttpHandler Constructor |
 | See Also

Initializes a new instance of the ChartHttpHandler class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ChartHttpHandler ()
public:
ChartHttpHandler ()
public ChartHttpHandler ()
public function ChartHttpHandler ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandler Class
ChartHttpHandler Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler Methods

ChartHttpHandler Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
AddOnPreRenderCompleteAsync | Overloaded. (inherited from Page )
ApplyStyleSheetSkin | (inherited from Control )
CreateHtmlTextWriterFromType | (inherited from Page )
DataBind | Overloaded. (inherited from Control )
DesignerInitialize | (inherited from Page )
Dispose | (inherited from Control )
Equals | Overloaded. (inherited from Object )
ExecuteRegisteredAsyncTasks | (inherited from Page )
FindControl | Overloaded. (inherited from Page )
Focus | (inherited from Control )
GetDataItem | (inherited from Page )
GetHashCode | (inherited from Object )
GetPostBackClientEvent | Obsolete. (inherited from Page )
GetPostBackClientHyperlink | Obsolete. (inherited from Page )
GetPostBackEventReference | Overloaded. (inherited from Page )
GetType | (inherited from Object )
GetTypeHashCode | (inherited from Page )
GetValidators | (inherited from Page )
HasControls | (inherited from Control )
IsClientScriptBlockRegistered | Obsolete. (inherited from Page )
IsStartupScriptRegistered | Obsolete. (inherited from Page )
LoadControl | Overloaded. (inherited from TemplateControl )
LoadTemplate | (inherited from TemplateControl )
MapPath | (inherited from Page )
ParseControl | (inherited from TemplateControl )
ProcessRequest | Enables HTTP web requests to be processed by a custom HTTP handler that implements the IHttpHandler interface. (inherited from Page )
ReadStringResource | Overloaded. (inherited from TemplateControl )
ReferenceEquals | (inherited from Object )
RegisterArrayDeclaration | Obsolete. (inherited from Page )
RegisterAsyncTask | (inherited from Page )
RegisterClientScriptBlock | Obsolete. (inherited from Page )
RegisterHiddenField | Obsolete. (inherited from Page )
RegisterOnSubmitStatement | Obsolete. (inherited from Page )
RegisterRequiresControlState | (inherited from Page )
RegisterRequiresPostBack | (inherited from Page )
RegisterRequiresRaiseEvent | (inherited from Page )
RegisterRequiresViewStateEncryption | (inherited from Page )
RegisterStartupScript | Obsolete. (inherited from Page )
RegisterViewStateHandler | (inherited from Page )
RenderControl | Overloaded. (inherited from Control )
RequiresControlState | (inherited from Page )
ResolveClientUrl | (inherited from Control )
ResolveUrl | (inherited from Control )
SetFocus | Overloaded. (inherited from Page )
SetRenderMethodDelegate | (inherited from Control )
TestDeviceFilter | (inherited from TemplateControl )
ToString | (inherited from Object )
UnregisterRequiresControlState | (inherited from Page )
Validate | Overloaded. (inherited from Page )
VerifyRenderingInServerForm | (inherited from Page )

Protected Methods

Name | Description
AddContentTemplate | (inherited from Page )
AddedControl | (inherited from Control )
AddParsedSubObject | (inherited from Control )
AddWrappedFileDependencies | (inherited from Page )
AspCompatBeginProcessRequest | (inherited from Page )
AspCompatEndProcessRequest | (inherited from Page )
AsyncPageBeginProcessRequest | (inherited from Page )
AsyncPageEndProcessRequest | (inherited from Page )
BuildProfileTree | (inherited from Control )
ClearChildControlState | (inherited from Control )
ClearChildState | (inherited from Control )
ClearChildViewState | (inherited from Control )
Construct | (inherited from TemplateControl )
CreateChildControls | (inherited from Control )
CreateControlCollection | (inherited from Control )
CreateHtmlTextWriter | (inherited from Page )
CreateResourceBasedLiteralControl | (inherited from TemplateControl )
DataBind | Overloaded. (inherited from Control )
DataBindChildren | (inherited from Control )
DeterminePostBackMode | (inherited from Page )
EnsureChildControls | (inherited from Control )
EnsureID | (inherited from Control )
Eval | Overloaded. (inherited from TemplateControl )
Finalize | (inherited from Object )
FindControl | Overloaded. (inherited from Control )
FrameworkInitialize | (inherited from Page )
GetDesignModeState | (inherited from Control )
GetGlobalResourceObject | Overloaded. (inherited from TemplateControl )
GetLocalResourceObject | Overloaded. (inherited from TemplateControl )
GetWrappedFileDependencies | (inherited from Page )
HasEvents | (inherited from Control )
InitializeCulture | (inherited from Page )
InitOutputCache | Overloaded. (inherited from Page )
IsLiteralContent | (inherited from Control )
LoadControlState | (inherited from Control )
LoadPageStateFromPersistenceMedium | (inherited from Page )
LoadViewState | (inherited from Control )
MapPathSecure | (inherited from Control )
MemberwiseClone | (inherited from Object )
OnAbortTransaction | (inherited from TemplateControl )
OnBubbleEvent | (inherited from Control )
OnCommitTransaction | (inherited from TemplateControl )
OnDataBinding | (inherited from Control )
OnError | (inherited from TemplateControl )
OnInit | (inherited from Page )
OnInitComplete | (inherited from Page )
OnLoad | (inherited from Control )
OnLoadComplete | (inherited from Page )
OnPreInit | (inherited from Page )
OnPreLoad | (inherited from Page )
OnPreRender | (inherited from Control )
OnPreRenderComplete | (inherited from Page )
OnSaveStateComplete | (inherited from Page )
OnUnload | (inherited from Control )
OpenFile | (inherited from Control )
RaiseBubbleEvent | (inherited from Control )
RaisePostBackEvent | (inherited from Page )
RemovedControl | (inherited from Control )
Render | (inherited from Page )
RenderChildren | (inherited from Control )
RenderControl | Overloaded. (inherited from Control )
ResolveAdapter | (inherited from Control )
SaveControlState | (inherited from Control )
SavePageStateToPersistenceMedium | (inherited from Page )
SaveViewState | (inherited from Control )
SetDesignModeState | (inherited from Control )
SetStringResourcePointer | (inherited from TemplateControl )
TrackViewState | (inherited from Control )
WriteUTF8ResourceString | (inherited from TemplateControl )
XPath | Overloaded. (inherited from TemplateControl )
XPathSelect | Overloaded. (inherited from TemplateControl )

Explicit Interface Implementations

Name | Description
System.Web.IHttpHandler.ProcessRequest |
System.Web.UI.IControlDesignerAccessor.GetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetDesignModeState | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.SetOwnerControl | (inherited from Control )
System.Web.UI.IFilterResolutionService.CompareFilters | (inherited from TemplateControl )
System.Web.UI.IFilterResolutionService.EvaluateFilter | (inherited from TemplateControl )
System.Web.UI.IParserAccessor.AddParsedSubObject | (inherited from Control )

See Also

Reference

ChartHttpHandler Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler.System.Web.IHttpHandler.ProcessRequest Method

ChartHttpHandler.System.Web.IHttpHandler.ProcessRequest Method |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Private Sub System.Web.IHttpHandler.ProcessRequest ( _
    context As HttpContext _
) Implements IHttpHandler.ProcessRequest

void IHttpHandler.ProcessRequest (
    HttpContext context
)

private:
virtual void System.Web.IHttpHandler.ProcessRequest (
    HttpContext^ context
) sealed = IHttpHandler::ProcessRequest

J# supports the use of explicit interface implementations, but not the declaration of new ones.

JScript supports the use of explicit interface implementations, but not the declarations of new ones.

Parameters

context

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandler Class
ChartHttpHandler Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler Properties

ChartHttpHandler Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Application | (inherited from Page )
AppRelativeTemplateSourceDirectory | (inherited from Control )
AppRelativeVirtualPath | (inherited from TemplateControl )
AsyncTimeout | (inherited from Page )
BindingContainer | (inherited from Control )
Buffer | (inherited from Page )
Cache | (inherited from Page )
ClientID | (inherited from Control )
ClientQueryString | (inherited from Page )
ClientScript | (inherited from Page )
ClientTarget | (inherited from Page )
CodePage | (inherited from Page )
ContentType | (inherited from Page )
Controls | (inherited from Control )
Culture | (inherited from Page )
EnableEventValidation | (inherited from Page )
EnableTheming | (inherited from TemplateControl )
EnableViewState | (inherited from Page )
EnableViewStateMac | (inherited from Page )
ErrorPage | (inherited from Page )
Form | (inherited from Page )
Header | (inherited from Page )
ID | (inherited from Page )
IdSeparator | (inherited from Page )
IsAsync | (inherited from Page )
IsCallback | (inherited from Page )
IsCrossPagePostBack | (inherited from Page )
IsPostBack | (inherited from Page )
IsReusable | Gets a value indicating whether another request can use the IHttpHandler object. (inherited from Page )
IsValid | (inherited from Page )
Items | (inherited from Page )
LCID | (inherited from Page )
MaintainScrollPositionOnPostBack | (inherited from Page )
Master | (inherited from Page )
MasterPageFile | (inherited from Page )
MaxPageStateFieldLength | (inherited from Page )
NamingContainer | (inherited from Control )
Page | (inherited from Control )
PageAdapter | (inherited from Page )
Parent | (inherited from Control )
PreviousPage | (inherited from Page )
Request | (inherited from Page )
Response | (inherited from Page )
ResponseEncoding | (inherited from Page )
Server | (inherited from Page )
Session | (inherited from Page )
Settings | Gets the chart image storage settings registered in the web.config file under the ChartHttpHandler key.
Site | (inherited from Control )
SkinID | (inherited from Control )
SmartNavigation | Obsolete. (inherited from Page )
StyleSheetTheme | (inherited from Page )
TemplateControl | (inherited from Control )
TemplateSourceDirectory | (inherited from Control )
Theme | (inherited from Page )
Title | (inherited from Page )
Trace | (inherited from Page )
TraceEnabled | (inherited from Page )
TraceModeValue | (inherited from Page )
UICulture | (inherited from Page )
UniqueID | (inherited from Control )
User | (inherited from Page )
Validators | (inherited from Page )
ViewStateEncryptionMode | (inherited from Page )
ViewStateUserKey | (inherited from Page )
Visible | (inherited from Page )

Protected Properties

Name | Description
Adapter | (inherited from Control )
AspCompatMode | (inherited from Page )
AsyncMode | (inherited from Page )
AutoHandlers | Obsolete. (inherited from TemplateControl )
ChildControlsCreated | (inherited from Control )
ClientIDSeparator | (inherited from Control )
Context | (inherited from Page )
DesignMode | (inherited from Control )
Events | (inherited from Control )
FileDependencies | Obsolete. (inherited from Page )
HasChildViewState | (inherited from Control )
IsChildControlStateCleared | (inherited from Control )
IsTrackingViewState | (inherited from Control )
IsViewStateEnabled | (inherited from Control )
LoadViewStateByID | (inherited from Control )
PageStatePersister | (inherited from Page )
SupportAutoEvents | (inherited from TemplateControl )
TransactionMode | (inherited from Page )
UniqueFilePathSuffix | (inherited from Page )
ViewState | (inherited from Control )
ViewStateIgnoresCase | (inherited from Control )

Explicit Interface Implementations

Name | Description
System.Web.IHttpHandler.IsReusable |
System.Web.UI.IControlBuilderAccessor.ControlBuilder | (inherited from Control )
System.Web.UI.IControlDesignerAccessor.UserData | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.DataBindings | (inherited from Control )
System.Web.UI.IDataBindingsAccessor.HasDataBindings | (inherited from Control )
System.Web.UI.IExpressionsAccessor.Expressions | (inherited from Control )
System.Web.UI.IExpressionsAccessor.HasExpressions | (inherited from Control )

See Also

Reference

ChartHttpHandler Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler.Settings Property

ChartHttpHandler.Settings Property |
 | See Also

Gets the chart image storage settings registered in the web.config file under the ChartHttpHandler key.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Shared ReadOnly Property Settings As ChartHttpHandlerSettings
public static ChartHttpHandlerSettings Settings { get; }
public:
static property ChartHttpHandlerSettings^ Settings {
    ChartHttpHandlerSettings^ get ();
}
/** @property */
public static ChartHttpHandlerSettings get_Settings ()

public static function get Settings () : ChartHttpHandlerSettings

Property Value

A ChartHttpHandlerSettings object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandler Class
ChartHttpHandler Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler.System.Web.IHttpHandler.IsReusable Property

ChartHttpHandler.System.Web.IHttpHandler.IsReusable Property |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Private ReadOnly Property System.Web.IHttpHandler.IsReusable As Boolean Implements IHttpHandler.IsReusable

bool IHttpHandler.IsReusable { get; }

private:
virtual property bool System.Web.IHttpHandler.IsReusable {
    bool get () sealed = IHttpHandler::IsReusable::get;
}

J# supports the use of explicit interface implementations, but not the declaration of new ones.

JScript supports the use of explicit interface implementations, but not the declarations of new ones.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandler Class
ChartHttpHandler Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandler Events

ChartHttpHandler Events |
 | See Also

Public Events

Name | Description
AbortTransaction | (inherited from TemplateControl )
CommitTransaction | (inherited from TemplateControl )
DataBinding | (inherited from Control )
Disposed | (inherited from Control )
Error | (inherited from TemplateControl )
Init | (inherited from Control )
InitComplete | (inherited from Page )
Load | (inherited from Control )
LoadComplete | (inherited from Page )
PreInit | (inherited from Page )
PreLoad | (inherited from Page )
PreRender | (inherited from Control )
PreRenderComplete | (inherited from Page )
SaveStateComplete | (inherited from Page )
Unload | (inherited from Control )

See Also

Reference

ChartHttpHandler Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings Class

ChartHttpHandlerSettings Class |
 | See Also Members

Provides attributes that can be used to write a custom HTTP handler for storing temporary image files.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartHttpHandlerSettings
public class ChartHttpHandlerSettings
public ref class ChartHttpHandlerSettings
public class ChartHttpHandlerSettings
public class ChartHttpHandlerSettings

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartHttpHandlerSettings

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings Members

ChartHttpHandlerSettings Members |
 | See Also Methods Properties

Provides attributes that can be used to write a custom HTTP handler for storing temporary image files.

The following tables list the members exposed by the ChartHttpHandlerSettings type.

Public Properties

Name | Description
CustomHandlerName | Gets or sets the name of the custom handler.
Directory | Gets or sets the directory of the custom handler where the temporary image files will be stored.
FolderName | Gets or sets the folder which will be used for storing images in the specified directory.
HandlerType | Gets the handler type of the custom handler.
Item | Gets a settings parameter with the specified name registered in the Web.config file under the ChartHttpHandler key.
PrivateImages | Gets a flag that indicates whether the handler will utilize private images.
StorageType | Gets or sets the chart image storage type.
Timeout | Gets or sets the timeout of the custom handler.
Url | Gets or sets the URL that corresponds to the HTTP path where temporary image files are stored.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartHttpHandlerSettings Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings Methods

ChartHttpHandlerSettings Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartHttpHandlerSettings Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings Properties

ChartHttpHandlerSettings Properties |
 | See Also

Public Properties

Name | Description
CustomHandlerName | Gets or sets the name of the custom handler.
Directory | Gets or sets the directory of the custom handler where the temporary image files will be stored.
FolderName | Gets or sets the folder which will be used for storing images in the specified directory.
HandlerType | Gets the handler type of the custom handler.
Item | Gets a settings parameter with the specified name registered in the Web.config file under the ChartHttpHandler key.
PrivateImages | Gets a flag that indicates whether the handler will utilize private images.
StorageType | Gets or sets the chart image storage type.
Timeout | Gets or sets the timeout of the custom handler.
Url | Gets or sets the URL that corresponds to the HTTP path where temporary image files are stored.

See Also

Reference

ChartHttpHandlerSettings Class
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.CustomHandlerName Property

ChartHttpHandlerSettings.CustomHandlerName Property |
 | See Also

Gets or sets the name of the custom handler.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property CustomHandlerName As String
public string CustomHandlerName { get; set; }
public:
property String^ CustomHandlerName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_CustomHandlerName ()

/** @property */
public void set_CustomHandlerName (String value)

public function get CustomHandlerName () : String

public function set CustomHandlerName (value : String)

Property Value

A string value that represents the name of the custom handler.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.Directory Property

ChartHttpHandlerSettings.Directory Property |
 | See Also

Gets or sets the directory of the custom handler where the temporary image files will be stored.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Directory As String
public string Directory { get; set; }
public:
property String^ Directory {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Directory ()

/** @property */
public void set_Directory (String value)

public function get Directory () : String

public function set Directory (value : String)

Property Value

A string value that represents the directory.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.FolderName Property

ChartHttpHandlerSettings.FolderName Property |
 | See Also

Gets or sets the folder which will be used for storing images in the specified directory.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property FolderName As String
public string FolderName { get; set; }
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_FolderName ()

/** @property */
public void set_FolderName (String value)

public function get FolderName () : String

public function set FolderName (value : String)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.HandlerType Property

ChartHttpHandlerSettings.HandlerType Property |
 | See Also

Gets the handler type of the custom handler.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property HandlerType As Type
public Type HandlerType { get; }
public:
property Type^ HandlerType {
    Type^ get ();
}
/** @property */
public Type get_HandlerType ()

public function get HandlerType () : Type

Property Value

The Type of the custom handler.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.Item Property

ChartHttpHandlerSettings.Item Property |
 | See Also

Gets a settings parameter with the specified name registered in the Web.config file under the ChartHttpHandler key.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Default Property Item ( _
    name As String _
) As String
public string this [
    string name
] { get; }
public:
property String^ default [String^] {
    String^ get (String^ name);
}
/** @property */
public String get_Item (String name)

Parameters

name

Property Value

Parameter value.

Remarks

Use this method to access any parameter in the Web.config file under the ChartHttpHandler key.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.PrivateImages Property

ChartHttpHandlerSettings.PrivateImages Property |
 | See Also

Gets a flag that indicates whether the handler will utilize private images.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property PrivateImages As Boolean
public bool PrivateImages { get; }
public:
property bool PrivateImages {
    bool get ();
}
/** @property */
public boolean get_PrivateImages ()

public function get PrivateImages () : boolean

Property Value

True if the handler will utilize private images, otherwise false.

Remarks

When the PrivateImages property is set, the handler will not return images out of session scope. In addition, the client will not be able to download another user's images. This is the default behavior.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.StorageType Property

ChartHttpHandlerSettings.StorageType Property |
 | See Also

Gets or sets the chart image storage type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property StorageType As ChartHttpHandlerStorageType
public ChartHttpHandlerStorageType StorageType { get; set; }
public:
property ChartHttpHandlerStorageType StorageType {
    ChartHttpHandlerStorageType get ();
    void set (ChartHttpHandlerStorageType value);
}
/** @property */
public ChartHttpHandlerStorageType get_StorageType ()

/** @property */
public void set_StorageType (ChartHttpHandlerStorageType value)

public function get StorageType () : ChartHttpHandlerStorageType

public function set StorageType (value : ChartHttpHandlerStorageType)

Property Value

A ChartHttpHandlerStorageType enumeration value that represents the chart image storage type.

Remarks

Chart images can be stored as files or in memory.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.Timeout Property

ChartHttpHandlerSettings.Timeout Property |
 | See Also

Gets or sets the timeout of the custom handler.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Timeout As TimeSpan
public TimeSpan Timeout { get; set; }
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
/** @property */
public TimeSpan get_Timeout ()

/** @property */
public void set_Timeout (TimeSpan value)

public function get Timeout () : TimeSpan

public function set Timeout (value : TimeSpan)

Property Value

A TimeSpan enumeration value that represents the lifetime of the chart images.

Remarks

When the timeout has expired, the stored chart image is overridden by a new chart image or discarded.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerSettings.Url Property

ChartHttpHandlerSettings.Url Property |
 | See Also

Gets or sets the URL that corresponds to the HTTP path where temporary image files are stored.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Url ()

/** @property */
public void set_Url (String value)

public function get Url () : String

public function set Url (value : String)

Property Value

A string value that represents the URL.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartHttpHandlerSettings Class
ChartHttpHandlerSettings Members
System.Web.UI.DataVisualization.Charting Namespace


ChartHttpHandlerStorageType Enumeration

ChartHttpHandlerStorageType Enumeration |
 | See Also

Specifies a storage type for chart images.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartHttpHandlerStorageType
public enum ChartHttpHandlerStorageType
public enum class ChartHttpHandlerStorageType
public enum ChartHttpHandlerStorageType
public enum ChartHttpHandlerStorageType

Members

Member name | Description
File | Chart images are stored in a file.
InProcess | Chart images are stored in the private process memory. You cannot use this option in a multiple-process or farm environment.
Session | Chart images are stored in the ASP.NET session.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartImageAlignmentStyle Enumeration

ChartImageAlignmentStyle Enumeration |
 | See Also

Specifies the image alignment for a chart background image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartImageAlignmentStyle
public enum ChartImageAlignmentStyle
public enum class ChartImageAlignmentStyle
public enum ChartImageAlignmentStyle
public enum ChartImageAlignmentStyle

Members

Member name | Description
Bottom | The image is aligned to the bottom boundary of the chart element.
BottomLeft | The image is aligned to the bottom left corner of the chart element.
BottomRight | The image is aligned to the bottom right corner of the chart element.
Center | The image is aligned in the center of the chart element.
Left | The image is aligned to the left boundary of the chart element.
Right | The image is aligned to the right boundary of the chart element.
Top | The image is aligned to the top boundary of the chart element.
TopLeft | The mage is aligned to the top left corner of the chart element.
TopRight | The image is aligned to the top right corner of the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartImageFormat Enumeration

ChartImageFormat Enumeration |
 | See Also

Specifies the image type for the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartImageFormat
public enum ChartImageFormat
public enum class ChartImageFormat
public enum ChartImageFormat
public enum ChartImageFormat

Members

Member name | Description
Bmp | A bitmap (BMP) image format.
Emf | A Windows Enhanced Metafile (EMF) image format.
EmfDual | A Windows Enhanced Metafile Dual (EMF-dual) image format.
EmfPlus | A Windows Enhanced Metafile Plus (EMF+) image format.
Gif | A GIF image format.
Jpeg | A JPEG image format.
Png | A PNG image format.
Tiff | A TIFF image format.

Remarks

The ChartImageFormat enumeration represents an image type that is used to save the chart to a file or stream.

Note:
Only charts saved to disk can use the EmfDual and EmfPlus formats. Charts cannot be rendered on a Web page using EMF-dual or EMF+.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartImageType Enumeration

ChartImageType Enumeration |
 | See Also

Specifies the image type for the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartImageType
public enum ChartImageType
public enum class ChartImageType
public enum ChartImageType
public enum ChartImageType

Members

Member name | Description
Bmp | BMP image format type.
Emf | Windows Enhanced Metafile (EMF) image format type.
Jpeg | JPEG image format type.
Png | PNG image format type.

Remarks

The ChartImageType enumeration represents the image format type of the chart, as set by the ImageType property. This property determines the image type in which the chart is rendered, if image tag or input tag rendering is used.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartImageWrapMode Enumeration

ChartImageWrapMode Enumeration |
 | See Also

Specifies the drawing mode for a background image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartImageWrapMode
public enum ChartImageWrapMode
public enum class ChartImageWrapMode
public enum ChartImageWrapMode
public enum ChartImageWrapMode

Members

Member name | Description
Scaled | Background image is scaled to fit the entire chart element.
Tile | Background image is tiled to fit the entire chart element.
TileFlipX | Every other tiled image is reversed around the X-axis.
TileFlipXY | Every other tiled image is reversed around the X-axis and Y-axis.
TileFlipY | Every other tiled image is reversed around the Y-axis.
Unscaled | Background image is not scaled.

Remarks

The ChartImageWrapMode enumeration represents the drawing mode for a background image, as set by the BackImageWrapMode property of the Chart control. To set a background image for a chart element, use the BackImage property.

Note:
If you specify the Unscaled value, the location where the image is drawn will depend on the BackImageAlignment property setting.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Class

ChartNamedElement Class |
 | See Also Members

Represents the base class for most chart elements. Chart elements such as series, chart areas, and legends must have unique names, and reuse the unique name generation and validation logic provided by the ChartNamedElementCollection class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public MustInherit Class ChartNamedElement
    Inherits ChartElement
public abstract class ChartNamedElement : ChartElement
public ref class ChartNamedElement abstract : public ChartElement
public abstract class ChartNamedElement extends ChartElement
public abstract class ChartNamedElement extends ChartElement

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Members

ChartNamedElement Members |
 | See Also Methods Properties Constructors

Represents the base class for most chart elements. Chart elements such as series, chart areas, and legends must have unique names, and reuse the unique name generation and validation logic provided by the ChartNamedElementCollection class.

The following tables list the members exposed by the ChartNamedElement type.

Protected Constructors

Name | Description
ChartNamedElement | Overloaded.
Top

Public Properties

Name | Description
Name | Gets or sets the name of the chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartNamedElement Class
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Constructor

ChartNamedElement Constructor |
 | See Also

Overload List

Name | Description
ChartNamedElement () | Initializes a new instance of the ChartNamedElement class.
ChartNamedElement (String) | Initializes a new instance of the ChartNamedElement class with the specified chart element name.

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Constructor ()

ChartNamedElement Constructor () |
 | See Also

Initializes a new instance of the ChartNamedElement class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Sub New
protected ChartNamedElement ()
protected:
ChartNamedElement ()
protected ChartNamedElement ()
protected function ChartNamedElement ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Constructor (String)

ChartNamedElement Constructor (String) |
 | See Also

Initializes a new instance of the ChartNamedElement class with the specified chart element name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Sub New ( _
    name As String _
)
protected ChartNamedElement (
    string name
)
protected:
ChartNamedElement (
    String^ name
)
protected ChartNamedElement (
    String name
)
protected function ChartNamedElement (
    name : String
)

Parameters

name

The name of the new chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Methods

ChartNamedElement Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartNamedElement Class
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Properties

ChartNamedElement Properties |
 | See Also

Public Properties

Name | Description
Name | Gets or sets the name of the chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

ChartNamedElement Class
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement.Name Property

ChartNamedElement.Name Property |
 | See Also

Gets or sets the name of the chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Name As String
public virtual string Name { get; set; }
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public function get Name () : String

public function set Name (value : String)

Property Value

A string value that represents the name of the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection Generic Class

ChartNamedElementCollection Generic Class |
 | See Also Members

Represents the base class for all collections of named chart elements. Performs name management and enforces the uniqueness of the names.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public MustInherit Class ChartNamedElementCollection(Of T As ChartNamedElement)
    Inherits ChartElementCollection(Of T)
public abstract class ChartNamedElementCollection<T> : ChartElementCollection<T> where T : ChartNamedElement
generic<typename T> where T : ChartNamedElement
public ref class ChartNamedElementCollection abstract : public ChartElementCollection<T>
J# supports the use of generic types and methods, but not the declaration of new ones.
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection Members

ChartNamedElementCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents the base class for all collections of named chart elements. Performs name management and enforces the uniqueness of the names.

The following tables list the members exposed by the ChartNamedElementCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded.
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names.
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Finds the chart element by the specified name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded.
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | Determines whether the chart element with the specified name already exists in the collection.
NextUniqueName | Finds the unique name for the new element to be added to the collection.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts the specified item in the collection at the specified index.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the chart element at the specified index of the collection.
SetItem | Overridden. Replaces the chart element at the specified index with a new chart element.
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

ChartNamedElementCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection Methods

ChartNamedElementCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Finds the chart element by the specified name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded.
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | Determines whether the chart element with the specified name already exists in the collection.
NextUniqueName | Finds the unique name for the new element to be added to the collection.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts the specified item in the collection at the specified index.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the chart element at the specified index of the collection.
SetItem | Overridden. Replaces the chart element at the specified index with a new chart element.

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

ChartNamedElementCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.FindByName Method

ChartNamedElementCollection.FindByName Method |
 | See Also

Finds the chart element by the specified name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Function FindByName ( _
    name As String _
) As T
public virtual T FindByName (
    string name
)
public:
virtual T FindByName (
    String^ name
)
public T FindByName (
    String name
)
public function FindByName (
    name : String
) : T

Parameters

name

The name of the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.IndexOf Method

ChartNamedElementCollection.IndexOf Method |
 | See Also

Overload List

Name | Description
ChartNamedElementCollection.IndexOf (String) | Finds the index of the chart element with the specified name.
ChartNamedElementCollection.IndexOf (T) | (inherited from IndexOf )

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.IndexOf Method (String)

ChartNamedElementCollection.IndexOf Method (String) |
 | See Also

Finds the index of the chart element with the specified name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function IndexOf ( _
    name As String _
) As Integer
public int IndexOf (
    string name
)
public:
int IndexOf (
    String^ name
)
public int IndexOf (
    String name
)
public function IndexOf (
    name : String
) : int

Parameters

name

The name of the chart element.

Return Value

An integer value that represents the position of the chart element in the zero-based index.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.InsertItem Method

ChartNamedElementCollection.InsertItem Method |
 | See Also

Inserts the specified item in the collection at the specified index.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)
protected override void InsertItem (
    int index,
    T item
)
protected:
virtual void InsertItem (
    int index,
    T item
) override
protected void InsertItem (
    int index,
    T item
)
protected override function InsertItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index where the item is to be inserted.

item

The object to insert.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.IsUniqueName Method

ChartNamedElementCollection.IsUniqueName Method |
 | See Also

Determines whether the chart element with the specified name already exists in the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Function IsUniqueName ( _
    name As String _
) As Boolean
public virtual bool IsUniqueName (
    string name
)
public:
virtual bool IsUniqueName (
    String^ name
)
public boolean IsUniqueName (
    String name
)
public function IsUniqueName (
    name : String
) : boolean

Parameters

name

The new chart element name.

Return Value

True if the new chart element name is unique, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.NextUniqueName Method

ChartNamedElementCollection.NextUniqueName Method |
 | See Also

Finds the unique name for the new element to be added to the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Function NextUniqueName As String
public virtual string NextUniqueName ()
public:
virtual String^ NextUniqueName ()
public String NextUniqueName ()
public function NextUniqueName () : String

Return Value

A string value that represents the next unique chart element name.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.RemoveItem Method

ChartNamedElementCollection.RemoveItem Method |
 | See Also

Removes the chart element at the specified index of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
protected override void RemoveItem (
    int index
)
protected:
virtual void RemoveItem (
    int index
) override
protected void RemoveItem (
    int index
)
protected override function RemoveItem (
    index : int
)

Parameters

index

The zero-based index of the chart element to remove.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.SetItem Method

ChartNamedElementCollection.SetItem Method |
 | See Also

Replaces the chart element at the specified index with a new chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)
protected override void SetItem (
    int index,
    T item
)
protected:
virtual void SetItem (
    int index,
    T item
) override
protected void SetItem (
    int index,
    T item
)
protected override function SetItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index of the chart element to replace.

item

The new chart element to insert at the specified index.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection Properties

ChartNamedElementCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded.

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names.

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

ChartNamedElementCollection Class
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.Item Property

ChartNamedElementCollection.Item Property |
 | See Also

Overload List

Name | Description
ChartNamedElementCollection.Item (Int32) | (inherited from Item )
ChartNamedElementCollection.Item (String) | Gets or sets the chart element with the specified name.

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.Item Property (String)

ChartNamedElementCollection.Item Property (String) |
 | See Also

Gets or sets the chart element with the specified name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Default Property Item ( _
    name As String _
) As T
public T this [
    string name
] { get; set; }
public:
property T default [String^] {
    T get (String^ name);
    void set (String^ name, T value);
}
/** @property */
public T get_Item (String name)

/** @property */
public void set_Item (String name, T value)

Parameters

name

The name of the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElementCollection.NamePrefix Property

ChartNamedElementCollection.NamePrefix Property |
 | See Also

Gets the name prefix that is used to create unique chart element names.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overridable ReadOnly Property NamePrefix As String
protected virtual string NamePrefix { get; }
protected:
virtual property String^ NamePrefix {
    String^ get ();
}
/** @property */
protected String get_NamePrefix ()

protected function get NamePrefix () : String

Property Value

A string value that represents the default name prefix of the chart elements stored in the collection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs Class

ChartPaintEventArgs Class |
 | See Also Members

Provides data for the paint events of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartPaintEventArgs
    Inherits EventArgs
public class ChartPaintEventArgs : EventArgs
public ref class ChartPaintEventArgs : public EventArgs
public class ChartPaintEventArgs extends EventArgs
public class ChartPaintEventArgs extends EventArgs

Remarks

A ChartPaintEventArgs object is used to set chart properties during the PostPaint and PrePaint events of the Chart control.

The Position property allows you to position chart elements, and the ChartGraphics property facilitates GDI+ drawing operations.

The Chart property gives the developer access to the root Chart object, which can be used to set various properties of the chart.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Web.UI.DataVisualization.Charting.ChartPaintEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs Members

ChartPaintEventArgs Members |
 | See Also Methods Properties

Provides data for the paint events of the Chart control.

The following tables list the members exposed by the ChartPaintEventArgs type.

Public Properties

Name | Description
Chart | Gets the root Chart object.
ChartElement | Gets an object for the event.
ChartGraphics | Gets a ChartGraphics object.
Position | Gets an ElementPosition object.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartPaintEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs Methods

ChartPaintEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartPaintEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs Properties

ChartPaintEventArgs Properties |
 | See Also

Public Properties

Name | Description
Chart | Gets the root Chart object.
ChartElement | Gets an object for the event.
ChartGraphics | Gets a ChartGraphics object.
Position | Gets an ElementPosition object.

See Also

Reference

ChartPaintEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs.Chart Property

ChartPaintEventArgs.Chart Property |
 | See Also

Gets the root Chart object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Chart As Chart
public Chart Chart { get; }
public:
property Chart^ Chart {
    Chart^ get ();
}
/** @property */
public Chart get_Chart ()

public function get Chart () : Chart

Property Value

The root Chart object.

Remarks

The Chart property allows the developer to set chart properties during the PostPaint and PrePaint events of the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs.ChartElement Property

ChartPaintEventArgs.ChartElement Property |
 | See Also

Gets an object for the event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ChartElement As Object
public Object ChartElement { get; }
public:
property Object^ ChartElement {
    Object^ get ();
}
/** @property */
public Object get_ChartElement ()

public function get ChartElement () : Object

Property Value

An Object that represents the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs.ChartGraphics Property

ChartPaintEventArgs.ChartGraphics Property |
 | See Also

Gets a ChartGraphics object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ChartGraphics As ChartGraphics
public ChartGraphics ChartGraphics { get; }
public:
property ChartGraphics^ ChartGraphics {
    ChartGraphics^ get ();
}
/** @property */
public ChartGraphics get_ChartGraphics ()

public function get ChartGraphics () : ChartGraphics

Property Value

A ChartGraphics object.

Remarks

Use this object property during a painting event to:

  • Help with the conversion to and from relative and/or absolute chart coordinates.

  • Perform custom drawing using a GDI+ Graphics object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


ChartPaintEventArgs.Position Property

ChartPaintEventArgs.Position Property |
 | See Also

Gets an ElementPosition object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Position As ElementPosition
public ElementPosition Position { get; }
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
}
/** @property */
public ElementPosition get_Position ()

public function get Position () : ElementPosition

Property Value

An ElementPosition object.

Remarks

Use this object property during a painting event to position a chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer Class

ChartSerializer Class |
 | See Also Members

Enables serialization of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ChartSerializer
public class ChartSerializer
public ref class ChartSerializer
public class ChartSerializer
public class ChartSerializer

Remarks

This class is exposed as the Serializer property of the root Chart class.

Serialization saves the state of the chart and also provides the option to load the serialized data into the chart. All chart properties can be persisted, including the chart's data. In addition, all chart properties marked for serialization can be reset.

This class can optionally be used when managing user-defined view state. One of its Load methods can be used to load the view state, and one of the Save methods can be used when setting the view state.

The XML or binary formats can be used to store serialized data. XML is used by default, but you can change the format with the Format property.

Chart properties are saved and loaded using the Save and Load methods, respectively. Note that only properties with non-default values will be saved. Data can be saved and/or loaded using a file, stream, TextWriter, TextReader, XmlWriter and XmlReader objects. When saving and/or loading data using an object derived from the TextReader, TextWriter, XmlReader or XmlWriter classes, the format of the data must be XML.

The following list describes three techniques, from basic to advanced, used to define serializable data. Note that it is also possible to define non-serializable data. This technique is described in the next paragraph.

  • Serialize the Chart using the Save and Load methods, without specifying any serializable properties. All chart properties with non-default values, which includes chart data, will be serialized.

  • Serialize the chart properties specified by the Content property. The Content property groups the chart properties to be serialized into categories such as Data, Appearance, and so forth. Note that the names of ChartArea and Series objects are automatically serialized; the serialized data is then applied to existing chart areas and series when loaded.

Important:
The Content property is implemented internally by the Chart control as the SerializableContent property

  • Serialization of chart properties specified by the SerializableContent property. This is a comma-separated listing of all chart properties that are serializable. After this property is set to an explicit value, it is the responsibility of the developer to specify all properties to be saved. In other words, unlike the Content property, the names of chart areas and series will not be automatically persisted. The Content and SerializableContent properties can also be used in conjunction. However, make sure that SerializableContent is concatenated with itself when being set, otherwise the chart properties specified by the Content property will be overridden.

To prohibit certain properties from being serialized, use the NonSerializableContent property. When one property is set as serializable and non-serializable, which is common when wildcards are used, the SerializableContent property has precedence. However, precedence also depends on how many wildcards were used when a property was specified.

By default, serializable properties are reset to their defaults before they are loaded. This behavior can be changed using the IsResetWhenLoading property. The Reset method can also be used to explicitly reset chart properties to their default values.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartSerializer

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer Members

ChartSerializer Members |
 | See Also Methods Properties

Enables serialization of the Chart control.

The following tables list the members exposed by the ChartSerializer type.

Public Properties

Name | Description
Content | Gets or sets the type of chart content to be serialized.
Format | Gets or sets the format used when the chart is serialized.
IsResetWhenLoading | Gets or sets a flag that indicates whether object properties are reset to default values before loading.
IsTemplateMode | Gets or sets a flag that indicates whether the chart serializer is working in template-creation mode.
IsUnknownAttributeIgnored | Gets or sets a flag that indicates whether unknown XML properties and elements will be ignored without throwing an exception.
NonSerializableContent | Gets or sets the chart properties that will not be serialized.
SerializableContent | Gets or sets the chart properties that can be serialized.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Load | Overloaded. Loads serialized data into the Chart control.
ReferenceEquals | (inherited from Object )
Reset | Resets all chart properties marked for serialization.
Save | Overloaded. Saves chart properties that have non-default values. All chart properties can be serialized; this includes data.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
GetContentString | Returns a serializable or non serializable class and/or property names, depending on the specific flag value.
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartSerializer Class
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer Methods

ChartSerializer Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Load | Overloaded. Loads serialized data into the Chart control.
ReferenceEquals | (inherited from Object )
Reset | Resets all chart properties marked for serialization.
Save | Overloaded. Saves chart properties that have non-default values. All chart properties can be serialized; this includes data.
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
GetContentString | Returns a serializable or non serializable class and/or property names, depending on the specific flag value.
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartSerializer Class
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.GetContentString Method

ChartSerializer.GetContentString Method |
 | See Also

Returns a serializable or non serializable class and/or property names, depending on the specific flag value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Function GetContentString ( _
    content As SerializationContents, _
    serializable As Boolean _
) As String
protected string GetContentString (
    SerializationContents content,
    bool serializable
)
protected:
String^ GetContentString (
    SerializationContents content,
    bool serializable
)
protected String GetContentString (
    SerializationContents content,
    boolean serializable
)
protected function GetContentString (
    content : SerializationContents,
    serializable : boolean
) : String

Parameters

content

The serializable content.

serializable

True to get a serializable string; false to get a non serializaable string.

Return Value

A string value that represents the serializable or non serializable class and/or property names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Load Method

ChartSerializer.Load Method |
 | See Also

Loads serialized data into the Chart control.

Overload List

Name | Description
ChartSerializer.Load (Stream) | Loads serialized data into the control from an object derived from the Stream class.
ChartSerializer.Load (String) | Loads serialized data saved to disk into the Chart control.
ChartSerializer.Load (TextReader) | Loads serialized data into the control from a reader object that derives from the TextReader class.
ChartSerializer.Load (XmlReader) | Loads serialized data into the control from an object derived from the XmlReader class.

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Load Method (Stream)

ChartSerializer.Load Method (Stream) |
 | See Also

Loads serialized data into the control from an object derived from the Stream class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Load ( _
    stream As Stream _
)
public void Load (
    Stream stream
)
public:
void Load (
    Stream^ stream
)
public void Load (
    Stream stream
)
public function Load (
    stream : Stream
)

Parameters

stream

An object derived from the Stream class, for example, a MemoryStream object.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, serializable properties are, by default, first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. To load specific serialized properties, set the Content , SerializableContent or NonSerializableContent properties before loading the data.

Note that when data is saved using a Save method, only those properties that have non-default values are actually serialized.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Load Method (String)

ChartSerializer.Load Method (String) |
 | See Also

Loads serialized data saved to disk into the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Load ( _
    fileName As String _
)
public void Load (
    string fileName
)
public:
void Load (
    String^ fileName
)
public void Load (
    String fileName
)
public function Load (
    fileName : String
)

Parameters

fileName

The relative or absolute path of the file used to store the serialized data. If a relative path is specified, the path will be relative to the current directory.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, serializable properties are, by default, first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. To load specific serialized properties, set the Content , SerializableContent or NonSerializableContent properties before loading the data.

Note that when data is saved using a Save method, only those properties that have non-default values are actually serialized.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Load Method (TextReader)

ChartSerializer.Load Method (TextReader) |
 | See Also

Loads serialized data into the control from a reader object that derives from the TextReader class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Load ( _
    reader As TextReader _
)
public void Load (
    TextReader reader
)
public:
void Load (
    TextReader^ reader
)
public void Load (
    TextReader reader
)
public function Load (
    reader : TextReader
)

Parameters

reader

A reader, such as StringReader, that is derived from the abstract TextReader class.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, by default the serializable properties are first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. By setting the Content, SerializableContent or NonSerializableContent properties, a specific set of properties can be loaded.

If you use this definition, note that the format, which is set by the Format property, must be XML.

If the ViewStateData property of the Chart control is used to persist state, this method can be used to load the serialized data that is posted by the client back to the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Load Method (XmlReader)

ChartSerializer.Load Method (XmlReader) |
 | See Also

Loads serialized data into the control from an object derived from the XmlReader class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Load ( _
    reader As XmlReader _
)
public void Load (
    XmlReader reader
)
public:
void Load (
    XmlReader^ reader
)
public void Load (
    XmlReader reader
)
public function Load (
    reader : XmlReader
)

Parameters

reader

An object from which to read the persisted data. The object is derived from the XmlReader class, and can be a .NET Framework object or a user-defined object.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, by default serializable properties are first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. If you set the Content, SerializableContent or NonSerializableContent properties, a specific set of properties can be loaded.

When you use this definition, the format must be XML; it can be changed with the Format property.

When you work with XML format text files, for simplicity use the Load method instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Reset Method

ChartSerializer.Reset Method |
 | See Also

Resets all chart properties marked for serialization.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Reset
public void Reset ()
public:
void Reset ()
public void Reset ()
public function Reset ()

Remarks

By default, this method resets all chart properties to their default values.

To limit the chart properties that are reset to their defaults, use the Content, SerializableContent and NonSerializableContent properties.

Note that this method is also called automatically when a Load method is used and the IsResetWhenLoading property is set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Save Method

ChartSerializer.Save Method |
 | See Also

Saves chart properties that have non-default values. All chart properties can be serialized; this includes data.

Overload List

Name | Description
ChartSerializer.Save (Stream) | Saves chart data and properties with non-default values to an object that derives from the Stream class.
ChartSerializer.Save (String) | Saves chart data and properties with non-default values to the given file.
ChartSerializer.Save (TextWriter) | Saves chart data and properties with non-default values to the given object that is derived from the TextWriter class.
ChartSerializer.Save (XmlWriter) | Saves chart data and properties with non-default values to the given object that is derived from the XmlWriter class.

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Save Method (Stream)

ChartSerializer.Save Method (Stream) |
 | See Also

Saves chart data and properties with non-default values to an object that derives from the Stream class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Save ( _
    stream As Stream _
)
public void Save (
    Stream stream
)
public:
void Save (
    Stream^ stream
)
public void Save (
    Stream stream
)
public function Save (
    stream : Stream
)

Parameters

stream

An object derived from the Stream class, such as MemoryStream, that is used to save chart properties.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control chart characteristics to be serialized, use the Content, SerializableContent and NonSerializableContent properties.

If this method is used to save appearance properties as a template, make sure that the IsTemplateMode property of the ChartSerializer object is first set to true before calling this method.

Serialization of a chart as a template occurs differently from non-template serialization; template serialization concentrates on Appearance properties.

When a template is serialized, the LoadTemplate method can be used to load the template, to provide the Appearance properties for a chart.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Save Method (String)

ChartSerializer.Save Method (String) |
 | See Also

Saves chart data and properties with non-default values to the given file.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Save ( _
    fileName As String _
)
public void Save (
    string fileName
)
public:
void Save (
    String^ fileName
)
public void Save (
    String fileName
)
public function Save (
    fileName : String
)

Parameters

fileName

The relative or absolute path of the file used to store the serialized data. Note that if a relative path is specified, the path will be relative to the current directory.

Remarks

By default all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control chart characteristics to be serialized use the Content, SerializableContent and NonSerializableContent properties.

By default data is saved in an XML format. To save the data in a binary format, use the Format property.

Note that Write permissions must be enabled for the directory in which the file is stored. By default, this is the Bin folder of the application.

If this method is being used to save Appearance properties as a template, make sure that the IsTemplateMode property is first set to true before calling this method.

Serialization of a chart as a template proceeds differently from non-template serialization, primarily because template serialization concentrates on Appearance properties.

When a template is serialized, the LoadTemplate method can be used to load the template, to provide the Appearance properties for a chart.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Save Method (TextWriter)

ChartSerializer.Save Method (TextWriter) |
 | See Also

Saves chart data and properties with non-default values to the given object that is derived from the TextWriter class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Save ( _
    writer As TextWriter _
)
public void Save (
    TextWriter writer
)
public:
void Save (
    TextWriter^ writer
)
public void Save (
    TextWriter writer
)
public function Save (
    writer : TextWriter
)

Parameters

writer

An object derived from TextWriter class, for example, StringWriter, that is used to save chart properties.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control which chart characteristics are serialized, use the Content, SerializableContent and NonSerializableContent properties.

When you use this definition, the format must be XML; the format can be set with the Format property.

If the ViewStateData property of the Chart control is used to persist state, this method can be used to save the serialized data to an object derived from TextWriter, which is then used to write the data to the ViewStateData property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Save Method (XmlWriter)

ChartSerializer.Save Method (XmlWriter) |
 | See Also

Saves chart data and properties with non-default values to the given object that is derived from the XmlWriter class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Save ( _
    writer As XmlWriter _
)
public void Save (
    XmlWriter writer
)
public:
void Save (
    XmlWriter^ writer
)
public void Save (
    XmlWriter writer
)
public function Save (
    writer : XmlWriter
)

Parameters

writer

An object derived from XmlWriter used to save Chart properties.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control which chart characteristics are serialized, use the Content, SerializableContent and NonSerializableContent properties.

When you use this definition, the format must be XML; the format can be changed with the Format property.

When you work with XML format text files, for simplicity use the Save method instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer Properties

ChartSerializer Properties |
 | See Also

Public Properties

Name | Description
Content | Gets or sets the type of chart content to be serialized.
Format | Gets or sets the format used when the chart is serialized.
IsResetWhenLoading | Gets or sets a flag that indicates whether object properties are reset to default values before loading.
IsTemplateMode | Gets or sets a flag that indicates whether the chart serializer is working in template-creation mode.
IsUnknownAttributeIgnored | Gets or sets a flag that indicates whether unknown XML properties and elements will be ignored without throwing an exception.
NonSerializableContent | Gets or sets the chart properties that will not be serialized.
SerializableContent | Gets or sets the chart properties that can be serialized.

See Also

Reference

ChartSerializer Class
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Content Property

ChartSerializer.Content Property |
 | See Also

Gets or sets the type of chart content to be serialized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Content As SerializationContents
public SerializationContents Content { get; set; }
public:
property SerializationContents Content {
    SerializationContents get ();
    void set (SerializationContents value);
}
/** @property */
public SerializationContents get_Content ()

/** @property */
public void set_Content (SerializationContents value)

public function get Content () : SerializationContents

public function set Content (value : SerializationContents)

Property Value

A SerializationContents enumeration value that represents the chart content that will be serialized during a load, save or reset operation. By default, all non-default chart properties, including data, are persisted.

Remarks

By default, all chart properties will be serialized when any of the Save and Load methods are called. To provide more control over what is serialized, use the Content property. Note that the SerializableContent and NonSerializableContent properties can also be used along with the Content property.

Important The Content property determines types of chart characteristics, such as "appearance", to be serialized, and is actually implemented internally as the SerializableContent property. This means that setting the Content property and then setting the SerializableContent property will result in the Content property value being overridden, unless SerializableContent is concatenated. See the sample code below for an example of this procedure.

If you set the Content property, all ChartArea and Series objects names will automatically be serialized; this means that serialized data that pertains to chart areas and series will be applied to existing objects when loaded.

Setting this property affects all load, save and reset operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.Format Property

ChartSerializer.Format Property |
 | See Also

Gets or sets the format used when the chart is serialized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Format As SerializationFormat
public SerializationFormat Format { get; set; }
public:
property SerializationFormat Format {
    SerializationFormat get ();
    void set (SerializationFormat value);
}
/** @property */
public SerializationFormat get_Format ()

/** @property */
public void set_Format (SerializationFormat value)

public function get Format () : SerializationFormat

public function set Format (value : SerializationFormat)

Property Value

A SerializationFormat enumeration value that represents the format of the serialized data. The default value is XML.

Remarks

Data can be serialized in either an XML or binary format. Binary format is compact, and takes less storage than XML. XML, however, is a text format that is human-readable.

When you save or load serialized data, the format must be XML.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.IsResetWhenLoading Property

ChartSerializer.IsResetWhenLoading Property |
 | See Also

Gets or sets a flag that indicates whether object properties are reset to default values before loading.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsResetWhenLoading As Boolean
public bool IsResetWhenLoading { get; set; }
public:
property bool IsResetWhenLoading {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsResetWhenLoading ()

/** @property */
public void set_IsResetWhenLoading (boolean value)

public function get IsResetWhenLoading () : boolean

public function set IsResetWhenLoading (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.IsTemplateMode Property

ChartSerializer.IsTemplateMode Property |
 | See Also

Gets or sets a flag that indicates whether the chart serializer is working in template-creation mode.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsTemplateMode As Boolean
public bool IsTemplateMode { get; set; }
public:
property bool IsTemplateMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsTemplateMode ()

/** @property */
public void set_IsTemplateMode (boolean value)

public function get IsTemplateMode () : boolean

public function set IsTemplateMode (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.IsUnknownAttributeIgnored Property

ChartSerializer.IsUnknownAttributeIgnored Property |
 | See Also

Gets or sets a flag that indicates whether unknown XML properties and elements will be ignored without throwing an exception.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsUnknownAttributeIgnored As Boolean
public bool IsUnknownAttributeIgnored { get; set; }
public:
property bool IsUnknownAttributeIgnored {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsUnknownAttributeIgnored ()

/** @property */
public void set_IsUnknownAttributeIgnored (boolean value)

public function get IsUnknownAttributeIgnored () : boolean

public function set IsUnknownAttributeIgnored (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.NonSerializableContent Property

ChartSerializer.NonSerializableContent Property |
 | See Also

Gets or sets the chart properties that will not be serialized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property NonSerializableContent As String
public string NonSerializableContent { get; set; }
public:
property String^ NonSerializableContent {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_NonSerializableContent ()

/** @property */
public void set_NonSerializableContent (String value)

public function get NonSerializableContent () : String

public function set NonSerializableContent (value : String)

Property Value

A comma-separated string expression that represents the chart properties that will not be serialized. The syntax is "Class.Property[,Class.Property]".

Remarks

By default all chart properties will be serialized when the Save and Load methods are called. You can use the NonSerializableContent property to limit chart characteristics to be serialized, along with the SerializableContent and Content properties.

This property determines which chart characteristics will not be serialized. Wildcards can be used in the string expression, in the same manner as the SerializableContent property. For example, to exclude all chart BackColor properties from serialization, set this property to "*.BackColor".

Sometimes, a property can be set to be both serialized and not serialized, which is common when wildcards are used. The NonSerializableContent expression has a lower priority when compared to the SerializableContent expression. However, note that less weight is given to string expressions that use wildcards. For example, if the SerializableContent property is set to "*.BackColor" and the NonSerializableContent property is set to BackColor, all BackColor properties except for ChartArea objects will be serialized.

If the Content property has been set, the priority depends on how many wild cards are used in the NonSerializableContent expression. For example, setting the Content property to Appearance will result in the SerializableContent property containing a "*.Back*" expression. If the NonSerializableContent property is set to "*.Back*", all Back* chart properties such as BackColor, BackGradient, and so forth, will still be serialized. This is because the SerializableContent property value has higher priority when compared to the NonSerializableContent property.

This property affects all save, load and reset operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartSerializer.SerializableContent Property

ChartSerializer.SerializableContent Property |
 | See Also

Gets or sets the chart properties that can be serialized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SerializableContent As String
public string SerializableContent { get; set; }
public:
property String^ SerializableContent {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_SerializableContent ()

/** @property */
public void set_SerializableContent (String value)

public function get SerializableContent () : String

public function set SerializableContent (value : String)

Property Value

A comma-separated string expression that represents the chart properties to be serialized. The syntax is "Class.Property[,Class.Property]".

Remarks

By default all chart properties will be serialized when the Save and Load methods are called. You can use the NonSerializableContent property to limit chart characteristics to be serialized, along with the SerializableContent and Content properties.

The SerializableContent property determines which chart characteristics will be serialized. Wildcards can be used in the string expression, in the same manner as the NonSerializableContent property. For example, to serialize all chart BackColor properties, set this property to "*.BackColor".

If ChartArea and/or Series child properties are specified, then the names of all ChartArea and Series objects must be also specified to enable the persisted data to be applied to existing ChartArea and Series objects; that is, you must specify "Series.Name" and "ChartArea.Name" expressions. See the sample code below for an example of this procedure. Similarly, if multiple chart areas are being used, the ChartArea property of all plotted Series must also be saved.

Sometimes, a property can be set to be both serialized and not serialized, which is common when wildcards are used. The NonSerializableContent expression has a lower priority when compared to the SerializableContent expression. However, note that less weight is given to string expressions that use wildcards. For example, if the SerializableContent property is set to "*.BackColor" and the NonSerializableContent property is set to BackColor, all BackColor properties except for ChartArea objects will be serialized.

If you set the Content property, the SerializableContent property will be set internally. If the Content property is already set but another property needs to be serialized, make sure to concatenate the SerializableContent property when specifying that extra property. See the sample code below for an example of this procedure.

This property affects all save, load and reset operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members
System.Web.UI.DataVisualization.Charting Namespace


ChartValueType Enumeration

ChartValueType Enumeration |
 | See Also

Specifies value types for various chart properties.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ChartValueType
public enum ChartValueType
public enum class ChartValueType
public enum ChartValueType
public enum ChartValueType

Members

Member name | Description
Auto | Property type is set automatically by the Chart control.
Date | The date portion of a DateTime value.
DateTime | A DateTime value.
DateTimeOffset | A DateTime value with offset.
Double | A Double value.
Int32 | A Int32 value.
Int64 | A Int64 value.
Single | A Single value.
String | A String value.
Time | The time portion of the DateTime value.
UInt32 | A UInt32 value.
UInt64 | A UInt64 value.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


CompareMethod Enumeration

CompareMethod Enumeration |
 | See Also

Specifies the type of comparison to be used when filtering data. This enumeration is used by the Filter method definitions in the DataManipulator class that take the CompareMethod argument.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration CompareMethod
public enum CompareMethod
public enum class CompareMethod
public enum CompareMethod
public enum CompareMethod

Members

Member name | Description
EqualTo | If the data point value is equal to the compared value, the point is filtered.
LessThan | If the data point value is less than the compared value, the point is filtered.
LessThanOrEqualTo | If the data point value is less than or equal to the compared value, the point is filtered.
MoreThan | If the data point value is more than the compared value, the point is filtered.
MoreThanOrEqualTo | If the data point value more than or equal to the compared value, the point is filtered.
NotEqualTo | If the data point value is not equal to the compared value, the point is filtered.

Remarks

The CompareMethod enumeration represents a comparison type for certain filtering operations.

Note:
By default, if the filtering criteria are met, a data point is either removed or marked as empty. However, data points can be filtered even if they do not match the filtering criteria, by setting the FilterMatchedPoints property to false.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Class

CustomizeLegendEventArgs Class |
 | See Also Members

Provides data for the CustomizeLegend event of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class CustomizeLegendEventArgs
    Inherits EventArgs
public class CustomizeLegendEventArgs : EventArgs
public ref class CustomizeLegendEventArgs : public EventArgs
public class CustomizeLegendEventArgs extends EventArgs
public class CustomizeLegendEventArgs extends EventArgs

Remarks

The CustomizeLegendEventArgs class is used in the CustomizeLegend event.

There are only two properties in this class. The LegendItems property allows you to delete or modify both default and custom legend items, and to add custom legend items. This property can also be used to change the order of legend items.

The LegendName property is used to identify the legend that raised this event.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Web.UI.DataVisualization.Charting.CustomizeLegendEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Members

CustomizeLegendEventArgs Members |
 | See Also Constructors Methods Properties

Provides data for the CustomizeLegend event of the Chart control.

The following tables list the members exposed by the CustomizeLegendEventArgs type.

Public Constructors

Name | Description
CustomizeLegendEventArgs | Overloaded. Initializes a new instance of the CustomizeLegendEventArgs class.
Top

Public Properties

Name | Description
LegendItems | Used to remove, modify or change the order of both custom and default legend items in the CustomizeLegend event. Can also be used to add custom legend items.
LegendName | Gets the name of the Legend object, which can be used to determine which legend was the sender of the CustomizeLegend event.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomizeLegendEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Constructor

CustomizeLegendEventArgs Constructor |
 | See Also

Initializes a new instance of the CustomizeLegendEventArgs class.

Overload List

Name | Description
CustomizeLegendEventArgs (LegendItemsCollection) | Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection.
CustomizeLegendEventArgs (LegendItemsCollection, String) | Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection and legend name.

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Constructor (LegendItemsCollection)

CustomizeLegendEventArgs Constructor (LegendItemsCollection) |
 | See Also

Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    legendItems As LegendItemsCollection _
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems
)
public:
CustomizeLegendEventArgs (
    LegendItemsCollection^ legendItems
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems
)
public function CustomizeLegendEventArgs (
    legendItems : LegendItemsCollection
)

Parameters

legendItems

The LegendItemsCollection.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Constructor (LegendItemsCollection, String)

CustomizeLegendEventArgs Constructor (LegendItemsCollection, String) |
 | See Also

Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection and legend name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    legendItems As LegendItemsCollection, _
    legendName As String _
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems,
    string legendName
)
public:
CustomizeLegendEventArgs (
    LegendItemsCollection^ legendItems,
    String^ legendName
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems,
    String legendName
)
public function CustomizeLegendEventArgs (
    legendItems : LegendItemsCollection,
    legendName : String
)

Parameters

legendItems

The LegendItemsCollection.

legendName

The legend name.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Methods

CustomizeLegendEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomizeLegendEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs Properties

CustomizeLegendEventArgs Properties |
 | See Also

Public Properties

Name | Description
LegendItems | Used to remove, modify or change the order of both custom and default legend items in the CustomizeLegend event. Can also be used to add custom legend items.
LegendName | Gets the name of the Legend object, which can be used to determine which legend was the sender of the CustomizeLegend event.

See Also

Reference

CustomizeLegendEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs.LegendItems Property

CustomizeLegendEventArgs.LegendItems Property |
 | See Also

Used to remove, modify or change the order of both custom and default legend items in the CustomizeLegend event. Can also be used to add custom legend items.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property LegendItems As LegendItemsCollection
public LegendItemsCollection LegendItems { get; }
public:
property LegendItemsCollection^ LegendItems {
    LegendItemsCollection^ get ();
}
/** @property */
public LegendItemsCollection get_LegendItems ()

public function get LegendItems () : LegendItemsCollection

Property Value

A LegendItemsCollection object.

Remarks

The LegendItems property allows you to delete or modify both default and custom legend items in the CustomizeLegend event, and to add custom legend items. The order of legend items can also be changed.

Note:
The SeriesPointIndex and LegendItem.SeriesPointIndex properties can be used to determine the data element that is associated with a default legend item. These properties will return zero-length strings for custom legend items, because custom items are not associated with chart data.

This property enables you to determine which Legend the event was raised for, which enables you to customize an individual Legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeLegendEventArgs.LegendName Property

CustomizeLegendEventArgs.LegendName Property |
 | See Also

Gets the name of the Legend object, which can be used to determine which legend was the sender of the CustomizeLegend event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property LegendName As String
public string LegendName { get; }
public:
property String^ LegendName {
    String^ get ();
}
/** @property */
public String get_LegendName ()

public function get LegendName () : String

Property Value

A string value that represents the name of the associated Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeMapAreasEventArgs Class

CustomizeMapAreasEventArgs Class |
 | See Also Members

Provides data for the CustomizeMapAreas event of the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class CustomizeMapAreasEventArgs
    Inherits EventArgs
public class CustomizeMapAreasEventArgs : EventArgs
public ref class CustomizeMapAreasEventArgs : public EventArgs
public class CustomizeMapAreasEventArgs extends EventArgs
public class CustomizeMapAreasEventArgs extends EventArgs

Remarks

This class provides data for the CustomizeMapAreas event of the Chart control.

The only property of this class is the MapAreaItemss property, which enables developers to:

  • Delete or customize map areas that have been created for a chart object; any DataPoint, Series, LegendItem or StripLine object that has a non-empty Url, MapAreaAttributes or ToolTip property will have an associated map area object.

  • Add custom map areas that have a user-defined shape and coordinates.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Web.UI.DataVisualization.Charting.CustomizeMapAreasEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeMapAreasEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeMapAreasEventArgs Members

CustomizeMapAreasEventArgs Members |
 | See Also Constructors Methods Properties

Provides data for the CustomizeMapAreas event of the Chart control.

The following tables list the members exposed by the CustomizeMapAreasEventArgs type.

Public Constructors

Name | Description
CustomizeMapAreasEventArgs | Initializes a new instance of the CustomizeMapAreasEventArgs class with the specified map areas collection.
Top

Public Properties

Name | Description
MapAreaItems | Gets or sets a MapAreasCollection object. Can be used to remove or modify map areas that correspond to a chart object, or to add custom map areas.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomizeMapAreasEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


CustomizeMapAreasEventArgs Constructor

CustomizeMapAreasEventArgs Constructor |
 | See Also

Initializes a new instance of the CustomizeMapAreasEventArgs class with the specified map areas collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    areaItems As MapAreasCollection _
)
public CustomizeMapAreasEventArgs (
    MapAreasCollection areaItems
)
public:
CustomizeMapAreasEventArgs (
    MapAreasCollection^ areaItems
)
public CustomizeMapAreasEventArgs (
    MapAreasCollection areaItems
)
public function CustomizeMapAreasEventArgs (
    areaItems : MapAreasCollection
)

Parameters

areaItems

A map areas collection.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeMapAreasEventArgs Class
CustomizeMapAreasEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomizeMapAreasEventArgs Methods

CustomizeMapAreasEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomizeMapAreasEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


CustomizeMapAreasEventArgs Properties

CustomizeMapAreasEventArgs Properties |
 | See Also

Public Properties

Name | Description
MapAreaItems | Gets or sets a MapAreasCollection object. Can be used to remove or modify map areas that correspond to a chart object, or to add custom map areas.

See Also

Reference

CustomizeMapAreasEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


CustomizeMapAreasEventArgs.MapAreaItems Property

CustomizeMapAreasEventArgs.MapAreaItems Property |
 | See Also

Gets or sets a MapAreasCollection object. Can be used to remove or modify map areas that correspond to a chart object, or to add custom map areas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property MapAreaItems As MapAreasCollection
public MapAreasCollection MapAreaItems { get; }
public:
property MapAreasCollection^ MapAreaItems {
    MapAreasCollection^ get ();
}
/** @property */
public MapAreasCollection get_MapAreaItems ()

public function get MapAreaItems () : MapAreasCollection

Property Value

A MapAreasCollection object.

Remarks

This property allows you to:

  • Delete or customize map areas that have been created for a chart object; any DataPoint, Series, LegendItem or StripLine object that has a non-empty Url, MapAreaAttributes or ToolTip property will have an associated map area object.

  • Add custom map areas that have a user-defined shape and coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeMapAreasEventArgs Class
CustomizeMapAreasEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Class

CustomLabel Class |
 | See Also Members

Represents a custom label for an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class CustomLabel
    Inherits ChartNamedElement
    Implements IChartMapArea
public class CustomLabel : ChartNamedElement, IChartMapArea
public ref class CustomLabel : public ChartNamedElement, IChartMapArea
public class CustomLabel extends ChartNamedElement implements IChartMapArea
public class CustomLabel extends ChartNamedElement implements IChartMapArea

Remarks

CustomLabel objects are stored in the CustomLabelsCollection class, which is exposed as the CustomLabels property of the Axis class.

Axis labels for the first label row are automatically generated unless custom labels are specified using the CustomLabels property. If you specify a custom label along the first label row, no axis labels will be automatically generated for the entire first row.

Only custom labels may be used for the second label row.

The ToPosition and FromPosition properties determine the axis range that the label applies to.

A grid line and/or tick mark can be displayed for a custom axis label by using the GridTicks property; this property specifies whether a custom grid line or tick mark will be drawn in the middle of the label range.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.CustomLabel

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Members

CustomLabel Members |
 | See Also Constructors Methods Properties

Represents a custom label for an axis.

The following tables list the members exposed by the CustomLabel type.

Public Constructors

Name | Description
CustomLabel | Overloaded.
Top

Public Properties

Name | Description
Axis | Gets the axis that this CustomLabel object belongs to.
ForeColor | Gets or sets the text color of the custom label.
FromPosition | Gets or sets the beginning position, in axis coordinates, of the custom label.
GridTicks | Gets or sets a property that specifies whether custom tick marks and grid lines will be drawn in the center of the label.
Image | Gets or sets the custom label image.
ImageMapAreaAttributes | Gets or sets a string that represents the area attributes of a custom label image.
ImagePostBackValue | Gets or sets the postback value that can be processed on a Click event.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when a custom label image is drawn.
ImageUrl | Gets or sets the URL target of the label image.
LabelMark | Gets or sets the label mark for a custom label. This applies to labels in the second row only.
MapAreaAttributes | Gets or sets the map area attributes, if any, of the custom label.
MarkColor | Gets or sets the marker color for the custom label.
Name | Overridden. Gets or sets the name of the custom label.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
RowIndex | Gets or sets the index of the custom label row.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the custom label text.
ToolTip | Gets or sets the custom label tooltip text.
ToPosition | Gets or sets the starting position of the custom label, in axis coordinates.
Url | Gets or sets the target URL of the custom label.
Top

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns a cloned label object.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomLabel Class
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Constructor

CustomLabel Constructor |
 | See Also

Overload List

Name | Description
CustomLabel () | Creates a new instance of the CustomLabel class.
CustomLabel (Double, Double, String, Int32, LabelMarkStyle) | Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, and markStyle parameters.
CustomLabel (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) | Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, markStyle and gridTick parameters.

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Constructor ()

CustomLabel Constructor () |
 | See Also

Creates a new instance of the CustomLabel class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public CustomLabel ()
public:
CustomLabel ()
public CustomLabel ()
public function CustomLabel ()

Remarks

This constructor can be used to create and initialize a new instance of the CustomLabel class.

However, it is recommended that you use one of the Add methods in the CustomLabelsCollection class to add custom labels.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle)

CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle) |
 | See Also

Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, and markStyle parameters.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    labelRow As Integer, _
    markStyle As LabelMarkStyle _
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    string text,
    int labelRow,
    LabelMarkStyle markStyle
)
public:
CustomLabel (
    double fromPosition,
    double toPosition,
    String^ text,
    int labelRow,
    LabelMarkStyle markStyle
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    String text,
    int labelRow,
    LabelMarkStyle markStyle
)
public function CustomLabel (
    fromPosition : double,
    toPosition : double,
    text : String,
    labelRow : int,
    markStyle : LabelMarkStyle
)

Parameters

fromPosition

The beginning of the axis range the label applies to.

toPosition

The end of the axis range the label applies to.

text

The label text.

labelRow

The label row index.

markStyle

The label mark style.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes)

CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) |
 | See Also

Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, markStyle and gridTick parameters.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    labelRow As Integer, _
    markStyle As LabelMarkStyle, _
    gridTick As GridTickTypes _
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    string text,
    int labelRow,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public:
CustomLabel (
    double fromPosition,
    double toPosition,
    String^ text,
    int labelRow,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    String text,
    int labelRow,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public function CustomLabel (
    fromPosition : double,
    toPosition : double,
    text : String,
    labelRow : int,
    markStyle : LabelMarkStyle,
    gridTick : GridTickTypes
)

Parameters

fromPosition

The beginning of the axis range the label applies to.

toPosition

The end of the axis range the label applies to.

text

The label text.

labelRow

The label row index.

markStyle

The label mark style.

gridTick

The custom grid line and/or tick marks flag.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Methods

CustomLabel Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns a cloned label object.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomLabel Class
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.Clone Method

CustomLabel.Clone Method |
 | See Also

Returns a cloned label object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Clone As CustomLabel
public CustomLabel Clone ()
public:
CustomLabel^ Clone ()
public CustomLabel Clone ()
public function Clone () : CustomLabel

Return Value

A CustomLabel object that represents a copy of the current custom label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel Properties

CustomLabel Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets the axis that this CustomLabel object belongs to.
ForeColor | Gets or sets the text color of the custom label.
FromPosition | Gets or sets the beginning position, in axis coordinates, of the custom label.
GridTicks | Gets or sets a property that specifies whether custom tick marks and grid lines will be drawn in the center of the label.
Image | Gets or sets the custom label image.
ImageMapAreaAttributes | Gets or sets a string that represents the area attributes of a custom label image.
ImagePostBackValue | Gets or sets the postback value that can be processed on a Click event.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when a custom label image is drawn.
ImageUrl | Gets or sets the URL target of the label image.
LabelMark | Gets or sets the label mark for a custom label. This applies to labels in the second row only.
MapAreaAttributes | Gets or sets the map area attributes, if any, of the custom label.
MarkColor | Gets or sets the marker color for the custom label.
Name | Overridden. Gets or sets the name of the custom label.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
RowIndex | Gets or sets the index of the custom label row.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the custom label text.
ToolTip | Gets or sets the custom label tooltip text.
ToPosition | Gets or sets the starting position of the custom label, in axis coordinates.
Url | Gets or sets the target URL of the custom label.

See Also

Reference

CustomLabel Class
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.Axis Property

CustomLabel.Axis Property |
 | See Also

Gets the axis that this CustomLabel object belongs to.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Axis As Axis
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Axis Axis { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Axis^ Axis {
    Axis^ get ();
}
/** @property */
public Axis get_Axis ()

public function get Axis () : Axis

Property Value

An Axis object.

Remarks

Use this method to determine which Axis object the CustomLabel object belongs to.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ForeColor Property

CustomLabel.ForeColor Property |
 | See Also

Gets or sets the text color of the custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value that represents the text color of a custom label.

Remarks

The ForeColor property determines the text color for a custom label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.FromPosition Property

CustomLabel.FromPosition Property |
 | See Also

Gets or sets the beginning position, in axis coordinates, of the custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property FromPosition As Double
public double FromPosition { get; set; }
public:
property double FromPosition {
    double get ();
    void set (double value);
}
/** @property */
public double get_FromPosition ()

/** @property */
public void set_FromPosition (double value)

public function get FromPosition () : double

public function set FromPosition (value : double)

Property Value

A double value that represents the beginning of the axis range that the label is applied to.

Remarks

The FromPosition property determines the start position of the axis range the label is applied to.

The difference between the values of the ToPosition and FromPosition properties determines where the label text will be displayed. For example, suppose the X-axis has a scale that ranges from 1 to 5 (1, 2 ,3 , 4, 5). In order to display a custom label just underneath the second point, you would set the ToPosition property to 1.5 and the FromPosition property to 2.5.

If the XValueType—or YValueType, depending on the axis in question—is set to a DateTime value, then this FromPosition property will be displayed as a DateTime value in the designer.

This property should not be set to the same value as the ToPosition property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.GridTicks Property

CustomLabel.GridTicks Property |
 | See Also

Gets or sets a property that specifies whether custom tick marks and grid lines will be drawn in the center of the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property GridTicks As GridTickTypes
public GridTickTypes GridTicks { get; set; }
public:
property GridTickTypes GridTicks {
    GridTickTypes get ();
    void set (GridTickTypes value);
}
/** @property */
public GridTickTypes get_GridTicks ()

/** @property */
public void set_GridTicks (GridTickTypes value)

public function get GridTicks () : GridTickTypes

public function set GridTicks (value : GridTickTypes)

Property Value

A GridTickTypes enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.Image Property

CustomLabel.Image Property |
 | See Also

Gets or sets the custom label image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Image As String
public string Image { get; set; }
public:
property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the name of the custom label image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ImageMapAreaAttributes Property

CustomLabel.ImageMapAreaAttributes Property |
 | See Also

Gets or sets a string that represents the area attributes of a custom label image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageMapAreaAttributes As String
public string ImageMapAreaAttributes { get; set; }
public:
property String^ ImageMapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ImageMapAreaAttributes ()

/** @property */
public void set_ImageMapAreaAttributes (String value)

public function get ImageMapAreaAttributes () : String

public function set ImageMapAreaAttributes (value : String)

Property Value

A string value that represents the area attributes of a custom label's image map.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ImagePostBackValue Property

CustomLabel.ImagePostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImagePostBackValue As String
public string ImagePostBackValue { get; set; }
public:
property String^ ImagePostBackValue {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ImagePostBackValue ()

/** @property */
public void set_ImagePostBackValue (String value)

public function get ImagePostBackValue () : String

public function set ImagePostBackValue (value : String)

Property Value

A string value that represents the value that is passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ImageTransparentColor Property

CustomLabel.ImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when a custom label image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageTransparentColor As Color
public Color ImageTransparentColor { get; set; }
public:
property Color ImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ImageTransparentColor ()

/** @property */
public void set_ImageTransparentColor (Color value)

public function get ImageTransparentColor () : Color

public function set ImageTransparentColor (value : Color)

Property Value

A Color value which is replaced with a transparent color when you draw the image. The default value is Magenta.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ImageUrl Property

CustomLabel.ImageUrl Property |
 | See Also

Gets or sets the URL target of the label image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageUrl As String
public string ImageUrl { get; set; }
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ImageUrl ()

/** @property */
public void set_ImageUrl (String value)

public function get ImageUrl () : String

public function set ImageUrl (value : String)

Property Value

A string value that represents the destination URL that is pointed to by this custom label image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.LabelMark Property

CustomLabel.LabelMark Property |
 | See Also

Gets or sets the label mark for a custom label. This applies to labels in the second row only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelMark As LabelMarkStyle
public LabelMarkStyle LabelMark { get; set; }
public:
property LabelMarkStyle LabelMark {
    LabelMarkStyle get ();
    void set (LabelMarkStyle value);
}
/** @property */
public LabelMarkStyle get_LabelMark ()

/** @property */
public void set_LabelMark (LabelMarkStyle value)

public function get LabelMark () : LabelMarkStyle

public function set LabelMark (value : LabelMarkStyle)

Property Value

A LabelMarkStyle enumeration value that determines the type of label mark, if any, to be used.

Remarks

Label marks can only be used for the second row of labels, and are usually used to group labels together from the first row.

The major tick mark's line style of the relevant Axis object is used for the line pattern of the mark, for example, the AxisX.MajorTickMark.LineDashStyle property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.MapAreaAttributes Property

CustomLabel.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes, if any, of the custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value that represents the map area attributes, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.MarkColor Property

CustomLabel.MarkColor Property |
 | See Also

Gets or sets the marker color for the custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkColor As Color
public Color MarkColor { get; set; }
public:
property Color MarkColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkColor ()

/** @property */
public void set_MarkColor (Color value)

public function get MarkColor () : Color

public function set MarkColor (value : Color)

Property Value

A Color value that represents the marker color of a custom label.

Remarks

The MarkColor property determines the color of a custom label's marker.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.Name Property

CustomLabel.Name Property |
 | See Also

Gets or sets the name of the custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignOnlyAttribute(True)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property Name As String
[DesignOnlyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string Name { get; set; }
[DesignOnlyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.PostBackValue Property

CustomLabel.PostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the value that is passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.RowIndex Property

CustomLabel.RowIndex Property |
 | See Also

Gets or sets the index of the custom label row.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property RowIndex As Integer
public int RowIndex { get; set; }
public:
property int RowIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_RowIndex ()

/** @property */
public void set_RowIndex (int value)

public function get RowIndex () : int

public function set RowIndex (value : int)

Property Value

An integer value that specifies the index, 0 to 10, of the custom label row.

Remarks

The RowIndex property specifies the index of the row label where zero is the row label closest to the axis to ten, the further most axis label.

Only custom labels can be used for the label rows beyond the first row.

If a custom label is used for the first row, labels for that entire axis will not be generated automatically; in this case, all labels for the first row must then be custom labels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.Text Property

CustomLabel.Text Property |
 | See Also

Gets or sets the custom label text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the label text.

Remarks

The Text property gets or sets the label text of the CustomLabel object.

Note that axis labels for the first label row are generated automatically, but can be overridden using CustomLabel objects. If you specify a custom label along the first axis row, no axis labels will be automatically generated for the entire first row.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ToolTip Property

CustomLabel.ToolTip Property |
 | See Also

Gets or sets the custom label tooltip text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string that represents the tooltip text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.ToPosition Property

CustomLabel.ToPosition Property |
 | See Also

Gets or sets the starting position of the custom label, in axis coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToPosition As Double
public double ToPosition { get; set; }
public:
property double ToPosition {
    double get ();
    void set (double value);
}
/** @property */
public double get_ToPosition ()

/** @property */
public void set_ToPosition (double value)

public function get ToPosition () : double

public function set ToPosition (value : double)

Property Value

A double value that represents the starting position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabel.Url Property

CustomLabel.Url Property |
 | See Also

Gets or sets the target URL of the custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value that represents the URL.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection Class

CustomLabelsCollection Class |
 | See Also Members

Represents a collection of CustomLabel objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class CustomLabelsCollection
    Inherits ChartElementCollection(Of CustomLabel)
public class CustomLabelsCollection : ChartElementCollection<CustomLabel>
public ref class CustomLabelsCollection : public ChartElementCollection<CustomLabel^>
public class CustomLabelsCollection extends ChartElementCollection<CustomLabel>
public class CustomLabelsCollection extends ChartElementCollection<CustomLabel>

Remarks

The CustomLabelsCollection class represents a collection of CustomLabel objects, which in turn represent the custom labels that an Axis object can use. This class is exposed as the CustomLabels collection property of an Axis object.

Note:
You can automatically populate the entire label row of an axis with custom DateTime labels using any Add method definition that includes a DateTimeIntervalType argument.

The Count property indicates the total number of items in the collection, and is commonly used to find the upper bound of the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.CustomLabelsCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection Members

CustomLabelsCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of CustomLabel objects.

The following tables list the members exposed by the CustomLabelsCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

CustomLabelsCollection Class
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection Methods

CustomLabelsCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

CustomLabelsCollection Class
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method

CustomLabelsCollection.Add Method |
 | See Also

Overload List

Name | Description
CustomLabelsCollection.Add (CustomLabel) | (inherited from Add )
CustomLabelsCollection.Add (Double, DateTimeIntervalType) | Adds multiple CustomLabel objects of type DateTime to the collection. Populates the entire first row of an axis with labels.
CustomLabelsCollection.Add (Double, DateTimeIntervalType, String) | Adds multiple DateTime CustomLabelsCollection objects to the collection. Populates the entire first row of an axis with labels with the specified format.
CustomLabelsCollection.Add (Double, Double, String) | Adds a CustomLabel object to the collection, using the given axis range and text.
CustomLabelsCollection.Add (Double, DateTimeIntervalType, String, Int32, LabelMarkStyle) | Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, text format, row index and marking style.
CustomLabelsCollection.Add (Double, Double, String, Int32, LabelMarkStyle) | Adds a custom label to the collection, using the given axis range, text, row index and marking style.
CustomLabelsCollection.Add (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) | Adds a custom label to the collection, using the given axis range, text, row index, marking style and grid tick type.
CustomLabelsCollection.Add (Double, DateTimeIntervalType, Double, Double, String, Int32, LabelMarkStyle) | Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, and will be generated for the axis range that is determined by the min and max arguments.

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType) |
 | See Also

Adds multiple CustomLabel objects of type DateTime to the collection. Populates the entire first row of an axis with labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType
)

Parameters

labelsStep

Determines how often the custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the interval type.

Remarks

The Add method creates and initializes CustomLabel objects for the entire first label row of an axis with DateTime labels of the specified type.

The labelsStep parameter determines how often the custom labels will be drawn.

Note:
The RecalculateAxesScale method must be called prior to calling this particular method definition.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String) |
 | See Also

Adds multiple DateTime CustomLabelsCollection objects to the collection. Populates the entire first row of an axis with labels with the specified format.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType, _
    format As String _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    string format
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String^ format
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String format
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType,
    format : String
)

Parameters

labelsStep

Determines how often custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the unit of measure for the labelsStep parameter.

format

Remarks

This method creates and initializes CustomLabel objects for an axis' entire first label row with DateTime labels of the specified type.

The step determines how often the custom labels will be drawn, and optional label formatting can be specified as well.

Note:
The RecalculateAxesScale method must be called prior to calling this particular method definition.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, Double, String)

CustomLabelsCollection.Add Method (Double, Double, String) |
 | See Also

Adds a CustomLabel object to the collection, using the given axis range and text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String _
) As CustomLabel
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    string text
)
public:
CustomLabel^ Add (
    double fromPosition,
    double toPosition,
    String^ text
)
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    String text
)
public function Add (
    fromPosition : double,
    toPosition : double,
    text : String
) : CustomLabel

Parameters

fromPosition

The minimum value of the axis range to which the label is applied.

toPosition

The maximum value of the axis range to which the label is applied.

text

The label text.

Return Value

The newly added CustomLabel object.

Remarks

Adds one custom label to the first label row of the relevant axis. No label mark is used.

If a custom label is used anywhere in the first label row, no labels are automatically generated for that first row.

Note:
The RecalculateAxesScale method must be called prior to calling this particular method definition.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String, Int32, LabelMarkStyle)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String, Int32, LabelMarkStyle) |
 | See Also

Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, text format, row index and marking style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType, _
    format As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    string format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String^ format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType,
    format : String,
    rowIndex : int,
    markStyle : LabelMarkStyle
)

Parameters

labelsStep

Determines how often custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the unit of measure for the labelsStep parameter.

format

The label text format.

rowIndex

The label row index.

markStyle

A LabelMarkstyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle)

CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle) |
 | See Also

Adds a custom label to the collection, using the given axis range, text, row index and marking style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle _
) As CustomLabel
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    string text,
    int rowIndex,
    LabelMarkStyle markStyle
)
public:
CustomLabel^ Add (
    double fromPosition,
    double toPosition,
    String^ text,
    int rowIndex,
    LabelMarkStyle markStyle
)
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    String text,
    int rowIndex,
    LabelMarkStyle markStyle
)
public function Add (
    fromPosition : double,
    toPosition : double,
    text : String,
    rowIndex : int,
    markStyle : LabelMarkStyle
) : CustomLabel

Parameters

fromPosition

The minimum value of the axis range the label is applied to.

toPosition

The maximum value of the axis range the label is applied to.

text

Label text.

rowIndex

Label row index.

markStyle

A LabelMarkstyle enumeration value.

Return Value

The newly added CustomLabel object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes)

CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) |
 | See Also

Adds a custom label to the collection, using the given axis range, text, row index, marking style and grid tick type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle, _
    gridTick As GridTickTypes _
) As CustomLabel
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    string text,
    int rowIndex,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public:
CustomLabel^ Add (
    double fromPosition,
    double toPosition,
    String^ text,
    int rowIndex,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    String text,
    int rowIndex,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public function Add (
    fromPosition : double,
    toPosition : double,
    text : String,
    rowIndex : int,
    markStyle : LabelMarkStyle,
    gridTick : GridTickTypes
) : CustomLabel

Parameters

fromPosition

The minimum value of the axis range the label is applied to.

toPosition

The maximum value of the axis range the label is applied to.

text

Label text.

rowIndex

Label row index.

markStyle

A LabelMarkstyle enumeration value.

gridTick

A GridTickTypes enumeration value.

Return Value

The newly added CustomLabel object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, Double, Double, String, Int32, LabelMarkStyle)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, Double, Double, String, Int32, LabelMarkStyle) |
 | See Also

Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, and will be generated for the axis range that is determined by the min and max arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType, _
    min As Double, _
    max As Double, _
    format As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    double min,
    double max,
    string format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    double min,
    double max,
    String^ format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    double min,
    double max,
    String format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType,
    min : double,
    max : double,
    format : String,
    rowIndex : int,
    markStyle : LabelMarkStyle
)

Parameters

labelsStep

Determines how often custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the unit of measure for the labelsStep parameter.

min

Minimum value.

max

Maximum value.

format

Label text format.

rowIndex

Label row index.

markStyle

A LabelMarkstyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


CustomLabelsCollection Properties

CustomLabelsCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

CustomLabelsCollection Class
System.Web.UI.DataVisualization.Charting Namespace


CustomProperties Class

CustomProperties Class |
 | See Also Members

For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class CustomProperties
public class CustomProperties
public ref class CustomProperties
public class CustomProperties
public class CustomProperties

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.CustomProperties

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


CustomProperties Members

CustomProperties Members |
 | See Also Methods

For internal use only.

The following tables list the members exposed by the CustomProperties type.

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomProperties Class
System.Web.UI.DataVisualization.Charting Namespace


CustomProperties Methods

CustomProperties Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomProperties Class
System.Web.UI.DataVisualization.Charting Namespace


DataFormula Class

DataFormula Class |
 | See Also Members

Provides properties and methods to prepare series data for technical analysis, apply formulas on the series data and prepare output data to be displayed as a chart. The actual calculations are performed in the StatisticFormula class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class DataFormula
public class DataFormula
public ref class DataFormula
public class DataFormula
public class DataFormula

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.DataFormula
System.Web.UI.DataVisualization.Charting.DataManipulator

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula Members

DataFormula Members |
 | See Also Constructors Methods Properties

Provides properties and methods to prepare series data for technical analysis, apply formulas on the series data and prepare output data to be displayed as a chart. The actual calculations are performed in the StatisticFormula class.

The following tables list the members exposed by the DataFormula type.

Public Constructors

Name | Description
DataFormula | Initializes a new instance of the DataFormula class.
Top

Public Properties

Name | Description
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations.
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as a rolling average from zero.
Statistics | Returns a reference to the StatisticFormula class.
Top

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | Merges, splits or moves Y values in the series.
Equals | Overloaded. (inherited from Object )
FinancialFormula | Overloaded. Calls a method from a formula module with the specified parameters.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataFormula Class
System.Web.UI.DataVisualization.Charting Namespace


DataFormula Constructor

DataFormula Constructor |
 | See Also

Initializes a new instance of the DataFormula class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public DataFormula ()
public:
DataFormula ()
public DataFormula ()
public function DataFormula ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula Methods

DataFormula Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | Merges, splits or moves Y values in the series.
Equals | Overloaded. (inherited from Object )
FinancialFormula | Overloaded. Calls a method from a formula module with the specified parameters.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataFormula Class
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.CopySeriesValues Method

DataFormula.CopySeriesValues Method |
 | See Also

Merges, splits or moves Y values in the series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub CopySeriesValues ( _
    inputSeries As String, _
    outputSeries As String _
)
public void CopySeriesValues (
    string inputSeries,
    string outputSeries
)
public:
void CopySeriesValues (
    String^ inputSeries,
    String^ outputSeries
)
public void CopySeriesValues (
    String inputSeries,
    String outputSeries
)
public function CopySeriesValues (
    inputSeries : String,
    outputSeries : String
)

Parameters

inputSeries

A comma-separated list of input data series names and optional X and Y value names.

outputSeries

A comma-separated list of output data series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method

DataFormula.FinancialFormula Method |
 | See Also

Calls a method from a formula module with the specified parameters.

Overload List

Name | Description
DataFormula.FinancialFormula (FinancialFormula, Series) | Calls a method from a formula module with the specified formula name and input series.
DataFormula.FinancialFormula (FinancialFormula, String) | Calls a method from a formula module with the specified formula name and input series name(s).
DataFormula.FinancialFormula (FinancialFormula, Series, Series) | Calls a method from a formula module with the specified formula name, input series and output series.
DataFormula.FinancialFormula (FinancialFormula, String, String) | Calls a method from a formula module with the specified formula name, input series name(s) and output series name(s).
DataFormula.FinancialFormula (FinancialFormula, String, Series, Series) | Calls a method from a formula module with the specified formula name, formula parameters, input series and output series.
DataFormula.FinancialFormula (FinancialFormula, String, String, String) | Calls a method from a formula module with the specified formula name, formula parameters, input series name(s) and output series name(s).

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method (FinancialFormula, Series)

DataFormula.FinancialFormula Method (FinancialFormula, Series) |
 | See Also

Calls a method from a formula module with the specified formula name and input series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As Series _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    Series^ inputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : Series
)

Parameters

formulaName

Formula name.

inputSeries

Input series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method (FinancialFormula, String)

DataFormula.FinancialFormula Method (FinancialFormula, String) |
 | See Also

Calls a method from a formula module with the specified formula name and input series name(s).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As String _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    string inputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ inputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    String inputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : String
)

Parameters

formulaName

Formula name.

inputSeries

A comma-separated list of input series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method (FinancialFormula, Series, Series)

DataFormula.FinancialFormula Method (FinancialFormula, Series, Series) |
 | See Also

Calls a method from a formula module with the specified formula name, input series and output series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries,
    Series outputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    Series^ inputSeries,
    Series^ outputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries,
    Series outputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formulaName

Formula name.

inputSeries

The input series.

outputSeries

The output series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method (FinancialFormula, String, String)

DataFormula.FinancialFormula Method (FinancialFormula, String, String) |
 | See Also

Calls a method from a formula module with the specified formula name, input series name(s) and output series name(s).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As String, _
    outputSeries As String _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    string inputSeries,
    string outputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ inputSeries,
    String^ outputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    String inputSeries,
    String outputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : String,
    outputSeries : String
)

Parameters

formulaName

Formula name.

inputSeries

A comma-separated list of input series names and optional X and Y value names.

outputSeries

A comma-separated list of output series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method (FinancialFormula, String, Series, Series)

DataFormula.FinancialFormula Method (FinancialFormula, String, Series, Series) |
 | See Also

Calls a method from a formula module with the specified formula name, formula parameters, input series and output series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    parameters As String, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    string parameters,
    Series inputSeries,
    Series outputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ parameters,
    Series^ inputSeries,
    Series^ outputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    String parameters,
    Series inputSeries,
    Series outputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    parameters : String,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formulaName

Formula name.

parameters

Formula parameters.

inputSeries

The input series.

outputSeries

The output series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.FinancialFormula Method (FinancialFormula, String, String, String)

DataFormula.FinancialFormula Method (FinancialFormula, String, String, String) |
 | See Also

Calls a method from a formula module with the specified formula name, formula parameters, input series name(s) and output series name(s).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    parameters As String, _
    inputSeries As String, _
    outputSeries As String _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    string parameters,
    string inputSeries,
    string outputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ parameters,
    String^ inputSeries,
    String^ outputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    String parameters,
    String inputSeries,
    String outputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    parameters : String,
    inputSeries : String,
    outputSeries : String
)

Parameters

formulaName

Formula name.

parameters

Formula parameters.

inputSeries

A comma-separated list of input series names and optional X and Y value names.

outputSeries

A comma-separated list of output series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula Properties

DataFormula Properties |
 | See Also

Public Properties

Name | Description
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations.
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as a rolling average from zero.
Statistics | Returns a reference to the StatisticFormula class.

See Also

Reference

DataFormula Class
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.IsEmptyPointIgnored Property

DataFormula.IsEmptyPointIgnored Property |
 | See Also

Gets or sets a flag that indicates whether empty points are ignored while performing calculations.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsEmptyPointIgnored As Boolean
public bool IsEmptyPointIgnored { get; set; }
public:
property bool IsEmptyPointIgnored {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEmptyPointIgnored ()

/** @property */
public void set_IsEmptyPointIgnored (boolean value)

public function get IsEmptyPointIgnored () : boolean

public function set IsEmptyPointIgnored (value : boolean)

Property Value

True if empty points are ignored, otherwise false.

Remarks

Returns value is true, empty points are ignored during calculations. Otherwise, empty points are treated as zeroes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.IsStartFromFirst Property

DataFormula.IsStartFromFirst Property |
 | See Also

Gets or sets a flag that indicates whether to start formulas such as a rolling average from zero.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsStartFromFirst As Boolean
public bool IsStartFromFirst { get; set; }
public:
property bool IsStartFromFirst {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsStartFromFirst ()

/** @property */
public void set_IsStartFromFirst (boolean value)

public function get IsStartFromFirst () : boolean

public function set IsStartFromFirst (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataFormula.Statistics Property

DataFormula.Statistics Property |
 | See Also

Returns a reference to the StatisticFormula class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Statistics As StatisticFormula
public StatisticFormula Statistics { get; }
public:
property StatisticFormula^ Statistics {
    StatisticFormula^ get ();
}
/** @property */
public StatisticFormula get_Statistics ()

public function get Statistics () : StatisticFormula

Property Value

A StatisticFormula object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator Class

DataManipulator Class |
 | See Also Members

Performs data manipulation operations at run time. This class is exposed by the DataManipulator property of the root Chart object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class DataManipulator
    Inherits DataFormula
public class DataManipulator : DataFormula
public ref class DataManipulator : public DataFormula
public class DataManipulator extends DataFormula
public class DataManipulator extends DataFormula

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.DataFormula
System.Web.UI.DataVisualization.Charting.DataManipulator

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator Members

DataManipulator Members |
 | See Also Constructors Methods Properties

Performs data manipulation operations at run time. This class is exposed by the DataManipulator property of the root Chart object.

The following tables list the members exposed by the DataManipulator type.

Public Constructors

Name | Description
DataManipulator | Initializes a new instance of the DataManipulator class.
Top

Public Properties

Name | Description
FilterMatchedPoints | Gets or sets a value that determines whether points are filtered if they match criteria specified in arguments in the Filter methods of this class.
FilterSetEmptyPoints | Gets or sets a flag that indicates whether points filtered by the Filter or FilterTopN methods will be removed or marked as empty.
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations. (inherited from DataFormula)
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as a rolling average from zero. (inherited from DataFormula)
Statistics | Returns a reference to the StatisticFormula class. (inherited from DataFormula)
Top

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | (inherited from DataFormula )
Equals | Overloaded. (inherited from Object )
ExportSeriesValues | Overloaded.
Filter | Overloaded.
FilterTopN | Overloaded.
FinancialFormula | Overloaded. (inherited from DataFormula )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Group | Overloaded.
GroupByAxisLabel | Overloaded.
InsertEmptyPoints | Overloaded.
ReferenceEquals | (inherited from Object )
Sort | Overloaded.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataManipulator Class
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator Constructor

DataManipulator Constructor |
 | See Also

Initializes a new instance of the DataManipulator class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public DataManipulator ()
public:
DataManipulator ()
public DataManipulator ()
public function DataManipulator ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator Methods

DataManipulator Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | (inherited from DataFormula )
Equals | Overloaded. (inherited from Object )
ExportSeriesValues | Overloaded.
Filter | Overloaded.
FilterTopN | Overloaded.
FinancialFormula | Overloaded. (inherited from DataFormula )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Group | Overloaded.
GroupByAxisLabel | Overloaded.
InsertEmptyPoints | Overloaded.
ReferenceEquals | (inherited from Object )
Sort | Overloaded.
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataManipulator Class
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.ExportSeriesValues Method

DataManipulator.ExportSeriesValues Method |
 | See Also

Overload List

Name | Description
DataManipulator.ExportSeriesValues () | Exports the data for every series stored in the SeriesCollection to the DataSet object.
DataManipulator.ExportSeriesValues (Series) | Exports data from the specified series to the DataSet object.
DataManipulator.ExportSeriesValues (String) | Exports data from one or more series to the DataSet object.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.ExportSeriesValues Method ()

DataManipulator.ExportSeriesValues Method () |
 | See Also

Exports the data for every series stored in the SeriesCollection to the DataSet object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ExportSeriesValues As DataSet
public DataSet ExportSeriesValues ()
public:
DataSet^ ExportSeriesValues ()
public DataSet ExportSeriesValues ()
public function ExportSeriesValues () : DataSet

Return Value

A DataSet object that contains series data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.ExportSeriesValues Method (Series)

DataManipulator.ExportSeriesValues Method (Series) |
 | See Also

Exports data from the specified series to the DataSet object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ExportSeriesValues ( _
    series As Series _
) As DataSet
public DataSet ExportSeriesValues (
    Series series
)
public:
DataSet^ ExportSeriesValues (
    Series^ series
)
public DataSet ExportSeriesValues (
    Series series
)
public function ExportSeriesValues (
    series : Series
) : DataSet

Parameters

series

The series to be exported.

Return Value

A DataSet object that contains series data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.ExportSeriesValues Method (String)

DataManipulator.ExportSeriesValues Method (String) |
 | See Also

Exports data from one or more series to the DataSet object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ExportSeriesValues ( _
    seriesNames As String _
) As DataSet
public DataSet ExportSeriesValues (
    string seriesNames
)
public:
DataSet^ ExportSeriesValues (
    String^ seriesNames
)
public DataSet ExportSeriesValues (
    String seriesNames
)
public function ExportSeriesValues (
    seriesNames : String
) : DataSet

Parameters

seriesNames

A comma-separated list of names of the Series to be exported.

Return Value

A DataSet object that contains series data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method

DataManipulator.Filter Method |
 | See Also

Overload List

Name | Description
DataManipulator.Filter (IDataPointFilter, Series) | Performs custom filtering on the data points in a series. The Series object that is filtered also stores the modified data.
DataManipulator.Filter (IDataPointFilter, String) | Performs custom filtering on the data points in one or more Series, based on the points in the first series. The filtered Series objects also store the modified data.
DataManipulator.Filter (CompareMethod, Double, Series) | Filters data points in a series by applying a filtering rule to the first Y-value of each data point. The Series object that is filtered also stores the modified data.
DataManipulator.Filter (CompareMethod, Double, String) | Filters one or more series by applying a filtering rule to the first Y-value of the data points in the first series. The filtered Series objects are used to store the modified data.
DataManipulator.Filter (DateRangeType, String, Series) | Filters the data points in a series, either by removing the specified points or by marking them as empty for the specified date/time ranges. The Series object that is filtered is used to store the modified data.
DataManipulator.Filter (DateRangeType, String, String) | Filters the data points of one or more series, either by removing the specified points or by marking them as empty for the given date/time ranges. The filtered Series objects are used to store the modified data.
DataManipulator.Filter (IDataPointFilter, Series, Series) | Performs custom filtering on the data points in a series.
DataManipulator.Filter (IDataPointFilter, String, String) | Performs custom filtering on the data points in one or more series, based on the points of the first series.
DataManipulator.Filter (CompareMethod, Double, Series, Series) | Filters the data points in a series by applying a filtering rule to the first Y-value of each of the data points.
DataManipulator.Filter (CompareMethod, Double, String, String) | Filters one or more series by applying a filtering rule to the first Y-value of each of the data points in the first series.
DataManipulator.Filter (DateRangeType, String, Series, Series) | Filters the data points in a series, either by removing the specified points or by marking them as empty for the given date/time ranges.
DataManipulator.Filter (DateRangeType, String, String, String) | Filters the data points for one or more series, by either removing the specified points or by marking them as empty for the given date/time ranges.
DataManipulator.Filter (CompareMethod, Double, Series, Series, String) | Filters the data points in a series by applying a filtering rule to the specified data point values for comparison.
DataManipulator.Filter (CompareMethod, Double, String, String, String) | Filters one or more series by applying a filtering rule to the specified data point values in the first series.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (IDataPointFilter, Series)

DataManipulator.Filter Method (IDataPointFilter, Series) |
 | See Also

Performs custom filtering on the data points in a series. The Series object that is filtered also stores the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeries As Series _
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    Series^ inputSeries
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeries : Series
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeries

The Series object that is filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (IDataPointFilter, String)

DataManipulator.Filter Method (IDataPointFilter, String) |
 | See Also

Performs custom filtering on the data points in one or more Series, based on the points in the first series. The filtered Series objects also store the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeriesNames As String _
)
public void Filter (
    IDataPointFilter filterInterface,
    string inputSeriesNames
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    String^ inputSeriesNames
)
public void Filter (
    IDataPointFilter filterInterface,
    String inputSeriesNames
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeriesNames : String
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (CompareMethod, Double, Series)

DataManipulator.Filter Method (CompareMethod, Double, Series) |
 | See Also

Filters data points in a series by applying a filtering rule to the first Y-value of each data point. The Series object that is filtered also stores the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeries As Series _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series^ inputSeries
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeries : Series
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeries

The Series object that is filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (CompareMethod, Double, String)

DataManipulator.Filter Method (CompareMethod, Double, String) |
 | See Also

Filters one or more series by applying a filtering rule to the first Y-value of the data points in the first series. The filtered Series objects are used to store the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeriesNames As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    string inputSeriesNames
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String^ inputSeriesNames
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String inputSeriesNames
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeriesNames : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (DateRangeType, String, Series)

DataManipulator.Filter Method (DateRangeType, String, Series) |
 | See Also

Filters the data points in a series, either by removing the specified points or by marking them as empty for the specified date/time ranges. The Series object that is filtered is used to store the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeries As Series _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    Series inputSeries
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    Series^ inputSeries
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    Series inputSeries
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeries : Series
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeries

The Series object to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (DateRangeType, String, String)

DataManipulator.Filter Method (DateRangeType, String, String) |
 | See Also

Filters the data points of one or more series, either by removing the specified points or by marking them as empty for the given date/time ranges. The filtered Series objects are used to store the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeriesNames As String _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    string inputSeriesNames
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    String^ inputSeriesNames
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    String inputSeriesNames
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeriesNames : String
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (IDataPointFilter, Series, Series)

DataManipulator.Filter Method (IDataPointFilter, Series, Series) |
 | See Also

Performs custom filtering on the data points in a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries,
    Series outputSeries
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries,
    Series outputSeries
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (IDataPointFilter, String, String)

DataManipulator.Filter Method (IDataPointFilter, String, String) |
 | See Also

Performs custom filtering on the data points in one or more series, based on the points of the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void Filter (
    IDataPointFilter filterInterface,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void Filter (
    IDataPointFilter filterInterface,
    String inputSeriesNames,
    String outputSeriesNames
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (CompareMethod, Double, Series, Series)

DataManipulator.Filter Method (CompareMethod, Double, Series, Series) |
 | See Also

Filters the data points in a series by applying a filtering rule to the first Y-value of each of the data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (CompareMethod, Double, String, String)

DataManipulator.Filter Method (CompareMethod, Double, String, String) |
 | See Also

Filters one or more series by applying a filtering rule to the first Y-value of each of the data points in the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String inputSeriesNames,
    String outputSeriesNames
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. The number of output series must match the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (DateRangeType, String, Series, Series)

DataManipulator.Filter Method (DateRangeType, String, Series, Series) |
 | See Also

Filters the data points in a series, either by removing the specified points or by marking them as empty for the given date/time ranges.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    Series inputSeries,
    Series outputSeries
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    Series inputSeries,
    Series outputSeries
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (DateRangeType, String, String, String)

DataManipulator.Filter Method (DateRangeType, String, String, String) |
 | See Also

Filters the data points for one or more series, by either removing the specified points or by marking them as empty for the given date/time ranges.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    String inputSeriesNames,
    String outputSeriesNames
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (CompareMethod, Double, Series, Series, String)

DataManipulator.Filter Method (CompareMethod, Double, Series, Series, String) |
 | See Also

Filters the data points in a series by applying a filtering rule to the specified data point values for comparison.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeries As Series, _
    outputSeries As Series, _
    usingValue As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries,
    string usingValue
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series^ inputSeries,
    Series^ outputSeries,
    String^ usingValue
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries,
    String usingValue
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeries : Series,
    outputSeries : Series,
    usingValue : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Filter Method (CompareMethod, Double, String, String, String)

DataManipulator.Filter Method (CompareMethod, Double, String, String, String) |
 | See Also

Filters one or more series by applying a filtering rule to the specified data point values in the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeriesNames As String, _
    outputSeriesNames As String, _
    usingValue As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    string inputSeriesNames,
    string outputSeriesNames,
    string usingValue
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String^ inputSeriesNames,
    String^ outputSeriesNames,
    String^ usingValue
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String inputSeriesNames,
    String outputSeriesNames,
    String usingValue
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeriesNames : String,
    outputSeriesNames : String,
    usingValue : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. The number of output series must equal the number of input series, otherwise an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method

DataManipulator.FilterTopN Method |
 | See Also

Overload List

Name | Description
DataManipulator.FilterTopN (Int32, Series) | Filters out all data points in a series except for a specified number of points with the largest first Y-values. The Series object that is filtered is used to store the modified data.
DataManipulator.FilterTopN (Int32, String) | Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first series that have the largest first Y-values. The Series objects that are filtered are used to store the modified data.
DataManipulator.FilterTopN (Int32, Series, Series) | Filters all data points in a series except for a specified number of points with the largest first Y-values.
DataManipulator.FilterTopN (Int32, String, String) | Filters out data points in one or more series except for a specified number of points. The points that aren't filtered correspond to points in the first series that have the largest first Y-values.
DataManipulator.FilterTopN (Int32, Series, Series, String) | Filters all data points in a series except for a specified number of data points with the largest values.
DataManipulator.FilterTopN (Int32, String, String, String) | Filters all data points in one or more series except for a specified number of data points. The points that are not filtered correspond to points in the first series that have the largest values.
DataManipulator.FilterTopN (Int32, Series, Series, String, Boolean) | Filters all data points in a series except for a specified number of points with the smallest or largest values.
DataManipulator.FilterTopN (Int32, String, String, String, Boolean) | Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first input series that have the largest or smallest values.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, Series)

DataManipulator.FilterTopN Method (Int32, Series) |
 | See Also

Filters out all data points in a series except for a specified number of points with the largest first Y-values. The Series object that is filtered is used to store the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries
)
public void FilterTopN (
    int pointCount,
    Series inputSeries
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, String)

DataManipulator.FilterTopN Method (Int32, String) |
 | See Also

Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first series that have the largest first Y-values. The Series objects that are filtered are used to store the modified data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, Series, Series)

DataManipulator.FilterTopN Method (Int32, Series, Series) |
 | See Also

Filters all data points in a series except for a specified number of points with the largest first Y-values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries,
    Series^ outputSeries
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, String, String)

DataManipulator.FilterTopN Method (Int32, String, String) |
 | See Also

Filters out data points in one or more series except for a specified number of points. The points that aren't filtered correspond to points in the first series that have the largest first Y-values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames,
    String outputSeriesNames
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, Series, Series, String)

DataManipulator.FilterTopN Method (Int32, Series, Series, String) |
 | See Also

Filters all data points in a series except for a specified number of data points with the largest values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series, _
    outputSeries As Series, _
    usingValue As String _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    string usingValue
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries,
    Series^ outputSeries,
    String^ usingValue
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    String usingValue
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series,
    outputSeries : Series,
    usingValue : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, String, String, String)

DataManipulator.FilterTopN Method (Int32, String, String, String) |
 | See Also

Filters all data points in one or more series except for a specified number of data points. The points that are not filtered correspond to points in the first series that have the largest values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String, _
    outputSeriesNames As String, _
    usingValue As String _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames,
    string outputSeriesNames,
    string usingValue
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames,
    String^ outputSeriesNames,
    String^ usingValue
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames,
    String outputSeriesNames,
    String usingValue
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String,
    outputSeriesNames : String,
    usingValue : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, Series, Series, String, Boolean)

DataManipulator.FilterTopN Method (Int32, Series, Series, String, Boolean) |
 | See Also

Filters all data points in a series except for a specified number of points with the smallest or largest values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series, _
    outputSeries As Series, _
    usingValue As String, _
    getTopValues As Boolean _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    string usingValue,
    bool getTopValues
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries,
    Series^ outputSeries,
    String^ usingValue,
    bool getTopValues
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    String usingValue,
    boolean getTopValues
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series,
    outputSeries : Series,
    usingValue : String,
    getTopValues : boolean
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

getTopValues

True if the largest values are kept, false if the smallest values are kept.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterTopN Method (Int32, String, String, String, Boolean)

DataManipulator.FilterTopN Method (Int32, String, String, String, Boolean) |
 | See Also

Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first input series that have the largest or smallest values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String, _
    outputSeriesNames As String, _
    usingValue As String, _
    getTopValues As Boolean _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames,
    string outputSeriesNames,
    string usingValue,
    bool getTopValues
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames,
    String^ outputSeriesNames,
    String^ usingValue,
    bool getTopValues
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames,
    String outputSeriesNames,
    String usingValue,
    boolean getTopValues
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String,
    outputSeriesNames : String,
    usingValue : String,
    getTopValues : boolean
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

getTopValues

True if the largest values are kept, false if the smallest values are kept.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method

DataManipulator.Group Method |
 | See Also

Overload List

Name | Description
DataManipulator.Group (String, Double, IntervalType, Series) | Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, String) | Groups data using one or more formulas, for one or more series. Series are cleared of their original data and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, Series, Series) | Groups a series' data using one or more formulas. An output series is used to store the grouped data points.
DataManipulator.Group (String, Double, IntervalType, String, String) | Groups data for one or more series, using one or more formulas. Output series are used to store the grouped data points.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, Series) | Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, String) | Groups data for one or more series, using one or more formulas. Series are cleared of their original data and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, Series, Series) | Groups a series using one or more formulas. An output series is used to store the grouped data points, and an offset can be used for intervals.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, String, String) | Groups one or more series, using one or more formulas. Output series are used to store the grouped data points, and an offset can be used for intervals.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, Series)

DataManipulator.Group Method (String, Double, IntervalType, Series) |
 | See Also

Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    Series^ inputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeries

The Series object to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, String)

DataManipulator.Group Method (String, Double, IntervalType, String) |
 | See Also

Groups data using one or more formulas, for one or more series. Series are cleared of their original data and used to store the new data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    string inputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    String^ inputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    String inputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, Series, Series)

DataManipulator.Group Method (String, Double, IntervalType, Series, Series) |
 | See Also

Groups a series' data using one or more formulas. An output series is used to store the grouped data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries,
    Series outputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries,
    Series outputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeries

The Series object to be grouped.

outputSeries

The Series that will store the new data points created by the grouping operation. If it does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, String, String)

DataManipulator.Group Method (String, Double, IntervalType, String, String) |
 | See Also

Groups data for one or more series, using one or more formulas. Output series are used to store the grouped data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeriesName As String, _
    outputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    string inputSeriesName,
    string outputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    String^ inputSeriesName,
    String^ outputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    String inputSeriesName,
    String outputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeriesName : String,
    outputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

outputSeriesName

A comma-separated list of names of the Series that will store the grouped data points. If a series does not exist, it will be created; if it does exist, it will first be cleared of all data before storing grouped data points. The number of output series must equal the number of input series, or an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series) |
 | See Also

Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series^ inputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeries

The Series object to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String) |
 | See Also

Groups data for one or more series, using one or more formulas. Series are cleared of their original data and used to store the new data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    string inputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String^ inputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String inputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series, Series)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series, Series) |
 | See Also

Groups a series using one or more formulas. An output series is used to store the grouped data points, and an offset can be used for intervals.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries,
    Series outputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries,
    Series outputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeries

The Series object to be grouped.

outputSeries

The Series that will store the new data points created by the grouping operation. If it does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String, String)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String, String) |
 | See Also

Groups one or more series, using one or more formulas. Output series are used to store the grouped data points, and an offset can be used for intervals.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeriesName As String, _
    outputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    string inputSeriesName,
    string outputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String^ inputSeriesName,
    String^ outputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String inputSeriesName,
    String outputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeriesName : String,
    outputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

outputSeriesName

A comma-separated list of names of the Series that will store the grouped data points. If a series does not exist, it will be created; if it does exist, it will first be cleared of all data before storing grouped data points. The number of output series must equal the number of input series, or an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.GroupByAxisLabel Method

DataManipulator.GroupByAxisLabel Method |
 | See Also

Overload List

Name | Description
DataManipulator.GroupByAxisLabel (String, Series) | Groups data points in a series by axis labels, using one or more formulas. Original data point values are cleared, and the series then stores the new grouped data points.
DataManipulator.GroupByAxisLabel (String, String) | Groups data points from one or more series by axis labels, using one or more formulas. Original data point values are cleared, and each of the series then stores its new grouped data points.
DataManipulator.GroupByAxisLabel (String, Series, Series) | Groups the data points in a series by axis labels, using one or more formulas. An output series is used to store the grouped data points.
DataManipulator.GroupByAxisLabel (String, String, String) | Groups the data points in one or more series by axis labels, using one or more formulas. Output series are used to store the grouped data points.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.GroupByAxisLabel Method (String, Series)

DataManipulator.GroupByAxisLabel Method (String, Series) |
 | See Also

Groups data points in a series by axis labels, using one or more formulas. Original data point values are cleared, and the series then stores the new grouped data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeries As Series _
)
public void GroupByAxisLabel (
    string formula,
    Series inputSeries
)
public:
void GroupByAxisLabel (
    String^ formula,
    Series^ inputSeries
)
public void GroupByAxisLabel (
    String formula,
    Series inputSeries
)
public function GroupByAxisLabel (
    formula : String,
    inputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeries

The input Series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.GroupByAxisLabel Method (String, String)

DataManipulator.GroupByAxisLabel Method (String, String) |
 | See Also

Groups data points from one or more series by axis labels, using one or more formulas. Original data point values are cleared, and each of the series then stores its new grouped data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeriesName As String _
)
public void GroupByAxisLabel (
    string formula,
    string inputSeriesName
)
public:
void GroupByAxisLabel (
    String^ formula,
    String^ inputSeriesName
)
public void GroupByAxisLabel (
    String formula,
    String inputSeriesName
)
public function GroupByAxisLabel (
    formula : String,
    inputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeriesName

A comma-separated list of names of the input Series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.GroupByAxisLabel Method (String, Series, Series)

DataManipulator.GroupByAxisLabel Method (String, Series, Series) |
 | See Also

Groups the data points in a series by axis labels, using one or more formulas. An output series is used to store the grouped data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void GroupByAxisLabel (
    string formula,
    Series inputSeries,
    Series outputSeries
)
public:
void GroupByAxisLabel (
    String^ formula,
    Series^ inputSeries,
    Series^ outputSeries
)
public void GroupByAxisLabel (
    String formula,
    Series inputSeries,
    Series outputSeries
)
public function GroupByAxisLabel (
    formula : String,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeries

The input Series to be grouped.

outputSeries

The Series that will store the new data points created by the grouping operation. If it does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.GroupByAxisLabel Method (String, String, String)

DataManipulator.GroupByAxisLabel Method (String, String, String) |
 | See Also

Groups the data points in one or more series by axis labels, using one or more formulas. Output series are used to store the grouped data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeriesName As String, _
    outputSeriesName As String _
)
public void GroupByAxisLabel (
    string formula,
    string inputSeriesName,
    string outputSeriesName
)
public:
void GroupByAxisLabel (
    String^ formula,
    String^ inputSeriesName,
    String^ outputSeriesName
)
public void GroupByAxisLabel (
    String formula,
    String inputSeriesName,
    String outputSeriesName
)
public function GroupByAxisLabel (
    formula : String,
    inputSeriesName : String,
    outputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeriesName

A comma-separated list of names of the input Series.

outputSeriesName

A comma-separated list of names of the Series that will store the grouped data points. If a series does not exist, it will be created; if it does exist, it will first be cleared of all data before storing grouped data points. The number of output series must equal the number of input series, or an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method

DataManipulator.InsertEmptyPoints Method |
 | See Also

Overload List

Name | Description
DataManipulator.InsertEmptyPoints (Double, IntervalType, Series) | Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, String) | Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, Series) | Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, String) | Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, Double, Double, Series) | Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, Double, Double, String) | Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Series)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Series) |
 | See Also

Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval and intervalType arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    series As Series _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    Series series
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    Series^ series
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    Series series
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    series : Series
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

series

The Series object that is checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, String)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, String) |
 | See Also

Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval and intervalType arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    seriesName As String _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    string seriesName
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    String^ seriesName
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    String seriesName
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    seriesName : String
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

seriesName

A comma-separated list of names of the Series to be checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Series)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Series) |
 | See Also

Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    series As Series _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series series
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series^ series
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series series
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    series : Series
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

series

The Series object in which to insert the empty points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, String)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, String) |
 | See Also

Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    seriesName As String _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    string seriesName
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String^ seriesName
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String seriesName
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    seriesName : String
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

seriesName

A comma-separated list of names of the Series to be checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, Series)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, Series) |
 | See Also

Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    fromXValue As Double, _
    toXValue As Double, _
    series As Series _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    Series series
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    Series^ series
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    Series series
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    fromXValue : double,
    toXValue : double,
    series : Series
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

fromXValue

The starting point for the series range to be checked. Uses the X-values of the data points.

toXValue

The end point for the series range to be checked. Uses the X-values of the data points.

series

The Series in which to insert the empty points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, String)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, String) |
 | See Also

Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    fromXValue As Double, _
    toXValue As Double, _
    seriesName As String _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    string seriesName
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    String^ seriesName
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    String seriesName
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    fromXValue : double,
    toXValue : double,
    seriesName : String
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

fromXValue

The starting point for the series range to be checked. Uses the X-values of the data points.

toXValue

The end point for the series range to be checked. Uses the X-values of the data points.

seriesName

A comma-separated list of names of the Series to be checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method

DataManipulator.Sort Method |
 | See Also

Overload List

Name | Description
DataManipulator.Sort (Generic , Series) | Performs a custom sort on the data points in a series.
DataManipulator.Sort (Generic , String) | Performs a custom sort on one or more series.
DataManipulator.Sort (PointSortOrder, Series) | Performs a sort on the data points in a series using the specified order. The sort is based on the first Y-value of each of the data points.
DataManipulator.Sort (PointSortOrder, String) | Performs a sort on the data points in one or more series, using the specified order. The sort is based on the first Y-value of each of the data points.
DataManipulator.Sort (PointSortOrder, String, Series) | Performs a sort on the data points in a series using the specified order. The sort can be based on any available data point value.
DataManipulator.Sort (PointSortOrder, String, String) | Sorts the data points of one or more series in the specified order. The sort can be based on any available data point value.

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method (Generic , Series)

DataManipulator.Sort Method (Generic , Series) |
 | See Also

Performs a custom sort on the data points in a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    comparer As IComparer(Of DataPoint), _
    series As Series _
)
public void Sort (
    IComparer<DataPoint> comparer,
    Series series
)
public:
void Sort (
    IComparer<DataPoint^>^ comparer,
    Series^ series
)
public void Sort (
    IComparer<DataPoint> comparer,
    Series series
)
public function Sort (
    comparer : IComparer<DataPoint>,
    series : Series
)

Parameters

comparer

An object that implements the IComparer interface and provides the custom sorting logic.

series

The Series object to be sorted.

Remarks

This method performs a custom sort on the data points in a series; the sort logic is defined by the comparer parameter. Override and implement the Compare method of the IComparer interface, perform the comparison(s) and then return true or false. The sort order is determined by the return value.

The two object parameters of the Compare method must always be of type DataPoint.

To perform a custom sort for more than one series per function call, use the Sort method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method (Generic , String)

DataManipulator.Sort Method (Generic , String) |
 | See Also

Performs a custom sort on one or more series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    comparer As IComparer(Of DataPoint), _
    seriesName As String _
)
public void Sort (
    IComparer<DataPoint> comparer,
    string seriesName
)
public:
void Sort (
    IComparer<DataPoint^>^ comparer,
    String^ seriesName
)
public void Sort (
    IComparer<DataPoint> comparer,
    String seriesName
)
public function Sort (
    comparer : IComparer<DataPoint>,
    seriesName : String
)

Parameters

comparer

An object that implements the IComparer interface and provides the custom sorting logic.

seriesName

A comma-separated list of names of the Series to be sorted.

Remarks

This method performs a custom sort on the data points in one or more series; the sort logic is defined by the comparer parameter. Override and implement the Compare method of the IComparer interface, perform the comparison(s) and then return true or false. The sort order is determined by the return value.

Note that if multiple series are sorted, the series must be aligned, otherwise an exception will be thrown.

The two object parameters of the Compare method must always be of type DataPoint.

Important:
All data points, regardless of the series they belong to, are sorted based on the first series; if the position of a data point in the first series changes, all corresponding points in the other series change as well.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method (PointSortOrder, Series)

DataManipulator.Sort Method (PointSortOrder, Series) |
 | See Also

Performs a sort on the data points in a series using the specified order. The sort is based on the first Y-value of each of the data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    series As Series _
)
public void Sort (
    PointSortOrder pointSortOrder,
    Series series
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    Series^ series
)
public void Sort (
    PointSortOrder pointSortOrder,
    Series series
)
public function Sort (
    pointSortOrder : PointSortOrder,
    series : Series
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending.

series

The Series object to be sorted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method (PointSortOrder, String)

DataManipulator.Sort Method (PointSortOrder, String) |
 | See Also

Performs a sort on the data points in one or more series, using the specified order. The sort is based on the first Y-value of each of the data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    seriesName As String _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string seriesName
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ seriesName
)
public void Sort (
    PointSortOrder pointSortOrder,
    String seriesName
)
public function Sort (
    pointSortOrder : PointSortOrder,
    seriesName : String
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending.

seriesName

A comma-separated list of names of the Series to be sorted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method (PointSortOrder, String, Series)

DataManipulator.Sort Method (PointSortOrder, String, Series) |
 | See Also

Performs a sort on the data points in a series using the specified order. The sort can be based on any available data point value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    sortBy As String, _
    series As Series _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string sortBy,
    Series series
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ sortBy,
    Series^ series
)
public void Sort (
    PointSortOrder pointSortOrder,
    String sortBy,
    Series series
)
public function Sort (
    pointSortOrder : PointSortOrder,
    sortBy : String,
    series : Series
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending

sortBy

A string value that represents the data point values to be sorted. Possible values are: "X", "Y", "Y2", "Y3", "AxisLabel", and so forth.

series

The Series object to be sorted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.Sort Method (PointSortOrder, String, String)

DataManipulator.Sort Method (PointSortOrder, String, String) |
 | See Also

Sorts the data points of one or more series in the specified order. The sort can be based on any available data point value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    sortBy As String, _
    seriesName As String _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string sortBy,
    string seriesName
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ sortBy,
    String^ seriesName
)
public void Sort (
    PointSortOrder pointSortOrder,
    String sortBy,
    String seriesName
)
public function Sort (
    pointSortOrder : PointSortOrder,
    sortBy : String,
    seriesName : String
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending.

sortBy

A string value that represents the data point values to be sorted. Possible values are: "X", "Y", "Y2", "Y3", "AxisLabel", and so forth.

seriesName

A comma-separated list of names of the Series to be sorted.

Remarks

This method performs an ascending or descending sort on data points in a series, and is based on the value that is set in the sortBy parameter such as "X", "AxisLabel", "Y", "Y1", and so forth.

Note that if multiple series are sorted, the series must be aligned, otherwise an exception will be thrown.

Important:
All series will be sorted using the specified Y-value from the FIRST listed series; that is, all data points, regardless of the series they belong to, are sorted based on the first series.

To sort points using a custom sort routine, use a different definition of this overloaded method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator Properties

DataManipulator Properties |
 | See Also

Public Properties

Name | Description
FilterMatchedPoints | Gets or sets a value that determines whether points are filtered if they match criteria specified in arguments in the Filter methods of this class.
FilterSetEmptyPoints | Gets or sets a flag that indicates whether points filtered by the Filter or FilterTopN methods will be removed or marked as empty.
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations. (inherited from DataFormula )
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as a rolling average from zero. (inherited from DataFormula )
Statistics | Returns a reference to the StatisticFormula class. (inherited from DataFormula )

See Also

Reference

DataManipulator Class
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterMatchedPoints Property

DataManipulator.FilterMatchedPoints Property |
 | See Also

Gets or sets a value that determines whether points are filtered if they match criteria specified in arguments in the Filter methods of this class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property FilterMatchedPoints As Boolean
public bool FilterMatchedPoints { get; set; }
public:
property bool FilterMatchedPoints {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_FilterMatchedPoints ()

/** @property */
public void set_FilterMatchedPoints (boolean value)

public function get FilterMatchedPoints () : boolean

public function set FilterMatchedPoints (value : boolean)

Property Value

True if points that match specified criteria are filtered, false if points that do not match the criteria are filtered. The default value is true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataManipulator.FilterSetEmptyPoints Property

DataManipulator.FilterSetEmptyPoints Property |
 | See Also

Gets or sets a flag that indicates whether points filtered by the Filter or FilterTopN methods will be removed or marked as empty.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property FilterSetEmptyPoints As Boolean
public bool FilterSetEmptyPoints { get; set; }
public:
property bool FilterSetEmptyPoints {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_FilterSetEmptyPoints ()

/** @property */
public void set_FilterSetEmptyPoints (boolean value)

public function get FilterSetEmptyPoints () : boolean

public function set FilterSetEmptyPoints (value : boolean)

Property Value

True if filtered points will be marked as empty, false if they will be removed. The default value is false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Class

DataPoint Class |
 | See Also Members

Represents a data point that is stored in the DataPointCollection class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class DataPoint
    Inherits DataPointCustomProperties
public class DataPoint : DataPointCustomProperties
public ref class DataPoint : public DataPointCustomProperties
public class DataPoint extends DataPointCustomProperties
public class DataPoint extends DataPointCustomProperties

Remarks

The DataPoint class stores properties associated with data as well as data point values. For example, a data point has a value, but it also has a color property, background image property, background gradient property, and so forth. For more information about data point properties, see the DataPointCustomProperties class overview topic.

Each data point consists of an X-value and one or more Y-values. The X-value can be zero, or you can set this explicitly.

Only one Y-value per point is required for all chart types except bubble, candlestick and stock charts. These chart types require more than one Y-value because one data point consists of multiple values. For example, to plot one stock chart column, four values are required: high, low, open and close values.

Data can be added at either design time or run time; you can also use data-binding at run time.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.DataPointCustomProperties
System.Web.UI.DataVisualization.Charting.DataPoint

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Members

DataPoint Members |
 | See Also Constructors Methods Properties

Represents a data point that is stored in the DataPointCollection class.

The following tables list the members exposed by the DataPoint type.

Public Constructors

Name | Description
DataPoint | Overloaded.
Top

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object. (inherited from DataPointCustomProperties)
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties)
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties)
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties)
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties)
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties)
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties)
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties)
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties)
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties)
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties)
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties)
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties)
CustomPropertiesExtended | For internal use only. (inherited from DataPointCustomProperties)
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties)
IsEmpty | Gets or sets a flag that indicates whether a data point is marked as empty.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties)
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties)
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties)
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties)
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties)
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties)
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties)
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties)
LabelMapAreaAttributes | Gets or sets map area attributes of the data point label. (inherited from DataPointCustomProperties)
LabelPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties)
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties)
LabelUrl | Gets or sets the URL target of the data point label. (inherited from DataPointCustomProperties)
LegendMapAreaAttributes | Gets or sets the attributes of the legend map area. (inherited from DataPointCustomProperties)
LegendPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties)
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties)
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties)
LegendUrl | Gets or sets the URL target of the item in the legend. (inherited from DataPointCustomProperties)
MapAreaAttributes | Gets or sets the map area attributes of a data point. (inherited from DataPointCustomProperties)
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties)
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties)
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties)
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties)
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties)
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties)
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties)
Name | Overridden. Gets or sets the name of the data point.
PostBackValue | Gets or sets the postback value that can be processed on a Click event. (inherited from DataPointCustomProperties)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties)
Url | Gets or sets the URL target of the area. (inherited from DataPointCustomProperties)
XValue | Gets or sets the X-value of a data point.
YValues | Gets or sets the Y-value(s) of a data point.
Top

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns an exact copy of the data point.
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
GetValueByName | Returns a data point that is specified by its name. This is a helper function.
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets the IsValueShownAsLabel property to its default value. (inherited from DataPointCustomProperties)
ResetIsVisibleInLegend | Resets the IsVisibleInLegend property to its default value. (inherited from DataPointCustomProperties)
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
SetValueXY | Sets the X-value and one or more Y-values of the data point.
SetValueY | Sets the Y-value(s) of a single data point.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataPoint Class
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Constructor

DataPoint Constructor |
 | See Also

Overload List

Name | Description
DataPoint () | Initializes a new instance of the DataPoint class.
DataPoint (Series) | Initializes a new instance of the DataPoint class, and sets the Series that the data point belongs to.
DataPoint (Double, Double) | Initializes a new instance of the DataPoint class with the specified X and Y-value.
DataPoint (Double, Double[]) | Initializes a new instance of the DataPoint class with the specified X-value and an array of Y-values.
DataPoint (Double, String) | Initializes a new instance of the DataPoint class with the specified X-value and Y-values.

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Constructor ()

DataPoint Constructor () |
 | See Also

Initializes a new instance of the DataPoint class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public DataPoint ()
public:
DataPoint ()
public DataPoint ()
public function DataPoint ()

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Constructor (Series)

DataPoint Constructor (Series) |
 | See Also

Initializes a new instance of the DataPoint class, and sets the Series that the data point belongs to.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    series As Series _
)
public DataPoint (
    Series series
)
public:
DataPoint (
    Series^ series
)
public DataPoint (
    Series series
)
public function DataPoint (
    series : Series
)

Parameters

series

The Series object that the data point belongs to.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Constructor (Double, Double)

DataPoint Constructor (Double, Double) |
 | See Also

Initializes a new instance of the DataPoint class with the specified X and Y-value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    xValue As Double, _
    yValue As Double _
)
public DataPoint (
    double xValue,
    double yValue
)
public:
DataPoint (
    double xValue,
    double yValue
)
public DataPoint (
    double xValue,
    double yValue
)
public function DataPoint (
    xValue : double,
    yValue : double
)

Parameters

xValue

The X-value of the data point.

yValue

The Y-value of the data point.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Constructor (Double, Double[])

DataPoint Constructor (Double, Double[]) |
 | See Also

Initializes a new instance of the DataPoint class with the specified X-value and an array of Y-values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    xValue As Double, _
    yValues As Double() _
)
public DataPoint (
    double xValue,
    double[] yValues
)
public:
DataPoint (
    double xValue,
    array<double>^ yValues
)
public DataPoint (
    double xValue,
    double[] yValues
)
public function DataPoint (
    xValue : double,
    yValues : double[]
)

Parameters

xValue

The X-value.

yValues

An array of Y-values.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Constructor (Double, String)

DataPoint Constructor (Double, String) |
 | See Also

Initializes a new instance of the DataPoint class with the specified X-value and Y-values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    xValue As Double, _
    yValues As String _
)
public DataPoint (
    double xValue,
    string yValues
)
public:
DataPoint (
    double xValue,
    String^ yValues
)
public DataPoint (
    double xValue,
    String yValues
)
public function DataPoint (
    xValue : double,
    yValues : String
)

Parameters

xValue

The X-value of the data point.

yValues

A string of Y-values separated by commas.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Methods

DataPoint Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns an exact copy of the data point.
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
GetValueByName | Returns a data point that is specified by its name. This is a helper function.
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets the IsValueShownAsLabel property to its default value. (inherited from DataPointCustomProperties )
ResetIsVisibleInLegend | Resets the IsVisibleInLegend property to its default value. (inherited from DataPointCustomProperties )
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
SetValueXY | Sets the X-value and one or more Y-values of the data point.
SetValueY | Sets the Y-value(s) of a single data point.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataPoint Class
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.Clone Method

DataPoint.Clone Method |
 | See Also

Returns an exact copy of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Clone As DataPoint
public DataPoint Clone ()
public:
DataPoint^ Clone ()
public DataPoint Clone ()
public function Clone () : DataPoint

Return Value

A cloned DataPoint object.

Remarks

Use the Clone method to obtain an exact copy of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.GetValueByName Method

DataPoint.GetValueByName Method |
 | See Also

Returns a data point that is specified by its name. This is a helper function.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GetValueByName ( _
    valueName As String _
) As Double
public double GetValueByName (
    string valueName
)
public:
double GetValueByName (
    String^ valueName
)
public double GetValueByName (
    String valueName
)
public function GetValueByName (
    valueName : String
) : double

Parameters

valueName

Point value names. X, Y, Y2...

Return Value

A string value that represents a data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.SetValueXY Method

DataPoint.SetValueXY Method |
 | See Also

Sets the X-value and one or more Y-values of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SetValueXY ( _
    xValue As Object, _
    ParamArray yValue As Object() _
)
public void SetValueXY (
    Object xValue,
    params Object[] yValue
)
public:
void SetValueXY (
    Object^ xValue,
    ... array<Object^>^ yValue
)
public void SetValueXY (
    Object xValue,
    Object[] yValue
)
public function SetValueXY (
    xValue : Object,
    ... yValue : Object[]
)

Parameters

xValue

The X-value of the data point.

yValue

A list of Y-values of the data point.

Remarks

Use the SetValueXY method to set the value(s) of a data point at run-time.

Note that if you set the X-value to a value other than zero (0), a scatter plot will be generated. For further details, see the Remarks section of the XValue property.

Refer to the following table for a complete listing of valid .NET Framework types that can be used for the object type parameter.

String | DateTime | Double
Decimal | Single | Int32
UInt32 | Int64 | UInt64

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.SetValueY Method

DataPoint.SetValueY Method |
 | See Also

Sets the Y-value(s) of a single data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub SetValueY ( _
    ParamArray yValue As Object() _
)
public void SetValueY (
    params Object[] yValue
)
public:
void SetValueY (
    ... array<Object^>^ yValue
)
public void SetValueY (
    Object[] yValue
)
public function SetValueY (
    ... yValue : Object[]
)

Parameters

yValue

The Y-value(s) of a DataPoint object in the collection. Formatted as one or more values separated by commas.

Remarks

The SetValueY property is used to set the Y-value(s) of a data point at run time.

Only one Y-value per point is required for all chart types except for bubble, candlestick and stock charts. These chart types require more than one Y-value because one data point consists of multiple values. For example, to plot one stock chart column, four values are required: high, low, open and close values.

This property returns an array of double values when used to retrieve multiple Y-values.

Important:
The YValuesPerPoint property determines the maximum number of Y-values that all data points in a Series can have. If you specify more than the allowable number of Y-values, an exception will be raised. Refer to the following table for a complete listing of valid .NET Framework types that can be used for the object type parameter:

String | DateTime | Double
Decimal | Single | Int32
UInt32 | Int64 | UInt64

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint Properties

DataPoint Properties |
 | See Also

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object. (inherited from DataPointCustomProperties )
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties )
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties )
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties )
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties )
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties )
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties )
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties )
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties )
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties )
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties )
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties )
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties )
CustomPropertiesExtended | For internal use only. (inherited from DataPointCustomProperties )
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties )
IsEmpty | Gets or sets a flag that indicates whether a data point is marked as empty.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties )
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties )
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties )
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties )
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties )
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties )
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties )
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties )
LabelMapAreaAttributes | Gets or sets map area attributes of the data point label. (inherited from DataPointCustomProperties )
LabelPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties )
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties )
LabelUrl | Gets or sets the URL target of the data point label. (inherited from DataPointCustomProperties )
LegendMapAreaAttributes | Gets or sets the attributes of the legend map area. (inherited from DataPointCustomProperties )
LegendPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties )
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties )
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties )
LegendUrl | Gets or sets the URL target of the item in the legend. (inherited from DataPointCustomProperties )
MapAreaAttributes | Gets or sets the map area attributes of a data point. (inherited from DataPointCustomProperties )
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties )
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties )
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties )
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties )
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties )
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties )
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties )
Name | Overridden. Gets or sets the name of the data point.
PostBackValue | Gets or sets the postback value that can be processed on a Click event. (inherited from DataPointCustomProperties )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties )
Url | Gets or sets the URL target of the area. (inherited from DataPointCustomProperties )
XValue | Gets or sets the X-value of a data point.
YValues | Gets or sets the Y-value(s) of a data point.

See Also

Reference

DataPoint Class
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.IsEmpty Property

DataPoint.IsEmpty Property |
 | See Also

Gets or sets a flag that indicates whether a data point is marked as empty.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsEmpty As Boolean
public bool IsEmpty { get; set; }
public:
property bool IsEmpty {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEmpty ()

/** @property */
public void set_IsEmpty (boolean value)

public function get IsEmpty () : boolean

public function set IsEmpty (value : boolean)

Property Value

True if the point is marked as an empty point, otherwise false. The default value is false.

Remarks

Set this property to true to mark a data point as an empty point.

Alternatively one of the InsertEmptyPoints methods in the DataManipulator class can be used to mark missing data as empty points.

The EmptyPointStyle property determines how empty points are displayed.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.Name Property

DataPoint.Name Property |
 | See Also

Gets or sets the name of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string Name { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.XValue Property

DataPoint.XValue Property |
 | See Also

Gets or sets the X-value of a data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property XValue As Double
public double XValue { get; set; }
public:
property double XValue {
    double get ();
    void set (double value);
}
/** @property */
public double get_XValue ()

/** @property */
public void set_XValue (double value)

public function get XValue () : double

public function set XValue (value : double)

Property Value

A double that represents the X-value of a data point.

Remarks

All chart types can be displayed as either scatter plots or as non-scatter plots, because both X-values and Y-values can be set. Setting an X-value will result in a scatter plot, whereas not setting this property—which is equivalent to setting it to zero—will result in a non-scatter plot. For example, to draw a point chart type, add data points that have X-values of zero. To display a traditional scatter chart, add data points that have X-values other than zero.

The X-values of data points are not required to be set. If they are not set, data points are plotted sequentially, using their index values from the DataPointCollection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPoint.YValues Property

DataPoint.YValues Property |
 | See Also

Gets or sets the Y-value(s) of a data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property YValues As Double()
public double[] YValues { get; set; }
public:
property array<double>^ YValues {
    array<double>^ get ();
    void set (array<double>^ value);
}
/** @property */
public double[] get_YValues ()

/** @property */
public void set_YValues (double[] value)

public function get YValues () : double[]

public function set YValues (value : double[])

Property Value

An array of double values that represent the Y-value(s) of a data point.

Remarks

The YValues property is used to set the Y-values of data points.

Only one Y-value per point is required for all chart types except bubble, candlestick and stock charts. These chart types require more than one Y-value because one data point consists of multiple values. For example, to plot one stock chart column, four values are required: high, low, open and close values.

The YValues property returns an array of double values when used to retrieve the Y-values.

Important The YValuesPerPoint property determines the maximum number of Y-values that all data points in a Series can have. If you specify more than the allowable number of Y-values, an exception will be raised.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection Class

DataPointCollection Class |
 | See Also Members

Represents a collection of DataPoint objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class DataPointCollection
    Inherits ChartElementCollection(Of DataPoint)
public class DataPointCollection : ChartElementCollection<DataPoint>
public ref class DataPointCollection : public ChartElementCollection<DataPoint^>
public class DataPointCollection extends ChartElementCollection<DataPoint>
public class DataPointCollection extends ChartElementCollection<DataPoint>

Remarks

The DataPointCollection class represents a collection of DataPoint objects, which in turn represent the data points that are part of a Series object.

This collection class is implemented as the Points property of a Series object.

DataPoint objects can be appended or inserted into the collection with their X-value and Y-value(s) already specified as parameters. Note that they are also added automatically when a series is bound to a data source using either the DataBindY or DataBindXY method.

Data points are plotted in the order that they occur in this collection only if the series that the collection belongs to has its IsXValueIndexed property set to true (the default value is false), or if all X-values for all data points are zero. Otherwise data points are plotted using their X-values.

Data points can be located, and manipulated, based on maximum, minimum or specified X or Y-values using the overloaded FindMaxValue, FindMinValue or FindValue methods, respectively.

The Count property indicates the total number of items in the collection, and is commonly used to find the upper bound of the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.DataPointCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection Members

DataPointCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of DataPoint objects.

The following tables list the members exposed by the DataPointCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
AddXY | Overloaded.
AddY | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
DataBind | Data binds the X-value, Y-value(s) and property values of the data points, such as Tooltip or LabelStyle, to the data source.
DataBindXY | Overloaded.
DataBindY | Overloaded.
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindAllByValue | Overloaded.
FindByValue | Overloaded.
FindMaxByValue | Overloaded.
FindMinByValue | Overloaded.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
InsertXY | Inserts a data point with the specified X value and one or more specified Y values.
InsertY | Inserts a data point with one or more specified Y values.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

DataPointCollection Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection Methods

DataPointCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
AddXY | Overloaded.
AddY | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
DataBind | Data binds the X-value, Y-value(s) and property values of the data points, such as Tooltip or LabelStyle, to the data source.
DataBindXY | Overloaded.
DataBindY | Overloaded.
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindAllByValue | Overloaded.
FindByValue | Overloaded.
FindMaxByValue | Overloaded.
FindMinByValue | Overloaded.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
InsertXY | Inserts a data point with the specified X value and one or more specified Y values.
InsertY | Inserts a data point with one or more specified Y values.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

DataPointCollection Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.Add Method

DataPointCollection.Add Method |
 | See Also

Overload List

Name | Description
DataPointCollection.Add (DataPoint) | (inherited from Add )
DataPointCollection.Add (Double[]) | Adds the new DataPoint object to a collection and sets its Y value.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.Add Method (Double[])

DataPointCollection.Add Method (Double[]) |
 | See Also

Adds the new DataPoint object to a collection and sets its Y value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    ParamArray y As Double() _
) As DataPoint
public DataPoint Add (
    params double[] y
)
public:
DataPoint^ Add (
    ... array<double>^ y
)
public DataPoint Add (
    double[] y
)
public function Add (
    ... y : double[]
) : DataPoint

Parameters

y

The Y-value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.AddXY Method

DataPointCollection.AddXY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.AddXY (Double, Double) | Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value.
DataPointCollection.AddXY (Object, Object[]) | Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value(s).

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.AddXY Method (Double, Double)

DataPointCollection.AddXY Method (Double, Double) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function AddXY ( _
    xValue As Double, _
    yValue As Double _
) As Integer
public int AddXY (
    double xValue,
    double yValue
)
public:
int AddXY (
    double xValue,
    double yValue
)
public int AddXY (
    double xValue,
    double yValue
)
public function AddXY (
    xValue : double,
    yValue : double
) : int

Parameters

xValue

X-value of the data point.

yValue

Y-value of the data point.

Return Value

An integer that represents the zero-based index where the item was inserted into the data point collection.

Remarks

This method adds DataPoint object to the DataPointCollection; the object is always added to the end of the collection.

Use the AddXY method overload if your data points require more than one Y-value.

If your data points do not need an X-value—that is, if you are creating non-scatter plots—use the AddY method instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.AddXY Method (Object, Object[])

DataPointCollection.AddXY Method (Object, Object[]) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value(s).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function AddXY ( _
    xValue As Object, _
    ParamArray yValue As Object() _
) As Integer
public int AddXY (
    Object xValue,
    params Object[] yValue
)
public:
int AddXY (
    Object^ xValue,
    ... array<Object^>^ yValue
)
public int AddXY (
    Object xValue,
    Object[] yValue
)
public function AddXY (
    xValue : Object,
    ... yValue : Object[]
) : int

Parameters

xValue

The X value of the data point.

yValue

One or more comma-separated values that represent the Y-value(s) of the data point.

Return Value

An integer value that represents the zero-based index where the item was inserted into the collection.

Remarks

This method adds one DataPoint object to the DataPointCollection; the data point is always added to the end of the collection.

You must provide at least one (1) Y-value, otherwise an exception will be thrown. This method also checks the YValueType property of the DataPointCollection object that this data belongs to; if too many Y-values are specified, an exception will be thrown.

In order for DateTime formatting to have an effect, a value must be a DateTime object.

If your data points do not need an X-value—that is, if you are creating non-scatter plots—use the AddY method instead

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.AddY Method

DataPointCollection.AddY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.AddY (Double) | Adds a DataPoint object to the end of the collection, with the specified Y-value.
DataPointCollection.AddY (Object[]) | Adds a DataPoint object to the end of the collection, with the specified Y-value(s).

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.AddY Method (Double)

DataPointCollection.AddY Method (Double) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified Y-value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function AddY ( _
    yValue As Double _
) As Integer
public int AddY (
    double yValue
)
public:
int AddY (
    double yValue
)
public int AddY (
    double yValue
)
public function AddY (
    yValue : double
) : int

Parameters

yValue

The Y-value of the data point.

Return Value

An integer that represents the zero-based index where the item was inserted into the data point collection.

Remarks

This method adds one DataPoint object to the DataPointCollection; the data point is always added to the end of the collection.

Use the method definition that allows for an array of Y-values if your data points require more than one Y-value.

If your data points need an X-value—that is, if you are creating scatter plots—use one of the AddXY methods instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.AddY Method (Object[])

DataPointCollection.AddY Method (Object[]) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified Y-value(s).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function AddY ( _
    ParamArray yValue As Object() _
) As Integer
public int AddY (
    params Object[] yValue
)
public:
int AddY (
    ... array<Object^>^ yValue
)
public int AddY (
    Object[] yValue
)
public function AddY (
    ... yValue : Object[]
) : int

Parameters

yValue

A comma-separated list of Y-value(s) of the DataPoint object added to the collection.

Return Value

An integer that represents the location in zero-based index where the item was inserted into the collection.

Remarks

This method adds one DataPoint object to the DataPointCollection; the data point is always added to the end of the collection.

You must provide at least one (1) Y-value, otherwise an exception will be thrown. This method also checks the ChartType property of the DataPoint object this data belongs to; if too many Y-values are specified, an exception will be thrown.

The X-value will always be set to zero (0), resulting in non-scatter plots. If you want the data points to use an X-value, call one of the AddXY methods instead.

In order for DateTime formatting to have an effect, a value must be a DateTime object.

Refer to the following for a complete listing of valid .NET Framework types that can be used for the object type parameters:

String | DateTime | Double
Decimal | Single | Int32
UInt32 | Int64 | UInt64

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBind Method

DataPointCollection.DataBind Method |
 | See Also

Data binds the X-value, Y-value(s) and property values of the data points, such as Tooltip or LabelStyle, to the data source.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBind ( _
    dataSource As IEnumerable, _
    xField As String, _
    yFields As String, _
    otherFields As String _
)
public void DataBind (
    IEnumerable dataSource,
    string xField,
    string yFields,
    string otherFields
)
public:
void DataBind (
    IEnumerable^ dataSource,
    String^ xField,
    String^ yFields,
    String^ otherFields
)
public void DataBind (
    IEnumerable dataSource,
    String xField,
    String yFields,
    String otherFields
)
public function DataBind (
    dataSource : IEnumerable,
    xField : String,
    yFields : String,
    otherFields : String
)

Parameters

dataSource

The data source.

xField

The name of the field for X-values.

yFields

A comma separated names of the fields for Y-values.

otherFields

Other data point properties with binding rules, in the format: PointProperty=Field[{Format}] [,PointProperty=Field[{Format}]].

For example: "Tooltip=Price{C1},Url=WebSiteName".

Remarks

The data source can be the Ole(SQL)DataReader, DataView, DataSet, DataTable or DataRow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBindXY Method

DataPointCollection.DataBindXY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.DataBindXY (IEnumerable, IEnumerable[]) | Data binds the X-value and Y-values of the collection's data points to the first columns of the specified data source.
DataPointCollection.DataBindXY (IEnumerable, String, IEnumerable, String) | Data binds the X-value and Y-values of the data points in the collection to the specified columns of the specified data sources.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBindXY Method (IEnumerable, IEnumerable[])

DataPointCollection.DataBindXY Method (IEnumerable, IEnumerable[]) |
 | See Also

Data binds the X-value and Y-values of the collection's data points to the first columns of the specified data source.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindXY ( _
    xValue As IEnumerable, _
    ParamArray yValues As IEnumerable() _
)
public void DataBindXY (
    IEnumerable xValue,
    params IEnumerable[] yValues
)
public:
void DataBindXY (
    IEnumerable^ xValue,
    ... array<IEnumerable^>^ yValues
)
public void DataBindXY (
    IEnumerable xValue,
    IEnumerable[] yValues
)
public function DataBindXY (
    xValue : IEnumerable,
    ... yValues : IEnumerable[]
)

Parameters

xValue

The data source that will supply the X-values for the data points.

yValues

A comma-separated list of the Y-value(s) of the DataPoint object added to the collection.

Remarks

This method binds all DataPoint objects in a Series, and uses separate data sources for the X and Y-value(s).

Note that the first available column in the data source will be used if data-binding to a table. To bind to a column other than the first column, use the DataBindXY method.

You can bind to multiple Y-values by providing a comma-separated list of IEnumerable objects for the yValues parameter.

If Y-values are not provided by the data source, or if the wrong number of values are provided, an exception will be thrown.

If you do not want to display scatter-type plots, in which both X and Y-values are used, use one of the DataBindY methods instead.

The following is a list of objects that you can use as the data source parameter:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBindXY Method (IEnumerable, String, IEnumerable, String)

DataPointCollection.DataBindXY Method (IEnumerable, String, IEnumerable, String) |
 | See Also

Data binds the X-value and Y-values of the data points in the collection to the specified columns of the specified data sources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindXY ( _
    xValue As IEnumerable, _
    xField As String, _
    yValue As IEnumerable, _
    yFields As String _
)
public void DataBindXY (
    IEnumerable xValue,
    string xField,
    IEnumerable yValue,
    string yFields
)
public:
void DataBindXY (
    IEnumerable^ xValue,
    String^ xField,
    IEnumerable^ yValue,
    String^ yFields
)
public void DataBindXY (
    IEnumerable xValue,
    String xField,
    IEnumerable yValue,
    String yFields
)
public function DataBindXY (
    xValue : IEnumerable,
    xField : String,
    yValue : IEnumerable,
    yFields : String
)

Parameters

xValue

The data source that will supply the X-values for the data points.

xField

The name of the column that will supply the X-values for the data points.

yValue

A comma-separated list of the Y-value(s) of the DataPoint object added to the collection.

yFields

A comma-separated list of column name(s) that will supply the Y-values for the data points. Note that a comma can be embedded as part of a column name, by using a double comma.

Remarks

Data binds the X-value and Y-values of the data points in the collection to the specified data source's first columns.

You can bind to several Y-values by setting the yFields parameter to multiple column names. Separate the column names with commas.

If Y-values are not provided by the data source, or if the wrong number of values are provided, an exception will be thrown.

If you do not want to display scatter-type plots, in which both X and Y-values are used, use one of the DataBindY methods instead.

The following is a list of objects that you can use as the data source parameter:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBindY Method

DataPointCollection.DataBindY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.DataBindY (IEnumerable[]) | Data binds the Y-value(s) of the collection's data points to the first column of the specified data source(s).
DataPointCollection.DataBindY (IEnumerable, String) | Data binds the Y-value(s) of the data points to the specified column(s) of the specified data source.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBindY Method (IEnumerable[])

DataPointCollection.DataBindY Method (IEnumerable[]) |
 | See Also

Data binds the Y-value(s) of the collection's data points to the first column of the specified data source(s).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindY ( _
    ParamArray yValue As IEnumerable() _
)
public void DataBindY (
    params IEnumerable[] yValue
)
public:
void DataBindY (
    ... array<IEnumerable^>^ yValue
)
public void DataBindY (
    IEnumerable[] yValue
)
public function DataBindY (
    ... yValue : IEnumerable[]
)

Parameters

yValue

One or more comma-separated IEnumerable data sources.

Remarks

This method binds the Y-value(s) of the data points in the collection to the first column of the specified data source(s).

To bind Y-values to a data source column that is not the first available column, use the DataBindY method.

You can bind several Y-values by specifying multiple data sources, using the yValue parameter. Note that the first available column in each data source will be used for each data point's successive Y-values. For example, the first column of the first IEnumerable data source will be bound to the first Y-value of data points, the first column of the second IEnumerable data source will be bound to the second Y-value of data points, and so forth.

If Y-values are not provided by the data source, or if the wrong number of values are provided, an exception will be thrown.

The following is a list of objects that you can use as the data source parameter:

The following is a list of objects that you can use as the data source:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.DataBindY Method (IEnumerable, String)

DataPointCollection.DataBindY Method (IEnumerable, String) |
 | See Also

Data binds the Y-value(s) of the data points to the specified column(s) of the specified data source.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub DataBindY ( _
    yValue As IEnumerable, _
    yFields As String _
)
public void DataBindY (
    IEnumerable yValue,
    string yFields
)
public:
void DataBindY (
    IEnumerable^ yValue,
    String^ yFields
)
public void DataBindY (
    IEnumerable yValue,
    String yFields
)
public function DataBindY (
    yValue : IEnumerable,
    yFields : String
)

Parameters

yValue

An IEnumerable

data source object that provides the Y-value(s).

yFields

The data source field(s) to which to bind data point(s). Note that a comma can be embedded as part of a column name, by using a double comma.

Remarks

This method binds the Y-values of the data points in the collection to the specified fields(s) of the data source.

To bind only to the first field in a data source, use the DataBindY method.

You can bind to several fields by setting the yFields parameter to multiple field names that are comma-separated. Note that the first field will be used for the data point's first Y-value, the second named field will be used for the data point's second Y-value, and so forth.

If Y-values are not provided by the data source, or the wrong number of values are provided, an exception will be thrown.

The following is a list of objects that you can use as the data source:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindAllByValue Method

DataPointCollection.FindAllByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindAllByValue (Double) | Find all the data points that are equal to the specified value.
DataPointCollection.FindAllByValue (Double, String) | Finds all the data points that are equal to the specified value.
DataPointCollection.FindAllByValue (Double, String, Int32) | Finds all the data points that are equal to the specified value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindAllByValue Method (Double)

DataPointCollection.FindAllByValue Method (Double) |
 | See Also

Find all the data points that are equal to the specified value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindAllByValue ( _
    valueToFind As Double _
) As IEnumerable(Of DataPoint)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind
)
public:
IEnumerable<DataPoint^>^ FindAllByValue (
    double valueToFind
)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind
)
public function FindAllByValue (
    valueToFind : double
) : IEnumerable<DataPoint>

Parameters

valueToFind

The data point value to find.

Return Value

An IEnumerable interface that represents the enumerator of the matching data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindAllByValue Method (Double, String)

DataPointCollection.FindAllByValue Method (Double, String) |
 | See Also

Finds all the data points that are equal to the specified value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindAllByValue ( _
    valueToFind As Double, _
    useValue As String _
) As IEnumerable(Of DataPoint)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    string useValue
)
public:
IEnumerable<DataPoint^>^ FindAllByValue (
    double valueToFind,
    String^ useValue
)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    String useValue
)
public function FindAllByValue (
    valueToFind : double,
    useValue : String
) : IEnumerable<DataPoint>

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

Return Value

An IEnumerable interface that represents the enumerator of the matching data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindAllByValue Method (Double, String, Int32)

DataPointCollection.FindAllByValue Method (Double, String, Int32) |
 | See Also

Finds all the data points that are equal to the specified value, starting from the specified index location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindAllByValue ( _
    valueToFind As Double, _
    useValue As String, _
    startIndex As Integer _
) As IEnumerable(Of DataPoint)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    string useValue,
    int startIndex
)
public:
IEnumerable<DataPoint^>^ FindAllByValue (
    double valueToFind,
    String^ useValue,
    int startIndex
)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    String useValue,
    int startIndex
)
public function FindAllByValue (
    valueToFind : double,
    useValue : String,
    startIndex : int
) : IEnumerable<DataPoint>

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

An IEnumerable interface that represents the enumerator of the matching data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindByValue Method

DataPointCollection.FindByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindByValue (Double) | Finds the first data point that is equal to the specified value.
DataPointCollection.FindByValue (Double, String) | Finds the first data point that is equal to the specified value.
DataPointCollection.FindByValue (Double, String, Int32) | Finds the first data point that is equal to the specified value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindByValue Method (Double)

DataPointCollection.FindByValue Method (Double) |
 | See Also

Finds the first data point that is equal to the specified value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindByValue ( _
    valueToFind As Double _
) As DataPoint
public DataPoint FindByValue (
    double valueToFind
)
public:
DataPoint^ FindByValue (
    double valueToFind
)
public DataPoint FindByValue (
    double valueToFind
)
public function FindByValue (
    valueToFind : double
) : DataPoint

Parameters

valueToFind

The data point value to find.

Return Value

The DataPoint that matches the specified value, or null if there is no match.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindByValue Method (Double, String)

DataPointCollection.FindByValue Method (Double, String) |
 | See Also

Finds the first data point that is equal to the specified value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindByValue ( _
    valueToFind As Double, _
    useValue As String _
) As DataPoint
public DataPoint FindByValue (
    double valueToFind,
    string useValue
)
public:
DataPoint^ FindByValue (
    double valueToFind,
    String^ useValue
)
public DataPoint FindByValue (
    double valueToFind,
    String useValue
)
public function FindByValue (
    valueToFind : double,
    useValue : String
) : DataPoint

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

Return Value

The DataPoint that matches the specified value, or null if there is no match.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindByValue Method (Double, String, Int32)

DataPointCollection.FindByValue Method (Double, String, Int32) |
 | See Also

Finds the first data point that is equal to the specified value, starting from the specified index location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindByValue ( _
    valueToFind As Double, _
    useValue As String, _
    startIndex As Integer _
) As DataPoint
public DataPoint FindByValue (
    double valueToFind,
    string useValue,
    int startIndex
)
public:
DataPoint^ FindByValue (
    double valueToFind,
    String^ useValue,
    int startIndex
)
public DataPoint FindByValue (
    double valueToFind,
    String useValue,
    int startIndex
)
public function FindByValue (
    valueToFind : double,
    useValue : String,
    startIndex : int
) : DataPoint

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

The DataPoint that matches the specified value, or null if there is no match.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMaxByValue Method

DataPointCollection.FindMaxByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindMaxByValue () | Finds the data point with the maximum value.
DataPointCollection.FindMaxByValue (String) | Finds the data point value with the maximum value.
DataPointCollection.FindMaxByValue (String, Int32) | Finds the data point with the maximum value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMaxByValue Method ()

DataPointCollection.FindMaxByValue Method () |
 | See Also

Finds the data point with the maximum value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindMaxByValue As DataPoint
public DataPoint FindMaxByValue ()
public:
DataPoint^ FindMaxByValue ()
public DataPoint FindMaxByValue ()
public function FindMaxByValue () : DataPoint

Return Value

The DataPoint object with the maximum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMaxByValue Method (String)

DataPointCollection.FindMaxByValue Method (String) |
 | See Also

Finds the data point value with the maximum value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindMaxByValue ( _
    useValue As String _
) As DataPoint
public DataPoint FindMaxByValue (
    string useValue
)
public:
DataPoint^ FindMaxByValue (
    String^ useValue
)
public DataPoint FindMaxByValue (
    String useValue
)
public function FindMaxByValue (
    useValue : String
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

Return Value

The DataPoint object with the maximum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMaxByValue Method (String, Int32)

DataPointCollection.FindMaxByValue Method (String, Int32) |
 | See Also

Finds the data point with the maximum value, starting from the specified index location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindMaxByValue ( _
    useValue As String, _
    startIndex As Integer _
) As DataPoint
public DataPoint FindMaxByValue (
    string useValue,
    int startIndex
)
public:
DataPoint^ FindMaxByValue (
    String^ useValue,
    int startIndex
)
public DataPoint FindMaxByValue (
    String useValue,
    int startIndex
)
public function FindMaxByValue (
    useValue : String,
    startIndex : int
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

The DataPoint object with the maximum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMinByValue Method

DataPointCollection.FindMinByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindMinByValue () | Finds the data point with the minimum value.
DataPointCollection.FindMinByValue (String) | Finds the data point with the minimum value.
DataPointCollection.FindMinByValue (String, Int32) | Finds the data point with the minimum value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMinByValue Method ()

DataPointCollection.FindMinByValue Method () |
 | See Also

Finds the data point with the minimum value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindMinByValue As DataPoint
public DataPoint FindMinByValue ()
public:
DataPoint^ FindMinByValue ()
public DataPoint FindMinByValue ()
public function FindMinByValue () : DataPoint

Return Value

The DataPoint object with the minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMinByValue Method (String)

DataPointCollection.FindMinByValue Method (String) |
 | See Also

Finds the data point with the minimum value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindMinByValue ( _
    useValue As String _
) As DataPoint
public DataPoint FindMinByValue (
    string useValue
)
public:
DataPoint^ FindMinByValue (
    String^ useValue
)
public DataPoint FindMinByValue (
    String useValue
)
public function FindMinByValue (
    useValue : String
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

Return Value

A DataPoint object with the minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.FindMinByValue Method (String, Int32)

DataPointCollection.FindMinByValue Method (String, Int32) |
 | See Also

Finds the data point with the minimum value, starting from the specified index location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FindMinByValue ( _
    useValue As String, _
    startIndex As Integer _
) As DataPoint
public DataPoint FindMinByValue (
    string useValue,
    int startIndex
)
public:
DataPoint^ FindMinByValue (
    String^ useValue,
    int startIndex
)
public DataPoint FindMinByValue (
    String useValue,
    int startIndex
)
public function FindMinByValue (
    useValue : String,
    startIndex : int
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

The DataPoint object with the minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.InsertXY Method

DataPointCollection.InsertXY Method |
 | See Also

Inserts a data point with the specified X value and one or more specified Y values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertXY ( _
    index As Integer, _
    xValue As Object, _
    ParamArray yValue As Object() _
)
public void InsertXY (
    int index,
    Object xValue,
    params Object[] yValue
)
public:
void InsertXY (
    int index,
    Object^ xValue,
    ... array<Object^>^ yValue
)
public void InsertXY (
    int index,
    Object xValue,
    Object[] yValue
)
public function InsertXY (
    index : int,
    xValue : Object,
    ... yValue : Object[]
)

Parameters

index

The index after which the data point will be inserted.

xValue

The X value of the data point.

yValue

A comma-separated list of Y values of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection.InsertY Method

DataPointCollection.InsertY Method |
 | See Also

Inserts a data point with one or more specified Y values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub InsertY ( _
    index As Integer, _
    ParamArray yValue As Object() _
)
public void InsertY (
    int index,
    params Object[] yValue
)
public:
void InsertY (
    int index,
    ... array<Object^>^ yValue
)
public void InsertY (
    int index,
    Object[] yValue
)
public function InsertY (
    index : int,
    ... yValue : Object[]
)

Parameters

index

The index after which the data point will be inserted.

yValue

A comma-separated list of Y values of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCollection Properties

DataPointCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

DataPointCollection Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointComparer Class

DataPointComparer Class |
 | See Also Members

Compares data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class DataPointComparer
    Implements IComparer(Of DataPoint)
public class DataPointComparer : IComparer<DataPoint>
public ref class DataPointComparer : IComparer<DataPoint^>
public class DataPointComparer implements IComparer<DataPoint>
public class DataPointComparer implements IComparer<DataPoint>

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.DataPointComparer

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointComparer Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointComparer Members

DataPointComparer Members |
 | See Also Constructors Methods

Compares data points.

The following tables list the members exposed by the DataPointComparer type.

Public Constructors

Name | Description
DataPointComparer | Initializes a new instance of the DataPointComparer class with the specified data series, sort order and sort value.
Top

Public Methods (see also Protected Methods )

Name | Description
Compare | Compares two data points.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataPointComparer Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointComparer Constructor

DataPointComparer Constructor |
 | See Also

Initializes a new instance of the DataPointComparer class with the specified data series, sort order and sort value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    series As Series, _
    sortOrder As PointSortOrder, _
    sortBy As String _
)
public DataPointComparer (
    Series series,
    PointSortOrder sortOrder,
    string sortBy
)
public:
DataPointComparer (
    Series^ series,
    PointSortOrder sortOrder,
    String^ sortBy
)
public DataPointComparer (
    Series series,
    PointSortOrder sortOrder,
    String sortBy
)
public function DataPointComparer (
    series : Series,
    sortOrder : PointSortOrder,
    sortBy : String
)

Parameters

series

Data series.

sortOrder

Sort order.

sortBy

Value used for the sort, for example, "X", "Y or Y1", "Y2", and so forth.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointComparer Class
DataPointComparer Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointComparer Methods

DataPointComparer Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Compare | Compares two data points.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataPointComparer Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointComparer.Compare Method

DataPointComparer.Compare Method |
 | See Also

Compares two data points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Compare ( _
    x As DataPoint, _
    y As DataPoint _
) As Integer
public int Compare (
    DataPoint x,
    DataPoint y
)
public:
virtual int Compare (
    DataPoint^ x,
    DataPoint^ y
) sealed
public final int Compare (
    DataPoint x,
    DataPoint y
)
public final function Compare (
    x : DataPoint,
    y : DataPoint
) : int

Parameters

x

First data point.

y

Second data point.

Return Value

An integer value. Returns zero (0) if the two values are equal. Returns a positive integer if the value of x is greater than the value of y; otherwise, returns a negative integer.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointComparer Class
DataPointComparer Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Class

DataPointCustomProperties Class |
 | See Also Members

Defines custom properties that are common to data points, series and empty points.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class DataPointCustomProperties
    Inherits ChartNamedElement
    Implements IChartMapArea
public class DataPointCustomProperties : ChartNamedElement, IChartMapArea
public ref class DataPointCustomProperties : public ChartNamedElement, IChartMapArea
public class DataPointCustomProperties extends ChartNamedElement implements IChartMapArea
public class DataPointCustomProperties extends ChartNamedElement implements IChartMapArea

Remarks

This class defines custom properties such as colors, the use of background images, hatching, and so forth.

The Series class, DataPoint class and the EmptyPointStyle property are all derived from this class.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.DataPointCustomProperties
System.Web.UI.DataVisualization.Charting.DataPoint
System.Web.UI.DataVisualization.Charting.Series

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Members

DataPointCustomProperties Members |
 | See Also Constructors Methods Properties

Defines custom properties that are common to data points, series and empty points.

The following tables list the members exposed by the DataPointCustomProperties type.

Public Constructors

Name | Description
DataPointCustomProperties | Overloaded.
Top

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object.
BackGradientStyle | Gets or sets the background gradient style.
BackHatchStyle | Gets or sets the background hatching style.
BackImage | Gets or sets the background image of the data point.
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of the background image.
BackSecondaryColor | Gets or sets the secondary background color.
BorderColor | Gets or sets the border color of the data point.
BorderDashStyle | Gets or sets the border style of the data point.
BorderWidth | Gets or sets the border width of the data point.
Color | Gets or sets the color of the data point.
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 …
CustomPropertiesExtended | For internal use only.
Font | Gets or sets the font of the data point.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label.
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend.
Item | Overloaded.
Label | Gets or sets the text of the data point label.
LabelAngle | Gets or sets the angle of the data point label.
LabelBackColor | Gets or sets the background color of the data point label.
LabelBorderColor | Gets or sets the border color of the data point label.
LabelBorderDashStyle | Gets or sets the border style of the label.
LabelBorderWidth | Gets or sets the border width of the label.
LabelForeColor | Gets or sets the text color of the label.
LabelFormat | Gets or sets the format of the data point label.
LabelMapAreaAttributes | Gets or sets map area attributes of the data point label.
LabelPostBackValue | Gets or sets the postback value which can be processed on a Click event.
LabelToolTip | Gets or sets the tooltip for the data point label.
LabelUrl | Gets or sets the URL target of the data point label.
LegendMapAreaAttributes | Gets or sets the attributes of the legend map area.
LegendPostBackValue | Gets or sets the postback value which can be processed on a Click event.
LegendText | Gets or sets the text of the item in the legend.
LegendToolTip | Gets or sets the tooltip of the item in the legend.
LegendUrl | Gets or sets the URL target of the item in the legend.
MapAreaAttributes | Gets or sets the map area attributes of a data point.
MarkerBorderColor | Gets or sets the border color of the marker.
MarkerBorderWidth | Gets or sets the border width of the marker.
MarkerColor | Gets or sets the marker color.
MarkerImage | Gets or sets the marker image.
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the marker.
MarkerStyle | Gets or sets the marker style.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement)
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip.
Url | Gets or sets the URL target of the area.
Top

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | Deletes the data point custom property with the specified name.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | Returns the data point custom property with the specified name.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
IsCustomPropertySet | Determines whether a custom property with the specified name was set.
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets the IsValueShownAsLabel property to its default value.
ResetIsVisibleInLegend | Resets the IsVisibleInLegend property to its default value.
SetCustomProperty | Sets a custom property of the data point.
SetDefault | Sets the default properties of the data point. Indicates whether the previous property values must be cleared.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataPointCustomProperties Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Constructor

DataPointCustomProperties Constructor |
 | See Also

Overload List

Name | Description
DataPointCustomProperties () | Initializes a new instance of the DataPointCustomProperties class.
DataPointCustomProperties (Series, Boolean) | For internal use only.

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Constructor ()

DataPointCustomProperties Constructor () |
 | See Also

Initializes a new instance of the DataPointCustomProperties class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public DataPointCustomProperties ()
public:
DataPointCustomProperties ()
public DataPointCustomProperties ()
public function DataPointCustomProperties ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Constructor (Series, Boolean)

DataPointCustomProperties Constructor (Series, Boolean) |
 | See Also

For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    series As Series, _
    pointProperties As Boolean _
)
public DataPointCustomProperties (
    Series series,
    bool pointProperties
)
public:
DataPointCustomProperties (
    Series^ series,
    bool pointProperties
)
public DataPointCustomProperties (
    Series series,
    boolean pointProperties
)
public function DataPointCustomProperties (
    series : Series,
    pointProperties : boolean
)

Parameters

series

The series that the data point belongs to.

pointProperties

A flag that indicates whether this is a data point custom property.

Remarks

This constructor is for internal use only.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Methods

DataPointCustomProperties Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | Deletes the data point custom property with the specified name.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | Returns the data point custom property with the specified name.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
IsCustomPropertySet | Determines whether a custom property with the specified name was set.
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets the IsValueShownAsLabel property to its default value.
ResetIsVisibleInLegend | Resets the IsVisibleInLegend property to its default value.
SetCustomProperty | Sets a custom property of the data point.
SetDefault | Sets the default properties of the data point. Indicates whether the previous property values must be cleared.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataPointCustomProperties Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.DeleteCustomProperty Method

DataPointCustomProperties.DeleteCustomProperty Method |
 | See Also

Deletes the data point custom property with the specified name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub DeleteCustomProperty ( _
    name As String _
)
public virtual void DeleteCustomProperty (
    string name
)
public:
virtual void DeleteCustomProperty (
    String^ name
)
public void DeleteCustomProperty (
    String name
)
public function DeleteCustomProperty (
    name : String
)

Parameters

name

The name of the property to delete.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.GetCustomProperty Method

DataPointCustomProperties.GetCustomProperty Method |
 | See Also

Returns the data point custom property with the specified name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Function GetCustomProperty ( _
    name As String _
) As String
public virtual string GetCustomProperty (
    string name
)
public:
virtual String^ GetCustomProperty (
    String^ name
)
public String GetCustomProperty (
    String name
)
public function GetCustomProperty (
    name : String
) : String

Parameters

name

The name of the property to return.

Return Value

A string value that represents the data point custom property with the specified name. If the requested property is not set, the default custom property of the data series will be returned.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.IsCustomPropertySet Method

DataPointCustomProperties.IsCustomPropertySet Method |
 | See Also

Determines whether a custom property with the specified name was set.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Function IsCustomPropertySet ( _
    name As String _
) As Boolean
public virtual bool IsCustomPropertySet (
    string name
)
public:
virtual bool IsCustomPropertySet (
    String^ name
)
public boolean IsCustomPropertySet (
    String name
)
public function IsCustomPropertySet (
    name : String
) : boolean

Parameters

name

The name of the custom property to check.

Return Value

True if the custom property was set, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.ResetIsValueShownAsLabel Method

DataPointCustomProperties.ResetIsValueShownAsLabel Method |
 | See Also

Resets the IsValueShownAsLabel property to its default value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub ResetIsValueShownAsLabel
public void ResetIsValueShownAsLabel ()
public:
void ResetIsValueShownAsLabel ()
public void ResetIsValueShownAsLabel ()
public function ResetIsValueShownAsLabel ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.ResetIsVisibleInLegend Method

DataPointCustomProperties.ResetIsVisibleInLegend Method |
 | See Also

Resets the IsVisibleInLegend property to its default value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub ResetIsVisibleInLegend
public void ResetIsVisibleInLegend ()
public:
void ResetIsVisibleInLegend ()
public void ResetIsVisibleInLegend ()
public function ResetIsVisibleInLegend ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.SetCustomProperty Method

DataPointCustomProperties.SetCustomProperty Method |
 | See Also

Sets a custom property of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub SetCustomProperty ( _
    name As String, _
    propertyValue As String _
)
public virtual void SetCustomProperty (
    string name,
    string propertyValue
)
public:
virtual void SetCustomProperty (
    String^ name,
    String^ propertyValue
)
public void SetCustomProperty (
    String name,
    String propertyValue
)
public function SetCustomProperty (
    name : String,
    propertyValue : String
)

Parameters

name

The name of the property.

propertyValue

The value of the property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.SetDefault Method

DataPointCustomProperties.SetDefault Method |
 | See Also

Sets the default properties of the data point. Indicates whether the previous property values must be cleared.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Sub SetDefault ( _
    clearAll As Boolean _
)
public virtual void SetDefault (
    bool clearAll
)
public:
virtual void SetDefault (
    bool clearAll
)
public void SetDefault (
    boolean clearAll
)
public function SetDefault (
    clearAll : boolean
)

Parameters

clearAll

A flag that indicates whether to clear previous property values.

Remarks

If the clearAll parameter is set to true, all previous property values are cleared, otherwise they are not.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties Properties

DataPointCustomProperties Properties |
 | See Also

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object.
BackGradientStyle | Gets or sets the background gradient style.
BackHatchStyle | Gets or sets the background hatching style.
BackImage | Gets or sets the background image of the data point.
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of the background image.
BackSecondaryColor | Gets or sets the secondary background color.
BorderColor | Gets or sets the border color of the data point.
BorderDashStyle | Gets or sets the border style of the data point.
BorderWidth | Gets or sets the border width of the data point.
Color | Gets or sets the color of the data point.
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 …
CustomPropertiesExtended | For internal use only.
Font | Gets or sets the font of the data point.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label.
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend.
Item | Overloaded.
Label | Gets or sets the text of the data point label.
LabelAngle | Gets or sets the angle of the data point label.
LabelBackColor | Gets or sets the background color of the data point label.
LabelBorderColor | Gets or sets the border color of the data point label.
LabelBorderDashStyle | Gets or sets the border style of the label.
LabelBorderWidth | Gets or sets the border width of the label.
LabelForeColor | Gets or sets the text color of the label.
LabelFormat | Gets or sets the format of the data point label.
LabelMapAreaAttributes | Gets or sets map area attributes of the data point label.
LabelPostBackValue | Gets or sets the postback value which can be processed on a Click event.
LabelToolTip | Gets or sets the tooltip for the data point label.
LabelUrl | Gets or sets the URL target of the data point label.
LegendMapAreaAttributes | Gets or sets the attributes of the legend map area.
LegendPostBackValue | Gets or sets the postback value which can be processed on a Click event.
LegendText | Gets or sets the text of the item in the legend.
LegendToolTip | Gets or sets the tooltip of the item in the legend.
LegendUrl | Gets or sets the URL target of the item in the legend.
MapAreaAttributes | Gets or sets the map area attributes of a data point.
MarkerBorderColor | Gets or sets the border color of the marker.
MarkerBorderWidth | Gets or sets the border width of the marker.
MarkerColor | Gets or sets the marker color.
MarkerImage | Gets or sets the marker image.
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the marker.
MarkerStyle | Gets or sets the marker style.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement )
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip.
Url | Gets or sets the URL target of the area.

See Also

Reference

DataPointCustomProperties Class
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.AxisLabel Property

DataPointCustomProperties.AxisLabel Property |
 | See Also

Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AxisLabel As String
public virtual string AxisLabel { get; set; }
public:
virtual property String^ AxisLabel {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AxisLabel ()

/** @property */
public void set_AxisLabel (String value)

public function get AxisLabel () : String

public function set AxisLabel (value : String)

Property Value

A string value that represents the text of the X-axis label.

Remarks

This property sets the axis label for a data point, series or an empty point.

This property can only be set at run time for a Series object. If you set this property or a Series object, all of its data points will use this label.

If the AxisLabel property is not set and a custom label has not been specified, an axis label will be generated automatically using the axis scale.

Empty point labels are set using the EmptyPointStyle property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackGradientStyle Property

DataPointCustomProperties.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackHatchStyle Property

DataPointCustomProperties.BackHatchStyle Property |
 | See Also

Gets or sets the background hatching style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackImage Property

DataPointCustomProperties.BackImage Property |
 | See Also

Gets or sets the background image of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackImageAlignment Property

DataPointCustomProperties.BackImageAlignment Property |
 | See Also

Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackImageTransparentColor Property

DataPointCustomProperties.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the background image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be replaced with a transparent color when the image is drawn.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackImageWrapMode Property

DataPointCustomProperties.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of the background image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value that defines the drawing mode of the image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BackSecondaryColor Property

DataPointCustomProperties.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary background color.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BorderColor Property

DataPointCustomProperties.BorderColor Property |
 | See Also

Gets or sets the border color of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BorderDashStyle Property

DataPointCustomProperties.BorderDashStyle Property |
 | See Also

Gets or sets the border style of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.BorderWidth Property

DataPointCustomProperties.BorderWidth Property |
 | See Also

Gets or sets the border width of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Color Property

DataPointCustomProperties.Color Property |
 | See Also

Gets or sets the color of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Color As Color
public Color Color { get; set; }
public:
property Color Color {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_Color ()

/** @property */
public void set_Color (Color value)

public function get Color () : Color

public function set Color (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.CustomProperties Property

DataPointCustomProperties.CustomProperties Property |
 | See Also

Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 …

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property CustomProperties As String
[BrowsableAttribute(false)]
public string CustomProperties { get; set; }
[BrowsableAttribute(false)]
public:
property String^ CustomProperties {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_CustomProperties ()

/** @property */
public void set_CustomProperties (String value)

public function get CustomProperties () : String

public function set CustomProperties (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.CustomPropertiesExtended Property

DataPointCustomProperties.CustomPropertiesExtended Property |
 | See Also

For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignOnlyAttribute(True)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property CustomPropertiesExtended As CustomProperties
[DesignOnlyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public CustomProperties CustomPropertiesExtended { get; set; }
[DesignOnlyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property CustomProperties^ CustomPropertiesExtended {
    CustomProperties^ get ();
    void set (CustomProperties^ value);
}
/** @property */
public CustomProperties get_CustomPropertiesExtended ()

/** @property */
public void set_CustomPropertiesExtended (CustomProperties value)

public function get CustomPropertiesExtended () : CustomProperties

public function set CustomPropertiesExtended (value : CustomProperties)

Property Value

A CustomProperties object.

Remarks

This property is for internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Font Property

DataPointCustomProperties.Font Property |
 | See Also

Gets or sets the font of the data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.IsValueShownAsLabel Property

DataPointCustomProperties.IsValueShownAsLabel Property |
 | See Also

Gets or sets a flag that indicates whether to show the value of the data point on the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsValueShownAsLabel As Boolean
public bool IsValueShownAsLabel { get; set; }
public:
property bool IsValueShownAsLabel {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsValueShownAsLabel ()

/** @property */
public void set_IsValueShownAsLabel (boolean value)

public function get IsValueShownAsLabel () : boolean

public function set IsValueShownAsLabel (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.IsVisibleInLegend Property

DataPointCustomProperties.IsVisibleInLegend Property |
 | See Also

Gets or sets a flag that indicates whether the item is shown in the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsVisibleInLegend As Boolean
public bool IsVisibleInLegend { get; set; }
public:
property bool IsVisibleInLegend {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsVisibleInLegend ()

/** @property */
public void set_IsVisibleInLegend (boolean value)

public function get IsVisibleInLegend () : boolean

public function set IsVisibleInLegend (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Item Property

DataPointCustomProperties.Item Property |
 | See Also

Overload List

Name | Description
DataPointCustomProperties.Item (Int32) | Gets the DataPointCustomProperties object by its position in the index.
DataPointCustomProperties.Item (String) | Gets or sets the DataPointCustomProperties object by name.

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Item Property (Int32)

DataPointCustomProperties.Item Property (Int32) |
 | See Also

Gets the DataPointCustomProperties object by its position in the index.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Default Property Item ( _
    index As Integer _
) As String
public string this [
    int index
] { get; }
public:
property String^ default [int] {
    String^ get (int index);
}
/** @property */
public String get_Item (int index)

Parameters

index

Index of the custom property.

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Item Property (String)

DataPointCustomProperties.Item Property (String) |
 | See Also

Gets or sets the DataPointCustomProperties object by name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Default Property Item ( _
    name As String _
) As String
public string this [
    string name
] { get; set; }
public:
property String^ default [String^] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}
/** @property */
public String get_Item (String name)

/** @property */
public void set_Item (String name, String value)

Parameters

name

The ame of the custom property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Label Property

DataPointCustomProperties.Label Property |
 | See Also

Gets or sets the text of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Label As String
public virtual string Label { get; set; }
public:
virtual property String^ Label {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Label ()

/** @property */
public void set_Label (String value)

public function get Label () : String

public function set Label (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelAngle Property

DataPointCustomProperties.LabelAngle Property |
 | See Also

Gets or sets the angle of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelAngle As Integer
public int LabelAngle { get; set; }
public:
property int LabelAngle {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelAngle ()

/** @property */
public void set_LabelAngle (int value)

public function get LabelAngle () : int

public function set LabelAngle (value : int)

Property Value

An integer value that represents the angle of the label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelBackColor Property

DataPointCustomProperties.LabelBackColor Property |
 | See Also

Gets or sets the background color of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelBackColor As Color
public Color LabelBackColor { get; set; }
public:
property Color LabelBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LabelBackColor ()

/** @property */
public void set_LabelBackColor (Color value)

public function get LabelBackColor () : Color

public function set LabelBackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelBorderColor Property

DataPointCustomProperties.LabelBorderColor Property |
 | See Also

Gets or sets the border color of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelBorderColor As Color
public Color LabelBorderColor { get; set; }
public:
property Color LabelBorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LabelBorderColor ()

/** @property */
public void set_LabelBorderColor (Color value)

public function get LabelBorderColor () : Color

public function set LabelBorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelBorderDashStyle Property

DataPointCustomProperties.LabelBorderDashStyle Property |
 | See Also

Gets or sets the border style of the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelBorderDashStyle As ChartDashStyle
public ChartDashStyle LabelBorderDashStyle { get; set; }
public:
property ChartDashStyle LabelBorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LabelBorderDashStyle ()

/** @property */
public void set_LabelBorderDashStyle (ChartDashStyle value)

public function get LabelBorderDashStyle () : ChartDashStyle

public function set LabelBorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelBorderWidth Property

DataPointCustomProperties.LabelBorderWidth Property |
 | See Also

Gets or sets the border width of the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelBorderWidth As Integer
public int LabelBorderWidth { get; set; }
public:
property int LabelBorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelBorderWidth ()

/** @property */
public void set_LabelBorderWidth (int value)

public function get LabelBorderWidth () : int

public function set LabelBorderWidth (value : int)

Property Value

An integer value that represents the width of the border.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelForeColor Property

DataPointCustomProperties.LabelForeColor Property |
 | See Also

Gets or sets the text color of the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelForeColor As Color
public Color LabelForeColor { get; set; }
public:
property Color LabelForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LabelForeColor ()

/** @property */
public void set_LabelForeColor (Color value)

public function get LabelForeColor () : Color

public function set LabelForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelFormat Property

DataPointCustomProperties.LabelFormat Property |
 | See Also

Gets or sets the format of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelFormat As String
public string LabelFormat { get; set; }
public:
property String^ LabelFormat {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelFormat ()

/** @property */
public void set_LabelFormat (String value)

public function get LabelFormat () : String

public function set LabelFormat (value : String)

Property Value

A string value that represents the format of the label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelMapAreaAttributes Property

DataPointCustomProperties.LabelMapAreaAttributes Property |
 | See Also

Gets or sets map area attributes of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelMapAreaAttributes As String
public string LabelMapAreaAttributes { get; set; }
public:
property String^ LabelMapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelMapAreaAttributes ()

/** @property */
public void set_LabelMapAreaAttributes (String value)

public function get LabelMapAreaAttributes () : String

public function set LabelMapAreaAttributes (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelPostBackValue Property

DataPointCustomProperties.LabelPostBackValue Property |
 | See Also

Gets or sets the postback value which can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelPostBackValue As String
public string LabelPostBackValue { get; set; }
public:
property String^ LabelPostBackValue {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelPostBackValue ()

/** @property */
public void set_LabelPostBackValue (String value)

public function get LabelPostBackValue () : String

public function set LabelPostBackValue (value : String)

Property Value

A string value that represents the postback value that is passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelToolTip Property

DataPointCustomProperties.LabelToolTip Property |
 | See Also

Gets or sets the tooltip for the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelToolTip As String
public string LabelToolTip { get; set; }
public:
property String^ LabelToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelToolTip ()

/** @property */
public void set_LabelToolTip (String value)

public function get LabelToolTip () : String

public function set LabelToolTip (value : String)

Property Value

A string value that represents the tooltip for the data point label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LabelUrl Property

DataPointCustomProperties.LabelUrl Property |
 | See Also

Gets or sets the URL target of the data point label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LabelUrl As String
public string LabelUrl { get; set; }
public:
property String^ LabelUrl {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelUrl ()

/** @property */
public void set_LabelUrl (String value)

public function get LabelUrl () : String

public function set LabelUrl (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LegendMapAreaAttributes Property

DataPointCustomProperties.LegendMapAreaAttributes Property |
 | See Also

Gets or sets the attributes of the legend map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendMapAreaAttributes As String
public string LegendMapAreaAttributes { get; set; }
public:
property String^ LegendMapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendMapAreaAttributes ()

/** @property */
public void set_LegendMapAreaAttributes (String value)

public function get LegendMapAreaAttributes () : String

public function set LegendMapAreaAttributes (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LegendPostBackValue Property

DataPointCustomProperties.LegendPostBackValue Property |
 | See Also

Gets or sets the postback value which can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendPostBackValue As String
public string LegendPostBackValue { get; set; }
public:
property String^ LegendPostBackValue {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendPostBackValue ()

/** @property */
public void set_LegendPostBackValue (String value)

public function get LegendPostBackValue () : String

public function set LegendPostBackValue (value : String)

Property Value

A string value that represents the postback value passed to the Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LegendText Property

DataPointCustomProperties.LegendText Property |
 | See Also

Gets or sets the text of the item in the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendText As String
public string LegendText { get; set; }
public:
property String^ LegendText {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendText ()

/** @property */
public void set_LegendText (String value)

public function get LegendText () : String

public function set LegendText (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LegendToolTip Property

DataPointCustomProperties.LegendToolTip Property |
 | See Also

Gets or sets the tooltip of the item in the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendToolTip As String
public string LegendToolTip { get; set; }
public:
property String^ LegendToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendToolTip ()

/** @property */
public void set_LegendToolTip (String value)

public function get LegendToolTip () : String

public function set LegendToolTip (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.LegendUrl Property

DataPointCustomProperties.LegendUrl Property |
 | See Also

Gets or sets the URL target of the item in the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendUrl As String
public string LegendUrl { get; set; }
public:
property String^ LegendUrl {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendUrl ()

/** @property */
public void set_LegendUrl (String value)

public function get LegendUrl () : String

public function set LegendUrl (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MapAreaAttributes Property

DataPointCustomProperties.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of a data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerBorderColor Property

DataPointCustomProperties.MarkerBorderColor Property |
 | See Also

Gets or sets the border color of the marker.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerBorderColor As Color
public Color MarkerBorderColor { get; set; }
public:
property Color MarkerBorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerBorderColor ()

/** @property */
public void set_MarkerBorderColor (Color value)

public function get MarkerBorderColor () : Color

public function set MarkerBorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerBorderWidth Property

DataPointCustomProperties.MarkerBorderWidth Property |
 | See Also

Gets or sets the border width of the marker.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerBorderWidth As Integer
public int MarkerBorderWidth { get; set; }
public:
property int MarkerBorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerBorderWidth ()

/** @property */
public void set_MarkerBorderWidth (int value)

public function get MarkerBorderWidth () : int

public function set MarkerBorderWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerColor Property

DataPointCustomProperties.MarkerColor Property |
 | See Also

Gets or sets the marker color.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerColor As Color
public Color MarkerColor { get; set; }
public:
property Color MarkerColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerColor ()

/** @property */
public void set_MarkerColor (Color value)

public function get MarkerColor () : Color

public function set MarkerColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerImage Property

DataPointCustomProperties.MarkerImage Property |
 | See Also

Gets or sets the marker image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerImage As String
public string MarkerImage { get; set; }
public:
property String^ MarkerImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MarkerImage ()

/** @property */
public void set_MarkerImage (String value)

public function get MarkerImage () : String

public function set MarkerImage (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerImageTransparentColor Property

DataPointCustomProperties.MarkerImageTransparentColor Property |
 | See Also

Gets or sets the color that will be replaced with a transparent color when the marker image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerImageTransparentColor As Color
public Color MarkerImageTransparentColor { get; set; }
public:
property Color MarkerImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerImageTransparentColor ()

/** @property */
public void set_MarkerImageTransparentColor (Color value)

public function get MarkerImageTransparentColor () : Color

public function set MarkerImageTransparentColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerSize Property

DataPointCustomProperties.MarkerSize Property |
 | See Also

Gets or sets the size of the marker.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerSize As Integer
public int MarkerSize { get; set; }
public:
property int MarkerSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerSize ()

/** @property */
public void set_MarkerSize (int value)

public function get MarkerSize () : int

public function set MarkerSize (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.MarkerStyle Property

DataPointCustomProperties.MarkerStyle Property |
 | See Also

Gets or sets the marker style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerStyle As MarkerStyle
public MarkerStyle MarkerStyle { get; set; }
public:
property MarkerStyle MarkerStyle {
    MarkerStyle get ();
    void set (MarkerStyle value);
}
/** @property */
public MarkerStyle get_MarkerStyle ()

/** @property */
public void set_MarkerStyle (MarkerStyle value)

public function get MarkerStyle () : MarkerStyle

public function set MarkerStyle (value : MarkerStyle)

Property Value

A MarkerStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.PostBackValue Property

DataPointCustomProperties.PostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the postback value passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.ToolTip Property

DataPointCustomProperties.ToolTip Property |
 | See Also

Gets or sets the tooltip.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DataPointCustomProperties.Url Property

DataPointCustomProperties.Url Property |
 | See Also

Gets or sets the URL target of the area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members
System.Web.UI.DataVisualization.Charting Namespace


DateRangeType Enumeration

DateRangeType Enumeration |
 | See Also

Specifies a date/time interval that determines the ranges that will be filtered when you invoke one of the Filter method definitionsfound in the DataManipulator class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration DateRangeType
public enum DateRangeType
public enum class DateRangeType
public enum DateRangeType
public enum DateRangeType

Members

Member name | Description
DayOfMonth | Date/time interval is days of the month.
DayOfWeek | Date/time interval is days of the week.
Hour | Date/time interval is hours.
Minute | Date/time interval is minutes.
Month | Date/time interval is months.
Year | Date/time interval is years.

Remarks

The DateRangeType enumeration is passed in the DateRange parameter of some Filter methods, which combined with the rangeElements parameter determines the date/time ranges that are filtered.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


DateTimeIntervalType Enumeration

DateTimeIntervalType Enumeration |
 | See Also

Specifies an interval type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration DateTimeIntervalType
public enum DateTimeIntervalType
public enum class DateTimeIntervalType
public enum DateTimeIntervalType
public enum DateTimeIntervalType

Members

Member name | Description
Auto | Automatically determined by the Chart control.
Days | Interval type is in days.
Hours | Interval type is in hours.
Milliseconds | Interval type is in milliseconds.
Minutes | Interval type is in minutes.
Months | Interval type is in months.
NotSet | The IntervalType or IntervalOffsetType property is not set. This value is used for grid lines, tick marks, strip lines and axis labels, and indicates that the interval type is being obtained from the Axis object to which the element belongs. Setting this value for an Axis object will have no effect.
Number | Interval type is in numerical.
Seconds | Interval type is in seconds.
Weeks | Interval type is in weeks.
Years | Interval type is in years.

Remarks

The DateTimeIntervalType enumeration represents date and time interval types.

Note that if you use the NotSet value, properties other than IntervalType or IntervalOffsetType will treat NotSet as an Auto value.

The DateTimeIntervalType values are applicable to the LabelStyle, Grid, TickMark and StripLine classes.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Docking Enumeration

Docking Enumeration |
 | See Also

Specifies where a chart element, such as a legend or title, will be docked on the chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration Docking
public enum Docking
public enum class Docking
public enum Docking
public enum Docking

Members

Member name | Description
Bottom | Docked to the bottom of either the chart image or a ChartArea object.
Left | Docked to the left of either the chart image or a ChartArea object.
Right | Docked to the right of either the chart image or a ChartArea object.
Top | Docked to the top of either the chart image or a ChartArea object.

Remarks

The Docking enumeration represents the location on the Chart control where a chart element will be docked.

Set the IsDockedInsideChartArea property of the relevant chart element to specify whether that element will be docked to the entire chart image or to a ChartArea object. The chart area is specified in the DockedToChartArea property of the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Class

ElementPosition Class |
 | See Also Members

Represents the base class for many visual elements of the chart such as the legend, title, and chart areas. Defines the position of the chart element in relative coordinates, which range from (0,0) to (100,100).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ElementPosition
    Inherits ChartElement
public class ElementPosition : ChartElement
public ref class ElementPosition : public ChartElement
public class ElementPosition extends ChartElement
public class ElementPosition extends ChartElement

Remarks

The ElementPosition class is used to define the position of a chart element, and represents one rectangle using the X, Y, Width and Height properties.

The ElementPosition class is always exposed as a Position property, such as Position, Position, and so forth. It is also exposed in the PrePaint and PostPaint events of the Chart control as a property of the ChartPaintEventArgs object.

The position of the applicable chart elements can be set automatically by setting the Auto property to true; chart elements can also be positioned at design time in the Design View.

There are two major differences between this class and a RectangleF structure:

  • This class can use automatic positioning.

  • This class only uses coordinates ranging from 0 to 100, otherwise an exception is thrown.

The position of chart elements is described using relative coordinates, with the top-left corner of an element having coordinates of (0,0) and the bottom-right corner of an element having coordinates of (100,100).

Elements that are plotted within a chart area use coordinates that are relative to the chart area, whereas elements outside a chart area use coordinates that are relative to the chart image.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ElementPosition

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Members

ElementPosition Members |
 | See Also Constructors Methods Properties

Represents the base class for many visual elements of the chart such as the legend, title, and chart areas. Defines the position of the chart element in relative coordinates, which range from (0,0) to (100,100).

The following tables list the members exposed by the ElementPosition type.

Public Constructors

Name | Description
ElementPosition | Overloaded.
Top

Public Properties

Name | Description
Auto | Gets or sets a flag that determines whether an applicable chart element will be positioned automatically by the Chart control.
Bottom | Gets the bottom position of a chart element, in relative coordinates.
Height | Gets or sets the height of a chart element.
Right | Gets the position of the right side of a chart element, in relative coordinates.
Size | Gets the size of a chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Width | Gets or sets the width of a chart element.
X | Gets or sets the relative X-coordinate of the top-left corner of an applicable chart element.
Y | Gets or sets the relative Y-coordinate of the top-left corner of an applicable chart element.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
FromRectangleF | Initializes an ElementPosition object from a RectangleF structure.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToRectangleF | Returns a RectangleF object that uses the coordinates of an ElementPosition object.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ElementPosition Class
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Constructor

ElementPosition Constructor |
 | See Also

Overload List

Name | Description
ElementPosition () | Initializes a new instance of the ElementPosition class.
ElementPosition (Single, Single, Single, Single) | Initializes a new instance of the ElementPosition class with the specified x, y, width and height parameters.

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Constructor ()

ElementPosition Constructor () |
 | See Also

Initializes a new instance of the ElementPosition class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ElementPosition ()
public:
ElementPosition ()
public ElementPosition ()
public function ElementPosition ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Constructor (Single, Single, Single, Single)

ElementPosition Constructor (Single, Single, Single, Single) |
 | See Also

Initializes a new instance of the ElementPosition class with the specified x, y, width and height parameters.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    x As Single, _
    y As Single, _
    width As Single, _
    height As Single _
)
public ElementPosition (
    float x,
    float y,
    float width,
    float height
)
public:
ElementPosition (
    float x,
    float y,
    float width,
    float height
)
public ElementPosition (
    float x,
    float y,
    float width,
    float height
)
public function ElementPosition (
    x : float,
    y : float,
    width : float,
    height : float
)

Parameters

x

The X position.

y

The Y position.

width

The width of the chart element.

height

The height of the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Methods

ElementPosition Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
FromRectangleF | Initializes an ElementPosition object from a RectangleF structure.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToRectangleF | Returns a RectangleF object that uses the coordinates of an ElementPosition object.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ElementPosition Class
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.FromRectangleF Method

ElementPosition.FromRectangleF Method |
 | See Also

Initializes an ElementPosition object from a RectangleF structure.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub FromRectangleF ( _
    rect As RectangleF _
)
public void FromRectangleF (
    RectangleF rect
)
public:
void FromRectangleF (
    RectangleF rect
)
public void FromRectangleF (
    RectangleF rect
)
public function FromRectangleF (
    rect : RectangleF
)

Parameters

rect

A RectangleF structure.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.ToRectangleF Method

ElementPosition.ToRectangleF Method |
 | See Also

Returns a RectangleF object that uses the coordinates of an ElementPosition object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ToRectangleF As RectangleF
public RectangleF ToRectangleF ()
public:
RectangleF ToRectangleF ()
public RectangleF ToRectangleF ()
public function ToRectangleF () : RectangleF

Return Value

A RectangleF structure.

Remarks

This method converts the position of an element to a RectangleF structure.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition Properties

ElementPosition Properties |
 | See Also

Public Properties

Name | Description
Auto | Gets or sets a flag that determines whether an applicable chart element will be positioned automatically by the Chart control.
Bottom | Gets the bottom position of a chart element, in relative coordinates.
Height | Gets or sets the height of a chart element.
Right | Gets the position of the right side of a chart element, in relative coordinates.
Size | Gets the size of a chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Width | Gets or sets the width of a chart element.
X | Gets or sets the relative X-coordinate of the top-left corner of an applicable chart element.
Y | Gets or sets the relative Y-coordinate of the top-left corner of an applicable chart element.

See Also

Reference

ElementPosition Class
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Auto Property

ElementPosition.Auto Property |
 | See Also

Gets or sets a flag that determines whether an applicable chart element will be positioned automatically by the Chart control.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Auto As Boolean
public bool Auto { get; set; }
public:
property bool Auto {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Auto ()

/** @property */
public void set_Auto (boolean value)

public function get Auto () : boolean

public function set Auto (value : boolean)

Property Value

A Boolean value.

Remarks

Use this property to automatically position a chart element. For example, to position the legend automatically, set the Position property to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Bottom Property

ElementPosition.Bottom Property |
 | See Also

Gets the bottom position of a chart element, in relative coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property Bottom As Single
[BrowsableAttribute(false)]
public float Bottom { get; }
[BrowsableAttribute(false)]
public:
property float Bottom {
    float get ();
}
/** @property */
public float get_Bottom ()

public function get Bottom () : float

Property Value

A float value that represents the bottom position of the chart element.

Remarks

The bottom of the chart element is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

Chart coordinates use (0,0) for a top-left corner, and (100,100) for a bottom-right corner.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Height Property

ElementPosition.Height Property |
 | See Also

Gets or sets the height of a chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Height As Single
public float Height { get; set; }
public:
property float Height {
    float get ();
    void set (float value);
}
/** @property */
public float get_Height ()

/** @property */
public void set_Height (float value)

public function get Height () : float

public function set Height (value : float)

Property Value

A float value that represents the height of the chart element.

Remarks

Always uses relative coordinates. If you set a value outside of the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Right Property

ElementPosition.Right Property |
 | See Also

Gets the position of the right side of a chart element, in relative coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property Right As Single
[BrowsableAttribute(false)]
public float Right { get; }
[BrowsableAttribute(false)]
public:
property float Right {
    float get ();
}
/** @property */
public float get_Right ()

public function get Right () : float

Property Value

A float value that represents the position of the right side of a chart element.

Remarks

Returns a value that represents the relative position of the right side of an applicable chart element.

The right side position is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

Chart coordinates use (0,0) for a top-left corner, and (100,100) for a bottom-right corner.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Size Property

ElementPosition.Size Property |
 | See Also

Gets the size of a chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property Size As SizeF
[BrowsableAttribute(false)]
public SizeF Size { get; }
[BrowsableAttribute(false)]
public:
property SizeF Size {
    SizeF get ();
}
/** @property */
public SizeF get_Size ()

public function get Size () : SizeF

Property Value

A SizeF value that represents the size of a chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Width Property

ElementPosition.Width Property |
 | See Also

Gets or sets the width of a chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Width As Single
public float Width { get; set; }
public:
property float Width {
    float get ();
    void set (float value);
}
/** @property */
public float get_Width ()

/** @property */
public void set_Width (float value)

public function get Width () : float

public function set Width (value : float)

Property Value

A float value that represents the width of a chart element.

Remarks

This property always uses relative coordinates; if you set a value outside the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.X Property

ElementPosition.X Property |
 | See Also

Gets or sets the relative X-coordinate of the top-left corner of an applicable chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property X As Single
public float X { get; set; }
public:
property float X {
    float get ();
    void set (float value);
}
/** @property */
public float get_X ()

/** @property */
public void set_X (float value)

public function get X () : float

public function set X (value : float)

Property Value

A float value that represents the X-coordinate of the top-left corner of an applicable chart element.

Remarks

The X property is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

This property always uses relative coordinates; if you set a value outside the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


ElementPosition.Y Property

ElementPosition.Y Property |
 | See Also

Gets or sets the relative Y-coordinate of the top-left corner of an applicable chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Y As Single
public float Y { get; set; }
public:
property float Y {
    float get ();
    void set (float value);
}
/** @property */
public float get_Y ()

/** @property */
public void set_Y (float value)

public function get Y () : float

public function set Y (value : float)

Property Value

A float value that represents the Y-coordinate of the top-left corner of an applicable chart element.

Remarks

The Y property is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

This property always uses relative coordinates; if you set a value outside the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members
System.Web.UI.DataVisualization.Charting Namespace


EllipseAnnotation Class

EllipseAnnotation Class |
 | See Also Members

Represents an ellipse annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class EllipseAnnotation
    Inherits RectangleAnnotation
public class EllipseAnnotation : RectangleAnnotation
public ref class EllipseAnnotation : public RectangleAnnotation
public class EllipseAnnotation extends RectangleAnnotation
public class EllipseAnnotation extends RectangleAnnotation

Remarks

An ellipse annotation can display text inside the ellipse, in addition to being displayed as an ellipse only. You can therefore annotate using an ellipse or an ellipse with text inside it.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.TextAnnotation
System.Web.UI.DataVisualization.Charting.RectangleAnnotation
System.Web.UI.DataVisualization.Charting.EllipseAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

EllipseAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


EllipseAnnotation Members

EllipseAnnotation Members |
 | See Also Constructors Methods Properties

Represents an ellipse annotation.

The following tables list the members exposed by the EllipseAnnotation type.

Public Constructors

Name | Description
EllipseAnnotation | Initializes a new instance of the EllipseAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation)
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation)
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation)
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation)
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

EllipseAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


EllipseAnnotation Constructor

EllipseAnnotation Constructor |
 | See Also

Initializes a new instance of the EllipseAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public EllipseAnnotation ()
public:
EllipseAnnotation ()
public EllipseAnnotation ()
public function EllipseAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


EllipseAnnotation Methods

EllipseAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

EllipseAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


EllipseAnnotation Properties

EllipseAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation )
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation )
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation )
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation )
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

EllipseAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


EllipseAnnotation.AnnotationType Property

EllipseAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type name. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type, such as a LineAnnotation, RectangleAnnotation, or EllipseAnnotation.

This property is for internal use and should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


FinancialFormula Enumeration

FinancialFormula Enumeration |
 | See Also

Specifies a financial formula.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration FinancialFormula
public enum FinancialFormula
public enum class FinancialFormula
public enum FinancialFormula
public enum FinancialFormula

Members

Member name | Description
AccumulationDistribution | Accumulation Distribution formula uses a relationship between volume and prices to estimate the strength of price movements; if volume is increased, there is a high probability that prices will go up.
AverageTrueRange | Average True Range indicator measures commitment and compares the range between the High, Low and Close prices.
BollingerBands | Bollinger Bands indicators are plotted at standard deviation levels above and below a simple moving average.
ChaikinOscillator | Chaikin Oscillator indicator is the difference between a 3-day exponential moving average and a 10-day exponential moving average applied to the accumulation distribution.
CommodityChannelIndex | Commodity Channel Index compares prices with their moving averages.
DetrendedPriceOscillator | Detrended Price Oscillator attempts to remove trends from prices.
EaseOfMovement | Ease of Movement deals with the relationship between volume and price change, and uses volume to indicate how strong a trend is for prices.
Envelopes | Envelopes are plotted above and below a moving average using a specified percentage as the shift.
ExponentialMovingAverage | An Exponential Moving Average is an average of data calculated over a period of time where the most recent days have more weight.
Forecasting | Forecasting predicts future values using historical observations.
MassIndex | The Mass Index is used to predict trend reversal by comparing the difference and range between High and Low prices.
MedianPrice | Median prices are mid-point values of daily prices and can be used as a filter for trend indicators.
MoneyFlow | The Money Flow indicator compares upward changes and downward changes of volume-weighted typical prices.
MovingAverage | A Simple Moving Average is an average of data calculated over a period of time. The moving average is the most popular price indicator used in technical analysis, and can be used with any price, for example, Hi, Low, Open and Close, or can be applied to other indicators.
MovingAverageConvergenceDivergence | Moving Average Convergence/Divergence indicator compares two moving averages of prices and is used with a 9-day Exponential Moving average as a signal that indicates buying and selling moments.
NegativeVolumeIndex | The Negative Volume Index should be used with the Positive Volume index; the Negative Volume Index only changes if the volume decreases from the previous day.
OnBalanceVolume | The On Balance Volume indicator measures positive and negative volume flow.
Performance | The Performance indicator compares a current closing price or any other price with the first closing value from the first time period.
PositiveVolumeIndex | The Positive Volume Index should be used with the Negative Volume index. The Positive volume index only changes if the volume decreases from the previous day.
PriceVolumeTrend | The Price Volume Trend is a cumulative volume total that is calculated using relative changes of the closing price, and should be used with other indicators.
RateOfChange | The Rate of Change indicator compares a specified closing price with the current price.
RelativeStrengthIndex | The Relative Strength Index is a momentum oscillator that compares upward movements of the closing price with downward movements, and results in values that range from 0 to 100.
StandardDeviation | Standard Deviation is used to indicate volatility, and measures the difference between values, for example, closing price, and their moving average.
StochasticIndicator | The Stochastic Indicator helps to find trend reversal by searching in a period for when the closing prices are close to low prices in an upward trending market and when the closing prices are close to high prices in a downward trending market.
TriangularMovingAverage | A Triangular Moving Average is an average of data calculated over a period of time where the middle portion of data has more weight.
TripleExponentialMovingAverage | The Triple Exponential Moving Average is based on a triple moving average of the closing price. Its purpose is to eliminate short cycles. This indicator keeps the closing price in trends that are shorter than the specified period.
TypicalPrice | Typical Price is the average value of daily prices, and can be used as a filter for trend indicators.
VolatilityChaikins | The Volatility Chaikins indicator measures the difference between High and Low prices, and is used to indicate tops or bottoms of the market.
VolumeOscillator | The Volume Oscillator attempts to identify trends in volume by comparing two moving averages: one with a short period and another with a longer period.
WeightedClose | The Weighted Close formula calculates the average value of daily prices. The only difference between Typical Price and the Weighted Close is that the closing price has extra weight, and is considered the most important price.
WeightedMovingAverage | Weighted Moving Average is an average of data that is calculated over a period of time, where greater weight is attached to the most recent data.
WilliamsR | Williams %R is a momentum indicator, and is used to measure overbought and oversold levels.

Remarks

The FinancialFormula enumeration is used in calls to the FinancialFormula methods that are contained in the DataFormula class, and specifies the type of financial formula to be used.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs Class

FormatNumberEventArgs Class |
 | See Also Members

Represents the event arguments of the localized number-formatting event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class FormatNumberEventArgs
    Inherits EventArgs
public class FormatNumberEventArgs : EventArgs
public ref class FormatNumberEventArgs : public EventArgs
public class FormatNumberEventArgs extends EventArgs
public class FormatNumberEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Web.UI.DataVisualization.Charting.FormatNumberEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs Members

FormatNumberEventArgs Members |
 | See Also Methods Properties

Represents the event arguments of the localized number-formatting event.

The following tables list the members exposed by the FormatNumberEventArgs type.

Public Properties

Name | Description
ElementType | Gets the chart element type.
Format | Gets or sets the format string.
LocalizedValue | Gets or sets the localized text.
SenderTag | Gets the sender object of the event.
Value | Gets the value to be formatted.
ValueType | Gets the value type.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

FormatNumberEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs Methods

FormatNumberEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

FormatNumberEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs Properties

FormatNumberEventArgs Properties |
 | See Also

Public Properties

Name | Description
ElementType | Gets the chart element type.
Format | Gets or sets the format string.
LocalizedValue | Gets or sets the localized text.
SenderTag | Gets the sender object of the event.
Value | Gets the value to be formatted.
ValueType | Gets the value type.

See Also

Reference

FormatNumberEventArgs Class
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs.ElementType Property

FormatNumberEventArgs.ElementType Property |
 | See Also

Gets the chart element type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ElementType As ChartElementType
public ChartElementType ElementType { get; }
public:
property ChartElementType ElementType {
    ChartElementType get ();
}
/** @property */
public ChartElementType get_ElementType ()

public function get ElementType () : ChartElementType

Property Value

A ChartElementType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs.Format Property

FormatNumberEventArgs.Format Property |
 | See Also

Gets or sets the format string.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Format As String
public string Format { get; }
public:
property String^ Format {
    String^ get ();
}
/** @property */
public String get_Format ()

public function get Format () : String

Property Value

A string value that represents the format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs.LocalizedValue Property

FormatNumberEventArgs.LocalizedValue Property |
 | See Also

Gets or sets the localized text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LocalizedValue As String
public string LocalizedValue { get; set; }
public:
property String^ LocalizedValue {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LocalizedValue ()

/** @property */
public void set_LocalizedValue (String value)

public function get LocalizedValue () : String

public function set LocalizedValue (value : String)

Property Value

A string value that represents the localized text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs.SenderTag Property

FormatNumberEventArgs.SenderTag Property |
 | See Also

Gets the sender object of the event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SenderTag As Object
public Object SenderTag { get; }
public:
property Object^ SenderTag {
    Object^ get ();
}
/** @property */
public Object get_SenderTag ()

public function get SenderTag () : Object

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs.Value Property

FormatNumberEventArgs.Value Property |
 | See Also

Gets the value to be formatted.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Value As Double
public double Value { get; }
public:
property double Value {
    double get ();
}
/** @property */
public double get_Value ()

public function get Value () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FormatNumberEventArgs.ValueType Property

FormatNumberEventArgs.ValueType Property |
 | See Also

Gets the value type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ValueType As ChartValueType
public ChartValueType ValueType { get; }
public:
property ChartValueType ValueType {
    ChartValueType get ();
}
/** @property */
public ChartValueType get_ValueType ()

public function get ValueType () : ChartValueType

Property Value

A ChartValueType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult Class

FTestResult Class |
 | See Also Members

Stores results of the FTest statistical methods.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class FTestResult
public class FTestResult
public ref class FTestResult
public class FTestResult
public class FTestResult

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.FTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult Members

FTestResult Members |
 | See Also Constructors Methods Properties

Stores results of the FTest statistical methods.

The following tables list the members exposed by the FTestResult type.

Public Constructors

Name | Description
FTestResult | Initializes a new instance of the FTestResult class.
Top

Public Properties

Name | Description
FCriticalValueOneTail | Gets the Critical F one tail.
FirstSeriesMean | Gets the first series mean.
FirstSeriesVariance | Gets the first series variance.
FValue | Gets the F value.
ProbabilityFOneTail | Gets the Probability F one tail.
SecondSeriesMean | Gets the second series mean.
SecondSeriesVariance | Gets the second series variance.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

FTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


FTestResult Constructor

FTestResult Constructor |
 | See Also

Initializes a new instance of the FTestResult class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public FTestResult ()
public:
FTestResult ()
public FTestResult ()
public function FTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult Methods

FTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

FTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


FTestResult Properties

FTestResult Properties |
 | See Also

Public Properties

Name | Description
FCriticalValueOneTail | Gets the Critical F one tail.
FirstSeriesMean | Gets the first series mean.
FirstSeriesVariance | Gets the first series variance.
FValue | Gets the F value.
ProbabilityFOneTail | Gets the Probability F one tail.
SecondSeriesMean | Gets the second series mean.
SecondSeriesVariance | Gets the second series variance.

See Also

Reference

FTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.FCriticalValueOneTail Property

FTestResult.FCriticalValueOneTail Property |
 | See Also

Gets the Critical F one tail.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FCriticalValueOneTail As Double
public double FCriticalValueOneTail { get; }
public:
property double FCriticalValueOneTail {
    double get ();
}
/** @property */
public double get_FCriticalValueOneTail ()

public function get FCriticalValueOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.FirstSeriesMean Property

FTestResult.FirstSeriesMean Property |
 | See Also

Gets the first series mean.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesMean As Double
public double FirstSeriesMean { get; }
public:
property double FirstSeriesMean {
    double get ();
}
/** @property */
public double get_FirstSeriesMean ()

public function get FirstSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.FirstSeriesVariance Property

FTestResult.FirstSeriesVariance Property |
 | See Also

Gets the first series variance.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesVariance As Double
public double FirstSeriesVariance { get; }
public:
property double FirstSeriesVariance {
    double get ();
}
/** @property */
public double get_FirstSeriesVariance ()

public function get FirstSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.FValue Property

FTestResult.FValue Property |
 | See Also

Gets the F value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FValue As Double
public double FValue { get; }
public:
property double FValue {
    double get ();
}
/** @property */
public double get_FValue ()

public function get FValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.ProbabilityFOneTail Property

FTestResult.ProbabilityFOneTail Property |
 | See Also

Gets the Probability F one tail.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityFOneTail As Double
public double ProbabilityFOneTail { get; }
public:
property double ProbabilityFOneTail {
    double get ();
}
/** @property */
public double get_ProbabilityFOneTail ()

public function get ProbabilityFOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.SecondSeriesMean Property

FTestResult.SecondSeriesMean Property |
 | See Also

Gets the second series mean.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesMean As Double
public double SecondSeriesMean { get; }
public:
property double SecondSeriesMean {
    double get ();
}
/** @property */
public double get_SecondSeriesMean ()

public function get SecondSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


FTestResult.SecondSeriesVariance Property

FTestResult.SecondSeriesVariance Property |
 | See Also

Gets the second series variance.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesVariance As Double
public double SecondSeriesVariance { get; }
public:
property double SecondSeriesVariance {
    double get ();
}
/** @property */
public double get_SecondSeriesVariance ()

public function get SecondSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


GradientStyle Enumeration

GradientStyle Enumeration |
 | See Also

Specifies a gradient style to be used for a chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration GradientStyle
public enum GradientStyle
public enum class GradientStyle
public enum GradientStyle
public enum GradientStyle

Members

Member name | Description
Center | Gradient is applied from the center outwards.
DiagonalLeft | Gradient is applied diagonally from left to right.
DiagonalRight | Gradient is applied diagonally from right to left.
HorizontalCenter | Gradient is applied horizontally from the center outwards.
LeftRight | Gradient is applied from left to right.
None | No gradient is applied.
TopBottom | Gradient is applied from top to bottom.
VerticalCenter | Gradient is applied vertically from the center outwards.

Remarks

The GradientStyle enumeration represents a gradient style, and is used with the BackGradientStyle property of the Chart.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Grid Class

Grid Class |
 | See Also Members

Provides methods and properties that manage the major and minor grids of Axis objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Grid
public class Grid
public ref class Grid
public class Grid
public class Grid

Remarks

This class provides the functionality for the grids on the chart, and is exposed using the MajorGrid and MinorGrid properties of each Axis object.

Major grid lines by default do not have their Interval, IntervalOffset, IntervalType, and IntervalOffsetType properties set. When these properties for major grid lines are not set, the Chart control determines the appropriate values for grid lines automatically.

The axis and its minor grid lines by default have their Interval, IntervalOffset, IntervalType, and IntervalOffsetType properties set to Auto (0). If axis labels or minor grid lines are enabled and these properties are not modified, the Chart control automatically determines how often to draw the minor grid lines.

Axis grids:

  • Can be enabled or disabled.

  • Have a starting point that determines where they are first drawn.

  • Display lines that can be set for style, width and color.

  • Can have either automatic intervals, or intervals that are set manually.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.Grid
System.Web.UI.DataVisualization.Charting.TickMark

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid Members

Grid Members |
 | See Also Constructors Methods Properties

Provides methods and properties that manage the major and minor grids of Axis objects.

The following tables list the members exposed by the Grid type.

Public Constructors

Name | Description
Grid | Initializes a new instance of the Grid class.
Top

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled.
Interval | Gets or sets the interval between major or minor grid lines.
IntervalOffset | Gets or sets the offset of grid lines.
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines.
IntervalType | Gets or sets the interval type for major or minor grid lines.
LineColor | Gets or sets the line color of a grid.
LineDashStyle | Gets or sets the line style of a grid.
LineWidth | Gets or sets the line width of major and minor grid lines.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Grid Class
System.Web.UI.DataVisualization.Charting Namespace


Grid Constructor

Grid Constructor |
 | See Also

Initializes a new instance of the Grid class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Grid ()
public:
Grid ()
public Grid ()
public function Grid ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid Methods

Grid Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Grid Class
System.Web.UI.DataVisualization.Charting Namespace


Grid Properties

Grid Properties |
 | See Also

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled.
Interval | Gets or sets the interval between major or minor grid lines.
IntervalOffset | Gets or sets the offset of grid lines.
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines.
IntervalType | Gets or sets the interval type for major or minor grid lines.
LineColor | Gets or sets the line color of a grid.
LineDashStyle | Gets or sets the line style of a grid.
LineWidth | Gets or sets the line width of major and minor grid lines.

See Also

Reference

Grid Class
System.Web.UI.DataVisualization.Charting Namespace


Grid.Enabled Property

Grid.Enabled Property |
 | See Also

Gets or sets a flag that determines whether major or minor grid lines are enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if enabled, false if disabled. The default is true for major grid objects and false for minor grid objects.

Remarks

Major and minor grids are visible when enabled, and not visible when disabled.

Tick marks will not be displayed if disabled.

You can disable tick marks by setting the TickMarkStyle property to None.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.Interval Property

Grid.Interval Property |
 | See Also

Gets or sets the interval between major or minor grid lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value that represents the interval between grid lines. By default, the value is not set (NaN) for major grid lines. For minor grid lines, the default value is zero (0).

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly using NotSet at design time, or by assigning a value of NaN at run time—the actual value of this property is determined by the Interval property of the Axis object to which the chart element, such as a grid line or tick mark, belongs.

The interval of minor tick marks and grid lines is never affected by the Interval property value.

The interval is measured in axis units, and determines how often an applicable chart element is drawn. For example, suppose a column chart has an X axis step of 1 (that is, 1, 2, 3, 4, and so forth); if you set the Interval property for the X axis to 2, an axis label will be displayed for every other column.

The same holds true for all applicable chart elements. In other words, if in the previous example strip lines were being used, with an IntervalOffset of 0.5, and their Interval property was 2, a strip line would be displayed at 0.5, 2.5, 4.5, and so on.

If you set a chart element Interval property to zero, an interval will be automatically determined by the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.IntervalOffset Property

Grid.IntervalOffset Property |
 | See Also

Gets or sets the offset of grid lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the interval offset.

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly specifying "Not Set"at design time, or by assigning it a value of NotSet at run time—the actual value of this property is determined by the IntervalOffset property of the Axis object that the chart element, such as a grid line or a tick mark, belongs to.

The interval offset of minor tick marks and grid lines is never affected by the value of the IntervalOffset property of the Axis object.

The IntervalOffsetType property setting defines the units of measurement of the offset.

The IntervalOffset can be a negative value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.IntervalOffsetType Property

Grid.IntervalOffsetType Property |
 | See Also

Gets or sets the interval offset type of major and minor grid lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. By default it is not set for major grid lines. The default value for minor grid lines is Auto.

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly specifying "Not Set" at design time, or by assigning it a value of NotSet at run time—the actual value of this property is determined by the IntervalOffsetType property of the Axis object that the chart element—a grid line or tick mark, for example—belongs to.

The interval offset type of minor tick marks and grid lines is never affected by the IntervalOffsetType property value.

If this interval offset type is set to Auto, the IntervalType property will be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.IntervalType Property

Grid.IntervalType Property |
 | See Also

Gets or sets the interval type for major or minor grid lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. By default it is not set for axis labels, major tick marks and major grid lines, by using the NotSet enumeration value. The default value for minor tick marks and grid lines is Auto.

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly using "Not Set" at design time, or by assigning it a value of NotSet at run time— the actual value of this property is determined by the IntervalOffsetType property of the Axis object that the chart element—a grid line or tick mark, for example—belongs to.

The interval type of minor tick marks and grid lines is never affected by the value of the IntervalType property.

Interval types can be set to Auto; the type of interval then depends on either the X-values or Y-values of the plotted DataPoint objects, depending on which axis the applicable elements belong to.

Setting the IntervalType property for a value axis will only have an effect if the values of the data points are DateTime or double values. Also, the XValueType or YValueType property of the plotted Series must be set to Auto or DateTime.

Setting the IntervalType property for a categorical axis will only have an effect if the XValueType property (or YValueType property, depending on the axis in question) of the plotted Series object is either Auto or DateTime.

Note:
Sunday is considered the first day of the week.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.LineColor Property

Grid.LineColor Property |
 | See Also

Gets or sets the line color of a grid.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color object. The default value is Black.

Remarks

The LineColor property is used to specify the color of major and minor tick marks or grids.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.LineDashStyle Property

Grid.LineDashStyle Property |
 | See Also

Gets or sets the line style of a grid.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value. The default is Solid.

Remarks

The LineDashStyle property can be used to specify the line style of major and minor tick marks or grids. The line can be solid, dotted, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


Grid.LineWidth Property

Grid.LineWidth Property |
 | See Also

Gets or sets the line width of major and minor grid lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer that represents the line width in pixels. The default value is one (1).

Remarks

The LineWidth property can be used to specify the line width, in pixels, of major and minor tick marks or grids.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members
System.Web.UI.DataVisualization.Charting Namespace


GridTickTypes Enumeration

GridTickTypes Enumeration |
 | See Also

Specifies the options for displaying a grid line or a tick mark for a custom label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration GridTickTypes
public enum GridTickTypes
public enum class GridTickTypes
public enum GridTickTypes
public enum GridTickTypes

Members

Member name | Description
All | A tick mark and a grid line are shown.
Gridline | A grid line is shown.
None | No tick mark or grid line is shown.
TickMark | A tick mark is shown.

Remarks

The GridTickTypes enumeration is used in conjunction with the GridTicks property to display a grid line and/or a tick mark for a custom label.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


HitTestResult Class

HitTestResult Class |
 | See Also Members

Represents the results of a hit test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class HitTestResult
public class HitTestResult
public ref class HitTestResult
public class HitTestResult
public class HitTestResult

Remarks

The HitTestResult class represents the results of a hit test, and is exposed as the return object from a HitTest method call.

A hit test checks a specified point in the chart to determine if a chart element is located at that point. If a chart element is detected, the HitTestResult class is used to obtain information about that chart element.

If a chart element is found, the Object property returns a reference to the chart element; the only exception to this being DataPoint objects, in which case the return value of this property is null.

If a data point is located, you can use the PointIndex property to get the index of that data point; that is, the zero-based index of the point in the DataPointCollection. Use the Series property to get the associated Series object for that data point.

The ChartArea and Axis properties are used to get the associated chart area and axis of the chart element—if any—returned by the hit test. Note that these properties may be null if the returned chart element does not have an associated chart area or axis.

Use the ChartElementType property to determine the type of the chart element returned by a hit test.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.HitTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult Members

HitTestResult Members |
 | See Also Constructors Methods Properties

Represents the results of a hit test.

The following tables list the members exposed by the HitTestResult type.

Public Constructors

Name | Description
HitTestResult | Initializes a new instance of the HitTestResult class.
Top

Public Properties

Name | Description
Axis | Gets or sets the Axis object that may be associated with a chart element returned by a hit test. The presence of an associated Axis object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartArea | Gets or sets the ChartArea object that may be associated with a chart element returned by a hit test. The presence of a ChartArea object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartElementType | Gets or sets the type of chart element, if any, returned by a hit test.
Object | Gets or sets the object, if any, returned by a hit test.
PointIndex | Gets or sets the index of a data point, if any, returned by a hit test.
Series | Gets or sets the associated series of a data point, if any, returned by a hit test.
SubObject | Gets the sub-object, if any, returned by a hit test.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

HitTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult Constructor

HitTestResult Constructor |
 | See Also

Initializes a new instance of the HitTestResult class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public HitTestResult ()
public:
HitTestResult ()
public HitTestResult ()
public function HitTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult Methods

HitTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

HitTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult Properties

HitTestResult Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets or sets the Axis object that may be associated with a chart element returned by a hit test. The presence of an associated Axis object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartArea | Gets or sets the ChartArea object that may be associated with a chart element returned by a hit test. The presence of a ChartArea object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartElementType | Gets or sets the type of chart element, if any, returned by a hit test.
Object | Gets or sets the object, if any, returned by a hit test.
PointIndex | Gets or sets the index of a data point, if any, returned by a hit test.
Series | Gets or sets the associated series of a data point, if any, returned by a hit test.
SubObject | Gets the sub-object, if any, returned by a hit test.

See Also

Reference

HitTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.Axis Property

HitTestResult.Axis Property |
 | See Also

Gets or sets the Axis object that may be associated with a chart element returned by a hit test. The presence of an associated Axis object depends on whether a chart element was detected at the given location, and the type of chart element returned.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Axis As Axis
public Axis Axis { get; set; }
public:
property Axis^ Axis {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_Axis ()

/** @property */
public void set_Axis (Axis value)

public function get Axis () : Axis

public function set Axis (value : Axis)

Property Value

An Axis object, otherwise null. The default value is null.

Remarks

If the chart object returned by the hit test is an object that is associated with an axis—for example, a scrollbar element, tick mark, grid line or strip line—the Axis property will reference the Axis object with which the returned chart object is associated. Otherwise this property will be null.

Note that the HitTest method can be called explicitly, in which case a chart element may or may not be at the specified location.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.ChartArea Property

HitTestResult.ChartArea Property |
 | See Also

Gets or sets the ChartArea object that may be associated with a chart element returned by a hit test. The presence of a ChartArea object depends on whether a chart element was detected at the given location, and the type of chart element returned.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ChartArea As ChartArea
public ChartArea ChartArea { get; set; }
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
    void set (ChartArea^ value);
}
/** @property */
public ChartArea get_ChartArea ()

/** @property */
public void set_ChartArea (ChartArea value)

public function get ChartArea () : ChartArea

public function set ChartArea (value : ChartArea)

Property Value

A ChartArea object, otherwise null. The default value is null.

Remarks

If a Chart object is returned by the hit test, the ChartArea property will reference the ChartArea object that is associated with the returned chart element.

If no chart element is returned by the hit test, the value of this property will be null.

Note The HitTest method can be called explicitly, in which case a chart element may or may not be at the specified location.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.ChartElementType Property

HitTestResult.ChartElementType Property |
 | See Also

Gets or sets the type of chart element, if any, returned by a hit test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ChartElementType As ChartElementType
public ChartElementType ChartElementType { get; set; }
public:
property ChartElementType ChartElementType {
    ChartElementType get ();
    void set (ChartElementType value);
}
/** @property */
public ChartElementType get_ChartElementType ()

/** @property */
public void set_ChartElementType (ChartElementType value)

public function get ChartElementType () : ChartElementType

public function set ChartElementType (value : ChartElementType)

Property Value

A ChartElementType enumeration value that indicates the type of chart element returned by a hit test. Defaults to Nothing.

Remarks

Use this property to determine the type of chart element, if any, returned by a hit test.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.Object Property

HitTestResult.Object Property |
 | See Also

Gets or sets the object, if any, returned by a hit test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Object As Object
public Object Object { get; set; }
public:
property Object^ Object {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_Object ()

/** @property */
public void set_Object (Object value)

public function get Object () : Object

public function set Object (value : Object)

Property Value

An object of type Object, otherwise null.

Remarks

If a chart element is located at the point that is checked by the hit test, this property will reference that chart element, otherwise the value of this property will be null.

Note:
If a data point is returned by the hit test, this property will still return a null. To obtain information about the data point, use the PointIndex and Series properties instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.PointIndex Property

HitTestResult.PointIndex Property |
 | See Also

Gets or sets the index of a data point, if any, returned by a hit test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PointIndex As Integer
public int PointIndex { get; set; }
public:
property int PointIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_PointIndex ()

/** @property */
public void set_PointIndex (int value)

public function get PointIndex () : int

public function set PointIndex (value : int)

Property Value

An integer value that represents the index of a data point returned by a hit test. The default value is negative one (-1).

Remarks

If a data point is at the location that is checked by a hit test, the PointIndex property will return the zero-based index of that data point, otherwise it will return a negative one (-1).

All data points are stored in a DataPointCollection, which is exposed as the Points collection property of a Series object; the index of the DataPointCollection is zero-based.

Use the Series property to determine the series to which the data point belongs.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.Series Property

HitTestResult.Series Property |
 | See Also

Gets or sets the associated series of a data point, if any, returned by a hit test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Series As Series
public Series Series { get; set; }
public:
property Series^ Series {
    Series^ get ();
    void set (Series^ value);
}
/** @property */
public Series get_Series ()

/** @property */
public void set_Series (Series value)

public function get Series () : Series

public function set Series (value : Series)

Property Value

The Series that a data point returned by a hit test belongs to. The default value is null.

Remarks

If a data point is at the location checked by a hit test, this property will reference the Series object that the data point belongs to. If no data point is returned by the hit test, the value of this property will be null.

To determine the index of a returned data point, use the PointIndex property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HitTestResult.SubObject Property

HitTestResult.SubObject Property |
 | See Also

Gets the sub-object, if any, returned by a hit test.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SubObject As Object
public Object SubObject { get; set; }
public:
property Object^ SubObject {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_SubObject ()

/** @property */
public void set_SubObject (Object value)

public function get SubObject () : Object

public function set SubObject (value : Object)

Property Value

A sub-object of type Object, otherwise null.

Remarks

An example of a sub-object is an Axis object that is displayed inside a ChartArea object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


HorizontalLineAnnotation Class

HorizontalLineAnnotation Class |
 | See Also Members

Represents a horizontal line annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class HorizontalLineAnnotation
    Inherits LineAnnotation
public class HorizontalLineAnnotation : LineAnnotation
public ref class HorizontalLineAnnotation : public LineAnnotation
public class HorizontalLineAnnotation extends LineAnnotation
public class HorizontalLineAnnotation extends LineAnnotation

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.LineAnnotation
System.Web.UI.DataVisualization.Charting.HorizontalLineAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HorizontalLineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


HorizontalLineAnnotation Members

HorizontalLineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a horizontal line annotation.

The following tables list the members exposed by the HorizontalLineAnnotation type.

Public Constructors

Name | Description
HorizontalLineAnnotation | Initializes a new instance of the HorizontalLineAnnotation class.
Top

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation)
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

HorizontalLineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


HorizontalLineAnnotation Constructor

HorizontalLineAnnotation Constructor |
 | See Also

Initializes a new instance of the HorizontalLineAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public HorizontalLineAnnotation ()
public:
HorizontalLineAnnotation ()
public HorizontalLineAnnotation ()
public function HorizontalLineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HorizontalLineAnnotation Class
HorizontalLineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


HorizontalLineAnnotation Methods

HorizontalLineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

HorizontalLineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


HorizontalLineAnnotation Properties

HorizontalLineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation )
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

HorizontalLineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


HorizontalLineAnnotation.AnnotationType Property

HorizontalLineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type name. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type, for example, LineAnnotation, RectangleAnnotation, EllipseAnnotation, and so forth.

This property is for internal use.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HorizontalLineAnnotation Class
HorizontalLineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea Interface

IChartMapArea Interface |
 | See Also Members

Common interface for all chart elements that support image maps.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Interface IChartMapArea
public interface IChartMapArea
public interface class IChartMapArea
public interface IChartMapArea
public interface IChartMapArea

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartMapArea Members
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea Members

IChartMapArea Members |
 | See Also Properties

Common interface for all chart elements that support image maps.

The following tables list the members exposed by the IChartMapArea type.

Public Properties

Name | Description
MapAreaAttributes | Gets or sets the custom attributes of a map area.
PostBackValue | Gets or sets a postback value for the map area.
Tag | Gets or sets custom data for the map area.
ToolTip | Gets or sets a tooltip for the map area.
Url | Gets or sets the URL for the map area.
Top

See Also

Reference

IChartMapArea Interface
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea Properties

IChartMapArea Properties |
 | See Also

Public Properties

Name | Description
MapAreaAttributes | Gets or sets the custom attributes of a map area.
PostBackValue | Gets or sets a postback value for the map area.
Tag | Gets or sets custom data for the map area.
ToolTip | Gets or sets a tooltip for the map area.
Url | Gets or sets the URL for the map area.

See Also

Reference

IChartMapArea Interface
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea.MapAreaAttributes Property

IChartMapArea.MapAreaAttributes Property |
 | See Also

Gets or sets the custom attributes of a map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Property MapAreaAttributes As String
string MapAreaAttributes { get; set; }
property String^ MapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
String get_MapAreaAttributes ()

/** @property */
void set_MapAreaAttributes (String value)

function get MapAreaAttributes () : String

function set MapAreaAttributes (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartMapArea Interface
IChartMapArea Members
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea.PostBackValue Property

IChartMapArea.PostBackValue Property |
 | See Also

Gets or sets a postback value for the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Property PostBackValue As String
string PostBackValue { get; set; }
property String^ PostBackValue {
    String^ get ();
    void set (String^ value);
}
/** @property */
String get_PostBackValue ()

/** @property */
void set_PostBackValue (String value)

function get PostBackValue () : String

function set PostBackValue (value : String)

Property Value

A string value that represents the postback value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartMapArea Interface
IChartMapArea Members
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea.Tag Property

IChartMapArea.Tag Property |
 | See Also

Gets or sets custom data for the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Property Tag As Object
Object Tag { get; set; }
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
Object get_Tag ()

/** @property */
void set_Tag (Object value)

function get Tag () : Object

function set Tag (value : Object)

Property Value

An Object that represents the custom data tag.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartMapArea Interface
IChartMapArea Members
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea.ToolTip Property

IChartMapArea.ToolTip Property |
 | See Also

Gets or sets a tooltip for the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Property ToolTip As String
string ToolTip { get; set; }
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
String get_ToolTip ()

/** @property */
void set_ToolTip (String value)

function get ToolTip () : String

function set ToolTip (value : String)

Property Value

A string value that represents the tooltip.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartMapArea Interface
IChartMapArea Members
System.Web.UI.DataVisualization.Charting Namespace


IChartMapArea.Url Property

IChartMapArea.Url Property |
 | See Also

Gets or sets the URL for the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Property Url As String
string Url { get; set; }
property String^ Url {
    String^ get ();
    void set (String^ value);
}
/** @property */
String get_Url ()

/** @property */
void set_Url (String value)

function get Url () : String

function set Url (value : String)

Property Value

A string value that represents the URL of the map area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartMapArea Interface
IChartMapArea Members
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler Interface

IChartStorageHandler Interface |
 | See Also Members

Defines methods to manage rendered chart images stored in an external medium.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Interface IChartStorageHandler
public interface IChartStorageHandler
public interface class IChartStorageHandler
public interface IChartStorageHandler
public interface IChartStorageHandler

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartStorageHandler Members
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler Members

IChartStorageHandler Members |
 | See Also Methods

Defines methods to manage rendered chart images stored in an external medium.

The following tables list the members exposed by the IChartStorageHandler type.

Public Methods

Name | Description
Delete | Deletes the data from the external medium.
Exists | Checks for the existence of data under a specified key.
Load | Loads the data from the external medium.
Save | Saves the data to the external medium.
Top

See Also

Reference

IChartStorageHandler Interface
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler Methods

IChartStorageHandler Methods |
 | See Also

Public Methods

Name | Description
Delete | Deletes the data from the external medium.
Exists | Checks for the existence of data under a specified key.
Load | Loads the data from the external medium.
Save | Saves the data to the external medium.

See Also

Reference

IChartStorageHandler Interface
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler.Delete Method

IChartStorageHandler.Delete Method |
 | See Also

Deletes the data from the external medium.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Sub Delete ( _
    key As String _
)
void Delete (
    string key
)
void Delete (
    String^ key
)
void Delete (
    String key
)
function Delete (
    key : String
)

Parameters

key

Index key.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartStorageHandler Interface
IChartStorageHandler Members
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler.Exists Method

IChartStorageHandler.Exists Method |
 | See Also

Checks for the existence of data under a specified key.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Function Exists ( _
    key As String _
) As Boolean
bool Exists (
    string key
)
bool Exists (
    String^ key
)
boolean Exists (
    String key
)
function Exists (
    key : String
) : boolean

Parameters

key

Index key.

Return Value

True if data exists under specified key, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartStorageHandler Interface
IChartStorageHandler Members
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler.Load Method

IChartStorageHandler.Load Method |
 | See Also

Loads the data from the external medium.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Function Load ( _
    key As String _
) As Byte()
byte[] Load (
    string key
)
array<unsigned char>^ Load (
    String^ key
)
byte[] Load (
    String key
)
function Load (
    key : String
) : byte[]

Parameters

key

Index key.

Return Value

A byte array that contains the image data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartStorageHandler Interface
IChartStorageHandler Members
System.Web.UI.DataVisualization.Charting Namespace


IChartStorageHandler.Save Method

IChartStorageHandler.Save Method |
 | See Also

Saves the data to the external medium.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Sub Save ( _
    key As String, _
    data As Byte() _
)
void Save (
    string key,
    byte[] data
)
void Save (
    String^ key,
    array<unsigned char>^ data
)
void Save (
    String key,
    byte[] data
)
function Save (
    key : String,
    data : byte[]
)

Parameters

key

Index key.

data

The image data to save.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IChartStorageHandler Interface
IChartStorageHandler Members
System.Web.UI.DataVisualization.Charting Namespace


IDataPointFilter Interface

IDataPointFilter Interface |
 | See Also Members

Exposes the FilterDataPoint method, which allows Series data to be custom filtered.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Interface IDataPointFilter
public interface IDataPointFilter
public interface class IDataPointFilter
public interface IDataPointFilter
public interface IDataPointFilter

Remarks

The IDataPointFilter interface exposes the FilterDataPoint method, which takes a specific data point within a series and returns a Boolean value that determines whether that data point will be filtered.

To perform custom filtering:

  • Derive a new or existing class from this interface.

  • Override the FilterDataPoint method to provide the custom filtering logic.

  • To initiate the filtering operation, call one of the Filter methods in the DataManipulator class that takes an IDataPointFilter object as its first parameter.

For sample source code, see the FilterDataPoint method.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IDataPointFilter Members
System.Web.UI.DataVisualization.Charting Namespace


IDataPointFilter Members

IDataPointFilter Members |
 | See Also Methods

Exposes the FilterDataPoint method, which allows Series data to be custom filtered.

The following tables list the members exposed by the IDataPointFilter type.

Public Methods

Name | Description
FilterDataPoint | Determines whether a particular data point in the series will be filtered.
Top

See Also

Reference

IDataPointFilter Interface
System.Web.UI.DataVisualization.Charting Namespace


IDataPointFilter Methods

IDataPointFilter Methods |
 | See Also

Public Methods

Name | Description
FilterDataPoint | Determines whether a particular data point in the series will be filtered.

See Also

Reference

IDataPointFilter Interface
System.Web.UI.DataVisualization.Charting Namespace


IDataPointFilter.FilterDataPoint Method

IDataPointFilter.FilterDataPoint Method |
 | See Also

Determines whether a particular data point in the series will be filtered.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Function FilterDataPoint ( _
    point As DataPoint, _
    series As Series, _
    pointIndex As Integer _
) As Boolean
bool FilterDataPoint (
    DataPoint point,
    Series series,
    int pointIndex
)
bool FilterDataPoint (
    DataPoint^ point,
    Series^ series,
    int pointIndex
)
boolean FilterDataPoint (
    DataPoint point,
    Series series,
    int pointIndex
)
function FilterDataPoint (
    point : DataPoint,
    series : Series,
    pointIndex : int
) : boolean

Parameters

point

The DataPoint object to be filtered.

series

The Series object that the data point belongs to.

pointIndex

The index of the data point, which determines its position in the series.

Return Value

True if the data point is removed, otherwise false.

Remarks

This method should be called for each data point in a series, and returns a Boolean value indicating whether a data point should be filtered.

To provide custom filtering, derive a new or existing class from the IDataPointFilter interface and then implement this method. Provide custom criteria matching logic, then return true or false to mark the data points to be filtered. After this method has been implemented, use one of the Filter method definitions in the DataManipulator class that takes an IDataPointFilter object as a parameter to perform the filtering.

Filtered points, by default, are removed from a series. They can also be displayed as empty points by setting the value of the FilterSetEmptyPoints property to true.

Filtered points can also be marked as filtered if they do not match filtering criteria, as determined by the FilterMatchedPoints value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IDataPointFilter Interface
IDataPointFilter Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation Class

ImageAnnotation Class |
 | See Also Members

Represents an image annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ImageAnnotation
    Inherits Annotation
public class ImageAnnotation : Annotation
public ref class ImageAnnotation : public Annotation
public class ImageAnnotation extends Annotation
public class ImageAnnotation extends Annotation

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.ImageAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation Members

ImageAnnotation Members |
 | See Also Constructors Methods Properties

Represents an image annotation.

The following tables list the members exposed by the ImageAnnotation type.

Public Constructors

Name | Description
ImageAnnotation | Initializes a new instance of the ImageAnnotation class.
Top

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the alignment of the annotation image.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the image annotation type.
BackGradientStyle | Overridden. This property is not applicable to the image annotation type.
BackHatchStyle | Overridden. This property is not applicable to the image annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the image annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Overridden. This property is not applicable to the image annotation type.
ForeColor | Overridden. This property is not applicable to the image annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
Image | Gets or sets the name of the annotation image.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the image is drawn.
ImageWrapMode | Gets or sets the drawing mode of the image.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. This property is not applicable to the image annotation type.
LineDashStyle | Overridden. This property is not applicable to the image annotation type.
LineWidth | Overridden. This property is not applicable to the image annotation type.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. Gets or sets the text style of the annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ImageAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation Constructor

ImageAnnotation Constructor |
 | See Also

Initializes a new instance of the ImageAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ImageAnnotation ()
public:
ImageAnnotation ()
public ImageAnnotation ()
public function ImageAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation Methods

ImageAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ImageAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation Properties

ImageAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the alignment of the annotation image.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the image annotation type.
BackGradientStyle | Overridden. This property is not applicable to the image annotation type.
BackHatchStyle | Overridden. This property is not applicable to the image annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the image annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Overridden. This property is not applicable to the image annotation type.
ForeColor | Overridden. This property is not applicable to the image annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
Image | Gets or sets the name of the annotation image.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the image is drawn.
ImageWrapMode | Gets or sets the drawing mode of the image.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. This property is not applicable to the image annotation type.
LineDashStyle | Overridden. This property is not applicable to the image annotation type.
LineWidth | Overridden. This property is not applicable to the image annotation type.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. Gets or sets the text style of the annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

ImageAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.Alignment Property

ImageAnnotation.Alignment Property |
 | See Also

Gets or sets the alignment of the annotation image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Alignment As ContentAlignment
public override ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the annotation image.

Remarks

This property is used to align a non-scaled image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.AnnotationType Property

ImageAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type name. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type such as LineAnnotation, RectangleAnnotation, EllipseAnnotation, and so forth.

This property is for internal use.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.BackColor Property

ImageAnnotation.BackColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.BackGradientStyle Property

ImageAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.BackHatchStyle Property

ImageAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.BackSecondaryColor Property

ImageAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.Font Property

ImageAnnotation.Font Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.ForeColor Property

ImageAnnotation.ForeColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.Image Property

ImageAnnotation.Image Property |
 | See Also

Gets or sets the name of the annotation image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Image As String
public virtual string Image { get; set; }
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the name of the annotation image.

Remarks

The image name can be a file name, a URL or a named image—that is, its name component—from the NamedImagesCollection class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.ImageTransparentColor Property

ImageAnnotation.ImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageTransparentColor As Color
public Color ImageTransparentColor { get; set; }
public:
property Color ImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ImageTransparentColor ()

/** @property */
public void set_ImageTransparentColor (Color value)

public function get ImageTransparentColor () : Color

public function set ImageTransparentColor (value : Color)

Property Value

A Color value that will be replaced with a transparent color when he image is drawn.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.ImageWrapMode Property

ImageAnnotation.ImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of the image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode ImageWrapMode { get; set; }
public:
property ChartImageWrapMode ImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_ImageWrapMode ()

/** @property */
public void set_ImageWrapMode (ChartImageWrapMode value)

public function get ImageWrapMode () : ChartImageWrapMode

public function set ImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value that defines the drawing mode of the image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.LineColor Property

ImageAnnotation.LineColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(false)]
public override Color LineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.LineDashStyle Property

ImageAnnotation.LineDashStyle Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.LineWidth Property

ImageAnnotation.LineWidth Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(false)]
public override int LineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageAnnotation.TextStyle Property

ImageAnnotation.TextStyle Property |
 | See Also

Gets or sets the text style of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value that represents the style used to draw the annotation text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ImageStorageMode Enumeration

ImageStorageMode Enumeration |
 | See Also

Specifies the mode of storing chart images.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration ImageStorageMode
public enum ImageStorageMode
public enum class ImageStorageMode
public enum ImageStorageMode
public enum ImageStorageMode

Members

Member name | Description
UseHttpHandler | The Chart uses an HTTP handler to store images to memory or a file.
UseImageLocation | The Chart stores the image in a temporary file at the specified location.

Remarks

The ImageStorageMode enumeration is used with the ImageStorageMode property of the Chart control. It defines the type of storage that will be used when the chart is rendered as an image.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


IntervalAutoMode Enumeration

IntervalAutoMode Enumeration |
 | See Also

Specifies the automatic axis interval mode.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration IntervalAutoMode
public enum IntervalAutoMode
public enum class IntervalAutoMode
public enum IntervalAutoMode
public enum IntervalAutoMode

Members

Member name | Description
FixedCount | A fixed number of intervals are always created on the axis.
VariableCount | The number of axis intervals depends on the axis length.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


IntervalType Enumeration

IntervalType Enumeration |
 | See Also

Specifies an interval type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration IntervalType
public enum IntervalType
public enum class IntervalType
public enum IntervalType
public enum IntervalType

Members

Member name | Description
Days | An interval of days.
Hours | An interval of hours.
Milliseconds | An interval of milliseconds.
Minutes | An interval of minutes.
Months | An interval of months.
Number | A numerical interval.
Seconds | An interval of seconds.
Weeks | An interval of weeks.
Years | An interval of years.

Remarks

The IntervalType enumeration represents the type of interval and interval offset used for some definitions of the Group and InsertEmptyPoints methods of the DataManipulator class.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LabelAlignmentStyles Enumeration

LabelAlignmentStyles Enumeration |
 | See Also

Specifies a label alignment when SmartLabelStyle is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LabelAlignmentStyles
public enum LabelAlignmentStyles
public enum class LabelAlignmentStyles
public enum LabelAlignmentStyles
public enum LabelAlignmentStyles

Members

Member name | Description
Bottom | Label is aligned to the bottom of the data point.
BottomLeft | Label is aligned to the bottom-left of the data point.
BottomRight | Label is aligned to the bottom-right of the data point.
Center | Label is aligned to the center of the data point.
Left | Label is aligned to the left of the data point.
Right | Label is aligned to the right of the data point.
Top | Label is aligned to the top of the data point.
TopLeft | Label is aligned to the top-left corner of the data point.
TopRight | Label is aligned to the top-right corner of the data point.

Remarks

The LabelAlignmentStyles enumeration represents the alignment of a label; it is set by the MovingDirection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LabelAutoFitStyles Enumeration

LabelAutoFitStyles Enumeration |
 | See Also

Specifies style changes that can automatically be made to a label when the LabelAutoFitStyle property is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LabelAutoFitStyles
public enum LabelAutoFitStyles
public enum class LabelAutoFitStyles
public enum LabelAutoFitStyles
public enum LabelAutoFitStyles

Members

Member name | Description
DecreaseFont | Label font can be decreased.
IncreaseFont | Label font can be increased.
LabelsAngleStep30 | Labels can be angled in 30 degree steps: 0, 30, 60 and 90.
LabelsAngleStep45 | Labels can be angled in 45 degree steps: 0, 45, and 90.
LabelsAngleStep90 | Labels can be angled in 90 degree steps: 0 and 90.
None | No label changes are allowed.
StaggeredLabels | Labels can be staggered.
WordWrap | Labels can be word wrapped.

Remarks

The LabelAutoFitStyles enumeration represents the changes to the font or orientation of labels that can be automatically made to enable labels to fit along the axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LabelCalloutStyle Enumeration

LabelCalloutStyle Enumeration |
 | See Also

Specifies the type of leader line that should be drawn from the point to the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LabelCalloutStyle
public enum LabelCalloutStyle
public enum class LabelCalloutStyle
public enum LabelCalloutStyle
public enum LabelCalloutStyle

Members

Member name | Description
Box | Line will terminate to a box drawn around the label text.
None | Line will terminate at the label without any added style.
Underlined | Line will terminate with a horizontal line beneath the label text.

Remarks

The LabelCalloutStyle enumeration represents the type of leader line that should be drawn from the point to the label. It is used in conjunction with the CalloutStyle property of the SmartLabelStyle object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LabelMarkStyle Enumeration

LabelMarkStyle Enumeration |
 | See Also

Specifies a mark for custom labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LabelMarkStyle
public enum LabelMarkStyle
public enum class LabelMarkStyle
public enum LabelMarkStyle
public enum LabelMarkStyle

Members

Member name | Description
Box | A box is drawn around the label.
LineSideMark | Custom labels use line and side marks.
None | No label marks are used.
SideMark | Custom labels use side marks.

Remarks

The LabelMarkStyle enumeration represents mark(s) for custom labels that are displayed along the second axis label row. This row can only be generated from custom labels. This enumeration is used in conjunction with the LabelMark property of the CustomLabel class.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LabelOutsidePlotAreaStyle Enumeration

LabelOutsidePlotAreaStyle Enumeration |
 | See Also

Specifies the degree to which a label can be drawn outside a plotting area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LabelOutsidePlotAreaStyle
public enum LabelOutsidePlotAreaStyle
public enum class LabelOutsidePlotAreaStyle
public enum LabelOutsidePlotAreaStyle
public enum LabelOutsidePlotAreaStyle

Members

Member name | Description
No | Labels cannot de drawn outside the plotting area.
Partial | Labels can be drawn partially outside the plotting area.
Yes | Labels can be drawn outside the plotting area.

Remarks

The LabelOutsidePlotAreaStyle enumeration represents the degree to which a label is allowed to leave a plotting area. It is used in conjunction with the AllowOutsidePlotArea property of the SmartLabelStyle object.

If you specify the Partial value, no more than 50% of the label can be drawn outside the plotting area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LabelStyle Class

LabelStyle Class |
 | See Also Members

Provides properties that define the visual appearance of the axis labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LabelStyle
    Inherits ChartElement
public class LabelStyle : ChartElement
public ref class LabelStyle : public ChartElement
public class LabelStyle extends ChartElement
public class LabelStyle extends ChartElement

Remarks

Members of this class are also used to calculate the intervals and positions of the axis labels, and to draw them.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.LabelStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle Members

LabelStyle Members |
 | See Also Constructors Methods Properties

Provides properties that define the visual appearance of the axis labels.

The following tables list the members exposed by the LabelStyle type.

Public Constructors

Name | Description
LabelStyle | Initializes a new instance of the LabelStyle class.
Top

Public Properties

Name | Description
Angle | Gets or sets a value that represents the angle at which the font is drawn.
Enabled | Gets or sets a flag that indicates whether the label is enabled.
Font | Gets or sets the font of the label.
ForeColor | Gets or sets the color of the label.
Format | Gets or sets the formatting string for the label text.
Interval | Gets or sets the size of the label interval.
IntervalOffset | Gets or sets the offset of the label interval.
IntervalOffsetType | Gets or sets the unit of measurement of the label interval offset.
IntervalType | Gets or sets the unit of measurement for the size of a label interval.
IsEndLabelVisible | Gets or sets a flag that determines whether the labels are shown at axis ends.
IsStaggered | Gets or sets a flag that determines whether the labels are shown with an offset.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TruncatedLabels | Gets or sets a flag that determines whether the labels can be truncated.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle Constructor

LabelStyle Constructor |
 | See Also

Initializes a new instance of the LabelStyle class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public LabelStyle ()
public:
LabelStyle ()
public LabelStyle ()
public function LabelStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle Methods

LabelStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Dispose Method

LabelStyle.Dispose Method |
 | See Also

Overload List

Name | Description
LabelStyle.Dispose () | (inherited from Dispose )
LabelStyle.Dispose (Boolean) |

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Dispose Method (Boolean)

LabelStyle.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle Properties

LabelStyle Properties |
 | See Also

Public Properties

Name | Description
Angle | Gets or sets a value that represents the angle at which the font is drawn.
Enabled | Gets or sets a flag that indicates whether the label is enabled.
Font | Gets or sets the font of the label.
ForeColor | Gets or sets the color of the label.
Format | Gets or sets the formatting string for the label text.
Interval | Gets or sets the size of the label interval.
IntervalOffset | Gets or sets the offset of the label interval.
IntervalOffsetType | Gets or sets the unit of measurement of the label interval offset.
IntervalType | Gets or sets the unit of measurement for the size of a label interval.
IsEndLabelVisible | Gets or sets a flag that determines whether the labels are shown at axis ends.
IsStaggered | Gets or sets a flag that determines whether the labels are shown with an offset.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TruncatedLabels | Gets or sets a flag that determines whether the labels can be truncated.

See Also

Reference

LabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Angle Property

LabelStyle.Angle Property |
 | See Also

Gets or sets a value that represents the angle at which the font is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Angle As Integer
public int Angle { get; set; }
public:
property int Angle {
    int get ();
    void set (int value);
}
/** @property */
public int get_Angle ()

/** @property */
public void set_Angle (int value)

public function get Angle () : int

public function set Angle (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Enabled Property

LabelStyle.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether the label is enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Font Property

LabelStyle.Font Property |
 | See Also

Gets or sets the font of the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.ForeColor Property

LabelStyle.ForeColor Property |
 | See Also

Gets or sets the color of the label.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Format Property

LabelStyle.Format Property |
 | See Also

Gets or sets the formatting string for the label text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Format As String
public string Format { get; set; }
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Format ()

/** @property */
public void set_Format (String value)

public function get Format () : String

public function set Format (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.Interval Property

LabelStyle.Interval Property |
 | See Also

Gets or sets the size of the label interval.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.IntervalOffset Property

LabelStyle.IntervalOffset Property |
 | See Also

Gets or sets the offset of the label interval.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.IntervalOffsetType Property

LabelStyle.IntervalOffsetType Property |
 | See Also

Gets or sets the unit of measurement of the label interval offset.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.IntervalType Property

LabelStyle.IntervalType Property |
 | See Also

Gets or sets the unit of measurement for the size of a label interval.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.IsEndLabelVisible Property

LabelStyle.IsEndLabelVisible Property |
 | See Also

Gets or sets a flag that determines whether the labels are shown at axis ends.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsEndLabelVisible As Boolean
public bool IsEndLabelVisible { get; set; }
public:
property bool IsEndLabelVisible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEndLabelVisible ()

/** @property */
public void set_IsEndLabelVisible (boolean value)

public function get IsEndLabelVisible () : boolean

public function set IsEndLabelVisible (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.IsStaggered Property

LabelStyle.IsStaggered Property |
 | See Also

Gets or sets a flag that determines whether the labels are shown with an offset.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsStaggered As Boolean
public bool IsStaggered { get; set; }
public:
property bool IsStaggered {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsStaggered ()

/** @property */
public void set_IsStaggered (boolean value)

public function get IsStaggered () : boolean

public function set IsStaggered (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


LabelStyle.TruncatedLabels Property

LabelStyle.TruncatedLabels Property |
 | See Also

Gets or sets a flag that determines whether the labels can be truncated.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TruncatedLabels As Boolean
public bool TruncatedLabels { get; set; }
public:
property bool TruncatedLabels {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_TruncatedLabels ()

/** @property */
public void set_TruncatedLabels (boolean value)

public function get TruncatedLabels () : boolean

public function set TruncatedLabels (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


Legend Class

Legend Class |
 | See Also Members

Represents the legend for the chart image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Legend
    Inherits ChartNamedElement
public class Legend : ChartNamedElement
public ref class Legend : public ChartNamedElement
public class Legend extends ChartNamedElement
public class Legend extends ChartNamedElement

Remarks

The Legend class encapsulates all the functionality of the Chart control's legend, and is exposed using the Legends collection property of the root Chart object.

There can be any number of legends for a chart image.

Legends can:

  • Be docked and aligned.

  • Be displayed inside or outside the plotted chart areas.

  • Automatically fit their contents.

  • Use a predefined style, such as row, column or table.

  • Use hatching, gradient colors and background images.

  • Be sized and positioned anywhere within the chart image.

Legend items are represented by the LegendItem object, and are either default or custom items. Custom items are not associated with data, and can be added, deleted and modified using the CustomItems property.

Default items are by default automatically added to the legend, and are the names of the plotted data points for doughnut and pie charts.

For all other chart types, the default items are the names of the plotted data series. Each series has a Legend property that defines the name of the legend that will be used. A legend item will not be created for a series if the IsVisibleInLegend property is set to false. The text for these default items can be changed using the LegendText property. This property will allow you to specify predefined keywords that will be replaced by their appropriate values at run-time.

If you have a pie chart and you set the Label property, it will also set the legend text to the value you set for the labels. If you want to set the text to a different value, you can set the LegendText property. In most cases, you would want to set the LegendText property to "#AXISLABEL" or "#VALX".

Legend series symbols are rectangles, dots or lines. The symbol type is set automatically by the chart and depends on the plotted chart type.

Legend text by default is automatically sized. You can disable automatic sizing of legend text by disabling the IsTextAutoFit property. When this property is set to false, the size of the legend text is determined by the Size property of the legend Font. If the IsTextAutoFit property is enabled, the AutoFitMinFontSize property determines the minimum font size that a legend item can have when resizing.

The TextWrapThreshold property defines a limit on the number of characters that can be shown on one line before text is wrapped to another line. If you do not wish to wrap text in the legend, set the value of the TextWrapThreshold property to zero. By default, when the entire legend text does not fit in the legend, the text will be truncated. You can set the TextWrapThreshold on the legend to get the text to wrap instead of being truncated.

If the contents of the legend cannot fit into the given space, legend entries are truncated. An ellipsis will be shown to indicate that there are more entries than the legend has space for. To prevent the legend items from being truncated,, set the position and size of the legend using the Position and Size properties, respectively. When setting the legend position or size, the chart can no longer automatically position the elements in the chart. In some cases, you many need to manually position other chart elements to achieve the desired appearance.

Another option would be to define your own cell columns instead of using the default legend settings.

The Legend object has a CellColumn Collection; each CellColumn object represents a column in the Legend. A cell column has MaximumWidth and MinimumWidth properties that can be used to adjust the size of the columns.

When the legend contains many entries, InterlacedRows can be used to improve readability. When this property is set to True, it will display a back color that you can set using the InterlacedRowsColor property.

By default, the legend is positioned in the top-right corner of the chart. This position can be modified by using the Docking and Alignment properties of the legend. The legend can also be associated with a chart area by use of the DockedToChartArea property. This property specifies the name of the chart area for which the legend should be docked. In addition, the IsDockedInsideChartArea property can be used to display the legend inside a chart area.

When IsDockedInsideChartArea is set to False, the MaximumAutoSize property defines the maximum size, in percent, of the legend within the available chart when the legend is automatically positioned. This property should be set if you wish to adjust the width or height of the legend after the docking properties have been set.

The legend can be modified using the CustomizeLegend event.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Legend

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend Members

Legend Members |
 | See Also Constructors Methods Properties

Represents the legend for the chart image.

The following tables list the members exposed by the Legend type.

Public Constructors

Name | Description
Legend | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend.
AutoFitMinFontSize | Gets or sets the minimum font size that can be used by the autofitting algorithm for the legend text.
BackColor | Gets or sets the background color of a legend.
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend.
BackImage | Gets or sets the background image of a legend.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of a legend background image.
BackSecondaryColor | Gets or sets the secondary color of a legend background.
BorderColor | Gets or sets the border color of a legend.
BorderDashStyle | Gets or sets the border style of a legend.
BorderWidth | Gets or sets the border width of a legend.
CellColumns | Gets the LegendCellColumnCollection for a legend.
CustomItems | Gets a T:System.Web.UI.DataVisualization.Charting.LegendItemsCollection object used for custom legend items.
DockedToChartArea | Gets or sets the name of the ChartArea where the legend will be docked.
Docking | Gets or sets a value that determines where the legend is docked.
Enabled | Gets or sets a value that determines if the legend is enabled.
Font | Gets or sets a Font object, which is used to set font properties of the legend.
ForeColor | Gets or sets the color of the legend text.
HeaderSeparator | Gets or sets the visual separator type for the legend header.
HeaderSeparatorColor | Gets or sets the color of the separator for the legend header.
InsideChartArea | Gets or sets the name of the chart area in which the legend is drawn.
InterlacedRows | Gets or sets a flag that indicates if legend rows will be drawn with interlaced background color.
InterlacedRowsColor | Gets or sets the background color of the legend's interlaced rows.
IsDockedInsideChartArea | Gets or sets a flag that indicates whether the legend is docked inside or outside the chart area.
IsEquallySpacedItems | Gets or sets a flag that indicates whether all legend items are equally spaced.
IsTextAutoFit | Gets or sets a flag that indicates if the legend text is automatically sized.
ItemColumnSeparator | Gets or sets the visual separator type for the legend table columns.
ItemColumnSeparatorColor | Gets or sets the color of the legend table column separator.
ItemColumnSpacing | Gets or sets the legend table column spacing.
LegendItemOrder | Gets or sets a flag that specifies the order in which legend items are displayed. This property only affects legend items automatically added for the chart series; it has no effect on custom legend items.
LegendStyle | Gets or sets the style of the legend.
MaximumAutoSize | Gets or sets the maximum size of the legend, measured as a percentage of the chart area. This value is used by the automatic layout algorithm.
Name | Overridden. Gets or sets the name of the legend.
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the legend.
ShadowColor | Gets or sets the shadow color of the legend.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the legend.
TableStyle | Gets or sets the legend table style.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextWrapThreshold | Gets or sets the number of characters that can be sequentially displayed in the legend before the text is wrapped.
Title | Gets or sets the text of the legend title.
TitleAlignment | Gets or sets the alignment of the legend title.
TitleBackColor | Gets or sets the background color of the legend title.
TitleFont | Gets or sets the font for the legend title.
TitleForeColor | Gets or sets the text color of the legend title.
TitleSeparator | Gets or sets the visual separator type for the legend title.
TitleSeparatorColor | Gets or sets the color of the legend title separator.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Legend Class
System.Web.UI.DataVisualization.Charting Namespace


Legend Constructor

Legend Constructor |
 | See Also

Overload List

Name | Description
Legend () | Initializes a new instance of the Legend class.
Legend (String) | Initializes a new instance of the AnnotationPathPoint class with the specified legend name.

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend Constructor ()

Legend Constructor () |
 | See Also

Initializes a new instance of the Legend class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Legend ()
public:
Legend ()
public Legend ()
public function Legend ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend Constructor (String)

Legend Constructor (String) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified legend name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String _
)
public Legend (
    string name
)
public:
Legend (
    String^ name
)
public Legend (
    String name
)
public function Legend (
    name : String
)

Parameters

name

The name of the Legend object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend Methods

Legend Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Legend Class
System.Web.UI.DataVisualization.Charting Namespace


Legend.Dispose Method

Legend.Dispose Method |
 | See Also

Overload List

Name | Description
Legend.Dispose () | (inherited from Dispose )
Legend.Dispose (Boolean) |

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Dispose Method (Boolean)

Legend.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend Properties

Legend Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend.
AutoFitMinFontSize | Gets or sets the minimum font size that can be used by the autofitting algorithm for the legend text.
BackColor | Gets or sets the background color of a legend.
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend.
BackImage | Gets or sets the background image of a legend.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of a legend background image.
BackSecondaryColor | Gets or sets the secondary color of a legend background.
BorderColor | Gets or sets the border color of a legend.
BorderDashStyle | Gets or sets the border style of a legend.
BorderWidth | Gets or sets the border width of a legend.
CellColumns | Gets the LegendCellColumnCollection for a legend.
CustomItems | Gets a T:System.Web.UI.DataVisualization.Charting.LegendItemsCollection object used for custom legend items.
DockedToChartArea | Gets or sets the name of the ChartArea where the legend will be docked.
Docking | Gets or sets a value that determines where the legend is docked.
Enabled | Gets or sets a value that determines if the legend is enabled.
Font | Gets or sets a Font object, which is used to set font properties of the legend.
ForeColor | Gets or sets the color of the legend text.
HeaderSeparator | Gets or sets the visual separator type for the legend header.
HeaderSeparatorColor | Gets or sets the color of the separator for the legend header.
InsideChartArea | Gets or sets the name of the chart area in which the legend is drawn.
InterlacedRows | Gets or sets a flag that indicates if legend rows will be drawn with interlaced background color.
InterlacedRowsColor | Gets or sets the background color of the legend's interlaced rows.
IsDockedInsideChartArea | Gets or sets a flag that indicates whether the legend is docked inside or outside the chart area.
IsEquallySpacedItems | Gets or sets a flag that indicates whether all legend items are equally spaced.
IsTextAutoFit | Gets or sets a flag that indicates if the legend text is automatically sized.
ItemColumnSeparator | Gets or sets the visual separator type for the legend table columns.
ItemColumnSeparatorColor | Gets or sets the color of the legend table column separator.
ItemColumnSpacing | Gets or sets the legend table column spacing.
LegendItemOrder | Gets or sets a flag that specifies the order in which legend items are displayed. This property only affects legend items automatically added for the chart series; it has no effect on custom legend items.
LegendStyle | Gets or sets the style of the legend.
MaximumAutoSize | Gets or sets the maximum size of the legend, measured as a percentage of the chart area. This value is used by the automatic layout algorithm.
Name | Overridden. Gets or sets the name of the legend.
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the legend.
ShadowColor | Gets or sets the shadow color of the legend.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the legend.
TableStyle | Gets or sets the legend table style.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextWrapThreshold | Gets or sets the number of characters that can be sequentially displayed in the legend before the text is wrapped.
Title | Gets or sets the text of the legend title.
TitleAlignment | Gets or sets the alignment of the legend title.
TitleBackColor | Gets or sets the background color of the legend title.
TitleFont | Gets or sets the font for the legend title.
TitleForeColor | Gets or sets the text color of the legend title.
TitleSeparator | Gets or sets the visual separator type for the legend title.
TitleSeparatorColor | Gets or sets the color of the legend title separator.

See Also

Reference

Legend Class
System.Web.UI.DataVisualization.Charting Namespace


Legend.Alignment Property

Legend.Alignment Property |
 | See Also

Gets or sets the alignment of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Alignment As StringAlignment
public StringAlignment Alignment { get; set; }
public:
property StringAlignment Alignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_Alignment ()

/** @property */
public void set_Alignment (StringAlignment value)

public function get Alignment () : StringAlignment

public function set Alignment (value : StringAlignment)

Property Value

A .NET Framework StringAlignment enumeration value that represents the alignment of the legend. The default value is Near.

Remarks

The legend can be aligned so that it is Near, Center or Far; its alignment is also affected by the Docking property setting.

If the legend is docked to the top or bottom, Near is to the left; if it is docked to the left or right, Near is at the top. The Far property setting is just the opposite, and aligns the legend to the right or the bottom, depending on where it is docked.

Center always centers the legend, either vertically or horizontally.

Setting the Alignment property will have no effect if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.AutoFitMinFontSize Property

Legend.AutoFitMinFontSize Property |
 | See Also

Gets or sets the minimum font size that can be used by the autofitting algorithm for the legend text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property AutoFitMinFontSize As Integer
public int AutoFitMinFontSize { get; set; }
public:
property int AutoFitMinFontSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_AutoFitMinFontSize ()

/** @property */
public void set_AutoFitMinFontSize (int value)

public function get AutoFitMinFontSize () : int

public function set AutoFitMinFontSize (value : int)

Property Value

An integer value that represents the minimum font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackColor Property

Legend.BackColor Property |
 | See Also

Gets or sets the background color of a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value. The default color is System.Drawing.Color.White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

The BackColor value will be the first color used if you have specified gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the legend. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackGradientStyle Property

Legend.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a legend. Also determines whether a gradient is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a legend will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

Set the primary color of the legend background with the BackColor property.

Set the secondary color of the legend background with the BackSecondaryColor property.

Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackHatchStyle Property

Legend.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackImage Property

Legend.BackImage Property |
 | See Also

Gets or sets the background image of a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default value is an empty string.

Remarks

This property defines a path to a background image for a Chart legend, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image can originate from any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackImageAlignment Property

Legend.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment used for the Unscaled drawing mode.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for the legend; it is only applied when the BackImageWrapMode property is set to Unscaled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackImageTransparentColor Property

Legend.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the background image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackImageWrapMode Property

Legend.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of a legend background image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

The BackImageWrapMode property determines how the image is displayed; the image can be tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the legend. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the legend.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BackSecondaryColor Property

Legend.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of a legend background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of background with hatching or gradient fill. The default value is Empty.

Remarks

The BackSecondaryColor property determines the secondary background color of many Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the legend.

To use gradient colors for the background of a legend:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BorderColor Property

Legend.BorderColor Property |
 | See Also

Gets or sets the border color of a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BorderDashStyle Property

Legend.BorderDashStyle Property |
 | See Also

Gets or sets the border style of a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the chart element.

Remarks

The BorderDashStyle property determines the line style to use for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.BorderWidth Property

Legend.BorderWidth Property |
 | See Also

Gets or sets the border width of a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the legend.

Remarks

Note that BorderWidth property can also set the width of lines in such elements as line charts, custom legend items displayed with a "line" style, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.CellColumns Property

Legend.CellColumns Property |
 | See Also

Gets the LegendCellColumnCollection for a legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property CellColumns As LegendCellColumnCollection
public LegendCellColumnCollection CellColumns { get; }
public:
property LegendCellColumnCollection^ CellColumns {
    LegendCellColumnCollection^ get ();
}
/** @property */
public LegendCellColumnCollection get_CellColumns ()

public function get CellColumns () : LegendCellColumnCollection

Property Value

A LegendCellColumnCollection object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.CustomItems Property

Legend.CustomItems Property |
 | See Also

Gets a T:System.Web.UI.DataVisualization.Charting.LegendItemsCollection object used for custom legend items.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property CustomItems As LegendItemsCollection
public LegendItemsCollection CustomItems { get; }
public:
property LegendItemsCollection^ CustomItems {
    LegendItemsCollection^ get ();
}
/** @property */
public LegendItemsCollection get_CustomItems ()

public function get CustomItems () : LegendItemsCollection

Property Value

A LegendItemsCollection object.

Remarks

This collection property can be used to add, delete or modify custom legend items.

Custom legend items, unlike default legend items, do not have associated series or data points.

To modify legend items, use the CustomizeLegend event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.DockedToChartArea Property

Legend.DockedToChartArea Property |
 | See Also

Gets or sets the name of the ChartArea where the legend will be docked.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property DockedToChartArea As String
public string DockedToChartArea { get; set; }
public:
property String^ DockedToChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_DockedToChartArea ()

/** @property */
public void set_DockedToChartArea (String value)

public function get DockedToChartArea () : String

public function set DockedToChartArea (value : String)

Property Value

A string value that represents the name of the ChartArea where this legend will be docked. The default value is the empty string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Docking Property

Legend.Docking Property |
 | See Also

Gets or sets a value that determines where the legend is docked.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Docking As Docking
public Docking Docking { get; set; }
public:
property Docking Docking {
    Docking get ();
    void set (Docking value);
}
/** @property */
public Docking get_Docking ()

/** @property */
public void set_Docking (Docking value)

public function get Docking () : Docking

public function set Docking (value : Docking)

Property Value

A Docking enumeration value. The default value is Right.

Remarks

The Legend can be docked to the top, left, bottom or right of either the entire chart image, or the inside or outside of a chart area. If the IsDockedInsideChartArea property is set to false, docking applies to the entire chart image. If the IsDockedInsideChartArea property is set to true, docking applies to the ChartArea object specified by the DockedToChartArea property

This property has no effect if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Enabled Property

Legend.Enabled Property |
 | See Also

Gets or sets a value that determines if the legend is enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if enabled, false if disabled. The default value is true.

Remarks

To hide a legend, set this property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Font Property

Legend.Font Property |
 | See Also

Gets or sets a Font object, which is used to set font properties of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object.

Remarks

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Note:
If you set the Legend.Font.Size property, the IsTextAutoFit property will be set to false. Also, if you set the IsTextAutoFit property to true, this property will be reset to its default, which is 8 points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.ForeColor Property

Legend.ForeColor Property |
 | See Also

Gets or sets the color of the legend text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

The ForeColor property is used to set the legend text color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.HeaderSeparator Property

Legend.HeaderSeparator Property |
 | See Also

Gets or sets the visual separator type for the legend header.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property HeaderSeparator As LegendSeparatorStyle
public LegendSeparatorStyle HeaderSeparator { get; set; }
public:
property LegendSeparatorStyle HeaderSeparator {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_HeaderSeparator ()

/** @property */
public void set_HeaderSeparator (LegendSeparatorStyle value)

public function get HeaderSeparator () : LegendSeparatorStyle

public function set HeaderSeparator (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.HeaderSeparatorColor Property

Legend.HeaderSeparatorColor Property |
 | See Also

Gets or sets the color of the separator for the legend header.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property HeaderSeparatorColor As Color
public Color HeaderSeparatorColor { get; set; }
public:
property Color HeaderSeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_HeaderSeparatorColor ()

/** @property */
public void set_HeaderSeparatorColor (Color value)

public function get HeaderSeparatorColor () : Color

public function set HeaderSeparatorColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.InsideChartArea Property

Legend.InsideChartArea Property |
 | See Also

Gets or sets the name of the chart area in which the legend is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
<BrowsableAttribute(False)> _
Public Property InsideChartArea As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[BrowsableAttribute(false)]
public string InsideChartArea { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
[BrowsableAttribute(false)]
public:
property String^ InsideChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_InsideChartArea ()

/** @property */
public void set_InsideChartArea (String value)

public function get InsideChartArea () : String

public function set InsideChartArea (value : String)

Property Value

A string value that represents the name of the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.InterlacedRows Property

Legend.InterlacedRows Property |
 | See Also

Gets or sets a flag that indicates if legend rows will be drawn with interlaced background color.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property InterlacedRows As Boolean
public bool InterlacedRows { get; set; }
public:
property bool InterlacedRows {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_InterlacedRows ()

/** @property */
public void set_InterlacedRows (boolean value)

public function get InterlacedRows () : boolean

public function set InterlacedRows (value : boolean)

Property Value

A Boolean value that determines whether alternating rows in the legend are drawn with a specified color.

Remarks

When the legend contains many entries, the InterlacedRows property can be used to improve readability. When this property is set to true, the legend will display a background color for the rows that are interlaced, which can be set using the InterlacedRowsColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.InterlacedRowsColor Property

Legend.InterlacedRowsColor Property |
 | See Also

Gets or sets the background color of the legend's interlaced rows.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property InterlacedRowsColor As Color
public Color InterlacedRowsColor { get; set; }
public:
property Color InterlacedRowsColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_InterlacedRowsColor ()

/** @property */
public void set_InterlacedRowsColor (Color value)

public function get InterlacedRowsColor () : Color

public function set InterlacedRowsColor (value : Color)

Property Value

A Color value.

Remarks

This property is only applicable if interlaced rows are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.IsDockedInsideChartArea Property

Legend.IsDockedInsideChartArea Property |
 | See Also

Gets or sets a flag that indicates whether the legend is docked inside or outside the chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsDockedInsideChartArea As Boolean
public bool IsDockedInsideChartArea { get; set; }
public:
property bool IsDockedInsideChartArea {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsDockedInsideChartArea ()

/** @property */
public void set_IsDockedInsideChartArea (boolean value)

public function get IsDockedInsideChartArea () : boolean

public function set IsDockedInsideChartArea (value : boolean)

Property Value

True is the legend is docked inside the chart area, otherwise false if it is docked outside the chart area. The default value is false.

Remarks

This property will only have an effect if the DockedToChartArea property is set to the name of a ChartArea object.

Note:
If the Position property is set to any value other than Auto, the IsDockedInsideChartArea property also has no effect. This is because the position of the legend is determined by the Position property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.IsEquallySpacedItems Property

Legend.IsEquallySpacedItems Property |
 | See Also

Gets or sets a flag that indicates whether all legend items are equally spaced.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsEquallySpacedItems As Boolean
public bool IsEquallySpacedItems { get; set; }
public:
property bool IsEquallySpacedItems {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEquallySpacedItems ()

/** @property */
public void set_IsEquallySpacedItems (boolean value)

public function get IsEquallySpacedItems () : boolean

public function set IsEquallySpacedItems (value : boolean)

Property Value

True if legend items are equally spaced, false if they are not. The default value is false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.IsTextAutoFit Property

Legend.IsTextAutoFit Property |
 | See Also

Gets or sets a flag that indicates if the legend text is automatically sized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsTextAutoFit As Boolean
public bool IsTextAutoFit { get; set; }
public:
property bool IsTextAutoFit {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsTextAutoFit ()

/** @property */
public void set_IsTextAutoFit (boolean value)

public function get IsTextAutoFit () : boolean

public function set IsTextAutoFit (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.ItemColumnSeparator Property

Legend.ItemColumnSeparator Property |
 | See Also

Gets or sets the visual separator type for the legend table columns.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ItemColumnSeparator As LegendSeparatorStyle
public LegendSeparatorStyle ItemColumnSeparator { get; set; }
public:
property LegendSeparatorStyle ItemColumnSeparator {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_ItemColumnSeparator ()

/** @property */
public void set_ItemColumnSeparator (LegendSeparatorStyle value)

public function get ItemColumnSeparator () : LegendSeparatorStyle

public function set ItemColumnSeparator (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.ItemColumnSeparatorColor Property

Legend.ItemColumnSeparatorColor Property |
 | See Also

Gets or sets the color of the legend table column separator.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ItemColumnSeparatorColor As Color
public Color ItemColumnSeparatorColor { get; set; }
public:
property Color ItemColumnSeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ItemColumnSeparatorColor ()

/** @property */
public void set_ItemColumnSeparatorColor (Color value)

public function get ItemColumnSeparatorColor () : Color

public function set ItemColumnSeparatorColor (value : Color)

Property Value

A Color value used to draw the color of the legend table column separator.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.ItemColumnSpacing Property

Legend.ItemColumnSpacing Property |
 | See Also

Gets or sets the legend table column spacing.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ItemColumnSpacing As Integer
public int ItemColumnSpacing { get; set; }
public:
property int ItemColumnSpacing {
    int get ();
    void set (int value);
}
/** @property */
public int get_ItemColumnSpacing ()

/** @property */
public void set_ItemColumnSpacing (int value)

public function get ItemColumnSpacing () : int

public function set ItemColumnSpacing (value : int)

Property Value

An integer value that represents the table column spacing.

Remarks

The ItemColumnSpacing property value is calculated as a percentage of the legend text font.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.LegendItemOrder Property

Legend.LegendItemOrder Property |
 | See Also

Gets or sets a flag that specifies the order in which legend items are displayed. This property only affects legend items automatically added for the chart series; it has no effect on custom legend items.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendItemOrder As LegendItemOrder
public LegendItemOrder LegendItemOrder { get; set; }
public:
property LegendItemOrder LegendItemOrder {
    LegendItemOrder get ();
    void set (LegendItemOrder value);
}
/** @property */
public LegendItemOrder get_LegendItemOrder ()

/** @property */
public void set_LegendItemOrder (LegendItemOrder value)

public function get LegendItemOrder () : LegendItemOrder

public function set LegendItemOrder (value : LegendItemOrder)

Property Value

A LegendItemOrder enumeration value.

Remarks

If the LegendItemOrder property is set to Auto, the legend will automatically be reversed if StackedColumn, StackedColumn100, StackedArea or StackedArea100 chart types are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.LegendStyle Property

Legend.LegendStyle Property |
 | See Also

Gets or sets the style of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property LegendStyle As LegendStyle
public LegendStyle LegendStyle { get; set; }
public:
property LegendStyle LegendStyle {
    LegendStyle get ();
    void set (LegendStyle value);
}
/** @property */
public LegendStyle get_LegendStyle ()

/** @property */
public void set_LegendStyle (LegendStyle value)

public function get LegendStyle () : LegendStyle

public function set LegendStyle (value : LegendStyle)

Property Value

A LegendStyle enumeration value that determines the legend style. The default value is Table.

Remarks

By default, the legend is displayed as a series of items in a table. You can specify whether to expand items in the table width-wise or height-wise by setting the TableStyle property. When the TableStyle property is set to Auto, the Chart control will determine whether to draw a wide table or a tall table, depending on the alignment and positioning of the chart. This may cause the legend to be drawn using multiple legend item columns.

There are three possible styles for a legend: Column, Row and Table. Refer to the table below for a summary of these styles:

Style | Description
Column | Legend items are displayed in one column, with multiple rows. Most commonly used when the legend is docked to the left or right of the chart.
Row | Legend items are displayed in one row, with multiple columns. Most commonly used when the legend is docked to the top or bottom of the chart.
Table | Legend items are displayed using multiple columns and rows.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.MaximumAutoSize Property

Legend.MaximumAutoSize Property |
 | See Also

Gets or sets the maximum size of the legend, measured as a percentage of the chart area. This value is used by the automatic layout algorithm.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MaximumAutoSize As Single
public float MaximumAutoSize { get; set; }
public:
property float MaximumAutoSize {
    float get ();
    void set (float value);
}
/** @property */
public float get_MaximumAutoSize ()

/** @property */
public void set_MaximumAutoSize (float value)

public function get MaximumAutoSize () : float

public function set MaximumAutoSize (value : float)

Property Value

A float value that represents the maximum size of the legend.

Remarks

If the legend is docked to the left or right of the chart area, this property determines the maximum width of the legend, which is measured as a percentage of the chart area. If the legend is docked to the top or bottom, this property determines the maximum height of the legend, which is also measured as a percentage.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Name Property

Legend.Name Property |
 | See Also

Gets or sets the name of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the name of the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Position Property

Legend.Position Property |
 | See Also

Gets or sets an ElementPosition object, which can be used to get or set the position of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Position As ElementPosition
public ElementPosition Position { get; set; }
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_Position ()

/** @property */
public void set_Position (ElementPosition value)

public function get Position () : ElementPosition

public function set Position (value : ElementPosition)

Property Value

An ElementPosition value that represents the position of the legend. The default value is Auto.

Remarks

If the Position property is automatic (that is, Legend.Position.Auto = true) the legend position is calculated automatically by the Chart control, taking into account the Docking, Alignment and IsDockedInsideChartArea property settings.

If it is not automatic, the Docking, DockedToChartArea and IsDockedInsideChartArea properties are ignored, and the legend position is solely determined by the value of the returned ElementPosition object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.ShadowColor Property

Legend.ShadowColor Property |
 | See Also

Gets or sets the shadow color of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.ShadowOffset Property

Legend.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset, in pixels, of the legend.

Remarks

To implement shadowing, set this property to a value other than zero (0). A positive value will result in a shadow that shifts down and to the right; a negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TableStyle Property

Legend.TableStyle Property |
 | See Also

Gets or sets the legend table style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TableStyle As LegendTableStyle
public LegendTableStyle TableStyle { get; set; }
public:
property LegendTableStyle TableStyle {
    LegendTableStyle get ();
    void set (LegendTableStyle value);
}
/** @property */
public LegendTableStyle get_TableStyle ()

/** @property */
public void set_TableStyle (LegendTableStyle value)

public function get TableStyle () : LegendTableStyle

public function set TableStyle (value : LegendTableStyle)

Property Value

A LegendTableStyle enumeration value.

Remarks

This property is only applicable if the LegendStyle property is set to Table.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TextWrapThreshold Property

Legend.TextWrapThreshold Property |
 | See Also

Gets or sets the number of characters that can be sequentially displayed in the legend before the text is wrapped.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextWrapThreshold As Integer
public int TextWrapThreshold { get; set; }
public:
property int TextWrapThreshold {
    int get ();
    void set (int value);
}
/** @property */
public int get_TextWrapThreshold ()

/** @property */
public void set_TextWrapThreshold (int value)

public function get TextWrapThreshold () : int

public function set TextWrapThreshold (value : int)

Property Value

An integer value that represents the number of characters that can be placed in the legend sequentially before the text is wrapped. The default value is 25.

Remarks

When the legend text exceeds the value specified by this property, text will be automatically wrapped when the next whitespace character is encountered. Text will not be wrapped if there are no whitespace characters in the text.

Set the TextWrapThreshold property to zero to disable the feature.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.Title Property

Legend.Title Property |
 | See Also

Gets or sets the text of the legend title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Title As String
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Title ()

/** @property */
public void set_Title (String value)

public function get Title () : String

public function set Title (value : String)

Property Value

A string value that represents the legend title text. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TitleAlignment Property

Legend.TitleAlignment Property |
 | See Also

Gets or sets the alignment of the legend title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleAlignment As StringAlignment
public StringAlignment TitleAlignment { get; set; }
public:
property StringAlignment TitleAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TitleAlignment ()

/** @property */
public void set_TitleAlignment (StringAlignment value)

public function get TitleAlignment () : StringAlignment

public function set TitleAlignment (value : StringAlignment)

Property Value

A StringAlignment enumeration value that represents the alignment of the legend title. The default value is Center.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TitleBackColor Property

Legend.TitleBackColor Property |
 | See Also

Gets or sets the background color of the legend title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleBackColor As Color
public Color TitleBackColor { get; set; }
public:
property Color TitleBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleBackColor ()

/** @property */
public void set_TitleBackColor (Color value)

public function get TitleBackColor () : Color

public function set TitleBackColor (value : Color)

Property Value

A Color value used to draw the background of the legend title. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TitleFont Property

Legend.TitleFont Property |
 | See Also

Gets or sets the font for the legend title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleFont As Font
public Font TitleFont { get; set; }
public:
property Font^ TitleFont {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_TitleFont ()

/** @property */
public void set_TitleFont (Font value)

public function get TitleFont () : Font

public function set TitleFont (value : Font)

Property Value

A Font object. The default value is "Microsoft Sans Serif, 8pt, Bold".

Remarks

This property can be used to set font properties of the legend title.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TitleForeColor Property

Legend.TitleForeColor Property |
 | See Also

Gets or sets the text color of the legend title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleForeColor As Color
public Color TitleForeColor { get; set; }
public:
property Color TitleForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleForeColor ()

/** @property */
public void set_TitleForeColor (Color value)

public function get TitleForeColor () : Color

public function set TitleForeColor (value : Color)

Property Value

A Color value used to draw the title text color. The default value is Black.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TitleSeparator Property

Legend.TitleSeparator Property |
 | See Also

Gets or sets the visual separator type for the legend title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleSeparator As LegendSeparatorStyle
public LegendSeparatorStyle TitleSeparator { get; set; }
public:
property LegendSeparatorStyle TitleSeparator {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_TitleSeparator ()

/** @property */
public void set_TitleSeparator (LegendSeparatorStyle value)

public function get TitleSeparator () : LegendSeparatorStyle

public function set TitleSeparator (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle value that represents the type of separator that will be drawn below the title. The default value is None.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


Legend.TitleSeparatorColor Property

Legend.TitleSeparatorColor Property |
 | See Also

Gets or sets the color of the legend title separator.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TitleSeparatorColor As Color
public Color TitleSeparatorColor { get; set; }
public:
property Color TitleSeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleSeparatorColor ()

/** @property */
public void set_TitleSeparatorColor (Color value)

public function get TitleSeparatorColor () : Color

public function set TitleSeparatorColor (value : Color)

Property Value

A Color value used to draw the color of the legend title separator. The default value is Color.Black.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Class

LegendCell Class |
 | See Also Members

Represents a legend cell in a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendCell
    Inherits ChartNamedElement
    Implements IChartMapArea
public class LegendCell : ChartNamedElement, IChartMapArea
public ref class LegendCell : public ChartNamedElement, IChartMapArea
public class LegendCell extends ChartNamedElement implements IChartMapArea
public class LegendCell extends ChartNamedElement implements IChartMapArea

Remarks

A legend is populated with legend items, which are represented by the LegendItemsCollection. These legend items consist of individual legend cells, which are in turn represented by the LegendCellCollection.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.LegendCell

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Members

LegendCell Members |
 | See Also Constructors Methods Properties

Represents a legend cell in a legend item.

The following tables list the members exposed by the LegendCell type.

Public Constructors

Name | Description
LegendCell | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend cell contents.
BackColor | Gets or sets the background color of the legend cell.
CellSpan | Gets or sets the number of horizontal cells used to draw the contents of the legend cell.
CellType | Gets or sets the legend cell type.
Font | Gets or sets the font for the legend cell.
ForeColor | Gets or sets the text color of the legend cell.
Image | Gets or sets the name of the image in a legend cell.
ImageSize | Gets or sets the size of the image in a legend cell.
ImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the image is drawn.
Legend | Gets the legend in which this cell belongs.
LegendItem | Gets the legend item in which this cell belongs.
MapAreaAttributes | Gets or sets the map area attributes of the legend cell.
Margins | Gets or sets the margins of the legend cell.
Name | Overridden. Gets or sets the name of the legend cell.
PostBackValue | Gets or sets a postback value that can be processed on a Chart.Click event.
SeriesSymbolSize | Gets or sets the size of the series symbol that is displayed in the legend cell.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the legend cell text.
ToolTip | Gets or sets the tooltip text for the legend cell.
Url | Gets or sets the URL target of the legend cell.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LegendCell Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Constructor

LegendCell Constructor |
 | See Also

Overload List

Name | Description
LegendCell () | Initializes a new instance of the LegendCell class
LegendCell (String) | Initializes a new instance of the LegendCell class with a text parameter that specifies the cell text or image name.
LegendCell (LegendCellType, String) | Initializes a new instance of the LegendCell class with the specified cell type and a text parameter that specifies the cell text or image name.
LegendCell (LegendCellType, String, ContentAlignment) | Initializes a new instance of the LegendCell class with the specified cell type, content alignment, and a text parameter that specifies the cell text or image name.

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Constructor ()

LegendCell Constructor () |
 | See Also

Initializes a new instance of the LegendCell class

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public LegendCell ()
public:
LegendCell ()
public LegendCell ()
public function LegendCell ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Constructor (String)

LegendCell Constructor (String) |
 | See Also

Initializes a new instance of the LegendCell class with a text parameter that specifies the cell text or image name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String _
)
public LegendCell (
    string text
)
public:
LegendCell (
    String^ text
)
public LegendCell (
    String text
)
public function LegendCell (
    text : String
)

Parameters

text

A string value that represent the cell text or image name, depending on the type of cell.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Constructor (LegendCellType, String)

LegendCell Constructor (LegendCellType, String) |
 | See Also

Initializes a new instance of the LegendCell class with the specified cell type and a text parameter that specifies the cell text or image name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    cellType As LegendCellType, _
    text As String _
)
public LegendCell (
    LegendCellType cellType,
    string text
)
public:
LegendCell (
    LegendCellType cellType,
    String^ text
)
public LegendCell (
    LegendCellType cellType,
    String text
)
public function LegendCell (
    cellType : LegendCellType,
    text : String
)

Parameters

cellType

A LegendCellType value that represents the legend cell type to be used.

text

A string value that represents the cell text or image name, depending on the type of cell.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Constructor (LegendCellType, String, ContentAlignment)

LegendCell Constructor (LegendCellType, String, ContentAlignment) |
 | See Also

Initializes a new instance of the LegendCell class with the specified cell type, content alignment, and a text parameter that specifies the cell text or image name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    cellType As LegendCellType, _
    text As String, _
    alignment As ContentAlignment _
)
public LegendCell (
    LegendCellType cellType,
    string text,
    ContentAlignment alignment
)
public:
LegendCell (
    LegendCellType cellType,
    String^ text,
    ContentAlignment alignment
)
public LegendCell (
    LegendCellType cellType,
    String text,
    ContentAlignment alignment
)
public function LegendCell (
    cellType : LegendCellType,
    text : String,
    alignment : ContentAlignment
)

Parameters

cellType

A LegendCellType value that represents the legend cell type to be used.

text

A string value representing the cell text or image name, depending on the type of cell.

alignment

A ContentAlignment value that represents the alignment of the legend cell contents.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Methods

LegendCell Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LegendCell Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Dispose Method

LegendCell.Dispose Method |
 | See Also

Overload List

Name | Description
LegendCell.Dispose () | (inherited from Dispose )
LegendCell.Dispose (Boolean) |

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Dispose Method (Boolean)

LegendCell.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell Properties

LegendCell Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend cell contents.
BackColor | Gets or sets the background color of the legend cell.
CellSpan | Gets or sets the number of horizontal cells used to draw the contents of the legend cell.
CellType | Gets or sets the legend cell type.
Font | Gets or sets the font for the legend cell.
ForeColor | Gets or sets the text color of the legend cell.
Image | Gets or sets the name of the image in a legend cell.
ImageSize | Gets or sets the size of the image in a legend cell.
ImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the image is drawn.
Legend | Gets the legend in which this cell belongs.
LegendItem | Gets the legend item in which this cell belongs.
MapAreaAttributes | Gets or sets the map area attributes of the legend cell.
Margins | Gets or sets the margins of the legend cell.
Name | Overridden. Gets or sets the name of the legend cell.
PostBackValue | Gets or sets a postback value that can be processed on a Chart.Click event.
SeriesSymbolSize | Gets or sets the size of the series symbol that is displayed in the legend cell.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the legend cell text.
ToolTip | Gets or sets the tooltip text for the legend cell.
Url | Gets or sets the URL target of the legend cell.

See Also

Reference

LegendCell Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Alignment Property

LegendCell.Alignment Property |
 | See Also

Gets or sets the alignment of the legend cell contents.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Alignment As ContentAlignment
public virtual ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the legend cell contents. The default value is MiddleCenter.

Remarks

The Alignment property is used to align text, series symbols or images within the legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.BackColor Property

LegendCell.BackColor Property |
 | See Also

Gets or sets the background color of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property BackColor As Color
public virtual Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value used to draw the legend cell's background.

Remarks

The BackColor property has the highest priority when setting the background color of any entity in the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.CellSpan Property

LegendCell.CellSpan Property |
 | See Also

Gets or sets the number of horizontal cells used to draw the contents of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CellSpan As Integer
public virtual int CellSpan { get; set; }
public:
virtual property int CellSpan {
    int get ();
    void set (int value);
}
/** @property */
public int get_CellSpan ()

/** @property */
public void set_CellSpan (int value)

public function get CellSpan () : int

public function set CellSpan (value : int)

Property Value

An integer value that represents the number of horizontal cells used to draw the legend cell contents. The default value is 1.

Remarks

If the cell contents must extend beyond the cell width, you can set the CellSpan property to the number of cells required to fit the contents. This property is most often used if you wish to add an extended header or title to the legend.

When this property is set to a value larger than 1, empty legend cells must be added in order to accommodate the contents of the extended legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.CellType Property

LegendCell.CellType Property |
 | See Also

Gets or sets the legend cell type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CellType As LegendCellType
public virtual LegendCellType CellType { get; set; }
public:
virtual property LegendCellType CellType {
    LegendCellType get ();
    void set (LegendCellType value);
}
/** @property */
public LegendCellType get_CellType ()

/** @property */
public void set_CellType (LegendCellType value)

public function get CellType () : LegendCellType

public function set CellType (value : LegendCellType)

Property Value

A LegendCellType enumeration value that represents the type that will be used to define the contents of the legend cell. The default value is Text.

Remarks

The CellType property determines the type of content that will be displayed in each individual legend cell. One of the following cell types must be specified:

  • Text: A string is specified using the Text property, and will be displayed in the legend cell.

  • SeriesSymbol: A series symbol is defined by the ImageStyle property in the LegendItem class. It will be displayed for the legend cell. Recall that a series symbol is a visual indicator—a line, rectangle or marker. When ImageStyle is set to Marker, all marker attributes of the custom item apply to the cell.

  • Image: An image is defined using the Image property and will be displayed in the legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Font Property

LegendCell.Font Property |
 | See Also

Gets or sets the font for the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Font As Font
public virtual Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object. The default value is "Microsoft Sans Serif, 8pt".

Remarks

The Font property can be used to set font properties of the legend cell.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.ForeColor Property

LegendCell.ForeColor Property |
 | See Also

Gets or sets the text color of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ForeColor As Color
public virtual Color ForeColor { get; set; }
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value used to draw the legend cell text. The default value is Empty.

Remarks

This property is only applicable if the CellType property is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Image Property

LegendCell.Image Property |
 | See Also

Gets or sets the name of the image in a legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Image As String
public virtual string Image { get; set; }
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the name of the image to be used in the legend cell.

Remarks

The image name should be a URL.

This property is only applicable if the CellType property is set to Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.ImageSize Property

LegendCell.ImageSize Property |
 | See Also

Gets or sets the size of the image in a legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ImageSize As Size
public virtual Size ImageSize { get; set; }
public:
virtual property Size ImageSize {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_ImageSize ()

/** @property */
public void set_ImageSize (Size value)

public function get ImageSize () : Size

public function set ImageSize (value : Size)

Property Value

A Size value that represents the size of the image. The default value is (0,0), which means the original size of the image will be used.

Remarks

The ImageSize property is used to explicitly set the width and height of the legend cell image.

This property is only applicable if the CellType property is set to Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.ImageTransparentColor Property

LegendCell.ImageTransparentColor Property |
 | See Also

Gets or sets a color which will be replaced with a transparent color when the image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ImageTransparentColor As Color
public virtual Color ImageTransparentColor { get; set; }
public:
virtual property Color ImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ImageTransparentColor ()

/** @property */
public void set_ImageTransparentColor (Color value)

public function get ImageTransparentColor () : Color

public function set ImageTransparentColor (value : Color)

Property Value

A Color value that is used as a transparent color in a legend cell image.

Remarks

The ImageTransparentColor property is only applicable if the CellType property is set to Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Legend Property

LegendCell.Legend Property |
 | See Also

Gets the legend in which this cell belongs.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overridable ReadOnly Property Legend As Legend
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public virtual Legend Legend { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property Legend^ Legend {
    Legend^ get ();
}
/** @property */
public Legend get_Legend ()

public function get Legend () : Legend

Property Value

A Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.LegendItem Property

LegendCell.LegendItem Property |
 | See Also

Gets the legend item in which this cell belongs.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable ReadOnly Property LegendItem As LegendItem
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual LegendItem LegendItem { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property LegendItem^ LegendItem {
    LegendItem^ get ();
}
/** @property */
public LegendItem get_LegendItem ()

public function get LegendItem () : LegendItem

Property Value

A LegendItem object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.MapAreaAttributes Property

LegendCell.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MapAreaAttributes As String
public virtual string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MapAreaAttributes ()

/** @property */
public void set_MapAreaAttributes (String value)

public function get MapAreaAttributes () : String

public function set MapAreaAttributes (value : String)

Property Value

A string value that represents the attributes of the legend cell's corresponding map area. The default value is a zero-length string.

Remarks

If you set the MapAreaAttributes property, a client-side image map will automatically be created. A map area will also be created, with its attribute string appended to the <map> tag that corresponds to the relevant legend cell.

The MapAreaAttributes property can be used in conjunction with the Url property to specify map area attributes, for example, target= _blank, as well as client-side event handlers, for example, OnClick="MyEvent()".

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

If the MapAreaAttributes property is set for both a series and a data point of that series, the data point property has precedence.

Special keywords may be used when setting this property, and each keyword will be replaced with some type of data from the applicable chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Margins Property

LegendCell.Margins Property |
 | See Also

Gets or sets the margins of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Margins As Margins
public virtual Margins Margins { get; set; }
public:
virtual property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}
/** @property */
public Margins get_Margins ()

/** @property */
public void set_Margins (Margins value)

public function get Margins () : Margins

public function set Margins (value : Margins)

Property Value

A Margins object that represents the top, bottom, left, and right values of the legend cell margins. The default values for top, bottom, left and right are "0,0,15,15".

Remarks

Margins are measured as a percentage of the font size for the legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Name Property

LegendCell.Name Property |
 | See Also

Gets or sets the name of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the legend cell.

Remarks

The name of the legend cell must be unique; otherwise an exception will be thrown.

The Name property can be used as the indexer when retrieving a LegendCell object from the LegendCellCollection.

If you set this property to a zero-length string, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.PostBackValue Property

LegendCell.PostBackValue Property |
 | See Also

Gets or sets a postback value that can be processed on a Chart.Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the postback value passed to a Chart.Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.SeriesSymbolSize Property

LegendCell.SeriesSymbolSize Property |
 | See Also

Gets or sets the size of the series symbol that is displayed in the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property SeriesSymbolSize As Size
public virtual Size SeriesSymbolSize { get; set; }
public:
virtual property Size SeriesSymbolSize {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_SeriesSymbolSize ()

/** @property */
public void set_SeriesSymbolSize (Size value)

public function get SeriesSymbolSize () : Size

public function set SeriesSymbolSize (value : Size)

Property Value

A Size object that represents the size of the series symbol as a percentage of the legend font size. The default values for the width and height of the symbol are 200 and 70, respectively.

Remarks

The size of the series symbol is measured as a percentage of the legend font size.

The SeriesSymbolSize property is only applicable if the CellType property is set to SeriesSymbol.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Text Property

LegendCell.Text Property |
 | See Also

Gets or sets the legend cell text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Text As String
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text for the legend cell. The default value is a zero-length string.

Remarks

The Text property is only applicable if the CellType property is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.ToolTip Property

LegendCell.ToolTip Property |
 | See Also

Gets or sets the tooltip text for the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ToolTip As String
public virtual string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip for the legend cell. The default value is a zero-length string.

Remarks

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

If the ToolTip property is set for both a legend item and a legend cell, the legend cell property has precedence.

This ToolTip property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCell.Url Property

LegendCell.Url Property |
 | See Also

Gets or sets the URL target of the legend cell.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Url As String
public virtual string Url { get; set; }
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Url ()

/** @property */
public void set_Url (String value)

public function get Url () : String

public function set Url (value : String)

Property Value

A string value that represents the destination URL or anchor point of the chart element. To use an absolute URL, start the string expression with either "http://" or "www.". If the string does not start with either of these prefixes it will be treated as a relative URL.

Remarks

If you set this property, a client-side image map will be automatically created. A map area will also be created with its Href attribute set to the specified anchor or URL.

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Attributes of the map area(s), for example, target=_blank, can be specified by using the MapAreaAttributes property.

The Url property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection Class

LegendCellCollection Class |
 | See Also Members

Stores legend cells in a LegendCellCollection object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendCellCollection
    Inherits ChartNamedElementCollection(Of LegendCell)
public class LegendCellCollection : ChartNamedElementCollection<LegendCell>
public ref class LegendCellCollection : public ChartNamedElementCollection<LegendCell^>
public class LegendCellCollection extends ChartNamedElementCollection<LegendCell>
public class LegendCellCollection extends ChartNamedElementCollection<LegendCell>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.LegendCellCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection Members

LegendCellCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Stores legend cells in a LegendCellCollection object.

The following tables list the members exposed by the LegendCellCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendCellCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection Methods

LegendCellCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendCellCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection.Add Method

LegendCellCollection.Add Method |
 | See Also

Overload List

Name | Description
LegendCellCollection.Add (LegendCell) | (inherited from Add )
LegendCellCollection.Add (LegendCellType, String, ContentAlignment) | Adds a legend cell with the specified cell type, text and alignment to the end of the collection.

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection.Add Method (LegendCellType, String, ContentAlignment)

LegendCellCollection.Add Method (LegendCellType, String, ContentAlignment) |
 | See Also

Adds a legend cell with the specified cell type, text and alignment to the end of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    cellType As LegendCellType, _
    text As String, _
    alignment As ContentAlignment _
) As Integer
public int Add (
    LegendCellType cellType,
    string text,
    ContentAlignment alignment
)
public:
int Add (
    LegendCellType cellType,
    String^ text,
    ContentAlignment alignment
)
public int Add (
    LegendCellType cellType,
    String text,
    ContentAlignment alignment
)
public function Add (
    cellType : LegendCellType,
    text : String,
    alignment : ContentAlignment
) : int

Parameters

cellType

A LegendCellType value representing the cell type.

text

A string value that represents either the cell text or its image name, depending on the value of the cellType parameter.

alignment

A ContentAlignment value that represents the cell content alignment.

Return Value

An integer value that represents the index of the newly added legend cell in the collection. The index is zero-based.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection.Insert Method

LegendCellCollection.Insert Method |
 | See Also

Overload List

Name | Description
LegendCellCollection.Insert (Int32, LegendCell) | (inherited from Insert )
LegendCellCollection.Insert (Int32, LegendCellType, String, ContentAlignment) | Inserts a legend cell with the specified cell type, text and alignment into the collection at a given location.

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection.Insert Method (Int32, LegendCellType, String, ContentAlignment)

LegendCellCollection.Insert Method (Int32, LegendCellType, String, ContentAlignment) |
 | See Also

Inserts a legend cell with the specified cell type, text and alignment into the collection at a given location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Insert ( _
    index As Integer, _
    cellType As LegendCellType, _
    text As String, _
    alignment As ContentAlignment _
)
public void Insert (
    int index,
    LegendCellType cellType,
    string text,
    ContentAlignment alignment
)
public:
void Insert (
    int index,
    LegendCellType cellType,
    String^ text,
    ContentAlignment alignment
)
public void Insert (
    int index,
    LegendCellType cellType,
    String text,
    ContentAlignment alignment
)
public function Insert (
    index : int,
    cellType : LegendCellType,
    text : String,
    alignment : ContentAlignment
)

Parameters

index

Index of the location to insert the object.

cellType

A LegendCellType value that represents the cell type.

text

A string value that represents either the cell text or its image name, depending on the value of the cellType parameter.

alignment

A ContentAlignment enumeration value that represents the alignment of the legend cell content.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellCollection Properties

LegendCellCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendCellCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Class

LegendCellColumn Class |
 | See Also Members

Represents a cell column in a legend, which is used to extend the functionality of the default legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendCellColumn
    Inherits ChartNamedElement
    Implements IChartMapArea
public class LegendCellColumn : ChartNamedElement, IChartMapArea
public ref class LegendCellColumn : public ChartNamedElement, IChartMapArea
public class LegendCellColumn extends ChartNamedElement implements IChartMapArea
public class LegendCellColumn extends ChartNamedElement implements IChartMapArea

Remarks

Any number of cell columns can be placed in any order, which gives you the flexibility to extend the abilities of the default legend entries.

The legend cell columns are only applicable to items that are automatically generated from series or data points.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.LegendCellColumn

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Members

LegendCellColumn Members |
 | See Also Constructors Methods Properties

Represents a cell column in a legend, which is used to extend the functionality of the default legend.

The following tables list the members exposed by the LegendCellColumn type.

Public Constructors

Name | Description
LegendCellColumn | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the legend column content alignment.
BackColor | Gets or sets the background color of the legend cell column.
ColumnType | Gets or sets the legend cell column type.
Font | Gets or sets the font for the legend column text.
ForeColor | Gets or sets the text color of the legend cell column.
HeaderAlignment | Gets or sets the horizontal text alignment of the legend cell column header.
HeaderBackColor | Gets or sets the background color for the legend cell column header.
HeaderFont | Gets or sets the font used in the legend column header.
HeaderForeColor | Gets or sets the color of the legend column header text (HeaderText property).
HeaderText | Gets or sets the text for the legend cell column header.
Legend | Gets the legend in which this legend cell column belongs.
MapAreaAttributes | Gets or sets the map area attributes of the legend cell column.
Margins | Gets or sets the margins of the legend cell column.
MaximumWidth | Gets or sets the maximum width of the legend cell column.
MinimumWidth | Gets or sets the minimum width of the legend cell column.
Name | Overridden. Gets or sets the name of the legend cell column.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
SeriesSymbolSize | Gets or sets the size of the series symbol displayed in a legend cell column.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the legend cell column.
ToolTip | Gets or sets the tooltip text for the legend cell column.
Url | Gets or sets the URL target of the legend cell columns automatically generated from a series or data point.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ShouldSerializeMargins | Determines whether the property should be serialized. For internal use only.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LegendCellColumn Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Constructor

LegendCellColumn Constructor |
 | See Also

Overload List

Name | Description
LegendCellColumn () | Initializes a new instance of the LegendCellColumn class.
LegendCellColumn (String, LegendCellColumnType, String) | Initializes a new instance of the LegendCellColumn class with the specified header text, column type and column cell text.
LegendCellColumn (String, LegendCellColumnType, String, ContentAlignment) | Initializes a new instance of the LegendCellColumn class with the specified header text, column type, column cell text and content alignment.

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Constructor ()

LegendCellColumn Constructor () |
 | See Also

Initializes a new instance of the LegendCellColumn class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public LegendCellColumn ()
public:
LegendCellColumn ()
public LegendCellColumn ()
public function LegendCellColumn ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Constructor (String, LegendCellColumnType, String)

LegendCellColumn Constructor (String, LegendCellColumnType, String) |
 | See Also

Initializes a new instance of the LegendCellColumn class with the specified header text, column type and column cell text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    headerText As String, _
    columnType As LegendCellColumnType, _
    text As String _
)
public LegendCellColumn (
    string headerText,
    LegendCellColumnType columnType,
    string text
)
public:
LegendCellColumn (
    String^ headerText,
    LegendCellColumnType columnType,
    String^ text
)
public LegendCellColumn (
    String headerText,
    LegendCellColumnType columnType,
    String text
)
public function LegendCellColumn (
    headerText : String,
    columnType : LegendCellColumnType,
    text : String
)

Parameters

headerText

Column header text.

columnType

A LegendCellColumnType enumeration value.

text

Column cell text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Constructor (String, LegendCellColumnType, String, ContentAlignment)

LegendCellColumn Constructor (String, LegendCellColumnType, String, ContentAlignment) |
 | See Also

Initializes a new instance of the LegendCellColumn class with the specified header text, column type, column cell text and content alignment.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    headerText As String, _
    columnType As LegendCellColumnType, _
    text As String, _
    alignment As ContentAlignment _
)
public LegendCellColumn (
    string headerText,
    LegendCellColumnType columnType,
    string text,
    ContentAlignment alignment
)
public:
LegendCellColumn (
    String^ headerText,
    LegendCellColumnType columnType,
    String^ text,
    ContentAlignment alignment
)
public LegendCellColumn (
    String headerText,
    LegendCellColumnType columnType,
    String text,
    ContentAlignment alignment
)
public function LegendCellColumn (
    headerText : String,
    columnType : LegendCellColumnType,
    text : String,
    alignment : ContentAlignment
)

Parameters

headerText

Column header text.

columnType

A LegendCellColumnType enumeration value.

text

Column cell text.

alignment

Column cell ContentAlignment.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Methods

LegendCellColumn Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ShouldSerializeMargins | Determines whether the property should be serialized. For internal use only.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LegendCellColumn Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Dispose Method

LegendCellColumn.Dispose Method |
 | See Also

Overload List

Name | Description
LegendCellColumn.Dispose () | (inherited from Dispose )
LegendCellColumn.Dispose (Boolean) |

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Dispose Method (Boolean)

LegendCellColumn.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.ShouldSerializeMargins Method

LegendCellColumn.ShouldSerializeMargins Method |
 | See Also

This method supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Determines whether the property should be serialized. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ShouldSerializeMargins As Boolean
public bool ShouldSerializeMargins ()
public:
bool ShouldSerializeMargins ()
public boolean ShouldSerializeMargins ()
public function ShouldSerializeMargins () : boolean

Return Value

True if the property should be serialized, otherwise false.

Remarks

For internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn Properties

LegendCellColumn Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the legend column content alignment.
BackColor | Gets or sets the background color of the legend cell column.
ColumnType | Gets or sets the legend cell column type.
Font | Gets or sets the font for the legend column text.
ForeColor | Gets or sets the text color of the legend cell column.
HeaderAlignment | Gets or sets the horizontal text alignment of the legend cell column header.
HeaderBackColor | Gets or sets the background color for the legend cell column header.
HeaderFont | Gets or sets the font used in the legend column header.
HeaderForeColor | Gets or sets the color of the legend column header text (HeaderText property).
HeaderText | Gets or sets the text for the legend cell column header.
Legend | Gets the legend in which this legend cell column belongs.
MapAreaAttributes | Gets or sets the map area attributes of the legend cell column.
Margins | Gets or sets the margins of the legend cell column.
MaximumWidth | Gets or sets the maximum width of the legend cell column.
MinimumWidth | Gets or sets the minimum width of the legend cell column.
Name | Overridden. Gets or sets the name of the legend cell column.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
SeriesSymbolSize | Gets or sets the size of the series symbol displayed in a legend cell column.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the legend cell column.
ToolTip | Gets or sets the tooltip text for the legend cell column.
Url | Gets or sets the URL target of the legend cell columns automatically generated from a series or data point.

See Also

Reference

LegendCellColumn Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Alignment Property

LegendCellColumn.Alignment Property |
 | See Also

Gets or sets the legend column content alignment.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Alignment As ContentAlignment
public virtual ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the legend cell contents. The default value is MiddleCenter.

Remarks

This property is used to align text or series symbols within the legend cell column.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.BackColor Property

LegendCellColumn.BackColor Property |
 | See Also

Gets or sets the background color of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property BackColor As Color
public virtual Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value used to draw the legend cell column background. The default value is Empty.

Remarks

This property overrides the BackColor property of the legend that the legend cell column belongs to. It also overrides the InterlacedRows property of the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.ColumnType Property

LegendCellColumn.ColumnType Property |
 | See Also

Gets or sets the legend cell column type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ColumnType As LegendCellColumnType
public virtual LegendCellColumnType ColumnType { get; set; }
public:
virtual property LegendCellColumnType ColumnType {
    LegendCellColumnType get ();
    void set (LegendCellColumnType value);
}
/** @property */
public LegendCellColumnType get_ColumnType ()

/** @property */
public void set_ColumnType (LegendCellColumnType value)

public function get ColumnType () : LegendCellColumnType

public function set ColumnType (value : LegendCellColumnType)

Property Value

A LegendCellColumnType enumeration value. This value represents the type that will be used to define the legend cell column contents. The default value is Text.

Remarks

This property determines the type of content that will be displayed in each individual legend cell column. There are two possible values:

  • Text: By default, the #LEGENDTEXT keyword is used to place the LegendText value in each cell column. However, you can use the Text property to set any keyword(s) that will be replaced by a value of the corresponding series.

  • SeriesSymbol: The legend cell will contain a series symbol, such as a rectangle, line, line with marker, or marker, of the same fill color as its corresponding series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Font Property

LegendCellColumn.Font Property |
 | See Also

Gets or sets the font for the legend column text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Font As Font
public virtual Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object. The default value is null.

Remarks

This property is only applicable when the LegendCellColumnType is set to Text, and a string value is defined for the Text property. You can use the Font property to set font properties of the legend cell column.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.ForeColor Property

LegendCellColumn.ForeColor Property |
 | See Also

Gets or sets the text color of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ForeColor As Color
public virtual Color ForeColor { get; set; }
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value used to draw the legend cell column text. The default value is Empty.

Remarks

This property is only applicable if the LegendCellColumnType is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.HeaderAlignment Property

LegendCellColumn.HeaderAlignment Property |
 | See Also

Gets or sets the horizontal text alignment of the legend cell column header.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property HeaderAlignment As StringAlignment
public StringAlignment HeaderAlignment { get; set; }
public:
property StringAlignment HeaderAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_HeaderAlignment ()

/** @property */
public void set_HeaderAlignment (StringAlignment value)

public function get HeaderAlignment () : StringAlignment

public function set HeaderAlignment (value : StringAlignment)

Property Value

A StringAlignment enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.HeaderBackColor Property

LegendCellColumn.HeaderBackColor Property |
 | See Also

Gets or sets the background color for the legend cell column header.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property HeaderBackColor As Color
public virtual Color HeaderBackColor { get; set; }
public:
virtual property Color HeaderBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_HeaderBackColor ()

/** @property */
public void set_HeaderBackColor (Color value)

public function get HeaderBackColor () : Color

public function set HeaderBackColor (value : Color)

Property Value

A Color value used to draw the background of the legend cell column header. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.HeaderFont Property

LegendCellColumn.HeaderFont Property |
 | See Also

Gets or sets the font used in the legend column header.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property HeaderFont As Font
public virtual Font HeaderFont { get; set; }
public:
virtual property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_HeaderFont ()

/** @property */
public void set_HeaderFont (Font value)

public function get HeaderFont () : Font

public function set HeaderFont (value : Font)

Property Value

A Font object. The default value is "Microsoft Sans Serif, 8pt, Bold".

Remarks

This property can be used to set font properties of the legend cell column header.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.HeaderForeColor Property

LegendCellColumn.HeaderForeColor Property |
 | See Also

Gets or sets the color of the legend column header text (HeaderText property).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property HeaderForeColor As Color
public virtual Color HeaderForeColor { get; set; }
public:
virtual property Color HeaderForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_HeaderForeColor ()

/** @property */
public void set_HeaderForeColor (Color value)

public function get HeaderForeColor () : Color

public function set HeaderForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.HeaderText Property

LegendCellColumn.HeaderText Property |
 | See Also

Gets or sets the text for the legend cell column header.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property HeaderText As String
public virtual string HeaderText { get; set; }
public:
virtual property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_HeaderText ()

/** @property */
public void set_HeaderText (String value)

public function get HeaderText () : String

public function set HeaderText (value : String)

Property Value

A string value that represents the legend cell column header text. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Legend Property

LegendCellColumn.Legend Property |
 | See Also

Gets the legend in which this legend cell column belongs.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable ReadOnly Property Legend As Legend
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Legend Legend { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Legend^ Legend {
    Legend^ get ();
}
/** @property */
public Legend get_Legend ()

public function get Legend () : Legend

Property Value

A Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.MapAreaAttributes Property

LegendCellColumn.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MapAreaAttributes As String
public virtual string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MapAreaAttributes ()

/** @property */
public void set_MapAreaAttributes (String value)

public function get MapAreaAttributes () : String

public function set MapAreaAttributes (value : String)

Property Value

A string value that represents the attributes of the map area that corresponds to the legend cell column. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Margins Property

LegendCellColumn.Margins Property |
 | See Also

Gets or sets the margins of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Overridable Property Margins As Margins
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public virtual Margins Margins { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
virtual property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}
/** @property */
public Margins get_Margins ()

/** @property */
public void set_Margins (Margins value)

public function get Margins () : Margins

public function set Margins (value : Margins)

Property Value

A Margins object that represents the top, bottom, left, and right values of the legend cell margins. The default values for top, bottom, left and right are "0,0,15,15".

Remarks

This property is measured as a percentage of the legend font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.MaximumWidth Property

LegendCellColumn.MaximumWidth Property |
 | See Also

Gets or sets the maximum width of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MaximumWidth As Integer
public virtual int MaximumWidth { get; set; }
public:
virtual property int MaximumWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaximumWidth ()

/** @property */
public void set_MaximumWidth (int value)

public function get MaximumWidth () : int

public function set MaximumWidth (value : int)

Property Value

An integer value that represents the maximum width of the legend cell column. The default value is minus one (-1), which means that the maximum width is automatically calculated.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.MinimumWidth Property

LegendCellColumn.MinimumWidth Property |
 | See Also

Gets or sets the minimum width of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MinimumWidth As Integer
public virtual int MinimumWidth { get; set; }
public:
virtual property int MinimumWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MinimumWidth ()

/** @property */
public void set_MinimumWidth (int value)

public function get MinimumWidth () : int

public function set MinimumWidth (value : int)

Property Value

An integer value that represents the minimum width of the legend cell column. The default value is minus one (-1), which means that the minimum width is automatically calculated.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Name Property

LegendCellColumn.Name Property |
 | See Also

Gets or sets the name of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the legend cell column.

Remarks

The name of the legend cell must be unique; otherwise an exception will be thrown.

The Name property can be used as the indexer when retrieving a LegendCellColumn object from the LegendCellColumnCollection.

If you set this property to a zero-length string, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.PostBackValue Property

LegendCellColumn.PostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the postback value that is passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.SeriesSymbolSize Property

LegendCellColumn.SeriesSymbolSize Property |
 | See Also

Gets or sets the size of the series symbol displayed in a legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property SeriesSymbolSize As Size
public virtual Size SeriesSymbolSize { get; set; }
public:
virtual property Size SeriesSymbolSize {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_SeriesSymbolSize ()

/** @property */
public void set_SeriesSymbolSize (Size value)

public function get SeriesSymbolSize () : Size

public function set SeriesSymbolSize (value : Size)

Property Value

A Size object that represents the size of the series symbol. The default values for the width and height of the symbol are 200 and 70, respectively.

Remarks

The size of the series symbol is measured as a percentage of the legend font size.

This property is only applicable if the LegendCellColumnType property is set to SeriesSymbol.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Text Property

LegendCellColumn.Text Property |
 | See Also

Gets or sets the text of the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Text As String
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text for the legend cell column. The default value is a zero-length string.

Remarks

This property is only applicable if the LegendCellColumnType is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.ToolTip Property

LegendCellColumn.ToolTip Property |
 | See Also

Gets or sets the tooltip text for the legend cell column.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property ToolTip As String
public virtual string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip for the legend cell column. The default value is a zero-length string.

Remarks

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

If the ToolTip property is set for both a legend item and a legend cell, the legend cell property has precedence.

This ToolTip property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumn.Url Property

LegendCellColumn.Url Property |
 | See Also

Gets or sets the URL target of the legend cell columns automatically generated from a series or data point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Url As String
public virtual string Url { get; set; }
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Url ()

/** @property */
public void set_Url (String value)

public function get Url () : String

public function set Url (value : String)

Property Value

A string value that represents the destination URL or anchor point of the chart element. To use an absolute URL start the string expression with either "http://" or "www.". If the string does not start with either of these prefixes it will be treated as a relative URL. The default value is azero-length string.

Remarks

If you set this property, a client-side image map will be automatically created. A map area will also be created with its Href attribute set to the specified anchor or URL.

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Attributes of the map area(s), for example, target=_blank, can be specified by using the MapAreaAttributes property.

The Url property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnCollection Class

LegendCellColumnCollection Class |
 | See Also Members

Stores LegendCellColumn objects, which are applied to default legend items.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendCellColumnCollection
    Inherits ChartNamedElementCollection(Of LegendCellColumn)
public class LegendCellColumnCollection : ChartNamedElementCollection<LegendCellColumn>
public ref class LegendCellColumnCollection : public ChartNamedElementCollection<LegendCellColumn^>
public class LegendCellColumnCollection extends ChartNamedElementCollection<LegendCellColumn>
public class LegendCellColumnCollection extends ChartNamedElementCollection<LegendCellColumn>

Remarks

The LegendCellColumnCollection class stores LegendCellColumn objects.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.LegendCellColumnCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumnCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnCollection Members

LegendCellColumnCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Stores LegendCellColumn objects, which are applied to default legend items.

The following tables list the members exposed by the LegendCellColumnCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendCellColumnCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnCollection Methods

LegendCellColumnCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendCellColumnCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnCollection.Dispose Method

LegendCellColumnCollection.Dispose Method |
 | See Also

Overload List

Name | Description
LegendCellColumnCollection.Dispose () | (inherited from Dispose )
LegendCellColumnCollection.Dispose (Boolean) |

See Also

Reference

LegendCellColumnCollection Class
LegendCellColumnCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnCollection.Dispose Method (Boolean)

LegendCellColumnCollection.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumnCollection Class
LegendCellColumnCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnCollection Properties

LegendCellColumnCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendCellColumnCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCellColumnType Enumeration

LegendCellColumnType Enumeration |
 | See Also

Specifies a legend cell column type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendCellColumnType
public enum LegendCellColumnType
public enum class LegendCellColumnType
public enum LegendCellColumnType
public enum LegendCellColumnType

Members

Member name | Description
SeriesSymbol | The legend cell column contains a series symbol such as a line, rectangle, or line with marker.
Text | The legend cell column contains text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LegendCellType Enumeration

LegendCellType Enumeration |
 | See Also

Specifies a legend cell type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendCellType
public enum LegendCellType
public enum class LegendCellType
public enum LegendCellType
public enum LegendCellType

Members

Member name | Description
Image | The legend cell contains an image.
SeriesSymbol | The legend cell contains a series symbol, such as a line or rectangle.
Text | The legend cell contains text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LegendCollection Class

LegendCollection Class |
 | See Also Members

Represents a collection of Legend objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendCollection
    Inherits ChartNamedElementCollection(Of Legend)
public class LegendCollection : ChartNamedElementCollection<Legend>
public ref class LegendCollection : public ChartNamedElementCollection<Legend^>
public class LegendCollection extends ChartNamedElementCollection<Legend>
public class LegendCollection extends ChartNamedElementCollection<Legend>

Remarks

The LegendCollection class is implemented as the Legends collection property of the root Chart object.

Legend objects can be appended, inserted or removed from the collection at either design time or run time.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.LegendCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCollection Members

LegendCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of Legend objects.

The following tables list the members exposed by the LegendCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCollection Methods

LegendCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendCollection.Add Method

LegendCollection.Add Method |
 | See Also

Overload List

Name | Description
LegendCollection.Add (Legend) | (inherited from Add )
LegendCollection.Add (String) | Adds the specified Legend object to the end of the collection.

See Also

Reference

LegendCollection Class
LegendCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCollection.Add Method (String)

LegendCollection.Add Method (String) |
 | See Also

Adds the specified Legend object to the end of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As Legend
public Legend Add (
    string name
)
public:
Legend^ Add (
    String^ name
)
public Legend Add (
    String name
)
public function Add (
    name : String
) : Legend

Parameters

name

The name of the legend to be added.

Return Value

A string value that represents the index of the added item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCollection Class
LegendCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendCollection Properties

LegendCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendImageStyle Enumeration

LegendImageStyle Enumeration |
 | See Also

Specifies the style to apply to the symbol for a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendImageStyle
public enum LegendImageStyle
public enum class LegendImageStyle
public enum LegendImageStyle
public enum LegendImageStyle

Members

Member name | Description
Line | The symbol will be a line.
Marker | The symbol will be a marker.
Rectangle | The symbol will be a rectangle.

Remarks

The LegendImageStyle enumeration represents the style that is used for a legend item, and is applied to the symbol for that item.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LegendItem Class

LegendItem Class |
 | See Also Members

Represents a legend item, which is stored in the LegendItemsCollection class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendItem
    Inherits ChartNamedElement
    Implements IChartMapArea
public class LegendItem : ChartNamedElement, IChartMapArea
public ref class LegendItem : public ChartNamedElement, IChartMapArea
public class LegendItem extends ChartNamedElement implements IChartMapArea
public class LegendItem extends ChartNamedElement implements IChartMapArea

Remarks

The LegendItem class represents a legend item, which can be either a default or custom item:

  • Default legend items are automatically inserted into the legend for either data series or data points. Default entries for pie and doughnut charts represent the plotted data points, whereas entries for all other chart types represent the plotted series. By default, these legend entries use the data point or series color for the symbol color, and the name of the series or data point for the legend item text. Default legend items can be customized or deleted at run time by using the CustomizeLegend event of the Chart control.

  • Custom legend items have user-defined text, symbol color, and so forth. Unlike the default entries, they are not connected with the plotted data. Custom legend items can be added at either design time or run time, using the CustomItems property of the Legend object.

Legend symbols can be rectangles, lines or markers, depending on the ImageStyle property setting of a LegendItem object.

The text of a custom legend item is determined by the Name property.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.LegendItem

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem Members

LegendItem Members |
 | See Also Constructors Methods Properties

Represents a legend item, which is stored in the LegendItemsCollection class.

The following tables list the members exposed by the LegendItem type.

Public Constructors

Name | Description
LegendItem | Overloaded.
Top

Public Properties

Name | Description
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend item. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend item.
BackImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the background image is drawn.
BackSecondaryColor | Gets or sets the secondary color of a legend item.
BorderColor | Gets or sets the border color of a legend item.
BorderDashStyle | Gets or sets the border style of a legend item.
BorderWidth | Gets or sets the border width of a legend item.
Cells | Gets the collection of cells in the legend item.
Color | Gets or sets the color of a legend item.
Enabled | Gets or sets a flag that indicates whether the legend item is enabled.
Image | Gets or sets the image that will be displayed for a legend item symbol.
ImageStyle | Gets or sets the display style of the legend item image.
Legend | Gets or sets the Legend object associated with this legend item.
MapAreaAttributes | Gets or sets the map area attributes of a legend item.
MarkerBorderColor | Gets or sets the border color of the markers, if used.
MarkerBorderWidth | Gets or sets the border width of the markers, if used. Measured in pixels.
MarkerColor | Gets or sets the color of the markers, if used.
MarkerImage | Gets or sets a marker image.
MarkerImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the legend item markers, if used.
MarkerStyle | Gets or sets a legend item marker style. Also used to enable or disable the display of markers.
Name | Overridden. Gets or sets the name of the legend item.
PostBackValue | Gets or sets the postback value which can be processed on a Click event.
SeparatorColor | Gets or sets the color of the legend item separator.
SeparatorType | Gets or sets the separator style of the legend item.
SeriesName | Gets or sets the name of the Series associated with a default legend item.
SeriesPointIndex | Gets or sets the index of a DataPoint object associated with a default legend item.
ShadowColor | Gets or sets the shadow color of a legend item.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a legend item.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip of the legend item.
Url | Gets or sets the destination URL of a legend item.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LegendItem Class
System.Web.UI.DataVisualization.Charting Namespace


LegendItem Constructor

LegendItem Constructor |
 | See Also

Overload List

Name | Description
LegendItem () | Initializes a new instance of the LegendItem class.
LegendItem (String, Color, String) | Initializes a new instance of the LegendItem class with the specified name, color and image path.

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem Constructor ()

LegendItem Constructor () |
 | See Also

Initializes a new instance of the LegendItem class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public LegendItem ()
public:
LegendItem ()
public LegendItem ()
public function LegendItem ()

Remarks

Use this constructor to create and initialize a new instance of the LegendItem class.

Note that you can also add custom legend items using the Add and Insert methods associated with the CustomItems collection property of the Legend object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem Constructor (String, Color, String)

LegendItem Constructor (String, Color, String) |
 | See Also

Initializes a new instance of the LegendItem class with the specified name, color and image path.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String, _
    color As Color, _
    image As String _
)
public LegendItem (
    string name,
    Color color,
    string image
)
public:
LegendItem (
    String^ name,
    Color color,
    String^ image
)
public LegendItem (
    String name,
    Color color,
    String image
)
public function LegendItem (
    name : String,
    color : Color,
    image : String
)

Parameters

name

Name of the legend item.

color

Color of the legend item.

image

Path of the image to be displayed for the legend item.

Remarks

Only the image or color parameter needs to be specified. If both are specified, the image parameter has precedence.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem Methods

LegendItem Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LegendItem Class
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Dispose Method

LegendItem.Dispose Method |
 | See Also

Overload List

Name | Description
LegendItem.Dispose () | (inherited from Dispose )
LegendItem.Dispose (Boolean) |

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Dispose Method (Boolean)

LegendItem.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem Properties

LegendItem Properties |
 | See Also

Public Properties

Name | Description
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend item. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend item.
BackImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the background image is drawn.
BackSecondaryColor | Gets or sets the secondary color of a legend item.
BorderColor | Gets or sets the border color of a legend item.
BorderDashStyle | Gets or sets the border style of a legend item.
BorderWidth | Gets or sets the border width of a legend item.
Cells | Gets the collection of cells in the legend item.
Color | Gets or sets the color of a legend item.
Enabled | Gets or sets a flag that indicates whether the legend item is enabled.
Image | Gets or sets the image that will be displayed for a legend item symbol.
ImageStyle | Gets or sets the display style of the legend item image.
Legend | Gets or sets the Legend object associated with this legend item.
MapAreaAttributes | Gets or sets the map area attributes of a legend item.
MarkerBorderColor | Gets or sets the border color of the markers, if used.
MarkerBorderWidth | Gets or sets the border width of the markers, if used. Measured in pixels.
MarkerColor | Gets or sets the color of the markers, if used.
MarkerImage | Gets or sets a marker image.
MarkerImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the legend item markers, if used.
MarkerStyle | Gets or sets a legend item marker style. Also used to enable or disable the display of markers.
Name | Overridden. Gets or sets the name of the legend item.
PostBackValue | Gets or sets the postback value which can be processed on a Click event.
SeparatorColor | Gets or sets the color of the legend item separator.
SeparatorType | Gets or sets the separator style of the legend item.
SeriesName | Gets or sets the name of the Series associated with a default legend item.
SeriesPointIndex | Gets or sets the index of a DataPoint object associated with a default legend item.
ShadowColor | Gets or sets the shadow color of a legend item.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a legend item.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip of the legend item.
Url | Gets or sets the destination URL of a legend item.

See Also

Reference

LegendItem Class
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BackGradientStyle Property

LegendItem.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a legend item. Also determines whether a gradient is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a title will display a gradient, and to determine the orientation of the gradient if one is used.

This property is only implemented if the ImageStyle property is set to Rectangle.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

  • Use the Color property to set the primary color.

  • Use the BackGradientStyle property to set the secondary color.

  • Use this BackGradientStyle property to set the desired gradient style.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BackHatchStyle Property

LegendItem.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note:
The color of hatching lines is determined by the BackSecondaryColor property.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BackImageTransparentColor Property

LegendItem.BackImageTransparentColor Property |
 | See Also

Gets or sets a color which will be replaced with a transparent color when the background image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent.

Remarks

This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BackSecondaryColor Property

LegendItem.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of background with hatching or gradient fill. The default value is Empty.

Remarks

The BackSecondaryColor property is one of several related properties that determine the secondary background color of many Chart objects; it is used when gradient colors are being applied.

This property is only implemented if the ImageStyle property is set to Rectangle.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the legend item.

To use gradient colors for a legend cell's background:

To use gradient colors:

  • Use the Color property to set the primary color.

  • Use the BackGradientStyle property to set the secondary color.

  • Use the BackGradientStyle property to set the desired gradient style.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BorderColor Property

LegendItem.BorderColor Property |
 | See Also

Gets or sets the border color of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

Note:
If you use a marker for a custom legend item. this property will set the border color of the marker. However, if the MarkerBorderColor property is also set, its value has precedence.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BorderDashStyle Property

LegendItem.BorderDashStyle Property |
 | See Also

Gets or sets the border style of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the legend item.

Remarks

This property determines the line style used for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.BorderWidth Property

LegendItem.BorderWidth Property |
 | See Also

Gets or sets the border width of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the width, in pixels, of the legend item border.

Remarks

The BorderWidth property can also be used to set the width of lines when, for example, custom legend items are displayed with a Line style.

Note This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Cells Property

LegendItem.Cells Property |
 | See Also

Gets the collection of cells in the legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Cells As LegendCellCollection
public LegendCellCollection Cells { get; }
public:
property LegendCellCollection^ Cells {
    LegendCellCollection^ get ();
}
/** @property */
public LegendCellCollection get_Cells ()

public function get Cells () : LegendCellCollection

Property Value

A LegendCellCollection object.

Remarks

A legend item consists of one or more legend cells, each represented by a LegendCell object and stored in a LegendCellCollection.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Color Property

LegendItem.Color Property |
 | See Also

Gets or sets the color of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Color As Color
public Color Color { get; set; }
public:
property Color Color {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_Color ()

/** @property */
public void set_Color (Color value)

public function get Color () : Color

public function set Color (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

This Color property is one several related properties that get or set the color of many chart elements; it can be set to any ARGB (alpha, red, green, blue) value.

If this property is set for both a data point and its series, the data point color will have precedence. The series color will only be used for data points that do not define their own color.

If a custom legend item uses a marker, this property will determine the marker color. However, if the MarkerColor property is set, its value then has precedence.

This property will be ignored if the Image property specifies an image to be used for the legend item symbol.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Enabled Property

LegendItem.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether the legend item is enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if the legend item is enabled, otherwise false. The default value is true.

Remarks

This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Image Property

LegendItem.Image Property |
 | See Also

Gets or sets the image that will be displayed for a legend item symbol.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Image As String
public string Image { get; set; }
public:
property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the URL of an image file. The default value is an empty string.

Remarks

This property determines the image file to be used for the LegendItem symbol.

The path can be an absolute or a relative URL.

If you set a background image, that image will be displayed regardless of the ImageStyle property setting.

Set the BackImageTransparentColor property to enable one color used by the image to appear transparent.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.ImageStyle Property

LegendItem.ImageStyle Property |
 | See Also

Gets or sets the display style of the legend item image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ImageStyle As LegendImageStyle
public LegendImageStyle ImageStyle { get; set; }
public:
property LegendImageStyle ImageStyle {
    LegendImageStyle get ();
    void set (LegendImageStyle value);
}
/** @property */
public LegendImageStyle get_ImageStyle ()

/** @property */
public void set_ImageStyle (LegendImageStyle value)

public function get ImageStyle () : LegendImageStyle

public function set ImageStyle (value : LegendImageStyle)

Property Value

A LegendImageStyle enumeration value.

Remarks

These styles determine how the item's corresponding symbol will be displayed.

A Line style can be combined with a Marker style. To accomplish this, first set the ImageStyle property to Line. Then use the MarkerImage property to specify a marker image, or the MarkerStyle property to specify a marker style. The resulting symbol will be a combination of a line and an image or marker.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Legend Property

LegendItem.Legend Property |
 | See Also

Gets or sets the Legend object associated with this legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Legend As Legend
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Legend Legend { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Legend^ Legend {
    Legend^ get ();
}
/** @property */
public Legend get_Legend ()

public function get Legend () : Legend

Property Value

A Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MapAreaAttributes Property

LegendItem.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value that represents the attributes of corresponding map area for the legend item.

Remarks

If you set the MapAreaAttributes property, a client-side image map will automatically be created. A map area will also be created, with its attribute string appended to the <map> tag that corresponds to the chart object for which this property is being set.

For example, setting the Target attribute using this property and the Url property of the first data point will result in HTML code that is similar to the following code:

<img id="Chart1" usemap="#Chart1ImageMap" src="ChartPic_000002.jpg?6735e83b-f0cd-4225-8be4-047695a61040" border="0" />...<map name="Chart1ImageMap"><area shape="rect" href="http://www.SomeDomain.ca" COORDS="69,120,106,309" target=_blank></map>

Because the entire string is appended to the <map> tag, multiple attributes should be separated with a space.

The MapAreaAttributes property can be used in conjunction with the Url property to specify map area attributes, for example, target= _blank, as well as client-side event handlers, for example, OnClick="MyEvent()".

Setting this property will have no effect if the IsMapEnabled property is set to false. Its default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Special keywords may be used when setting this property; each keyword will be replaced with some type of data from the applicable chart element. Refer to the following table for a listing of all available keywords:

Keyword | Replaced by
#VALX | X-value of the data point.
#VAL, #VALY, #VALY2, #VALY3… | Y-values of the data point.
#SER | Series name.
#LABEL | Data point label.
#INDEX | Data point index.
#PERCENT | Percentage of the data point Y-value.
#TOTAL | Total of all Y-values in the series.
#LEGENDTEXT | Legend text.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerBorderColor Property

LegendItem.MarkerBorderColor Property |
 | See Also

Gets or sets the border color of the markers, if used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerBorderColor As Color
public Color MarkerBorderColor { get; set; }
public:
property Color MarkerBorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerBorderColor ()

/** @property */
public void set_MarkerBorderColor (Color value)

public function get MarkerBorderColor () : Color

public function set MarkerBorderColor (value : Color)

Property Value

A Color value that represents the ARGB (alpha, red, green, blue) color of a marker border.

Remarks

To use markers, set the MarkerStyle property to a value other than None.

Note that markers will not be applied to pie, doughnut, and any stacked chart types.

For custom legends, the BorderColor property will also set the border color of markers. The MarkerBorderColor property setting has precedence over the BorderColor property setting.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerBorderWidth Property

LegendItem.MarkerBorderWidth Property |
 | See Also

Gets or sets the border width of the markers, if used. Measured in pixels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerBorderWidth As Integer
public int MarkerBorderWidth { get; set; }
public:
property int MarkerBorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerBorderWidth ()

/** @property */
public void set_MarkerBorderWidth (int value)

public function get MarkerBorderWidth () : int

public function set MarkerBorderWidth (value : int)

Property Value

An integer value. The default value is one (1) pixel.

Remarks

This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerColor Property

LegendItem.MarkerColor Property |
 | See Also

Gets or sets the color of the markers, if used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerColor As Color
public Color MarkerColor { get; set; }
public:
property Color MarkerColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerColor ()

/** @property */
public void set_MarkerColor (Color value)

public function get MarkerColor () : Color

public function set MarkerColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerImage Property

LegendItem.MarkerImage Property |
 | See Also

Gets or sets a marker image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerImage As String
public string MarkerImage { get; set; }
public:
property String^ MarkerImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MarkerImage ()

/** @property */
public void set_MarkerImage (String value)

public function get MarkerImage () : String

public function set MarkerImage (value : String)

Property Value

A string value that represents the URL of an image file.

Remarks

Represents a path to an image file, which can be an absolute or relative URL.

To use markers, set the MarkerStyle property to a value other than None.

The MarkerImage property takes precedence over the MarkerColor property.

A marker image can be any valid graphics file supported by .NET Framework, including icons.

To set one color of the marker image to be transparent, use the MarkerImageTransparentColor property.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerImageTransparentColor Property

LegendItem.MarkerImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the marker image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerImageTransparentColor As Color
public Color MarkerImageTransparentColor { get; set; }
public:
property Color MarkerImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerImageTransparentColor ()

/** @property */
public void set_MarkerImageTransparentColor (Color value)

public function get MarkerImageTransparentColor () : Color

public function set MarkerImageTransparentColor (value : Color)

Property Value

A T:System.Drawing.Color value that represents an ARGB (alpha, red, green, blue) color.

Remarks

The MarkerImageTransparentColor property is used to select one color in a marker image that will be displayed as transparent.

You can set this property to any valid ARGB (alpha, red, green, blue) value.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerSize Property

LegendItem.MarkerSize Property |
 | See Also

Gets or sets the size of the legend item markers, if used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerSize As Integer
public int MarkerSize { get; set; }
public:
property int MarkerSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerSize ()

/** @property */
public void set_MarkerSize (int value)

public function get MarkerSize () : int

public function set MarkerSize (value : int)

Property Value

An integer expression that represents the height and width of the plotting area of markers, in pixels. The default value is 5 pixels.

Remarks

To use markers, set the MarkerStyle property to a value other than None.

Note that markers will not be applied to data points of pie, doughnut and any stacked chart types.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.MarkerStyle Property

LegendItem.MarkerStyle Property |
 | See Also

Gets or sets a legend item marker style. Also used to enable or disable the display of markers.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerStyle As MarkerStyle
public MarkerStyle MarkerStyle { get; set; }
public:
property MarkerStyle MarkerStyle {
    MarkerStyle get ();
    void set (MarkerStyle value);
}
/** @property */
public MarkerStyle get_MarkerStyle ()

/** @property */
public void set_MarkerStyle (MarkerStyle value)

public function get MarkerStyle () : MarkerStyle

public function set MarkerStyle (value : MarkerStyle)

Property Value

A MarkerStyle integer enumeration. The default value is None.

Remarks

To disable markers, set this property to None.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Name Property

LegendItem.Name Property |
 | See Also

Gets or sets the name of the legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the name of the legend item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.PostBackValue Property

LegendItem.PostBackValue Property |
 | See Also

Gets or sets the postback value which can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the postback value passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.SeparatorColor Property

LegendItem.SeparatorColor Property |
 | See Also

Gets or sets the color of the legend item separator.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SeparatorColor As Color
public Color SeparatorColor { get; set; }
public:
property Color SeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_SeparatorColor ()

/** @property */
public void set_SeparatorColor (Color value)

public function get SeparatorColor () : Color

public function set SeparatorColor (value : Color)

Property Value

A Color value used to draw the color of the legend item separator. The default value is Black.

Remarks

This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.SeparatorType Property

LegendItem.SeparatorType Property |
 | See Also

Gets or sets the separator style of the legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property SeparatorType As LegendSeparatorStyle
public LegendSeparatorStyle SeparatorType { get; set; }
public:
property LegendSeparatorStyle SeparatorType {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_SeparatorType ()

/** @property */
public void set_SeparatorType (LegendSeparatorStyle value)

public function get SeparatorType () : LegendSeparatorStyle

public function set SeparatorType (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.SeriesName Property

LegendItem.SeriesName Property |
 | See Also

Gets or sets the name of the Series associated with a default legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property SeriesName As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string SeriesName { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property String^ SeriesName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_SeriesName ()

/** @property */
public void set_SeriesName (String value)

public function get SeriesName () : String

public function set SeriesName (value : String)

Property Value

A string value that determines the name of the series associated with a default legend item. The default value is a zero-length string.

Remarks

This property should only be used in the CustomizeLegend event, to determine which data series a default legend entry represents.

The SeriesName property applies to all charts except pie and sphere charts; their default legend items correspond to plotted data points, and not to plotted series. When you deal with pie and sphere charts, use the SeriesPointIndex property instead.

This property should not be set by the developer.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.SeriesPointIndex Property

LegendItem.SeriesPointIndex Property |
 | See Also

Gets or sets the index of a DataPoint object associated with a default legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property SeriesPointIndex As Integer
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int SeriesPointIndex { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property int SeriesPointIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_SeriesPointIndex ()

/** @property */
public void set_SeriesPointIndex (int value)

public function get SeriesPointIndex () : int

public function set SeriesPointIndex (value : int)

Property Value

An integer value that represents the location of the default legend's associated data point in a zero-based index. All chart types except for pie and doughnut charts will return a negative one (-1).

Remarks

This property should only be used in the CustomizeLegend event to determine the DataPoint object that is represented by a default pie or sphere chart legend entry.

Chart types other than pie or sphere charts will return a negative one (-1), because the default legend items correspond to plotted series, and not plotted data points. Use the SeriesName property for these chart types.

This property should not be set by the developer.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.ShadowColor Property

LegendItem.ShadowColor Property |
 | See Also

Gets or sets the shadow color of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

Gets or sets the shadow color of several chart elements, and can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try using a color of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Note This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.ShadowOffset Property

LegendItem.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset, in pixels, of the relevant chart element.

Remarks

To implement shadowing, use a value other than zero (0). A positive value will result in a shadow that shifts down and to the right. A negative value will result in a shadow that shifts up and to the left.

Note This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.ToolTip Property

LegendItem.ToolTip Property |
 | See Also

Gets or sets the tooltip of the legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string value that represents the tooltip for the legend item.

Remarks

If you set the ToolTip property, a client-side image map will automatically be created. A map area will also be created with its Title attribute set to the specified tooltip string. The map area will use the dimensions that correspond to the title. For example, if the ToolTip property is set for a data point, then HTML code similar to the following will be generated at run time:

<MAP NAME="Chart1ImageMap"><AREA SHAPE="rect" Title="First Data Value = 19" COORDS="69,120,106,309"></MAP>

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

This property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItem.Url Property

LegendItem.Url Property |
 | See Also

Gets or sets the destination URL of a legend item.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value that represents the destination URL of a legend item. To use an absolute URL, start the string expression with either "http://" or "www.". If the string does not start with either of these prefixes it will be treated as a relative URL.

Remarks

If you set this property, a client-side image map will be automatically created. A map area will also be created with its HREF attribute set to the specified anchor or URL. This map area will also use the dimensions that correspond to the relevant chart element. For example, if the Url property is set for a data point, then HTML code similar to the following will be generated at run time:

<img id="Chart1" USEMAP="#Chart1ImageMap" src="ChartPic_000002.jpg?6735e83b-f0cd-4225-8be4-047695a61040" border="0" />...<MAP NAME="Chart1ImageMap"><AREA SHAPE="rect" HREF="http://www.healthquotes.ca" COORDS= "69,120,106,309"></MAP>

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Attributes of the map area(s), for example, TARGET=_Blank, can be specified by using the MapAreaAttributes property.

The Url property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemOrder Enumeration

LegendItemOrder Enumeration |
 | See Also

Specifies the order in which items are added to the legend.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendItemOrder
public enum LegendItemOrder
public enum class LegendItemOrder
public enum LegendItemOrder
public enum LegendItemOrder

Members

Member name | Description
Auto | The chart automatically determines the order in which items are added to the legend.
ReversedSeriesOrder | Items are added to the legend in the reverse order of items added to the chart series.
SameAsSeriesOrder | Items are added to the legend in the same order as items added to the chart series.

Remarks

By default, the chart determines the order in which items are added to the legend. All chart types except stacked area, stacked bar and stacked column charts will always place items in the legend in the same order as how items are ordered in the SeriesCollection. By default, stacked charts will always show items in the reversed order as how they are ordered in the series collection.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection Class

LegendItemsCollection Class |
 | See Also Members

Represents a collection of LegendItem objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LegendItemsCollection
    Inherits ChartElementCollection(Of LegendItem)
public class LegendItemsCollection : ChartElementCollection<LegendItem>
public ref class LegendItemsCollection : public ChartElementCollection<LegendItem^>
public class LegendItemsCollection extends ChartElementCollection<LegendItem>
public class LegendItemsCollection extends ChartElementCollection<LegendItem>

Remarks

The LegendItemsCollection class represents a collection of LegendItem objects, which in turn represent items in a legend.

This collection class is exposed in two ways:

  • As the CustomItems object property of the Legend object, which can be used to add, delete or modify custom legend items. The term "custom" refers to legend items that have user-defined text, symbol color, and so forth. In comparison, "default" legend items are items that are automatically inserted into the legend and represent a data series or data point. Default legend item entries for pie and doughnut charts represent the plotted data points, whereas item entries for all other chart types represent the plotted series. The CustomItems property is available at both design time and run time.

  • In the CustomizeLegend event, as the LegendItems property of the CustomizeLegendEventArgs parameter. The LegendItems property stores both default legend items and custom legend items that have been added to the Chart control at design time. Legend items can be modified or deleted; in addition, their order can be changed.

To add legend items to the collection, use one of the overloaded Add and Insert methods in this class.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.LegendItemsCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection Members

LegendItemsCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of LegendItem objects.

The following tables list the members exposed by the LegendItemsCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
Reverse | Reverses the order of items in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendItemsCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection Methods

LegendItemsCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
Reverse | Reverses the order of items in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendItemsCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Add Method

LegendItemsCollection.Add Method |
 | See Also

Overload List

Name | Description
LegendItemsCollection.Add (LegendItem) | (inherited from Add )
LegendItemsCollection.Add (Color, String) | Adds a custom LegendItem object with the specified text and symbol color to the end of the collection.
LegendItemsCollection.Add (String, String) | Adds a custom LegendItem object with the specified image to the end of the collection.

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Add Method (Color, String)

LegendItemsCollection.Add Method (Color, String) |
 | See Also

Adds a custom LegendItem object with the specified text and symbol color to the end of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    color As Color, _
    text As String _
) As Integer
public int Add (
    Color color,
    string text
)
public:
int Add (
    Color color,
    String^ text
)
public int Add (
    Color color,
    String text
)
public function Add (
    color : Color,
    text : String
) : int

Parameters

color

The symbol color of the legend item.

text

The legend item text.

Return Value

An integer that represents the location in the zero-based index where the item was inserted into the collection.

Remarks

Appends a custom legend item with the specified text and symbol color to the end of the collection.

To add a custom legend item that uses an image for its symbol, call the Add method.

To insert a custom LegendItem object into the collection, use one of the Insert methods in this class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Add Method (String, String)

LegendItemsCollection.Add Method (String, String) |
 | See Also

Adds a custom LegendItem object with the specified image to the end of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    image As String, _
    text As String _
) As Integer
public int Add (
    string image,
    string text
)
public:
int Add (
    String^ image,
    String^ text
)
public int Add (
    String image,
    String text
)
public function Add (
    image : String,
    text : String
) : int

Parameters

image

The absolute or relative URL of the image file to be used for the legend item symbol.

text

The legend item text.

Return Value

An integer that represents the location in the zero-based index where the item was inserted into the collection.

Remarks

Appends a custom legend item to the collection with the specified text and image to be used as the symbol for the legend item.

To add a custom legend item that uses a color for its symbol, call the Add method.

To insert a LegendItem object into the collection use one of the Insert methods in this class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Insert Method

LegendItemsCollection.Insert Method |
 | See Also

Overload List

Name | Description
LegendItemsCollection.Insert (Int32, LegendItem) | (inherited from Insert )
LegendItemsCollection.Insert (Int32, Color, String) | Inserts a LegendItem object with the specified text and symbol color into the collection at the specified location.
LegendItemsCollection.Insert (Int32, String, String) | Inserts a LegendItem object with the specified text and symbol image into the collection at the specified location.

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Insert Method (Int32, Color, String)

LegendItemsCollection.Insert Method (Int32, Color, String) |
 | See Also

Inserts a LegendItem object with the specified text and symbol color into the collection at the specified location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Insert ( _
    index As Integer, _
    color As Color, _
    text As String _
)
public void Insert (
    int index,
    Color color,
    string text
)
public:
void Insert (
    int index,
    Color color,
    String^ text
)
public void Insert (
    int index,
    Color color,
    String text
)
public function Insert (
    index : int,
    color : Color,
    text : String
)

Parameters

index

The location in the zero-based index where the LegendItem object is to be inserted.

color

The symbol color of the legend item.

text

The legend item text.

Remarks

Inserts a custom legend item into the collection at the specified location using the specified text and symbol color.

To insert a legend item that uses an image for its symbol, use the Insert method.

Use the Add method to append a LegendItem object that uses a color for its symbol to the end if the collection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Insert Method (Int32, String, String)

LegendItemsCollection.Insert Method (Int32, String, String) |
 | See Also

Inserts a LegendItem object with the specified text and symbol image into the collection at the specified location.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Insert ( _
    index As Integer, _
    image As String, _
    text As String _
)
public void Insert (
    int index,
    string image,
    string text
)
public:
void Insert (
    int index,
    String^ image,
    String^ text
)
public void Insert (
    int index,
    String image,
    String text
)
public function Insert (
    index : int,
    image : String,
    text : String
)

Parameters

index

The location in the zero-based index where the LegendItem object is to be inserted.

image

The absolute or relative URL of the image file to be used for the legend item symbol.

text

The legend item text.

Remarks

Inserts a custom legend item into the collection at the specified location using the specified text and image for the symbol.

To insert a legend item that uses a color for its symbol, use the Insert method.

Use the Add method to append a LegendItem object with a symbol image to the end if the collection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection.Reverse Method

LegendItemsCollection.Reverse Method |
 | See Also

Reverses the order of items in the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Reverse
public void Reverse ()
public:
void Reverse ()
public void Reverse ()
public function Reverse ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
System.Web.UI.DataVisualization.Charting Namespace


LegendItemsCollection Properties

LegendItemsCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendItemsCollection Class
System.Web.UI.DataVisualization.Charting Namespace


LegendSeparatorStyle Enumeration

LegendSeparatorStyle Enumeration |
 | See Also

Specifies the styles for legend separator lines.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendSeparatorStyle
public enum LegendSeparatorStyle
public enum class LegendSeparatorStyle
public enum LegendSeparatorStyle
public enum LegendSeparatorStyle

Members

Member name | Description
DashLine | Legend separator is a dashed line.
DotLine | Legend separator is a dotted line.
DoubleLine | Legend separator is a double line.
GradientLine | Legend separator is a solid line with a gradient on the ends.
Line | Legend separator is a solid line.
None | No separator will be shown.
ThickGradientLine | Legend separator is a thick solid line with a gradient on the ends.
ThickLine | Legend separator is a thick solid line.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LegendStyle Enumeration

LegendStyle Enumeration |
 | See Also

Specifies the legend style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendStyle
public enum LegendStyle
public enum class LegendStyle
public enum LegendStyle
public enum LegendStyle

Members

Member name | Description
Column | Legend items are displayed using one column and multiple rows.
Row | Legend items are displayed using multiple columns and one row.
Table | Legend items are displayed using multiple columns and multiple rows.

Remarks

The LegendStyle enumeration represents a legend style, and is used in conjunction with the LegendStyle property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LegendTableStyle Enumeration

LegendTableStyle Enumeration |
 | See Also

Specifies the legend table style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LegendTableStyle
public enum LegendTableStyle
public enum class LegendTableStyle
public enum LegendTableStyle
public enum LegendTableStyle

Members

Member name | Description
Auto | The legend table style is automatically determined by the Chart control.
Tall | Legend items will be fit vertically within the legend. This style is preferred when Docking is set to Left or Right.
Wide | Legend items will be fit horizontally within the legend. This style is preferred when Docking is set to Top or Bottom.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LightStyle Enumeration

LightStyle Enumeration |
 | See Also

Specifies a lighting style for a three-dimensional (3D) chart area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LightStyle
public enum LightStyle
public enum class LightStyle
public enum LightStyle
public enum LightStyle

Members

Member name | Description
None | No lighting is applied.
Realistic | A realistic lighting style is applied, where the hue of all chart area elements changes depending on the amount of rotation.
Simplistic | A simplistic lighting style is applied, where the hue of all chart area elements is fixed.

Remarks

The LightStyle enumeration is used with the LightStyle property to set the lighting style of a 3D chart area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LineAnchorCapStyle Enumeration

LineAnchorCapStyle Enumeration |
 | See Also

Specifies the shape—that is, the anchor cap—to draw on the point end of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration LineAnchorCapStyle
public enum LineAnchorCapStyle
public enum class LineAnchorCapStyle
public enum LineAnchorCapStyle
public enum LineAnchorCapStyle

Members

Member name | Description
Arrow | Anchor cap will be drawn with an arrowhead.
Diamond | Anchor cap will be drawn with a diamond-shaped end.
None | Anchor cap will not be drawn.
Round | Anchor cap will be drawn with a round end.
Square | Anchor cap will be drawn with a square head.

Remarks

The LineAnchorCapStyle enumeration represents the shape to be drawn on the point end of the label callout line. It is used in conjunction with the CalloutStyle and the CalloutLineAnchorCapStyle properties. If a callout line is not used, this enumeration will have no effect.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation Class

LineAnnotation Class |
 | See Also Members

Represents a line annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class LineAnnotation
    Inherits Annotation
public class LineAnnotation : Annotation
public ref class LineAnnotation : public Annotation
public class LineAnnotation extends Annotation
public class LineAnnotation extends Annotation

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.LineAnnotation
System.Web.UI.DataVisualization.Charting.HorizontalLineAnnotation
System.Web.UI.DataVisualization.Charting.VerticalLineAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation Members

LineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a line annotation.

The following tables list the members exposed by the LineAnnotation type.

Public Constructors

Name | Description
LineAnnotation | Initializes a new instance of the LineAnnotation class.
Top

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the line annotation type.
AnchorAlignment | Overridden. Gets or sets the position alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the type of annotation. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the line annotation type.
BackGradientStyle | Overridden. This property is not applicable to the line annotation type.
BackHatchStyle | Overridden. This property is not applicable to the line annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the line annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the line annotation type.
ForeColor | Overridden. This property is not applicable to the line annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. This property is not applicable to the line annotation type.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation Constructor

LineAnnotation Constructor |
 | See Also

Initializes a new instance of the LineAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public LineAnnotation ()
public:
LineAnnotation ()
public LineAnnotation ()
public function LineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation Methods

LineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation Properties

LineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the line annotation type.
AnchorAlignment | Overridden. Gets or sets the position alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the type of annotation. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the line annotation type.
BackGradientStyle | Overridden. This property is not applicable to the line annotation type.
BackHatchStyle | Overridden. This property is not applicable to the line annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the line annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the line annotation type.
ForeColor | Overridden. This property is not applicable to the line annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. This property is not applicable to the line annotation type.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

LineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.Alignment Property

LineAnnotation.Alignment Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Alignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment Alignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.AnchorAlignment Property

LineAnnotation.AnchorAlignment Property |
 | See Also

Gets or sets the position alignment of an annotation to the anchor point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property AnchorAlignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment AnchorAlignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public override function get AnchorAlignment () : ContentAlignment

public override function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the annotation alignment to the anchor point.

Remarks

The annotation must be anchored using either AnchorDataPoint, or the AnchorX and AnchorY properties. Its X and Y properties must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.AnnotationType Property

LineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the type of annotation. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.BackColor Property

LineAnnotation.BackColor Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.BackGradientStyle Property

LineAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.BackHatchStyle Property

LineAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.BackSecondaryColor Property

LineAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.EndCap Property

LineAnnotation.EndCap Property |
 | See Also

Gets or sets a style for the anchor cap at the end of the annotation line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property EndCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle EndCap { get; set; }
public:
virtual property LineAnchorCapStyle EndCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_EndCap ()

/** @property */
public void set_EndCap (LineAnchorCapStyle value)

public function get EndCap () : LineAnchorCapStyle

public function set EndCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value that represents the style to apply to the anchor cap at the end of the line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.Font Property

LineAnnotation.Font Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.ForeColor Property

LineAnnotation.ForeColor Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A T:System.Drawing.Color enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.IsInfinitive Property

LineAnnotation.IsInfinitive Property |
 | See Also

Gets or sets a flag that indicates whether an infinite line should be drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property IsInfinitive As Boolean
public virtual bool IsInfinitive { get; set; }
public:
virtual property bool IsInfinitive {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsInfinitive ()

/** @property */
public void set_IsInfinitive (boolean value)

public function get IsInfinitive () : boolean

public function set IsInfinitive (value : boolean)

Property Value

True if a line should be drawn infinitely through two points provided, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.IsSizeAlwaysRelative Property

LineAnnotation.IsSizeAlwaysRelative Property |
 | See Also

Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property IsSizeAlwaysRelative As Boolean
public override bool IsSizeAlwaysRelative { get; set; }
public:
virtual property bool IsSizeAlwaysRelative {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_IsSizeAlwaysRelative ()

/** @property */
public void set_IsSizeAlwaysRelative (boolean value)

public override function get IsSizeAlwaysRelative () : boolean

public override function set IsSizeAlwaysRelative (value : boolean)

Property Value

True if the Width and Height of an annotation are always in chart relative coordinates, otherwise false.

Remarks

The width and height of an annotation may be set in relative chart or in axes coordinates. By default, relative chart coordinates are used. To use axes coordinates for the annotation size, set the IsSizeAlwaysRelative property to false. Then anchor the annotation to a data point or set the AxisX or AxisY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.StartCap Property

LineAnnotation.StartCap Property |
 | See Also

Gets or sets a style for the anchor cap at the start of an annotation line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property StartCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle StartCap { get; set; }
public:
virtual property LineAnchorCapStyle StartCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_StartCap ()

/** @property */
public void set_StartCap (LineAnchorCapStyle value)

public function get StartCap () : LineAnchorCapStyle

public function set StartCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value that represents the style to apply to the anchor cap at the start of the line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


LineAnnotation.TextStyle Property

LineAnnotation.TextStyle Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Class

MapArea Class |
 | See Also Members

Represents a map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class MapArea
    Inherits ChartNamedElement
    Implements IChartMapArea
public class MapArea : ChartNamedElement, IChartMapArea
public ref class MapArea : public ChartNamedElement, IChartMapArea
public class MapArea extends ChartNamedElement implements IChartMapArea
public class MapArea extends ChartNamedElement implements IChartMapArea

Remarks

The MapArea class represents a map area of a client-side image map, and corresponds to an HTML <AREA> tag.

The MapArea objects are stored in the MapAreasCollection class.

There are two types of MapArea objects:

  • Map areas that are automatically created when a chart element—for example, a data point, series, legend item or strip line object—has a non-empty ToolTip, Url or MapAreaAttributes property; note that other HTML elements that are required for a client-side image map are also created. In this case, the dimensions and location of a map area are automatically determined by the chart element. Use the CustomizeMapAreas event of the root Chart object to delete or modify these map areas at run time.

  • Custom map areas that have a user-defined shape and coordinates. Use the MapAreas property of the Chart object to add these custom map areas at design time or run time.

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map using the previously described MapArea objects, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

For custom MapArea objects, the Shape property determines the shape, and the Coordinates property determines the location of the map area.

Tooltips, hyperlinks, or attributes, such as Target=_Blank or OnClick="javascript:MyJavaScriptFunction()", can be set for all map areas.

Use the IsCustom property to determine whether a map area is a custom MapArea object; that is, whether it has user-defined shape and coordinates.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.MapArea

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Members

MapArea Members |
 | See Also Constructors Methods Properties

Represents a map area.

The following tables list the members exposed by the MapArea type.

Public Constructors

Name | Description
MapArea | Overloaded.
Top

Public Properties

Name | Description
Coordinates | Gets or sets the coordinates of a MapArea object.
IsCustom | Gets or sets a flag that indicates whether the map area is custom.
MapAreaAttributes | Gets or sets the attributes of the map area.
Name | Overridden. Gets or sets the name of the map area.
PostBackValue | Gets or sets the postback value which can be processed on a Click event.
Shape | Gets or sets the shape of a MapArea object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip for the map area.
Url | Gets or sets the destination URL or anchor point of the map area.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

MapArea Class
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor

MapArea Constructor |
 | See Also

Overload List

Name | Description
MapArea () | Initializes a new instance of the MapArea class.
MapArea (String, GraphicsPath) | Initializes a new instance of the MapArea class with the specified URL and GraphicsPath object.
MapArea (String, RectangleF) | Initializes a new instance of the MapArea class with the specified URL and RectangleF structure.
MapArea (MapAreaShape, String, Single[]) | Initializes a new instance of the MapArea class with the specified shape, URL and coordinates.
MapArea (String, String, String, String, GraphicsPath, Object) | Initializes a new instance of the MapArea class with the specified tooltip text, URL, attributes, postback value, path and tag.
MapArea (String, String, String, String, RectangleF, Object) | Initializes a new instance of the MapArea class with the specified tooltip text, URL, attributes, postback value, rectangle coordinates and tag.
MapArea (MapAreaShape, String, String, String, String, Single[], Object) | Initializes a new instance of the MapArea class with the specified shape, tooltip text, URL, attributes, postback value, coordinates and tag.

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor ()

MapArea Constructor () |
 | See Also

Initializes a new instance of the MapArea class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public MapArea ()
public:
MapArea ()
public MapArea ()
public function MapArea ()

Remarks

This constructor can be used to create and initialize a new instance of the MapArea class.

However, an easier way to create a custom MapArea object is to use one of the overloaded Add or Insert methods of the MapAreasCollection class.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor (String, GraphicsPath)

MapArea Constructor (String, GraphicsPath) |
 | See Also

Initializes a new instance of the MapArea class with the specified URL and GraphicsPath object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    url As String, _
    path As GraphicsPath _
)
public MapArea (
    string url,
    GraphicsPath path
)
public:
MapArea (
    String^ url,
    GraphicsPath^ path
)
public MapArea (
    String url,
    GraphicsPath path
)
public function MapArea (
    url : String,
    path : GraphicsPath
)

Parameters

url

The destination URL or anchor point of the map area.

path

A GraphicsPath object that defines the shape of the map area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor (String, RectangleF)

MapArea Constructor (String, RectangleF) |
 | See Also

Initializes a new instance of the MapArea class with the specified URL and RectangleF structure.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    url As String, _
    rect As RectangleF _
)
public MapArea (
    string url,
    RectangleF rect
)
public:
MapArea (
    String^ url,
    RectangleF rect
)
public MapArea (
    String url,
    RectangleF rect
)
public function MapArea (
    url : String,
    rect : RectangleF
)

Parameters

url

The destination URL or anchor point of the map area.

rect

A RectangleF structure that defines the shape of the rectangular map area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor (MapAreaShape, String, Single[])

MapArea Constructor (MapAreaShape, String, Single[]) |
 | See Also

Initializes a new instance of the MapArea class with the specified shape, URL and coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    shape As MapAreaShape, _
    url As String, _
    coordinates As Single() _
)
public MapArea (
    MapAreaShape shape,
    string url,
    float[] coordinates
)
public:
MapArea (
    MapAreaShape shape,
    String^ url,
    array<float>^ coordinates
)
public MapArea (
    MapAreaShape shape,
    String url,
    float[] coordinates
)
public function MapArea (
    shape : MapAreaShape,
    url : String,
    coordinates : float[]
)

Parameters

shape

The shape of the map area.

url

The destination URL or anchor point of the map area.

coordinates

An array of coordinates that determine the location of the circle, rectangle or polygon. The type of shape that is being used determines the type of coordinates required.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor (String, String, String, String, GraphicsPath, Object)

MapArea Constructor (String, String, String, String, GraphicsPath, Object) |
 | See Also

Initializes a new instance of the MapArea class with the specified tooltip text, URL, attributes, postback value, path and tag.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    toolTip As String, _
    url As String, _
    attributes As String, _
    postBackValue As String, _
    path As GraphicsPath, _
    tag As Object _
)
public MapArea (
    string toolTip,
    string url,
    string attributes,
    string postBackValue,
    GraphicsPath path,
    Object tag
)
public:
MapArea (
    String^ toolTip,
    String^ url,
    String^ attributes,
    String^ postBackValue,
    GraphicsPath^ path,
    Object^ tag
)
public MapArea (
    String toolTip,
    String url,
    String attributes,
    String postBackValue,
    GraphicsPath path,
    Object tag
)
public function MapArea (
    toolTip : String,
    url : String,
    attributes : String,
    postBackValue : String,
    path : GraphicsPath,
    tag : Object
)

Parameters

toolTip

Tool tip.

url

Jump URL.

attributes
postBackValue
path

Area coordinates as graphic path

tag

The tag.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor (String, String, String, String, RectangleF, Object)

MapArea Constructor (String, String, String, String, RectangleF, Object) |
 | See Also

Initializes a new instance of the MapArea class with the specified tooltip text, URL, attributes, postback value, rectangle coordinates and tag.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    toolTip As String, _
    url As String, _
    attributes As String, _
    postBackValue As String, _
    rect As RectangleF, _
    tag As Object _
)
public MapArea (
    string toolTip,
    string url,
    string attributes,
    string postBackValue,
    RectangleF rect,
    Object tag
)
public:
MapArea (
    String^ toolTip,
    String^ url,
    String^ attributes,
    String^ postBackValue,
    RectangleF rect,
    Object^ tag
)
public MapArea (
    String toolTip,
    String url,
    String attributes,
    String postBackValue,
    RectangleF rect,
    Object tag
)
public function MapArea (
    toolTip : String,
    url : String,
    attributes : String,
    postBackValue : String,
    rect : RectangleF,
    tag : Object
)

Parameters

toolTip

Tool tip.

url

Jump URL.

attributes
postBackValue
rect

The rectangle coordinates.

tag

The tag.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Constructor (MapAreaShape, String, String, String, String, Single[], Object)

MapArea Constructor (MapAreaShape, String, String, String, String, Single[], Object) |
 | See Also

Initializes a new instance of the MapArea class with the specified shape, tooltip text, URL, attributes, postback value, coordinates and tag.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    shape As MapAreaShape, _
    toolTip As String, _
    url As String, _
    attributes As String, _
    postBackValue As String, _
    coordinates As Single(), _
    tag As Object _
)
public MapArea (
    MapAreaShape shape,
    string toolTip,
    string url,
    string attributes,
    string postBackValue,
    float[] coordinates,
    Object tag
)
public:
MapArea (
    MapAreaShape shape,
    String^ toolTip,
    String^ url,
    String^ attributes,
    String^ postBackValue,
    array<float>^ coordinates,
    Object^ tag
)
public MapArea (
    MapAreaShape shape,
    String toolTip,
    String url,
    String attributes,
    String postBackValue,
    float[] coordinates,
    Object tag
)
public function MapArea (
    shape : MapAreaShape,
    toolTip : String,
    url : String,
    attributes : String,
    postBackValue : String,
    coordinates : float[],
    tag : Object
)

Parameters

shape

The shape of the map area.

toolTip

The tool tip.

url

The URL.

attributes
postBackValue
coordinates

The coordinates.

tag

The tag.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea Methods

MapArea Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

MapArea Class
System.Web.UI.DataVisualization.Charting Namespace


MapArea Properties

MapArea Properties |
 | See Also

Public Properties

Name | Description
Coordinates | Gets or sets the coordinates of a MapArea object.
IsCustom | Gets or sets a flag that indicates whether the map area is custom.
MapAreaAttributes | Gets or sets the attributes of the map area.
Name | Overridden. Gets or sets the name of the map area.
PostBackValue | Gets or sets the postback value which can be processed on a Click event.
Shape | Gets or sets the shape of a MapArea object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip for the map area.
Url | Gets or sets the destination URL or anchor point of the map area.

See Also

Reference

MapArea Class
System.Web.UI.DataVisualization.Charting Namespace


MapArea.Coordinates Property

MapArea.Coordinates Property |
 | See Also

Gets or sets the coordinates of a MapArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Coordinates As Single()
public float[] Coordinates { get; set; }
public:
property array<float>^ Coordinates {
    array<float>^ get ();
    void set (array<float>^ value);
}
/** @property */
public float[] get_Coordinates ()

/** @property */
public void set_Coordinates (float[] value)

public function get Coordinates () : float[]

public function set Coordinates (value : float[])

Property Value

An array of coordinates that is dependent on the shape of the map area.

Remarks

The Coordinates property is usually used to set the coordinates of a custom map area object that has a user-defined shape and coordinates.

The coordinates that must be specified for a custom map area depend on the shape of the map area:

  • Circle. Three coordinates must be provided: "x1, y1, r", where "x1, y2" are the coordinates of the center of the circle, and "r" is the radius of the circle.

  • Rectangle. Four coordinates must be provided: "x1, y1, x2, y2", where "x1, y1" are the coordinates of the upper-left corner of the rectangle and "x2, y2" are the coordinates of the lower-right corner of the rectangle.

  • Polygon. Two or more x and y pairs must be provided "x1, y1, x2, y2...xn, yn", where each "x, y" pair contains the coordinates of one vertex of the polygon.

When setting coordinates, use the relative coordinate system of the chart, where the top-left corner of the chart image is "0,0" and the bottom-right corner of the image is "100,100".

After the shape and coordinates are defined for the map area, the ToolTip, Url and/or MapAreaAttributes properties can be used to specify a particular user interaction.

Note the following:

  • A client-side image map will only be created at run time if the IsMapEnabled property of the root Chart object is true, which is the default.

  • To create an image map by adding a MapArea object to the map areas collection, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but a special technique must be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.IsCustom Property

MapArea.IsCustom Property |
 | See Also

Gets or sets a flag that indicates whether the map area is custom.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property IsCustom As Boolean
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool IsCustom { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property bool IsCustom {
    bool get ();
}
/** @property */
public boolean get_IsCustom ()

public function get IsCustom () : boolean

Property Value

True if the map area is custom, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.MapAreaAttributes Property

MapArea.MapAreaAttributes Property |
 | See Also

Gets or sets the attributes of the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value that represents the attributes of the map area that corresponds to a particular chart element.

Remarks

If you set this property, a client-side image map will be automatically created, and a map area will be created with the attribute string appended to the <MAP> tag that corresponds to the Chart object that this property is being set for. For example, setting the Target attribute using this property and setting the Url property of the first data point will result in HTML code that is similar to the following:

<img id="Chart1" USEMAP="#Chart1ImageMap" src="ChartPic_000002.jpg?6735e83b-f0cd-4225-8be4-047695a61040" border="0" />...<MAP NAME="Chart1ImageMap"><AREA SHAPE="rect" HREF="http://www.SomeDomain.ca" COORDS="69,120,106,309" Target=_Blank></MAP>

Because the entire string is appended to the <MAP> tag, multiple attributes should be separated with a space.

The MapAreaAttributes property can be used in conjunction with the Url property to specify map area attributes such as Target= _Blank, as well as client-side event handlers such as OnClick="MyEvent()".

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Special keywords can be used when you set this property. Each keyword will be replaced with some type of data from the applicable chart element. Refer to the following table for a list of all available keywords:

Keyword | Replaced by
#VALX | X-value of the data point.
#VAL, #VALY, #VALY2, #VALY3… | Y-values of the data point.
#SER | Series name.
#LABEL | Data point label.
#INDEX | Data point index.
#PERCENT | Percentage of the data point Y-value.
#TOTAL | Total of all Y-values in the series.
#LEGENDTEXT | Legend text.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.Name Property

MapArea.Name Property |
 | See Also

Gets or sets the name of the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string Name { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.PostBackValue Property

MapArea.PostBackValue Property |
 | See Also

Gets or sets the postback value which can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the postback value passed to Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.Shape Property

MapArea.Shape Property |
 | See Also

Gets or sets the shape of a MapArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Shape As MapAreaShape
public MapAreaShape Shape { get; set; }
public:
property MapAreaShape Shape {
    MapAreaShape get ();
    void set (MapAreaShape value);
}
/** @property */
public MapAreaShape get_Shape ()

/** @property */
public void set_Shape (MapAreaShape value)

public function get Shape () : MapAreaShape

public function set Shape (value : MapAreaShape)

Property Value

A MapAreaShape enumeration value that determines the shape of a map area object.

Remarks

This property is usually used to set the shape of a custom map area object, which has a user-defined shape and coordinates.

The shape of the custom map area determines the type of coordinates that must be specified, and available shapes are circles, rectangles and polygons.

When retrieving the shapes of MapArea objects that are stored in the MapAreasCollection, any shape that is not a rectangle or a circle will be considered a polygon. For example, a custom map area can be added to the map areas collection using a GraphicsPath object as a parameter, which allows any type of shape to be used. If the Shape property of this particular MapArea object is retrieved, it will return a Polygon.

After the shape and coordinates of a map area are defined, the ToolTip, Urland/or MapAreaAttributes properties can be used to specify a particular user interaction.

Note the following:

  • A client-side image map will only be created at run-time if the IsMapEnabled property of the root Chart object is true, which is the default.

  • To create an image map by adding a MapArea object to the map areas collection the RenderType property of the Chart object MUST be RenderType.ImageTag. It is possible to create an image map when using binary streaming, but a special technique must be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.ToolTip Property

MapArea.ToolTip Property |
 | See Also

Gets or sets the tooltip for the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string value that represents the tooltip of the chart element.

Remarks

Setting this property will automatically result in a client-side image map being created, and a map area will be created with the Title attribute set to the specified tooltip string. The map area will use the dimensions that correspond to the relevant chart element. For example, if the ToolTip property is set for a data point, then HTML code similar to the following code will be generated at run time:

<MAP NAME="Chart1ImageMap"><AREA SHAPE="rect" Title="First Data Value = 19" COORDS="69,120,106,309"></MAP>

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

This property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapArea.Url Property

MapArea.Url Property |
 | See Also

Gets or sets the destination URL or anchor point of the map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value that represents the destination URL or anchor point of the map area. To use an absolute URL, start the string expression with either "http://" or "www.". If the string does not start with either of these prefixes, it will be treated as a relative URL.

Remarks

When you set this property, a client-side image map will automatically be created, and a map area will be created with the HREF attribute set to the specified anchor or URL. This map area will also use the dimensions that correspond to the relevant chart element. For example, if the HREF property is set for a data point, then HTML code similar to the following will be generated at run time:

&lt;img id="Chart1" USEMAP="#Chart1ImageMap" src="ChartPic_000002.jpg?6735e83b-f0cd-4225-8be4-047695a61040" border="0" /&gt;<BR>...<BR>&lt;MAP NAME="Chart1ImageMap"&gt;<BR>&lt;AREA SHAPE="rect" HREF="http://www.healthquotes.ca" COORDS= "69,120,106,309"&gt;<BR>&lt;/MAP&gt;

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Attributes of the map area(s), such as TARGET=-Blank, can be specified by using the MapAreaAttributes property.

This property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapArea Class
MapArea Members
System.Web.UI.DataVisualization.Charting Namespace


MapAreasCollection Class

MapAreasCollection Class |
 | See Also Members

Represents a collection of MapArea objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class MapAreasCollection
    Inherits ChartElementCollection(Of MapArea)
public class MapAreasCollection : ChartElementCollection<MapArea>
public ref class MapAreasCollection : public ChartElementCollection<MapArea^>
public class MapAreasCollection extends ChartElementCollection<MapArea>
public class MapAreasCollection extends ChartElementCollection<MapArea>

Remarks

The MapAreasCollection class represents a collection of MapArea objects, which in turn represent map areas of a client-side image map, such as HTML <AREA> tags.

This class is used in two ways:

  • As the MapAreas property of the root Chart object, which is used for custom map areas. These custom map areas have a user-defined shape and coordinates, and can be added at either design time or at run time using the overloaded M:System.Web.UI.DataVisualization.MapAreasCollection.Add or M:System.Web.UI.DataVisualization.MapAreasCollection.Insert methods.

  • In the CustomizeMapAreas event, as the MapAreaItems property of the CustomizeMapAreasEventArgs parameter. This MapAreaItems property stores T:System.Web.UI.DataVisualization.Charting.MapArea objects that have automatically been created for a chart object (map areas are automatically created when an applicable chart element, such as a data point, series, legend item or stripline object, has a non-empty ToolTip, Url or MapAreaAttributes property). In this case the dimensions and location of a map area are determined by the chart element. The MapAreaItems property enables you to delete or modify these automatically generated map areas, and can also be used to add custom map areas.

A client-side image map will only be created at run time if the IsMapEnabled property of the root Chart object is true. This is the default.

Important To create an image map using the previously described MapArea objects, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but a special technique must be used.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.MapAreasCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapAreasCollection Members
System.Web.UI.DataVisualization.Charting Namespace


MapAreasCollection Members

MapAreasCollection Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

Represents a collection of MapArea objects.

The following tables list the members exposed by the MapAreasCollection type.

Public Constructors

Name | Description
MapAreasCollection | Initializes a new instance of the MapAreasCollection class.
Top

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

MapAreasCollection Class
System.Web.UI.DataVisualization.Charting Namespace


MapAreasCollection Constructor

MapAreasCollection Constructor |
 | See Also

Initializes a new instance of the MapAreasCollection class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public MapAreasCollection ()
public:
MapAreasCollection ()
public MapAreasCollection ()
public function MapAreasCollection ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

MapAreasCollection Class
MapAreasCollection Members
System.Web.UI.DataVisualization.Charting Namespace


MapAreasCollection Methods

MapAreasCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

MapAreasCollection Class
System.Web.UI.DataVisualization.Charting Namespace


MapAreasCollection Properties

MapAreasCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

MapAreasCollection Class
System.Web.UI.DataVisualization.Charting Namespace


MapAreaShape Enumeration

MapAreaShape Enumeration |
 | See Also

Specifies the shape of a map area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration MapAreaShape
public enum MapAreaShape
public enum class MapAreaShape
public enum MapAreaShape
public enum MapAreaShape

Members

Member name | Description
Circle | The shape of the map area is circular.
Polygon | The shape of the map area is polygonal.
Rectangle | The shape of the map area is rectangular.

Remarks

The MapAreaShape enumeration represents the shape of a MapArea object. This enumeration is usually used to set the shape of a custom map area. A custom map area has user-defined coordinates and shape, as opposed to a map area that represents a chart element, which has a shape that is determined by the element it represents.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Margins Class

Margins Class |
 | See Also Members

Represents the margins for various chart elements.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Margins
public class Margins
public ref class Margins
public class Margins
public class Margins

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.Margins

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins Members

Margins Members |
 | See Also Constructors Methods Properties

Represents the margins for various chart elements.

The following tables list the members exposed by the Margins type.

Public Constructors

Name | Description
Margins | Overloaded. Initializes a new instance of the Margins class.
Top

Public Properties

Name | Description
Bottom | Gets or sets the bottom margin.
Left | Gets or sets the left margin.
Right | Gets or sets the right margin.
Top | Gets or sets the top margin.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden. Determines whether the specified object is equal to the current object.
GetHashCode | Overridden. Gets the hash code for the Margins object.
GetType | (inherited from Object )
IsEmpty | Determines whether the margins are empty.
ReferenceEquals | (inherited from Object )
ToRectangleF | Converts a Margins object to a RectangleF object.
ToString | Overridden. Converts a Margins object to its string representation.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Margins Class
System.Web.UI.DataVisualization.Charting Namespace


Margins Constructor

Margins Constructor |
 | See Also

Initializes a new instance of the Margins class.

Overload List

Name | Description
Margins () | Initializes a new instance of the Margins class.
Margins (Int32, Int32, Int32, Int32) | Initializes a new instance of the Margins class with the specified top, bottom, left and right coordinates of the margin.

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins Constructor ()

Margins Constructor () |
 | See Also

Initializes a new instance of the Margins class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Margins ()
public:
Margins ()
public Margins ()
public function Margins ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins Constructor (Int32, Int32, Int32, Int32)

Margins Constructor (Int32, Int32, Int32, Int32) |
 | See Also

Initializes a new instance of the Margins class with the specified top, bottom, left and right coordinates of the margin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    top As Integer, _
    bottom As Integer, _
    left As Integer, _
    right As Integer _
)
public Margins (
    int top,
    int bottom,
    int left,
    int right
)
public:
Margins (
    int top,
    int bottom,
    int left,
    int right
)
public Margins (
    int top,
    int bottom,
    int left,
    int right
)
public function Margins (
    top : int,
    bottom : int,
    left : int,
    right : int
)

Parameters

top

Top margin.

bottom

Bottom margin.

left

Left margin.

right

Right margin.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins Methods

Margins Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden. Determines whether the specified object is equal to the current object.
GetHashCode | Overridden. Gets the hash code for the Margins object.
GetType | (inherited from Object )
IsEmpty | Determines whether the margins are empty.
ReferenceEquals | (inherited from Object )
ToRectangleF | Converts a Margins object to a RectangleF object.
ToString | Overridden. Converts a Margins object to its string representation.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Margins Class
System.Web.UI.DataVisualization.Charting Namespace


Margins.Equals Method

Margins.Equals Method |
 | See Also

Determines whether the specified object is equal to the current object.

Overload List

Name | Description
Margins.Equals (Object) | Determines whether the specified object is equal to the current object.
Margins.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.Equals Method (Object)

Margins.Equals Method (Object) |
 | See Also

Determines whether the specified object is equal to the current object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

The object to compare with the current object.

Return Value

True if the specified object is equal to the current object, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.GetHashCode Method

Margins.GetHashCode Method |
 | See Also

Gets the hash code for the Margins object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

An integer value that represents the hash code for a Margins object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.IsEmpty Method

Margins.IsEmpty Method |
 | See Also

Determines whether the margins are empty.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function IsEmpty As Boolean
public bool IsEmpty ()
public:
bool IsEmpty ()
public boolean IsEmpty ()
public function IsEmpty () : boolean

Return Value

True if all margins values are zero, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.ToRectangleF Method

Margins.ToRectangleF Method |
 | See Also

Converts a Margins object to a RectangleF object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ToRectangleF As RectangleF
public RectangleF ToRectangleF ()
public:
RectangleF ToRectangleF ()
public RectangleF ToRectangleF ()
public function ToRectangleF () : RectangleF

Return Value

A RectangleF object that has margins.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.ToString Method

Margins.ToString Method |
 | See Also

Converts a Margins object to its string representation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Return Value

A string value that represents this object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins Properties

Margins Properties |
 | See Also

Public Properties

Name | Description
Bottom | Gets or sets the bottom margin.
Left | Gets or sets the left margin.
Right | Gets or sets the right margin.
Top | Gets or sets the top margin.

See Also

Reference

Margins Class
System.Web.UI.DataVisualization.Charting Namespace


Margins.Bottom Property

Margins.Bottom Property |
 | See Also

Gets or sets the bottom margin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Bottom As Integer
public int Bottom { get; set; }
public:
property int Bottom {
    int get ();
    void set (int value);
}
/** @property */
public int get_Bottom ()

/** @property */
public void set_Bottom (int value)

public function get Bottom () : int

public function set Bottom (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.Left Property

Margins.Left Property |
 | See Also

Gets or sets the left margin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Left As Integer
public int Left { get; set; }
public:
property int Left {
    int get ();
    void set (int value);
}
/** @property */
public int get_Left ()

/** @property */
public void set_Left (int value)

public function get Left () : int

public function set Left (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.Right Property

Margins.Right Property |
 | See Also

Gets or sets the right margin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Right As Integer
public int Right { get; set; }
public:
property int Right {
    int get ();
    void set (int value);
}
/** @property */
public int get_Right ()

/** @property */
public void set_Right (int value)

public function get Right () : int

public function set Right (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


Margins.Top Property

Margins.Top Property |
 | See Also

Gets or sets the top margin.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Top As Integer
public int Top { get; set; }
public:
property int Top {
    int get ();
    void set (int value);
}
/** @property */
public int get_Top ()

/** @property */
public void set_Top (int value)

public function get Top () : int

public function set Top (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members
System.Web.UI.DataVisualization.Charting Namespace


MarkerStyle Enumeration

MarkerStyle Enumeration |
 | See Also

Specifies a style for markers.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration MarkerStyle
public enum MarkerStyle
public enum class MarkerStyle
public enum MarkerStyle
public enum MarkerStyle

Members

Member name | Description
Circle | A circular marker is displayed.
Cross | A cross-shaped marker is displayed.
Diamond | A diamond-shaped marker is displayed.
None | No marker is displayed for the series or data point.
Square | A square marker is displayed.
Star10 | A 10-point star-shaped marker is displayed.
Star4 | A 4-point star-shaped marker is displayed.
Star5 | A 5-point star-shaped marker is displayed.
Star6 | A 6-point star-shaped marker is displayed.
Triangle | A triangular marker is displayed.

Remarks

The MarkerStyle enumeration represents the style used for a series or data point marker. It is used as a value for the MarkerStyle property and the MarkerStyle property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


NamedImage Class

NamedImage Class |
 | See Also Members

Represents named images, which are stored in the NamedImagesCollection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class NamedImage
    Inherits ChartNamedElement
public class NamedImage : ChartNamedElement
public ref class NamedImage : public ChartNamedElement
public class NamedImage extends ChartNamedElement
public class NamedImage extends ChartNamedElement

Remarks

The NamedImage class represents an image that has a unique name, and is useful when an image is dynamically created using a particular drawing routine, and then specified as the image for one of the image properties of the Chart control.

The Name property determines the unique name of a NamedImage object. The Image property determines its associated image, which can be any object derived from the .NET Framework Image class.

When one of the image properties of the Chart control is set by specifying a string value, the Images collection property is first checked to determine whether an image with the specified name exists. If a matching NamedImage object is found, this image is used. If a matching NamedImage object is not located, the string value is treated as a URL, image resource name, or an image path.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.NamedImage

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage Members

NamedImage Members |
 | See Also Constructors Methods Properties

Represents named images, which are stored in the NamedImagesCollection.

The following tables list the members exposed by the NamedImage type.

Public Constructors

Name | Description
NamedImage | Overloaded.
Top

Public Properties

Name | Description
Image | Gets or sets the image of a NamedImage object.
Name | Overridden. Gets or sets the unique name of a NamedImage object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

NamedImage Class
System.Web.UI.DataVisualization.Charting Namespace


NamedImage Constructor

NamedImage Constructor |
 | See Also

Overload List

Name | Description
NamedImage () | Initializes a new instance of the NamedImage class.
NamedImage (String, Image) | Initializes a new instance of the NamedImage class with the specified name of the named image and its associated image.

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage Constructor ()

NamedImage Constructor () |
 | See Also

Initializes a new instance of the NamedImage class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public NamedImage ()
public:
NamedImage ()
public NamedImage ()
public function NamedImage ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage Constructor (String, Image)

NamedImage Constructor (String, Image) |
 | See Also

Initializes a new instance of the NamedImage class with the specified name of the named image and its associated image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String, _
    image As Image _
)
public NamedImage (
    string name,
    Image image
)
public:
NamedImage (
    String^ name,
    Image^ image
)
public NamedImage (
    String name,
    Image image
)
public function NamedImage (
    name : String,
    image : Image
)

Parameters

name

The name of the named image. Use this name when setting a named image to one of the image properties.

image

The associated image.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage Methods

NamedImage Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

NamedImage Class
System.Web.UI.DataVisualization.Charting Namespace


NamedImage.Dispose Method

NamedImage.Dispose Method |
 | See Also

Overload List

Name | Description
NamedImage.Dispose () | (inherited from Dispose )
NamedImage.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage.Dispose Method (Boolean)

NamedImage.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage Properties

NamedImage Properties |
 | See Also

Public Properties

Name | Description
Image | Gets or sets the image of a NamedImage object.
Name | Overridden. Gets or sets the unique name of a NamedImage object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

NamedImage Class
System.Web.UI.DataVisualization.Charting Namespace


NamedImage.Image Property

NamedImage.Image Property |
 | See Also

Gets or sets the image of a NamedImage object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Image As Image
public Image Image { get; set; }
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
/** @property */
public Image get_Image ()

/** @property */
public void set_Image (Image value)

public function get Image () : Image

public function set Image (value : Image)

Property Value

The image component of a NamedImage object. This can be any object derived from the .NET Framework Image class, for example, a Bitmap object.

Remarks

The Image property determines which image is stored in a NamedImage object.

Use NamedImage objects for dynamically created images, which can then be assigned to a chart image property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImage.Name Property

NamedImage.Name Property |
 | See Also

Gets or sets the unique name of a NamedImage object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the unique name of a NamedImage object stored in the NamedImagesCollection.

Remarks

The property identifies a NamedImage object that is stored in the NamedImagesCollection. This name must be unique, or an exception will be thrown when the object is added to the collection.

Use NamedImage objects for dynamically created images, which can then be assigned to a chart image property.

This Name property value is used when you set a chart image property to a NamedImage object.

When one of the image properties of the Chart control is set by specifying a string value, the Images collection property—of type NamedImagesCollection—is first checked to determine whether an image with the specified name exists. If a matching NamedImage object is found, this image is used. If a matching NamedImage object is not located, the string value is treated as a URL, an image resource name, or an image path.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImagesCollection Class

NamedImagesCollection Class |
 | See Also Members

Represents a collection of NamedImage objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class NamedImagesCollection
    Inherits ChartNamedElementCollection(Of NamedImage)
public class NamedImagesCollection : ChartNamedElementCollection<NamedImage>
public ref class NamedImagesCollection : public ChartNamedElementCollection<NamedImage^>
public class NamedImagesCollection extends ChartNamedElementCollection<NamedImage>
public class NamedImagesCollection extends ChartNamedElementCollection<NamedImage>

Remarks

The NamedImagesCollection class represents a collection of NamedImage objects, which are objects that have an associated image and a name that is unique to the collection.

This class is exposed as the Images collection property of the root Chart object, and is only available at run time.

An image can be any object derived from the .NET Framework Image class, such as Bitmap, which is created dynamically. The image can be stored in this collection, and then assigned at a later time to any image property in the Chart control, such as BackImage.

When one of the image properties in the Chart control is set by specifying a string value, the Images collection property, of type NamedImagesCollection, is first checked to see if an image with that name exists. If a matching NamedImage object is found, this image is used. If a matching NamedImage object is not located, the string expression is treated as a URL, image resource name or pathname.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.NamedImagesCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImagesCollection Members
System.Web.UI.DataVisualization.Charting Namespace


NamedImagesCollection Members

NamedImagesCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of NamedImage objects.

The following tables list the members exposed by the NamedImagesCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

NamedImagesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


NamedImagesCollection Methods

NamedImagesCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

NamedImagesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


NamedImagesCollection Properties

NamedImagesCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

NamedImagesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


Point3D Class

Point3D Class |
 | See Also Members

Represents the coordinates of a three-dimensional (3D) data point. This class is used when performing custom drawing with 3D charts.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Point3D
public class Point3D
public ref class Point3D
public class Point3D
public class Point3D

Remarks

The Point3D class represents the coordinates of a 3D data point.

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from relative X, Y and Z (3D) coordinates into relative X and Y (2D) coordinates using the TransformPoints method. By calling TransformPoints, the X and Y-values of the Point3D objects are changed so that they reflect the 3-dimensional space. The new X and Y points can then be used for GDI+ method calls—the Z value is then disregarded—after being changed to absolute pixel coordinates using the GetAbsolutePoint method.

Note that the Z coordinate may be less than zero (located behind a chart area) or greater than 100 (located in front of a chart area).

To both enable 3D charts and work with their styles, use the Area3DStyle property. The Point3D class is not used for 3D styles.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.Point3D

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D Members

Point3D Members |
 | See Also Constructors Methods Properties

Represents the coordinates of a three-dimensional (3D) data point. This class is used when performing custom drawing with 3D charts.

The following tables list the members exposed by the Point3D type.

Public Constructors

Name | Description
Point3D | Overloaded.
Top

Public Properties

Name | Description
PointF | Gets or sets a PointF structure, which stores the X and Y coordinates of a 3D point.
X | Gets or sets the X coordinate of a 3D point.
Y | Gets or sets the Y coordinate of a 3D point.
Z | Gets or sets the Z coordinate of a 3D point.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Point3D Class
System.Web.UI.DataVisualization.Charting Namespace


Point3D Constructor

Point3D Constructor |
 | See Also

Overload List

Name | Description
Point3D () | Initializes a new instance of the Point3D class.
Point3D (Single, Single, Single) | Initializes a new instance of the AnnotationPathPoint class with the specified X, Y and Z coordinates.

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D Constructor ()

Point3D Constructor () |
 | See Also

Initializes a new instance of the Point3D class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Point3D ()
public:
Point3D ()
public Point3D ()
public function Point3D ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D Constructor (Single, Single, Single)

Point3D Constructor (Single, Single, Single) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified X, Y and Z coordinates.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
public Point3D (
    float x,
    float y,
    float z
)
public:
Point3D (
    float x,
    float y,
    float z
)
public Point3D (
    float x,
    float y,
    float z
)
public function Point3D (
    x : float,
    y : float,
    z : float
)

Parameters

x

The X coordinate of 3D point.

y

The Y coordinate of 3D point.

z

The Z coordinate, which represents the depth of 3D point.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D Methods

Point3D Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Point3D Class
System.Web.UI.DataVisualization.Charting Namespace


Point3D Properties

Point3D Properties |
 | See Also

Public Properties

Name | Description
PointF | Gets or sets a PointF structure, which stores the X and Y coordinates of a 3D point.
X | Gets or sets the X coordinate of a 3D point.
Y | Gets or sets the Y coordinate of a 3D point.
Z | Gets or sets the Z coordinate of a 3D point.

See Also

Reference

Point3D Class
System.Web.UI.DataVisualization.Charting Namespace


Point3D.PointF Property

Point3D.PointF Property |
 | See Also

Gets or sets a PointF structure, which stores the X and Y coordinates of a 3D point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PointF As PointF
public PointF PointF { get; set; }
public:
property PointF PointF {
    PointF get ();
    void set (PointF value);
}
/** @property */
public PointF get_PointF ()

/** @property */
public void set_PointF (PointF value)

public function get PointF () : PointF

public function set PointF (value : PointF)

Property Value

Gets or sets a PointF structure.

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling TransformPoints, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates, by using a method such as the GetAbsolutePoint method. After converting the coordinates, the PointF property of each Point3D object can be used for any GDI+ method that take a PointF object as a parameter.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D.X Property

Point3D.X Property |
 | See Also

Gets or sets the X coordinate of a 3D point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property X As Single
public float X { get; set; }
public:
property float X {
    float get ();
    void set (float value);
}
/** @property */
public float get_X ()

/** @property */
public void set_X (float value)

public function get X () : float

public function set X (value : float)

Property Value

A float that represents the X coordinate of a 3D point.

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling the TransformPoints method, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates using the GetAbsolutePoint method. They are then used for GDI+ method calls.

A relative X coordinate can be obtained from an axis value by calling the ValueToPosition method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D.Y Property

Point3D.Y Property |
 | See Also

Gets or sets the Y coordinate of a 3D point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Y As Single
public float Y { get; set; }
public:
property float Y {
    float get ();
    void set (float value);
}
/** @property */
public float get_Y ()

/** @property */
public void set_Y (float value)

public function get Y () : float

public function set Y (value : float)

Property Value

A float value that represents the Y coordinate of a 3D point.

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling the TransformPoints method, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates by using the GetAbsolutePoint method. They are then used for GDI+ method calls.

A relative Y coordinate can be obtained from an axis value using the ValueToPosition method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


Point3D.Z Property

Point3D.Z Property |
 | See Also

Gets or sets the Z coordinate of a 3D point.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Z As Single
public float Z { get; set; }
public:
property float Z {
    float get ();
    void set (float value);
}
/** @property */
public float get_Z ()

/** @property */
public void set_Z (float value)

public function get Z () : float

public function set Z (value : float)

Property Value

The Z coordinate of a 3D point, which is measured as a percentage of the relevant chart area's depth.

Remarks

This Z property is always expressed as a percentage of the relevant chart area's depth. With 3D charts, Z coordinates are relative, and have a value of 0 for the back wall of the chart area and a value of 100 for the front wall of the chart area.

Note This Z property may be less than zero (located behind a chart area) or greater than 100 (located in front of a chart area).

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling the TransformPoints method, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates by using the GetAbsolutePoint method. They are then used for GDI+ method calls.

Relative Z coordinates can be obtained for series by using the GetSeriesDepth and GetSeriesZPosition methods.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members
System.Web.UI.DataVisualization.Charting Namespace


PointSortOrder Enumeration

PointSortOrder Enumeration |
 | See Also

Indicates whether the sort order for data point values is ascending or descending.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration PointSortOrder
public enum PointSortOrder
public enum class PointSortOrder
public enum PointSortOrder
public enum PointSortOrder

Members

Member name | Description
Ascending | Ascending sort order, that is, smallest to largest values.
Descending | Descending sort order, that is, largest to smallest values.

Remarks

The PointSortOrder enumeration represents the order for the sort to be performed on data point values. It is used with the Sort method definitions in the DataManipulator class that include a pointSortOrder parameter.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation Class

PolygonAnnotation Class |
 | See Also Members

Represents a polygon annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class PolygonAnnotation
    Inherits PolylineAnnotation
public class PolygonAnnotation : PolylineAnnotation
public ref class PolygonAnnotation : public PolylineAnnotation
public class PolygonAnnotation extends PolylineAnnotation
public class PolygonAnnotation extends PolylineAnnotation

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.PolylineAnnotation
System.Web.UI.DataVisualization.Charting.PolygonAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation Members

PolygonAnnotation Members |
 | See Also Constructors Methods Properties

Represents a polygon annotation.

The following tables list the members exposed by the PolygonAnnotation type.

Public Constructors

Name | Description
PolygonAnnotation | Initializes a new instance of the PolygonAnnotation class.
Top

Public Properties

Name | Description
Alignment | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the background hatch style of an annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color of the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Overridden. This property is not applicable to the polygon annotation type.
Font | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation)
ForeColor | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation)
GraphicsPath | Gets or sets the path points of a polyline annotation at run time. (inherited from PolylineAnnotation)
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time. (inherited from PolylineAnnotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode. (inherited from PolylineAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Overridden. This property is not applicable to the polygon annotation type.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Gets or sets the text style of an annotation. (inherited from PolylineAnnotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from PolylineAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from PolylineAnnotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PolygonAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation Constructor

PolygonAnnotation Constructor |
 | See Also

Initializes a new instance of the PolygonAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public PolygonAnnotation ()
public:
PolygonAnnotation ()
public PolygonAnnotation ()
public function PolygonAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation Methods

PolygonAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from PolylineAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from PolylineAnnotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PolygonAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation Properties

PolygonAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the background hatch style of an annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color of the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Overridden. This property is not applicable to the polygon annotation type.
Font | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation )
ForeColor | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation )
GraphicsPath | Gets or sets the path points of a polyline annotation at run time. (inherited from PolylineAnnotation )
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time. (inherited from PolylineAnnotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode. (inherited from PolylineAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Overridden. This property is not applicable to the polygon annotation type.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Gets or sets the text style of an annotation. (inherited from PolylineAnnotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

PolygonAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.AnnotationType Property

PolygonAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.BackColor Property

PolygonAnnotation.BackColor Property |
 | See Also

Gets or sets the background color of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(true)]
public override Color BackColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value used to draw the annotation background.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.BackGradientStyle Property

PolygonAnnotation.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(true)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw the annotation background.

Remarks

Two colors are used to draw the gradient fill; the primary color is specified with the BackColor property and the secondary color is specified with the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.BackHatchStyle Property

PolygonAnnotation.BackHatchStyle Property |
 | See Also

Gets or sets the background hatch style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(true)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the annotation background.

Remarks

Two colors are used to draw the hatching fill; the primary color is specified with the BackColor property and the secondary color is specified with the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.BackSecondaryColor Property

PolygonAnnotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(true)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw the annotation background with hatching or gradient fill.

Remarks

This secondary color is used with a primary color, defined with the BackColor property, when the BackHatchStyle and BackGradientStyle properties are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.EndCap Property

PolygonAnnotation.EndCap Property |
 | See Also

This property is not applicable to the polygon annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property EndCap As LineAnchorCapStyle
[BrowsableAttribute(false)]
public override LineAnchorCapStyle EndCap { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LineAnchorCapStyle EndCap {
    LineAnchorCapStyle get () override;
    void set (LineAnchorCapStyle value) override;
}
/** @property */
public LineAnchorCapStyle get_EndCap ()

/** @property */
public void set_EndCap (LineAnchorCapStyle value)

public override function get EndCap () : LineAnchorCapStyle

public override function set EndCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value.

Remarks

This property is not applicable to the polygon annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolygonAnnotation.StartCap Property

PolygonAnnotation.StartCap Property |
 | See Also

This property is not applicable to the polygon annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property StartCap As LineAnchorCapStyle
[BrowsableAttribute(false)]
public override LineAnchorCapStyle StartCap { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LineAnchorCapStyle StartCap {
    LineAnchorCapStyle get () override;
    void set (LineAnchorCapStyle value) override;
}
/** @property */
public LineAnchorCapStyle get_StartCap ()

/** @property */
public void set_StartCap (LineAnchorCapStyle value)

public override function get StartCap () : LineAnchorCapStyle

public override function set StartCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value.

Remarks

This property is not applicable to the polygon annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation Class

PolylineAnnotation Class |
 | See Also Members

Represents a polyline annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class PolylineAnnotation
    Inherits Annotation
public class PolylineAnnotation : Annotation
public ref class PolylineAnnotation : public Annotation
public class PolylineAnnotation extends Annotation
public class PolylineAnnotation extends Annotation

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.PolylineAnnotation
System.Web.UI.DataVisualization.Charting.PolygonAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation Members

PolylineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a polyline annotation.

The following tables list the members exposed by the PolylineAnnotation type.

Public Constructors

Name | Description
PolylineAnnotation | Initializes a new instance of the PolylineAnnotation class.
Top

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the polyline annotation type.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the polyline annotation type.
BackGradientStyle | Overridden. This property is not applicable to the polyline annotation type.
BackHatchStyle | Overridden. This property is not applicable to the polyline annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the polyline annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets the style of an anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the polyline annotation type.
ForeColor | Overridden. This property is not applicable to the polyline annotation type.
GraphicsPath | Gets or sets the path points of a polyline annotation at run time.
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of the annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PolylineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation Constructor

PolylineAnnotation Constructor |
 | See Also

Initializes a new instance of the PolylineAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public PolylineAnnotation ()
public:
PolylineAnnotation ()
public PolylineAnnotation ()
public function PolylineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation Methods

PolylineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PolylineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.Dispose Method

PolylineAnnotation.Dispose Method |
 | See Also

Overload List

Name | Description
PolylineAnnotation.Dispose () | (inherited from Dispose )
PolylineAnnotation.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.Dispose Method (Boolean)

PolylineAnnotation.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation Properties

PolylineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the polyline annotation type.
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the polyline annotation type.
BackGradientStyle | Overridden. This property is not applicable to the polyline annotation type.
BackHatchStyle | Overridden. This property is not applicable to the polyline annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the polyline annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets the style of an anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the polyline annotation type.
ForeColor | Overridden. This property is not applicable to the polyline annotation type.
GraphicsPath | Gets or sets the path points of a polyline annotation at run time.
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of the annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

PolylineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.Alignment Property

PolylineAnnotation.Alignment Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Alignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment Alignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.AnnotationType Property

PolylineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.BackColor Property

PolylineAnnotation.BackColor Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.BackGradientStyle Property

PolylineAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.BackHatchStyle Property

PolylineAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.BackSecondaryColor Property

PolylineAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.EndCap Property

PolylineAnnotation.EndCap Property |
 | See Also

Gets or sets the style of an anchor cap at the end of the annotation line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property EndCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle EndCap { get; set; }
public:
virtual property LineAnchorCapStyle EndCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_EndCap ()

/** @property */
public void set_EndCap (LineAnchorCapStyle value)

public function get EndCap () : LineAnchorCapStyle

public function set EndCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value that represents the style used for an anchor cap located at the end of an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.Font Property

PolylineAnnotation.Font Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.ForeColor Property

PolylineAnnotation.ForeColor Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.GraphicsPath Property

PolylineAnnotation.GraphicsPath Property |
 | See Also

Gets or sets the path points of a polyline annotation at run time.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property GraphicsPath As GraphicsPath
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual GraphicsPath GraphicsPath { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property GraphicsPath^ GraphicsPath {
    GraphicsPath^ get ();
    void set (GraphicsPath^ value);
}
/** @property */
public GraphicsPath get_GraphicsPath ()

/** @property */
public void set_GraphicsPath (GraphicsPath value)

public function get GraphicsPath () : GraphicsPath

public function set GraphicsPath (value : GraphicsPath)

Property Value

A GraphicsPath object with the polyline shape.

Remarks

A polyline must use coordinates relative to an annotation object, where (0,0) denotes the top-left coordinates and (100,100) denotes the bottom-right coordinates of the annotation.

This property is not accessible at design time, when you should use the GraphicsPathPoints property instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.GraphicsPathPoints Property

PolylineAnnotation.GraphicsPathPoints Property |
 | See Also

Gets or sets the path points of the polyline annotation at design time.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property GraphicsPathPoints As AnnotationPathPointCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public AnnotationPathPointCollection GraphicsPathPoints { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property AnnotationPathPointCollection^ GraphicsPathPoints {
    AnnotationPathPointCollection^ get ();
}
/** @property */
public AnnotationPathPointCollection get_GraphicsPathPoints ()

public function get GraphicsPathPoints () : AnnotationPathPointCollection

Property Value

An AnnotationPathPointCollection object with the polyline shape.

Remarks

A polyline must use coordinates relative to an annotation object, where (0,0) denotes the top-left coordinates and (100,100) denotes the bottom-right coordinates of the annotation.

This property is not accessible at run time, when you should use the GraphicsPath property instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.IsFreeDrawPlacement Property

PolylineAnnotation.IsFreeDrawPlacement Property |
 | See Also

Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property IsFreeDrawPlacement As Boolean
[BrowsableAttribute(false)]
public virtual bool IsFreeDrawPlacement { get; set; }
[BrowsableAttribute(false)]
public:
virtual property bool IsFreeDrawPlacement {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsFreeDrawPlacement ()

/** @property */
public void set_IsFreeDrawPlacement (boolean value)

public function get IsFreeDrawPlacement () : boolean

public function set IsFreeDrawPlacement (value : boolean)

Property Value

True if an annotation should be placed using free-draw mode, otherwise false. The default value is false.

Remarks

Two different placement modes are supported when the BeginPlacement method is called. Set the IsFreeDrawPlacement property to true to switch from the default mode to free-draw mode, which allows the user to freely-draw while moving the mouse cursor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.StartCap Property

PolylineAnnotation.StartCap Property |
 | See Also

Gets or sets a style for the anchor cap at the start of the annotation line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property StartCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle StartCap { get; set; }
public:
virtual property LineAnchorCapStyle StartCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_StartCap ()

/** @property */
public void set_StartCap (LineAnchorCapStyle value)

public function get StartCap () : LineAnchorCapStyle

public function set StartCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value that represents the style for an anchor cap located at the start of an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


PolylineAnnotation.TextStyle Property

PolylineAnnotation.TextStyle Property |
 | See Also

Gets or sets the text style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle value used to draw the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation Class

RectangleAnnotation Class |
 | See Also Members

Represents a rectangle annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class RectangleAnnotation
    Inherits TextAnnotation
public class RectangleAnnotation : TextAnnotation
public ref class RectangleAnnotation : public TextAnnotation
public class RectangleAnnotation extends TextAnnotation
public class RectangleAnnotation extends TextAnnotation

Remarks

A rectangle annotation can display text inside the rectangle, in addition to being displayed as a rectangle only. So you can annotate using a rectangle or a rectangle with text inside it.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.TextAnnotation
System.Web.UI.DataVisualization.Charting.RectangleAnnotation
System.Web.UI.DataVisualization.Charting.Border3DAnnotation
System.Web.UI.DataVisualization.Charting.EllipseAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation Members

RectangleAnnotation Members |
 | See Also Constructors Methods Properties

Represents a rectangle annotation.

The following tables list the members exposed by the RectangleAnnotation type.

Public Constructors

Name | Description
RectangleAnnotation | Initializes a new instance of the AnnotationPathPoint class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the gradient style of the annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. Gets or sets the line color of an annotation.
LineDashStyle | Overridden. Gets or sets the line style of an annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of an annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

RectangleAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation Constructor

RectangleAnnotation Constructor |
 | See Also

Initializes a new instance of the AnnotationPathPoint class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public RectangleAnnotation ()
public:
RectangleAnnotation ()
public RectangleAnnotation ()
public function RectangleAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation Methods

RectangleAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

RectangleAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation Properties

RectangleAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the gradient style of the annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. Gets or sets the line color of an annotation.
LineDashStyle | Overridden. Gets or sets the line style of an annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of an annotation.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

RectangleAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.AnnotationType Property

RectangleAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.BackColor Property

RectangleAnnotation.BackColor Property |
 | See Also

Gets or sets the background color of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(true)]
public override Color BackColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value used to draw the annotation background.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.BackGradientStyle Property

RectangleAnnotation.BackGradientStyle Property |
 | See Also

Gets or sets the gradient style of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(true)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw an annotation background.

Remarks

Two colors are used to draw the gradient, a primary color that is specified the BackColor and a secondary color that is specified with the BackSecondaryColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.BackHatchStyle Property

RectangleAnnotation.BackHatchStyle Property |
 | See Also

Gets or sets the hatch style of an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(true)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the background.

Remarks

Two colors are used to draw the hatching, a primary color that is specified the BackColor property, and a secondary color that is specified with the BackColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.BackSecondaryColor Property

RectangleAnnotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for an annotation background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(true)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw the annotation background with hatching or gradient fill.

Remarks

This color is used with BackColor when the BackHatchStyle or BackGradientStyle property is used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.LineColor Property

RectangleAnnotation.LineColor Property |
 | See Also

Gets or sets the line color of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(true)]
public override Color LineColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value used to draw the annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.LineDashStyle Property

RectangleAnnotation.LineDashStyle Property |
 | See Also

Gets or sets the line style of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(true)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value used to draw the line style of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RectangleAnnotation.LineWidth Property

RectangleAnnotation.LineWidth Property |
 | See Also

Gets or sets the line width, in pixels, of an annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(true)]
public override int LineWidth { get; set; }
[BrowsableAttribute(true)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value that represents the line width, in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


RenderType Enumeration

RenderType Enumeration |
 | See Also

Specifies how the image of the chart will be rendered.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration RenderType
public enum RenderType
public enum class RenderType
public enum RenderType
public enum RenderType

Members

Member name | Description
BinaryStreaming | Chart is streamed directly to the client.
ImageMap | Chart is rendered as an image map.
ImageTag | Chart is rendered using an HTML image tag.

Remarks

The RenderType enumeration represents the way in which the chart image will be rendered, and is used in conjunction with the RenderType property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


SerializationContents Enumeration

SerializationContents Enumeration |
 | See Also

Specifies the type of chart content to be serialized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration SerializationContents
public enum SerializationContents
public enum class SerializationContents
public enum SerializationContents
public enum SerializationContents

Members

Member name | Description
All | Serialize all chart information. This includes all appearance properties and data point values.
Appearance | Serialize all appearance properties, such as color or line style, if they have non-default values
Data | Serialize data values from all chart series. Does not include appearance properties.
Default | Serialize all non-default chart content. This includes appearance properties, series and their data points, axis minimums/maximums, and so forth.

Remarks

The SerializationContents enumeration represents the chart content type to be serialized. This enumeration is used with the Content and ViewStateContent properties.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


SerializationFormat Enumeration

SerializationFormat Enumeration |
 | See Also

Represents the formatting type to use when the chart is serialized.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration SerializationFormat
public enum SerializationFormat
public enum class SerializationFormat
public enum SerializationFormat
public enum SerializationFormat

Members

Member name | Description
Binary | Chart data will be serialized in a binary format.
Xml | Chart data will be serialized using well-formed XML.

Remarks

The SerializationFormat enumeration is used in conjunction with the Format property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Series Class

Series Class |
 | See Also Members

Stores data points and series attributes.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Series
    Inherits DataPointCustomProperties
public class Series : DataPointCustomProperties
public ref class Series : public DataPointCustomProperties
public class Series extends DataPointCustomProperties
public class Series extends DataPointCustomProperties

Remarks

A Series object represents a data series and is stored in the SeriesCollection class.

A Series stores DataPoint objects using the DataPointCollection class. It also stores attributes of the data series. For example, a data series has a color attribute, background image attribute, background gradient attribute, and so forth.

The DataPoint objects that belong to a series also have their own attributes. Normally, if the same attribute is set for a data point and the series to which it belongs, the data point attribute has precedence.

A series is not necessarily plotted on a chart; it can store data point values that are used to perform a calculation from which another series is created and then plotted. For example, Series A, which is plotted, may be the result of adding Series B and Series C data points together, though neither of these series is plotted. In order to draw a Series object, the ChartArea property must be set to the name of the ChartArea object used to plot the series.

When a series is created, it is automatically assigned to the ChartArea object named "Default", or to the first available chart area in the chart area collection if the "Default" object does not exist.

To disable the display of a series, set its ChartArea property to a zero-length string.

The ChartType property determines the type of chart that will be used to plot this series, if it is drawn.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.DataPointCustomProperties
System.Web.UI.DataVisualization.Charting.Series

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series Members

Series Members |
 | See Also Constructors Methods Properties

Stores data points and series attributes.

The following tables list the members exposed by the Series type.

Public Constructors

Name | Description
Series | Overloaded.
Top

Public Properties

Name | Description
AxisLabel | Overridden. Gets or sets the axis label text for the series.
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties)
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties)
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties)
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties)
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties)
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties)
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties)
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties)
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties)
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties)
ChartArea | Gets or sets the name of the ChartArea object used to plot the data series, if any.
ChartType | Gets or sets the chart type of a series.
ChartTypeName | Gets or sets the name of the chart type used to draw the series.
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties)
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties)
CustomPropertiesExtended | For internal use only. (inherited from DataPointCustomProperties)
EmptyPointStyle | Gets or sets the drawing style of points marked as empty.
Enabled | Gets or sets a flag that indicates whether the series will be visible on the rendered chart.
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties)
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties)
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties)
IsXValueIndexed | Gets or sets a flag that indicates whether data point indices will be used for the X-values.
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties)
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties)
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties)
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties)
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties)
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties)
LabelMapAreaAttributes | Gets or sets map area attributes of the data point label. (inherited from DataPointCustomProperties)
LabelPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties)
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties)
LabelUrl | Gets or sets the URL target of the data point label. (inherited from DataPointCustomProperties)
Legend | Gets or sets the name of the series associated with the Legend object.
LegendMapAreaAttributes | Gets or sets the attributes of the legend map area. (inherited from DataPointCustomProperties)
LegendPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties)
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties)
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties)
LegendUrl | Gets or sets the URL target of the item in the legend. (inherited from DataPointCustomProperties)
MapAreaAttributes | Gets or sets the map area attributes of a data point. (inherited from DataPointCustomProperties)
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties)
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties)
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties)
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties)
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties)
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties)
MarkerStep | Gets or sets a value that determines how often to display data point markers.
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties)
Name | Overridden. Gets or sets the unique name of a Series object.
Palette | Gets or sets the color palette of a Series object.
Points | Gets a DataPointCollection object.
PostBackValue | Gets or sets the postback value that can be processed on a Click event. (inherited from DataPointCustomProperties)
ShadowColor | Gets or sets the shadow color of a series.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a series.
SmartLabelStyle | Gets or sets the style of the smart labels.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties)
Url | Gets or sets the URL target of the area. (inherited from DataPointCustomProperties)
XAxisType | Gets or sets the X-axis type of the series.
XValueMember | Gets or sets the member column of the chart data source used to data bind to the X-value of the series.
XValueType | Gets or sets the value types plotted along the X-axis.
YAxisType | Gets or sets the Y-axis type of a series.
YValueMembers | Gets or sets member columns of the chart data source used to bind data to the Y-values of the series.
YValuesPerPoint | Gets or sets the maximum number of Y-values that DataPoint objects in a Series are allowed to have.
YValueType | Gets or sets the type of Y-value data in the data points stored by a series.
Top

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets the IsValueShownAsLabel property to its default value. (inherited from DataPointCustomProperties)
ResetIsVisibleInLegend | Resets the IsVisibleInLegend property to its default value. (inherited from DataPointCustomProperties)
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
Sort | Overloaded. Performs a sort on a Series. Note that the DataManipulator class provides sort methods that have greater flexibility than these sort methods.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Series Class
System.Web.UI.DataVisualization.Charting Namespace


Series Constructor

Series Constructor |
 | See Also

Overload List

Name | Description
Series () | Initializes a new instance of the Series class.
Series (String) | Initializes a new instance of the Series class with the specified series name.
Series (String, Int32) | Initializes a new instance of the Series class with the specified name and maximum number of Y values.

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series Constructor ()

Series Constructor () |
 | See Also

Initializes a new instance of the Series class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Series ()
public:
Series ()
public Series ()
public function Series ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series Constructor (String)

Series Constructor (String) |
 | See Also

Initializes a new instance of the Series class with the specified series name.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String _
)
public Series (
    string name
)
public:
Series (
    String^ name
)
public Series (
    String name
)
public function Series (
    name : String
)

Parameters

name

The name of the Series object that will be created. This must be a unique name, otherwise an exception will be thrown.

Remarks

This constructor can be used to create a new instance of the Series class.

Note:
This series is only capable of storing DataPoint objects that have one Y-value. If a data point that has multiple Y-values is added to this series, an exception will be thrown.

To create a series at run time, use the Add method.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series Constructor (String, Int32)

Series Constructor (String, Int32) |
 | See Also

Initializes a new instance of the Series class with the specified name and maximum number of Y values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String, _
    yValues As Integer _
)
public Series (
    string name,
    int yValues
)
public:
Series (
    String^ name,
    int yValues
)
public Series (
    String name,
    int yValues
)
public function Series (
    name : String,
    yValues : int
)

Parameters

name

The name of the Series object that will be created.

yValues

The maximum number of Y-values allowed for the DataPoint objects that belong to this series.

Remarks

Use this constructor to create and initialize a new instance of the Series class.

Important:
This series will only be able to store DataPoint objects that do not have more Y-values than the maximum set by the yValues parameter. If you add a data point that has more Y-values than the set maximum, an exception will be thrown.

To create a Series object at run time, the Add and Insert methods of the Series collection property can also be used.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series Methods

Series Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets the IsValueShownAsLabel property to its default value. (inherited from DataPointCustomProperties )
ResetIsVisibleInLegend | Resets the IsVisibleInLegend property to its default value. (inherited from DataPointCustomProperties )
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
Sort | Overloaded. Performs a sort on a Series. Note that the DataManipulator class provides sort methods that have greater flexibility than these sort methods.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Series Class
System.Web.UI.DataVisualization.Charting Namespace


Series.Dispose Method

Series.Dispose Method |
 | See Also

Overload List

Name | Description
Series.Dispose () | (inherited from Dispose )
Series.Dispose (Boolean) |

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Dispose Method (Boolean)

Series.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Sort Method

Series.Sort Method |
 | See Also

Performs a sort on a Series. Note that the DataManipulator class provides sort methods that have greater flexibility than these sort methods.

Overload List

Name | Description
Series.Sort (Generic ) | Sorts the points in the series using IComparer interface.
Series.Sort (PointSortOrder) | Sorts the data points in the series, given the specified sort order.
Series.Sort (PointSortOrder, String) | Sorts the points in the series, given the specified sort order and value to use for the sort.

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Sort Method (Generic )

Series.Sort Method (Generic ) |
 | See Also

Sorts the points in the series using IComparer interface.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    comparer As IComparer(Of DataPoint) _
)
public void Sort (
    IComparer<DataPoint> comparer
)
public:
void Sort (
    IComparer<DataPoint^>^ comparer
)
public void Sort (
    IComparer<DataPoint> comparer
)
public function Sort (
    comparer : IComparer<DataPoint>
)

Parameters

comparer

The IComparer interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Sort Method (PointSortOrder)

Series.Sort Method (PointSortOrder) |
 | See Also

Sorts the data points in the series, given the specified sort order.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder _
)
public void Sort (
    PointSortOrder pointSortOrder
)
public:
void Sort (
    PointSortOrder pointSortOrder
)
public void Sort (
    PointSortOrder pointSortOrder
)
public function Sort (
    pointSortOrder : PointSortOrder
)

Parameters

pointSortOrder

The sort order.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Sort Method (PointSortOrder, String)

Series.Sort Method (PointSortOrder, String) |
 | See Also

Sorts the points in the series, given the specified sort order and value to use for the sort.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    sortBy As String _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string sortBy
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ sortBy
)
public void Sort (
    PointSortOrder pointSortOrder,
    String sortBy
)
public function Sort (
    pointSortOrder : PointSortOrder,
    sortBy : String
)

Parameters

pointSortOrder

The sort order.

sortBy

The value used for the sort (X, Y, Y2 ...).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series Properties

Series Properties |
 | See Also

Public Properties

Name | Description
AxisLabel | Overridden. Gets or sets the axis label text for the series.
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties )
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties )
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties )
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties )
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties )
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties )
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties )
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties )
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties )
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties )
ChartArea | Gets or sets the name of the ChartArea object used to plot the data series, if any.
ChartType | Gets or sets the chart type of a series.
ChartTypeName | Gets or sets the name of the chart type used to draw the series.
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties )
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties )
CustomPropertiesExtended | For internal use only. (inherited from DataPointCustomProperties )
EmptyPointStyle | Gets or sets the drawing style of points marked as empty.
Enabled | Gets or sets a flag that indicates whether the series will be visible on the rendered chart.
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties )
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties )
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties )
IsXValueIndexed | Gets or sets a flag that indicates whether data point indices will be used for the X-values.
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties )
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties )
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties )
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties )
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties )
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties )
LabelMapAreaAttributes | Gets or sets map area attributes of the data point label. (inherited from DataPointCustomProperties )
LabelPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties )
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties )
LabelUrl | Gets or sets the URL target of the data point label. (inherited from DataPointCustomProperties )
Legend | Gets or sets the name of the series associated with the Legend object.
LegendMapAreaAttributes | Gets or sets the attributes of the legend map area. (inherited from DataPointCustomProperties )
LegendPostBackValue | Gets or sets the postback value which can be processed on a Click event. (inherited from DataPointCustomProperties )
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties )
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties )
LegendUrl | Gets or sets the URL target of the item in the legend. (inherited from DataPointCustomProperties )
MapAreaAttributes | Gets or sets the map area attributes of a data point. (inherited from DataPointCustomProperties )
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties )
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties )
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties )
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties )
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties )
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties )
MarkerStep | Gets or sets a value that determines how often to display data point markers.
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties )
Name | Overridden. Gets or sets the unique name of a Series object.
Palette | Gets or sets the color palette of a Series object.
Points | Gets a DataPointCollection object.
PostBackValue | Gets or sets the postback value that can be processed on a Click event. (inherited from DataPointCustomProperties )
ShadowColor | Gets or sets the shadow color of a series.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a series.
SmartLabelStyle | Gets or sets the style of the smart labels.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties )
Url | Gets or sets the URL target of the area. (inherited from DataPointCustomProperties )
XAxisType | Gets or sets the X-axis type of the series.
XValueMember | Gets or sets the member column of the chart data source used to data bind to the X-value of the series.
XValueType | Gets or sets the value types plotted along the X-axis.
YAxisType | Gets or sets the Y-axis type of a series.
YValueMembers | Gets or sets member columns of the chart data source used to bind data to the Y-values of the series.
YValuesPerPoint | Gets or sets the maximum number of Y-values that DataPoint objects in a Series are allowed to have.
YValueType | Gets or sets the type of Y-value data in the data points stored by a series.

See Also

Reference

Series Class
System.Web.UI.DataVisualization.Charting Namespace


Series.AxisLabel Property

Series.AxisLabel Property |
 | See Also

Gets or sets the axis label text for the series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property AxisLabel As String
[BrowsableAttribute(false)]
public override string AxisLabel { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AxisLabel {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_AxisLabel ()

/** @property */
public void set_AxisLabel (String value)

public override function get AxisLabel () : String

public override function set AxisLabel (value : String)

Property Value

A string value. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.ChartArea Property

Series.ChartArea Property |
 | See Also Example

Gets or sets the name of the ChartArea object used to plot the data series, if any.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ChartArea As String
public string ChartArea { get; set; }
public:
property String^ ChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ChartArea ()

/** @property */
public void set_ChartArea (String value)

public function get ChartArea () : String

public function set ChartArea (value : String)

Property Value

A string value that represents a ChartArea object, which is used to plot the series.

Remarks

When a series is added at both design time and run time, it is automatically assigned to the "Default" ChartArea object, or the first available chart area in the ChartAreaCollection if "Default" does not exist.

Set this property to a zero-length string if you do not want the series to be plotted.

Example

Copy Code
' Create a new legend and associate three series with the legend.
Public Sub CreateSecondLegend()
    ' Attach the first series to a chart area.
    Chart1.Series["Series1"].ChartArea = "Chart Area 1";

    ' Attach the second series to a chart area.
    Chart1.Series["Series2"].ChartArea = "Chart Area 2";

End Sub 'CreateSecondLegend
Copy Code
// Create a new legend and associate three series with the legend.
public void CreateSecondLegend()
{
     // Attach the first series to a chart area.
     Chart1.Series["Series1"].ChartArea = "Chart Area 1";

     // Attach the second series to a chart area.
     Chart1.Series["Series2"].ChartArea = "Chart Area 2";

}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.ChartType Property

Series.ChartType Property |
 | See Also

Gets or sets the chart type of a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ChartType As SeriesChartType
public SeriesChartType ChartType { get; set; }
public:
property SeriesChartType ChartType {
    SeriesChartType get ();
    void set (SeriesChartType value);
}
/** @property */
public SeriesChartType get_ChartType ()

/** @property */
public void set_ChartType (SeriesChartType value)

public function get ChartType () : SeriesChartType

public function set ChartType (value : SeriesChartType)

Property Value

A SeriesChartType enumeration value that indicates the chart type that will be used to represent the series. The default value is Column.

Remarks

This property determines the chart type of the Series object; the value is case-sensitive. See the SeriesChartType enumeration for a list of all possible chart types for a series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.ChartTypeName Property

Series.ChartTypeName Property |
 | See Also

Gets or sets the name of the chart type used to draw the series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property ChartTypeName As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string ChartTypeName { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property String^ ChartTypeName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ChartTypeName ()

/** @property */
public void set_ChartTypeName (String value)

public function get ChartTypeName () : String

public function set ChartTypeName (value : String)

Property Value

A string value that represents the name of the chart type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.EmptyPointStyle Property

Series.EmptyPointStyle Property |
 | See Also

Gets or sets the drawing style of points marked as empty.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property EmptyPointStyle As DataPointCustomProperties
public DataPointCustomProperties EmptyPointStyle { get; set; }
public:
property DataPointCustomProperties^ EmptyPointStyle {
    DataPointCustomProperties^ get ();
    void set (DataPointCustomProperties^ value);
}
/** @property */
public DataPointCustomProperties get_EmptyPointStyle ()

/** @property */
public void set_EmptyPointStyle (DataPointCustomProperties value)

public function get EmptyPointStyle () : DataPointCustomProperties

public function set EmptyPointStyle (value : DataPointCustomProperties)

Property Value

A DataPointCustomProperties object.

Remarks

The EmptyPointStyle property determines the drawing style of points marked as empty, for example, in the border color, in the marker images, background color or images, and so forth.

Certain properties are only applicable for specific chart types. For example, the BackImage property does not apply to line charts, but does apply to an area chart.

To display an image that indicates an empty point, use the MarkerImage and MarkerStyle properties, and not the BackImage property.

The AxisLabel property determines the axis label for empty points. Note that for stacked chart types, the axis label is determined by the AxisLabel property of the first plotted series that has this property set.

Data points can be manually marked as an empty by setting the IsEmpty property to true. Alternatively, one of the InsertEmptyPoints methods in the DataManipulator class can be used to check for missing data and insert empty points if a data point is missing.

Note:
In the case of line-type charts, the line color for lines that connect to an empty point is determined by the Color property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Enabled Property

Series.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether the series will be visible on the rendered chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if the series will be visible on the rendered chart, otherwise false. The default value is true.

Remarks

Gets or sets a value that determines if the series will be visible on the rendered ChartArea.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.IsXValueIndexed Property

Series.IsXValueIndexed Property |
 | See Also

Gets or sets a flag that indicates whether data point indices will be used for the X-values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsXValueIndexed As Boolean
public bool IsXValueIndexed { get; set; }
public:
property bool IsXValueIndexed {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsXValueIndexed ()

/** @property */
public void set_IsXValueIndexed (boolean value)

public function get IsXValueIndexed () : boolean

public function set IsXValueIndexed (value : boolean)

Property Value

True if the indices of data points that belong to the series will be used for X-values; false if they will not. The default value is false.

Remarks

All data points in a series use sequential indices, and if this property is true then data points will be plotted sequentially, regardless of their associated X-values. This means that there will be no "missing" data points.

For example, assume there are three (3) data points in a series having X-values of 1, 2 and 4. If this property was false, there would be a data point missing at the X-axis location labeled "3". However, if you set this property to true, the three data points will be plotted at points 1, 2, and 4, sequentially, and there will be no missing data point. The X-axis location labeled "3" will not appear on the chart.

This is useful when you do not want to have missing data points for intervals that you know you will not have data for, such as weekends.

Important:
If you are displaying multiple series and at least one series uses indexed X-values, then all series must be aligned—that is, have the same number of data points—and the corresponding points must have the same X-values.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Legend Property

Series.Legend Property |
 | See Also

Gets or sets the name of the series associated with the Legend object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Legend As String
public string Legend { get; set; }
public:
property String^ Legend {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Legend ()

/** @property */
public void set_Legend (String value)

public function get Legend () : String

public function set Legend (value : String)

Property Value

A string value that represents the name of a Legend object.

Remarks

When a series is added at both design time and run time, it is automatically assigned to the default Legend object.

If you do not want the series shown in a legend, set this property to a zero-length string, or set the IsVisibleInLegend property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.MarkerStep Property

Series.MarkerStep Property |
 | See Also

Gets or sets a value that determines how often to display data point markers.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MarkerStep As Integer
public int MarkerStep { get; set; }
public:
property int MarkerStep {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerStep ()

/** @property */
public void set_MarkerStep (int value)

public function get MarkerStep () : int

public function set MarkerStep (value : int)

Property Value

An integer value that determines how often to display data point markers. The default value is one (1).

Remarks

The MarkerStep property specifies the frequency with which markers are displayed. For example, if you set this property to two (2), every other data point will use a marker.

This property is only used if markers are enabled using the MarkerStyle property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Name Property

Series.Name Property |
 | See Also

Gets or sets the unique name of a Series object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the unique name of the data series.

Remarks

The name of a data series must be unique; otherwise an exception will be thrown.

This property can be used as the indexer when you retrieve a Series object from the SeriesCollection object.

If this property is set to a zero-length string, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Palette Property

Series.Palette Property |
 | See Also

Gets or sets the color palette of a Series object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Palette As ChartColorPalette
public ChartColorPalette Palette { get; set; }
public:
property ChartColorPalette Palette {
    ChartColorPalette get ();
    void set (ChartColorPalette value);
}
/** @property */
public ChartColorPalette get_Palette ()

/** @property */
public void set_Palette (ChartColorPalette value)

public function get Palette () : ChartColorPalette

public function set Palette (value : ChartColorPalette)

Property Value

An ChartColorPalette enumeration value that determines the palette for the data series.

Remarks

A palette is used to automatically assign colors to data elements if the data points themselves do not have colors assigned to them and if the data Series object that the data points belong to also does not have an assigned color.

If no series or data point colors are explicitly specified, the colors used depend on the chart type and the Chart control palette or Series palette, if one is specified. See the table below for further details:

Chart Type | Series Palette Used? | Colors Displayed by Data Points
Any shape chart (for example, Pie and Doughnut charts) | No | First available colors used from Chart control palette. One color per data point.
All charts except shape charts | No | First available colors from Chart control palette. One color per data series.
Any shape chart (for example, Pie and Doughnut charts) | Yes | First available colors used from Series palette. One color per data point.
All charts except shape charts | Yes | First available colors used from Series palette. One color per data series.

This Palette property has precedence over the Palette property of the root Chart object, with respect to the display of data.

NOTE: If the Palette property for both the Chart and Series objects is set to None, and no color is assigned to the relevant data series/data points, the default palette "BrightPastel" or PaletteCustomColors is used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.Points Property

Series.Points Property |
 | See Also

Gets a DataPointCollection object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property Points As DataPointCollection
public DataPointCollection Points { get; }
public:
property DataPointCollection^ Points {
    DataPointCollection^ get ();
}
/** @property */
public DataPointCollection get_Points ()

public function get Points () : DataPointCollection

Property Value

A DataPointCollection object that represents a collection of DataPoint objects.

Remarks

The Points collection property allows you to add and remove data points to a series. This property also provides methods and properties that can be used to manipulate this collection, such as finding data points, performing data-binding, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.ShadowColor Property

Series.ShadowColor Property |
 | See Also Example

Gets or sets the shadow color of a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

Gets or sets the shadow color of a series, which can be to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a realistic shadow effect; try using a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Example

Copy Code
' Set series shadow color and offset
Public Sub SetSeriesShadow()
     Chart1.Series("Default"}.ShadowColor = Color.Blue
     Chart1.Series("Default"}.ShadowOffset = 2
End Sub 'SetSeriesShadow
Copy Code
// Set series shadow color and offset
public void SetSeriesShadow()
{
    Chart1.Series("Default"}.ShadowColor = Color.Blue;
    Chart1.Series["Default"].ShadowOffset = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.ShadowOffset Property

Series.ShadowOffset Property |
 | See Also Example

Gets or sets the shadow offset, in pixels, of a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset of the series, in pixels.

Remarks

To implement shadowing, use a value other than zero (0). A positive value will result in a shadow that shifts down and to the right. A negative value will result in a shadow that shifts up and to the left.

Example

The following code example sets the visual attributes of a series.

Copy Code
' Set series shadow offset
Public Sub SetSeriesShadowOffset()
    Chart1.Series("Default"}.ShadowOffset = 2
End Sub 'SetSeriesVisualAttributes
Copy Code
// Set series shadow offset
public void SetSeriesShadowOffset ()
{
    Chart1.Series["Default"].ShadowOffset = 2;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.SmartLabelStyle Property

Series.SmartLabelStyle Property |
 | See Also

Gets or sets the style of the smart labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Property SmartLabelStyle As SmartLabelStyle
[BrowsableAttribute(true)]
public SmartLabelStyle SmartLabelStyle { get; set; }
[BrowsableAttribute(true)]
public:
property SmartLabelStyle^ SmartLabelStyle {
    SmartLabelStyle^ get ();
    void set (SmartLabelStyle^ value);
}
/** @property */
public SmartLabelStyle get_SmartLabelStyle ()

/** @property */
public void set_SmartLabelStyle (SmartLabelStyle value)

public function get SmartLabelStyle () : SmartLabelStyle

public function set SmartLabelStyle (value : SmartLabelStyle)

Property Value

A SmartLabelStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.XAxisType Property

Series.XAxisType Property |
 | See Also

Gets or sets the X-axis type of the series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property XAxisType As AxisType
public AxisType XAxisType { get; set; }
public:
property AxisType XAxisType {
    AxisType get ();
    void set (AxisType value);
}
/** @property */
public AxisType get_XAxisType ()

/** @property */
public void set_XAxisType (AxisType value)

public function get XAxisType () : AxisType

public function set XAxisType (value : AxisType)

Property Value

A XAxisType enumeration value that determines if the series uses the primary or secondary X-axis.

Remarks

For all chart types except horizontally oriented charts such as bar and stacked bar charts, and shape charts such as pie, doughnut, funnel and pyramid charts, the primary X-axis is always the lower axis and the secondary axis is the upper axis. For bar and stacked bar charts, the primary X-axis is the left axis, and the secondary X-axis is the right axis.

When data is plotted using the secondary X-axis, you must use the AxisX2 property to set axis properties, and not the AxisX property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.XValueMember Property

Series.XValueMember Property |
 | See Also

Gets or sets the member column of the chart data source used to data bind to the X-value of the series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property XValueMember As String
public string XValueMember { get; set; }
public:
property String^ XValueMember {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_XValueMember ()

/** @property */
public void set_XValueMember (String value)

public function get XValueMember () : String

public function set XValueMember (value : String)

Property Value

A string value.

Remarks

This property accepts either the name of the member column or the ordinal value of the member column.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.XValueType Property

Series.XValueType Property |
 | See Also

Gets or sets the value types plotted along the X-axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property XValueType As ChartValueType
public ChartValueType XValueType { get; set; }
public:
property ChartValueType XValueType {
    ChartValueType get ();
    void set (ChartValueType value);
}
/** @property */
public ChartValueType get_XValueType ()

/** @property */
public void set_XValueType (ChartValueType value)

public function get XValueType () : ChartValueType

public function set XValueType (value : ChartValueType)

Property Value

A ChartValueType enumeration value that determines the type of X-value data stored by the series. The default value is Auto.

Remarks

The XValueType property determines the type of data stored by the series.

Set this property to DateTime to allow the X-value to be entered as a DateTime value, and not as a Double. Date and time values are internally stored by .NET Framework as Double values. The same holds true for the ToPosition and FromPosition properties of CustomLabel objects.

The IntervalType property found in axis label, tick mark, and grid classes determines the interval type.

Note:
To correctly apply a DateTime format to axis labels that are generated from data point X-values, using the Format property, this property must be set to DateTime.

This property can also be used to determine the data type to which the X-values are bound.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.YAxisType Property

Series.YAxisType Property |
 | See Also

Gets or sets the Y-axis type of a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property YAxisType As AxisType
public AxisType YAxisType { get; set; }
public:
property AxisType YAxisType {
    AxisType get ();
    void set (AxisType value);
}
/** @property */
public AxisType get_YAxisType ()

/** @property */
public void set_YAxisType (AxisType value)

public function get YAxisType () : AxisType

public function set YAxisType (value : AxisType)

Property Value

An AxisType enumeration value that determines if a series uses the primary or secondary Y-axis.

Remarks

The YAxisType property determines if a series is plotted using the primary or secondary Y-axis.

For all chart types except pie, doughnut, range bar, bar and stacked bar charts, the primary Y-axis is the left vertical axis, and the secondary axis is the right vertical axis. For bar and stacked bar charts, the primary axis is the lower horizontal axis, and the secondary Y-axis is the upper horizontal axis.

When data is plotted using the secondary Y-axis, you must use the AxisY2 property to set axis properties, and not the AxisY property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.YValueMembers Property

Series.YValueMembers Property |
 | See Also

Gets or sets member columns of the chart data source used to bind data to the Y-values of the series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property YValueMembers As String
public string YValueMembers { get; set; }
public:
property String^ YValueMembers {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_YValueMembers ()

/** @property */
public void set_YValueMembers (String value)

public function get YValueMembers () : String

public function set YValueMembers (value : String)

Property Value

A string value.

Remarks

This property accepts a comma separated string that contains the names or ordinal values of the columns.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.YValuesPerPoint Property

Series.YValuesPerPoint Property |
 | See Also

Gets or sets the maximum number of Y-values that DataPoint objects in a Series are allowed to have.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property YValuesPerPoint As Integer
public int YValuesPerPoint { get; set; }
public:
property int YValuesPerPoint {
    int get ();
    void set (int value);
}
/** @property */
public int get_YValuesPerPoint ()

/** @property */
public void set_YValuesPerPoint (int value)

public function get YValuesPerPoint () : int

public function set YValuesPerPoint (value : int)

Property Value

An integer value that represents the maximum number of Y-values that the data points in a series are allowed to have. The default value to one (1).

Remarks

If you add a DataPoint object that has more Y-values than this property specifies, the excess Y-values will be ignored.

The number of Y-values that are required to properly display a chart depends on the chart type selected.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


Series.YValueType Property

Series.YValueType Property |
 | See Also

Gets or sets the type of Y-value data in the data points stored by a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property YValueType As ChartValueType
public ChartValueType YValueType { get; set; }
public:
property ChartValueType YValueType {
    ChartValueType get ();
    void set (ChartValueType value);
}
/** @property */
public ChartValueType get_YValueType ()

/** @property */
public void set_YValueType (ChartValueType value)

public function get YValueType () : ChartValueType

public function set YValueType (value : ChartValueType)

Property Value

A ChartValueType enumeration value that determines the type of Y-value data stored by the series. The default value is Auto.

Remarks

The YValueType property determines the type of data stored by the series. The value of this property is normally set to either Auto or DateTime.

The IntervalType property found in axis label, tick mark, and grid classes determines the interval type.

This property can also be used to determine the data type to which the Y-values are bound.

It is possible to plot date expressions as the values of data points, though this is rarely done. If you set this property to DateTime, the Y-value can then entered as a DateTime value, and not as a Double. Date and time values are internally stored by .NET Framework as Double values.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members
System.Web.UI.DataVisualization.Charting Namespace


SeriesChartType Enumeration

SeriesChartType Enumeration |
 | See Also

Specifies a chart type for a Series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration SeriesChartType
public enum SeriesChartType
public enum class SeriesChartType
public enum SeriesChartType
public enum SeriesChartType

Members

Member name | Description
Area | Area chart type.
Bar | Bar chart type.
BoxPlot | Box plot chart type.
Bubble | Bubble chart type.
Candlestick | Candlestick chart type.
Column | Column chart type.
Doughnut | Doughnut chart type.
ErrorBar | Error bar chart type.
FastLine | FastLine chart type.
FastPoint | FastPoint chart type.
Funnel | Funnel chart type.
Kagi | Kagi chart type.
Line | Line chart type.
Pie | Pie chart type.
Point | Point chart type.
PointAndFigure | PointAndFigure chart type.
Polar | Polar chart type.
Pyramid | Pyramid chart type.
Radar | Radar chart type.
Range | Range chart type.
RangeBar | RangeBar chart type.
RangeColumn | Range column chart type.
Renko | Renko chart type.
Spline | Spline chart type.
SplineArea | Spline area chart type.
SplineRange | Spline range chart type.
StackedArea | Stacked area chart type.
StackedArea100 | Hundred-percent stacked area chart type.
StackedBar | Stacked bar chart type.
StackedBar100 | Hundred-percent stacked bar chart type.
StackedColumn | Stacked column chart type.
StackedColumn100 | Hundred-percent stacked column chart type.
StepLine | StepLine chart type.
Stock | Stock chart type.
ThreeLineBreak | ThreeLineBreak chart type.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


SeriesCollection Class

SeriesCollection Class |
 | See Also Members

Represents a collection of Series objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class SeriesCollection
    Inherits ChartNamedElementCollection(Of Series)
public class SeriesCollection : ChartNamedElementCollection<Series>
public ref class SeriesCollection : public ChartNamedElementCollection<Series^>
public class SeriesCollection extends ChartNamedElementCollection<Series>
public class SeriesCollection extends ChartNamedElementCollection<Series>

Remarks

The SeriesCollection class represents a collection of Series objects, which in turn represent a grouping of related data points and attributes for the series. This collection class is implemented as the Series collection property of the root Chart object.

Series objects can be appended, inserted or removed from the collection at both design time and run time.

When a series is added to the collection, it is automatically assigned to the ChartArea object named "Default" or, if "Default" does not exist, to the first available chart area in the chart area collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.SeriesCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SeriesCollection Members
System.Web.UI.DataVisualization.Charting Namespace


SeriesCollection Members

SeriesCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of Series objects.

The following tables list the members exposed by the SeriesCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

SeriesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


SeriesCollection Methods

SeriesCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

SeriesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


SeriesCollection.Add Method

SeriesCollection.Add Method |
 | See Also

Overload List

Name | Description
SeriesCollection.Add (Series) | (inherited from Add )
SeriesCollection.Add (String) | Adds a Series object with the given name to the end of the collection.

See Also

Reference

SeriesCollection Class
SeriesCollection Members
System.Web.UI.DataVisualization.Charting Namespace


SeriesCollection.Add Method (String)

SeriesCollection.Add Method (String) |
 | See Also

Adds a Series object with the given name to the end of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As Series
public Series Add (
    string name
)
public:
Series^ Add (
    String^ name
)
public Series Add (
    String name
)
public function Add (
    name : String
) : Series

Parameters

name

The name of the Series to be added.

Return Value

The new Series object appended to the collection. .

Remarks

Items are always added as the last item in the collection.

The name argument refers to the Name property of the object being added.

Note If you use this method to add Series objects to the SeriesCollection class, the associated DataPoint objects of the newly added Series object cannot have more than one Y-value per data point. To add a series that can handle multiple Y-values per data point, use the Add definition of this overloaded method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SeriesCollection Class
SeriesCollection Members
System.Web.UI.DataVisualization.Charting Namespace


SeriesCollection Properties

SeriesCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

SeriesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle Class

SmartLabelStyle Class |
 | See Also Example Members

Provides methods and properties used to perform intelligent, rule-based data point label positioning to resolve overlapping data point label issues.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class SmartLabelStyle
public class SmartLabelStyle
public ref class SmartLabelStyle
public class SmartLabelStyle
public class SmartLabelStyle

Remarks

When smart labels are enabled, the chart repositions overlapping data point labels, based on a set of user-defined rules.

Callout lines will be drawn to link the label with its data point. The visual attributes of the callout line can be controlled. These visual attributes include color, line style, and line width. The CalloutStyle and CalloutLineAnchorCapStyle properties control the embellishments, such as arrowheads, that appear at the end of the callout line.

The CalloutLineColor property can be set to any Color object. If you set the color of the callout line, you will also automatically set the color of the CalloutLineAnchorCapStyle and the embellishment defined by the CalloutStyle.

The CalloutLineWidth property controls the pixel width of the callout line. Use of this property will also scale the embellishments of the CalloutLineAnchorCapStyle and the CalloutStyle.

The movement of smart labels can be controlled through the use of several motion-related properties. These define the rules of movement for the direction, distance and whether the data point label is allowed to leave the plotting area. The default movement rules will normally resolve most issues. The MaxMovingDistance defines a value that specifies the maximum distance in pixels from the data point that data point labels are allowed to be moved in case of overlapping. The MinMovingDistance property defines a value that specifies the minimum distance in pixels from the data point that data point labels will be moved in case of overlapping. When a data point label needs to be repositioned, the label will be moved by at least the number of pixels specified.

The IsOverlappedHidden property indicates whether the labels are hidden when overlapping issues cannot be resolved. If the IsOverlappedHidden property is true, and the data point cannot be drawn within the region specified by MinMovingDistance and MaxMovingDistance in the directions allowed by MovingDirection, the data point label will not be drawn.

The MovingDirection property defines the direction(s) in which the data point label can be moved. This property accepts one LabelAlignmentStyles value or a bitwise-OR of multiple LabelAlignmentStyles values. The default is the bitwise-OR of all LabelAlignmentStyles values, to allow repositioning in all possible directions except to the center of the data point.

Smart labels are not supported for the following chart types:

  • Bar charts: bar and hundred-percent-stacked bar charts.

  • Shape charts: pie, doughnut, polar and radar charts.

  • Range charts: range, range column and range bar charts.

  • Stacked area charts: stacked area and hundred-percent-stacked area charts.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.SmartLabelStyle
System.Web.UI.DataVisualization.Charting.AnnotationSmartLabelStyle

Example

Copy Code
Imports System.Web.UI.DataVisualization.Charting

Private Function SetSmartLabelsOptions()

   ' Enabling the SmartLabels™ attribute.
   Chart1.Series("Series1").SmartLabels.Enabled = true

   ' Set the callout style.
   Chart1.Series("Series1").SmartLabels.CalloutStyle = LabelCalloutStyle.Underlined

   ' Set the callout line color.
   Chart1.Series("Series1").SmartLabels.CalloutLineColor = Color.Goldenrod;

   ' Set the callout line style.
   Chart1.Series("Series1").SmartLabels.CalloutLineStyle = ChartDashStyle.Dash

   ' Set the callout line width.
   Chart1.Series("Series1").SmartLabels.CalloutLineWidth = 3

   ' Set the callout line anchor cap.
   Chart1.Series("Series1").SmartLabels.CalloutLineAnchorCap = LineAnchorCap.Arrow
End Function
Copy Code
using System.Web.UI.DataVisualization.Charting

private void SetSmartLabelsOptions()
{
   // Enabling the SmartLabels™ attribute.
   Chart1.Series["Series1"].SmartLabels.Enabled = true;

   // Set the callout style.
   Chart1.Series["Series1"].SmartLabels.CalloutStyle = LabelCalloutStyle.Underlined;

   // Set the callout line color.
   Chart1.Series["Series1"].SmartLabels.CalloutLineColor = Color.Goldenrod;

   // Set the callout line style.
   Chart1.Series["Series1"].SmartLabels.CalloutLineStyle = ChartDashStyle.Dash;

   // Set the callout line width.
   Chart1.Series["Series1"].SmartLabels.CalloutLineWidth = 3;

   // Set the callout line anchor cap.
   Chart1.Series["Series1"].SmartLabels.CalloutLineAnchorCap = LineAnchorCap.Arrow;
}

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle Members

SmartLabelStyle Members |
 | See Also Constructors Methods Properties

Provides methods and properties used to perform intelligent, rule-based data point label positioning to resolve overlapping data point label issues.

The following tables list the members exposed by the SmartLabelStyle type.

Public Constructors

Name | Description
SmartLabelStyle | Initializes a new instance of the SmartLabelStyle class.
Top

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area.
CalloutBackColor | Gets or sets the background color of the label callout.
CalloutLineAnchorCapStyle | Gets or sets the anchor cap style of the label callout line.
CalloutLineColor | Gets or sets the color of the label callout line.
CalloutLineDashStyle | Gets or sets the style of the label callout line.
CalloutLineWidth | Gets or sets the width of the label callout line.
CalloutStyle | Gets or sets the callout style of the repositioned SmartLabelStyle object.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled.
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker.
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden.
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

SmartLabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle Constructor

SmartLabelStyle Constructor |
 | See Also

Initializes a new instance of the SmartLabelStyle class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public SmartLabelStyle ()
public:
SmartLabelStyle ()
public SmartLabelStyle ()
public function SmartLabelStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle Methods

SmartLabelStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

SmartLabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle Properties

SmartLabelStyle Properties |
 | See Also

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area.
CalloutBackColor | Gets or sets the background color of the label callout.
CalloutLineAnchorCapStyle | Gets or sets the anchor cap style of the label callout line.
CalloutLineColor | Gets or sets the color of the label callout line.
CalloutLineDashStyle | Gets or sets the style of the label callout line.
CalloutLineWidth | Gets or sets the width of the label callout line.
CalloutStyle | Gets or sets the callout style of the repositioned SmartLabelStyle object.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled.
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker.
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden.
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved.

See Also

Reference

SmartLabelStyle Class
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.AllowOutsidePlotArea Property

SmartLabelStyle.AllowOutsidePlotArea Property |
 | See Also

Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property AllowOutsidePlotArea As LabelOutsidePlotAreaStyle
public virtual LabelOutsidePlotAreaStyle AllowOutsidePlotArea { get; set; }
public:
virtual property LabelOutsidePlotAreaStyle AllowOutsidePlotArea {
    LabelOutsidePlotAreaStyle get ();
    void set (LabelOutsidePlotAreaStyle value);
}
/** @property */
public LabelOutsidePlotAreaStyle get_AllowOutsidePlotArea ()

/** @property */
public void set_AllowOutsidePlotArea (LabelOutsidePlotAreaStyle value)

public function get AllowOutsidePlotArea () : LabelOutsidePlotAreaStyle

public function set AllowOutsidePlotArea (value : LabelOutsidePlotAreaStyle)

Property Value

A LabelOutsidePlotAreaStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.CalloutBackColor Property

SmartLabelStyle.CalloutBackColor Property |
 | See Also

Gets or sets the background color of the label callout.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutBackColor As Color
public virtual Color CalloutBackColor { get; set; }
public:
virtual property Color CalloutBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_CalloutBackColor ()

/** @property */
public void set_CalloutBackColor (Color value)

public function get CalloutBackColor () : Color

public function set CalloutBackColor (value : Color)

Property Value

A Color value.

Remarks

This property is only applicable when the CalloutStyle property is set to a value of Box.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.CalloutLineAnchorCapStyle Property

SmartLabelStyle.CalloutLineAnchorCapStyle Property |
 | See Also

Gets or sets the anchor cap style of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineAnchorCapStyle As LineAnchorCapStyle
public virtual LineAnchorCapStyle CalloutLineAnchorCapStyle { get; set; }
public:
virtual property LineAnchorCapStyle CalloutLineAnchorCapStyle {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_CalloutLineAnchorCapStyle ()

/** @property */
public void set_CalloutLineAnchorCapStyle (LineAnchorCapStyle value)

public function get CalloutLineAnchorCapStyle () : LineAnchorCapStyle

public function set CalloutLineAnchorCapStyle (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.CalloutLineColor Property

SmartLabelStyle.CalloutLineColor Property |
 | See Also

Gets or sets the color of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineColor As Color
public virtual Color CalloutLineColor { get; set; }
public:
virtual property Color CalloutLineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_CalloutLineColor ()

/** @property */
public void set_CalloutLineColor (Color value)

public function get CalloutLineColor () : Color

public function set CalloutLineColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.CalloutLineDashStyle Property

SmartLabelStyle.CalloutLineDashStyle Property |
 | See Also

Gets or sets the style of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineDashStyle As ChartDashStyle
public virtual ChartDashStyle CalloutLineDashStyle { get; set; }
public:
virtual property ChartDashStyle CalloutLineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_CalloutLineDashStyle ()

/** @property */
public void set_CalloutLineDashStyle (ChartDashStyle value)

public function get CalloutLineDashStyle () : ChartDashStyle

public function set CalloutLineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.CalloutLineWidth Property

SmartLabelStyle.CalloutLineWidth Property |
 | See Also

Gets or sets the width of the label callout line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineWidth As Integer
public virtual int CalloutLineWidth { get; set; }
public:
virtual property int CalloutLineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_CalloutLineWidth ()

/** @property */
public void set_CalloutLineWidth (int value)

public function get CalloutLineWidth () : int

public function set CalloutLineWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.CalloutStyle Property

SmartLabelStyle.CalloutStyle Property |
 | See Also

Gets or sets the callout style of the repositioned SmartLabelStyle object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property CalloutStyle As LabelCalloutStyle
public virtual LabelCalloutStyle CalloutStyle { get; set; }
public:
virtual property LabelCalloutStyle CalloutStyle {
    LabelCalloutStyle get ();
    void set (LabelCalloutStyle value);
}
/** @property */
public LabelCalloutStyle get_CalloutStyle ()

/** @property */
public void set_CalloutStyle (LabelCalloutStyle value)

public function get CalloutStyle () : LabelCalloutStyle

public function set CalloutStyle (value : LabelCalloutStyle)

Property Value

A LabelCalloutStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.Enabled Property

SmartLabelStyle.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Enabled As Boolean
public virtual bool Enabled { get; set; }
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if an algorithm will be applied to prevent data point labels from overlapping. False if overlapping of data point labels will not be prevented. The default value is True.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.IsMarkerOverlappingAllowed Property

SmartLabelStyle.IsMarkerOverlappingAllowed Property |
 | See Also

Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property IsMarkerOverlappingAllowed As Boolean
public virtual bool IsMarkerOverlappingAllowed { get; set; }
public:
virtual property bool IsMarkerOverlappingAllowed {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMarkerOverlappingAllowed ()

/** @property */
public void set_IsMarkerOverlappingAllowed (boolean value)

public function get IsMarkerOverlappingAllowed () : boolean

public function set IsMarkerOverlappingAllowed (value : boolean)

Property Value

True if data point labels are permitted to overlap point markers. False if data point labels will be prevented from overlapping the point markers. The default value is false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.IsOverlappedHidden Property

SmartLabelStyle.IsOverlappedHidden Property |
 | See Also

Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property IsOverlappedHidden As Boolean
public virtual bool IsOverlappedHidden { get; set; }
public:
virtual property bool IsOverlappedHidden {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsOverlappedHidden ()

/** @property */
public void set_IsOverlappedHidden (boolean value)

public function get IsOverlappedHidden () : boolean

public function set IsOverlappedHidden (value : boolean)

Property Value

True if labels will be hidden if they overlap. False if overlapped labels will not be hidden. The default value is True.

Remarks

If the point cannot be drawn within the region specified by the properties MinMovingDistance and MaxMovingDistance, in the directions allowed by the MovingDirection, property, and this property is true, the data point label will not be drawn.

Note:
Smart labels only work when the Angle property is set to zero.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.MaxMovingDistance Property

SmartLabelStyle.MaxMovingDistance Property |
 | See Also

Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MaxMovingDistance As Double
public virtual double MaxMovingDistance { get; set; }
public:
virtual property double MaxMovingDistance {
    double get ();
    void set (double value);
}
/** @property */
public double get_MaxMovingDistance ()

/** @property */
public void set_MaxMovingDistance (double value)

public function get MaxMovingDistance () : double

public function set MaxMovingDistance (value : double)

Property Value

A double value.

Remarks

This property specifies the maximum distance in pixels from the data point that data point labels are allowed to be moved in case of overlapping.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.MinMovingDistance Property

SmartLabelStyle.MinMovingDistance Property |
 | See Also

Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MinMovingDistance As Double
public virtual double MinMovingDistance { get; set; }
public:
virtual property double MinMovingDistance {
    double get ();
    void set (double value);
}
/** @property */
public double get_MinMovingDistance ()

/** @property */
public void set_MinMovingDistance (double value)

public function get MinMovingDistance () : double

public function set MinMovingDistance (value : double)

Property Value

A double value.

Remarks

This property specifies the minimum distance in pixels from the data point that data point labels are allowed to be moved in case of overlapping.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


SmartLabelStyle.MovingDirection Property

SmartLabelStyle.MovingDirection Property |
 | See Also

Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property MovingDirection As LabelAlignmentStyles
public virtual LabelAlignmentStyles MovingDirection { get; set; }
public:
virtual property LabelAlignmentStyles MovingDirection {
    LabelAlignmentStyles get ();
    void set (LabelAlignmentStyles value);
}
/** @property */
public LabelAlignmentStyles get_MovingDirection ()

/** @property */
public void set_MovingDirection (LabelAlignmentStyles value)

public function get MovingDirection () : LabelAlignmentStyles

public function set MovingDirection (value : LabelAlignmentStyles)

Property Value

A LabelAlignmentStyles enumeration value or multiple bitwise OR'd LabelAlignmentStyles values. The default is the bitwise OR of all LabelAlignmentStyles values to allow repositioning in all directions except to the center of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members
System.Web.UI.DataVisualization.Charting Namespace


StartFromZero Enumeration

StartFromZero Enumeration |
 | See Also

Indicates whether an axis segment should start from zero when a scale break is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration StartFromZero
public enum StartFromZero
public enum class StartFromZero
public enum StartFromZero
public enum StartFromZero

Members

Member name | Description
Auto | The Chart control calculates whether to start the axis scale at zero or at a more appropriate rounded value.
No | Do not start the axis segment scale from zero.
Yes | Start the axis segment scale from zero.

Remarks

The StartFromZero enumeration is used to set the value of the StartFromZero property and indicates whether an axis segment should start from zero.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula Class

StatisticFormula Class |
 | See Also Members

Calculates statistical formulas.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class StatisticFormula
public class StatisticFormula
public ref class StatisticFormula
public class StatisticFormula
public class StatisticFormula

Remarks

Formulas can be loosely grouped into the following categories: distributions, including inverse distributions; tests; and basic statistical formulas. Each group has common characteristics with respect to their input and return values.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.StatisticFormula

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula Members

StatisticFormula Members |
 | See Also Methods

Calculates statistical formulas.

The following tables list the members exposed by the StatisticFormula type.

Public Methods (see also Protected Methods )

Name | Description
Anova | Performs an ANOVA test to determine whether there is a statistically significant difference between the mean values of two or more groups of data.
BetaFunction | Returns the beta function value for two given values.
Correlation | Returns the correlation value for two data series.
Covariance | Returns the covariance value for two data series.
Equals | Overloaded. (inherited from Object )
FDistribution | Returns the cumulative F distribution function probability.
FTest | Performs a two-sample F Test using the F distribution. This test is used to determine if the samples have different variances.
GammaFunction | Returns the gamma function value for the given variable.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
InverseFDistribution | Returns the inverse of the F cumulative distribution.
InverseNormalDistribution | Returns the inverse of the standard normal cumulative distribution.
InverseTDistribution | Returns the inverse t-value of the Students t-distribution as a function of probability and degree of freedom.
Mean | Returns the average of all data points stored in the specified series.
Median | Returns the median of all data points in the specified series.
NormalDistribution | Returns the probability for the standard normal cumulative distribution function.
ReferenceEquals | (inherited from Object )
TDistribution | Returns the probability for the T distribution (Student's distribution).
ToString | (inherited from Object )
TTestEqualVariances | Performs a T Test using Student's distribution (T distribution) with equal variances.
TTestPaired | Performs a T Test using Student's distribution (T distribution) with paired samples. This is useful when there is a natural pairing of observations in samples.
TTestUnequalVariances | Performs a T Test using Student's distribution (T distribution) with unequal variances.
Variance | Returns the variance for a series.
ZTest | Performs a Z Test using the normal distribution.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

StatisticFormula Class
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula Methods

StatisticFormula Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Anova | Performs an ANOVA test to determine whether there is a statistically significant difference between the mean values of two or more groups of data.
BetaFunction | Returns the beta function value for two given values.
Correlation | Returns the correlation value for two data series.
Covariance | Returns the covariance value for two data series.
Equals | Overloaded. (inherited from Object )
FDistribution | Returns the cumulative F distribution function probability.
FTest | Performs a two-sample F Test using the F distribution. This test is used to determine if the samples have different variances.
GammaFunction | Returns the gamma function value for the given variable.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
InverseFDistribution | Returns the inverse of the F cumulative distribution.
InverseNormalDistribution | Returns the inverse of the standard normal cumulative distribution.
InverseTDistribution | Returns the inverse t-value of the Students t-distribution as a function of probability and degree of freedom.
Mean | Returns the average of all data points stored in the specified series.
Median | Returns the median of all data points in the specified series.
NormalDistribution | Returns the probability for the standard normal cumulative distribution function.
ReferenceEquals | (inherited from Object )
TDistribution | Returns the probability for the T distribution (Student's distribution).
ToString | (inherited from Object )
TTestEqualVariances | Performs a T Test using Student's distribution (T distribution) with equal variances.
TTestPaired | Performs a T Test using Student's distribution (T distribution) with paired samples. This is useful when there is a natural pairing of observations in samples.
TTestUnequalVariances | Performs a T Test using Student's distribution (T distribution) with unequal variances.
Variance | Returns the variance for a series.
ZTest | Performs a Z Test using the normal distribution.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

StatisticFormula Class
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.Anova Method

StatisticFormula.Anova Method |
 | See Also

Performs an ANOVA test to determine whether there is a statistically significant difference between the mean values of two or more groups of data.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Anova ( _
    probability As Double, _
    inputSeriesNames As String _
) As AnovaResult
public AnovaResult Anova (
    double probability,
    string inputSeriesNames
)
public:
AnovaResult^ Anova (
    double probability,
    String^ inputSeriesNames
)
public AnovaResult Anova (
    double probability,
    String inputSeriesNames
)
public function Anova (
    probability : double,
    inputSeriesNames : String
) : AnovaResult

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

inputSeriesNames

A comma-delimited list of input series names.

Return Value

An AnovaResult object.

Remarks

An ANOVA test is used to test the difference between the means of two or more groups of data.

Two or more groups of series data must be specified, and each series must have the same number of data points; otherwise, an exception will be raised.

If a specified input series does not exist in the SeriesCollection at the time of the method call, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.BetaFunction Method

StatisticFormula.BetaFunction Method |
 | See Also

Returns the beta function value for two given values.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function BetaFunction ( _
    m As Double, _
    n As Double _
) As Double
public double BetaFunction (
    double m,
    double n
)
public:
double BetaFunction (
    double m,
    double n
)
public double BetaFunction (
    double m,
    double n
)
public function BetaFunction (
    m : double,
    n : double
) : double

Parameters

m

The first value for the beta function.

n

The second value for the beta function.

Return Value

A double value that represents the beta function for the two given values.

Remarks

This method returns the beta function value for two given values that are specified by m and n.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.Correlation Method

StatisticFormula.Correlation Method |
 | See Also

Returns the correlation value for two data series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Correlation ( _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As Double
public double Correlation (
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
double Correlation (
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public double Correlation (
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function Correlation (
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : double

Parameters

firstInputSeriesName

The first input series name.

secondInputSeriesName

The second input series name.

Return Value

A double value that represents the correlation between two data series.

Remarks

Correlation measures the relationship between two data sets that are scaled to be independent of the unit of measurement. The Correlation method returns the covariance of two data sets divided by the product of their standard deviations, and always ranges from -1 to 1.

Use correlation to determine whether two ranges of data move together; that is, whether large values of one set are associated with large values of the other (positive correlation), whether small values of one set are associated with large values of the other (negative correlation), or whether values in both sets are unrelated (correlation near zero).

If a specified input series does not exist in the series collection at the time of the method call, an exception will be thrown. An exception will also be raised if the specified series do not have the same number of data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.Covariance Method

StatisticFormula.Covariance Method |
 | See Also

Returns the covariance value for two data series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Covariance ( _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As Double
public double Covariance (
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
double Covariance (
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public double Covariance (
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function Covariance (
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : double

Parameters

firstInputSeriesName

The first input series name.

secondInputSeriesName

The second input series name.

Return Value

A double value that represents the covariance between two data series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.FDistribution Method

StatisticFormula.FDistribution Method |
 | See Also

Returns the cumulative F distribution function probability.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FDistribution ( _
    value As Double, _
    firstDegreeOfFreedom As Integer, _
    secondDegreeOfFreedom As Integer _
) As Double
public double FDistribution (
    double value,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public:
double FDistribution (
    double value,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public double FDistribution (
    double value,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public function FDistribution (
    value : double,
    firstDegreeOfFreedom : int,
    secondDegreeOfFreedom : int
) : double

Parameters

value

The F value.

firstDegreeOfFreedom

First degree of freedom.

secondDegreeOfFreedom

Second degree of freedom.

Return Value

A double value that represents the cumulative F distribution function probability.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.FTest Method

StatisticFormula.FTest Method |
 | See Also

Performs a two-sample F Test using the F distribution. This test is used to determine if the samples have different variances.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function FTest ( _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As FTestResult
public FTestResult FTest (
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
FTestResult^ FTest (
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public FTestResult FTest (
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function FTest (
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : FTestResult

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

An FTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.GammaFunction Method

StatisticFormula.GammaFunction Method |
 | See Also

Returns the gamma function value for the given variable.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function GammaFunction ( _
    value As Double _
) As Double
public double GammaFunction (
    double value
)
public:
double GammaFunction (
    double value
)
public double GammaFunction (
    double value
)
public function GammaFunction (
    value : double
) : double

Parameters

value

The input variable.

Return Value

A double value that represents the gamma function.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.InverseFDistribution Method

StatisticFormula.InverseFDistribution Method |
 | See Also

Returns the inverse of the F cumulative distribution.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function InverseFDistribution ( _
    probability As Double, _
    firstDegreeOfFreedom As Integer, _
    secondDegreeOfFreedom As Integer _
) As Double
public double InverseFDistribution (
    double probability,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public:
double InverseFDistribution (
    double probability,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public double InverseFDistribution (
    double probability,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public function InverseFDistribution (
    probability : double,
    firstDegreeOfFreedom : int,
    secondDegreeOfFreedom : int
) : double

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstDegreeOfFreedom

First degree of freedom.

secondDegreeOfFreedom

Second degree of freedom.

Return Value

A double value from the inverse F distribution function.

Remarks

This method returns the F value for the given F distribution probability.

The F distribution can be used in an F-test that compares the degree of variability in two data sets. For example, income distributions in the United States and Canada can be analyzed to determine whether the two countries have a similar degree of diversity.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.InverseNormalDistribution Method

StatisticFormula.InverseNormalDistribution Method |
 | See Also

Returns the inverse of the standard normal cumulative distribution.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function InverseNormalDistribution ( _
    probability As Double _
) As Double
public double InverseNormalDistribution (
    double probability
)
public:
double InverseNormalDistribution (
    double probability
)
public double InverseNormalDistribution (
    double probability
)
public function InverseNormalDistribution (
    probability : double
) : double

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

Return Value

A double value from the inverse standard normal cumulative distribution function.

Remarks

This method returns the F value for the given F distribution probability.

It is assumed that the distribution has a mean of 0 (zero) and a standard deviation of one.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.InverseTDistribution Method

StatisticFormula.InverseTDistribution Method |
 | See Also

Returns the inverse t-value of the Students t-distribution as a function of probability and degree of freedom.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function InverseTDistribution ( _
    probability As Double, _
    degreeOfFreedom As Integer _
) As Double
public double InverseTDistribution (
    double probability,
    int degreeOfFreedom
)
public:
double InverseTDistribution (
    double probability,
    int degreeOfFreedom
)
public double InverseTDistribution (
    double probability,
    int degreeOfFreedom
)
public function InverseTDistribution (
    probability : double,
    degreeOfFreedom : int
) : double

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

degreeOfFreedom

The degree of freedom.

Return Value

A double value that represents the inverse T distribution.

Remarks

This method returns the t value for the given T distribution probability.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.Mean Method

StatisticFormula.Mean Method |
 | See Also

Returns the average of all data points stored in the specified series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Mean ( _
    inputSeriesName As String _
) As Double
public double Mean (
    string inputSeriesName
)
public:
double Mean (
    String^ inputSeriesName
)
public double Mean (
    String inputSeriesName
)
public function Mean (
    inputSeriesName : String
) : double

Parameters

inputSeriesName

Input series name.

Return Value

A double value that represents the average of all data points.

Remarks

Use this method to calculate the mean (that is, the average) of the points stored in a series.

If the specified input series does not exist in the SeriesCollection at the time of the method call, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.Median Method

StatisticFormula.Median Method |
 | See Also

Returns the median of all data points in the specified series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Median ( _
    inputSeriesName As String _
) As Double
public double Median (
    string inputSeriesName
)
public:
double Median (
    String^ inputSeriesName
)
public double Median (
    String inputSeriesName
)
public function Median (
    inputSeriesName : String
) : double

Parameters

inputSeriesName

Input series name.

Return Value

A double value that represents the median.

Remarks

Use this method to calculate the median of the points stored in a series.

The median is the middle value of a sample set, where half of the members are greater in size and half the members are lesser in size.

If the specified input series does not exist in the SeriesCollection at the time of the method call, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.NormalDistribution Method

StatisticFormula.NormalDistribution Method |
 | See Also

Returns the probability for the standard normal cumulative distribution function.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function NormalDistribution ( _
    zValue As Double _
) As Double
public double NormalDistribution (
    double zValue
)
public:
double NormalDistribution (
    double zValue
)
public double NormalDistribution (
    double zValue
)
public function NormalDistribution (
    zValue : double
) : double

Parameters

zValue

The Z value for which the probability is required.

Return Value

A double value from the standard normal cumulative distribution function.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.TDistribution Method

StatisticFormula.TDistribution Method |
 | See Also

Returns the probability for the T distribution (Student's distribution).

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function TDistribution ( _
    value As Double, _
    degreeOfFreedom As Integer, _
    oneTail As Boolean _
) As Double
public double TDistribution (
    double value,
    int degreeOfFreedom,
    bool oneTail
)
public:
double TDistribution (
    double value,
    int degreeOfFreedom,
    bool oneTail
)
public double TDistribution (
    double value,
    int degreeOfFreedom,
    boolean oneTail
)
public function TDistribution (
    value : double,
    degreeOfFreedom : int,
    oneTail : boolean
) : double

Parameters

value

The T value

degreeOfFreedom

Degree of freedom

oneTail

If true, a one-tailed distribution is used; otherwise, a two-tailed distribution is used.

Return Value

A double value that represents a T Distribution cumulative function.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.TTestEqualVariances Method

StatisticFormula.TTestEqualVariances Method |
 | See Also

Performs a T Test using Student's distribution (T distribution) with equal variances.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function TTestEqualVariances ( _
    hypothesizedMeanDifference As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As TTestResult
public TTestResult TTestEqualVariances (
    double hypothesizedMeanDifference,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
TTestResult^ TTestEqualVariances (
    double hypothesizedMeanDifference,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public TTestResult TTestEqualVariances (
    double hypothesizedMeanDifference,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function TTestEqualVariances (
    hypothesizedMeanDifference : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : TTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A TTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.TTestPaired Method

StatisticFormula.TTestPaired Method |
 | See Also

Performs a T Test using Student's distribution (T distribution) with paired samples. This is useful when there is a natural pairing of observations in samples.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function TTestPaired ( _
    hypothesizedMeanDifference As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As TTestResult
public TTestResult TTestPaired (
    double hypothesizedMeanDifference,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
TTestResult^ TTestPaired (
    double hypothesizedMeanDifference,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public TTestResult TTestPaired (
    double hypothesizedMeanDifference,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function TTestPaired (
    hypothesizedMeanDifference : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : TTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A TTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.TTestUnequalVariances Method

StatisticFormula.TTestUnequalVariances Method |
 | See Also

Performs a T Test using Student's distribution (T distribution) with unequal variances.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function TTestUnequalVariances ( _
    hypothesizedMeanDifference As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As TTestResult
public TTestResult TTestUnequalVariances (
    double hypothesizedMeanDifference,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
TTestResult^ TTestUnequalVariances (
    double hypothesizedMeanDifference,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public TTestResult TTestUnequalVariances (
    double hypothesizedMeanDifference,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function TTestUnequalVariances (
    hypothesizedMeanDifference : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : TTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A TTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.Variance Method

StatisticFormula.Variance Method |
 | See Also

Returns the variance for a series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Variance ( _
    inputSeriesName As String, _
    sampleVariance As Boolean _
) As Double
public double Variance (
    string inputSeriesName,
    bool sampleVariance
)
public:
double Variance (
    String^ inputSeriesName,
    bool sampleVariance
)
public double Variance (
    String inputSeriesName,
    boolean sampleVariance
)
public function Variance (
    inputSeriesName : String,
    sampleVariance : boolean
) : double

Parameters

inputSeriesName

The input series name.

sampleVariance

True if the data is a sample of the population; false if the data is the entire population.

Return Value

A double value that represents the variance.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StatisticFormula.ZTest Method

StatisticFormula.ZTest Method |
 | See Also

Performs a Z Test using the normal distribution.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function ZTest ( _
    hypothesizedMeanDifference As Double, _
    varianceFirstGroup As Double, _
    varianceSecondGroup As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As ZTestResult
public ZTestResult ZTest (
    double hypothesizedMeanDifference,
    double varianceFirstGroup,
    double varianceSecondGroup,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
ZTestResult^ ZTest (
    double hypothesizedMeanDifference,
    double varianceFirstGroup,
    double varianceSecondGroup,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public ZTestResult ZTest (
    double hypothesizedMeanDifference,
    double varianceFirstGroup,
    double varianceSecondGroup,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function ZTest (
    hypothesizedMeanDifference : double,
    varianceFirstGroup : double,
    varianceSecondGroup : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : ZTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

varianceFirstGroup

Variance of the first group.

varianceSecondGroup

Variance of the second group.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A ZTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine Class

StripLine Class |
 | See Also Example Members

Represents the strip lines on a chart.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class StripLine
    Inherits ChartElement
    Implements IChartMapArea
public class StripLine : ChartElement, IChartMapArea
public ref class StripLine : public ChartElement, IChartMapArea
public class StripLine extends ChartElement implements IChartMapArea
public class StripLine extends ChartElement implements IChartMapArea

Remarks

Strip lines, or strips, are horizontal or vertical ranges that shade the background of a chart in regular or custom intervals. You can use strip lines to:

  • Improve readability for looking up individual values on the chart.

  • Separate data points when reading the chart.

  • Highlight dates that occur at regular intervals, for example, to identify weekend data points.

  • Highlight a specific key range of data.

  • Add a threshold line at a specific constant value.

A single StripLine object can either be drawn once, or repeatedly, for a given interval. This action is controlled by the Interval property. When a value of zero is assigned to the Interval property, one strip line will be drawn. When a non-zero value is assigned to the Interval property, a strip line will be drawn repeatedly at each given interval. The location where a strip line is drawn is also affected by the IntervalOffset and IntervalOffsetType properties of the strip line.

Strip lines are always associated with an Axis object. They can be added at both design time and run time.

To add a horizontal or vertical line to display a threshold, set the StripWidth property to a value of 0.0. This will result in a line being drawn. You can use the BorderColor, BorderDashStyle and BorderWidth properties for the color, width and style of the line. No chart background properties (Back*) are used when the StripWidth property is set to 0.0.

Use the Text property of the strip line to associate text with a strip line. The placement and orientation of this text can be controlled by the TextAlignment property.

When multiple strip lines are defined for the same axis, it is possible that the strip lines will overlap. The Z-order of StripLine objects is determined by their order of occurrence in the StripLinesCollection object. This means that the first occurrence is drawn first; the second occurrence is drawn second, and so on.

Strip lines are not supported for the following chart types: Pie, Doughnut, Funnel, Pyramid, Kagi, ThreeLineBreak, PointAndFigure, Polar and Radar.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.StripLine

Example

The following code example demonstrates three applications of strip lines. First, horizontal strip lines are added at recurring intervals. Second, vertical strip lines are added to highlight weekend data points. Lastly, a non-recurring strip line is added to denote the mean of the data points in the first series of the chart.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds repeating horizontal strip lines.

AddHorizRepeatingStripLines()

' Highlights weekend points using strip lines.

HighlightWeekendsWithStripLines()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

' Adds a week of data with values between 20 and 35.

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

' Adds repeating horizontal strip lines at intervals of 5.

Private Sub AddHorizRepeatingStripLines()

' Instantiate new strip line

Dim stripLine1 As New StripLine()

stripLine1.StripWidth = 2.5

stripLine1.Interval = 5

' Consider adding transparency so that the strip lines are lighter

stripLine1.BackColor = Color.FromArgb(120, Color.Red)

' Add the strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine1)

End Sub

' Adds strip lines to highlight weekend values.

Private Sub HighlightWeekendsWithStripLines()

' Set strip line to highlight weekends

Dim stripLine2 As New StripLine()

stripLine2.BackColor = Color.FromArgb(120, Color.Gold)

stripLine2.IntervalOffset = -1.5

stripLine2.IntervalOffsetType = DateTimeIntervalType.Days

stripLine2.Interval = 1

stripLine2.IntervalType = DateTimeIntervalType.Weeks

stripLine2.StripWidth = 2

stripLine2.StripWidthType = DateTimeIntervalType.Days

' Add strip line to the chart

chart1.ChartAreas(0).AxisX.StripLines.Add(stripLine2)

' Set the axis label to show the name of the day

' This is done in order to demonstrate that weekends are highlighted

chart1.ChartAreas(0).AxisX.LabelStyle.Format = "ddd"

End Sub

' Adds a horizontal threshold strip line at the mean value of the first series.

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds repeating horizontal strip lines.
            AddHorizRepeatingStripLines();

            // Highlights weekend points using strip lines.
            HighlightWeekendsWithStripLines();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds repeating horizontal strip lines at intervals of 5.
        /// </summary>
        private void AddHorizRepeatingStripLines()
        {
            // Instantiate new strip line
            StripLine stripLine1 = new StripLine();
            stripLine1.StripWidth = 0;
            stripLine1.BorderColor = Color.Black;
            stripLine1.BorderWidth = 3;
            stripLine1.Interval = 5;

            // Consider adding transparency so that the strip lines are lighter
            stripLine1.BackColor = Color.FromArgb(120, Color.Red);

            stripLine1.BackSecondaryColor = Color.Black;
            stripLine1.BackGradientStyle = GradientStyle.LeftRight;

            // Add the strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine1);
        }

        /// <summary>
        /// Adds strip lines to highlight weekend values.
        /// </summary>
        private void HighlightWeekendsWithStripLines()
        {
            // Set strip line to highlight weekends
            StripLine stripLine2 = new StripLine();
            stripLine2.BackColor = Color.FromArgb(120, Color.Gold);
            stripLine2.IntervalOffset = -1.5;
            stripLine2.IntervalOffsetType = DateTimeIntervalType.Days;
            stripLine2.Interval = 1;
            stripLine2.IntervalType = DateTimeIntervalType.Weeks;
            stripLine2.StripWidth = 2;
            stripLine2.StripWidthType = DateTimeIntervalType.Days;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisX.StripLines.Add(stripLine2);

            // Set the axis label to show the name of the day
            // This is done in order to demonstrate that weekends are highlighted
            chart1.ChartAreas[0].AxisX.LabelStyle.Format = "ddd";
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine Members

StripLine Members |
 | See Also Constructors Methods Properties

Represents the strip lines on a chart.

The following tables list the members exposed by the StripLine type.

Public Constructors

Name | Description
StripLine | Initializes a new instance of the StripLine class.
Top

Public Properties

Name | Description
BackColor | Gets or sets the background color of the strip line.
BackGradientStyle | Gets or sets the gradient style of the strip line.
BackHatchStyle | Gets or sets the hatching style of the strip line.
BackImage | Gets or sets the background image of the strip line.
BackImageAlignment | Gets or sets the background image alignment.
BackImageTransparentColor | Gets or sets the color of a strip line background image that will be implemented as transparent.
BackImageWrapMode | Gets or sets the drawing mode of the background image of the strip line.
BackSecondaryColor | Gets or sets the secondary color of the strip line background.
BorderColor | Gets or sets the border color of a strip line.
BorderDashStyle | Gets or sets the border style of the strip line.
BorderWidth | Gets or sets the border width of the strip line.
Font | Gets or sets the font used for the strip line text.
ForeColor | Gets or sets the color of the strip line text.
Interval | Gets or sets the interval for a strip line, and determines if the strip line is drawn once or repeatedly.
IntervalOffset | Gets or sets the offset of grid lines, tick marks, strip lines and axis labels.
IntervalOffsetType | Gets or sets the interval offset type of the strip line.
IntervalType | Gets or sets the interval type of a StripLine object.
MapAreaAttributes | Gets or sets the map area attributes of the strip line.
Name | Gets the name of the strip line.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
StripWidth | Gets or sets the width of a strip line.
StripWidthType | Gets or sets the unit of measurement for the StripWidth property.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text for the strip line.
TextAlignment | Gets or sets the text alignment of the strip line.
TextLineAlignment | Gets or sets the text line alignment of strip line text.
TextOrientation | Gets or sets the text orientation.
ToolTip | Gets or sets the tooltip of a strip line.
Url | Gets or sets the destination URL or anchor point of the strip line.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

StripLine Class
System.Web.UI.DataVisualization.Charting Namespace


StripLine Constructor

StripLine Constructor |
 | See Also

Initializes a new instance of the StripLine class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public StripLine ()
public:
StripLine ()
public StripLine ()
public function StripLine ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine Methods

StripLine Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

StripLine Class
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Dispose Method

StripLine.Dispose Method |
 | See Also

Overload List

Name | Description
StripLine.Dispose () | (inherited from Dispose )
StripLine.Dispose (Boolean) |

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Dispose Method (Boolean)

StripLine.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine Properties

StripLine Properties |
 | See Also

Public Properties

Name | Description
BackColor | Gets or sets the background color of the strip line.
BackGradientStyle | Gets or sets the gradient style of the strip line.
BackHatchStyle | Gets or sets the hatching style of the strip line.
BackImage | Gets or sets the background image of the strip line.
BackImageAlignment | Gets or sets the background image alignment.
BackImageTransparentColor | Gets or sets the color of a strip line background image that will be implemented as transparent.
BackImageWrapMode | Gets or sets the drawing mode of the background image of the strip line.
BackSecondaryColor | Gets or sets the secondary color of the strip line background.
BorderColor | Gets or sets the border color of a strip line.
BorderDashStyle | Gets or sets the border style of the strip line.
BorderWidth | Gets or sets the border width of the strip line.
Font | Gets or sets the font used for the strip line text.
ForeColor | Gets or sets the color of the strip line text.
Interval | Gets or sets the interval for a strip line, and determines if the strip line is drawn once or repeatedly.
IntervalOffset | Gets or sets the offset of grid lines, tick marks, strip lines and axis labels.
IntervalOffsetType | Gets or sets the interval offset type of the strip line.
IntervalType | Gets or sets the interval type of a StripLine object.
MapAreaAttributes | Gets or sets the map area attributes of the strip line.
Name | Gets the name of the strip line.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
StripWidth | Gets or sets the width of a strip line.
StripWidthType | Gets or sets the unit of measurement for the StripWidth property.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text for the strip line.
TextAlignment | Gets or sets the text alignment of the strip line.
TextLineAlignment | Gets or sets the text line alignment of strip line text.
TextOrientation | Gets or sets the text orientation.
ToolTip | Gets or sets the tooltip of a strip line.
Url | Gets or sets the destination URL or anchor point of the strip line.

See Also

Reference

StripLine Class
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackColor Property

StripLine.BackColor Property |
 | See Also Example

Gets or sets the background color of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color structure. The default color is White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

To set a gradient for the strip line, set the BackColor and BackSecondaryColor properties.

If you set this color to "transparent"—in other words, set the alpha value to 0—no color will be assigned to the background of the element. As a result, the background will be transparent.

If the StripWidth property is set to 0.0, a line will be drawn and the BorderColor property will determine the color of the line, not this property.

Example

The following code example demonstrates three applications of strip lines. First, horizontal strip lines are added at recurring intervals. Second, vertical strip lines are added to highlight weekend data points. Lastly, a non-recurring strip line is added to denote the mean of the data points in the first series of the chart.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds repeating horizontal strip lines.

AddHorizRepeatingStripLines()

' Highlights weekend points using strip lines.

HighlightWeekendsWithStripLines()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds repeating horizontal strip lines at intervals of 5.

''' </summary>

Private Sub AddHorizRepeatingStripLines()

' Instantiate new strip line

Dim stripLine1 As New StripLine()

stripLine1.StripWidth = 2.5

stripLine1.Interval = 5

' Consider adding transparency so that the strip lines are lighter

stripLine1.BackColor = Color.FromArgb(120, Color.Red)

' Add the strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine1)

End Sub

''' <summary>

''' Adds strip lines to highlight weekend values.

''' </summary>

Private Sub HighlightWeekendsWithStripLines()

' Set strip line to highlight weekends

Dim stripLine2 As New StripLine()

stripLine2.BackColor = Color.FromArgb(120, Color.Gold)

stripLine2.IntervalOffset = -1.5

stripLine2.IntervalOffsetType = DateTimeIntervalType.Days

stripLine2.Interval = 1

stripLine2.IntervalType = DateTimeIntervalType.Weeks

stripLine2.StripWidth = 2

stripLine2.StripWidthType = DateTimeIntervalType.Days

' Add strip line to the chart

chart1.ChartAreas(0).AxisX.StripLines.Add(stripLine2)

' Set the axis label to show the name of the day

' This is done in order to demonstrate that weekends are highlighted

chart1.ChartAreas(0).AxisX.LabelStyle.Format = "ddd"

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds repeating horizontal strip lines.
            AddHorizRepeatingStripLines();

            // Highlights weekend points using strip lines.
            HighlightWeekendsWithStripLines();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds repeating horizontal strip lines at intervals of 5.
        /// </summary>
        private void AddHorizRepeatingStripLines()
        {
            // Instantiate new strip line
            StripLine stripLine1 = new StripLine();
            stripLine1.StripWidth = 0;
            stripLine1.BorderColor = Color.Black;
            stripLine1.BorderWidth = 3;
            stripLine1.Interval = 5;

            // Consider adding transparency so that the strip lines are lighter
            stripLine1.BackColor = Color.FromArgb(120, Color.Red);

            stripLine1.BackSecondaryColor = Color.Black;
            stripLine1.BackGradientStyle = GradientStyle.LeftRight;

            // Add the strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine1);
        }

        /// <summary>
        /// Adds strip lines to highlight weekend values.
        /// </summary>
        private void HighlightWeekendsWithStripLines()
        {
            // Set strip line to highlight weekends
            StripLine stripLine2 = new StripLine();
            stripLine2.BackColor = Color.FromArgb(120, Color.Gold);
            stripLine2.IntervalOffset = -1.5;
            stripLine2.IntervalOffsetType = DateTimeIntervalType.Days;
            stripLine2.Interval = 1;
            stripLine2.IntervalType = DateTimeIntervalType.Weeks;
            stripLine2.StripWidth = 2;
            stripLine2.StripWidthType = DateTimeIntervalType.Days;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisX.StripLines.Add(stripLine2);

            // Set the axis label to show the name of the day
            // This is done in order to demonstrate that weekends are highlighted
            chart1.ChartAreas[0].AxisX.LabelStyle.Format = "ddd";
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackGradientStyle Property

StripLine.BackGradientStyle Property |
 | See Also

Gets or sets the gradient style of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

The BackGradientStyle property determines whether a chart element will display a gradient, as well as the orientation of the gradient, if used.

To use gradient colors:

  • Use the BackColor property to set the primary color.

  • Use the BackSecondaryColor property to set the secondary color.

  • Set this BackGradientStyle property of the chart element to the desired gradient style.

This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackHatchStyle Property

StripLine.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The hatch pattern consists of a solid background color and lines drawn over the background. The two colors used in the hatch style are set by the BackColor and BackSecondaryColor properties. This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackImage Property

StripLine.BackImage Property |
 | See Also

Gets or sets the background image of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents an image file URL. The default is an empty string.

Remarks

The BackImage property defines a path to a background image for many chart elements, and is an absolute or relative URL.

To position this image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify that one color will be displayed by the image as "transparent" by setting the BackImageTransparentColor property.

An image can be any valid graphics file supported by .NET Framework, including icons.

This property is not applicable if the StripWidth property is set to a value of 0.0.

Background images take precedence over other background properties, such as gradient colors.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackImageAlignment Property

StripLine.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for strip lines; it is only applied when the BackImageWrapMode property is set to Unscaled.

For more information about available alignments, see the ChartImageAlignmentStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackImageTransparentColor Property

StripLine.BackImageTransparentColor Property |
 | See Also

Gets or sets the color of a strip line background image that will be implemented as transparent.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent.

Remarks

This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackImageWrapMode Property

StripLine.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of the background image of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode integer enumeration. The default is Tile.

Remarks

This property determines how the image is displayed; that is, tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounding strip line. If the image is tiled, it is repeatedly drawn, starting from the top-left corner.

For more information concerning the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn will be determined by the BackImageAlignment property setting.

This property is not applicable if StripWidth is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BackSecondaryColor Property

StripLine.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the strip line background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of a background with hatching or gradient fill. The default color is Empty.

Remarks

This property determines the secondary background color of many chart objects, and is used when gradient colors are being applied.

You can set background secondary color to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines.

To use gradient colors for the background of a chart element:

  • Use the BackColor property to set the primary color.

  • Use this BackSecondaryColor property to set the secondary color.

  • Set the BackGradientStyle property to the desired gradient style.

This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BorderColor Property

StripLine.BorderColor Property |
 | See Also

Gets or sets the border color of a strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value. The default color is Empty.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

If the StripWidth property of a StripLine object is set to 0.0, a line will be drawn, and it is this property and not the BackColor property setting that will determine the color of the line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BorderDashStyle Property

StripLine.BorderDashStyle Property |
 | See Also

Gets or sets the border style of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the strip line.

Remarks

This property specifies the line style used for a border. The line can be solid, dotted or some variation of solid and dotted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.BorderWidth Property

StripLine.BorderWidth Property |
 | See Also

Gets or sets the border width of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the width of the strip line's border, in pixels.

Remarks

This property is measured in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Font Property

StripLine.Font Property |
 | See Also

Gets or sets the font used for the strip line text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font value that represents the font of the strip line text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.ForeColor Property

StripLine.ForeColor Property |
 | See Also

Gets or sets the color of the strip line text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value that represents the text color of a strip line. The default value is Black.

Remarks

You can specify any valid ARGB color for this property. This property is only applicable when a text value is specified for the strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Interval Property

StripLine.Interval Property |
 | See Also Example

Gets or sets the interval for a strip line, and determines if the strip line is drawn once or repeatedly.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value that represents the interval between strip lines. The default value is 0.0.

Remarks

When you set the Interval property to a value of zero (0.0), one strip line will be displayed, with a width specified by the StripWidth property. When you set Interval to a value of other than zero, multiple strip lines will be shown. The unit that is used for the Interval property is defined by the IntervalType property.

Example

The following code example demonstrates three applications of strip lines. First, horizontal strip lines are added at recurring intervals. Second, vertical strip lines are added to highlight weekend data points. Lastly, a non-recurring strip line is added to denote the mean of the data points in the first series of the chart.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds repeating horizontal strip lines.

AddHorizRepeatingStripLines()

' Highlights weekend points using strip lines.

HighlightWeekendsWithStripLines()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds repeating horizontal strip lines at intervals of 5.

''' </summary>

Private Sub AddHorizRepeatingStripLines()

' Instantiate new strip line

Dim stripLine1 As New StripLine()

stripLine1.StripWidth = 2.5

stripLine1.Interval = 5

' Consider adding transparency so that the strip lines are lighter

stripLine1.BackColor = Color.FromArgb(120, Color.Red)

' Add the strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine1)

End Sub

''' <summary>

''' Adds strip lines to highlight weekend values.

''' </summary>

Private Sub HighlightWeekendsWithStripLines()

' Set strip line to highlight weekends

Dim stripLine2 As New StripLine()

stripLine2.BackColor = Color.FromArgb(120, Color.Gold)

stripLine2.IntervalOffset = -1.5

stripLine2.IntervalOffsetType = DateTimeIntervalType.Days

stripLine2.Interval = 1

stripLine2.IntervalType = DateTimeIntervalType.Weeks

stripLine2.StripWidth = 2

stripLine2.StripWidthType = DateTimeIntervalType.Days

' Add strip line to the chart

chart1.ChartAreas(0).AxisX.StripLines.Add(stripLine2)

' Set the axis label to show the name of the day

' This is done in order to demonstrate that weekends are highlighted

chart1.ChartAreas(0).AxisX.LabelStyle.Format = "ddd"

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds repeating horizontal strip lines.
            AddHorizRepeatingStripLines();

            // Highlights weekend points using strip lines.
            HighlightWeekendsWithStripLines();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds repeating horizontal strip lines at intervals of 5.
        /// </summary>
        private void AddHorizRepeatingStripLines()
        {
            // Instantiate new strip line
            StripLine stripLine1 = new StripLine();
            stripLine1.StripWidth = 0;
            stripLine1.BorderColor = Color.Black;
            stripLine1.BorderWidth = 3;
            stripLine1.Interval = 5;

            // Consider adding transparency so that the strip lines are lighter
            stripLine1.BackColor = Color.FromArgb(120, Color.Red);

            stripLine1.BackSecondaryColor = Color.Black;
            stripLine1.BackGradientStyle = GradientStyle.LeftRight;

            // Add the strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine1);
        }

        /// <summary>
        /// Adds strip lines to highlight weekend values.
        /// </summary>
        private void HighlightWeekendsWithStripLines()
        {
            // Set strip line to highlight weekends
            StripLine stripLine2 = new StripLine();
            stripLine2.BackColor = Color.FromArgb(120, Color.Gold);
            stripLine2.IntervalOffset = -1.5;
            stripLine2.IntervalOffsetType = DateTimeIntervalType.Days;
            stripLine2.Interval = 1;
            stripLine2.IntervalType = DateTimeIntervalType.Weeks;
            stripLine2.StripWidth = 2;
            stripLine2.StripWidthType = DateTimeIntervalType.Days;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisX.StripLines.Add(stripLine2);

            // Set the axis label to show the name of the day
            // This is done in order to demonstrate that weekends are highlighted
            chart1.ChartAreas[0].AxisX.LabelStyle.Format = "ddd";
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.IntervalOffset Property

StripLine.IntervalOffset Property |
 | See Also Example

Gets or sets the offset of grid lines, tick marks, strip lines and axis labels.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the interval offset.

Remarks

The interval offset of minor tick marks and grid lines is never affected by the value of the IntervalOffset property of the Axis object.

The IntervalOffset property setting defines the units of measurement of the offset.

The Interval can be a negative value.

The default value is Auto (0).

Example

The following code example demonstrates three applications of strip lines. First, horizontal strip lines are added at recurring intervals. Second, vertical strip lines are added to highlight weekend data points. Lastly, a non-recurring strip line is added to denote the mean of the data points in the first series of the chart.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds repeating horizontal strip lines.

AddHorizRepeatingStripLines()

' Highlights weekend points using strip lines.

HighlightWeekendsWithStripLines()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds repeating horizontal strip lines at intervals of 5.

''' </summary>

Private Sub AddHorizRepeatingStripLines()

' Instantiate new strip line

Dim stripLine1 As New StripLine()

stripLine1.StripWidth = 2.5

stripLine1.Interval = 5

' Consider adding transparency so that the strip lines are lighter

stripLine1.BackColor = Color.FromArgb(120, Color.Red)

' Add the strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine1)

End Sub

''' <summary>

''' Adds strip lines to highlight weekend values.

''' </summary>

Private Sub HighlightWeekendsWithStripLines()

' Set strip line to highlight weekends

Dim stripLine2 As New StripLine()

stripLine2.BackColor = Color.FromArgb(120, Color.Gold)

stripLine2.IntervalOffset = -1.5

stripLine2.IntervalOffsetType = DateTimeIntervalType.Days

stripLine2.Interval = 1

stripLine2.IntervalType = DateTimeIntervalType.Weeks

stripLine2.StripWidth = 2

stripLine2.StripWidthType = DateTimeIntervalType.Days

' Add strip line to the chart

chart1.ChartAreas(0).AxisX.StripLines.Add(stripLine2)

' Set the axis label to show the name of the day

' This is done in order to demonstrate that weekends are highlighted

chart1.ChartAreas(0).AxisX.LabelStyle.Format = "ddd"

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds repeating horizontal strip lines.
            AddHorizRepeatingStripLines();

            // Highlights weekend points using strip lines.
            HighlightWeekendsWithStripLines();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds repeating horizontal strip lines at intervals of 5.
        /// </summary>
        private void AddHorizRepeatingStripLines()
        {
            // Instantiate new strip line
            StripLine stripLine1 = new StripLine();
            stripLine1.StripWidth = 0;
            stripLine1.BorderColor = Color.Black;
            stripLine1.BorderWidth = 3;
            stripLine1.Interval = 5;

            // Consider adding transparency so that the strip lines are lighter
            stripLine1.BackColor = Color.FromArgb(120, Color.Red);

            stripLine1.BackSecondaryColor = Color.Black;
            stripLine1.BackGradientStyle = GradientStyle.LeftRight;

            // Add the strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine1);
        }

        /// <summary>
        /// Adds strip lines to highlight weekend values.
        /// </summary>
        private void HighlightWeekendsWithStripLines()
        {
            // Set strip line to highlight weekends
            StripLine stripLine2 = new StripLine();
            stripLine2.BackColor = Color.FromArgb(120, Color.Gold);
            stripLine2.IntervalOffset = -1.5;
            stripLine2.IntervalOffsetType = DateTimeIntervalType.Days;
            stripLine2.Interval = 1;
            stripLine2.IntervalType = DateTimeIntervalType.Weeks;
            stripLine2.StripWidth = 2;
            stripLine2.StripWidthType = DateTimeIntervalType.Days;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisX.StripLines.Add(stripLine2);

            // Set the axis label to show the name of the day
            // This is done in order to demonstrate that weekends are highlighted
            chart1.ChartAreas[0].AxisX.LabelStyle.Format = "ddd";
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.IntervalOffsetType Property

StripLine.IntervalOffsetType Property |
 | See Also Example

Gets or sets the interval offset type of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. The default value is Auto.

Remarks

By default, this property is set to Auto; the actual value of this property is determined by the IntervalType property.

Example

The following code example demonstrates three applications of strip lines. First, horizontal strip lines are added at recurring intervals. Second, vertical strip lines are added to highlight weekend data points. Lastly, a non-recurring strip line is added to denote the mean of the data points in the first series of the chart.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds repeating horizontal strip lines.

AddHorizRepeatingStripLines()

' Highlights weekend points using strip lines.

HighlightWeekendsWithStripLines()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds repeating horizontal strip lines at intervals of 5.

''' </summary>

Private Sub AddHorizRepeatingStripLines()

' Instantiate new strip line

Dim stripLine1 As New StripLine()

stripLine1.StripWidth = 2.5

stripLine1.Interval = 5

' Consider adding transparency so that the strip lines are lighter

stripLine1.BackColor = Color.FromArgb(120, Color.Red)

' Add the strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine1)

End Sub

''' <summary>

''' Adds strip lines to highlight weekend values.

''' </summary>

Private Sub HighlightWeekendsWithStripLines()

' Set strip line to highlight weekends

Dim stripLine2 As New StripLine()

stripLine2.BackColor = Color.FromArgb(120, Color.Gold)

stripLine2.IntervalOffset = -1.5

stripLine2.IntervalOffsetType = DateTimeIntervalType.Days

stripLine2.Interval = 1

stripLine2.IntervalType = DateTimeIntervalType.Weeks

stripLine2.StripWidth = 2

stripLine2.StripWidthType = DateTimeIntervalType.Days

' Add strip line to the chart

chart1.ChartAreas(0).AxisX.StripLines.Add(stripLine2)

' Set the axis label to show the name of the day

' This is done in order to demonstrate that weekends are highlighted

chart1.ChartAreas(0).AxisX.LabelStyle.Format = "ddd"

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds repeating horizontal strip lines.
            AddHorizRepeatingStripLines();

            // Highlights weekend points using strip lines.
            HighlightWeekendsWithStripLines();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds repeating horizontal strip lines at intervals of 5.
        /// </summary>
        private void AddHorizRepeatingStripLines()
        {
            // Instantiate new strip line
            StripLine stripLine1 = new StripLine();
            stripLine1.StripWidth = 0;
            stripLine1.BorderColor = Color.Black;
            stripLine1.BorderWidth = 3;
            stripLine1.Interval = 5;

            // Consider adding transparency so that the strip lines are lighter
            stripLine1.BackColor = Color.FromArgb(120, Color.Red);

            stripLine1.BackSecondaryColor = Color.Black;
            stripLine1.BackGradientStyle = GradientStyle.LeftRight;

            // Add the strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine1);
        }

        /// <summary>
        /// Adds strip lines to highlight weekend values.
        /// </summary>
        private void HighlightWeekendsWithStripLines()
        {
            // Set strip line to highlight weekends
            StripLine stripLine2 = new StripLine();
            stripLine2.BackColor = Color.FromArgb(120, Color.Gold);
            stripLine2.IntervalOffset = -1.5;
            stripLine2.IntervalOffsetType = DateTimeIntervalType.Days;
            stripLine2.Interval = 1;
            stripLine2.IntervalType = DateTimeIntervalType.Weeks;
            stripLine2.StripWidth = 2;
            stripLine2.StripWidthType = DateTimeIntervalType.Days;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisX.StripLines.Add(stripLine2);

            // Set the axis label to show the name of the day
            // This is done in order to demonstrate that weekends are highlighted
            chart1.ChartAreas[0].AxisX.LabelStyle.Format = "ddd";
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.IntervalType Property

StripLine.IntervalType Property |
 | See Also Example

Gets or sets the interval type of a StripLine object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. The default value is Auto.

Remarks

Interval types can be set to Auto, in which case the type depends on: the X-value or Y-value types of the plotted DataPoint objects—depending on which axis the StripLine objects belong to—and the axis scale.

The Interval property determines how often a strip or line is drawn.

Example

The following code example demonstrates three applications of strip lines. First, horizontal strip lines are added at recurring intervals. Second, vertical strip lines are added to highlight weekend data points. Lastly, a non-recurring strip line is added to denote the mean of the data points in the first series of the chart.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds repeating horizontal strip lines.

AddHorizRepeatingStripLines()

' Highlights weekend points using strip lines.

HighlightWeekendsWithStripLines()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds repeating horizontal strip lines at intervals of 5.

''' </summary>

Private Sub AddHorizRepeatingStripLines()

' Instantiate new strip line

Dim stripLine1 As New StripLine()

stripLine1.StripWidth = 2.5

stripLine1.Interval = 5

' Consider adding transparency so that the strip lines are lighter

stripLine1.BackColor = Color.FromArgb(120, Color.Red)

' Add the strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine1)

End Sub

''' <summary>

''' Adds strip lines to highlight weekend values.

''' </summary>

Private Sub HighlightWeekendsWithStripLines()

' Set strip line to highlight weekends

Dim stripLine2 As New StripLine()

stripLine2.BackColor = Color.FromArgb(120, Color.Gold)

stripLine2.IntervalOffset = -1.5

stripLine2.IntervalOffsetType = DateTimeIntervalType.Days

stripLine2.Interval = 1

stripLine2.IntervalType = DateTimeIntervalType.Weeks

stripLine2.StripWidth = 2

stripLine2.StripWidthType = DateTimeIntervalType.Days

' Add strip line to the chart

chart1.ChartAreas(0).AxisX.StripLines.Add(stripLine2)

' Set the axis label to show the name of the day

' This is done in order to demonstrate that weekends are highlighted

chart1.ChartAreas(0).AxisX.LabelStyle.Format = "ddd"

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds repeating horizontal strip lines.
            AddHorizRepeatingStripLines();

            // Highlights weekend points using strip lines.
            HighlightWeekendsWithStripLines();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds repeating horizontal strip lines at intervals of 5.
        /// </summary>
        private void AddHorizRepeatingStripLines()
        {
            // Instantiate new strip line
            StripLine stripLine1 = new StripLine();
            stripLine1.StripWidth = 0;
            stripLine1.BorderColor = Color.Black;
            stripLine1.BorderWidth = 3;
            stripLine1.Interval = 5;

            // Consider adding transparency so that the strip lines are lighter
            stripLine1.BackColor = Color.FromArgb(120, Color.Red);

            stripLine1.BackSecondaryColor = Color.Black;
            stripLine1.BackGradientStyle = GradientStyle.LeftRight;

            // Add the strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine1);
        }

        /// <summary>
        /// Adds strip lines to highlight weekend values.
        /// </summary>
        private void HighlightWeekendsWithStripLines()
        {
            // Set strip line to highlight weekends
            StripLine stripLine2 = new StripLine();
            stripLine2.BackColor = Color.FromArgb(120, Color.Gold);
            stripLine2.IntervalOffset = -1.5;
            stripLine2.IntervalOffsetType = DateTimeIntervalType.Days;
            stripLine2.Interval = 1;
            stripLine2.IntervalType = DateTimeIntervalType.Weeks;
            stripLine2.StripWidth = 2;
            stripLine2.StripWidthType = DateTimeIntervalType.Days;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisX.StripLines.Add(stripLine2);

            // Set the axis label to show the name of the day
            // This is done in order to demonstrate that weekends are highlighted
            chart1.ChartAreas[0].AxisX.LabelStyle.Format = "ddd";
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.MapAreaAttributes Property

StripLine.MapAreaAttributes Property |
 | See Also

Gets or sets the map area attributes of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value that represents the attributes of the chart element's corresponding map area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Name Property

StripLine.Name Property |
 | See Also

Gets the name of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string Name { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Property Value

A string value that represents the name of the strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.PostBackValue Property

StripLine.PostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the postback value that is passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.StripWidth Property

StripLine.StripWidth Property |
 | See Also

Gets or sets the width of a strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property StripWidth As Double
public double StripWidth { get; set; }
public:
property double StripWidth {
    double get ();
    void set (double value);
}
/** @property */
public double get_StripWidth ()

/** @property */
public void set_StripWidth (double value)

public function get StripWidth () : double

public function set StripWidth (value : double)

Property Value

A double value that determines whether a strip or a line is drawn. The default value is 0.0.

Remarks

This property cannot be set to a value less than 0.0, otherwise an exception will be raised.

A setting of 0.0 will result in a line being drawn; this line will use the BorderColor, BorderDashStyle and BorderWidth property settings for its color, width and style. None of the Back* properties in this class are utilized when the value of StripWidth is 0.0.

If you set the StripWidth property to a value greater than 0.0, a strip will be created. The BorderColor, BorderDashStyle and BorderWidth properties only apply to the border of the strip; all of the Back* properties are then used for the background properties of the strip.

If the value of the StripWidth property is greater than 0.0, the units are determined by the relevant axis scale.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.StripWidthType Property

StripLine.StripWidthType Property |
 | See Also

Gets or sets the unit of measurement for the StripWidth property.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property StripWidthType As DateTimeIntervalType
public DateTimeIntervalType StripWidthType { get; set; }
public:
property DateTimeIntervalType StripWidthType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_StripWidthType ()

/** @property */
public void set_StripWidthType (DateTimeIntervalType value)

public function get StripWidthType () : DateTimeIntervalType

public function set StripWidthType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the width type. The default value is Auto.

Remarks

This property determines the units used for the StripWidth property. For example, to set a strip line to represent "one week", you could set this property to Weeks and set the StripWidth property to one (1.0).

You can change the value of this property from Auto to a DateTime value when the relevant axis scale uses a DateTime value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Text Property

StripLine.Text Property |
 | See Also Example

Gets or sets the text for the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text of a strip line.

Remarks

Use this property to add text to a strip line.

Example

The following code example demonstrates how to add a threshold line after the chart control has been added to the design surface. The chart uses a non-recurring strip line to show a calculation of the mean of all data points in a series.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.TextAlignment Property

StripLine.TextAlignment Property |
 | See Also Example

Gets or sets the text alignment of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextAlignment As StringAlignment
public StringAlignment TextAlignment { get; set; }
public:
property StringAlignment TextAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TextAlignment ()

/** @property */
public void set_TextAlignment (StringAlignment value)

public function get TextAlignment () : StringAlignment

public function set TextAlignment (value : StringAlignment)

Property Value

A StringAlignment value that represents the alignment of the strip line text.

Example

The following code example demonstrates how to add a threshold line after the chart control has been added to the design surface. The chart uses a non-recurring strip line to show a calculation of the mean of all data points in a series.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

stripLine3.TextAlignment = StringAlignment.Near

Copy Code
        stripLine3.TextLineAlignment = StringAlignment.Near
        stripLine3.TextOrientation = TextOrientation.Auto

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;
            stripLine3.TextAlignment = StringAlignment.Near;
            stripLine3.TextLineAlignment = StringAlignment.Near;
            stripLine3.TextOrientation = TextOrientation.Auto;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.TextLineAlignment Property

StripLine.TextLineAlignment Property |
 | See Also Example

Gets or sets the text line alignment of strip line text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextLineAlignment As StringAlignment
public StringAlignment TextLineAlignment { get; set; }
public:
property StringAlignment TextLineAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TextLineAlignment ()

/** @property */
public void set_TextLineAlignment (StringAlignment value)

public function get TextLineAlignment () : StringAlignment

public function set TextLineAlignment (value : StringAlignment)

Property Value

A StringAlignment value that represents the alignment of the text line.

Example

The following code example demonstrates how to add a threshold line after the chart control has been added to the design surface. The chart uses a non-recurring strip line to show a calculation of the mean of all data points in a series.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

stripLine3.TextAlignment = StringAlignment.Near

Copy Code
        stripLine3.TextLineAlignment = StringAlignment.Near
        stripLine3.TextOrientation = TextOrientation.Auto

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;
            stripLine3.TextAlignment = StringAlignment.Near;
            stripLine3.TextLineAlignment = StringAlignment.Near;
            stripLine3.TextOrientation = TextOrientation.Auto;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.TextOrientation Property

StripLine.TextOrientation Property |
 | See Also Example

Gets or sets the text orientation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextOrientation As TextOrientation
public TextOrientation TextOrientation { get; set; }
public:
property TextOrientation TextOrientation {
    TextOrientation get ();
    void set (TextOrientation value);
}
/** @property */
public TextOrientation get_TextOrientation ()

/** @property */
public void set_TextOrientation (TextOrientation value)

public function get TextOrientation () : TextOrientation

public function set TextOrientation (value : TextOrientation)

Property Value

A TextOrientation value that represents the alignment of the text orientation.

Remarks

When this property is set to a value of Auto, the text is oriented based on the chart type. For all X-Y chart types other than Bar, X-axis strip line text is oriented horizontally from left to right on the bottom of the strip line. For Bar charts, X-axis strip line text is oriented vertically from top to bottom to the right of the strip line.

Example

The following code example demonstrates how to add a threshold line after the chart control has been added to the design surface. The chart uses a non-recurring strip line to show a calculation of the mean of all data points in a series.

Copy Code

Imports System.Web.UI.DataVisualization.Charting

Public Partial Class StripLines

Inherits System.Web.UI.Page

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

' Add chart data before adding strip lines.

AddChartData()

' Adds a threshold line using strip lines.

AddThresholdStripLine()

End Sub

''' <summary>

''' Adds a week of data with values between 20 and 35.

''' </summary>

Private Sub AddChartData()

' Declare new random variable

Dim rand As New Random()

For i As Integer = 0 To 6

' Add a week of data

chart1.Series(0).Points.AddXY(DateTime.Now.AddDays(i), rand.[Next](20, 35))

Next

End Sub

''' <summary>

''' Adds a horizontal threshold strip line at the calculated mean

''' value of all data points in the first series of the chart.

''' </summary>

Private Sub AddThresholdStripLine()

Dim stripLine3 As New StripLine()

' Set threshold line so that it is only shown once

stripLine3.Interval = 0

' Set the threshold line to be drawn at the calculated mean of the first series

stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series(0).Name)

stripLine3.BackColor = Color.DarkGreen

stripLine3.StripWidth = 0.25

' Set text properties for the threshold line

stripLine3.Text = "Mean"

stripLine3.ForeColor = Color.Black

stripLine3.TextAlignment = StringAlignment.Near

Copy Code
        stripLine3.TextLineAlignment = StringAlignment.Near
        stripLine3.TextOrientation = TextOrientation.Auto

' Add strip line to the chart

chart1.ChartAreas(0).AxisY.StripLines.Add(stripLine3)

End Sub

End Class

Copy Code
public partial class StripLines : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            // Add chart data
            AddChartData();

            // Adds a threshold line using strip lines.
            AddThresholdStripLine();
        }

        /// <summary>
        /// Adds a week of data with values between 20 and 35.
        /// </summary>
        private void AddChartData()
        {
            // Declare new random variable
            Random rand = new Random();

            // Add a week of data
            for (int i = 0; i < 7; i++)
            {
                chart1.Series[0].Points.AddXY(DateTime.Now.AddDays(i), rand.Next(20,35));
            }
        }

        /// <summary>
        /// Adds a horizontal threshold strip line at the calculated mean
        /// value of all data points in the first series of the chart.
        /// </summary>
        private void AddThresholdStripLine()
        {
            StripLine stripLine3 = new StripLine();

            // Set threshold line so that it is only shown once
            stripLine3.Interval = 0;

            // Set the threshold line to be drawn at the calculated mean of the first series
            stripLine3.IntervalOffset = chart1.DataManipulator.Statistics.Mean(chart1.Series[0].Name);

            stripLine3.BackColor = Color.DarkGreen;
            stripLine3.StripWidth = 0.25;

            // Set text properties for the threshold line
            stripLine3.Text = "Mean";
            stripLine3.ForeColor = Color.Black;
            stripLine3.TextAlignment = StringAlignment.Near;
            stripLine3.TextLineAlignment = StringAlignment.Near;
            stripLine3.TextOrientation = TextOrientation.Auto;

            // Add strip line to the chart
            chart1.ChartAreas[0].AxisY.StripLines.Add(stripLine3);
        }
    }

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.ToolTip Property

StripLine.ToolTip Property |
 | See Also

Gets or sets the tooltip of a strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string value that represents the tooltip of the strip line.

Remarks

If you set this property, a client-side image map will automatically be created, and a map area will be created with the Title attribute set to the specified tooltip string. The map area will use the dimensions that correspond to the strip line.

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLine.Url Property

StripLine.Url Property |
 | See Also

Gets or sets the destination URL or anchor point of the strip line.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value that represents the destination URL or anchor point of the strip line.

Remarks

To use an absolute URL, start the string expression with either "http://" or "www.". If the string does not start with either of these prefixes, it will be treated as a relative URL.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members
System.Web.UI.DataVisualization.Charting Namespace


StripLinesCollection Class

StripLinesCollection Class |
 | See Also Members

Represents a collection of StripLine objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class StripLinesCollection
    Inherits ChartElementCollection(Of StripLine)
public class StripLinesCollection : ChartElementCollection<StripLine>
public ref class StripLinesCollection : public ChartElementCollection<StripLine^>
public class StripLinesCollection extends ChartElementCollection<StripLine>
public class StripLinesCollection extends ChartElementCollection<StripLine>

Remarks

The StripLinesCollection class represents a collection of StripLine objects, and is implemented as the StripLines property of the Axis class.

StripLine objects can be appended, inserted or removed from the collection at both design time and run time.

Note Strip lines can be displayed once or repeatedly for a set interval.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.StripLinesCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLinesCollection Members
System.Web.UI.DataVisualization.Charting Namespace


StripLinesCollection Members

StripLinesCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of StripLine objects.

The following tables list the members exposed by the StripLinesCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

StripLinesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


StripLinesCollection Methods

StripLinesCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

StripLinesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


StripLinesCollection Properties

StripLinesCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

StripLinesCollection Class
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation Class

TextAnnotation Class |
 | See Also Members

Represents a text annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class TextAnnotation
    Inherits Annotation
public class TextAnnotation : Annotation
public ref class TextAnnotation : public Annotation
public class TextAnnotation extends Annotation
public class TextAnnotation extends Annotation

Remarks

Note that other annotations, such as rectangle and ellipse annotations, can display inner text.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.TextAnnotation
System.Web.UI.DataVisualization.Charting.CalloutAnnotation
System.Web.UI.DataVisualization.Charting.RectangleAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation Members

TextAnnotation Members |
 | See Also Constructors Methods Properties

Represents a text annotation.

The following tables list the members exposed by the TextAnnotation type.

Public Constructors

Name | Description
TextAnnotation | Initializes a new instance of the TextAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the text annotation type.
BackGradientStyle | Overridden. This property is not applicable to the text annotation type.
BackHatchStyle | Overridden. This property is not applicable to the text annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the text annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Overridden. Gets or sets the font for the annotation text.
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. This property is not applicable to the text annotation type.
LineDashStyle | Overridden. This property is not applicable to the text annotation type.
LineWidth | Overridden. This property is not applicable to the text annotation type.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation.
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TextAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation Constructor

TextAnnotation Constructor |
 | See Also

Initializes a new instance of the TextAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public TextAnnotation ()
public:
TextAnnotation ()
public TextAnnotation ()
public function TextAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation Methods

TextAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TextAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation Properties

TextAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the text annotation type.
BackGradientStyle | Overridden. This property is not applicable to the text annotation type.
BackHatchStyle | Overridden. This property is not applicable to the text annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the text annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Overridden. Gets or sets the font for the annotation text.
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. This property is not applicable to the text annotation type.
LineDashStyle | Overridden. This property is not applicable to the text annotation type.
LineWidth | Overridden. This property is not applicable to the text annotation type.
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation.
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

TextAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.AnnotationType Property

TextAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.BackColor Property

TextAnnotation.BackColor Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Remarks

Not applicable to this annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.BackGradientStyle Property

TextAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.BackHatchStyle Property

TextAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.BackSecondaryColor Property

TextAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.Font Property

TextAnnotation.Font Property |
 | See Also

Gets or sets the font for the annotation text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overrides Property Font As Font
public override Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object used as the font for the annotation text.

Remarks

To set this property, create a new Font object, and then assign it to this property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.IsMultiline Property

TextAnnotation.IsMultiline Property |
 | See Also

Gets or sets a flag that indicates whether the annotation text is multiline.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property IsMultiline As Boolean
public virtual bool IsMultiline { get; set; }
public:
virtual property bool IsMultiline {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMultiline ()

/** @property */
public void set_IsMultiline (boolean value)

public function get IsMultiline () : boolean

public function set IsMultiline (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.LineColor Property

TextAnnotation.LineColor Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(false)]
public override Color LineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.LineDashStyle Property

TextAnnotation.LineDashStyle Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.LineWidth Property

TextAnnotation.LineWidth Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(false)]
public override int LineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAnnotation.Text Property

TextAnnotation.Text Property |
 | See Also

Gets or sets the text of the annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Text As String
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


TextAntiAliasingQuality Enumeration

TextAntiAliasingQuality Enumeration |
 | See Also

Specifies the quality of the anti-aliasing to be used with the TextAntiAliasingQuality property.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration TextAntiAliasingQuality
public enum TextAntiAliasingQuality
public enum class TextAntiAliasingQuality
public enum TextAntiAliasingQuality
public enum TextAntiAliasingQuality

Members

Member name | Description
High | High anti-aliasing quality.
Normal | Normal anti-aliasing quality.
SystemDefault | System default anti-aliasing quality. The text will be drawn using whatever font smoothing settings the user has selected for the system.

Remarks

The TextAntiAliasingQuality enumeration represents the quality ranges for the text.

When you set a higher value for text anti-aliasing, the chart load increases and the performance is decreased. If your chart contains significant amounts of text, consider setting text anti-aliasing to a lower value.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


TextOrientation Enumeration

TextOrientation Enumeration |
 | See Also

Specifies text orientation in a chart element.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration TextOrientation
public enum TextOrientation
public enum class TextOrientation
public enum TextOrientation
public enum TextOrientation

Members

Member name | Description
Auto | Text orientation is automatically determined, based on the type of chart element in which the text appears.
Horizontal | Text is horizontal.
Rotated270 | Text is rotated 270 degrees and oriented from bottom to top.
Rotated90 | Text is rotated 90 degrees and oriented from top to bottom.
Stacked | Text characters are not rotated and are positioned one below the other.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


TextStyle Enumeration

TextStyle Enumeration |
 | See Also

Specifies text drawing styles.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration TextStyle
public enum TextStyle
public enum class TextStyle
public enum TextStyle
public enum TextStyle

Members

Member name | Description
Default | Default text drawing style.
Embed | Embedded text.
Emboss | Embossed text.
Frame | Framed text.
Shadow | Shadow text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


TickMark Class

TickMark Class |
 | See Also Members

Represents the major and minor tick marks along an axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class TickMark
    Inherits Grid
public class TickMark : Grid
public ref class TickMark : public Grid
public class TickMark extends Grid
public class TickMark extends Grid

Remarks

The TickMark class encapsulates the functionality for all chart tick marks.

The TickMark class is exposed as the MajorTickMark and MinorTickMark properties of Axis objects.

By default, major tick marks are displayed at the major grid lines, whereas minor tick marks must be explicitly displayed.

MajorTickMark.Interval is not set (Double.NaN) by default, and the tick marks are drawn according to Interval. MinorTickMark.Interval is set to Auto (0) by default, and the Chart control automatically determines the interval.

A developer can use this class to:

  • Enable or disable tick marks.

  • Set the color, width, length and line style of tick marks.

  • Specify a style that determines whether tick marks are displayed outside the axis, inside the axis or across the axis.

  • Specify the starting point—where the first tick mark is drawn—as well as the tick mark interval, which correlates to their frequency.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.Grid
System.Web.UI.DataVisualization.Charting.TickMark

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Members
System.Web.UI.DataVisualization.Charting Namespace


TickMark Members

TickMark Members |
 | See Also Constructors Methods Properties

Represents the major and minor tick marks along an axis.

The following tables list the members exposed by the TickMark type.

Public Constructors

Name | Description
TickMark | Initializes a new instance of the TickMark class.
Top

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled. (inherited from Grid)
Interval | Gets or sets the interval between major or minor grid lines. (inherited from Grid)
IntervalOffset | Gets or sets the offset of grid lines. (inherited from Grid)
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines. (inherited from Grid)
IntervalType | Gets or sets the interval type for major or minor grid lines. (inherited from Grid)
LineColor | Gets or sets the line color of a grid. (inherited from Grid)
LineDashStyle | Gets or sets the line style of a grid. (inherited from Grid)
LineWidth | Gets or sets the line width of major and minor grid lines. (inherited from Grid)
Size | Gets or sets the length of tick marks. The length is measured in units that represent a percentage of the height or width of the chart image, depending on the axis.
TickMarkStyle | Gets or sets the tick mark style.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TickMark Class
System.Web.UI.DataVisualization.Charting Namespace


TickMark Constructor

TickMark Constructor |
 | See Also

Initializes a new instance of the TickMark class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public TickMark ()
public:
TickMark ()
public TickMark ()
public function TickMark ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Class
TickMark Members
System.Web.UI.DataVisualization.Charting Namespace


TickMark Methods

TickMark Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TickMark Class
System.Web.UI.DataVisualization.Charting Namespace


TickMark Properties

TickMark Properties |
 | See Also

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled. (inherited from Grid )
Interval | Gets or sets the interval between major or minor grid lines. (inherited from Grid )
IntervalOffset | Gets or sets the offset of grid lines. (inherited from Grid )
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines. (inherited from Grid )
IntervalType | Gets or sets the interval type for major or minor grid lines. (inherited from Grid )
LineColor | Gets or sets the line color of a grid. (inherited from Grid )
LineDashStyle | Gets or sets the line style of a grid. (inherited from Grid )
LineWidth | Gets or sets the line width of major and minor grid lines. (inherited from Grid )
Size | Gets or sets the length of tick marks. The length is measured in units that represent a percentage of the height or width of the chart image, depending on the axis.
TickMarkStyle | Gets or sets the tick mark style.

See Also

Reference

TickMark Class
System.Web.UI.DataVisualization.Charting Namespace


TickMark.Size Property

TickMark.Size Property |
 | See Also

Gets or sets the length of tick marks. The length is measured in units that represent a percentage of the height or width of the chart image, depending on the axis.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Size As Single
public float Size { get; set; }
public:
property float Size {
    float get ();
    void set (float value);
}
/** @property */
public float get_Size ()

/** @property */
public void set_Size (float value)

public function get Size () : float

public function set Size (value : float)

Property Value

A float value that represents the size, or length, of tick marks. The default value is 1.0 percent.

Remarks

The size of a tick mark determines the tick mark's length.

The Size property is measured in units that represent a percentage of the height or width of the chart image. If the tick mark is displayed along a vertical axis, the unit of measure is a percentage of the chart image's width. If the tick mark is displayed along a horizontal axis, the unit of measure is a percentage of the chart image's height.

A change in the width of the chart image will result in the resizing of all tick marks displayed along vertical axes, for all chart areas. Similarly, a change in the height of the chart image will result in the resizing of all tick marks displayed along horizontal axes, for all chart areas.

To display tick marks for three-dimensional (3D) charts, so that they are just drawn for the width of a wall, set the TickMarkStyle property to AcrossAxis and specify a tick mark size of zero (0) using the Size property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Class
TickMark Members
System.Web.UI.DataVisualization.Charting Namespace


TickMark.TickMarkStyle Property

TickMark.TickMarkStyle Property |
 | See Also

Gets or sets the tick mark style.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TickMarkStyle As TickMarkStyle
public TickMarkStyle TickMarkStyle { get; set; }
public:
property TickMarkStyle TickMarkStyle {
    TickMarkStyle get ();
    void set (TickMarkStyle value);
}
/** @property */
public TickMarkStyle get_TickMarkStyle ()

/** @property */
public void set_TickMarkStyle (TickMarkStyle value)

public function get TickMarkStyle () : TickMarkStyle

public function set TickMarkStyle (value : TickMarkStyle)

Property Value

A TickMarkStyle enumeration value. The default value is OutsideArea.

Remarks

The TickMarkStyle property determines the style of tick marks.

Tick marks can be drawn inside the chart area, outside the chart area, across an axis line, or can be disabled.

To display tick marks for three-dimensional (3D) charts, so that they are just drawn for the width of a wall, set the TickMarkStyle property to AcrossAxis. Then specify a tick mark size of zero (0) using the Size property.

If the TickMarkStyle property is set to None, tick marks are not displayed. Tick marks can also be toggled on or off by setting the Enabled property to true or false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Class
TickMark Members
System.Web.UI.DataVisualization.Charting Namespace


TickMarkStyle Enumeration

TickMarkStyle Enumeration |
 | See Also

Specifies a tick mark style when setting the TickMarkStyle property of a TickMark object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Enumeration TickMarkStyle
public enum TickMarkStyle
public enum class TickMarkStyle
public enum TickMarkStyle
public enum TickMarkStyle

Members

Member name | Description
AcrossAxis | Tick marks are drawn across the relevant axis line.
InsideArea | Tick marks are drawn inside the chart area.
None | Tick marks are disabled.
OutsideArea | Tick marks are drawn outside the chart area.

Remarks

The TickMarkStyle enumeration represents the styles for major and minor tick marks.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

System.Web.UI.DataVisualization.Charting Namespace


Title Class

Title Class |
 | See Also Members

Represents a title for the entire chart image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class Title
    Inherits ChartNamedElement
    Implements IDisposable, IChartMapArea
public class Title : ChartNamedElement, IDisposable, IChartMapArea
public ref class Title : public ChartNamedElement, IDisposable, IChartMapArea
public class Title extends ChartNamedElement implements IDisposable, IChartMapArea
public class Title extends ChartNamedElement implements IDisposable, IChartMapArea

Remarks

The Title class encapsulates all the functionality of a title for the Chart control. This class is exposed using the Titles collection property of the root Chart object.

There can be any number of titles for an entire chart image.

Titles are able to:

  • Be docked and aligned or custom-positioned.

  • Be displayed inside or outside the plotted chart areas.

  • Use a predefined TextStyle such as Embed or Shadow.

  • Use hatching, gradient colors and background images.

  • Be sized and positioned anywhere within the chart image.

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Title

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Members

Title Members |
 | See Also Constructors Methods Properties

Represents a title for the entire chart image.

The following tables list the members exposed by the Title type.

Public Constructors

Name | Description
Title | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the title.
BackColor | Gets or sets the background color of the title.
BackGradientStyle | Gets or sets the orientation for the background gradient of a title. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style for the title.
BackImage | Gets or sets the background image of the title.
BackImageAlignment | Gets or sets the alignment of the title background image.
BackImageTransparentColor | Gets or sets a color that will drawn as transparent when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the title.
BackSecondaryColor | Gets or sets the secondary color of the title background.
BorderColor | Gets or sets the border color of the title.
BorderDashStyle | Gets or sets the border style of the title.
BorderWidth | Gets or sets the border width of the title.
DockedToChartArea | Gets or sets the name of the ChartArea where the title will be docked.
Docking | Gets or sets a value that determines where the title is docked.
DockingOffset | Gets or sets the positive or negative offset of the docked title position.
Font | Gets or sets the font for the title.
ForeColor | Gets or sets the color of the title text.
IsDockedInsideChartArea | Gets or sets a flag that specifies whether the title should be docked within a ChartArea object.
MapAreaAttributes | Gets or sets map area attributes of the title.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement)
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the title.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
ShadowColor | Gets or sets the shadow color for the title.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the title.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text for the title.
TextOrientation | Gets or sets the orientation of the text in the title.
TextStyle | Gets or sets the style of the text for the title.
ToolTip | Gets or sets the tooltip for the title.
Url | Gets or sets the target URL of the hyperlink for the title.
Visible | Gets or sets the visibility flag of the title.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Title Class
System.Web.UI.DataVisualization.Charting Namespace


Title Constructor

Title Constructor |
 | See Also

Overload List

Name | Description
Title () | Initializes a new instance of the Title class.
Title (String) | Initializes a new instance of the Title class with the specified title text.
Title (String, Docking) | Initializes a new instance of the Title class with the specified title text and docking value.
Title (String, Docking, Font, Color) | Initializes a new instance of the Title class with the specified title text, docking value, font and color.

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Constructor ()

Title Constructor () |
 | See Also

Initializes a new instance of the Title class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public Title ()
public:
Title ()
public Title ()
public function Title ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Constructor (String)

Title Constructor (String) |
 | See Also

Initializes a new instance of the Title class with the specified title text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String _
)
public Title (
    string text
)
public:
Title (
    String^ text
)
public Title (
    String text
)
public function Title (
    text : String
)

Parameters

text

Text for the title.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Constructor (String, Docking)

Title Constructor (String, Docking) |
 | See Also

Initializes a new instance of the Title class with the specified title text and docking value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String, _
    docking As Docking _
)
public Title (
    string text,
    Docking docking
)
public:
Title (
    String^ text,
    Docking docking
)
public Title (
    String text,
    Docking docking
)
public function Title (
    text : String,
    docking : Docking
)

Parameters

text

Text for the title.

docking

A Docking enumeration value that determines where the title will be docked on the chart.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Constructor (String, Docking, Font, Color)

Title Constructor (String, Docking, Font, Color) |
 | See Also

Initializes a new instance of the Title class with the specified title text, docking value, font and color.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String, _
    docking As Docking, _
    font As Font, _
    color As Color _
)
public Title (
    string text,
    Docking docking,
    Font font,
    Color color
)
public:
Title (
    String^ text,
    Docking docking,
    Font^ font,
    Color color
)
public Title (
    String text,
    Docking docking,
    Font font,
    Color color
)
public function Title (
    text : String,
    docking : Docking,
    font : Font,
    color : Color
)

Parameters

text

Text for the title.

docking

A Docking enumeration value that determines where the title will be docked on the chart.

font

Title font.

color

Title color.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Methods

Title Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Title Class
System.Web.UI.DataVisualization.Charting Namespace


Title.Dispose Method

Title.Dispose Method |
 | See Also

Overload List

Name | Description
Title.Dispose () | (inherited from Dispose )
Title.Dispose (Boolean) |

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Dispose Method (Boolean)

Title.Dispose Method (Boolean) |
 | See Also

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title Properties

Title Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the title.
BackColor | Gets or sets the background color of the title.
BackGradientStyle | Gets or sets the orientation for the background gradient of a title. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style for the title.
BackImage | Gets or sets the background image of the title.
BackImageAlignment | Gets or sets the alignment of the title background image.
BackImageTransparentColor | Gets or sets a color that will drawn as transparent when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the title.
BackSecondaryColor | Gets or sets the secondary color of the title background.
BorderColor | Gets or sets the border color of the title.
BorderDashStyle | Gets or sets the border style of the title.
BorderWidth | Gets or sets the border width of the title.
DockedToChartArea | Gets or sets the name of the ChartArea where the title will be docked.
Docking | Gets or sets a value that determines where the title is docked.
DockingOffset | Gets or sets the positive or negative offset of the docked title position.
Font | Gets or sets the font for the title.
ForeColor | Gets or sets the color of the title text.
IsDockedInsideChartArea | Gets or sets a flag that specifies whether the title should be docked within a ChartArea object.
MapAreaAttributes | Gets or sets map area attributes of the title.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement )
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the title.
PostBackValue | Gets or sets the postback value that can be processed on a Click event.
ShadowColor | Gets or sets the shadow color for the title.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the title.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text for the title.
TextOrientation | Gets or sets the orientation of the text in the title.
TextStyle | Gets or sets the style of the text for the title.
ToolTip | Gets or sets the tooltip for the title.
Url | Gets or sets the target URL of the hyperlink for the title.
Visible | Gets or sets the visibility flag of the title.

See Also

Reference

Title Class
System.Web.UI.DataVisualization.Charting Namespace


Title.Alignment Property

Title.Alignment Property |
 | See Also

Gets or sets the alignment of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Alignment As ContentAlignment
public ContentAlignment Alignment { get; set; }
public:
property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the title alignment within the text drawing region. The default value is MiddleCenter.

Remarks

The Alignment property has no effect on alignment if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackColor Property

Title.BackColor Property |
 | See Also

Gets or sets the background color of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value. The default color is White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

The BackColor value will be the first color used if you have specified gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the title. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackGradientStyle Property

Title.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a title. Also determines whether a gradient is used.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a title will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

Set the primary color of the title background with the BackColor property.

Set the secondary color of the title background with the BackSecondaryColor property.

Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackHatchStyle Property

Title.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackImage Property

Title.BackImage Property |
 | See Also

Gets or sets the background image of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default is an empty string.

Remarks

This property defines a path to a background image for a Chart title, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image be any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackImageAlignment Property

Title.BackImageAlignment Property |
 | See Also

Gets or sets the alignment of the title background image.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property is used when the BackImageWrapMode property is set to Unscaled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackImageTransparentColor Property

Title.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that will drawn as transparent when the background image is drawn.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value. The default value is Empty.

Remarks

This color will be displayed as transparent when the chart is rendered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackImageWrapMode Property

Title.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

The BackImageWrapMode property determines how the image is displayed; the image can be tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the title. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the title.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BackSecondaryColor Property

Title.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the title background.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of a background with hatching or gradient fill. The default value is Empty.

Remarks

This BackSecondaryColor property is one of several related properties that determine the secondary background color of Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the title.

To use gradient colors for the background of a title:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BorderColor Property

Title.BorderColor Property |
 | See Also

Gets or sets the border color of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set the BorderColor property to any valid ARGB (alpha, red, green, blue) value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BorderDashStyle Property

Title.BorderDashStyle Property |
 | See Also

Gets or sets the border style of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the title.

Remarks

The BorderDashStyle property determines the line style to use for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.BorderWidth Property

Title.BorderWidth Property |
 | See Also

Gets or sets the border width of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the title.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.DockedToChartArea Property

Title.DockedToChartArea Property |
 | See Also

Gets or sets the name of the ChartArea where the title will be docked.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property DockedToChartArea As String
public string DockedToChartArea { get; set; }
public:
property String^ DockedToChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_DockedToChartArea ()

/** @property */
public void set_DockedToChartArea (String value)

public function get DockedToChartArea () : String

public function set DockedToChartArea (value : String)

Property Value

A string value that represents the name of the ChartArea where this title will be docked. The default value is the empty string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Docking Property

Title.Docking Property |
 | See Also

Gets or sets a value that determines where the title is docked.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Docking As Docking
public Docking Docking { get; set; }
public:
property Docking Docking {
    Docking get ();
    void set (Docking value);
}
/** @property */
public Docking get_Docking ()

/** @property */
public void set_Docking (Docking value)

public function get Docking () : Docking

public function set Docking (value : Docking)

Property Value

A Docking enumeration value. The default value is Top.

Remarks

The Title can be docked to the top, left, bottom or right of either the entire chart image, or the inside or outside of a chart area. If the IsDockedInsideChartArea property is set to false, docking applies to the entire chart image. If the IsDockedInsideChartArea property is set to true, docking applies to the ChartArea object specified by the DockedToChartArea property

This property has no effect if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.DockingOffset Property

Title.DockingOffset Property |
 | See Also

Gets or sets the positive or negative offset of the docked title position.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property DockingOffset As Integer
public int DockingOffset { get; set; }
public:
property int DockingOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_DockingOffset ()

/** @property */
public void set_DockingOffset (int value)

public function get DockingOffset () : int

public function set DockingOffset (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Font Property

Title.Font Property |
 | See Also

Gets or sets the font for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object. Defaults to "Microsoft Sans Serif, 8pt".

Remarks

Use a new Font object when setting this property. Assign the entire object to the property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.ForeColor Property

Title.ForeColor Property |
 | See Also

Gets or sets the color of the title text.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

The ForeColor property is used to set the title text color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.IsDockedInsideChartArea Property

Title.IsDockedInsideChartArea Property |
 | See Also

Gets or sets a flag that specifies whether the title should be docked within a ChartArea object.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property IsDockedInsideChartArea As Boolean
public bool IsDockedInsideChartArea { get; set; }
public:
property bool IsDockedInsideChartArea {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsDockedInsideChartArea ()

/** @property */
public void set_IsDockedInsideChartArea (boolean value)

public function get IsDockedInsideChartArea () : boolean

public function set IsDockedInsideChartArea (value : boolean)

Property Value

True if the title will be docked within a chart area, false if the title will be docked outside the chart area. The default value is false.

Remarks

If the IsDockedInsideChartArea property is set to false, the title is docked to the outside edge of the plotted chart areas; if this property is set to true, the title will be docked to the inside edge of the chart area. This property will have no effect if the name of a ChartArea object is not assigned to the DockedToChartArea property.

Note This behavior only applies if the Position property is set to Auto. If this is not the case, setting the IsDockedInsideChartArea property has no effect, because the position of the title is then determined by the Position property value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.MapAreaAttributes Property

Title.MapAreaAttributes Property |
 | See Also

Gets or sets map area attributes of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property MapAreaAttributes As String
public string MapAreaAttributes { get; set; }
public:
virtual property String^ MapAreaAttributes {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_MapAreaAttributes ()

/** @property */
public final void set_MapAreaAttributes (String value)

public final function get MapAreaAttributes () : String

public final function set MapAreaAttributes (value : String)

Property Value

A string value. The default is a zero-length string.

Remarks

If you set the MapAreaAttributes property, a client-side image map will automatically be created. A map area will also be created, with its attribute string appended to the <MAP> tag that corresponds to the chart object for which this property is being set.

Because the entire attribute string is appended to the <MAP> tag, multiple attributes should be separated with a space.

The MapAreaAttributes property can be used in conjunction with the Url property to specify map area attributes, for example, Target= _Blank, as well as client-side event handlers, for example, OnClick="MyEvent()".

Setting this property will have no effect if the IsMapEnabled property is set to false. Its default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Special keywords may be used when setting this property; each keyword will be replaced with some type of data from the applicable chart element. Refer to the following table for a listing of all available keywords:

Keyword | Replaced by
#VALX | X-value of the data point.
#VAL, #VALY, #VALY2, #VALY3… | Y-values of the data point.
#SER | Series name.
#LABEL | Data point label.
#INDEX | Data point index.
#PERCENT | Percentage of the data point Y-value.
#TOTAL | Total of all Y-values in the series.
#LEGENDTEXT | Legend text.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Position Property

Title.Position Property |
 | See Also

Gets or sets an ElementPosition object, which can be used to get or set the position of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Position As ElementPosition
public ElementPosition Position { get; set; }
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_Position ()

/** @property */
public void set_Position (ElementPosition value)

public function get Position () : ElementPosition

public function set Position (value : ElementPosition)

Property Value

An ElementPosition value that represents the position of the title. The default value is Auto.

Remarks

If the Position property is automatic (that is, Title.Position.Auto = true) the title position is calculated automatically by the Chart control, taking into account the Docking, Alignment and IsDockedInsideChartArea property settings.

If it is not automatic, the Docking, DockedToChartArea and IsDockedInsideChartArea properties are ignored, and the title position is solely determined by the value of the returned ElementPosition object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.PostBackValue Property

Title.PostBackValue Property |
 | See Also

Gets or sets the postback value that can be processed on a Click event.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property PostBackValue As String
public string PostBackValue { get; set; }
public:
virtual property String^ PostBackValue {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_PostBackValue ()

/** @property */
public final void set_PostBackValue (String value)

public final function get PostBackValue () : String

public final function set PostBackValue (value : String)

Property Value

A string value that represents the value that is passed to a Click event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.ShadowColor Property

Title.ShadowColor Property |
 | See Also

Gets or sets the shadow color for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.ShadowOffset Property

Title.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset, in pixels, of the title.

Remarks

To implement shadowing, set this property to a value other than zero (0). A positive value will result in a shadow that shifts down and to the right; a negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Text Property

Title.Text Property |
 | See Also

Gets or sets the text for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text for the title.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.TextOrientation Property

Title.TextOrientation Property |
 | See Also

Gets or sets the orientation of the text in the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextOrientation As TextOrientation
public TextOrientation TextOrientation { get; set; }
public:
property TextOrientation TextOrientation {
    TextOrientation get ();
    void set (TextOrientation value);
}
/** @property */
public TextOrientation get_TextOrientation ()

/** @property */
public void set_TextOrientation (TextOrientation value)

public function get TextOrientation () : TextOrientation

public function set TextOrientation (value : TextOrientation)

Property Value

A TextOrientation enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.TextStyle Property

Title.TextStyle Property |
 | See Also

Gets or sets the style of the text for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property TextStyle As TextStyle
public TextStyle TextStyle { get; set; }
public:
property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public function get TextStyle () : TextStyle

public function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value that determines the style of the text for the title. The default value is Default.

Remarks

There are five possible styles for title text: Default, Shadow, Emboss, Embed, and Frame. Refer to the table below for a summary of these styles:

Style | Description
Default | Text is displayed using the desired font and color, with no additional effects.
Shadow | Text is displayed using the desired font and color with an added shadow effect on the text.
Emboss | Text is displayed using the desired font and color but drawn with an embossing effect.
Embed | Text is displayed using the desired font and color but drawn with an embedding effect.
Frame | Text is displayed using the desired font and color but drawn as an outline of the text, that is, with no fill.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.ToolTip Property

Title.ToolTip Property |
 | See Also

Gets or sets the tooltip for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_ToolTip ()

/** @property */
public final void set_ToolTip (String value)

public final function get ToolTip () : String

public final function set ToolTip (value : String)

Property Value

A string value that represents the tooltip.

Remarks

If you set the ToolTip property, a client-side image map will automatically be created. A map area will also be created with its Title attribute set to the specified tooltip string. The map area will use the dimensions that correspond to the title.

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Url Property

Title.Url Property |
 | See Also

Gets or sets the target URL of the hyperlink for the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Property Url As String
public string Url { get; set; }
public:
virtual property String^ Url {
    String^ get () sealed;
    void set (String^ value) sealed;
}
/** @property */
public final String get_Url ()

/** @property */
public final void set_Url (String value)

public final function get Url () : String

public final function set Url (value : String)

Property Value

A string value. The default value is a zero-length string.

Remarks

If you set this property, a client-side image map will be automatically created. A map area will also be created with its HREF attribute set to the specified anchor or URL.

Setting this property will have no effect if the IsMapEnabled property is set to false. The default value is true.

Important To create an image map in this manner, the RenderType property of the Chart object must be set to ImageTag. It is possible to create an image map when using binary streaming, but another technique must be used.

Attributes of the map area(s), for example, TARGET=_Blank, can be specified by using the MapAreaAttributes property.

The Url property allows you to set special keywords to display different types of chart-related data.

To create image maps that have user-defined coordinates, use the MapAreas property of the root Chart object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


Title.Visible Property

Title.Visible Property |
 | See Also

Gets or sets the visibility flag of the title.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Overridable Property Visible As Boolean
public virtual bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public function get Visible () : boolean

public function set Visible (value : boolean)

Property Value

True if visible, otherwise false.

Remarks

Example

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members
System.Web.UI.DataVisualization.Charting Namespace


TitleCollection Class

TitleCollection Class |
 | See Also Members

Represents a collection of Title objects.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class TitleCollection
    Inherits ChartNamedElementCollection(Of Title)
public class TitleCollection : ChartNamedElementCollection<Title>
public ref class TitleCollection : public ChartNamedElementCollection<Title^>
public class TitleCollection extends ChartNamedElementCollection<Title>
public class TitleCollection extends ChartNamedElementCollection<Title>

Remarks

The TitleCollection class is implemented as the Titles collection property of the root Chart object.

Title objects can be appended, inserted or removed from the collection at design time and run time.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Web.UI.DataVisualization.Charting.ChartElementCollection
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection
System.Web.UI.DataVisualization.Charting.TitleCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TitleCollection Members
System.Web.UI.DataVisualization.Charting Namespace


TitleCollection Members

TitleCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of Title objects.

The following tables list the members exposed by the TitleCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

TitleCollection Class
System.Web.UI.DataVisualization.Charting Namespace


TitleCollection Methods

TitleCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

TitleCollection Class
System.Web.UI.DataVisualization.Charting Namespace


TitleCollection.Add Method

TitleCollection.Add Method |
 | See Also

Overload List

Name | Description
TitleCollection.Add (String) | Adds a Title object with the specified name to the end of the collection.
TitleCollection.Add (Title) | (inherited from Add )

See Also

Reference

TitleCollection Class
TitleCollection Members
System.Web.UI.DataVisualization.Charting Namespace


TitleCollection.Add Method (String)

TitleCollection.Add Method (String) |
 | See Also

Adds a Title object with the specified name to the end of the collection.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As Title
public Title Add (
    string name
)
public:
Title^ Add (
    String^ name
)
public Title Add (
    String name
)
public function Add (
    name : String
) : Title

Parameters

name

The name of the title to add to the collection.

Return Value

A string value that represents the zero-based index of the added title.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TitleCollection Class
TitleCollection Members
System.Web.UI.DataVisualization.Charting Namespace


TitleCollection Properties

TitleCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

TitleCollection Class
System.Web.UI.DataVisualization.Charting Namespace


TTestResult Class

TTestResult Class |
 | See Also Members

Stores the results of a T Test statistical formula.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class TTestResult
public class TTestResult
public ref class TTestResult
public class TTestResult
public class TTestResult

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.TTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult Members

TTestResult Members |
 | See Also Constructors Methods Properties

Stores the results of a T Test statistical formula.

The following tables list the members exposed by the TTestResult type.

Public Constructors

Name | Description
TTestResult | Initializes a new instance of the TTestResult class.
Top

Public Properties

Name | Description
DegreeOfFreedom | Gets the degree of freedom.
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityTOneTail | Gets the Probability T one tail value.
ProbabilityTTwoTail | Gets the Probability T two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
TCriticalValueOneTail | Gets the Critical T one tail value.
TCriticalValueTwoTail | Gets the Critical T two tail value.
TValue | Gets the T value.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


TTestResult Constructor

TTestResult Constructor |
 | See Also

Initializes a new instance of the TTestResult class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public TTestResult ()
public:
TTestResult ()
public TTestResult ()
public function TTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult Methods

TTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


TTestResult Properties

TTestResult Properties |
 | See Also

Public Properties

Name | Description
DegreeOfFreedom | Gets the degree of freedom.
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityTOneTail | Gets the Probability T one tail value.
ProbabilityTTwoTail | Gets the Probability T two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
TCriticalValueOneTail | Gets the Critical T one tail value.
TCriticalValueTwoTail | Gets the Critical T two tail value.
TValue | Gets the T value.

See Also

Reference

TTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.DegreeOfFreedom Property

TTestResult.DegreeOfFreedom Property |
 | See Also

Gets the degree of freedom.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedom As Double
public double DegreeOfFreedom { get; }
public:
property double DegreeOfFreedom {
    double get ();
}
/** @property */
public double get_DegreeOfFreedom ()

public function get DegreeOfFreedom () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.FirstSeriesMean Property

TTestResult.FirstSeriesMean Property |
 | See Also

Gets the mean of the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesMean As Double
public double FirstSeriesMean { get; }
public:
property double FirstSeriesMean {
    double get ();
}
/** @property */
public double get_FirstSeriesMean ()

public function get FirstSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.FirstSeriesVariance Property

TTestResult.FirstSeriesVariance Property |
 | See Also

Gets the variance of the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesVariance As Double
public double FirstSeriesVariance { get; }
public:
property double FirstSeriesVariance {
    double get ();
}
/** @property */
public double get_FirstSeriesVariance ()

public function get FirstSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.ProbabilityTOneTail Property

TTestResult.ProbabilityTOneTail Property |
 | See Also

Gets the Probability T one tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityTOneTail As Double
public double ProbabilityTOneTail { get; }
public:
property double ProbabilityTOneTail {
    double get ();
}
/** @property */
public double get_ProbabilityTOneTail ()

public function get ProbabilityTOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.ProbabilityTTwoTail Property

TTestResult.ProbabilityTTwoTail Property |
 | See Also

Gets the Probability T two tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityTTwoTail As Double
public double ProbabilityTTwoTail { get; }
public:
property double ProbabilityTTwoTail {
    double get ();
}
/** @property */
public double get_ProbabilityTTwoTail ()

public function get ProbabilityTTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.SecondSeriesMean Property

TTestResult.SecondSeriesMean Property |
 | See Also

Gets the mean of the second series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesMean As Double
public double SecondSeriesMean { get; }
public:
property double SecondSeriesMean {
    double get ();
}
/** @property */
public double get_SecondSeriesMean ()

public function get SecondSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.SecondSeriesVariance Property

TTestResult.SecondSeriesVariance Property |
 | See Also

Gets the variance of the second series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesVariance As Double
public double SecondSeriesVariance { get; }
public:
property double SecondSeriesVariance {
    double get ();
}
/** @property */
public double get_SecondSeriesVariance ()

public function get SecondSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.TCriticalValueOneTail Property

TTestResult.TCriticalValueOneTail Property |
 | See Also

Gets the Critical T one tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property TCriticalValueOneTail As Double
public double TCriticalValueOneTail { get; }
public:
property double TCriticalValueOneTail {
    double get ();
}
/** @property */
public double get_TCriticalValueOneTail ()

public function get TCriticalValueOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.TCriticalValueTwoTail Property

TTestResult.TCriticalValueTwoTail Property |
 | See Also

Gets the Critical T two tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property TCriticalValueTwoTail As Double
public double TCriticalValueTwoTail { get; }
public:
property double TCriticalValueTwoTail {
    double get ();
}
/** @property */
public double get_TCriticalValueTwoTail ()

public function get TCriticalValueTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


TTestResult.TValue Property

TTestResult.TValue Property |
 | See Also

Gets the T value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property TValue As Double
public double TValue { get; }
public:
property double TValue {
    double get ();
}
/** @property */
public double get_TValue ()

public function get TValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


VerticalLineAnnotation Class

VerticalLineAnnotation Class |
 | See Also Members

Represents a vertical line annotation.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class VerticalLineAnnotation
    Inherits LineAnnotation
public class VerticalLineAnnotation : LineAnnotation
public ref class VerticalLineAnnotation : public LineAnnotation
public class VerticalLineAnnotation extends LineAnnotation
public class VerticalLineAnnotation extends LineAnnotation

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ChartElement
System.Web.UI.DataVisualization.Charting.ChartNamedElement
System.Web.UI.DataVisualization.Charting.Annotation
System.Web.UI.DataVisualization.Charting.LineAnnotation
System.Web.UI.DataVisualization.Charting.VerticalLineAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

VerticalLineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


VerticalLineAnnotation Members

VerticalLineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a vertical line annotation.

The following tables list the members exposed by the VerticalLineAnnotation type.

Public Constructors

Name | Description
VerticalLineAnnotation | Initializes a new instance of the VerticalLineAnnotation class.
Top

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation)
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Url | Gets or sets the URL of an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

VerticalLineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


VerticalLineAnnotation Constructor

VerticalLineAnnotation Constructor |
 | See Also

Initializes a new instance of the VerticalLineAnnotation class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public VerticalLineAnnotation ()
public:
VerticalLineAnnotation ()
public VerticalLineAnnotation ()
public function VerticalLineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

VerticalLineAnnotation Class
VerticalLineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


VerticalLineAnnotation Methods

VerticalLineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

VerticalLineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


VerticalLineAnnotation Properties

VerticalLineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation )
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
MapAreaAttributes | Gets or sets the map area attributes of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
PostBackValue | Gets or sets the postback value which can be processed on the Click event. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Url | Gets or sets the URL of an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

VerticalLineAnnotation Class
System.Web.UI.DataVisualization.Charting Namespace


VerticalLineAnnotation.AnnotationType Property

VerticalLineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use only.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

VerticalLineAnnotation Class
VerticalLineAnnotation Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult Class

ZTestResult Class |
 | See Also Members

Stores the results of a Z Test statistical formula.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Class ZTestResult
public class ZTestResult
public ref class ZTestResult
public class ZTestResult
public class ZTestResult

Inheritance Hierarchy

System.Object
System.Web.UI.DataVisualization.Charting.ZTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult Members

ZTestResult Members |
 | See Also Constructors Methods Properties

Stores the results of a Z Test statistical formula.

The following tables list the members exposed by the ZTestResult type.

Public Constructors

Name | Description
ZTestResult | Initializes a new instance of the ZTestResult class.
Top

Public Properties

Name | Description
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityZOneTail | Gets the Probability Z one tail value.
ProbabilityZTwoTail | Gets the Probability Z two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
ZCriticalValueOneTail | Gets the Critical Z one tail value.
ZCriticalValueTwoTail | Gets the Critical Z two tail value.
ZValue | Gets the Z value.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ZTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult Constructor

ZTestResult Constructor |
 | See Also

Initializes a new instance of the ZTestResult class.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public Sub New
public ZTestResult ()
public:
ZTestResult ()
public ZTestResult ()
public function ZTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult Methods

ZTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ZTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult Properties

ZTestResult Properties |
 | See Also

Public Properties

Name | Description
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityZOneTail | Gets the Probability Z one tail value.
ProbabilityZTwoTail | Gets the Probability Z two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
ZCriticalValueOneTail | Gets the Critical Z one tail value.
ZCriticalValueTwoTail | Gets the Critical Z two tail value.
ZValue | Gets the Z value.

See Also

Reference

ZTestResult Class
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.FirstSeriesMean Property

ZTestResult.FirstSeriesMean Property |
 | See Also

Gets the mean of the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesMean As Double
public double FirstSeriesMean { get; }
public:
property double FirstSeriesMean {
    double get ();
}
/** @property */
public double get_FirstSeriesMean ()

public function get FirstSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.FirstSeriesVariance Property

ZTestResult.FirstSeriesVariance Property |
 | See Also

Gets the variance of the first series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesVariance As Double
public double FirstSeriesVariance { get; }
public:
property double FirstSeriesVariance {
    double get ();
}
/** @property */
public double get_FirstSeriesVariance ()

public function get FirstSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.ProbabilityZOneTail Property

ZTestResult.ProbabilityZOneTail Property |
 | See Also

Gets the Probability Z one tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityZOneTail As Double
public double ProbabilityZOneTail { get; }
public:
property double ProbabilityZOneTail {
    double get ();
}
/** @property */
public double get_ProbabilityZOneTail ()

public function get ProbabilityZOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.ProbabilityZTwoTail Property

ZTestResult.ProbabilityZTwoTail Property |
 | See Also

Gets the Probability Z two tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityZTwoTail As Double
public double ProbabilityZTwoTail { get; }
public:
property double ProbabilityZTwoTail {
    double get ();
}
/** @property */
public double get_ProbabilityZTwoTail ()

public function get ProbabilityZTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.SecondSeriesMean Property

ZTestResult.SecondSeriesMean Property |
 | See Also

Gets the mean of the second series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesMean As Double
public double SecondSeriesMean { get; }
public:
property double SecondSeriesMean {
    double get ();
}
/** @property */
public double get_SecondSeriesMean ()

public function get SecondSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.SecondSeriesVariance Property

ZTestResult.SecondSeriesVariance Property |
 | See Also

Gets the variance of the second series.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesVariance As Double
public double SecondSeriesVariance { get; }
public:
property double SecondSeriesVariance {
    double get ();
}
/** @property */
public double get_SecondSeriesVariance ()

public function get SecondSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.ZCriticalValueOneTail Property

ZTestResult.ZCriticalValueOneTail Property |
 | See Also

Gets the Critical Z one tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ZCriticalValueOneTail As Double
public double ZCriticalValueOneTail { get; }
public:
property double ZCriticalValueOneTail {
    double get ();
}
/** @property */
public double get_ZCriticalValueOneTail ()

public function get ZCriticalValueOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.ZCriticalValueTwoTail Property

ZTestResult.ZCriticalValueTwoTail Property |
 | See Also

Gets the Critical Z two tail value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ZCriticalValueTwoTail As Double
public double ZCriticalValueTwoTail { get; }
public:
property double ZCriticalValueTwoTail {
    double get ();
}
/** @property */
public double get_ZCriticalValueTwoTail ()

public function get ZCriticalValueTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


ZTestResult.ZValue Property

ZTestResult.ZValue Property |
 | See Also

Gets the Z value.

Namespace: System.Web.UI.DataVisualization.Charting
Assembly: System.Web.DataVisualization (in system.web.datavisualization.dll)

Syntax

Public ReadOnly Property ZValue As Double
public double ZValue { get; }
public:
property double ZValue {
    double get ();
}
/** @property */
public double get_ZValue ()

public function get ZValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members
System.Web.UI.DataVisualization.Charting Namespace


System.Windows.Forms.DataVisualization.Charting Namespace

The System.Windows.Forms.DataVisualization.Charting namespace contains methods and properties for the Chart Windows forms control.

Classes

Class | Description
Annotation | Defines properties and methods common to all annotations. This is an abstract class.
AnnotationCollection | Stores chart annotation objects.
AnnotationGroup | Represents a group of annotations.
AnnotationPathPoint | Represents a path point of a PolylineAnnotation or PolygonAnnotation, which is stored in their PathPoints property.
AnnotationPathPointCollection | Represents a collection of PolylineAnnotation or PolygonAnnotation path points, which can be accessed using the GraphicPathPoints property.
AnnotationPositionChangingEventArgs | Provides data for the events in the Chart control that change the position of the annotation.
AnnotationSmartLabelStyle | Stores the smart label properties of an annotation.
AnovaResult | Represents the results of an ANOVA statistical test.
ArrowAnnotation | Represents an arrow annotation.
Axis | Provides methods and properties that manage axes in the Chart control.
AxisScaleBreakStyle | Represents a scale break on the Y-axis of the chart.
AxisScaleView | Represents a scaled view of the chart.
AxisScrollBar | Represents the scrollbar of a chart axis.
Border3DAnnotation | Represents an annotation with a 3D border.
BorderSkin | Represents the drawing properties of the 3D border skin.
CalloutAnnotation | Represents a callout annotation.
Chart | Serves as the root class of the Chart control.
ChartArea | Represents a chart area on the chart image.
ChartArea3DStyle | Manages the display attributes for three-dimensional (3D) chart areas.
ChartAreaCollection | Represents a collection of ChartArea objects.
ChartElement | Base class for all the chart elements. The ChartElement class represents the most basic element of the chart element hierarchy.
ChartElementCollection | Represents the base class for all chart element collections.
ChartElementOutline | Represents an array of marker points and the outline path used for visual object selection in the chart.
ChartGraphics | Provides numerous conversion functions and exposes a GDI+ Graphics object.
ChartNamedElement | Represents the base class for most chart elements. Chart elements such as series, chart areas, and legends must have unique names, and reuse the unique name generation and validation logic provided by the ChartNamedElementCollection class.
ChartNamedElementCollection | Represents the base class for all collections of named chart elements. Performs name management and enforces the uniqueness of the names.
ChartPaintEventArgs | Provides data for the paint events of the Chart control.
ChartSerializer | Enables serialization of the Chart control.
Cursor | Represents a horizontal or vertical line that defines a position along an axis.
CursorEventArgs | Members of this class are used with the following events in the root Chart object: CursorPositionChanged, CursorPositionChanging, SelectionRangeChanged and SelectionRangeChanging.
CustomizeLegendEventArgs | Provides data for the CustomizeLegend event of the Chart control.
CustomLabel | Represents a custom label for an axis.
CustomLabelsCollection | Represents a collection of CustomLabel objects.
CustomProperties | For internal use only.
DataFormula | Provides properties and methods to prepare series data for technical analysis, apply formulas on the series data and prepare output data to be displayed as a chart. The actual calculations are performed in the StatisticFormula class.
DataManipulator | Performs data manipulation operations at run time. This class is exposed by the DataManipulator property of the root Chart object.
DataPoint | Represents a data point that is stored in the DataPointCollection class.
DataPointCollection | Represents a collection of DataPoint objects.
DataPointComparer | Compares data points.
DataPointCustomProperties | Defines custom properties that are common to data points, series and empty points.
ElementPosition | Represents the base class for many visual elements of the chart such as the legend, title, and chart areas. Defines the position of the chart element in relative coordinates, which range from (0,0) to (100,100).
EllipseAnnotation | Represents an ellipse annotation.
FormatNumberEventArgs | Represents the event arguments of the localized number-formatting event.
FTestResult | Stores results of the FTest statistical methods.
Grid | Provides methods and properties that manage the major and minor grids of Axis objects.
HitTestResult | Represents the results of a hit test.
HorizontalLineAnnotation | Represents a horizontal line annotation.
ImageAnnotation | Represents an image annotation.
LabelStyle | Provides properties that define the visual appearance of the axis labels.
Legend | Represents the legend for the chart image.
LegendCell | Represents a legend cell in a legend item.
LegendCellCollection | Stores legend cells in a LegendCellCollection object.
LegendCellColumn | Represents a cell column in a legend, which is used to extend the functionality of the default legend.
LegendCellColumnCollection | Stores LegendCellColumn objects, which are applied to default legend items.
LegendCollection | Represents a collection of Legend objects.
LegendItem | Represents a legend item, which is stored in the LegendItemsCollection class.
LegendItemsCollection | Represents a collection of LegendItem objects.
LineAnnotation | Represents a line annotation.
Margins | Represents the margins for various chart elements.
NamedImage | Represents named images, which are stored in the NamedImagesCollection.
NamedImagesCollection | Represents a collection of NamedImage objects.
Point3D | Represents the coordinates of a three-dimensional (3D) data point. This class is used when performing custom drawing with 3D charts.
PolygonAnnotation | Represents a polygon annotation.
PolylineAnnotation | Represents a polyline annotation.
PrintingManager | Prints the chart.
RectangleAnnotation | Represents a rectangle annotation.
ScrollBarEventArgs | Used as a parameter object in the AxisScrollBarClicked of the root Chart object.
Series | Stores data points and series attributes.
SeriesCollection | Represents a collection of Series objects.
SmartLabelStyle | Provides methods and properties used to perform intelligent, rule-based data point label positioning to resolve overlapping data point label issues.
StatisticFormula | Calculates statistical formulas.
StripLine | Represents the strip lines on a chart.
StripLinesCollection | Represents a collection of StripLine objects.
TextAnnotation | Represents a text annotation.
TickMark | Represents the major and minor tick marks along an axis.
Title | Represents a title for the entire chart image.
TitleCollection | Represents a collection of Title objects.
ToolTipEventArgs | Used as a parameter object in the GetToolTipText event of the root Chart object.
TTestResult | Stores the results of a T Test statistical formula.
VerticalLineAnnotation | Represents a vertical line annotation.
ViewEventArgs | Used as a parameter object in the AxisViewChanged and AxisViewChanging events of the root Chart object.
ZTestResult | Stores the results of a Z Test statistical formula.

Interfaces

Interface | Description
IDataPointFilter | Exposes the FilterDataPoint method, which allows Series data to be custom filtered.

Enumerations

Enumeration | Description
AntiAliasingStyles | Specifies the anti-aliasing options for the chart.
AreaAlignmentOrientations | Specifies the alignment orientation of a chart area.
AreaAlignmentStyles | Specifies the alignment styles of chart areas.
ArrowStyle | Specifies styles for an arrow annotation.
AxisArrowStyle | An enumeration of axis arrow styles.
AxisEnabled | Specifies the state of an axis.
AxisName | Specifies the name of an axis.
AxisType | Specifies the axis type for the X and Y-axes of a Series.
BorderSkinStyle | Specifies a style for the border skin of a chart.
BreakLineStyle | Specifies line styles for axis scale breaks.
CalloutStyle | Represents the available callout styles. Applicable only to callout annotations.
ChartColorPalette | Specifies a palette when setting a Palette property.
ChartDashStyle | Specifies a line style.
ChartElementType | Specifies a chart element type.
ChartHatchStyle | Specifies a hatching style for a chart element.
ChartImageAlignmentStyle | Specifies the image alignment for a chart background image.
ChartImageFormat | Specifies the image type of the chart.
ChartImageWrapMode | Specifies the drawing mode for a background image.
ChartValueType | Specifies value types for various chart properties.
CompareMethod | Specifies the type of comparison to be used when filtering data. This enumeration is used by the Filter method definitions in the DataManipulator class that take the CompareMethod argument.
DateRangeType | Specifies a date/time interval that determines the ranges that will be filtered when you invoke one of the Filter method definitionsfound in the DataManipulator class.
DateTimeIntervalType | Specifies an interval type.
Docking | Specifies where a chart element, such as a legend or title, will be docked on the chart.
FinancialFormula | Specifies a financial formula.
GradientStyle | Specifies a gradient style to be used for a chart element.
GridTickTypes | Specifies the options for displaying a grid line or a tick mark for a custom label.
IntervalAutoMode | Specifies the automatic axis interval mode.
IntervalType | Specifies an interval type.
LabelAlignmentStyles | Specifies a label alignment when SmartLabelStyle is used.
LabelAutoFitStyles | Specifies style changes that can automatically be made to a label when the LabelAutoFitStyle property is used.
LabelCalloutStyle | Specifies the type of leader line that should be drawn from the point to the label.
LabelMarkStyle | Specifies a mark for custom labels.
LabelOutsidePlotAreaStyle | Specifies the degree to which a label can be drawn outside a plotting area.
LegendCellColumnType | Specifies a legend cell column type.
LegendCellType | Specifies a legend cell type.
LegendImageStyle | Specifies the style to apply to the symbol for a legend item.
LegendItemOrder | Specifies the order in which items are added to the legend.
LegendSeparatorStyle | Specifies the styles for legend separator lines.
LegendStyle | Specifies the legend style.
LegendTableStyle | Specifies the legend table style.
LightStyle | Specifies a lighting style for a three-dimensional (3D) chart area.
LineAnchorCapStyle | Specifies the shape—that is, the anchor cap—to draw on the point end of the label callout line.
MarkerStyle | Specifies a style for markers.
PointSortOrder | Indicates whether the sort order for data points is ascending or descending.
ScrollBarButtonStyles | Specifies the type of button that will be displayed on the scrollbar.
ScrollBarButtonType | Specifies the button clicked by a user in the AxisScrollBarClicked event.
ScrollType | Specifies the scrolling that will occur when the one of the Scroll methods in the AxisScaleView class is called.
SerializationContents | Specifies the type of chart content to be serialized.
SerializationFormat | Represents the formatting type to use when the chart is serialized.
SeriesChartType | Specifies a chart type for a Series.
StartFromZero | Indicates whether an axis segment should start from zero when a scale break is used.
TextAntiAliasingQuality | Specifies the level of anti-aliasing quality to be used with the TextAntiAliasingQuality&nbsp;property.
TextOrientation | Specifies text orientation in a chart element.
TextStyle | Specifies text drawing styles.
TickMarkStyle | Specifies a tick mark style when setting the TickMarkStyle property of a TickMark object.


Annotation Class

Annotation Class |
 | See Also Members

Defines properties and methods common to all annotations. This is an abstract class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public MustInherit Class Annotation
    Inherits ChartNamedElement
public abstract class Annotation : ChartNamedElement
public ref class Annotation abstract : public ChartNamedElement
public abstract class Annotation extends ChartNamedElement
public abstract class Annotation extends ChartNamedElement

Remarks

Annotations are commonly used to comment or elaborate on chart elements such as data points. Annotations can also be used to draw custom shapes.

By default, annotations are positioned using relative coordinates, with (0,0) representing the top-left corner, and (100,100) representing the bottom-right corner of the chart image. It is also possible to switch from this relative coordinate system to a system that uses axis values. With an axis coordinate system, X and Y, which represent the position of the top-left corner of an annotation, are set using X axis and Y axis values, instead of values that range from 0-100.

There are two ways to use axis values when you specify the position and size of an annotation:

  • Set the AxisX, AxisY or both of these annotation properties to the AxisX and AxisY property values of a ChartArea object.

  • Use the AnchorDataPoint property to anchor the annotation to a data point. In this case, its positioning is automatically calculated.

All annotations are derived from the Annotation class, which can be used to set attributes common to all Annotation objects, such as color, position, anchoring and so forth.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Members
System.Windows.Forms.DataVisualization.Charting Namespace


Annotation Members

Annotation Members |
 | See Also Methods Properties Constructors

Defines properties and methods common to all annotations. This is an abstract class.

The following tables list the members exposed by the Annotation type.

Protected Constructors

Name | Description
Annotation | Initializes a new instance of the Annotation class. This is the default constructor and should not be used.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse.
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse.
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse.
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse.
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse.
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text.
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored.
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only.
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation.
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored.
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored.
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only.
AnnotationType | Gets or sets an annotation's type name. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached.
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only.
AxisY | Gets or sets the Y axis to which an annotation is attached.
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only.
BackColor | Gets or sets the color of an annotation background.
BackGradientStyle | Gets or sets the gradient style of an annotation background.
BackHatchStyle | Gets or sets the hatching style of an annotation background.
BackSecondaryColor | Gets or sets the secondary color of an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped.
Font |
ForeColor | Gets or sets the text color of an annotation.
Height | Gets or sets the height of an annotation.
IsSelected | Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation.
LineDashStyle | Gets or sets the line style of an annotation.
LineWidth | Gets or sets the line width of an annotation.
Name | Overridden. Gets or sets the unique name of an annotation.
Right | Gets or sets the right boundary position of an annotation.
ShadowColor | Gets or sets the color of an annotation's shadow.
ShadowOffset | Gets or sets the size of an annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation.
Visible | Gets or sets a flag that specifies whether an annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation.
X | Gets or sets the X coordinate of an annotation.
Y | Gets or sets the Y coordinate of the annotation.
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse.
BringToFront | Brings an annotation to the front of all annotations.
Dispose | Overloaded.
EndPlacement | Ends the end user placement of an annotation.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size.
SendToBack | Sends an annotation to the back of all the annotations.
SetAnchor | Overloaded.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Annotation Class


Annotation Constructor

Annotation Constructor |
 | See Also

Initializes a new instance of the Annotation class. This is the default constructor and should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Sub New
protected Annotation ()
protected:
Annotation ()
protected Annotation ()
protected function Annotation ()

Remarks

Annotation is an abstract class and cannot be created directly. To create a new annotation object, use constructors of classes such as LineAnnotation, RectangleAnnotation, and the like.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation Methods

Annotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse.
BringToFront | Brings an annotation to the front of all annotations.
Dispose | Overloaded.
EndPlacement | Ends the end user placement of an annotation.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size.
SendToBack | Sends an annotation to the back of all the annotations.
SetAnchor | Overloaded.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Annotation Class


Annotation.BeginPlacement Method

Annotation.BeginPlacement Method |
 | See Also

Begins the end user placement of an annotation using the mouse.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub BeginPlacement
public virtual void BeginPlacement ()
public:
virtual void BeginPlacement ()
public void BeginPlacement ()
public function BeginPlacement ()

Remarks

When this method is called, the end user is allowed to place an annotation using the mouse.

Placement finishes when the end user specifies all required points, or when the EndPlacement method is called.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.BringToFront Method

Annotation.BringToFront Method |
 | See Also

Brings an annotation to the front of all annotations.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub BringToFront
public virtual void BringToFront ()
public:
virtual void BringToFront ()
public void BringToFront ()
public function BringToFront ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Dispose Method

Annotation.Dispose Method |
 | See Also

Overload List

Name | Description
Annotation.Dispose () | (inherited from Dispose )
Annotation.Dispose (Boolean) | Releases unmanaged resources and, optionally, managed resources.

See Also

Reference

Annotation Class
Annotation Members


Annotation.Dispose Method (Boolean)

Annotation.Dispose Method (Boolean) |
 | See Also

Releases unmanaged resources and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.EndPlacement Method

Annotation.EndPlacement Method |
 | See Also

Ends the end user placement of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub EndPlacement
public virtual void EndPlacement ()
public:
virtual void EndPlacement ()
public void EndPlacement ()
public function EndPlacement ()

Remarks

This method ends an annotation placement operation previously started by a BeginPlacement method call.

Calling this method is not required, because placement will automatically end when an end user enters all required points. However, it is useful when an annotation placement operation needs to be aborted for some reason.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.ResizeToContent Method

Annotation.ResizeToContent Method |
 | See Also

Resizes an annotation according to its content size.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub ResizeToContent
public virtual void ResizeToContent ()
public:
virtual void ResizeToContent ()
public void ResizeToContent ()
public function ResizeToContent ()

Remarks

Sets the annotation width and height to fit the specified text.

This method applies to TextAnnotation, RectangleAnnotation, EllipseAnnotation and CalloutAnnotation objects only.

Note:
This method requires that the annotation be added to the AnnotationCollection to function correctly.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.SendToBack Method

Annotation.SendToBack Method |
 | See Also

Sends an annotation to the back of all the annotations.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub SendToBack
public virtual void SendToBack ()
public:
virtual void SendToBack ()
public void SendToBack ()
public function SendToBack ()

Remarks

Sends an annotation to the back of the all annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.SetAnchor Method

Annotation.SetAnchor Method |
 | See Also

Overload List

Name | Description
Annotation.SetAnchor (DataPoint) | Anchors an annotation to the specified data point.
Annotation.SetAnchor (DataPoint, DataPoint) | Anchors an annotation to two data points.

See Also

Reference

Annotation Class
Annotation Members


Annotation.SetAnchor Method (DataPoint)

Annotation.SetAnchor Method (DataPoint) |
 | See Also

Anchors an annotation to the specified data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SetAnchor ( _
    dataPoint As DataPoint _
)
public void SetAnchor (
    DataPoint dataPoint
)
public:
void SetAnchor (
    DataPoint^ dataPoint
)
public void SetAnchor (
    DataPoint dataPoint
)
public function SetAnchor (
    dataPoint : DataPoint
)

Parameters

dataPoint

The DataPoint to which the annotation will be anchored.

Remarks

Anchors an annotation to the specified data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.SetAnchor Method (DataPoint, DataPoint)

Annotation.SetAnchor Method (DataPoint, DataPoint) |
 | See Also

Anchors an annotation to two data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SetAnchor ( _
    dataPoint1 As DataPoint, _
    dataPoint2 As DataPoint _
)
public void SetAnchor (
    DataPoint dataPoint1,
    DataPoint dataPoint2
)
public:
void SetAnchor (
    DataPoint^ dataPoint1,
    DataPoint^ dataPoint2
)
public void SetAnchor (
    DataPoint dataPoint1,
    DataPoint dataPoint2
)
public function SetAnchor (
    dataPoint1 : DataPoint,
    dataPoint2 : DataPoint
)

Parameters

dataPoint1

The first anchor DataPoint.

dataPoint2

The second anchor DataPoint.

Remarks

Anchors an annotation's top-left and bottom-right corners to the specified data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation Properties

Annotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse.
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse.
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse.
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse.
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse.
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text.
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored.
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only.
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation.
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored.
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored.
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only.
AnnotationType | Gets or sets an annotation's type name. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached.
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only.
AxisY | Gets or sets the Y axis to which an annotation is attached.
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only.
BackColor | Gets or sets the color of an annotation background.
BackGradientStyle | Gets or sets the gradient style of an annotation background.
BackHatchStyle | Gets or sets the hatching style of an annotation background.
BackSecondaryColor | Gets or sets the secondary color of an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped.
Font |
ForeColor | Gets or sets the text color of an annotation.
Height | Gets or sets the height of an annotation.
IsSelected | Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation.
LineDashStyle | Gets or sets the line style of an annotation.
LineWidth | Gets or sets the line width of an annotation.
Name | Overridden. Gets or sets the unique name of an annotation.
Right | Gets or sets the right boundary position of an annotation.
ShadowColor | Gets or sets the color of an annotation's shadow.
ShadowOffset | Gets or sets the size of an annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation.
Visible | Gets or sets a flag that specifies whether an annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation.
X | Gets or sets the X coordinate of an annotation.
Y | Gets or sets the Y coordinate of the annotation.
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only.

See Also

Reference

Annotation Class


Annotation.Alignment Property

Annotation.Alignment Property |
 | See Also

Gets or sets the content alignment of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Alignment As ContentAlignment
public virtual ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the content alignment.

Remarks

This property is used to align text for TextAnnotation, RectangleAnnotation, EllipseAnnotation and CalloutAnnotation objects, and to align a non-scaled image inside an ImageAnnotation object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AllowAnchorMoving Property

Annotation.AllowAnchorMoving Property |
 | See Also

Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowAnchorMoving As Boolean
public virtual bool AllowAnchorMoving { get; set; }
public:
virtual property bool AllowAnchorMoving {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AllowAnchorMoving ()

/** @property */
public void set_AllowAnchorMoving (boolean value)

public function get AllowAnchorMoving () : boolean

public function set AllowAnchorMoving (value : boolean)

Property Value

True if the annotation anchor may be moved, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AllowMoving Property

Annotation.AllowMoving Property |
 | See Also

Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowMoving As Boolean
public virtual bool AllowMoving { get; set; }
public:
virtual property bool AllowMoving {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AllowMoving ()

/** @property */
public void set_AllowMoving (boolean value)

public function get AllowMoving () : boolean

public function set AllowMoving (value : boolean)

Property Value

True if the annotation may be moved, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AllowPathEditing Property

Annotation.AllowPathEditing Property |
 | See Also

Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowPathEditing As Boolean
public virtual bool AllowPathEditing { get; set; }
public:
virtual property bool AllowPathEditing {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AllowPathEditing ()

/** @property */
public void set_AllowPathEditing (boolean value)

public function get AllowPathEditing () : boolean

public function set AllowPathEditing (value : boolean)

Property Value

True if the polygon annotation's points may be moved, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AllowResizing Property

Annotation.AllowResizing Property |
 | See Also

Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowResizing As Boolean
public virtual bool AllowResizing { get; set; }
public:
virtual property bool AllowResizing {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AllowResizing ()

/** @property */
public void set_AllowResizing (boolean value)

public function get AllowResizing () : boolean

public function set AllowResizing (value : boolean)

Property Value

True if the annotation may be resized, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AllowSelecting Property

Annotation.AllowSelecting Property |
 | See Also

Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowSelecting As Boolean
public virtual bool AllowSelecting { get; set; }
public:
virtual property bool AllowSelecting {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AllowSelecting ()

/** @property */
public void set_AllowSelecting (boolean value)

public function get AllowSelecting () : boolean

public function set AllowSelecting (value : boolean)

Property Value

True if the annotation may be selected, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AllowTextEditing Property

Annotation.AllowTextEditing Property |
 | See Also

Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowTextEditing As Boolean
public virtual bool AllowTextEditing { get; set; }
public:
virtual property bool AllowTextEditing {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AllowTextEditing ()

/** @property */
public void set_AllowTextEditing (boolean value)

public function get AllowTextEditing () : boolean

public function set AllowTextEditing (value : boolean)

Property Value

True if the annotation text may be edited, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorAlignment Property

Annotation.AnchorAlignment Property |
 | See Also

Gets or sets the alignment of an annotation to the anchor point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AnchorAlignment As ContentAlignment
public virtual ContentAlignment AnchorAlignment { get; set; }
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public function get AnchorAlignment () : ContentAlignment

public function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the alignment of the annotation to the anchor point.

Remarks

The annotation must be anchored by either using the AnchorDataPoint property, or by setting the AnchorX and AnchorY properties. Its X and Y properties must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorDataPoint Property

Annotation.AnchorDataPoint Property |
 | See Also

Gets or sets the data point to which an annotation is anchored.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property AnchorDataPoint As DataPoint
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual DataPoint AnchorDataPoint { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property DataPoint^ AnchorDataPoint {
    DataPoint^ get ();
    void set (DataPoint^ value);
}
/** @property */
public DataPoint get_AnchorDataPoint ()

/** @property */
public void set_AnchorDataPoint (DataPoint value)

public function get AnchorDataPoint () : DataPoint

public function set AnchorDataPoint (value : DataPoint)

Property Value

A DataPoint object to which an annotation is anchored.

Remarks

The annotation is anchored to the X and Y values of the specified data point, and automatically uses the same axes coordinates as the data point.

To automatically position the annotation relative to the anchor point, make sure its X and Y properties are set to NaN. The AnchorAlignment property can be used to change the automatic position alignment of the annotation to the anchor point. The AnchorOffsetX and AnchorOffsetY properties may be used to add extra spacing.

When you use this property, make sure the AnchorX and AnchorY properties are set to Double.NaN, as they have precedence.

Set this value to null to disable annotation anchoring to a data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorDataPointName Property

Annotation.AnchorDataPointName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of a data point to which an annotation is anchored. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property AnchorDataPointName As String
[BrowsableAttribute(false)]
public virtual string AnchorDataPointName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AnchorDataPointName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AnchorDataPointName ()

/** @property */
public void set_AnchorDataPointName (String value)

public function get AnchorDataPointName () : String

public function set AnchorDataPointName (value : String)

Property Value

A string value that represents the name of the data point that an annotation is anchored to.

Remarks

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorOffsetX Property

Annotation.AnchorOffsetX Property |
 | See Also

Gets or sets the offset from the anchor point for the X position of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AnchorOffsetX As Double
public virtual double AnchorOffsetX { get; set; }
public:
virtual property double AnchorOffsetX {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorOffsetX ()

/** @property */
public void set_AnchorOffsetX (double value)

public function get AnchorOffsetX () : double

public function set AnchorOffsetX (value : double)

Property Value

A double value that represents the offset of the X position from the anchor point.

Remarks

The annotation must be anchored using either the AnchorDataPoint or the AnchorX property, and its X property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorOffsetY Property

Annotation.AnchorOffsetY Property |
 | See Also

Gets or sets the offset from the anchor point for the Y position of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AnchorOffsetY As Double
public virtual double AnchorOffsetY { get; set; }
public:
virtual property double AnchorOffsetY {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorOffsetY ()

/** @property */
public void set_AnchorOffsetY (double value)

public function get AnchorOffsetY () : double

public function set AnchorOffsetY (value : double)

Property Value

A double value that represents the offset of the Y position from the anchor point.

Remarks

The annotation must be anchored using either the AnchorDataPoint or AnchorY property, and its Y property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorX Property

Annotation.AnchorX Property |
 | See Also

Gets or sets the X coordinate to which the annotation is anchored.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AnchorX As Double
public virtual double AnchorX { get; set; }
public:
virtual property double AnchorX {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorX ()

/** @property */
public void set_AnchorX (double value)

public function get AnchorX () : double

public function set AnchorX (value : double)

Property Value

A double value that represents the X coordinate an annotation is anchored to.

Remarks

The annotation is anchored to the X coordinate and is specified in relative chart or axes coordinates, depending on the AxisX property value.

To automatically position an annotation relative to an anchor point, make sure its X property is set to NaN. The AnchorAlignment property can be used to change the automatic position alignment of the annotation to the anchor point. The AnchorOffsetX and AnchorOffsetY properties may be used to add extra spacing.

This property has a higher priority than the AnchorDataPoint property.

Set this value to NaN to disable annotation anchoring to the value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnchorY Property

Annotation.AnchorY Property |
 | See Also

Gets or sets the Y coordinate to which the annotation is anchored.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AnchorY As Double
public virtual double AnchorY { get; set; }
public:
virtual property double AnchorY {
    double get ();
    void set (double value);
}
/** @property */
public double get_AnchorY ()

/** @property */
public void set_AnchorY (double value)

public function get AnchorY () : double

public function set AnchorY (value : double)

Property Value

A double value that represents the Y coordinate an annotation is anchored to.

Remarks

The annotation is anchored to the Y coordinate and is specified in relative chart or axes coordinates, depending on the AxisX property value.

To automatically position an annotation relative to an anchor point make sure its Y property is set to NaN. The AnchorAlignment property can be used to change the automatic position alignment of the annotation to the anchor point. The AnchorOffsetX and AnchorOffsetY properties may be used to add extra spacing.

This property has a higher priority than the AnchorDataPoint property.

Set this value to NaN to disable annotation anchoring to the value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnnotationGroup Property

Annotation.AnnotationGroup Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the group, if any, to which the annotation belongs. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property AnnotationGroup As AnnotationGroup
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public AnnotationGroup AnnotationGroup { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property AnnotationGroup^ AnnotationGroup {
    AnnotationGroup^ get ();
}
/** @property */
public AnnotationGroup get_AnnotationGroup ()

public function get AnnotationGroup () : AnnotationGroup

Property Value

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AnnotationType Property

Annotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets an annotation's type name. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public MustOverride ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public abstract string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () abstract;
}
/** @property */
public abstract String get_AnnotationType ()

public abstract function get AnnotationType () : String

Remarks

This property is used to get the name of each annotation type, for example, Line, Rectangle, Ellipse, and so forth. This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AxisX Property

Annotation.AxisX Property |
 | See Also

Gets or sets the X axis to which an annotation is attached.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property AxisX As Axis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Axis AxisX { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Axis^ AxisX {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisX ()

/** @property */
public void set_AxisX (Axis value)

public function get AxisX () : Axis

public function set AxisX (value : Axis)

Property Value

An Axis object to which the annotation is attached.

Remarks

When an annotation is attached to an axis, its X position is always specified in axes coordinates. To also define the size of an annotation in axes coordinates, make sure the IsSizeAlwaysRelative property is set to false.

Set this value to null to disable attachment to the axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AxisXName Property

Annotation.AxisXName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of the X axis to which an annotation is attached. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property AxisXName As String
[BrowsableAttribute(false)]
public virtual string AxisXName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AxisXName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AxisXName ()

/** @property */
public void set_AxisXName (String value)

public function get AxisXName () : String

public function set AxisXName (value : String)

Property Value

A string value that represents the name of the X axis which an annotation is attached to.

Remarks

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AxisY Property

Annotation.AxisY Property |
 | See Also

Gets or sets the Y axis to which an annotation is attached.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property AxisY As Axis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Axis AxisY { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Axis^ AxisY {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisY ()

/** @property */
public void set_AxisY (Axis value)

public function get AxisY () : Axis

public function set AxisY (value : Axis)

Property Value

An Axis object to which this annotation is attached.

Remarks

When an annotation is attached to an axis, its Y position is always specified in axes coordinates. To also define the size of an annotation in axes coordinates, make sure the IsSizeAlwaysRelative property is set to false.

Set to null to disable annotation attachment to an axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.AxisYName Property

Annotation.AxisYName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of the Y axis which an annotation is attached to. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property AxisYName As String
[BrowsableAttribute(false)]
public virtual string AxisYName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AxisYName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AxisYName ()

/** @property */
public void set_AxisYName (String value)

public function get AxisYName () : String

public function set AxisYName (value : String)

Property Value

A string value that represents the name of the Y axis that an annotation is attached to.

Remarks

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.BackColor Property

Annotation.BackColor Property |
 | See Also

Gets or sets the color of an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property BackColor As Color
public virtual Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value used to draw an annotation background.

Remarks

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.BackGradientStyle Property

Annotation.BackGradientStyle Property |
 | See Also

Gets or sets the gradient style of an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property BackGradientStyle As GradientStyle
public virtual GradientStyle BackGradientStyle { get; set; }
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw an annotation background.

Remarks

Two colors are used to draw the gradients, BackColor and BackSecondaryColor.

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.BackHatchStyle Property

Annotation.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property BackHatchStyle As ChartHatchStyle
public virtual ChartHatchStyle BackHatchStyle { get; set; }
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the background.

Remarks

Two colors are used to draw the hatching, BackColor and BackSecondaryColor.

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.BackSecondaryColor Property

Annotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property BackSecondaryColor As Color
public virtual Color BackSecondaryColor { get; set; }
public:
virtual property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw an annotation background with hatching or gradient fill.

Remarks

The secondary color is used with the BackColor when BackHatchStyle or BackGradientStyle is used.

This property does not apply to line-type annotations, image annotations and text annotations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Bottom Property

Annotation.Bottom Property |
 | See Also

Gets or sets the bottom boundary of an annotation position.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overridable Property Bottom As Double
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public virtual double Bottom { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property double Bottom {
    double get ();
    void set (double value);
}
/** @property */
public double get_Bottom ()

/** @property */
public void set_Bottom (double value)

public function get Bottom () : double

public function set Bottom (value : double)

Property Value

A double value that represents the position of the bottom boundary of an annotation.

Remarks

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX or AxisY properties and set the IsSizeAlwaysRelative property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.ClipToChartArea Property

Annotation.ClipToChartArea Property |
 | See Also

Gets or sets the name of the chart area to which an annotation is clipped.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ClipToChartArea As String
public virtual string ClipToChartArea { get; set; }
public:
virtual property String^ ClipToChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ClipToChartArea ()

/** @property */
public void set_ClipToChartArea (String value)

public function get ClipToChartArea () : String

public function set ClipToChartArea (value : String)

Property Value

A string that represents the name of an existing chart area.

Remarks

If the chart area name is specified, an annotation will only be drawn inside the plotting area of the chart area specified. All parts of the annotation outside of the plotting area will be clipped.

To disable chart area clipping, set the property to Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Font Property

Annotation.Font Property |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Font As Font
public virtual Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object used to draw the annotation text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.ForeColor Property

Annotation.ForeColor Property |
 | See Also

Gets or sets the text color of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ForeColor As Color
public virtual Color ForeColor { get; set; }
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value used for the text color of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Height Property

Annotation.Height Property |
 | See Also

Gets or sets the height of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Height As Double
public virtual double Height { get; set; }
public:
virtual property double Height {
    double get ();
    void set (double value);
}
/** @property */
public double get_Height ()

/** @property */
public void set_Height (double value)

public function get Height () : double

public function set Height (value : double)

Property Value

A double value that represents the height of an annotation.

Remarks

The height of an annotation can be a negative value, in which case the annotation orientation is switched.

Annotation width can be in relative chart coordinates or in axes coordinates. Chart relative coordinates are used by default.

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX or AxisY properties and set the IsSizeAlwaysRelative property to false.

Set the width to NaN to achieve automatic size calculation for annotations with text. The size will automatically be calculated based on the annotation text and font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.IsSelected Property

Annotation.IsSelected Property |
 | See Also

Gets or sets a flag that determines if an annotation is selected.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property IsSelected As Boolean
[BrowsableAttribute(false)]
public virtual bool IsSelected { get; set; }
[BrowsableAttribute(false)]
public:
virtual property bool IsSelected {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSelected ()

/** @property */
public void set_IsSelected (boolean value)

public function get IsSelected () : boolean

public function set IsSelected (value : boolean)

Property Value

True if the annotation is selected, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.IsSizeAlwaysRelative Property

Annotation.IsSizeAlwaysRelative Property |
 | See Also

Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsSizeAlwaysRelative As Boolean
public virtual bool IsSizeAlwaysRelative { get; set; }
public:
virtual property bool IsSizeAlwaysRelative {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSizeAlwaysRelative ()

/** @property */
public void set_IsSizeAlwaysRelative (boolean value)

public function get IsSizeAlwaysRelative () : boolean

public function set IsSizeAlwaysRelative (value : boolean)

Property Value

True if the Width and Height of an annotation are always expressed in relative chart coordinates, otherwise false.

Remarks

The height and width of an annotation may be set in relative chart or in axes coordinates. Relative chart coordinates are the default.

To express the size of an annotation in axes coordinates, set the IsSizeAlwaysRelative property to false. Then anchor the annotation to a data point or set the AxisX and AxisY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.LineColor Property

Annotation.LineColor Property |
 | See Also

Gets or sets the line color of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property LineColor As Color
public virtual Color LineColor { get; set; }
public:
virtual property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color value used to draw an annotation's line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.LineDashStyle Property

Annotation.LineDashStyle Property |
 | See Also

Gets or sets the line style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property LineDashStyle As ChartDashStyle
public virtual ChartDashStyle LineDashStyle { get; set; }
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value used to draw the line style of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.LineWidth Property

Annotation.LineWidth Property |
 | See Also

Gets or sets the line width of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property LineWidth As Integer
public virtual int LineWidth { get; set; }
public:
virtual property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that defines the line width, in pixels, of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Name Property

Annotation.Name Property |
 | See Also

Gets or sets the unique name of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string that represents the unique name of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Right Property

Annotation.Right Property |
 | See Also

Gets or sets the right boundary position of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overridable Property Right As Double
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public virtual double Right { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property double Right {
    double get ();
    void set (double value);
}
/** @property */
public double get_Right ()

/** @property */
public void set_Right (double value)

public function get Right () : double

public function set Right (value : double)

Property Value

A double value that represents the position of the right boundary of an annotation.

Remarks

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX and AxisY properties and set the IsSizeAlwaysRelative property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.ShadowColor Property

Annotation.ShadowColor Property |
 | See Also

Gets or sets the color of an annotation's shadow.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ShadowColor As Color
public virtual Color ShadowColor { get; set; }
public:
virtual property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value used to draw the annotation shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.ShadowOffset Property

Annotation.ShadowOffset Property |
 | See Also

Gets or sets the size of an annotation's shadow.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ShadowOffset As Integer
public virtual int ShadowOffset { get; set; }
public:
virtual property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the size of the shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.SmartLabelStyle Property

Annotation.SmartLabelStyle Property |
 | See Also

Gets or sets the smart label style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
<BrowsableAttribute(True)> _
Public Property SmartLabelStyle As AnnotationSmartLabelStyle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[BrowsableAttribute(true)]
public AnnotationSmartLabelStyle SmartLabelStyle { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
[BrowsableAttribute(true)]
public:
property AnnotationSmartLabelStyle^ SmartLabelStyle {
    AnnotationSmartLabelStyle^ get ();
    void set (AnnotationSmartLabelStyle^ value);
}
/** @property */
public AnnotationSmartLabelStyle get_SmartLabelStyle ()

/** @property */
public void set_SmartLabelStyle (AnnotationSmartLabelStyle value)

public function get SmartLabelStyle () : AnnotationSmartLabelStyle

public function set SmartLabelStyle (value : AnnotationSmartLabelStyle)

Property Value

An AnnotationSmartLabelStyle object that represents an annotation's smart labels style properties.

Remarks

Smart labels are used to prevent an annotation from overlapping the data point labels and other annotations.

Note:
Data point labels must also have smart labels enabled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.TextStyle Property

Annotation.TextStyle Property |
 | See Also

Gets or sets the text style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property TextStyle As TextStyle
public virtual TextStyle TextStyle { get; set; }
public:
virtual property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public function get TextStyle () : TextStyle

public function set TextStyle (value : TextStyle)

Property Value

A TextStyle value used to draw the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.ToolTip Property

Annotation.ToolTip Property |
 | See Also

Gets or sets the tooltip text for an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ToolTip As String
public virtual string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value.

Remarks

Special keywords can be used in the text when an annotation is anchored to a data point using the AnchorDataPoint property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Visible Property

Annotation.Visible Property |
 | See Also

Gets or sets a flag that specifies whether an annotation is visible.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Visible As Boolean
public virtual bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public function get Visible () : boolean

public function set Visible (value : boolean)

Property Value

True if the annotation is visible, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Width Property

Annotation.Width Property |
 | See Also

Gets or sets the width, in pixels, of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Width As Double
public virtual double Width { get; set; }
public:
virtual property double Width {
    double get ();
    void set (double value);
}
/** @property */
public double get_Width ()

/** @property */
public void set_Width (double value)

public function get Width () : double

public function set Width (value : double)

Property Value

A double value that represents the width of an annotation.

Remarks

For more information, see the Height property description.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.X Property

Annotation.X Property |
 | See Also

Gets or sets the X coordinate of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="X")> _
Public Overridable Property X As Double
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="X")]
public virtual double X { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"X")]
public:
virtual property double X {
    double get ();
    void set (double value);
}
/** @property */
public double get_X ()

/** @property */
public void set_X (double value)

public function get X () : double

public function set X (value : double)

Property Value

A double value that represents the X coordinate of an annotation's position.

Remarks

The X coordinate of an annotation is specified in relative chart coordinates or in axes coordinates. Relative chart coordinates are used by default.

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX and AxisY properties.

Set the X position to NaN to automatically calculate position when the annotation has been anchored using the AnchorDataPoint property or the AnchorX and AnchorY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.Y Property

Annotation.Y Property |
 | See Also

Gets or sets the Y coordinate of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Y")> _
Public Overridable Property Y As Double
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Y")]
public virtual double Y { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Y")]
public:
virtual property double Y {
    double get ();
    void set (double value);
}
/** @property */
public double get_Y ()

/** @property */
public void set_Y (double value)

public function get Y () : double

public function set Y (value : double)

Property Value

A double value that represents the Y coordinate of an annotation's position.

Remarks

The Y coordinate of an annotation is specified in relative chart coordinates or in axes coordinates. Relative chart coordinates are used by default.

To use axes coordinates, anchor an annotation to a data point using the AnchorDataPoint property, or set the annotation axes using the AxisX or AxisY properties.

Set the Y position to NaN to automatically calculate the position when the annotation has been anchored using the AnchorDataPoint property or the AnchorX and AnchorY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


Annotation.YAxisName Property

Annotation.YAxisName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the name of the Y axis to which an annotation is attached. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overridable Property YAxisName As String
[BrowsableAttribute(false)]
public virtual string YAxisName { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ YAxisName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_YAxisName ()

/** @property */
public void set_YAxisName (String value)

public function get YAxisName () : String

public function set YAxisName (value : String)

Property Value

A string value that represents the name of the Y axis which an annotation is attached to.

Remarks

This property is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Annotation Class
Annotation Members


AnnotationCollection Class

AnnotationCollection Class |
 | See Also Members

Stores chart annotation objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnnotationCollection
    Inherits ChartNamedElementCollection(Of Annotation)
public class AnnotationCollection : ChartNamedElementCollection<Annotation>
public ref class AnnotationCollection : public ChartNamedElementCollection<Annotation^>
public class AnnotationCollection extends ChartNamedElementCollection<Annotation>
public class AnnotationCollection extends ChartNamedElementCollection<Annotation>

Remarks

All chart annotations are stored in this collection.

This class includes methods to add, insert, iterate through and remove annotations from the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.AnnotationCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationCollection Members


AnnotationCollection Members

AnnotationCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Stores chart annotation objects.

The following tables list the members exposed by the AnnotationCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Overridden. Finds an annotation in the collection by name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

AnnotationCollection Class


AnnotationCollection Methods

AnnotationCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Overridden. Finds an annotation in the collection by name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

AnnotationCollection Class


AnnotationCollection.FindByName Method

AnnotationCollection.FindByName Method |
 | See Also

Finds an annotation in the collection by name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Function FindByName ( _
    name As String _
) As Annotation
public override Annotation FindByName (
    string name
)
public:
virtual Annotation^ FindByName (
    String^ name
) override
public Annotation FindByName (
    String name
)
public override function FindByName (
    name : String
) : Annotation

Parameters

name

The name of the annotation to find.

Return Value

An Annotation object, or null if the object does not exist.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Properties

AnnotationCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

AnnotationCollection Class


AnnotationGroup Class

AnnotationGroup Class |
 | See Also Members

Represents a group of annotations.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnnotationGroup
    Inherits Annotation
public class AnnotationGroup : Annotation
public ref class AnnotationGroup : public Annotation
public class AnnotationGroup extends Annotation
public class AnnotationGroup extends Annotation

Remarks

The AnnotationGroup class represents a collection of annotations. This class can be used to manipulate annotations relative to each other.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.AnnotationGroup

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Members


AnnotationGroup Members

AnnotationGroup Members |
 | See Also Constructors Methods Properties

Represents a group of annotations.

The following tables list the members exposed by the AnnotationGroup type.

Public Constructors

Name | Description
AnnotationGroup | Initializes a new instance of the AnnotationGroup class.
Top

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the content alignment of an annotation.
AllowAnchorMoving | Overridden. Gets or sets a flag that specifies whether an annotation anchor may be moved with a mouse by the end user.
AllowMoving | Overridden. Gets or sets a flag that specifies whether an annotation may be moved with a mouse by the end user.
AllowPathEditing | Overridden. Gets or sets a flag that specifies whether the points of a polygon annotation may be moved with a mouse by the end user.
AllowResizing | Overridden. Gets or sets a flag that specifies whether an annotation may be resized with a mouse by the end user.
AllowSelecting | Overridden. Gets or sets a flag that specifies whether an annotation may be selected with a mouse by the end user.
AllowTextEditing | Overridden. Gets or sets a flag that specifies whether an annotation's text may be edited when the end user double clicks the text.
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
Annotations | Gets the collection of annotations in the group.
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the background of an annotation.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Overridden. Gets or sets the name of the chart area to which the annotation is clipped.
Font | Overridden. Gets or sets the font to use for the text of an annotation.
ForeColor | Overridden. Gets or sets the text color for an annotation.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsSelected | Overridden. Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Overridden. Gets or sets the line color of the annotation.
LineDashStyle | Overridden. Gets or sets the line style of the annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of the annotation.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Overridden. Gets or sets the color of the annotation's shadow.
ShadowOffset | Overridden. Gets or sets the size of the annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Overridden. Gets or sets a flag that indicates whether the annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded.
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationGroup Class


AnnotationGroup Constructor

AnnotationGroup Constructor |
 | See Also

Initializes a new instance of the AnnotationGroup class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AnnotationGroup ()
public:
AnnotationGroup ()
public AnnotationGroup ()
public function AnnotationGroup ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup Methods

AnnotationGroup Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded.
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationGroup Class


AnnotationGroup.Dispose Method

AnnotationGroup.Dispose Method |
 | See Also

Overload List

Name | Description
AnnotationGroup.Dispose () | (inherited from Dispose )
AnnotationGroup.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.Dispose Method (Boolean)

AnnotationGroup.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup Properties

AnnotationGroup Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the content alignment of an annotation.
AllowAnchorMoving | Overridden. Gets or sets a flag that specifies whether an annotation anchor may be moved with a mouse by the end user.
AllowMoving | Overridden. Gets or sets a flag that specifies whether an annotation may be moved with a mouse by the end user.
AllowPathEditing | Overridden. Gets or sets a flag that specifies whether the points of a polygon annotation may be moved with a mouse by the end user.
AllowResizing | Overridden. Gets or sets a flag that specifies whether an annotation may be resized with a mouse by the end user.
AllowSelecting | Overridden. Gets or sets a flag that specifies whether an annotation may be selected with a mouse by the end user.
AllowTextEditing | Overridden. Gets or sets a flag that specifies whether an annotation's text may be edited when the end user double clicks the text.
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
Annotations | Gets the collection of annotations in the group.
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the background of an annotation.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Overridden. Gets or sets the name of the chart area to which the annotation is clipped.
Font | Overridden. Gets or sets the font to use for the text of an annotation.
ForeColor | Overridden. Gets or sets the text color for an annotation.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsSelected | Overridden. Gets or sets a flag that determines if an annotation is selected.
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Overridden. Gets or sets the line color of the annotation.
LineDashStyle | Overridden. Gets or sets the line style of the annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of the annotation.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Overridden. Gets or sets the color of the annotation's shadow.
ShadowOffset | Overridden. Gets or sets the size of the annotation's shadow.
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Overridden. Gets or sets a flag that indicates whether the annotation is visible.
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

AnnotationGroup Class


AnnotationGroup.Alignment Property

AnnotationGroup.Alignment Property |
 | See Also

Gets or sets the content alignment of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Alignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment Alignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the content alignment of an annotation.

Remarks

This property is used to align text for TextAnnotation, RectangleAnnotation, EllipseAnnotation and CalloutAnnotation objects, and to align a nonscaled image inside an ImageAnnotation object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AllowAnchorMoving Property

AnnotationGroup.AllowAnchorMoving Property |
 | See Also

Gets or sets a flag that specifies whether an annotation anchor may be moved with a mouse by the end user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AllowAnchorMoving As Boolean
public override bool AllowAnchorMoving { get; set; }
public:
virtual property bool AllowAnchorMoving {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AllowAnchorMoving ()

/** @property */
public void set_AllowAnchorMoving (boolean value)

public override function get AllowAnchorMoving () : boolean

public override function set AllowAnchorMoving (value : boolean)

Property Value

True if the annotation anchor may be moved, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AllowMoving Property

AnnotationGroup.AllowMoving Property |
 | See Also

Gets or sets a flag that specifies whether an annotation may be moved with a mouse by the end user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AllowMoving As Boolean
public override bool AllowMoving { get; set; }
public:
virtual property bool AllowMoving {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AllowMoving ()

/** @property */
public void set_AllowMoving (boolean value)

public override function get AllowMoving () : boolean

public override function set AllowMoving (value : boolean)

Property Value

True if the annotation may be moved, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AllowPathEditing Property

AnnotationGroup.AllowPathEditing Property |
 | See Also

Gets or sets a flag that specifies whether the points of a polygon annotation may be moved with a mouse by the end user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AllowPathEditing As Boolean
public override bool AllowPathEditing { get; set; }
public:
virtual property bool AllowPathEditing {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AllowPathEditing ()

/** @property */
public void set_AllowPathEditing (boolean value)

public override function get AllowPathEditing () : boolean

public override function set AllowPathEditing (value : boolean)

Property Value

True if the points of the polygon annotation may be moved, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AllowResizing Property

AnnotationGroup.AllowResizing Property |
 | See Also

Gets or sets a flag that specifies whether an annotation may be resized with a mouse by the end user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AllowResizing As Boolean
public override bool AllowResizing { get; set; }
public:
virtual property bool AllowResizing {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AllowResizing ()

/** @property */
public void set_AllowResizing (boolean value)

public override function get AllowResizing () : boolean

public override function set AllowResizing (value : boolean)

Property Value

True if the annotation may be resized, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AllowSelecting Property

AnnotationGroup.AllowSelecting Property |
 | See Also

Gets or sets a flag that specifies whether an annotation may be selected with a mouse by the end user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AllowSelecting As Boolean
public override bool AllowSelecting { get; set; }
public:
virtual property bool AllowSelecting {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AllowSelecting ()

/** @property */
public void set_AllowSelecting (boolean value)

public override function get AllowSelecting () : boolean

public override function set AllowSelecting (value : boolean)

Property Value

True if the annotation may be selected, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AllowTextEditing Property

AnnotationGroup.AllowTextEditing Property |
 | See Also

Gets or sets a flag that specifies whether an annotation's text may be edited when the end user double clicks the text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AllowTextEditing As Boolean
public override bool AllowTextEditing { get; set; }
public:
virtual property bool AllowTextEditing {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AllowTextEditing ()

/** @property */
public void set_AllowTextEditing (boolean value)

public override function get AllowTextEditing () : boolean

public override function set AllowTextEditing (value : boolean)

Property Value

True if the annotation text may be edited, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.Annotations Property

AnnotationGroup.Annotations Property |
 | See Also

Gets the collection of annotations in the group.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Annotations As AnnotationCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public AnnotationCollection Annotations { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property AnnotationCollection^ Annotations {
    AnnotationCollection^ get ();
}
/** @property */
public AnnotationCollection get_Annotations ()

public function get Annotations () : AnnotationCollection

Property Value

An AnnotationCollection object.

Remarks

Note that the coordinates of all annotations in the group are relative to the group annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.AnnotationType Property

AnnotationGroup.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This property is used to get the name of each annotation type, for example. Line, Rectangle, Ellipse, and so forth. This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.BackColor Property

AnnotationGroup.BackColor Property |
 | See Also

Gets or sets the background color of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value used for the background of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.BackGradientStyle Property

AnnotationGroup.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw the background of an annotation.

Remarks

Two colors are used to draw the gradient, BackColor and BackSecondaryColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.BackHatchStyle Property

AnnotationGroup.BackHatchStyle Property |
 | See Also

Gets or sets the hatch style of an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the background of an annotation.

Remarks

Two colors are used to draw the hatching, BackColor and BackSecondaryColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.BackSecondaryColor Property

AnnotationGroup.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for the background of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw the background with hatching or gradient fill.

Remarks

A secondary color is used with BackColor when BackHatchStyle or BackGradientStyle are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.ClipToChartArea Property

AnnotationGroup.ClipToChartArea Property |
 | See Also

Gets or sets the name of the chart area to which the annotation is clipped.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ClipToChartArea As String
[BrowsableAttribute(false)]
public override string ClipToChartArea { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ ClipToChartArea {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_ClipToChartArea ()

/** @property */
public void set_ClipToChartArea (String value)

public override function get ClipToChartArea () : String

public override function set ClipToChartArea (value : String)

Property Value

A string that represents the name of an existing chart area.

Remarks

If a chart area name is specified, the annotation will only be drawn inside the plotting area of that chart area. All parts of the annotation outside of the plotting area will be clipped.

To disable chart area clipping, set this property to NaN or an empty string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.Font Property

AnnotationGroup.Font Property |
 | See Also

Gets or sets the font to use for the text of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object used for the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.ForeColor Property

AnnotationGroup.ForeColor Property |
 | See Also

Gets or sets the text color for an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value used for the text color of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.IsSelected Property

AnnotationGroup.IsSelected Property |
 | See Also

Gets or sets a flag that determines if an annotation is selected.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property IsSelected As Boolean
[BrowsableAttribute(false)]
public override bool IsSelected { get; set; }
[BrowsableAttribute(false)]
public:
virtual property bool IsSelected {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_IsSelected ()

/** @property */
public void set_IsSelected (boolean value)

public override function get IsSelected () : boolean

public override function set IsSelected (value : boolean)

Property Value

True if the annotation is selected, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.IsSizeAlwaysRelative Property

AnnotationGroup.IsSizeAlwaysRelative Property |
 | See Also

Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property IsSizeAlwaysRelative As Boolean
public override bool IsSizeAlwaysRelative { get; set; }
public:
virtual property bool IsSizeAlwaysRelative {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_IsSizeAlwaysRelative ()

/** @property */
public void set_IsSizeAlwaysRelative (boolean value)

public override function get IsSizeAlwaysRelative () : boolean

public override function set IsSizeAlwaysRelative (value : boolean)

Property Value

True if the Width and Height of an annotation are always in chart relative coordinates, otherwise false.

Remarks

The height and width of an annotation may be set in relative chart or in axes coordinates. By default, relative chart coordinates are used.

To use axes coordinates, set the IsSizeAlwaysRelative property to false. Then either anchor the annotation to a data point or set the AxisX or AxisY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.LineColor Property

AnnotationGroup.LineColor Property |
 | See Also

Gets or sets the line color of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(false)]
public override Color LineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value used to draw an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.LineDashStyle Property

AnnotationGroup.LineDashStyle Property |
 | See Also

Gets or sets the line style of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value used to draw an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.LineWidth Property

AnnotationGroup.LineWidth Property |
 | See Also

Gets or sets the line width, in pixels, of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(false)]
public override int LineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value defining the width, in pixels, of an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.ShadowColor Property

AnnotationGroup.ShadowColor Property |
 | See Also

Gets or sets the color of the annotation's shadow.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ShadowColor As Color
[BrowsableAttribute(false)]
public override Color ShadowColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ShadowColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public override function get ShadowColor () : Color

public override function set ShadowColor (value : Color)

Property Value

A Color value used to draw the shadow of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.ShadowOffset Property

AnnotationGroup.ShadowOffset Property |
 | See Also

Gets or sets the size of the annotation's shadow.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ShadowOffset As Integer
[BrowsableAttribute(false)]
public override int ShadowOffset { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int ShadowOffset {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public override function get ShadowOffset () : int

public override function set ShadowOffset (value : int)

Property Value

An integer value that represents the offset between an annotation and its shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.TextStyle Property

AnnotationGroup.TextStyle Property |
 | See Also

Gets or sets the text style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value used to draw the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationGroup.Visible Property

AnnotationGroup.Visible Property |
 | See Also

Gets or sets a flag that indicates whether the annotation is visible.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Visible As Boolean
public override bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public override function get Visible () : boolean

public override function set Visible (value : boolean)

Property Value

True if the annotation is visible, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationGroup Class
AnnotationGroup Members


AnnotationPathPoint Class

AnnotationPathPoint Class |
 | See Also Members

Represents a path point of a PolylineAnnotation or PolygonAnnotation, which is stored in their PathPoints property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnnotationPathPoint
    Inherits ChartElement
public class AnnotationPathPoint : ChartElement
public ref class AnnotationPathPoint : public ChartElement
public class AnnotationPathPoint extends ChartElement
public class AnnotationPathPoint extends ChartElement

Remarks

At run time, use the GraphicsPath or GraphicsPath class to set the path of a polyline or polygon.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.AnnotationPathPoint

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Members


AnnotationPathPoint Members

AnnotationPathPoint Members |
 | See Also Constructors Methods Properties

Represents a path point of a PolylineAnnotation or PolygonAnnotation, which is stored in their PathPoints property.

The following tables list the members exposed by the AnnotationPathPoint type.

Public Constructors

Name | Description
AnnotationPathPoint | Overloaded. Initializes a new instance of the AnnotationPathPoint class.
Top

Public Properties

Name | Description
Name | Gets the name for the path point of an annotation.
PointType | Gets or sets the type for the path point of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
X | Gets or sets the X coordinate for the path point of an annotation.
Y | Gets or sets the Y coordinate for the path point of an annotation.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationPathPoint Class


AnnotationPathPoint Constructor

AnnotationPathPoint Constructor |
 | See Also

Initializes a new instance of the AnnotationPathPoint class.

Overload List

Name | Description
AnnotationPathPoint () | Initializes a new instance of the AnnotationPathPoint class.
AnnotationPathPoint (Single, Single) | Initializes a new instance of the AnnotationPathPoint class with the specified x and y values.
AnnotationPathPoint (Single, Single, Byte) | Initializes a new instance of the AnnotationPathPoint class with the specified x, y and point type values.

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint Constructor ()

AnnotationPathPoint Constructor () |
 | See Also

Initializes a new instance of the AnnotationPathPoint class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AnnotationPathPoint ()
public:
AnnotationPathPoint ()
public AnnotationPathPoint ()
public function AnnotationPathPoint ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint Constructor (Single, Single)

AnnotationPathPoint Constructor (Single, Single) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified x and y values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    x As Single, _
    y As Single _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public AnnotationPathPoint (
    float x,
    float y
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
AnnotationPathPoint (
    float x,
    float y
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public AnnotationPathPoint (
    float x,
    float y
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function AnnotationPathPoint (
    x : float,
    y : float
)

Parameters

x

Point X-value.

y

Point Y-value.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint Constructor (Single, Single, Byte)

AnnotationPathPoint Constructor (Single, Single, Byte) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified x, y and point type values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    x As Single, _
    y As Single, _
    type As Byte _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public AnnotationPathPoint (
    float x,
    float y,
    byte type
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
AnnotationPathPoint (
    float x,
    float y,
    unsigned char type
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public AnnotationPathPoint (
    float x,
    float y,
    byte type
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function AnnotationPathPoint (
    x : float,
    y : float,
    type : byte
)

Parameters

x

Point X-value.

y

Point Y-value.

type

Point type.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint Methods

AnnotationPathPoint Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationPathPoint Class


AnnotationPathPoint Properties

AnnotationPathPoint Properties |
 | See Also

Public Properties

Name | Description
Name | Gets the name for the path point of an annotation.
PointType | Gets or sets the type for the path point of an annotation.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
X | Gets or sets the X coordinate for the path point of an annotation.
Y | Gets or sets the Y coordinate for the path point of an annotation.

See Also

Reference

AnnotationPathPoint Class


AnnotationPathPoint.Name Property

AnnotationPathPoint.Name Property |
 | See Also

Gets the name for the path point of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string Name { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Property Value

A string value that represents the name of the path point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint.PointType Property

AnnotationPathPoint.PointType Property |
 | See Also

Gets or sets the type for the path point of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property PointType As Byte
[BrowsableAttribute(false)]
public byte PointType { get; set; }
[BrowsableAttribute(false)]
public:
property unsigned char PointType {
    unsigned char get ();
    void set (unsigned char value);
}
/** @property */
public byte get_PointType ()

/** @property */
public void set_PointType (byte value)

public function get PointType () : byte

public function set PointType (value : byte)

Property Value

A byte value.

Remarks

See the PathPointType enumeration for more details.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint.X Property

AnnotationPathPoint.X Property |
 | See Also

Gets or sets the X coordinate for the path point of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="X")> _
<BrowsableAttribute(True)> _
Public Property X As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="X")]
[BrowsableAttribute(true)]
public float X { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"X")]
[BrowsableAttribute(true)]
public:
property float X {
    float get ();
    void set (float value);
}
/** @property */
public float get_X ()

/** @property */
public void set_X (float value)

public function get X () : float

public function set X (value : float)

Property Value

A float that represents the X value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPoint.Y Property

AnnotationPathPoint.Y Property |
 | See Also

Gets or sets the Y coordinate for the path point of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Y")> _
<BrowsableAttribute(True)> _
Public Property Y As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Y")]
[BrowsableAttribute(true)]
public float Y { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Y")]
[BrowsableAttribute(true)]
public:
property float Y {
    float get ();
    void set (float value);
}
/** @property */
public float get_Y ()

/** @property */
public void set_Y (float value)

public function get Y () : float

public function set Y (value : float)

Property Value

A float that represents the Y value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPoint Class
AnnotationPathPoint Members


AnnotationPathPointCollection Class

AnnotationPathPointCollection Class |
 | See Also Members

Represents a collection of PolylineAnnotation or PolygonAnnotation path points, which can be accessed using the GraphicPathPoints property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnnotationPathPointCollection
    Inherits ChartElementCollection(Of AnnotationPathPoint)
public class AnnotationPathPointCollection : ChartElementCollection<AnnotationPathPoint>
public ref class AnnotationPathPointCollection : public ChartElementCollection<AnnotationPathPoint^>
public class AnnotationPathPointCollection extends ChartElementCollection<AnnotationPathPoint>
public class AnnotationPathPointCollection extends ChartElementCollection<AnnotationPathPoint>

Remarks

This collection is used at design time only, and employs serialization to expose the shape of a polyline or polygon annotation, using their respective GraphicPathPoints collection properties.

At run time, use the GraphicsPath property to set the path of a PolylineAnnotation or PolygonAnnotation.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.AnnotationPathPointCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Members


AnnotationPathPointCollection Members

AnnotationPathPointCollection Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

Represents a collection of PolylineAnnotation or PolygonAnnotation path points, which can be accessed using the GraphicPathPoints property.

The following tables list the members exposed by the AnnotationPathPointCollection type.

Public Constructors

Name | Description
AnnotationPathPointCollection | Initializes a new instance of the AnnotationPathPointCollection class with the specified polyline annotation.
Top

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Overridden. Forces the invalidation of the chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

AnnotationPathPointCollection Class


AnnotationPathPointCollection Constructor

AnnotationPathPointCollection Constructor |
 | See Also

Initializes a new instance of the AnnotationPathPointCollection class with the specified polyline annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    annotation As PolylineAnnotation _
)
public AnnotationPathPointCollection (
    PolylineAnnotation annotation
)
public:
AnnotationPathPointCollection (
    PolylineAnnotation^ annotation
)
public AnnotationPathPointCollection (
    PolylineAnnotation annotation
)
public function AnnotationPathPointCollection (
    annotation : PolylineAnnotation
)

Parameters

annotation

A polyline annotation.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members


AnnotationPathPointCollection Methods

AnnotationPathPointCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Overridden. Forces the invalidation of the chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

AnnotationPathPointCollection Class


AnnotationPathPointCollection.Dispose Method

AnnotationPathPointCollection.Dispose Method |
 | See Also

Overload List

Name | Description
AnnotationPathPointCollection.Dispose () | (inherited from Dispose )
AnnotationPathPointCollection.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members


AnnotationPathPointCollection.Dispose Method (Boolean)

AnnotationPathPointCollection.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members


AnnotationPathPointCollection.Invalidate Method

AnnotationPathPointCollection.Invalidate Method |
 | See Also

Forces the invalidation of the chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Sub Invalidate
public override void Invalidate ()
public:
virtual void Invalidate () override
public void Invalidate ()
public override function Invalidate ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPathPointCollection Class
AnnotationPathPointCollection Members


AnnotationPathPointCollection Properties

AnnotationPathPointCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

AnnotationPathPointCollection Class


AnnotationPositionChangingEventArgs Class

AnnotationPositionChangingEventArgs Class |
 | See Also Members

Provides data for the events in the Chart control that change the position of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnnotationPositionChangingEventArgs
    Inherits EventArgs
public class AnnotationPositionChangingEventArgs : EventArgs
public ref class AnnotationPositionChangingEventArgs : public EventArgs
public class AnnotationPositionChangingEventArgs extends EventArgs
public class AnnotationPositionChangingEventArgs extends EventArgs

Remarks

The AnnotationPositionChangingEventArgs class is used for the two annotation-positioning events, AnnotationPositionChanging and AnnotationPositionChanged, in the Chart control.

The Annotation property gets the annotation object that is being positioned. This class also contains properties that retrieve the new location, width, height and anchor location of the annotation that is repositioned.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.AnnotationPositionChangingEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs Members

AnnotationPositionChangingEventArgs Members |
 | See Also Constructors Methods Properties

Provides data for the events in the Chart control that change the position of the annotation.

The following tables list the members exposed by the AnnotationPositionChangingEventArgs type.

Public Constructors

Name | Description
AnnotationPositionChangingEventArgs | Initializes a new instance of the AnnotationPositionChangingEventArgs class.
Top

Public Properties

Name | Description
Annotation | Gets or sets the Annotation object.
NewAnchorLocation | Gets or sets the new anchor location of the annotation.
NewAnchorLocationX | Gets or sets the new annotation anchor point X location.
NewAnchorLocationY | Gets or sets the new annotation anchor point Y location.
NewLocationX | Gets or sets the new X coordinate location of the annotation.
NewLocationY | Gets or sets the new Y coordinate of the annotation location.
NewPosition | Gets or sets the new location and size of the annotation.
NewSizeHeight | Gets or sets the new height of the annotation.
NewSizeWidth | Gets or sets the new width of the annotation.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationPositionChangingEventArgs Class


AnnotationPositionChangingEventArgs Constructor

AnnotationPositionChangingEventArgs Constructor |
 | See Also

Initializes a new instance of the AnnotationPositionChangingEventArgs class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AnnotationPositionChangingEventArgs ()
public:
AnnotationPositionChangingEventArgs ()
public AnnotationPositionChangingEventArgs ()
public function AnnotationPositionChangingEventArgs ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs Methods

AnnotationPositionChangingEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationPositionChangingEventArgs Class


AnnotationPositionChangingEventArgs Properties

AnnotationPositionChangingEventArgs Properties |
 | See Also

Public Properties

Name | Description
Annotation | Gets or sets the Annotation object.
NewAnchorLocation | Gets or sets the new anchor location of the annotation.
NewAnchorLocationX | Gets or sets the new annotation anchor point X location.
NewAnchorLocationY | Gets or sets the new annotation anchor point Y location.
NewLocationX | Gets or sets the new X coordinate location of the annotation.
NewLocationY | Gets or sets the new Y coordinate of the annotation location.
NewPosition | Gets or sets the new location and size of the annotation.
NewSizeHeight | Gets or sets the new height of the annotation.
NewSizeWidth | Gets or sets the new width of the annotation.

See Also

Reference

AnnotationPositionChangingEventArgs Class


AnnotationPositionChangingEventArgs.Annotation Property

AnnotationPositionChangingEventArgs.Annotation Property |
 | See Also

Gets or sets the Annotation object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Annotation As Annotation
public Annotation Annotation { get; set; }
public:
property Annotation^ Annotation {
    Annotation^ get ();
    void set (Annotation^ value);
}
/** @property */
public Annotation get_Annotation ()

/** @property */
public void set_Annotation (Annotation value)

public function get Annotation () : Annotation

public function set Annotation (value : Annotation)

Property Value

The Annotation object.

Remarks

The Annotation property allows the developer to set Annotation properties during the AnnotationPositionChanging and AnnotationPositionChanged events of the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewAnchorLocation Property

AnnotationPositionChangingEventArgs.NewAnchorLocation Property |
 | See Also

Gets or sets the new anchor location of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property NewAnchorLocation As PointF
[BrowsableAttribute(false)]
public PointF NewAnchorLocation { get; set; }
[BrowsableAttribute(false)]
public:
property PointF NewAnchorLocation {
    PointF get ();
    void set (PointF value);
}
/** @property */
public PointF get_NewAnchorLocation ()

/** @property */
public void set_NewAnchorLocation (PointF value)

public function get NewAnchorLocation () : PointF

public function set NewAnchorLocation (value : PointF)

Property Value

A PointF object that represents the new anchor position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewAnchorLocationX Property

AnnotationPositionChangingEventArgs.NewAnchorLocationX Property |
 | See Also

Gets or sets the new annotation anchor point X location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewAnchorLocationX As Double
public double NewAnchorLocationX { get; set; }
public:
property double NewAnchorLocationX {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewAnchorLocationX ()

/** @property */
public void set_NewAnchorLocationX (double value)

public function get NewAnchorLocationX () : double

public function set NewAnchorLocationX (value : double)

Property Value

A double value that represents the new annotation anchor point X location.

Remarks

When the AnnotationPositionChanging and AnnotationPositionChanging events are raised, the NewAnchorLocationX property determines the new X coordinate of the annotation. This information is useful when the annotation is newly anchored to a data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewAnchorLocationY Property

AnnotationPositionChangingEventArgs.NewAnchorLocationY Property |
 | See Also

Gets or sets the new annotation anchor point Y location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewAnchorLocationY As Double
public double NewAnchorLocationY { get; set; }
public:
property double NewAnchorLocationY {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewAnchorLocationY ()

/** @property */
public void set_NewAnchorLocationY (double value)

public function get NewAnchorLocationY () : double

public function set NewAnchorLocationY (value : double)

Property Value

A double value representing the new annotation anchor point Y location.

Remarks

When the AnnotationPositionChanging and AnnotationPositionChanged events are raised, the NewAnchorLocationY property determines the new Y coordinate of the annotation. This information is useful when the annotation is newly anchored to a data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewLocationX Property

AnnotationPositionChangingEventArgs.NewLocationX Property |
 | See Also

Gets or sets the new X coordinate location of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewLocationX As Double
public double NewLocationX { get; set; }
public:
property double NewLocationX {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewLocationX ()

/** @property */
public void set_NewLocationX (double value)

public function get NewLocationX () : double

public function set NewLocationX (value : double)

Property Value

A double value that represents the new X coordinate location of the annotation.

Remarks

When the AnnotationPositionChanging and AnnotationPositionChanged events are raised, the NewLocationX property defines the X-coordinate location of the annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewLocationY Property

AnnotationPositionChangingEventArgs.NewLocationY Property |
 | See Also

Gets or sets the new Y coordinate of the annotation location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewLocationY As Double
public double NewLocationY { get; set; }
public:
property double NewLocationY {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewLocationY ()

/** @property */
public void set_NewLocationY (double value)

public function get NewLocationY () : double

public function set NewLocationY (value : double)

Property Value

A double value that represents the new Y coordinate of the annotation location.

Remarks

When the AnnotationPositionChanging and AnnotationPositionChanged events are raised, the NewLocationY property defines the Y-coordinate location of the annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewPosition Property

AnnotationPositionChangingEventArgs.NewPosition Property |
 | See Also

Gets or sets the new location and size of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property NewPosition As RectangleF
[BrowsableAttribute(false)]
public RectangleF NewPosition { get; set; }
[BrowsableAttribute(false)]
public:
property RectangleF NewPosition {
    RectangleF get ();
    void set (RectangleF value);
}
/** @property */
public RectangleF get_NewPosition ()

/** @property */
public void set_NewPosition (RectangleF value)

public function get NewPosition () : RectangleF

public function set NewPosition (value : RectangleF)

Property Value

A RectangleF object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewSizeHeight Property

AnnotationPositionChangingEventArgs.NewSizeHeight Property |
 | See Also

Gets or sets the new height of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewSizeHeight As Double
public double NewSizeHeight { get; set; }
public:
property double NewSizeHeight {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewSizeHeight ()

/** @property */
public void set_NewSizeHeight (double value)

public function get NewSizeHeight () : double

public function set NewSizeHeight (value : double)

Property Value

A double value that represents the new height of the annotation.

Remarks

When the AnnotationPositionChanging and AnnotationPositionChanged events are raised, use the NewSizeHeight property to determine the new height of the annotation. This information can be used when you resize the annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationPositionChangingEventArgs.NewSizeWidth Property

AnnotationPositionChangingEventArgs.NewSizeWidth Property |
 | See Also

Gets or sets the new width of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewSizeWidth As Double
public double NewSizeWidth { get; set; }
public:
property double NewSizeWidth {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewSizeWidth ()

/** @property */
public void set_NewSizeWidth (double value)

public function get NewSizeWidth () : double

public function set NewSizeWidth (value : double)

Property Value

A double value that represents the new width of the annotation.

Remarks

When the AnnotationPositionChanging and AnnotationPositionChanged events are raised, use the NewSizeWidth property to determine the new width of the annotation. This information can be used when you resize the annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationPositionChangingEventArgs Class
AnnotationPositionChangingEventArgs Members


AnnotationSmartLabelStyle Class

AnnotationSmartLabelStyle Class |
 | See Also Members

Stores the smart label properties of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnnotationSmartLabelStyle
    Inherits SmartLabelStyle
public class AnnotationSmartLabelStyle : SmartLabelStyle
public ref class AnnotationSmartLabelStyle : public SmartLabelStyle
public class AnnotationSmartLabelStyle extends SmartLabelStyle
public class AnnotationSmartLabelStyle extends SmartLabelStyle

Remarks

This class is derived from the SmartLabelStyle class used for Series objects.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.SmartLabelStyle
System.Windows.Forms.DataVisualization.Charting.AnnotationSmartLabelStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle Members

AnnotationSmartLabelStyle Members |
 | See Also Constructors Methods Properties

Stores the smart label properties of an annotation.

The following tables list the members exposed by the AnnotationSmartLabelStyle type.

Public Constructors

Name | Description
AnnotationSmartLabelStyle | Overloaded.
Top

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area. (inherited from SmartLabelStyle)
CalloutBackColor | Overridden. Gets or sets the back color of the label callout. This property is only applicable when the CalloutStyle property is set to a value of Box.
CalloutLineAnchorCapStyle | Overridden. Gets or sets the anchor cap style for the label callout line.
CalloutLineColor | Overridden. Gets or sets the color of the label callout line.
CalloutLineDashStyle | Overridden. Gets or sets the style of the label callout line.
CalloutLineWidth | Overridden. Gets or sets the width of the label callout line.
CalloutStyle | Overridden. Gets or sets the callout style of the repositioned smart labels.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled. (inherited from SmartLabelStyle)
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker. (inherited from SmartLabelStyle)
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden. (inherited from SmartLabelStyle)
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle)
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle)
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved. (inherited from SmartLabelStyle)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnnotationSmartLabelStyle Class


AnnotationSmartLabelStyle Constructor

AnnotationSmartLabelStyle Constructor |
 | See Also

Overload List

Name | Description
AnnotationSmartLabelStyle () | Initializes a new instance of the AnnotationSmartLabelStyle class.
AnnotationSmartLabelStyle (Object) | Initializes a new instance of the AnnotationSmartLabelStyle class with the specified chart element.

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle Constructor ()

AnnotationSmartLabelStyle Constructor () |
 | See Also

Initializes a new instance of the AnnotationSmartLabelStyle class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AnnotationSmartLabelStyle ()
public:
AnnotationSmartLabelStyle ()
public AnnotationSmartLabelStyle ()
public function AnnotationSmartLabelStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle Constructor (Object)

AnnotationSmartLabelStyle Constructor (Object) |
 | See Also

Initializes a new instance of the AnnotationSmartLabelStyle class with the specified chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    chartElement As Object _
)
public AnnotationSmartLabelStyle (
    Object chartElement
)
public:
AnnotationSmartLabelStyle (
    Object^ chartElement
)
public AnnotationSmartLabelStyle (
    Object chartElement
)
public function AnnotationSmartLabelStyle (
    chartElement : Object
)

Parameters

chartElement

Chart element that this style belongs to.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle Methods

AnnotationSmartLabelStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnnotationSmartLabelStyle Class


AnnotationSmartLabelStyle Properties

AnnotationSmartLabelStyle Properties |
 | See Also

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area. (inherited from SmartLabelStyle )
CalloutBackColor | Overridden. Gets or sets the back color of the label callout. This property is only applicable when the CalloutStyle property is set to a value of Box.
CalloutLineAnchorCapStyle | Overridden. Gets or sets the anchor cap style for the label callout line.
CalloutLineColor | Overridden. Gets or sets the color of the label callout line.
CalloutLineDashStyle | Overridden. Gets or sets the style of the label callout line.
CalloutLineWidth | Overridden. Gets or sets the width of the label callout line.
CalloutStyle | Overridden. Gets or sets the callout style of the repositioned smart labels.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled. (inherited from SmartLabelStyle )
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker. (inherited from SmartLabelStyle )
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden. (inherited from SmartLabelStyle )
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle )
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker. (inherited from SmartLabelStyle )
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved. (inherited from SmartLabelStyle )

See Also

Reference

AnnotationSmartLabelStyle Class


AnnotationSmartLabelStyle.CalloutBackColor Property

AnnotationSmartLabelStyle.CalloutBackColor Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the back color of the label callout. This property is only applicable when the CalloutStyle property is set to a value of Box.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutBackColor As Color
[BrowsableAttribute(false)]
public override Color CalloutBackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color CalloutBackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_CalloutBackColor ()

/** @property */
public void set_CalloutBackColor (Color value)

public override function get CalloutBackColor () : Color

public override function set CalloutBackColor (value : Color)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle.CalloutLineAnchorCapStyle Property

AnnotationSmartLabelStyle.CalloutLineAnchorCapStyle Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the anchor cap style for the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineAnchorCapStyle As LineAnchorCapStyle
[BrowsableAttribute(false)]
public override LineAnchorCapStyle CalloutLineAnchorCapStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LineAnchorCapStyle CalloutLineAnchorCapStyle {
    LineAnchorCapStyle get () override;
    void set (LineAnchorCapStyle value) override;
}
/** @property */
public LineAnchorCapStyle get_CalloutLineAnchorCapStyle ()

/** @property */
public void set_CalloutLineAnchorCapStyle (LineAnchorCapStyle value)

public override function get CalloutLineAnchorCapStyle () : LineAnchorCapStyle

public override function set CalloutLineAnchorCapStyle (value : LineAnchorCapStyle)

Remarks

This method is for internal use and is hidden at design and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle.CalloutLineColor Property

AnnotationSmartLabelStyle.CalloutLineColor Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the color of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineColor As Color
[BrowsableAttribute(false)]
public override Color CalloutLineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color CalloutLineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_CalloutLineColor ()

/** @property */
public void set_CalloutLineColor (Color value)

public override function get CalloutLineColor () : Color

public override function set CalloutLineColor (value : Color)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle.CalloutLineDashStyle Property

AnnotationSmartLabelStyle.CalloutLineDashStyle Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the style of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle CalloutLineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle CalloutLineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_CalloutLineDashStyle ()

/** @property */
public void set_CalloutLineDashStyle (ChartDashStyle value)

public override function get CalloutLineDashStyle () : ChartDashStyle

public override function set CalloutLineDashStyle (value : ChartDashStyle)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle.CalloutLineWidth Property

AnnotationSmartLabelStyle.CalloutLineWidth Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the width of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutLineWidth As Integer
[BrowsableAttribute(false)]
public override int CalloutLineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int CalloutLineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CalloutLineWidth ()

/** @property */
public void set_CalloutLineWidth (int value)

public override function get CalloutLineWidth () : int

public override function set CalloutLineWidth (value : int)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnnotationSmartLabelStyle.CalloutStyle Property

AnnotationSmartLabelStyle.CalloutStyle Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the callout style of the repositioned smart labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property CalloutStyle As LabelCalloutStyle
[BrowsableAttribute(false)]
public override LabelCalloutStyle CalloutStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LabelCalloutStyle CalloutStyle {
    LabelCalloutStyle get () override;
    void set (LabelCalloutStyle value) override;
}
/** @property */
public LabelCalloutStyle get_CalloutStyle ()

/** @property */
public void set_CalloutStyle (LabelCalloutStyle value)

public override function get CalloutStyle () : LabelCalloutStyle

public override function set CalloutStyle (value : LabelCalloutStyle)

Remarks

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnnotationSmartLabelStyle Class
AnnotationSmartLabelStyle Members


AnovaResult Class

AnovaResult Class |
 | See Also Members

Represents the results of an ANOVA statistical test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AnovaResult
public class AnovaResult
public ref class AnovaResult
public class AnovaResult
public class AnovaResult

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.AnovaResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Members


AnovaResult Members

AnovaResult Members |
 | See Also Constructors Methods Properties

Represents the results of an ANOVA statistical test.

The following tables list the members exposed by the AnovaResult type.

Public Constructors

Name | Description
AnovaResult | Initializes a new instance of the AnovaResult class.
Top

Public Properties

Name | Description
DegreeOfFreedomBetweenGroups | Gets the degree of freedom between groups.
DegreeOfFreedomTotal | Gets the total degree of freedom.
DegreeOfFreedomWithinGroups | Gets the degree of freedom within groups.
FCriticalValue | Gets the F critical value.
FRatio | Gets the F ratio.
MeanSquareVarianceBetweenGroups | Gets the mean square variance between groups.
MeanSquareVarianceWithinGroups | Gets the mean square variance within groups.
SumOfSquaresBetweenGroups | Gets the sum of the squares between groups.
SumOfSquaresTotal | Gets the total sum of the squares.
SumOfSquaresWithinGroups | Gets the sum of the squares within groups.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AnovaResult Class


AnovaResult Constructor

AnovaResult Constructor |
 | See Also

Initializes a new instance of the AnovaResult class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AnovaResult ()
public:
AnovaResult ()
public AnovaResult ()
public function AnovaResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult Methods

AnovaResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AnovaResult Class


AnovaResult Properties

AnovaResult Properties |
 | See Also

Public Properties

Name | Description
DegreeOfFreedomBetweenGroups | Gets the degree of freedom between groups.
DegreeOfFreedomTotal | Gets the total degree of freedom.
DegreeOfFreedomWithinGroups | Gets the degree of freedom within groups.
FCriticalValue | Gets the F critical value.
FRatio | Gets the F ratio.
MeanSquareVarianceBetweenGroups | Gets the mean square variance between groups.
MeanSquareVarianceWithinGroups | Gets the mean square variance within groups.
SumOfSquaresBetweenGroups | Gets the sum of the squares between groups.
SumOfSquaresTotal | Gets the total sum of the squares.
SumOfSquaresWithinGroups | Gets the sum of the squares within groups.

See Also

Reference

AnovaResult Class


AnovaResult.DegreeOfFreedomBetweenGroups Property

AnovaResult.DegreeOfFreedomBetweenGroups Property |
 | See Also

Gets the degree of freedom between groups.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedomBetweenGroups As Double
public double DegreeOfFreedomBetweenGroups { get; }
public:
property double DegreeOfFreedomBetweenGroups {
    double get ();
}
/** @property */
public double get_DegreeOfFreedomBetweenGroups ()

public function get DegreeOfFreedomBetweenGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.DegreeOfFreedomTotal Property

AnovaResult.DegreeOfFreedomTotal Property |
 | See Also

Gets the total degree of freedom.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedomTotal As Double
public double DegreeOfFreedomTotal { get; }
public:
property double DegreeOfFreedomTotal {
    double get ();
}
/** @property */
public double get_DegreeOfFreedomTotal ()

public function get DegreeOfFreedomTotal () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.DegreeOfFreedomWithinGroups Property

AnovaResult.DegreeOfFreedomWithinGroups Property |
 | See Also

Gets the degree of freedom within groups.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedomWithinGroups As Double
public double DegreeOfFreedomWithinGroups { get; }
public:
property double DegreeOfFreedomWithinGroups {
    double get ();
}
/** @property */
public double get_DegreeOfFreedomWithinGroups ()

public function get DegreeOfFreedomWithinGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.FCriticalValue Property

AnovaResult.FCriticalValue Property |
 | See Also

Gets the F critical value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FCriticalValue As Double
public double FCriticalValue { get; }
public:
property double FCriticalValue {
    double get ();
}
/** @property */
public double get_FCriticalValue ()

public function get FCriticalValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.FRatio Property

AnovaResult.FRatio Property |
 | See Also

Gets the F ratio.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FRatio As Double
public double FRatio { get; }
public:
property double FRatio {
    double get ();
}
/** @property */
public double get_FRatio ()

public function get FRatio () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.MeanSquareVarianceBetweenGroups Property

AnovaResult.MeanSquareVarianceBetweenGroups Property |
 | See Also

Gets the mean square variance between groups.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property MeanSquareVarianceBetweenGroups As Double
public double MeanSquareVarianceBetweenGroups { get; }
public:
property double MeanSquareVarianceBetweenGroups {
    double get ();
}
/** @property */
public double get_MeanSquareVarianceBetweenGroups ()

public function get MeanSquareVarianceBetweenGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.MeanSquareVarianceWithinGroups Property

AnovaResult.MeanSquareVarianceWithinGroups Property |
 | See Also

Gets the mean square variance within groups.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property MeanSquareVarianceWithinGroups As Double
public double MeanSquareVarianceWithinGroups { get; }
public:
property double MeanSquareVarianceWithinGroups {
    double get ();
}
/** @property */
public double get_MeanSquareVarianceWithinGroups ()

public function get MeanSquareVarianceWithinGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.SumOfSquaresBetweenGroups Property

AnovaResult.SumOfSquaresBetweenGroups Property |
 | See Also

Gets the sum of the squares between groups.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SumOfSquaresBetweenGroups As Double
public double SumOfSquaresBetweenGroups { get; }
public:
property double SumOfSquaresBetweenGroups {
    double get ();
}
/** @property */
public double get_SumOfSquaresBetweenGroups ()

public function get SumOfSquaresBetweenGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.SumOfSquaresTotal Property

AnovaResult.SumOfSquaresTotal Property |
 | See Also

Gets the total sum of the squares.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SumOfSquaresTotal As Double
public double SumOfSquaresTotal { get; }
public:
property double SumOfSquaresTotal {
    double get ();
}
/** @property */
public double get_SumOfSquaresTotal ()

public function get SumOfSquaresTotal () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AnovaResult.SumOfSquaresWithinGroups Property

AnovaResult.SumOfSquaresWithinGroups Property |
 | See Also

Gets the sum of the squares within groups.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SumOfSquaresWithinGroups As Double
public double SumOfSquaresWithinGroups { get; }
public:
property double SumOfSquaresWithinGroups {
    double get ();
}
/** @property */
public double get_SumOfSquaresWithinGroups ()

public function get SumOfSquaresWithinGroups () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AnovaResult Class
AnovaResult Members


AntiAliasingStyles Enumeration

AntiAliasingStyles Enumeration |
 | See Also

Specifies the anti-aliasing options for the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AntiAliasingStyles
public enum AntiAliasingStyles
public enum class AntiAliasingStyles
public enum AntiAliasingStyles
public enum AntiAliasingStyles

Members

Member name | Description
All | Use anti-aliasing for text and graphics.
Graphics | Use anti-aliasing when drawing graphics primitives such as circles or rectangles.
None | Do not use anti-aliasing.
Text | Use anti-aliasing when drawing text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


AreaAlignmentOrientations Enumeration

AreaAlignmentOrientations Enumeration |
 | See Also

Specifies the alignment orientation of a chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AreaAlignmentOrientations
public enum AreaAlignmentOrientations
public enum class AreaAlignmentOrientations
public enum AreaAlignmentOrientations
public enum AreaAlignmentOrientations

Members

Member name | Description
All | Chart areas are aligned horizontally and vertically.
Horizontal | Chart areas are aligned horizontally.
None | Chart areas are not automatically aligned.
Vertical | Chart areas are aligned vertically.

Remarks

The AreaAlignmentOrientations enumeration represents the physical orientation, such as vertical or horizontal, of a chart area.

In contrast, the AreaAlignmentStyles enumeration represents the chart elements, such as the cursor or inner plot position, which can be used to align a chart area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


AreaAlignmentStyles Enumeration

AreaAlignmentStyles Enumeration |
 | See Also

Specifies the alignment styles of chart areas.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AreaAlignmentStyles
public enum AreaAlignmentStyles
public enum class AreaAlignmentStyles
public enum AreaAlignmentStyles
public enum AreaAlignmentStyles

Members

Member name | Description
All | Chart areas are aligned using all values.
AxesView | Chart areas are aligned by their data view.
Cursor | Chart areas are aligned using their cursors.
None | Chart areas are not automatically aligned.
PlotPosition | Chart areas are aligned by their inner plot position.
Position | Chart areas are aligned by the chart area position.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ArrowAnnotation Class

ArrowAnnotation Class |
 | See Also Members

Represents an arrow annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ArrowAnnotation
    Inherits Annotation
public class ArrowAnnotation : Annotation
public ref class ArrowAnnotation : public Annotation
public class ArrowAnnotation extends Annotation
public class ArrowAnnotation extends Annotation

Remarks

Arrow annotations can be used to connect to points on the chart or to highlight a single chart area.

Different arrow styles and sizes can be applied to the annotation.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.ArrowAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Members


ArrowAnnotation Members

ArrowAnnotation Members |
 | See Also Constructors Methods Properties

Represents an arrow annotation.

The following tables list the members exposed by the ArrowAnnotation type.

Public Constructors

Name | Description
ArrowAnnotation | Initializes a new instance of the ArrowAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Overridden. Gets or sets the position alignment of the annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the name of the annotation type. For internal use, should not be used.
ArrowSize | Gets or sets an arrow size, in pixels.
ArrowStyle | Gets or sets the arrow style.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Gets or sets the color of an annotation background. (inherited from Annotation)
BackGradientStyle | Gets or sets the gradient style of an annotation background. (inherited from Annotation)
BackHatchStyle | Gets or sets the hatching style of an annotation background. (inherited from Annotation)
BackSecondaryColor | Gets or sets the secondary color of an annotation background. (inherited from Annotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | (inherited from Annotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ArrowAnnotation Class


ArrowAnnotation Constructor

ArrowAnnotation Constructor |
 | See Also

Initializes a new instance of the ArrowAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public ArrowAnnotation ()
public:
ArrowAnnotation ()
public ArrowAnnotation ()
public function ArrowAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members


ArrowAnnotation Methods

ArrowAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ArrowAnnotation Class


ArrowAnnotation Properties

ArrowAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Overridden. Gets or sets the position alignment of the annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the name of the annotation type. For internal use, should not be used.
ArrowSize | Gets or sets an arrow size, in pixels.
ArrowStyle | Gets or sets the arrow style.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Gets or sets the color of an annotation background. (inherited from Annotation )
BackGradientStyle | Gets or sets the gradient style of an annotation background. (inherited from Annotation )
BackHatchStyle | Gets or sets the hatching style of an annotation background. (inherited from Annotation )
BackSecondaryColor | Gets or sets the secondary color of an annotation background. (inherited from Annotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | (inherited from Annotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

ArrowAnnotation Class


ArrowAnnotation.AnchorAlignment Property

ArrowAnnotation.AnchorAlignment Property |
 | See Also

Gets or sets the position alignment of the annotation to the anchor point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property AnchorAlignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment AnchorAlignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public override function get AnchorAlignment () : ContentAlignment

public override function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the alignment of the annotation to the anchor point.

Remarks

The annotation must be anchored using either AnchorDataPoint, or the AnchorX and AnchorY properties.

Its X and Y properties must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members


ArrowAnnotation.AnnotationType Property

ArrowAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the name of the annotation type. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Property Value

A string value that represents the name of the annotation type.

Remarks

Gets the name of each annotation type such as Line, Rectangle, Ellipse, and so forth.

This property is for internal use and is hidden at design time and run time.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members


ArrowAnnotation.ArrowSize Property

ArrowAnnotation.ArrowSize Property |
 | See Also

Gets or sets an arrow size, in pixels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ArrowSize As Integer
public virtual int ArrowSize { get; set; }
public:
virtual property int ArrowSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_ArrowSize ()

/** @property */
public void set_ArrowSize (int value)

public function get ArrowSize () : int

public function set ArrowSize (value : int)

Property Value

An integer value that represents arrow size—that is, its thickness—in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members


ArrowAnnotation.ArrowStyle Property

ArrowAnnotation.ArrowStyle Property |
 | See Also

Gets or sets the arrow style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ArrowStyle As ArrowStyle
public virtual ArrowStyle ArrowStyle { get; set; }
public:
virtual property ArrowStyle ArrowStyle {
    ArrowStyle get ();
    void set (ArrowStyle value);
}
/** @property */
public ArrowStyle get_ArrowStyle ()

/** @property */
public void set_ArrowStyle (ArrowStyle value)

public function get ArrowStyle () : ArrowStyle

public function set ArrowStyle (value : ArrowStyle)

Property Value

The ArrowStyle of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ArrowAnnotation Class
ArrowAnnotation Members


ArrowStyle Enumeration

ArrowStyle Enumeration |
 | See Also

Specifies styles for an arrow annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ArrowStyle
public enum ArrowStyle
public enum class ArrowStyle
public enum ArrowStyle
public enum ArrowStyle

Members

Member name | Description
DoubleArrow | An arrow that points in two directions.
Simple | A simple one-pointed arrow.
Tailed | An arrow with a tail.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Axis Class

Axis Class |
 | See Also Members

Provides methods and properties that manage axes in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Axis
    Inherits ChartNamedElement
public class Axis : ChartNamedElement
public ref class Axis : public ChartNamedElement
public class Axis extends ChartNamedElement
public class Axis extends ChartNamedElement

Remarks

This class encapsulates all the functionality for axes in the Chart control, and is exposed by the AxisX, AxisY, AxisX2 and AxisY2 properties of ChartArea objects.

For all charts—except bar, stacked bar, pie and doughnut—the primary and secondary axes are as follows:

Axis Type | Description
Primary X-Axis | Bottom horizontal axis.
Secondary X-Axis | Top horizontal axis.
Primary Y-Axis | Left vertical axis.
Secondary Y-Axis | Right vertical axis.

Bar and stacked-bar charts have their axes rotated 90 degrees clockwise, so the primary X axis for these two chart types is the left-vertical axis.

Note There can be only one set of axes—two vertical and two horizontal—for each ChartArea object.

The Axis class also contains several methods that can be used to convert axis values to absolute pixel coordinates, which are useful for 2D custom drawing, or to relative coordinates, which are useful for 3D custom drawing. Absolute and relative coordinates can also be converted to axis values.

The following are the most important axis elements exposed by the Axis class:

Axis Element | Description
Axis Labels | The labels of an axis, and their associated properties.
Grid Lines | The major and minor grid lines of an axis.
Tick Marks | The major and minor tick marks of an axis.
Strip Lines | Strip lines.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Axis

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Members


Axis Members

Axis Members |
 | See Also Constructors Methods Properties

Provides methods and properties that manage axes in the Chart control.

The following tables list the members exposed by the Axis type.

Public Constructors

Name | Description
Axis | Overloaded.
Top

Public Properties

Name | Description
ArrowStyle | Gets or sets the arrow style of a 2D axis; this style is not applied to 3D chart areas.
AxisName | Gets the name of the axis, which can be either X, Y, X2 or Y2. For internal use only.
Crossing | Gets or sets the location at which an axis is crossed by its associated axis.
CustomLabels | Gets a CustomLabelsCollection object used to store CustomLabel objects.
Enabled | Gets or sets a value that indicates whether an axis is enabled.
InterlacedColor | Gets or sets the color of interlaced strip lines.
Interval | Gets or sets the interval of an axis.
IntervalAutoMode | Gets or sets a flag that determines if a fixed number of intervals is used on the axis, or if the number of intervals depends on the axis size.
IntervalOffset | Gets or sets the interval offset of an axis.
IntervalOffsetType | Gets or sets the interval offset type of an axis.
IntervalType | Gets or sets the interval type of an axis.
IsInterlaced | Gets or sets a flag that determines if interlaced strip lines are displayed for an axis.
IsLabelAutoFit | Gets or sets a flag that determines whether axis labels are automatically fitted.
IsLogarithmic | Gets or sets a flag which indicates whether the axis is logarithmic. Zeros or negative data values are not allowed on logarithmic charts.
IsMarginVisible | Gets or sets a flag that determines whether to add a margin to the axis.
IsMarksNextToAxis | Gets or sets a flag that determines whether tick marks and axis labels move with an axis if the crossing point of an axis changes.
IsReversed | Gets or sets a flag which indicates whether the axis is reversed.
IsStartedFromZero | Gets or sets a flag which indicates whether the minimum value of the axis will be automatically set to zero if all data point values are positive. If there are negative data point values, the minimum value of the data points will be used.
LabelAutoFitMaxFontSize | Gets or sets the maximum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitMinFontSize | Gets or sets the minimum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitStyle | Gets or sets the allowable label changes that can be made to enable the label to be fit along an axis.
LabelStyle | Gets or sets the LabelStyle properties of an axis.
LineColor | Gets or sets the line color of an axis.
LineDashStyle | Gets or sets the line style of an axis.
LineWidth | Gets or sets the line width of an axis, in pixels.
LogarithmBase | Gets or sets a value for the logarithm base for the logarithmic axis.
MajorGrid | Gets or sets a Grid object used to set the major grid line properties for an axis.
MajorTickMark | Gets or sets a TickMark object used to set the major tick mark properties of an axis.
Maximum | Gets or sets the maximum value of an axis.
Minimum | Gets or sets the minimum value of an axis.
MinorGrid | Gets or sets a Grid object used to specify the minor grid lines attributes of an axis.
MinorTickMark | Gets or sets a TickMark object used to set the minor tick mark properties of an axis.
Name | Overridden. Gets or sets the name of the axis.
ScaleBreakStyle | Gets or sets the axis scale break style.
ScaleView | Gets or sets the view of an axis.
ScrollBar | Gets or sets an axis scrollbar.
StripLines | Gets a StripLinesCollection collection object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextOrientation | Gets or sets the orientation of the text in the axis title.
Title | Gets or sets the title of the axis.
TitleAlignment | Gets or sets the alignment of an axis title.
TitleFont | Gets or sets the title font properties of an axis.
TitleForeColor | Gets or sets the text color of the axis title.
ToolTip | Gets or sets the tooltip used for the axis.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetPosition | Converts an axis value to a relative position (0-100%). If an axis is logarithmic, the value is converted to a linear scale.
GetType | (inherited from Object )
PixelPositionToValue | Converts an absolute pixel position along an axis to an axis value. This method only works in paint events.
PositionToValue | Converts a relative coordinate along an axis to an axis value. This method only works in paint events.
ReferenceEquals | (inherited from Object )
RoundAxisValues | Automatically rounds axis values.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
ValueToPixelPosition | Converts an axis value to an absolute coordinate along an axis. Measured in pixels. This method only works in paint events.
ValueToPosition | Converts an axis value to its relative position (0-100%). If an axis has a logarithmic scale, the value is converted to a linear scale. This method only works in paint events.
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Axis Class


Axis Constructor

Axis Constructor |
 | See Also

Overload List

Name | Description
Axis () | Initializes a new instance of the Axis class.
Axis (ChartArea, AxisName) | Initializes a new instance of the Axis class with the specified ChartArea and axisTypeName values.

See Also

Reference

Axis Class
Axis Members


Axis Constructor ()

Axis Constructor () |
 | See Also

Initializes a new instance of the Axis class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Axis ()
public:
Axis ()
public Axis ()
public function Axis ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis Constructor (ChartArea, AxisName)

Axis Constructor (ChartArea, AxisName) |
 | See Also

Initializes a new instance of the Axis class with the specified ChartArea and axisTypeName values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    chartArea As ChartArea, _
    axisTypeName As AxisName _
)
public Axis (
    ChartArea chartArea,
    AxisName axisTypeName
)
public:
Axis (
    ChartArea^ chartArea,
    AxisName axisTypeName
)
public Axis (
    ChartArea chartArea,
    AxisName axisTypeName
)
public function Axis (
    chartArea : ChartArea,
    axisTypeName : AxisName
)

Parameters

chartArea
axisTypeName

The axis name.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis Methods

Axis Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetPosition | Converts an axis value to a relative position (0-100%). If an axis is logarithmic, the value is converted to a linear scale.
GetType | (inherited from Object )
PixelPositionToValue | Converts an absolute pixel position along an axis to an axis value. This method only works in paint events.
PositionToValue | Converts a relative coordinate along an axis to an axis value. This method only works in paint events.
ReferenceEquals | (inherited from Object )
RoundAxisValues | Automatically rounds axis values.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )
ValueToPixelPosition | Converts an axis value to an absolute coordinate along an axis. Measured in pixels. This method only works in paint events.
ValueToPosition | Converts an axis value to its relative position (0-100%). If an axis has a logarithmic scale, the value is converted to a linear scale. This method only works in paint events.

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Axis Class


Axis.Dispose Method

Axis.Dispose Method |
 | See Also

Overload List

Name | Description
Axis.Dispose () | (inherited from Dispose )
Axis.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

Axis Class
Axis Members


Axis.Dispose Method (Boolean)

Axis.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.GetPosition Method

Axis.GetPosition Method |
 | See Also

Converts an axis value to a relative position (0-100%). If an axis is logarithmic, the value is converted to a linear scale.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetPosition ( _
    axisValue As Double _
) As Double
public double GetPosition (
    double axisValue
)
public:
double GetPosition (
    double axisValue
)
public double GetPosition (
    double axisValue
)
public function GetPosition (
    axisValue : double
) : double

Parameters

axisValue

The axis value.

Return Value

A double value that represents the relative position (0-100%).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.PixelPositionToValue Method

Axis.PixelPositionToValue Method |
 | See Also

Converts an absolute pixel position along an axis to an axis value. This method only works in paint events.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function PixelPositionToValue ( _
    position As Double _
) As Double
public double PixelPositionToValue (
    double position
)
public:
double PixelPositionToValue (
    double position
)
public double PixelPositionToValue (
    double position
)
public function PixelPositionToValue (
    position : double
) : double

Parameters

position

The pixel position.

Return Value

A double value that represents the axis value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.PositionToValue Method

Axis.PositionToValue Method |
 | See Also

Converts a relative coordinate along an axis to an axis value. This method only works in paint events.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function PositionToValue ( _
    position As Double _
) As Double
public double PositionToValue (
    double position
)
public:
double PositionToValue (
    double position
)
public double PositionToValue (
    double position
)
public function PositionToValue (
    position : double
) : double

Parameters

position

The relative position (0-100%).

Return Value

A double value that represents the axis value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.RoundAxisValues Method

Axis.RoundAxisValues Method |
 | See Also

Automatically rounds axis values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub RoundAxisValues
public void RoundAxisValues ()
public:
void RoundAxisValues ()
public void RoundAxisValues ()
public function RoundAxisValues ()

Remarks

Call the RoundAxisValues method to round the values of an axis. Note that the interval used for the axis will not be changed when this method is called. This method is only supported for the X and X2 axes. The Y and Y2 axes values are rounded by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.ValueToPixelPosition Method

Axis.ValueToPixelPosition Method |
 | See Also

Converts an axis value to an absolute coordinate along an axis. Measured in pixels. This method only works in paint events.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ValueToPixelPosition ( _
    axisValue As Double _
) As Double
public double ValueToPixelPosition (
    double axisValue
)
public:
double ValueToPixelPosition (
    double axisValue
)
public double ValueToPixelPosition (
    double axisValue
)
public function ValueToPixelPosition (
    axisValue : double
) : double

Parameters

axisValue

The axis value.

Return Value

A double value that represents the pixel position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.ValueToPosition Method

Axis.ValueToPosition Method |
 | See Also

Converts an axis value to its relative position (0-100%). If an axis has a logarithmic scale, the value is converted to a linear scale. This method only works in paint events.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ValueToPosition ( _
    axisValue As Double _
) As Double
public double ValueToPosition (
    double axisValue
)
public:
double ValueToPosition (
    double axisValue
)
public double ValueToPosition (
    double axisValue
)
public function ValueToPosition (
    axisValue : double
) : double

Parameters

axisValue

The axis value.

Return Value

A double value that represents the relative position (0-100%).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis Properties

Axis Properties |
 | See Also

Public Properties

Name | Description
ArrowStyle | Gets or sets the arrow style of a 2D axis; this style is not applied to 3D chart areas.
AxisName | Gets the name of the axis, which can be either X, Y, X2 or Y2. For internal use only.
Crossing | Gets or sets the location at which an axis is crossed by its associated axis.
CustomLabels | Gets a CustomLabelsCollection object used to store CustomLabel objects.
Enabled | Gets or sets a value that indicates whether an axis is enabled.
InterlacedColor | Gets or sets the color of interlaced strip lines.
Interval | Gets or sets the interval of an axis.
IntervalAutoMode | Gets or sets a flag that determines if a fixed number of intervals is used on the axis, or if the number of intervals depends on the axis size.
IntervalOffset | Gets or sets the interval offset of an axis.
IntervalOffsetType | Gets or sets the interval offset type of an axis.
IntervalType | Gets or sets the interval type of an axis.
IsInterlaced | Gets or sets a flag that determines if interlaced strip lines are displayed for an axis.
IsLabelAutoFit | Gets or sets a flag that determines whether axis labels are automatically fitted.
IsLogarithmic | Gets or sets a flag which indicates whether the axis is logarithmic. Zeros or negative data values are not allowed on logarithmic charts.
IsMarginVisible | Gets or sets a flag that determines whether to add a margin to the axis.
IsMarksNextToAxis | Gets or sets a flag that determines whether tick marks and axis labels move with an axis if the crossing point of an axis changes.
IsReversed | Gets or sets a flag which indicates whether the axis is reversed.
IsStartedFromZero | Gets or sets a flag which indicates whether the minimum value of the axis will be automatically set to zero if all data point values are positive. If there are negative data point values, the minimum value of the data points will be used.
LabelAutoFitMaxFontSize | Gets or sets the maximum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitMinFontSize | Gets or sets the minimum font size that can be used by the label auto-fitting algorithm.
LabelAutoFitStyle | Gets or sets the allowable label changes that can be made to enable the label to be fit along an axis.
LabelStyle | Gets or sets the LabelStyle properties of an axis.
LineColor | Gets or sets the line color of an axis.
LineDashStyle | Gets or sets the line style of an axis.
LineWidth | Gets or sets the line width of an axis, in pixels.
LogarithmBase | Gets or sets a value for the logarithm base for the logarithmic axis.
MajorGrid | Gets or sets a Grid object used to set the major grid line properties for an axis.
MajorTickMark | Gets or sets a TickMark object used to set the major tick mark properties of an axis.
Maximum | Gets or sets the maximum value of an axis.
Minimum | Gets or sets the minimum value of an axis.
MinorGrid | Gets or sets a Grid object used to specify the minor grid lines attributes of an axis.
MinorTickMark | Gets or sets a TickMark object used to set the minor tick mark properties of an axis.
Name | Overridden. Gets or sets the name of the axis.
ScaleBreakStyle | Gets or sets the axis scale break style.
ScaleView | Gets or sets the view of an axis.
ScrollBar | Gets or sets an axis scrollbar.
StripLines | Gets a StripLinesCollection collection object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextOrientation | Gets or sets the orientation of the text in the axis title.
Title | Gets or sets the title of the axis.
TitleAlignment | Gets or sets the alignment of an axis title.
TitleFont | Gets or sets the title font properties of an axis.
TitleForeColor | Gets or sets the text color of the axis title.
ToolTip | Gets or sets the tooltip used for the axis.

See Also

Reference

Axis Class


Axis.ArrowStyle Property

Axis.ArrowStyle Property |
 | See Also

Gets or sets the arrow style of a 2D axis; this style is not applied to 3D chart areas.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ArrowStyle As AxisArrowStyle
public AxisArrowStyle ArrowStyle { get; set; }
public:
property AxisArrowStyle ArrowStyle {
    AxisArrowStyle get ();
    void set (AxisArrowStyle value);
}
/** @property */
public AxisArrowStyle get_ArrowStyle ()

/** @property */
public void set_ArrowStyle (AxisArrowStyle value)

public function get ArrowStyle () : AxisArrowStyle

public function set ArrowStyle (value : AxisArrowStyle)

Property Value

An AxisArrowStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.AxisName Property

Axis.AxisName Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the name of the axis, which can be either X, Y, X2 or Y2. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overridable ReadOnly Property AxisName As AxisName
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public virtual AxisName AxisName { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property AxisName AxisName {
    AxisName get ();
}
/** @property */
public AxisName get_AxisName ()

public function get AxisName () : AxisName

Property Value

An AxisName enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Crossing Property

Axis.Crossing Property |
 | See Also

Gets or sets the location at which an axis is crossed by its associated axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Crossing As Double
public virtual double Crossing { get; set; }
public:
virtual property double Crossing {
    double get ();
    void set (double value);
}
/** @property */
public double get_Crossing ()

/** @property */
public void set_Crossing (double value)

public function get Crossing () : double

public function set Crossing (value : double)

Property Value

A double value that represents where an axis is crossed by its associated axis. The default value is NaN.

Remarks

Setting this property for a primary axis will determine where the other primary axis crosses it, and similarly setting it for a secondary axis will determine where the other secondary axis crosses it. For example, setting the Crossing property of the primary X-axis determines where the primary Y-axis will cross it.

Four modes can be used for the Crossing property of an axis:

  • "Auto", which means that the crossing value will be set to the minimum or maximum value for the relevant axis. If the axis is primary, the value will be its minimum value, if the axis is secondary it will its maximum value. To set to "Auto" at run time, use a NaN value.

  • "Minimum", which means the crossing value of the axis will be its minimum value. To set to "Minimum" at run-time use a MinValue value.

  • "Maximum", which means the crossing value of the axis will be its maximum value. To set to "Maximum" at run-time use a MaxValue value.

  • A specified double value that is between the minimum and maximum values for the relevant axis. If the crossing value is less then minimum value, or the crossing value is greater than maximum value, an exception will be thrown.

When a non-default crossing value is used, the labels and tick marks of the axis may or may not follow the crossing axis, depending on the IsMarksNextToAxis property setting. By default they will move with the crossing axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.CustomLabels Property

Axis.CustomLabels Property |
 | See Also

Gets a CustomLabelsCollection object used to store CustomLabel objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property CustomLabels As CustomLabelsCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public CustomLabelsCollection CustomLabels { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property CustomLabelsCollection^ CustomLabels {
    CustomLabelsCollection^ get ();
}
/** @property */
public CustomLabelsCollection get_CustomLabels ()

public function get CustomLabels () : CustomLabelsCollection

Property Value

A CustomLabelsCollection object.

Remarks

Use this property to add or remove custom labels for an axis. Using CustomLabel objects enables the developer to arbitrarily set the text for axis labels.

Only custom labels can be used in the second row of labels. Also, if a custom label is used in the first label row, then all labels in this first row must be custom labels.

Labels can also be set from the data points, or generated automatically from the axis scale.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Enabled Property

Axis.Enabled Property |
 | See Also

Gets or sets a value that indicates whether an axis is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As AxisEnabled
public AxisEnabled Enabled { get; set; }
public:
property AxisEnabled Enabled {
    AxisEnabled get ();
    void set (AxisEnabled value);
}
/** @property */
public AxisEnabled get_Enabled ()

/** @property */
public void set_Enabled (AxisEnabled value)

public function get Enabled () : AxisEnabled

public function set Enabled (value : AxisEnabled)

Property Value

An AxisEnabled enumeration value. The default value is Auto.

Remarks

If an axis is disabled, the axis, along with its attributes (tick marks, strip lines, labels, and so forth), will not be displayed.

If an axis is enabled, the axis, along with all its attributes (tick marks, strip lines, labels, and so forth), will be displayed regardless of whether or not it is being used to plot a Series.

If a value of Auto is used, an axis may or may not be displayed, depending on whether it is being used to plot a Series. The axes that are used to plot data are determined by the XAxisType and YAxisType property settings.

Note:
If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto, but the axis is not being used to plot data; the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.InterlacedColor Property

Axis.InterlacedColor Property |
 | See Also

Gets or sets the color of interlaced strip lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property InterlacedColor As Color
public Color InterlacedColor { get; set; }
public:
property Color InterlacedColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_InterlacedColor ()

/** @property */
public void set_InterlacedColor (Color value)

public function get InterlacedColor () : Color

public function set InterlacedColor (value : Color)

Property Value

A Color object that represents the color of interlaced strip lines.

Remarks

Use this property to specify the color of interlaced strip lines that are displayed when you invoke the InterlacedColor property.

To specify the border color of the interlaced strip lines, you must display the strips using the StripLines collection property instead of the InterlacedColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Interval Property

Axis.Interval Property |
 | See Also

Gets or sets the interval of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value that represents the interval of an axis. The default value is "Auto", which is represented by a value of zero (0).

Remarks

This property determines how often the labels and major tick marks and grid lines associated with the axis are drawn if the Interval property value of a label, tick mark, or grid line is set to NaN, which signifies that it is not set.

The Interval property of a major tick mark, grid line or label of the axis has priority over the Interval property setting of the Axis object.

A value of zero represents an "Auto" value. This Interval property cannot be set to NaN. If you assign this property a value of NaN, a value of zero will be used instead.

Note The minor grid lines and tick marks of an axis never use this property for their interval.

The interval type of the axis is determined by the IntervalType property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IntervalAutoMode Property

Axis.IntervalAutoMode Property |
 | See Also

Gets or sets a flag that determines if a fixed number of intervals is used on the axis, or if the number of intervals depends on the axis size.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalAutoMode As IntervalAutoMode
public IntervalAutoMode IntervalAutoMode { get; set; }
public:
property IntervalAutoMode IntervalAutoMode {
    IntervalAutoMode get ();
    void set (IntervalAutoMode value);
}
/** @property */
public IntervalAutoMode get_IntervalAutoMode ()

/** @property */
public void set_IntervalAutoMode (IntervalAutoMode value)

public function get IntervalAutoMode () : IntervalAutoMode

public function set IntervalAutoMode (value : IntervalAutoMode)

Property Value

An IntervalAutoMode enumeration value. The default value is FixedCount.

Remarks

When the Interval property is set to "Auto", the IntervalAutoMode property determines how many intervals should be calculated. If your chart is resized or redrawn often, you can set the IntervalAutoMode property to VariableCount, in which case the chart will dynamically calculate axis intervals. This is especially useful in situations where the chart intervals are displayed differently, depending on their data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IntervalOffset Property

Axis.IntervalOffset Property |
 | See Also

Gets or sets the interval offset of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the interval offset of an axis. The default value is "Auto", which is represented by a value of zero (0).

Remarks

The IntervalOffset property determines the interval offset of an axis. This value is used as the interval offset of an axis' labels and the major tick marks and grid lines associated with the axis if the IntervalOffset property value of the labels, tick marks, or grid lines is not set, which is represented by a value of NaN.

The IntervalOffset property of the tick marks, labels and grid lines of an axis has priority over the IntervalOffset property setting of the Axis object.

A value of zero represents an "Auto" value. Also, Interval cannot be set to not set (that is, a NaN). If you assign NaN, a value of "Auto"—that is, a value of zero—will be used instead.

Note The minor grid lines and tick marks of an axis never use this property for their interval offset.

The interval offset type of the axis is determined by the IntervalOffsetType property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IntervalOffsetType Property

Axis.IntervalOffsetType Property |
 | See Also

Gets or sets the interval offset type of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

The interval offset type of an axis. The default value is Auto.

Remarks

This property determines the interval offset type of an axis, and is used for the interval offset type of an axis' labels, and major tick marks or grid lines if the axis element's own IntervalOffsetType property value is set to NotSet.

Setting this property to NotSet will result in a value of Auto being used (only the axis elements such as major grid lines, etc. can be set to NotSet).

Note:
The minor grid lines and tick marks of an axis never use this property for their interval offset type.

The interval of the axis is determined by the IntervalOffset property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IntervalType Property

Axis.IntervalType Property |
 | See Also

Gets or sets the interval type of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType that represents the interval type of an axis. The default value is Auto.

Remarks

This property determines the interval type of an axis, and is used for the interval type of an axis' labels, major tick marks, or major grid lines if the axis element's own IntervalType property value is set to NotSet.

Setting this property to NotSet will result in a value of Auto being used. Only the axis elements, such as grid lines, can be set to NotSet.

Note The minor grid lines and tick marks of an axis never use this property for their interval type.

The interval of the axis is determined by the Interval property.

Important:
If the axis interval type is represented by a time such as hours, minutes, and so forth, then in order for zooming to function correctly, the IntervalType must be set to a time value as well. For example, if ChartArea1.AxisX.IntervalType is set to hours, then ChartArea1.CursorX.IntervalType could be set to minutes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsInterlaced Property

Axis.IsInterlaced Property |
 | See Also

Gets or sets a flag that determines if interlaced strip lines are displayed for an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsInterlaced As Boolean
public bool IsInterlaced { get; set; }
public:
property bool IsInterlaced {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsInterlaced ()

/** @property */
public void set_IsInterlaced (boolean value)

public function get IsInterlaced () : boolean

public function set IsInterlaced (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsLabelAutoFit Property

Axis.IsLabelAutoFit Property |
 | See Also

Gets or sets a flag that determines whether axis labels are automatically fitted.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsLabelAutoFit As Boolean
public bool IsLabelAutoFit { get; set; }
public:
property bool IsLabelAutoFit {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsLabelAutoFit ()

/** @property */
public void set_IsLabelAutoFit (boolean value)

public function get IsLabelAutoFit () : boolean

public function set IsLabelAutoFit (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsLogarithmic Property

Axis.IsLogarithmic Property |
 | See Also

Gets or sets a flag which indicates whether the axis is logarithmic. Zeros or negative data values are not allowed on logarithmic charts.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsLogarithmic As Boolean
public bool IsLogarithmic { get; set; }
public:
property bool IsLogarithmic {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsLogarithmic ()

/** @property */
public void set_IsLogarithmic (boolean value)

public function get IsLogarithmic () : boolean

public function set IsLogarithmic (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsMarginVisible Property

Axis.IsMarginVisible Property |
 | See Also

Gets or sets a flag that determines whether to add a margin to the axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsMarginVisible As Boolean
public bool IsMarginVisible { get; set; }
public:
property bool IsMarginVisible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMarginVisible ()

/** @property */
public void set_IsMarginVisible (boolean value)

public function get IsMarginVisible () : boolean

public function set IsMarginVisible (value : boolean)

Property Value

True if a space is added between the first or last data point and the border of chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsMarksNextToAxis Property

Axis.IsMarksNextToAxis Property |
 | See Also

Gets or sets a flag that determines whether tick marks and axis labels move with an axis if the crossing point of an axis changes.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsMarksNextToAxis As Boolean
public virtual bool IsMarksNextToAxis { get; set; }
public:
virtual property bool IsMarksNextToAxis {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMarksNextToAxis ()

/** @property */
public void set_IsMarksNextToAxis (boolean value)

public function get IsMarksNextToAxis () : boolean

public function set IsMarksNextToAxis (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsReversed Property

Axis.IsReversed Property |
 | See Also

Gets or sets a flag which indicates whether the axis is reversed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsReversed As Boolean
public bool IsReversed { get; set; }
public:
property bool IsReversed {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsReversed ()

/** @property */
public void set_IsReversed (boolean value)

public function get IsReversed () : boolean

public function set IsReversed (value : boolean)

Remarks

If set to reversed, the values on the axis are in reversed sort order and the direction of values on the axis is flipped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.IsStartedFromZero Property

Axis.IsStartedFromZero Property |
 | See Also

Gets or sets a flag which indicates whether the minimum value of the axis will be automatically set to zero if all data point values are positive. If there are negative data point values, the minimum value of the data points will be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsStartedFromZero As Boolean
public bool IsStartedFromZero { get; set; }
public:
property bool IsStartedFromZero {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsStartedFromZero ()

/** @property */
public void set_IsStartedFromZero (boolean value)

public function get IsStartedFromZero () : boolean

public function set IsStartedFromZero (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LabelAutoFitMaxFontSize Property

Axis.LabelAutoFitMaxFontSize Property |
 | See Also

Gets or sets the maximum font size that can be used by the label auto-fitting algorithm.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelAutoFitMaxFontSize As Integer
public int LabelAutoFitMaxFontSize { get; set; }
public:
property int LabelAutoFitMaxFontSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelAutoFitMaxFontSize ()

/** @property */
public void set_LabelAutoFitMaxFontSize (int value)

public function get LabelAutoFitMaxFontSize () : int

public function set LabelAutoFitMaxFontSize (value : int)

Property Value

An integer value.

Remarks

The font size cannot be less than 5.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LabelAutoFitMinFontSize Property

Axis.LabelAutoFitMinFontSize Property |
 | See Also

Gets or sets the minimum font size that can be used by the label auto-fitting algorithm.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelAutoFitMinFontSize As Integer
public int LabelAutoFitMinFontSize { get; set; }
public:
property int LabelAutoFitMinFontSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelAutoFitMinFontSize ()

/** @property */
public void set_LabelAutoFitMinFontSize (int value)

public function get LabelAutoFitMinFontSize () : int

public function set LabelAutoFitMinFontSize (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LabelAutoFitStyle Property

Axis.LabelAutoFitStyle Property |
 | See Also

Gets or sets the allowable label changes that can be made to enable the label to be fit along an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelAutoFitStyle As LabelAutoFitStyles
public LabelAutoFitStyles LabelAutoFitStyle { get; set; }
public:
property LabelAutoFitStyles LabelAutoFitStyle {
    LabelAutoFitStyles get ();
    void set (LabelAutoFitStyles value);
}
/** @property */
public LabelAutoFitStyles get_LabelAutoFitStyle ()

/** @property */
public void set_LabelAutoFitStyle (LabelAutoFitStyles value)

public function get LabelAutoFitStyle () : LabelAutoFitStyles

public function set LabelAutoFitStyle (value : LabelAutoFitStyles)

Property Value

A LabelAutoFitStyles enumeration value.

Remarks

The IsLabelAutoFit property must be set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LabelStyle Property

Axis.LabelStyle Property |
 | See Also

Gets or sets the LabelStyle properties of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property LabelStyle As LabelStyle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LabelStyle LabelStyle { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property LabelStyle^ LabelStyle {
    LabelStyle^ get ();
    void set (LabelStyle^ value);
}
/** @property */
public LabelStyle get_LabelStyle ()

/** @property */
public void set_LabelStyle (LabelStyle value)

public function get LabelStyle () : LabelStyle

public function set LabelStyle (value : LabelStyle)

Property Value

A LabelStyle object, which defines the axis label style.

Remarks

Use this property to specify the style, formatting, and so forth, of axis labels.

If the IsLabelAutoFit property is true, the font size, font angle and the use of offset labels are determined automatically. If you set any one of the LabelStyle.Font.Size, Angle or IsStaggered properties, the IsLabelAutoFit property will be set to false.

Note that if a format that consists of a date without a time is used for labels, and the DateTime data point values that are used specify times, the times will affect the positions of the data points, even though they are not displayed due to the label formatting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LineColor Property

Axis.LineColor Property |
 | See Also

Gets or sets the line color of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color object that represents the line color used to draw the axis. The default is Black.

Remarks

Use the LineColor property to specify the line color of an axis.

Note If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto. In this case, the axis is not being used to plot data, and the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LineDashStyle Property

Axis.LineDashStyle Property |
 | See Also

Gets or sets the line style of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Remarks

The LineDashStyle property determines the line style used for an axis. The line can be solid, dotted, and so forth.

Note If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto. In this case, the axis is not being used to plot data, and the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LineWidth Property

Axis.LineWidth Property |
 | See Also

Gets or sets the line width of an axis, in pixels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that represents the width of an axis line. The default value is one (1) pixel.

Remarks

The LineWidth property gets or sets the width of an axis line, in pixels. If the width is set to zero (0), the line will not be displayed.

Note If an axis is disabled but an adjacent axis is using grid lines, one of those grid lines will be displayed in place of the disabled axis. The same situation will occur if the Enabled property of an axis is set to Auto. In this case, the axis is not being used to plot data, and the grid line of an adjacent axis will be drawn instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.LogarithmBase Property

Axis.LogarithmBase Property |
 | See Also

Gets or sets a value for the logarithm base for the logarithmic axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LogarithmBase As Double
public double LogarithmBase { get; set; }
public:
property double LogarithmBase {
    double get ();
    void set (double value);
}
/** @property */
public double get_LogarithmBase ()

/** @property */
public void set_LogarithmBase (double value)

public function get LogarithmBase () : double

public function set LogarithmBase (value : double)

Property Value

A double value. The default value is base 10.

Remarks

This property only has an effect when the IsLogarithmic property is set to true.

Note that this property is only applicable to value axes, which are used to plot data. Setting this property for a categorical axis will result in an exception being thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.MajorGrid Property

Axis.MajorGrid Property |
 | See Also

Gets or sets a Grid object used to set the major grid line properties for an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property MajorGrid As Grid
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Grid MajorGrid { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Grid^ MajorGrid {
    Grid^ get ();
    void set (Grid^ value);
}
/** @property */
public Grid get_MajorGrid ()

/** @property */
public void set_MajorGrid (Grid value)

public function get MajorGrid () : Grid

public function set MajorGrid (value : Grid)

Property Value

A Grid object used to get or set the major grid properties of an axis.

Remarks

Major grid lines are always drawn in conjunction with a data point. That is, they will occur at the same point along an axis as a data point, for categorical axis tick marks. For value axes, major grid lines by default are drawn wherever labels occur.

You can use this property to change major grid line frequency, color, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.MajorTickMark Property

Axis.MajorTickMark Property |
 | See Also

Gets or sets a TickMark object used to set the major tick mark properties of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property MajorTickMark As TickMark
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public TickMark MajorTickMark { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property TickMark^ MajorTickMark {
    TickMark^ get ();
    void set (TickMark^ value);
}
/** @property */
public TickMark get_MajorTickMark ()

/** @property */
public void set_MajorTickMark (TickMark value)

public function get MajorTickMark () : TickMark

public function set MajorTickMark (value : TickMark)

Property Value

A TickMark object used to set the properties of a major tick mark of an axis.

Remarks

Major tick marks are always drawn in conjunction with a data point. Categorical axis tick marks will occur at the same point along an axis as a data point. For value axes, major tick marks are drawn by default wherever labels occur.

You can use this property to change the major tick mark properties such as frequency, color, or size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Maximum Property

Axis.Maximum Property |
 | See Also

Gets or sets the maximum value of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Maximum As Double
public double Maximum { get; set; }
public:
property double Maximum {
    double get ();
    void set (double value);
}
/** @property */
public double get_Maximum ()

/** @property */
public void set_Maximum (double value)

public function get Maximum () : double

public function set Maximum (value : double)

Property Value

A double value that represents the maximum value of an axis. The default value is NaN.

Remarks

To automatically round the maximum and minimum axis values call the RoundAxisValues method. The Maximum value must be greater than the Minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Minimum Property

Axis.Minimum Property |
 | See Also

Gets or sets the minimum value of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Minimum As Double
public double Minimum { get; set; }
public:
property double Minimum {
    double get ();
    void set (double value);
}
/** @property */
public double get_Minimum ()

/** @property */
public void set_Minimum (double value)

public function get Minimum () : double

public function set Minimum (value : double)

Property Value

A double value that represents the minimum value of an axis. The default value is NaN.

Remarks

Note that if you set this value explicitly, the X-values of data elements must be taken into account. If all data points have X-values of zero, the Chart control will assume the first data point occurs at zero. Also, if the Minimum value is explicitly set, the IsStartedFromZero property will be ignored. The Minimum value must be less than the Maximum value.

To automatically round the maximum and minimum axis values. call the RoundAxisValues method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.MinorGrid Property

Axis.MinorGrid Property |
 | See Also

Gets or sets a Grid object used to specify the minor grid lines attributes of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property MinorGrid As Grid
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Grid MinorGrid { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Grid^ MinorGrid {
    Grid^ get ();
    void set (Grid^ value);
}
/** @property */
public Grid get_MinorGrid ()

/** @property */
public void set_MinorGrid (Grid value)

public function get MinorGrid () : Grid

public function set MinorGrid (value : Grid)

Property Value

A Grid object used to get or set the attributes of the minor grid lines of an axis.

Remarks

Minor grid lines are drawn in between the major grid lines.

Use this property to change the attributes of a minor grid line, such as frequency, color, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.MinorTickMark Property

Axis.MinorTickMark Property |
 | See Also

Gets or sets a TickMark object used to set the minor tick mark properties of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property MinorTickMark As TickMark
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public TickMark MinorTickMark { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property TickMark^ MinorTickMark {
    TickMark^ get ();
    void set (TickMark^ value);
}
/** @property */
public TickMark get_MinorTickMark ()

/** @property */
public void set_MinorTickMark (TickMark value)

public function get MinorTickMark () : TickMark

public function set MinorTickMark (value : TickMark)

Property Value

A TickMark object used for the minor tick mark properties of an axis.

Remarks

Minor tick marks should be drawn between major tick marks, where labels usually occur.

Use this property to change the minor tick mark frequency, color, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Name Property

Axis.Name Property |
 | See Also

Gets or sets the name of the axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string Name { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.ScaleBreakStyle Property

Axis.ScaleBreakStyle Property |
 | See Also

Gets or sets the axis scale break style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Overridable Property ScaleBreakStyle As AxisScaleBreakStyle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public virtual AxisScaleBreakStyle ScaleBreakStyle { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
virtual property AxisScaleBreakStyle^ ScaleBreakStyle {
    AxisScaleBreakStyle^ get ();
    void set (AxisScaleBreakStyle^ value);
}
/** @property */
public AxisScaleBreakStyle get_ScaleBreakStyle ()

/** @property */
public void set_ScaleBreakStyle (AxisScaleBreakStyle value)

public function get ScaleBreakStyle () : AxisScaleBreakStyle

public function set ScaleBreakStyle (value : AxisScaleBreakStyle)

Property Value

An AxisScaleBreakStyle object, which represents the scale break style of the chart axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.ScaleView Property

Axis.ScaleView Property |
 | See Also

Gets or sets the view of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property ScaleView As AxisScaleView
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public AxisScaleView ScaleView { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property AxisScaleView^ ScaleView {
    AxisScaleView^ get ();
    void set (AxisScaleView^ value);
}
/** @property */
public AxisScaleView get_ScaleView ()

/** @property */
public void set_ScaleView (AxisScaleView value)

public function get ScaleView () : AxisScaleView

public function set ScaleView (value : AxisScaleView)

Property Value

An AxisScaleView object, which represents the scale view of an axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.ScrollBar Property

Axis.ScrollBar Property |
 | See Also

Gets or sets an axis scrollbar.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property ScrollBar As AxisScrollBar
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public AxisScrollBar ScrollBar { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property AxisScrollBar^ ScrollBar {
    AxisScrollBar^ get ();
    void set (AxisScrollBar^ value);
}
/** @property */
public AxisScrollBar get_ScrollBar ()

/** @property */
public void set_ScrollBar (AxisScrollBar value)

public function get ScrollBar () : AxisScrollBar

public function set ScrollBar (value : AxisScrollBar)

Property Value

An AxisScrollbar object, which represents the scrollbar of an axis.

Remarks

Use this property to manipulate the scrollbar of an axis.

For further details, refer to the AxisScrollbar class documentation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.StripLines Property

Axis.StripLines Property |
 | See Also

Gets a StripLinesCollection collection object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property StripLines As StripLinesCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public StripLinesCollection StripLines { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property StripLinesCollection^ StripLines {
    StripLinesCollection^ get ();
}
/** @property */
public StripLinesCollection get_StripLines ()

public function get StripLines () : StripLinesCollection

Property Value

A StripLinesCollection collection object, which stores all StripLine objects for an axis.

Remarks

Strip lines are used to draw rectangular strips across a ChartArea object, and are always drawn across the entire <A href="">area.

These strip lines are not related to the grid lines.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.TextOrientation Property

Axis.TextOrientation Property |
 | See Also

Gets or sets the orientation of the text in the axis title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextOrientation As TextOrientation
public TextOrientation TextOrientation { get; set; }
public:
property TextOrientation TextOrientation {
    TextOrientation get ();
    void set (TextOrientation value);
}
/** @property */
public TextOrientation get_TextOrientation ()

/** @property */
public void set_TextOrientation (TextOrientation value)

public function get TextOrientation () : TextOrientation

public function set TextOrientation (value : TextOrientation)

Property Value

A TextOrientation enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.Title Property

Axis.Title Property |
 | See Also

Gets or sets the title of the axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Title As String
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Title ()

/** @property */
public void set_Title (String value)

public function get Title () : String

public function set Title (value : String)

Property Value

A string value that represents the title of the axis.

Remarks

Gets or sets the title of the axis.

You can set the font properties of the title using the TitleFont property.

You can set the color of the title using the TitleForeColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.TitleAlignment Property

Axis.TitleAlignment Property |
 | See Also

Gets or sets the alignment of an axis title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleAlignment As StringAlignment
public StringAlignment TitleAlignment { get; set; }
public:
property StringAlignment TitleAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TitleAlignment ()

/** @property */
public void set_TitleAlignment (StringAlignment value)

public function get TitleAlignment () : StringAlignment

public function set TitleAlignment (value : StringAlignment)

Property Value

A StringAlignment enumeration value.

Remarks

Possible alignment values are Center, Far, and Near. A value of Far equates to an alignment to the top or the right, depending on the orientation of the axis or strip line. In the same manner, a value of Near equates to an alignment to the bottom or the right.

If you want more control over the positioning of an axis title, you must perform custom drawing using the PostPaint or PrePaint event.

You can further align and position the titles of StripLine objects by using their TextLineAlignment and TitleAngle properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.TitleFont Property

Axis.TitleFont Property |
 | See Also

Gets or sets the title font properties of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleFont As Font
public Font TitleFont { get; set; }
public:
property Font^ TitleFont {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_TitleFont ()

/** @property */
public void set_TitleFont (Font value)

public function get TitleFont () : Font

public function set TitleFont (value : Font)

Property Value

A Font object used for the font properties of a title.

Remarks

Gets or sets title font properties such as face or size.

To set font properties at run time, a new Font object must be created. Any attempt to change the properties of the current Font object at run time will result in a compilation error.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.TitleForeColor Property

Axis.TitleForeColor Property |
 | See Also

Gets or sets the text color of the axis title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleForeColor As Color
public Color TitleForeColor { get; set; }
public:
property Color TitleForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleForeColor ()

/** @property */
public void set_TitleForeColor (Color value)

public function get TitleForeColor () : Color

public function set TitleForeColor (value : Color)

Property Value

A Color structure. The default color is Black.

Remarks

Gets or sets the text color of an Axis object title.

You can use any valid ARGB (alpha, red, green, blue) color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


Axis.ToolTip Property

Axis.ToolTip Property |
 | See Also

Gets or sets the tooltip used for the axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Axis Class
Axis Members


AxisArrowStyle Enumeration

AxisArrowStyle Enumeration |
 | See Also

An enumeration of axis arrow styles.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AxisArrowStyle
public enum AxisArrowStyle
public enum class AxisArrowStyle
public enum AxisArrowStyle
public enum AxisArrowStyle

Members

Member name | Description
Lines | A line-shaped arrow is used for the relevant axis.
None | No arrow is used for the relevant axis.
SharpTriangle | A sharp triangular arrow is used for the relevant axis.
Triangle | A triangular arrow is used for the relevant axis.

Remarks

The AxisArrowStyle enumeration represents the style for an axis arrow. If the ArrowStyle property is set to None, no arrow is displayed for an axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


AxisEnabled Enumeration

AxisEnabled Enumeration |
 | See Also

Specifies the state of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AxisEnabled
public enum AxisEnabled
public enum class AxisEnabled
public enum AxisEnabled
public enum AxisEnabled

Members

Member name | Description
Auto | The axis is only enabled if it used to plot a Series.
False | The axis is never enabled.
True | The axis is always enabled.

Remarks

The AxisEnabled enumeration is used with the Enabled property to enable or disable an axis.

If the Enabled property is set to Auto, an axis may or may not be displayed, depending on whether it is being used to plot a Series. The axes that are used to plot data for a series are determined by the XAxisType and YAxisType property settings.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


AxisName Enumeration

AxisName Enumeration |
 | See Also

Specifies the name of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AxisName
public enum AxisName
public enum class AxisName
public enum AxisName
public enum AxisName

Members

Member name | Description
X | Primary X-axis.
X2 | Secondary X-axis.
Y | Primary Y-axis.
Y2 | Secondary Y-axis.

Remarks

The AxisName enumeration represents the four different axes that can be used for a chart.

Bar and stacked bar charts have their axes rotated 90 degrees clockwise. For example, the primary X-axis for these two charts is the left-vertical axis.

For all charts except bar, stacked bar, pie and doughnut charts, the primary and secondary axes are as follows:

Axis Type | Description
Primary X-Axis | Bottom horizontal axis.
Secondary X-Axis | Top horizontal axis.
Primary Y-Axis | Left vertical axis.
Secondary Y-Axis | Right vertical axis.

Bar and stacked bar charts have their axes rotated 90 degrees clockwise. For example, the primary X-axis for these two charts is the left-vertical axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


AxisScaleBreakStyle Class

AxisScaleBreakStyle Class |
 | See Also Members

Represents a scale break on the Y-axis of the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AxisScaleBreakStyle
public class AxisScaleBreakStyle
public ref class AxisScaleBreakStyle
public class AxisScaleBreakStyle
public class AxisScaleBreakStyle

Remarks

Scale breaks are intentional discontinuities on the Y-axis that are most often used to redistribute the data points in a series on a chart. This feature improves readability when there are large differences between the high and low values of the data in one series being plotted. Scale breaks are not drawn for differences between data in multiple series.

By default, scale breaks are disabled. You can enable scale breaks on the Y-axis by setting the Enabled property to true. To change the amount of vertical space of the scale break, you can specify a Spacing value. This is calculated as a percentage of the Y-axis scale.

You must have sufficient separation between ranges of data points in a single series to draw a scale break. By default, a scale break can be added only if there is a separation between the data ranges of at least 25% of the chart. If you enable a scale break but it does not appear, even though there is sufficient distance between the data ranges, you can set the CollapsibleSpaceThreshold property to a value less than 25.

Charts support up to five scale breaks per chart; however, the chart can become unreadable if you display more than one scale break. If you have more than two data ranges, consider using a different method for displaying this data. Use the MaxNumberOfBreaks property to reduce the number of scale breaks that can be displayed on the chart.

When a scale break is used, the Y-axis labels may become offset. To disable the label offset, set the IsStaggered property to false.

Scale breaks are not supported under any of the following conditions:

  • Pie, doughnut, funnel, pyramid, radial or any stacked chart types are used.

  • Custom intervals for labels, tick marks or grid lines are enabled.

  • The minimum or maximum value for the axis is set.

  • Custom labels are used.

  • A logarithmic Y-axis is specified.

  • Axis views on the Y-axis, which include scrolling and zooming, are used.

  • 3-D charts are used.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.AxisScaleBreakStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Members


AxisScaleBreakStyle Members

AxisScaleBreakStyle Members |
 | See Also Constructors Methods Properties

Represents a scale break on the Y-axis of the chart.

The following tables list the members exposed by the AxisScaleBreakStyle type.

Public Constructors

Name | Description
AxisScaleBreakStyle | Initializes a new instance of the AxisScaleBreakStyle class.
Top

Public Properties

Name | Description
BreakLineStyle | Gets or sets the style of the break line that will be used to draw the scale break.
CollapsibleSpaceThreshold | Gets or sets the threshold of space on the chart at which scale breaks are drawn.
Enabled | Gets or sets a flag that indicates whether scale breaks are enabled.
LineColor | Gets or sets the color of the scale break line.
LineDashStyle | Gets or sets the style of the scale break line.
LineWidth | Gets or sets the width of the scale break line.
MaxNumberOfBreaks | Gets or sets the maximum number of scale breaks to be displayed on the chart.
Spacing | Gets or sets the spacing gap between the lines of the scale break. The spacing gap is represented as a percentage of the Y-axis.
StartFromZero | Gets or sets a StartFromZero enumeration value that indicates whether to start the scale break from zero.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AxisScaleBreakStyle Class


AxisScaleBreakStyle Constructor

AxisScaleBreakStyle Constructor |
 | See Also

Initializes a new instance of the AxisScaleBreakStyle class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AxisScaleBreakStyle ()
public:
AxisScaleBreakStyle ()
public AxisScaleBreakStyle ()
public function AxisScaleBreakStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle Methods

AxisScaleBreakStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AxisScaleBreakStyle Class


AxisScaleBreakStyle Properties

AxisScaleBreakStyle Properties |
 | See Also

Public Properties

Name | Description
BreakLineStyle | Gets or sets the style of the break line that will be used to draw the scale break.
CollapsibleSpaceThreshold | Gets or sets the threshold of space on the chart at which scale breaks are drawn.
Enabled | Gets or sets a flag that indicates whether scale breaks are enabled.
LineColor | Gets or sets the color of the scale break line.
LineDashStyle | Gets or sets the style of the scale break line.
LineWidth | Gets or sets the width of the scale break line.
MaxNumberOfBreaks | Gets or sets the maximum number of scale breaks to be displayed on the chart.
Spacing | Gets or sets the spacing gap between the lines of the scale break. The spacing gap is represented as a percentage of the Y-axis.
StartFromZero | Gets or sets a StartFromZero enumeration value that indicates whether to start the scale break from zero.

See Also

Reference

AxisScaleBreakStyle Class


AxisScaleBreakStyle.BreakLineStyle Property

AxisScaleBreakStyle.BreakLineStyle Property |
 | See Also

Gets or sets the style of the break line that will be used to draw the scale break.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BreakLineStyle As BreakLineStyle
public BreakLineStyle BreakLineStyle { get; set; }
public:
property BreakLineStyle BreakLineStyle {
    BreakLineStyle get ();
    void set (BreakLineStyle value);
}
/** @property */
public BreakLineStyle get_BreakLineStyle ()

/** @property */
public void set_BreakLineStyle (BreakLineStyle value)

public function get BreakLineStyle () : BreakLineStyle

public function set BreakLineStyle (value : BreakLineStyle)

Property Value

A BreakLineStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.CollapsibleSpaceThreshold Property

AxisScaleBreakStyle.CollapsibleSpaceThreshold Property |
 | See Also

Gets or sets the threshold of space on the chart at which scale breaks are drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property CollapsibleSpaceThreshold As Integer
public int CollapsibleSpaceThreshold { get; set; }
public:
property int CollapsibleSpaceThreshold {
    int get ();
    void set (int value);
}
/** @property */
public int get_CollapsibleSpaceThreshold ()

/** @property */
public void set_CollapsibleSpaceThreshold (int value)

public function get CollapsibleSpaceThreshold () : int

public function set CollapsibleSpaceThreshold (value : int)

Property Value

An integer value that specifies the threshold of space on the chart at which scale breaks are drawn.

Remarks

This property is measured as a percentage of the Y-axis scale. By default, its value is set to 25. This means that data points in a series that have a difference of at least 25% of the scale will be collapsed with a scale break.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.Enabled Property

AxisScaleBreakStyle.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether scale breaks are enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

A Boolean value that specifies whether scale breaks are enabled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.LineColor Property

AxisScaleBreakStyle.LineColor Property |
 | See Also

Gets or sets the color of the scale break line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color value that represents the color of the scale break line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.LineDashStyle Property

AxisScaleBreakStyle.LineDashStyle Property |
 | See Also

Gets or sets the style of the scale break line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value that represents the style of the scale break line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.LineWidth Property

AxisScaleBreakStyle.LineWidth Property |
 | See Also

Gets or sets the width of the scale break line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that represents the width of the scale break line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.MaxNumberOfBreaks Property

AxisScaleBreakStyle.MaxNumberOfBreaks Property |
 | See Also

Gets or sets the maximum number of scale breaks to be displayed on the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MaxNumberOfBreaks As Integer
public int MaxNumberOfBreaks { get; set; }
public:
property int MaxNumberOfBreaks {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaxNumberOfBreaks ()

/** @property */
public void set_MaxNumberOfBreaks (int value)

public function get MaxNumberOfBreaks () : int

public function set MaxNumberOfBreaks (value : int)

Property Value

An integer value that represents the maximum number of scale breaks to be displayed on the chart.

Remarks

The Chart is capable of displaying up to five scale breaks.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.Spacing Property

AxisScaleBreakStyle.Spacing Property |
 | See Also

Gets or sets the spacing gap between the lines of the scale break. The spacing gap is represented as a percentage of the Y-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Spacing As Double
public double Spacing { get; set; }
public:
property double Spacing {
    double get ();
    void set (double value);
}
/** @property */
public double get_Spacing ()

/** @property */
public void set_Spacing (double value)

public function get Spacing () : double

public function set Spacing (value : double)

Property Value

A double value that represents the spacing gap between the lines of the scale break.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleBreakStyle.StartFromZero Property

AxisScaleBreakStyle.StartFromZero Property |
 | See Also

Gets or sets a StartFromZero enumeration value that indicates whether to start the scale break from zero.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property StartFromZero As StartFromZero
public StartFromZero StartFromZero { get; set; }
public:
property StartFromZero StartFromZero {
    StartFromZero get ();
    void set (StartFromZero value);
}
/** @property */
public StartFromZero get_StartFromZero ()

/** @property */
public void set_StartFromZero (StartFromZero value)

public function get StartFromZero () : StartFromZero

public function set StartFromZero (value : StartFromZero)

Property Value

A StartFromZero enumeration value that indicates whether to start the scale break from zero.

Remarks

If the StartFromZero property is set to Auto, the chart will automatically calculate whether to start the Y-axis scale minimum from the lowest value in the series or from zero.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleBreakStyle Class
AxisScaleBreakStyle Members


AxisScaleView Class

AxisScaleView Class |
 | See Also Members

Represents a scaled view of the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AxisScaleView
public class AxisScaleView
public ref class AxisScaleView
public class AxisScaleView
public class AxisScaleView

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.AxisScaleView

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Members


AxisScaleView Members

AxisScaleView Members |
 | See Also Constructors Methods Properties

Represents a scaled view of the chart.

The following tables list the members exposed by the AxisScaleView type.

Public Constructors

Name | Description
AxisScaleView | Initializes a new instance of the AxisScaleView class.
Top

Public Properties

Name | Description
IsZoomed | Gets a flag that indicates whether the axis is zoomed in.
MinSize | Gets or sets the minimum size of the AxisScaleView object.
MinSizeType | Gets or sets the unit of measurement of the MinSize property.
Position | Gets or sets the position of the scale view.
Size | Gets or sets the size of the scale view.
SizeType | Gets or sets the unit of measurement for the Size property.
SmallScrollMinSize | Gets or sets the minimum small scrolling size. Used only if the small scrolling size is not set.
SmallScrollMinSizeType | Gets or sets the unit of measurement for the SmallScrollMinSize property.
SmallScrollSize | Gets or sets the small scrolling size.
SmallScrollSizeType | Gets or sets the unit of measurement for the SmallScrollMinSize property.
ViewMaximum | Gets the maximum axis value of a data view.
ViewMinimum | Gets the minimum axis value of a data view.
Zoomable | Gets or sets a flag that indicates whether the zooming user interface is enabled.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
Scroll | Overloaded.
ToString | (inherited from Object )
Zoom | Overloaded.
ZoomReset | Overloaded.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AxisScaleView Class


AxisScaleView Constructor

AxisScaleView Constructor |
 | See Also

Initializes a new instance of the AxisScaleView class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AxisScaleView ()
public:
AxisScaleView ()
public AxisScaleView ()
public function AxisScaleView ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView Methods

AxisScaleView Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
Scroll | Overloaded.
ToString | (inherited from Object )
Zoom | Overloaded.
ZoomReset | Overloaded.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AxisScaleView Class


AxisScaleView.Scroll Method

AxisScaleView.Scroll Method |
 | See Also

Overload List

Name | Description
AxisScaleView.Scroll (DateTime) | Scrolls to a position along an axis specified by the newPosition parameter, which is expressed as a DateTime value.
AxisScaleView.Scroll (Double) | Scrolls to a position along an axis specified by the newPosition parameter.
AxisScaleView.Scroll (ScrollType) | Scrolls along an axis according to the direction and size indicated by the scrollType parameter.

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Scroll Method (DateTime)

AxisScaleView.Scroll Method (DateTime) |
 | See Also

Scrolls to a position along an axis specified by the newPosition parameter, which is expressed as a DateTime value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Scroll ( _
    newPosition As DateTime _
)
public void Scroll (
    DateTime newPosition
)
public:
void Scroll (
    DateTime newPosition
)
public void Scroll (
    DateTime newPosition
)
public function Scroll (
    newPosition : DateTime
)

Parameters

newPosition

The new position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Scroll Method (Double)

AxisScaleView.Scroll Method (Double) |
 | See Also

Scrolls to a position along an axis specified by the newPosition parameter.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Scroll ( _
    newPosition As Double _
)
public void Scroll (
    double newPosition
)
public:
void Scroll (
    double newPosition
)
public void Scroll (
    double newPosition
)
public function Scroll (
    newPosition : double
)

Parameters

newPosition

The new position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Scroll Method (ScrollType)

AxisScaleView.Scroll Method (ScrollType) |
 | See Also

Scrolls along an axis according to the direction and size indicated by the scrollType parameter.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Scroll ( _
    scrollType As ScrollType _
)
public void Scroll (
    ScrollType scrollType
)
public:
void Scroll (
    ScrollType scrollType
)
public void Scroll (
    ScrollType scrollType
)
public function Scroll (
    scrollType : ScrollType
)

Parameters

scrollType

The direction and size to scroll.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Zoom Method

AxisScaleView.Zoom Method |
 | See Also

Overload List

Name | Description
AxisScaleView.Zoom (Double, Double) | Sets a new axis data view and/or position based on the specified start and end values.
AxisScaleView.Zoom (Double, Double, DateTimeIntervalType) | Sets a new axis data view and/or position based on the specified start position, view size and unit of measurement.
AxisScaleView.Zoom (Double, Double, DateTimeIntervalType, Boolean) | Sets a new axis data view and/or position based on the specified start position, view size, unit of measurement and save state.

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Zoom Method (Double, Double)

AxisScaleView.Zoom Method (Double, Double) |
 | See Also

Sets a new axis data view and/or position based on the specified start and end values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Zoom ( _
    viewStart As Double, _
    viewEnd As Double _
)
public void Zoom (
    double viewStart,
    double viewEnd
)
public:
void Zoom (
    double viewStart,
    double viewEnd
)
public void Zoom (
    double viewStart,
    double viewEnd
)
public function Zoom (
    viewStart : double,
    viewEnd : double
)

Parameters

viewStart

The new start position for the axis scale view.

viewEnd

The new end position for the axis scale view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Zoom Method (Double, Double, DateTimeIntervalType)

AxisScaleView.Zoom Method (Double, Double, DateTimeIntervalType) |
 | See Also

Sets a new axis data view and/or position based on the specified start position, view size and unit of measurement.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Zoom ( _
    viewPosition As Double, _
    viewSize As Double, _
    viewSizeType As DateTimeIntervalType _
)
public void Zoom (
    double viewPosition,
    double viewSize,
    DateTimeIntervalType viewSizeType
)
public:
void Zoom (
    double viewPosition,
    double viewSize,
    DateTimeIntervalType viewSizeType
)
public void Zoom (
    double viewPosition,
    double viewSize,
    DateTimeIntervalType viewSizeType
)
public function Zoom (
    viewPosition : double,
    viewSize : double,
    viewSizeType : DateTimeIntervalType
)

Parameters

viewPosition

The new start position for the axis scale view.

viewSize

The new size for the axis scale view.

viewSizeType

The new unit of measurement of the size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Zoom Method (Double, Double, DateTimeIntervalType, Boolean)

AxisScaleView.Zoom Method (Double, Double, DateTimeIntervalType, Boolean) |
 | See Also

Sets a new axis data view and/or position based on the specified start position, view size, unit of measurement and save state.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Zoom ( _
    viewPosition As Double, _
    viewSize As Double, _
    viewSizeType As DateTimeIntervalType, _
    saveState As Boolean _
)
public void Zoom (
    double viewPosition,
    double viewSize,
    DateTimeIntervalType viewSizeType,
    bool saveState
)
public:
void Zoom (
    double viewPosition,
    double viewSize,
    DateTimeIntervalType viewSizeType,
    bool saveState
)
public void Zoom (
    double viewPosition,
    double viewSize,
    DateTimeIntervalType viewSizeType,
    boolean saveState
)
public function Zoom (
    viewPosition : double,
    viewSize : double,
    viewSizeType : DateTimeIntervalType,
    saveState : boolean
)

Parameters

viewPosition

The new start position for the axis scale view.

viewSize

The new size for the axis scale view.

viewSizeType

The new unit of measurement of the size.

saveState

Indicates whether the current size and/or position must be saved.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.ZoomReset Method

AxisScaleView.ZoomReset Method |
 | See Also

Overload List

Name | Description
AxisScaleView.ZoomReset () | Resets one zoom operation by restoring the axis data view.
AxisScaleView.ZoomReset (Int32) | Resets the specified number of zoom operations by restoring the axis data view.

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.ZoomReset Method ()

AxisScaleView.ZoomReset Method () |
 | See Also

Resets one zoom operation by restoring the axis data view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub ZoomReset
public void ZoomReset ()
public:
void ZoomReset ()
public void ZoomReset ()
public function ZoomReset ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.ZoomReset Method (Int32)

AxisScaleView.ZoomReset Method (Int32) |
 | See Also

Resets the specified number of zoom operations by restoring the axis data view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub ZoomReset ( _
    numberOfViews As Integer _
)
public void ZoomReset (
    int numberOfViews
)
public:
void ZoomReset (
    int numberOfViews
)
public void ZoomReset (
    int numberOfViews
)
public function ZoomReset (
    numberOfViews : int
)

Parameters

numberOfViews

Number of zoom operations to reset.

Remarks

Set the numberOfViews parameter to zero (0) to reset all zoom operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView Properties

AxisScaleView Properties |
 | See Also

Public Properties

Name | Description
IsZoomed | Gets a flag that indicates whether the axis is zoomed in.
MinSize | Gets or sets the minimum size of the AxisScaleView object.
MinSizeType | Gets or sets the unit of measurement of the MinSize property.
Position | Gets or sets the position of the scale view.
Size | Gets or sets the size of the scale view.
SizeType | Gets or sets the unit of measurement for the Size property.
SmallScrollMinSize | Gets or sets the minimum small scrolling size. Used only if the small scrolling size is not set.
SmallScrollMinSizeType | Gets or sets the unit of measurement for the SmallScrollMinSize property.
SmallScrollSize | Gets or sets the small scrolling size.
SmallScrollSizeType | Gets or sets the unit of measurement for the SmallScrollMinSize property.
ViewMaximum | Gets the maximum axis value of a data view.
ViewMinimum | Gets the minimum axis value of a data view.
Zoomable | Gets or sets a flag that indicates whether the zooming user interface is enabled.

See Also

Reference

AxisScaleView Class


AxisScaleView.IsZoomed Property

AxisScaleView.IsZoomed Property |
 | See Also

Gets a flag that indicates whether the axis is zoomed in.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property IsZoomed As Boolean
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsZoomed { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property bool IsZoomed {
    bool get ();
}
/** @property */
public boolean get_IsZoomed ()

public function get IsZoomed () : boolean

Property Value

True if the axis is zoomed in, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.MinSize Property

AxisScaleView.MinSize Property |
 | See Also

Gets or sets the minimum size of the AxisScaleView object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MinSize As Double
public double MinSize { get; set; }
public:
property double MinSize {
    double get ();
    void set (double value);
}
/** @property */
public double get_MinSize ()

/** @property */
public void set_MinSize (double value)

public function get MinSize () : double

public function set MinSize (value : double)

Property Value

A double that represents the minimum size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.MinSizeType Property

AxisScaleView.MinSizeType Property |
 | See Also

Gets or sets the unit of measurement of the MinSize property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MinSizeType As DateTimeIntervalType
public DateTimeIntervalType MinSizeType { get; set; }
public:
property DateTimeIntervalType MinSizeType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_MinSizeType ()

/** @property */
public void set_MinSizeType (DateTimeIntervalType value)

public function get MinSizeType () : DateTimeIntervalType

public function set MinSizeType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Position Property

AxisScaleView.Position Property |
 | See Also

Gets or sets the position of the scale view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Position As Double
public double Position { get; set; }
public:
property double Position {
    double get ();
    void set (double value);
}
/** @property */
public double get_Position ()

/** @property */
public void set_Position (double value)

public function get Position () : double

public function set Position (value : double)

Property Value

A double that represents the position of the scale view.-

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Size Property

AxisScaleView.Size Property |
 | See Also

Gets or sets the size of the scale view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Size As Double
public double Size { get; set; }
public:
property double Size {
    double get ();
    void set (double value);
}
/** @property */
public double get_Size ()

/** @property */
public void set_Size (double value)

public function get Size () : double

public function set Size (value : double)

Property Value

A double that represents the size of the scale view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.SizeType Property

AxisScaleView.SizeType Property |
 | See Also

Gets or sets the unit of measurement for the Size property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SizeType As DateTimeIntervalType
public DateTimeIntervalType SizeType { get; set; }
public:
property DateTimeIntervalType SizeType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_SizeType ()

/** @property */
public void set_SizeType (DateTimeIntervalType value)

public function get SizeType () : DateTimeIntervalType

public function set SizeType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.SmallScrollMinSize Property

AxisScaleView.SmallScrollMinSize Property |
 | See Also

Gets or sets the minimum small scrolling size. Used only if the small scrolling size is not set.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SmallScrollMinSize As Double
public double SmallScrollMinSize { get; set; }
public:
property double SmallScrollMinSize {
    double get ();
    void set (double value);
}
/** @property */
public double get_SmallScrollMinSize ()

/** @property */
public void set_SmallScrollMinSize (double value)

public function get SmallScrollMinSize () : double

public function set SmallScrollMinSize (value : double)

Property Value

A double that represents the small scrolling size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.SmallScrollMinSizeType Property

AxisScaleView.SmallScrollMinSizeType Property |
 | See Also

Gets or sets the unit of measurement for the SmallScrollMinSize property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SmallScrollMinSizeType As DateTimeIntervalType
public DateTimeIntervalType SmallScrollMinSizeType { get; set; }
public:
property DateTimeIntervalType SmallScrollMinSizeType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_SmallScrollMinSizeType ()

/** @property */
public void set_SmallScrollMinSizeType (DateTimeIntervalType value)

public function get SmallScrollMinSizeType () : DateTimeIntervalType

public function set SmallScrollMinSizeType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.SmallScrollSize Property

AxisScaleView.SmallScrollSize Property |
 | See Also

Gets or sets the small scrolling size.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SmallScrollSize As Double
public double SmallScrollSize { get; set; }
public:
property double SmallScrollSize {
    double get ();
    void set (double value);
}
/** @property */
public double get_SmallScrollSize ()

/** @property */
public void set_SmallScrollSize (double value)

public function get SmallScrollSize () : double

public function set SmallScrollSize (value : double)

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.SmallScrollSizeType Property

AxisScaleView.SmallScrollSizeType Property |
 | See Also

Gets or sets the unit of measurement for the SmallScrollMinSize property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SmallScrollSizeType As DateTimeIntervalType
public DateTimeIntervalType SmallScrollSizeType { get; set; }
public:
property DateTimeIntervalType SmallScrollSizeType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_SmallScrollSizeType ()

/** @property */
public void set_SmallScrollSizeType (DateTimeIntervalType value)

public function get SmallScrollSizeType () : DateTimeIntervalType

public function set SmallScrollSizeType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.ViewMaximum Property

AxisScaleView.ViewMaximum Property |
 | See Also

Gets the maximum axis value of a data view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property ViewMaximum As Double
[BrowsableAttribute(false)]
public double ViewMaximum { get; }
[BrowsableAttribute(false)]
public:
property double ViewMaximum {
    double get ();
}
/** @property */
public double get_ViewMaximum ()

public function get ViewMaximum () : double

Property Value

A double that represents the maximum axis value for the data view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.ViewMinimum Property

AxisScaleView.ViewMinimum Property |
 | See Also

Gets the minimum axis value of a data view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property ViewMinimum As Double
[BrowsableAttribute(false)]
public double ViewMinimum { get; }
[BrowsableAttribute(false)]
public:
property double ViewMinimum {
    double get ();
}
/** @property */
public double get_ViewMinimum ()

public function get ViewMinimum () : double

Property Value

A double that represents the minimum axis value for the data view.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScaleView.Zoomable Property

AxisScaleView.Zoomable Property |
 | See Also

Gets or sets a flag that indicates whether the zooming user interface is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="'Zoomable' is a commonly used term and generally well understood")> _
Public Property Zoomable As Boolean
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="\'Zoomable\' is a commonly used term and generally well understood")]
public bool Zoomable { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"\'Zoomable\' is a commonly used term and generally well understood")]
public:
property bool Zoomable {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Zoomable ()

/** @property */
public void set_Zoomable (boolean value)

public function get Zoomable () : boolean

public function set Zoomable (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScaleView Class
AxisScaleView Members


AxisScrollBar Class

AxisScrollBar Class |
 | See Also Members

Represents the scrollbar of a chart axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class AxisScrollBar
    Implements IDisposable
public class AxisScrollBar : IDisposable
public ref class AxisScrollBar : IDisposable
public class AxisScrollBar implements IDisposable
public class AxisScrollBar implements IDisposable

Remarks

The AxisScrollBar class is exposed as the ScrollBar property of the Axis class.

Scrollbars allow the end user to scroll through data when a subset of data is being displayed. A subset of data is referred to as a view, and is represented by the AxisScaleView class.

Scrollbars are only shown when zooming occurs. In other words, even if a scrollbar is enabled, it will only be visible when a view is being displayed.

Important:
To fix the position of scrollbars, the plotting area position of a chart area must not be set to Auto. To explicitly set the plotting area position, use the InnerPlotPosition property.

To display scrollbars when a chart is first displayed, use the AxisScaleView class properties and methods so that a view is initially displayed to end users.

The background color, button color and width of scrollbars can be set using this AxisScrollBar class.

Note that there are two main types of scrolling: large scrolling, which occurs when the end user clicks in the background of a scrollbar—that is, that part of a scrollbar not covered by the thumb; and small scrolling, which occurs when the end user clicks a left/right or up/down button. To control the large scrolling size, use the Size property of the ScaleView object. To set the small scrolling size, use the SmallScrollSize property of the AxisScaleView class.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.AxisScrollBar

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Members


AxisScrollBar Members

AxisScrollBar Members |
 | See Also Constructors Methods Properties

Represents the scrollbar of a chart axis.

The following tables list the members exposed by the AxisScrollBar type.

Public Constructors

Name | Description
AxisScrollBar | Initializes a new instance of the AxisScrollBar class.
Top

Public Properties

Name | Description
Axis | Gets the Axis object that uses the scrollbar.
BackColor | Gets or sets the background color of a scrollbar.
ButtonColor | Gets or sets the color of the scrollbar buttons.
ButtonStyle | Gets or sets the style of the scrollbar button.
ChartArea | Gets the chart area that contains this scrollbar.
Enabled | Gets or sets a flag that determines whether a scrollbar is enabled.
IsPositionedInside | Gets or sets a flag that indicates whether scroll bar is positioned inside or outside the chart area.
IsVisible | Gets a flag that indicates whether the scrollbar is visible.
LineColor | Gets or sets the line color of a scrollbar.
Size | Gets or sets the width of a scrollbar, in pixels.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

AxisScrollBar Class


AxisScrollBar Constructor

AxisScrollBar Constructor |
 | See Also

Initializes a new instance of the AxisScrollBar class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public AxisScrollBar ()
public:
AxisScrollBar ()
public AxisScrollBar ()
public function AxisScrollBar ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar Methods

AxisScrollBar Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

AxisScrollBar Class


AxisScrollBar.Dispose Method

AxisScrollBar.Dispose Method |
 | See Also

Overload List

Name | Description
AxisScrollBar.Dispose () | Performs application-defined tasks that free, release, or reset unmanaged resources.
AxisScrollBar.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.Dispose Method ()

AxisScrollBar.Dispose Method () |
 | See Also

Performs application-defined tasks that free, release, or reset unmanaged resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Dispose
public void Dispose ()
public:
virtual void Dispose () sealed
public final void Dispose ()
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.Dispose Method (Boolean)

AxisScrollBar.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar Properties

AxisScrollBar Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets the Axis object that uses the scrollbar.
BackColor | Gets or sets the background color of a scrollbar.
ButtonColor | Gets or sets the color of the scrollbar buttons.
ButtonStyle | Gets or sets the style of the scrollbar button.
ChartArea | Gets the chart area that contains this scrollbar.
Enabled | Gets or sets a flag that determines whether a scrollbar is enabled.
IsPositionedInside | Gets or sets a flag that indicates whether scroll bar is positioned inside or outside the chart area.
IsVisible | Gets a flag that indicates whether the scrollbar is visible.
LineColor | Gets or sets the line color of a scrollbar.
Size | Gets or sets the width of a scrollbar, in pixels.

See Also

Reference

AxisScrollBar Class


AxisScrollBar.Axis Property

AxisScrollBar.Axis Property |
 | See Also

Gets the Axis object that uses the scrollbar.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Axis As Axis
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Axis Axis { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Axis^ Axis {
    Axis^ get ();
}
/** @property */
public Axis get_Axis ()

public function get Axis () : Axis

Property Value

An Axis object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.BackColor Property

AxisScrollBar.BackColor Property |
 | See Also

Gets or sets the background color of a scrollbar.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value that represents the background color of the scrollbar. The default value is Empty.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) color.

If the value of this property is Empty, the background color of the scrollbar will be determined by the BackColor property value of the chart area the scrollbar is being used for.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.ButtonColor Property

AxisScrollBar.ButtonColor Property |
 | See Also

Gets or sets the color of the scrollbar buttons.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ButtonColor As Color
public Color ButtonColor { get; set; }
public:
property Color ButtonColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ButtonColor ()

/** @property */
public void set_ButtonColor (Color value)

public function get ButtonColor () : Color

public function set ButtonColor (value : Color)

Property Value

A Color value that represents the color of the scrollbar buttons.

Remarks

Use this property to get or set the color of the left/right, up/down, reset and thumb buttons of a scrollbar.

If the value of this property is Empty, the color used for the buttons will be determined by the LineColor property value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.ButtonStyle Property

AxisScrollBar.ButtonStyle Property |
 | See Also

Gets or sets the style of the scrollbar button.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ButtonStyle As ScrollBarButtonStyles
public ScrollBarButtonStyles ButtonStyle { get; set; }
public:
property ScrollBarButtonStyles ButtonStyle {
    ScrollBarButtonStyles get ();
    void set (ScrollBarButtonStyles value);
}
/** @property */
public ScrollBarButtonStyles get_ButtonStyle ()

/** @property */
public void set_ButtonStyle (ScrollBarButtonStyles value)

public function get ButtonStyle () : ScrollBarButtonStyles

public function set ButtonStyle (value : ScrollBarButtonStyles)

Property Value

A ScrollBarButtonStyles enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.ChartArea Property

AxisScrollBar.ChartArea Property |
 | See Also

Gets the chart area that contains this scrollbar.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ChartArea As ChartArea
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ChartArea ChartArea { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
}
/** @property */
public ChartArea get_ChartArea ()

public function get ChartArea () : ChartArea

Property Value

A ChartArea object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.Enabled Property

AxisScrollBar.Enabled Property |
 | See Also

Gets or sets a flag that determines whether a scrollbar is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if the scrollbar is enabled for an axis, false if the scrollbar is not enabled. The default value is true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.IsPositionedInside Property

AxisScrollBar.IsPositionedInside Property |
 | See Also

Gets or sets a flag that indicates whether scroll bar is positioned inside or outside the chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsPositionedInside As Boolean
public bool IsPositionedInside { get; set; }
public:
property bool IsPositionedInside {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsPositionedInside ()

/** @property */
public void set_IsPositionedInside (boolean value)

public function get IsPositionedInside () : boolean

public function set IsPositionedInside (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.IsVisible Property

AxisScrollBar.IsVisible Property |
 | See Also

Gets a flag that indicates whether the scrollbar is visible.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property IsVisible As Boolean
[BrowsableAttribute(false)]
public bool IsVisible { get; }
[BrowsableAttribute(false)]
public:
property bool IsVisible {
    bool get ();
}
/** @property */
public boolean get_IsVisible ()

public function get IsVisible () : boolean

Property Value

True if the scrollbar is visible.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.LineColor Property

AxisScrollBar.LineColor Property |
 | See Also

Gets or sets the line color of a scrollbar.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color value that represents the line color of the scrollbar. The default value is Empty.

Remarks

This property represents the color used for the arrows in up/down and left/right buttons, the symbol inside the reset button, as well as the border of the entire scrollbar.

If the value of this property is Empty, the line color used will be determined by the LineColor property value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisScrollBar.Size Property

AxisScrollBar.Size Property |
 | See Also

Gets or sets the width of a scrollbar, in pixels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Size As Double
public double Size { get; set; }
public:
property double Size {
    double get ();
    void set (double value);
}
/** @property */
public double get_Size ()

/** @property */
public void set_Size (double value)

public function get Size () : double

public function set Size (value : double)

Property Value

A double value that represents the width of a scrollbar in pixels. The default value is 14 pixels. The value can range from 5 to 20 pixels.

Remarks

Gets or sets the width of a scrollbar, which can be from 5 to 20 pixels.

Set this property to zero to disable a scrollbar.

Important:
To fix the position of scrollbars, the plotting area position of a chart area must not be set to Auto. To explicitly set the plotting area position, use the InnerPlotPosition property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

AxisScrollBar Class
AxisScrollBar Members


AxisType Enumeration

AxisType Enumeration |
 | See Also

Specifies the axis type for the X and Y-axes of a Series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration AxisType
public enum AxisType
public enum class AxisType
public enum AxisType
public enum AxisType

Members

Member name | Description
Primary | Designates an axis as the primary axis.
Secondary | Designates an axis as the secondary axis.

Remarks

The AxisType enumeration represents the axis type used for the X and Y-axes of a Series.

A Series is plotted using two axes, with the exception of pie and doughnut charts. This enumeration is used in conjunction with the XAxisType and YAxisType properties to set the axes used for plotting the associated data points of the series.

For all charts except for bar, stacked bar, pie and doughnut types, the primary and secondary axes are as follows:

Axis Type | Description
Primary X-Axis | Bottom horizontal axis.
Secondary X-Axis | Top horizontal axis.
Primary Y-Axis | Left vertical axis.
Secondary Y-Axis | Right vertical axis.

Bar and stacked bar charts have their axes rotated 90 degrees clockwise. For example, the primary X-axis for these two charts is the left-vertical axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Border3DAnnotation Class

Border3DAnnotation Class |
 | See Also Members

Represents an annotation with a 3D border.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Border3DAnnotation
    Inherits RectangleAnnotation
public class Border3DAnnotation : RectangleAnnotation
public ref class Border3DAnnotation : public RectangleAnnotation
public class Border3DAnnotation extends RectangleAnnotation
public class Border3DAnnotation extends RectangleAnnotation

Remarks

A Border3DAnnotation can also display inner text.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.TextAnnotation
System.Windows.Forms.DataVisualization.Charting.RectangleAnnotation
System.Windows.Forms.DataVisualization.Charting.Border3DAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Members


Border3DAnnotation Members

Border3DAnnotation Members |
 | See Also Constructors Methods Properties

Represents an annotation with a 3D border.

The following tables list the members exposed by the Border3DAnnotation type.

Public Constructors

Name | Description
Border3DAnnotation | Initializes a new instance of the Border3DAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation)
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation)
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation)
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation)
BorderSkin | Gets or sets the skin attributes of the 3D border.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation)
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation)
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Border3DAnnotation Class


Border3DAnnotation Constructor

Border3DAnnotation Constructor |
 | See Also

Initializes a new instance of the Border3DAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Border3DAnnotation ()
public:
Border3DAnnotation ()
public Border3DAnnotation ()
public function Border3DAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Class
Border3DAnnotation Members


Border3DAnnotation Methods

Border3DAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Border3DAnnotation Class


Border3DAnnotation Properties

Border3DAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation )
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation )
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation )
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation )
BorderSkin | Gets or sets the skin attributes of the 3D border.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation )
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

Border3DAnnotation Class


Border3DAnnotation.AnnotationType Property

Border3DAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the annotation type name. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type, such as Line, Rectangle, Ellipse, and so forth.

For internal use; should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Class
Border3DAnnotation Members


Border3DAnnotation.BorderSkin Property

Border3DAnnotation.BorderSkin Property |
 | See Also

Gets or sets the skin attributes of the 3D border.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property BorderSkin As BorderSkin
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public BorderSkin BorderSkin { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property BorderSkin^ BorderSkin {
    BorderSkin^ get ();
    void set (BorderSkin^ value);
}
/** @property */
public BorderSkin get_BorderSkin ()

/** @property */
public void set_BorderSkin (BorderSkin value)

public function get BorderSkin () : BorderSkin

public function set BorderSkin (value : BorderSkin)

Property Value

A BorderSkin object, which determines the attributes of the 3D border.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Border3DAnnotation Class
Border3DAnnotation Members


BorderSkin Class

BorderSkin Class |
 | See Also Members

Represents the drawing properties of the 3D border skin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class BorderSkin
    Inherits ChartElement
public class BorderSkin : ChartElement
public ref class BorderSkin : public ChartElement
public class BorderSkin extends ChartElement
public class BorderSkin extends ChartElement

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.BorderSkin

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Members


BorderSkin Members

BorderSkin Members |
 | See Also Constructors Methods Properties

Represents the drawing properties of the 3D border skin.

The following tables list the members exposed by the BorderSkin type.

Public Constructors

Name | Description
BorderSkin | Initializes a new instance of the BorderSkin class.
Top

Public Properties

Name | Description
BackColor | Gets or sets the background color of a skin frame.
BackGradientStyle | Gets or sets the background gradient style of a skin frame.
BackHatchStyle | Gets or sets the background hatch style of a skin frame.
BackImage | Gets or sets the background image of a skin frame.
BackImageAlignment | Gets or sets the background image alignment of a skin frame.
BackImageTransparentColor | Gets or sets a color that is replaced with a transparent color when the background image of a border skin frame is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a border skin frame.
BackSecondaryColor | Gets or sets the secondary background color of a border skin frame.
BorderColor | Gets or sets the border color of a skin frame.
BorderDashStyle | Gets or sets the style of the border line of a border skin frame.
BorderWidth | Gets or sets the width of the border line of a border skin frame.
PageColor | Gets or sets the page color of a border skin.
SkinStyle | Gets or sets the style of a border skin.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

BorderSkin Class


BorderSkin Constructor

BorderSkin Constructor |
 | See Also

Initializes a new instance of the BorderSkin class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public BorderSkin ()
public:
BorderSkin ()
public BorderSkin ()
public function BorderSkin ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin Methods

BorderSkin Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

BorderSkin Class


BorderSkin Properties

BorderSkin Properties |
 | See Also

Public Properties

Name | Description
BackColor | Gets or sets the background color of a skin frame.
BackGradientStyle | Gets or sets the background gradient style of a skin frame.
BackHatchStyle | Gets or sets the background hatch style of a skin frame.
BackImage | Gets or sets the background image of a skin frame.
BackImageAlignment | Gets or sets the background image alignment of a skin frame.
BackImageTransparentColor | Gets or sets a color that is replaced with a transparent color when the background image of a border skin frame is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a border skin frame.
BackSecondaryColor | Gets or sets the secondary background color of a border skin frame.
BorderColor | Gets or sets the border color of a skin frame.
BorderDashStyle | Gets or sets the style of the border line of a border skin frame.
BorderWidth | Gets or sets the width of the border line of a border skin frame.
PageColor | Gets or sets the page color of a border skin.
SkinStyle | Gets or sets the style of a border skin.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

BorderSkin Class


BorderSkin.BackColor Property

BorderSkin.BackColor Property |
 | See Also

Gets or sets the background color of a skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackGradientStyle Property

BorderSkin.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style of a skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackHatchStyle Property

BorderSkin.BackHatchStyle Property |
 | See Also

Gets or sets the background hatch style of a skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackImage Property

BorderSkin.BackImage Property |
 | See Also

Gets or sets the background image of a skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackImageAlignment Property

BorderSkin.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment of a skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value.

Remarks

The BackImageAlignment property is used by Unscaled drawing mode.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackImageTransparentColor Property

BorderSkin.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that is replaced with a transparent color when the background image of a border skin frame is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackImageWrapMode Property

BorderSkin.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of a border skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BackSecondaryColor Property

BorderSkin.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary background color of a border skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This color is combined with the primary background color, which is set with the BackColor property, when the BackHatchStyle and BackGradientStyle properties are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BorderColor Property

BorderSkin.BorderColor Property |
 | See Also

Gets or sets the border color of a skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BorderDashStyle Property

BorderSkin.BorderDashStyle Property |
 | See Also

Gets or sets the style of the border line of a border skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.BorderWidth Property

BorderSkin.BorderWidth Property |
 | See Also

Gets or sets the width of the border line of a border skin frame.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.PageColor Property

BorderSkin.PageColor Property |
 | See Also

Gets or sets the page color of a border skin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property PageColor As Color
public Color PageColor { get; set; }
public:
property Color PageColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_PageColor ()

/** @property */
public void set_PageColor (Color value)

public function get PageColor () : Color

public function set PageColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkin.SkinStyle Property

BorderSkin.SkinStyle Property |
 | See Also

Gets or sets the style of a border skin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SkinStyle As BorderSkinStyle
public BorderSkinStyle SkinStyle { get; set; }
public:
property BorderSkinStyle SkinStyle {
    BorderSkinStyle get ();
    void set (BorderSkinStyle value);
}
/** @property */
public BorderSkinStyle get_SkinStyle ()

/** @property */
public void set_SkinStyle (BorderSkinStyle value)

public function get SkinStyle () : BorderSkinStyle

public function set SkinStyle (value : BorderSkinStyle)

Property Value

A BorderSkinStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

BorderSkin Class
BorderSkin Members


BorderSkinStyle Enumeration

BorderSkinStyle Enumeration |
 | See Also

Specifies a style for the border skin of a chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration BorderSkinStyle
public enum BorderSkinStyle
public enum class BorderSkinStyle
public enum BorderSkinStyle
public enum BorderSkinStyle

Members

Member name | Description
Emboss | Use an embossed border skin.
FrameThin1 | Use a thin border skin with rounded corners.
FrameThin2 | Use a thin border skin with rounded top corners.
FrameThin3 | Use a thin border skin with square corners.
FrameThin4 | Use a thin border skin with square outside corners and rounded inside corners.
FrameThin5 | Use a thin border skin with rounded corners and screws.
FrameThin6 | Use a thin border skin with square inside corners and rounded outside corners.
FrameTitle1 | Use a border skin with rounded corners.
FrameTitle2 | Use a border skin with rounded top corners.
FrameTitle3 | Use a border skin with square corners.
FrameTitle4 | Use a border skin with rounded inside corners and square outside corners.
FrameTitle5 | Use a border skin with rounded corners and screws.
FrameTitle6 | Use a border skin with rounded outside corners and square inside corners.
FrameTitle7 | Use a border skin with rounded corners. No border on the right side.
FrameTitle8 | Use a border skin with rounded corners on top and bottom sides only.
None | No border skin is used.
Raised | Use a raised border skin.
Sunken | Use a sunken border skin.

Remarks

The BorderSkin class represents the style of the border skin used for a chart image. If you set the SkinStyle property to None, no skin will be used. This is the default value for the SkinStyle property.

Note:
The difference between the sets of border skin styles that use frames and follow either the naming convention FrameThin* or "FrameTitle*—for example, FrameThin1 or FrameTitle1—is the shape and thickness of their frames.

In addition, if you use one of the "FrameThin" style border skins, the title of the chart will not be displayed. However, if you use one of the "FrameTitle" style border skins, the title of the chart will appear in the top-horizontal part of the frame.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


BreakLineStyle Enumeration

BreakLineStyle Enumeration |
 | See Also

Specifies line styles for axis scale breaks.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration BreakLineStyle
public enum BreakLineStyle
public enum class BreakLineStyle
public enum BreakLineStyle
public enum BreakLineStyle

Members

Member name | Description
None | Scale break is not displayed.
Ragged | Scale break is displayed as a ragged line.
Straight | Scale break is displayed as a straight line.
Wave | Scale break is displayed as a wavy line.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


CalloutAnnotation Class

CalloutAnnotation Class |
 | See Also Members

Represents a callout annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class CalloutAnnotation
    Inherits TextAnnotation
public class CalloutAnnotation : TextAnnotation
public ref class CalloutAnnotation : public TextAnnotation
public class CalloutAnnotation extends TextAnnotation
public class CalloutAnnotation extends TextAnnotation

Remarks

A callout annotation is the only annotation that draws a connection between the annotation position and the anchor point. This class can also display text and automatically calculate its required size.

Different callout styles are supported.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.TextAnnotation
System.Windows.Forms.DataVisualization.Charting.CalloutAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Members


CalloutAnnotation Members

CalloutAnnotation Members |
 | See Also Constructors Methods Properties

Represents a callout annotation.

The following tables list the members exposed by the CalloutAnnotation type.

Public Constructors

Name | Description
CalloutAnnotation | Initializes a new instance of the CalloutAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Overridden. Gets or sets the annotation position alignment to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Overridden. Gets or sets the offset that the X-position of the annotation has from the anchor point.
AnchorOffsetY | Overridden. Gets or sets the offset that the Y-position of the annotation has from the anchor point.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the annotation background gradient style.
BackHatchStyle | Overridden. Gets or sets the background hatch style of the annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
CalloutAnchorCap | Gets or sets the style of the callout line anchor cap.
CalloutStyle | Gets or sets the annotation callout style.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. Gets or sets the annotation line color.
LineDashStyle | Overridden. Gets or sets the annotation line style.
LineWidth | Overridden. Gets or sets the line width of the annotation.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation)
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CalloutAnnotation Class


CalloutAnnotation Constructor

CalloutAnnotation Constructor |
 | See Also

Initializes a new instance of the CalloutAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public CalloutAnnotation ()
public:
CalloutAnnotation ()
public CalloutAnnotation ()
public function CalloutAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation Methods

CalloutAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CalloutAnnotation Class


CalloutAnnotation Properties

CalloutAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Overridden. Gets or sets the annotation position alignment to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Overridden. Gets or sets the offset that the X-position of the annotation has from the anchor point.
AnchorOffsetY | Overridden. Gets or sets the offset that the Y-position of the annotation has from the anchor point.
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets or sets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the annotation background gradient style.
BackHatchStyle | Overridden. Gets or sets the background hatch style of the annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color for the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
CalloutAnchorCap | Gets or sets the style of the callout line anchor cap.
CalloutStyle | Gets or sets the annotation callout style.
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. Gets or sets the annotation line color.
LineDashStyle | Overridden. Gets or sets the annotation line style.
LineWidth | Overridden. Gets or sets the line width of the annotation.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

CalloutAnnotation Class


CalloutAnnotation.AnchorAlignment Property

CalloutAnnotation.AnchorAlignment Property |
 | See Also

Gets or sets the annotation position alignment to the anchor point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AnchorAlignment As ContentAlignment
public override ContentAlignment AnchorAlignment { get; set; }
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public override function get AnchorAlignment () : ContentAlignment

public override function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the annotation to the anchor point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.AnchorOffsetX Property

CalloutAnnotation.AnchorOffsetX Property |
 | See Also

Gets or sets the offset that the X-position of the annotation has from the anchor point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AnchorOffsetX As Double
public override double AnchorOffsetX { get; set; }
public:
virtual property double AnchorOffsetX {
    double get () override;
    void set (double value) override;
}
/** @property */
public double get_AnchorOffsetX ()

/** @property */
public void set_AnchorOffsetX (double value)

public override function get AnchorOffsetX () : double

public override function set AnchorOffsetX (value : double)

Property Value

A double value that represents the offset of the annotation's X-position from the anchor point.

Remarks

The CalloutAnnotation must be anchored using either the AnchorDataPoint or the AnchorX property, and its X property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.AnchorOffsetY Property

CalloutAnnotation.AnchorOffsetY Property |
 | See Also

Gets or sets the offset that the Y-position of the annotation has from the anchor point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property AnchorOffsetY As Double
public override double AnchorOffsetY { get; set; }
public:
virtual property double AnchorOffsetY {
    double get () override;
    void set (double value) override;
}
/** @property */
public double get_AnchorOffsetY ()

/** @property */
public void set_AnchorOffsetY (double value)

public override function get AnchorOffsetY () : double

public override function set AnchorOffsetY (value : double)

Property Value

A double value that represents the offset of the annotation's Y-position from the anchor point.

Remarks

The CalloutAnnotation must be anchored using either the AnchorDataPoint or the AnchorY property, and its Y property must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.AnnotationType Property

CalloutAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the annotation type name. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.BackColor Property

CalloutAnnotation.BackColor Property |
 | See Also

Gets or sets the background color of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(true)]
public override Color BackColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color enumeration value used for the background of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.BackGradientStyle Property

CalloutAnnotation.BackGradientStyle Property |
 | See Also

Gets or sets the annotation background gradient style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(true)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value used to draw the annotation background.

Remarks

Two colors are used to draw the gradient, and are set with the BackColor and BackSecondaryColor properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.BackHatchStyle Property

CalloutAnnotation.BackHatchStyle Property |
 | See Also

Gets or sets the background hatch style of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(true)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the annotation background.

Remarks

Two colors are used to draw the hatching, and are set with the BackColor and BackSecondaryColor properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.BackSecondaryColor Property

CalloutAnnotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for the annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(true)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color enumeration value used in conjunction with a primary color to draw the annotation background with hatching or gradient fill.

Remarks

This color is used with the BackColor property when the BackHatchStyle or BackGradientStyle properties are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.CalloutAnchorCap Property

CalloutAnnotation.CalloutAnchorCap Property |
 | See Also

Gets or sets the style of the callout line anchor cap.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutAnchorCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle CalloutAnchorCap { get; set; }
public:
virtual property LineAnchorCapStyle CalloutAnchorCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_CalloutAnchorCap ()

/** @property */
public void set_CalloutAnchorCap (LineAnchorCapStyle value)

public function get CalloutAnchorCap () : LineAnchorCapStyle

public function set CalloutAnchorCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value that represents the style to use for a callout line anchor cap.

Remarks

The CalloutAnchorCap property sets the style of the anchor cap for the line that connects the annotation with the anchor point. This property is only applicable when a SimpleLine or Borderline callout style is used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.CalloutStyle Property

CalloutAnnotation.CalloutStyle Property |
 | See Also

Gets or sets the annotation callout style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutStyle As CalloutStyle
public virtual CalloutStyle CalloutStyle { get; set; }
public:
virtual property CalloutStyle CalloutStyle {
    CalloutStyle get ();
    void set (CalloutStyle value);
}
/** @property */
public CalloutStyle get_CalloutStyle ()

/** @property */
public void set_CalloutStyle (CalloutStyle value)

public function get CalloutStyle () : CalloutStyle

public function set CalloutStyle (value : CalloutStyle)

Property Value

A CalloutStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.LineColor Property

CalloutAnnotation.LineColor Property |
 | See Also

Gets or sets the annotation line color.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(true)]
public override Color LineColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value used to draw the annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.LineDashStyle Property

CalloutAnnotation.LineDashStyle Property |
 | See Also

Gets or sets the annotation line style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(true)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value used to draw the annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutAnnotation.LineWidth Property

CalloutAnnotation.LineWidth Property |
 | See Also

Gets or sets the line width of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(true)]
public override int LineWidth { get; set; }
[BrowsableAttribute(true)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value that represents the annotation line width, in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CalloutAnnotation Class
CalloutAnnotation Members


CalloutStyle Enumeration

CalloutStyle Enumeration |
 | See Also

Represents the available callout styles. Applicable only to callout annotations.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration CalloutStyle
public enum CalloutStyle
public enum class CalloutStyle
public enum CalloutStyle
public enum CalloutStyle

Members

Member name | Description
Borderline | A border is drawn around the callout text and a line points to the anchor point.
Cloud | Callout text is inside the cloud and smaller clouds point to the anchor point.
Ellipse | An ellipse is drawn around the callout text, which is connected to the anchor point.
Perspective | A perspective rectangle is drawn around the callout text, which is connected to the anchor point.
Rectangle | A rectangle is drawn around the callout text, which is connected to the anchor point.
RoundedRectangle | A rounded rectangle is drawn around the callout text, which is connected to the anchor point.
SimpleLine | Callout text is underlined and a line points to the anchor point.

Remarks

The CalloutStyle enumeration is used in conjunction with the CalloutStyle property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Chart Class

Chart Class |
 | See Also Members

Serves as the root class of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Chart
    Inherits Control
    Implements ISupportInitialize, IDisposable
public class Chart : Control, ISupportInitialize, IDisposable
public ref class Chart : public Control, ISupportInitialize, IDisposable
public class Chart extends Control implements ISupportInitialize, IDisposable
public class Chart extends Control implements ISupportInitialize, IDisposable

Remarks

This class exposes all of the properties, methods and events of the Chart Windows control.

Two important properties of the Chart class are the Series and ChartAreas properties, both of which are collection properties. The Series collection property stores Series objects, which are used to store data that is to be displayed, along with attributes of that data. The ChartAreas collection property stores ChartArea objects, which are primarily used to draw one or more charts using one set of axes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.DataVisualization.Charting.Chart

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Members


Chart Members

Chart Members |
 | See Also Constructors Events Methods Properties Explicit Interface Implementations

Serves as the root class of the Chart control.

The following tables list the members exposed by the Chart type.

Public Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.
Top

Public Properties (see also Protected Properties )

Name | Description
AccessibilityObject | (inherited from Control )
AccessibleDefaultActionDescription | (inherited from Control )
AccessibleDescription | (inherited from Control )
AccessibleName | (inherited from Control )
AccessibleRole | (inherited from Control )
AllowDrop | (inherited from Control )
Anchor | (inherited from Control )
Annotations | Stores the chart annotations.
AntiAliasing | Gets or sets a value that determines whether anti-aliasing is used when text and graphics are drawn.
AutoScrollOffset | (inherited from Control )
AutoSize | (inherited from Control )
BackColor | Overridden. Gets or sets the background color of the Chart object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a Chart control. Also determines whether a gradient is used.
BackgroundImage | Overridden. The BackgroundImage property is not used. Use the BackImage property instead.
BackgroundImageLayout | (inherited from Control )
BackHatchStyle | Gets or sets the hatching style of the Chart control.
BackImage | Gets or sets the background image of the Chart control.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets the color of the Chart control that will be displayed as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the Chart control.
BackSecondaryColor | Gets or sets the secondary color of the chart background.
BindingContext | (inherited from Control )
BorderColor | For internal use only.
BorderDashStyle | Gets or sets the style of the border.
BorderlineColor | Gets or sets the color of the border line.
BorderlineDashStyle | Gets or sets the style of the border line.
BorderlineWidth | Gets or sets the width of the border line.
BorderSkin | Gets or sets a BorderSkin object, which provides border skin functionality for the Chart control.
BorderWidth | For internal use only.
Bottom | (inherited from Control )
Bounds | (inherited from Control )
BuildNumber | Gets the build number of the Chart control. This property is for internal use only.
CanFocus | (inherited from Control )
CanSelect | (inherited from Control )
Capture | (inherited from Control )
CausesValidation | (inherited from Control )
ChartAreas | Gets a read-only ChartAreaCollection object that is used to store ChartArea objects.
CheckForIllegalCrossThreadCalls | (inherited from Control )
ClientRectangle | (inherited from Control )
ClientSize | (inherited from Control )
CompanyName | (inherited from Control )
Container | (inherited from Component )
ContainsFocus | (inherited from Control )
ContextMenu | (inherited from Control )
ContextMenuStrip | (inherited from Control )
Controls | (inherited from Control )
Created | (inherited from Control )
Cursor | Overridden. Gets or sets the cursor that is displayed when the mouse pointer is held over the control.
DataBindings | (inherited from Control )
DataManipulator | Gets a DataManipulator object that provides methods and properties that handle data.
DataSource | Gets or sets the data source for the Chart object.
DefaultBackColor | (inherited from Control )
DefaultFont | (inherited from Control )
DefaultForeColor | (inherited from Control )
DisplayRectangle | (inherited from Control )
Disposing | (inherited from Control )
Dock | (inherited from Control )
Enabled | (inherited from Control )
Focused | (inherited from Control )
Font | For internal use only.
ForeColor | Overridden. Gets or sets the text color of the Chart control.
Handle | (inherited from Control )
HasChildren | (inherited from Control )
Height | (inherited from Control )
Images | Gets a NamedImagesCollection object that stores NamedImage objects for the chart.
ImeMode | (inherited from Control )
InvokeRequired | (inherited from Control )
IsAccessible | (inherited from Control )
IsDisposed | (inherited from Control )
IsHandleCreated | (inherited from Control )
IsMirrored | (inherited from Control )
IsSoftShadows | Gets or sets a flag that determines if a smooth gradient is applied when shadows are drawn.
LayoutEngine | (inherited from Control )
Left | (inherited from Control )
Legends | Stores all Legend objects used by the Chart control.
Location | (inherited from Control )
Margin | (inherited from Control )
MaximumSize | (inherited from Control )
MinimumSize | (inherited from Control )
ModifierKeys | (inherited from Control )
MouseButtons | (inherited from Control )
MousePosition | (inherited from Control )
Name | (inherited from Control )
Padding | (inherited from Control )
Palette | Gets or sets the palette for the Chart control.
PaletteCustomColors | Gets or sets an array of custom palette colors.
Parent | (inherited from Control )
PreferredSize | (inherited from Control )
Printing | Gets a read-only PrintingManager object used for printing a chart.
ProductName | (inherited from Control )
ProductVersion | (inherited from Control )
RecreatingHandle | (inherited from Control )
Region | (inherited from Control )
RenderingDpiX | Gets or sets the horizontal resolution of the Chart renderer. For internal use only.
RenderingDpiY | Gets or sets the ertical resolution of the Chart renderer. For internal use only.
Right | (inherited from Control )
RightToLeft | (inherited from Control )
Serializer | Gets a ChartSerializer object that is used for chart serialization.
Series | Gets a SeriesCollection object.
Site | (inherited from Control )
Size | Gets or sets the size of the Chart control.
SuppressExceptions | Gets or sets a flag that determines whether non-critical exceptions should be suppressed.
TabIndex | (inherited from Control )
TabStop | (inherited from Control )
Tag | (inherited from Control )
Text | (inherited from Control )
TextAntiAliasingQuality | Gets or sets the TextAntiAliasingQuality type to use when applying anti-aliasing to text.
Titles | Stores all Title objects used by the Chart control.
Top | (inherited from Control )
TopLevelControl | (inherited from Control )
UseWaitCursor | (inherited from Control )
Visible | (inherited from Control )
Width | (inherited from Control )
WindowTarget | (inherited from Control )
Top

Protected Properties

Name | Description
CanRaiseEvents | (inherited from Control )
CreateParams | (inherited from Control )
DefaultCursor | (inherited from Control )
DefaultImeMode | (inherited from Control )
DefaultMargin | (inherited from Control )
DefaultMaximumSize | (inherited from Control )
DefaultMinimumSize | (inherited from Control )
DefaultPadding | (inherited from Control )
DefaultSize | Overridden. Gets the default control size.
DesignMode | (inherited from Component )
DoubleBuffered | (inherited from Control )
Events | (inherited from Component )
FontHeight | (inherited from Control )
RenderRightToLeft | Obsolete. (inherited from Control )
ResizeRedraw | (inherited from Control )
ScaleChildren | (inherited from Control )
ShowFocusCues | (inherited from Control )
ShowKeyboardCues | (inherited from Control )
Top

Public Methods (see also Protected Methods )

Name | Description
AlignDataPointsByAxisLabel | Overloaded.
ApplyPaletteColors | Sets the automatically assigned series and data point colors, to allow programmatic access at run time.
BeginInit | Signals to the object that initialization is starting.
BeginInvoke | Overloaded. (inherited from Control )
BringToFront | (inherited from Control )
Contains | (inherited from Control )
CreateControl | (inherited from Control )
CreateGraphics | (inherited from Control )
CreateObjRef | (inherited from MarshalByRefObject )
DataBind | Data binds the Chart control to a data source.
DataBindCrossTable | Overloaded.
DataBindTable | Overloaded.
Dispose | Overloaded.
DoDragDrop | (inherited from Control )
DrawToBitmap | (inherited from Control )
EndInit | Signals to the Chart object that initialization is complete.
EndInvoke | (inherited from Control )
Equals | Overloaded. (inherited from Object )
FindForm | (inherited from Control )
Focus | (inherited from Control )
FromChildHandle | (inherited from Control )
FromHandle | (inherited from Control )
GetChartElementOutline | Returns the chart element outline.
GetChildAtPoint | Overloaded. (inherited from Control )
GetContainerControl | (inherited from Control )
GetHashCode | (inherited from Object )
GetLifetimeService | (inherited from MarshalByRefObject )
GetNextControl | (inherited from Control )
GetPreferredSize | (inherited from Control )
GetService | Returns the requested chart service.
GetType | (inherited from Object )
Hide | (inherited from Control )
HitTest | Overloaded. Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.
InitializeLifetimeService | (inherited from MarshalByRefObject )
Invalidate | Overloaded.
Invoke | Overloaded. (inherited from Control )
IsKeyLocked | (inherited from Control )
IsMnemonic | (inherited from Control )
LoadTemplate | Overloaded.
PerformLayout | Overloaded. (inherited from Control )
PointToClient | (inherited from Control )
PointToScreen | (inherited from Control )
PreProcessControlMessage | (inherited from Control )
PreProcessMessage | (inherited from Control )
RectangleToClient | (inherited from Control )
RectangleToScreen | (inherited from Control )
ReferenceEquals | (inherited from Object )
Refresh | Overridden. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAutoValues | Resets automatically calculated chart property values to "Auto".
ResetBackColor | (inherited from Control )
ResetBindings | (inherited from Control )
ResetCursor | (inherited from Control )
ResetFont | (inherited from Control )
ResetForeColor | (inherited from Control )
ResetImeMode | (inherited from Control )
ResetRightToLeft | (inherited from Control )
ResetText | (inherited from Control )
ResumeLayout | Overloaded. (inherited from Control )
SaveImage | Overloaded.
Scale | Overloaded. (inherited from Control )
Select | Overloaded. (inherited from Control )
SelectNextControl | (inherited from Control )
SendToBack | (inherited from Control )
SetBounds | Overloaded. (inherited from Control )
Show | (inherited from Control )
SuspendLayout | (inherited from Control )
ToString | (inherited from Component )
Update | (inherited from Control )
UpdateAnnotations | Updates the annotations in the Chart control.
UpdateCursor | Updates the cursor in the Chart control.
Top

Protected Methods

Name | Description
AccessibilityNotifyClients | Overloaded. (inherited from Control )
CreateAccessibilityInstance | Overridden. Overridden to return the custom AccessibleObject for the entire chart.
CreateControlsInstance | (inherited from Control )
CreateHandle | (inherited from Control )
DefWndProc | (inherited from Control )
DestroyHandle | (inherited from Control )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Component )
GetAccessibilityObjectById | (inherited from Control )
GetAutoSizeMode | (inherited from Control )
GetScaledBounds | (inherited from Control )
GetStyle | (inherited from Control )
GetTopLevel | (inherited from Control )
InitLayout | (inherited from Control )
InvokeGotFocus | (inherited from Control )
InvokeLostFocus | (inherited from Control )
InvokeOnClick | (inherited from Control )
InvokePaint | (inherited from Control )
InvokePaintBackground | (inherited from Control )
IsInputChar | (inherited from Control )
IsInputKey | (inherited from Control )
MemberwiseClone | Overloaded. (inherited from MarshalByRefObject )
NotifyInvalidate | (inherited from Control )
OnAutoSizeChanged | (inherited from Control )
OnBackColorChanged | (inherited from Control )
OnBackgroundImageChanged | (inherited from Control )
OnBackgroundImageLayoutChanged | (inherited from Control )
OnBindingContextChanged | (inherited from Control )
OnCausesValidationChanged | (inherited from Control )
OnChangeUICues | (inherited from Control )
OnClick | (inherited from Control )
OnClientSizeChanged | (inherited from Control )
OnContextMenuChanged | (inherited from Control )
OnContextMenuStripChanged | (inherited from Control )
OnControlAdded | (inherited from Control )
OnControlRemoved | (inherited from Control )
OnCreateControl | (inherited from Control )
OnCursorChanged | (inherited from Control )
OnCustomize | Occurs when all chart data is prepared to be customized before drawing.
OnCustomizeLegend | Occurs when all chart legend data is prepared to be customized before drawing.
OnDockChanged | (inherited from Control )
OnDoubleClick | Overridden. Occurs when the end-user double-clicks the mouse on the Chart control.
OnDragDrop | (inherited from Control )
OnDragEnter | (inherited from Control )
OnDragLeave | (inherited from Control )
OnDragOver | (inherited from Control )
OnEnabledChanged | (inherited from Control )
OnEnter | (inherited from Control )
OnFontChanged | (inherited from Control )
OnForeColorChanged | (inherited from Control )
OnFormatNumber | Converts a numeric value to a string.
OnGiveFeedback | (inherited from Control )
OnGotFocus | (inherited from Control )
OnHandleCreated | (inherited from Control )
OnHandleDestroyed | (inherited from Control )
OnHelpRequested | (inherited from Control )
OnImeModeChanged | (inherited from Control )
OnInvalidated | (inherited from Control )
OnKeyDown | (inherited from Control )
OnKeyPress | (inherited from Control )
OnKeyUp | (inherited from Control )
OnLayout | (inherited from Control )
OnLeave | (inherited from Control )
OnLocationChanged | Overridden. Occurs when the location of the Chart control is changed.
OnLostFocus | (inherited from Control )
OnMarginChanged | (inherited from Control )
OnMouseCaptureChanged | (inherited from Control )
OnMouseClick | (inherited from Control )
OnMouseDoubleClick | (inherited from Control )
OnMouseDown | Overridden. Occurs when the end-user presses the mouse button in the Chart control.
OnMouseEnter | (inherited from Control )
OnMouseHover | (inherited from Control )
OnMouseLeave | (inherited from Control )
OnMouseMove | Overridden. Occurs when the mouse is moved in the Chart control.
OnMouseUp | Overridden. Occurs when the user releases the mouse button in the Chart control.
OnMouseWheel | (inherited from Control )
OnMove | (inherited from Control )
OnNotifyMessage | (inherited from Control )
OnPaddingChanged | (inherited from Control )
OnPaint | Overridden. Occurs when painting starts in the Chart control.
OnPaintBackground | Overridden. Occurs when painting starts in the background of the Chart control.
OnParentBackColorChanged | (inherited from Control )
OnParentBackgroundImageChanged | (inherited from Control )
OnParentBindingContextChanged | (inherited from Control )
OnParentChanged | (inherited from Control )
OnParentCursorChanged | (inherited from Control )
OnParentEnabledChanged | (inherited from Control )
OnParentFontChanged | (inherited from Control )
OnParentForeColorChanged | (inherited from Control )
OnParentRightToLeftChanged | (inherited from Control )
OnParentVisibleChanged | (inherited from Control )
OnPostPaint | Occurs when the chart element must be drawn.
OnPrePaint | Occurs when the chart element background must be drawn.
OnPreviewKeyDown | (inherited from Control )
OnPrint | (inherited from Control )
OnQueryContinueDrag | (inherited from Control )
OnRegionChanged | (inherited from Control )
OnResize | Overridden. Occurs when the Chart control is resized.
OnRightToLeftChanged | (inherited from Control )
OnSizeChanged | (inherited from Control )
OnStyleChanged | (inherited from Control )
OnSystemColorsChanged | Overridden.
OnTabIndexChanged | (inherited from Control )
OnTabStopChanged | (inherited from Control )
OnTextChanged | (inherited from Control )
OnValidated | (inherited from Control )
OnValidating | (inherited from Control )
OnVisibleChanged | (inherited from Control )
ProcessCmdKey | (inherited from Control )
ProcessDialogChar | (inherited from Control )
ProcessDialogKey | (inherited from Control )
ProcessKeyEventArgs | (inherited from Control )
ProcessKeyMessage | (inherited from Control )
ProcessKeyPreview | (inherited from Control )
ProcessMnemonic | (inherited from Control )
RaiseDragEvent | (inherited from Control )
RaiseKeyEvent | (inherited from Control )
RaiseMouseEvent | (inherited from Control )
RaisePaintEvent | (inherited from Control )
RecreateHandle | (inherited from Control )
ReflectMessage | (inherited from Control )
ResetMouseEventArgs | (inherited from Control )
RtlTranslateAlignment | Overloaded. (inherited from Control )
RtlTranslateContent | (inherited from Control )
RtlTranslateHorizontal | (inherited from Control )
RtlTranslateLeftRight | (inherited from Control )
ScaleControl | (inherited from Control )
ScaleCore | (inherited from Control )
Select | Overloaded. (inherited from Control )
SetAutoSizeMode | (inherited from Control )
SetBoundsCore | (inherited from Control )
SetClientSizeCore | (inherited from Control )
SetStyle | (inherited from Control )
SetTopLevel | (inherited from Control )
SetVisibleCore | (inherited from Control )
SizeFromClientSize | (inherited from Control )
UpdateBounds | Overloaded. (inherited from Control )
UpdateStyles | (inherited from Control )
UpdateZOrder | (inherited from Control )
WndProc | (inherited from Control )
Top

Public Events

Name | Description
AnnotationPlaced | Occurs when the end-user places an annotation on the chart.
AnnotationPositionChanged | Occurs when the annotation position is changed.
AnnotationPositionChanging | Occurs when the annotation position is about to change.
AnnotationSelectionChanged | Occurs when a selection of the annotation is changed.
AnnotationTextChanged | Occurs when the annotation text is changed.
AutoSizeChanged | (inherited from Control )
AxisScrollBarClicked | Occurs when the axis scroll bar is clicked by the end-user.
AxisViewChanged | Called when the axis scale view position or size is changed.
AxisViewChanging | Occurs when the axis scale view position or size is about to change.
BackColorChanged | (inherited from Control )
BackgroundImageChanged | (inherited from Control )
BackgroundImageLayoutChanged | (inherited from Control )
BindingContextChanged | (inherited from Control )
CausesValidationChanged | (inherited from Control )
ChangeUICues | (inherited from Control )
Click | (inherited from Control )
ClientSizeChanged | (inherited from Control )
ContextMenuChanged | (inherited from Control )
ContextMenuStripChanged | (inherited from Control )
ControlAdded | (inherited from Control )
ControlRemoved | (inherited from Control )
CursorChanged | (inherited from Control )
CursorPositionChanged | Occurs when the cursor position is changed.
CursorPositionChanging | Occurs when the cursor position is about to change.
Customize | Occurs just before the chart image is drawn. Use this event to customize the chart picture.
CustomizeLegend | Occurs when the chart legend must be customized.
Disposed | (inherited from Component )
DockChanged | (inherited from Control )
DoubleClick | (inherited from Control )
DragDrop | (inherited from Control )
DragEnter | (inherited from Control )
DragLeave | (inherited from Control )
DragOver | (inherited from Control )
EnabledChanged | (inherited from Control )
Enter | (inherited from Control )
FontChanged | (inherited from Control )
ForeColorChanged | (inherited from Control )
FormatNumber | Occurs when a numeric value has to be converted to a string.
GetToolTipText | Occurs before showing the tooltip to get the tooltip text.
GiveFeedback | (inherited from Control )
GotFocus | (inherited from Control )
HandleCreated | (inherited from Control )
HandleDestroyed | (inherited from Control )
HelpRequested | (inherited from Control )
ImeModeChanged | (inherited from Control )
Invalidated | (inherited from Control )
KeyDown | (inherited from Control )
KeyPress | (inherited from Control )
KeyUp | (inherited from Control )
Layout | (inherited from Control )
Leave | (inherited from Control )
LocationChanged | (inherited from Control )
LostFocus | (inherited from Control )
MarginChanged | (inherited from Control )
MouseCaptureChanged | (inherited from Control )
MouseClick | (inherited from Control )
MouseDoubleClick | (inherited from Control )
MouseDown | (inherited from Control )
MouseEnter | (inherited from Control )
MouseHover | (inherited from Control )
MouseLeave | (inherited from Control )
MouseMove | (inherited from Control )
MouseUp | (inherited from Control )
MouseWheel | (inherited from Control )
Move | (inherited from Control )
PaddingChanged | (inherited from Control )
Paint | (inherited from Control )
ParentChanged | (inherited from Control )
PostPaint | Occurs when the chart element is painted.
PrePaint | Occurs when the chart element background is painted.
PreviewKeyDown | (inherited from Control )
QueryAccessibilityHelp | (inherited from Control )
QueryContinueDrag | (inherited from Control )
RegionChanged | (inherited from Control )
Resize | (inherited from Control )
RightToLeftChanged | (inherited from Control )
SelectionRangeChanged | Occurs when the selection start position or end position is changed.
SelectionRangeChanging | Occurs when the selection start or end position is about to change.
SizeChanged | (inherited from Control )
StyleChanged | (inherited from Control )
SystemColorsChanged | (inherited from Control )
TabIndexChanged | (inherited from Control )
TabStopChanged | (inherited from Control )
TextChanged | (inherited from Control )
Validated | (inherited from Control )
Validating | (inherited from Control )
VisibleChanged | (inherited from Control )
Top

Explicit Interface Implementations

Name | Description
System.Windows.Forms.IDropTarget.OnDragDrop | (inherited from Control )
System.Windows.Forms.IDropTarget.OnDragEnter | (inherited from Control )
System.Windows.Forms.IDropTarget.OnDragLeave | (inherited from Control )
System.Windows.Forms.IDropTarget.OnDragOver | (inherited from Control )
Top

See Also

Reference

Chart Class


Chart Constructor

Chart Constructor |
 | See Also

Initializes a new instance of the Chart class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Chart ()
public:
Chart ()
public Chart ()
public function Chart ()

Remarks

You can use this constructor to create a new instance of the Chart class at run time.

However, for simplicity, it is recommended that you create a Chart instance at design time.

This is the root object of the Chart control.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart Methods

Chart Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
AlignDataPointsByAxisLabel | Overloaded.
ApplyPaletteColors | Sets the automatically assigned series and data point colors, to allow programmatic access at run time.
BeginInit | Signals to the object that initialization is starting.
BeginInvoke | Overloaded. (inherited from Control )
BringToFront | (inherited from Control )
Contains | (inherited from Control )
CreateControl | (inherited from Control )
CreateGraphics | (inherited from Control )
CreateObjRef | (inherited from MarshalByRefObject )
DataBind | Data binds the Chart control to a data source.
DataBindCrossTable | Overloaded.
DataBindTable | Overloaded.
Dispose | Overloaded.
DoDragDrop | (inherited from Control )
DrawToBitmap | (inherited from Control )
EndInit | Signals to the Chart object that initialization is complete.
EndInvoke | (inherited from Control )
Equals | Overloaded. (inherited from Object )
FindForm | (inherited from Control )
Focus | (inherited from Control )
FromChildHandle | (inherited from Control )
FromHandle | (inherited from Control )
GetChartElementOutline | Returns the chart element outline.
GetChildAtPoint | Overloaded. (inherited from Control )
GetContainerControl | (inherited from Control )
GetHashCode | (inherited from Object )
GetLifetimeService | (inherited from MarshalByRefObject )
GetNextControl | (inherited from Control )
GetPreferredSize | (inherited from Control )
GetService | Returns the requested chart service.
GetType | (inherited from Object )
Hide | (inherited from Control )
HitTest | Overloaded. Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.
InitializeLifetimeService | (inherited from MarshalByRefObject )
Invalidate | Overloaded.
Invoke | Overloaded. (inherited from Control )
IsKeyLocked | (inherited from Control )
IsMnemonic | (inherited from Control )
LoadTemplate | Overloaded.
PerformLayout | Overloaded. (inherited from Control )
PointToClient | (inherited from Control )
PointToScreen | (inherited from Control )
PreProcessControlMessage | (inherited from Control )
PreProcessMessage | (inherited from Control )
RectangleToClient | (inherited from Control )
RectangleToScreen | (inherited from Control )
ReferenceEquals | (inherited from Object )
Refresh | Overridden. Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetAutoValues | Resets automatically calculated chart property values to "Auto".
ResetBackColor | (inherited from Control )
ResetBindings | (inherited from Control )
ResetCursor | (inherited from Control )
ResetFont | (inherited from Control )
ResetForeColor | (inherited from Control )
ResetImeMode | (inherited from Control )
ResetRightToLeft | (inherited from Control )
ResetText | (inherited from Control )
ResumeLayout | Overloaded. (inherited from Control )
SaveImage | Overloaded.
Scale | Overloaded. (inherited from Control )
Select | Overloaded. (inherited from Control )
SelectNextControl | (inherited from Control )
SendToBack | (inherited from Control )
SetBounds | Overloaded. (inherited from Control )
Show | (inherited from Control )
SuspendLayout | (inherited from Control )
ToString | (inherited from Component )
Update | (inherited from Control )
UpdateAnnotations | Updates the annotations in the Chart control.
UpdateCursor | Updates the cursor in the Chart control.

Protected Methods

Name | Description
AccessibilityNotifyClients | Overloaded. (inherited from Control )
CreateAccessibilityInstance | Overridden. Overridden to return the custom AccessibleObject for the entire chart.
CreateControlsInstance | (inherited from Control )
CreateHandle | (inherited from Control )
DefWndProc | (inherited from Control )
DestroyHandle | (inherited from Control )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Component )
GetAccessibilityObjectById | (inherited from Control )
GetAutoSizeMode | (inherited from Control )
GetScaledBounds | (inherited from Control )
GetStyle | (inherited from Control )
GetTopLevel | (inherited from Control )
InitLayout | (inherited from Control )
InvokeGotFocus | (inherited from Control )
InvokeLostFocus | (inherited from Control )
InvokeOnClick | (inherited from Control )
InvokePaint | (inherited from Control )
InvokePaintBackground | (inherited from Control )
IsInputChar | (inherited from Control )
IsInputKey | (inherited from Control )
MemberwiseClone | Overloaded. (inherited from MarshalByRefObject )
NotifyInvalidate | (inherited from Control )
OnAutoSizeChanged | (inherited from Control )
OnBackColorChanged | (inherited from Control )
OnBackgroundImageChanged | (inherited from Control )
OnBackgroundImageLayoutChanged | (inherited from Control )
OnBindingContextChanged | (inherited from Control )
OnCausesValidationChanged | (inherited from Control )
OnChangeUICues | (inherited from Control )
OnClick | (inherited from Control )
OnClientSizeChanged | (inherited from Control )
OnContextMenuChanged | (inherited from Control )
OnContextMenuStripChanged | (inherited from Control )
OnControlAdded | (inherited from Control )
OnControlRemoved | (inherited from Control )
OnCreateControl | (inherited from Control )
OnCursorChanged | (inherited from Control )
OnCustomize | Occurs when all chart data is prepared to be customized before drawing.
OnCustomizeLegend | Occurs when all chart legend data is prepared to be customized before drawing.
OnDockChanged | (inherited from Control )
OnDoubleClick | Overridden. Occurs when the end-user double-clicks the mouse on the Chart control.
OnDragDrop | (inherited from Control )
OnDragEnter | (inherited from Control )
OnDragLeave | (inherited from Control )
OnDragOver | (inherited from Control )
OnEnabledChanged | (inherited from Control )
OnEnter | (inherited from Control )
OnFontChanged | (inherited from Control )
OnForeColorChanged | (inherited from Control )
OnFormatNumber | Converts a numeric value to a string.
OnGiveFeedback | (inherited from Control )
OnGotFocus | (inherited from Control )
OnHandleCreated | (inherited from Control )
OnHandleDestroyed | (inherited from Control )
OnHelpRequested | (inherited from Control )
OnImeModeChanged | (inherited from Control )
OnInvalidated | (inherited from Control )
OnKeyDown | (inherited from Control )
OnKeyPress | (inherited from Control )
OnKeyUp | (inherited from Control )
OnLayout | (inherited from Control )
OnLeave | (inherited from Control )
OnLocationChanged | Overridden. Occurs when the location of the Chart control is changed.
OnLostFocus | (inherited from Control )
OnMarginChanged | (inherited from Control )
OnMouseCaptureChanged | (inherited from Control )
OnMouseClick | (inherited from Control )
OnMouseDoubleClick | (inherited from Control )
OnMouseDown | Overridden. Occurs when the end-user presses the mouse button in the Chart control.
OnMouseEnter | (inherited from Control )
OnMouseHover | (inherited from Control )
OnMouseLeave | (inherited from Control )
OnMouseMove | Overridden. Occurs when the mouse is moved in the Chart control.
OnMouseUp | Overridden. Occurs when the user releases the mouse button in the Chart control.
OnMouseWheel | (inherited from Control )
OnMove | (inherited from Control )
OnNotifyMessage | (inherited from Control )
OnPaddingChanged | (inherited from Control )
OnPaint | Overridden. Occurs when painting starts in the Chart control.
OnPaintBackground | Overridden. Occurs when painting starts in the background of the Chart control.
OnParentBackColorChanged | (inherited from Control )
OnParentBackgroundImageChanged | (inherited from Control )
OnParentBindingContextChanged | (inherited from Control )
OnParentChanged | (inherited from Control )
OnParentCursorChanged | (inherited from Control )
OnParentEnabledChanged | (inherited from Control )
OnParentFontChanged | (inherited from Control )
OnParentForeColorChanged | (inherited from Control )
OnParentRightToLeftChanged | (inherited from Control )
OnParentVisibleChanged | (inherited from Control )
OnPostPaint | Occurs when the chart element must be drawn.
OnPrePaint | Occurs when the chart element background must be drawn.
OnPreviewKeyDown | (inherited from Control )
OnPrint | (inherited from Control )
OnQueryContinueDrag | (inherited from Control )
OnRegionChanged | (inherited from Control )
OnResize | Overridden. Occurs when the Chart control is resized.
OnRightToLeftChanged | (inherited from Control )
OnSizeChanged | (inherited from Control )
OnStyleChanged | (inherited from Control )
OnSystemColorsChanged | Overridden.
OnTabIndexChanged | (inherited from Control )
OnTabStopChanged | (inherited from Control )
OnTextChanged | (inherited from Control )
OnValidated | (inherited from Control )
OnValidating | (inherited from Control )
OnVisibleChanged | (inherited from Control )
ProcessCmdKey | (inherited from Control )
ProcessDialogChar | (inherited from Control )
ProcessDialogKey | (inherited from Control )
ProcessKeyEventArgs | (inherited from Control )
ProcessKeyMessage | (inherited from Control )
ProcessKeyPreview | (inherited from Control )
ProcessMnemonic | (inherited from Control )
RaiseDragEvent | (inherited from Control )
RaiseKeyEvent | (inherited from Control )
RaiseMouseEvent | (inherited from Control )
RaisePaintEvent | (inherited from Control )
RecreateHandle | (inherited from Control )
ReflectMessage | (inherited from Control )
ResetMouseEventArgs | (inherited from Control )
RtlTranslateAlignment | Overloaded. (inherited from Control )
RtlTranslateContent | (inherited from Control )
RtlTranslateHorizontal | (inherited from Control )
RtlTranslateLeftRight | (inherited from Control )
ScaleControl | (inherited from Control )
ScaleCore | (inherited from Control )
Select | Overloaded. (inherited from Control )
SetAutoSizeMode | (inherited from Control )
SetBoundsCore | (inherited from Control )
SetClientSizeCore | (inherited from Control )
SetStyle | (inherited from Control )
SetTopLevel | (inherited from Control )
SetVisibleCore | (inherited from Control )
SizeFromClientSize | (inherited from Control )
UpdateBounds | Overloaded. (inherited from Control )
UpdateStyles | (inherited from Control )
UpdateZOrder | (inherited from Control )
WndProc | (inherited from Control )

Explicit Interface Implementations

Name | Description
System.Windows.Forms.IDropTarget.OnDragDrop | (inherited from Control )
System.Windows.Forms.IDropTarget.OnDragEnter | (inherited from Control )
System.Windows.Forms.IDropTarget.OnDragLeave | (inherited from Control )
System.Windows.Forms.IDropTarget.OnDragOver | (inherited from Control )

See Also

Reference

Chart Class


Chart.AlignDataPointsByAxisLabel Method

Chart.AlignDataPointsByAxisLabel Method |
 | See Also

Overload List

Name | Description
Chart.AlignDataPointsByAxisLabel () | Aligns data points along the X axis using their axis labels. Applicable when multiple series are indexed and their X-values are strings.
Chart.AlignDataPointsByAxisLabel (PointSortOrder) | Aligns data points using their axis labels. All series in the chart are aligned, using the specified sort order.
Chart.AlignDataPointsByAxisLabel (String) | Aligns data points from different series along the X axis using their axis labels. The specified series in the chart are aligned using an ascending sort order.
Chart.AlignDataPointsByAxisLabel (String, PointSortOrder) | Aligns data points using their axis labels.

See Also

Reference

Chart Class
Chart Members


Chart.AlignDataPointsByAxisLabel Method ()

Chart.AlignDataPointsByAxisLabel Method () |
 | See Also

Aligns data points along the X axis using their axis labels. Applicable when multiple series are indexed and their X-values are strings.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel
public void AlignDataPointsByAxisLabel ()
public:
void AlignDataPointsByAxisLabel ()
public void AlignDataPointsByAxisLabel ()
public function AlignDataPointsByAxisLabel ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AlignDataPointsByAxisLabel Method (PointSortOrder)

Chart.AlignDataPointsByAxisLabel Method (PointSortOrder) |
 | See Also

Aligns data points using their axis labels. All series in the chart are aligned, using the specified sort order.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel ( _
    sortingOrder As PointSortOrder _
)
public void AlignDataPointsByAxisLabel (
    PointSortOrder sortingOrder
)
public:
void AlignDataPointsByAxisLabel (
    PointSortOrder sortingOrder
)
public void AlignDataPointsByAxisLabel (
    PointSortOrder sortingOrder
)
public function AlignDataPointsByAxisLabel (
    sortingOrder : PointSortOrder
)

Parameters

sortingOrder

A PointSortOrder object that indicates if ascending or descending sort order is used on axis labels, which in turn determines the order by which points that previously occupied the same axis space are displayed.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AlignDataPointsByAxisLabel Method (String)

Chart.AlignDataPointsByAxisLabel Method (String) |
 | See Also

Aligns data points from different series along the X axis using their axis labels. The specified series in the chart are aligned using an ascending sort order.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel ( _
    series As String _
)
public void AlignDataPointsByAxisLabel (
    string series
)
public:
void AlignDataPointsByAxisLabel (
    String^ series
)
public void AlignDataPointsByAxisLabel (
    String series
)
public function AlignDataPointsByAxisLabel (
    series : String
)

Parameters

series

A comma-separated list of series that will have their data points aligned to the X axis using the data point axis labels.

Remarks

This method is used to align data points from different series along the X axis using their axis labels, and is applicable when:

  • Multiple series are displayed and are indexed; that is, all data points have an XValue of 0, or the IsXValueIndexed property is true.

  • All data points have non-empty axis labels, which are unique to their Series. If they are not unique, an exception will be thrown.

This situation is very common when data-binding results in the creation of multiple series, and string values are used for X-axis values.

Two issues arise when multiple, indexed series are plotted, and the X-values are set using string values:

  • It cannot be guaranteed that data points from different series with the same string X-values will be plotted at the same index along the X axis.

  • Only the axis label for the data points in the first series will be displayed, even though data points from other series with the same index have axis labels too.

By default, points are plotted in the order in which they are stored in their series. To specify a sort order, use an AlignDataPointsByAxisLabel method overload that has a sortingOrder parameter.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AlignDataPointsByAxisLabel Method (String, PointSortOrder)

Chart.AlignDataPointsByAxisLabel Method (String, PointSortOrder) |
 | See Also

Aligns data points using their axis labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub AlignDataPointsByAxisLabel ( _
    series As String, _
    sortingOrder As PointSortOrder _
)
public void AlignDataPointsByAxisLabel (
    string series,
    PointSortOrder sortingOrder
)
public:
void AlignDataPointsByAxisLabel (
    String^ series,
    PointSortOrder sortingOrder
)
public void AlignDataPointsByAxisLabel (
    String series,
    PointSortOrder sortingOrder
)
public function AlignDataPointsByAxisLabel (
    series : String,
    sortingOrder : PointSortOrder
)

Parameters

series

A comma-separated list of series that should be aligned by axis label.

sortingOrder

A PointSortOrder enumeration value that determines if ascending or descending sort order is used on axis labels, which in turn determines the order by which points that previously occupied the same axis space are displayed.

Remarks

This method is used to align data points from different series along the X axis using their axis labels, and is applicable when:

  • Multiple series are displayed and are indexed; that is, all data points have an XValue of 0, or the IsXValueIndexed property is true.

  • All data points have non-empty axis labels, which are unique to their Series. If they are not unique, an exception will be thrown.

This situation is very common when data-binding results in the creation of multiple series, and string values are used for X-axis values.

Two issues arise when multiple, indexed series are plotted, and the X-values are set using string values:

  • It cannot be guaranteed that data points from different series with the same string X-values will be plotted at the same index along the X axis.

  • Only the axis label for the data points in the first series will be displayed, even though data points from other series with the same index have axis labels too.

By default, points are plotted in the order in which they are stored in their series. To specify a sort order, use an AlignDataPointsByAxisLabel method overload that has a sortingOrder parameter.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.ApplyPaletteColors Method

Chart.ApplyPaletteColors Method |
 | See Also

Sets the automatically assigned series and data point colors, to allow programmatic access at run time.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub ApplyPaletteColors
public void ApplyPaletteColors ()
public:
void ApplyPaletteColors ()
public void ApplyPaletteColors ()
public function ApplyPaletteColors ()

Remarks

When the Chart colors are automatically assigned at run time, there is no way to know what the colors will be prior to the time when the chart rendered; the Color property of an automatically assigned value will return Empty at this time.

If you call the ApplyPaletteColors method, the colors for the series and the data points will be set, which allows for programmatic access.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BeginInit Method

Chart.BeginInit Method |
 | See Also

Signals to the object that initialization is starting.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub BeginInit
public void BeginInit ()
public:
virtual void BeginInit () sealed
public final void BeginInit ()
public final function BeginInit ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.CreateAccessibilityInstance Method

Chart.CreateAccessibilityInstance Method |
 | See Also

Overridden to return the custom AccessibleObject for the entire chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Function CreateAccessibilityInstance As AccessibleObject
protected override AccessibleObject CreateAccessibilityInstance ()
protected:
virtual AccessibleObject^ CreateAccessibilityInstance () override
protected AccessibleObject CreateAccessibilityInstance ()
protected override function CreateAccessibilityInstance () : AccessibleObject

Return Value

The AccessibleObject for the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataBind Method

Chart.DataBind Method |
 | See Also

Data binds the Chart control to a data source.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub DataBind
public void DataBind ()
public:
void DataBind ()
public void DataBind ()
public function DataBind ()

Remarks

This method will bind the Chart control to the specified data source.

In cases where a data source is set to a chart and no other data operations are required, the DataBind method does not have to be explicitly called. In these cases, the Chart itself will data bind to the data source prior to being rendered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataBindCrossTable Method

Chart.DataBindCrossTable Method |
 | See Also

Overload List

Name | Description
Chart.DataBindCrossTable (IEnumerable, String, String, String, String) | Data binds a chart to the table, with one series created per unique value in a given column.
Chart.DataBindCrossTable (IEnumerable, String, String, String, String, PointSortOrder) | Data binds a chart to the table, with one series created per unique value in a given column.

See Also

Reference

Chart Class
Chart Members


Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String)

Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String) |
 | See Also

Data binds a chart to the table, with one series created per unique value in a given column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub DataBindCrossTable ( _
    dataSource As IEnumerable, _
    seriesGroupByField As String, _
    xField As String, _
    yFields As String, _
    otherFields As String _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void DataBindCrossTable (
    IEnumerable dataSource,
    string seriesGroupByField,
    string xField,
    string yFields,
    string otherFields
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void DataBindCrossTable (
    IEnumerable^ dataSource,
    String^ seriesGroupByField,
    String^ xField,
    String^ yFields,
    String^ otherFields
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void DataBindCrossTable (
    IEnumerable dataSource,
    String seriesGroupByField,
    String xField,
    String yFields,
    String otherFields
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataBindCrossTable (
    dataSource : IEnumerable,
    seriesGroupByField : String,
    xField : String,
    yFields : String,
    otherFields : String
)

Parameters

dataSource

The data source.

seriesGroupByField

The name of the field used to group data into the series.

xField

Name of the field for X values.

yFields

A comma-separated list of name(s) of the field(s) for Y value(s).

otherFields

Other data point properties that can be bound.

Remarks

Series will be automatically added to the chart, depending on the number of unique values in the given seriesGroupByField column of the data source; in other words, the creation of series depends upon grouping of a column.

The data source can be a OleDbDataReader, SqlDataReader or a DataView object. Note that all collections that implement the IEnumerable interface can be used.

Other data point properties besides X and Y-values can be bound. The format is: PointProperty=Field[{Format}] [,PointProperty= Field[{Format}]]. For example:"Tooltip=Price{C1},Href=WebSiteName".

A list of these data point properties is as follows: P:System.Windows.Forms.DataVisualization.Charting.DataPoint.AxisLabel, ToolTip, Url, Label, LegendText, LegendToolTip and CustomProperties, which are the names of the custom properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String, PointSortOrder)

Chart.DataBindCrossTable Method (IEnumerable, String, String, String, String, PointSortOrder) |
 | See Also

Data binds a chart to the table, with one series created per unique value in a given column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub DataBindCrossTable ( _
    dataSource As IEnumerable, _
    seriesGroupByField As String, _
    xField As String, _
    yFields As String, _
    otherFields As String, _
    sortingOrder As PointSortOrder _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void DataBindCrossTable (
    IEnumerable dataSource,
    string seriesGroupByField,
    string xField,
    string yFields,
    string otherFields,
    PointSortOrder sortingOrder
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void DataBindCrossTable (
    IEnumerable^ dataSource,
    String^ seriesGroupByField,
    String^ xField,
    String^ yFields,
    String^ otherFields,
    PointSortOrder sortingOrder
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void DataBindCrossTable (
    IEnumerable dataSource,
    String seriesGroupByField,
    String xField,
    String yFields,
    String otherFields,
    PointSortOrder sortingOrder
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataBindCrossTable (
    dataSource : IEnumerable,
    seriesGroupByField : String,
    xField : String,
    yFields : String,
    otherFields : String,
    sortingOrder : PointSortOrder
)

Parameters

dataSource

The data source.

seriesGroupByField

The name of the field used to group data into the series.

xField

Name of the field for X values.

yFields

A comma-separated list of name(s) of the field(s) for Y value(s).

otherFields

Other data point properties that can be bound.

sortingOrder

Series will be sorted by group field values in the specified order.

Remarks

Series will be automatically added to the chart, depending on the number of unique values in the given seriesGroupByField column of the data source; in other words, the creation of series depends upon grouping of a column.

The data source can be a OleDbDataReader, SqlDataReader or a DataView object.

Note that all collections that implement the IEnumerable interface can be used.

Other data point properties besides X and Y-values can be bound. The format is: PointProperty=Field[{Format}] [,PointProperty= Field[{Format}]]. For example:"Tooltip=Price{C1},Href=WebSiteName".

A list of these data point properties is as follows: P:System.Windows.Forms.DataVisualization.Charting.DataPoint.AxisLabel, ToolTip, Url, Label, LegendText, LegendToolTip and CustomProperties, which are the names of the custom properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataBindTable Method

Chart.DataBindTable Method |
 | See Also

Overload List

Name | Description
Chart.DataBindTable (IEnumerable) | Automatically creates and binds series data to the specified data table.
Chart.DataBindTable (IEnumerable, String) | Automatically creates and binds series data to the specified data table, and optionally populates X-values.

See Also

Reference

Chart Class
Chart Members


Chart.DataBindTable Method (IEnumerable)

Chart.DataBindTable Method (IEnumerable) |
 | See Also

Automatically creates and binds series data to the specified data table.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub DataBindTable ( _
    dataSource As IEnumerable _
)
public void DataBindTable (
    IEnumerable dataSource
)
public:
void DataBindTable (
    IEnumerable^ dataSource
)
public void DataBindTable (
    IEnumerable dataSource
)
public function DataBindTable (
    dataSource : IEnumerable
)

Parameters

dataSource

The data source, which can be any IEnumerable object.

Remarks

Each column of the table becomes a Y-value for a series, with one series per column.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataBindTable Method (IEnumerable, String)

Chart.DataBindTable Method (IEnumerable, String) |
 | See Also

Automatically creates and binds series data to the specified data table, and optionally populates X-values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X is a cartesian coordinate and well understood")> _
Public Sub DataBindTable ( _
    dataSource As IEnumerable, _
    xField As String _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X is a cartesian coordinate and well understood")]
public void DataBindTable (
    IEnumerable dataSource,
    string xField
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X is a cartesian coordinate and well understood")]
public:
void DataBindTable (
    IEnumerable^ dataSource,
    String^ xField
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X is a cartesian coordinate and well understood") */
public void DataBindTable (
    IEnumerable dataSource,
    String xField
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X is a cartesian coordinate and well understood")
public function DataBindTable (
    dataSource : IEnumerable,
    xField : String
)

Parameters

dataSource

The data source, which can be any IEnumerable object.

xField

The name of the field used for the series X-values.

Remarks

Each column of the table becomes a Y-value for a series, with one series per column.

The series' X-value field can also be provided.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Dispose Method

Chart.Dispose Method |
 | See Also

Overload List

Name | Description
Chart.Dispose () | (inherited from Dispose )
Chart.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

Chart Class
Chart Members


Chart.Dispose Method (Boolean)

Chart.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.EndInit Method

Chart.EndInit Method |
 | See Also

Signals to the Chart object that initialization is complete.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub EndInit
public void EndInit ()
public:
virtual void EndInit () sealed
public final void EndInit ()
public final function EndInit ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.GetChartElementOutline Method

Chart.GetChartElementOutline Method |
 | See Also

Returns the chart element outline.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetChartElementOutline ( _
    element As Object, _
    elementType As ChartElementType _
) As ChartElementOutline
public ChartElementOutline GetChartElementOutline (
    Object element,
    ChartElementType elementType
)
public:
ChartElementOutline^ GetChartElementOutline (
    Object^ element,
    ChartElementType elementType
)
public ChartElementOutline GetChartElementOutline (
    Object element,
    ChartElementType elementType
)
public function GetChartElementOutline (
    element : Object,
    elementType : ChartElementType
) : ChartElementOutline

Parameters

element

The Chart object.

elementType

The type of the element.

Return Value

A ChartElementOutline object that contains:

  • An array of points in absolute coordinates that can be used as outline markers around this chart element.

  • A GraphicsPath object for drawing an outline around this chart element.

Remarks

If the chartElement is not part of the chart, or the elementType cannot be combined with chartElement, the result will contain an empty array of marker points. The marker points are sorted clockwise.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.GetService Method

Chart.GetService Method |
 | See Also

Returns the requested chart service.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetService ( _
    serviceType As Type _
) As Object
public Object GetService (
    Type serviceType
)
public:
Object^ GetService (
    Type^ serviceType
)
public Object GetService (
    Type serviceType
)
public function GetService (
    serviceType : Type
) : Object

Parameters

serviceType

The type of requested chart service.

Return Value

An Object that represents the service type, or null if the service cannot be found.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.HitTest Method

Chart.HitTest Method |
 | See Also

Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.

Remarks

Call this method to determine the chart element, if any, that is located at a specified point.

This method is often used in some mouse-related event—for example, OnMouseDown—to determine which chart element the end-user clicked. The X and Y mouse coordinates obtained from the event parameters are then used for the x and y parameter values of this method call.

The properties of the HitTestResult object that is returned can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Overload List

Name | Description
Chart.HitTest (Int32, Int32) | Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.
Chart.HitTest (Int32, Int32, Boolean) | Determines the chart element, if any, that is located at a point defined by given X and Y coordinates. Transparent elements can optionally be ignored.
Chart.HitTest (Int32, Int32, ChartElementType) | Determines if a chart element of a given type is located at a point defined by given X and Y coordinates.
Chart.HitTest (Int32, Int32, Boolean, ChartElementType[]) | Determines whether a chart element that is one of the specified types is located at a point defined by the given X and Y coordinates.

See Also

Reference

Chart Class
Chart Members


Chart.HitTest Method (Int32, Int32)

Chart.HitTest Method (Int32, Int32) |
 | See Also

Determines the chart element, if any, that is located at a point defined by the given X and Y coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function HitTest ( _
    x As Integer, _
    y As Integer _
) As HitTestResult
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public HitTestResult HitTest (
    int x,
    int y
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
HitTestResult^ HitTest (
    int x,
    int y
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public HitTestResult HitTest (
    int x,
    int y
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function HitTest (
    x : int,
    y : int
) : HitTestResult

Parameters

x

The X-coordinate value of the point the user clicked.

y

The Y-coordinate value of the point the user clicked.

Return Value

A HitTestResult object, which provides information concerning the chart element, if any, that is at the specified location.

Remarks

Call this method to determine the chart element, if any, which is located at a specified point.

The properties of the HitTestResult object that is returned can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.HitTest Method (Int32, Int32, Boolean)

Chart.HitTest Method (Int32, Int32, Boolean) |
 | See Also

Determines the chart element, if any, that is located at a point defined by given X and Y coordinates. Transparent elements can optionally be ignored.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function HitTest ( _
    x As Integer, _
    y As Integer, _
    ignoreTransparent As Boolean _
) As HitTestResult
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public HitTestResult HitTest (
    int x,
    int y,
    bool ignoreTransparent
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
HitTestResult^ HitTest (
    int x,
    int y,
    bool ignoreTransparent
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public HitTestResult HitTest (
    int x,
    int y,
    boolean ignoreTransparent
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function HitTest (
    x : int,
    y : int,
    ignoreTransparent : boolean
) : HitTestResult

Parameters

x

The X-coordinate value of the point the user clicked on.

y

The Y-coordinate value of the point the user clicked on.

ignoreTransparent

A flag that determines if transparent elements are ignored.

Return Value

A HitTestResult object, which provides information concerning the chart element, if any, that is at the specified location.

Remarks

Call this method to determine the chart element, if any, which is located at a specified point.

To ignore transparent elements, set the ignoreTransparent parameter to true.

The properties of the HitTestResult object that is returned can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.HitTest Method (Int32, Int32, ChartElementType)

Chart.HitTest Method (Int32, Int32, ChartElementType) |
 | See Also

Determines if a chart element of a given type is located at a point defined by given X and Y coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function HitTest ( _
    x As Integer, _
    y As Integer, _
    requestedElement As ChartElementType _
) As HitTestResult
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public HitTestResult HitTest (
    int x,
    int y,
    ChartElementType requestedElement
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
HitTestResult^ HitTest (
    int x,
    int y,
    ChartElementType requestedElement
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public HitTestResult HitTest (
    int x,
    int y,
    ChartElementType requestedElement
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function HitTest (
    x : int,
    y : int,
    requestedElement : ChartElementType
) : HitTestResult

Parameters

x

The X-coordinate value of the point the user clicked on.

y

The Y-coordinate value of the point the user clicked on.

requestedElement

A flag that determines the chart element type to be tested.

Return Value

A HitTestResult object, which provides information concerning the chart element, if any, that is at the specified location.

Remarks

Call this method to determine if a chart element of the given type is located at a specified point.

The properties of the HitTestResult object that is returned can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.HitTest Method (Int32, Int32, Boolean, ChartElementType[])

Chart.HitTest Method (Int32, Int32, Boolean, ChartElementType[]) |
 | See Also

Determines whether a chart element that is one of the specified types is located at a point defined by the given X and Y coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function HitTest ( _
    x As Integer, _
    y As Integer, _
    ignoreTransparent As Boolean, _
    ParamArray requestedElement As ChartElementType() _
) As HitTestResult()
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public HitTestResult[] HitTest (
    int x,
    int y,
    bool ignoreTransparent,
    params ChartElementType[] requestedElement
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
array<HitTestResult^>^ HitTest (
    int x,
    int y,
    bool ignoreTransparent,
    ... array<ChartElementType>^ requestedElement
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public HitTestResult[] HitTest (
    int x,
    int y,
    boolean ignoreTransparent,
    ChartElementType[] requestedElement
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function HitTest (
    x : int,
    y : int,
    ignoreTransparent : boolean,
    ... requestedElement : ChartElementType[]
) : HitTestResult[]

Parameters

x

The X-coordinate for the specified data point.

y

The Y-coordinate for the specified data point.

ignoreTransparent

A flag that indicates that transparent elements should be ignored.

requestedElement

An array of ChartElementType objects that specify the types to test for, in order to filter the result. If omitted, checking for element types will be ignored and all element types will be valid.

Return Value

An array of T:System.Windows.Forms.DataVisualization.Charting.HitTestResult objects that provides information about the chart element, if any, found at the specified location. The array contains at least one element, which can be Nothing. The objects in the result are sorted from the top to the bottom of different layers of control.

Remarks

Call this method to determine the gauge element, if any, which is located at a specified point. This method is often used in some mouse-related event, for example, OnMouseDown, to determine which gauge element the end-user clicked. The X and Y mouse coordinates obtained from the event parameters are then used for the X and Y parameter values of this method call.

The properties of the returned HitTestResult object can then be used to determine which chart element was clicked; the HitTestResult object also provides an instance of the actual object selected, if any.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Invalidate Method

Chart.Invalidate Method |
 | See Also

Overload List

Name | Description
Chart.Invalidate () | Invalidates the entire surface of the Chart and causes the Chart control to be redrawn.
Chart.Invalidate (Boolean) | (inherited from Invalidate )
Chart.Invalidate (Rectangle) | Invalidates the specified region of the Chart control.
Chart.Invalidate (Region) | (inherited from Invalidate )
Chart.Invalidate (Rectangle, Boolean) | (inherited from Invalidate )
Chart.Invalidate (Region, Boolean) | (inherited from Invalidate )

See Also

Reference

Chart Class
Chart Members


Chart.Invalidate Method ()

Chart.Invalidate Method () |
 | See Also

Invalidates the entire surface of the Chart and causes the Chart control to be redrawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Invalidate
public void Invalidate ()
public:
void Invalidate ()
public void Invalidate ()
public function Invalidate ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Invalidate Method (Rectangle)

Chart.Invalidate Method (Rectangle) |
 | See Also

Invalidates the specified region of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Invalidate ( _
    rectangle As Rectangle _
)
public void Invalidate (
    Rectangle rectangle
)
public:
void Invalidate (
    Rectangle rectangle
)
public void Invalidate (
    Rectangle rectangle
)
public function Invalidate (
    rectangle : Rectangle
)

Parameters

rectangle

A Rectangle object.

Remarks

This method adds the specified region to the Chart control's update region, which is the area that will be repainted at the next paint operation. This method also causes a paint message to be sent to the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.LoadTemplate Method

Chart.LoadTemplate Method |
 | See Also

Overload List

Name | Description
Chart.LoadTemplate (Stream) | Loads a template into the Chart control from an image stream.
Chart.LoadTemplate (String) | Loads a template with the specified filename from the disk.

See Also

Reference

Chart Class
Chart Members


Chart.LoadTemplate Method (Stream)

Chart.LoadTemplate Method (Stream) |
 | See Also

Loads a template into the Chart control from an image stream.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub LoadTemplate ( _
    stream As Stream _
)
public void LoadTemplate (
    Stream stream
)
public:
void LoadTemplate (
    Stream^ stream
)
public void LoadTemplate (
    Stream stream
)
public function LoadTemplate (
    stream : Stream
)

Parameters

stream

The stream to load from.

Remarks

Use this method if you want to load a template from a stream, such as a memory stream, file stream, and so forth.

Make sure to set the IsTemplateMode property to true before saving the template with the Save method.

If a loaded template has two data series, the appearance properties of the series are applied sequentially to the chart. In other words, the first template series appearance properties are assigned to the first series of the chart, the second template series appearance properties are applied to the second series of the chart, then the first template series is used again for the third series of the chart, and so on. The same holds true for chart areas, and any other collections that have appearance properties.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.LoadTemplate Method (String)

Chart.LoadTemplate Method (String) |
 | See Also

Loads a template with the specified filename from the disk.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub LoadTemplate ( _
    name As String _
)
public void LoadTemplate (
    string name
)
public:
void LoadTemplate (
    String^ name
)
public void LoadTemplate (
    String name
)
public function LoadTemplate (
    name : String
)

Parameters

name

The file name of the template to load. You must specify the full path of the template to be loaded from the disk.

Remarks

The name parameter must use a full path, for example, C:\MyPic.jpg. Note that you must also specify the file extension.

This method loads a template from disk that was saved using the Save method.

Make sure to set the IsTemplateMode property to true before saving the template with the Save method.

If a loaded template has two data series, the appearance properties of the series are applied sequentially to the chart. In other words, the first template series appearance properties are assigned to the first series of the chart, the second template series appearance properties are applied to the second series of the chart, then the first template series is used again for the third series of the chart, and so on. The same holds true for chart areas, and any other collections that have appearance properties.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnCustomize Method

Chart.OnCustomize Method |
 | See Also

Occurs when all chart data is prepared to be customized before drawing.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub OnCustomize
protected virtual void OnCustomize ()
protected:
virtual void OnCustomize ()
protected void OnCustomize ()
protected function OnCustomize ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnCustomizeLegend Method

Chart.OnCustomizeLegend Method |
 | See Also

Occurs when all chart legend data is prepared to be customized before drawing.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub OnCustomizeLegend ( _
    legendItems As LegendItemsCollection, _
    legendName As String _
)
protected virtual void OnCustomizeLegend (
    LegendItemsCollection legendItems,
    string legendName
)
protected:
virtual void OnCustomizeLegend (
    LegendItemsCollection^ legendItems,
    String^ legendName
)
protected void OnCustomizeLegend (
    LegendItemsCollection legendItems,
    String legendName
)
protected function OnCustomizeLegend (
    legendItems : LegendItemsCollection,
    legendName : String
)

Parameters

legendItems

A LegendItemsCollection object.

legendName

The name of the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnDoubleClick Method

Chart.OnDoubleClick Method |
 | See Also

Occurs when the end-user double-clicks the mouse on the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnDoubleClick ( _
    e As EventArgs _
)
protected override void OnDoubleClick (
    EventArgs e
)
protected:
virtual void OnDoubleClick (
    EventArgs^ e
) override
protected void OnDoubleClick (
    EventArgs e
)
protected override function OnDoubleClick (
    e : EventArgs
)

Parameters

e

An EventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnFormatNumber Method

Chart.OnFormatNumber Method |
 | See Also

Converts a numeric value to a string.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub OnFormatNumber ( _
    e As FormatNumberEventArgs _
)
protected virtual void OnFormatNumber (
    FormatNumberEventArgs e
)
protected:
virtual void OnFormatNumber (
    FormatNumberEventArgs^ e
)
protected void OnFormatNumber (
    FormatNumberEventArgs e
)
protected function OnFormatNumber (
    e : FormatNumberEventArgs
)

Parameters

e

A FormatNumberEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnLocationChanged Method

Chart.OnLocationChanged Method |
 | See Also

Occurs when the location of the Chart control is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnLocationChanged ( _
    e As EventArgs _
)
protected override void OnLocationChanged (
    EventArgs e
)
protected:
virtual void OnLocationChanged (
    EventArgs^ e
) override
protected void OnLocationChanged (
    EventArgs e
)
protected override function OnLocationChanged (
    e : EventArgs
)

Parameters

e

An EventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnMouseDown Method

Chart.OnMouseDown Method |
 | See Also

Occurs when the end-user presses the mouse button in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
protected override void OnMouseDown (
    MouseEventArgs e
)
protected:
virtual void OnMouseDown (
    MouseEventArgs^ e
) override
protected void OnMouseDown (
    MouseEventArgs e
)
protected override function OnMouseDown (
    e : MouseEventArgs
)

Parameters

e

A MouseEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnMouseMove Method

Chart.OnMouseMove Method |
 | See Also

Occurs when the mouse is moved in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
protected override void OnMouseMove (
    MouseEventArgs e
)
protected:
virtual void OnMouseMove (
    MouseEventArgs^ e
) override
protected void OnMouseMove (
    MouseEventArgs e
)
protected override function OnMouseMove (
    e : MouseEventArgs
)

Parameters

e

A MouseEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnMouseUp Method

Chart.OnMouseUp Method |
 | See Also

Occurs when the user releases the mouse button in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
protected override void OnMouseUp (
    MouseEventArgs e
)
protected:
virtual void OnMouseUp (
    MouseEventArgs^ e
) override
protected void OnMouseUp (
    MouseEventArgs e
)
protected override function OnMouseUp (
    e : MouseEventArgs
)

Parameters

e

A MouseEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnPaint Method

Chart.OnPaint Method |
 | See Also

Occurs when painting starts in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
protected override void OnPaint (
    PaintEventArgs e
)
protected:
virtual void OnPaint (
    PaintEventArgs^ e
) override
protected void OnPaint (
    PaintEventArgs e
)
protected override function OnPaint (
    e : PaintEventArgs
)

Parameters

e

A PaintEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnPaintBackground Method

Chart.OnPaintBackground Method |
 | See Also

Occurs when painting starts in the background of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnPaintBackground ( _
    pevent As PaintEventArgs _
)
protected override void OnPaintBackground (
    PaintEventArgs pevent
)
protected:
virtual void OnPaintBackground (
    PaintEventArgs^ pevent
) override
protected void OnPaintBackground (
    PaintEventArgs pevent
)
protected override function OnPaintBackground (
    pevent : PaintEventArgs
)

Parameters

pevent

A PaintEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnPostPaint Method

Chart.OnPostPaint Method |
 | See Also

Occurs when the chart element must be drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub OnPostPaint ( _
    e As ChartPaintEventArgs _
)
protected virtual void OnPostPaint (
    ChartPaintEventArgs e
)
protected:
virtual void OnPostPaint (
    ChartPaintEventArgs^ e
)
protected void OnPostPaint (
    ChartPaintEventArgs e
)
protected function OnPostPaint (
    e : ChartPaintEventArgs
)

Parameters

e

A ChartPaintEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnPrePaint Method

Chart.OnPrePaint Method |
 | See Also

Occurs when the chart element background must be drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub OnPrePaint ( _
    e As ChartPaintEventArgs _
)
protected virtual void OnPrePaint (
    ChartPaintEventArgs e
)
protected:
virtual void OnPrePaint (
    ChartPaintEventArgs^ e
)
protected void OnPrePaint (
    ChartPaintEventArgs e
)
protected function OnPrePaint (
    e : ChartPaintEventArgs
)

Parameters

e

A ChartPaintEventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnResize Method

Chart.OnResize Method |
 | See Also

Occurs when the Chart control is resized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
protected override void OnResize (
    EventArgs e
)
protected:
virtual void OnResize (
    EventArgs^ e
) override
protected void OnResize (
    EventArgs e
)
protected override function OnResize (
    e : EventArgs
)

Parameters

e

An EventArgs object that contains the event arguments.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.OnSystemColorsChanged Method

Chart.OnSystemColorsChanged Method |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub OnSystemColorsChanged ( _
    e As EventArgs _
)

protected override void OnSystemColorsChanged (
    EventArgs e
)

protected:
virtual void OnSystemColorsChanged (
    EventArgs^ e
) override

protected void OnSystemColorsChanged (
    EventArgs e
)

protected override function OnSystemColorsChanged (
    e : EventArgs
)

Parameters

e

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Refresh Method

Chart.Refresh Method |
 | See Also

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Sub Refresh
public override void Refresh ()
public:
virtual void Refresh () override
public void Refresh ()
public override function Refresh ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.ResetAutoValues Method

Chart.ResetAutoValues Method |
 | See Also

Resets automatically calculated chart property values to "Auto".

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub ResetAutoValues
public void ResetAutoValues ()
public:
void ResetAutoValues ()
public void ResetAutoValues ()
public function ResetAutoValues ()

Remarks

Several chart properties can be set to "Auto"—for example, Minimum; these properties are calculated prior to the chart being rendered. "Auto" is usually represented as a NaN value.

Call this method to reset these properties from their calculated value to "Auto" (NaN).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SaveImage Method

Chart.SaveImage Method |
 | See Also

Overload List

Name | Description
Chart.SaveImage (Stream, ChartImageFormat) | Saves the chart image to the specified stream.
Chart.SaveImage (Stream, ImageFormat) | Saves the image to the specifed stream.
Chart.SaveImage (String, ChartImageFormat) | Saves the chart image to the specified file.
Chart.SaveImage (String, ImageFormat) | Saves an image to the specified file.

See Also

Reference

Chart Class
Chart Members


Chart.SaveImage Method (Stream, ChartImageFormat)

Chart.SaveImage Method (Stream, ChartImageFormat) |
 | See Also

Saves the chart image to the specified stream.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageStream As Stream, _
    format As ChartImageFormat _
)
public void SaveImage (
    Stream imageStream,
    ChartImageFormat format
)
public:
void SaveImage (
    Stream^ imageStream,
    ChartImageFormat format
)
public void SaveImage (
    Stream imageStream,
    ChartImageFormat format
)
public function SaveImage (
    imageStream : Stream,
    format : ChartImageFormat
)

Parameters

imageStream

The image stream.

format

The chart image format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SaveImage Method (Stream, ImageFormat)

Chart.SaveImage Method (Stream, ImageFormat) |
 | See Also

Saves the image to the specifed stream.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageStream As Stream, _
    format As ImageFormat _
)
public void SaveImage (
    Stream imageStream,
    ImageFormat format
)
public:
void SaveImage (
    Stream^ imageStream,
    ImageFormat^ format
)
public void SaveImage (
    Stream imageStream,
    ImageFormat format
)
public function SaveImage (
    imageStream : Stream,
    format : ImageFormat
)

Parameters

imageStream

The image stream.

format

The image format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SaveImage Method (String, ChartImageFormat)

Chart.SaveImage Method (String, ChartImageFormat) |
 | See Also

Saves the chart image to the specified file.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageFileName As String, _
    format As ChartImageFormat _
)
public void SaveImage (
    string imageFileName,
    ChartImageFormat format
)
public:
void SaveImage (
    String^ imageFileName,
    ChartImageFormat format
)
public void SaveImage (
    String imageFileName,
    ChartImageFormat format
)
public function SaveImage (
    imageFileName : String,
    format : ChartImageFormat
)

Parameters

imageFileName

The image file name

format

The chart image format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SaveImage Method (String, ImageFormat)

Chart.SaveImage Method (String, ImageFormat) |
 | See Also

Saves an image to the specified file.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SaveImage ( _
    imageFileName As String, _
    format As ImageFormat _
)
public void SaveImage (
    string imageFileName,
    ImageFormat format
)
public:
void SaveImage (
    String^ imageFileName,
    ImageFormat^ format
)
public void SaveImage (
    String imageFileName,
    ImageFormat format
)
public function SaveImage (
    imageFileName : String,
    format : ImageFormat
)

Parameters

imageFileName

The image file name

format

The image format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.UpdateAnnotations Method

Chart.UpdateAnnotations Method |
 | See Also

Updates the annotations in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub UpdateAnnotations
public void UpdateAnnotations ()
public:
void UpdateAnnotations ()
public void UpdateAnnotations ()
public function UpdateAnnotations ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.UpdateCursor Method

Chart.UpdateCursor Method |
 | See Also

Updates the cursor in the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub UpdateCursor
public void UpdateCursor ()
public:
void UpdateCursor ()
public void UpdateCursor ()
public function UpdateCursor ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart Properties

Chart Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
AccessibilityObject | (inherited from Control )
AccessibleDefaultActionDescription | (inherited from Control )
AccessibleDescription | (inherited from Control )
AccessibleName | (inherited from Control )
AccessibleRole | (inherited from Control )
AllowDrop | (inherited from Control )
Anchor | (inherited from Control )
Annotations | Stores the chart annotations.
AntiAliasing | Gets or sets a value that determines whether anti-aliasing is used when text and graphics are drawn.
AutoScrollOffset | (inherited from Control )
AutoSize | (inherited from Control )
BackColor | Overridden. Gets or sets the background color of the Chart object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a Chart control. Also determines whether a gradient is used.
BackgroundImage | Overridden. The BackgroundImage property is not used. Use the BackImage property instead.
BackgroundImageLayout | (inherited from Control )
BackHatchStyle | Gets or sets the hatching style of the Chart control.
BackImage | Gets or sets the background image of the Chart control.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets the color of the Chart control that will be displayed as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the Chart control.
BackSecondaryColor | Gets or sets the secondary color of the chart background.
BindingContext | (inherited from Control )
BorderColor | For internal use only.
BorderDashStyle | Gets or sets the style of the border.
BorderlineColor | Gets or sets the color of the border line.
BorderlineDashStyle | Gets or sets the style of the border line.
BorderlineWidth | Gets or sets the width of the border line.
BorderSkin | Gets or sets a BorderSkin object, which provides border skin functionality for the Chart control.
BorderWidth | For internal use only.
Bottom | (inherited from Control )
Bounds | (inherited from Control )
BuildNumber | Gets the build number of the Chart control. This property is for internal use only.
CanFocus | (inherited from Control )
CanSelect | (inherited from Control )
Capture | (inherited from Control )
CausesValidation | (inherited from Control )
ChartAreas | Gets a read-only ChartAreaCollection object that is used to store ChartArea objects.
CheckForIllegalCrossThreadCalls | (inherited from Control )
ClientRectangle | (inherited from Control )
ClientSize | (inherited from Control )
CompanyName | (inherited from Control )
Container | (inherited from Component )
ContainsFocus | (inherited from Control )
ContextMenu | (inherited from Control )
ContextMenuStrip | (inherited from Control )
Controls | (inherited from Control )
Created | (inherited from Control )
Cursor | Overridden. Gets or sets the cursor that is displayed when the mouse pointer is held over the control.
DataBindings | (inherited from Control )
DataManipulator | Gets a DataManipulator object that provides methods and properties that handle data.
DataSource | Gets or sets the data source for the Chart object.
DefaultBackColor | (inherited from Control )
DefaultFont | (inherited from Control )
DefaultForeColor | (inherited from Control )
DisplayRectangle | (inherited from Control )
Disposing | (inherited from Control )
Dock | (inherited from Control )
Enabled | (inherited from Control )
Focused | (inherited from Control )
Font | For internal use only.
ForeColor | Overridden. Gets or sets the text color of the Chart control.
Handle | (inherited from Control )
HasChildren | (inherited from Control )
Height | (inherited from Control )
Images | Gets a NamedImagesCollection object that stores NamedImage objects for the chart.
ImeMode | (inherited from Control )
InvokeRequired | (inherited from Control )
IsAccessible | (inherited from Control )
IsDisposed | (inherited from Control )
IsHandleCreated | (inherited from Control )
IsMirrored | (inherited from Control )
IsSoftShadows | Gets or sets a flag that determines if a smooth gradient is applied when shadows are drawn.
LayoutEngine | (inherited from Control )
Left | (inherited from Control )
Legends | Stores all Legend objects used by the Chart control.
Location | (inherited from Control )
Margin | (inherited from Control )
MaximumSize | (inherited from Control )
MinimumSize | (inherited from Control )
ModifierKeys | (inherited from Control )
MouseButtons | (inherited from Control )
MousePosition | (inherited from Control )
Name | (inherited from Control )
Padding | (inherited from Control )
Palette | Gets or sets the palette for the Chart control.
PaletteCustomColors | Gets or sets an array of custom palette colors.
Parent | (inherited from Control )
PreferredSize | (inherited from Control )
Printing | Gets a read-only PrintingManager object used for printing a chart.
ProductName | (inherited from Control )
ProductVersion | (inherited from Control )
RecreatingHandle | (inherited from Control )
Region | (inherited from Control )
RenderingDpiX | Gets or sets the horizontal resolution of the Chart renderer. For internal use only.
RenderingDpiY | Gets or sets the ertical resolution of the Chart renderer. For internal use only.
Right | (inherited from Control )
RightToLeft | (inherited from Control )
Serializer | Gets a ChartSerializer object that is used for chart serialization.
Series | Gets a SeriesCollection object.
Site | (inherited from Control )
Size | Gets or sets the size of the Chart control.
SuppressExceptions | Gets or sets a flag that determines whether non-critical exceptions should be suppressed.
TabIndex | (inherited from Control )
TabStop | (inherited from Control )
Tag | (inherited from Control )
Text | (inherited from Control )
TextAntiAliasingQuality | Gets or sets the TextAntiAliasingQuality type to use when applying anti-aliasing to text.
Titles | Stores all Title objects used by the Chart control.
Top | (inherited from Control )
TopLevelControl | (inherited from Control )
UseWaitCursor | (inherited from Control )
Visible | (inherited from Control )
Width | (inherited from Control )
WindowTarget | (inherited from Control )

Protected Properties

Name | Description
CanRaiseEvents | (inherited from Control )
CreateParams | (inherited from Control )
DefaultCursor | (inherited from Control )
DefaultImeMode | (inherited from Control )
DefaultMargin | (inherited from Control )
DefaultMaximumSize | (inherited from Control )
DefaultMinimumSize | (inherited from Control )
DefaultPadding | (inherited from Control )
DefaultSize | Overridden. Gets the default control size.
DesignMode | (inherited from Component )
DoubleBuffered | (inherited from Control )
Events | (inherited from Component )
FontHeight | (inherited from Control )
RenderRightToLeft | Obsolete. (inherited from Control )
ResizeRedraw | (inherited from Control )
ScaleChildren | (inherited from Control )
ShowFocusCues | (inherited from Control )
ShowKeyboardCues | (inherited from Control )

See Also

Reference

Chart Class


Chart.Annotations Property

Chart.Annotations Property |
 | See Also

Stores the chart annotations.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Annotations As AnnotationCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public AnnotationCollection Annotations { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property AnnotationCollection^ Annotations {
    AnnotationCollection^ get ();
}
/** @property */
public AnnotationCollection get_Annotations ()

public function get Annotations () : AnnotationCollection

Property Value

An AnnotationCollection object that is used to store chart annotations.

Remarks

All of the chart annotations are stored in this collection property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AntiAliasing Property

Chart.AntiAliasing Property |
 | See Also

Gets or sets a value that determines whether anti-aliasing is used when text and graphics are drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AntiAliasing As AntiAliasingStyles
public AntiAliasingStyles AntiAliasing { get; set; }
public:
property AntiAliasingStyles AntiAliasing {
    AntiAliasingStyles get ();
    void set (AntiAliasingStyles value);
}
/** @property */
public AntiAliasingStyles get_AntiAliasing ()

/** @property */
public void set_AntiAliasing (AntiAliasingStyles value)

public function get AntiAliasing () : AntiAliasingStyles

public function set AntiAliasing (value : AntiAliasingStyles)

Property Value

An AntiAliasingStyles enumeration value.

Remarks

Anti-aliasing smoothens out "jagged edges" by padding pixels with intermediate colors, and is especially effective for smoothing out edges for charts that are not drawn as rectangles. For example, anti-aliasing is very effective for line charts and pie charts, but is not as effective for bar and column charts.

Anti-aliasing can be applied to text and/or graphics primitives such as rectangles, circles, and so forth.

Note that anti-aliasing will affect performance.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackColor Property

Chart.BackColor Property |
 | See Also

Gets or sets the background color of the Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property BackColor As Color
public override Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value. The default color is System.Drawing.Color.White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value. Note that for the Chart object, the alpha component cannot be set to a value other than 255. This also means that, for the Chart object only, a Transparent value cannot be used.

The BackColor value will be the first color used if you are using gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the title. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackGradientStyle Property

Chart.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a Chart control. Also determines whether a gradient is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a Chart control will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

Set the primary color of the chart background with the BackColor property.

Set the secondary color of the chart background with the BackSecondaryColor property.

Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackgroundImage Property

Chart.BackgroundImage Property |
 | See Also

The BackgroundImage property is not used. Use the BackImage property instead.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides Property BackgroundImage As Image
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override Image BackgroundImage { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Image^ BackgroundImage {
    Image^ get () override;
    void set (Image^ value) override;
}
/** @property */
public Image get_BackgroundImage ()

/** @property */
public void set_BackgroundImage (Image value)

public override function get BackgroundImage () : Image

public override function set BackgroundImage (value : Image)

Property Value

An Image object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackHatchStyle Property

Chart.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackImage Property

Chart.BackImage Property |
 | See Also

Gets or sets the background image of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default value is an empty string.

Remarks

This property defines a path to a background image for a Chart legend, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image can originate from any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackImageAlignment Property

Chart.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment used for the Unscaled drawing mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for the Chart control; it is only applied when the BackImageWrapMode property is set to Unscaled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackImageTransparentColor Property

Chart.BackImageTransparentColor Property |
 | See Also

Gets or sets the color of the Chart control that will be displayed as transparent.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent when the chart image is drawn. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackImageWrapMode Property

Chart.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

This property determines how the image is displayed, for example, tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the chart. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the chart.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BackSecondaryColor Property

Chart.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the chart background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value. The default value is Empty.

Remarks

The BackSecondaryColor property determines the secondary background color of many Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the chart.

To use gradient colors for the background of a chart:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderColor Property

Chart.BorderColor Property |
 | See Also

For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property BorderColor As Color
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Color BorderColor { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value.

Remarks

This property is for internal use only. Use BorderlineColor instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderDashStyle Property

Chart.BorderDashStyle Property |
 | See Also

Gets or sets the style of the border.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property BorderDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ChartDashStyle BorderDashStyle { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderlineColor Property

Chart.BorderlineColor Property |
 | See Also

Gets or sets the color of the border line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderlineColor As Color
public Color BorderlineColor { get; set; }
public:
property Color BorderlineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderlineColor ()

/** @property */
public void set_BorderlineColor (Color value)

public function get BorderlineColor () : Color

public function set BorderlineColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderlineDashStyle Property

Chart.BorderlineDashStyle Property |
 | See Also

Gets or sets the style of the border line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderlineDashStyle As ChartDashStyle
public ChartDashStyle BorderlineDashStyle { get; set; }
public:
property ChartDashStyle BorderlineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderlineDashStyle ()

/** @property */
public void set_BorderlineDashStyle (ChartDashStyle value)

public function get BorderlineDashStyle () : ChartDashStyle

public function set BorderlineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderlineWidth Property

Chart.BorderlineWidth Property |
 | See Also

Gets or sets the width of the border line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderlineWidth As Integer
public int BorderlineWidth { get; set; }
public:
property int BorderlineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderlineWidth ()

/** @property */
public void set_BorderlineWidth (int value)

public function get BorderlineWidth () : int

public function set BorderlineWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderSkin Property

Chart.BorderSkin Property |
 | See Also

Gets or sets a BorderSkin object, which provides border skin functionality for the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property BorderSkin As BorderSkin
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public BorderSkin BorderSkin { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property BorderSkin^ BorderSkin {
    BorderSkin^ get ();
    void set (BorderSkin^ value);
}
/** @property */
public BorderSkin get_BorderSkin ()

/** @property */
public void set_BorderSkin (BorderSkin value)

public function get BorderSkin () : BorderSkin

public function set BorderSkin (value : BorderSkin)

Property Value

A BorderSkin object.

Remarks

Use this property to specify a border skin for the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BorderWidth Property

Chart.BorderWidth Property |
 | See Also

For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property BorderWidth As Integer
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int BorderWidth { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the chart.

Remarks

This property is for internal use only. Use BorderlineWidth instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.BuildNumber Property

Chart.BuildNumber Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the build number of the Chart control. This property is for internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property BuildNumber As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string BuildNumber { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property String^ BuildNumber {
    String^ get ();
}
/** @property */
public String get_BuildNumber ()

public function get BuildNumber () : String

Remarks

This property is for internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.ChartAreas Property

Chart.ChartAreas Property |
 | See Also

Gets a read-only ChartAreaCollection object that is used to store ChartArea objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property ChartAreas As ChartAreaCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ChartAreaCollection ChartAreas { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ChartAreaCollection^ ChartAreas {
    ChartAreaCollection^ get ();
}
/** @property */
public ChartAreaCollection get_ChartAreas ()

public function get ChartAreas () : ChartAreaCollection

Property Value

A ChartAreaCollection object.

Remarks

This collection property lets you access the ChartAreaCollection object, which stores ChartArea objects and also provides methods and properties used to manipulate the collection.

ChartArea objects are used to plot one or more charts.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Cursor Property

Chart.Cursor Property |
 | See Also

Gets or sets the cursor that is displayed when the mouse pointer is held over the control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Cursor As Cursor
public override Cursor Cursor { get; set; }
public:
virtual property Cursor^ Cursor {
    Cursor^ get () override;
    void set (Cursor^ value) override;
}
/** @property */
public Cursor get_Cursor ()

/** @property */
public void set_Cursor (Cursor value)

public override function get Cursor () : Cursor

public override function set Cursor (value : Cursor)

Property Value

A Cursor object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataManipulator Property

Chart.DataManipulator Property |
 | See Also

Gets a DataManipulator object that provides methods and properties that handle data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property DataManipulator As DataManipulator
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public DataManipulator DataManipulator { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property DataManipulator^ DataManipulator {
    DataManipulator^ get ();
}
/** @property */
public DataManipulator get_DataManipulator ()

public function get DataManipulator () : DataManipulator

Property Value

A DataManipulator object.

Remarks

Use this property at run-time to:

  • Copy Y-values.

  • Filter data.

  • Group data.

  • Replace missing data with empty points.

  • Export data to a DataSet object.

  • Sort data.

  • Apply a financial formula to data.

Refer to the DataManipulator class overview for further details.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DataSource Property

Chart.DataSource Property |
 | See Also

Gets or sets the data source for the Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<AttributeProviderAttribute(GetType(IListSource))> _
Public Property DataSource As Object
[AttributeProviderAttribute(typeof(IListSource))]
public Object DataSource { get; set; }
[AttributeProviderAttribute(typeof(IListSource))]
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_DataSource ()

/** @property */
public void set_DataSource (Object value)

public function get DataSource () : Object

public function set DataSource (value : Object)

Property Value

An Object that represents the data source for the Chart object.

Remarks

The data points in a series can be bound to a data source at any time using the DataSource property.

To force the chart to bind to the data source, call the DataBind method.

The following is a list of objects that you can use as the data source:

  • DataView

  • Data readers (SQL, OleDB)

  • DataSet

  • DataTable

  • Binding Source

  • IDataSource

  • Arrays

  • Lists

  • All Enumerable objects

  • SqlCommand / OleDbCommand (DataSource data-binding only)

  • SqlDataAdapter / OleDbDataAdapter (DataSource data-binding only)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.DefaultSize Property

Chart.DefaultSize Property |
 | See Also

Gets the default control size.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides ReadOnly Property DefaultSize As Size
protected override Size DefaultSize { get; }
protected:
virtual property Size DefaultSize {
    Size get () override;
}
/** @property */
protected Size get_DefaultSize ()

protected override function get DefaultSize () : Size

Property Value

A Size object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Font Property

Chart.Font Property |
 | See Also

For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property Font As Font
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Font Font { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.ForeColor Property

Chart.ForeColor Property |
 | See Also

Gets or sets the text color of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to this class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Images Property

Chart.Images Property |
 | See Also

Gets a NamedImagesCollection object that stores NamedImage objects for the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Images As NamedImagesCollection
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public NamedImagesCollection Images { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property NamedImagesCollection^ Images {
    NamedImagesCollection^ get ();
}
/** @property */
public NamedImagesCollection get_Images ()

public function get Images () : NamedImagesCollection

Property Value

A NamedImagesCollection object.

Remarks

Use this property to add NamedImage objects to and remove NamedImage objects from the NamedImagesCollection object of the Chart. This collection property is available at run time only.

An image—that is, an object derived from type Image, such as Bitmap, that is created dynamically—can be stored in this collection, and then assigned at a later time to any image-related Chart property, such as BackImage.

When you assign a NamedImage object to an image-related property in the Chart class, use the name of the NamedImage object for the string value of the image-related property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.IsSoftShadows Property

Chart.IsSoftShadows Property |
 | See Also

Gets or sets a flag that determines if a smooth gradient is applied when shadows are drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsSoftShadows As Boolean
public bool IsSoftShadows { get; set; }
public:
property bool IsSoftShadows {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSoftShadows ()

/** @property */
public void set_IsSoftShadows (boolean value)

public function get IsSoftShadows () : boolean

public function set IsSoftShadows (value : boolean)

Property Value

True if shadows are drawn using smoothing, false if they are not. The default value is true.

Remarks

If the value of the ShadowOffset property for a series, data point, chart area or legend is nonzero, a shadow will be applied using a color set by their ShadowColor property.

If the value of the IsSoftShadows property is true, a smooth gradient will be applied to the shadow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Legends Property

Chart.Legends Property |
 | See Also

Stores all Legend objects used by the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Legends As LegendCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LegendCollection Legends { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property LegendCollection^ Legends {
    LegendCollection^ get ();
}
/** @property */
public LegendCollection get_Legends ()

public function get Legends () : LegendCollection

Property Value

A LegendCollection object.

Remarks

This collection property stores all Legend objects used by the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Palette Property

Chart.Palette Property |
 | See Also

Gets or sets the palette for the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Palette As ChartColorPalette
public ChartColorPalette Palette { get; set; }
public:
property ChartColorPalette Palette {
    ChartColorPalette get ();
    void set (ChartColorPalette value);
}
/** @property */
public ChartColorPalette get_Palette ()

/** @property */
public void set_Palette (ChartColorPalette value)

public function get Palette () : ChartColorPalette

public function set Palette (value : ChartColorPalette)

Property Value

A ChartColorPalette enumeration value that determines the palette to be used.

Remarks

A palette is used to automatically assign colors to data elements if both of the following conditions have been met:

  • the data points themselves do not have colors assigned to them.

  • the data series that the data points belong to also does not have an assigned color.

If no series or data point colors are explicitly specified, the colors used depend on the chart type and the Chart object's palette or the palette of an associated series, if one is specified.

Note:
If the Palette property for both the Chart and Series objects is set to None, and no color is assigned to the relevant data series or data points, the data points will not be drawn, and will be displayed as "empty" areas.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.PaletteCustomColors Property

Chart.PaletteCustomColors Property |
 | See Also

Gets or sets an array of custom palette colors.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property PaletteCustomColors As Color()
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Color[] PaletteCustomColors { get; set; }
[SuppressMessageAttribute(L"Microsoft.Performance", L"CA1819:PropertiesShouldNotReturnArrays")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property array<Color>^ PaletteCustomColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}
/** @property */
public Color[] get_PaletteCustomColors ()

/** @property */
public void set_PaletteCustomColors (Color[] value)

public function get PaletteCustomColors () : Color[]

public function set PaletteCustomColors (value : Color[])

Property Value

An array of Color objects that represent the set of colors used for series on the chart.

Remarks

If you need more than 16 colors or you want to apply your own colors to the chart, you must define a custom palette. A custom palette let you add your own colors in the order you want them to appear on the chart. This type of palette is especially helpful if the number of series in your chart is unknown at design time.

This property has no effect when the Palette property is not set to

None.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Printing Property

Chart.Printing Property |
 | See Also

Gets a read-only PrintingManager object used for printing a chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property Printing As PrintingManager
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public PrintingManager Printing { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property PrintingManager^ Printing {
    PrintingManager^ get ();
}
/** @property */
public PrintingManager get_Printing ()

public function get Printing () : PrintingManager

Property Value

A PrintingManager object.

Remarks

When a chart is printed, all chart elements except scrollbars will be printed.

The PrintingManager object contains the following methods, which are used for basic printing operations:

PageSetup: Displays a Page Setup dialog, which allows the end-user to select paper size, paper source, page orientation, and so forth.

PrintPreview: Displays a Print Preview dialog, which allows the end-user to zoom, print the chart, and so forth.

Print: Prints the Chart; the Print dialog can optionally be displayed prior to printing.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.RenderingDpiX Property

Chart.RenderingDpiX Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets or sets the horizontal resolution of the Chart renderer. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property RenderingDpiX As Double
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public double RenderingDpiX { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property double RenderingDpiX {
    double get ();
    void set (double value);
}
/** @property */
public double get_RenderingDpiX ()

/** @property */
public void set_RenderingDpiX (double value)

public function get RenderingDpiX () : double

public function set RenderingDpiX (value : double)

Property Value

A double value.

Remarks

This property is for the internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.RenderingDpiY Property

Chart.RenderingDpiY Property |
 | See Also

Gets or sets the ertical resolution of the Chart renderer. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property RenderingDpiY As Double
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public double RenderingDpiY { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property double RenderingDpiY {
    double get ();
    void set (double value);
}
/** @property */
public double get_RenderingDpiY ()

/** @property */
public void set_RenderingDpiY (double value)

public function get RenderingDpiY () : double

public function set RenderingDpiY (value : double)

Property Value

A double value.

Remarks

This property is for the internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Serializer Property

Chart.Serializer Property |
 | See Also

Gets a ChartSerializer object that is used for chart serialization.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Serializer As ChartSerializer
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ChartSerializer Serializer { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property ChartSerializer^ Serializer {
    ChartSerializer^ get ();
}
/** @property */
public ChartSerializer get_Serializer ()

public function get Serializer () : ChartSerializer

Property Value

A ChartSerializer object.

Remarks

Use this property at either design time or run time to serialize the chart.

For a detailed discussion of the ChartSerializer class, refer to the class overview.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Series Property

Chart.Series Property |
 | See Also

Gets a SeriesCollection object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Series As SeriesCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public SeriesCollection Series { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property SeriesCollection^ Series {
    SeriesCollection^ get ();
}
/** @property */
public SeriesCollection get_Series ()

public function get Series () : SeriesCollection

Property Value

A SeriesCollection object, which contains Series objects.

Remarks

This collection property allows you to access the SeriesCollection class, which stores Series objects and also provides methods and properties used to manipulate this collection.

Series objects store DataPoint objects, as well as data attributes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Size Property

Chart.Size Property |
 | See Also

Gets or sets the size of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Size As Size
public Size Size { get; set; }
public:
property Size Size {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_Size ()

/** @property */
public void set_Size (Size value)

public function get Size () : Size

public function set Size (value : Size)

Property Value

A Size object that represents the size of the control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SuppressExceptions Property

Chart.SuppressExceptions Property |
 | See Also

Gets or sets a flag that determines whether non-critical exceptions should be suppressed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SuppressExceptions As Boolean
public bool SuppressExceptions { get; set; }
public:
property bool SuppressExceptions {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_SuppressExceptions ()

/** @property */
public void set_SuppressExceptions (boolean value)

public function get SuppressExceptions () : boolean

public function set SuppressExceptions (value : boolean)

Property Value

True if non-critical exceptions should be suppressed, otherwise false. The default value is false.

Remarks

If you set this property to true, non-critical exceptions will be suppressed.

When the Chart control cannot properly plot the chart using the data and other settings provided, an exception will be thrown. Although displaying exceptions is useful during application testing, they should not be shown when the application is released.

Note:
Setting this property to true may hide serious issues in the user application source code. This setting could also cause a chart image to be generated that might misrepresent your data. It is highly recommended that this mode be only used in Release builds.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.TextAntiAliasingQuality Property

Chart.TextAntiAliasingQuality Property |
 | See Also

Gets or sets the TextAntiAliasingQuality type to use when applying anti-aliasing to text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextAntiAliasingQuality As TextAntiAliasingQuality
public TextAntiAliasingQuality TextAntiAliasingQuality { get; set; }
public:
property TextAntiAliasingQuality TextAntiAliasingQuality {
    TextAntiAliasingQuality get ();
    void set (TextAntiAliasingQuality value);
}
/** @property */
public TextAntiAliasingQuality get_TextAntiAliasingQuality ()

/** @property */
public void set_TextAntiAliasingQuality (TextAntiAliasingQuality value)

public function get TextAntiAliasingQuality () : TextAntiAliasingQuality

public function set TextAntiAliasingQuality (value : TextAntiAliasingQuality)

Property Value

A TextAntiAliasingQuality enumeration value. The default value is High.

Remarks

If the anti-aliasing is applied to text, the Chart control will use this property to determine the type of textual anti-aliasing to apply.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Titles Property

Chart.Titles Property |
 | See Also

Stores all Title objects used by the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Titles As TitleCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public TitleCollection Titles { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property TitleCollection^ Titles {
    TitleCollection^ get ();
}
/** @property */
public TitleCollection get_Titles ()

public function get Titles () : TitleCollection

Property Value

A TitleCollection object.

Remarks

The Titles property stores all Title objects used by the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart Events

Chart Events |
 | See Also

Public Events

Name | Description
AnnotationPlaced | Occurs when the end-user places an annotation on the chart.
AnnotationPositionChanged | Occurs when the annotation position is changed.
AnnotationPositionChanging | Occurs when the annotation position is about to change.
AnnotationSelectionChanged | Occurs when a selection of the annotation is changed.
AnnotationTextChanged | Occurs when the annotation text is changed.
AutoSizeChanged | (inherited from Control )
AxisScrollBarClicked | Occurs when the axis scroll bar is clicked by the end-user.
AxisViewChanged | Called when the axis scale view position or size is changed.
AxisViewChanging | Occurs when the axis scale view position or size is about to change.
BackColorChanged | (inherited from Control )
BackgroundImageChanged | (inherited from Control )
BackgroundImageLayoutChanged | (inherited from Control )
BindingContextChanged | (inherited from Control )
CausesValidationChanged | (inherited from Control )
ChangeUICues | (inherited from Control )
Click | (inherited from Control )
ClientSizeChanged | (inherited from Control )
ContextMenuChanged | (inherited from Control )
ContextMenuStripChanged | (inherited from Control )
ControlAdded | (inherited from Control )
ControlRemoved | (inherited from Control )
CursorChanged | (inherited from Control )
CursorPositionChanged | Occurs when the cursor position is changed.
CursorPositionChanging | Occurs when the cursor position is about to change.
Customize | Occurs just before the chart image is drawn. Use this event to customize the chart picture.
CustomizeLegend | Occurs when the chart legend must be customized.
Disposed | (inherited from Component )
DockChanged | (inherited from Control )
DoubleClick | (inherited from Control )
DragDrop | (inherited from Control )
DragEnter | (inherited from Control )
DragLeave | (inherited from Control )
DragOver | (inherited from Control )
EnabledChanged | (inherited from Control )
Enter | (inherited from Control )
FontChanged | (inherited from Control )
ForeColorChanged | (inherited from Control )
FormatNumber | Occurs when a numeric value has to be converted to a string.
GetToolTipText | Occurs before showing the tooltip to get the tooltip text.
GiveFeedback | (inherited from Control )
GotFocus | (inherited from Control )
HandleCreated | (inherited from Control )
HandleDestroyed | (inherited from Control )
HelpRequested | (inherited from Control )
ImeModeChanged | (inherited from Control )
Invalidated | (inherited from Control )
KeyDown | (inherited from Control )
KeyPress | (inherited from Control )
KeyUp | (inherited from Control )
Layout | (inherited from Control )
Leave | (inherited from Control )
LocationChanged | (inherited from Control )
LostFocus | (inherited from Control )
MarginChanged | (inherited from Control )
MouseCaptureChanged | (inherited from Control )
MouseClick | (inherited from Control )
MouseDoubleClick | (inherited from Control )
MouseDown | (inherited from Control )
MouseEnter | (inherited from Control )
MouseHover | (inherited from Control )
MouseLeave | (inherited from Control )
MouseMove | (inherited from Control )
MouseUp | (inherited from Control )
MouseWheel | (inherited from Control )
Move | (inherited from Control )
PaddingChanged | (inherited from Control )
Paint | (inherited from Control )
ParentChanged | (inherited from Control )
PostPaint | Occurs when the chart element is painted.
PrePaint | Occurs when the chart element background is painted.
PreviewKeyDown | (inherited from Control )
QueryAccessibilityHelp | (inherited from Control )
QueryContinueDrag | (inherited from Control )
RegionChanged | (inherited from Control )
Resize | (inherited from Control )
RightToLeftChanged | (inherited from Control )
SelectionRangeChanged | Occurs when the selection start position or end position is changed.
SelectionRangeChanging | Occurs when the selection start or end position is about to change.
SizeChanged | (inherited from Control )
StyleChanged | (inherited from Control )
SystemColorsChanged | (inherited from Control )
TabIndexChanged | (inherited from Control )
TabStopChanged | (inherited from Control )
TextChanged | (inherited from Control )
Validated | (inherited from Control )
Validating | (inherited from Control )
VisibleChanged | (inherited from Control )

See Also

Reference

Chart Class


Chart.AnnotationPlaced Event

Chart.AnnotationPlaced Event |
 | See Also

Occurs when the end-user places an annotation on the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AnnotationPlaced As EventHandler
public event EventHandler AnnotationPlaced
public:
event EventHandler^ AnnotationPlaced {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
/** @event */
public void add_AnnotationPlaced (EventHandler value)

/** @event */
public void remove_AnnotationPlaced (EventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AnnotationPositionChanged Event

Chart.AnnotationPositionChanged Event |
 | See Also

Occurs when the annotation position is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AnnotationPositionChanged As EventHandler
public event EventHandler AnnotationPositionChanged
public:
event EventHandler^ AnnotationPositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
/** @event */
public void add_AnnotationPositionChanged (EventHandler value)

/** @event */
public void remove_AnnotationPositionChanged (EventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AnnotationPositionChanging Event

Chart.AnnotationPositionChanging Event |
 | See Also

Occurs when the annotation position is about to change.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AnnotationPositionChanging As EventHandler(Of AnnotationPositionChangingEventArgs)
public event EventHandler<AnnotationPositionChangingEventArgs> AnnotationPositionChanging
public:
event EventHandler<AnnotationPositionChangingEventArgs^>^ AnnotationPositionChanging {
    void add (EventHandler<AnnotationPositionChangingEventArgs^>^ value);
    void remove (EventHandler<AnnotationPositionChangingEventArgs^>^ value);
}
/** @event */
public void add_AnnotationPositionChanging (EventHandler<AnnotationPositionChangingEventArgs> value)

/** @event */
public void remove_AnnotationPositionChanging (EventHandler<AnnotationPositionChangingEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AnnotationSelectionChanged Event

Chart.AnnotationSelectionChanged Event |
 | See Also

Occurs when a selection of the annotation is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AnnotationSelectionChanged As EventHandler
public event EventHandler AnnotationSelectionChanged
public:
event EventHandler^ AnnotationSelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
/** @event */
public void add_AnnotationSelectionChanged (EventHandler value)

/** @event */
public void remove_AnnotationSelectionChanged (EventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AnnotationTextChanged Event

Chart.AnnotationTextChanged Event |
 | See Also

Occurs when the annotation text is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AnnotationTextChanged As EventHandler
public event EventHandler AnnotationTextChanged
public:
event EventHandler^ AnnotationTextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
/** @event */
public void add_AnnotationTextChanged (EventHandler value)

/** @event */
public void remove_AnnotationTextChanged (EventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AxisScrollBarClicked Event

Chart.AxisScrollBarClicked Event |
 | See Also

Occurs when the axis scroll bar is clicked by the end-user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AxisScrollBarClicked As EventHandler(Of ScrollBarEventArgs)
public event EventHandler<ScrollBarEventArgs> AxisScrollBarClicked
public:
event EventHandler<ScrollBarEventArgs^>^ AxisScrollBarClicked {
    void add (EventHandler<ScrollBarEventArgs^>^ value);
    void remove (EventHandler<ScrollBarEventArgs^>^ value);
}
/** @event */
public void add_AxisScrollBarClicked (EventHandler<ScrollBarEventArgs> value)

/** @event */
public void remove_AxisScrollBarClicked (EventHandler<ScrollBarEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AxisViewChanged Event

Chart.AxisViewChanged Event |
 | See Also

Called when the axis scale view position or size is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AxisViewChanged As EventHandler(Of ViewEventArgs)
public event EventHandler<ViewEventArgs> AxisViewChanged
public:
event EventHandler<ViewEventArgs^>^ AxisViewChanged {
    void add (EventHandler<ViewEventArgs^>^ value);
    void remove (EventHandler<ViewEventArgs^>^ value);
}
/** @event */
public void add_AxisViewChanged (EventHandler<ViewEventArgs> value)

/** @event */
public void remove_AxisViewChanged (EventHandler<ViewEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.AxisViewChanging Event

Chart.AxisViewChanging Event |
 | See Also

Occurs when the axis scale view position or size is about to change.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event AxisViewChanging As EventHandler(Of ViewEventArgs)
public event EventHandler<ViewEventArgs> AxisViewChanging
public:
event EventHandler<ViewEventArgs^>^ AxisViewChanging {
    void add (EventHandler<ViewEventArgs^>^ value);
    void remove (EventHandler<ViewEventArgs^>^ value);
}
/** @event */
public void add_AxisViewChanging (EventHandler<ViewEventArgs> value)

/** @event */
public void remove_AxisViewChanging (EventHandler<ViewEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.CursorPositionChanged Event

Chart.CursorPositionChanged Event |
 | See Also

Occurs when the cursor position is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event CursorPositionChanged As EventHandler(Of CursorEventArgs)
public event EventHandler<CursorEventArgs> CursorPositionChanged
public:
event EventHandler<CursorEventArgs^>^ CursorPositionChanged {
    void add (EventHandler<CursorEventArgs^>^ value);
    void remove (EventHandler<CursorEventArgs^>^ value);
}
/** @event */
public void add_CursorPositionChanged (EventHandler<CursorEventArgs> value)

/** @event */
public void remove_CursorPositionChanged (EventHandler<CursorEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.CursorPositionChanging Event

Chart.CursorPositionChanging Event |
 | See Also

Occurs when the cursor position is about to change.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event CursorPositionChanging As EventHandler(Of CursorEventArgs)
public event EventHandler<CursorEventArgs> CursorPositionChanging
public:
event EventHandler<CursorEventArgs^>^ CursorPositionChanging {
    void add (EventHandler<CursorEventArgs^>^ value);
    void remove (EventHandler<CursorEventArgs^>^ value);
}
/** @event */
public void add_CursorPositionChanging (EventHandler<CursorEventArgs> value)

/** @event */
public void remove_CursorPositionChanging (EventHandler<CursorEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.Customize Event

Chart.Customize Event |
 | See Also

Occurs just before the chart image is drawn. Use this event to customize the chart picture.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event Customize As EventHandler
public event EventHandler Customize
public:
event EventHandler^ Customize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
/** @event */
public void add_Customize (EventHandler value)

/** @event */
public void remove_Customize (EventHandler value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.CustomizeLegend Event

Chart.CustomizeLegend Event |
 | See Also

Occurs when the chart legend must be customized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event CustomizeLegend As EventHandler(Of CustomizeLegendEventArgs)
public event EventHandler<CustomizeLegendEventArgs> CustomizeLegend
public:
event EventHandler<CustomizeLegendEventArgs^>^ CustomizeLegend {
    void add (EventHandler<CustomizeLegendEventArgs^>^ value);
    void remove (EventHandler<CustomizeLegendEventArgs^>^ value);
}
/** @event */
public void add_CustomizeLegend (EventHandler<CustomizeLegendEventArgs> value)

/** @event */
public void remove_CustomizeLegend (EventHandler<CustomizeLegendEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.FormatNumber Event

Chart.FormatNumber Event |
 | See Also

Occurs when a numeric value has to be converted to a string.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event FormatNumber As EventHandler(Of FormatNumberEventArgs)
public event EventHandler<FormatNumberEventArgs> FormatNumber
public:
event EventHandler<FormatNumberEventArgs^>^ FormatNumber {
    void add (EventHandler<FormatNumberEventArgs^>^ value);
    void remove (EventHandler<FormatNumberEventArgs^>^ value);
}
/** @event */
public void add_FormatNumber (EventHandler<FormatNumberEventArgs> value)

/** @event */
public void remove_FormatNumber (EventHandler<FormatNumberEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.GetToolTipText Event

Chart.GetToolTipText Event |
 | See Also

Occurs before showing the tooltip to get the tooltip text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event GetToolTipText As EventHandler(Of ToolTipEventArgs)
public event EventHandler<ToolTipEventArgs> GetToolTipText
public:
event EventHandler<ToolTipEventArgs^>^ GetToolTipText {
    void add (EventHandler<ToolTipEventArgs^>^ value);
    void remove (EventHandler<ToolTipEventArgs^>^ value);
}
/** @event */
public void add_GetToolTipText (EventHandler<ToolTipEventArgs> value)

/** @event */
public void remove_GetToolTipText (EventHandler<ToolTipEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.PostPaint Event

Chart.PostPaint Event |
 | See Also

Occurs when the chart element is painted.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event PostPaint As EventHandler(Of ChartPaintEventArgs)
public event EventHandler<ChartPaintEventArgs> PostPaint
public:
event EventHandler<ChartPaintEventArgs^>^ PostPaint {
    void add (EventHandler<ChartPaintEventArgs^>^ value);
    void remove (EventHandler<ChartPaintEventArgs^>^ value);
}
/** @event */
public void add_PostPaint (EventHandler<ChartPaintEventArgs> value)

/** @event */
public void remove_PostPaint (EventHandler<ChartPaintEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.PrePaint Event

Chart.PrePaint Event |
 | See Also

Occurs when the chart element background is painted.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event PrePaint As EventHandler(Of ChartPaintEventArgs)
public event EventHandler<ChartPaintEventArgs> PrePaint
public:
event EventHandler<ChartPaintEventArgs^>^ PrePaint {
    void add (EventHandler<ChartPaintEventArgs^>^ value);
    void remove (EventHandler<ChartPaintEventArgs^>^ value);
}
/** @event */
public void add_PrePaint (EventHandler<ChartPaintEventArgs> value)

/** @event */
public void remove_PrePaint (EventHandler<ChartPaintEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SelectionRangeChanged Event

Chart.SelectionRangeChanged Event |
 | See Also

Occurs when the selection start position or end position is changed.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event SelectionRangeChanged As EventHandler(Of CursorEventArgs)
public event EventHandler<CursorEventArgs> SelectionRangeChanged
public:
event EventHandler<CursorEventArgs^>^ SelectionRangeChanged {
    void add (EventHandler<CursorEventArgs^>^ value);
    void remove (EventHandler<CursorEventArgs^>^ value);
}
/** @event */
public void add_SelectionRangeChanged (EventHandler<CursorEventArgs> value)

/** @event */
public void remove_SelectionRangeChanged (EventHandler<CursorEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


Chart.SelectionRangeChanging Event

Chart.SelectionRangeChanging Event |
 | See Also

Occurs when the selection start or end position is about to change.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Event SelectionRangeChanging As EventHandler(Of CursorEventArgs)
public event EventHandler<CursorEventArgs> SelectionRangeChanging
public:
event EventHandler<CursorEventArgs^>^ SelectionRangeChanging {
    void add (EventHandler<CursorEventArgs^>^ value);
    void remove (EventHandler<CursorEventArgs^>^ value);
}
/** @event */
public void add_SelectionRangeChanging (EventHandler<CursorEventArgs> value)

/** @event */
public void remove_SelectionRangeChanging (EventHandler<CursorEventArgs> value)

JScript supports the use of events, but not the declaration of new ones.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Chart Class
Chart Members


ChartArea Class

ChartArea Class |
 | See Also Members

Represents a chart area on the chart image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartArea
    Inherits ChartNamedElement
public class ChartArea : ChartNamedElement
public ref class ChartArea : public ChartNamedElement
public class ChartArea extends ChartNamedElement
public class ChartArea extends ChartNamedElement

Remarks

Within any given chart, the inner plot position is the rectangular area, inside the x and y-axis lines, where the data points are drawn. The plot position is the rectangular area that encompasses the inner plot position, the tick marks, and the axis labels. The chart area is the rectangular region that encompasses the plot position, the tick marks, the axis labels and the axis titles on the chart.

A chart area is represented by a ChartArea class; ChartArea objects are stored in the ChartAreaCollection class.

The number of chart series that can be plotted in a chart area is unlimited.

A ChartArea object:

  • Uses one distinct inner plotting region.

  • Is used to plot one or more chart series.

  • Has primary and secondary x and y-axes, except for pie and doughnut chart types.

When you use Shape chart types, which includes pie, doughnut, funnel, pyramid, polar, and radar charts, the inner plotting position defines the size of the chart type shape. For example, when you increase the value of the InnerPlotPosition property on a pie chart, you will increase the radius of the pie shape.

For all other chart types, each chart area has two sets of X- and Y-axes, primary and secondary. To access properties related to these axes, use the AxisX, AxisX2, AxisY and AxisY2 properties. If you need to set a property that affects all axes on the chart, use the Axes property.

One or more series are associated with a chart area. The series has a ChartArea property that determines the chart area that each series belongs to. By default, the series is connected to the default chart area. To disable the display of a series, set the ChartArea property of that series to a zero-length string.

If another chart area is added to the chart, you can associate any series with the new chart area. In all Shape chart types, as well as bar and stacked bar chart types, each series must be plotted in a separate chart area. In all other chart types, multiple series can be combined in the same chart area.

A 3D chart is displayed on a chart area-by-chart area basis. You can use the Area3DStyle property to enable and customize your chart in 3D.

The chart area minimum and maximum will not be automatically recalculated if you add new data, so the chart will not automatically change axis sizes. You can require the chart area to recalculate these values by using the RecalculateAxesScale method.

To align multiple chart areas vertically, set the AlignmentOrientation property. To align multiple chart areas horizontally, you must first position the chart areas using the Position property, and then set the AlignmentOrientation property to Horizontal.

To suppress the display of a series, set the Series property of that series to a zero-length string.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.ChartArea

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Members


ChartArea Members

ChartArea Members |
 | See Also Constructors Methods Properties

Represents a chart area on the chart image.

The following tables list the members exposed by the ChartArea type.

Public Constructors

Name | Description
ChartArea | Overloaded.
Top

Public Properties

Name | Description
AlignmentOrientation | Gets or sets the alignment orientation of a chart area.
AlignmentStyle | Gets or sets the alignment style of the ChartArea.
AlignWithChartArea | Gets or sets the name of the ChartArea object to which this chart area should be aligned.
Area3DStyle | Gets or sets a ChartArea3DStyle object, which is used to implement 3D for all series in a chart area.
Axes | Gets or sets an array that represents all axes for a chart area.
AxisX | Gets or sets an Axis object that represents the primary X-axis.
AxisX2 | Gets or sets an Axis object that represents the secondary X-axis.
AxisY | Gets or sets an Axis object that represents the primary Y-axis.
AxisY2 | Gets or sets an Axis object that represents the secondary Y-axis.
BackColor | Gets or sets the background color of a ChartArea object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a chart area, and also determines whether or not a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a ChartArea object.
BackImage | Gets or sets the background image of a ChartArea object.
BackImageAlignment | Gets or sets the alignment of a ChartArea background image.
BackImageTransparentColor | Gets or sets the color of a ChartArea object background image that will be drawn as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a ChartArea object.
BackSecondaryColor | Gets or sets the secondary color for the background of a ChartArea object.
BorderColor | Gets or sets the border color of a ChartArea object.
BorderDashStyle | Gets or sets the border style of a ChartArea object.
BorderWidth | Gets or sets the border width of a ChartArea object.
CursorX | Gets or sets a Cursor object that is used for cursors and selected ranges along the X-axis.
CursorY | Gets or sets a Cursor object that is used for cursors and selected ranges along the Y-axis.
InnerPlotPosition | Gets or sets an ElementPosition object, which defines the inner plot position of a chart area object.
IsSameFontSizeForAllAxes | Gets or sets a flag that determines if the labels of the relevant chart area axes are of equal size.
Name | Overridden. Gets or sets the unique name of a ChartArea object.
Position | Gets or sets an ElementPosition object that defines the position of a ChartArea object within the Chart.
ShadowColor | Gets or sets the shadow color of a ChartArea object.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a ChartArea object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Visible | Gets or sets a flag that determines if a chart area is visible.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetSeriesDepth | Returns the depth of a Series in a chart area.
GetSeriesZPosition | Returns the Z position of a series, which is useful for custom drawing.
GetType | (inherited from Object )
RecalculateAxesScale | Recalculates the properties of the chart area after changes have been made to the chart in the Customize event.
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
TransformPoints | Applies 3D transformations to an array of 3D points, which must be done before GDI+ drawing methods can be called.
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartArea Class


ChartArea Constructor

ChartArea Constructor |
 | See Also

Overload List

Name | Description
ChartArea () | Initializes a new instance of the ChartArea class.
ChartArea (String) | Initializes a new instance of the ChartArea class with the specified chart area name.

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Constructor ()

ChartArea Constructor () |
 | See Also

Initializes a new instance of the ChartArea class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public ChartArea ()
public:
ChartArea ()
public ChartArea ()
public function ChartArea ()

Remarks

Use this constructor to create and initialize a new instance of the ChartArea class.

Note:
It is highly recommended that you use one of the Add or Insert methods of the ChartAreas collection property to add a chart area at run time.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Constructor (String)

ChartArea Constructor (String) |
 | See Also

Initializes a new instance of the ChartArea class with the specified chart area name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String _
)
public ChartArea (
    string name
)
public:
ChartArea (
    String^ name
)
public ChartArea (
    String name
)
public function ChartArea (
    name : String
)

Parameters

name

The name for the new ChartArea object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Methods

ChartArea Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetSeriesDepth | Returns the depth of a Series in a chart area.
GetSeriesZPosition | Returns the Z position of a series, which is useful for custom drawing.
GetType | (inherited from Object )
RecalculateAxesScale | Recalculates the properties of the chart area after changes have been made to the chart in the Customize event.
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )
TransformPoints | Applies 3D transformations to an array of 3D points, which must be done before GDI+ drawing methods can be called.

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartArea Class


ChartArea.Dispose Method

ChartArea.Dispose Method |
 | See Also

Overload List

Name | Description
ChartArea.Dispose () | (inherited from Dispose )
ChartArea.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.Dispose Method (Boolean)

ChartArea.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId:="axisX")> _
<SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId:="axisY")> _
<SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId:="axisY2")> _
<SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId:="axisX2")> _
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
[SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisX")]
[SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisY")]
[SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisY2")]
[SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisX2")]
protected override void Dispose (
    bool disposing
)
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA2213:DisposableFieldsShouldBeDisposed", MessageId=L"axisX")]
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA2213:DisposableFieldsShouldBeDisposed", MessageId=L"axisY")]
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA2213:DisposableFieldsShouldBeDisposed", MessageId=L"axisY2")]
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA2213:DisposableFieldsShouldBeDisposed", MessageId=L"axisX2")]
protected:
virtual void Dispose (
    bool disposing
) override
/** @attribute SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisX") */
/** @attribute SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisY") */
/** @attribute SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisY2") */
/** @attribute SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisX2") */
protected void Dispose (
    boolean disposing
)
SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisX")
SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisY")
SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisY2")
SuppressMessageAttribute("Microsoft.Usage", "CA2213:DisposableFieldsShouldBeDisposed", MessageId="axisX2")
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.GetSeriesDepth Method

ChartArea.GetSeriesDepth Method |
 | See Also

Returns the depth of a Series in a chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetSeriesDepth ( _
    series As Series _
) As Single
public float GetSeriesDepth (
    Series series
)
public:
float GetSeriesDepth (
    Series^ series
)
public float GetSeriesDepth (
    Series series
)
public function GetSeriesDepth (
    series : Series
) : float

Parameters

series

The Series for which the depth is retrieved.

Return Value

A float value that represents the depth of the specified Series, which is measured as a percentage of the chart area's depth.

Remarks

Call this method to get the depth of a specified series. The returned value is measured as a percentage of the chart area's depth, which is the same unit of measurement used in the Z property.

All series have a depth, regardless of their chart type. For example, even point and bubble series have a depth, even though the entire depth is not used to draw the points or bubbles.

The depth of a series can be used to determine a Z value for a point that is used in a custom drawing routine.

Note:
Any points used in custom 3D drawing must be transformed from relative 3D coordinates to relative 2D coordinates using the TransformPoints method.

To get relative X and Y-values from an axis, use the ValueToPosition method for both the X and Y axes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.GetSeriesZPosition Method

ChartArea.GetSeriesZPosition Method |
 | See Also

Returns the Z position of a series, which is useful for custom drawing.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetSeriesZPosition ( _
    series As Series _
) As Single
public float GetSeriesZPosition (
    Series series
)
public:
float GetSeriesZPosition (
    Series^ series
)
public float GetSeriesZPosition (
    Series series
)
public function GetSeriesZPosition (
    series : Series
) : float

Parameters

series

The Series for which the Z position is retrieved.

Return Value

A float value that represents the Z position of the specified series, which is measured as a percentage of the depth of a chart area.

Remarks

Call this method to get the Z position of a series. The Z position is measured from the back wall of the chart area to the center of a data series, and is represented as a percentage of the chart area's depth. For example, a series that is drawn halfway along the Z-axis has a Z position of 50.

The Z position of a series is normally used for a custom drawing routine.

Note:
Any points used in custom 3D drawing must be transformed from relative 3D coordinates to relative 2D coordinates using the TransformPoints method.

To get relative X and Y-values from an axis, use the ValueToPosition method for both the X and Y axes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.RecalculateAxesScale Method

ChartArea.RecalculateAxesScale Method |
 | See Also

Recalculates the properties of the chart area after changes have been made to the chart in the Customize event.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub RecalculateAxesScale
public void RecalculateAxesScale ()
public:
void RecalculateAxesScale ()
public void RecalculateAxesScale ()
public function RecalculateAxesScale ()

Remarks

If you use the Customize event to make changes, it is sometimes necessary to recalculate chart area properties so that the chart is rendered correctly. For example, if an axis range is changed, the labels for that axis must be recalculated.

Call this method after you use the Customize event to make ANY changes to a chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.TransformPoints Method

ChartArea.TransformPoints Method |
 | See Also

Applies 3D transformations to an array of 3D points, which must be done before GDI+ drawing methods can be called.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub TransformPoints ( _
    points As Point3D() _
)
public void TransformPoints (
    Point3D[] points
)
public:
void TransformPoints (
    array<Point3D^>^ points
)
public void TransformPoints (
    Point3D[] points
)
public function TransformPoints (
    points : Point3D[]
)

Parameters

points

An array of 3D points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Properties

ChartArea Properties |
 | See Also

Public Properties

Name | Description
AlignmentOrientation | Gets or sets the alignment orientation of a chart area.
AlignmentStyle | Gets or sets the alignment style of the ChartArea.
AlignWithChartArea | Gets or sets the name of the ChartArea object to which this chart area should be aligned.
Area3DStyle | Gets or sets a ChartArea3DStyle object, which is used to implement 3D for all series in a chart area.
Axes | Gets or sets an array that represents all axes for a chart area.
AxisX | Gets or sets an Axis object that represents the primary X-axis.
AxisX2 | Gets or sets an Axis object that represents the secondary X-axis.
AxisY | Gets or sets an Axis object that represents the primary Y-axis.
AxisY2 | Gets or sets an Axis object that represents the secondary Y-axis.
BackColor | Gets or sets the background color of a ChartArea object.
BackGradientStyle | Gets or sets the orientation for the background gradient of a chart area, and also determines whether or not a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a ChartArea object.
BackImage | Gets or sets the background image of a ChartArea object.
BackImageAlignment | Gets or sets the alignment of a ChartArea background image.
BackImageTransparentColor | Gets or sets the color of a ChartArea object background image that will be drawn as transparent.
BackImageWrapMode | Gets or sets the drawing mode for the background image of a ChartArea object.
BackSecondaryColor | Gets or sets the secondary color for the background of a ChartArea object.
BorderColor | Gets or sets the border color of a ChartArea object.
BorderDashStyle | Gets or sets the border style of a ChartArea object.
BorderWidth | Gets or sets the border width of a ChartArea object.
CursorX | Gets or sets a Cursor object that is used for cursors and selected ranges along the X-axis.
CursorY | Gets or sets a Cursor object that is used for cursors and selected ranges along the Y-axis.
InnerPlotPosition | Gets or sets an ElementPosition object, which defines the inner plot position of a chart area object.
IsSameFontSizeForAllAxes | Gets or sets a flag that determines if the labels of the relevant chart area axes are of equal size.
Name | Overridden. Gets or sets the unique name of a ChartArea object.
Position | Gets or sets an ElementPosition object that defines the position of a ChartArea object within the Chart.
ShadowColor | Gets or sets the shadow color of a ChartArea object.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a ChartArea object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Visible | Gets or sets a flag that determines if a chart area is visible.

See Also

Reference

ChartArea Class


ChartArea.AlignmentOrientation Property

ChartArea.AlignmentOrientation Property |
 | See Also

Gets or sets the alignment orientation of a chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AlignmentOrientation As AreaAlignmentOrientations
public AreaAlignmentOrientations AlignmentOrientation { get; set; }
public:
property AreaAlignmentOrientations AlignmentOrientation {
    AreaAlignmentOrientations get ();
    void set (AreaAlignmentOrientations value);
}
/** @property */
public AreaAlignmentOrientations get_AlignmentOrientation ()

/** @property */
public void set_AlignmentOrientation (AreaAlignmentOrientations value)

public function get AlignmentOrientation () : AreaAlignmentOrientations

public function set AlignmentOrientation (value : AreaAlignmentOrientations)

Property Value

An AreaAlignmentOrientations enumeration value.

Remarks

Through the use of the AlignWithChartArea, AlignmentOrientation and AlignmentStyle properties, it is possible to align or synchronize two or more chart areas horizontally, vertically or both.

First, set the AlignWithChartArea property to the name of a ChartArea object. This chart area will then be aligned, based on the AlignmentStyle setting, which defines the alignment to use, and the AlignmentOrientation setting, which defines the elements of the chart area that should be used to set the alignment.

If the AlignWithChartArea property is not set, the chart area will not be aligned, regardless of the AlignmentStyle and AlignmentOrientation settings.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.AlignmentStyle Property

ChartArea.AlignmentStyle Property |
 | See Also

Gets or sets the alignment style of the ChartArea.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AlignmentStyle As AreaAlignmentStyles
public AreaAlignmentStyles AlignmentStyle { get; set; }
public:
property AreaAlignmentStyles AlignmentStyle {
    AreaAlignmentStyles get ();
    void set (AreaAlignmentStyles value);
}
/** @property */
public AreaAlignmentStyles get_AlignmentStyle ()

/** @property */
public void set_AlignmentStyle (AreaAlignmentStyles value)

public function get AlignmentStyle () : AreaAlignmentStyles

public function set AlignmentStyle (value : AreaAlignmentStyles)

Property Value

An AreaAlignmentStyles enumeration value that can represent either a single value or the bitwise-OR of multiple values that define the alignment to use.

Remarks

Use the AlignmentStyle property to align two or more chart areas horizontally, vertically or both. The alignment type is one of the following values, or a bitwise OR combination of the values below.

Member Name | Description
All | Chart areas are aligned using all values.
AxesView | Chart areas are aligned using the View of the specified ChartArea.
Cursor | Chart areas are aligned on the cursor.
None | Chart areas are not automatically aligned.
Position | Chart areas are aligned with the Position of the chart area specified.
InnerPlotPosition | Chart areas are aligned with the InnerPlotPosition of the chart area specified.

If the AlignWithChartArea value is not set, the AlignmentStyle property will have no effect.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.AlignWithChartArea Property

ChartArea.AlignWithChartArea Property |
 | See Also

Gets or sets the name of the ChartArea object to which this chart area should be aligned.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AlignWithChartArea As String
public string AlignWithChartArea { get; set; }
public:
property String^ AlignWithChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AlignWithChartArea ()

/** @property */
public void set_AlignWithChartArea (String value)

public function get AlignWithChartArea () : String

public function set AlignWithChartArea (value : String)

Property Value

A string value that represents the name of a ChartArea object to which this chart area should be aligned. The default is the empty string.

Remarks

Through the use of the AlignWithChartArea, AlignmentOrientation and AlignmentStyle properties, it is possible to align or synchronize two or more chart areas horizontally, vertically or both.

First, set the AlignWithChartArea property to the name of a ChartArea object. This chart area will then be aligned, based on the AlignmentStyle setting, which defines the alignment to use, and the AlignmentOrientation setting, which defines the elements of the chart area that should be used to set the alignment.

If the AlignWithChartArea property is not set, the chart area will not be aligned, regardless of the AlignmentStyle and AlignmentOrientation settings.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.Area3DStyle Property

ChartArea.Area3DStyle Property |
 | See Also

Gets or sets a ChartArea3DStyle object, which is used to implement 3D for all series in a chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property Area3DStyle As ChartArea3DStyle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ChartArea3DStyle Area3DStyle { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ChartArea3DStyle^ Area3DStyle {
    ChartArea3DStyle^ get ();
    void set (ChartArea3DStyle^ value);
}
/** @property */
public ChartArea3DStyle get_Area3DStyle ()

/** @property */
public void set_Area3DStyle (ChartArea3DStyle value)

public function get Area3DStyle () : ChartArea3DStyle

public function set Area3DStyle (value : ChartArea3DStyle)

Property Value

A ChartArea3DStyle object that implements 3D for all series plotted in a chart area.

Remarks

To enable or disable 3D for a chart area, set the Enable3D property.

When the chart is drawn in 3D, scale breaks are not supported on the axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.Axes Property

ChartArea.Axes Property |
 | See Also

Gets or sets an array that represents all axes for a chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property Axes As Axis()
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Axis[] Axes { get; set; }
[SuppressMessageAttribute(L"Microsoft.Performance", L"CA1819:PropertiesShouldNotReturnArrays")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property array<Axis^>^ Axes {
    array<Axis^>^ get ();
    void set (array<Axis^>^ value);
}
/** @property */
public Axis[] get_Axes ()

/** @property */
public void set_Axes (Axis[] value)

public function get Axes () : Axis[]

public function set Axes (value : Axis[])

Property Value

An array of Axis objects that represents all axes used by a chart area.

Remarks

The main purpose of this property is to provide access to the properties of the X, Y, X2 and Y2 axes at design time.

At run time, the axes for a chart area should be accessed using the individual axis properties, such as AxisX, AxisX2, and so forth.

If you decide to use this property at run time—for example, in an event—you can access an item in this array by specifying an AxisName enumeration member as the identifier.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.AxisX Property

ChartArea.AxisX Property |
 | See Also

Gets or sets an Axis object that represents the primary X-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
<BrowsableAttribute(False)> _
Public Property AxisX As Axis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[BrowsableAttribute(false)]
public Axis AxisX { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
[BrowsableAttribute(false)]
public:
property Axis^ AxisX {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisX ()

/** @property */
public void set_AxisX (Axis value)

public function get AxisX () : Axis

public function set AxisX (value : Axis)

Property Value

An Axis object that represents the primary X-axis.

Remarks

Use this property to manipulate the primary X-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.AxisX2 Property

ChartArea.AxisX2 Property |
 | See Also

Gets or sets an Axis object that represents the secondary X-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property AxisX2 As Axis
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Axis AxisX2 { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Axis^ AxisX2 {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisX2 ()

/** @property */
public void set_AxisX2 (Axis value)

public function get AxisX2 () : Axis

public function set AxisX2 (value : Axis)

Property Value

An Axis object that represents the secondary X-axis.

Remarks

Use this property to manipulate the secondary X-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.AxisY Property

ChartArea.AxisY Property |
 | See Also

Gets or sets an Axis object that represents the primary Y-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property AxisY As Axis
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Axis AxisY { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Axis^ AxisY {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisY ()

/** @property */
public void set_AxisY (Axis value)

public function get AxisY () : Axis

public function set AxisY (value : Axis)

Property Value

An Axis object that represents the primary Y-axis.

Remarks

Use this property to manipulate the primary Y-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.AxisY2 Property

ChartArea.AxisY2 Property |
 | See Also

Gets or sets an Axis object that represents the secondary Y-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property AxisY2 As Axis
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Axis AxisY2 { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Axis^ AxisY2 {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_AxisY2 ()

/** @property */
public void set_AxisY2 (Axis value)

public function get AxisY2 () : Axis

public function set AxisY2 (value : Axis)

Property Value

An Axis object that represents the secondary Y-axis.

Remarks

Use this property to manipulate the secondary Y-axis in the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackColor Property

ChartArea.BackColor Property |
 | See Also

Gets or sets the background color of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value. The default color is White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

The BackColor value will be the first color used if you have specified gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the chart area. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackGradientStyle Property

ChartArea.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a chart area, and also determines whether or not a gradient is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a chart area will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

  • Set the primary color of the chart area background with the BackColor property.

  • Set the secondary color of the chart area background with the BackSecondaryColor property.

  • Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackHatchStyle Property

ChartArea.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note:
The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackImage Property

ChartArea.BackImage Property |
 | See Also

Gets or sets the background image of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default is an empty string.

Remarks

This property defines a path to a background image for a ChartArea, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image be any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackImageAlignment Property

ChartArea.BackImageAlignment Property |
 | See Also

Gets or sets the alignment of a ChartArea background image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for the chart area, and is only applied when the ChartImageWrapMode property is set to Unscaled.

For more information about the available alignments, see the ChartImageAlignmentStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackImageTransparentColor Property

ChartArea.BackImageTransparentColor Property |
 | See Also

Gets or sets the color of a ChartArea object background image that will be drawn as transparent.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackImageWrapMode Property

ChartArea.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

The BackImageWrapMode property determines how the image is displayed; the image can be tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the chart area. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the chart area.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BackSecondaryColor Property

ChartArea.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for the background of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value. The default value is Empty.

Remarks

This BackSecondaryColor property is one of several related properties that determine the secondary background color of Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the chart area.

To use gradient colors for the background of a chart area:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BorderColor Property

ChartArea.BorderColor Property |
 | See Also

Gets or sets the border color of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set the BorderColor property to any valid ARGB (alpha, red, green, blue) value.

Note:
For pie and doughnut charts, this property determines the color of radial and horizontal lines if data labels are drawn outside the pie or doughnut—that is, if the LabelStyle custom property is set to "Outside".

This property also determines the marker lines for 3D charts if the ShowMarkerLines custom property is set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BorderDashStyle Property

ChartArea.BorderDashStyle Property |
 | See Also

Gets or sets the border style of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the chart area.

Remarks

The BorderDashStyle property determines the line style to use for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.BorderWidth Property

ChartArea.BorderWidth Property |
 | See Also

Gets or sets the border width of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the chart area.

Remarks

Note that the BorderWidth property can also set the width of lines for line charts, custom legend items displayed with a line style, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.CursorX Property

ChartArea.CursorX Property |
 | See Also

Gets or sets a Cursor object that is used for cursors and selected ranges along the X-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property CursorX As Cursor
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Cursor CursorX { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Cursor^ CursorX {
    Cursor^ get ();
    void set (Cursor^ value);
}
/** @property */
public Cursor get_CursorX ()

/** @property */
public void set_CursorX (Cursor value)

public function get CursorX () : Cursor

public function set CursorX (value : Cursor)

Property Value

A Cursor object used for cursors and selected ranges along the X-axis.

Remarks

This Cursor object is used for the X-axis cursor and its selected ranges. For all charts except bar chart types, the X-axis cursor represents the vertical cursor. For bar chart types, the X-axis cursor represents the horizontal cursor.

Refer to the Cursor class documentation for a description of its members, as well as sample source code.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.CursorY Property

ChartArea.CursorY Property |
 | See Also

Gets or sets a Cursor object that is used for cursors and selected ranges along the Y-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property CursorY As Cursor
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Cursor CursorY { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property Cursor^ CursorY {
    Cursor^ get ();
    void set (Cursor^ value);
}
/** @property */
public Cursor get_CursorY ()

/** @property */
public void set_CursorY (Cursor value)

public function get CursorY () : Cursor

public function set CursorY (value : Cursor)

Property Value

A Cursor object used for cursors and selected ranges along the X-axis.

Remarks

This Cursor object is used for the Y-axis cursor and its selected ranges. For all charts except bar chart types, the Y-axis cursor represents the horizontal cursor. For bar chart types, the Y-axis cursor represents the vertical cursor.

Refer to the Cursor class documentation for a description of its members, as well as sample source code.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.InnerPlotPosition Property

ChartArea.InnerPlotPosition Property |
 | See Also

Gets or sets an ElementPosition object, which defines the inner plot position of a chart area object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property InnerPlotPosition As ElementPosition
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ElementPosition InnerPlotPosition { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ElementPosition^ InnerPlotPosition {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_InnerPlotPosition ()

/** @property */
public void set_InnerPlotPosition (ElementPosition value)

public function get InnerPlotPosition () : ElementPosition

public function set InnerPlotPosition (value : ElementPosition)

Property Value

An ElementPosition object, which defines the inner plot position of a ChartArea object.

Remarks

The InnerPlotPosition property defines the rectangle within a chart area element that is used for plotting data; it excludes tick marks, axis labels, and so forth.

The coordinates used for this property (0,0 to 100,100) are related to the ChartArea object, and not to the entire Chart.

The InnerPlotPosition property can be used to align multiple chart areas. However, if one chart area has tick marks and axis labels and another one does not, their axis lines cannot be aligned.

Important:
This property can also be used to change the size of charts, such as pie or doughnut, without changing the size of the generated chart image.

To change the position of an entire ChartArea object use the Position property instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.IsSameFontSizeForAllAxes Property

ChartArea.IsSameFontSizeForAllAxes Property |
 | See Also

Gets or sets a flag that determines if the labels of the relevant chart area axes are of equal size.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsSameFontSizeForAllAxes As Boolean
public bool IsSameFontSizeForAllAxes { get; set; }
public:
property bool IsSameFontSizeForAllAxes {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsSameFontSizeForAllAxes ()

/** @property */
public void set_IsSameFontSizeForAllAxes (boolean value)

public function get IsSameFontSizeForAllAxes () : boolean

public function set IsSameFontSizeForAllAxes (value : boolean)

Property Value

True if all axes that have their IsLabelAutoFit property set to true will display their labels using the same font size, otherwise false.

Remarks

The font size is automatically calculated by the Chart control, with the largest size that fits being used.

This property applies to all chart area axes that have their IsLabelAutoFit property set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.Name Property

ChartArea.Name Property |
 | See Also

Gets or sets the unique name of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the name of a ChartArea object.

Remarks

The name of a ChartArea object must be unique, otherwise an exception will be thrown.

This property can be used as the indexer when retrieving a ChartArea object from the ChartAreaCollection object.

If you set this property to a zero-length string. an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.Position Property

ChartArea.Position Property |
 | See Also

Gets or sets an ElementPosition object that defines the position of a ChartArea object within the Chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property Position As ElementPosition
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ElementPosition Position { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_Position ()

/** @property */
public void set_Position (ElementPosition value)

public function get Position () : ElementPosition

public function set Position (value : ElementPosition)

Property Value

An ElementPosition object that defines the position of a chart area object within the chart image.

Remarks

This property defines the position of a ChartArea object within the Chart, and includes tick marks, axis labels, and so forth.

The coordinates used for this property (0,0 to 100,100) are related to the entire chart image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.ShadowColor Property

ChartArea.ShadowColor Property |
 | See Also

Gets or sets the shadow color of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.ShadowOffset Property

ChartArea.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer that represents the shadow offset, in pixels, of the chart area.

Remarks

To implement shadowing, use a value other than zero (0). A positive value will result in a shadow that shifts down and to the right. A negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea.Visible Property

ChartArea.Visible Property |
 | See Also

Gets or sets a flag that determines if a chart area is visible.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Visible As Boolean
public virtual bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public function get Visible () : boolean

public function set Visible (value : boolean)

Property Value

True if the chart area is visible, otherwise false.

Remarks

When this flag is set to false, all series, legends, titles and annotation objects associated with the chart area will also be hidden.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea Class
ChartArea Members


ChartArea3DStyle Class

ChartArea3DStyle Class |
 | See Also Members

Manages the display attributes for three-dimensional (3D) chart areas.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartArea3DStyle
public class ChartArea3DStyle
public ref class ChartArea3DStyle
public class ChartArea3DStyle
public class ChartArea3DStyle

Remarks

This class provides the styles for 3D chart areas, and is exposed using the Area3DStyle property.

To enable 3D for a chart area, set the Enable3D property to true. This causes 3D to be applied to all data series drawn in a chart area.

An isometric projection of a chart area can be displayed by setting the IsRightAngleAxes property to true, which is the default. Isometric views are not actually 3D, because the displayed angles of rotation may not match the actual angles of rotation around the vertical and horizontal axes. The actual angles are controlled using the Rotation and Inclination properties, respectively.

For more information about isometric projections, see the Remarks section of the IsRightAngleAxes property.

You can also use this class to:

  • Cluster bar and column chart data series using the IsClustered property.

  • Control the lighting effects using the LightStyle property.

  • Set the width of chart area walls using the WallWidth property.

  • Set the amount of perspective with the Perspective property.

  • Control the depth of data points and the distance between data rows using the PointDepth and PointGapDepth properties, respectively.

  • Rotate a chart area using the Inclination and Rotation properties.

To work with coordinates of 3D points, use the Point3D class.

When a chart is set to 3D, the following chart features are not valid:

  • Scale breaks

  • Gradients

  • Scrolling and zooming

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartArea3DStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Members


ChartArea3DStyle Members

ChartArea3DStyle Members |
 | See Also Constructors Methods Properties

Manages the display attributes for three-dimensional (3D) chart areas.

The following tables list the members exposed by the ChartArea3DStyle type.

Public Constructors

Name | Description
ChartArea3DStyle | Overloaded.
Top

Public Properties

Name | Description
Enable3D | Gets or sets a flag that toggles the 3D on and off for a chart area.
Inclination | Gets or sets the angle of rotation around the horizontal axes for 3D chart areas.
IsClustered | Gets or sets a flag that determines whether data series for a bar or column chart are clustered; that is, displayed along distinct rows.
IsRightAngleAxes | Gets or sets a flag that determines whether a chart area is displayed using an isometric projection.
LightStyle | Gets or sets the style of lighting for a 3D chart area.
Perspective | Gets or sets the percent of perspective for a 3D chart area.
PointDepth | Gets or sets the depth of data points displayed in a 3D chart area.
PointGapDepth | Gets or sets the distance between series rows in a 3D chart area.
Rotation | Gets or sets the angle of rotation around the vertical axes for 3D chart areas.
WallWidth | Gets or sets the width of the walls displayed in a 3D chart area.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartArea3DStyle Class


ChartArea3DStyle Constructor

ChartArea3DStyle Constructor |
 | See Also

Overload List

Name | Description
ChartArea3DStyle () | Initializes a new instance of the ChartArea3DStyle class.
ChartArea3DStyle (ChartArea) | Initializes a new instance of the ChartArea3DStyle class using the chartArea parameter.

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle Constructor ()

ChartArea3DStyle Constructor () |
 | See Also

Initializes a new instance of the ChartArea3DStyle class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public ChartArea3DStyle ()
public:
ChartArea3DStyle ()
public ChartArea3DStyle ()
public function ChartArea3DStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle Constructor (ChartArea)

ChartArea3DStyle Constructor (ChartArea) |
 | See Also

Initializes a new instance of the ChartArea3DStyle class using the chartArea parameter.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    chartArea As ChartArea _
)
public ChartArea3DStyle (
    ChartArea chartArea
)
public:
ChartArea3DStyle (
    ChartArea^ chartArea
)
public ChartArea3DStyle (
    ChartArea chartArea
)
public function ChartArea3DStyle (
    chartArea : ChartArea
)

Parameters

chartArea

A ChartArea object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle Methods

ChartArea3DStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartArea3DStyle Class


ChartArea3DStyle Properties

ChartArea3DStyle Properties |
 | See Also

Public Properties

Name | Description
Enable3D | Gets or sets a flag that toggles the 3D on and off for a chart area.
Inclination | Gets or sets the angle of rotation around the horizontal axes for 3D chart areas.
IsClustered | Gets or sets a flag that determines whether data series for a bar or column chart are clustered; that is, displayed along distinct rows.
IsRightAngleAxes | Gets or sets a flag that determines whether a chart area is displayed using an isometric projection.
LightStyle | Gets or sets the style of lighting for a 3D chart area.
Perspective | Gets or sets the percent of perspective for a 3D chart area.
PointDepth | Gets or sets the depth of data points displayed in a 3D chart area.
PointGapDepth | Gets or sets the distance between series rows in a 3D chart area.
Rotation | Gets or sets the angle of rotation around the vertical axes for 3D chart areas.
WallWidth | Gets or sets the width of the walls displayed in a 3D chart area.

See Also

Reference

ChartArea3DStyle Class


ChartArea3DStyle.Enable3D Property

ChartArea3DStyle.Enable3D Property |
 | See Also

Gets or sets a flag that toggles the 3D on and off for a chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enable3D As Boolean
public bool Enable3D { get; set; }
public:
property bool Enable3D {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enable3D ()

/** @property */
public void set_Enable3D (boolean value)

public function get Enable3D () : boolean

public function set Enable3D (value : boolean)

Property Value

true the chart area is displayed using 3D, false if the chart area is displayed in 2D. The default value is false.

Remarks

Toggles the three-dimensional display of a chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.Inclination Property

ChartArea3DStyle.Inclination Property |
 | See Also

Gets or sets the angle of rotation around the horizontal axes for 3D chart areas.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Inclination As Integer
public int Inclination { get; set; }
public:
property int Inclination {
    int get ();
    void set (int value);
}
/** @property */
public int get_Inclination ()

/** @property */
public void set_Inclination (int value)

public function get Inclination () : int

public function set Inclination (value : int)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.IsClustered Property

ChartArea3DStyle.IsClustered Property |
 | See Also

Gets or sets a flag that determines whether data series for a bar or column chart are clustered; that is, displayed along distinct rows.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsClustered As Boolean
public bool IsClustered { get; set; }
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsClustered ()

/** @property */
public void set_IsClustered (boolean value)

public function get IsClustered () : boolean

public function set IsClustered (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.IsRightAngleAxes Property

ChartArea3DStyle.IsRightAngleAxes Property |
 | See Also

Gets or sets a flag that determines whether a chart area is displayed using an isometric projection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsRightAngleAxes As Boolean
public bool IsRightAngleAxes { get; set; }
public:
property bool IsRightAngleAxes {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsRightAngleAxes ()

/** @property */
public void set_IsRightAngleAxes (boolean value)

public function get IsRightAngleAxes () : boolean

public function set IsRightAngleAxes (value : boolean)

Property Value

True if the chart area is displayed using an isometric projection, otherwise false.

Remarks

Isometric views are not actually 3D, because the displayed angles of rotation may not match the actual angles of rotation around the vertical and horizontal axes. The actual angles are controlled using the Rotation and Inclination properties, respectively.

Note the following points concerning isometric projection:

  • It is not "real" 3D. That is, the angle of rotation around axes doesn't use true rotational angles.

  • It is ideal for displaying 3D charts with some depth.

  • If your application allows end-users to rotate the charts, the rotation will not be smooth. In this case, using isometric views is not recommended.

  • With isometric projection, perspective is not supported.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.LightStyle Property

ChartArea3DStyle.LightStyle Property |
 | See Also

Gets or sets the style of lighting for a 3D chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LightStyle As LightStyle
public LightStyle LightStyle { get; set; }
public:
property LightStyle LightStyle {
    LightStyle get ();
    void set (LightStyle value);
}
/** @property */
public LightStyle get_LightStyle ()

/** @property */
public void set_LightStyle (LightStyle value)

public function get LightStyle () : LightStyle

public function set LightStyle (value : LightStyle)

Property Value

A LightStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.Perspective Property

ChartArea3DStyle.Perspective Property |
 | See Also

Gets or sets the percent of perspective for a 3D chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Perspective As Integer
public int Perspective { get; set; }
public:
property int Perspective {
    int get ();
    void set (int value);
}
/** @property */
public int get_Perspective ()

/** @property */
public void set_Perspective (int value)

public function get Perspective () : int

public function set Perspective (value : int)

Property Value

An integer value that represents the percent of perspective for a 3D chart area. The allowable range is 0-100 percent, and the default is zero (0) percent.

Remarks

A perspective projection of any set of parallel lines that are not parallel to the projection plane converges to a vanishing point.

If you set the Perspective property, the IsRightAngleAxes property will be automatically set to false, because these properties are mutually exclusive.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.PointDepth Property

ChartArea3DStyle.PointDepth Property |
 | See Also

Gets or sets the depth of data points displayed in a 3D chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property PointDepth As Integer
public int PointDepth { get; set; }
public:
property int PointDepth {
    int get ();
    void set (int value);
}
/** @property */
public int get_PointDepth ()

/** @property */
public void set_PointDepth (int value)

public function get PointDepth () : int

public function set PointDepth (value : int)

Property Value

An integer value that represents the depth of data points. The allowable range is 0-1000 percent. The default is 100 percent.

Remarks

This property determines the depth of data points, and is represented as a percentage of the data point width.

The PointDepth property can be applied to the depth of bar, column, line, pie and spline chart data points only. If you set this property for other chart types (for example, bubble and point charts) that cannot have their point depths "stretched", it will reserve extra space for the data points, but will not increase their depth.

You can display the chart as an isometric projection by setting the IsRightAngleAxes property to true, which is the the default value. This will cause the point depth to appear to be more or less than the percentage set by this property, depending on the chart being displayed.

To control the spacing between rows of data, use the PointGapDepth property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.PointGapDepth Property

ChartArea3DStyle.PointGapDepth Property |
 | See Also

Gets or sets the distance between series rows in a 3D chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property PointGapDepth As Integer
public int PointGapDepth { get; set; }
public:
property int PointGapDepth {
    int get ();
    void set (int value);
}
/** @property */
public int get_PointGapDepth ()

/** @property */
public void set_PointGapDepth (int value)

public function get PointGapDepth () : int

public function set PointGapDepth (value : int)

Property Value

An integer value that represents the distance between data rows (that is, the data series) in the 3D chart area. The allowable range is 0-1000 percent, and the default is 100 percent.

Remarks

This property determines the distance between data rows, with each row corresponding to a data series. The unit of measurement is expressed as a percentage of the distance between data points in one row.

Changing the gap between columns or bars for column and bar chart types using the PointWidth custom property will affect the PointGapDepth property value.

Set the IsRightAngleAxes property to true (the default value) to display the chart as an isometric projection. This will cause the point gap depth to appear to be more or less than the percentage set by this property, depending on the chart being displayed.

To control the depth of data points, use the PointDepth property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.Rotation Property

ChartArea3DStyle.Rotation Property |
 | See Also

Gets or sets the angle of rotation around the vertical axes for 3D chart areas.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Rotation As Integer
public int Rotation { get; set; }
public:
property int Rotation {
    int get ();
    void set (int value);
}
/** @property */
public int get_Rotation ()

/** @property */
public void set_Rotation (int value)

public function get Rotation () : int

public function set Rotation (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartArea3DStyle.WallWidth Property

ChartArea3DStyle.WallWidth Property |
 | See Also

Gets or sets the width of the walls displayed in a 3D chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property WallWidth As Integer
public int WallWidth { get; set; }
public:
property int WallWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_WallWidth ()

/** @property */
public void set_WallWidth (int value)

public function get WallWidth () : int

public function set WallWidth (value : int)

Property Value

An integer value that represents the width, in pixels, of the walls displayed in a 3D chart area.

Remarks

This property determines the width of the walls (for example, the back wall, side walls, and so forth) that are displayed in 3D chart areas. The allowable range is 0-30 pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartArea3DStyle Class
ChartArea3DStyle Members


ChartAreaCollection Class

ChartAreaCollection Class |
 | See Also Members

Represents a collection of ChartArea objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartAreaCollection
    Inherits ChartNamedElementCollection(Of ChartArea)
public class ChartAreaCollection : ChartNamedElementCollection<ChartArea>
public ref class ChartAreaCollection : public ChartNamedElementCollection<ChartArea^>
public class ChartAreaCollection extends ChartNamedElementCollection<ChartArea>
public class ChartAreaCollection extends ChartNamedElementCollection<ChartArea>

Remarks

The ChartAreaCollection class represents a collection of ChartArea objects, which in turn represent the chart areas that are displayed within the chart image.

This class is exposed as the ChartAreas property of the root Chart object.

The Count property indicates the total number of items in the collection, and is commonly used to find the upper bound of the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartAreaCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartAreaCollection Members


ChartAreaCollection Members

ChartAreaCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of ChartArea objects.

The following tables list the members exposed by the ChartAreaCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

ChartAreaCollection Class


ChartAreaCollection Methods

ChartAreaCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

ChartAreaCollection Class


ChartAreaCollection.Add Method

ChartAreaCollection.Add Method |
 | See Also

Overload List

Name | Description
ChartAreaCollection.Add (ChartArea) | (inherited from Add )
ChartAreaCollection.Add (String) | Adds a ChartArea object with the specified name to the collection.

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


ChartAreaCollection.Add Method (String)

ChartAreaCollection.Add Method (String) |
 | See Also

Adds a ChartArea object with the specified name to the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As ChartArea
public ChartArea Add (
    string name
)
public:
ChartArea^ Add (
    String^ name
)
public ChartArea Add (
    String name
)
public function Add (
    name : String
) : ChartArea

Parameters

name

The name of the object to be added to the collection.

Return Value

A string value that represents a reference to the newly added object.

Remarks

Objects are always added as the last item in the collection.

The name argument specifies the Name property of the object being added.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


ChartAreaCollection Properties

ChartAreaCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

ChartAreaCollection Class


ChartColorPalette Enumeration

ChartColorPalette Enumeration |
 | See Also

Specifies a palette when setting a Palette property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartColorPalette
public enum ChartColorPalette
public enum class ChartColorPalette
public enum ChartColorPalette
public enum ChartColorPalette

Members

Member name | Description
Berry | Palette utilizes blues and purples.
Bright | Palette utilizes bright colors.
BrightPastel | Palette utilizes bright pastel colors.
Chocolate | Palette utilizes shades of brown.
EarthTones | Palette utilizes earth tone colors such as green and brown.
Excel | Palette utilizes Excel-style colors.
Fire | Palette utilizes red, orange and yellow colors.
Grayscale | Palette utilizes grayscale colors, that is, shades of black and white.
Light | Palette utilizes LightStyle style colors; very light colors..
None | No palette is used.
Pastel | Palette utilizes pastel colors.
SeaGreen | Palette utilizes colors that range from green to blue.
SemiTransparent | Palette utilizes semi-transparent colors.

Remarks

The ChartColorPalette enumeration represents the palettes to be used for the root Chart object and any Series objects.

If no colors are assigned to data points and their associated series, the default colors will be assigned to the data. For example:

  • If Palette is set to None, then the default palette is set to PaletteCustomColors or BrightPastel.

If.Palette is set to None, then the default palette for the chart is used (Palette).

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartDashStyle Enumeration

ChartDashStyle Enumeration |
 | See Also

Specifies a line style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartDashStyle
public enum ChartDashStyle
public enum class ChartDashStyle
public enum ChartDashStyle
public enum ChartDashStyle

Members

Member name | Description
Dash | A dashed line.
DashDot | A line with a repeating dash-dot pattern.
DashDotDot | A line a repeating dash-dot-dot pattern.
Dot | A line with a repeating dot pattern.
NotSet | The line style is not set.
Solid | A solid line.

Remarks

The ChartDashStyle enumeration represents a line style.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartElement Class

ChartElement Class |
 | See Also Members

Base class for all the chart elements. The ChartElement class represents the most basic element of the chart element hierarchy.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public MustInherit Class ChartElement
    Implements IDisposable
public abstract class ChartElement : IDisposable
public ref class ChartElement abstract : IDisposable
public abstract class ChartElement implements IDisposable
public abstract class ChartElement implements IDisposable

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Members


ChartElement Members

ChartElement Members |
 | See Also Methods Properties Constructors

Base class for all the chart elements. The ChartElement class represents the most basic element of the chart element hierarchy.

The following tables list the members exposed by the ChartElement type.

Protected Constructors

Name | Description
ChartElement | Initializes a new instance of the ChartElement class.
Top

Public Properties

Name | Description
Tag | Gets or sets an object associated with this chart element.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns a hash function for a particular type.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string that represents the current Object.
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartElement Class


ChartElement Constructor

ChartElement Constructor |
 | See Also

Initializes a new instance of the ChartElement class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Sub New
protected ChartElement ()
protected:
ChartElement ()
protected ChartElement ()
protected function ChartElement ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement Methods

ChartElement Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns a hash function for a particular type.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string that represents the current Object.

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartElement Class


ChartElement.Dispose Method

ChartElement.Dispose Method |
 | See Also

Overload List

Name | Description
ChartElement.Dispose () |
ChartElement.Dispose (Boolean) |

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement.Dispose Method ()

ChartElement.Dispose Method () |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Sub Dispose

[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public void Dispose ()

[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual void Dispose () sealed

/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public final void Dispose ()

SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement.Dispose Method (Boolean)

ChartElement.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

protected virtual void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
)

protected void Dispose (
    boolean disposing
)

protected function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement.Equals Method

ChartElement.Equals Method |
 | See Also

Overload List

Name | Description
ChartElement.Equals (Object) |
ChartElement.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement.Equals Method (Object)

ChartElement.Equals Method (Object) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public override bool Equals (
    Object obj
)

[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual bool Equals (
    Object^ obj
) override

/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public boolean Equals (
    Object obj
)

SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement.GetHashCode Method

ChartElement.GetHashCode Method |
 | See Also

Returns a hash function for a particular type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Overrides Function GetHashCode As Integer
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public override int GetHashCode ()
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual int GetHashCode () override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public int GetHashCode ()
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public override function GetHashCode () : int

Return Value

An integer value that represents the hash code for the current Object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement.ToString Method

ChartElement.ToString Method |
 | See Also

Returns a string that represents the current Object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Overrides Function ToString As String
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public override string ToString ()
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual String^ ToString () override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public String ToString ()
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public override function ToString () : String

Return Value

A string value that represents the current Object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElement Properties

ChartElement Properties |
 | See Also

Public Properties

Name | Description
Tag | Gets or sets an object associated with this chart element.

See Also

Reference

ChartElement Class


ChartElement.Tag Property

ChartElement.Tag Property |
 | See Also

Gets or sets an object associated with this chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property Tag As Object
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Object Tag { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_Tag ()

/** @property */
public void set_Tag (Object value)

public function get Tag () : Object

public function set Tag (value : Object)

Property Value

An Object associated with this chart element.

Remarks

The Tag property can be used to store additional data with this chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElement Class
ChartElement Members


ChartElementCollection Generic Class

ChartElementCollection Generic Class |
 | See Also Members

Represents the base class for all chart element collections.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public MustInherit Class ChartElementCollection(Of T As ChartElement)
    Inherits Collection(Of T)
    Implements IDisposable
public abstract class ChartElementCollection<T> : Collection<T>, IDisposable where T : ChartElement
generic<typename T> where T : ChartElement
public ref class ChartElementCollection abstract : public Collection<T>, IDisposable
J# supports the use of generic types and methods, but not the declaration of new ones.
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Members


ChartElementCollection Members

ChartElementCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents the base class for all chart element collections.

The following tables list the members exposed by the ChartElementCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Overridden. Removes all elements from the Collection.
Dispose | Overloaded.
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts an element into the Collection at the specified index location.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the element at the specified index location of the Collection.
SetItem | Overridden. Replaces the element at the specified index location.
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

ChartElementCollection Class


ChartElementCollection Methods

ChartElementCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection.
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Overridden. Removes all elements from the Collection.
Dispose | Overloaded.
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts an element into the Collection at the specified index location.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the element at the specified index location of the Collection.
SetItem | Overridden. Replaces the element at the specified index location.

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

ChartElementCollection Class


ChartElementCollection.ClearItems Method

ChartElementCollection.ClearItems Method |
 | See Also

Removes all elements from the Collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Protected Overrides Sub ClearItems
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected override void ClearItems ()
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected:
virtual void ClearItems () override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
protected void ClearItems ()
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
protected override function ClearItems ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.Dispose Method

ChartElementCollection.Dispose Method |
 | See Also

Overload List

Name | Description
ChartElementCollection.Dispose () |
ChartElementCollection.Dispose (Boolean) |

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.Dispose Method ()

ChartElementCollection.Dispose Method () |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Sub Dispose

[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public void Dispose ()

[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual void Dispose () sealed

/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public final void Dispose ()

SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.Dispose Method (Boolean)

ChartElementCollection.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

protected virtual void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
)

protected void Dispose (
    boolean disposing
)

protected function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.InsertItem Method

ChartElementCollection.InsertItem Method |
 | See Also

Inserts an element into the Collection at the specified index location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected override void InsertItem (
    int index,
    T item
)
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected:
virtual void InsertItem (
    int index,
    T item
) override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
protected void InsertItem (
    int index,
    T item
)
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
protected override function InsertItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index location of the item will be inserted.

item

The object to insert. The value can be null for reference types.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.Invalidate Method

ChartElementCollection.Invalidate Method |
 | See Also

Forces the invalidation of the parent chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub Invalidate
public virtual void Invalidate ()
public:
virtual void Invalidate ()
public void Invalidate ()
public function Invalidate ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.RemoveItem Method

ChartElementCollection.RemoveItem Method |
 | See Also

Removes the element at the specified index location of the Collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected override void RemoveItem (
    int index
)
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected:
virtual void RemoveItem (
    int index
) override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
protected void RemoveItem (
    int index
)
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
protected override function RemoveItem (
    index : int
)

Parameters

index

The zero-based index location of the element to remove.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.ResumeUpdates Method

ChartElementCollection.ResumeUpdates Method |
 | See Also

Resumes the invalidation of a chart element in the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub ResumeUpdates
public virtual void ResumeUpdates ()
public:
virtual void ResumeUpdates ()
public void ResumeUpdates ()
public function ResumeUpdates ()

Remarks

If you call the SuspendUpdates method several times, you will need to call the ResumeUpdates method an equal number of times.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.SetItem Method

ChartElementCollection.SetItem Method |
 | See Also

Replaces the element at the specified index location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected override void SetItem (
    int index,
    T item
)
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
protected:
virtual void SetItem (
    int index,
    T item
) override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
protected void SetItem (
    int index,
    T item
)
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
protected override function SetItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index location of the element to replace.

item

The new value for the element at the specified index location. The value can be null for reference types.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection.SuspendUpdates Method

ChartElementCollection.SuspendUpdates Method |
 | See Also

Suspends the invalidation of a chart element in the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub SuspendUpdates
public virtual void SuspendUpdates ()
public:
virtual void SuspendUpdates ()
public void SuspendUpdates ()
public function SuspendUpdates ()

Remarks

A call to the Invalidate method will have no effect after the SuspendUpdates method is called.

If you call the SuspendUpdates method several times, you will need to call the ResumeUpdates method an equal number of times.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection Properties

ChartElementCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

ChartElementCollection Class


ChartElementOutline Class

ChartElementOutline Class |
 | See Also Members

Represents an array of marker points and the outline path used for visual object selection in the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartElementOutline
    Implements IDisposable
public class ChartElementOutline : IDisposable
public ref class ChartElementOutline : IDisposable
public class ChartElementOutline implements IDisposable
public class ChartElementOutline implements IDisposable

Remarks

The value of the OutlinePath property can be null for complex objects or objects with two points or fewer.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElementOutline

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Members


ChartElementOutline Members

ChartElementOutline Members |
 | See Also Methods Properties

Represents an array of marker points and the outline path used for visual object selection in the chart.

The following tables list the members exposed by the ChartElementOutline type.

Public Properties

Name | Description
Markers | Gets or sets the markers.
OutlinePath | Gets or sets the outline path. The result can be null for complex objects and objects with two points or fewer.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartElementOutline Class


ChartElementOutline Methods

ChartElementOutline Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartElementOutline Class


ChartElementOutline.Dispose Method

ChartElementOutline.Dispose Method |
 | See Also

Overload List

Name | Description
ChartElementOutline.Dispose () | Performs application-defined tasks that free, release, or reset unmanaged resources.
ChartElementOutline.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members


ChartElementOutline.Dispose Method ()

ChartElementOutline.Dispose Method () |
 | See Also

Performs application-defined tasks that free, release, or reset unmanaged resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Sub Dispose
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public void Dispose ()
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual void Dispose () sealed
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public final void Dispose ()
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members


ChartElementOutline.Dispose Method (Boolean)

ChartElementOutline.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members


ChartElementOutline Properties

ChartElementOutline Properties |
 | See Also

Public Properties

Name | Description
Markers | Gets or sets the markers.
OutlinePath | Gets or sets the outline path. The result can be null for complex objects and objects with two points or fewer.

See Also

Reference

ChartElementOutline Class


ChartElementOutline.Markers Property

ChartElementOutline.Markers Property |
 | See Also

Gets or sets the markers.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Markers As ReadOnlyCollection(Of PointF)
public ReadOnlyCollection<PointF> Markers { get; }
public:
property ReadOnlyCollection<PointF>^ Markers {
    ReadOnlyCollection<PointF>^ get ();
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public ReadOnlyCollection<PointF> get_Markers ()

CompilerGeneratedAttribute
public function get Markers () : ReadOnlyCollection<PointF>

Property Value

An array of PointF values that represents the marker points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members


ChartElementOutline.OutlinePath Property

ChartElementOutline.OutlinePath Property |
 | See Also

Gets or sets the outline path. The result can be null for complex objects and objects with two points or fewer.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property OutlinePath As GraphicsPath
public GraphicsPath OutlinePath { get; }
public:
property GraphicsPath^ OutlinePath {
    GraphicsPath^ get ();
}
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public GraphicsPath get_OutlinePath ()

CompilerGeneratedAttribute
public function get OutlinePath () : GraphicsPath

Property Value

A GraphicsPath object that represents the outline path.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartElementOutline Class
ChartElementOutline Members


ChartElementType Enumeration

ChartElementType Enumeration |
 | See Also

Specifies a chart element type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartElementType
public enum ChartElementType
public enum class ChartElementType
public enum ChartElementType
public enum ChartElementType

Members

Member name | Description
Annotation | Any object derived from the Annotation class.
Axis | An Axis object.
AxisLabelImage | An Axis label image.
AxisLabels | A LabelStyle object.
AxisTitle | An Axis title.
DataPoint | A DataPoint object.
DataPointLabel | A series DataPoint label.
Gridlines | Any major or minor grid line, either vertical or horizontal.
LegendArea | The area inside a Legend object. Does not include the space occupied by legend items.
LegendHeader | A Legend header.
LegendItem | A LegendItem object.
LegendTitle | A Legend title.
Nothing | No chart element.
PlottingArea | The plotting area, which is the chart area excluding axes, labels, and so on. Also excludes the regions that data points might occupy.
ScrollBarLargeDecrement | The background of a scrollbar that, when clicked, results in a large decrement in the view size. This background is located below the thumb for a vertical scrollbar, and to the left of the thumb for a horizontal scrollbar.
ScrollBarLargeIncrement | The background of a scrollbar that, when clicked, results in a large increment in the view size. This background is located above the thumb for a vertical scrollbar, and to the right of the thumb for a horizontal scrollbar.
ScrollBarSmallDecrement | A scrollbar small decrement button. A "down arrow" button for a vertical scrollbar, a "left arrow" button for a horizontal scrollbar.
ScrollBarSmallIncrement | A scrollbar small increment button. An "up arrow" button for a vertical scrollbar, a "right arrow" button for a horizontal scrollbar.
ScrollBarThumbTracker | A scrollbar tracking thumb.
ScrollBarZoomReset | The ZoomReset button of a scrollbar.
StripLines | A StripLine object.
TickMarks | Any major or minor TickMark object.
Title | The title of a Chart.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartGraphics Class

ChartGraphics Class |
 | See Also Members

Provides numerous conversion functions and exposes a GDI+ Graphics object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartGraphics
    Inherits ChartElement
public class ChartGraphics : ChartElement
public ref class ChartGraphics : public ChartElement
public class ChartGraphics extends ChartElement
public class ChartGraphics extends ChartElement

Remarks

This class provides numerous conversion functions and also exposes a GDI+ Graphics object. Note that when rendering as Scalable Vector Graphics (SVG), use of the Graphics object for custom drawing will not be included as part of the SVG document.

Note also that, by default, Graphics functions usually take absolute coordinates. Therefore the conversion methods of this class should be useful if you perform drawing operations.

A ChartGraphics object is exposed in the ChartGraphics property of the ChartPaintEventArgs class, which makes it easy to perform custom drawing in the PrePaint and PostPaint events.

Important:
If significant changes are made to the default behavior of the Graphics object, the chart image and its associated elements may be drawn erratically. For example, positioning may be altered. It is highly recommended that you become well acquainted with GDI+ before you make any significant changes to the properties of the Graphics object.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartGraphics

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Members


ChartGraphics Members

ChartGraphics Members |
 | See Also Methods Properties

Provides numerous conversion functions and exposes a GDI+ Graphics object.

The following tables list the members exposed by the ChartGraphics type.

Public Properties

Name | Description
Graphics | Gets or sets a GDI+ Graphics object that can be used for drawing purposes.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetAbsolutePoint | Takes a PointF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteRectangle | Takes a RectangleF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteSize | Takes a SizeF object that uses relative coordinates and returns a SizeF object that uses absolute coordinates.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetPositionFromAxis | Takes a given axis value for a specified axis and returns the relative pixel value.
GetRelativePoint | Takes a PointF object that uses absolute coordinates and returns a PointF object that uses relative coordinates.
GetRelativeRectangle | Takes a RectangleF structure that is using absolute coordinates and returns a RectangleF object that uses relative coordinates.
GetRelativeSize | Takes a SizeF object in absolute coordinates and returns a SizeF object that uses relative coordinates.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartGraphics Class


ChartGraphics Methods

ChartGraphics Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetAbsolutePoint | Takes a PointF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteRectangle | Takes a RectangleF object and converts its relative coordinates to absolute coordinates.
GetAbsoluteSize | Takes a SizeF object that uses relative coordinates and returns a SizeF object that uses absolute coordinates.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetPositionFromAxis | Takes a given axis value for a specified axis and returns the relative pixel value.
GetRelativePoint | Takes a PointF object that uses absolute coordinates and returns a PointF object that uses relative coordinates.
GetRelativeRectangle | Takes a RectangleF structure that is using absolute coordinates and returns a RectangleF object that uses relative coordinates.
GetRelativeSize | Takes a SizeF object in absolute coordinates and returns a SizeF object that uses relative coordinates.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartGraphics Class


ChartGraphics.Dispose Method

ChartGraphics.Dispose Method |
 | See Also

Overload List

Name | Description
ChartGraphics.Dispose () | (inherited from Dispose )
ChartGraphics.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.Dispose Method (Boolean)

ChartGraphics.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetAbsolutePoint Method

ChartGraphics.GetAbsolutePoint Method |
 | See Also

Takes a PointF object and converts its relative coordinates to absolute coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetAbsolutePoint ( _
    point As PointF _
) As PointF
public PointF GetAbsolutePoint (
    PointF point
)
public:
PointF GetAbsolutePoint (
    PointF point
)
public PointF GetAbsolutePoint (
    PointF point
)
public function GetAbsolutePoint (
    point : PointF
) : PointF

Parameters

point

A PointF object in relative coordinates.

Return Value

A PointF object in absolute coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetAbsoluteRectangle Method

ChartGraphics.GetAbsoluteRectangle Method |
 | See Also

Takes a RectangleF object and converts its relative coordinates to absolute coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetAbsoluteRectangle ( _
    rectangle As RectangleF _
) As RectangleF
public RectangleF GetAbsoluteRectangle (
    RectangleF rectangle
)
public:
RectangleF GetAbsoluteRectangle (
    RectangleF rectangle
)
public RectangleF GetAbsoluteRectangle (
    RectangleF rectangle
)
public function GetAbsoluteRectangle (
    rectangle : RectangleF
) : RectangleF

Parameters

rectangle

A RectangleF object in relative coordinates.

Return Value

A RectangleF object in absolute coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetAbsoluteSize Method

ChartGraphics.GetAbsoluteSize Method |
 | See Also

Takes a SizeF object that uses relative coordinates and returns a SizeF object that uses absolute coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetAbsoluteSize ( _
    size As SizeF _
) As SizeF
public SizeF GetAbsoluteSize (
    SizeF size
)
public:
SizeF GetAbsoluteSize (
    SizeF size
)
public SizeF GetAbsoluteSize (
    SizeF size
)
public function GetAbsoluteSize (
    size : SizeF
) : SizeF

Parameters

size

A SizeF object in relative coordinates.

Return Value

A SizeF object in absolute coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetPositionFromAxis Method

ChartGraphics.GetPositionFromAxis Method |
 | See Also

Takes a given axis value for a specified axis and returns the relative pixel value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetPositionFromAxis ( _
    chartAreaName As String, _
    axis As AxisName, _
    axisValue As Double _
) As Double
public double GetPositionFromAxis (
    string chartAreaName,
    AxisName axis,
    double axisValue
)
public:
double GetPositionFromAxis (
    String^ chartAreaName,
    AxisName axis,
    double axisValue
)
public double GetPositionFromAxis (
    String chartAreaName,
    AxisName axis,
    double axisValue
)
public function GetPositionFromAxis (
    chartAreaName : String,
    axis : AxisName,
    axisValue : double
) : double

Parameters

chartAreaName

Chart area name.

axis

An AxisName enumeration value that identifies the relevant axis.

axisValue

The axis value to be converted to a relative pixel value.

Return Value

A string value that represents the converted axis value, in relative pixel coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetRelativePoint Method

ChartGraphics.GetRelativePoint Method |
 | See Also

Takes a PointF object that uses absolute coordinates and returns a PointF object that uses relative coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetRelativePoint ( _
    point As PointF _
) As PointF
public PointF GetRelativePoint (
    PointF point
)
public:
PointF GetRelativePoint (
    PointF point
)
public PointF GetRelativePoint (
    PointF point
)
public function GetRelativePoint (
    point : PointF
) : PointF

Parameters

point

A PointF object in absolute coordinates.

Return Value

A PointF object in relative coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetRelativeRectangle Method

ChartGraphics.GetRelativeRectangle Method |
 | See Also

Takes a RectangleF structure that is using absolute coordinates and returns a RectangleF object that uses relative coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetRelativeRectangle ( _
    rectangle As RectangleF _
) As RectangleF
public RectangleF GetRelativeRectangle (
    RectangleF rectangle
)
public:
RectangleF GetRelativeRectangle (
    RectangleF rectangle
)
public RectangleF GetRelativeRectangle (
    RectangleF rectangle
)
public function GetRelativeRectangle (
    rectangle : RectangleF
) : RectangleF

Parameters

rectangle

A RectangleF structure in absolute coordinates.

Return Value

A RectangleF structure in relative coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics.GetRelativeSize Method

ChartGraphics.GetRelativeSize Method |
 | See Also

Takes a SizeF object in absolute coordinates and returns a SizeF object that uses relative coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetRelativeSize ( _
    size As SizeF _
) As SizeF
public SizeF GetRelativeSize (
    SizeF size
)
public:
SizeF GetRelativeSize (
    SizeF size
)
public SizeF GetRelativeSize (
    SizeF size
)
public function GetRelativeSize (
    size : SizeF
) : SizeF

Parameters

size

A SizeF object in absolute coordinates.

Return Value

A SizeF object in relative coordinates.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartGraphics Properties

ChartGraphics Properties |
 | See Also

Public Properties

Name | Description
Graphics | Gets or sets a GDI+ Graphics object that can be used for drawing purposes.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

ChartGraphics Class


ChartGraphics.Graphics Property

ChartGraphics.Graphics Property |
 | See Also

Gets or sets a GDI+ Graphics object that can be used for drawing purposes.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Graphics As Graphics
public Graphics Graphics { get; set; }
public:
property Graphics^ Graphics {
    Graphics^ get ();
    void set (Graphics^ value);
}
/** @property */
public Graphics get_Graphics ()

/** @property */
public void set_Graphics (Graphics value)

public function get Graphics () : Graphics

public function set Graphics (value : Graphics)

Property Value

A Graphics object used for drawing.

Remarks

You can use this property to perform any custom drawing that can be performed using GDI+.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartGraphics Class
ChartGraphics Members


ChartHatchStyle Enumeration

ChartHatchStyle Enumeration |
 | See Also

Specifies a hatching style for a chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartHatchStyle
public enum ChartHatchStyle
public enum class ChartHatchStyle
public enum ChartHatchStyle
public enum ChartHatchStyle

Members

Member name | Description
BackwardDiagonal | Backward diagonal style.
Cross | Cross style.
DarkDownwardDiagonal | Dark downward diagonal style.
DarkHorizontal | Dark horizontal style.
DarkUpwardDiagonal | Dark upward diagonal style.
DarkVertical | Dark vertical style.
DashedDownwardDiagonal | Dashed downward diagonal style.
DashedHorizontal | Dashed horizontal style.
DashedUpwardDiagonal | Dashed upward diagonal style.
DashedVertical | Dashed vertical style.
DiagonalBrick | Diagonal brick style.
DiagonalCross | Diagonal cross style.
Divot | Divot style.
DottedDiamond | Dotted diamond style.
DottedGrid | Dotted grid style.
ForwardDiagonal | Forward diagonal style.
Horizontal | Horizontal style.
HorizontalBrick | Horizontal brick style.
LargeCheckerBoard | Large checker board style.
LargeConfetti | Large confetti style.
LargeGrid | Large grid style.
LightDownwardDiagonal | Light downward diagonal style.
LightHorizontal | Light horizontal style.
LightUpwardDiagonal | Light upward diagonal style.
LightVertical | Light vertical style.
NarrowHorizontal | Narrow horizontal style.
NarrowVertical | Narrow vertical style.
None | No hatching style.
OutlinedDiamond | Outlined diamond style.
Percent05 | Percent05 style.
Percent10 | Percent10 style.
Percent20 | Percent20 style.
Percent25 | Percent25 style.
Percent30 | Percent30 style.
Percent40 | Percent40 style.
Percent50 | Percent50 style.
Percent60 | Percent60 style.
Percent70 | Percent70 style.
Percent75 | Percent75 style.
Percent80 | Percent80 style.
Percent90 | Percent90 style.
Plaid | Plaid style.
Shingle | Shingle style.
SmallCheckerBoard | Small checker board style.
SmallConfetti | Small confetti style.
SmallGrid | Small grid style.
SolidDiamond | Solid diamond style.
Sphere | Sphere style.
Trellis | Trellis style.
Vertical | Vertical style.
Wave | Wave style.
Weave | Weave style.
WideDownwardDiagonal | Wide downward diagonal style.
WideUpwardDiagonal | Wide upward diagonal style.
ZigZag | Zigzag style.

Remarks

The ChartHatchStyle enumeration represents the hatching styles that can be used for numerous chart elements, such as the ChartArea, Legend, and so forth.

Setting the BackHatchStyle property of a chart element object to any member of this enumeration except None will cause the corresponding hatching style to be applied to the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartImageAlignmentStyle Enumeration

ChartImageAlignmentStyle Enumeration |
 | See Also

Specifies the image alignment for a chart background image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartImageAlignmentStyle
public enum ChartImageAlignmentStyle
public enum class ChartImageAlignmentStyle
public enum ChartImageAlignmentStyle
public enum ChartImageAlignmentStyle

Members

Member name | Description
Bottom | The image is aligned to the bottom boundary of the chart element.
BottomLeft | The image is aligned to the bottom left corner of the chart element.
BottomRight | The image is aligned to the bottom right corner of the chart element.
Center | The image is aligned in the center of the chart element.
Left | The image is aligned to the left boundary of the chart element.
Right | The image is aligned to the right boundary of the chart element.
Top | The image is aligned to the top boundary of the chart element.
TopLeft | The mage is aligned to the top left corner of the chart element.
TopRight | The image is aligned to the top right corner of the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartImageFormat Enumeration

ChartImageFormat Enumeration |
 | See Also

Specifies the image type of the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartImageFormat
public enum ChartImageFormat
public enum class ChartImageFormat
public enum ChartImageFormat
public enum ChartImageFormat

Members

Member name | Description
Bmp | A bitmap (BMP) image format.
Emf | A Windows Enhanced Metafile (EMF) image format.
EmfDual | A Windows Enhanced Metafile Dual (EMF-dual) image format.
EmfPlus | A Windows Enhanced Metafile Plus (EMF+) image format.
Gif | A GIF image format.
Jpeg | A JPEG image format.
Png | A PNG image format.
Tiff | A TIFF image format.

Remarks

The ChartImageFormat enumeration represents an image type that is used to save the chart to a file or stream.

Note:
Only charts saved to disk can use the EmfDual or EmfDual format. Charts cannot be rendered on a Web page using EMF-dual or EMF+.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartImageWrapMode Enumeration

ChartImageWrapMode Enumeration |
 | See Also

Specifies the drawing mode for a background image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartImageWrapMode
public enum ChartImageWrapMode
public enum class ChartImageWrapMode
public enum ChartImageWrapMode
public enum ChartImageWrapMode

Members

Member name | Description
Scaled | Background image is scaled to fit the entire chart element.
Tile | Background image is tiled to fit the entire chart element.
TileFlipX | Every other tiled image is reversed around the X-axis.
TileFlipXY | Every other tiled image is reversed around the X-axis and Y-axis.
TileFlipY | Every other tiled image is reversed around the Y-axis.
Unscaled | Background image is not scaled.

Remarks

The ChartImageWrapMode enumeration represents the drawing mode for a background image, as set by the BackImageWrapMode property of the Chart control. To set a background image for a chart element, use the BackImage property.

Note:
If you specify the Unscaled value, the location where the image is drawn will depend on the BackImageAlignment property setting.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ChartNamedElement Class

ChartNamedElement Class |
 | See Also Members

Represents the base class for most chart elements. Chart elements such as series, chart areas, and legends must have unique names, and reuse the unique name generation and validation logic provided by the ChartNamedElementCollection class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public MustInherit Class ChartNamedElement
    Inherits ChartElement
public abstract class ChartNamedElement : ChartElement
public ref class ChartNamedElement abstract : public ChartElement
public abstract class ChartNamedElement extends ChartElement
public abstract class ChartNamedElement extends ChartElement

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Members


ChartNamedElement Members

ChartNamedElement Members |
 | See Also Methods Properties Constructors

Represents the base class for most chart elements. Chart elements such as series, chart areas, and legends must have unique names, and reuse the unique name generation and validation logic provided by the ChartNamedElementCollection class.

The following tables list the members exposed by the ChartNamedElement type.

Protected Constructors

Name | Description
ChartNamedElement | Overloaded.
Top

Public Properties

Name | Description
Name | Gets or sets the name of the chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartNamedElement Class


ChartNamedElement Constructor

ChartNamedElement Constructor |
 | See Also

Overload List

Name | Description
ChartNamedElement () | Initializes a new instance of the ChartNamedElement class.
ChartNamedElement (String) | Initializes a new instance of the ChartNamedElement class with the specified chart element name.

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members


ChartNamedElement Constructor ()

ChartNamedElement Constructor () |
 | See Also

Initializes a new instance of the ChartNamedElement class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Sub New
protected ChartNamedElement ()
protected:
ChartNamedElement ()
protected ChartNamedElement ()
protected function ChartNamedElement ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members


ChartNamedElement Constructor (String)

ChartNamedElement Constructor (String) |
 | See Also

Initializes a new instance of the ChartNamedElement class with the specified chart element name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Sub New ( _
    name As String _
)
protected ChartNamedElement (
    string name
)
protected:
ChartNamedElement (
    String^ name
)
protected ChartNamedElement (
    String name
)
protected function ChartNamedElement (
    name : String
)

Parameters

name

The name of the new chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members


ChartNamedElement Methods

ChartNamedElement Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartNamedElement Class


ChartNamedElement Properties

ChartNamedElement Properties |
 | See Also

Public Properties

Name | Description
Name | Gets or sets the name of the chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

ChartNamedElement Class


ChartNamedElement.Name Property

ChartNamedElement.Name Property |
 | See Also

Gets or sets the name of the chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Name As String
public virtual string Name { get; set; }
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public function get Name () : String

public function set Name (value : String)

Property Value

A string value that represents the name of the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members


ChartNamedElementCollection Generic Class

ChartNamedElementCollection Generic Class |
 | See Also Members

Represents the base class for all collections of named chart elements. Performs name management and enforces the uniqueness of the names.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public MustInherit Class ChartNamedElementCollection(Of T As ChartNamedElement)
    Inherits ChartElementCollection(Of T)
public abstract class ChartNamedElementCollection<T> : ChartElementCollection<T> where T : ChartNamedElement
generic<typename T> where T : ChartNamedElement
public ref class ChartNamedElementCollection abstract : public ChartElementCollection<T>
J# supports the use of generic types and methods, but not the declaration of new ones.
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
Derived Classes

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Members


ChartNamedElementCollection Members

ChartNamedElementCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents the base class for all collections of named chart elements. Performs name management and enforces the uniqueness of the names.

The following tables list the members exposed by the ChartNamedElementCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded.
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names.
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Finds the chart element by the specified name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded.
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | Determines whether the chart element with the specified name already exists in the collection.
NextUniqueName | Finds the unique name for the new element to be added to the collection.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts the specified item in the collection at the specified index.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the chart element at the specified index of the collection.
SetItem | Overridden. Replaces the chart element at the specified index with a new chart element.
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

ChartNamedElementCollection Class


ChartNamedElementCollection Methods

ChartNamedElementCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | Finds the chart element by the specified name.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded.
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | Determines whether the chart element with the specified name already exists in the collection.
NextUniqueName | Finds the unique name for the new element to be added to the collection.
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | Overridden. Inserts the specified item in the collection at the specified index.
MemberwiseClone | (inherited from Object )
RemoveItem | Overridden. Removes the chart element at the specified index of the collection.
SetItem | Overridden. Replaces the chart element at the specified index with a new chart element.

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

ChartNamedElementCollection Class


ChartNamedElementCollection.FindByName Method

ChartNamedElementCollection.FindByName Method |
 | See Also

Finds the chart element by the specified name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Function FindByName ( _
    name As String _
) As T
public virtual T FindByName (
    string name
)
public:
virtual T FindByName (
    String^ name
)
public T FindByName (
    String name
)
public function FindByName (
    name : String
) : T

Parameters

name

The name of the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.IndexOf Method

ChartNamedElementCollection.IndexOf Method |
 | See Also

Overload List

Name | Description
ChartNamedElementCollection.IndexOf (String) | Finds the index of the chart element with the specified name.
ChartNamedElementCollection.IndexOf (T) | (inherited from IndexOf )

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.IndexOf Method (String)

ChartNamedElementCollection.IndexOf Method (String) |
 | See Also

Finds the index of the chart element with the specified name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function IndexOf ( _
    name As String _
) As Integer
public int IndexOf (
    string name
)
public:
int IndexOf (
    String^ name
)
public int IndexOf (
    String name
)
public function IndexOf (
    name : String
) : int

Parameters

name

The name of the chart element.

Return Value

An integer value that represents the position of the chart element in the zero-based index.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.InsertItem Method

ChartNamedElementCollection.InsertItem Method |
 | See Also

Inserts the specified item in the collection at the specified index.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)
protected override void InsertItem (
    int index,
    T item
)
protected:
virtual void InsertItem (
    int index,
    T item
) override
protected void InsertItem (
    int index,
    T item
)
protected override function InsertItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index where the item is to be inserted.

item

The object to insert.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.IsUniqueName Method

ChartNamedElementCollection.IsUniqueName Method |
 | See Also

Determines whether the chart element with the specified name already exists in the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Function IsUniqueName ( _
    name As String _
) As Boolean
public virtual bool IsUniqueName (
    string name
)
public:
virtual bool IsUniqueName (
    String^ name
)
public boolean IsUniqueName (
    String name
)
public function IsUniqueName (
    name : String
) : boolean

Parameters

name

The new chart element name.

Return Value

True if the new chart element name is unique, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.NextUniqueName Method

ChartNamedElementCollection.NextUniqueName Method |
 | See Also

Finds the unique name for the new element to be added to the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Function NextUniqueName As String
public virtual string NextUniqueName ()
public:
virtual String^ NextUniqueName ()
public String NextUniqueName ()
public function NextUniqueName () : String

Return Value

A string value that represents the next unique chart element name.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.RemoveItem Method

ChartNamedElementCollection.RemoveItem Method |
 | See Also

Removes the chart element at the specified index of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub RemoveItem ( _
    index As Integer _
)
protected override void RemoveItem (
    int index
)
protected:
virtual void RemoveItem (
    int index
) override
protected void RemoveItem (
    int index
)
protected override function RemoveItem (
    index : int
)

Parameters

index

The zero-based index of the chart element to remove.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.SetItem Method

ChartNamedElementCollection.SetItem Method |
 | See Also

Replaces the chart element at the specified index with a new chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)
protected override void SetItem (
    int index,
    T item
)
protected:
virtual void SetItem (
    int index,
    T item
) override
protected void SetItem (
    int index,
    T item
)
protected override function SetItem (
    index : int,
    item : T
)

Parameters

index

The zero-based index of the chart element to replace.

item

The new chart element to insert at the specified index.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection Properties

ChartNamedElementCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded.

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names.

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

ChartNamedElementCollection Class


ChartNamedElementCollection.Item Property

ChartNamedElementCollection.Item Property |
 | See Also

Overload List

Name | Description
ChartNamedElementCollection.Item (Int32) | (inherited from Item )
ChartNamedElementCollection.Item (String) | Gets or sets the chart element with the specified name.

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.Item Property (String)

ChartNamedElementCollection.Item Property (String) |
 | See Also

Gets or sets the chart element with the specified name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Default Property Item ( _
    name As String _
) As T
public T this [
    string name
] { get; set; }
public:
property T default [String^] {
    T get (String^ name);
    void set (String^ name, T value);
}
/** @property */
public T get_Item (String name)

/** @property */
public void set_Item (String name, T value)

Parameters

name

The name of the chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection.NamePrefix Property

ChartNamedElementCollection.NamePrefix Property |
 | See Also

Gets the name prefix that is used to create unique chart element names.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable ReadOnly Property NamePrefix As String
protected virtual string NamePrefix { get; }
protected:
virtual property String^ NamePrefix {
    String^ get ();
}
/** @property */
protected String get_NamePrefix ()

protected function get NamePrefix () : String

Property Value

A string value that represents the default name prefix of the chart elements stored in the collection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartPaintEventArgs Class

ChartPaintEventArgs Class |
 | See Also Members

Provides data for the paint events of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartPaintEventArgs
    Inherits EventArgs
public class ChartPaintEventArgs : EventArgs
public ref class ChartPaintEventArgs : public EventArgs
public class ChartPaintEventArgs extends EventArgs
public class ChartPaintEventArgs extends EventArgs

Remarks

A ChartPaintEventArgs object is used to set chart properties during the PostPaint and PrePaint events of the Chart control.

The Position property allows you to position chart elements, and the ChartGraphics property facilitates GDI+ drawing operations.

The Chart property gives the developer access to the root Chart object, which can be used to set various properties of the chart.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.ChartPaintEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Members


ChartPaintEventArgs Members

ChartPaintEventArgs Members |
 | See Also Methods Properties

Provides data for the paint events of the Chart control.

The following tables list the members exposed by the ChartPaintEventArgs type.

Public Properties

Name | Description
Chart | Gets the root Chart object.
ChartElement | Gets an Object for the event.
ChartGraphics | Gets a ChartGraphics object.
Position | Gets an ElementPosition object.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartPaintEventArgs Class


ChartPaintEventArgs Methods

ChartPaintEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartPaintEventArgs Class


ChartPaintEventArgs Properties

ChartPaintEventArgs Properties |
 | See Also

Public Properties

Name | Description
Chart | Gets the root Chart object.
ChartElement | Gets an Object for the event.
ChartGraphics | Gets a ChartGraphics object.
Position | Gets an ElementPosition object.

See Also

Reference

ChartPaintEventArgs Class


ChartPaintEventArgs.Chart Property

ChartPaintEventArgs.Chart Property |
 | See Also

Gets the root Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Chart As Chart
public Chart Chart { get; }
public:
property Chart^ Chart {
    Chart^ get ();
}
/** @property */
public Chart get_Chart ()

public function get Chart () : Chart

Property Value

The root Chart object.

Remarks

The Chart property allows the developer to set chart properties during the PostPaint and PrePaint events of the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members


ChartPaintEventArgs.ChartElement Property

ChartPaintEventArgs.ChartElement Property |
 | See Also

Gets an Object for the event.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ChartElement As Object
public Object ChartElement { get; }
public:
property Object^ ChartElement {
    Object^ get ();
}
/** @property */
public Object get_ChartElement ()

public function get ChartElement () : Object

Property Value

An Object that represents the hart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members


ChartPaintEventArgs.ChartGraphics Property

ChartPaintEventArgs.ChartGraphics Property |
 | See Also

Gets a ChartGraphics object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ChartGraphics As ChartGraphics
public ChartGraphics ChartGraphics { get; }
public:
property ChartGraphics^ ChartGraphics {
    ChartGraphics^ get ();
}
/** @property */
public ChartGraphics get_ChartGraphics ()

public function get ChartGraphics () : ChartGraphics

Property Value

A ChartGraphics object.

Remarks

Use this object property during a painting event to:

  • Help with the conversion to and from relative and/or absolute chart coordinates.

  • Perform custom drawing using a GDI+ Graphics object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members


ChartPaintEventArgs.Position Property

ChartPaintEventArgs.Position Property |
 | See Also

Gets an ElementPosition object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Position As ElementPosition
public ElementPosition Position { get; }
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
}
/** @property */
public ElementPosition get_Position ()

public function get Position () : ElementPosition

Property Value

An ElementPosition object.

Remarks

Use this object property during a painting event to position a chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartPaintEventArgs Class
ChartPaintEventArgs Members


ChartSerializer Class

ChartSerializer Class |
 | See Also Members

Enables serialization of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ChartSerializer
public class ChartSerializer
public ref class ChartSerializer
public class ChartSerializer
public class ChartSerializer

Remarks

This class is exposed as the Serializer property of the root Chart class.

Serialization saves the state of the chart and also provides the option to load the serialized data into the chart. All chart properties can be persisted, including the chart's data. In addition, all chart properties marked for serialization can be reset.

This class can optionally be used when managing user-defined view state. One of its Load methods can be used to load the view state, and one of the Save methods can be used when setting the view state.

The XML or binary formats can be used to store serialized data. XML is used by default, but you can change the format with the Format property.

Chart properties are saved and loaded using the Save and Load methods, respectively. Note that only properties with non-default values will be saved. Data can be saved and/or loaded using a file, stream, TextWriter, TextReader, XmlWriter and XmlReader objects. When saving and/or loading data using an object derived from the TextReader, TextWriter, XmlReader or XmlWriter classes, the format of the data must be XML.

The following list describes three techniques, from basic to advanced, used to define serializable data. Note that it is also possible to define non-serializable data. This technique is described in the next paragraph.

  • Serialize the Chart using the Save and Load methods, without specifying any serializable properties. All chart properties with non-default values, which includes chart data, will be serialized.

  • Serialize the chart properties specified by the Content property. The Content property groups the chart properties to be serialized into categories such as Data, Appearance, and so forth. Note that the names of ChartArea and Series objects are automatically serialized; the serialized data is then applied to existing chart areas and series when loaded.

Important:
The Content property is implemented internally by the Chart control as the SerializableContent property

  • Serialization of chart properties specified by the SerializableContent property. This is a comma-separated listing of all chart properties that are serializable. After this property is set to an explicit value, it is the responsibility of the developer to specify all properties to be saved. In other words, unlike the Content property, the names of chart areas and series will not be automatically persisted. The Content and SerializableContent properties can also be used in conjunction. However, make sure that SerializableContent is concatenated with itself when being set, otherwise the chart properties specified by the Content property will be overridden.

To prohibit certain properties from being serialized, use the NonSerializableContent property. When one property is set as serializable and non-serializable, which is common when wildcards are used, the SerializableContent property has precedence. However, precedence also depends on how many wildcards were used when a property was specified.

By default, serializable properties are reset to their defaults before they are loaded. This behavior can be changed using the IsResetWhenLoading property. The Reset method can also be used to explicitly reset chart properties to their default values.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartSerializer

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Members


ChartSerializer Members

ChartSerializer Members |
 | See Also Methods Properties

Enables serialization of the Chart control.

The following tables list the members exposed by the ChartSerializer type.

Public Properties

Name | Description
Content | Gets or sets the type of chart content to be serialized.
Format | Gets or sets the format used when the chart is serialized.
IsResetWhenLoading | Gets or sets a flag that indicates whether object properties are reset to default values before loading.
IsTemplateMode | Gets or sets a flag that indicates whether the chart serializer is working in template-creation mode.
IsUnknownAttributeIgnored | Gets or sets a flag that indicates whether unknown XML properties and elements will be ignored without throwing an exception.
NonSerializableContent | Gets or sets the chart properties that will not be serialized.
SerializableContent | Gets or sets the chart properties that can be serialized.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Load | Overloaded. Loads serialized data into the Chart control.
ReferenceEquals | (inherited from Object )
Reset | Resets all chart properties marked for serialization.
Save | Overloaded. Saves chart properties that have non-default values. All chart properties can be serialized; this includes data.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
GetContentString | Returns a serializable or non serializable class and/or property names, depending on the specific flag value.
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ChartSerializer Class


ChartSerializer Methods

ChartSerializer Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Load | Overloaded. Loads serialized data into the Chart control.
ReferenceEquals | (inherited from Object )
Reset | Resets all chart properties marked for serialization.
Save | Overloaded. Saves chart properties that have non-default values. All chart properties can be serialized; this includes data.
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
GetContentString | Returns a serializable or non serializable class and/or property names, depending on the specific flag value.
MemberwiseClone | (inherited from Object )

See Also

Reference

ChartSerializer Class


ChartSerializer.GetContentString Method

ChartSerializer.GetContentString Method |
 | See Also

Returns a serializable or non serializable class and/or property names, depending on the specific flag value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Function GetContentString ( _
    content As SerializationContents, _
    serializable As Boolean _
) As String
protected string GetContentString (
    SerializationContents content,
    bool serializable
)
protected:
String^ GetContentString (
    SerializationContents content,
    bool serializable
)
protected String GetContentString (
    SerializationContents content,
    boolean serializable
)
protected function GetContentString (
    content : SerializationContents,
    serializable : boolean
) : String

Parameters

content

The serializable content.

serializable

True to get a serializable string; false to get a non serializaable string.

Return Value

A string value that represents the serializable or non serializable class and/or property names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Load Method

ChartSerializer.Load Method |
 | See Also

Loads serialized data into the Chart control.

Overload List

Name | Description
ChartSerializer.Load (Stream) | Loads serialized data into the control from an object derived from the Stream class.
ChartSerializer.Load (String) | Loads serialized data saved to disk into the Chart control.
ChartSerializer.Load (TextReader) | Loads serialized data into the control from a reader object that derives from the TextReader class.
ChartSerializer.Load (XmlReader) | Loads serialized data into the control from an object derived from the XmlReader class.

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Load Method (Stream)

ChartSerializer.Load Method (Stream) |
 | See Also

Loads serialized data into the control from an object derived from the Stream class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Load ( _
    stream As Stream _
)
public void Load (
    Stream stream
)
public:
void Load (
    Stream^ stream
)
public void Load (
    Stream stream
)
public function Load (
    stream : Stream
)

Parameters

stream

An object derived from the Stream class, for example, a MemoryStream object.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, serializable properties are, by default, first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. To load specific serialized properties, set the Content , SerializableContent or NonSerializableContent properties before loading the data.

Note that when data is saved using a Save method, only those properties that have non-default values are actually serialized.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Load Method (String)

ChartSerializer.Load Method (String) |
 | See Also

Loads serialized data saved to disk into the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Load ( _
    fileName As String _
)
public void Load (
    string fileName
)
public:
void Load (
    String^ fileName
)
public void Load (
    String fileName
)
public function Load (
    fileName : String
)

Parameters

fileName

The relative or absolute path of the file used to store the serialized data. If a relative path is specified, the path will be relative to the current directory.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, serializable properties are, by default, first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. To load specific serialized properties, set the Content , SerializableContent or NonSerializableContent properties before loading the data.

Note that when data is saved using a Save method, only those properties that have non-default values are actually serialized.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Load Method (TextReader)

ChartSerializer.Load Method (TextReader) |
 | See Also

Loads serialized data into the control from a reader object that derives from the TextReader class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Load ( _
    reader As TextReader _
)
public void Load (
    TextReader reader
)
public:
void Load (
    TextReader^ reader
)
public void Load (
    TextReader reader
)
public function Load (
    reader : TextReader
)

Parameters

reader

A reader, such as StringReader, that is derived from the abstract TextReader class.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, by default the serializable properties are first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. By setting the Content, SerializableContent or NonSerializableContent properties, a specific set of properties can be loaded.

If you use this definition, note that the format, which is set by the Format property, must be XML.

If the ViewStateData property of the Chart control is used to persist state, this method can be used to load the serialized data that is posted by the client back to the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Load Method (XmlReader)

ChartSerializer.Load Method (XmlReader) |
 | See Also

Loads serialized data into the control from an object derived from the XmlReader class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Load ( _
    reader As XmlReader _
)
public void Load (
    XmlReader reader
)
public:
void Load (
    XmlReader^ reader
)
public void Load (
    XmlReader reader
)
public function Load (
    reader : XmlReader
)

Parameters

reader

An object from which to read the persisted data. The object is derived from the XmlReader class, and can be a .NET Framework object or a user-defined object.

Remarks

Call this method to load serialized data into the Chart control.

When a load operation occurs, by default serializable properties are first reset to their default values before they are set to the persisted values, if saved. To change this behavior, use the IsResetWhenLoading property.

By default, all serialized chart properties will be loaded. If you set the Content, SerializableContent or NonSerializableContent properties, a specific set of properties can be loaded.

When you use this definition, the format must be XML; the format can be changed with the Format property.

When you work with XML format text files, for simplicity use the Load method instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Reset Method

ChartSerializer.Reset Method |
 | See Also

Resets all chart properties marked for serialization.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Reset
public void Reset ()
public:
void Reset ()
public void Reset ()
public function Reset ()

Remarks

By default, this method resets all chart properties to their default values.

To limit the chart properties that are reset to their defaults, use the Content, SerializableContent and NonSerializableContent properties.

Note that this method is also called automatically when a Load method is used and the IsResetWhenLoading property is set to true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Save Method

ChartSerializer.Save Method |
 | See Also

Saves chart properties that have non-default values. All chart properties can be serialized; this includes data.

Overload List

Name | Description
ChartSerializer.Save (Stream) | Saves chart data and properties with non-default values to an object that derives from the Stream class.
ChartSerializer.Save (String) | Saves chart data and properties with non-default values to the given file.
ChartSerializer.Save (TextWriter) | Saves chart data and properties with non-default values to the given object that is derived from the TextWriter class.
ChartSerializer.Save (XmlWriter) | Saves chart data and properties with non-default values to the given object that is derived from the XmlWriter class.

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Save Method (Stream)

ChartSerializer.Save Method (Stream) |
 | See Also

Saves chart data and properties with non-default values to an object that derives from the Stream class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Save ( _
    stream As Stream _
)
public void Save (
    Stream stream
)
public:
void Save (
    Stream^ stream
)
public void Save (
    Stream stream
)
public function Save (
    stream : Stream
)

Parameters

stream

An object derived from the Stream class, such as MemoryStream, that is used to save chart properties.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control chart characteristics to be serialized, use the Content, SerializableContent and NonSerializableContent properties.

If this method is used to save appearance properties as a template, make sure that the IsTemplateMode property of the ChartSerializer object is first set to true before calling this method.

Serialization of a chart as a template occurs differently from non-template serialization; template serialization concentrates on Appearance properties.

When a template is serialized, the LoadTemplate method can be used to load the template, to provide the Appearance properties for a chart.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Save Method (String)

ChartSerializer.Save Method (String) |
 | See Also

Saves chart data and properties with non-default values to the given file.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Save ( _
    fileName As String _
)
public void Save (
    string fileName
)
public:
void Save (
    String^ fileName
)
public void Save (
    String fileName
)
public function Save (
    fileName : String
)

Parameters

fileName

The relative or absolute path of the file used to store the serialized data. Note that if a relative path is specified, the path will be relative to the current directory.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control chart characteristics to be serialized use the Content, SerializableContent and NonSerializableContent properties.

By default data is saved in an XML format. To save the data in a binary format, use the Format property.

Note that Write permissions must be enabled for the directory in which the file is stored. By default, this is the Bin folder of the application.

If this method is being used to save Appearance properties as a template, make sure that the IsTemplateMode property is first set to true before calling this method.

Serialization of a chart as a template proceeds differently from non-template serialization, primarily because template serialization concentrates on Appearance properties.

When a template is serialized, the LoadTemplate method can be used to load the template, to provide the Appearance properties for a chart.

Templates can be used to simulate custom palettes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Save Method (TextWriter)

ChartSerializer.Save Method (TextWriter) |
 | See Also

Saves chart data and properties with non-default values to the given object that is derived from the TextWriter class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Save ( _
    writer As TextWriter _
)
public void Save (
    TextWriter writer
)
public:
void Save (
    TextWriter^ writer
)
public void Save (
    TextWriter writer
)
public function Save (
    writer : TextWriter
)

Parameters

writer

An object derived from TextWriter class, for example, StringWriter, that is used to save chart properties.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control which chart characteristics are serialized, use the Content, SerializableContent and NonSerializableContent properties.

When you use this definition, the format must be XML; the format can be set with the Format property.

If the ViewStateData property of the Chart control is used to persist state, this method can be used to save the serialized data to an object derived from TextWriter, which is then used to write the data to the ViewStateData property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Save Method (XmlWriter)

ChartSerializer.Save Method (XmlWriter) |
 | See Also

Saves chart data and properties with non-default values to the given object that is derived from the XmlWriter class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Save ( _
    writer As XmlWriter _
)
public void Save (
    XmlWriter writer
)
public:
void Save (
    XmlWriter^ writer
)
public void Save (
    XmlWriter writer
)
public function Save (
    writer : XmlWriter
)

Parameters

writer

An object derived from XmlWriter used to save Chart properties.

Remarks

By default, all chart properties with non-default values, which includes data points, will be serialized when this method is called. To control which chart characteristics are serialized, use the Content, SerializableContent and NonSerializableContent properties.

When you use this definition, the format must be XML; the format can be changed with the Format property.

When you work with XML format text files, for simplicity use the Save method instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer Properties

ChartSerializer Properties |
 | See Also

Public Properties

Name | Description
Content | Gets or sets the type of chart content to be serialized.
Format | Gets or sets the format used when the chart is serialized.
IsResetWhenLoading | Gets or sets a flag that indicates whether object properties are reset to default values before loading.
IsTemplateMode | Gets or sets a flag that indicates whether the chart serializer is working in template-creation mode.
IsUnknownAttributeIgnored | Gets or sets a flag that indicates whether unknown XML properties and elements will be ignored without throwing an exception.
NonSerializableContent | Gets or sets the chart properties that will not be serialized.
SerializableContent | Gets or sets the chart properties that can be serialized.

See Also

Reference

ChartSerializer Class


ChartSerializer.Content Property

ChartSerializer.Content Property |
 | See Also

Gets or sets the type of chart content to be serialized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Content As SerializationContents
public SerializationContents Content { get; set; }
public:
property SerializationContents Content {
    SerializationContents get ();
    void set (SerializationContents value);
}
/** @property */
public SerializationContents get_Content ()

/** @property */
public void set_Content (SerializationContents value)

public function get Content () : SerializationContents

public function set Content (value : SerializationContents)

Property Value

A SerializationContents enumeration value that represents the chart content that will be serialized during a load, save or reset operation. By default, all non-default chart properties, including data, are persisted.

Remarks

By default, all chart properties will be serialized when any of the Save and Load methods are called. To provide more control over what is serialized, use the Content property. Note that the SerializableContent and NonSerializableContent properties can also be used along with the Content property.

Important The Content property determines types of chart characteristics, such as "appearance", to be serialized, and is actually implemented internally as the SerializableContent property. This means that setting the Content property and then setting the SerializableContent property will result in the Content property value being overridden, unless SerializableContent is concatenated. See the sample code below for an example of this procedure.

If you set the Content property, all ChartArea and Series objects names will automatically be serialized; this means that serialized data that pertains to chart areas and series will be applied to existing objects when loaded.

Setting this property affects all load, save and reset operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.Format Property

ChartSerializer.Format Property |
 | See Also

Gets or sets the format used when the chart is serialized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Format As SerializationFormat
public SerializationFormat Format { get; set; }
public:
property SerializationFormat Format {
    SerializationFormat get ();
    void set (SerializationFormat value);
}
/** @property */
public SerializationFormat get_Format ()

/** @property */
public void set_Format (SerializationFormat value)

public function get Format () : SerializationFormat

public function set Format (value : SerializationFormat)

Property Value

A SerializationFormat enumeration value that represents the format of the serialized data. The default value is XML.

Remarks

Data can be serialized in either an XML or binary format. Binary format is compact, and takes less storage than XML. XML, however, is a text format that is human-readable.

When you save or load serialized data, the format must be XML.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.IsResetWhenLoading Property

ChartSerializer.IsResetWhenLoading Property |
 | See Also

Gets or sets a flag that indicates whether object properties are reset to default values before loading.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsResetWhenLoading As Boolean
public bool IsResetWhenLoading { get; set; }
public:
property bool IsResetWhenLoading {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsResetWhenLoading ()

/** @property */
public void set_IsResetWhenLoading (boolean value)

public function get IsResetWhenLoading () : boolean

public function set IsResetWhenLoading (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.IsTemplateMode Property

ChartSerializer.IsTemplateMode Property |
 | See Also

Gets or sets a flag that indicates whether the chart serializer is working in template-creation mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsTemplateMode As Boolean
public bool IsTemplateMode { get; set; }
public:
property bool IsTemplateMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsTemplateMode ()

/** @property */
public void set_IsTemplateMode (boolean value)

public function get IsTemplateMode () : boolean

public function set IsTemplateMode (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.IsUnknownAttributeIgnored Property

ChartSerializer.IsUnknownAttributeIgnored Property |
 | See Also

Gets or sets a flag that indicates whether unknown XML properties and elements will be ignored without throwing an exception.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsUnknownAttributeIgnored As Boolean
public bool IsUnknownAttributeIgnored { get; set; }
public:
property bool IsUnknownAttributeIgnored {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsUnknownAttributeIgnored ()

/** @property */
public void set_IsUnknownAttributeIgnored (boolean value)

public function get IsUnknownAttributeIgnored () : boolean

public function set IsUnknownAttributeIgnored (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.NonSerializableContent Property

ChartSerializer.NonSerializableContent Property |
 | See Also

Gets or sets the chart properties that will not be serialized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NonSerializableContent As String
public string NonSerializableContent { get; set; }
public:
property String^ NonSerializableContent {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_NonSerializableContent ()

/** @property */
public void set_NonSerializableContent (String value)

public function get NonSerializableContent () : String

public function set NonSerializableContent (value : String)

Property Value

A comma-separated string expression that represents the chart properties that will not be serialized. The syntax is "Class.Property[,Class.Property]".

Remarks

By default all chart properties will be serialized when the Save and Load methods are called. You can use the NonSerializableContent property to limit chart characteristics to be serialized, along with the SerializableContent and Content properties.

This property determines which chart characteristics will not be serialized. Wildcards can be used in the string expression, in the same manner as the SerializableContent property. For example, to exclude all chart BackColor properties from serialization, set this property to "*.BackColor".

Sometimes, a property can be set to be both serialized and not serialized, which is common when wildcards are used. The NonSerializableContent expression has a lower priority when compared to the SerializableContent expression. However, note that less weight is given to string expressions that use wildcards. For example, if the SerializableContent property is set to "*.BackColor" and the NonSerializableContent property is set to BackColor, all BackColor properties except for ChartArea objects will be serialized.

If the Content property has been set, the priority depends on how many wild cards are used in the NonSerializableContent expression. For example, setting the Content property to Appearance will result in the SerializableContent property containing a "*.Back*" expression. If the NonSerializableContent property is set to "*.Back*", all Back* chart properties such as BackColor, BackGradient, and so forth, will still be serialized. This is because the SerializableContent property value has higher priority when compared to the NonSerializableContent property.

This property affects all save, load and reset operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartSerializer.SerializableContent Property

ChartSerializer.SerializableContent Property |
 | See Also

Gets or sets the chart properties that can be serialized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SerializableContent As String
public string SerializableContent { get; set; }
public:
property String^ SerializableContent {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_SerializableContent ()

/** @property */
public void set_SerializableContent (String value)

public function get SerializableContent () : String

public function set SerializableContent (value : String)

Property Value

A comma-separated string expression that represents the chart properties to be serialized. The syntax is "Class.Property[,Class.Property]".

Remarks

By default all chart properties will be serialized when the Save and Load methods are called. You can use the NonSerializableContent property to limit chart characteristics to be serialized, along with the SerializableContent and Content properties.

The SerializableContent property determines which chart characteristics will be serialized. Wildcards can be used in the string expression, in the same manner as the NonSerializableContent property. For example, to serialize all chart BackColor properties, set this property to "*.BackColor".

If ChartArea and/or Series child properties are specified, then the names of all ChartArea and Series objects must be also specified to enable the persisted data to be applied to existing ChartArea and Series objects; that is, you must specify "Series.Name" and "ChartArea.Name" expressions. See the sample code below for an example of this procedure. Similarly, if multiple chart areas are being used, the ChartArea property of all plotted Series must also be saved.

Sometimes, a property can be set to be both serialized and not serialized, which is common when wildcards are used. The NonSerializableContent expression has a lower priority when compared to the SerializableContent expression. However, note that less weight is given to string expressions that use wildcards. For example, if the SerializableContent property is set to "*.BackColor" and the NonSerializableContent property is set to BackColor, all BackColor properties except for ChartArea objects will be serialized.

If you set the Content property, the SerializableContent property will be set internally. If the Content property is already set but another property needs to be serialized, make sure to concatenate the SerializableContent property when specifying that extra property. See the sample code below for an example of this procedure.

This property affects all save, load and reset operations.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ChartSerializer Class
ChartSerializer Members


ChartValueType Enumeration

ChartValueType Enumeration |
 | See Also

Specifies value types for various chart properties.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ChartValueType
public enum ChartValueType
public enum class ChartValueType
public enum ChartValueType
public enum ChartValueType

Members

Member name | Description
Auto | Property type is set automatically by the Chart control.
Date | The Date portion of a DateTime value.
DateTime | A DateTime value.
DateTimeOffset | A DateTime value with offset.
Double | A Double value.
Int32 | A Int32 value.
Int64 | A Int64 value.
Single | A Single value.
String | A String value.
Time | The Time portion of the DateTime value.
UInt32 | A UInt32 value.
UInt64 | A UInt64 value.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


CompareMethod Enumeration

CompareMethod Enumeration |
 | See Also

Specifies the type of comparison to be used when filtering data. This enumeration is used by the Filter method definitions in the DataManipulator class that take the CompareMethod argument.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration CompareMethod
public enum CompareMethod
public enum class CompareMethod
public enum CompareMethod
public enum CompareMethod

Members

Member name | Description
EqualTo | If the data point value is equal to the compared value, the point is filtered.
LessThan | If the data point value is less than the compared value, the point is filtered.
LessThanOrEqualTo | If the data point value is less than or equal to the compared value, the point is filtered.
MoreThan | If the data point value is more than the compared value, the point is filtered.
MoreThanOrEqualTo | If the data point value more than or equal to the compared value, the point is filtered.
NotEqualTo | If the data point value is not equal to the compared value, the point is filtered.

Remarks

The CompareMethod enumeration represents a comparison type for certain filtering operations.

Note:
By default, if the filtering criteria are met, a data point is either removed or marked as empty. However, data points can be filtered even if they do not match the filtering criteria, by setting the FilterMatchedPoints property to false.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Cursor Class

Cursor Class |
 | See Also Members

Represents a horizontal or vertical line that defines a position along an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Cursor
    Implements IDisposable
public class Cursor : IDisposable
public ref class Cursor : IDisposable
public class Cursor implements IDisposable
public class Cursor implements IDisposable

Remarks

A cursor is a horizontal or vertical line that defines a position along an axis. A range selection is a range along an axis that is defined by a beginning and end position, and is displayed using a semi-transparent color.

Cursors and range selections are both implemented by the Cursor class, which is exposed as the CursorX and CursorY properties of the ChartArea object. The CursorX object is for the X axis of a chart area, and the CursorY object is for the Y axis. The AxisType property of these objects determines whether the associated axis is primary or secondary.

The only cursor and range selection functionality found outside the Cursor class are the events related to the cursor and range selection that are in the root Chart object.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.Cursor

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Members


Cursor Members

Cursor Members |
 | See Also Constructors Methods Properties

Represents a horizontal or vertical line that defines a position along an axis.

The following tables list the members exposed by the Cursor type.

Public Constructors

Name | Description
Cursor | Initializes a new instance of the Cursor class.
Top

Public Properties

Name | Description
AutoScroll | Gets or sets a flag that determines whether scrolling will occur if a range selection operation extends beyond a boundary of the chart area.
AxisType | Gets or sets the type of axis that the cursor is attached to.
Interval | Gets or sets the cursor interval.
IntervalOffset | Gets or sets the interval offset, which affects where the cursor and range selection can be drawn when they are set by a user.
IntervalOffsetType | Gets or sets the interval offset type of a cursor and selected range for an axis.
IntervalType | Gets or sets the interval type for the cursor and selected range of an axis.
IsUserEnabled | Gets or sets a flag that enables or disables the cursor user interface.
IsUserSelectionEnabled | Gets or sets a flag that enables or disables the range selection user interface.
LineColor | Gets or sets the cursor line color.
LineDashStyle | Gets or sets the style of the cursor line.
LineWidth | Gets or sets the line width, in pixels, of a cursor
Position | Gets or sets the position of a cursor.
SelectionColor | Gets or sets a semi-transparent color that highlights a range of data.
SelectionEnd | Gets or sets the end position of a range selection.
SelectionStart | Gets or sets the start position of a cursor's selected range.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
SetCursorPixelPosition | Displays a cursor at the specified position. Measured in pixels.
SetCursorPosition | Sets the position of a cursor within a chart area at the specified axis value.
SetSelectionPixelPosition | Sets the start and end positions of a range selection.
SetSelectionPosition | Sets the position of a selected range within a chart area at the specified axis values.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Cursor Class


Cursor Constructor

Cursor Constructor |
 | See Also

Initializes a new instance of the Cursor class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Cursor ()
public:
Cursor ()
public Cursor ()
public function Cursor ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor Methods

Cursor Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
SetCursorPixelPosition | Displays a cursor at the specified position. Measured in pixels.
SetCursorPosition | Sets the position of a cursor within a chart area at the specified axis value.
SetSelectionPixelPosition | Sets the start and end positions of a range selection.
SetSelectionPosition | Sets the position of a selected range within a chart area at the specified axis values.
ToString | (inherited from Object )

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Cursor Class


Cursor.Dispose Method

Cursor.Dispose Method |
 | See Also

Overload List

Name | Description
Cursor.Dispose () | Performs application-defined tasks that free, release, or reset unmanaged resources.
Cursor.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources

See Also

Reference

Cursor Class
Cursor Members


Cursor.Dispose Method ()

Cursor.Dispose Method () |
 | See Also

Performs application-defined tasks that free, release, or reset unmanaged resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Dispose
public void Dispose ()
public:
virtual void Dispose () sealed
public final void Dispose ()
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.Dispose Method (Boolean)

Cursor.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SetCursorPixelPosition Method

Cursor.SetCursorPixelPosition Method |
 | See Also

Displays a cursor at the specified position. Measured in pixels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SetCursorPixelPosition ( _
    point As PointF, _
    roundToBoundary As Boolean _
)
public void SetCursorPixelPosition (
    PointF point,
    bool roundToBoundary
)
public:
void SetCursorPixelPosition (
    PointF point,
    bool roundToBoundary
)
public void SetCursorPixelPosition (
    PointF point,
    boolean roundToBoundary
)
public function SetCursorPixelPosition (
    point : PointF,
    roundToBoundary : boolean
)

Parameters

point

A PointF structure that specifies where the cursor will be drawn.

roundToBoundary

If true, the cursor will be drawn along the nearest chart area boundary, if the specified position does not fall within a ChartArea object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SetCursorPosition Method

Cursor.SetCursorPosition Method |
 | See Also

Sets the position of a cursor within a chart area at the specified axis value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SetCursorPosition ( _
    newPosition As Double _
)
public void SetCursorPosition (
    double newPosition
)
public:
void SetCursorPosition (
    double newPosition
)
public void SetCursorPosition (
    double newPosition
)
public function SetCursorPosition (
    newPosition : double
)

Parameters

newPosition

The new position of the cursor. Measured as a value along the relevant axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SetSelectionPixelPosition Method

Cursor.SetSelectionPixelPosition Method |
 | See Also

Sets the start and end positions of a range selection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SetSelectionPixelPosition ( _
    startPoint As PointF, _
    endPoint As PointF, _
    roundToBoundary As Boolean _
)
public void SetSelectionPixelPosition (
    PointF startPoint,
    PointF endPoint,
    bool roundToBoundary
)
public:
void SetSelectionPixelPosition (
    PointF startPoint,
    PointF endPoint,
    bool roundToBoundary
)
public void SetSelectionPixelPosition (
    PointF startPoint,
    PointF endPoint,
    boolean roundToBoundary
)
public function SetSelectionPixelPosition (
    startPoint : PointF,
    endPoint : PointF,
    roundToBoundary : boolean
)

Parameters

startPoint

A PointF structure that specifies where the range selection begins.

endPoint

A PointF structure that specifies where the range selection ends.

roundToBoundary

If true, the start and end points will be rounded to the nearest chart area boundary if the specified positions do not fall within a ChartArea object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SetSelectionPosition Method

Cursor.SetSelectionPosition Method |
 | See Also

Sets the position of a selected range within a chart area at the specified axis values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub SetSelectionPosition ( _
    newStart As Double, _
    newEnd As Double _
)
public void SetSelectionPosition (
    double newStart,
    double newEnd
)
public:
void SetSelectionPosition (
    double newStart,
    double newEnd
)
public void SetSelectionPosition (
    double newStart,
    double newEnd
)
public function SetSelectionPosition (
    newStart : double,
    newEnd : double
)

Parameters

newStart

The new start position of the range selection. Measured as a value along the relevant axis.

newEnd

The new end position of the range selection. Measured as a value along the relevant axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor Properties

Cursor Properties |
 | See Also

Public Properties

Name | Description
AutoScroll | Gets or sets a flag that determines whether scrolling will occur if a range selection operation extends beyond a boundary of the chart area.
AxisType | Gets or sets the type of axis that the cursor is attached to.
Interval | Gets or sets the cursor interval.
IntervalOffset | Gets or sets the interval offset, which affects where the cursor and range selection can be drawn when they are set by a user.
IntervalOffsetType | Gets or sets the interval offset type of a cursor and selected range for an axis.
IntervalType | Gets or sets the interval type for the cursor and selected range of an axis.
IsUserEnabled | Gets or sets a flag that enables or disables the cursor user interface.
IsUserSelectionEnabled | Gets or sets a flag that enables or disables the range selection user interface.
LineColor | Gets or sets the cursor line color.
LineDashStyle | Gets or sets the style of the cursor line.
LineWidth | Gets or sets the line width, in pixels, of a cursor
Position | Gets or sets the position of a cursor.
SelectionColor | Gets or sets a semi-transparent color that highlights a range of data.
SelectionEnd | Gets or sets the end position of a range selection.
SelectionStart | Gets or sets the start position of a cursor's selected range.

See Also

Reference

Cursor Class


Cursor.AutoScroll Property

Cursor.AutoScroll Property |
 | See Also

Gets or sets a flag that determines whether scrolling will occur if a range selection operation extends beyond a boundary of the chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AutoScroll As Boolean
public bool AutoScroll { get; set; }
public:
property bool AutoScroll {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AutoScroll ()

/** @property */
public void set_AutoScroll (boolean value)

public function get AutoScroll () : boolean

public function set AutoScroll (value : boolean)

Property Value

A Boolean value that represents whether the data view can be scrolled automatically. The default value is true.

Remarks

If a data view does not display all data points in a plotted series and a range is being selected by the user, automatic scrolling of the view will occur if this property is true and the mouse—and therefore the cursor—is moved outside the chart area boundary.

Scrolling will only occur along an axis if there is more data available to be viewed.

A data view that does not display all data usually results if the end-user zooms into a subset of data. Views and zooming are implemented by the AxisScaleView class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.AxisType Property

Cursor.AxisType Property |
 | See Also

Gets or sets the type of axis that the cursor is attached to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AxisType As AxisType
public AxisType AxisType { get; set; }
public:
property AxisType AxisType {
    AxisType get ();
    void set (AxisType value);
}
/** @property */
public AxisType get_AxisType ()

/** @property */
public void set_AxisType (AxisType value)

public function get AxisType () : AxisType

public function set AxisType (value : AxisType)

Property Value

An AxisType enumeration value that represents whether the axis is attached to the primary or secondary axis.

Remarks

There are two sets of axes: primary and secondary. Primary axes for all charts except the bar charts are located at the bottom (primary X-axis) and left (primary Y-axis) border of the chart area.

The secondary axes are located at the right (secondary X-axis) and top (secondary Y-axis) border of the chart area.

Note:
If all series plotted within a chart area use only one type of axis (for example, the primary X-axis), then setting this property to an axis type not used by the series (in this case, the secondary X-axis) will have no effect; the cursor will automatically be attached to the only axis being used to plot the series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.Interval Property

Cursor.Interval Property |
 | See Also

Gets or sets the cursor interval.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value representing the cursor interval.

Remarks

The Interval property determines how often and where a cursor can be drawn by an end user, as well as where the beginning and end points of a range selection can be drawn. A value of zero, which is the default value, signifies that a cursor or range selection can be drawn anywhere within a chart area. A nonzero value signifies that the cursor or beginning and/or end points of a selected range will only be drawn at the specified interval when set by user interaction.

The unit of measurement is determined by the IntervalType property.

This property can also be used in conjunction with the IntervalOffset property, which allows you to specify an offset from the specified interval. For example, to allow a cursor to only be displayed every Saturday, an interval of 1 week should be specified, along with an interval offset of 6 days. In .NET Framework, Sunday is considered to be the first day of the week.

If the cursor user interface is enabled by setting the IsUserEnabled property, and the mouse is clicked inside a chart area, the position of the cursor will be set to the nearest allowable location.

Important:
TheInterval property has no effect if you set the position of a cursor or range selection programmatically.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.IntervalOffset Property

Cursor.IntervalOffset Property |
 | See Also

Gets or sets the interval offset, which affects where the cursor and range selection can be drawn when they are set by a user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the offset from the interval. The default value is zero, which signifies no limitations, and negative values are allowed.

Remarks

The IntervalOffset property determines the interval offset of a cursor and the beginning and/or end points of a range selection. In conjunction with the Interval property, this property determines where a cursor and range can be displayed within a chart area. A value of zero, which is the default, signifies that there is no offset.

The unit of measurement is determined by the IntervalOffsetType property.

The offset affects the locations at which a cursor and the beginning and/or end points of a range selection can be drawn. For example, to allow a cursor to only be displayed every Saturday, an interval of 1 week should be specified, along with an interval offset of 6 days. In .NET Framework, Sunday is considered to be the first day of the week.

If the cursor user interface is enabled by setting the IsUserEnabled property, and the mouse is clicked inside a chart area, the position of the cursor will be set to the nearest allowable location.

Important:
Interval-related properties have no effect when a range selection or cursor position are set programmatically.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.IntervalOffsetType Property

Cursor.IntervalOffsetType Property |
 | See Also

Gets or sets the interval offset type of a cursor and selected range for an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that determines the unit of measurement for the interval offset.

Remarks

The IntervalOffsetType property determines the type of interval offset, which is specified using the IntervalOffset property.

If the IntervalOffsetType property is set to Auto, the IntervalType property setting will be used.

Note:
Interval-related properties have no effect when a range selection or cursor position are set programmatically.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.IntervalType Property

Cursor.IntervalType Property |
 | See Also

Gets or sets the interval type for the cursor and selected range of an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Remarks

The IntervalType property determines the type of interval, which is specified using the Interval property.

If the interval type is Auto, the unit of measurement for the interval is treated as a double, which is equivalent to one day when DateTime values are specified.

Note:
Interval-related properties have no effect when a range selection or cursor position is set programmatically.

If the axis interval type represents a time—for example, hours, minutes, and so forth—then in order to correctly enable the zooming function, the IntervalType must also be set to a time value. For example, if the ChartArea1.AxisX.IntervalType is expressed in hours, then the ChartArea1.CursorX.IntervalType could be set to minutes.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.IsUserEnabled Property

Cursor.IsUserEnabled Property |
 | See Also

Gets or sets a flag that enables or disables the cursor user interface.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsUserEnabled As Boolean
public bool IsUserEnabled { get; set; }
public:
property bool IsUserEnabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsUserEnabled ()

/** @property */
public void set_IsUserEnabled (boolean value)

public function get IsUserEnabled () : boolean

public function set IsUserEnabled (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.IsUserSelectionEnabled Property

Cursor.IsUserSelectionEnabled Property |
 | See Also

Gets or sets a flag that enables or disables the range selection user interface.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsUserSelectionEnabled As Boolean
public bool IsUserSelectionEnabled { get; set; }
public:
property bool IsUserSelectionEnabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsUserSelectionEnabled ()

/** @property */
public void set_IsUserSelectionEnabled (boolean value)

public function get IsUserSelectionEnabled () : boolean

public function set IsUserSelectionEnabled (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.LineColor Property

Cursor.LineColor Property |
 | See Also

Gets or sets the cursor line color.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color value that represents the line color of the cursor. The default value is Red.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.LineDashStyle Property

Cursor.LineDashStyle Property |
 | See Also

Gets or sets the style of the cursor line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.LineWidth Property

Cursor.LineWidth Property |
 | See Also

Gets or sets the line width, in pixels, of a cursor

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer value that represents the line width, in pixels. The default value is one (1).

Remarks

Use this property to specify the line width, in pixels, of a cursor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.Position Property

Cursor.Position Property |
 | See Also

Gets or sets the position of a cursor.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Position As Double
public double Position { get; set; }
public:
property double Position {
    double get ();
    void set (double value);
}
/** @property */
public double get_Position ()

/** @property */
public void set_Position (double value)

public function get Position () : double

public function set Position (value : double)

Property Value

A double value that represents the position of a cursor.

Remarks

This property can be used to get the position of a cursor, as well as to programmatically set the cursor position.

The position is measured as a value of the axis that the cursor belongs to, which is determined by the AxisType property. For example, if the cursor belongs to the primary X axis, then setting this property to a value of January 1, 2000 will result in the X-axis cursor being drawn at the January 1, 2000 position along the axis. If this axis value does not exist, the cursor will not be displayed.

Note that if you set this property, the Interval and IntervalOffset properties will have no effect; that is, the cursor will be displayed at this specified location.

Setting this property will not raise the CursorPositionChanged or CursorPositionChanging events.

Alternatively, the SetCursorPosition and SetCursorPixelPosition methods can be used to set the cursor.

To programmatically remove a cursor, use this property to set the position of the cursor to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SelectionColor Property

Cursor.SelectionColor Property |
 | See Also

Gets or sets a semi-transparent color that highlights a range of data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SelectionColor As Color
public Color SelectionColor { get; set; }
public:
property Color SelectionColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_SelectionColor ()

/** @property */
public void set_SelectionColor (Color value)

public function get SelectionColor () : Color

public function set SelectionColor (value : Color)

Property Value

A Color value represents the color of the highlighted range. The default value is LightGray, with an alpha value of 120.

Remarks

This property determines the color of the range selection, and can be set to any valid ARGB (alpha, red, green, blue) value. If an alpha value, which determines the level of transparency, is not provided, a default alpha value of 120 is used.

The selected color can be set for both the X and Y axis cursors, which is implemented using the CursorX and CursorY properties of the ChartArea object, respectively. If a range is only selected along the X-axis, the SelectionColor value for the X-axis cursor is used; if a range is only selected along the Y-axis, the SelectionColor value for the Y-axis cursor is used. If a range is selected along both axes, the SelectionColor value for the Y-axis cursor is also used for the selected color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SelectionEnd Property

Cursor.SelectionEnd Property |
 | See Also

Gets or sets the end position of a range selection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SelectionEnd As Double
public double SelectionEnd { get; set; }
public:
property double SelectionEnd {
    double get ();
    void set (double value);
}
/** @property */
public double get_SelectionEnd ()

/** @property */
public void set_SelectionEnd (double value)

public function get SelectionEnd () : double

public function set SelectionEnd (value : double)

Property Value

A double value that represents the end position of a range selection.

Remarks

A user can select a range within a chart area by clicking on the left mouse button and then dragging the mouse. Note that the IsUserSelectionEnabled property must also be set to true. In addition, a range selection can be set programmatically using either the SelectionEnd and SelectionStart properties, or the SetSelectionPosition or SetSelectionPixelPosition methods.

The end position of a range selection is calculated as a value of the axis to which the cursor belongs. For example, if the cursor belongs to the primary X-axis, and you set the SelectionEnd property to a value of December 31, 2000, the end of the selected region will occur at December 31, 2000 along the primary X axis.

To programmatically remove a range selection, set the beginning and end points of the range to NaN using the SelectionEnd and SelectionStart properties, or use the SetSelectionPosition method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


Cursor.SelectionStart Property

Cursor.SelectionStart Property |
 | See Also

Gets or sets the start position of a cursor's selected range.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SelectionStart As Double
public double SelectionStart { get; set; }
public:
property double SelectionStart {
    double get ();
    void set (double value);
}
/** @property */
public double get_SelectionStart ()

/** @property */
public void set_SelectionStart (double value)

public function get SelectionStart () : double

public function set SelectionStart (value : double)

Property Value

A double value that represents the start position of a cursor's range selection.

Remarks

A user can select a range by clicking on the left mouse button and then moving the cursor position by dragging the mouse. Note that the IsUserSelectionEnabled property must also be set to true. In addition, a range selection can be set programmatically using either the SelectionEnd and SelectionStart properties, or the SetSelectionPosition or SetSelectionPixelPosition methods.

The start position of a range selection is calculated as a value of the axis to which the cursor belongs. For example, if the cursor belongs to the primary X-axis, and you set the SelectionStart property to a value of January 1, 2000, the beginning of the selected region will occur at January 1, 2000 along the primary X axis.

To programmatically remove a range selection, set the beginning and end points of the range to NaN using the SelectionEnd and SelectionStart properties, or use the SetSelectionPosition method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Cursor Class
Cursor Members


CursorEventArgs Class

CursorEventArgs Class |
 | See Also Members

Members of this class are used with the following events in the root Chart object: CursorPositionChanged, CursorPositionChanging, SelectionRangeChanged and SelectionRangeChanging.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class CursorEventArgs
    Inherits EventArgs
public class CursorEventArgs : EventArgs
public ref class CursorEventArgs : public EventArgs
public class CursorEventArgs extends EventArgs
public class CursorEventArgs extends EventArgs

Remarks

The CursorEventArgs class is exposed as the e parameter in the CursorPositionChanged, CursorPositionChanging, SelectionRangeChanged and SelectionRangeChanging events of the root Chart object.

This class contains the following properties:

  • The ChartArea property, which is used to get the ChartArea object that the event was raised for. The Name property gets the name of the chart area; other chart area properties can also be set.

  • The Axis property, which is used to get the Axis object that the event was raised for. To determine the type of axis—X, X2, Y or Y2—use the AxisName property. Other axis properties can also be set.

  • The NewPosition property, which represents the position of a cursor along an axis, measured as an axis value, at the time the event was raised. The NewPosition property can be used to get the position of a cursor. In the CursorPositionChanging event, this property can also be used to reset the cursor position.

  • The NewSelectionStart property, which represents the starting position of a range selection along an axis, measured as an axis value, at the time the event was raised. The NewSelectionStart property can be used to get the selected range start position. In the SelectionRangeChanging event, this property can also be used to reset the position.

  • The NewSelectionEnd property, which represents the end position of a range selection along an axis, measured as an axis value, at the time the event was raised. The NewSelectionEnd property can be used to get the selected range end position. In the SelectionRangeChanging event, this property can also be used to reset the position.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.CursorEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Members


CursorEventArgs Members

CursorEventArgs Members |
 | See Also Constructors Methods Properties

Members of this class are used with the following events in the root Chart object: CursorPositionChanged, CursorPositionChanging, SelectionRangeChanged and SelectionRangeChanging.

The following tables list the members exposed by the CursorEventArgs type.

Public Constructors

Name | Description
CursorEventArgs | Overloaded.
Top

Public Properties

Name | Description
Axis | Gets the Axis object that a cursor or range selection belongs to.
ChartArea | Gets the ChartArea object that a cursor or range selection belongs to.
NewPosition | Gets or sets the position of a cursor. Depending on the event, also sets the cursor's position.
NewSelectionEnd | Gets or sets the end position of a selected range. Depending on the event, also sets the end position of the range.
NewSelectionStart | Gets or sets the start position of a selected range. Depending on the event, also sets the start position of the range.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CursorEventArgs Class


CursorEventArgs Constructor

CursorEventArgs Constructor |
 | See Also

Overload List

Name | Description
CursorEventArgs (ChartArea, Axis, Double) | Initializes a new instance of the CursorEventArgs class with the specified chart area, axis, and cursor position.
CursorEventArgs (ChartArea, Axis, Double, Double) | Initializes a new instance of the CursorEventArgs class with the specified chart area, axis, start and end positions for the new range.

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs Constructor (ChartArea, Axis, Double)

CursorEventArgs Constructor (ChartArea, Axis, Double) |
 | See Also

Initializes a new instance of the CursorEventArgs class with the specified chart area, axis, and cursor position.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    chartArea As ChartArea, _
    axis As Axis, _
    newPosition As Double _
)
public CursorEventArgs (
    ChartArea chartArea,
    Axis axis,
    double newPosition
)
public:
CursorEventArgs (
    ChartArea^ chartArea,
    Axis^ axis,
    double newPosition
)
public CursorEventArgs (
    ChartArea chartArea,
    Axis axis,
    double newPosition
)
public function CursorEventArgs (
    chartArea : ChartArea,
    axis : Axis,
    newPosition : double
)

Parameters

chartArea

The ChartArea of the cursor.

axis

The axis of the cursor.

newPosition

The new cursor position.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs Constructor (ChartArea, Axis, Double, Double)

CursorEventArgs Constructor (ChartArea, Axis, Double, Double) |
 | See Also

Initializes a new instance of the CursorEventArgs class with the specified chart area, axis, start and end positions for the new range.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    chartArea As ChartArea, _
    axis As Axis, _
    newSelectionStart As Double, _
    newSelectionEnd As Double _
)
public CursorEventArgs (
    ChartArea chartArea,
    Axis axis,
    double newSelectionStart,
    double newSelectionEnd
)
public:
CursorEventArgs (
    ChartArea^ chartArea,
    Axis^ axis,
    double newSelectionStart,
    double newSelectionEnd
)
public CursorEventArgs (
    ChartArea chartArea,
    Axis axis,
    double newSelectionStart,
    double newSelectionEnd
)
public function CursorEventArgs (
    chartArea : ChartArea,
    axis : Axis,
    newSelectionStart : double,
    newSelectionEnd : double
)

Parameters

chartArea

The ChartArea of the cursor.

axis

Axis of the cursor.

newSelectionStart

Start position of the new range selection.

newSelectionEnd

End position of the new range selection.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs Methods

CursorEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CursorEventArgs Class


CursorEventArgs Properties

CursorEventArgs Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets the Axis object that a cursor or range selection belongs to.
ChartArea | Gets the ChartArea object that a cursor or range selection belongs to.
NewPosition | Gets or sets the position of a cursor. Depending on the event, also sets the cursor's position.
NewSelectionEnd | Gets or sets the end position of a selected range. Depending on the event, also sets the end position of the range.
NewSelectionStart | Gets or sets the start position of a selected range. Depending on the event, also sets the start position of the range.

See Also

Reference

CursorEventArgs Class


CursorEventArgs.Axis Property

CursorEventArgs.Axis Property |
 | See Also

Gets the Axis object that a cursor or range selection belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Axis As Axis
public Axis Axis { get; }
public:
property Axis^ Axis {
    Axis^ get ();
}
/** @property */
public Axis get_Axis ()

public function get Axis () : Axis

Property Value

An Axis object.

Remarks

The Axis property is exposed in the following events of the root Chart object: CursorPositionChanged, CursorPositionChanging, SelectionRangeChanged and SelectionRangeChanging.

This property can be used to:

  • determine the type of axis—X, X2, Y or Y2—that the event is being raised for, using the AxisName property.

  • get and set axis properties, such as LineColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs.ChartArea Property

CursorEventArgs.ChartArea Property |
 | See Also

Gets the ChartArea object that a cursor or range selection belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ChartArea As ChartArea
public ChartArea ChartArea { get; }
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
}
/** @property */
public ChartArea get_ChartArea ()

public function get ChartArea () : ChartArea

Property Value

An object of type ChartArea that represents the chart area that a range selection or cursor belongs to.

Remarks

The ChartArea property is exposed in the following events of the root Chart object: CursorPositionChanged, CursorPositionChanging, SelectionRangeChanged and SelectionRangeChanging.

This property can be used to:

  • determine which chart area the event is being raised for; this is useful to know when there are multiple chart areas within a chart image.

  • get and set chart area properties, such as BackColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs.NewPosition Property

CursorEventArgs.NewPosition Property |
 | See Also

Gets or sets the position of a cursor. Depending on the event, also sets the cursor's position.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewPosition As Double
public double NewPosition { get; set; }
public:
property double NewPosition {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewPosition ()

/** @property */
public void set_NewPosition (double value)

public function get NewPosition () : double

public function set NewPosition (value : double)

Property Value

A double value that represents the position of a cursor along an axis.

Remarks

This property represents the new position of a cursor, and can be used in the CursorPositionChanging and CursorPositionChanged events to get the cursor position. It can also be used in the SelectionRangeChanging event to set the cursor position.

Note that setting this property in the SelectionRangeChanging event will have no effect. The NewPosition property will have a value of NaN in this event.

To determine the chart area that the event is being raised for, use the ChartArea property.

Use the Axis property to determine if this end position is for a range selected along the primary or secondary X or Y axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs.NewSelectionEnd Property

CursorEventArgs.NewSelectionEnd Property |
 | See Also

Gets or sets the end position of a selected range. Depending on the event, also sets the end position of the range.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewSelectionEnd As Double
public double NewSelectionEnd { get; set; }
public:
property double NewSelectionEnd {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewSelectionEnd ()

/** @property */
public void set_NewSelectionEnd (double value)

public function get NewSelectionEnd () : double

public function set NewSelectionEnd (value : double)

Property Value

A double value that represents the end position of a selected range.

Remarks

The NewSelectionEnd property represents the new position of a cursor, and can be used in the CursorPositionChanging and CursorPositionChanged events to get the cursor position. It can also be used in the SelectionRangeChanging event to set the cursor position.

Note that setting this property in the SelectionRangeChanging event will have no effect. The NewSelectionEnd property will have a value of NaN in this event.

The start position of a selected range is not necessarily less than the end position of a selected range. The start position is the position where the user fist clicked within the chart area, and the end position is the position of the mouse at the time the event is raised.

To determine the chart area that the event is being raised for use the ChartArea property.

Use the Axis property to determine if this end position is for a range selected along the primary or secondary X or Y axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CursorEventArgs.NewSelectionStart Property

CursorEventArgs.NewSelectionStart Property |
 | See Also

Gets or sets the start position of a selected range. Depending on the event, also sets the start position of the range.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewSelectionStart As Double
public double NewSelectionStart { get; set; }
public:
property double NewSelectionStart {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewSelectionStart ()

/** @property */
public void set_NewSelectionStart (double value)

public function get NewSelectionStart () : double

public function set NewSelectionStart (value : double)

Property Value

A double value that represents the start position of a selected range.

Remarks

The NewSelectionStart property represents the new position of a cursor, and can be used in the CursorPositionChanging and CursorPositionChanged events to get the cursor position. It can also be used in the CursorPositionChanging event to set the cursor position.

Note that setting this property in the CursorPositionChanging event will have no effect; the NewSelectionStart property will have a value of NaN in this event.

The start position of a selected range is not necessarily less than the end position of a selected range. The start position is the position where the user fist clicked within the chart area, and the end position is the position of the mouse at the time the event is raised.

To determine the chart area that the event is being raised for, use the ChartArea property.

Use the Axis property to determine if this end position is for a range selected along the primary or secondary X or Y axis.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CursorEventArgs Class
CursorEventArgs Members


CustomizeLegendEventArgs Class

CustomizeLegendEventArgs Class |
 | See Also Members

Provides data for the CustomizeLegend event of the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class CustomizeLegendEventArgs
    Inherits EventArgs
public class CustomizeLegendEventArgs : EventArgs
public ref class CustomizeLegendEventArgs : public EventArgs
public class CustomizeLegendEventArgs extends EventArgs
public class CustomizeLegendEventArgs extends EventArgs

Remarks

The CustomizeLegendEventArgs class is used in the CustomizeLegend event.

There are only two properties in this class. The LegendItems property allows you to delete or modify both default and custom legend items, and to add custom legend items. This property can also be used to change the order of legend items.

The LegendName property is used to identify the legend that raised this event.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.CustomizeLegendEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Members


CustomizeLegendEventArgs Members

CustomizeLegendEventArgs Members |
 | See Also Constructors Methods Properties

Provides data for the CustomizeLegend event of the Chart control.

The following tables list the members exposed by the CustomizeLegendEventArgs type.

Public Constructors

Name | Description
CustomizeLegendEventArgs | Overloaded. Initializes a new instance of the CustomizeLegendEventArgs class.
Top

Public Properties

Name | Description
LegendItems | Used to remove, modify or change the order of both custom and default legend items in the CustomizeLegend event. Can also be used to add custom legend items.
LegendName | Gets the name of the Legend object, which can be used to determine which legend was the sender of the CustomizeLegend event.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomizeLegendEventArgs Class


CustomizeLegendEventArgs Constructor

CustomizeLegendEventArgs Constructor |
 | See Also

Initializes a new instance of the CustomizeLegendEventArgs class.

Overload List

Name | Description
CustomizeLegendEventArgs (LegendItemsCollection) | Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection.
CustomizeLegendEventArgs (LegendItemsCollection, String) | Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection and legend name.

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members


CustomizeLegendEventArgs Constructor (LegendItemsCollection)

CustomizeLegendEventArgs Constructor (LegendItemsCollection) |
 | See Also

Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    legendItems As LegendItemsCollection _
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems
)
public:
CustomizeLegendEventArgs (
    LegendItemsCollection^ legendItems
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems
)
public function CustomizeLegendEventArgs (
    legendItems : LegendItemsCollection
)

Parameters

legendItems

The LegendItemsCollection.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members


CustomizeLegendEventArgs Constructor (LegendItemsCollection, String)

CustomizeLegendEventArgs Constructor (LegendItemsCollection, String) |
 | See Also

Initializes a new instance of the CustomizeLegendEventArgs class with the specified LegendItemsCollection and legend name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    legendItems As LegendItemsCollection, _
    legendName As String _
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems,
    string legendName
)
public:
CustomizeLegendEventArgs (
    LegendItemsCollection^ legendItems,
    String^ legendName
)
public CustomizeLegendEventArgs (
    LegendItemsCollection legendItems,
    String legendName
)
public function CustomizeLegendEventArgs (
    legendItems : LegendItemsCollection,
    legendName : String
)

Parameters

legendItems

The LegendItemsCollection.

legendName

The legend name.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members


CustomizeLegendEventArgs Methods

CustomizeLegendEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomizeLegendEventArgs Class


CustomizeLegendEventArgs Properties

CustomizeLegendEventArgs Properties |
 | See Also

Public Properties

Name | Description
LegendItems | Used to remove, modify or change the order of both custom and default legend items in the CustomizeLegend event. Can also be used to add custom legend items.
LegendName | Gets the name of the Legend object, which can be used to determine which legend was the sender of the CustomizeLegend event.

See Also

Reference

CustomizeLegendEventArgs Class


CustomizeLegendEventArgs.LegendItems Property

CustomizeLegendEventArgs.LegendItems Property |
 | See Also

Used to remove, modify or change the order of both custom and default legend items in the CustomizeLegend event. Can also be used to add custom legend items.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property LegendItems As LegendItemsCollection
public LegendItemsCollection LegendItems { get; }
public:
property LegendItemsCollection^ LegendItems {
    LegendItemsCollection^ get ();
}
/** @property */
public LegendItemsCollection get_LegendItems ()

public function get LegendItems () : LegendItemsCollection

Property Value

A LegendItemsCollection object.

Remarks

The LegendItems property allows you to delete or modify both default and custom legend items in the CustomizeLegend event, and to add custom legend items. The order of legend items can also be changed.

Note:
The SeriesPointIndex and LegendItem.SeriesPointIndex properties can be used to determine the data element that is associated with a default legend item. These properties will return zero-length strings for custom legend items, because custom items are not associated with chart data.

This property enables you to determine which Legend the event was raised for, which enables you to customize an individual Legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members


CustomizeLegendEventArgs.LegendName Property

CustomizeLegendEventArgs.LegendName Property |
 | See Also

Gets the name of the Legend object, which can be used to determine which legend was the sender of the CustomizeLegend event.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property LegendName As String
public string LegendName { get; }
public:
property String^ LegendName {
    String^ get ();
}
/** @property */
public String get_LegendName ()

public function get LegendName () : String

Property Value

A string value that represents the name of the associated Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomizeLegendEventArgs Class
CustomizeLegendEventArgs Members


CustomLabel Class

CustomLabel Class |
 | See Also Members

Represents a custom label for an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class CustomLabel
    Inherits ChartNamedElement
public class CustomLabel : ChartNamedElement
public ref class CustomLabel : public ChartNamedElement
public class CustomLabel extends ChartNamedElement
public class CustomLabel extends ChartNamedElement

Remarks

CustomLabel objects are stored in the CustomLabelsCollection class, which is exposed as the CustomLabels property of the Axis class.

Axis labels for the first label row are automatically generated unless custom labels are specified using the CustomLabels property. If you specify a custom label along the first label row, no axis labels will be automatically generated for the entire first row.

Only custom labels may be used for the second label row.

The ToPosition and FromPosition properties determine the axis range that the label applies to.

A grid line and/or tick mark can be displayed for a custom axis label by using the GridTicks property; this property specifies whether a custom grid line or tick mark will be drawn in the middle of the label range.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.CustomLabel

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Members


CustomLabel Members

CustomLabel Members |
 | See Also Constructors Methods Properties

Represents a custom label for an axis.

The following tables list the members exposed by the CustomLabel type.

Public Constructors

Name | Description
CustomLabel | Overloaded.
Top

Public Properties

Name | Description
Axis | Gets the axis that this CustomLabel object belongs to.
ForeColor | Gets or sets the text color of the custom label.
FromPosition | Gets or sets the beginning position, in axis coordinates, of the custom label.
GridTicks | Gets or sets a property that specifies whether custom tick marks and grid lines will be drawn in the center of the label.
Image | Gets or sets the custom label image.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when a custom label image is drawn.
LabelMark | Gets or sets the label mark for a custom label. This applies to labels in the second row only.
MarkColor | Gets or sets the marker color for the custom label
Name | Overridden. Gets or sets the name of the custom label.
RowIndex | Gets or sets the index of the custom label row.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the custom label text.
ToolTip | Gets or sets the custom label tooltip text.
ToPosition | Gets or sets the starting position of the custom label, in axis coordinates.
Top

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns a cloned label object.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomLabel Class


CustomLabel Constructor

CustomLabel Constructor |
 | See Also

Overload List

Name | Description
CustomLabel () | Creates a new instance of the CustomLabel class.
CustomLabel (Double, Double, String, Int32, LabelMarkStyle) | Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, and markStyle parameters.
CustomLabel (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) | Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, markStyle and gridTick parameters.

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel Constructor ()

CustomLabel Constructor () |
 | See Also

Creates a new instance of the CustomLabel class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public CustomLabel ()
public:
CustomLabel ()
public CustomLabel ()
public function CustomLabel ()

Remarks

This constructor can be used to create and initialize a new instance of the CustomLabel class.

However, it is recommended that you use one of the Add methods in the CustomLabelsCollection class to add custom labels.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle)

CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle) |
 | See Also

Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, and markStyle parameters.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    labelRow As Integer, _
    markStyle As LabelMarkStyle _
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    string text,
    int labelRow,
    LabelMarkStyle markStyle
)
public:
CustomLabel (
    double fromPosition,
    double toPosition,
    String^ text,
    int labelRow,
    LabelMarkStyle markStyle
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    String text,
    int labelRow,
    LabelMarkStyle markStyle
)
public function CustomLabel (
    fromPosition : double,
    toPosition : double,
    text : String,
    labelRow : int,
    markStyle : LabelMarkStyle
)

Parameters

fromPosition

The beginning of the axis range the label applies to.

toPosition

The end of the axis range the label applies to.

text

The label text.

labelRow

The label row index.

markStyle

The label mark style.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes)

CustomLabel Constructor (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) |
 | See Also

Initializes a new instance of the CustomLabel class with the specified fromPosition, toPosition, text, labelRow, markStyle and gridTick parameters.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    labelRow As Integer, _
    markStyle As LabelMarkStyle, _
    gridTick As GridTickTypes _
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    string text,
    int labelRow,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public:
CustomLabel (
    double fromPosition,
    double toPosition,
    String^ text,
    int labelRow,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public CustomLabel (
    double fromPosition,
    double toPosition,
    String text,
    int labelRow,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public function CustomLabel (
    fromPosition : double,
    toPosition : double,
    text : String,
    labelRow : int,
    markStyle : LabelMarkStyle,
    gridTick : GridTickTypes
)

Parameters

fromPosition

The beginning of the axis range the label applies to.

toPosition

The end of the axis range the label applies to.

text

The label text.

labelRow

The label row index.

markStyle

The label mark style.

gridTick

The custom grid line and/or tick marks flag.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel Methods

CustomLabel Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns a cloned label object.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomLabel Class


CustomLabel.Clone Method

CustomLabel.Clone Method |
 | See Also

Returns a cloned label object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Clone As CustomLabel
public CustomLabel Clone ()
public:
CustomLabel^ Clone ()
public CustomLabel Clone ()
public function Clone () : CustomLabel

Return Value

A CustomLabel object that represents a copy of the current custom label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel Properties

CustomLabel Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets the axis that this CustomLabel object belongs to.
ForeColor | Gets or sets the text color of the custom label.
FromPosition | Gets or sets the beginning position, in axis coordinates, of the custom label.
GridTicks | Gets or sets a property that specifies whether custom tick marks and grid lines will be drawn in the center of the label.
Image | Gets or sets the custom label image.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when a custom label image is drawn.
LabelMark | Gets or sets the label mark for a custom label. This applies to labels in the second row only.
MarkColor | Gets or sets the marker color for the custom label
Name | Overridden. Gets or sets the name of the custom label.
RowIndex | Gets or sets the index of the custom label row.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the custom label text.
ToolTip | Gets or sets the custom label tooltip text.
ToPosition | Gets or sets the starting position of the custom label, in axis coordinates.

See Also

Reference

CustomLabel Class


CustomLabel.Axis Property

CustomLabel.Axis Property |
 | See Also

Gets the axis that this CustomLabel object belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Axis As Axis
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Axis Axis { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Axis^ Axis {
    Axis^ get ();
}
/** @property */
public Axis get_Axis ()

public function get Axis () : Axis

Property Value

An Axis object.

Remarks

Use this method to determine which Axis object the CustomLabel object belongs to.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.ForeColor Property

CustomLabel.ForeColor Property |
 | See Also

Gets or sets the text color of the custom label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value that represents the text color of a custom label.

Remarks

The ForeColor property determines the text color for a custom label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.FromPosition Property

CustomLabel.FromPosition Property |
 | See Also

Gets or sets the beginning position, in axis coordinates, of the custom label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property FromPosition As Double
public double FromPosition { get; set; }
public:
property double FromPosition {
    double get ();
    void set (double value);
}
/** @property */
public double get_FromPosition ()

/** @property */
public void set_FromPosition (double value)

public function get FromPosition () : double

public function set FromPosition (value : double)

Property Value

A double value that represents the beginning of the axis range that the label is applied to.

Remarks

The FromPosition property determines the start position of the axis range the label is applied to.

The difference between the values of the ToPosition and FromPosition properties determines where the label text will be displayed. For example, suppose the X-axis has a scale that ranges from 1 to 5 (1, 2 ,3 , 4, 5). In order to display a custom label just underneath the second point, you would set the ToPosition property to 1.5 and the FromPosition property to 2.5.

If the XValueType—or YValueType, depending on the axis in question—is set to a DateTime value, then this FromPosition property will be displayed as a DateTime value in the designer.

This property should not be set to the same value as the ToPosition property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.GridTicks Property

CustomLabel.GridTicks Property |
 | See Also

Gets or sets a property that specifies whether custom tick marks and grid lines will be drawn in the center of the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property GridTicks As GridTickTypes
public GridTickTypes GridTicks { get; set; }
public:
property GridTickTypes GridTicks {
    GridTickTypes get ();
    void set (GridTickTypes value);
}
/** @property */
public GridTickTypes get_GridTicks ()

/** @property */
public void set_GridTicks (GridTickTypes value)

public function get GridTicks () : GridTickTypes

public function set GridTicks (value : GridTickTypes)

Property Value

A GridTickTypes enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.Image Property

CustomLabel.Image Property |
 | See Also

Gets or sets the custom label image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Image As String
public string Image { get; set; }
public:
property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the name of the custom label image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.ImageTransparentColor Property

CustomLabel.ImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when a custom label image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ImageTransparentColor As Color
public Color ImageTransparentColor { get; set; }
public:
property Color ImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ImageTransparentColor ()

/** @property */
public void set_ImageTransparentColor (Color value)

public function get ImageTransparentColor () : Color

public function set ImageTransparentColor (value : Color)

Property Value

A Color value which is replaced with a transparent color when you draw the image. The default value is Magenta.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.LabelMark Property

CustomLabel.LabelMark Property |
 | See Also

Gets or sets the label mark for a custom label. This applies to labels in the second row only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelMark As LabelMarkStyle
public LabelMarkStyle LabelMark { get; set; }
public:
property LabelMarkStyle LabelMark {
    LabelMarkStyle get ();
    void set (LabelMarkStyle value);
}
/** @property */
public LabelMarkStyle get_LabelMark ()

/** @property */
public void set_LabelMark (LabelMarkStyle value)

public function get LabelMark () : LabelMarkStyle

public function set LabelMark (value : LabelMarkStyle)

Property Value

A LabelMarkStyle enumeration value that determines the type of label mark, if any, to be used.

Remarks

Label marks can only be used for the second row of labels, and are usually used to group labels together from the first row.

The major tick mark's line style of the relevant Axis object is used for the line pattern of the mark, for example, the AxisX.MajorTickMark.LineDashStyle property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.MarkColor Property

CustomLabel.MarkColor Property |
 | See Also

Gets or sets the marker color for the custom label

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkColor As Color
public Color MarkColor { get; set; }
public:
property Color MarkColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkColor ()

/** @property */
public void set_MarkColor (Color value)

public function get MarkColor () : Color

public function set MarkColor (value : Color)

Property Value

A Color value that represents the marker color of a custom label.

Remarks

The MarkColor property determines the color of a custom label's marker.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.Name Property

CustomLabel.Name Property |
 | See Also

Gets or sets the name of the custom label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<DesignOnlyAttribute(True)> _
Public Overrides Property Name As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DesignOnlyAttribute(true)]
public override string Name { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[DesignOnlyAttribute(true)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the item.

Remarks

A string value that represents the text name of the item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.RowIndex Property

CustomLabel.RowIndex Property |
 | See Also

Gets or sets the index of the custom label row.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property RowIndex As Integer
public int RowIndex { get; set; }
public:
property int RowIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_RowIndex ()

/** @property */
public void set_RowIndex (int value)

public function get RowIndex () : int

public function set RowIndex (value : int)

Property Value

An integer value that specifies the index, 0 to 10, of the custom label row.

Remarks

The RowIndex property specifies the index of the row label where zero is the row label closest to the axis to ten, the further most axis label.

Only custom labels can be used for the label rows beyond the first row.

If a custom label is used for the first row, labels for that entire axis will not be generated automatically; in this case, all labels for the first row must then be custom labels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.Text Property

CustomLabel.Text Property |
 | See Also

Gets or sets the custom label text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the label text.

Remarks

The Text property gets or sets the label text of the CustomLabel object.

Note that axis labels for the first label row are generated automatically, but can be overridden using CustomLabel objects. If you specify a custom label along the first axis row, no axis labels will be automatically generated for the entire first row.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.ToolTip Property

CustomLabel.ToolTip Property |
 | See Also

Gets or sets the custom label tooltip text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string that represents the tooltip text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabel.ToPosition Property

CustomLabel.ToPosition Property |
 | See Also

Gets or sets the starting position of the custom label, in axis coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToPosition As Double
public double ToPosition { get; set; }
public:
property double ToPosition {
    double get ();
    void set (double value);
}
/** @property */
public double get_ToPosition ()

/** @property */
public void set_ToPosition (double value)

public function get ToPosition () : double

public function set ToPosition (value : double)

Property Value

A double value that represents the starting position.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabel Class
CustomLabel Members


CustomLabelsCollection Class

CustomLabelsCollection Class |
 | See Also Members

Represents a collection of CustomLabel objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class CustomLabelsCollection
    Inherits ChartElementCollection(Of CustomLabel)
public class CustomLabelsCollection : ChartElementCollection<CustomLabel>
public ref class CustomLabelsCollection : public ChartElementCollection<CustomLabel^>
public class CustomLabelsCollection extends ChartElementCollection<CustomLabel>
public class CustomLabelsCollection extends ChartElementCollection<CustomLabel>

Remarks

The CustomLabelsCollection class represents a collection of CustomLabel objects, which in turn represent the custom labels that an Axis object can use. This class is exposed as the CustomLabels collection property of an Axis object.

Note:
You can automatically populate the entire label row of an axis with custom DateTime labels using any Add method definition that includes a DateTimeIntervalType argument.

The Count property indicates the total number of items in the collection, and is commonly used to find the upper bound of the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.CustomLabelsCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Members


CustomLabelsCollection Members

CustomLabelsCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of CustomLabel objects.

The following tables list the members exposed by the CustomLabelsCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

CustomLabelsCollection Class


CustomLabelsCollection Methods

CustomLabelsCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

CustomLabelsCollection Class


CustomLabelsCollection.Add Method

CustomLabelsCollection.Add Method |
 | See Also

Overload List

Name | Description
CustomLabelsCollection.Add (CustomLabel) | (inherited from Add )
CustomLabelsCollection.Add (Double, DateTimeIntervalType) | Adds multiple CustomLabel objects of type DateTime to the collection. Populates the entire first row of an axis with labels.
CustomLabelsCollection.Add (Double, DateTimeIntervalType, String) | Adds multiple DateTime CustomLabelsCollection objects to the collection. Populates the entire first row of an axis with labels with the specified format.
CustomLabelsCollection.Add (Double, Double, String) | Adds a CustomLabel object to the collection, using the given axis range and text.
CustomLabelsCollection.Add (Double, DateTimeIntervalType, String, Int32, LabelMarkStyle) | Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, text format, row index and marking style.
CustomLabelsCollection.Add (Double, Double, String, Int32, LabelMarkStyle) | Adds a custom label to the collection, using the given axis range, text, row index and marking style.
CustomLabelsCollection.Add (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) | Adds a custom label to the collection, using the given axis range, text, row index, marking style and grid tick type.
CustomLabelsCollection.Add (Double, DateTimeIntervalType, Double, Double, String, Int32, LabelMarkStyle) | Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, and will be generated for the axis range that is determined by the min and max arguments.

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType) |
 | See Also

Adds multiple CustomLabel objects of type DateTime to the collection. Populates the entire first row of an axis with labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType
)

Parameters

labelsStep

Determines how often the custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the interval type.

Remarks

The Add method creates and initializes CustomLabel objects for the entire first label row of an axis with DateTime labels of the specified type.

The labelsStep parameter determines how often the custom labels will be drawn.

Note:
The RecalculateAxesScale method must be called prior to calling this particular method definition.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String) |
 | See Also

Adds multiple DateTime CustomLabelsCollection objects to the collection. Populates the entire first row of an axis with labels with the specified format.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType, _
    format As String _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    string format
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String^ format
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String format
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType,
    format : String
)

Parameters

labelsStep

Determines how often custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the unit of measure for the labelsStep parameter.

format

A value that determines the format of the custom label.

Remarks

This method creates and initializes CustomLabel objects for an axis' entire first label row with DateTime labels of the specified type.

The step determines how often the custom labels will be drawn, and optional label formatting can be specified as well.

Note:
The RecalculateAxesScale method must be called prior to calling this particular method definition.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, Double, String)

CustomLabelsCollection.Add Method (Double, Double, String) |
 | See Also

Adds a CustomLabel object to the collection, using the given axis range and text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String _
) As CustomLabel
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    string text
)
public:
CustomLabel^ Add (
    double fromPosition,
    double toPosition,
    String^ text
)
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    String text
)
public function Add (
    fromPosition : double,
    toPosition : double,
    text : String
) : CustomLabel

Parameters

fromPosition

The minimum value of the axis range to which the label is applied.

toPosition

The maximum value of the axis range to which the label is applied.

text

The label text.

Return Value

The newly added CustomLabel object.

Remarks

Adds one custom label to the first label row of the relevant axis. No label mark is used.

If a custom label is used anywhere in the first label row, no labels are automatically generated for that first row.

Note:
The RecalculateAxesScale method must be called prior to calling this particular method definition.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String, Int32, LabelMarkStyle)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, String, Int32, LabelMarkStyle) |
 | See Also

Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, text format, row index and marking style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType, _
    format As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    string format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String^ format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    String format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType,
    format : String,
    rowIndex : int,
    markStyle : LabelMarkStyle
)

Parameters

labelsStep

Determines how often custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the unit of measure for the labelsStep parameter.

format

The label text format.

rowIndex

The label row index.

markStyle

A LabelMarkstyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle)

CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle) |
 | See Also

Adds a custom label to the collection, using the given axis range, text, row index and marking style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle _
) As CustomLabel
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    string text,
    int rowIndex,
    LabelMarkStyle markStyle
)
public:
CustomLabel^ Add (
    double fromPosition,
    double toPosition,
    String^ text,
    int rowIndex,
    LabelMarkStyle markStyle
)
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    String text,
    int rowIndex,
    LabelMarkStyle markStyle
)
public function Add (
    fromPosition : double,
    toPosition : double,
    text : String,
    rowIndex : int,
    markStyle : LabelMarkStyle
) : CustomLabel

Parameters

fromPosition

The minimum value of the axis range the label is applied to.

toPosition

The maximum value of the axis range the label is applied to.

text

Label text.

rowIndex

Label row index.

markStyle

A LabelMarkstyle enumeration value.

Return Value

The newly added CustomLabel object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes)

CustomLabelsCollection.Add Method (Double, Double, String, Int32, LabelMarkStyle, GridTickTypes) |
 | See Also

Adds a custom label to the collection, using the given axis range, text, row index, marking style and grid tick type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    fromPosition As Double, _
    toPosition As Double, _
    text As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle, _
    gridTick As GridTickTypes _
) As CustomLabel
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    string text,
    int rowIndex,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public:
CustomLabel^ Add (
    double fromPosition,
    double toPosition,
    String^ text,
    int rowIndex,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public CustomLabel Add (
    double fromPosition,
    double toPosition,
    String text,
    int rowIndex,
    LabelMarkStyle markStyle,
    GridTickTypes gridTick
)
public function Add (
    fromPosition : double,
    toPosition : double,
    text : String,
    rowIndex : int,
    markStyle : LabelMarkStyle,
    gridTick : GridTickTypes
) : CustomLabel

Parameters

fromPosition

The minimum value of the axis range the label is applied to.

toPosition

The maximum value of the axis range the label is applied to.

text

Label text.

rowIndex

Label row index.

markStyle

A LabelMarkstyle enumeration value.

gridTick

A GridTickTypes enumeration value.

Return Value

The newly added CustomLabel object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, Double, Double, String, Int32, LabelMarkStyle)

CustomLabelsCollection.Add Method (Double, DateTimeIntervalType, Double, Double, String, Int32, LabelMarkStyle) |
 | See Also

Adds multiple custom labels to the collection. The labels will be DateTime labels with the specified interval type, and will be generated for the axis range that is determined by the min and max arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Add ( _
    labelsStep As Double, _
    intervalType As DateTimeIntervalType, _
    min As Double, _
    max As Double, _
    format As String, _
    rowIndex As Integer, _
    markStyle As LabelMarkStyle _
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    double min,
    double max,
    string format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public:
void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    double min,
    double max,
    String^ format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public void Add (
    double labelsStep,
    DateTimeIntervalType intervalType,
    double min,
    double max,
    String format,
    int rowIndex,
    LabelMarkStyle markStyle
)
public function Add (
    labelsStep : double,
    intervalType : DateTimeIntervalType,
    min : double,
    max : double,
    format : String,
    rowIndex : int,
    markStyle : LabelMarkStyle
)

Parameters

labelsStep

Determines how often custom labels will be drawn.

intervalType

A DateTimeIntervalType enumeration value that determines the unit of measure for the labelsStep parameter.

min

Minimum value.

max

Maximum value.

format

Label text format.

rowIndex

Label row index.

markStyle

A LabelMarkstyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomLabelsCollection Class
CustomLabelsCollection Members


CustomLabelsCollection Properties

CustomLabelsCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

CustomLabelsCollection Class


CustomProperties Class

CustomProperties Class |
 | See Also Members

For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class CustomProperties
public class CustomProperties
public ref class CustomProperties
public class CustomProperties
public class CustomProperties

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.CustomProperties

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

CustomProperties Members


CustomProperties Members

CustomProperties Members |
 | See Also Methods

For internal use only.

The following tables list the members exposed by the CustomProperties type.

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CustomProperties Class


CustomProperties Methods

CustomProperties Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CustomProperties Class


DataFormula Class

DataFormula Class |
 | See Also Members

Provides properties and methods to prepare series data for technical analysis, apply formulas on the series data and prepare output data to be displayed as a chart. The actual calculations are performed in the StatisticFormula class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class DataFormula
public class DataFormula
public ref class DataFormula
public class DataFormula
public class DataFormula

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.DataFormula
System.Windows.Forms.DataVisualization.Charting.DataManipulator

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Members


DataFormula Members

DataFormula Members |
 | See Also Constructors Methods Properties

Provides properties and methods to prepare series data for technical analysis, apply formulas on the series data and prepare output data to be displayed as a chart. The actual calculations are performed in the StatisticFormula class.

The following tables list the members exposed by the DataFormula type.

Public Constructors

Name | Description
DataFormula | Initializes a new instance of the DataFormula class.
Top

Public Properties

Name | Description
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations; otherwise, empty points are treated as zeroes.
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as "rolling average" from zero.
Statistics | Gets a reference to the StatisticFormula class.
Top

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | Merges, splits or moves Y values in the series.
Equals | Overloaded. (inherited from Object )
FinancialFormula | Overloaded.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataFormula Class


DataFormula Constructor

DataFormula Constructor |
 | See Also

Initializes a new instance of the DataFormula class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public DataFormula ()
public:
DataFormula ()
public DataFormula ()
public function DataFormula ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula Methods

DataFormula Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | Merges, splits or moves Y values in the series.
Equals | Overloaded. (inherited from Object )
FinancialFormula | Overloaded.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataFormula Class


DataFormula.CopySeriesValues Method

DataFormula.CopySeriesValues Method |
 | See Also

Merges, splits or moves Y values in the series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub CopySeriesValues ( _
    inputSeries As String, _
    outputSeries As String _
)
public void CopySeriesValues (
    string inputSeries,
    string outputSeries
)
public:
void CopySeriesValues (
    String^ inputSeries,
    String^ outputSeries
)
public void CopySeriesValues (
    String inputSeries,
    String outputSeries
)
public function CopySeriesValues (
    inputSeries : String,
    outputSeries : String
)

Parameters

inputSeries

A comma-separated list of input data series names and optional X and Y value names.

outputSeries

A comma-separated list of output data series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method

DataFormula.FinancialFormula Method |
 | See Also

Overload List

Name | Description
DataFormula.FinancialFormula (FinancialFormula, Series) | Calls a method from a formula module with the specified name and input series.
DataFormula.FinancialFormula (FinancialFormula, String) | Calls a method from a formula module with the specified formula name and input series.
DataFormula.FinancialFormula (FinancialFormula, Series, Series) | Calls a method from a formula module with the specified name, input and output series.
DataFormula.FinancialFormula (FinancialFormula, String, String) | Calls a method from a formula module with the specified formula name, and the names of the input and output series.
DataFormula.FinancialFormula (FinancialFormula, String, Series, Series) | This method calls a method from a formula module with the specified formula name and parameters, using the specified input and output series.
DataFormula.FinancialFormula (FinancialFormula, String, String, String) | Calls a method from a formula module with the specified formula name and parameters, and the names of the input and output series.

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method (FinancialFormula, Series)

DataFormula.FinancialFormula Method (FinancialFormula, Series) |
 | See Also

Calls a method from a formula module with the specified name and input series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")> _
Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As Series _
)
[SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")]
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries
)
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1011:ConsiderPassingBaseTypesAsParameters")]
public:
void FinancialFormula (
    FinancialFormula formulaName,
    Series^ inputSeries
)
/** @attribute SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters") */
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries
)
SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : Series
)

Parameters

formulaName

Formula name.

inputSeries

A comma-separated list of input series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method (FinancialFormula, String)

DataFormula.FinancialFormula Method (FinancialFormula, String) |
 | See Also

Calls a method from a formula module with the specified formula name and input series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")> _
Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As String _
)
[SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")]
public void FinancialFormula (
    FinancialFormula formulaName,
    string inputSeries
)
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1011:ConsiderPassingBaseTypesAsParameters")]
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ inputSeries
)
/** @attribute SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters") */
public void FinancialFormula (
    FinancialFormula formulaName,
    String inputSeries
)
SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : String
)

Parameters

formulaName

Formula name.

inputSeries

The input series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method (FinancialFormula, Series, Series)

DataFormula.FinancialFormula Method (FinancialFormula, Series, Series) |
 | See Also

Calls a method from a formula module with the specified name, input and output series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")> _
Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As Series, _
    outputSeries As Series _
)
[SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")]
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries,
    Series outputSeries
)
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1011:ConsiderPassingBaseTypesAsParameters")]
public:
void FinancialFormula (
    FinancialFormula formulaName,
    Series^ inputSeries,
    Series^ outputSeries
)
/** @attribute SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters") */
public void FinancialFormula (
    FinancialFormula formulaName,
    Series inputSeries,
    Series outputSeries
)
SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formulaName

Formula name.

inputSeries

Comma-separated list of input series names and optional X and Y value names.

outputSeries

Comma-separated list of output series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method (FinancialFormula, String, String)

DataFormula.FinancialFormula Method (FinancialFormula, String, String) |
 | See Also

Calls a method from a formula module with the specified formula name, and the names of the input and output series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")> _
Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    inputSeries As String, _
    outputSeries As String _
)
[SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")]
public void FinancialFormula (
    FinancialFormula formulaName,
    string inputSeries,
    string outputSeries
)
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1011:ConsiderPassingBaseTypesAsParameters")]
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ inputSeries,
    String^ outputSeries
)
/** @attribute SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters") */
public void FinancialFormula (
    FinancialFormula formulaName,
    String inputSeries,
    String outputSeries
)
SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")
public function FinancialFormula (
    formulaName : FinancialFormula,
    inputSeries : String,
    outputSeries : String
)

Parameters

formulaName

Formula name.

inputSeries

The input series.

outputSeries

The output series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method (FinancialFormula, String, Series, Series)

DataFormula.FinancialFormula Method (FinancialFormula, String, Series, Series) |
 | See Also

This method calls a method from a formula module with the specified formula name and parameters, using the specified input and output series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")> _
Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    parameters As String, _
    inputSeries As Series, _
    outputSeries As Series _
)
[SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")]
public void FinancialFormula (
    FinancialFormula formulaName,
    string parameters,
    Series inputSeries,
    Series outputSeries
)
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1011:ConsiderPassingBaseTypesAsParameters")]
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ parameters,
    Series^ inputSeries,
    Series^ outputSeries
)
/** @attribute SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters") */
public void FinancialFormula (
    FinancialFormula formulaName,
    String parameters,
    Series inputSeries,
    Series outputSeries
)
SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters")
public function FinancialFormula (
    formulaName : FinancialFormula,
    parameters : String,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formulaName

Formula name.

parameters

Formula parameters.

inputSeries

Comma-separated list of input series names and optional X and Y value names.

outputSeries

Comma-separated list of output series names and optional X and Y value names.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.FinancialFormula Method (FinancialFormula, String, String, String)

DataFormula.FinancialFormula Method (FinancialFormula, String, String, String) |
 | See Also

Calls a method from a formula module with the specified formula name and parameters, and the names of the input and output series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FinancialFormula ( _
    formulaName As FinancialFormula, _
    parameters As String, _
    inputSeries As String, _
    outputSeries As String _
)
public void FinancialFormula (
    FinancialFormula formulaName,
    string parameters,
    string inputSeries,
    string outputSeries
)
public:
void FinancialFormula (
    FinancialFormula formulaName,
    String^ parameters,
    String^ inputSeries,
    String^ outputSeries
)
public void FinancialFormula (
    FinancialFormula formulaName,
    String parameters,
    String inputSeries,
    String outputSeries
)
public function FinancialFormula (
    formulaName : FinancialFormula,
    parameters : String,
    inputSeries : String,
    outputSeries : String
)

Parameters

formulaName

Formula name.

parameters

Formula parameters.

inputSeries

The input series.

outputSeries

The output series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula Properties

DataFormula Properties |
 | See Also

Public Properties

Name | Description
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations; otherwise, empty points are treated as zeroes.
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as "rolling average" from zero.
Statistics | Gets a reference to the StatisticFormula class.

See Also

Reference

DataFormula Class


DataFormula.IsEmptyPointIgnored Property

DataFormula.IsEmptyPointIgnored Property |
 | See Also

Gets or sets a flag that indicates whether empty points are ignored while performing calculations; otherwise, empty points are treated as zeroes.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsEmptyPointIgnored As Boolean
public bool IsEmptyPointIgnored { get; set; }
public:
property bool IsEmptyPointIgnored {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEmptyPointIgnored ()

/** @property */
public void set_IsEmptyPointIgnored (boolean value)

public function get IsEmptyPointIgnored () : boolean

public function set IsEmptyPointIgnored (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.IsStartFromFirst Property

DataFormula.IsStartFromFirst Property |
 | See Also

Gets or sets a flag that indicates whether to start formulas such as "rolling average" from zero.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsStartFromFirst As Boolean
public bool IsStartFromFirst { get; set; }
public:
property bool IsStartFromFirst {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsStartFromFirst ()

/** @property */
public void set_IsStartFromFirst (boolean value)

public function get IsStartFromFirst () : boolean

public function set IsStartFromFirst (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataFormula.Statistics Property

DataFormula.Statistics Property |
 | See Also

Gets a reference to the StatisticFormula class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Statistics As StatisticFormula
public StatisticFormula Statistics { get; }
public:
property StatisticFormula^ Statistics {
    StatisticFormula^ get ();
}
/** @property */
public StatisticFormula get_Statistics ()

public function get Statistics () : StatisticFormula

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataFormula Class
DataFormula Members


DataManipulator Class

DataManipulator Class |
 | See Also Members

Performs data manipulation operations at run time. This class is exposed by the DataManipulator property of the root Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class DataManipulator
    Inherits DataFormula
public class DataManipulator : DataFormula
public ref class DataManipulator : public DataFormula
public class DataManipulator extends DataFormula
public class DataManipulator extends DataFormula

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.DataFormula
System.Windows.Forms.DataVisualization.Charting.DataManipulator

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Members


DataManipulator Members

DataManipulator Members |
 | See Also Constructors Methods Properties

Performs data manipulation operations at run time. This class is exposed by the DataManipulator property of the root Chart object.

The following tables list the members exposed by the DataManipulator type.

Public Constructors

Name | Description
DataManipulator | Initializes a new instance of the DataManipulator class.
Top

Public Properties

Name | Description
FilterMatchedPoints | Gets or sets a value that determines whether points are filtered if they match criteria specified in arguments in the Filter methods of this class.
FilterSetEmptyPoints | Gets or sets a flag that indicates whether points filtered by the Filter or FilterTopN methods will be removed or marked as empty.
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations; otherwise, empty points are treated as zeroes. (inherited from DataFormula)
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as "rolling average" from zero. (inherited from DataFormula)
Statistics | Gets a reference to the StatisticFormula class. (inherited from DataFormula)
Top

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | (inherited from DataFormula )
Equals | Overloaded. (inherited from Object )
ExportSeriesValues | Overloaded.
Filter | Overloaded.
FilterTopN | Overloaded.
FinancialFormula | Overloaded. (inherited from DataFormula )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Group | Overloaded.
GroupByAxisLabel | Overloaded.
InsertEmptyPoints | Overloaded.
ReferenceEquals | (inherited from Object )
Sort | Overloaded.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataManipulator Class


DataManipulator Constructor

DataManipulator Constructor |
 | See Also

Initializes a new instance of the DataManipulator class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public DataManipulator ()
public:
DataManipulator ()
public DataManipulator ()
public function DataManipulator ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator Methods

DataManipulator Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
CopySeriesValues | (inherited from DataFormula )
Equals | Overloaded. (inherited from Object )
ExportSeriesValues | Overloaded.
Filter | Overloaded.
FilterTopN | Overloaded.
FinancialFormula | Overloaded. (inherited from DataFormula )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Group | Overloaded.
GroupByAxisLabel | Overloaded.
InsertEmptyPoints | Overloaded.
ReferenceEquals | (inherited from Object )
Sort | Overloaded.
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataManipulator Class


DataManipulator.ExportSeriesValues Method

DataManipulator.ExportSeriesValues Method |
 | See Also

Overload List

Name | Description
DataManipulator.ExportSeriesValues () | Exports the data for every series stored in the SeriesCollection to the DataSet object.
DataManipulator.ExportSeriesValues (Series) | Exports data from the specified series to the DataSet object.
DataManipulator.ExportSeriesValues (String) | Exports data from one or more series to the DataSet object.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.ExportSeriesValues Method ()

DataManipulator.ExportSeriesValues Method () |
 | See Also

Exports the data for every series stored in the SeriesCollection to the DataSet object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ExportSeriesValues As DataSet
public DataSet ExportSeriesValues ()
public:
DataSet^ ExportSeriesValues ()
public DataSet ExportSeriesValues ()
public function ExportSeriesValues () : DataSet

Return Value

A DataSet object that contains series data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.ExportSeriesValues Method (Series)

DataManipulator.ExportSeriesValues Method (Series) |
 | See Also

Exports data from the specified series to the DataSet object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ExportSeriesValues ( _
    series As Series _
) As DataSet
public DataSet ExportSeriesValues (
    Series series
)
public:
DataSet^ ExportSeriesValues (
    Series^ series
)
public DataSet ExportSeriesValues (
    Series series
)
public function ExportSeriesValues (
    series : Series
) : DataSet

Parameters

series

The series to be exported.

Return Value

A DataSet object that contains series data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.ExportSeriesValues Method (String)

DataManipulator.ExportSeriesValues Method (String) |
 | See Also

Exports data from one or more series to the DataSet object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ExportSeriesValues ( _
    seriesNames As String _
) As DataSet
public DataSet ExportSeriesValues (
    string seriesNames
)
public:
DataSet^ ExportSeriesValues (
    String^ seriesNames
)
public DataSet ExportSeriesValues (
    String seriesNames
)
public function ExportSeriesValues (
    seriesNames : String
) : DataSet

Parameters

seriesNames

A comma-separated list of names of the Series to be exported.

Return Value

A DataSet object that contains series data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method

DataManipulator.Filter Method |
 | See Also

Overload List

Name | Description
DataManipulator.Filter (IDataPointFilter, Series) | Performs custom filtering on the data points in a series. The Series object that is filtered also stores the modified data.
DataManipulator.Filter (IDataPointFilter, String) | Performs custom filtering on the data points in one or more Series, based on the points in the first series. The filtered Series objects also store the modified data.
DataManipulator.Filter (CompareMethod, Double, Series) | Filters data points in a series by applying a filtering rule to the first Y-value of each data point. The Series object that is filtered also stores the modified data.
DataManipulator.Filter (CompareMethod, Double, String) | Filters one or more series by applying a filtering rule to the first Y-value of the data points in the first series. The filtered Series objects are used to store the modified data.
DataManipulator.Filter (DateRangeType, String, Series) | Filters the data points in a series, either by removing the specified points or by marking them as empty for the specified date/time ranges. The Series object that is filtered is used to store the modified data.
DataManipulator.Filter (DateRangeType, String, String) | Filters the data points of one or more series, either by removing the specified points or by marking them as empty for the given date/time ranges. The filtered Series objects are used to store the modified data.
DataManipulator.Filter (IDataPointFilter, Series, Series) | Performs custom filtering on the data points in a series.
DataManipulator.Filter (IDataPointFilter, String, String) | Performs custom filtering on the data points in one or more series, based on the points of the first series.
DataManipulator.Filter (CompareMethod, Double, Series, Series) | Filters the data points in a series by applying a filtering rule to the first Y-value of each of the data points.
DataManipulator.Filter (CompareMethod, Double, String, String) | Filters one or more series by applying a filtering rule to the first Y-value of each of the data points in the first series.
DataManipulator.Filter (DateRangeType, String, Series, Series) | Filters the data points in a series, either by removing the specified points or by marking them as empty for the given date/time ranges.
DataManipulator.Filter (DateRangeType, String, String, String) | Filters the data points for one or more series, by either removing the specified points or by marking them as empty for the given date/time ranges.
DataManipulator.Filter (CompareMethod, Double, Series, Series, String) | Filters the data points in a series by applying a filtering rule to the specified data point values for comparison.
DataManipulator.Filter (CompareMethod, Double, String, String, String) | Filters one or more series by applying a filtering rule to the specified data point values in the first series.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (IDataPointFilter, Series)

DataManipulator.Filter Method (IDataPointFilter, Series) |
 | See Also

Performs custom filtering on the data points in a series. The Series object that is filtered also stores the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeries As Series _
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    Series^ inputSeries
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeries : Series
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeries

The Series object that is filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (IDataPointFilter, String)

DataManipulator.Filter Method (IDataPointFilter, String) |
 | See Also

Performs custom filtering on the data points in one or more Series, based on the points in the first series. The filtered Series objects also store the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeriesNames As String _
)
public void Filter (
    IDataPointFilter filterInterface,
    string inputSeriesNames
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    String^ inputSeriesNames
)
public void Filter (
    IDataPointFilter filterInterface,
    String inputSeriesNames
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeriesNames : String
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (CompareMethod, Double, Series)

DataManipulator.Filter Method (CompareMethod, Double, Series) |
 | See Also

Filters data points in a series by applying a filtering rule to the first Y-value of each data point. The Series object that is filtered also stores the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeries As Series _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series^ inputSeries
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeries : Series
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeries

The Series object that is filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (CompareMethod, Double, String)

DataManipulator.Filter Method (CompareMethod, Double, String) |
 | See Also

Filters one or more series by applying a filtering rule to the first Y-value of the data points in the first series. The filtered Series objects are used to store the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeriesNames As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    string inputSeriesNames
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String^ inputSeriesNames
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String inputSeriesNames
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeriesNames : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (DateRangeType, String, Series)

DataManipulator.Filter Method (DateRangeType, String, Series) |
 | See Also

Filters the data points in a series, either by removing the specified points or by marking them as empty for the specified date/time ranges. The Series object that is filtered is used to store the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeries As Series _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    Series inputSeries
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    Series^ inputSeries
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    Series inputSeries
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeries : Series
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeries

The Series object to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (DateRangeType, String, String)

DataManipulator.Filter Method (DateRangeType, String, String) |
 | See Also

Filters the data points of one or more series, either by removing the specified points or by marking them as empty for the given date/time ranges. The filtered Series objects are used to store the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeriesNames As String _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    string inputSeriesNames
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    String^ inputSeriesNames
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    String inputSeriesNames
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeriesNames : String
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (IDataPointFilter, Series, Series)

DataManipulator.Filter Method (IDataPointFilter, Series, Series) |
 | See Also

Performs custom filtering on the data points in a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries,
    Series outputSeries
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Filter (
    IDataPointFilter filterInterface,
    Series inputSeries,
    Series outputSeries
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (IDataPointFilter, String, String)

DataManipulator.Filter Method (IDataPointFilter, String, String) |
 | See Also

Performs custom filtering on the data points in one or more series, based on the points of the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    filterInterface As IDataPointFilter, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void Filter (
    IDataPointFilter filterInterface,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void Filter (
    IDataPointFilter^ filterInterface,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void Filter (
    IDataPointFilter filterInterface,
    String inputSeriesNames,
    String outputSeriesNames
)
public function Filter (
    filterInterface : IDataPointFilter,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

filterInterface

An object that implements the IDataPointFilter interface.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (CompareMethod, Double, Series, Series)

DataManipulator.Filter Method (CompareMethod, Double, Series, Series) |
 | See Also

Filters the data points in a series by applying a filtering rule to the first Y-value of each of the data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (CompareMethod, Double, String, String)

DataManipulator.Filter Method (CompareMethod, Double, String, String) |
 | See Also

Filters one or more series by applying a filtering rule to the first Y-value of each of the data points in the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String inputSeriesNames,
    String outputSeriesNames
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. The number of output series must match the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (DateRangeType, String, Series, Series)

DataManipulator.Filter Method (DateRangeType, String, Series, Series) |
 | See Also

Filters the data points in a series, either by removing the specified points or by marking them as empty for the given date/time ranges.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    Series inputSeries,
    Series outputSeries
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    Series inputSeries,
    Series outputSeries
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (DateRangeType, String, String, String)

DataManipulator.Filter Method (DateRangeType, String, String, String) |
 | See Also

Filters the data points for one or more series, by either removing the specified points or by marking them as empty for the given date/time ranges.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    dateRange As DateRangeType, _
    rangeElements As String, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void Filter (
    DateRangeType dateRange,
    string rangeElements,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void Filter (
    DateRangeType dateRange,
    String^ rangeElements,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void Filter (
    DateRangeType dateRange,
    String rangeElements,
    String inputSeriesNames,
    String outputSeriesNames
)
public function Filter (
    dateRange : DateRangeType,
    rangeElements : String,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

dateRange

A DateRangeType enumeration value that represents a date/time interval, such as days of the week, days of the month, and so forth. Determines the range over which the given elements will be filtered.

rangeElements

Specifies the elements within the date/time range designated by the dateRange parameter that will be filtered. Can be a single value, for example, "7"; comma-separated values, for example, "5,6"; a range of values, such as "9-11"; or any variation thereof, such as "5,6,9-11".

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (CompareMethod, Double, Series, Series, String)

DataManipulator.Filter Method (CompareMethod, Double, Series, Series, String) |
 | See Also

Filters the data points in a series by applying a filtering rule to the specified data point values for comparison.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeries As Series, _
    outputSeries As Series, _
    usingValue As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries,
    string usingValue
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series^ inputSeries,
    Series^ outputSeries,
    String^ usingValue
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    Series inputSeries,
    Series outputSeries,
    String usingValue
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeries : Series,
    outputSeries : Series,
    usingValue : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Filter Method (CompareMethod, Double, String, String, String)

DataManipulator.Filter Method (CompareMethod, Double, String, String, String) |
 | See Also

Filters one or more series by applying a filtering rule to the specified data point values in the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Filter ( _
    compareMethod As CompareMethod, _
    compareValue As Double, _
    inputSeriesNames As String, _
    outputSeriesNames As String, _
    usingValue As String _
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    string inputSeriesNames,
    string outputSeriesNames,
    string usingValue
)
public:
void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String^ inputSeriesNames,
    String^ outputSeriesNames,
    String^ usingValue
)
public void Filter (
    CompareMethod compareMethod,
    double compareValue,
    String inputSeriesNames,
    String outputSeriesNames,
    String usingValue
)
public function Filter (
    compareMethod : CompareMethod,
    compareValue : double,
    inputSeriesNames : String,
    outputSeriesNames : String,
    usingValue : String
)

Parameters

compareMethod

A CompareMethod enumeration value that determines the comparison method for the filtering rule. Can be LessThan, EqualTo, and so forth.

compareValue

The value part of the filtering rule that is applied to the first Y-values of data points. For example, in the filtering rule "<6", 6 is the value.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. The number of output series must equal the number of input series, otherwise an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method

DataManipulator.FilterTopN Method |
 | See Also

Overload List

Name | Description
DataManipulator.FilterTopN (Int32, Series) | Filters out all data points in a series except for a specified number of points with the largest first Y-values. The Series object that is filtered is used to store the modified data.
DataManipulator.FilterTopN (Int32, String) | Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first series that have the largest first Y-values. The Series objects that are filtered are used to store the modified data.
DataManipulator.FilterTopN (Int32, Series, Series) | Filters all data points in a series except for a specified number of points with the largest first Y-values.
DataManipulator.FilterTopN (Int32, String, String) | Filters out data points in one or more series except for a specified number of points. The points that aren't filtered correspond to points in the first series that have the largest first Y-values.
DataManipulator.FilterTopN (Int32, Series, Series, String) | Filters all data points in a series except for a specified number of data points with the largest values.
DataManipulator.FilterTopN (Int32, String, String, String) | Filters all data points in one or more series except for a specified number of data points. The points that are not filtered correspond to points in the first series that have the largest values.
DataManipulator.FilterTopN (Int32, Series, Series, String, Boolean) | Filters all data points in a series except for a specified number of points with the smallest or largest values.
DataManipulator.FilterTopN (Int32, String, String, String, Boolean) | Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first input series that have the largest or smallest values.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, Series)

DataManipulator.FilterTopN Method (Int32, Series) |
 | See Also

Filters out all data points in a series except for a specified number of points with the largest first Y-values. The Series object that is filtered is used to store the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries
)
public void FilterTopN (
    int pointCount,
    Series inputSeries
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, String)

DataManipulator.FilterTopN Method (Int32, String) |
 | See Also

Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first series that have the largest first Y-values. The Series objects that are filtered are used to store the modified data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, Series, Series)

DataManipulator.FilterTopN Method (Int32, Series, Series) |
 | See Also

Filters all data points in a series except for a specified number of points with the largest first Y-values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries,
    Series^ outputSeries
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, String, String)

DataManipulator.FilterTopN Method (Int32, String, String) |
 | See Also

Filters out data points in one or more series except for a specified number of points. The points that aren't filtered correspond to points in the first series that have the largest first Y-values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String, _
    outputSeriesNames As String _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames,
    string outputSeriesNames
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames,
    String^ outputSeriesNames
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames,
    String outputSeriesNames
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String,
    outputSeriesNames : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, Series, Series, String)

DataManipulator.FilterTopN Method (Int32, Series, Series, String) |
 | See Also

Filters all data points in a series except for a specified number of data points with the largest values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series, _
    outputSeries As Series, _
    usingValue As String _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    string usingValue
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries,
    Series^ outputSeries,
    String^ usingValue
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    String usingValue
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series,
    outputSeries : Series,
    usingValue : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, String, String, String)

DataManipulator.FilterTopN Method (Int32, String, String, String) |
 | See Also

Filters all data points in one or more series except for a specified number of data points. The points that are not filtered correspond to points in the first series that have the largest values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String, _
    outputSeriesNames As String, _
    usingValue As String _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames,
    string outputSeriesNames,
    string usingValue
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames,
    String^ outputSeriesNames,
    String^ usingValue
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames,
    String outputSeriesNames,
    String usingValue
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String,
    outputSeriesNames : String,
    usingValue : String
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, Series, Series, String, Boolean)

DataManipulator.FilterTopN Method (Int32, Series, Series, String, Boolean) |
 | See Also

Filters all data points in a series except for a specified number of points with the smallest or largest values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeries As Series, _
    outputSeries As Series, _
    usingValue As String, _
    getTopValues As Boolean _
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    string usingValue,
    bool getTopValues
)
public:
void FilterTopN (
    int pointCount,
    Series^ inputSeries,
    Series^ outputSeries,
    String^ usingValue,
    bool getTopValues
)
public void FilterTopN (
    int pointCount,
    Series inputSeries,
    Series outputSeries,
    String usingValue,
    boolean getTopValues
)
public function FilterTopN (
    pointCount : int,
    inputSeries : Series,
    outputSeries : Series,
    usingValue : String,
    getTopValues : boolean
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeries

The Series object to be filtered.

outputSeries

A Series object that stores the filtered data. If the series does not exist, an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

getTopValues

True if the largest values are kept, false if the smallest values are kept.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterTopN Method (Int32, String, String, String, Boolean)

DataManipulator.FilterTopN Method (Int32, String, String, String, Boolean) |
 | See Also

Filters all data points in one or more series except for a specified number of points. The points that are not filtered correspond to points in the first input series that have the largest or smallest values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FilterTopN ( _
    pointCount As Integer, _
    inputSeriesNames As String, _
    outputSeriesNames As String, _
    usingValue As String, _
    getTopValues As Boolean _
)
public void FilterTopN (
    int pointCount,
    string inputSeriesNames,
    string outputSeriesNames,
    string usingValue,
    bool getTopValues
)
public:
void FilterTopN (
    int pointCount,
    String^ inputSeriesNames,
    String^ outputSeriesNames,
    String^ usingValue,
    bool getTopValues
)
public void FilterTopN (
    int pointCount,
    String inputSeriesNames,
    String outputSeriesNames,
    String usingValue,
    boolean getTopValues
)
public function FilterTopN (
    pointCount : int,
    inputSeriesNames : String,
    outputSeriesNames : String,
    usingValue : String,
    getTopValues : boolean
)

Parameters

pointCount

The number of data points that the filtering operation will not remove.

inputSeriesNames

A comma-separated list of names of the Series to be filtered.

outputSeriesNames

A comma-separated list of names of the Series that store the filtered data. Make sure that the number of output series matches the number of input series, otherwise an exception will be thrown.

usingValue

The data point value that the filtering rule is applied to. Can be X, Y, Y2, Y3, and so forth.

getTopValues

True if the largest values are kept, false if the smallest values are kept.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method

DataManipulator.Group Method |
 | See Also

Overload List

Name | Description
DataManipulator.Group (String, Double, IntervalType, Series) | Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, String) | Groups data using one or more formulas, for one or more series. Series are cleared of their original data and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, Series, Series) | Groups a series' data using one or more formulas. An output series is used to store the grouped data points.
DataManipulator.Group (String, Double, IntervalType, String, String) | Groups data for one or more series, using one or more formulas. Output series are used to store the grouped data points.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, Series) | Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, String) | Groups data for one or more series, using one or more formulas. Series are cleared of their original data and used to store the new data points.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, Series, Series) | Groups a series using one or more formulas. An output series is used to store the grouped data points, and an offset can be used for intervals.
DataManipulator.Group (String, Double, IntervalType, Double, IntervalType, String, String) | Groups one or more series, using one or more formulas. Output series are used to store the grouped data points, and an offset can be used for intervals.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, Series)

DataManipulator.Group Method (String, Double, IntervalType, Series) |
 | See Also

Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    Series^ inputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeries

The Series object to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, String)

DataManipulator.Group Method (String, Double, IntervalType, String) |
 | See Also

Groups data using one or more formulas, for one or more series. Series are cleared of their original data and used to store the new data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    string inputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    String^ inputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    String inputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, Series, Series)

DataManipulator.Group Method (String, Double, IntervalType, Series, Series) |
 | See Also

Groups a series' data using one or more formulas. An output series is used to store the grouped data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries,
    Series outputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    Series inputSeries,
    Series outputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeries

The Series object to be grouped.

outputSeries

The Series that will store the new data points created by the grouping operation. If it does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, String, String)

DataManipulator.Group Method (String, Double, IntervalType, String, String) |
 | See Also

Groups data for one or more series, using one or more formulas. Output series are used to store the grouped data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    inputSeriesName As String, _
    outputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    string inputSeriesName,
    string outputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    String^ inputSeriesName,
    String^ outputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    String inputSeriesName,
    String outputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    inputSeriesName : String,
    outputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

outputSeriesName

A comma-separated list of names of the Series that will store the grouped data points. If a series does not exist, it will be created; if it does exist, it will first be cleared of all data before storing grouped data points. The number of output series must equal the number of input series, or an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series) |
 | See Also

Groups data using one or more formulas. The series that is grouped is cleared of its original data, and used to store the new data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series^ inputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeries

The Series object to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String) |
 | See Also

Groups data for one or more series, using one or more formulas. Series are cleared of their original data and used to store the new data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    string inputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String^ inputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String inputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series, Series)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, Series, Series) |
 | See Also

Groups a series using one or more formulas. An output series is used to store the grouped data points, and an offset can be used for intervals.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries,
    Series outputSeries
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series^ inputSeries,
    Series^ outputSeries
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series inputSeries,
    Series outputSeries
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeries

The Series object to be grouped.

outputSeries

The Series that will store the new data points created by the grouping operation. If it does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String, String)

DataManipulator.Group Method (String, Double, IntervalType, Double, IntervalType, String, String) |
 | See Also

Groups one or more series, using one or more formulas. Output series are used to store the grouped data points, and an offset can be used for intervals.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Group ( _
    formula As String, _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    inputSeriesName As String, _
    outputSeriesName As String _
)
public void Group (
    string formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    string inputSeriesName,
    string outputSeriesName
)
public:
void Group (
    String^ formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String^ inputSeriesName,
    String^ outputSeriesName
)
public void Group (
    String formula,
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String inputSeriesName,
    String outputSeriesName
)
public function Group (
    formula : String,
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    inputSeriesName : String,
    outputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

inputSeriesName

A comma-separated list of names of the Series to be grouped.

outputSeriesName

A comma-separated list of names of the Series that will store the grouped data points. If a series does not exist, it will be created; if it does exist, it will first be cleared of all data before storing grouped data points. The number of output series must equal the number of input series, or an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.GroupByAxisLabel Method

DataManipulator.GroupByAxisLabel Method |
 | See Also

Overload List

Name | Description
DataManipulator.GroupByAxisLabel (String, Series) | Groups data points in a series by axis labels, using one or more formulas. Original data point values are cleared, and the series then stores the new grouped data points.
DataManipulator.GroupByAxisLabel (String, String) | Groups data points from one or more series by axis labels, using one or more formulas. Original data point values are cleared, and each of the series then stores its new grouped data points.
DataManipulator.GroupByAxisLabel (String, Series, Series) | Groups the data points in a series by axis labels, using one or more formulas. An output series is used to store the grouped data points.
DataManipulator.GroupByAxisLabel (String, String, String) | Groups the data points in one or more series by axis labels, using one or more formulas. Output series are used to store the grouped data points.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.GroupByAxisLabel Method (String, Series)

DataManipulator.GroupByAxisLabel Method (String, Series) |
 | See Also

Groups data points in a series by axis labels, using one or more formulas. Original data point values are cleared, and the series then stores the new grouped data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeries As Series _
)
public void GroupByAxisLabel (
    string formula,
    Series inputSeries
)
public:
void GroupByAxisLabel (
    String^ formula,
    Series^ inputSeries
)
public void GroupByAxisLabel (
    String formula,
    Series inputSeries
)
public function GroupByAxisLabel (
    formula : String,
    inputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeries

The input Series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.GroupByAxisLabel Method (String, String)

DataManipulator.GroupByAxisLabel Method (String, String) |
 | See Also

Groups data points from one or more series by axis labels, using one or more formulas. Original data point values are cleared, and each of the series then stores its new grouped data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeriesName As String _
)
public void GroupByAxisLabel (
    string formula,
    string inputSeriesName
)
public:
void GroupByAxisLabel (
    String^ formula,
    String^ inputSeriesName
)
public void GroupByAxisLabel (
    String formula,
    String inputSeriesName
)
public function GroupByAxisLabel (
    formula : String,
    inputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeriesName

A comma-separated list of names of the input Series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.GroupByAxisLabel Method (String, Series, Series)

DataManipulator.GroupByAxisLabel Method (String, Series, Series) |
 | See Also

Groups the data points in a series by axis labels, using one or more formulas. An output series is used to store the grouped data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeries As Series, _
    outputSeries As Series _
)
public void GroupByAxisLabel (
    string formula,
    Series inputSeries,
    Series outputSeries
)
public:
void GroupByAxisLabel (
    String^ formula,
    Series^ inputSeries,
    Series^ outputSeries
)
public void GroupByAxisLabel (
    String formula,
    Series inputSeries,
    Series outputSeries
)
public function GroupByAxisLabel (
    formula : String,
    inputSeries : Series,
    outputSeries : Series
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeries

The input Series to be grouped.

outputSeries

The Series that will store the new data points created by the grouping operation. If it does not exist, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.GroupByAxisLabel Method (String, String, String)

DataManipulator.GroupByAxisLabel Method (String, String, String) |
 | See Also

Groups the data points in one or more series by axis labels, using one or more formulas. Output series are used to store the grouped data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub GroupByAxisLabel ( _
    formula As String, _
    inputSeriesName As String, _
    outputSeriesName As String _
)
public void GroupByAxisLabel (
    string formula,
    string inputSeriesName,
    string outputSeriesName
)
public:
void GroupByAxisLabel (
    String^ formula,
    String^ inputSeriesName,
    String^ outputSeriesName
)
public void GroupByAxisLabel (
    String formula,
    String inputSeriesName,
    String outputSeriesName
)
public function GroupByAxisLabel (
    formula : String,
    inputSeriesName : String,
    outputSeriesName : String
)

Parameters

formula

A comma-separated list of one or more formulas to be used for calculating the grouped data point values.

inputSeriesName

A comma-separated list of names of the input Series.

outputSeriesName

A comma-separated list of names of the Series that will store the grouped data points. If a series does not exist, it will be created; if it does exist, it will first be cleared of all data before storing grouped data points. The number of output series must equal the number of input series, or an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method

DataManipulator.InsertEmptyPoints Method |
 | See Also

Overload List

Name | Description
DataManipulator.InsertEmptyPoints (Double, IntervalType, Series) | Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, String) | Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, Series) | Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, String) | Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, Double, Double, Series) | Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.
DataManipulator.InsertEmptyPoints (Double, IntervalType, Double, IntervalType, Double, Double, String) | Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Series)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Series) |
 | See Also

Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval and intervalType arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    series As Series _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    Series series
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    Series^ series
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    Series series
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    series : Series
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

series

The Series object that is checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, String)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, String) |
 | See Also

Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval and intervalType arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    seriesName As String _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    string seriesName
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    String^ seriesName
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    String seriesName
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    seriesName : String
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

seriesName

A comma-separated list of names of the Series to be checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Series)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Series) |
 | See Also

Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    series As Series _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series series
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series^ series
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    Series series
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    series : Series
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

series

The Series object in which to insert the empty points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, String)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, String) |
 | See Also

Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    seriesName As String _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    string seriesName
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String^ seriesName
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    String seriesName
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    seriesName : String
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

seriesName

A comma-separated list of names of the Series to be checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, Series)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, Series) |
 | See Also

Replaces the missing data points in a series with empty points. The series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    fromXValue As Double, _
    toXValue As Double, _
    series As Series _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    Series series
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    Series^ series
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    Series series
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    fromXValue : double,
    toXValue : double,
    series : Series
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

fromXValue

The starting point for the series range to be checked. Uses the X-values of the data points.

toXValue

The end point for the series range to be checked. Uses the X-values of the data points.

series

The Series in which to insert the empty points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, String)

DataManipulator.InsertEmptyPoints Method (Double, IntervalType, Double, IntervalType, Double, Double, String) |
 | See Also

Replaces the missing data points in one or more series with empty points. Each series is checked for a given interval that is determined by the interval, intervalOffset, intervalOffsetType and intervalType arguments. The series range that is checked is determined by the toXValue and fromXValue arguments.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub InsertEmptyPoints ( _
    interval As Double, _
    intervalType As IntervalType, _
    intervalOffset As Double, _
    intervalOffsetType As IntervalType, _
    fromXValue As Double, _
    toXValue As Double, _
    seriesName As String _
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    string seriesName
)
public:
void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    String^ seriesName
)
public void InsertEmptyPoints (
    double interval,
    IntervalType intervalType,
    double intervalOffset,
    IntervalType intervalOffsetType,
    double fromXValue,
    double toXValue,
    String seriesName
)
public function InsertEmptyPoints (
    interval : double,
    intervalType : IntervalType,
    intervalOffset : double,
    intervalOffsetType : IntervalType,
    fromXValue : double,
    toXValue : double,
    seriesName : String
)

Parameters

interval

The size of the interval checked for missing data points.

intervalType

The unit of measurement for the interval parameter.

intervalOffset

The interval offset size.

intervalOffsetType

The unit of measurement for the interval offset.

fromXValue

The starting point for the series range to be checked. Uses the X-values of the data points.

toXValue

The end point for the series range to be checked. Uses the X-values of the data points.

seriesName

A comma-separated list of names of the Series to be checked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method

DataManipulator.Sort Method |
 | See Also

Overload List

Name | Description
DataManipulator.Sort (Generic , Series) | Performs a custom sort on the data points in a series.
DataManipulator.Sort (Generic , String) | Performs a custom sort on one or more series.
DataManipulator.Sort (PointSortOrder, Series) | Performs a sort on the data points in a series using the specified order. The sort is based on the first Y-value of each of the data points.
DataManipulator.Sort (PointSortOrder, String) | Performs a sort on the data points in one or more series, using the specified order. The sort is based on the first Y-value of each of the data points.
DataManipulator.Sort (PointSortOrder, String, Series) | Performs a sort on the data points in a series using the specified order. The sort can be based on any available data point value.
DataManipulator.Sort (PointSortOrder, String, String) | Sorts the data points of one or more series in the specified order. The sort can be based on any available data point value.

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method (Generic , Series)

DataManipulator.Sort Method (Generic , Series) |
 | See Also

Performs a custom sort on the data points in a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    comparer As IComparer(Of DataPoint), _
    series As Series _
)
public void Sort (
    IComparer<DataPoint> comparer,
    Series series
)
public:
void Sort (
    IComparer<DataPoint^>^ comparer,
    Series^ series
)
public void Sort (
    IComparer<DataPoint> comparer,
    Series series
)
public function Sort (
    comparer : IComparer<DataPoint>,
    series : Series
)

Parameters

comparer

An object that implements the IComparer interface and provides the custom sorting logic.

series

The Series object to be sorted.

Remarks

This method performs a custom sort on the data points in a series; the sort logic is defined by the comparer parameter. Override and implement the Compare method of the IComparer interface, perform the comparison(s) and then return true or false. The sort order is determined by the return value.

The two object parameters of the Compare method must always be of type DataPoint.

To perform a custom sort for more than one series per function call, use the Sort method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method (Generic , String)

DataManipulator.Sort Method (Generic , String) |
 | See Also

Performs a custom sort on one or more series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    comparer As IComparer(Of DataPoint), _
    seriesName As String _
)
public void Sort (
    IComparer<DataPoint> comparer,
    string seriesName
)
public:
void Sort (
    IComparer<DataPoint^>^ comparer,
    String^ seriesName
)
public void Sort (
    IComparer<DataPoint> comparer,
    String seriesName
)
public function Sort (
    comparer : IComparer<DataPoint>,
    seriesName : String
)

Parameters

comparer

An object that implements the IComparer interface and provides the custom sorting logic.

seriesName

A comma-separated list of names of the Series to be sorted.

Remarks

This method performs a custom sort on the data points in one or more series; the sort logic is defined by the comparer parameter. Override and implement the Compare method of the IComparer interface, perform the comparison(s) and then return true or false. The sort order is determined by the return value.

Note that if multiple series are sorted, the series must be aligned, otherwise an exception will be thrown.

The two object parameters of the Compare method must always be of type DataPoint.

Important:
All data points, regardless of the series they belong to, are sorted based on the first series; if the position of a data point in the first series changes, all corresponding points in the other series change as well.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method (PointSortOrder, Series)

DataManipulator.Sort Method (PointSortOrder, Series) |
 | See Also

Performs a sort on the data points in a series using the specified order. The sort is based on the first Y-value of each of the data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    series As Series _
)
public void Sort (
    PointSortOrder pointSortOrder,
    Series series
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    Series^ series
)
public void Sort (
    PointSortOrder pointSortOrder,
    Series series
)
public function Sort (
    pointSortOrder : PointSortOrder,
    series : Series
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending.

series

The Series object to be sorted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method (PointSortOrder, String)

DataManipulator.Sort Method (PointSortOrder, String) |
 | See Also

Performs a sort on the data points in one or more series, using the specified order. The sort is based on the first Y-value of each of the data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    seriesName As String _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string seriesName
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ seriesName
)
public void Sort (
    PointSortOrder pointSortOrder,
    String seriesName
)
public function Sort (
    pointSortOrder : PointSortOrder,
    seriesName : String
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending.

seriesName

A comma-separated list of names of the Series to be sorted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method (PointSortOrder, String, Series)

DataManipulator.Sort Method (PointSortOrder, String, Series) |
 | See Also

Performs a sort on the data points in a series using the specified order. The sort can be based on any available data point value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    sortBy As String, _
    series As Series _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string sortBy,
    Series series
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ sortBy,
    Series^ series
)
public void Sort (
    PointSortOrder pointSortOrder,
    String sortBy,
    Series series
)
public function Sort (
    pointSortOrder : PointSortOrder,
    sortBy : String,
    series : Series
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending

sortBy

A string value that represents the data point values to be sorted. Possible values are: "X", "Y", "Y2", "Y3", "AxisLabel", and so forth.

series

The Series object to be sorted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.Sort Method (PointSortOrder, String, String)

DataManipulator.Sort Method (PointSortOrder, String, String) |
 | See Also

Sorts the data points of one or more series in the specified order. The sort can be based on any available data point value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    sortBy As String, _
    seriesName As String _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string sortBy,
    string seriesName
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ sortBy,
    String^ seriesName
)
public void Sort (
    PointSortOrder pointSortOrder,
    String sortBy,
    String seriesName
)
public function Sort (
    pointSortOrder : PointSortOrder,
    sortBy : String,
    seriesName : String
)

Parameters

pointSortOrder

A PointSortOrder enumeration value that determines if the sort is ascending or descending.

sortBy

A string value that represents the data point values to be sorted. Possible values are: "X", "Y", "Y2", "Y3", "AxisLabel", and so forth.

seriesName

A comma-separated list of names of the Series to be sorted.

Remarks

This method performs an ascending or descending sort on data points in a series, and is based on the value that is set in the sortBy parameter such as "X", "AxisLabel", "Y", "Y1", and so forth.

Note that if multiple series are sorted, the series must be aligned, otherwise an exception will be thrown.

Important:
All series will be sorted using the specified Y-value from the FIRST listed series; that is, all data points, regardless of the series they belong to, are sorted based on the first series.

To sort points using a custom sort routine, use a different definition of this overloaded method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator Properties

DataManipulator Properties |
 | See Also

Public Properties

Name | Description
FilterMatchedPoints | Gets or sets a value that determines whether points are filtered if they match criteria specified in arguments in the Filter methods of this class.
FilterSetEmptyPoints | Gets or sets a flag that indicates whether points filtered by the Filter or FilterTopN methods will be removed or marked as empty.
IsEmptyPointIgnored | Gets or sets a flag that indicates whether empty points are ignored while performing calculations; otherwise, empty points are treated as zeroes. (inherited from DataFormula )
IsStartFromFirst | Gets or sets a flag that indicates whether to start formulas such as "rolling average" from zero. (inherited from DataFormula )
Statistics | Gets a reference to the StatisticFormula class. (inherited from DataFormula )

See Also

Reference

DataManipulator Class


DataManipulator.FilterMatchedPoints Property

DataManipulator.FilterMatchedPoints Property |
 | See Also

Gets or sets a value that determines whether points are filtered if they match criteria specified in arguments in the Filter methods of this class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property FilterMatchedPoints As Boolean
public bool FilterMatchedPoints { get; set; }
public:
property bool FilterMatchedPoints {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_FilterMatchedPoints ()

/** @property */
public void set_FilterMatchedPoints (boolean value)

public function get FilterMatchedPoints () : boolean

public function set FilterMatchedPoints (value : boolean)

Property Value

True if points that match specified criteria are filtered, false if points that do not match the criteria are filtered. The default value is true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataManipulator.FilterSetEmptyPoints Property

DataManipulator.FilterSetEmptyPoints Property |
 | See Also

Gets or sets a flag that indicates whether points filtered by the Filter or FilterTopN methods will be removed or marked as empty.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property FilterSetEmptyPoints As Boolean
public bool FilterSetEmptyPoints { get; set; }
public:
property bool FilterSetEmptyPoints {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_FilterSetEmptyPoints ()

/** @property */
public void set_FilterSetEmptyPoints (boolean value)

public function get FilterSetEmptyPoints () : boolean

public function set FilterSetEmptyPoints (value : boolean)

Property Value

True if filtered points will be marked as empty, false if they will be removed. The default value is false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataManipulator Class
DataManipulator Members


DataPoint Class

DataPoint Class |
 | See Also Members

Represents a data point that is stored in the DataPointCollection class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class DataPoint
    Inherits DataPointCustomProperties
public class DataPoint : DataPointCustomProperties
public ref class DataPoint : public DataPointCustomProperties
public class DataPoint extends DataPointCustomProperties
public class DataPoint extends DataPointCustomProperties

Remarks

The DataPoint class stores properties associated with data as well as data point values. For example, a data point has a value, but it also has a color property, background image property, background gradient property, and so forth. For more information about data point properties, see the DataPointCustomProperties class overview topic.

Each data point consists of an X-value and one or more Y-values. The X-value can be zero, or you can set this explicitly.

Only one Y-value per point is required for all chart types except bubble, candlestick and stock charts. These chart types require more than one Y-value because one data point consists of multiple values. For example, to plot one stock chart column, four values are required: high, low, open and close values.

Data can be added at either design time or run time; you can also use data-binding at run time.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.DataPointCustomProperties
System.Windows.Forms.DataVisualization.Charting.DataPoint

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Members


DataPoint Members

DataPoint Members |
 | See Also Constructors Methods Properties

Represents a data point that is stored in the DataPointCollection class.

The following tables list the members exposed by the DataPoint type.

Public Constructors

Name | Description
DataPoint | Overloaded.
Top

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object. (inherited from DataPointCustomProperties)
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties)
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties)
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties)
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties)
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties)
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties)
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties)
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties)
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties)
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties)
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties)
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties)
CustomPropertiesExtended | Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2... (inherited from DataPointCustomProperties)
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties)
IsEmpty | Gets or sets a flag that indicates whether a data point is marked as empty.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties)
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties)
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties)
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties)
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties)
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties)
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties)
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties)
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties)
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties)
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties)
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties)
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties)
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties)
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties)
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties)
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties)
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties)
Name | Overridden. Gets or sets the name of the data point.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties)
XValue | Gets or sets the X-value of a data point.
YValues | Gets or sets the Y-value(s) of a data point.
Top

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns an exact copy of the data point.
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
GetValueByName | Returns a data point that is specified by its name. This is a helper function.
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets a custom property to its default value. (inherited from DataPointCustomProperties)
ResetIsVisibleInLegend | Resets a custom property to its default value. (inherited from DataPointCustomProperties)
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
SetValueXY | Sets the X-value and one or more Y-values of the data point.
SetValueY | Sets the Y-value(s) of a single data point.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataPoint Class


DataPoint Constructor

DataPoint Constructor |
 | See Also

Overload List

Name | Description
DataPoint () | Initializes a new instance of the DataPoint class.
DataPoint (Series) | Initializes a new instance of the DataPoint class, and sets the Series that the data point belongs to.
DataPoint (Double, Double) | Initializes a new instance of the DataPoint class with the specified X and Y-value.
DataPoint (Double, Double[]) | Initializes a new instance of the DataPoint class with the specified X-value and an array of Y-values.
DataPoint (Double, String) | Initializes a new instance of the DataPoint class with the specified X-value and Y-values.

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor ()

DataPoint Constructor () |
 | See Also

Initializes a new instance of the DataPoint class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public DataPoint ()
public:
DataPoint ()
public DataPoint ()
public function DataPoint ()

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor (Series)

DataPoint Constructor (Series) |
 | See Also

Initializes a new instance of the DataPoint class, and sets the Series that the data point belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    series As Series _
)
public DataPoint (
    Series series
)
public:
DataPoint (
    Series^ series
)
public DataPoint (
    Series series
)
public function DataPoint (
    series : Series
)

Parameters

series

The Series object that the data point belongs to.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor (Double, Double)

DataPoint Constructor (Double, Double) |
 | See Also

Initializes a new instance of the DataPoint class with the specified X and Y-value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    xValue As Double, _
    yValue As Double _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public DataPoint (
    double xValue,
    double yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
DataPoint (
    double xValue,
    double yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public DataPoint (
    double xValue,
    double yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataPoint (
    xValue : double,
    yValue : double
)

Parameters

xValue

The X-value of the data point.

yValue

The Y-value of the data point.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor (Double, Double[])

DataPoint Constructor (Double, Double[]) |
 | See Also

Initializes a new instance of the DataPoint class with the specified X-value and an array of Y-values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    xValue As Double, _
    yValues As Double() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public DataPoint (
    double xValue,
    double[] yValues
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
DataPoint (
    double xValue,
    array<double>^ yValues
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public DataPoint (
    double xValue,
    double[] yValues
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataPoint (
    xValue : double,
    yValues : double[]
)

Parameters

xValue

The X-value.

yValues

An array of Y-values.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor (Double, String)

DataPoint Constructor (Double, String) |
 | See Also

Initializes a new instance of the DataPoint class with the specified X-value and Y-values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    xValue As Double, _
    yValues As String _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public DataPoint (
    double xValue,
    string yValues
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
DataPoint (
    double xValue,
    String^ yValues
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public DataPoint (
    double xValue,
    String yValues
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataPoint (
    xValue : double,
    yValues : String
)

Parameters

xValue

The X-value of the data point.

yValues

A string of Y-values separated by commas.

Remarks

This constructor can be used to create and initialize a new instance of the DataPoint class.

However, it is highly recommended that you instead add data points at run time, using the Points collection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Methods

DataPoint Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Clone | Returns an exact copy of the data point.
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
GetValueByName | Returns a data point that is specified by its name. This is a helper function.
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets a custom property to its default value. (inherited from DataPointCustomProperties )
ResetIsVisibleInLegend | Resets a custom property to its default value. (inherited from DataPointCustomProperties )
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
SetValueXY | Sets the X-value and one or more Y-values of the data point.
SetValueY | Sets the Y-value(s) of a single data point.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataPoint Class


DataPoint.Clone Method

DataPoint.Clone Method |
 | See Also

Returns an exact copy of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Clone As DataPoint
public DataPoint Clone ()
public:
DataPoint^ Clone ()
public DataPoint Clone ()
public function Clone () : DataPoint

Return Value

A cloned DataPoint object.

Remarks

Use the Clone method to obtain an exact copy of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint.GetValueByName Method

DataPoint.GetValueByName Method |
 | See Also

Returns a data point that is specified by its name. This is a helper function.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GetValueByName ( _
    valueName As String _
) As Double
public double GetValueByName (
    string valueName
)
public:
double GetValueByName (
    String^ valueName
)
public double GetValueByName (
    String valueName
)
public function GetValueByName (
    valueName : String
) : double

Parameters

valueName

Point value names. X, Y, Y2...

Return Value

A string value that represents a data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint.SetValueXY Method

DataPoint.SetValueXY Method |
 | See Also

Sets the X-value and one or more Y-values of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub SetValueXY ( _
    xValue As Object, _
    ParamArray yValue As Object() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void SetValueXY (
    Object xValue,
    params Object[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void SetValueXY (
    Object^ xValue,
    ... array<Object^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void SetValueXY (
    Object xValue,
    Object[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function SetValueXY (
    xValue : Object,
    ... yValue : Object[]
)

Parameters

xValue

The X-value of the data point.

yValue

A list of Y-values of the data point.

Remarks

Use the SetValueXY method to set the value(s) of a data point at run-time.

Note that if you set the X-value to a value other than zero (0), a scatter plot will be generated. For further details, see the Remarks section of the XValue property.

Refer to the following table for a complete listing of valid .NET Framework types that can be used for the object type parameter.

String | DateTime | Double
Decimal | Single | Int32
UInt32 | Int64 | UInt64

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint.SetValueY Method

DataPoint.SetValueY Method |
 | See Also

Sets the Y-value(s) of a single data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Y is a cartesian coordinate and well understood")> _
Public Sub SetValueY ( _
    ParamArray yValue As Object() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")]
public void SetValueY (
    params Object[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Y is a cartesian coordinate and well understood")]
public:
void SetValueY (
    ... array<Object^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood") */
public void SetValueY (
    Object[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")
public function SetValueY (
    ... yValue : Object[]
)

Parameters

yValue

The Y-value(s) of a DataPoint object in the collection. Formatted as one or more values separated by commas.

Remarks

The SetValueY property is used to set the Y-value(s) of a data point at run time.

Only one Y-value per point is required for all chart types except for bubble, candlestick and stock charts. These chart types require more than one Y-value because one data point consists of multiple values. For example, to plot one stock chart column, four values are required: high, low, open and close values.

This property returns an array of double values when used to retrieve multiple Y-values.

Important:
The YValuesPerPoint property determines the maximum number of Y-values that all data points in a Series can have. If you specify more than the allowable number of Y-values, an exception will be raised. Refer to the following table for a complete listing of valid .NET Framework types that can be used for the object type parameter:

String | DateTime | Double
Decimal | Single | Int32
UInt32 | Int64 | UInt64

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Properties

DataPoint Properties |
 | See Also

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object. (inherited from DataPointCustomProperties )
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties )
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties )
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties )
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties )
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties )
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties )
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties )
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties )
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties )
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties )
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties )
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties )
CustomPropertiesExtended | Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2... (inherited from DataPointCustomProperties )
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties )
IsEmpty | Gets or sets a flag that indicates whether a data point is marked as empty.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties )
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties )
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties )
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties )
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties )
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties )
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties )
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties )
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties )
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties )
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties )
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties )
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties )
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties )
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties )
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties )
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties )
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties )
Name | Overridden. Gets or sets the name of the data point.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties )
XValue | Gets or sets the X-value of a data point.
YValues | Gets or sets the Y-value(s) of a data point.

See Also

Reference

DataPoint Class


DataPoint.IsEmpty Property

DataPoint.IsEmpty Property |
 | See Also

Gets or sets a flag that indicates whether a data point is marked as empty.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsEmpty As Boolean
public bool IsEmpty { get; set; }
public:
property bool IsEmpty {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEmpty ()

/** @property */
public void set_IsEmpty (boolean value)

public function get IsEmpty () : boolean

public function set IsEmpty (value : boolean)

Property Value

True if the point is marked as an empty point, otherwise false. The default value is false.

Remarks

Set this property to true to mark a data point as an empty point.

Alternatively one of the InsertEmptyPoints methods in the DataManipulator class can be used to mark missing data as empty points.

The EmptyPointStyle property determines how empty points are displayed.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint.Name Property

DataPoint.Name Property |
 | See Also

Gets or sets the name of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides Property Name As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string Name { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint.XValue Property

DataPoint.XValue Property |
 | See Also

Gets or sets the X-value of a data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property XValue As Double
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public double XValue { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property double XValue {
    double get ();
    void set (double value);
}
/** @property */
public double get_XValue ()

/** @property */
public void set_XValue (double value)

public function get XValue () : double

public function set XValue (value : double)

Property Value

A double that represents the X-value of a data point.

Remarks

All chart types can be displayed as either scatter plots or as non-scatter plots, because both X-values and Y-values can be set. Setting an X-value will result in a scatter plot, whereas not setting this property—which is equivalent to setting it to zero—will result in a non-scatter plot. For example, to draw a point chart type, add data points that have X-values of zero. To display a traditional scatter chart, add data points that have X-values other than zero.

The X-values of data points are not required to be set. If they are not set, data points are plotted sequentially, using their index values from the DataPointCollection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint.YValues Property

DataPoint.YValues Property |
 | See Also

Gets or sets the Y-value(s) of a data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property YValues As Double()
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public double[] YValues { get; set; }
[SuppressMessageAttribute(L"Microsoft.Performance", L"CA1819:PropertiesShouldNotReturnArrays")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property array<double>^ YValues {
    array<double>^ get ();
    void set (array<double>^ value);
}
/** @property */
public double[] get_YValues ()

/** @property */
public void set_YValues (double[] value)

public function get YValues () : double[]

public function set YValues (value : double[])

Property Value

An array of double values that represent the Y-value(s) of a data point.

Remarks

The YValues property is used to set the Y-values of data points.

Only one Y-value per point is required for all chart types except bubble, candlestick and stock charts. These chart types require more than one Y-value because one data point consists of multiple values. For example, to plot one stock chart column, four values are required: high, low, open and close values.

The YValues property returns an array of double values when used to retrieve the Y-values.

Important The YValuesPerPoint property determines the maximum number of Y-values that all data points in a Series can have. If you specify more than the allowable number of Y-values, an exception will be raised.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPoint Class
DataPoint Members


DataPointCollection Class

DataPointCollection Class |
 | See Also Members

Represents a collection of DataPoint objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class DataPointCollection
    Inherits ChartElementCollection(Of DataPoint)
public class DataPointCollection : ChartElementCollection<DataPoint>
public ref class DataPointCollection : public ChartElementCollection<DataPoint^>
public class DataPointCollection extends ChartElementCollection<DataPoint>
public class DataPointCollection extends ChartElementCollection<DataPoint>

Remarks

The DataPointCollection class represents a collection of DataPoint objects, which in turn represent the data points that are part of a Series object.

This collection class is implemented as the Points property of a Series object.

DataPoint objects can be appended or inserted into the collection with their X-value and Y-value(s) already specified as parameters. Note that they are also added automatically when a series is bound to a data source using either the DataBindY or DataBindXY method.

Data points are plotted in the order that they occur in this collection only if the series that the collection belongs to has its IsXValueIndexed property set to true (the default value is false), or if all X-values for all data points are zero. Otherwise data points are plotted using their X-values.

Data points can be located, and manipulated, based on maximum, minimum or specified X or Y-values using the overloaded FindMaxValue, FindMinValue or FindValue methods, respectively.

The Count property indicates the total number of items in the collection, and is commonly used to find the upper bound of the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.DataPointCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Members


DataPointCollection Members

DataPointCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of DataPoint objects.

The following tables list the members exposed by the DataPointCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
AddXY | Overloaded.
AddY | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
DataBind | Data binds the X-value, Y-value(s) and property values of the data points, such as Tooltip or LabelStyle, to the data source.
DataBindXY | Overloaded.
DataBindY | Overloaded.
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindAllByValue | Overloaded.
FindByValue | Overloaded.
FindMaxByValue | Overloaded.
FindMinByValue | Overloaded.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
InsertXY | Inserts a data point with the specified X value and one or more specified Y values.
InsertY | Inserts a data point with one or more specified Y values.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Overridden. Removes all elements from the Collection.
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

DataPointCollection Class


DataPointCollection Methods

DataPointCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
AddXY | Overloaded.
AddY | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
DataBind | Data binds the X-value, Y-value(s) and property values of the data points, such as Tooltip or LabelStyle, to the data source.
DataBindXY | Overloaded.
DataBindY | Overloaded.
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindAllByValue | Overloaded.
FindByValue | Overloaded.
FindMaxByValue | Overloaded.
FindMinByValue | Overloaded.
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
InsertXY | Inserts a data point with the specified X value and one or more specified Y values.
InsertY | Inserts a data point with one or more specified Y values.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Overridden. Removes all elements from the Collection.
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

DataPointCollection Class


DataPointCollection.Add Method

DataPointCollection.Add Method |
 | See Also

Overload List

Name | Description
DataPointCollection.Add (DataPoint) | (inherited from Add )
DataPointCollection.Add (Double[]) | Adds the new DataPoint object to a collection and sets its Y value.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.Add Method (Double[])

DataPointCollection.Add Method (Double[]) |
 | See Also

Adds the new DataPoint object to a collection and sets its Y value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function Add ( _
    ParamArray y As Double() _
) As DataPoint
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public DataPoint Add (
    params double[] y
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
DataPoint^ Add (
    ... array<double>^ y
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public DataPoint Add (
    double[] y
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function Add (
    ... y : double[]
) : DataPoint

Parameters

y

The Y-value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.AddXY Method

DataPointCollection.AddXY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.AddXY (Double, Double) | Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value.
DataPointCollection.AddXY (Object, Object[]) | Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value(s).

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.AddXY Method (Double, Double)

DataPointCollection.AddXY Method (Double, Double) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function AddXY ( _
    xValue As Double, _
    yValue As Double _
) As Integer
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public int AddXY (
    double xValue,
    double yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
int AddXY (
    double xValue,
    double yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public int AddXY (
    double xValue,
    double yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function AddXY (
    xValue : double,
    yValue : double
) : int

Parameters

xValue

X-value of the data point.

yValue

Y-value of the data point.

Return Value

An integer that represents the zero-based index where the item was inserted into the data point collection.

Remarks

This method adds DataPoint object to the DataPointCollection; the object is always added to the end of the collection.

Use the AddXY method overload if your data points require more than one Y-value.

If your data points do not need an X-value—that is, if you are creating non-scatter plots—use the AddY method instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.AddXY Method (Object, Object[])

DataPointCollection.AddXY Method (Object, Object[]) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified X-value and Y-value(s).

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Function AddXY ( _
    xValue As Object, _
    ParamArray yValue As Object() _
) As Integer
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public int AddXY (
    Object xValue,
    params Object[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
int AddXY (
    Object^ xValue,
    ... array<Object^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public int AddXY (
    Object xValue,
    Object[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function AddXY (
    xValue : Object,
    ... yValue : Object[]
) : int

Parameters

xValue

The X value of the data point.

yValue

One or more comma-separated values that represent the Y-value(s) of the data point.

Return Value

An integer value that represents the zero-based index where the item was inserted into the collection.

Remarks

This method adds one DataPoint object to the DataPointCollection; the data point is always added to the end of the collection.

You must provide at least one (1) Y-value, otherwise an exception will be thrown. This method also checks the YValueType property of the DataPointCollection object that this data belongs to; if too many Y-values are specified, an exception will be thrown.

In order for DateTime formatting to have an effect, a value must be a DateTime object.

If your data points do not need an X-value—that is, if you are creating non-scatter plots—use the AddY method instead

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.AddY Method

DataPointCollection.AddY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.AddY (Double) | Adds a DataPoint object to the end of the collection, with the specified Y-value.
DataPointCollection.AddY (Object[]) | Adds a DataPoint object to the end of the collection, with the specified Y-value(s).

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.AddY Method (Double)

DataPointCollection.AddY Method (Double) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified Y-value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Y is a cartesian coordinate and well understood")> _
Public Function AddY ( _
    yValue As Double _
) As Integer
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")]
public int AddY (
    double yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Y is a cartesian coordinate and well understood")]
public:
int AddY (
    double yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood") */
public int AddY (
    double yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")
public function AddY (
    yValue : double
) : int

Parameters

yValue

The Y-value of the data point.

Return Value

An integer that represents the zero-based index where the item was inserted into the data point collection.

Remarks

This method adds one DataPoint object to the DataPointCollection; the data point is always added to the end of the collection.

Use the method definition that allows for an array of Y-values if your data points require more than one Y-value.

If your data points need an X-value—that is, if you are creating scatter plots—use one of the AddXY methods instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.AddY Method (Object[])

DataPointCollection.AddY Method (Object[]) |
 | See Also

Adds a DataPoint object to the end of the collection, with the specified Y-value(s).

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Y is a cartesian coordinate and well understood")> _
Public Function AddY ( _
    ParamArray yValue As Object() _
) As Integer
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")]
public int AddY (
    params Object[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Y is a cartesian coordinate and well understood")]
public:
int AddY (
    ... array<Object^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood") */
public int AddY (
    Object[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")
public function AddY (
    ... yValue : Object[]
) : int

Parameters

yValue

A comma-separated list of Y-value(s) of the DataPoint object added to the collection.

Return Value

An integer that represents the location in zero-based index where the item was inserted into the collection.

Remarks

This method adds one DataPoint object to the DataPointCollection; the data point is always added to the end of the collection.

You must provide at least one (1) Y-value, otherwise an exception will be thrown. This method also checks the ChartType property of the DataPoint object this data belongs to; if too many Y-values are specified, an exception will be thrown.

The X-value will always be set to zero (0), resulting in non-scatter plots. If you want the data points to use an X-value, call one of the AddXY methods instead.

In order for DateTime formatting to have an effect, a value must be a DateTime object.

Refer to the following for a complete listing of valid .NET Framework types that can be used for the object type parameters:

String | DateTime | Double
Decimal | Single | Int32
UInt32 | Int64 | UInt64

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.ClearItems Method

DataPointCollection.ClearItems Method |
 | See Also

Removes all elements from the Collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub ClearItems
protected override void ClearItems ()
protected:
virtual void ClearItems () override
protected void ClearItems ()
protected override function ClearItems ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBind Method

DataPointCollection.DataBind Method |
 | See Also

Data binds the X-value, Y-value(s) and property values of the data points, such as Tooltip or LabelStyle, to the data source.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub DataBind ( _
    dataSource As IEnumerable, _
    xField As String, _
    yFields As String, _
    otherFields As String _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void DataBind (
    IEnumerable dataSource,
    string xField,
    string yFields,
    string otherFields
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void DataBind (
    IEnumerable^ dataSource,
    String^ xField,
    String^ yFields,
    String^ otherFields
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void DataBind (
    IEnumerable dataSource,
    String xField,
    String yFields,
    String otherFields
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataBind (
    dataSource : IEnumerable,
    xField : String,
    yFields : String,
    otherFields : String
)

Parameters

dataSource

The data source.

xField

The name of the field for X-values.

yFields

A comma separated names of the fields for Y-values.

otherFields

Other data point properties with binding rules, in the format: PointProperty=Field[{Format}] [,PointProperty=Field[{Format}]].

For example: "Tooltip=Price{C1},Url=WebSiteName".

Remarks

The data source can be the Ole(SQL)DataReader, DataView, DataSet, DataTable or DataRow.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBindXY Method

DataPointCollection.DataBindXY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.DataBindXY (IEnumerable, IEnumerable[]) | Data binds the X-value and Y-values of the collection's data points to the first columns of the specified data source.
DataPointCollection.DataBindXY (IEnumerable, String, IEnumerable, String) | Data binds the X-value and Y-values of the data points in the collection to the specified columns of the specified data sources.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBindXY Method (IEnumerable, IEnumerable[])

DataPointCollection.DataBindXY Method (IEnumerable, IEnumerable[]) |
 | See Also

Data binds the X-value and Y-values of the collection's data points to the first columns of the specified data source.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub DataBindXY ( _
    xValue As IEnumerable, _
    ParamArray yValues As IEnumerable() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void DataBindXY (
    IEnumerable xValue,
    params IEnumerable[] yValues
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void DataBindXY (
    IEnumerable^ xValue,
    ... array<IEnumerable^>^ yValues
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void DataBindXY (
    IEnumerable xValue,
    IEnumerable[] yValues
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataBindXY (
    xValue : IEnumerable,
    ... yValues : IEnumerable[]
)

Parameters

xValue

The data source that will supply the X-values for the data points.

yValues

A comma-separated list of the Y-value(s) of the DataPoint object added to the collection.

Remarks

This method binds all DataPoint objects in a Series, and uses separate data sources for the X and Y-value(s).

Note that the first available column in the data source will be used if data-binding to a table. To bind to a column other than the first column, use the DataBindXY method.

You can bind to multiple Y-values by providing a comma-separated list of IEnumerable objects for the yValues parameter.

If Y-values are not provided by the data source, or if the wrong number of values are provided, an exception will be thrown.

If you do not want to display scatter-type plots, in which both X and Y-values are used, use one of the DataBindY methods instead.

The following is a list of objects that you can use as the data source parameter:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBindXY Method (IEnumerable, String, IEnumerable, String)

DataPointCollection.DataBindXY Method (IEnumerable, String, IEnumerable, String) |
 | See Also

Data binds the X-value and Y-values of the data points in the collection to the specified columns of the specified data sources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub DataBindXY ( _
    xValue As IEnumerable, _
    xField As String, _
    yValue As IEnumerable, _
    yFields As String _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void DataBindXY (
    IEnumerable xValue,
    string xField,
    IEnumerable yValue,
    string yFields
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void DataBindXY (
    IEnumerable^ xValue,
    String^ xField,
    IEnumerable^ yValue,
    String^ yFields
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void DataBindXY (
    IEnumerable xValue,
    String xField,
    IEnumerable yValue,
    String yFields
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataBindXY (
    xValue : IEnumerable,
    xField : String,
    yValue : IEnumerable,
    yFields : String
)

Parameters

xValue

The data source that will supply the X-values for the data points.

xField

The name of the column that will supply the X-values for the data points.

yValue

A comma-separated list of the Y-value(s) of the DataPoint object added to the collection.

yFields

A comma-separated list of column name(s) that will supply the Y-values for the data points. Note that a comma can be embedded as part of a column name, by using a double comma.

Remarks

Data binds the X-value and Y-values of the data points in the collection to the specified data source's first columns.

You can bind to several Y-values by setting the yFields parameter to multiple column names. Separate the column names with commas.

If Y-values are not provided by the data source, or if the wrong number of values are provided, an exception will be thrown.

If you do not want to display scatter-type plots, in which both X and Y-values are used, use one of the DataBindY methods instead.

The following is a list of objects that you can use as the data source parameter:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBindY Method

DataPointCollection.DataBindY Method |
 | See Also

Overload List

Name | Description
DataPointCollection.DataBindY (IEnumerable[]) | Data binds the Y-value(s) of the collection's data points to the first column of the specified data source(s).
DataPointCollection.DataBindY (IEnumerable, String) | Data binds the Y-value(s) of the data points to the specified column(s) of the specified data source.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBindY Method (IEnumerable[])

DataPointCollection.DataBindY Method (IEnumerable[]) |
 | See Also

Data binds the Y-value(s) of the collection's data points to the first column of the specified data source(s).

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Y is a cartesian coordinate and well understood")> _
Public Sub DataBindY ( _
    ParamArray yValue As IEnumerable() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")]
public void DataBindY (
    params IEnumerable[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Y is a cartesian coordinate and well understood")]
public:
void DataBindY (
    ... array<IEnumerable^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood") */
public void DataBindY (
    IEnumerable[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")
public function DataBindY (
    ... yValue : IEnumerable[]
)

Parameters

yValue

One or more comma-separated IEnumerable data sources.

Remarks

This method binds the Y-value(s) of the data points in the collection to the first column of the specified data source(s).

To bind Y-values to a data source column that is not the first available column, use the DataBindY method.

You can bind several Y-values by specifying multiple data sources, using the yValue parameter. Note that the first available column in each data source will be used for each data point's successive Y-values. For example, the first column of the first IEnumerable data source will be bound to the first Y-value of data points, the first column of the second IEnumerable data source will be bound to the second Y-value of data points, and so forth.

If Y-values are not provided by the data source, or if the wrong number of values are provided, an exception will be thrown.

The following is a list of objects that you can use as the data source parameter:

The following is a list of objects that you can use as the data source:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.DataBindY Method (IEnumerable, String)

DataPointCollection.DataBindY Method (IEnumerable, String) |
 | See Also

Data binds the Y-value(s) of the data points to the specified column(s) of the specified data source.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub DataBindY ( _
    yValue As IEnumerable, _
    yFields As String _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void DataBindY (
    IEnumerable yValue,
    string yFields
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void DataBindY (
    IEnumerable^ yValue,
    String^ yFields
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void DataBindY (
    IEnumerable yValue,
    String yFields
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function DataBindY (
    yValue : IEnumerable,
    yFields : String
)

Parameters

yValue

An IEnumerable

data source object that provides the Y-value(s).

yFields

The data source field(s) to which to bind data point(s). Note that a comma can be embedded as part of a column name, by using a double comma.

Remarks

This method binds the Y-values of the data points in the collection to the specified fields(s) of the data source.

To bind only to the first field in a data source, use the DataBindY method.

You can bind to several fields by setting the yFields parameter to multiple field names that are comma-separated. Note that the first field will be used for the data point's first Y-value, the second named field will be used for the data point's second Y-value, and so forth.

If Y-values are not provided by the data source, or the wrong number of values are provided, an exception will be thrown.

The following is a list of objects that you can use as the data source:

  • DataView

  • Data readers (SQL, OleDB)

  • Arrays

  • Lists

  • All other objects that use the IEnumerable interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindAllByValue Method

DataPointCollection.FindAllByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindAllByValue (Double) | Find all the data points that are equal to the specified value.
DataPointCollection.FindAllByValue (Double, String) | Finds all the data points that are equal to the specified value.
DataPointCollection.FindAllByValue (Double, String, Int32) | Finds all the data points that are equal to the specified value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindAllByValue Method (Double)

DataPointCollection.FindAllByValue Method (Double) |
 | See Also

Find all the data points that are equal to the specified value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindAllByValue ( _
    valueToFind As Double _
) As IEnumerable(Of DataPoint)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind
)
public:
IEnumerable<DataPoint^>^ FindAllByValue (
    double valueToFind
)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind
)
public function FindAllByValue (
    valueToFind : double
) : IEnumerable<DataPoint>

Parameters

valueToFind

The data point value to find.

Return Value

An IEnumerable interface that represents the enumerator of the matching data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindAllByValue Method (Double, String)

DataPointCollection.FindAllByValue Method (Double, String) |
 | See Also

Finds all the data points that are equal to the specified value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindAllByValue ( _
    valueToFind As Double, _
    useValue As String _
) As IEnumerable(Of DataPoint)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    string useValue
)
public:
IEnumerable<DataPoint^>^ FindAllByValue (
    double valueToFind,
    String^ useValue
)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    String useValue
)
public function FindAllByValue (
    valueToFind : double,
    useValue : String
) : IEnumerable<DataPoint>

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

Return Value

An IEnumerable interface that represents the enumerator of the matching data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindAllByValue Method (Double, String, Int32)

DataPointCollection.FindAllByValue Method (Double, String, Int32) |
 | See Also

Finds all the data points that are equal to the specified value, starting from the specified index location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindAllByValue ( _
    valueToFind As Double, _
    useValue As String, _
    startIndex As Integer _
) As IEnumerable(Of DataPoint)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    string useValue,
    int startIndex
)
public:
IEnumerable<DataPoint^>^ FindAllByValue (
    double valueToFind,
    String^ useValue,
    int startIndex
)
public IEnumerable<DataPoint> FindAllByValue (
    double valueToFind,
    String useValue,
    int startIndex
)
public function FindAllByValue (
    valueToFind : double,
    useValue : String,
    startIndex : int
) : IEnumerable<DataPoint>

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

An IEnumerable interface that represents the enumerator of the matching data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindByValue Method

DataPointCollection.FindByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindByValue (Double) | Finds the first data point that is equal to the specified value.
DataPointCollection.FindByValue (Double, String) | Finds the first data point that is equal to the specified value.
DataPointCollection.FindByValue (Double, String, Int32) | Finds the first data point that is equal to the specified value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindByValue Method (Double)

DataPointCollection.FindByValue Method (Double) |
 | See Also

Finds the first data point that is equal to the specified value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindByValue ( _
    valueToFind As Double _
) As DataPoint
public DataPoint FindByValue (
    double valueToFind
)
public:
DataPoint^ FindByValue (
    double valueToFind
)
public DataPoint FindByValue (
    double valueToFind
)
public function FindByValue (
    valueToFind : double
) : DataPoint

Parameters

valueToFind

The data point value to find.

Return Value

The DataPoint that matches the specified value, or null if there is no match.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindByValue Method (Double, String)

DataPointCollection.FindByValue Method (Double, String) |
 | See Also

Finds the first data point that is equal to the specified value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindByValue ( _
    valueToFind As Double, _
    useValue As String _
) As DataPoint
public DataPoint FindByValue (
    double valueToFind,
    string useValue
)
public:
DataPoint^ FindByValue (
    double valueToFind,
    String^ useValue
)
public DataPoint FindByValue (
    double valueToFind,
    String useValue
)
public function FindByValue (
    valueToFind : double,
    useValue : String
) : DataPoint

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

Return Value

The DataPoint that matches the specified value, or null if there is no match.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindByValue Method (Double, String, Int32)

DataPointCollection.FindByValue Method (Double, String, Int32) |
 | See Also

Finds the first data point that is equal to the specified value, starting from the specified index location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindByValue ( _
    valueToFind As Double, _
    useValue As String, _
    startIndex As Integer _
) As DataPoint
public DataPoint FindByValue (
    double valueToFind,
    string useValue,
    int startIndex
)
public:
DataPoint^ FindByValue (
    double valueToFind,
    String^ useValue,
    int startIndex
)
public DataPoint FindByValue (
    double valueToFind,
    String useValue,
    int startIndex
)
public function FindByValue (
    valueToFind : double,
    useValue : String,
    startIndex : int
) : DataPoint

Parameters

valueToFind

The data point value to find.

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

The DataPoint that matches the specified value, or null if there is no match.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMaxByValue Method

DataPointCollection.FindMaxByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindMaxByValue () | Finds the data point with the maximum value.
DataPointCollection.FindMaxByValue (String) | Finds the data point value with the maximum value.
DataPointCollection.FindMaxByValue (String, Int32) | Finds the data point with the maximum value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMaxByValue Method ()

DataPointCollection.FindMaxByValue Method () |
 | See Also

Finds the data point with the maximum value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindMaxByValue As DataPoint
public DataPoint FindMaxByValue ()
public:
DataPoint^ FindMaxByValue ()
public DataPoint FindMaxByValue ()
public function FindMaxByValue () : DataPoint

Return Value

The DataPoint object with the maximum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMaxByValue Method (String)

DataPointCollection.FindMaxByValue Method (String) |
 | See Also

Finds the data point value with the maximum value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindMaxByValue ( _
    useValue As String _
) As DataPoint
public DataPoint FindMaxByValue (
    string useValue
)
public:
DataPoint^ FindMaxByValue (
    String^ useValue
)
public DataPoint FindMaxByValue (
    String useValue
)
public function FindMaxByValue (
    useValue : String
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

Return Value

The DataPoint object with the maximum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMaxByValue Method (String, Int32)

DataPointCollection.FindMaxByValue Method (String, Int32) |
 | See Also

Finds the data point with the maximum value, starting from the specified index location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindMaxByValue ( _
    useValue As String, _
    startIndex As Integer _
) As DataPoint
public DataPoint FindMaxByValue (
    string useValue,
    int startIndex
)
public:
DataPoint^ FindMaxByValue (
    String^ useValue,
    int startIndex
)
public DataPoint FindMaxByValue (
    String useValue,
    int startIndex
)
public function FindMaxByValue (
    useValue : String,
    startIndex : int
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

The DataPoint object with the maximum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMinByValue Method

DataPointCollection.FindMinByValue Method |
 | See Also

Overload List

Name | Description
DataPointCollection.FindMinByValue () | Finds the data point with the minimum value.
DataPointCollection.FindMinByValue (String) | Finds the data point with the minimum value.
DataPointCollection.FindMinByValue (String, Int32) | Finds the data point with the minimum value, starting from the specified index location.

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMinByValue Method ()

DataPointCollection.FindMinByValue Method () |
 | See Also

Finds the data point with the minimum value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindMinByValue As DataPoint
public DataPoint FindMinByValue ()
public:
DataPoint^ FindMinByValue ()
public DataPoint FindMinByValue ()
public function FindMinByValue () : DataPoint

Return Value

The DataPoint object with the minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMinByValue Method (String)

DataPointCollection.FindMinByValue Method (String) |
 | See Also

Finds the data point with the minimum value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindMinByValue ( _
    useValue As String _
) As DataPoint
public DataPoint FindMinByValue (
    string useValue
)
public:
DataPoint^ FindMinByValue (
    String^ useValue
)
public DataPoint FindMinByValue (
    String useValue
)
public function FindMinByValue (
    useValue : String
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

Return Value

A DataPoint object with the minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.FindMinByValue Method (String, Int32)

DataPointCollection.FindMinByValue Method (String, Int32) |
 | See Also

Finds the data point with the minimum value, starting from the specified index location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FindMinByValue ( _
    useValue As String, _
    startIndex As Integer _
) As DataPoint
public DataPoint FindMinByValue (
    string useValue,
    int startIndex
)
public:
DataPoint^ FindMinByValue (
    String^ useValue,
    int startIndex
)
public DataPoint FindMinByValue (
    String useValue,
    int startIndex
)
public function FindMinByValue (
    useValue : String,
    startIndex : int
) : DataPoint

Parameters

useValue

The data point value to use (X, Y1, Y2...).

startIndex

The index location of the data point to start searching from.

Return Value

The DataPoint object with the minimum value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.InsertXY Method

DataPointCollection.InsertXY Method |
 | See Also

Inserts a data point with the specified X value and one or more specified Y values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub InsertXY ( _
    index As Integer, _
    xValue As Object, _
    ParamArray yValue As Object() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public void InsertXY (
    int index,
    Object xValue,
    params Object[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
void InsertXY (
    int index,
    Object^ xValue,
    ... array<Object^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public void InsertXY (
    int index,
    Object xValue,
    Object[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function InsertXY (
    index : int,
    xValue : Object,
    ... yValue : Object[]
)

Parameters

index

The index after which the data point will be inserted.

xValue

The X value of the data point.

yValue

A comma-separated list of Y values of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection.InsertY Method

DataPointCollection.InsertY Method |
 | See Also

Inserts a data point with one or more specified Y values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Y is a cartesian coordinate and well understood")> _
Public Sub InsertY ( _
    index As Integer, _
    ParamArray yValue As Object() _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")]
public void InsertY (
    int index,
    params Object[] yValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Y is a cartesian coordinate and well understood")]
public:
void InsertY (
    int index,
    ... array<Object^>^ yValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood") */
public void InsertY (
    int index,
    Object[] yValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")
public function InsertY (
    index : int,
    ... yValue : Object[]
)

Parameters

index

The index after which the data point will be inserted.

yValue

A comma-separated list of Y values of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection Properties

DataPointCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

DataPointCollection Class


DataPointComparer Class

DataPointComparer Class |
 | See Also Members

Compares data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class DataPointComparer
    Implements IComparer(Of DataPoint)
public class DataPointComparer : IComparer<DataPoint>
public ref class DataPointComparer : IComparer<DataPoint^>
public class DataPointComparer implements IComparer<DataPoint>
public class DataPointComparer implements IComparer<DataPoint>

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.DataPointComparer

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointComparer Members


DataPointComparer Members

DataPointComparer Members |
 | See Also Constructors Methods

Compares data points.

The following tables list the members exposed by the DataPointComparer type.

Public Constructors

Name | Description
DataPointComparer | Initializes a new instance of the DataPointComparer class with the specified data series, sort order and sort value.
Top

Public Methods (see also Protected Methods )

Name | Description
Compare | Compares two data points.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataPointComparer Class


DataPointComparer Constructor

DataPointComparer Constructor |
 | See Also

Initializes a new instance of the DataPointComparer class with the specified data series, sort order and sort value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    series As Series, _
    sortOrder As PointSortOrder, _
    sortBy As String _
)
public DataPointComparer (
    Series series,
    PointSortOrder sortOrder,
    string sortBy
)
public:
DataPointComparer (
    Series^ series,
    PointSortOrder sortOrder,
    String^ sortBy
)
public DataPointComparer (
    Series series,
    PointSortOrder sortOrder,
    String sortBy
)
public function DataPointComparer (
    series : Series,
    sortOrder : PointSortOrder,
    sortBy : String
)

Parameters

series

Data series.

sortOrder

Sort order.

sortBy

Value used for the sort, for example, "X", "Y or Y1", "Y2", and so forth.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointComparer Class
DataPointComparer Members


DataPointComparer Methods

DataPointComparer Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Compare | Compares two data points.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataPointComparer Class


DataPointComparer.Compare Method

DataPointComparer.Compare Method |
 | See Also

Compares two data points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Compare ( _
    x As DataPoint, _
    y As DataPoint _
) As Integer
public int Compare (
    DataPoint x,
    DataPoint y
)
public:
virtual int Compare (
    DataPoint^ x,
    DataPoint^ y
) sealed
public final int Compare (
    DataPoint x,
    DataPoint y
)
public final function Compare (
    x : DataPoint,
    y : DataPoint
) : int

Parameters

x

First data point.

y

Second data point.

Return Value

An integer value. Returns zero (0) if the two values are equal. Returns a positive integer if the value of x is greater than the value of y; otherwise, returns a negative integer.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointComparer Class
DataPointComparer Members


DataPointCustomProperties Class

DataPointCustomProperties Class |
 | See Also Members

Defines custom properties that are common to data points, series and empty points.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class DataPointCustomProperties
    Inherits ChartNamedElement
public class DataPointCustomProperties : ChartNamedElement
public ref class DataPointCustomProperties : public ChartNamedElement
public class DataPointCustomProperties extends ChartNamedElement
public class DataPointCustomProperties extends ChartNamedElement

Remarks

This class defines custom properties such as colors, the use of background images, hatching, and so forth.

The Series class, DataPoint class and the EmptyPointStyle property are all derived from this class.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.DataPointCustomProperties
System.Windows.Forms.DataVisualization.Charting.DataPoint
System.Windows.Forms.DataVisualization.Charting.Series

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Members


DataPointCustomProperties Members

DataPointCustomProperties Members |
 | See Also Constructors Methods Properties

Defines custom properties that are common to data points, series and empty points.

The following tables list the members exposed by the DataPointCustomProperties type.

Public Constructors

Name | Description
DataPointCustomProperties | Overloaded.
Top

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object.
BackGradientStyle | Gets or sets the background gradient style.
BackHatchStyle | Gets or sets the background hatching style.
BackImage | Gets or sets the background image of the data point.
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of the background image.
BackSecondaryColor | Gets or sets the secondary background color.
BorderColor | Gets or sets the border color of the data point.
BorderDashStyle | Gets or sets the border style of the data point.
BorderWidth | Gets or sets the border width of the data point.
Color | Gets or sets the color of the data point.
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 …
CustomPropertiesExtended | Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2...
Font | Gets or sets the font of the data point.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label.
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend.
Item | Overloaded.
Label | Gets or sets the text of the data point label.
LabelAngle | Gets or sets the angle of the data point label.
LabelBackColor | Gets or sets the background color of the data point label.
LabelBorderColor | Gets or sets the border color of the data point label.
LabelBorderDashStyle | Gets or sets the border style of the label.
LabelBorderWidth | Gets or sets the border width of the label.
LabelForeColor | Gets or sets the text color of the label.
LabelFormat | Gets or sets the format of the data point label.
LabelToolTip | Gets or sets the tooltip for the data point label.
LegendText | Gets or sets the text of the item in the legend.
LegendToolTip | Gets or sets the tooltip of the item in the legend.
MarkerBorderColor | Gets or sets the border color of the marker.
MarkerBorderWidth | Gets or sets the border width of the marker.
MarkerColor | Gets or sets the marker color.
MarkerImage | Gets or sets the marker image.
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the marker.
MarkerStyle | Gets or sets the marker style.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip.
Top

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | Deletes the data point custom property with the specified name.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | Returns the data point custom property with the specified name.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
IsCustomPropertySet | Determines whether a custom property with the specified name was set.
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets a custom property to its default value.
ResetIsVisibleInLegend | Resets a custom property to its default value.
SetCustomProperty | Sets a custom property of the data point.
SetDefault | Sets the default properties of the data point. Indicates whether the previous property values must be cleared.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DataPointCustomProperties Class


DataPointCustomProperties Constructor

DataPointCustomProperties Constructor |
 | See Also

Overload List

Name | Description
DataPointCustomProperties () | Initializes a new instance of the DataPointCustomProperties class.
DataPointCustomProperties (Series, Boolean) | Initializes a new instance of the DataPointCustomProperties class with the specified series and custom properties flag.

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties Constructor ()

DataPointCustomProperties Constructor () |
 | See Also

Initializes a new instance of the DataPointCustomProperties class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public DataPointCustomProperties ()
public:
DataPointCustomProperties ()
public DataPointCustomProperties ()
public function DataPointCustomProperties ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties Constructor (Series, Boolean)

DataPointCustomProperties Constructor (Series, Boolean) |
 | See Also

Initializes a new instance of the DataPointCustomProperties class with the specified series and custom properties flag.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    series As Series, _
    pointProperties As Boolean _
)
public DataPointCustomProperties (
    Series series,
    bool pointProperties
)
public:
DataPointCustomProperties (
    Series^ series,
    bool pointProperties
)
public DataPointCustomProperties (
    Series series,
    boolean pointProperties
)
public function DataPointCustomProperties (
    series : Series,
    pointProperties : boolean
)

Parameters

series

The series that the data point belongs to.

pointProperties

A flag that indicates whether this is a data point custom property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties Methods

DataPointCustomProperties Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | Deletes the data point custom property with the specified name.
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | Returns the data point custom property with the specified name.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
IsCustomPropertySet | Determines whether a custom property with the specified name was set.
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets a custom property to its default value.
ResetIsVisibleInLegend | Resets a custom property to its default value.
SetCustomProperty | Sets a custom property of the data point.
SetDefault | Sets the default properties of the data point. Indicates whether the previous property values must be cleared.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DataPointCustomProperties Class


DataPointCustomProperties.DeleteCustomProperty Method

DataPointCustomProperties.DeleteCustomProperty Method |
 | See Also

Deletes the data point custom property with the specified name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub DeleteCustomProperty ( _
    name As String _
)
public virtual void DeleteCustomProperty (
    string name
)
public:
virtual void DeleteCustomProperty (
    String^ name
)
public void DeleteCustomProperty (
    String name
)
public function DeleteCustomProperty (
    name : String
)

Parameters

name

The name of the property to delete.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.GetCustomProperty Method

DataPointCustomProperties.GetCustomProperty Method |
 | See Also

Returns the data point custom property with the specified name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Function GetCustomProperty ( _
    name As String _
) As String
public virtual string GetCustomProperty (
    string name
)
public:
virtual String^ GetCustomProperty (
    String^ name
)
public String GetCustomProperty (
    String name
)
public function GetCustomProperty (
    name : String
) : String

Parameters

name

The name of the property to return.

Return Value

A string value that represents the data point custom property with the specified name. If the requested property is not set, the default custom property of the data series will be returned.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.IsCustomPropertySet Method

DataPointCustomProperties.IsCustomPropertySet Method |
 | See Also

Determines whether a custom property with the specified name was set.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Function IsCustomPropertySet ( _
    name As String _
) As Boolean
public virtual bool IsCustomPropertySet (
    string name
)
public:
virtual bool IsCustomPropertySet (
    String^ name
)
public boolean IsCustomPropertySet (
    String name
)
public function IsCustomPropertySet (
    name : String
) : boolean

Parameters

name

The name of the custom property to check.

Return Value

True if the custom property was set, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.ResetIsValueShownAsLabel Method

DataPointCustomProperties.ResetIsValueShownAsLabel Method |
 | See Also

Resets a custom property to its default value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub ResetIsValueShownAsLabel
public void ResetIsValueShownAsLabel ()
public:
void ResetIsValueShownAsLabel ()
public void ResetIsValueShownAsLabel ()
public function ResetIsValueShownAsLabel ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.ResetIsVisibleInLegend Method

DataPointCustomProperties.ResetIsVisibleInLegend Method |
 | See Also

Resets a custom property to its default value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub ResetIsVisibleInLegend
public void ResetIsVisibleInLegend ()
public:
void ResetIsVisibleInLegend ()
public void ResetIsVisibleInLegend ()
public function ResetIsVisibleInLegend ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.SetCustomProperty Method

DataPointCustomProperties.SetCustomProperty Method |
 | See Also

Sets a custom property of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub SetCustomProperty ( _
    name As String, _
    propertyValue As String _
)
public virtual void SetCustomProperty (
    string name,
    string propertyValue
)
public:
virtual void SetCustomProperty (
    String^ name,
    String^ propertyValue
)
public void SetCustomProperty (
    String name,
    String propertyValue
)
public function SetCustomProperty (
    name : String,
    propertyValue : String
)

Parameters

name

The name of the property.

propertyValue

The value of the property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.SetDefault Method

DataPointCustomProperties.SetDefault Method |
 | See Also

Sets the default properties of the data point. Indicates whether the previous property values must be cleared.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Sub SetDefault ( _
    clearAll As Boolean _
)
public virtual void SetDefault (
    bool clearAll
)
public:
virtual void SetDefault (
    bool clearAll
)
public void SetDefault (
    boolean clearAll
)
public function SetDefault (
    clearAll : boolean
)

Parameters

clearAll

A flag that indicates whether to clear previous property values.

Remarks

If the clearAll parameter is set to true, all previous property values are cleared, otherwise they are not.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties Properties

DataPointCustomProperties Properties |
 | See Also

Public Properties

Name | Description
AxisLabel | Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object.
BackGradientStyle | Gets or sets the background gradient style.
BackHatchStyle | Gets or sets the background hatching style.
BackImage | Gets or sets the background image of the data point.
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of the background image.
BackSecondaryColor | Gets or sets the secondary background color.
BorderColor | Gets or sets the border color of the data point.
BorderDashStyle | Gets or sets the border style of the data point.
BorderWidth | Gets or sets the border width of the data point.
Color | Gets or sets the color of the data point.
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 …
CustomPropertiesExtended | Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2...
Font | Gets or sets the font of the data point.
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label.
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend.
Item | Overloaded.
Label | Gets or sets the text of the data point label.
LabelAngle | Gets or sets the angle of the data point label.
LabelBackColor | Gets or sets the background color of the data point label.
LabelBorderColor | Gets or sets the border color of the data point label.
LabelBorderDashStyle | Gets or sets the border style of the label.
LabelBorderWidth | Gets or sets the border width of the label.
LabelForeColor | Gets or sets the text color of the label.
LabelFormat | Gets or sets the format of the data point label.
LabelToolTip | Gets or sets the tooltip for the data point label.
LegendText | Gets or sets the text of the item in the legend.
LegendToolTip | Gets or sets the tooltip of the item in the legend.
MarkerBorderColor | Gets or sets the border color of the marker.
MarkerBorderWidth | Gets or sets the border width of the marker.
MarkerColor | Gets or sets the marker color.
MarkerImage | Gets or sets the marker image.
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the marker.
MarkerStyle | Gets or sets the marker style.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip.

See Also

Reference

DataPointCustomProperties Class


DataPointCustomProperties.AxisLabel Property

DataPointCustomProperties.AxisLabel Property |
 | See Also

Gets or sets the text of the X-axis label for the data point, series or an empty point. This property is only used if a custom label has not been specified for the relevant Axis object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AxisLabel As String
public virtual string AxisLabel { get; set; }
public:
virtual property String^ AxisLabel {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AxisLabel ()

/** @property */
public void set_AxisLabel (String value)

public function get AxisLabel () : String

public function set AxisLabel (value : String)

Property Value

A string value that represents the text of the X-axis label.

Remarks

This property sets the axis label for a data point, series or an empty point.

This property can only be set at run time for a Series object. If you set this property or a Series object, all of its data points will use this label.

If the AxisLabel property is not set and a custom label has not been specified, an axis label will be generated automatically using the axis scale.

Empty point labels are set using the EmptyPointStyle property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackGradientStyle Property

DataPointCustomProperties.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackHatchStyle Property

DataPointCustomProperties.BackHatchStyle Property |
 | See Also

Gets or sets the background hatching style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackImage Property

DataPointCustomProperties.BackImage Property |
 | See Also

Gets or sets the background image of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackImageAlignment Property

DataPointCustomProperties.BackImageAlignment Property |
 | See Also

Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackImageTransparentColor Property

DataPointCustomProperties.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the background image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be replaced with a transparent color when the image is drawn.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackImageWrapMode Property

DataPointCustomProperties.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of the background image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value that defines the drawing mode of the image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BackSecondaryColor Property

DataPointCustomProperties.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary background color.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BorderColor Property

DataPointCustomProperties.BorderColor Property |
 | See Also

Gets or sets the border color of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BorderDashStyle Property

DataPointCustomProperties.BorderDashStyle Property |
 | See Also

Gets or sets the border style of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.BorderWidth Property

DataPointCustomProperties.BorderWidth Property |
 | See Also

Gets or sets the border width of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.Color Property

DataPointCustomProperties.Color Property |
 | See Also

Gets or sets the color of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Color As Color
public Color Color { get; set; }
public:
property Color Color {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_Color ()

/** @property */
public void set_Color (Color value)

public function get Color () : Color

public function set Color (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.CustomProperties Property

DataPointCustomProperties.CustomProperties Property |
 | See Also

Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 …

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Property CustomProperties As String
[BrowsableAttribute(false)]
public string CustomProperties { get; set; }
[BrowsableAttribute(false)]
public:
property String^ CustomProperties {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_CustomProperties ()

/** @property */
public void set_CustomProperties (String value)

public function get CustomProperties () : String

public function set CustomProperties (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.CustomPropertiesExtended Property

DataPointCustomProperties.CustomPropertiesExtended Property |
 | See Also

Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2...

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignOnlyAttribute(True)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property CustomPropertiesExtended As CustomProperties
[DesignOnlyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public CustomProperties CustomPropertiesExtended { get; set; }
[DesignOnlyAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property CustomProperties^ CustomPropertiesExtended {
    CustomProperties^ get ();
    void set (CustomProperties^ value);
}
/** @property */
public CustomProperties get_CustomPropertiesExtended ()

/** @property */
public void set_CustomPropertiesExtended (CustomProperties value)

public function get CustomPropertiesExtended () : CustomProperties

public function set CustomPropertiesExtended (value : CustomProperties)

Property Value

A CustomProperties object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.Font Property

DataPointCustomProperties.Font Property |
 | See Also

Gets or sets the font of the data point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.IsValueShownAsLabel Property

DataPointCustomProperties.IsValueShownAsLabel Property |
 | See Also

Gets or sets a flag that indicates whether to show the value of the data point on the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsValueShownAsLabel As Boolean
public bool IsValueShownAsLabel { get; set; }
public:
property bool IsValueShownAsLabel {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsValueShownAsLabel ()

/** @property */
public void set_IsValueShownAsLabel (boolean value)

public function get IsValueShownAsLabel () : boolean

public function set IsValueShownAsLabel (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.IsVisibleInLegend Property

DataPointCustomProperties.IsVisibleInLegend Property |
 | See Also

Gets or sets a flag that indicates whether the item is shown in the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsVisibleInLegend As Boolean
public bool IsVisibleInLegend { get; set; }
public:
property bool IsVisibleInLegend {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsVisibleInLegend ()

/** @property */
public void set_IsVisibleInLegend (boolean value)

public function get IsVisibleInLegend () : boolean

public function set IsVisibleInLegend (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.Item Property

DataPointCustomProperties.Item Property |
 | See Also

Overload List

Name | Description
DataPointCustomProperties.Item (Int32) | Gets the DataPointCustomProperties object by its position in the index.
DataPointCustomProperties.Item (String) | Gets or sets the DataPointCustomProperties object by name.

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.Item Property (Int32)

DataPointCustomProperties.Item Property (Int32) |
 | See Also

Gets the DataPointCustomProperties object by its position in the index.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Default Property Item ( _
    index As Integer _
) As String
public string this [
    int index
] { get; }
public:
property String^ default [int] {
    String^ get (int index);
}
/** @property */
public String get_Item (int index)

Parameters

index

Index of the custom property.

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.Item Property (String)

DataPointCustomProperties.Item Property (String) |
 | See Also

Gets or sets the DataPointCustomProperties object by name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Default Property Item ( _
    name As String _
) As String
public string this [
    string name
] { get; set; }
public:
property String^ default [String^] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}
/** @property */
public String get_Item (String name)

/** @property */
public void set_Item (String name, String value)

Parameters

name

The name of the custom property.

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.Label Property

DataPointCustomProperties.Label Property |
 | See Also

Gets or sets the text of the data point label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Label As String
public virtual string Label { get; set; }
public:
virtual property String^ Label {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Label ()

/** @property */
public void set_Label (String value)

public function get Label () : String

public function set Label (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelAngle Property

DataPointCustomProperties.LabelAngle Property |
 | See Also

Gets or sets the angle of the data point label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelAngle As Integer
public int LabelAngle { get; set; }
public:
property int LabelAngle {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelAngle ()

/** @property */
public void set_LabelAngle (int value)

public function get LabelAngle () : int

public function set LabelAngle (value : int)

Property Value

An integer value that represents the angle of the label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelBackColor Property

DataPointCustomProperties.LabelBackColor Property |
 | See Also

Gets or sets the background color of the data point label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelBackColor As Color
public Color LabelBackColor { get; set; }
public:
property Color LabelBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LabelBackColor ()

/** @property */
public void set_LabelBackColor (Color value)

public function get LabelBackColor () : Color

public function set LabelBackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelBorderColor Property

DataPointCustomProperties.LabelBorderColor Property |
 | See Also

Gets or sets the border color of the data point label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelBorderColor As Color
public Color LabelBorderColor { get; set; }
public:
property Color LabelBorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LabelBorderColor ()

/** @property */
public void set_LabelBorderColor (Color value)

public function get LabelBorderColor () : Color

public function set LabelBorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelBorderDashStyle Property

DataPointCustomProperties.LabelBorderDashStyle Property |
 | See Also

Gets or sets the border style of the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelBorderDashStyle As ChartDashStyle
public ChartDashStyle LabelBorderDashStyle { get; set; }
public:
property ChartDashStyle LabelBorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LabelBorderDashStyle ()

/** @property */
public void set_LabelBorderDashStyle (ChartDashStyle value)

public function get LabelBorderDashStyle () : ChartDashStyle

public function set LabelBorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelBorderWidth Property

DataPointCustomProperties.LabelBorderWidth Property |
 | See Also

Gets or sets the border width of the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelBorderWidth As Integer
public int LabelBorderWidth { get; set; }
public:
property int LabelBorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LabelBorderWidth ()

/** @property */
public void set_LabelBorderWidth (int value)

public function get LabelBorderWidth () : int

public function set LabelBorderWidth (value : int)

Property Value

An integer value that represents the width of the border.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelForeColor Property

DataPointCustomProperties.LabelForeColor Property |
 | See Also

Gets or sets the text color of the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelForeColor As Color
public Color LabelForeColor { get; set; }
public:
property Color LabelForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LabelForeColor ()

/** @property */
public void set_LabelForeColor (Color value)

public function get LabelForeColor () : Color

public function set LabelForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelFormat Property

DataPointCustomProperties.LabelFormat Property |
 | See Also

Gets or sets the format of the data point label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelFormat As String
public string LabelFormat { get; set; }
public:
property String^ LabelFormat {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelFormat ()

/** @property */
public void set_LabelFormat (String value)

public function get LabelFormat () : String

public function set LabelFormat (value : String)

Property Value

A string value that represents the format of the label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LabelToolTip Property

DataPointCustomProperties.LabelToolTip Property |
 | See Also

Gets or sets the tooltip for the data point label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LabelToolTip As String
public string LabelToolTip { get; set; }
public:
property String^ LabelToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LabelToolTip ()

/** @property */
public void set_LabelToolTip (String value)

public function get LabelToolTip () : String

public function set LabelToolTip (value : String)

Property Value

A string value that represents the tooltip for the data point label.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LegendText Property

DataPointCustomProperties.LegendText Property |
 | See Also

Gets or sets the text of the item in the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LegendText As String
public string LegendText { get; set; }
public:
property String^ LegendText {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendText ()

/** @property */
public void set_LegendText (String value)

public function get LegendText () : String

public function set LegendText (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.LegendToolTip Property

DataPointCustomProperties.LegendToolTip Property |
 | See Also

Gets or sets the tooltip of the item in the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LegendToolTip As String
public string LegendToolTip { get; set; }
public:
property String^ LegendToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LegendToolTip ()

/** @property */
public void set_LegendToolTip (String value)

public function get LegendToolTip () : String

public function set LegendToolTip (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerBorderColor Property

DataPointCustomProperties.MarkerBorderColor Property |
 | See Also

Gets or sets the border color of the marker.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerBorderColor As Color
public Color MarkerBorderColor { get; set; }
public:
property Color MarkerBorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerBorderColor ()

/** @property */
public void set_MarkerBorderColor (Color value)

public function get MarkerBorderColor () : Color

public function set MarkerBorderColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerBorderWidth Property

DataPointCustomProperties.MarkerBorderWidth Property |
 | See Also

Gets or sets the border width of the marker.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerBorderWidth As Integer
public int MarkerBorderWidth { get; set; }
public:
property int MarkerBorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerBorderWidth ()

/** @property */
public void set_MarkerBorderWidth (int value)

public function get MarkerBorderWidth () : int

public function set MarkerBorderWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerColor Property

DataPointCustomProperties.MarkerColor Property |
 | See Also

Gets or sets the marker color.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerColor As Color
public Color MarkerColor { get; set; }
public:
property Color MarkerColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerColor ()

/** @property */
public void set_MarkerColor (Color value)

public function get MarkerColor () : Color

public function set MarkerColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerImage Property

DataPointCustomProperties.MarkerImage Property |
 | See Also

Gets or sets the marker image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerImage As String
public string MarkerImage { get; set; }
public:
property String^ MarkerImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MarkerImage ()

/** @property */
public void set_MarkerImage (String value)

public function get MarkerImage () : String

public function set MarkerImage (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerImageTransparentColor Property

DataPointCustomProperties.MarkerImageTransparentColor Property |
 | See Also

Gets or sets the color that will be replaced with a transparent color when the marker image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerImageTransparentColor As Color
public Color MarkerImageTransparentColor { get; set; }
public:
property Color MarkerImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerImageTransparentColor ()

/** @property */
public void set_MarkerImageTransparentColor (Color value)

public function get MarkerImageTransparentColor () : Color

public function set MarkerImageTransparentColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerSize Property

DataPointCustomProperties.MarkerSize Property |
 | See Also

Gets or sets the size of the marker.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerSize As Integer
public int MarkerSize { get; set; }
public:
property int MarkerSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerSize ()

/** @property */
public void set_MarkerSize (int value)

public function get MarkerSize () : int

public function set MarkerSize (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.MarkerStyle Property

DataPointCustomProperties.MarkerStyle Property |
 | See Also

Gets or sets the marker style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerStyle As MarkerStyle
public MarkerStyle MarkerStyle { get; set; }
public:
property MarkerStyle MarkerStyle {
    MarkerStyle get ();
    void set (MarkerStyle value);
}
/** @property */
public MarkerStyle get_MarkerStyle ()

/** @property */
public void set_MarkerStyle (MarkerStyle value)

public function get MarkerStyle () : MarkerStyle

public function set MarkerStyle (value : MarkerStyle)

Property Value

A MarkerStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DataPointCustomProperties.ToolTip Property

DataPointCustomProperties.ToolTip Property |
 | See Also

Gets or sets the tooltip.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

DataPointCustomProperties Class
DataPointCustomProperties Members


DateRangeType Enumeration

DateRangeType Enumeration |
 | See Also

Specifies a date/time interval that determines the ranges that will be filtered when you invoke one of the Filter method definitionsfound in the DataManipulator class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration DateRangeType
public enum DateRangeType
public enum class DateRangeType
public enum DateRangeType
public enum DateRangeType

Members

Member name | Description
DayOfMonth | Date/time interval is days of the month.
DayOfWeek | Date/time interval is days of the week.
Hour | Date/time interval is hours.
Minute | Date/time interval is minutes.
Month | Date/time interval is months.
Year | Date/time interval is years.

Remarks

The DateRangeType enumeration is passed in the DateRange parameter of some Filter methods, which combined with the rangeElements parameter determines the date/time ranges that are filtered.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


DateTimeIntervalType Enumeration

DateTimeIntervalType Enumeration |
 | See Also

Specifies an interval type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration DateTimeIntervalType
public enum DateTimeIntervalType
public enum class DateTimeIntervalType
public enum DateTimeIntervalType
public enum DateTimeIntervalType

Members

Member name | Description
Auto | Automatically determined by the Chart control.
Days | Interval type is in days.
Hours | Interval type is in hours.
Milliseconds | Interval type is in milliseconds.
Minutes | Interval type is in minutes.
Months | Interval type is in months.
NotSet | The IntervalType or IntervalOffsetType property is not set. This value is used for grid lines, tick marks, strip lines and axis labels, and indicates that the interval type is being obtained from the Axis object to which the element belongs. Setting this value for an Axis object will have no effect.
Number | Interval type is in numerical.
Seconds | Interval type is in seconds.
Weeks | Interval type is in weeks.
Years | Interval type is in years.

Remarks

The DateTimeIntervalType enumeration represents date and time interval types.

Note that if you use the NotSet value, properties other than IntervalType or IntervalOffsetType will treat NotSet as an Auto value.

The DateTimeIntervalType values are applicable to the LabelStyle, Grid, TickMark and StripLine classes.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Docking Enumeration

Docking Enumeration |
 | See Also

Specifies where a chart element, such as a legend or title, will be docked on the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration Docking
public enum Docking
public enum class Docking
public enum Docking
public enum Docking

Members

Member name | Description
Bottom | Docked to the bottom of either the chart image or a ChartArea object.
Left | Docked to the left of either the chart image or a ChartArea object.
Right | Docked to the right of either the chart image or a ChartArea object.
Top | Docked to the top of either the chart image or a ChartArea object.

Remarks

The Docking enumeration represents the docking location on the Chart control that an chart element should be docked.

Set the IsDockedInsideChartArea property of the relevant chart element to specify whether that element will be docked to the entire chart image or to a ChartArea object. The chart area is specified in the DockedToChartArea property of the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ElementPosition Class

ElementPosition Class |
 | See Also Members

Represents the base class for many visual elements of the chart such as the legend, title, and chart areas. Defines the position of the chart element in relative coordinates, which range from (0,0) to (100,100).

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ElementPosition
    Inherits ChartElement
public class ElementPosition : ChartElement
public ref class ElementPosition : public ChartElement
public class ElementPosition extends ChartElement
public class ElementPosition extends ChartElement

Remarks

The ElementPosition class is used to define the position of a chart element, and represents one rectangle using the X, Y, Width and Height properties.

The ElementPosition class is always exposed as a Position property, such as Position, Position, and so forth. It is also exposed in the PrePaint and PostPaint events of the Chart control as a property of the ChartPaintEventArgs object.

The position of the applicable chart elements can be set automatically by setting the Auto property to true; chart elements can also be positioned at design time in the Design View.

There are two major differences between this class and a RectangleF structure:

  • This class can use automatic positioning.

  • This class only uses coordinates ranging from 0 to 100, otherwise an exception is thrown.

The position of chart elements is described using relative coordinates, with the top-left corner of an element having coordinates of (0,0) and the bottom-right corner of an element having coordinates of (100,100).

Elements that are plotted within a chart area use coordinates that are relative to the chart area, whereas elements outside a chart area use coordinates that are relative to the chart image.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ElementPosition

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Members


ElementPosition Members

ElementPosition Members |
 | See Also Constructors Methods Properties

Represents the base class for many visual elements of the chart such as the legend, title, and chart areas. Defines the position of the chart element in relative coordinates, which range from (0,0) to (100,100).

The following tables list the members exposed by the ElementPosition type.

Public Constructors

Name | Description
ElementPosition | Overloaded.
Top

Public Properties

Name | Description
Auto | Gets or sets a value that determines whether an applicable chart element will be positioned automatically by the Chart control.
Bottom | Gets the bottom position of a chart element, in relative coordinates.
Height | Gets or sets the height of a chart element.
Right | Gets the position of the right side of a chart element, in relative coordinates.
Size | Gets the size of a chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Width | Gets or sets the width of a chart element.
X | Gets or sets the relative X-coordinate of the top-left corner of an applicable chart element.
Y | Gets or sets the relative Y-coordinate of the top-left corner of an applicable chart element.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
FromRectangleF | Initializes an ElementPosition object from a RectangleF structure.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToRectangleF | Returns a RectangleF object that uses the coordinates of an ElementPosition object.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ElementPosition Class


ElementPosition Constructor

ElementPosition Constructor |
 | See Also

Overload List

Name | Description
ElementPosition () | Initializes a new instance of the ElementPosition class.
ElementPosition (Single, Single, Single, Single) | Initializes a new instance of the ElementPosition class with the specified x, y, width and height parameters.

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition Constructor ()

ElementPosition Constructor () |
 | See Also

Initializes a new instance of the ElementPosition class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public ElementPosition ()
public:
ElementPosition ()
public ElementPosition ()
public function ElementPosition ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition Constructor (Single, Single, Single, Single)

ElementPosition Constructor (Single, Single, Single, Single) |
 | See Also

Initializes a new instance of the ElementPosition class with the specified x, y, width and height parameters.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    x As Single, _
    y As Single, _
    width As Single, _
    height As Single _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public ElementPosition (
    float x,
    float y,
    float width,
    float height
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
ElementPosition (
    float x,
    float y,
    float width,
    float height
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public ElementPosition (
    float x,
    float y,
    float width,
    float height
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function ElementPosition (
    x : float,
    y : float,
    width : float,
    height : float
)

Parameters

x

The X position.

y

The Y position.

width

The width of the chart element.

height

The height of the chart element.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition Methods

ElementPosition Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Equals | Overloaded. (inherited from ChartElement )
FromRectangleF | Initializes an ElementPosition object from a RectangleF structure.
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToRectangleF | Returns a RectangleF object that uses the coordinates of an ElementPosition object.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from ChartElement )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ElementPosition Class


ElementPosition.FromRectangleF Method

ElementPosition.FromRectangleF Method |
 | See Also

Initializes an ElementPosition object from a RectangleF structure.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub FromRectangleF ( _
    rect As RectangleF _
)
public void FromRectangleF (
    RectangleF rect
)
public:
void FromRectangleF (
    RectangleF rect
)
public void FromRectangleF (
    RectangleF rect
)
public function FromRectangleF (
    rect : RectangleF
)

Parameters

rect

A RectangleF structure.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.ToRectangleF Method

ElementPosition.ToRectangleF Method |
 | See Also

Returns a RectangleF object that uses the coordinates of an ElementPosition object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ToRectangleF As RectangleF
public RectangleF ToRectangleF ()
public:
RectangleF ToRectangleF ()
public RectangleF ToRectangleF ()
public function ToRectangleF () : RectangleF

Return Value

A RectangleF structure.

Remarks

This method converts the position of an element to a RectangleF structure.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition Properties

ElementPosition Properties |
 | See Also

Public Properties

Name | Description
Auto | Gets or sets a value that determines whether an applicable chart element will be positioned automatically by the Chart control.
Bottom | Gets the bottom position of a chart element, in relative coordinates.
Height | Gets or sets the height of a chart element.
Right | Gets the position of the right side of a chart element, in relative coordinates.
Size | Gets the size of a chart element.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Width | Gets or sets the width of a chart element.
X | Gets or sets the relative X-coordinate of the top-left corner of an applicable chart element.
Y | Gets or sets the relative Y-coordinate of the top-left corner of an applicable chart element.

See Also

Reference

ElementPosition Class


ElementPosition.Auto Property

ElementPosition.Auto Property |
 | See Also

Gets or sets a value that determines whether an applicable chart element will be positioned automatically by the Chart control.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Auto As Boolean
public bool Auto { get; set; }
public:
property bool Auto {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Auto ()

/** @property */
public void set_Auto (boolean value)

public function get Auto () : boolean

public function set Auto (value : boolean)

Property Value

A Boolean value.

Remarks

Use this property to automatically position a chart element. For example, to position the legend automatically, set the Position property to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.Bottom Property

ElementPosition.Bottom Property |
 | See Also

Gets the bottom position of a chart element, in relative coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property Bottom As Single
[BrowsableAttribute(false)]
public float Bottom { get; }
[BrowsableAttribute(false)]
public:
property float Bottom {
    float get ();
}
/** @property */
public float get_Bottom ()

public function get Bottom () : float

Property Value

A float value that represents the relative position of the bottom of a chart element.

Remarks

The bottom of the chart element is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

Chart coordinates use (0,0) for a top-left corner, and (100,100) for a bottom-right corner.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.Height Property

ElementPosition.Height Property |
 | See Also

Gets or sets the height of a chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Height As Single
public float Height { get; set; }
public:
property float Height {
    float get ();
    void set (float value);
}
/** @property */
public float get_Height ()

/** @property */
public void set_Height (float value)

public function get Height () : float

public function set Height (value : float)

Property Value

A float value that represents the height of the chart element.

Remarks

Always uses relative coordinates. If you set a value outside of the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.Right Property

ElementPosition.Right Property |
 | See Also

Gets the position of the right side of a chart element, in relative coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property Right As Single
[BrowsableAttribute(false)]
public float Right { get; }
[BrowsableAttribute(false)]
public:
property float Right {
    float get ();
}
/** @property */
public float get_Right ()

public function get Right () : float

Property Value

A float value that represents the relative position of the right side of a chart element.

Remarks

Returns a value that represents the relative position of the right side of an applicable chart element.

The right side position is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

Chart coordinates use (0,0) for a top-left corner, and (100,100) for a bottom-right corner.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.Size Property

ElementPosition.Size Property |
 | See Also

Gets the size of a chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public ReadOnly Property Size As SizeF
[BrowsableAttribute(false)]
public SizeF Size { get; }
[BrowsableAttribute(false)]
public:
property SizeF Size {
    SizeF get ();
}
/** @property */
public SizeF get_Size ()

public function get Size () : SizeF

Property Value

A SizeF value that represents the size of a chart element.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.Width Property

ElementPosition.Width Property |
 | See Also

Gets or sets the width of a chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Width As Single
public float Width { get; set; }
public:
property float Width {
    float get ();
    void set (float value);
}
/** @property */
public float get_Width ()

/** @property */
public void set_Width (float value)

public function get Width () : float

public function set Width (value : float)

Property Value

A float value that represents the width of a chart element.

Remarks

This property always uses relative coordinates; if you set a value outside the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.X Property

ElementPosition.X Property |
 | See Also

Gets or sets the relative X-coordinate of the top-left corner of an applicable chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="X")> _
Public Property X As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="X")]
public float X { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"X")]
public:
property float X {
    float get ();
    void set (float value);
}
/** @property */
public float get_X ()

/** @property */
public void set_X (float value)

public function get X () : float

public function set X (value : float)

Property Value

A float value that represents the X-coordinate of the top-left corner of an applicable chart element.

Remarks

The X property is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

This property always uses relative coordinates; if you set a value outside the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


ElementPosition.Y Property

ElementPosition.Y Property |
 | See Also

Gets or sets the relative Y-coordinate of the top-left corner of an applicable chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Y")> _
Public Property Y As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Y")]
public float Y { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Y")]
public:
property float Y {
    float get ();
    void set (float value);
}
/** @property */
public float get_Y ()

/** @property */
public void set_Y (float value)

public function get Y () : float

public function set Y (value : float)

Property Value

A float value that represents the Y-coordinate of the top-left corner of an applicable chart element.

Remarks

The Y property is always expressed in relative coordinates, and is either relative to a ChartArea object if plotted within a chart area, or relative to the entire chart image if plotted outside of a chart area element.

This property always uses relative coordinates; if you set a value outside the 0-100 pixel range, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ElementPosition Class
ElementPosition Members


EllipseAnnotation Class

EllipseAnnotation Class |
 | See Also Members

Represents an ellipse annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class EllipseAnnotation
    Inherits RectangleAnnotation
public class EllipseAnnotation : RectangleAnnotation
public ref class EllipseAnnotation : public RectangleAnnotation
public class EllipseAnnotation extends RectangleAnnotation
public class EllipseAnnotation extends RectangleAnnotation

Remarks

An ellipse annotation can display text inside the ellipse, in addition to being displayed as an ellipse only. You can therefore annotate using an ellipse or an ellipse with text inside it.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.TextAnnotation
System.Windows.Forms.DataVisualization.Charting.RectangleAnnotation
System.Windows.Forms.DataVisualization.Charting.EllipseAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

EllipseAnnotation Members


EllipseAnnotation Members

EllipseAnnotation Members |
 | See Also Constructors Methods Properties

Represents an ellipse annotation.

The following tables list the members exposed by the EllipseAnnotation type.

Public Constructors

Name | Description
EllipseAnnotation | Initializes a new instance of the EllipseAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation)
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation)
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation)
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation)
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation)
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

EllipseAnnotation Class


EllipseAnnotation Constructor

EllipseAnnotation Constructor |
 | See Also

Initializes a new instance of the EllipseAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public EllipseAnnotation ()
public:
EllipseAnnotation ()
public EllipseAnnotation ()
public function EllipseAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Members


EllipseAnnotation Methods

EllipseAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

EllipseAnnotation Class


EllipseAnnotation Properties

EllipseAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Gets or sets the background color of the annotation. (inherited from RectangleAnnotation )
BackGradientStyle | Gets or sets the gradient style of the annotation. (inherited from RectangleAnnotation )
BackHatchStyle | Gets or sets the hatch style of an annotation background. (inherited from RectangleAnnotation )
BackSecondaryColor | Gets or sets the secondary color for an annotation background. (inherited from RectangleAnnotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from RectangleAnnotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from RectangleAnnotation )
LineWidth | Gets or sets the line width, in pixels, of an annotation. (inherited from RectangleAnnotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

EllipseAnnotation Class


EllipseAnnotation.AnnotationType Property

EllipseAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type name. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type, such as a LineAnnotation, RectangleAnnotation, or EllipseAnnotation.

This property is for internal use and should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

EllipseAnnotation Class
EllipseAnnotation Members


FinancialFormula Enumeration

FinancialFormula Enumeration |
 | See Also

Specifies a financial formula.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration FinancialFormula
public enum FinancialFormula
public enum class FinancialFormula
public enum FinancialFormula
public enum FinancialFormula

Members

Member name | Description
AccumulationDistribution | Accumulation Distribution formula uses a relationship between volume and prices to estimate the strength of price movements; if volume is increased, there is a high probability that prices will go up.
AverageTrueRange | Average True Range indicator measures commitment and compares the range between the High, Low and Close prices.
BollingerBands | Bollinger Bands indicators are plotted at standard deviation levels above and below a simple moving average.
ChaikinOscillator | Chaikin Oscillator indicator is the difference between a 3-day exponential moving average and a 10-day exponential moving average applied to the accumulation distribution.
CommodityChannelIndex | Commodity Channel Index compares prices with their moving averages.
DetrendedPriceOscillator | Detrended Price Oscillator attempts to remove trends from prices.
EaseOfMovement | Ease of Movement deals with the relationship between volume and price change, and uses volume to indicate how strong a trend is for prices.
Envelopes | Envelopes are plotted above and below a moving average using a specified percentage as the shift.
ExponentialMovingAverage | An Exponential Moving Average is an average of data calculated over a period of time where the most recent days have more weight.
Forecasting | Forecasting predicts future values using historical observations.
MassIndex | The Mass Index is used to predict trend reversal by comparing the difference and range between High and Low prices.
MedianPrice | Median prices are mid-point values of daily prices and can be used as a filter for trend indicators.
MoneyFlow | The Money Flow indicator compares upward changes and downward changes of volume-weighted typical prices.
MovingAverage | A Simple Moving Average is an average of data calculated over a period of time. The moving average is the most popular price indicator used in technical analysis, and can be used with any price, for example, Hi, Low, Open and Close, or can be applied to other indicators.
MovingAverageConvergenceDivergence | The Moving Average Convergence/Divergence indicator compares two moving averages of prices and is used with a 9-day Exponential Moving average as a signal that indicates buying and selling moments.
NegativeVolumeIndex | The Negative Volume Index should be used with the Positive Volume index; the Negative Volume Index only changes if the volume decreases from the previous day.
OnBalanceVolume | The On Balance Volume indicator measures positive and negative volume flow.
Performance | The Performance indicator compares a current closing price or any other price with the first closing value from the first time period.
PositiveVolumeIndex | The Positive Volume Index should be used with the Negative Volume index. The Positive volume index only changes if the volume decreases from the previous day.
PriceVolumeTrend | The Price Volume Trend is a cumulative volume total that is calculated using relative changes of the closing price, and should be used with other indicators.
RateOfChange | The Rate of Change indicator compares a specified closing price with the current price.
RelativeStrengthIndex | The Relative Strength Index is a momentum oscillator that compares upward movements of the closing price with downward movements, and results in values that range from 0 to 100.
StandardDeviation | Standard Deviation is used to indicate volatility, and measures the difference between values, for example, closing price, and their moving average.
StochasticIndicator | The Stochastic Indicator helps to find trend reversal by searching in a period for when the closing prices are close to low prices in an upward trending market and when the closing prices are close to high prices in a downward trending market.
TriangularMovingAverage | A Triangular Moving Average is an average of data calculated over a period of time where the middle portion of data has more weight.
TripleExponentialMovingAverage | The Triple Exponential Moving Average is based on a triple moving average of the closing price. Its purpose is to eliminate short cycles. This indicator keeps the closing price in trends that are shorter than the specified period.
TypicalPrice | Typical Price is the average value of daily prices, and can be used as a filter for trend indicators.
VolatilityChaikins | The Volatility Chaikins indicator measures the difference between High and Low prices, and is used to indicate tops or bottoms of the market.
VolumeOscillator | The Volume Oscillator attempts to identify trends in volume by comparing two moving averages: one with a short period and another with a longer period.
WeightedClose | The Weighted Close formula calculates the average value of daily prices. The only difference between Typical Price and the Weighted Close is that the closing price has extra weight, and is considered the most important price.
WeightedMovingAverage | Weighted Moving Average is an average of data that is calculated over a period of time, where greater weight is attached to the most recent data.
WilliamsR | Williams %R is a momentum indicator, and is used to measure overbought and oversold levels.

Remarks

The FinancialFormula enumeration is used in calls to the FinancialFormula methods that are contained in the DataFormula class, and specifies the type of financial formula to be used.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


FormatNumberEventArgs Class

FormatNumberEventArgs Class |
 | See Also Members

Represents the event arguments of the localized number-formatting event.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class FormatNumberEventArgs
    Inherits EventArgs
public class FormatNumberEventArgs : EventArgs
public ref class FormatNumberEventArgs : public EventArgs
public class FormatNumberEventArgs extends EventArgs
public class FormatNumberEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.FormatNumberEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Members


FormatNumberEventArgs Members

FormatNumberEventArgs Members |
 | See Also Methods Properties

Represents the event arguments of the localized number-formatting event.

The following tables list the members exposed by the FormatNumberEventArgs type.

Public Properties

Name | Description
ElementType | Gets the chart element type.
Format | Gets or sets the format string.
LocalizedValue | Gets or sets the localized text.
SenderTag | Gets the sender object of the event.
Value | Gets the value to be formatted.
ValueType | Gets the value type.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

FormatNumberEventArgs Class


FormatNumberEventArgs Methods

FormatNumberEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

FormatNumberEventArgs Class


FormatNumberEventArgs Properties

FormatNumberEventArgs Properties |
 | See Also

Public Properties

Name | Description
ElementType | Gets the chart element type.
Format | Gets or sets the format string.
LocalizedValue | Gets or sets the localized text.
SenderTag | Gets the sender object of the event.
Value | Gets the value to be formatted.
ValueType | Gets the value type.

See Also

Reference

FormatNumberEventArgs Class


FormatNumberEventArgs.ElementType Property

FormatNumberEventArgs.ElementType Property |
 | See Also

Gets the chart element type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ElementType As ChartElementType
public ChartElementType ElementType { get; }
public:
property ChartElementType ElementType {
    ChartElementType get ();
}
/** @property */
public ChartElementType get_ElementType ()

public function get ElementType () : ChartElementType

Property Value

A ChartElementType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members


FormatNumberEventArgs.Format Property

FormatNumberEventArgs.Format Property |
 | See Also

Gets or sets the format string.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Format As String
public string Format { get; }
public:
property String^ Format {
    String^ get ();
}
/** @property */
public String get_Format ()

public function get Format () : String

Property Value

A string value that represents the format.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members


FormatNumberEventArgs.LocalizedValue Property

FormatNumberEventArgs.LocalizedValue Property |
 | See Also

Gets or sets the localized text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LocalizedValue As String
public string LocalizedValue { get; set; }
public:
property String^ LocalizedValue {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LocalizedValue ()

/** @property */
public void set_LocalizedValue (String value)

public function get LocalizedValue () : String

public function set LocalizedValue (value : String)

Property Value

A string value that represents the localized text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members


FormatNumberEventArgs.SenderTag Property

FormatNumberEventArgs.SenderTag Property |
 | See Also

Gets the sender object of the event.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SenderTag As Object
public Object SenderTag { get; }
public:
property Object^ SenderTag {
    Object^ get ();
}
/** @property */
public Object get_SenderTag ()

public function get SenderTag () : Object

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members


FormatNumberEventArgs.Value Property

FormatNumberEventArgs.Value Property |
 | See Also

Gets the value to be formatted.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Value As Double
public double Value { get; }
public:
property double Value {
    double get ();
}
/** @property */
public double get_Value ()

public function get Value () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members


FormatNumberEventArgs.ValueType Property

FormatNumberEventArgs.ValueType Property |
 | See Also

Gets the value type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ValueType As ChartValueType
public ChartValueType ValueType { get; }
public:
property ChartValueType ValueType {
    ChartValueType get ();
}
/** @property */
public ChartValueType get_ValueType ()

public function get ValueType () : ChartValueType

Property Value

A ChartValueType enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FormatNumberEventArgs Class
FormatNumberEventArgs Members


FTestResult Class

FTestResult Class |
 | See Also Members

Stores results of the FTest statistical methods.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class FTestResult
public class FTestResult
public ref class FTestResult
public class FTestResult
public class FTestResult

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.FTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Members


FTestResult Members

FTestResult Members |
 | See Also Constructors Methods Properties

Stores results of the FTest statistical methods.

The following tables list the members exposed by the FTestResult type.

Public Constructors

Name | Description
FTestResult | Initializes a new instance of the FTestResult class.
Top

Public Properties

Name | Description
FCriticalValueOneTail | Gets the Critical F one tail.
FirstSeriesMean | Gets the first series mean.
FirstSeriesVariance | Gets the first series variance.
FValue | Gets the F value.
ProbabilityFOneTail | Gets the Probability F one tail.
SecondSeriesMean | Gets the second series mean.
SecondSeriesVariance | Gets the second series variance.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

FTestResult Class


FTestResult Constructor

FTestResult Constructor |
 | See Also

Initializes a new instance of the FTestResult class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public FTestResult ()
public:
FTestResult ()
public FTestResult ()
public function FTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult Methods

FTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

FTestResult Class


FTestResult Properties

FTestResult Properties |
 | See Also

Public Properties

Name | Description
FCriticalValueOneTail | Gets the Critical F one tail.
FirstSeriesMean | Gets the first series mean.
FirstSeriesVariance | Gets the first series variance.
FValue | Gets the F value.
ProbabilityFOneTail | Gets the Probability F one tail.
SecondSeriesMean | Gets the second series mean.
SecondSeriesVariance | Gets the second series variance.

See Also

Reference

FTestResult Class


FTestResult.FCriticalValueOneTail Property

FTestResult.FCriticalValueOneTail Property |
 | See Also

Gets the Critical F one tail.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FCriticalValueOneTail As Double
public double FCriticalValueOneTail { get; }
public:
property double FCriticalValueOneTail {
    double get ();
}
/** @property */
public double get_FCriticalValueOneTail ()

public function get FCriticalValueOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult.FirstSeriesMean Property

FTestResult.FirstSeriesMean Property |
 | See Also

Gets the first series mean.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesMean As Double
public double FirstSeriesMean { get; }
public:
property double FirstSeriesMean {
    double get ();
}
/** @property */
public double get_FirstSeriesMean ()

public function get FirstSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult.FirstSeriesVariance Property

FTestResult.FirstSeriesVariance Property |
 | See Also

Gets the first series variance.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesVariance As Double
public double FirstSeriesVariance { get; }
public:
property double FirstSeriesVariance {
    double get ();
}
/** @property */
public double get_FirstSeriesVariance ()

public function get FirstSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult.FValue Property

FTestResult.FValue Property |
 | See Also

Gets the F value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FValue As Double
public double FValue { get; }
public:
property double FValue {
    double get ();
}
/** @property */
public double get_FValue ()

public function get FValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult.ProbabilityFOneTail Property

FTestResult.ProbabilityFOneTail Property |
 | See Also

Gets the Probability F one tail.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityFOneTail As Double
public double ProbabilityFOneTail { get; }
public:
property double ProbabilityFOneTail {
    double get ();
}
/** @property */
public double get_ProbabilityFOneTail ()

public function get ProbabilityFOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult.SecondSeriesMean Property

FTestResult.SecondSeriesMean Property |
 | See Also

Gets the second series mean.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesMean As Double
public double SecondSeriesMean { get; }
public:
property double SecondSeriesMean {
    double get ();
}
/** @property */
public double get_SecondSeriesMean ()

public function get SecondSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


FTestResult.SecondSeriesVariance Property

FTestResult.SecondSeriesVariance Property |
 | See Also

Gets the second series variance.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesVariance As Double
public double SecondSeriesVariance { get; }
public:
property double SecondSeriesVariance {
    double get ();
}
/** @property */
public double get_SecondSeriesVariance ()

public function get SecondSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

FTestResult Class
FTestResult Members


GradientStyle Enumeration

GradientStyle Enumeration |
 | See Also

Specifies a gradient style to be used for a chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration GradientStyle
public enum GradientStyle
public enum class GradientStyle
public enum GradientStyle
public enum GradientStyle

Members

Member name | Description
Center | Gradient is applied from the center outwards.
DiagonalLeft | Gradient is applied diagonally from left to right.
DiagonalRight | Gradient is applied diagonally from right to left.
HorizontalCenter | Gradient is applied horizontally from the center outwards.
LeftRight | Gradient is applied from left to right.
None | No gradient is applied.
TopBottom | Gradient is applied from top to bottom.
VerticalCenter | Gradient is applied vertically from the center outwards.

Remarks

The GradientStyle enumeration represents a gradient style, and is used with the BackGradientStyle property of the Chart.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Grid Class

Grid Class |
 | See Also Members

Provides methods and properties that manage the major and minor grids of Axis objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Grid
public class Grid
public ref class Grid
public class Grid
public class Grid

Remarks

This class provides the functionality for the grids on the chart, and is exposed using the MajorGrid and MinorGrid properties of each Axis object.

Major grid lines by default do not have their Interval, IntervalOffset, IntervalType, and IntervalOffsetType properties set. When these properties for major grid lines are not set, the Chart control determines the appropriate values for grid lines automatically.

The axis and its minor grid lines by default have their Interval, IntervalOffset, IntervalType, and IntervalOffsetType properties set to Auto (0). If axis labels or minor grid lines are enabled and these properties are not modified, the Chart control automatically determines how often to draw the minor grid lines.

Axis grids:

  • Can be enabled or disabled.

  • Have a starting point that determines where they are first drawn.

  • Display lines that can be set for style, width and color.

  • Can have either automatic intervals, or intervals that are set manually.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.Grid
System.Windows.Forms.DataVisualization.Charting.TickMark

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Members


Grid Members

Grid Members |
 | See Also Constructors Methods Properties

Provides methods and properties that manage the major and minor grids of Axis objects.

The following tables list the members exposed by the Grid type.

Public Constructors

Name | Description
Grid | Initializes a new instance of the Grid class.
Top

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled.
Interval | Gets or sets the interval between major or minor grid lines.
IntervalOffset | Gets or sets the offset of grid lines.
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines.
IntervalType | Gets or sets the interval type for major or minor grid lines.
LineColor | Gets or sets the line color of a grid.
LineDashStyle | Gets or sets the line style of a grid.
LineWidth | Gets or sets the line width of major and minor grid lines.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Grid Class


Grid Constructor

Grid Constructor |
 | See Also

Initializes a new instance of the Grid class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Grid ()
public:
Grid ()
public Grid ()
public function Grid ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid Methods

Grid Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Grid Class


Grid Properties

Grid Properties |
 | See Also

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled.
Interval | Gets or sets the interval between major or minor grid lines.
IntervalOffset | Gets or sets the offset of grid lines.
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines.
IntervalType | Gets or sets the interval type for major or minor grid lines.
LineColor | Gets or sets the line color of a grid.
LineDashStyle | Gets or sets the line style of a grid.
LineWidth | Gets or sets the line width of major and minor grid lines.

See Also

Reference

Grid Class


Grid.Enabled Property

Grid.Enabled Property |
 | See Also

Gets or sets a flag that determines whether major or minor grid lines are enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if enabled, false if disabled. The default is true for major grid objects and false for minor grid objects.

Remarks

Major and minor grids are visible when enabled, and not visible when disabled.

Tick marks will not be displayed if disabled.

You can disable tick marks by setting the TickMarkStyle property to None.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.Interval Property

Grid.Interval Property |
 | See Also

Gets or sets the interval between major or minor grid lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value that represents the interval between grid lines. By default, the value is not set (NaN) for major grid lines. For minor grid lines, the default value is zero (0).

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly using NotSet at design time, or by assigning a value of NaN at run time—the actual value of this property is determined by the Interval property of the Axis object to which the chart element, such as a grid line or tick mark, belongs.

The interval of minor tick marks and grid lines is never affected by the Interval property value.

The interval is measured in axis units, and determines how often an applicable chart element is drawn. For example, suppose a column chart has an X axis step of 1 (that is, 1, 2, 3, 4, and so forth); if you set the Interval property for the X axis to 2, an axis label will be displayed for every other column.

The same holds true for all applicable chart elements. In other words, if in the previous example strip lines were being used, with an IntervalOffset of 0.5, and their Interval property was 2, a strip line would be displayed at 0.5, 2.5, 4.5, and so on.

If you set a chart element Interval property to zero, an interval will be automatically determined by the Chart control.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.IntervalOffset Property

Grid.IntervalOffset Property |
 | See Also

Gets or sets the offset of grid lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the interval offset.

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly specifying "Not Set"at design time, or by assigning it a value of NotSet at run time—the actual value of this property is determined by the IntervalOffset property of the Axis object that the chart element, such as a grid line or a tick mark, belongs to.

The interval offset of minor tick marks and grid lines is never affected by the value of the IntervalOffset property of the Axis object.

The IntervalOffsetType property setting defines the units of measurement of the offset.

The IntervalOffset can be a negative value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.IntervalOffsetType Property

Grid.IntervalOffsetType Property |
 | See Also

Gets or sets the interval offset type of major and minor grid lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. By default it is not set for major grid lines. The default value for minor grid lines is Auto.

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly specifying "Not Set" at design time, or by assigning it a value of NotSet at run time—the actual value of this property is determined by the IntervalOffsetType property of the Axis object that the chart element—a grid line or tick mark, for example—belongs to.

The interval offset type of minor tick marks and grid lines is never affected by the IntervalOffsetType property value.

If this interval offset type is set to Auto, the IntervalType property will be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.IntervalType Property

Grid.IntervalType Property |
 | See Also

Gets or sets the interval type for major or minor grid lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. By default it is not set for axis labels, major tick marks and major grid lines, by using the NotSet enumeration value. The default value for minor tick marks and grid lines is Auto.

Remarks

By default this property is not set for axis labels, major tick marks and major grid lines. If it is not set—either by default, by explicitly using "Not Set" at design time, or by assigning it a value of NotSet at run time— the actual value of this property is determined by the IntervalOffsetType property of the Axis object that the chart element—a grid line or tick mark, for example—belongs to.

The interval type of minor tick marks and grid lines is never affected by the value of the IntervalType property.

Interval types can be set to Auto; the type of interval then depends on either the X-values or Y-values of the plotted DataPoint objects, depending on which axis the applicable elements belong to.

Setting the IntervalType property for a value axis will only have an effect if the values of the data points are DateTime or double values. Also, the XValueType or YValueType property of the plotted Series must be set to Auto or DateTime.

Setting the IntervalType property for a categorical axis will only have an effect if the XValueType property (or YValueType property, depending on the axis in question) of the plotted Series object is either Auto or DateTime.

Note:
Sunday is considered the first day of the week.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.LineColor Property

Grid.LineColor Property |
 | See Also

Gets or sets the line color of a grid.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineColor As Color
public Color LineColor { get; set; }
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public function get LineColor () : Color

public function set LineColor (value : Color)

Property Value

A Color object. The default value is Black.

Remarks

The LineColor property is used to specify the color of major and minor tick marks or grids.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.LineDashStyle Property

Grid.LineDashStyle Property |
 | See Also

Gets or sets the line style of a grid.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineDashStyle As ChartDashStyle
public ChartDashStyle LineDashStyle { get; set; }
public:
property ChartDashStyle LineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public function get LineDashStyle () : ChartDashStyle

public function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value. The default is Solid.

Remarks

The LineDashStyle property can be used to specify the line style of major and minor tick marks or grids. The line can be solid, dotted, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


Grid.LineWidth Property

Grid.LineWidth Property |
 | See Also

Gets or sets the line width of major and minor grid lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LineWidth As Integer
public int LineWidth { get; set; }
public:
property int LineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public function get LineWidth () : int

public function set LineWidth (value : int)

Property Value

An integer that represents the line width in pixels. The default value is one (1).

Remarks

The LineWidth property can be used to specify the line width, in pixels, of major and minor tick marks or grids.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Grid Class
Grid Members


GridTickTypes Enumeration

GridTickTypes Enumeration |
 | See Also

Specifies the options for displaying a grid line or a tick mark for a custom label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration GridTickTypes
public enum GridTickTypes
public enum class GridTickTypes
public enum GridTickTypes
public enum GridTickTypes

Members

Member name | Description
All | A tick mark and a grid line are shown.
Gridline | A grid line is shown.
None | No tick mark or grid line is shown.
TickMark | A tick mark is shown.

Remarks

The GridTickTypes enumeration is used in conjunction with the GridTicks property to display a grid line and/or a tick mark for a custom label.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


HitTestResult Class

HitTestResult Class |
 | See Also Members

Represents the results of a hit test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class HitTestResult
public class HitTestResult
public ref class HitTestResult
public class HitTestResult
public class HitTestResult

Remarks

The HitTestResult class represents the results of a hit test, and is exposed as the return object from a HitTest method call.

A hit test checks a specified point in the chart to determine if a chart element is located at that point. If a chart element is detected, the HitTestResult class is used to obtain information about that chart element.

If a chart element is found, the Object property returns a reference to the chart element; the only exception to this being DataPoint objects, in which case the return value of this property is null.

If a data point is located, you can use the PointIndex property to get the index of that data point; that is, the zero-based index of the point in the DataPointCollection. Use the Series property to get the associated Series object for that data point.

The ChartArea and Axis properties are used to get the associated chart area and axis of the chart element—if any—returned by the hit test. Note that these properties may be null if the returned chart element does not have an associated chart area or axis.

Use the ChartElementType property to determine the type of the chart element returned by a hit test.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.HitTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Members


HitTestResult Members

HitTestResult Members |
 | See Also Constructors Methods Properties

Represents the results of a hit test.

The following tables list the members exposed by the HitTestResult type.

Public Constructors

Name | Description
HitTestResult | Initializes a new instance of the HitTestResult class.
Top

Public Properties

Name | Description
Axis | Gets or sets the Axis object that may be associated with a chart element returned by a hit test. The presence of an associated Axis object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartArea | Gets or sets the ChartArea object that may be associated with a chart element returned by a hit test. The presence of a ChartArea object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartElementType | Gets or sets the type of chart element, if any, returned by a hit test.
Object | Gets or sets the object, if any, returned by a hit test.
PointIndex | Gets or sets the index of a data point, if any, returned by a hit test.
Series | Gets or sets the associated series of a data point, if any, returned by a hit test.
SubObject | Gets the sub-object, if any, returned by a hit test.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

HitTestResult Class


HitTestResult Constructor

HitTestResult Constructor |
 | See Also

Initializes a new instance of the HitTestResult class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public HitTestResult ()
public:
HitTestResult ()
public HitTestResult ()
public function HitTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult Methods

HitTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

HitTestResult Class


HitTestResult Properties

HitTestResult Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets or sets the Axis object that may be associated with a chart element returned by a hit test. The presence of an associated Axis object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartArea | Gets or sets the ChartArea object that may be associated with a chart element returned by a hit test. The presence of a ChartArea object depends on whether a chart element was detected at the given location, and the type of chart element returned.
ChartElementType | Gets or sets the type of chart element, if any, returned by a hit test.
Object | Gets or sets the object, if any, returned by a hit test.
PointIndex | Gets or sets the index of a data point, if any, returned by a hit test.
Series | Gets or sets the associated series of a data point, if any, returned by a hit test.
SubObject | Gets the sub-object, if any, returned by a hit test.

See Also

Reference

HitTestResult Class


HitTestResult.Axis Property

HitTestResult.Axis Property |
 | See Also

Gets or sets the Axis object that may be associated with a chart element returned by a hit test. The presence of an associated Axis object depends on whether a chart element was detected at the given location, and the type of chart element returned.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Axis As Axis
public Axis Axis { get; set; }
public:
property Axis^ Axis {
    Axis^ get ();
    void set (Axis^ value);
}
/** @property */
public Axis get_Axis ()

/** @property */
public void set_Axis (Axis value)

public function get Axis () : Axis

public function set Axis (value : Axis)

Property Value

An Axis object, otherwise null. The default value is null.

Remarks

If the chart object returned by the hit test is an object that is associated with an axis—for example, a scrollbar element, tick mark, grid line or strip line—the Axis property will reference the Axis object with which the returned chart object is associated. Otherwise this property will be null.

Note that the HitTest method can be called explicitly, in which case a chart element may or may not be at the specified location.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult.ChartArea Property

HitTestResult.ChartArea Property |
 | See Also

Gets or sets the ChartArea object that may be associated with a chart element returned by a hit test. The presence of a ChartArea object depends on whether a chart element was detected at the given location, and the type of chart element returned.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ChartArea As ChartArea
public ChartArea ChartArea { get; set; }
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
    void set (ChartArea^ value);
}
/** @property */
public ChartArea get_ChartArea ()

/** @property */
public void set_ChartArea (ChartArea value)

public function get ChartArea () : ChartArea

public function set ChartArea (value : ChartArea)

Property Value

A ChartArea object, otherwise null. The default value is null.

Remarks

If a Chart object is returned by the hit test, the ChartArea property will reference the ChartArea object that is associated with the returned chart element.

If no chart element is returned by the hit test, the value of this property will be null.

Note The HitTest method can be called explicitly, in which case a chart element may or may not be at the specified location.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult.ChartElementType Property

HitTestResult.ChartElementType Property |
 | See Also

Gets or sets the type of chart element, if any, returned by a hit test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ChartElementType As ChartElementType
public ChartElementType ChartElementType { get; set; }
public:
property ChartElementType ChartElementType {
    ChartElementType get ();
    void set (ChartElementType value);
}
/** @property */
public ChartElementType get_ChartElementType ()

/** @property */
public void set_ChartElementType (ChartElementType value)

public function get ChartElementType () : ChartElementType

public function set ChartElementType (value : ChartElementType)

Property Value

A ChartElementType enumeration value that indicates the type of chart element returned by a hit test. Defaults to Nothing.

Remarks

Use this property to determine the type of chart element, if any, returned by a hit test.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult.Object Property

HitTestResult.Object Property |
 | See Also

Gets or sets the object, if any, returned by a hit test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Object As Object
public Object Object { get; set; }
public:
property Object^ Object {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_Object ()

/** @property */
public void set_Object (Object value)

public function get Object () : Object

public function set Object (value : Object)

Property Value

An object of type Object, otherwise null.

Remarks

If a chart element is located at the point that is checked by the hit test, this property will reference that chart element, otherwise the value of this property will be null.

Note:
If a data point is returned by the hit test, this property will still return a null. To obtain information about the data point, use the PointIndex and Series properties instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult.PointIndex Property

HitTestResult.PointIndex Property |
 | See Also

Gets or sets the index of a data point, if any, returned by a hit test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property PointIndex As Integer
public int PointIndex { get; set; }
public:
property int PointIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_PointIndex ()

/** @property */
public void set_PointIndex (int value)

public function get PointIndex () : int

public function set PointIndex (value : int)

Property Value

An integer value that represents the index of a data point returned by a hit test. The default value is negative one (-1).

Remarks

If a data point is at the location that is checked by a hit test, the PointIndex property will return the zero-based index of that data point, otherwise it will return a negative one (-1).

All data points are stored in a DataPointCollection, which is exposed as the Points collection property of a Series object; the index of the DataPointCollection is zero-based.

Use the Series property to determine the series to which the data point belongs.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult.Series Property

HitTestResult.Series Property |
 | See Also

Gets or sets the associated series of a data point, if any, returned by a hit test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Series As Series
public Series Series { get; set; }
public:
property Series^ Series {
    Series^ get ();
    void set (Series^ value);
}
/** @property */
public Series get_Series ()

/** @property */
public void set_Series (Series value)

public function get Series () : Series

public function set Series (value : Series)

Property Value

The Series that a data point returned by a hit test belongs to. The default value is null.

Remarks

If a data point is at the location checked by a hit test, this property will reference the Series object that the data point belongs to. If no data point is returned by the hit test, the value of this property will be null.

To determine the index of a returned data point, use the PointIndex property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HitTestResult.SubObject Property

HitTestResult.SubObject Property |
 | See Also

Gets the sub-object, if any, returned by a hit test.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SubObject As Object
public Object SubObject { get; set; }
public:
property Object^ SubObject {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_SubObject ()

/** @property */
public void set_SubObject (Object value)

public function get SubObject () : Object

public function set SubObject (value : Object)

Property Value

A sub-object of type Object, otherwise null.

Remarks

An example of a sub-object is an Axis object that is displayed inside a ChartArea object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HitTestResult Class
HitTestResult Members


HorizontalLineAnnotation Class

HorizontalLineAnnotation Class |
 | See Also Members

Represents a horizontal line annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class HorizontalLineAnnotation
    Inherits LineAnnotation
public class HorizontalLineAnnotation : LineAnnotation
public ref class HorizontalLineAnnotation : public LineAnnotation
public class HorizontalLineAnnotation extends LineAnnotation
public class HorizontalLineAnnotation extends LineAnnotation

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.LineAnnotation
System.Windows.Forms.DataVisualization.Charting.HorizontalLineAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HorizontalLineAnnotation Members


HorizontalLineAnnotation Members

HorizontalLineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a horizontal line annotation.

The following tables list the members exposed by the HorizontalLineAnnotation type.

Public Constructors

Name | Description
HorizontalLineAnnotation | Initializes a new instance of the HorizontalLineAnnotation class.
Top

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation)
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

HorizontalLineAnnotation Class


HorizontalLineAnnotation Constructor

HorizontalLineAnnotation Constructor |
 | See Also

Initializes a new instance of the HorizontalLineAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public HorizontalLineAnnotation ()
public:
HorizontalLineAnnotation ()
public HorizontalLineAnnotation ()
public function HorizontalLineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HorizontalLineAnnotation Class
HorizontalLineAnnotation Members


HorizontalLineAnnotation Methods

HorizontalLineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

HorizontalLineAnnotation Class


HorizontalLineAnnotation Properties

HorizontalLineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation )
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

HorizontalLineAnnotation Class


HorizontalLineAnnotation.AnnotationType Property

HorizontalLineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type name. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type, for example, LineAnnotation, RectangleAnnotation, EllipseAnnotation, and so forth.

This property is for internal use.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

HorizontalLineAnnotation Class
HorizontalLineAnnotation Members


IDataPointFilter Interface

IDataPointFilter Interface |
 | See Also Members

Exposes the FilterDataPoint method, which allows Series data to be custom filtered.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Interface IDataPointFilter
public interface IDataPointFilter
public interface class IDataPointFilter
public interface IDataPointFilter
public interface IDataPointFilter

Remarks

The IDataPointFilter interface exposes the FilterDataPoint method, which takes a specific data point within a series and returns a Boolean value that determines whether that data point will be filtered.

To perform custom filtering:

  • Derive a new or existing class from this interface.

  • Override the FilterDataPoint method to provide the custom filtering logic.

  • To initiate the filtering operation, call one of the Filter methods in the DataManipulator class that takes an IDataPointFilter object as its first parameter.

For sample source code, see the FilterDataPoint method.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IDataPointFilter Members


IDataPointFilter Members

IDataPointFilter Members |
 | See Also Methods

Exposes the FilterDataPoint method, which allows Series data to be custom filtered.

The following tables list the members exposed by the IDataPointFilter type.

Public Methods

Name | Description
FilterDataPoint | Determines whether a particular data point in the series will be filtered.
Top

See Also

Reference

IDataPointFilter Interface


IDataPointFilter Methods

IDataPointFilter Methods |
 | See Also

Public Methods

Name | Description
FilterDataPoint | Determines whether a particular data point in the series will be filtered.

See Also

Reference

IDataPointFilter Interface


IDataPointFilter.FilterDataPoint Method

IDataPointFilter.FilterDataPoint Method |
 | See Also

Determines whether a particular data point in the series will be filtered.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Function FilterDataPoint ( _
    point As DataPoint, _
    series As Series, _
    pointIndex As Integer _
) As Boolean
bool FilterDataPoint (
    DataPoint point,
    Series series,
    int pointIndex
)
bool FilterDataPoint (
    DataPoint^ point,
    Series^ series,
    int pointIndex
)
boolean FilterDataPoint (
    DataPoint point,
    Series series,
    int pointIndex
)
function FilterDataPoint (
    point : DataPoint,
    series : Series,
    pointIndex : int
) : boolean

Parameters

point

The DataPoint object to be filtered.

series

The Series object that the data point belongs to.

pointIndex

The index of the data point, which determines its position in the series.

Return Value

True if the data point is removed, otherwise false.

Remarks

This method should be called for each data point in a series, and returns a Boolean value indicating whether a data point should be filtered.

To provide custom filtering, derive a new or existing class from the IDataPointFilter interface and then implement this method. Provide custom criteria matching logic, then return true or false to mark the data points to be filtered. After this method has been implemented, use one of the Filter method definitions in the DataManipulator class that takes an IDataPointFilter object as a parameter to perform the filtering.

Filtered points, by default, are removed from a series. They can also be displayed as empty points by setting the value of the FilterSetEmptyPoints property to true.

Filtered points can also be marked as filtered if they do not match filtering criteria, as determined by the FilterMatchedPoints value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

IDataPointFilter Interface
IDataPointFilter Members


ImageAnnotation Class

ImageAnnotation Class |
 | See Also Members

Represents an image annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ImageAnnotation
    Inherits Annotation
public class ImageAnnotation : Annotation
public ref class ImageAnnotation : public Annotation
public class ImageAnnotation extends Annotation
public class ImageAnnotation extends Annotation

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.ImageAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Members


ImageAnnotation Members

ImageAnnotation Members |
 | See Also Constructors Methods Properties

Represents an image annotation.

The following tables list the members exposed by the ImageAnnotation type.

Public Constructors

Name | Description
ImageAnnotation | Initializes a new instance of the ImageAnnotation class.
Top

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the alignment of the annotation image.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the image annotation type.
BackGradientStyle | Overridden. This property is not applicable to the image annotation type.
BackHatchStyle | Overridden. This property is not applicable to the image annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the image annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Overridden. This property is not applicable to the image annotation type.
ForeColor | Overridden. This property is not applicable to the image annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
Image | Gets or sets the name of the annotation image.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the image is drawn.
ImageWrapMode | Gets or sets the drawing mode of the image.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. This property is not applicable to the image annotation type.
LineDashStyle | Overridden. This property is not applicable to the image annotation type.
LineWidth | Overridden. This property is not applicable to the image annotation type.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. Gets or sets the text style of the annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ImageAnnotation Class


ImageAnnotation Constructor

ImageAnnotation Constructor |
 | See Also

Initializes a new instance of the ImageAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public ImageAnnotation ()
public:
ImageAnnotation ()
public ImageAnnotation ()
public function ImageAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation Methods

ImageAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ImageAnnotation Class


ImageAnnotation Properties

ImageAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. Gets or sets the alignment of the annotation image.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type name. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the image annotation type.
BackGradientStyle | Overridden. This property is not applicable to the image annotation type.
BackHatchStyle | Overridden. This property is not applicable to the image annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the image annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Overridden. This property is not applicable to the image annotation type.
ForeColor | Overridden. This property is not applicable to the image annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
Image | Gets or sets the name of the annotation image.
ImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the image is drawn.
ImageWrapMode | Gets or sets the drawing mode of the image.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. This property is not applicable to the image annotation type.
LineDashStyle | Overridden. This property is not applicable to the image annotation type.
LineWidth | Overridden. This property is not applicable to the image annotation type.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. Gets or sets the text style of the annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

ImageAnnotation Class


ImageAnnotation.Alignment Property

ImageAnnotation.Alignment Property |
 | See Also

Gets or sets the alignment of the annotation image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Alignment As ContentAlignment
public override ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the annotation image.

Remarks

This property is used to align a non-scaled image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.AnnotationType Property

ImageAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type name. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

This abstract property is used to get the name of each annotation type such as LineAnnotation, RectangleAnnotation, EllipseAnnotation, and so forth.

This property is for internal use.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.BackColor Property

ImageAnnotation.BackColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.BackGradientStyle Property

ImageAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.BackHatchStyle Property

ImageAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.BackSecondaryColor Property

ImageAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.Font Property

ImageAnnotation.Font Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.ForeColor Property

ImageAnnotation.ForeColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.Image Property

ImageAnnotation.Image Property |
 | See Also

Gets or sets the name of the annotation image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Image As String
public virtual string Image { get; set; }
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the name of the annotation image.

Remarks

The image name can be a file name, a URL or a named image—that is, its name component—from the NamedImagesCollection class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.ImageTransparentColor Property

ImageAnnotation.ImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ImageTransparentColor As Color
public Color ImageTransparentColor { get; set; }
public:
property Color ImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ImageTransparentColor ()

/** @property */
public void set_ImageTransparentColor (Color value)

public function get ImageTransparentColor () : Color

public function set ImageTransparentColor (value : Color)

Property Value

A Color value that will be replaced with a transparent color when he image is drawn.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.ImageWrapMode Property

ImageAnnotation.ImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of the image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode ImageWrapMode { get; set; }
public:
property ChartImageWrapMode ImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_ImageWrapMode ()

/** @property */
public void set_ImageWrapMode (ChartImageWrapMode value)

public function get ImageWrapMode () : ChartImageWrapMode

public function set ImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value that defines the drawing mode of the image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.LineColor Property

ImageAnnotation.LineColor Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(false)]
public override Color LineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.LineDashStyle Property

ImageAnnotation.LineDashStyle Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.LineWidth Property

ImageAnnotation.LineWidth Property |
 | See Also

This property is not applicable to the image annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(false)]
public override int LineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value.

Remarks

This property is not applicable to the image annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


ImageAnnotation.TextStyle Property

ImageAnnotation.TextStyle Property |
 | See Also

Gets or sets the text style of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value that represents the style used to draw the annotation text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ImageAnnotation Class
ImageAnnotation Members


IntervalAutoMode Enumeration

IntervalAutoMode Enumeration |
 | See Also

Specifies the automatic axis interval mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration IntervalAutoMode
public enum IntervalAutoMode
public enum class IntervalAutoMode
public enum IntervalAutoMode
public enum IntervalAutoMode

Members

Member name | Description
FixedCount | A fixed number of intervals are always created on the axis.
VariableCount | The number of axis intervals depends on the axis length.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


IntervalType Enumeration

IntervalType Enumeration |
 | See Also

Specifies an interval type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration IntervalType
public enum IntervalType
public enum class IntervalType
public enum IntervalType
public enum IntervalType

Members

Member name | Description
Days | An interval of days.
Hours | An interval of hours.
Milliseconds | An interval of milliseconds.
Minutes | An interval of minutes.
Months | An interval of months.
Number | A numerical interval.
Seconds | An interval of seconds.
Weeks | An interval of weeks.
Years | An interval of years.

Remarks

The IntervalType enumeration represents the type of interval and interval offset used for some definitions of the Group and InsertEmptyPoints methods of the DataManipulator class.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LabelAlignmentStyles Enumeration

LabelAlignmentStyles Enumeration |
 | See Also

Specifies a label alignment when SmartLabelStyle is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LabelAlignmentStyles
public enum LabelAlignmentStyles
public enum class LabelAlignmentStyles
public enum LabelAlignmentStyles
public enum LabelAlignmentStyles

Members

Member name | Description
Bottom | Label is aligned to the bottom of the data point.
BottomLeft | Label is aligned to the bottom-left of the data point.
BottomRight | Label is aligned to the bottom-right of the data point.
Center | Label is aligned to the center of the data point.
Left | Label is aligned to the left of the data point.
Right | Label is aligned to the right of the data point.
Top | Label is aligned to the top of the data point.
TopLeft | Label is aligned to the top-left corner of the data point.
TopRight | Label is aligned to the top-right corner of the data point.

Remarks

The LabelAlignmentStyles enumeration represents the alignment of a label; it is set by the MovingDirection property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LabelAutoFitStyles Enumeration

LabelAutoFitStyles Enumeration |
 | See Also

Specifies style changes that can automatically be made to a label when the LabelAutoFitStyle property is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LabelAutoFitStyles
public enum LabelAutoFitStyles
public enum class LabelAutoFitStyles
public enum LabelAutoFitStyles
public enum LabelAutoFitStyles

Members

Member name | Description
DecreaseFont | Label font can be decreased.
IncreaseFont | Label font can be increased.
LabelsAngleStep30 | Labels can be angled in 30 degree steps: 0, 30, 60 and 90.
LabelsAngleStep45 | Labels can be angled in 45 degree steps: 0, 45, and 90.
LabelsAngleStep90 | Labels can be angled in 90 degree steps: 0 and 90.
None | No label changes are allowed.
StaggeredLabels | Labels can be staggered.
WordWrap | Labels can be word wrapped.

Remarks

The LabelAutoFitStyles enumeration represents the changes to the font or orientation of labels that can be automatically made to enable labels to fit along the axis.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LabelCalloutStyle Enumeration

LabelCalloutStyle Enumeration |
 | See Also

Specifies the type of leader line that should be drawn from the point to the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LabelCalloutStyle
public enum LabelCalloutStyle
public enum class LabelCalloutStyle
public enum LabelCalloutStyle
public enum LabelCalloutStyle

Members

Member name | Description
Box | Line will terminate at a box drawn around the label text.
None | Line will terminate at the label without any added style.
Underlined | Line will terminate with a horizontal line beneath the label text.

Remarks

The LabelCalloutStyle enumeration represents the type of leader line that should be drawn from the point to the label. It is used in conjunction with the CalloutStyle property of the SmartLabelStyle object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LabelMarkStyle Enumeration

LabelMarkStyle Enumeration |
 | See Also

Specifies a mark for custom labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LabelMarkStyle
public enum LabelMarkStyle
public enum class LabelMarkStyle
public enum LabelMarkStyle
public enum LabelMarkStyle

Members

Member name | Description
Box | Draws a box around the label. The box always starts at the axis position.
LineSideMark | Custom labels use line and side marks.
None | No label marks are used.
SideMark | Custom labels use side marks.

Remarks

The LabelMarkStyle enumeration represents mark(s) for custom labels that are displayed along the second axis label row. This row can only be generated from custom labels. This enumeration is used in conjunction with the LabelMark property of the CustomLabel class.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LabelOutsidePlotAreaStyle Enumeration

LabelOutsidePlotAreaStyle Enumeration |
 | See Also

Specifies the degree to which a label can be drawn outside a plotting area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LabelOutsidePlotAreaStyle
public enum LabelOutsidePlotAreaStyle
public enum class LabelOutsidePlotAreaStyle
public enum LabelOutsidePlotAreaStyle
public enum LabelOutsidePlotAreaStyle

Members

Member name | Description
No | Labels cannot de drawn outside the plotting area.
Partial | Labels can be drawn partially outside the plotting area.
Yes | Labels can be drawn outside the plotting area.

Remarks

The LabelOutsidePlotAreaStyle enumeration represents the degree to which a label is allowed to leave a plotting area. It is used in conjunction with the AllowOutsidePlotArea property of the SmartLabelStyle object.

If you specify the Partial value, no more than 50% of the label can be drawn outside the plotting area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LabelStyle Class

LabelStyle Class |
 | See Also Members

Provides properties that define the visual appearance of the axis labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LabelStyle
    Inherits ChartElement
public class LabelStyle : ChartElement
public ref class LabelStyle : public ChartElement
public class LabelStyle extends ChartElement
public class LabelStyle extends ChartElement

Remarks

Members of this class are also used to calculate the intervals and positions of the axis labels, and to draw them.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.LabelStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Members


LabelStyle Members

LabelStyle Members |
 | See Also Constructors Methods Properties

Provides properties that define the visual appearance of the axis labels.

The following tables list the members exposed by the LabelStyle type.

Public Constructors

Name | Description
LabelStyle | Initializes a new instance of the LabelStyle class.
Top

Public Properties

Name | Description
Angle | Gets or sets a value that represents the angle at which the font is drawn.
Enabled | Gets or sets a flag that indicates whether the label is enabled.
Font | Gets or sets the font of the label.
ForeColor | Gets or sets the color of the label.
Format | Gets or sets the formatting string for the label text.
Interval | Gets or sets the size of the label interval.
IntervalOffset | Gets or sets the offset of the label interval.
IntervalOffsetType | Gets or sets the unit of measurement of the label interval offset.
IntervalType | Gets or sets the unit of measurement for the size of a label interval.
IsEndLabelVisible | Gets or sets a flag that determines whether the labels are shown at axis ends.
IsStaggered | Gets or sets a flag that determines whether the labels are shown with an offset.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TruncatedLabels | Gets or sets a flag that determines whether the labels can be truncated.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LabelStyle Class


LabelStyle Constructor

LabelStyle Constructor |
 | See Also

Initializes a new instance of the LabelStyle class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public LabelStyle ()
public:
LabelStyle ()
public LabelStyle ()
public function LabelStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle Methods

LabelStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LabelStyle Class


LabelStyle.Dispose Method

LabelStyle.Dispose Method |
 | See Also

Overload List

Name | Description
LabelStyle.Dispose () | (inherited from Dispose )
LabelStyle.Dispose (Boolean) |

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.Dispose Method (Boolean)

LabelStyle.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle Properties

LabelStyle Properties |
 | See Also

Public Properties

Name | Description
Angle | Gets or sets a value that represents the angle at which the font is drawn.
Enabled | Gets or sets a flag that indicates whether the label is enabled.
Font | Gets or sets the font of the label.
ForeColor | Gets or sets the color of the label.
Format | Gets or sets the formatting string for the label text.
Interval | Gets or sets the size of the label interval.
IntervalOffset | Gets or sets the offset of the label interval.
IntervalOffsetType | Gets or sets the unit of measurement of the label interval offset.
IntervalType | Gets or sets the unit of measurement for the size of a label interval.
IsEndLabelVisible | Gets or sets a flag that determines whether the labels are shown at axis ends.
IsStaggered | Gets or sets a flag that determines whether the labels are shown with an offset.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TruncatedLabels | Gets or sets a flag that determines whether the labels can be truncated.

See Also

Reference

LabelStyle Class


LabelStyle.Angle Property

LabelStyle.Angle Property |
 | See Also

Gets or sets a value that represents the angle at which the font is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Angle As Integer
public int Angle { get; set; }
public:
property int Angle {
    int get ();
    void set (int value);
}
/** @property */
public int get_Angle ()

/** @property */
public void set_Angle (int value)

public function get Angle () : int

public function set Angle (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.Enabled Property

LabelStyle.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether the label is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.Font Property

LabelStyle.Font Property |
 | See Also

Gets or sets the font of the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.ForeColor Property

LabelStyle.ForeColor Property |
 | See Also

Gets or sets the color of the label.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.Format Property

LabelStyle.Format Property |
 | See Also

Gets or sets the formatting string for the label text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Format As String
public string Format { get; set; }
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Format ()

/** @property */
public void set_Format (String value)

public function get Format () : String

public function set Format (value : String)

Property Value

A string value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.Interval Property

LabelStyle.Interval Property |
 | See Also

Gets or sets the size of the label interval.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.IntervalOffset Property

LabelStyle.IntervalOffset Property |
 | See Also

Gets or sets the offset of the label interval.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.IntervalOffsetType Property

LabelStyle.IntervalOffsetType Property |
 | See Also

Gets or sets the unit of measurement of the label interval offset.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.IntervalType Property

LabelStyle.IntervalType Property |
 | See Also

Gets or sets the unit of measurement for the size of a label interval.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value.

Remarks

This property is not set by default.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.IsEndLabelVisible Property

LabelStyle.IsEndLabelVisible Property |
 | See Also

Gets or sets a flag that determines whether the labels are shown at axis ends.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsEndLabelVisible As Boolean
public bool IsEndLabelVisible { get; set; }
public:
property bool IsEndLabelVisible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEndLabelVisible ()

/** @property */
public void set_IsEndLabelVisible (boolean value)

public function get IsEndLabelVisible () : boolean

public function set IsEndLabelVisible (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.IsStaggered Property

LabelStyle.IsStaggered Property |
 | See Also

Gets or sets a flag that determines whether the labels are shown with an offset.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsStaggered As Boolean
public bool IsStaggered { get; set; }
public:
property bool IsStaggered {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsStaggered ()

/** @property */
public void set_IsStaggered (boolean value)

public function get IsStaggered () : boolean

public function set IsStaggered (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


LabelStyle.TruncatedLabels Property

LabelStyle.TruncatedLabels Property |
 | See Also

Gets or sets a flag that determines whether the labels can be truncated.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TruncatedLabels As Boolean
public bool TruncatedLabels { get; set; }
public:
property bool TruncatedLabels {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_TruncatedLabels ()

/** @property */
public void set_TruncatedLabels (boolean value)

public function get TruncatedLabels () : boolean

public function set TruncatedLabels (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LabelStyle Class
LabelStyle Members


Legend Class

Legend Class |
 | See Also Members

Represents the legend for the chart image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Legend
    Inherits ChartNamedElement
public class Legend : ChartNamedElement
public ref class Legend : public ChartNamedElement
public class Legend extends ChartNamedElement
public class Legend extends ChartNamedElement

Remarks

The Legend class encapsulates all the functionality of the Chart control's legend, and is exposed using the Legends collection property of the root Chart object.

There can be any number of legends for a chart image.

Legends can:

  • Be docked and aligned.

  • Be displayed inside or outside the plotted chart areas.

  • Automatically fit their contents.

  • Use a predefined style, such as row, column or table.

  • Use hatching, gradient colors and background images.

  • Be sized and positioned anywhere within the chart image.

Legend items are represented by the LegendItem object, and are either default or custom items. Custom items are not associated with data, and can be added, deleted and modified using the CustomItems property.

Default items are by default automatically added to the legend, and are the names of the plotted data points for doughnut and pie charts.

For all other chart types, the default items are the names of the plotted data series. Each series has a Legend property that defines the name of the legend that will be used. A legend item will not be created for a series if the IsVisibleInLegend property is set to false. The text for these default items can be changed using the LegendText property. This property will allow you to specify predefined keywords that will be replaced by their appropriate values at run-time.

If you have a pie chart and you set the Label property, it will also set the legend text to the value you set for the labels. If you want to set the text to a different value, you can set the LegendText property. In most cases, you would want to set the LegendText property to "#AXISLABEL" or "#VALX".

Legend series symbols are rectangles, dots or lines. The symbol type is set automatically by the chart and depends on the plotted chart type.

Legend text by default is automatically sized. You can disable automatic sizing of legend text by disabling the IsTextAutoFit property. When this property is set to false, the size of the legend text is determined by the Size property of the legend Font. If the IsTextAutoFit property is enabled, the AutoFitMinFontSize property determines the minimum font size that a legend item can have when resizing.

The TextWrapThreshold property defines a limit on the number of characters that can be shown on one line before text is wrapped to another line. If you do not wish to wrap text in the legend, set the value of the TextWrapThreshold property to zero. By default, when the entire legend text does not fit in the legend, the text will be truncated. You can set the TextWrapThreshold on the legend to get the text to wrap instead of being truncated.

If the contents of the legend cannot fit into the given space, legend entries are truncated. An ellipsis will be shown to indicate that there are more entries than the legend has space for. To prevent the legend items from being truncated,, set the position and size of the legend using the Position and Size properties, respectively. When setting the legend position or size, the chart can no longer automatically position the elements in the chart. In some cases, you many need to manually position other chart elements to achieve the desired appearance.

Another option would be to define your own cell columns instead of using the default legend settings.

The Legend object has a CellColumn Collection; each CellColumn object represents a column in the Legend. A cell column has MaximumWidth and MinimumWidth properties that can be used to adjust the size of the columns.

When the legend contains many entries, InterlacedRows can be used to improve readability. When this property is set to True, it will display a back color that you can set using the InterlacedRowsColor property.

By default, the legend is positioned in the top-right corner of the chart. This position can be modified by using the Docking and Alignment properties of the legend. The legend can also be associated with a chart area by use of the DockedToChartArea property. This property specifies the name of the chart area for which the legend should be docked. In addition, the IsDockedInsideChartArea property can be used to display the legend inside a chart area.

When IsDockedInsideChartArea is set to False, the MaximumAutoSize property defines the maximum size, in percent, of the legend within the available chart when the legend is automatically positioned. This property should be set if you wish to adjust the width or height of the legend after the docking properties have been set.

The legend can be modified using the CustomizeLegend event.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Legend

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Members


Legend Members

Legend Members |
 | See Also Constructors Methods Properties

Represents the legend for the chart image.

The following tables list the members exposed by the Legend type.

Public Constructors

Name | Description
Legend | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend.
AutoFitMinFontSize | Gets or sets the minimum font size that can be used by the autofitting algorithm for the legend text.
BackColor | Gets or sets the background color of a legend.
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend.
BackImage | Gets or sets the background image of a legend.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the legend background image drawing mode.
BackSecondaryColor | Gets or sets the secondary color of a legend background.
BorderColor | Gets or sets the border color of a legend.
BorderDashStyle | Gets or sets the border style of a legend.
BorderWidth | Gets or sets the border width of a legend.
CellColumns | Gets the LegendCellColumnCollection for a legend.
CustomItems | Gets a T:System.Windows.Forms.DataVisualization.Charting.LegendItemsCollection object used for custom legend items.
DockedToChartArea | Gets or sets the name of the ChartArea where the legend will be docked.
Docking | Gets or sets a value that determines where the legend is docked.
Enabled | Gets or sets a value that determines if the legend is enabled.
Font | Gets or sets a Font object, which is used to set font properties of the legend.
ForeColor | Gets or sets the color of the legend text.
HeaderSeparator | Gets or sets the visual separator type for the legend header.
HeaderSeparatorColor | Gets or sets the color of the separator for the legend header.
InsideChartArea | Gets or sets the name of the chart area in which the legend is drawn.
InterlacedRows | Gets or sets a flag that indicates if legend rows will be drawn with interlaced background color.
InterlacedRowsColor | Gets or sets the background color of the legend's interlaced rows.
IsDockedInsideChartArea | Gets or sets a flag that indicates whether the legend is docked inside or outside the chart area.
IsEquallySpacedItems | Gets or sets a flag that indicates whether all legend items are equally spaced.
IsTextAutoFit | Gets or sets a flag that indicates if the legend text is automatically sized.
ItemColumnSeparator | Gets or sets the visual separator type for the legend table columns.
ItemColumnSeparatorColor | Gets or sets the color of the legend table column separator.
ItemColumnSpacing | Gets or sets the legend table column spacing.
LegendItemOrder | Gets or sets a flag that specifies the order in which legend items are displayed. This property only affects legend items automatically added for the chart series; it has no effect on custom legend items.
LegendStyle | Gets or sets the style of the legend.
MaximumAutoSize | Gets or sets the maximum size of the legend, measured as a percentage of the chart area. This value is used by the automatic layout algorithm.
Name | Overridden. Gets or sets the name of the legend.
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the legend.
ShadowColor | Gets or sets the shadow color of the legend.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the legend.
TableStyle | Gets or sets the legend table style.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextWrapThreshold | Gets or sets the number of characters that can be sequentially displayed in the legend before the text is wrapped.
Title | Gets or sets the text of the legend title.
TitleAlignment | Gets or sets the alignment of the legend title.
TitleBackColor | Gets or sets the background color of the legend title.
TitleFont | Gets or sets the font for the legend title.
TitleForeColor | Gets or sets the text color of the legend title.
TitleSeparator | Gets or sets the visual separator type for the legend title.
TitleSeparatorColor | Gets or sets the color of the legend title separator.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Legend Class


Legend Constructor

Legend Constructor |
 | See Also

Overload List

Name | Description
Legend () | Initializes a new instance of the Legend class.
Legend (String) | Initializes a new instance of the AnnotationPathPoint class with the specified legend name.

See Also

Reference

Legend Class
Legend Members


Legend Constructor ()

Legend Constructor () |
 | See Also

Initializes a new instance of the Legend class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Legend ()
public:
Legend ()
public Legend ()
public function Legend ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend Constructor (String)

Legend Constructor (String) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified legend name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String _
)
public Legend (
    string name
)
public:
Legend (
    String^ name
)
public Legend (
    String name
)
public function Legend (
    name : String
)

Parameters

name

The name of the Legend object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend Methods

Legend Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Legend Class


Legend.Dispose Method

Legend.Dispose Method |
 | See Also

Overload List

Name | Description
Legend.Dispose () | (inherited from Dispose )
Legend.Dispose (Boolean) |

See Also

Reference

Legend Class
Legend Members


Legend.Dispose Method (Boolean)

Legend.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend Properties

Legend Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend.
AutoFitMinFontSize | Gets or sets the minimum font size that can be used by the autofitting algorithm for the legend text.
BackColor | Gets or sets the background color of a legend.
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend.
BackImage | Gets or sets the background image of a legend.
BackImageAlignment | Gets or sets the background image alignment used for the Unscaled drawing mode.
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the legend background image drawing mode.
BackSecondaryColor | Gets or sets the secondary color of a legend background.
BorderColor | Gets or sets the border color of a legend.
BorderDashStyle | Gets or sets the border style of a legend.
BorderWidth | Gets or sets the border width of a legend.
CellColumns | Gets the LegendCellColumnCollection for a legend.
CustomItems | Gets a T:System.Windows.Forms.DataVisualization.Charting.LegendItemsCollection object used for custom legend items.
DockedToChartArea | Gets or sets the name of the ChartArea where the legend will be docked.
Docking | Gets or sets a value that determines where the legend is docked.
Enabled | Gets or sets a value that determines if the legend is enabled.
Font | Gets or sets a Font object, which is used to set font properties of the legend.
ForeColor | Gets or sets the color of the legend text.
HeaderSeparator | Gets or sets the visual separator type for the legend header.
HeaderSeparatorColor | Gets or sets the color of the separator for the legend header.
InsideChartArea | Gets or sets the name of the chart area in which the legend is drawn.
InterlacedRows | Gets or sets a flag that indicates if legend rows will be drawn with interlaced background color.
InterlacedRowsColor | Gets or sets the background color of the legend's interlaced rows.
IsDockedInsideChartArea | Gets or sets a flag that indicates whether the legend is docked inside or outside the chart area.
IsEquallySpacedItems | Gets or sets a flag that indicates whether all legend items are equally spaced.
IsTextAutoFit | Gets or sets a flag that indicates if the legend text is automatically sized.
ItemColumnSeparator | Gets or sets the visual separator type for the legend table columns.
ItemColumnSeparatorColor | Gets or sets the color of the legend table column separator.
ItemColumnSpacing | Gets or sets the legend table column spacing.
LegendItemOrder | Gets or sets a flag that specifies the order in which legend items are displayed. This property only affects legend items automatically added for the chart series; it has no effect on custom legend items.
LegendStyle | Gets or sets the style of the legend.
MaximumAutoSize | Gets or sets the maximum size of the legend, measured as a percentage of the chart area. This value is used by the automatic layout algorithm.
Name | Overridden. Gets or sets the name of the legend.
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the legend.
ShadowColor | Gets or sets the shadow color of the legend.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the legend.
TableStyle | Gets or sets the legend table style.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextWrapThreshold | Gets or sets the number of characters that can be sequentially displayed in the legend before the text is wrapped.
Title | Gets or sets the text of the legend title.
TitleAlignment | Gets or sets the alignment of the legend title.
TitleBackColor | Gets or sets the background color of the legend title.
TitleFont | Gets or sets the font for the legend title.
TitleForeColor | Gets or sets the text color of the legend title.
TitleSeparator | Gets or sets the visual separator type for the legend title.
TitleSeparatorColor | Gets or sets the color of the legend title separator.

See Also

Reference

Legend Class


Legend.Alignment Property

Legend.Alignment Property |
 | See Also

Gets or sets the alignment of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Alignment As StringAlignment
public StringAlignment Alignment { get; set; }
public:
property StringAlignment Alignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_Alignment ()

/** @property */
public void set_Alignment (StringAlignment value)

public function get Alignment () : StringAlignment

public function set Alignment (value : StringAlignment)

Property Value

A .NET Framework StringAlignment enumeration value that represents the alignment of the legend. The default value is Near.

Remarks

The legend can be aligned so that it is Near, Center or Far; its alignment is also affected by the Docking property setting.

If the legend is docked to the top or bottom, Near is to the left; if it is docked to the left or right, Near is at the top. The Far property setting is just the opposite, and aligns the legend to the right or the bottom, depending on where it is docked.

Center always centers the legend, either vertically or horizontally.

Setting the Alignment property will have no effect if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.AutoFitMinFontSize Property

Legend.AutoFitMinFontSize Property |
 | See Also

Gets or sets the minimum font size that can be used by the autofitting algorithm for the legend text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property AutoFitMinFontSize As Integer
public int AutoFitMinFontSize { get; set; }
public:
property int AutoFitMinFontSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_AutoFitMinFontSize ()

/** @property */
public void set_AutoFitMinFontSize (int value)

public function get AutoFitMinFontSize () : int

public function set AutoFitMinFontSize (value : int)

Property Value

An integer value that represents the minimum font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackColor Property

Legend.BackColor Property |
 | See Also

Gets or sets the background color of a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value. The default color is System.Drawing.Color.White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

The BackColor value will be the first color used if you have specified gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the legend. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackGradientStyle Property

Legend.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a legend. Also determines whether a gradient is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a legend will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

Set the primary color of the legend background with the BackColor property.

Set the secondary color of the legend background with the BackSecondaryColor property.

Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackHatchStyle Property

Legend.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackImage Property

Legend.BackImage Property |
 | See Also

Gets or sets the background image of a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default value is an empty string.

Remarks

This property defines a path to a background image for a Chart legend, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image can originate from any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackImageAlignment Property

Legend.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment used for the Unscaled drawing mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for the legend; it is only applied when the BackImageWrapMode property is set to Unscaled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackImageTransparentColor Property

Legend.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the background image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackImageWrapMode Property

Legend.BackImageWrapMode Property |
 | See Also

Gets or sets the legend background image drawing mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

The BackImageWrapMode property determines how the image is displayed; the image can be tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the legend. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the legend.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BackSecondaryColor Property

Legend.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of a legend background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of background with hatching or gradient fill. The default value is Empty.

Remarks

The BackSecondaryColor property determines the secondary background color of many Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the legend.

To use gradient colors for the background of a legend:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BorderColor Property

Legend.BorderColor Property |
 | See Also

Gets or sets the border color of a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BorderDashStyle Property

Legend.BorderDashStyle Property |
 | See Also

Gets or sets the border style of a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the chart element.

Remarks

The BorderDashStyle property determines the line style to use for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.BorderWidth Property

Legend.BorderWidth Property |
 | See Also

Gets or sets the border width of a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the legend.

Remarks

Note that BorderWidth property can also set the width of lines in such elements as line charts, custom legend items displayed with a "line" style, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.CellColumns Property

Legend.CellColumns Property |
 | See Also

Gets the LegendCellColumnCollection for a legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property CellColumns As LegendCellColumnCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LegendCellColumnCollection CellColumns { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property LegendCellColumnCollection^ CellColumns {
    LegendCellColumnCollection^ get ();
}
/** @property */
public LegendCellColumnCollection get_CellColumns ()

public function get CellColumns () : LegendCellColumnCollection

Property Value

A LegendCellColumnCollection object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.CustomItems Property

Legend.CustomItems Property |
 | See Also

Gets a T:System.Windows.Forms.DataVisualization.Charting.LegendItemsCollection object used for custom legend items.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property CustomItems As LegendItemsCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LegendItemsCollection CustomItems { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property LegendItemsCollection^ CustomItems {
    LegendItemsCollection^ get ();
}
/** @property */
public LegendItemsCollection get_CustomItems ()

public function get CustomItems () : LegendItemsCollection

Property Value

A LegendItemsCollection object.

Remarks

This collection property can be used to add, delete or modify custom legend items.

Custom legend items, unlike default legend items, do not have associated series or data points.

To modify legend items, use the CustomizeLegend event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.DockedToChartArea Property

Legend.DockedToChartArea Property |
 | See Also

Gets or sets the name of the ChartArea where the legend will be docked.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property DockedToChartArea As String
public string DockedToChartArea { get; set; }
public:
property String^ DockedToChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_DockedToChartArea ()

/** @property */
public void set_DockedToChartArea (String value)

public function get DockedToChartArea () : String

public function set DockedToChartArea (value : String)

Property Value

A string value that represents the name of the ChartArea where this legend will be docked. The default value is the empty string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.Docking Property

Legend.Docking Property |
 | See Also

Gets or sets a value that determines where the legend is docked.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Docking As Docking
public Docking Docking { get; set; }
public:
property Docking Docking {
    Docking get ();
    void set (Docking value);
}
/** @property */
public Docking get_Docking ()

/** @property */
public void set_Docking (Docking value)

public function get Docking () : Docking

public function set Docking (value : Docking)

Property Value

A Docking enumeration value. The default value is Right.

Remarks

The Legend can be docked to the top, left, bottom or right of either the entire chart image, or the inside or outside of a chart area. If the IsDockedInsideChartArea property is set to false, docking applies to the entire chart image. If the IsDockedInsideChartArea property is set to true, docking applies to the ChartArea object specified by the DockedToChartArea property

This property has no effect if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.Enabled Property

Legend.Enabled Property |
 | See Also

Gets or sets a value that determines if the legend is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if enabled, false if disabled. The default value is true.

Remarks

To hide a legend, set this property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.Font Property

Legend.Font Property |
 | See Also

Gets or sets a Font object, which is used to set font properties of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object.

Remarks

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Note:
If you set the Legend.Font.Size property, the IsTextAutoFit property will be set to false. Also, if you set the IsTextAutoFit property to true, this property will be reset to its default, which is 8 points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.ForeColor Property

Legend.ForeColor Property |
 | See Also

Gets or sets the color of the legend text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

The ForeColor property is used to set the legend text color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.HeaderSeparator Property

Legend.HeaderSeparator Property |
 | See Also

Gets or sets the visual separator type for the legend header.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property HeaderSeparator As LegendSeparatorStyle
public LegendSeparatorStyle HeaderSeparator { get; set; }
public:
property LegendSeparatorStyle HeaderSeparator {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_HeaderSeparator ()

/** @property */
public void set_HeaderSeparator (LegendSeparatorStyle value)

public function get HeaderSeparator () : LegendSeparatorStyle

public function set HeaderSeparator (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.HeaderSeparatorColor Property

Legend.HeaderSeparatorColor Property |
 | See Also

Gets or sets the color of the separator for the legend header.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property HeaderSeparatorColor As Color
public Color HeaderSeparatorColor { get; set; }
public:
property Color HeaderSeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_HeaderSeparatorColor ()

/** @property */
public void set_HeaderSeparatorColor (Color value)

public function get HeaderSeparatorColor () : Color

public function set HeaderSeparatorColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.InsideChartArea Property

Legend.InsideChartArea Property |
 | See Also

Gets or sets the name of the chart area in which the legend is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property InsideChartArea As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public string InsideChartArea { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property String^ InsideChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_InsideChartArea ()

/** @property */
public void set_InsideChartArea (String value)

public function get InsideChartArea () : String

public function set InsideChartArea (value : String)

Property Value

A string value that represents the name of the chart area.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.InterlacedRows Property

Legend.InterlacedRows Property |
 | See Also

Gets or sets a flag that indicates if legend rows will be drawn with interlaced background color.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property InterlacedRows As Boolean
public bool InterlacedRows { get; set; }
public:
property bool InterlacedRows {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_InterlacedRows ()

/** @property */
public void set_InterlacedRows (boolean value)

public function get InterlacedRows () : boolean

public function set InterlacedRows (value : boolean)

Property Value

A Boolean value that determines whether alternating rows in the legend are drawn with a specified color.

Remarks

When the legend contains many entries, the InterlacedRows property can be used to improve readability. When this property is set to true, the legend will display a background color for the rows that are interlaced, which can be set using the InterlacedRowsColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.InterlacedRowsColor Property

Legend.InterlacedRowsColor Property |
 | See Also

Gets or sets the background color of the legend's interlaced rows.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property InterlacedRowsColor As Color
public Color InterlacedRowsColor { get; set; }
public:
property Color InterlacedRowsColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_InterlacedRowsColor ()

/** @property */
public void set_InterlacedRowsColor (Color value)

public function get InterlacedRowsColor () : Color

public function set InterlacedRowsColor (value : Color)

Property Value

A Color value.

Remarks

This property is only applicable if interlaced rows are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.IsDockedInsideChartArea Property

Legend.IsDockedInsideChartArea Property |
 | See Also

Gets or sets a flag that indicates whether the legend is docked inside or outside the chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsDockedInsideChartArea As Boolean
public bool IsDockedInsideChartArea { get; set; }
public:
property bool IsDockedInsideChartArea {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsDockedInsideChartArea ()

/** @property */
public void set_IsDockedInsideChartArea (boolean value)

public function get IsDockedInsideChartArea () : boolean

public function set IsDockedInsideChartArea (value : boolean)

Property Value

True is the legend is docked inside the chart area, otherwise false if it is docked outside the chart area. The default value is false.

Remarks

This property will only have an effect if the DockedToChartArea property is set to the name of a ChartArea object.

Note:
If the Position property is set to any value other than Auto, the IsDockedInsideChartArea property also has no effect. This is because the position of the legend is determined by the Position property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.IsEquallySpacedItems Property

Legend.IsEquallySpacedItems Property |
 | See Also

Gets or sets a flag that indicates whether all legend items are equally spaced.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsEquallySpacedItems As Boolean
public bool IsEquallySpacedItems { get; set; }
public:
property bool IsEquallySpacedItems {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsEquallySpacedItems ()

/** @property */
public void set_IsEquallySpacedItems (boolean value)

public function get IsEquallySpacedItems () : boolean

public function set IsEquallySpacedItems (value : boolean)

Property Value

True if legend items are equally spaced, false if they are not. The default value is false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.IsTextAutoFit Property

Legend.IsTextAutoFit Property |
 | See Also

Gets or sets a flag that indicates if the legend text is automatically sized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsTextAutoFit As Boolean
public bool IsTextAutoFit { get; set; }
public:
property bool IsTextAutoFit {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsTextAutoFit ()

/** @property */
public void set_IsTextAutoFit (boolean value)

public function get IsTextAutoFit () : boolean

public function set IsTextAutoFit (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.ItemColumnSeparator Property

Legend.ItemColumnSeparator Property |
 | See Also

Gets or sets the visual separator type for the legend table columns.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ItemColumnSeparator As LegendSeparatorStyle
public LegendSeparatorStyle ItemColumnSeparator { get; set; }
public:
property LegendSeparatorStyle ItemColumnSeparator {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_ItemColumnSeparator ()

/** @property */
public void set_ItemColumnSeparator (LegendSeparatorStyle value)

public function get ItemColumnSeparator () : LegendSeparatorStyle

public function set ItemColumnSeparator (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.ItemColumnSeparatorColor Property

Legend.ItemColumnSeparatorColor Property |
 | See Also

Gets or sets the color of the legend table column separator.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ItemColumnSeparatorColor As Color
public Color ItemColumnSeparatorColor { get; set; }
public:
property Color ItemColumnSeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ItemColumnSeparatorColor ()

/** @property */
public void set_ItemColumnSeparatorColor (Color value)

public function get ItemColumnSeparatorColor () : Color

public function set ItemColumnSeparatorColor (value : Color)

Property Value

A Color value used to draw the color of the legend table column separator.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.ItemColumnSpacing Property

Legend.ItemColumnSpacing Property |
 | See Also

Gets or sets the legend table column spacing.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ItemColumnSpacing As Integer
public int ItemColumnSpacing { get; set; }
public:
property int ItemColumnSpacing {
    int get ();
    void set (int value);
}
/** @property */
public int get_ItemColumnSpacing ()

/** @property */
public void set_ItemColumnSpacing (int value)

public function get ItemColumnSpacing () : int

public function set ItemColumnSpacing (value : int)

Property Value

An integer value that represents the table column spacing.

Remarks

The ItemColumnSpacing property value is calculated as a percentage of the legend text font.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.LegendItemOrder Property

Legend.LegendItemOrder Property |
 | See Also

Gets or sets a flag that specifies the order in which legend items are displayed. This property only affects legend items automatically added for the chart series; it has no effect on custom legend items.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LegendItemOrder As LegendItemOrder
public LegendItemOrder LegendItemOrder { get; set; }
public:
property LegendItemOrder LegendItemOrder {
    LegendItemOrder get ();
    void set (LegendItemOrder value);
}
/** @property */
public LegendItemOrder get_LegendItemOrder ()

/** @property */
public void set_LegendItemOrder (LegendItemOrder value)

public function get LegendItemOrder () : LegendItemOrder

public function set LegendItemOrder (value : LegendItemOrder)

Property Value

A LegendItemOrder enumeration value.

Remarks

If the LegendItemOrder property is set to Auto, the legend will automatically be reversed if StackedColumn, StackedColumn100, StackedArea or StackedArea100 chart types are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.LegendStyle Property

Legend.LegendStyle Property |
 | See Also

Gets or sets the style of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property LegendStyle As LegendStyle
public LegendStyle LegendStyle { get; set; }
public:
property LegendStyle LegendStyle {
    LegendStyle get ();
    void set (LegendStyle value);
}
/** @property */
public LegendStyle get_LegendStyle ()

/** @property */
public void set_LegendStyle (LegendStyle value)

public function get LegendStyle () : LegendStyle

public function set LegendStyle (value : LegendStyle)

Property Value

A LegendStyle enumeration value that determines the legend style. The default value is Table.

Remarks

By default, the legend is displayed as a series of items in a table. You can specify whether to expand items in the table width-wise or height-wise by setting the TableStyle property. When the TableStyle property is set to Auto, the Chart control will determine whether to draw a wide table or a tall table, depending on the alignment and positioning of the chart. This may cause the legend to be drawn using multiple legend item columns.

There are three possible styles for a legend: Column, Row and Table. Refer to the table below for a summary of these styles:

Style | Description
Column | Legend items are displayed in one column, with multiple rows. Most commonly used when the legend is docked to the left or right of the chart.
Row | Legend items are displayed in one row, with multiple columns. Most commonly used when the legend is docked to the top or bottom of the chart.
Table | Legend items are displayed using multiple columns and rows.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.MaximumAutoSize Property

Legend.MaximumAutoSize Property |
 | See Also

Gets or sets the maximum size of the legend, measured as a percentage of the chart area. This value is used by the automatic layout algorithm.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MaximumAutoSize As Single
public float MaximumAutoSize { get; set; }
public:
property float MaximumAutoSize {
    float get ();
    void set (float value);
}
/** @property */
public float get_MaximumAutoSize ()

/** @property */
public void set_MaximumAutoSize (float value)

public function get MaximumAutoSize () : float

public function set MaximumAutoSize (value : float)

Property Value

A float value that represents the maximum size of the legend.

Remarks

If the legend is docked to the left or right of the chart area, this property determines the maximum width of the legend, which is measured as a percentage of the chart area. If the legend is docked to the top or bottom, this property determines the maximum height of the legend, which is also measured as a percentage.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.Name Property

Legend.Name Property |
 | See Also

Gets or sets the name of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the name of the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.Position Property

Legend.Position Property |
 | See Also

Gets or sets an ElementPosition object, which can be used to get or set the position of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property Position As ElementPosition
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ElementPosition Position { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_Position ()

/** @property */
public void set_Position (ElementPosition value)

public function get Position () : ElementPosition

public function set Position (value : ElementPosition)

Property Value

If the Position property is automatic (that is, Legend.Position.Auto = true) the legend position is calculated automatically by the Chart control, taking into account the Docking, Alignment and IsDockedInsideChartArea property settings. If it is not automatic, the Docking, DockedToChartArea and IsDockedInsideChartArea properties are ignored, and the legend position is solely determined by the value of the returned ElementPosition object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.ShadowColor Property

Legend.ShadowColor Property |
 | See Also

Gets or sets the shadow color of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.ShadowOffset Property

Legend.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset, in pixels, of the legend.

Remarks

To implement shadowing, set this property to a value other than zero (0). A positive value will result in a shadow that shifts down and to the right; a negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TableStyle Property

Legend.TableStyle Property |
 | See Also

Gets or sets the legend table style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TableStyle As LegendTableStyle
public LegendTableStyle TableStyle { get; set; }
public:
property LegendTableStyle TableStyle {
    LegendTableStyle get ();
    void set (LegendTableStyle value);
}
/** @property */
public LegendTableStyle get_TableStyle ()

/** @property */
public void set_TableStyle (LegendTableStyle value)

public function get TableStyle () : LegendTableStyle

public function set TableStyle (value : LegendTableStyle)

Property Value

A LegendTableStyle enumeration value.

Remarks

This property is only applicable if the LegendStyle property is set to Table.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TextWrapThreshold Property

Legend.TextWrapThreshold Property |
 | See Also

Gets or sets the number of characters that can be sequentially displayed in the legend before the text is wrapped.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextWrapThreshold As Integer
public int TextWrapThreshold { get; set; }
public:
property int TextWrapThreshold {
    int get ();
    void set (int value);
}
/** @property */
public int get_TextWrapThreshold ()

/** @property */
public void set_TextWrapThreshold (int value)

public function get TextWrapThreshold () : int

public function set TextWrapThreshold (value : int)

Property Value

An integer value that represents the number of characters that can be placed in the legend sequentially before the text is wrapped. The default value is 25.

Remarks

When the legend text exceeds the value specified by this property, text will be automatically wrapped when the next whitespace character is encountered. Text will not be wrapped if there are no whitespace characters in the text.

Set the TextWrapThreshold property to zero to disable the feature.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.Title Property

Legend.Title Property |
 | See Also

Gets or sets the text of the legend title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Title As String
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Title ()

/** @property */
public void set_Title (String value)

public function get Title () : String

public function set Title (value : String)

Property Value

A string value that represents the legend title text. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TitleAlignment Property

Legend.TitleAlignment Property |
 | See Also

Gets or sets the alignment of the legend title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleAlignment As StringAlignment
public StringAlignment TitleAlignment { get; set; }
public:
property StringAlignment TitleAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TitleAlignment ()

/** @property */
public void set_TitleAlignment (StringAlignment value)

public function get TitleAlignment () : StringAlignment

public function set TitleAlignment (value : StringAlignment)

Property Value

A StringAlignment enumeration value that represents the alignment of the legend title. The default value is Center.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TitleBackColor Property

Legend.TitleBackColor Property |
 | See Also

Gets or sets the background color of the legend title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleBackColor As Color
public Color TitleBackColor { get; set; }
public:
property Color TitleBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleBackColor ()

/** @property */
public void set_TitleBackColor (Color value)

public function get TitleBackColor () : Color

public function set TitleBackColor (value : Color)

Property Value

A Color value used to draw the background of the legend title. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TitleFont Property

Legend.TitleFont Property |
 | See Also

Gets or sets the font for the legend title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleFont As Font
public Font TitleFont { get; set; }
public:
property Font^ TitleFont {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_TitleFont ()

/** @property */
public void set_TitleFont (Font value)

public function get TitleFont () : Font

public function set TitleFont (value : Font)

Property Value

A Font object. The default value is "Microsoft Sans Serif, 8pt, Bold".

Remarks

This property can be used to set font properties of the legend title.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TitleForeColor Property

Legend.TitleForeColor Property |
 | See Also

Gets or sets the text color of the legend title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleForeColor As Color
public Color TitleForeColor { get; set; }
public:
property Color TitleForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleForeColor ()

/** @property */
public void set_TitleForeColor (Color value)

public function get TitleForeColor () : Color

public function set TitleForeColor (value : Color)

Property Value

A Color value used to draw the title text color. The default value is Black.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TitleSeparator Property

Legend.TitleSeparator Property |
 | See Also

Gets or sets the visual separator type for the legend title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleSeparator As LegendSeparatorStyle
public LegendSeparatorStyle TitleSeparator { get; set; }
public:
property LegendSeparatorStyle TitleSeparator {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_TitleSeparator ()

/** @property */
public void set_TitleSeparator (LegendSeparatorStyle value)

public function get TitleSeparator () : LegendSeparatorStyle

public function set TitleSeparator (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle value that represents the type of separator that will be drawn below the title. The default value is None.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


Legend.TitleSeparatorColor Property

Legend.TitleSeparatorColor Property |
 | See Also

Gets or sets the color of the legend title separator.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TitleSeparatorColor As Color
public Color TitleSeparatorColor { get; set; }
public:
property Color TitleSeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_TitleSeparatorColor ()

/** @property */
public void set_TitleSeparatorColor (Color value)

public function get TitleSeparatorColor () : Color

public function set TitleSeparatorColor (value : Color)

Property Value

A Color value used to draw the color of the legend title separator. The default value is Color.Black.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Legend Class
Legend Members


LegendCell Class

LegendCell Class |
 | See Also Members

Represents a legend cell in a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendCell
    Inherits ChartNamedElement
public class LegendCell : ChartNamedElement
public ref class LegendCell : public ChartNamedElement
public class LegendCell extends ChartNamedElement
public class LegendCell extends ChartNamedElement

Remarks

A legend is populated with legend items, which are represented by the LegendItemsCollection. These legend items consist of individual legend cells, which are in turn represented by the LegendCellCollection.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.LegendCell

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Members


LegendCell Members

LegendCell Members |
 | See Also Constructors Methods Properties

Represents a legend cell in a legend item.

The following tables list the members exposed by the LegendCell type.

Public Constructors

Name | Description
LegendCell | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend cell contents.
BackColor | Gets or sets the background color of the legend cell.
CellSpan | Gets or sets the number of horizontal cells used to draw the contents of the legend cell.
CellType | Gets or sets the legend cell type.
Font | Gets or sets the font for the legend cell.
ForeColor | Gets or sets the text color of the legend cell.
Image | Gets or sets the name of the image in a legend cell.
ImageSize | Gets or sets the size of the image in a legend cell.
ImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the image is drawn.
Legend | Gets the legend in which this cell belongs.
LegendItem | Gets the legend item in which this cell belongs.
Margins | Gets or sets the margins of the legend cell.
Name | Overridden. Gets or sets the name of the legend cell.
SeriesSymbolSize | Gets or sets the size of the series symbol that is displayed in the legend cell.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the legend cell text.
ToolTip | Gets or sets the tooltip text for the legend cell.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LegendCell Class


LegendCell Constructor

LegendCell Constructor |
 | See Also

Overload List

Name | Description
LegendCell () | Initializes a new instance of the LegendCell class
LegendCell (String) | Initializes a new instance of the LegendCell class with a text parameter that specifies the cell text or image name.
LegendCell (LegendCellType, String) | Initializes a new instance of the LegendCell class with the specified cell type and a text parameter that specifies the cell text or image name.
LegendCell (LegendCellType, String, ContentAlignment) | Initializes a new instance of the LegendCell class with the specified cell type, content alignment, and a text parameter that specifies the cell text or image name.

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell Constructor ()

LegendCell Constructor () |
 | See Also

Initializes a new instance of the LegendCell class

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public LegendCell ()
public:
LegendCell ()
public LegendCell ()
public function LegendCell ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell Constructor (String)

LegendCell Constructor (String) |
 | See Also

Initializes a new instance of the LegendCell class with a text parameter that specifies the cell text or image name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String _
)
public LegendCell (
    string text
)
public:
LegendCell (
    String^ text
)
public LegendCell (
    String text
)
public function LegendCell (
    text : String
)

Parameters

text

A string value that represent the cell text or image name, depending on the type of cell.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell Constructor (LegendCellType, String)

LegendCell Constructor (LegendCellType, String) |
 | See Also

Initializes a new instance of the LegendCell class with the specified cell type and a text parameter that specifies the cell text or image name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    cellType As LegendCellType, _
    text As String _
)
public LegendCell (
    LegendCellType cellType,
    string text
)
public:
LegendCell (
    LegendCellType cellType,
    String^ text
)
public LegendCell (
    LegendCellType cellType,
    String text
)
public function LegendCell (
    cellType : LegendCellType,
    text : String
)

Parameters

cellType

A LegendCellType value that represents the legend cell type to be used.

text

A string value that represents the cell text or image name, depending on the type of cell.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell Constructor (LegendCellType, String, ContentAlignment)

LegendCell Constructor (LegendCellType, String, ContentAlignment) |
 | See Also

Initializes a new instance of the LegendCell class with the specified cell type, content alignment, and a text parameter that specifies the cell text or image name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    cellType As LegendCellType, _
    text As String, _
    alignment As ContentAlignment _
)
public LegendCell (
    LegendCellType cellType,
    string text,
    ContentAlignment alignment
)
public:
LegendCell (
    LegendCellType cellType,
    String^ text,
    ContentAlignment alignment
)
public LegendCell (
    LegendCellType cellType,
    String text,
    ContentAlignment alignment
)
public function LegendCell (
    cellType : LegendCellType,
    text : String,
    alignment : ContentAlignment
)

Parameters

cellType

A LegendCellType value that represents the legend cell type to be used.

text

A string value representing the cell text or image name, depending on the type of cell.

alignment

A ContentAlignment value that represents the alignment of the legend cell contents.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell Methods

LegendCell Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LegendCell Class


LegendCell.Dispose Method

LegendCell.Dispose Method |
 | See Also

Overload List

Name | Description
LegendCell.Dispose () | (inherited from Dispose )
LegendCell.Dispose (Boolean) |

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Dispose Method (Boolean)

LegendCell.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell Properties

LegendCell Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the legend cell contents.
BackColor | Gets or sets the background color of the legend cell.
CellSpan | Gets or sets the number of horizontal cells used to draw the contents of the legend cell.
CellType | Gets or sets the legend cell type.
Font | Gets or sets the font for the legend cell.
ForeColor | Gets or sets the text color of the legend cell.
Image | Gets or sets the name of the image in a legend cell.
ImageSize | Gets or sets the size of the image in a legend cell.
ImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the image is drawn.
Legend | Gets the legend in which this cell belongs.
LegendItem | Gets the legend item in which this cell belongs.
Margins | Gets or sets the margins of the legend cell.
Name | Overridden. Gets or sets the name of the legend cell.
SeriesSymbolSize | Gets or sets the size of the series symbol that is displayed in the legend cell.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the legend cell text.
ToolTip | Gets or sets the tooltip text for the legend cell.

See Also

Reference

LegendCell Class


LegendCell.Alignment Property

LegendCell.Alignment Property |
 | See Also

Gets or sets the alignment of the legend cell contents.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Alignment As ContentAlignment
public virtual ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the legend cell contents. The default value is MiddleCenter.

Remarks

The Alignment property is used to align text, series symbols or images within the legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.BackColor Property

LegendCell.BackColor Property |
 | See Also

Gets or sets the background color of the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property BackColor As Color
public virtual Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value used to draw the legend cell's background.

Remarks

The BackColor property has the highest priority when setting the background color of any entity in the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.CellSpan Property

LegendCell.CellSpan Property |
 | See Also

Gets or sets the number of horizontal cells used to draw the contents of the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CellSpan As Integer
public virtual int CellSpan { get; set; }
public:
virtual property int CellSpan {
    int get ();
    void set (int value);
}
/** @property */
public int get_CellSpan ()

/** @property */
public void set_CellSpan (int value)

public function get CellSpan () : int

public function set CellSpan (value : int)

Property Value

An integer value that represents the number of horizontal cells used to draw the legend cell contents. The default value is 1.

Remarks

If the cell contents must extend beyond the cell width, you can set the CellSpan property to the number of cells required to fit the contents. This property is most often used if you wish to add an extended header or title to the legend.

When this property is set to a value larger than 1, empty legend cells must be added in order to accommodate the contents of the extended legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.CellType Property

LegendCell.CellType Property |
 | See Also

Gets or sets the legend cell type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CellType As LegendCellType
public virtual LegendCellType CellType { get; set; }
public:
virtual property LegendCellType CellType {
    LegendCellType get ();
    void set (LegendCellType value);
}
/** @property */
public LegendCellType get_CellType ()

/** @property */
public void set_CellType (LegendCellType value)

public function get CellType () : LegendCellType

public function set CellType (value : LegendCellType)

Property Value

A LegendCellType enumeration value that represents the type that will be used to define the contents of the legend cell. The default value is Text.

Remarks

The CellType property determines the type of content that will be displayed in each individual legend cell. One of the following cell types must be specified:

  • Text: A string is specified using the Text property, and will be displayed in the legend cell.

  • SeriesSymbol: A series symbol is defined by the ImageStyle property in the LegendItem class. It will be displayed for the legend cell. Recall that a series symbol is a visual indicator—a line, rectangle or marker. When ImageStyle is set to Marker, all marker attributes of the custom item apply to the cell.

  • Image: An image is defined using the Image property and will be displayed in the legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Font Property

LegendCell.Font Property |
 | See Also

Gets or sets the font for the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Font As Font
public virtual Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object. The default value is "Microsoft Sans Serif, 8pt".

Remarks

The Font property can be used to set font properties of the legend cell.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.ForeColor Property

LegendCell.ForeColor Property |
 | See Also

Gets or sets the text color of the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ForeColor As Color
public virtual Color ForeColor { get; set; }
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value used to draw the legend cell text. The default value is Empty.

Remarks

This property is only applicable if the CellType property is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Image Property

LegendCell.Image Property |
 | See Also

Gets or sets the name of the image in a legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Image As String
public virtual string Image { get; set; }
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the name of the image to be used in the legend cell.

Remarks

The image name should be a URL.

This property is only applicable if the CellType property is set to Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.ImageSize Property

LegendCell.ImageSize Property |
 | See Also

Gets or sets the size of the image in a legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ImageSize As Size
public virtual Size ImageSize { get; set; }
public:
virtual property Size ImageSize {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_ImageSize ()

/** @property */
public void set_ImageSize (Size value)

public function get ImageSize () : Size

public function set ImageSize (value : Size)

Property Value

A Size value that represents the size of the image. The default value is (0,0), which means the original size of the image will be used.

Remarks

The ImageSize property is used to explicitly set the width and height of the legend cell image.

This property is only applicable if the CellType property is set to Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.ImageTransparentColor Property

LegendCell.ImageTransparentColor Property |
 | See Also

Gets or sets a color which will be replaced with a transparent color when the image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ImageTransparentColor As Color
public virtual Color ImageTransparentColor { get; set; }
public:
virtual property Color ImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ImageTransparentColor ()

/** @property */
public void set_ImageTransparentColor (Color value)

public function get ImageTransparentColor () : Color

public function set ImageTransparentColor (value : Color)

Property Value

A Color value that is used as a transparent color in a legend cell image.

Remarks

The ImageTransparentColor property is only applicable if the CellType property is set to Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Legend Property

LegendCell.Legend Property |
 | See Also

Gets the legend in which this cell belongs.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable ReadOnly Property Legend As Legend
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Legend Legend { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Legend^ Legend {
    Legend^ get ();
}
/** @property */
public Legend get_Legend ()

public function get Legend () : Legend

Property Value

A Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.LegendItem Property

LegendCell.LegendItem Property |
 | See Also

Gets the legend item in which this cell belongs.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable ReadOnly Property LegendItem As LegendItem
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual LegendItem LegendItem { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property LegendItem^ LegendItem {
    LegendItem^ get ();
}
/** @property */
public LegendItem get_LegendItem ()

public function get LegendItem () : LegendItem

Property Value

A LegendItem object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Margins Property

LegendCell.Margins Property |
 | See Also

Gets or sets the margins of the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Margins As Margins
public virtual Margins Margins { get; set; }
public:
virtual property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}
/** @property */
public Margins get_Margins ()

/** @property */
public void set_Margins (Margins value)

public function get Margins () : Margins

public function set Margins (value : Margins)

Property Value

A Margins object that represents the top, bottom, left, and right values of the legend cell margins. The default values for top, bottom, left and right are "0,0,15,15".

Remarks

Margins are measured as a percentage of the font size for the legend cell.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Name Property

LegendCell.Name Property |
 | See Also

Gets or sets the name of the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the legend cell.

Remarks

The name of the legend cell must be unique; otherwise an exception will be thrown.

The Name property can be used as the indexer when retrieving a LegendCell object from the LegendCellCollection.

If you set this property to a zero-length string, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.SeriesSymbolSize Property

LegendCell.SeriesSymbolSize Property |
 | See Also

Gets or sets the size of the series symbol that is displayed in the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property SeriesSymbolSize As Size
public virtual Size SeriesSymbolSize { get; set; }
public:
virtual property Size SeriesSymbolSize {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_SeriesSymbolSize ()

/** @property */
public void set_SeriesSymbolSize (Size value)

public function get SeriesSymbolSize () : Size

public function set SeriesSymbolSize (value : Size)

Property Value

A Size object that represents the size of the series symbol. The default values for the width and height of the symbol are 200 and 70, respectively.

Remarks

The size of the series symbol is measured as a percentage of the legend font size.

The SeriesSymbolSize property is only applicable if the CellType property is set to SeriesSymbol.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.Text Property

LegendCell.Text Property |
 | See Also

Gets or sets the legend cell text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Text As String
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text for the legend cell. The default value is a zero-length string.

Remarks

The Text property is only applicable if the CellType property is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCell.ToolTip Property

LegendCell.ToolTip Property |
 | See Also

Gets or sets the tooltip text for the legend cell.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ToolTip As String
public virtual string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip for the legend cell. The default value is a zero-length string.

Remarks

If the ToolTip property is set for both a legend item and a legend cell, the legend cell property has precedence.

This ToolTip property allows you to set special keywords to display different types of chart-related data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCell Class
LegendCell Members


LegendCellCollection Class

LegendCellCollection Class |
 | See Also Members

Stores legend cells in a LegendCellCollection object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendCellCollection
    Inherits ChartNamedElementCollection(Of LegendCell)
public class LegendCellCollection : ChartNamedElementCollection<LegendCell>
public ref class LegendCellCollection : public ChartNamedElementCollection<LegendCell^>
public class LegendCellCollection extends ChartNamedElementCollection<LegendCell>
public class LegendCellCollection extends ChartNamedElementCollection<LegendCell>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.LegendCellCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellCollection Members


LegendCellCollection Members

LegendCellCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Stores legend cells in a LegendCellCollection object.

The following tables list the members exposed by the LegendCellCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendCellCollection Class


LegendCellCollection Methods

LegendCellCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendCellCollection Class


LegendCellCollection.Add Method

LegendCellCollection.Add Method |
 | See Also

Overload List

Name | Description
LegendCellCollection.Add (LegendCell) | (inherited from Add )
LegendCellCollection.Add (LegendCellType, String, ContentAlignment) | Adds a legend cell with the specified cell type, text and alignment to the end of the collection.

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members


LegendCellCollection.Add Method (LegendCellType, String, ContentAlignment)

LegendCellCollection.Add Method (LegendCellType, String, ContentAlignment) |
 | See Also

Adds a legend cell with the specified cell type, text and alignment to the end of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    cellType As LegendCellType, _
    text As String, _
    alignment As ContentAlignment _
) As Integer
public int Add (
    LegendCellType cellType,
    string text,
    ContentAlignment alignment
)
public:
int Add (
    LegendCellType cellType,
    String^ text,
    ContentAlignment alignment
)
public int Add (
    LegendCellType cellType,
    String text,
    ContentAlignment alignment
)
public function Add (
    cellType : LegendCellType,
    text : String,
    alignment : ContentAlignment
) : int

Parameters

cellType

A LegendCellType value representing the cell type.

text

A string value that represents either the cell text or its image name, depending on the value of the cellType parameter.

alignment

A ContentAlignment value that represents the cell content alignment.

Return Value

An integer value that represents the index of the newly added legend cell in the collection. The index is zero-based.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members


LegendCellCollection.Insert Method

LegendCellCollection.Insert Method |
 | See Also

Overload List

Name | Description
LegendCellCollection.Insert (Int32, LegendCell) | (inherited from Insert )
LegendCellCollection.Insert (Int32, LegendCellType, String, ContentAlignment) | Inserts a legend cell with the specified cell type, text and alignment into the collection at a given location.

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members


LegendCellCollection.Insert Method (Int32, LegendCellType, String, ContentAlignment)

LegendCellCollection.Insert Method (Int32, LegendCellType, String, ContentAlignment) |
 | See Also

Inserts a legend cell with the specified cell type, text and alignment into the collection at a given location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Insert ( _
    index As Integer, _
    cellType As LegendCellType, _
    text As String, _
    alignment As ContentAlignment _
)
public void Insert (
    int index,
    LegendCellType cellType,
    string text,
    ContentAlignment alignment
)
public:
void Insert (
    int index,
    LegendCellType cellType,
    String^ text,
    ContentAlignment alignment
)
public void Insert (
    int index,
    LegendCellType cellType,
    String text,
    ContentAlignment alignment
)
public function Insert (
    index : int,
    cellType : LegendCellType,
    text : String,
    alignment : ContentAlignment
)

Parameters

index

Index of the location to insert the object.

cellType

A LegendCellType value that represents the cell type.

text

A string value that represents either the cell text or its image name, depending on the value of the cellType parameter.

alignment

A ContentAlignment enumeration value that represents the alignment of the legend cell content.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellCollection Class
LegendCellCollection Members


LegendCellCollection Properties

LegendCellCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendCellCollection Class


LegendCellColumn Class

LegendCellColumn Class |
 | See Also Members

Represents a cell column in a legend, which is used to extend the functionality of the default legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendCellColumn
    Inherits ChartNamedElement
public class LegendCellColumn : ChartNamedElement
public ref class LegendCellColumn : public ChartNamedElement
public class LegendCellColumn extends ChartNamedElement
public class LegendCellColumn extends ChartNamedElement

Remarks

Any number of cell columns can be placed in any order, which gives you the flexibility to extend the abilities of the default legend entries.

The legend cell columns are only applicable to items that are automatically generated from series or data points.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.LegendCellColumn

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Members


LegendCellColumn Members

LegendCellColumn Members |
 | See Also Constructors Methods Properties

Represents a cell column in a legend, which is used to extend the functionality of the default legend.

The following tables list the members exposed by the LegendCellColumn type.

Public Constructors

Name | Description
LegendCellColumn | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the legend column content alignment.
BackColor | Gets or sets the background color of the legend cell column.
ColumnType | Gets or sets the legend cell column type.
Font | Gets or sets the font for the legend column text.
ForeColor | Gets or sets the text color of the legend cell column.
HeaderAlignment | Gets or sets the horizontal text alignment of the legend cell column header.
HeaderBackColor | Gets or sets the background color for the legend cell column header.
HeaderFont | Gets or sets the font used in the legend column header.
HeaderForeColor | Gets or sets the color of the legend column header text (HeaderText property).
HeaderText | Gets or sets the text for the legend cell column header.
Legend | Gets the legend in which this legend cell column belongs.
Margins | Gets or sets the margins of the legend cell column.
MaximumWidth | Gets or sets the maximum width of the legend cell column.
MinimumWidth | Gets or sets the minimum width of the legend cell column.
Name | Overridden. Gets or sets the name of the legend cell column.
SeriesSymbolSize | Gets or sets the size of the series symbol displayed in a legend cell column.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the legend cell column.
ToolTip | Gets or sets the tooltip text for the legend cell column.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ShouldSerializeMargins | Determines whether the property should be serialized. For internal use only.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LegendCellColumn Class


LegendCellColumn Constructor

LegendCellColumn Constructor |
 | See Also

Overload List

Name | Description
LegendCellColumn () | Initializes a new instance of the LegendCellColumn class.
LegendCellColumn (String, LegendCellColumnType, String) | Initializes a new instance of the LegendCellColumn class with the specified header text, column type and column cell text.
LegendCellColumn (String, LegendCellColumnType, String, ContentAlignment) | Initializes a new instance of the LegendCellColumn class with the specified header text, column type, column cell text and content alignment.

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn Constructor ()

LegendCellColumn Constructor () |
 | See Also

Initializes a new instance of the LegendCellColumn class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public LegendCellColumn ()
public:
LegendCellColumn ()
public LegendCellColumn ()
public function LegendCellColumn ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn Constructor (String, LegendCellColumnType, String)

LegendCellColumn Constructor (String, LegendCellColumnType, String) |
 | See Also

Initializes a new instance of the LegendCellColumn class with the specified header text, column type and column cell text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    headerText As String, _
    columnType As LegendCellColumnType, _
    text As String _
)
public LegendCellColumn (
    string headerText,
    LegendCellColumnType columnType,
    string text
)
public:
LegendCellColumn (
    String^ headerText,
    LegendCellColumnType columnType,
    String^ text
)
public LegendCellColumn (
    String headerText,
    LegendCellColumnType columnType,
    String text
)
public function LegendCellColumn (
    headerText : String,
    columnType : LegendCellColumnType,
    text : String
)

Parameters

headerText

Column header text.

columnType

A LegendCellColumnType enumeration value.

text

Column cell text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn Constructor (String, LegendCellColumnType, String, ContentAlignment)

LegendCellColumn Constructor (String, LegendCellColumnType, String, ContentAlignment) |
 | See Also

Initializes a new instance of the LegendCellColumn class with the specified header text, column type, column cell text and content alignment.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    headerText As String, _
    columnType As LegendCellColumnType, _
    text As String, _
    alignment As ContentAlignment _
)
public LegendCellColumn (
    string headerText,
    LegendCellColumnType columnType,
    string text,
    ContentAlignment alignment
)
public:
LegendCellColumn (
    String^ headerText,
    LegendCellColumnType columnType,
    String^ text,
    ContentAlignment alignment
)
public LegendCellColumn (
    String headerText,
    LegendCellColumnType columnType,
    String text,
    ContentAlignment alignment
)
public function LegendCellColumn (
    headerText : String,
    columnType : LegendCellColumnType,
    text : String,
    alignment : ContentAlignment
)

Parameters

headerText

Column header text.

columnType

A LegendCellColumnType enumeration value.

text

Column cell text.

alignment

Column cell ContentAlignment.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn Methods

LegendCellColumn Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ShouldSerializeMargins | Determines whether the property should be serialized. For internal use only.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LegendCellColumn Class


LegendCellColumn.Dispose Method

LegendCellColumn.Dispose Method |
 | See Also

Overload List

Name | Description
LegendCellColumn.Dispose () | (inherited from Dispose )
LegendCellColumn.Dispose (Boolean) |

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.Dispose Method (Boolean)

LegendCellColumn.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.ShouldSerializeMargins Method

LegendCellColumn.ShouldSerializeMargins Method |
 | See Also

This method supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Determines whether the property should be serialized. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ShouldSerializeMargins As Boolean
public bool ShouldSerializeMargins ()
public:
bool ShouldSerializeMargins ()
public boolean ShouldSerializeMargins ()
public function ShouldSerializeMargins () : boolean

Return Value

True if property should be serialized, otherwise false.

Remarks

For internal use only.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn Properties

LegendCellColumn Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the legend column content alignment.
BackColor | Gets or sets the background color of the legend cell column.
ColumnType | Gets or sets the legend cell column type.
Font | Gets or sets the font for the legend column text.
ForeColor | Gets or sets the text color of the legend cell column.
HeaderAlignment | Gets or sets the horizontal text alignment of the legend cell column header.
HeaderBackColor | Gets or sets the background color for the legend cell column header.
HeaderFont | Gets or sets the font used in the legend column header.
HeaderForeColor | Gets or sets the color of the legend column header text (HeaderText property).
HeaderText | Gets or sets the text for the legend cell column header.
Legend | Gets the legend in which this legend cell column belongs.
Margins | Gets or sets the margins of the legend cell column.
MaximumWidth | Gets or sets the maximum width of the legend cell column.
MinimumWidth | Gets or sets the minimum width of the legend cell column.
Name | Overridden. Gets or sets the name of the legend cell column.
SeriesSymbolSize | Gets or sets the size of the series symbol displayed in a legend cell column.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the legend cell column.
ToolTip | Gets or sets the tooltip text for the legend cell column.

See Also

Reference

LegendCellColumn Class


LegendCellColumn.Alignment Property

LegendCellColumn.Alignment Property |
 | See Also

Gets or sets the legend column content alignment.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Alignment As ContentAlignment
public virtual ContentAlignment Alignment { get; set; }
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the alignment of the legend cell contents. The default value is MiddleCenter.

Remarks

This property is used to align text or series symbols within the legend cell column.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.BackColor Property

LegendCellColumn.BackColor Property |
 | See Also

Gets or sets the background color of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property BackColor As Color
public virtual Color BackColor { get; set; }
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value used to draw the legend cell column background. The default value is Empty.

Remarks

This property overrides the BackColor property of the legend that the legend cell column belongs to. It also overrides the InterlacedRows property of the legend.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.ColumnType Property

LegendCellColumn.ColumnType Property |
 | See Also

Gets or sets the legend cell column type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ColumnType As LegendCellColumnType
public virtual LegendCellColumnType ColumnType { get; set; }
public:
virtual property LegendCellColumnType ColumnType {
    LegendCellColumnType get ();
    void set (LegendCellColumnType value);
}
/** @property */
public LegendCellColumnType get_ColumnType ()

/** @property */
public void set_ColumnType (LegendCellColumnType value)

public function get ColumnType () : LegendCellColumnType

public function set ColumnType (value : LegendCellColumnType)

Property Value

A LegendCellColumnType enumeration value. This value represents the type that will be used to define the legend cell column contents. The default value is Text.

Remarks

This property determines the type of content that will be displayed in each individual legend cell column. There are two possible values:

  • Text: By default, the #LEGENDTEXT keyword is used to place the LegendText value in each cell column. However, you can use the Text property to set any keyword(s) that will be replaced by a value of the corresponding series.

  • SeriesSymbol: The legend cell will contain a series symbol, such as a rectangle, line, line with marker, or marker, of the same fill color as its corresponding series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.Font Property

LegendCellColumn.Font Property |
 | See Also

Gets or sets the font for the legend column text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Font As Font
public virtual Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object. The default value is null.

Remarks

This property is only applicable when the LegendCellColumnType is set to Text, and a string value is defined for the Text property. You can use the Font property to set font properties of the legend cell column.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.ForeColor Property

LegendCellColumn.ForeColor Property |
 | See Also

Gets or sets the text color of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ForeColor As Color
public virtual Color ForeColor { get; set; }
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value used to draw the legend cell column text. The default value is Empty.

Remarks

This property is only applicable if the LegendCellColumnType is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.HeaderAlignment Property

LegendCellColumn.HeaderAlignment Property |
 | See Also

Gets or sets the horizontal text alignment of the legend cell column header.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property HeaderAlignment As StringAlignment
public StringAlignment HeaderAlignment { get; set; }
public:
property StringAlignment HeaderAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_HeaderAlignment ()

/** @property */
public void set_HeaderAlignment (StringAlignment value)

public function get HeaderAlignment () : StringAlignment

public function set HeaderAlignment (value : StringAlignment)

Property Value

A StringAlignment enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.HeaderBackColor Property

LegendCellColumn.HeaderBackColor Property |
 | See Also

Gets or sets the background color for the legend cell column header.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property HeaderBackColor As Color
public virtual Color HeaderBackColor { get; set; }
public:
virtual property Color HeaderBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_HeaderBackColor ()

/** @property */
public void set_HeaderBackColor (Color value)

public function get HeaderBackColor () : Color

public function set HeaderBackColor (value : Color)

Property Value

A Color value used to draw the background of the legend cell column header. The default value is Empty.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.HeaderFont Property

LegendCellColumn.HeaderFont Property |
 | See Also

Gets or sets the font used in the legend column header.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property HeaderFont As Font
public virtual Font HeaderFont { get; set; }
public:
virtual property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_HeaderFont ()

/** @property */
public void set_HeaderFont (Font value)

public function get HeaderFont () : Font

public function set HeaderFont (value : Font)

Property Value

A Font object. The default value is "Microsoft Sans Serif, 8pt, Bold".

Remarks

This property can be used to set font properties of the legend cell column header.

If you attempt to change the properties of this Font object at run time, a compilation error will occur. To set font properties at run time, you must create a new Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.HeaderForeColor Property

LegendCellColumn.HeaderForeColor Property |
 | See Also

Gets or sets the color of the legend column header text (HeaderText property).

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property HeaderForeColor As Color
public virtual Color HeaderForeColor { get; set; }
public:
virtual property Color HeaderForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_HeaderForeColor ()

/** @property */
public void set_HeaderForeColor (Color value)

public function get HeaderForeColor () : Color

public function set HeaderForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.HeaderText Property

LegendCellColumn.HeaderText Property |
 | See Also

Gets or sets the text for the legend cell column header.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property HeaderText As String
public virtual string HeaderText { get; set; }
public:
virtual property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_HeaderText ()

/** @property */
public void set_HeaderText (String value)

public function get HeaderText () : String

public function set HeaderText (value : String)

Property Value

A string value that represents the legend cell column header text. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.Legend Property

LegendCellColumn.Legend Property |
 | See Also

Gets the legend in which this legend cell column belongs.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable ReadOnly Property Legend As Legend
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Legend Legend { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Legend^ Legend {
    Legend^ get ();
}
/** @property */
public Legend get_Legend ()

public function get Legend () : Legend

Property Value

A Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.Margins Property

LegendCellColumn.Margins Property |
 | See Also

Gets or sets the margins of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Overridable Property Margins As Margins
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public virtual Margins Margins { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
virtual property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}
/** @property */
public Margins get_Margins ()

/** @property */
public void set_Margins (Margins value)

public function get Margins () : Margins

public function set Margins (value : Margins)

Property Value

A Margins object that represents the top, bottom, left, and right values of the legend cell margins. The default values for top, bottom, left and right are "0,0,15,15".

Remarks

This property is measured as a percentage of the legend font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.MaximumWidth Property

LegendCellColumn.MaximumWidth Property |
 | See Also

Gets or sets the maximum width of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property MaximumWidth As Integer
public virtual int MaximumWidth { get; set; }
public:
virtual property int MaximumWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaximumWidth ()

/** @property */
public void set_MaximumWidth (int value)

public function get MaximumWidth () : int

public function set MaximumWidth (value : int)

Property Value

An integer value that represents the maximum width of the legend cell column. The default value is minus one (-1), which means that the maximum width is automatically calculated.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.MinimumWidth Property

LegendCellColumn.MinimumWidth Property |
 | See Also

Gets or sets the minimum width of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property MinimumWidth As Integer
public virtual int MinimumWidth { get; set; }
public:
virtual property int MinimumWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MinimumWidth ()

/** @property */
public void set_MinimumWidth (int value)

public function get MinimumWidth () : int

public function set MinimumWidth (value : int)

Property Value

An integer value that represents the minimum width of the legend cell column. The default value is minus one (-1), which means that the minimum width is automatically calculated.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.Name Property

LegendCellColumn.Name Property |
 | See Also

Gets or sets the name of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the text name of the legend cell column.

Remarks

The name of the legend cell must be unique; otherwise an exception will be thrown.

The Name property can be used as the indexer when retrieving a LegendCellColumn object from the LegendCellColumnCollection.

If you set this property to a zero-length string, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.SeriesSymbolSize Property

LegendCellColumn.SeriesSymbolSize Property |
 | See Also

Gets or sets the size of the series symbol displayed in a legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property SeriesSymbolSize As Size
public virtual Size SeriesSymbolSize { get; set; }
public:
virtual property Size SeriesSymbolSize {
    Size get ();
    void set (Size value);
}
/** @property */
public Size get_SeriesSymbolSize ()

/** @property */
public void set_SeriesSymbolSize (Size value)

public function get SeriesSymbolSize () : Size

public function set SeriesSymbolSize (value : Size)

Property Value

A Size object that represents the size of the series symbol. The default values for the width and height of the symbol are 200 and 70, respectively.

Remarks

The size of the series symbol is measured as a percentage of the legend font size.

This property is only applicable if the LegendCellColumnType property is set to SeriesSymbol.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.Text Property

LegendCellColumn.Text Property |
 | See Also

Gets or sets the text of the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Text As String
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text for the legend cell column. The default value is a zero-length string.

Remarks

This property is only applicable if the LegendCellColumnType is set to Text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumn.ToolTip Property

LegendCellColumn.ToolTip Property |
 | See Also

Gets or sets the tooltip text for the legend cell column.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property ToolTip As String
public virtual string ToolTip { get; set; }
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip for the legend cell column. The default value is a zero-length string.

Remarks

If the ToolTip property is set for both a legend item and a legend cell, the legend cell property has precedence.

This property allows you to set special keywords to display different types of chart-related data.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumn Class
LegendCellColumn Members


LegendCellColumnCollection Class

LegendCellColumnCollection Class |
 | See Also Members

Stores LegendCellColumn objects, which are applied to default legend items.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendCellColumnCollection
    Inherits ChartNamedElementCollection(Of LegendCellColumn)
public class LegendCellColumnCollection : ChartNamedElementCollection<LegendCellColumn>
public ref class LegendCellColumnCollection : public ChartNamedElementCollection<LegendCellColumn^>
public class LegendCellColumnCollection extends ChartNamedElementCollection<LegendCellColumn>
public class LegendCellColumnCollection extends ChartNamedElementCollection<LegendCellColumn>

Remarks

The LegendCellColumnCollection class stores LegendCellColumn objects.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.LegendCellColumnCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumnCollection Members


LegendCellColumnCollection Members

LegendCellColumnCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Stores LegendCellColumn objects, which are applied to default legend items.

The following tables list the members exposed by the LegendCellColumnCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendCellColumnCollection Class


LegendCellColumnCollection Methods

LegendCellColumnCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendCellColumnCollection Class


LegendCellColumnCollection.Dispose Method

LegendCellColumnCollection.Dispose Method |
 | See Also

Overload List

Name | Description
LegendCellColumnCollection.Dispose () | (inherited from Dispose )
LegendCellColumnCollection.Dispose (Boolean) |

See Also

Reference

LegendCellColumnCollection Class
LegendCellColumnCollection Members


LegendCellColumnCollection.Dispose Method (Boolean)

LegendCellColumnCollection.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCellColumnCollection Class
LegendCellColumnCollection Members


LegendCellColumnCollection Properties

LegendCellColumnCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendCellColumnCollection Class


LegendCellColumnType Enumeration

LegendCellColumnType Enumeration |
 | See Also

Specifies a legend cell column type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendCellColumnType
public enum LegendCellColumnType
public enum class LegendCellColumnType
public enum LegendCellColumnType
public enum LegendCellColumnType

Members

Member name | Description
SeriesSymbol | The legend cell column contains a series symbol such as a line, rectangle, or line with marker.
Text | The legend cell column contains text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LegendCellType Enumeration

LegendCellType Enumeration |
 | See Also

Specifies a legend cell type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendCellType
public enum LegendCellType
public enum class LegendCellType
public enum LegendCellType
public enum LegendCellType

Members

Member name | Description
Image | The legend cell contains an image.
SeriesSymbol | The legend cell contains a series symbol, such as a line or rectangle.
Text | The legend cell contains text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LegendCollection Class

LegendCollection Class |
 | See Also Members

Represents a collection of Legend objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendCollection
    Inherits ChartNamedElementCollection(Of Legend)
public class LegendCollection : ChartNamedElementCollection<Legend>
public ref class LegendCollection : public ChartNamedElementCollection<Legend^>
public class LegendCollection extends ChartNamedElementCollection<Legend>
public class LegendCollection extends ChartNamedElementCollection<Legend>

Remarks

The LegendCollection class is implemented as the Legends collection property of the root Chart object.

Legend objects can be appended, inserted or removed from the collection at either design time or run time.

The Count property indicates the total number of items in the collection, and is commonly used to find the upper bound of the collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.LegendCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCollection Members


LegendCollection Members

LegendCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of Legend objects.

The following tables list the members exposed by the LegendCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendCollection Class


LegendCollection Methods

LegendCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendCollection Class


LegendCollection.Add Method

LegendCollection.Add Method |
 | See Also

Overload List

Name | Description
LegendCollection.Add (Legend) | (inherited from Add )
LegendCollection.Add (String) | Adds the specified Legend object to the end of the collection.

See Also

Reference

LegendCollection Class
LegendCollection Members


LegendCollection.Add Method (String)

LegendCollection.Add Method (String) |
 | See Also

Adds the specified Legend object to the end of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As Legend
public Legend Add (
    string name
)
public:
Legend^ Add (
    String^ name
)
public Legend Add (
    String name
)
public function Add (
    name : String
) : Legend

Parameters

name

The name of legend to be added.

Return Value

A string value that represents the index of the added item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendCollection Class
LegendCollection Members


LegendCollection Properties

LegendCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendCollection Class


LegendImageStyle Enumeration

LegendImageStyle Enumeration |
 | See Also

Specifies the style to apply to the symbol for a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendImageStyle
public enum LegendImageStyle
public enum class LegendImageStyle
public enum LegendImageStyle
public enum LegendImageStyle

Members

Member name | Description
Line | The symbol will be a line.
Marker | The symbol will be a marker.
Rectangle | The symbol will be a rectangle.

Remarks

The LegendImageStyle enumeration represents the style that is used for a legend item, and is applied to the symbol for that item.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LegendItem Class

LegendItem Class |
 | See Also Members

Represents a legend item, which is stored in the LegendItemsCollection class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendItem
    Inherits ChartNamedElement
public class LegendItem : ChartNamedElement
public ref class LegendItem : public ChartNamedElement
public class LegendItem extends ChartNamedElement
public class LegendItem extends ChartNamedElement

Remarks

The LegendItem class represents a legend item, which can be either a default or custom item:

  • Default legend items are automatically inserted into the legend for either data series or data points. Default entries for pie and doughnut charts represent the plotted data points, whereas entries for all other chart types represent the plotted series. By default, these legend entries use the data point or series color for the symbol color, and the name of the series or data point for the legend item text. Default legend items can be customized or deleted at run time by using the CustomizeLegend event of the Chart control.

  • Custom legend items have user-defined text, symbol color, and so forth. Unlike the default entries, they are not connected with the plotted data. Custom legend items can be added at either design time or run time, using the CustomItems property of the Legend object.

Legend symbols can be rectangles, lines or markers, depending on the ImageStyle property setting of a LegendItem object.

The text of a custom legend item is determined by the Name property.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.LegendItem

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Members


LegendItem Members

LegendItem Members |
 | See Also Constructors Methods Properties

Represents a legend item, which is stored in the LegendItemsCollection class.

The following tables list the members exposed by the LegendItem type.

Public Constructors

Name | Description
LegendItem | Overloaded.
Top

Public Properties

Name | Description
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend item. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend item.
BackImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the background image is drawn.
BackSecondaryColor | Gets or sets the secondary color of a legend item.
BorderColor | Gets or sets the border color of a legend item.
BorderDashStyle | Gets or sets the border style of a legend item.
BorderWidth | Gets or sets the border width of a legend item.
Cells | Gets the collection of cells in the legend item.
Color | Gets or sets the color of a legend item.
Enabled | Gets or sets a flag that indicates whether the legend item is enabled.
Image | Gets or sets the image that will be displayed for a legend item symbol.
ImageStyle | Gets or sets the display style of the legend item image.
Legend | Gets or sets the Legend object associated with this legend item.
MarkerBorderColor | Gets or sets the border color of the markers, if used.
MarkerBorderWidth | Gets or sets the border width of the markers, if used. Measured in pixels.
MarkerColor | Gets or sets the color of the markers, if used.
MarkerImage | Gets or sets a marker image.
MarkerImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the legend item markers, if used.
MarkerStyle | Gets or sets a legend item marker style. Also used to enable or disable the display of markers.
Name | Overridden. Gets or sets the name of the legend item.
SeparatorColor | Gets or sets the color of the legend item separator.
SeparatorType | Gets or sets the separator style of the legend item.
SeriesName | Gets or sets the name of the Series associated with a default legend item.
SeriesPointIndex | Gets or sets the index of a DataPoint object associated with a default legend item.
ShadowColor | Gets or sets the shadow color of a legend item.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a legend item.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip of the legend item.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LegendItem Class


LegendItem Constructor

LegendItem Constructor |
 | See Also

Overload List

Name | Description
LegendItem () | Initializes a new instance of the LegendItem class.
LegendItem (String, Color, String) | Initializes a new instance of the LegendItem class with the specified name, color and image path.

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Constructor ()

LegendItem Constructor () |
 | See Also

Initializes a new instance of the LegendItem class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public LegendItem ()
public:
LegendItem ()
public LegendItem ()
public function LegendItem ()

Remarks

Use this constructor to create and initialize a new instance of the LegendItem class.

Note that you can also add custom legend items using the Add and Insert methods associated with the CustomItems collection property of the Legend object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Constructor (String, Color, String)

LegendItem Constructor (String, Color, String) |
 | See Also

Initializes a new instance of the LegendItem class with the specified name, color and image path.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String, _
    color As Color, _
    image As String _
)
public LegendItem (
    string name,
    Color color,
    string image
)
public:
LegendItem (
    String^ name,
    Color color,
    String^ image
)
public LegendItem (
    String name,
    Color color,
    String image
)
public function LegendItem (
    name : String,
    color : Color,
    image : String
)

Parameters

name

Name of the legend item.

color

Color of the legend item.

image

Path of the image to be displayed for the legend item.

Remarks

Only the image or color parameter needs to be specified. If both are specified, the image parameter has precedence.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Methods

LegendItem Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LegendItem Class


LegendItem.Dispose Method

LegendItem.Dispose Method |
 | See Also

Overload List

Name | Description
LegendItem.Dispose () | (inherited from Dispose )
LegendItem.Dispose (Boolean) |

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Dispose Method (Boolean)

LegendItem.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Properties

LegendItem Properties |
 | See Also

Public Properties

Name | Description
BackGradientStyle | Gets or sets the orientation for the background gradient of a legend item. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style of a legend item.
BackImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the background image is drawn.
BackSecondaryColor | Gets or sets the secondary color of a legend item.
BorderColor | Gets or sets the border color of a legend item.
BorderDashStyle | Gets or sets the border style of a legend item.
BorderWidth | Gets or sets the border width of a legend item.
Cells | Gets the collection of cells in the legend item.
Color | Gets or sets the color of a legend item.
Enabled | Gets or sets a flag that indicates whether the legend item is enabled.
Image | Gets or sets the image that will be displayed for a legend item symbol.
ImageStyle | Gets or sets the display style of the legend item image.
Legend | Gets or sets the Legend object associated with this legend item.
MarkerBorderColor | Gets or sets the border color of the markers, if used.
MarkerBorderWidth | Gets or sets the border width of the markers, if used. Measured in pixels.
MarkerColor | Gets or sets the color of the markers, if used.
MarkerImage | Gets or sets a marker image.
MarkerImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the marker image is drawn.
MarkerSize | Gets or sets the size of the legend item markers, if used.
MarkerStyle | Gets or sets a legend item marker style. Also used to enable or disable the display of markers.
Name | Overridden. Gets or sets the name of the legend item.
SeparatorColor | Gets or sets the color of the legend item separator.
SeparatorType | Gets or sets the separator style of the legend item.
SeriesName | Gets or sets the name of the Series associated with a default legend item.
SeriesPointIndex | Gets or sets the index of a DataPoint object associated with a default legend item.
ShadowColor | Gets or sets the shadow color of a legend item.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a legend item.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip of the legend item.

See Also

Reference

LegendItem Class


LegendItem.BackGradientStyle Property

LegendItem.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a legend item. Also determines whether a gradient is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a title will display a gradient, and to determine the orientation of the gradient if one is used.

This property is only implemented if the ImageStyle property is set to Rectangle.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

  • Use the Color property to set the primary color.

  • Use the BackGradientStyle property to set the secondary color.

  • Use this BackGradientStyle property to set the desired gradient style.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.BackHatchStyle Property

LegendItem.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note:
The color of hatching lines is determined by the BackSecondaryColor property.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.BackImageTransparentColor Property

LegendItem.BackImageTransparentColor Property |
 | See Also

Gets or sets a color which will be replaced with a transparent color when the background image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent.

Remarks

This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.BackSecondaryColor Property

LegendItem.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of background with hatching or gradient fill. The default value is Empty.

Remarks

The BackSecondaryColor property is one of several related properties that determine the secondary background color of many Chart objects; it is used when gradient colors are being applied.

This property is only implemented if the ImageStyle property is set to Rectangle.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the legend item.

To use gradient colors for a legend cell's background:

To use gradient colors:

  • Use the Color property to set the primary color.

  • Use the BackGradientStyle property to set the secondary color.

  • Use the BackGradientStyle property to set the desired gradient style.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.BorderColor Property

LegendItem.BorderColor Property |
 | See Also

Gets or sets the border color of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

Note:
If you use a marker for a custom legend item. this property will set the border color of the marker. However, if the MarkerBorderColor property is also set, its value has precedence.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.BorderDashStyle Property

LegendItem.BorderDashStyle Property |
 | See Also

Gets or sets the border style of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the legend item.

Remarks

This property determines the line style used for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.BorderWidth Property

LegendItem.BorderWidth Property |
 | See Also

Gets or sets the border width of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the width, in pixels, of the legend item border.

Remarks

The BorderWidth property can also be used to set the width of lines when, for example, custom legend items are displayed with a Line style.

Note This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Cells Property

LegendItem.Cells Property |
 | See Also

Gets the collection of cells in the legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Cells As LegendCellCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LegendCellCollection Cells { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property LegendCellCollection^ Cells {
    LegendCellCollection^ get ();
}
/** @property */
public LegendCellCollection get_Cells ()

public function get Cells () : LegendCellCollection

Property Value

A LegendCellCollection object.

Remarks

A legend item consists of one or more legend cells, each represented by a LegendCell object and stored in a LegendCellCollection.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Color Property

LegendItem.Color Property |
 | See Also

Gets or sets the color of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Color As Color
public Color Color { get; set; }
public:
property Color Color {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_Color ()

/** @property */
public void set_Color (Color value)

public function get Color () : Color

public function set Color (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

This Color property is one several related properties that get or set the color of many chart elements; it can be set to any ARGB (alpha, red, green, blue) value.

If this property is set for both a data point and its series, the data point color will have precedence. The series color will only be used for data points that do not define their own color.

If a custom legend item uses a marker, this property will determine the marker color. However, if the MarkerColor property is set, its value then has precedence.

This property will be ignored if the Image property specifies an image to be used for the legend item symbol.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Enabled Property

LegendItem.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether the legend item is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if the legend item is enabled, otherwise false. The default value is true.

Remarks

This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Image Property

LegendItem.Image Property |
 | See Also

Gets or sets the image that will be displayed for a legend item symbol.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Image As String
public string Image { get; set; }
public:
property String^ Image {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Image ()

/** @property */
public void set_Image (String value)

public function get Image () : String

public function set Image (value : String)

Property Value

A string value that represents the URL of an image file. The default value is an empty string.

Remarks

This property determines the image file to be used for the LegendItem symbol.

The path can be an absolute or a relative URL.

If you set a background image, that image will be displayed regardless of the ImageStyle property setting.

Set the BackImageTransparentColor property to enable one color used by the image to appear transparent.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.ImageStyle Property

LegendItem.ImageStyle Property |
 | See Also

Gets or sets the display style of the legend item image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ImageStyle As LegendImageStyle
public LegendImageStyle ImageStyle { get; set; }
public:
property LegendImageStyle ImageStyle {
    LegendImageStyle get ();
    void set (LegendImageStyle value);
}
/** @property */
public LegendImageStyle get_ImageStyle ()

/** @property */
public void set_ImageStyle (LegendImageStyle value)

public function get ImageStyle () : LegendImageStyle

public function set ImageStyle (value : LegendImageStyle)

Property Value

A LegendImageStyle enumeration value.

Remarks

These styles determine how the item's corresponding symbol will be displayed.

A Line style can be combined with a Marker style. To accomplish this, first set the ImageStyle property to Line. Then use the MarkerImage property to specify a marker image, or the MarkerStyle property to specify a marker style. The resulting symbol will be a combination of a line and an image or marker.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Legend Property

LegendItem.Legend Property |
 | See Also

Gets or sets the Legend object associated with this legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Legend As Legend
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Legend Legend { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property Legend^ Legend {
    Legend^ get ();
}
/** @property */
public Legend get_Legend ()

public function get Legend () : Legend

Property Value

A Legend object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerBorderColor Property

LegendItem.MarkerBorderColor Property |
 | See Also

Gets or sets the border color of the markers, if used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerBorderColor As Color
public Color MarkerBorderColor { get; set; }
public:
property Color MarkerBorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerBorderColor ()

/** @property */
public void set_MarkerBorderColor (Color value)

public function get MarkerBorderColor () : Color

public function set MarkerBorderColor (value : Color)

Property Value

A Color value that represents the ARGB (alpha, red, green, blue) color of a marker border.

Remarks

To use markers, set the MarkerStyle property to a value other than None.

Note that markers will not be applied to pie, doughnut, and any stacked chart types.

For custom legends, the BorderColor property will also set the border color of markers. The MarkerBorderColor property setting has precedence over the BorderColor property setting.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerBorderWidth Property

LegendItem.MarkerBorderWidth Property |
 | See Also

Gets or sets the border width of the markers, if used. Measured in pixels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerBorderWidth As Integer
public int MarkerBorderWidth { get; set; }
public:
property int MarkerBorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerBorderWidth ()

/** @property */
public void set_MarkerBorderWidth (int value)

public function get MarkerBorderWidth () : int

public function set MarkerBorderWidth (value : int)

Property Value

An integer value. The default value is one (1) pixel.

Remarks

This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerColor Property

LegendItem.MarkerColor Property |
 | See Also

Gets or sets the color of the markers, if used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerColor As Color
public Color MarkerColor { get; set; }
public:
property Color MarkerColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerColor ()

/** @property */
public void set_MarkerColor (Color value)

public function get MarkerColor () : Color

public function set MarkerColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerImage Property

LegendItem.MarkerImage Property |
 | See Also

Gets or sets a marker image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerImage As String
public string MarkerImage { get; set; }
public:
property String^ MarkerImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MarkerImage ()

/** @property */
public void set_MarkerImage (String value)

public function get MarkerImage () : String

public function set MarkerImage (value : String)

Property Value

A string value that represents the URL of an image file.

Remarks

Represents a path to an image file, which can be an absolute or relative URL.

To use markers, set the MarkerStyle property to a value other than None.

The MarkerImage property takes precedence over the MarkerColor property.

A marker image can be any valid graphics file supported by .NET Framework, including icons.

To set one color of the marker image to be transparent, use the MarkerImageTransparentColor property.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerImageTransparentColor Property

LegendItem.MarkerImageTransparentColor Property |
 | See Also

Gets or sets a color that will be replaced with a transparent color when the marker image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerImageTransparentColor As Color
public Color MarkerImageTransparentColor { get; set; }
public:
property Color MarkerImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_MarkerImageTransparentColor ()

/** @property */
public void set_MarkerImageTransparentColor (Color value)

public function get MarkerImageTransparentColor () : Color

public function set MarkerImageTransparentColor (value : Color)

Property Value

A T:System.Drawing.Color value that represents an ARGB (alpha, red, green, blue) color.

Remarks

The MarkerImageTransparentColor property is used to select one color in a marker image that will be displayed as transparent.

You can set this property to any valid ARGB (alpha, red, green, blue) value.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerSize Property

LegendItem.MarkerSize Property |
 | See Also

Gets or sets the size of the legend item markers, if used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerSize As Integer
public int MarkerSize { get; set; }
public:
property int MarkerSize {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerSize ()

/** @property */
public void set_MarkerSize (int value)

public function get MarkerSize () : int

public function set MarkerSize (value : int)

Property Value

An integer expression that represents the height and width of the plotting area of markers, in pixels. The default value is 5 pixels.

Remarks

To use markers, set the MarkerStyle property to a value other than None.

Note that markers will not be applied to data points of pie, doughnut and any stacked chart types.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.MarkerStyle Property

LegendItem.MarkerStyle Property |
 | See Also

Gets or sets a legend item marker style. Also used to enable or disable the display of markers.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerStyle As MarkerStyle
public MarkerStyle MarkerStyle { get; set; }
public:
property MarkerStyle MarkerStyle {
    MarkerStyle get ();
    void set (MarkerStyle value);
}
/** @property */
public MarkerStyle get_MarkerStyle ()

/** @property */
public void set_MarkerStyle (MarkerStyle value)

public function get MarkerStyle () : MarkerStyle

public function set MarkerStyle (value : MarkerStyle)

Property Value

A MarkerStyle integer enumeration. The default value is None.

Remarks

To disable markers, set this property to None.

Note:
This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.Name Property

LegendItem.Name Property |
 | See Also

Gets or sets the name of the legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the name of the legend item.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.SeparatorColor Property

LegendItem.SeparatorColor Property |
 | See Also

Gets or sets the color of the legend item separator.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SeparatorColor As Color
public Color SeparatorColor { get; set; }
public:
property Color SeparatorColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_SeparatorColor ()

/** @property */
public void set_SeparatorColor (Color value)

public function get SeparatorColor () : Color

public function set SeparatorColor (value : Color)

Property Value

A Color value used to draw the color of the legend item separator. The default value is Black.

Remarks

This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.SeparatorType Property

LegendItem.SeparatorType Property |
 | See Also

Gets or sets the separator style of the legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property SeparatorType As LegendSeparatorStyle
public LegendSeparatorStyle SeparatorType { get; set; }
public:
property LegendSeparatorStyle SeparatorType {
    LegendSeparatorStyle get ();
    void set (LegendSeparatorStyle value);
}
/** @property */
public LegendSeparatorStyle get_SeparatorType ()

/** @property */
public void set_SeparatorType (LegendSeparatorStyle value)

public function get SeparatorType () : LegendSeparatorStyle

public function set SeparatorType (value : LegendSeparatorStyle)

Property Value

A LegendSeparatorStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.SeriesName Property

LegendItem.SeriesName Property |
 | See Also

Gets or sets the name of the Series associated with a default legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property SeriesName As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string SeriesName { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property String^ SeriesName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_SeriesName ()

/** @property */
public void set_SeriesName (String value)

public function get SeriesName () : String

public function set SeriesName (value : String)

Property Value

A string value that determines the name of the series associated with a default legend item. The default value is a zero-length string.

Remarks

This property should only be used in the CustomizeLegend event, to determine which data series a default legend entry represents.

The SeriesName property applies to all charts except pie and sphere charts; their default legend items correspond to plotted data points, and not to plotted series. When you deal with pie and sphere charts, use the SeriesPointIndex property instead.

This property should not be set by the developer.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.SeriesPointIndex Property

LegendItem.SeriesPointIndex Property |
 | See Also

Gets or sets the index of a DataPoint object associated with a default legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property SeriesPointIndex As Integer
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int SeriesPointIndex { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property int SeriesPointIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_SeriesPointIndex ()

/** @property */
public void set_SeriesPointIndex (int value)

public function get SeriesPointIndex () : int

public function set SeriesPointIndex (value : int)

Property Value

An integer value that represents the location of the default legend's associated data point in a zero-based index. All chart types except for pie and doughnut charts will return a negative one (-1).

Remarks

This property should only be used in the CustomizeLegend event to determine the DataPoint object that is represented by a default pie or sphere chart legend entry.

Chart types other than pie or sphere charts will return a negative one (-1), because the default legend items correspond to plotted series, and not plotted data points. Use the SeriesName property for these chart types.

This property should not be set by the developer.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.ShadowColor Property

LegendItem.ShadowColor Property |
 | See Also

Gets or sets the shadow color of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

Gets or sets the shadow color of several chart elements, and can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try using a color of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Note This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.ShadowOffset Property

LegendItem.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of a legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset, in pixels, of the relevant chart element.

Remarks

To implement shadowing, use a value other than zero (0). A positive value will result in a shadow that shifts down and to the right. A negative value will result in a shadow that shifts up and to the left.

Note This property is applicable only to LegendCell objects with a LegendCellType of either SeriesSymbol or Image.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItem.ToolTip Property

LegendItem.ToolTip Property |
 | See Also

Gets or sets the tooltip of the legend item.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip for the legend item.

Remarks

This property allows you to set special keywords to display different types of chart-related data.

Note:
This property is applicable to the entire LegendItem.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItem Class
LegendItem Members


LegendItemOrder Enumeration

LegendItemOrder Enumeration |
 | See Also

Specifies the order in which items are added to the legend.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendItemOrder
public enum LegendItemOrder
public enum class LegendItemOrder
public enum LegendItemOrder
public enum LegendItemOrder

Members

Member name | Description
Auto | The chart automatically determines the order in which items are added to the legend.
ReversedSeriesOrder | Items are added to the legend in the reverse order of items added to the chart series.
SameAsSeriesOrder | Items are added to the legend in the same order as items added to the chart series.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LegendItemsCollection Class

LegendItemsCollection Class |
 | See Also Members

Represents a collection of LegendItem objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LegendItemsCollection
    Inherits ChartElementCollection(Of LegendItem)
public class LegendItemsCollection : ChartElementCollection<LegendItem>
public ref class LegendItemsCollection : public ChartElementCollection<LegendItem^>
public class LegendItemsCollection extends ChartElementCollection<LegendItem>
public class LegendItemsCollection extends ChartElementCollection<LegendItem>

Remarks

The LegendItemsCollection class represents a collection of LegendItem objects, which in turn represent items in a legend.

This collection class is exposed in two ways:

  • As the CustomItems object property of the Legend object, which can be used to add, delete or modify custom legend items. The term "custom" refers to legend items that have user-defined text, symbol color, and so forth. In comparison, "default" legend items are items that are automatically inserted into the legend and represent a data series or data point. Default legend item entries for pie and doughnut charts represent the plotted data points, whereas item entries for all other chart types represent the plotted series. The CustomItems property is available at both design time and run time.

  • In the CustomizeLegend event, as the LegendItems property of the CustomizeLegendEventArgs parameter. The LegendItems property stores both default legend items and custom legend items that have been added to the Chart control at design time. Legend items can be modified or deleted; in addition, their order can be changed.

To add legend items to the collection, use one of the overloaded Add and Insert methods in this class.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.LegendItemsCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Members


LegendItemsCollection Members

LegendItemsCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of LegendItem objects.

The following tables list the members exposed by the LegendItemsCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
Reverse | Reverses the order of items in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

LegendItemsCollection Class


LegendItemsCollection Methods

LegendItemsCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | Overloaded.
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
Reverse | Reverses the order of items in the collection.
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

LegendItemsCollection Class


LegendItemsCollection.Add Method

LegendItemsCollection.Add Method |
 | See Also

Overload List

Name | Description
LegendItemsCollection.Add (LegendItem) | (inherited from Add )
LegendItemsCollection.Add (Color, String) | Adds a custom LegendItem object to the end of the collection.
LegendItemsCollection.Add (String, String) | Adds a custom LegendItem object with the specified image to the end of the collection.

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection.Add Method (Color, String)

LegendItemsCollection.Add Method (Color, String) |
 | See Also

Adds a custom LegendItem object to the end of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    color As Color, _
    text As String _
) As Integer
public int Add (
    Color color,
    string text
)
public:
int Add (
    Color color,
    String^ text
)
public int Add (
    Color color,
    String text
)
public function Add (
    color : Color,
    text : String
) : int

Parameters

color

The symbol color of the legend item.

text

The legend item text.

Return Value

An integer that represents the location in the zero-based index where the item was inserted into the collection.

Remarks

Appends a custom legend item with the specified text and symbol color to the end of the collection.

To add a custom legend item that uses an image for its symbol, call the Add method.

To insert a custom LegendItem object into the collection, use one of the Insert methods in this class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection.Add Method (String, String)

LegendItemsCollection.Add Method (String, String) |
 | See Also

Adds a custom LegendItem object with the specified image to the end of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    image As String, _
    text As String _
) As Integer
public int Add (
    string image,
    string text
)
public:
int Add (
    String^ image,
    String^ text
)
public int Add (
    String image,
    String text
)
public function Add (
    image : String,
    text : String
) : int

Parameters

image

The absolute or relative URL of the image file to be used for the legend item symbol.

text

The legend item text.

Return Value

An integer that represents the location in the zero-based index where the item was inserted into the collection.

Remarks

Appends a custom legend item to the collection with the specified text and image to be used as the symbol for the legend item.

To add a custom legend item that uses a color for its symbol, call the Add method.

To insert a LegendItem object into the collection use one of the Insert methods in this class.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection.Insert Method

LegendItemsCollection.Insert Method |
 | See Also

Overload List

Name | Description
LegendItemsCollection.Insert (Int32, LegendItem) | (inherited from Insert )
LegendItemsCollection.Insert (Int32, Color, String) | Inserts a LegendItem object with the specified text and symbol color into the collection at the specified location.
LegendItemsCollection.Insert (Int32, String, String) | Inserts a LegendItem object with the specified text and symbol image into the collection at the specified location.

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection.Insert Method (Int32, Color, String)

LegendItemsCollection.Insert Method (Int32, Color, String) |
 | See Also

Inserts a LegendItem object with the specified text and symbol color into the collection at the specified location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Insert ( _
    index As Integer, _
    color As Color, _
    text As String _
)
public void Insert (
    int index,
    Color color,
    string text
)
public:
void Insert (
    int index,
    Color color,
    String^ text
)
public void Insert (
    int index,
    Color color,
    String text
)
public function Insert (
    index : int,
    color : Color,
    text : String
)

Parameters

index

The location in the zero-based index where the LegendItem object is to be inserted.

color

The symbol color of the legend item.

text

The legend item text.

Remarks

Inserts a custom legend item into the collection at the specified location using the specified text and symbol color.

To insert a legend item that uses an image for its symbol, use the Insert method.

Use the Add method to append a LegendItem object that uses a color for its symbol to the end if the collection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection.Insert Method (Int32, String, String)

LegendItemsCollection.Insert Method (Int32, String, String) |
 | See Also

Inserts a LegendItem object with the specified text and symbol image into the collection at the specified location.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Insert ( _
    index As Integer, _
    image As String, _
    text As String _
)
public void Insert (
    int index,
    string image,
    string text
)
public:
void Insert (
    int index,
    String^ image,
    String^ text
)
public void Insert (
    int index,
    String image,
    String text
)
public function Insert (
    index : int,
    image : String,
    text : String
)

Parameters

index

The location in the zero-based index where the LegendItem object is to be inserted.

image

The absolute or relative URL of the image file to be used for the legend item symbol.

text

The legend item text.

Remarks

Inserts a custom legend item into the collection at the specified location using the specified text and image for the symbol.

To insert a legend item that uses a color for its symbol, use the Insert method.

Use the Add method to append a LegendItem object with a symbol image to the end if the collection.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection.Reverse Method

LegendItemsCollection.Reverse Method |
 | See Also

Reverses the order of items in the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Reverse
public void Reverse ()
public:
void Reverse ()
public void Reverse ()
public function Reverse ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection Properties

LegendItemsCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

LegendItemsCollection Class


LegendSeparatorStyle Enumeration

LegendSeparatorStyle Enumeration |
 | See Also

Specifies the styles for legend separator lines.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendSeparatorStyle
public enum LegendSeparatorStyle
public enum class LegendSeparatorStyle
public enum LegendSeparatorStyle
public enum LegendSeparatorStyle

Members

Member name | Description
DashLine | Legend separator is a dashed line.
DotLine | Legend separator is a dotted line.
DoubleLine | Legend separator is a double line.
GradientLine | Legend separator is a solid line with a gradient on the ends.
Line | Legend separator is a solid line.
None | No separator will be shown.
ThickGradientLine | Legend separator is a thick solid line with a gradient on the ends.
ThickLine | Legend separator is a thick solid line.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LegendStyle Enumeration

LegendStyle Enumeration |
 | See Also

Specifies the legend style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendStyle
public enum LegendStyle
public enum class LegendStyle
public enum LegendStyle
public enum LegendStyle

Members

Member name | Description
Column | Legend items are displayed using one column and multiple rows.
Row | Legend items are displayed using multiple columns and one row.
Table | Legend items are displayed using multiple columns and multiple rows.

Remarks

The LegendStyle enumeration represents a legend style, and is used in conjunction with the LegendStyle property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LegendTableStyle Enumeration

LegendTableStyle Enumeration |
 | See Also

Specifies the legend table style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LegendTableStyle
public enum LegendTableStyle
public enum class LegendTableStyle
public enum LegendTableStyle
public enum LegendTableStyle

Members

Member name | Description
Auto | The legend table style is automatically determined by the Chart control.
Tall | Legend items will be fit vertically within the legend. This style is preferred when Docking is set to Left or Right.
Wide | Legend items will be fit horizontally within the legend. This style is preferred when Docking is set to Top or Bottom.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LightStyle Enumeration

LightStyle Enumeration |
 | See Also

Specifies a lighting style for a three-dimensional (3D) chart area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LightStyle
public enum LightStyle
public enum class LightStyle
public enum LightStyle
public enum LightStyle

Members

Member name | Description
None | No lighting is applied.
Realistic | A realistic lighting style is applied, where the hue of all chart area elements changes depending on the amount of rotation.
Simplistic | A simplistic lighting style is applied, where the hue of all chart area elements is fixed.

Remarks

The LightStyle enumeration is used with the LightStyle property to set the lighting style of a 3D chart area.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LineAnchorCapStyle Enumeration

LineAnchorCapStyle Enumeration |
 | See Also

Specifies the shape—that is, the anchor cap—to draw on the point end of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration LineAnchorCapStyle
public enum LineAnchorCapStyle
public enum class LineAnchorCapStyle
public enum LineAnchorCapStyle
public enum LineAnchorCapStyle

Members

Member name | Description
Arrow | Anchor cap will be drawn with an arrowhead.
Diamond | Anchor cap will be drawn with a diamond-shaped end.
None | Anchor cap will not be drawn.
Round | Anchor cap will be drawn with a round end.
Square | Anchor cap will be drawn with a square head.

Remarks

The LineAnchorCapStyle enumeration represents the shape to be drawn on the point end of the label callout line. It is used in conjunction with the CalloutStyle and the CalloutLineAnchorCapStyle properties. If a callout line is not used, this enumeration will have no effect.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


LineAnnotation Class

LineAnnotation Class |
 | See Also Members

Represents a line annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class LineAnnotation
    Inherits Annotation
public class LineAnnotation : Annotation
public ref class LineAnnotation : public Annotation
public class LineAnnotation extends Annotation
public class LineAnnotation extends Annotation

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.LineAnnotation
System.Windows.Forms.DataVisualization.Charting.HorizontalLineAnnotation
System.Windows.Forms.DataVisualization.Charting.VerticalLineAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Members


LineAnnotation Members

LineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a line annotation.

The following tables list the members exposed by the LineAnnotation type.

Public Constructors

Name | Description
LineAnnotation | Initializes a new instance of the LineAnnotation class.
Top

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the line annotation type.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Overridden. Gets or sets the position alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the type of annotation. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the line annotation type.
BackGradientStyle | Overridden. This property is not applicable to the line annotation type.
BackHatchStyle | Overridden. This property is not applicable to the line annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the line annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the line annotation type.
ForeColor | Overridden. This property is not applicable to the line annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. This property is not applicable to the line annotation type.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LineAnnotation Class


LineAnnotation Constructor

LineAnnotation Constructor |
 | See Also

Initializes a new instance of the LineAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public LineAnnotation ()
public:
LineAnnotation ()
public LineAnnotation ()
public function LineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation Methods

LineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LineAnnotation Class


LineAnnotation Properties

LineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the line annotation type.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Overridden. Gets or sets the position alignment of an annotation to the anchor point.
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the type of annotation. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the line annotation type.
BackGradientStyle | Overridden. This property is not applicable to the line annotation type.
BackHatchStyle | Overridden. This property is not applicable to the line annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the line annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the line annotation type.
ForeColor | Overridden. This property is not applicable to the line annotation type.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Overridden. Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. This property is not applicable to the line annotation type.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

LineAnnotation Class


LineAnnotation.Alignment Property

LineAnnotation.Alignment Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Alignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment Alignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.AnchorAlignment Property

LineAnnotation.AnchorAlignment Property |
 | See Also

Gets or sets the position alignment of an annotation to the anchor point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property AnchorAlignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment AnchorAlignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment AnchorAlignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_AnchorAlignment ()

/** @property */
public void set_AnchorAlignment (ContentAlignment value)

public override function get AnchorAlignment () : ContentAlignment

public override function set AnchorAlignment (value : ContentAlignment)

Property Value

A ContentAlignment value that represents the annotation alignment to the anchor point.

Remarks

The annotation must be anchored using either AnchorDataPoint, or the AnchorX and AnchorY properties. Its X and Y properties must be set to NaN.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.AnnotationType Property

LineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the type of annotation. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.BackColor Property

LineAnnotation.BackColor Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.BackGradientStyle Property

LineAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.BackHatchStyle Property

LineAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.BackSecondaryColor Property

LineAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.EndCap Property

LineAnnotation.EndCap Property |
 | See Also

Gets or sets a style for the anchor cap at the end of the annotation line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property EndCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle EndCap { get; set; }
public:
virtual property LineAnchorCapStyle EndCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_EndCap ()

/** @property */
public void set_EndCap (LineAnchorCapStyle value)

public function get EndCap () : LineAnchorCapStyle

public function set EndCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value that represents the style to apply to the anchor cap at the end of the line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.Font Property

LineAnnotation.Font Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.ForeColor Property

LineAnnotation.ForeColor Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.IsInfinitive Property

LineAnnotation.IsInfinitive Property |
 | See Also

Gets or sets a flag that indicates whether an infinite line should be drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsInfinitive As Boolean
public virtual bool IsInfinitive { get; set; }
public:
virtual property bool IsInfinitive {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsInfinitive ()

/** @property */
public void set_IsInfinitive (boolean value)

public function get IsInfinitive () : boolean

public function set IsInfinitive (value : boolean)

Property Value

True if a line should be drawn infinitely through two points provided, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.IsSizeAlwaysRelative Property

LineAnnotation.IsSizeAlwaysRelative Property |
 | See Also

Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property IsSizeAlwaysRelative As Boolean
public override bool IsSizeAlwaysRelative { get; set; }
public:
virtual property bool IsSizeAlwaysRelative {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_IsSizeAlwaysRelative ()

/** @property */
public void set_IsSizeAlwaysRelative (boolean value)

public override function get IsSizeAlwaysRelative () : boolean

public override function set IsSizeAlwaysRelative (value : boolean)

Property Value

True if the Width and Height of an annotation are always in chart relative coordinates, otherwise false.

Remarks

The width and height of an annotation may be set in relative chart or in axes coordinates. By default, relative chart coordinates are used. To use axes coordinates for the annotation size, set the IsSizeAlwaysRelative property to false. Then anchor the annotation to a data point or set the AxisX or AxisY properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.StartCap Property

LineAnnotation.StartCap Property |
 | See Also

Gets or sets a style for the anchor cap at the start of an annotation line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property StartCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle StartCap { get; set; }
public:
virtual property LineAnchorCapStyle StartCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_StartCap ()

/** @property */
public void set_StartCap (LineAnchorCapStyle value)

public function get StartCap () : LineAnchorCapStyle

public function set StartCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value that represents the style to apply to the anchor cap at the start of the line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


LineAnnotation.TextStyle Property

LineAnnotation.TextStyle Property |
 | See Also

This property is not applicable to the line annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

LineAnnotation Class
LineAnnotation Members


Margins Class

Margins Class |
 | See Also Members

Represents the margins for various chart elements.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Margins
public class Margins
public ref class Margins
public class Margins
public class Margins

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.Margins

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Members


Margins Members

Margins Members |
 | See Also Constructors Methods Properties

Represents the margins for various chart elements.

The following tables list the members exposed by the Margins type.

Public Constructors

Name | Description
Margins | Overloaded. Initializes a new instance of the Margins class.
Top

Public Properties

Name | Description
Bottom | Gets or sets the bottom margin.
Left | Gets or sets the left margin.
Right | Gets or sets the right margin.
Top | Gets or sets the top margin.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden. Determines whether the specified object is equal to the current object.
GetHashCode | Overridden. Gets the hash code for the Margins object.
GetType | (inherited from Object )
IsEmpty | Determines whether the margins are empty.
ReferenceEquals | (inherited from Object )
ToRectangleF | Converts a Margins object to a RectangleF object.
ToString | Overridden. Converts a Margins object to its string representation.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Margins Class


Margins Constructor

Margins Constructor |
 | See Also

Initializes a new instance of the Margins class.

Overload List

Name | Description
Margins () | Initializes a new instance of the Margins class.
Margins (Int32, Int32, Int32, Int32) | Initializes a new instance of the Margins class with the specified top, bottom, left and right coordinates of the margin.

See Also

Reference

Margins Class
Margins Members


Margins Constructor ()

Margins Constructor () |
 | See Also

Initializes a new instance of the Margins class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Margins ()
public:
Margins ()
public Margins ()
public function Margins ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins Constructor (Int32, Int32, Int32, Int32)

Margins Constructor (Int32, Int32, Int32, Int32) |
 | See Also

Initializes a new instance of the Margins class with the specified top, bottom, left and right coordinates of the margin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    top As Integer, _
    bottom As Integer, _
    left As Integer, _
    right As Integer _
)
public Margins (
    int top,
    int bottom,
    int left,
    int right
)
public:
Margins (
    int top,
    int bottom,
    int left,
    int right
)
public Margins (
    int top,
    int bottom,
    int left,
    int right
)
public function Margins (
    top : int,
    bottom : int,
    left : int,
    right : int
)

Parameters

top

Top margin.

bottom

Bottom margin.

left

Left margin.

right

Right margin.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins Methods

Margins Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden. Determines whether the specified object is equal to the current object.
GetHashCode | Overridden. Gets the hash code for the Margins object.
GetType | (inherited from Object )
IsEmpty | Determines whether the margins are empty.
ReferenceEquals | (inherited from Object )
ToRectangleF | Converts a Margins object to a RectangleF object.
ToString | Overridden. Converts a Margins object to its string representation.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Margins Class


Margins.Equals Method

Margins.Equals Method |
 | See Also

Determines whether the specified object is equal to the current object.

Overload List

Name | Description
Margins.Equals (Object) | Determines whether the specified object is equal to the current object.
Margins.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

Margins Class
Margins Members


Margins.Equals Method (Object)

Margins.Equals Method (Object) |
 | See Also

Determines whether the specified object is equal to the current object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public override bool Equals (
    Object obj
)
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual bool Equals (
    Object^ obj
) override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public boolean Equals (
    Object obj
)
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

The object to compare with the current object.

Return Value

True if the specified object is equal to the current object, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.GetHashCode Method

Margins.GetHashCode Method |
 | See Also

Gets the hash code for the Margins object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Overrides Function GetHashCode As Integer
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public override int GetHashCode ()
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual int GetHashCode () override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public int GetHashCode ()
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public override function GetHashCode () : int

Return Value

An integer value that represents the hash code for a Margins object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.IsEmpty Method

Margins.IsEmpty Method |
 | See Also

Determines whether the margins are empty.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function IsEmpty As Boolean
public bool IsEmpty ()
public:
bool IsEmpty ()
public boolean IsEmpty ()
public function IsEmpty () : boolean

Return Value

True if all margins values are zero, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.ToRectangleF Method

Margins.ToRectangleF Method |
 | See Also

Converts a Margins object to a RectangleF object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ToRectangleF As RectangleF
public RectangleF ToRectangleF ()
public:
RectangleF ToRectangleF ()
public RectangleF ToRectangleF ()
public function ToRectangleF () : RectangleF

Return Value

A RectangleF object that has margins.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.ToString Method

Margins.ToString Method |
 | See Also

Converts a Margins object to its string representation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")> _
Public Overrides Function ToString As String
[SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public override string ToString ()
[SuppressMessageAttribute(L"Microsoft.Security", L"CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")]
public:
virtual String^ ToString () override
/** @attribute SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase") */
public String ToString ()
SuppressMessageAttribute("Microsoft.Security", "CA2123:OverrideLinkDemandsShouldBeIdenticalToBase")
public override function ToString () : String

Return Value

A string value that represents this object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins Properties

Margins Properties |
 | See Also

Public Properties

Name | Description
Bottom | Gets or sets the bottom margin.
Left | Gets or sets the left margin.
Right | Gets or sets the right margin.
Top | Gets or sets the top margin.

See Also

Reference

Margins Class


Margins.Bottom Property

Margins.Bottom Property |
 | See Also

Gets or sets the bottom margin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Bottom As Integer
public int Bottom { get; set; }
public:
property int Bottom {
    int get ();
    void set (int value);
}
/** @property */
public int get_Bottom ()

/** @property */
public void set_Bottom (int value)

public function get Bottom () : int

public function set Bottom (value : int)

Property Value

Returns an integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.Left Property

Margins.Left Property |
 | See Also

Gets or sets the left margin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Left As Integer
public int Left { get; set; }
public:
property int Left {
    int get ();
    void set (int value);
}
/** @property */
public int get_Left ()

/** @property */
public void set_Left (int value)

public function get Left () : int

public function set Left (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.Right Property

Margins.Right Property |
 | See Also

Gets or sets the right margin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Right As Integer
public int Right { get; set; }
public:
property int Right {
    int get ();
    void set (int value);
}
/** @property */
public int get_Right ()

/** @property */
public void set_Right (int value)

public function get Right () : int

public function set Right (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


Margins.Top Property

Margins.Top Property |
 | See Also

Gets or sets the top margin.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Top As Integer
public int Top { get; set; }
public:
property int Top {
    int get ();
    void set (int value);
}
/** @property */
public int get_Top ()

/** @property */
public void set_Top (int value)

public function get Top () : int

public function set Top (value : int)

Property Value

An integer value. The default value is 0.

Remarks

When used for legend cells, the margins are measured as a percentage of the legend's font size.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Margins Class
Margins Members


MarkerStyle Enumeration

MarkerStyle Enumeration |
 | See Also

Specifies a style for markers.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration MarkerStyle
public enum MarkerStyle
public enum class MarkerStyle
public enum MarkerStyle
public enum MarkerStyle

Members

Member name | Description
Circle | A circular marker is displayed.
Cross | A cross-shaped marker is displayed.
Diamond | A diamond-shaped marker is displayed.
None | No marker is displayed for the series or data point.
Square | A square marker is displayed.
Star10 | A 10-point star-shaped marker is displayed.
Star4 | A 4-point star-shaped marker is displayed.
Star5 | A 5-point star-shaped marker is displayed.
Star6 | A 6-point star-shaped marker is displayed.
Triangle | A triangular marker is displayed.

Remarks

The MarkerStyle enumeration represents a style that is used for a series or data point marker. It is used in conjunction with the MarkerStyle property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


NamedImage Class

NamedImage Class |
 | See Also Members

Represents named images, which are stored in the NamedImagesCollection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class NamedImage
    Inherits ChartNamedElement
public class NamedImage : ChartNamedElement
public ref class NamedImage : public ChartNamedElement
public class NamedImage extends ChartNamedElement
public class NamedImage extends ChartNamedElement

Remarks

The NamedImage class represents an image that has a unique name, and is useful when an image is dynamically created using a particular drawing routine, and then specified as the image for one of the image properties of the Chart control.

The Name property determines the unique name of a NamedImage object. The Image property determines its associated image, which can be any object derived from the .NET Framework Image class.

When one of the image properties of the Chart control is set by specifying a string value, the Images collection property is first checked to determine whether an image with the specified name exists. If a matching NamedImage object is found, this image is used. If a matching NamedImage object is not located, the string value is treated as a URL, image resource name, or an image path.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.NamedImage

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Members


NamedImage Members

NamedImage Members |
 | See Also Constructors Methods Properties

Represents named images, which are stored in the NamedImagesCollection.

The following tables list the members exposed by the NamedImage type.

Public Constructors

Name | Description
NamedImage | Overloaded.
Top

Public Properties

Name | Description
Image | Gets or sets the image of a NamedImage object.
Name | Overridden. Gets or sets the unique name of a NamedImage object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

NamedImage Class


NamedImage Constructor

NamedImage Constructor |
 | See Also

Overload List

Name | Description
NamedImage () | Initializes a new instance of the NamedImage class.
NamedImage (String, Image) | Initializes a new instance of the NamedImage class with the specified name of the named image and its associated image.

See Also

Reference

NamedImage Class
NamedImage Members


NamedImage Constructor ()

NamedImage Constructor () |
 | See Also

Initializes a new instance of the NamedImage class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public NamedImage ()
public:
NamedImage ()
public NamedImage ()
public function NamedImage ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members


NamedImage Constructor (String, Image)

NamedImage Constructor (String, Image) |
 | See Also

Initializes a new instance of the NamedImage class with the specified name of the named image and its associated image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String, _
    image As Image _
)
public NamedImage (
    string name,
    Image image
)
public:
NamedImage (
    String^ name,
    Image^ image
)
public NamedImage (
    String name,
    Image image
)
public function NamedImage (
    name : String,
    image : Image
)

Parameters

name

The name of the named image. Use this name when setting a named image to one of the image properties.

image

The associated image.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members


NamedImage Methods

NamedImage Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

NamedImage Class


NamedImage.Dispose Method

NamedImage.Dispose Method |
 | See Also

Overload List

Name | Description
NamedImage.Dispose () | (inherited from Dispose )
NamedImage.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

NamedImage Class
NamedImage Members


NamedImage.Dispose Method (Boolean)

NamedImage.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members


NamedImage Properties

NamedImage Properties |
 | See Also

Public Properties

Name | Description
Image | Gets or sets the image of a NamedImage object.
Name | Overridden. Gets or sets the unique name of a NamedImage object.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )

See Also

Reference

NamedImage Class


NamedImage.Image Property

NamedImage.Image Property |
 | See Also

Gets or sets the image of a NamedImage object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Image As Image
public Image Image { get; set; }
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
/** @property */
public Image get_Image ()

/** @property */
public void set_Image (Image value)

public function get Image () : Image

public function set Image (value : Image)

Property Value

The image component of a NamedImage object. This can be any object derived from the .NET Framework Image class, for example, a Bitmap object.

Remarks

The Image property determines which image is stored in a NamedImage object.

Use NamedImage objects for dynamically created images, which can then be assigned to a chart image property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members


NamedImage.Name Property

NamedImage.Name Property |
 | See Also

Gets or sets the unique name of a NamedImage object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the unique name of a NamedImage object stored in the NamedImagesCollection.

Remarks

The property identifies a NamedImage object that is stored in the NamedImagesCollection. This name must be unique, or an exception will be thrown when the object is added to the collection.

Use NamedImage objects for dynamically created images, which can then be assigned to a chart image property.

This Name property value is used when you set a chart image property to a NamedImage object.

When one of the image properties of the Chart control is set by specifying a string value, the Images collection property—of type NamedImagesCollection—is first checked to determine whether an image with the specified name exists. If a matching NamedImage object is found, this image is used. If a matching NamedImage object is not located, the string value is treated as a URL, an image resource name, or an image path.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImage Class
NamedImage Members


NamedImagesCollection Class

NamedImagesCollection Class |
 | See Also Members

Represents a collection of NamedImage objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class NamedImagesCollection
    Inherits ChartNamedElementCollection(Of NamedImage)
public class NamedImagesCollection : ChartNamedElementCollection<NamedImage>
public ref class NamedImagesCollection : public ChartNamedElementCollection<NamedImage^>
public class NamedImagesCollection extends ChartNamedElementCollection<NamedImage>
public class NamedImagesCollection extends ChartNamedElementCollection<NamedImage>

Remarks

The NamedImagesCollection class represents a collection of NamedImage objects, which are objects that have an associated image and a name that is unique to the collection.

This class is exposed as the Images collection property of the root Chart object, and is only available at run time.

An image can be any object derived from the .NET Framework Image class, such as Bitmap, which is created dynamically. The image can be stored in this collection, and then assigned at a later time to any image property in the Chart control, such as BackImage.

When one of the image properties in the Chart control is set by specifying a string value, the Images collection property, of type NamedImagesCollection, is first checked to see if an image with that name exists. If a matching NamedImage object is found, this image is used. If a matching NamedImage object is not located, the string expression is treated as a URL, image resource name or pathname.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.NamedImagesCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

NamedImagesCollection Members


NamedImagesCollection Members

NamedImagesCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of NamedImage objects.

The following tables list the members exposed by the NamedImagesCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

NamedImagesCollection Class


NamedImagesCollection Methods

NamedImagesCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

NamedImagesCollection Class


NamedImagesCollection Properties

NamedImagesCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

NamedImagesCollection Class


Point3D Class

Point3D Class |
 | See Also Members

Represents the coordinates of a three-dimensional (3D) data point. This class is used when performing custom drawing with 3D charts.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Point3D
public class Point3D
public ref class Point3D
public class Point3D
public class Point3D

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from relative X, Y and Z (3D) coordinates into relative X and Y (2D) coordinates using the TransformPoints method. By calling TransformPoints, the X and Y-values of the Point3D objects are changed so that they reflect the 3-dimensional space. The new X and Y points can then be used for GDI+ method calls—the Z value is then disregarded—after being changed to absolute pixel coordinates using the GetAbsolutePoint method.

Note that the Z coordinate may be less than zero (located behind a chart area) or greater than 100 (located in front of a chart area).

To both enable 3D charts and work with their styles, use the Area3DStyle property. The Point3D class is not used for 3D styles.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.Point3D

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Members


Point3D Members

Point3D Members |
 | See Also Constructors Methods Properties

Represents the coordinates of a three-dimensional (3D) data point. This class is used when performing custom drawing with 3D charts.

The following tables list the members exposed by the Point3D type.

Public Constructors

Name | Description
Point3D | Overloaded.
Top

Public Properties

Name | Description
PointF | Gets or sets a PointF structure, which stores the X and Y coordinates of a 3D point.
X | Gets or sets the X coordinate of a 3D point.
Y | Gets or sets the Y coordinate of a 3D point.
Z | Gets or sets the Z coordinate of a 3D point.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Point3D Class


Point3D Constructor

Point3D Constructor |
 | See Also

Overload List

Name | Description
Point3D () | Initializes a new instance of the Point3D class.
Point3D (Single, Single, Single) | Initializes a new instance of the AnnotationPathPoint class with the specified X, Y and Z coordinates.

See Also

Reference

Point3D Class
Point3D Members


Point3D Constructor ()

Point3D Constructor () |
 | See Also

Initializes a new instance of the Point3D class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Point3D ()
public:
Point3D ()
public Point3D ()
public function Point3D ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members


Point3D Constructor (Single, Single, Single)

Point3D Constructor (Single, Single, Single) |
 | See Also

Initializes a new instance of the AnnotationPathPoint class with the specified X, Y and Z coordinates.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X, Y and Z are cartesian coordinates and well understood")> _
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X, Y and Z are cartesian coordinates and well understood")]
public Point3D (
    float x,
    float y,
    float z
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X, Y and Z are cartesian coordinates and well understood")]
public:
Point3D (
    float x,
    float y,
    float z
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X, Y and Z are cartesian coordinates and well understood") */
public Point3D (
    float x,
    float y,
    float z
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X, Y and Z are cartesian coordinates and well understood")
public function Point3D (
    x : float,
    y : float,
    z : float
)

Parameters

x

The X coordinate of 3D point.

y

The Y coordinate of 3D point.

z

The Z coordinate, which represents the depth of 3D point.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members


Point3D Methods

Point3D Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Point3D Class


Point3D Properties

Point3D Properties |
 | See Also

Public Properties

Name | Description
PointF | Gets or sets a PointF structure, which stores the X and Y coordinates of a 3D point.
X | Gets or sets the X coordinate of a 3D point.
Y | Gets or sets the Y coordinate of a 3D point.
Z | Gets or sets the Z coordinate of a 3D point.

See Also

Reference

Point3D Class


Point3D.PointF Property

Point3D.PointF Property |
 | See Also

Gets or sets a PointF structure, which stores the X and Y coordinates of a 3D point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property PointF As PointF
public PointF PointF { get; set; }
public:
property PointF PointF {
    PointF get ();
    void set (PointF value);
}
/** @property */
public PointF get_PointF ()

/** @property */
public void set_PointF (PointF value)

public function get PointF () : PointF

public function set PointF (value : PointF)

Property Value

Gets or sets a PointF structure.

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling TransformPoints, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates, by using a method such as the GetAbsolutePoint method. After converting the coordinates, the PointF property of each Point3D object can be used for any GDI+ method that take a PointF object as a parameter.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members


Point3D.X Property

Point3D.X Property |
 | See Also

Gets or sets the X coordinate of a 3D point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="X")> _
Public Property X As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="X")]
public float X { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"X")]
public:
property float X {
    float get ();
    void set (float value);
}
/** @property */
public float get_X ()

/** @property */
public void set_X (float value)

public function get X () : float

public function set X (value : float)

Property Value

A float that represents the X coordinate of a 3D point.

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling the TransformPoints method, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates using the GetAbsolutePoint method. They are then used for GDI+ method calls.

A relative X coordinate can be obtained from an axis value by calling the ValueToPosition method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members


Point3D.Y Property

Point3D.Y Property |
 | See Also

Gets or sets the Y coordinate of a 3D point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Y")> _
Public Property Y As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Y")]
public float Y { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Y")]
public:
property float Y {
    float get ();
    void set (float value);
}
/** @property */
public float get_Y ()

/** @property */
public void set_Y (float value)

public function get Y () : float

public function set Y (value : float)

Property Value

A float value that represents the Y coordinate of a 3D point.

Remarks

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling the TransformPoints method, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates by using the GetAbsolutePoint method. They are then used for GDI+ method calls.

A relative Y coordinate can be obtained from an axis value using the ValueToPosition method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members


Point3D.Z Property

Point3D.Z Property |
 | See Also

Gets or sets the Z coordinate of a 3D point.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Z")> _
Public Property Z As Single
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Z")]
public float Z { get; set; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Z")]
public:
property float Z {
    float get ();
    void set (float value);
}
/** @property */
public float get_Z ()

/** @property */
public void set_Z (float value)

public function get Z () : float

public function set Z (value : float)

Property Value

The Z coordinate of a 3D point, which is measured as a percentage of the relevant chart area's depth.

Remarks

This Z property is always expressed as a percentage of the relevant chart area's depth. With 3D charts, Z coordinates are relative, and have a value of 0 for the back wall of the chart area and a value of 100 for the front wall of the chart area.

Note This Z property may be less than zero (located behind a chart area) or greater than 100 (located in front of a chart area).

Any point used in custom 3D drawing—which is accomplished using GDI+—must be transformed from X, Y and Z (3D) coordinates into X and Y (2D) coordinates using the TransformPoints method. This method takes an array of Point3D objects as its only parameter. By calling the TransformPoints method, the X and Y property values are changed to reflect the 3-dimensional space.

These new X and Y coordinates are then converted to absolute coordinates by using the GetAbsolutePoint method. They are then used for GDI+ method calls.

Relative Z coordinates can be obtained for series by using the GetSeriesDepth and GetSeriesZPosition methods.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Point3D Class
Point3D Members


PointSortOrder Enumeration

PointSortOrder Enumeration |
 | See Also

Indicates whether the sort order for data points is ascending or descending.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration PointSortOrder
public enum PointSortOrder
public enum class PointSortOrder
public enum PointSortOrder
public enum PointSortOrder

Members

Member name | Description
Ascending | Ascending sort order, that is, smallest to largest values.
Descending | Descending sort order, that is, largest to smallest values.

Remarks

The PointSortOrder enumeration represents the order of the sort to be performed on data point values. It is used with the Sort method definitions in the DataManipulator class that include a pointSortOrder parameter.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


PolygonAnnotation Class

PolygonAnnotation Class |
 | See Also Members

Represents a polygon annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class PolygonAnnotation
    Inherits PolylineAnnotation
public class PolygonAnnotation : PolylineAnnotation
public ref class PolygonAnnotation : public PolylineAnnotation
public class PolygonAnnotation extends PolylineAnnotation
public class PolygonAnnotation extends PolylineAnnotation

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.PolylineAnnotation
System.Windows.Forms.DataVisualization.Charting.PolygonAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Members


PolygonAnnotation Members

PolygonAnnotation Members |
 | See Also Constructors Methods Properties

Represents a polygon annotation.

The following tables list the members exposed by the PolygonAnnotation type.

Public Constructors

Name | Description
PolygonAnnotation | Initializes a new instance of the PolygonAnnotation class.
Top

Public Properties

Name | Description
Alignment | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the background hatch style of an annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color of the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Overridden. This property is not applicable to the polygon annotation type.
Font | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation)
ForeColor | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation)
GraphicsPath | Gets or sets the path points of a polyline annotation at run time. (inherited from PolylineAnnotation)
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time. (inherited from PolylineAnnotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode. (inherited from PolylineAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Overridden. This property is not applicable to the polygon annotation type.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Gets or sets the text style of an annotation. (inherited from PolylineAnnotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from PolylineAnnotation )
EndPlacement | Ends the user placement of a polyline annotation. (inherited from PolylineAnnotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from PolylineAnnotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PolygonAnnotation Class


PolygonAnnotation Constructor

PolygonAnnotation Constructor |
 | See Also

Initializes a new instance of the PolygonAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public PolygonAnnotation ()
public:
PolygonAnnotation ()
public PolygonAnnotation ()
public function PolygonAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation Methods

PolygonAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from PolylineAnnotation )
EndPlacement | Ends the user placement of a polyline annotation. (inherited from PolylineAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from PolylineAnnotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PolygonAnnotation Class


PolygonAnnotation Properties

PolygonAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of an annotation.
BackGradientStyle | Overridden. Gets or sets the background gradient style of an annotation.
BackHatchStyle | Overridden. Gets or sets the background hatch style of an annotation.
BackSecondaryColor | Overridden. Gets or sets the secondary color of the annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Overridden. This property is not applicable to the polygon annotation type.
Font | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation )
ForeColor | This property is not applicable to the polyline annotation type. (inherited from PolylineAnnotation )
GraphicsPath | Gets or sets the path points of a polyline annotation at run time. (inherited from PolylineAnnotation )
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time. (inherited from PolylineAnnotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode. (inherited from PolylineAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Overridden. This property is not applicable to the polygon annotation type.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Gets or sets the text style of an annotation. (inherited from PolylineAnnotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

PolygonAnnotation Class


PolygonAnnotation.AnnotationType Property

PolygonAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation.BackColor Property

PolygonAnnotation.BackColor Property |
 | See Also

Gets or sets the background color of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(true)]
public override Color BackColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value used to draw the annotation background.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation.BackGradientStyle Property

PolygonAnnotation.BackGradientStyle Property |
 | See Also

Gets or sets the background gradient style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(true)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw the annotation background.

Remarks

Two colors are used to draw the gradient fill; the primary color is specified with the BackColor property and the secondary color is specified with the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation.BackHatchStyle Property

PolygonAnnotation.BackHatchStyle Property |
 | See Also

Gets or sets the background hatch style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(true)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the annotation background.

Remarks

Two colors are used to draw the hatching fill; the primary color is specified with the BackColor property and the secondary color is specified with the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation.BackSecondaryColor Property

PolygonAnnotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(true)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw the annotation background with hatching or gradient fill.

Remarks

This secondary color is used with a primary color, defined with the BackColor property, when the BackHatchStyle and BackGradientStyle properties are used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation.EndCap Property

PolygonAnnotation.EndCap Property |
 | See Also

This property is not applicable to the polygon annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property EndCap As LineAnchorCapStyle
[BrowsableAttribute(false)]
public override LineAnchorCapStyle EndCap { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LineAnchorCapStyle EndCap {
    LineAnchorCapStyle get () override;
    void set (LineAnchorCapStyle value) override;
}
/** @property */
public LineAnchorCapStyle get_EndCap ()

/** @property */
public void set_EndCap (LineAnchorCapStyle value)

public override function get EndCap () : LineAnchorCapStyle

public override function set EndCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value.

Remarks

This property is not applicable to the polygon annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolygonAnnotation.StartCap Property

PolygonAnnotation.StartCap Property |
 | See Also

This property is not applicable to the polygon annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property StartCap As LineAnchorCapStyle
[BrowsableAttribute(false)]
public override LineAnchorCapStyle StartCap { get; set; }
[BrowsableAttribute(false)]
public:
virtual property LineAnchorCapStyle StartCap {
    LineAnchorCapStyle get () override;
    void set (LineAnchorCapStyle value) override;
}
/** @property */
public LineAnchorCapStyle get_StartCap ()

/** @property */
public void set_StartCap (LineAnchorCapStyle value)

public override function get StartCap () : LineAnchorCapStyle

public override function set StartCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value.

Remarks

This property is not applicable to the polygon annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolygonAnnotation Class
PolygonAnnotation Members


PolylineAnnotation Class

PolylineAnnotation Class |
 | See Also Members

Represents a polyline annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Polyline")> _
Public Class PolylineAnnotation
    Inherits Annotation
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Polyline")]
public class PolylineAnnotation : Annotation
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Polyline")]
public ref class PolylineAnnotation : public Annotation
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Polyline") */
public class PolylineAnnotation extends Annotation
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Polyline")
public class PolylineAnnotation extends Annotation

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.PolylineAnnotation
System.Windows.Forms.DataVisualization.Charting.PolygonAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Members


PolylineAnnotation Members

PolylineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a polyline annotation.

The following tables list the members exposed by the PolylineAnnotation type.

Public Constructors

Name | Description
PolylineAnnotation | Initializes a new instance of the PolylineAnnotation class.
Top

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the polyline annotation type.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the polyline annotation type.
BackGradientStyle | Overridden. This property is not applicable to the polyline annotation type.
BackHatchStyle | Overridden. This property is not applicable to the polyline annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the polyline annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets the style of an anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the polyline annotation type.
ForeColor | Overridden. This property is not applicable to the polyline annotation type.
GraphicsPath | Gets or sets the path points of a polyline annotation at run time.
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time.
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of the annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded.
EndPlacement | Overridden. Ends the user placement of a polyline annotation.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PolylineAnnotation Class


PolylineAnnotation Constructor

PolylineAnnotation Constructor |
 | See Also

Initializes a new instance of the PolylineAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public PolylineAnnotation ()
public:
PolylineAnnotation ()
public PolylineAnnotation ()
public function PolylineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation Methods

PolylineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded.
EndPlacement | Overridden. Ends the user placement of a polyline annotation.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PolylineAnnotation Class


PolylineAnnotation.Dispose Method

PolylineAnnotation.Dispose Method |
 | See Also

Overload List

Name | Description
PolylineAnnotation.Dispose () | (inherited from Dispose )
PolylineAnnotation.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources.

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.Dispose Method (Boolean)

PolylineAnnotation.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.EndPlacement Method

PolylineAnnotation.EndPlacement Method |
 | See Also

Ends the user placement of a polyline annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Sub EndPlacement
public override void EndPlacement ()
public:
virtual void EndPlacement () override
public void EndPlacement ()
public override function EndPlacement ()

Remarks

This method ends an annotation placement operation previously started by a BeginPlacement method call.

You are not required to call this method, because placement will automatically end when an end user enters all required points. However, it is useful when an annotation placement operation needs to be aborted for some reason.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation Properties

PolylineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Overridden. This property is not applicable to the polyline annotation type.
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the polyline annotation type.
BackGradientStyle | Overridden. This property is not applicable to the polyline annotation type.
BackHatchStyle | Overridden. This property is not applicable to the polyline annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the polyline annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets the style of an anchor cap at the end of the annotation line.
Font | Overridden. This property is not applicable to the polyline annotation type.
ForeColor | Overridden. This property is not applicable to the polyline annotation type.
GraphicsPath | Gets or sets the path points of a polyline annotation at run time.
GraphicsPathPoints | Gets or sets the path points of the polyline annotation at design time.
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsFreeDrawPlacement | Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of the annotation line.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | Overridden. Gets or sets the text style of an annotation.
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

PolylineAnnotation Class


PolylineAnnotation.Alignment Property

PolylineAnnotation.Alignment Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Alignment As ContentAlignment
[BrowsableAttribute(false)]
public override ContentAlignment Alignment { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ContentAlignment Alignment {
    ContentAlignment get () override;
    void set (ContentAlignment value) override;
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public override function get Alignment () : ContentAlignment

public override function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.AnnotationType Property

PolylineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.BackColor Property

PolylineAnnotation.BackColor Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.BackGradientStyle Property

PolylineAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.BackHatchStyle Property

PolylineAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.BackSecondaryColor Property

PolylineAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.EndCap Property

PolylineAnnotation.EndCap Property |
 | See Also

Gets or sets the style of an anchor cap at the end of the annotation line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property EndCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle EndCap { get; set; }
public:
virtual property LineAnchorCapStyle EndCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_EndCap ()

/** @property */
public void set_EndCap (LineAnchorCapStyle value)

public function get EndCap () : LineAnchorCapStyle

public function set EndCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value that represents the style used for an anchor cap located at the end of an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.Font Property

PolylineAnnotation.Font Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property Font As Font
[BrowsableAttribute(false)]
public override Font Font { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.ForeColor Property

PolylineAnnotation.ForeColor Property |
 | See Also

This property is not applicable to the polyline annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property ForeColor As Color
[BrowsableAttribute(false)]
public override Color ForeColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public override function get ForeColor () : Color

public override function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the polyline annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.GraphicsPath Property

PolylineAnnotation.GraphicsPath Property |
 | See Also

Gets or sets the path points of a polyline annotation at run time.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overridable Property GraphicsPath As GraphicsPath
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual GraphicsPath GraphicsPath { get; set; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property GraphicsPath^ GraphicsPath {
    GraphicsPath^ get ();
    void set (GraphicsPath^ value);
}
/** @property */
public GraphicsPath get_GraphicsPath ()

/** @property */
public void set_GraphicsPath (GraphicsPath value)

public function get GraphicsPath () : GraphicsPath

public function set GraphicsPath (value : GraphicsPath)

Property Value

A GraphicsPath object with the polyline shape.

Remarks

A polyline must use coordinates relative to an annotation object, where (0,0) denotes the top-left coordinates and (100,100) denotes the bottom-right coordinates of the annotation.

This property is not accessible at design time, when you should use the GraphicsPathPoints property instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.GraphicsPathPoints Property

PolylineAnnotation.GraphicsPathPoints Property |
 | See Also

Gets or sets the path points of the polyline annotation at design time.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property GraphicsPathPoints As AnnotationPathPointCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public AnnotationPathPointCollection GraphicsPathPoints { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property AnnotationPathPointCollection^ GraphicsPathPoints {
    AnnotationPathPointCollection^ get ();
}
/** @property */
public AnnotationPathPointCollection get_GraphicsPathPoints ()

public function get GraphicsPathPoints () : AnnotationPathPointCollection

Property Value

An AnnotationPathPointCollection object with the polyline shape.

Remarks

A polyline must use coordinates relative to an annotation object, where (0,0) denotes the top-left coordinates and (100,100) denotes the bottom-right coordinates of the annotation.

This property is not accessible at run time, when you should use the GraphicsPath property instead.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.IsFreeDrawPlacement Property

PolylineAnnotation.IsFreeDrawPlacement Property |
 | See Also

Gets or sets a flag that determines whether an annotation should be placed using the free-draw mode.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsFreeDrawPlacement As Boolean
public virtual bool IsFreeDrawPlacement { get; set; }
public:
virtual property bool IsFreeDrawPlacement {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsFreeDrawPlacement ()

/** @property */
public void set_IsFreeDrawPlacement (boolean value)

public function get IsFreeDrawPlacement () : boolean

public function set IsFreeDrawPlacement (value : boolean)

Property Value

True if an annotation should be placed using free-draw mode, otherwise false. The default value is false.

Remarks

Two different placement modes are supported when the BeginPlacement method is called. Set the IsFreeDrawPlacement property to true to switch from the default mode to free-draw mode, which allows the user to freely-draw while moving the mouse cursor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.StartCap Property

PolylineAnnotation.StartCap Property |
 | See Also

Gets or sets a style for the anchor cap at the start of the annotation line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property StartCap As LineAnchorCapStyle
public virtual LineAnchorCapStyle StartCap { get; set; }
public:
virtual property LineAnchorCapStyle StartCap {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_StartCap ()

/** @property */
public void set_StartCap (LineAnchorCapStyle value)

public function get StartCap () : LineAnchorCapStyle

public function set StartCap (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle value that represents the style for an anchor cap located at the start of an annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PolylineAnnotation.TextStyle Property

PolylineAnnotation.TextStyle Property |
 | See Also

Gets or sets the text style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property TextStyle As TextStyle
[BrowsableAttribute(false)]
public override TextStyle TextStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property TextStyle TextStyle {
    TextStyle get () override;
    void set (TextStyle value) override;
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public override function get TextStyle () : TextStyle

public override function set TextStyle (value : TextStyle)

Property Value

A TextStyle value used to draw the text of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PolylineAnnotation Class
PolylineAnnotation Members


PrintingManager Class

PrintingManager Class |
 | See Also Members

Prints the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class PrintingManager
    Implements IDisposable
public class PrintingManager : IDisposable
public ref class PrintingManager : IDisposable
public class PrintingManager implements IDisposable
public class PrintingManager implements IDisposable

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.PrintingManager

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Members


PrintingManager Members

PrintingManager Members |
 | See Also Constructors Methods Properties

Prints the chart.

The following tables list the members exposed by the PrintingManager type.

Public Constructors

Name | Description
PrintingManager | Initializes a new instance of the PrintingManager class.
Top

Public Properties

Name | Description
PrintDocument | Gets or sets a print document for the chart.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
PageSetup | Displays a Page Setup dialog.
Print | Prints the chart.
PrintPaint | Draws the chart on the printer graphics.
PrintPreview | Provides a preview of the chart.
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintingManager Class


PrintingManager Constructor

PrintingManager Constructor |
 | See Also

Initializes a new instance of the PrintingManager class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    container As IServiceContainer _
)
public PrintingManager (
    IServiceContainer container
)
public:
PrintingManager (
    IServiceContainer^ container
)
public PrintingManager (
    IServiceContainer container
)
public function PrintingManager (
    container : IServiceContainer
)

Parameters

container

An IServiceContainer reference.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager Methods

PrintingManager Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
PageSetup | Displays a Page Setup dialog.
Print | Prints the chart.
PrintPaint | Draws the chart on the printer graphics.
PrintPreview | Provides a preview of the chart.
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintingManager Class


PrintingManager.Dispose Method

PrintingManager.Dispose Method |
 | See Also

Overload List

Name | Description
PrintingManager.Dispose () | Frees, releases, or resets managed resources.
PrintingManager.Dispose (Boolean) | Releases unmanaged and, optionally, managed resources

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager.Dispose Method ()

PrintingManager.Dispose Method () |
 | See Also

Frees, releases, or resets managed resources.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Dispose
public void Dispose ()
public:
virtual void Dispose () sealed
public final void Dispose ()
public final function Dispose ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager.Dispose Method (Boolean)

PrintingManager.Dispose Method (Boolean) |
 | See Also

Releases unmanaged and, optionally, managed resources

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

True to release both unmanaged and managed resources; false to release only unmanaged resources.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager.PageSetup Method

PrintingManager.PageSetup Method |
 | See Also

Displays a Page Setup dialog.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub PageSetup
public void PageSetup ()
public:
void PageSetup ()
public void PageSetup ()
public function PageSetup ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager.Print Method

PrintingManager.Print Method |
 | See Also

Prints the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Print ( _
    showPrintDialog As Boolean _
)
public void Print (
    bool showPrintDialog
)
public:
void Print (
    bool showPrintDialog
)
public void Print (
    boolean showPrintDialog
)
public function Print (
    showPrintDialog : boolean
)

Parameters

showPrintDialog

Indicates whether a print dialog should be shown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager.PrintPaint Method

PrintingManager.PrintPaint Method |
 | See Also

Draws the chart on the printer graphics.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub PrintPaint ( _
    graphics As Graphics, _
    position As Rectangle _
)
public void PrintPaint (
    Graphics graphics,
    Rectangle position
)
public:
void PrintPaint (
    Graphics^ graphics,
    Rectangle position
)
public void PrintPaint (
    Graphics graphics,
    Rectangle position
)
public function PrintPaint (
    graphics : Graphics,
    position : Rectangle
)

Parameters

graphics

The printer Graphics object.

position

The position to draw on the graphics.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager.PrintPreview Method

PrintingManager.PrintPreview Method |
 | See Also

Provides a preview of the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub PrintPreview
public void PrintPreview ()
public:
void PrintPreview ()
public void PrintPreview ()
public function PrintPreview ()

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


PrintingManager Properties

PrintingManager Properties |
 | See Also

Public Properties

Name | Description
PrintDocument | Gets or sets a print document for the chart.

See Also

Reference

PrintingManager Class


PrintingManager.PrintDocument Property

PrintingManager.PrintDocument Property |
 | See Also

Gets or sets a print document for the chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property PrintDocument As PrintDocument
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public PrintDocument PrintDocument { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
    void set (PrintDocument^ value);
}
/** @property */
public PrintDocument get_PrintDocument ()

/** @property */
public void set_PrintDocument (PrintDocument value)

public function get PrintDocument () : PrintDocument

public function set PrintDocument (value : PrintDocument)

Property Value

A PrintDocument object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

PrintingManager Class
PrintingManager Members


RectangleAnnotation Class

RectangleAnnotation Class |
 | See Also Members

Represents a rectangle annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class RectangleAnnotation
    Inherits TextAnnotation
public class RectangleAnnotation : TextAnnotation
public ref class RectangleAnnotation : public TextAnnotation
public class RectangleAnnotation extends TextAnnotation
public class RectangleAnnotation extends TextAnnotation

Remarks

A rectangle annotation can display text inside the rectangle, in addition to being displayed as a rectangle only. So you can annotate using a rectangle or a rectangle with text inside it.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.TextAnnotation
System.Windows.Forms.DataVisualization.Charting.RectangleAnnotation
System.Windows.Forms.DataVisualization.Charting.Border3DAnnotation
System.Windows.Forms.DataVisualization.Charting.EllipseAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Members


RectangleAnnotation Members

RectangleAnnotation Members |
 | See Also Constructors Methods Properties

Represents a rectangle annotation.

The following tables list the members exposed by the RectangleAnnotation type.

Public Constructors

Name | Description
RectangleAnnotation | Initializes a new instance of the AnnotationPathPoint class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the gradient style of the annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation)
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. Gets or sets the line color of an annotation.
LineDashStyle | Overridden. Gets or sets the line style of an annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of an annotation.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation)
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation)
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

RectangleAnnotation Class


RectangleAnnotation Constructor

RectangleAnnotation Constructor |
 | See Also

Initializes a new instance of the AnnotationPathPoint class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public RectangleAnnotation ()
public:
RectangleAnnotation ()
public RectangleAnnotation ()
public function RectangleAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation Methods

RectangleAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BeginTextEditing | Begins editing of the annotation text by an end-user. (inherited from TextAnnotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends user placement of an annotation. (inherited from TextAnnotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text. (inherited from TextAnnotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

RectangleAnnotation Class


RectangleAnnotation Properties

RectangleAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. Gets or sets the background color of the annotation.
BackGradientStyle | Overridden. Gets or sets the gradient style of the annotation.
BackHatchStyle | Overridden. Gets or sets the hatch style of an annotation background.
BackSecondaryColor | Overridden. Gets or sets the secondary color for an annotation background.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Gets or sets the font for the annotation text. (inherited from TextAnnotation )
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline. (inherited from TextAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. Gets or sets the line color of an annotation.
LineDashStyle | Overridden. Gets or sets the line style of an annotation.
LineWidth | Overridden. Gets or sets the line width, in pixels, of an annotation.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation. (inherited from TextAnnotation )
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

RectangleAnnotation Class


RectangleAnnotation.AnnotationType Property

RectangleAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.BackColor Property

RectangleAnnotation.BackColor Property |
 | See Also

Gets or sets the background color of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(true)]
public override Color BackColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value used to draw the annotation background.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.BackGradientStyle Property

RectangleAnnotation.BackGradientStyle Property |
 | See Also

Gets or sets the gradient style of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(true)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle value used to draw an annotation background.

Remarks

Two colors are used to draw the gradient, a primary color that is specified the BackColor and a secondary color that is specified with the BackSecondaryColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.BackHatchStyle Property

RectangleAnnotation.BackHatchStyle Property |
 | See Also

Gets or sets the hatch style of an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(true)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle value used to draw the background.

Remarks

Two colors are used to draw the hatching, a primary color that is specified the BackColor property, and a secondary color that is specified with the BackColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.BackSecondaryColor Property

RectangleAnnotation.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color for an annotation background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(true)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value used to draw the annotation background with hatching or gradient fill.

Remarks

This color is used with BackColor when the BackHatchStyle or BackGradientStyle property is used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.LineColor Property

RectangleAnnotation.LineColor Property |
 | See Also

Gets or sets the line color of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(true)]
public override Color LineColor { get; set; }
[BrowsableAttribute(true)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value used to draw the annotation line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.LineDashStyle Property

RectangleAnnotation.LineDashStyle Property |
 | See Also

Gets or sets the line style of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(true)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(true)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle value used to draw the line style of an annotation.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


RectangleAnnotation.LineWidth Property

RectangleAnnotation.LineWidth Property |
 | See Also

Gets or sets the line width, in pixels, of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(true)]
public override int LineWidth { get; set; }
[BrowsableAttribute(true)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value that represents the line width, in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

RectangleAnnotation Class
RectangleAnnotation Members


ScrollBarButtonStyles Enumeration

ScrollBarButtonStyles Enumeration |
 | See Also

Specifies the type of button that will be displayed on the scrollbar.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ScrollBarButtonStyles
public enum ScrollBarButtonStyles
public enum class ScrollBarButtonStyles
public enum ScrollBarButtonStyles
public enum ScrollBarButtonStyles

Members

Member name | Description
All | All buttons are displayed.
None | No buttons are displayed.
ResetZoom | The reset and zoom (thumb) buttons are displayed.
SmallScroll | The up/down and left/right buttons only are displayed.

Remarks

The ScrollBarButtonStyles enumeration is used with the ButtonStyle property to specify the buttons to be displayed for a scrollbar.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ScrollBarButtonType Enumeration

ScrollBarButtonType Enumeration |
 | See Also

Specifies the button clicked by a user in the AxisScrollBarClicked event.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ScrollBarButtonType
public enum ScrollBarButtonType
public enum class ScrollBarButtonType
public enum ScrollBarButtonType
public enum ScrollBarButtonType

Members

Member name | Description
LargeDecrement | The scroll view was decreased by a large decrement, by clicking the area beneath a scrolling thumb for a vertical scrollbar, or to the left of a scrolling thumb for a horizontal scrollbar.
LargeIncrement | The scroll view was increased by a large increment, by clicking the area above a scrolling thumb for a vertical scrollbar, or to the right of a scrolling thumb for a horizontal scrollbar.
SmallDecrement | A down or left arrow button was clicked to decrease the scroll view by a small decrement.
SmallIncrement | An up or right arrow button was clicked to increase the scroll view by a small increment.
ThumbTracker | The tracker button (also known as the scrollbar thumb) was clicked.
ZoomReset | The zoom or reset button was clicked.

Remarks

The ScrollBarButtonType enumeration is used with the ButtonType property, and allows the developer to determine what type of scrollbar button the end-user clicked on.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


ScrollBarEventArgs Class

ScrollBarEventArgs Class |
 | See Also Members

Used as a parameter object in the AxisScrollBarClicked of the root Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ScrollBarEventArgs
    Inherits EventArgs
public class ScrollBarEventArgs : EventArgs
public ref class ScrollBarEventArgs : public EventArgs
public class ScrollBarEventArgs extends EventArgs
public class ScrollBarEventArgs extends EventArgs

Remarks

The ScrollBarEventArgs class is exposed as the e parameter in the AxisScrollBarClicked event.

The ScrollBarEventArgs class contains the following properties:

  • The ChartArea property, which is used to get the ChartArea object that the event was raised for. The Name property gets the name of the chart area; other chart area properties can also be set.

  • The Axis property, which is used to get the Axis object that the scrollbar belongs to, using the AxisName property. Other Axis properties can also be set.

  • The ButtonType property, which is used to get the scrollbar button that the end-user clicked.

  • The IsHandled property, which determines if the Chart control cancels default behavior of the scrollbar button after the code in the AxisScrollBarClicked event completes execution.

  • The MousePositionX property, which represents the X position of the mouse cursor at the time the end-user clicked the scrollbar element.

  • The MousePositionY property, which represents the Y-position of the mouse cursor at the time the end-user clicked the scrollbar element.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.ScrollBarEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Members


ScrollBarEventArgs Members

ScrollBarEventArgs Members |
 | See Also Constructors Methods Properties

Used as a parameter object in the AxisScrollBarClicked of the root Chart object.

The following tables list the members exposed by the ScrollBarEventArgs type.

Public Constructors

Name | Description
ScrollBarEventArgs | Initializes a new instance of the ScrollBarEventArgs class with the specified axis, X and Y positions of the mouse cursor, and type of button clicked.
Top

Public Properties

Name | Description
Axis | Gets the Axis object that a scrollbar belongs to.
ButtonType | Gets the type of scrollbar button that the end-user clicked.
ChartArea | Gets the ChartArea object that the scrollbar belongs to.
IsHandled | Gets or sets a flag that indicates whether to cancel the default behavior of specific scrollbar events.
MousePositionX | Gets the X position of the mouse cursor at the time the AxisScrollBarClicked event was raised.
MousePositionY | Gets the Y position of the mouse cursor at the time the AxisScrollBarClicked event was raised.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ScrollBarEventArgs Class


ScrollBarEventArgs Constructor

ScrollBarEventArgs Constructor |
 | See Also

Initializes a new instance of the ScrollBarEventArgs class with the specified axis, X and Y positions of the mouse cursor, and type of button clicked.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    axis As Axis, _
    x As Integer, _
    y As Integer, _
    buttonType As ScrollBarButtonType _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public ScrollBarEventArgs (
    Axis axis,
    int x,
    int y,
    ScrollBarButtonType buttonType
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
ScrollBarEventArgs (
    Axis^ axis,
    int x,
    int y,
    ScrollBarButtonType buttonType
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public ScrollBarEventArgs (
    Axis axis,
    int x,
    int y,
    ScrollBarButtonType buttonType
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function ScrollBarEventArgs (
    axis : Axis,
    x : int,
    y : int,
    buttonType : ScrollBarButtonType
)

Parameters

axis

The Axis that contains the scrollbar.

x

The X position of mouse cursor.

y

The Y position of mouse cursor.

buttonType

The type of button clicked.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollBarEventArgs Methods

ScrollBarEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ScrollBarEventArgs Class


ScrollBarEventArgs Properties

ScrollBarEventArgs Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets the Axis object that a scrollbar belongs to.
ButtonType | Gets the type of scrollbar button that the end-user clicked.
ChartArea | Gets the ChartArea object that the scrollbar belongs to.
IsHandled | Gets or sets a flag that indicates whether to cancel the default behavior of specific scrollbar events.
MousePositionX | Gets the X position of the mouse cursor at the time the AxisScrollBarClicked event was raised.
MousePositionY | Gets the Y position of the mouse cursor at the time the AxisScrollBarClicked event was raised.

See Also

Reference

ScrollBarEventArgs Class


ScrollBarEventArgs.Axis Property

ScrollBarEventArgs.Axis Property |
 | See Also

Gets the Axis object that a scrollbar belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Axis As Axis
public Axis Axis { get; }
public:
property Axis^ Axis {
    Axis^ get ();
}
/** @property */
public Axis get_Axis ()

public function get Axis () : Axis

Property Value

An Axis object that represents the axis that the scrollbar belongs to.

Remarks

This property is exposed in the AxisScrollBarClicked event of the root Chart object.

This property can be used to:

  • determine the type of axis—X, X2, Y or Y2—that the event is being raised for, using the AxisName property.

  • get and set axis properties, such as LineColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollBarEventArgs.ButtonType Property

ScrollBarEventArgs.ButtonType Property |
 | See Also

Gets the type of scrollbar button that the end-user clicked.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ButtonType As ScrollBarButtonType
public ScrollBarButtonType ButtonType { get; }
public:
property ScrollBarButtonType ButtonType {
    ScrollBarButtonType get ();
}
/** @property */
public ScrollBarButtonType get_ButtonType ()

public function get ButtonType () : ScrollBarButtonType

Property Value

A ScrollBarButtonType enumeration value that represents the type of scrollbar button the end-user clicked.

Remarks

This property is exposed in the AxisScrollBarClicked event of the root Chart object, and can be used to determine the type of scrollbar button the end-user clicked.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollBarEventArgs.ChartArea Property

ScrollBarEventArgs.ChartArea Property |
 | See Also

Gets the ChartArea object that the scrollbar belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ChartArea As ChartArea
public ChartArea ChartArea { get; }
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
}
/** @property */
public ChartArea get_ChartArea ()

public function get ChartArea () : ChartArea

Property Value

A ChartArea object.

Remarks

This property is exposed in the AxisScrollBarClicked event of the root Chart object.

The ChartArea property can be used to determine the chart area that the scrollbar belongs to by accessing the Name property. This property can also be used to get and set chart area properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollBarEventArgs.IsHandled Property

ScrollBarEventArgs.IsHandled Property |
 | See Also

Gets or sets a flag that indicates whether to cancel the default behavior of specific scrollbar events.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsHandled As Boolean
public bool IsHandled { get; set; }
public:
property bool IsHandled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsHandled ()

/** @property */
public void set_IsHandled (boolean value)

public function get IsHandled () : boolean

public function set IsHandled (value : boolean)

Property Value

True if the default behavior of the event should be cancelled, otherwise false.

Remarks

This property is exposed in the AxisScrollBarClicked event of the root Chart object.

This property can be used to cancel the default behavior on specific scrollbar events.

If you click on a scrollbar button, the default manipulation of the view will occur.

The following list summarizes this default behavior:

  • If the user clicks the Reset/Zoom button, the previous view will be displayed.

  • If the user clicks in the scrollbar background—that is, not on the scrolling thumb, otherwise known as the tracker— large increments and/or decrements of the scrollbar will occur, with the increment and/or decrement size being determined by the Size property.

To turn off these default behaviors, set the IsHandled property to true after providing custom logic in the AxisScrollBarClicked event.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollBarEventArgs.MousePositionX Property

ScrollBarEventArgs.MousePositionX Property |
 | See Also

Gets the X position of the mouse cursor at the time the AxisScrollBarClicked event was raised.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property MousePositionX As Integer
public int MousePositionX { get; }
public:
property int MousePositionX {
    int get ();
}
/** @property */
public int get_MousePositionX ()

public function get MousePositionX () : int

Property Value

An integer value that represents the X mouse cursor position. The position is expressed in pixels, with 0,0 being the top-left corner of the chart image.

Remarks

This property is used to get the X mouse position, in pixels, when the end-user clicks on a scrollbar element. The 0,0 coordinate represents the top-left corner of the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollBarEventArgs.MousePositionY Property

ScrollBarEventArgs.MousePositionY Property |
 | See Also

Gets the Y position of the mouse cursor at the time the AxisScrollBarClicked event was raised.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property MousePositionY As Integer
public int MousePositionY { get; }
public:
property int MousePositionY {
    int get ();
}
/** @property */
public int get_MousePositionY ()

public function get MousePositionY () : int

Property Value

An integer value that represents the Y mouse cursor position. The position is expressed in pixels, with 0,0 being the top-left corner of the chart image.

Remarks

This property is used to get the Y mouse position, in pixels, when the end-user clicks on a scrollbar element. The 0,0 coordinate represents the top-left corner of the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ScrollBarEventArgs Class
ScrollBarEventArgs Members


ScrollType Enumeration

ScrollType Enumeration |
 | See Also

Specifies the scrolling that will occur when the one of the Scroll methods in the AxisScaleView class is called.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration ScrollType
public enum ScrollType
public enum class ScrollType
public enum ScrollType
public enum ScrollType

Members

Member name | Description
First | Data is scrolled to the first displayed view.
LargeDecrement | The data view is decreased by one large scrolling interval.
LargeIncrement | The data view is increased by one large scrolling interval.
Last | Data is scrolled to the last displayed view.
SmallDecrement | The data view is decreased by one small scrolling interval.
SmallIncrement | The data view is increased by one small scrolling interval.

Remarks

The ScrollType enumeration is used with one of the Scroll methods to specify the direction and amount of scrolling.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


SerializationContents Enumeration

SerializationContents Enumeration |
 | See Also

Specifies the type of chart content to be serialized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration SerializationContents
public enum SerializationContents
public enum class SerializationContents
public enum SerializationContents
public enum SerializationContents

Members

Member name | Description
All | Serialize all chart information. This includes all appearance properties and data point values.
Appearance | Serialize all appearance properties, such as color or line style, if they have non-default values.
Data | Serialize data values from all chart series. Does not include appearance properties.
Default | Serialize all non-default chart content. This includes appearance properties, series and their data points, axis minimums/maximums, and so forth.

Remarks

The SerializationContents enumeration represents the chart content type to be serialized. This enumeration is used with the Content property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


SerializationFormat Enumeration

SerializationFormat Enumeration |
 | See Also

Represents the formatting type to use when the chart is serialized.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration SerializationFormat
public enum SerializationFormat
public enum class SerializationFormat
public enum SerializationFormat
public enum SerializationFormat

Members

Member name | Description
Binary | Chart data will be serialized in a binary format.
Xml | Chart data will be serialized using well-formed XML.

Remarks

The SerializationFormat enumeration is used in conjunction with the Format property.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Series Class

Series Class |
 | See Also Members

Stores data points and series attributes.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Series
    Inherits DataPointCustomProperties
public class Series : DataPointCustomProperties
public ref class Series : public DataPointCustomProperties
public class Series extends DataPointCustomProperties
public class Series extends DataPointCustomProperties

Remarks

A Series object represents a data series and is stored in the SeriesCollection class.

A Series stores DataPoint objects using the DataPointCollection class. It also stores attributes of the data series. For example, a data series has a color attribute, background image attribute, background gradient attribute, and so forth.

The DataPoint objects that belong to a series also have their own attributes. Normally, if the same attribute is set for a data point and the series to which it belongs, the data point attribute has precedence.

A series is not necessarily plotted on a chart; it can store data point values that are used to perform a calculation from which another series is created and then plotted. For example, Series A, which is plotted, may be the result of adding Series B and Series C data points together, though neither of these series is plotted. In order to draw a Series object, the ChartArea property must be set to the name of the ChartArea object used to plot the series.

When a series is created, it is automatically assigned to the ChartArea object named "Default", or to the first available chart area in the chart area collection if the "Default" object does not exist.

To disable the display of a series, set its ChartArea property to a zero-length string.

The ChartType property determines the type of chart that will be used to plot this series, if it is drawn.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.DataPointCustomProperties
System.Windows.Forms.DataVisualization.Charting.Series

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Members


Series Members

Series Members |
 | See Also Constructors Methods Properties

Stores data points and series attributes.

The following tables list the members exposed by the Series type.

Public Constructors

Name | Description
Series | Overloaded.
Top

Public Properties

Name | Description
AxisLabel | Overridden. Gets or sets the axis label text for the series.
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties)
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties)
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties)
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties)
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties)
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties)
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties)
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties)
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties)
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties)
ChartArea | Gets or sets the name of the ChartArea object used to plot the data series, if any.
ChartType | Gets or sets the chart type of a series.
ChartTypeName | Gets or sets the name of the chart type used to draw the series.
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties)
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties)
CustomPropertiesExtended | Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2... (inherited from DataPointCustomProperties)
EmptyPointStyle | Gets or sets the drawing style of points marked as empty.
Enabled | Gets or sets a flag that indicates whether the series will be visible on the rendered chart.
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties)
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties)
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties)
IsXValueIndexed | Gets or sets a flag that indicates whether data point indices will be used for the X-values.
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties)
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties)
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties)
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties)
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties)
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties)
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties)
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties)
Legend | Gets or sets the name of the series associated with the Legend object.
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties)
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties)
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties)
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties)
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties)
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties)
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties)
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties)
MarkerStep | Gets or sets a value that determines how often to display data point markers.
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties)
Name | Overridden. Gets or sets the unique name of a Series object.
Palette | Gets or sets the color palette of a Series object.
Points | Gets a DataPointCollection object.
ShadowColor | Gets or sets the shadow color of a series.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a series.
SmartLabelStyle | Gets or sets the style of the smart labels.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties)
XAxisType | Gets or sets the X-axis type of the series.
XValueMember | Gets or sets the member of the chart data source used to data bind to the X-value of the series.
XValueType | Gets or sets the value types plotted along the X-axis.
YAxisType | Gets or sets the Y-axis type of a series.
YValueMembers | Gets or sets member columns of the chart data source used to bind data to the Y-values of the series.
YValuesPerPoint | Gets or sets the maximum number of Y-values that DataPoint objects in a Series are allowed to have.
YValueType | Gets or sets the type of Y-value data in the data points stored by a series.
Top

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets a custom property to its default value. (inherited from DataPointCustomProperties)
ResetIsVisibleInLegend | Resets a custom property to its default value. (inherited from DataPointCustomProperties)
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
Sort | Overloaded. Performs a sort on a Series. Note that the DataManipulator class provides sort methods that have greater flexibility than these sort methods.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Series Class


Series Constructor

Series Constructor |
 | See Also

Overload List

Name | Description
Series () | Initializes a new instance of the Series class.
Series (String) | Initializes a new instance of the Series class with the specified series name.
Series (String, Int32) | Initializes a new instance of the Series class with the specified name and maximum number of Y values.

See Also

Reference

Series Class
Series Members


Series Constructor ()

Series Constructor () |
 | See Also

Initializes a new instance of the Series class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Series ()
public:
Series ()
public Series ()
public function Series ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series Constructor (String)

Series Constructor (String) |
 | See Also

Initializes a new instance of the Series class with the specified series name.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    name As String _
)
public Series (
    string name
)
public:
Series (
    String^ name
)
public Series (
    String name
)
public function Series (
    name : String
)

Parameters

name

The name of the Series object that will be created. This must be a unique name, otherwise an exception will be thrown.

Remarks

This constructor can be used to create a new instance of the Series class.

Note:
This series is only capable of storing DataPoint objects that have one Y-value. If a data point that has multiple Y-values is added to this series, an exception will be thrown.

To create a series at run time, use the Add method.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series Constructor (String, Int32)

Series Constructor (String, Int32) |
 | See Also

Initializes a new instance of the Series class with the specified name and maximum number of Y values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Y is a cartesian coordinate and well understood")> _
Public Sub New ( _
    name As String, _
    yValues As Integer _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")]
public Series (
    string name,
    int yValues
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Y is a cartesian coordinate and well understood")]
public:
Series (
    String^ name,
    int yValues
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood") */
public Series (
    String name,
    int yValues
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Y is a cartesian coordinate and well understood")
public function Series (
    name : String,
    yValues : int
)

Parameters

name

The name of the Series object that will be created.

yValues

The maximum number of Y-values allowed for the DataPoint objects that belong to this series.

Remarks

Use this constructor to create and initialize a new instance of the Series class.

Important:
This series will only be able to store DataPoint objects that do not have more Y-values than the maximum set by the yValues parameter. If you add a data point that has more Y-values than the set maximum, an exception will be thrown.

To create a Series object at run time, the Add and Insert methods of the Series collection property can also be used.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series Methods

Series Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
DeleteCustomProperty | (inherited from DataPointCustomProperties )
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetCustomProperty | (inherited from DataPointCustomProperties )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
IsCustomPropertySet | (inherited from DataPointCustomProperties )
ReferenceEquals | (inherited from Object )
ResetIsValueShownAsLabel | Resets a custom property to its default value. (inherited from DataPointCustomProperties )
ResetIsVisibleInLegend | Resets a custom property to its default value. (inherited from DataPointCustomProperties )
SetCustomProperty | (inherited from DataPointCustomProperties )
SetDefault | (inherited from DataPointCustomProperties )
Sort | Overloaded. Performs a sort on a Series. Note that the DataManipulator class provides sort methods that have greater flexibility than these sort methods.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Series Class


Series.Dispose Method

Series.Dispose Method |
 | See Also

Overload List

Name | Description
Series.Dispose () | (inherited from Dispose )
Series.Dispose (Boolean) |

See Also

Reference

Series Class
Series Members


Series.Dispose Method (Boolean)

Series.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Sort Method

Series.Sort Method |
 | See Also

Performs a sort on a Series. Note that the DataManipulator class provides sort methods that have greater flexibility than these sort methods.

Overload List

Name | Description
Series.Sort (Generic ) | Sorts the points in the series using IComparer interface.
Series.Sort (PointSortOrder) | Sorts the data points in the series, given the specified sort order.
Series.Sort (PointSortOrder, String) | Sorts the points in the series, given the specified sort order and value to use for the sort.

See Also

Reference

Series Class
Series Members


Series.Sort Method (Generic )

Series.Sort Method (Generic ) |
 | See Also

Sorts the points in the series using IComparer interface.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    comparer As IComparer(Of DataPoint) _
)
public void Sort (
    IComparer<DataPoint> comparer
)
public:
void Sort (
    IComparer<DataPoint^>^ comparer
)
public void Sort (
    IComparer<DataPoint> comparer
)
public function Sort (
    comparer : IComparer<DataPoint>
)

Parameters

comparer

The IComparer interface.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Sort Method (PointSortOrder)

Series.Sort Method (PointSortOrder) |
 | See Also

Sorts the data points in the series, given the specified sort order.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder _
)
public void Sort (
    PointSortOrder pointSortOrder
)
public:
void Sort (
    PointSortOrder pointSortOrder
)
public void Sort (
    PointSortOrder pointSortOrder
)
public function Sort (
    pointSortOrder : PointSortOrder
)

Parameters

pointSortOrder

The sort order.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Sort Method (PointSortOrder, String)

Series.Sort Method (PointSortOrder, String) |
 | See Also

Sorts the points in the series, given the specified sort order and value to use for the sort.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub Sort ( _
    pointSortOrder As PointSortOrder, _
    sortBy As String _
)
public void Sort (
    PointSortOrder pointSortOrder,
    string sortBy
)
public:
void Sort (
    PointSortOrder pointSortOrder,
    String^ sortBy
)
public void Sort (
    PointSortOrder pointSortOrder,
    String sortBy
)
public function Sort (
    pointSortOrder : PointSortOrder,
    sortBy : String
)

Parameters

pointSortOrder

The sort order.

sortBy

The value used for the sort (X, Y, Y2 ...).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series Properties

Series Properties |
 | See Also

Public Properties

Name | Description
AxisLabel | Overridden. Gets or sets the axis label text for the series.
BackGradientStyle | Gets or sets the background gradient style. (inherited from DataPointCustomProperties )
BackHatchStyle | Gets or sets the background hatching style. (inherited from DataPointCustomProperties )
BackImage | Gets or sets the background image of the data point. (inherited from DataPointCustomProperties )
BackImageAlignment | Gets or sets the alignment of the background image, which is used with the Unscaled drawing mode. (inherited from DataPointCustomProperties )
BackImageTransparentColor | Gets or sets a color that will be replaced with a transparent color when the background image is drawn. (inherited from DataPointCustomProperties )
BackImageWrapMode | Gets or sets the drawing mode of the background image. (inherited from DataPointCustomProperties )
BackSecondaryColor | Gets or sets the secondary background color. (inherited from DataPointCustomProperties )
BorderColor | Gets or sets the border color of the data point. (inherited from DataPointCustomProperties )
BorderDashStyle | Gets or sets the border style of the data point. (inherited from DataPointCustomProperties )
BorderWidth | Gets or sets the border width of the data point. (inherited from DataPointCustomProperties )
ChartArea | Gets or sets the name of the ChartArea object used to plot the data series, if any.
ChartType | Gets or sets the chart type of a series.
ChartTypeName | Gets or sets the name of the chart type used to draw the series.
Color | Gets or sets the color of the data point. (inherited from DataPointCustomProperties )
CustomProperties | Gets or sets the custom properties of the data point. Custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2 … (inherited from DataPointCustomProperties )
CustomPropertiesExtended | Gets or sets the extended custom properties of the data point. Extended custom properties can be specified in the following format: AttrName1=Value1, AttrName2=Value2... (inherited from DataPointCustomProperties )
EmptyPointStyle | Gets or sets the drawing style of points marked as empty.
Enabled | Gets or sets a flag that indicates whether the series will be visible on the rendered chart.
Font | Gets or sets the font of the data point. (inherited from DataPointCustomProperties )
IsValueShownAsLabel | Gets or sets a flag that indicates whether to show the value of the data point on the label. (inherited from DataPointCustomProperties )
IsVisibleInLegend | Gets or sets a flag that indicates whether the item is shown in the legend. (inherited from DataPointCustomProperties )
IsXValueIndexed | Gets or sets a flag that indicates whether data point indices will be used for the X-values.
Item | Overloaded. (inherited from DataPointCustomProperties )
Label | Gets or sets the text of the data point label. (inherited from DataPointCustomProperties )
LabelAngle | Gets or sets the angle of the data point label. (inherited from DataPointCustomProperties )
LabelBackColor | Gets or sets the background color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderColor | Gets or sets the border color of the data point label. (inherited from DataPointCustomProperties )
LabelBorderDashStyle | Gets or sets the border style of the label. (inherited from DataPointCustomProperties )
LabelBorderWidth | Gets or sets the border width of the label. (inherited from DataPointCustomProperties )
LabelForeColor | Gets or sets the text color of the label. (inherited from DataPointCustomProperties )
LabelFormat | Gets or sets the format of the data point label. (inherited from DataPointCustomProperties )
LabelToolTip | Gets or sets the tooltip for the data point label. (inherited from DataPointCustomProperties )
Legend | Gets or sets the name of the series associated with the Legend object.
LegendText | Gets or sets the text of the item in the legend. (inherited from DataPointCustomProperties )
LegendToolTip | Gets or sets the tooltip of the item in the legend. (inherited from DataPointCustomProperties )
MarkerBorderColor | Gets or sets the border color of the marker. (inherited from DataPointCustomProperties )
MarkerBorderWidth | Gets or sets the border width of the marker. (inherited from DataPointCustomProperties )
MarkerColor | Gets or sets the marker color. (inherited from DataPointCustomProperties )
MarkerImage | Gets or sets the marker image. (inherited from DataPointCustomProperties )
MarkerImageTransparentColor | Gets or sets the color that will be replaced with a transparent color when the marker image is drawn. (inherited from DataPointCustomProperties )
MarkerSize | Gets or sets the size of the marker. (inherited from DataPointCustomProperties )
MarkerStep | Gets or sets a value that determines how often to display data point markers.
MarkerStyle | Gets or sets the marker style. (inherited from DataPointCustomProperties )
Name | Overridden. Gets or sets the unique name of a Series object.
Palette | Gets or sets the color palette of a Series object.
Points | Gets a DataPointCollection object.
ShadowColor | Gets or sets the shadow color of a series.
ShadowOffset | Gets or sets the shadow offset, in pixels, of a series.
SmartLabelStyle | Gets or sets the style of the smart labels.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
ToolTip | Gets or sets the tooltip. (inherited from DataPointCustomProperties )
XAxisType | Gets or sets the X-axis type of the series.
XValueMember | Gets or sets the member of the chart data source used to data bind to the X-value of the series.
XValueType | Gets or sets the value types plotted along the X-axis.
YAxisType | Gets or sets the Y-axis type of a series.
YValueMembers | Gets or sets member columns of the chart data source used to bind data to the Y-values of the series.
YValuesPerPoint | Gets or sets the maximum number of Y-values that DataPoint objects in a Series are allowed to have.
YValueType | Gets or sets the type of Y-value data in the data points stored by a series.

See Also

Reference

Series Class


Series.AxisLabel Property

Series.AxisLabel Property |
 | See Also

Gets or sets the axis label text for the series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property AxisLabel As String
[BrowsableAttribute(false)]
public override string AxisLabel { get; set; }
[BrowsableAttribute(false)]
public:
virtual property String^ AxisLabel {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_AxisLabel ()

/** @property */
public void set_AxisLabel (String value)

public override function get AxisLabel () : String

public override function set AxisLabel (value : String)

Property Value

A string value. The default value is a zero-length string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.ChartArea Property

Series.ChartArea Property |
 | See Also

Gets or sets the name of the ChartArea object used to plot the data series, if any.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ChartArea As String
public string ChartArea { get; set; }
public:
property String^ ChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ChartArea ()

/** @property */
public void set_ChartArea (String value)

public function get ChartArea () : String

public function set ChartArea (value : String)

Property Value

A string value that represents a ChartArea object, which is used to plot the series.

Remarks

When a series is added at both design time and run time, it is automatically assigned to the "Default" ChartArea object, or the first available chart area in the ChartAreaCollection if "Default" does not exist.

Set this property to a zero-length string if you do not want the series to be plotted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.ChartType Property

Series.ChartType Property |
 | See Also

Gets or sets the chart type of a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ChartType As SeriesChartType
public SeriesChartType ChartType { get; set; }
public:
property SeriesChartType ChartType {
    SeriesChartType get ();
    void set (SeriesChartType value);
}
/** @property */
public SeriesChartType get_ChartType ()

/** @property */
public void set_ChartType (SeriesChartType value)

public function get ChartType () : SeriesChartType

public function set ChartType (value : SeriesChartType)

Property Value

A SeriesChartType enumeration value that indicates the chart type that will be used to represent the series. The default value is Column.

Remarks

This property determines the chart type of the Series object; the value is case-sensitive. See the SeriesChartType enumeration for a list of all possible chart types for a series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.ChartTypeName Property

Series.ChartTypeName Property |
 | See Also

Gets or sets the name of the chart type used to draw the series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Property ChartTypeName As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string ChartTypeName { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property String^ ChartTypeName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ChartTypeName ()

/** @property */
public void set_ChartTypeName (String value)

public function get ChartTypeName () : String

public function set ChartTypeName (value : String)

Property Value

A string value that represents the name of the chart type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.EmptyPointStyle Property

Series.EmptyPointStyle Property |
 | See Also

Gets or sets the drawing style of points marked as empty.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property EmptyPointStyle As DataPointCustomProperties
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public DataPointCustomProperties EmptyPointStyle { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property DataPointCustomProperties^ EmptyPointStyle {
    DataPointCustomProperties^ get ();
    void set (DataPointCustomProperties^ value);
}
/** @property */
public DataPointCustomProperties get_EmptyPointStyle ()

/** @property */
public void set_EmptyPointStyle (DataPointCustomProperties value)

public function get EmptyPointStyle () : DataPointCustomProperties

public function set EmptyPointStyle (value : DataPointCustomProperties)

Property Value

A DataPointCustomProperties object.

Remarks

The EmptyPointStyle property determines the drawing style of points marked as empty, for example, in the border color, in the marker images, background color or images, and so forth.

Certain properties are only applicable for specific chart types. For example, the BackImage property does not apply to line charts, but does apply to an area chart.

To display an image that indicates an empty point, use the MarkerImage and MarkerStyle properties, and not the BackImage property.

The AxisLabel property determines the axis label for empty points. Note that for stacked chart types, the axis label is determined by the AxisLabel property of the first plotted series that has this property set.

Data points can be manually marked as an empty by setting the IsEmpty property to true. Alternatively, one of the InsertEmptyPoints methods in the DataManipulator class can be used to check for missing data and insert empty points if a data point is missing.

Note:
In the case of line-type charts, the line color for lines that connect to an empty point is determined by the Color property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Enabled Property

Series.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether the series will be visible on the rendered chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Enabled As Boolean
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if the series will be visible on the rendered chart, otherwise false. The default value is true.

Remarks

Gets or sets a value that determines if the series will be visible on the rendered ChartArea.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.IsXValueIndexed Property

Series.IsXValueIndexed Property |
 | See Also

Gets or sets a flag that indicates whether data point indices will be used for the X-values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsXValueIndexed As Boolean
public bool IsXValueIndexed { get; set; }
public:
property bool IsXValueIndexed {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsXValueIndexed ()

/** @property */
public void set_IsXValueIndexed (boolean value)

public function get IsXValueIndexed () : boolean

public function set IsXValueIndexed (value : boolean)

Property Value

True if the indices of data points that belong to the series will be used for X-values; false if they will not. The default value is false.

Remarks

All data points in a series use sequential indices, and if this property is true then data points will be plotted sequentially, regardless of their associated X-values. This means that there will be no "missing" data points.

For example, assume there are three (3) data points in a series having X-values of 1, 2 and 4. If this property was false, there would be a data point missing at the X-axis location labeled "3". However, if you set this property to true, the three data points will be plotted at points 1, 2, and 4, sequentially, and there will be no missing data point. The X-axis location labeled "3" will not appear on the chart.

This is useful when you do not want to have missing data points for intervals that you know you will not have data for, such as weekends.

Important:
If you are displaying multiple series and at least one series uses indexed X-values, then all series must be aligned—that is, have the same number of data points—and the corresponding points must have the same X-values.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Legend Property

Series.Legend Property |
 | See Also

Gets or sets the name of the series associated with the Legend object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Legend As String
public string Legend { get; set; }
public:
property String^ Legend {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Legend ()

/** @property */
public void set_Legend (String value)

public function get Legend () : String

public function set Legend (value : String)

Property Value

A string value that represents the name of a Legend object.

Remarks

When a series is added at both design time and run time, it is automatically assigned to the default Legend object.

If you do not want the series shown in a legend, set this property to a zero-length string, or set the IsVisibleInLegend property to false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.MarkerStep Property

Series.MarkerStep Property |
 | See Also

Gets or sets a value that determines how often to display data point markers.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property MarkerStep As Integer
public int MarkerStep { get; set; }
public:
property int MarkerStep {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarkerStep ()

/** @property */
public void set_MarkerStep (int value)

public function get MarkerStep () : int

public function set MarkerStep (value : int)

Property Value

An integer value that determines how often to display data point markers. The default value is one (1).

Remarks

The MarkerStep property specifies the frequency with which markers are displayed. For example, if you set this property to two (2), every other data point will use a marker.

This property is only used if markers are enabled using the MarkerStyle property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Name Property

Series.Name Property |
 | See Also

Gets or sets the unique name of a Series object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Name As String
public override string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_Name ()

/** @property */
public void set_Name (String value)

public override function get Name () : String

public override function set Name (value : String)

Property Value

A string value that represents the unique name of the data series.

Remarks

The name of a data series must be unique; otherwise an exception will be thrown.

This property can be used as the indexer when you retrieve a Series object from the SeriesCollection object.

If this property is set to a zero-length string, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Palette Property

Series.Palette Property |
 | See Also

Gets or sets the color palette of a Series object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Palette As ChartColorPalette
public ChartColorPalette Palette { get; set; }
public:
property ChartColorPalette Palette {
    ChartColorPalette get ();
    void set (ChartColorPalette value);
}
/** @property */
public ChartColorPalette get_Palette ()

/** @property */
public void set_Palette (ChartColorPalette value)

public function get Palette () : ChartColorPalette

public function set Palette (value : ChartColorPalette)

Property Value

An ChartColorPalette enumeration value that determines the palette for the data series.

Remarks

A palette is used to automatically assign colors to data elements if the data points themselves do not have colors assigned to them and if the data Series object that the data points belong to also does not have an assigned color.

If no series or data point colors are explicitly specified, the colors used depend on the chart type and the Chart control palette or Series palette, if one is specified. See the table below for further details:

Chart Type | Series Palette Used? | Colors Displayed by Data Points
Any shape chart (for example, Pie and Doughnut charts) | No | First available colors used from Chart control palette. One color per data point.
All charts except shape charts. | No | First available colors from Chart control palette. One color per data series.
Any shape chart (for example, Pie and Doughnut charts) | Yes | First available colors used from Series palette. One color per data point.
All charts except shape charts. | Yes | First available colors used from Series palette. One color per data series.

This Palette property has precedence over the Palette property of the root Chart object, with respect to the display of data.

NOTE: If the Palette property for both the Chart and Series objects is set to None, and no color is assigned to the relevant data series/data points, the default palette "BrightPastel" or PaletteCustomColors is used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.Points Property

Series.Points Property |
 | See Also

Gets a DataPointCollection object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Points As DataPointCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public DataPointCollection Points { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property DataPointCollection^ Points {
    DataPointCollection^ get ();
}
/** @property */
public DataPointCollection get_Points ()

public function get Points () : DataPointCollection

Property Value

A DataPointCollection object that represents a collection of DataPoint objects.

Remarks

The Points collection property allows you to add and remove data points to a series. This property also provides methods and properties that can be used to manipulate this collection, such as finding data points, performing data-binding, and so forth.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.ShadowColor Property

Series.ShadowColor Property |
 | See Also

Gets or sets the shadow color of a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

Gets or sets the shadow color of a series, which can be to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a realistic shadow effect; try using a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.ShadowOffset Property

Series.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset of the series, in pixels.

Remarks

To implement shadowing, use a value other than zero (0). A positive value will result in a shadow that shifts down and to the right. A negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.SmartLabelStyle Property

Series.SmartLabelStyle Property |
 | See Also

Gets or sets the style of the smart labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(True)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property SmartLabelStyle As SmartLabelStyle
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public SmartLabelStyle SmartLabelStyle { get; set; }
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property SmartLabelStyle^ SmartLabelStyle {
    SmartLabelStyle^ get ();
    void set (SmartLabelStyle^ value);
}
/** @property */
public SmartLabelStyle get_SmartLabelStyle ()

/** @property */
public void set_SmartLabelStyle (SmartLabelStyle value)

public function get SmartLabelStyle () : SmartLabelStyle

public function set SmartLabelStyle (value : SmartLabelStyle)

Property Value

A SmartLabelStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.XAxisType Property

Series.XAxisType Property |
 | See Also

Gets or sets the X-axis type of the series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property XAxisType As AxisType
public AxisType XAxisType { get; set; }
public:
property AxisType XAxisType {
    AxisType get ();
    void set (AxisType value);
}
/** @property */
public AxisType get_XAxisType ()

/** @property */
public void set_XAxisType (AxisType value)

public function get XAxisType () : AxisType

public function set XAxisType (value : AxisType)

Property Value

A XAxisType enumeration value that determines if the series uses the primary or secondary X-axis.

Remarks

For all chart types except horizontally oriented charts such as bar and stacked bar charts, and shape charts such as pie, doughnut, funnel and pyramid charts, the primary X-axis is always the lower axis and the secondary axis is the upper axis. For bar and stacked bar charts, the primary X-axis is the left axis, and the secondary X-axis is the right axis.

When data is plotted using the secondary X-axis, you must use the AxisX2 property to set axis properties, and not the AxisX property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.XValueMember Property

Series.XValueMember Property |
 | See Also

Gets or sets the member of the chart data source used to data bind to the X-value of the series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property XValueMember As String
public string XValueMember { get; set; }
public:
property String^ XValueMember {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_XValueMember ()

/** @property */
public void set_XValueMember (String value)

public function get XValueMember () : String

public function set XValueMember (value : String)

Property Value

A string value.

Remarks

This property accepts either the name of the member column or the ordinal value of the member column.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.XValueType Property

Series.XValueType Property |
 | See Also

Gets or sets the value types plotted along the X-axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property XValueType As ChartValueType
public ChartValueType XValueType { get; set; }
public:
property ChartValueType XValueType {
    ChartValueType get ();
    void set (ChartValueType value);
}
/** @property */
public ChartValueType get_XValueType ()

/** @property */
public void set_XValueType (ChartValueType value)

public function get XValueType () : ChartValueType

public function set XValueType (value : ChartValueType)

Property Value

A ChartValueType enumeration value that determines the type of X-value data stored by the series. The default value is Auto.

Remarks

The XValueType property determines the type of data stored by the series.

Set this property to DateTime to allow the X-value to be entered as a DateTime value, and not as a Double. Date and time values are internally stored by .NET Framework as Double values. The same holds true for the ToPosition and FromPosition properties of CustomLabel objects.

The IntervalType property found in axis label, tick mark, and grid classes determines the interval type.

Note:
To correctly apply a DateTime format to axis labels that are generated from data point X-values, using the Format property, this property must be set to DateTime.

This property can also be used to determine the data type to which the X-values are bound.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.YAxisType Property

Series.YAxisType Property |
 | See Also

Gets or sets the Y-axis type of a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property YAxisType As AxisType
public AxisType YAxisType { get; set; }
public:
property AxisType YAxisType {
    AxisType get ();
    void set (AxisType value);
}
/** @property */
public AxisType get_YAxisType ()

/** @property */
public void set_YAxisType (AxisType value)

public function get YAxisType () : AxisType

public function set YAxisType (value : AxisType)

Property Value

An AxisType enumeration value that determines if a series uses the primary or secondary Y-axis.

Remarks

The YAxisType property determines if a series is plotted using the primary or secondary Y-axis.

For all chart types except pie, doughnut, range bar, bar and stacked bar charts, the primary Y-axis is the left vertical axis, and the secondary axis is the right vertical axis. For bar and stacked bar charts, the primary axis is the lower horizontal axis, and the secondary Y-axis is the upper horizontal axis.

When data is plotted using the secondary Y-axis, you must use the AxisY2 property to set axis properties, and not the AxisY property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.YValueMembers Property

Series.YValueMembers Property |
 | See Also

Gets or sets member columns of the chart data source used to bind data to the Y-values of the series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property YValueMembers As String
public string YValueMembers { get; set; }
public:
property String^ YValueMembers {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_YValueMembers ()

/** @property */
public void set_YValueMembers (String value)

public function get YValueMembers () : String

public function set YValueMembers (value : String)

Property Value

A string value.

Remarks

This property accepts a comma separated string that contains the names or ordinal values of the columns.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.YValuesPerPoint Property

Series.YValuesPerPoint Property |
 | See Also

Gets or sets the maximum number of Y-values that DataPoint objects in a Series are allowed to have.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property YValuesPerPoint As Integer
public int YValuesPerPoint { get; set; }
public:
property int YValuesPerPoint {
    int get ();
    void set (int value);
}
/** @property */
public int get_YValuesPerPoint ()

/** @property */
public void set_YValuesPerPoint (int value)

public function get YValuesPerPoint () : int

public function set YValuesPerPoint (value : int)

Property Value

An integer value that represents the maximum number of Y-values that the data points in a series are allowed to have. The default value to one (1).

Remarks

If you add a DataPoint object that has more Y-values than this property specifies, the excess Y-values will be ignored.

The number of Y-values that are required to properly display a chart depends on the chart type selected.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


Series.YValueType Property

Series.YValueType Property |
 | See Also

Gets or sets the type of Y-value data in the data points stored by a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property YValueType As ChartValueType
public ChartValueType YValueType { get; set; }
public:
property ChartValueType YValueType {
    ChartValueType get ();
    void set (ChartValueType value);
}
/** @property */
public ChartValueType get_YValueType ()

/** @property */
public void set_YValueType (ChartValueType value)

public function get YValueType () : ChartValueType

public function set YValueType (value : ChartValueType)

Property Value

A ChartValueType enumeration value that determines the type of Y-value data stored by the series. The default value is Auto.

Remarks

The YValueType property determines the type of data stored by the series. The value of this property is normally set to either Auto or DateTime.

The IntervalType property found in axis label, tick mark, and grid classes determines the interval type.

This property can also be used to determine the data type to which the Y-values are bound.

It is possible to plot date expressions as the values of data points, though this is rarely done. If you set this property to DateTime, the Y-value can then entered as a DateTime value, and not as a Double. Date and time values are internally stored by .NET Framework as Double values.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Series Class
Series Members


SeriesChartType Enumeration

SeriesChartType Enumeration |
 | See Also

Specifies a chart type for a Series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration SeriesChartType
public enum SeriesChartType
public enum class SeriesChartType
public enum SeriesChartType
public enum SeriesChartType

Members

Member name | Description
Area | Area chart type.
Bar | Bar chart type.
BoxPlot | Box plot chart type.
Bubble | Bubble chart type.
Candlestick | Candlestick chart type.
Column | Column chart type.
Doughnut | Doughnut chart type.
ErrorBar | Error bar chart type.
FastLine | FastLine chart type.
FastPoint | FastPoint chart type.
Funnel | Funnel chart type.
Kagi | Kagi chart type.
Line | Line chart type.
Pie | Pie chart type.
Point | Point chart type.
PointAndFigure | PointAndFigure chart type.
Polar | Polar chart type.
Pyramid | Pyramid chart type.
Radar | Radar chart type.
Range | Range chart type.
RangeBar | RangeBar chart type.
RangeColumn | Range column chart type.
Renko | Renko chart type.
Spline |
SplineArea |
SplineRange |
StackedArea |
StackedArea100 |
StackedBar |
StackedBar100 |
StackedColumn |
StackedColumn100 |
StepLine |
Stock |
ThreeLineBreak |

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


SeriesCollection Class

SeriesCollection Class |
 | See Also Members

Represents a collection of Series objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class SeriesCollection
    Inherits ChartNamedElementCollection(Of Series)
public class SeriesCollection : ChartNamedElementCollection<Series>
public ref class SeriesCollection : public ChartNamedElementCollection<Series^>
public class SeriesCollection extends ChartNamedElementCollection<Series>
public class SeriesCollection extends ChartNamedElementCollection<Series>

Remarks

The SeriesCollection class represents a collection of Series objects, which in turn represent a grouping of related data points and attributes for the series. This collection class is implemented as the Series collection property of the root Chart object.

Series objects can be appended, inserted or removed from the collection at both design time and run time.

When a series is added to the collection, it is automatically assigned to the ChartArea object named "Default" or, if "Default" does not exist, to the first available chart area in the chart area collection.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.SeriesCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SeriesCollection Members


SeriesCollection Members

SeriesCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of Series objects.

The following tables list the members exposed by the SeriesCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

SeriesCollection Class


SeriesCollection Methods

SeriesCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

SeriesCollection Class


SeriesCollection.Add Method

SeriesCollection.Add Method |
 | See Also

Overload List

Name | Description
SeriesCollection.Add (Series) | (inherited from Add )
SeriesCollection.Add (String) | Adds a Series object to the end of the collection.

See Also

Reference

SeriesCollection Class
SeriesCollection Members


SeriesCollection.Add Method (String)

SeriesCollection.Add Method (String) |
 | See Also

Adds a Series object to the end of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As Series
public Series Add (
    string name
)
public:
Series^ Add (
    String^ name
)
public Series Add (
    String name
)
public function Add (
    name : String
) : Series

Parameters

name

The name of the Series to be added.

Return Value

The new Series object appended to the collection..

Remarks

Items are always added as the last item in the collection.

The name argument refers to the Name property of the object being added.

Note If you use this method to add Series objects to the SeriesCollection class, the associated DataPoint objects of the newly added Series object cannot have more than one Y-value per data point. To add a series that can handle multiple Y-values per data point, use the Add definition of this overloaded method.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SeriesCollection Class
SeriesCollection Members


SeriesCollection Properties

SeriesCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

SeriesCollection Class


SmartLabelStyle Class

SmartLabelStyle Class |
 | See Also Members

Provides methods and properties used to perform intelligent, rule-based data point label positioning to resolve overlapping data point label issues.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class SmartLabelStyle
public class SmartLabelStyle
public ref class SmartLabelStyle
public class SmartLabelStyle
public class SmartLabelStyle

Remarks

When smart labels are enabled, the chart repositions overlapping data point labels, based on a set of user-defined rules.

Callout lines will be drawn to link the label with its data point. The visual attributes of the callout line can be controlled. These visual attributes include color, line style, and line width. The CalloutStyle and CalloutLineAnchorCapStyle properties control the embellishments, such as arrowheads, that appear at the end of the callout line.

The CalloutLineColor property can be set to any Color object. If you set the color of the callout line, you will also automatically set the color of the CalloutLineAnchorCapStyle and the embellishment defined by the CalloutStyle.

The CalloutLineWidth property controls the pixel width of the callout line. Use of this property will also scale the embellishments of the CalloutLineAnchorCapStyle and the CalloutStyle.

The movement of smart labels can be controlled through the use of several motion-related properties. These define the rules of movement for the direction, distance and whether the data point label is allowed to leave the plotting area. The default movement rules will normally resolve most issues. The MaxMovingDistance defines a value that specifies the maximum distance in pixels from the data point that data point labels are allowed to be moved in case of overlapping. The MinMovingDistance property defines a value that specifies the minimum distance in pixels from the data point that data point labels will be moved in case of overlapping. When a data point label needs to be repositioned, the label will be moved by at least the number of pixels specified.

The IsOverlappedHidden property indicates whether the labels are hidden when overlapping issues cannot be resolved. If the IsOverlappedHidden property is true, and the data point cannot be drawn within the region specified by MinMovingDistance and MaxMovingDistance in the directions allowed by MovingDirection, the data point label will not be drawn.

The MovingDirection property defines the direction(s) in which the data point label can be moved. This property accepts one LabelAlignmentStyles value or a bitwise-OR of multiple LabelAlignmentStyles values. The default is the bitwise-OR of all LabelAlignmentStyles values, to allow repositioning in all possible directions except to the center of the data point.

Smart labels are not supported for the following chart types:

  • Bar charts: bar and hundred-percent-stacked bar charts.

  • Shape charts: pie, doughnut, polar and radar charts.

  • Range charts: range, range column and range bar charts.

  • Stacked area charts: stacked area and hundred-percent-stacked area charts.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.SmartLabelStyle
System.Windows.Forms.DataVisualization.Charting.AnnotationSmartLabelStyle

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Members


SmartLabelStyle Members

SmartLabelStyle Members |
 | See Also Constructors Methods Properties

Provides methods and properties used to perform intelligent, rule-based data point label positioning to resolve overlapping data point label issues.

The following tables list the members exposed by the SmartLabelStyle type.

Public Constructors

Name | Description
SmartLabelStyle | Initializes a new instance of the SmartLabelStyle class.
Top

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area.
CalloutBackColor | Gets or sets the background color of the label callout.
CalloutLineAnchorCapStyle | Gets or sets the anchor cap style of the label callout line.
CalloutLineColor | Gets or sets the color of the label callout line.
CalloutLineDashStyle | Gets or sets the style of the label callout line.
CalloutLineWidth | Gets or sets the width of the label callout line.
CalloutStyle | Gets or sets the callout style of the repositioned SmartLabelStyle object.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled.
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker.
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden.
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

SmartLabelStyle Class


SmartLabelStyle Constructor

SmartLabelStyle Constructor |
 | See Also

Initializes a new instance of the SmartLabelStyle class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public SmartLabelStyle ()
public:
SmartLabelStyle ()
public SmartLabelStyle ()
public function SmartLabelStyle ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle Methods

SmartLabelStyle Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

SmartLabelStyle Class


SmartLabelStyle Properties

SmartLabelStyle Properties |
 | See Also

Public Properties

Name | Description
AllowOutsidePlotArea | Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area.
CalloutBackColor | Gets or sets the background color of the label callout.
CalloutLineAnchorCapStyle | Gets or sets the anchor cap style of the label callout line.
CalloutLineColor | Gets or sets the color of the label callout line.
CalloutLineDashStyle | Gets or sets the style of the label callout line.
CalloutLineWidth | Gets or sets the width of the label callout line.
CalloutStyle | Gets or sets the callout style of the repositioned SmartLabelStyle object.
Enabled | Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled.
IsMarkerOverlappingAllowed | Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker.
IsOverlappedHidden | Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden.
MaxMovingDistance | Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MinMovingDistance | Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.
MovingDirection | Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved.

See Also

Reference

SmartLabelStyle Class


SmartLabelStyle.AllowOutsidePlotArea Property

SmartLabelStyle.AllowOutsidePlotArea Property |
 | See Also

Gets or sets a flag that specifies whether a SmartLabelStyle object can be drawn outside the plotting area.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property AllowOutsidePlotArea As LabelOutsidePlotAreaStyle
public virtual LabelOutsidePlotAreaStyle AllowOutsidePlotArea { get; set; }
public:
virtual property LabelOutsidePlotAreaStyle AllowOutsidePlotArea {
    LabelOutsidePlotAreaStyle get ();
    void set (LabelOutsidePlotAreaStyle value);
}
/** @property */
public LabelOutsidePlotAreaStyle get_AllowOutsidePlotArea ()

/** @property */
public void set_AllowOutsidePlotArea (LabelOutsidePlotAreaStyle value)

public function get AllowOutsidePlotArea () : LabelOutsidePlotAreaStyle

public function set AllowOutsidePlotArea (value : LabelOutsidePlotAreaStyle)

Property Value

A LabelOutsidePlotAreaStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.CalloutBackColor Property

SmartLabelStyle.CalloutBackColor Property |
 | See Also

Gets or sets the background color of the label callout.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutBackColor As Color
public virtual Color CalloutBackColor { get; set; }
public:
virtual property Color CalloutBackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_CalloutBackColor ()

/** @property */
public void set_CalloutBackColor (Color value)

public function get CalloutBackColor () : Color

public function set CalloutBackColor (value : Color)

Property Value

A Color value.

Remarks

This property is only applicable when the CalloutStyle property is set to a value of Box.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.CalloutLineAnchorCapStyle Property

SmartLabelStyle.CalloutLineAnchorCapStyle Property |
 | See Also

Gets or sets the anchor cap style of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineAnchorCapStyle As LineAnchorCapStyle
public virtual LineAnchorCapStyle CalloutLineAnchorCapStyle { get; set; }
public:
virtual property LineAnchorCapStyle CalloutLineAnchorCapStyle {
    LineAnchorCapStyle get ();
    void set (LineAnchorCapStyle value);
}
/** @property */
public LineAnchorCapStyle get_CalloutLineAnchorCapStyle ()

/** @property */
public void set_CalloutLineAnchorCapStyle (LineAnchorCapStyle value)

public function get CalloutLineAnchorCapStyle () : LineAnchorCapStyle

public function set CalloutLineAnchorCapStyle (value : LineAnchorCapStyle)

Property Value

A LineAnchorCapStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.CalloutLineColor Property

SmartLabelStyle.CalloutLineColor Property |
 | See Also

Gets or sets the color of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineColor As Color
public virtual Color CalloutLineColor { get; set; }
public:
virtual property Color CalloutLineColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_CalloutLineColor ()

/** @property */
public void set_CalloutLineColor (Color value)

public function get CalloutLineColor () : Color

public function set CalloutLineColor (value : Color)

Property Value

A Color value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.CalloutLineDashStyle Property

SmartLabelStyle.CalloutLineDashStyle Property |
 | See Also

Gets or sets the style of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineDashStyle As ChartDashStyle
public virtual ChartDashStyle CalloutLineDashStyle { get; set; }
public:
virtual property ChartDashStyle CalloutLineDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_CalloutLineDashStyle ()

/** @property */
public void set_CalloutLineDashStyle (ChartDashStyle value)

public function get CalloutLineDashStyle () : ChartDashStyle

public function set CalloutLineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.CalloutLineWidth Property

SmartLabelStyle.CalloutLineWidth Property |
 | See Also

Gets or sets the width of the label callout line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutLineWidth As Integer
public virtual int CalloutLineWidth { get; set; }
public:
virtual property int CalloutLineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_CalloutLineWidth ()

/** @property */
public void set_CalloutLineWidth (int value)

public function get CalloutLineWidth () : int

public function set CalloutLineWidth (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.CalloutStyle Property

SmartLabelStyle.CalloutStyle Property |
 | See Also

Gets or sets the callout style of the repositioned SmartLabelStyle object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property CalloutStyle As LabelCalloutStyle
public virtual LabelCalloutStyle CalloutStyle { get; set; }
public:
virtual property LabelCalloutStyle CalloutStyle {
    LabelCalloutStyle get ();
    void set (LabelCalloutStyle value);
}
/** @property */
public LabelCalloutStyle get_CalloutStyle ()

/** @property */
public void set_CalloutStyle (LabelCalloutStyle value)

public function get CalloutStyle () : LabelCalloutStyle

public function set CalloutStyle (value : LabelCalloutStyle)

Property Value

A LabelCalloutStyle enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.Enabled Property

SmartLabelStyle.Enabled Property |
 | See Also

Gets or sets a flag that indicates whether a SmartLabelStyle algorithm is enabled.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Enabled As Boolean
public virtual bool Enabled { get; set; }
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Enabled ()

/** @property */
public void set_Enabled (boolean value)

public function get Enabled () : boolean

public function set Enabled (value : boolean)

Property Value

True if an algorithm will be applied to prevent data point labels from overlapping. False if overlapping of data point labels will not be prevented. The default value is True.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.IsMarkerOverlappingAllowed Property

SmartLabelStyle.IsMarkerOverlappingAllowed Property |
 | See Also

Gets or sets a flag that specifies whether the point labels are allowed to overlap a point marker.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsMarkerOverlappingAllowed As Boolean
public virtual bool IsMarkerOverlappingAllowed { get; set; }
public:
virtual property bool IsMarkerOverlappingAllowed {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMarkerOverlappingAllowed ()

/** @property */
public void set_IsMarkerOverlappingAllowed (boolean value)

public function get IsMarkerOverlappingAllowed () : boolean

public function set IsMarkerOverlappingAllowed (value : boolean)

Property Value

True if data point labels are permitted to overlap point markers. False if data point labels will be prevented from overlapping the point markers. The default value is false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.IsOverlappedHidden Property

SmartLabelStyle.IsOverlappedHidden Property |
 | See Also

Gets or sets a flag that indicates whether overlapped labels that cannot be repositioned will be hidden.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsOverlappedHidden As Boolean
public virtual bool IsOverlappedHidden { get; set; }
public:
virtual property bool IsOverlappedHidden {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsOverlappedHidden ()

/** @property */
public void set_IsOverlappedHidden (boolean value)

public function get IsOverlappedHidden () : boolean

public function set IsOverlappedHidden (value : boolean)

Property Value

True if labels will be hidden if they overlap. False if overlapped labels will not be hidden. The default value is True.

Remarks

If the point cannot be drawn within the region specified by the properties MinMovingDistance and MaxMovingDistance, in the directions allowed by the MovingDirection, property, and this property is true, the data point label will not be drawn.

Note:
Smart labels only work when the Angle property is set to zero.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.MaxMovingDistance Property

SmartLabelStyle.MaxMovingDistance Property |
 | See Also

Gets or sets the maximum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property MaxMovingDistance As Double
public virtual double MaxMovingDistance { get; set; }
public:
virtual property double MaxMovingDistance {
    double get ();
    void set (double value);
}
/** @property */
public double get_MaxMovingDistance ()

/** @property */
public void set_MaxMovingDistance (double value)

public function get MaxMovingDistance () : double

public function set MaxMovingDistance (value : double)

Property Value

A double value.

Remarks

This property specifies the maximum distance in pixels from the data point that data point labels are allowed to be moved in case of overlapping.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.MinMovingDistance Property

SmartLabelStyle.MinMovingDistance Property |
 | See Also

Gets or sets the minimum distance, in pixels, that the overlapped SmartLabelStyle object can be moved from the marker.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property MinMovingDistance As Double
public virtual double MinMovingDistance { get; set; }
public:
virtual property double MinMovingDistance {
    double get ();
    void set (double value);
}
/** @property */
public double get_MinMovingDistance ()

/** @property */
public void set_MinMovingDistance (double value)

public function get MinMovingDistance () : double

public function set MinMovingDistance (value : double)

Property Value

A double value.

Remarks

This property specifies the minimum distance in pixels from the data point that data point labels are allowed to be moved in case of overlapping.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


SmartLabelStyle.MovingDirection Property

SmartLabelStyle.MovingDirection Property |
 | See Also

Gets or sets the direction(s) in which the overlapped SmartLabelStyle object is allowed to be moved.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property MovingDirection As LabelAlignmentStyles
public virtual LabelAlignmentStyles MovingDirection { get; set; }
public:
virtual property LabelAlignmentStyles MovingDirection {
    LabelAlignmentStyles get ();
    void set (LabelAlignmentStyles value);
}
/** @property */
public LabelAlignmentStyles get_MovingDirection ()

/** @property */
public void set_MovingDirection (LabelAlignmentStyles value)

public function get MovingDirection () : LabelAlignmentStyles

public function set MovingDirection (value : LabelAlignmentStyles)

Property Value

A LabelAlignmentStyles enumeration value or multiple bitwise OR'd LabelAlignmentStyles values. The default is the bitwise OR of all LabelAlignmentStyles values to allow repositioning in all directions except to the center of the data point.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

SmartLabelStyle Class
SmartLabelStyle Members


StartFromZero Enumeration

StartFromZero Enumeration |
 | See Also

Indicates whether an axis segment should start from zero when a scale break is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration StartFromZero
public enum StartFromZero
public enum class StartFromZero
public enum StartFromZero
public enum StartFromZero

Members

Member name | Description
Auto | The Chart control calculates whether to start the axis scale at zero or at a more appropriate rounded value.
No | Do not start the axis segment scale from zero.
Yes | Start the axis segment scale from zero.

Remarks

The StartFromZero enumeration is used to set the value of the StartFromZero property and indicates whether an axis segment should start from zero.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


StatisticFormula Class

StatisticFormula Class |
 | See Also Members

Calculates statistical formulas.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class StatisticFormula
public class StatisticFormula
public ref class StatisticFormula
public class StatisticFormula
public class StatisticFormula

Remarks

Formulas can be loosely grouped into the following categories: distributions, including inverse distributions; tests; and basic statistical formulas. Each group has common characteristics with respect to their input and return values.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.StatisticFormula

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Members


StatisticFormula Members

StatisticFormula Members |
 | See Also Methods

Calculates statistical formulas.

The following tables list the members exposed by the StatisticFormula type.

Public Methods (see also Protected Methods )

Name | Description
Anova | Performs an ANOVA test to determine whether there is a statistically significant difference between the mean values of two or more groups of data.
BetaFunction | Returns the beta function value for two given values.
Correlation | Returns the correlation value for two data series.
Covariance | Returns the covariance value for two data series.
Equals | Overloaded. (inherited from Object )
FDistribution | Returns the cumulative F distribution function probability.
FTest | Performs a two-sample F Test using the F distribution. This test is used to determine if the samples have different variances.
GammaFunction | Returns the gamma function value for the given variable.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
InverseFDistribution | Returns the inverse of the F cumulative distribution.
InverseNormalDistribution | Returns the inverse of the standard normal cumulative distribution.
InverseTDistribution | Returns the inverse t-value of the Students t-distribution as a function of probability and degree of freedom.
Mean | Returns the average of all data points stored in the specified series.
Median | Returns the median of all data points in the specified series.
NormalDistribution | Returns the probability for the standard normal cumulative distribution function.
ReferenceEquals | (inherited from Object )
TDistribution | Returns the probability for the T distribution (Student's distribution).
ToString | (inherited from Object )
TTestEqualVariances | Performs a T Test using Student's distribution (T distribution) with equal variances.
TTestPaired | Performs a T Test using Student's distribution (T distribution) with paired samples. This is useful when there is a natural pairing of observations in samples.
TTestUnequalVariances | Performs a T Test using Student's distribution (T distribution) with unequal variances.
Variance | Returns the variance for a series.
ZTest | Performs a Z Test using the Normal distribution.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

StatisticFormula Class


StatisticFormula Methods

StatisticFormula Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Anova | Performs an ANOVA test to determine whether there is a statistically significant difference between the mean values of two or more groups of data.
BetaFunction | Returns the beta function value for two given values.
Correlation | Returns the correlation value for two data series.
Covariance | Returns the covariance value for two data series.
Equals | Overloaded. (inherited from Object )
FDistribution | Returns the cumulative F distribution function probability.
FTest | Performs a two-sample F Test using the F distribution. This test is used to determine if the samples have different variances.
GammaFunction | Returns the gamma function value for the given variable.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
InverseFDistribution | Returns the inverse of the F cumulative distribution.
InverseNormalDistribution | Returns the inverse of the standard normal cumulative distribution.
InverseTDistribution | Returns the inverse t-value of the Students t-distribution as a function of probability and degree of freedom.
Mean | Returns the average of all data points stored in the specified series.
Median | Returns the median of all data points in the specified series.
NormalDistribution | Returns the probability for the standard normal cumulative distribution function.
ReferenceEquals | (inherited from Object )
TDistribution | Returns the probability for the T distribution (Student's distribution).
ToString | (inherited from Object )
TTestEqualVariances | Performs a T Test using Student's distribution (T distribution) with equal variances.
TTestPaired | Performs a T Test using Student's distribution (T distribution) with paired samples. This is useful when there is a natural pairing of observations in samples.
TTestUnequalVariances | Performs a T Test using Student's distribution (T distribution) with unequal variances.
Variance | Returns the variance for a series.
ZTest | Performs a Z Test using the Normal distribution.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

StatisticFormula Class


StatisticFormula.Anova Method

StatisticFormula.Anova Method |
 | See Also

Performs an ANOVA test to determine whether there is a statistically significant difference between the mean values of two or more groups of data.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Anova ( _
    probability As Double, _
    inputSeriesNames As String _
) As AnovaResult
public AnovaResult Anova (
    double probability,
    string inputSeriesNames
)
public:
AnovaResult^ Anova (
    double probability,
    String^ inputSeriesNames
)
public AnovaResult Anova (
    double probability,
    String inputSeriesNames
)
public function Anova (
    probability : double,
    inputSeriesNames : String
) : AnovaResult

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

inputSeriesNames

A comma-delimited list of input series names.

Return Value

An AnovaResult object.

Remarks

An ANOVA test is used to test the difference between the means of two or more groups of data.

Two or more groups of series data must be specified, and each series must have the same number of data points; otherwise, an exception will be raised.

If a specified input series does not exist in the SeriesCollection at the time of the method call, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.BetaFunction Method

StatisticFormula.BetaFunction Method |
 | See Also

Returns the beta function value for two given values.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="The Beta Function is a mathematical function where arbitrary letters to indicate inputs are common")> _
Public Function BetaFunction ( _
    m As Double, _
    n As Double _
) As Double
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="The Beta Function is a mathematical function where arbitrary letters to indicate inputs are common")]
public double BetaFunction (
    double m,
    double n
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"The Beta Function is a mathematical function where arbitrary letters to indicate inputs are common")]
public:
double BetaFunction (
    double m,
    double n
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="The Beta Function is a mathematical function where arbitrary letters to indicate inputs are common") */
public double BetaFunction (
    double m,
    double n
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="The Beta Function is a mathematical function where arbitrary letters to indicate inputs are common")
public function BetaFunction (
    m : double,
    n : double
) : double

Parameters

m

The first value for the beta function.

n

The second value for the beta function.

Return Value

A double value that represents the beta function for the two given values.

Remarks

This method returns the beta function value for two given values that are specified by m and n.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.Correlation Method

StatisticFormula.Correlation Method |
 | See Also

Returns the correlation value for two data series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Correlation ( _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As Double
public double Correlation (
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
double Correlation (
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public double Correlation (
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function Correlation (
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : double

Parameters

firstInputSeriesName

The first input series name.

secondInputSeriesName

The second input series name.

Return Value

A double value that represents the correlation between two data series.

Remarks

Correlation measures the relationship between two data sets that are scaled to be independent of the unit of measurement. The Correlation method returns the covariance of two data sets divided by the product of their standard deviations, and always ranges from -1 to 1.

Use correlation to determine whether two ranges of data move together; that is, whether large values of one set are associated with large values of the other (positive correlation), whether small values of one set are associated with large values of the other (negative correlation), or whether values in both sets are unrelated (correlation near zero).

If a specified input series does not exist in the series collection at the time of the method call, an exception will be thrown. An exception will also be raised if the specified series do not have the same number of data points.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.Covariance Method

StatisticFormula.Covariance Method |
 | See Also

Returns the covariance value for two data series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Covariance ( _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As Double
public double Covariance (
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
double Covariance (
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public double Covariance (
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function Covariance (
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : double

Parameters

firstInputSeriesName

The first input series name.

secondInputSeriesName

The second input series name.

Return Value

A double value that represents the covariance between two data series.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.FDistribution Method

StatisticFormula.FDistribution Method |
 | See Also

Returns the cumulative F distribution function probability.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FDistribution ( _
    value As Double, _
    firstDegreeOfFreedom As Integer, _
    secondDegreeOfFreedom As Integer _
) As Double
public double FDistribution (
    double value,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public:
double FDistribution (
    double value,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public double FDistribution (
    double value,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public function FDistribution (
    value : double,
    firstDegreeOfFreedom : int,
    secondDegreeOfFreedom : int
) : double

Parameters

value

The F value.

firstDegreeOfFreedom

First degree of freedom.

secondDegreeOfFreedom

Second degree of freedom.

Return Value

A double value that represents the cumulative F distribution function probability.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.FTest Method

StatisticFormula.FTest Method |
 | See Also

Performs a two-sample F Test using the F distribution. This test is used to determine if the samples have different variances.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function FTest ( _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As FTestResult
public FTestResult FTest (
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
FTestResult^ FTest (
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public FTestResult FTest (
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function FTest (
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : FTestResult

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

An FTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.GammaFunction Method

StatisticFormula.GammaFunction Method |
 | See Also

Returns the gamma function value for the given variable.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function GammaFunction ( _
    value As Double _
) As Double
public double GammaFunction (
    double value
)
public:
double GammaFunction (
    double value
)
public double GammaFunction (
    double value
)
public function GammaFunction (
    value : double
) : double

Parameters

value

The input variable.

Return Value

A double value that represents the gamma function.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.InverseFDistribution Method

StatisticFormula.InverseFDistribution Method |
 | See Also

Returns the inverse of the F cumulative distribution.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function InverseFDistribution ( _
    probability As Double, _
    firstDegreeOfFreedom As Integer, _
    secondDegreeOfFreedom As Integer _
) As Double
public double InverseFDistribution (
    double probability,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public:
double InverseFDistribution (
    double probability,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public double InverseFDistribution (
    double probability,
    int firstDegreeOfFreedom,
    int secondDegreeOfFreedom
)
public function InverseFDistribution (
    probability : double,
    firstDegreeOfFreedom : int,
    secondDegreeOfFreedom : int
) : double

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstDegreeOfFreedom

First degree of freedom.

secondDegreeOfFreedom

Second degree of freedom.

Return Value

A double value from the inverse F distribution function.

Remarks

This method returns the F value for the given F distribution probability.

The F distribution can be used in an F-test that compares the degree of variability in two data sets. For example, income distributions in the United States and Canada can be analyzed to determine whether the two countries have a similar degree of diversity.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.InverseNormalDistribution Method

StatisticFormula.InverseNormalDistribution Method |
 | See Also

Returns the inverse of the standard normal cumulative distribution.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function InverseNormalDistribution ( _
    probability As Double _
) As Double
public double InverseNormalDistribution (
    double probability
)
public:
double InverseNormalDistribution (
    double probability
)
public double InverseNormalDistribution (
    double probability
)
public function InverseNormalDistribution (
    probability : double
) : double

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

Return Value

A double value from the inverse standard normal cumulative distribution function.

Remarks

This method returns the F value for the given F distribution probability.

It is assumed that the distribution has a mean of 0 (zero) and a standard deviation of one.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.InverseTDistribution Method

StatisticFormula.InverseTDistribution Method |
 | See Also

Returns the inverse t-value of the Students t-distribution as a function of probability and degree of freedom.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function InverseTDistribution ( _
    probability As Double, _
    degreeOfFreedom As Integer _
) As Double
public double InverseTDistribution (
    double probability,
    int degreeOfFreedom
)
public:
double InverseTDistribution (
    double probability,
    int degreeOfFreedom
)
public double InverseTDistribution (
    double probability,
    int degreeOfFreedom
)
public function InverseTDistribution (
    probability : double,
    degreeOfFreedom : int
) : double

Parameters

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

degreeOfFreedom

The degree of freedom.

Return Value

A double value that represents the inverse T distribution.

Remarks

This method returns the t value for the given T distribution probability.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.Mean Method

StatisticFormula.Mean Method |
 | See Also

Returns the average of all data points stored in the specified series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Mean ( _
    inputSeriesName As String _
) As Double
public double Mean (
    string inputSeriesName
)
public:
double Mean (
    String^ inputSeriesName
)
public double Mean (
    String inputSeriesName
)
public function Mean (
    inputSeriesName : String
) : double

Parameters

inputSeriesName

Input series name.

Return Value

A double value that represents the average of all data points.

Remarks

Use this method to calculate the mean (that is, the average) of the points stored in a series.

If the specified input series does not exist in the SeriesCollection at the time of the method call, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.Median Method

StatisticFormula.Median Method |
 | See Also

Returns the median of all data points in the specified series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Median ( _
    inputSeriesName As String _
) As Double
public double Median (
    string inputSeriesName
)
public:
double Median (
    String^ inputSeriesName
)
public double Median (
    String inputSeriesName
)
public function Median (
    inputSeriesName : String
) : double

Parameters

inputSeriesName

Input series name.

Return Value

A double value that represents the median.

Remarks

Use this method to calculate the median of the points stored in a series.

The median is the middle value of a sample set, where half of the members are greater in size and half the members are lesser in size.

If the specified input series does not exist in the SeriesCollection at the time of the method call, an exception will be thrown.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.NormalDistribution Method

StatisticFormula.NormalDistribution Method |
 | See Also

Returns the probability for the standard normal cumulative distribution function.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="Z is a cartesian coordinate and well understood")> _
Public Function NormalDistribution ( _
    zValue As Double _
) As Double
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Z is a cartesian coordinate and well understood")]
public double NormalDistribution (
    double zValue
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"Z is a cartesian coordinate and well understood")]
public:
double NormalDistribution (
    double zValue
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Z is a cartesian coordinate and well understood") */
public double NormalDistribution (
    double zValue
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="Z is a cartesian coordinate and well understood")
public function NormalDistribution (
    zValue : double
) : double

Parameters

zValue

The Z value for which the probability is required.

Return Value

A double value from the standard normal cumulative distribution function.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.TDistribution Method

StatisticFormula.TDistribution Method |
 | See Also

Returns the probability for the T distribution (Student's distribution).

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function TDistribution ( _
    value As Double, _
    degreeOfFreedom As Integer, _
    oneTail As Boolean _
) As Double
public double TDistribution (
    double value,
    int degreeOfFreedom,
    bool oneTail
)
public:
double TDistribution (
    double value,
    int degreeOfFreedom,
    bool oneTail
)
public double TDistribution (
    double value,
    int degreeOfFreedom,
    boolean oneTail
)
public function TDistribution (
    value : double,
    degreeOfFreedom : int,
    oneTail : boolean
) : double

Parameters

value

The T value

degreeOfFreedom

Degree of freedom

oneTail

If true, a one-tailed distribution is used; otherwise, a two-tailed distribution is used.

Return Value

A double value that represents a T Distribution cumulative function.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.TTestEqualVariances Method

StatisticFormula.TTestEqualVariances Method |
 | See Also

Performs a T Test using Student's distribution (T distribution) with equal variances.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function TTestEqualVariances ( _
    hypothesizedMeanDifference As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As TTestResult
public TTestResult TTestEqualVariances (
    double hypothesizedMeanDifference,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
TTestResult^ TTestEqualVariances (
    double hypothesizedMeanDifference,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public TTestResult TTestEqualVariances (
    double hypothesizedMeanDifference,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function TTestEqualVariances (
    hypothesizedMeanDifference : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : TTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A TTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.TTestPaired Method

StatisticFormula.TTestPaired Method |
 | See Also

Performs a T Test using Student's distribution (T distribution) with paired samples. This is useful when there is a natural pairing of observations in samples.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function TTestPaired ( _
    hypothesizedMeanDifference As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As TTestResult
public TTestResult TTestPaired (
    double hypothesizedMeanDifference,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
TTestResult^ TTestPaired (
    double hypothesizedMeanDifference,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public TTestResult TTestPaired (
    double hypothesizedMeanDifference,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function TTestPaired (
    hypothesizedMeanDifference : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : TTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A TTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.TTestUnequalVariances Method

StatisticFormula.TTestUnequalVariances Method |
 | See Also

Performs a T Test using Student's distribution (T distribution) with unequal variances.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function TTestUnequalVariances ( _
    hypothesizedMeanDifference As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As TTestResult
public TTestResult TTestUnequalVariances (
    double hypothesizedMeanDifference,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
TTestResult^ TTestUnequalVariances (
    double hypothesizedMeanDifference,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public TTestResult TTestUnequalVariances (
    double hypothesizedMeanDifference,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function TTestUnequalVariances (
    hypothesizedMeanDifference : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : TTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A TTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.Variance Method

StatisticFormula.Variance Method |
 | See Also

Returns the variance for a series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Variance ( _
    inputSeriesName As String, _
    sampleVariance As Boolean _
) As Double
public double Variance (
    string inputSeriesName,
    bool sampleVariance
)
public:
double Variance (
    String^ inputSeriesName,
    bool sampleVariance
)
public double Variance (
    String inputSeriesName,
    boolean sampleVariance
)
public function Variance (
    inputSeriesName : String,
    sampleVariance : boolean
) : double

Parameters

inputSeriesName

The input series name.

sampleVariance

True if the data is a sample of the population; false if the data is the entire population.

Return Value

A double value that represents the variance.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StatisticFormula.ZTest Method

StatisticFormula.ZTest Method |
 | See Also

Performs a Z Test using the Normal distribution.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function ZTest ( _
    hypothesizedMeanDifference As Double, _
    varianceFirstGroup As Double, _
    varianceSecondGroup As Double, _
    probability As Double, _
    firstInputSeriesName As String, _
    secondInputSeriesName As String _
) As ZTestResult
public ZTestResult ZTest (
    double hypothesizedMeanDifference,
    double varianceFirstGroup,
    double varianceSecondGroup,
    double probability,
    string firstInputSeriesName,
    string secondInputSeriesName
)
public:
ZTestResult^ ZTest (
    double hypothesizedMeanDifference,
    double varianceFirstGroup,
    double varianceSecondGroup,
    double probability,
    String^ firstInputSeriesName,
    String^ secondInputSeriesName
)
public ZTestResult ZTest (
    double hypothesizedMeanDifference,
    double varianceFirstGroup,
    double varianceSecondGroup,
    double probability,
    String firstInputSeriesName,
    String secondInputSeriesName
)
public function ZTest (
    hypothesizedMeanDifference : double,
    varianceFirstGroup : double,
    varianceSecondGroup : double,
    probability : double,
    firstInputSeriesName : String,
    secondInputSeriesName : String
) : ZTestResult

Parameters

hypothesizedMeanDifference

Hypothesized mean difference.

varianceFirstGroup

Variance of the first group.

varianceSecondGroup

Variance of the second group.

probability

The alpha value, which is the probability that the hypothesis is rejected. The allowable range is 0-1.

firstInputSeriesName

First input series name.

secondInputSeriesName

Second input series name.

Return Value

A ZTestResult object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StatisticFormula Class
StatisticFormula Members


StripLine Class

StripLine Class |
 | See Also Members

Represents the strip lines on a chart.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class StripLine
    Inherits ChartElement
public class StripLine : ChartElement
public ref class StripLine : public ChartElement
public class StripLine extends ChartElement
public class StripLine extends ChartElement

Remarks

Strip lines, or strips, are horizontal or vertical ranges that shade the background of a chart in regular or custom intervals. You can use strip lines to:

  • Improve readability for looking up individual values on the chart.

  • Separate data points when reading the chart.

  • Highlight dates that occur at regular intervals, for example, to identify weekend data points.

  • Highlight a specific key range of data.

  • Add a threshold line at a specific constant value.

A single StripLine object can either be drawn once, or repeatedly, for a given interval. This action is controlled by the Interval property. When a value of zero is assigned to the Interval property, one strip line will be drawn. When a non-zero value is assigned to the Interval property, a strip line will be drawn repeatedly at each given interval. The location where a strip line is drawn is also affected by the IntervalOffset and IntervalOffsetType properties of the strip line.

Strip lines are always associated with an Axis object. They can be added at both design time and run time.

To add a horizontal or vertical line to display a threshold, set the StripWidth property to a value of 0.0. This will result in a line being drawn. You can use the BorderColor, BorderDashStyle and BorderWidth properties for the color, width and style of the line. No chart background properties (Back*) are used when the StripWidth property is set to 0.0.

Use the Text property of the strip line to associate text with a strip line. The placement and orientation of this text can be controlled by the TextAlignment property.

When multiple strip lines are defined for the same axis, it is possible that the strip lines will overlap. The Z-order of StripLine objects is determined by their order of occurrence in the StripLinesCollection object. This means that the first occurrence is drawn first; the second occurrence is drawn second, and so on.

Strip lines are not supported for the following chart types: Pie, Doughnut, Funnel, Pyramid, Kagi, ThreeLineBreak, PointAndFigure, Polar and Radar.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.StripLine

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Members


StripLine Members

StripLine Members |
 | See Also Constructors Methods Properties

Represents the strip lines on a chart.

The following tables list the members exposed by the StripLine type.

Public Constructors

Name | Description
StripLine | Initializes a new instance of the StripLine class.
Top

Public Properties

Name | Description
BackColor | Gets or sets the background color of the strip line.
BackGradientStyle | Gets or sets the gradient style of the strip line.
BackHatchStyle | Gets or sets the hatching style of the strip line.
BackImage | Gets or sets the background image of the strip line.
BackImageAlignment | Gets or sets the background image alignment.
BackImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of the background image of the strip line.
BackSecondaryColor | Gets or sets the secondary color of the strip line background.
BorderColor | Gets or sets the border color of a strip line.
BorderDashStyle | Gets or sets the border style of the strip line.
BorderWidth | Gets or sets the border width of the strip line.
Font | Gets or sets the font used for the strip line text.
ForeColor | Gets or sets the color of the strip line text.
Interval | Gets or sets the interval for a strip line, and determines if the strip line is drawn once or repeatedly.
IntervalOffset | Gets or sets the offset of grid lines, tick marks, strip lines and axis labels.
IntervalOffsetType | Gets or sets the interval offset type of the strip line.
IntervalType | Gets or sets the interval type of a StripLine object.
Name | Gets the name of the strip line.
StripWidth | Gets or sets the width of a strip line.
StripWidthType | Gets or sets the unit of measurement for the StripWidth property.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the strip line.
TextAlignment | Gets or sets the text alignment of the strip line.
TextLineAlignment | Gets or sets the text line alignment of the strip line.
TextOrientation | Gets or sets the text orientation.
ToolTip | Gets or sets the tooltip of a strip line.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

StripLine Class


StripLine Constructor

StripLine Constructor |
 | See Also

Initializes a new instance of the StripLine class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public StripLine ()
public:
StripLine ()
public StripLine ()
public function StripLine ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine Methods

StripLine Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

StripLine Class


StripLine.Dispose Method

StripLine.Dispose Method |
 | See Also

Overload List

Name | Description
StripLine.Dispose () | (inherited from Dispose )
StripLine.Dispose (Boolean) |

See Also

Reference

StripLine Class
StripLine Members


StripLine.Dispose Method (Boolean)

StripLine.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine Properties

StripLine Properties |
 | See Also

Public Properties

Name | Description
BackColor | Gets or sets the background color of the strip line.
BackGradientStyle | Gets or sets the gradient style of the strip line.
BackHatchStyle | Gets or sets the hatching style of the strip line.
BackImage | Gets or sets the background image of the strip line.
BackImageAlignment | Gets or sets the background image alignment.
BackImageTransparentColor | Gets or sets a color which will be replaced with a transparent color when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode of the background image of the strip line.
BackSecondaryColor | Gets or sets the secondary color of the strip line background.
BorderColor | Gets or sets the border color of a strip line.
BorderDashStyle | Gets or sets the border style of the strip line.
BorderWidth | Gets or sets the border width of the strip line.
Font | Gets or sets the font used for the strip line text.
ForeColor | Gets or sets the color of the strip line text.
Interval | Gets or sets the interval for a strip line, and determines if the strip line is drawn once or repeatedly.
IntervalOffset | Gets or sets the offset of grid lines, tick marks, strip lines and axis labels.
IntervalOffsetType | Gets or sets the interval offset type of the strip line.
IntervalType | Gets or sets the interval type of a StripLine object.
Name | Gets the name of the strip line.
StripWidth | Gets or sets the width of a strip line.
StripWidthType | Gets or sets the unit of measurement for the StripWidth property.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the strip line.
TextAlignment | Gets or sets the text alignment of the strip line.
TextLineAlignment | Gets or sets the text line alignment of the strip line.
TextOrientation | Gets or sets the text orientation.
ToolTip | Gets or sets the tooltip of a strip line.

See Also

Reference

StripLine Class


StripLine.BackColor Property

StripLine.BackColor Property |
 | See Also

Gets or sets the background color of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color structure. The default color is White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

To set a gradient for the strip line, set the BackColor and BackSecondaryColor properties.

If you set this color to "transparent"—in other words, set the alpha value to 0—no color will be assigned to the background of the element. As a result, the background will be transparent.

If the StripWidth property is set to 0.0, a line will be drawn and the BorderColor property will determine the color of the line, not this property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackGradientStyle Property

StripLine.BackGradientStyle Property |
 | See Also

Gets or sets the gradient style of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

The BackGradientStyle property determines whether a chart element will display a gradient, as well as the orientation of the gradient, if used.

To use gradient colors:

  • Use the BackColor property to set the primary color.

  • Use the BackSecondaryColor property to set the secondary color.

  • Set this BackGradientStyle property of the chart element to the desired gradient style.

This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackHatchStyle Property

StripLine.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The hatch pattern consists of a solid background color and lines drawn over the background. The two colors used in the hatch style are set by the BackColor and BackSecondaryColor properties. This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackImage Property

StripLine.BackImage Property |
 | See Also

Gets or sets the background image of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents an image file's URL. The default is an empty string.

Remarks

The BackImage property defines a path to a background image for many chart elements, and is an absolute or relative URL.

To position this image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify that one color will be displayed by the image as "transparent" by setting the BackImageTransparentColor property.

An image can be any valid graphics file supported by .NET Framework, including icons.

This property is not applicable if the StripWidth property is set to a value of 0.0.

Background images take precedence over other background properties, such as gradient colors.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackImageAlignment Property

StripLine.BackImageAlignment Property |
 | See Also

Gets or sets the background image alignment.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property determines the alignment of the background image for strip lines; it is only applied when the BackImageWrapMode property is set to Unscaled.

For more information about available alignments, see the ChartImageAlignmentStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackImageTransparentColor Property

StripLine.BackImageTransparentColor Property |
 | See Also

Gets or sets a color which will be replaced with a transparent color when the background image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value that will be displayed as transparent.

Remarks

This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackImageWrapMode Property

StripLine.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode of the background image of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode integer enumeration. The default is Tile.

Remarks

This property determines how the image is displayed; that is, tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounding strip line. If the image is tiled, it is repeatedly drawn, starting from the top-left corner.

For more information concerning the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn will be determined by the BackImageAlignment property setting.

This property is not applicable if StripWidth is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BackSecondaryColor Property

StripLine.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the strip line background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of a background with hatching or gradient fill. The default color is Empty.

Remarks

This property determines the secondary background color of many chart objects, and is used when gradient colors are being applied.

You can set background secondary color to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines.

To use gradient colors for the background of a chart element:

  • Use the BackColor property to set the primary color.

  • Use this BackSecondaryColor property to set the secondary color.

  • Set the BackGradientStyle property to the desired gradient style.

This property is not applicable if the StripWidth property is set to a value of 0.0.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BorderColor Property

StripLine.BorderColor Property |
 | See Also

Gets or sets the border color of a strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A Color value. The default color is Empty.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

If the StripWidth property of a StripLine object is set to 0.0, a line will be drawn, and it is this property and not the BackColor property setting that will determine the color of the line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BorderDashStyle Property

StripLine.BorderDashStyle Property |
 | See Also

Gets or sets the border style of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the strip line.

Remarks

This property specifies the line style used for a border. The line can be solid, dotted or some variation of solid and dotted.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.BorderWidth Property

StripLine.BorderWidth Property |
 | See Also

Gets or sets the border width of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the width of the strip line's border, in pixels.

Remarks

This property is measured in pixels.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.Font Property

StripLine.Font Property |
 | See Also

Gets or sets the font used for the strip line text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font value that represents the font of the strip line text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.ForeColor Property

StripLine.ForeColor Property |
 | See Also

Gets or sets the color of the strip line text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value that represents the text color of a strip line. The default value is Black.

Remarks

You can specify any valid ARGB color for this property. This property is only applicable when a text value is specified for the strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.Interval Property

StripLine.Interval Property |
 | See Also

Gets or sets the interval for a strip line, and determines if the strip line is drawn once or repeatedly.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Interval As Double
public double Interval { get; set; }
public:
property double Interval {
    double get ();
    void set (double value);
}
/** @property */
public double get_Interval ()

/** @property */
public void set_Interval (double value)

public function get Interval () : double

public function set Interval (value : double)

Property Value

A double value that represents the interval between strip lines. The default value is zero.

Remarks

When you set the Interval property to a value of zero, one strip line will be displayed, with a width specified by the StripWidth property. When you set Interval to a value of other than zero, multiple strip lines will be shown. The unit that is used for the Interval property is defined by the IntervalType property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.IntervalOffset Property

StripLine.IntervalOffset Property |
 | See Also

Gets or sets the offset of grid lines, tick marks, strip lines and axis labels.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffset As Double
public double IntervalOffset { get; set; }
public:
property double IntervalOffset {
    double get ();
    void set (double value);
}
/** @property */
public double get_IntervalOffset ()

/** @property */
public void set_IntervalOffset (double value)

public function get IntervalOffset () : double

public function set IntervalOffset (value : double)

Property Value

A double value that represents the interval offset.

Remarks

The interval offset of minor tick marks and grid lines is never affected by the value of the IntervalOffset property of the Axis object.

The IntervalOffset property setting defines the units of measurement of the offset.

The Interval can be a negative value.

The default value is Auto (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.IntervalOffsetType Property

StripLine.IntervalOffsetType Property |
 | See Also

Gets or sets the interval offset type of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalOffsetType As DateTimeIntervalType
public DateTimeIntervalType IntervalOffsetType { get; set; }
public:
property DateTimeIntervalType IntervalOffsetType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalOffsetType ()

/** @property */
public void set_IntervalOffsetType (DateTimeIntervalType value)

public function get IntervalOffsetType () : DateTimeIntervalType

public function set IntervalOffsetType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. The default value is Auto.

Remarks

By default, this property is set to Auto; the actual value of this property is determined by the IntervalType property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.IntervalType Property

StripLine.IntervalType Property |
 | See Also

Gets or sets the interval type of a StripLine object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IntervalType As DateTimeIntervalType
public DateTimeIntervalType IntervalType { get; set; }
public:
property DateTimeIntervalType IntervalType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_IntervalType ()

/** @property */
public void set_IntervalType (DateTimeIntervalType value)

public function get IntervalType () : DateTimeIntervalType

public function set IntervalType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the interval type. The default value is Auto.

Remarks

Interval types can be set to Auto, in which case the type depends on: the X-value or Y-value types of the plotted DataPoint objects—depending on which axis the StripLine objects belong to—and the axis scale.

The Interval property determines how often a strip or line is drawn.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.Name Property

StripLine.Name Property |
 | See Also

Gets the name of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Name As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string Name { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Property Value

A string value that represents the name of the strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.StripWidth Property

StripLine.StripWidth Property |
 | See Also

Gets or sets the width of a strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property StripWidth As Double
public double StripWidth { get; set; }
public:
property double StripWidth {
    double get ();
    void set (double value);
}
/** @property */
public double get_StripWidth ()

/** @property */
public void set_StripWidth (double value)

public function get StripWidth () : double

public function set StripWidth (value : double)

Property Value

A double value that determines whether a strip or a line is drawn. The default value is 0.0.

Remarks

This property cannot be set to a value less than zero, otherwise an exception will be raised.

A setting of 0.0 will result in a line being drawn; this line will use the BorderColor, BorderDashStyle and BorderWidth property settings for its color, width and style. None of the Back* properties in this class are utilized when the value of StripWidth is 0.0.

If you set the StripWidth property to a value greater than zero, a strip will be created. The BorderColor, BorderDashStyle and BorderWidth properties only apply to the border of the strip; all of the Back* properties are then used for the background properties of the strip.

If the value of the StripWidth property is greater than 0.0, the units are determined by the relevant axis scale.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.StripWidthType Property

StripLine.StripWidthType Property |
 | See Also

Gets or sets the unit of measurement for the StripWidth property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property StripWidthType As DateTimeIntervalType
public DateTimeIntervalType StripWidthType { get; set; }
public:
property DateTimeIntervalType StripWidthType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_StripWidthType ()

/** @property */
public void set_StripWidthType (DateTimeIntervalType value)

public function get StripWidthType () : DateTimeIntervalType

public function set StripWidthType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that indicates the width type. The default value is Auto.

Remarks

This property determines the units used for the StripWidth property. For example, to set a strip line to represent "one week", you could set this property to Weeks and set the StripWidth property to one (1.0).

You can change the value of this property from Auto to a DateTime value when the relevant axis scale uses a DateTime value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.Text Property

StripLine.Text Property |
 | See Also

Gets or sets the text of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text of a strip line.

Remarks

Use this property to add text to a strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.TextAlignment Property

StripLine.TextAlignment Property |
 | See Also

Gets or sets the text alignment of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextAlignment As StringAlignment
public StringAlignment TextAlignment { get; set; }
public:
property StringAlignment TextAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TextAlignment ()

/** @property */
public void set_TextAlignment (StringAlignment value)

public function get TextAlignment () : StringAlignment

public function set TextAlignment (value : StringAlignment)

Property Value

A StringAlignment value that represents the alignment of the strip line text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.TextLineAlignment Property

StripLine.TextLineAlignment Property |
 | See Also

Gets or sets the text line alignment of the strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextLineAlignment As StringAlignment
public StringAlignment TextLineAlignment { get; set; }
public:
property StringAlignment TextLineAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
/** @property */
public StringAlignment get_TextLineAlignment ()

/** @property */
public void set_TextLineAlignment (StringAlignment value)

public function get TextLineAlignment () : StringAlignment

public function set TextLineAlignment (value : StringAlignment)

Property Value

A StringAlignment value that represents the alignment of the text line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.TextOrientation Property

StripLine.TextOrientation Property |
 | See Also

Gets or sets the text orientation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextOrientation As TextOrientation
public TextOrientation TextOrientation { get; set; }
public:
property TextOrientation TextOrientation {
    TextOrientation get ();
    void set (TextOrientation value);
}
/** @property */
public TextOrientation get_TextOrientation ()

/** @property */
public void set_TextOrientation (TextOrientation value)

public function get TextOrientation () : TextOrientation

public function set TextOrientation (value : TextOrientation)

Property Value

A TextOrientation value that represents the alignment of the text orientation.

Remarks

When this property is set to a value of Auto, the text is oriented based on the chart type. For all X-Y chart types other than Bar, X-axis strip line text is oriented horizontally from left to right on the bottom of the strip line. For Bar charts, X-axis strip line text is oriented vertically from top to bottom to the right of the strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLine.ToolTip Property

StripLine.ToolTip Property |
 | See Also

Gets or sets the tooltip of a strip line.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip of the strip line.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLine Class
StripLine Members


StripLinesCollection Class

StripLinesCollection Class |
 | See Also Members

Represents a collection of StripLine objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class StripLinesCollection
    Inherits ChartElementCollection(Of StripLine)
public class StripLinesCollection : ChartElementCollection<StripLine>
public ref class StripLinesCollection : public ChartElementCollection<StripLine^>
public class StripLinesCollection extends ChartElementCollection<StripLine>
public class StripLinesCollection extends ChartElementCollection<StripLine>

Remarks

The StripLinesCollection class represents a collection of StripLine objects, and is implemented as the StripLines property of the Axis class.

StripLine objects can be appended, inserted or removed from the collection at both design time and run time.

Note Strip lines can be displayed once or repeatedly for a set interval.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.StripLinesCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

StripLinesCollection Members


StripLinesCollection Members

StripLinesCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of StripLine objects.

The following tables list the members exposed by the StripLinesCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
Top

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

StripLinesCollection Class


StripLinesCollection Methods

StripLinesCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | (inherited from Collection )
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | (inherited from Collection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartElementCollection )
SetItem | (inherited from ChartElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

StripLinesCollection Class


StripLinesCollection Properties

StripLinesCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | (inherited from Collection )

Protected Properties

Name | Description
Items | (inherited from Collection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

StripLinesCollection Class


TextAnnotation Class

TextAnnotation Class |
 | See Also Members

Represents a text annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class TextAnnotation
    Inherits Annotation
public class TextAnnotation : Annotation
public ref class TextAnnotation : public Annotation
public class TextAnnotation extends Annotation
public class TextAnnotation extends Annotation

Remarks

Note that other annotations, such as rectangle and ellipse annotations, can display inner text.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.TextAnnotation
System.Windows.Forms.DataVisualization.Charting.CalloutAnnotation
System.Windows.Forms.DataVisualization.Charting.RectangleAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Members


TextAnnotation Members

TextAnnotation Members |
 | See Also Constructors Methods Properties

Represents a text annotation.

The following tables list the members exposed by the TextAnnotation type.

Public Constructors

Name | Description
TextAnnotation | Initializes a new instance of the TextAnnotation class.
Top

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | Overridden. This property is not applicable to the text annotation type.
BackGradientStyle | Overridden. This property is not applicable to the text annotation type.
BackHatchStyle | Overridden. This property is not applicable to the text annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the text annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
Font | Overridden. Gets or sets the font for the annotation text.
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation)
LineColor | Overridden. This property is not applicable to the text annotation type.
LineDashStyle | Overridden. This property is not applicable to the text annotation type.
LineWidth | Overridden. This property is not applicable to the text annotation type.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text of the annotation.
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BeginTextEditing | Begins editing of the annotation text by an end-user.
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Overridden. Ends user placement of an annotation.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text.
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TextAnnotation Class


TextAnnotation Constructor

TextAnnotation Constructor |
 | See Also

Initializes a new instance of the TextAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public TextAnnotation ()
public:
TextAnnotation ()
public TextAnnotation ()
public function TextAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation Methods

TextAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BeginTextEditing | Begins editing of the annotation text by an end-user.
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Overridden. Ends user placement of an annotation.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
StopTextEditing | Stops end-user editing of the annotation text.
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TextAnnotation Class


TextAnnotation.BeginTextEditing Method

TextAnnotation.BeginTextEditing Method |
 | See Also

Begins editing of the annotation text by an end-user.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub BeginTextEditing
public void BeginTextEditing ()
public:
void BeginTextEditing ()
public void BeginTextEditing ()
public function BeginTextEditing ()

Remarks

After calling this method, the annotation displays an editing box that allows the user to edit the annotation text.

Call the StopTextEditing method to cancel this mode programmatically. Note that editing also ends when the end-user hits the Enter key if the value of the IsMultiline property is false, or when the end-user clicks outside the editing box if the value is true.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.EndPlacement Method

TextAnnotation.EndPlacement Method |
 | See Also

Ends user placement of an annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Sub EndPlacement
public override void EndPlacement ()
public:
virtual void EndPlacement () override
public void EndPlacement ()
public override function EndPlacement ()

Remarks

Ends an annotation placement operation previously started by a BeginPlacement method call. You are not required to call this method, because placement will automatically end when an end-user enters all required points. However, it is useful when an annotation placement operation needs to be aborted for some reason.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.StopTextEditing Method

TextAnnotation.StopTextEditing Method |
 | See Also

Stops end-user editing of the annotation text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub StopTextEditing
public void StopTextEditing ()
public:
void StopTextEditing ()
public void StopTextEditing ()
public function StopTextEditing ()

Remarks

Call this method to cancel a text editing operation that was started with a call to the BeginTextEditing method.

Note that if the end user double-clicks the annotation, the BeginTextEditing method will be automatically called.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation Properties

TextAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the content alignment of an annotation. (inherited from Annotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the alignment of an annotation to the anchor point. (inherited from Annotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use, should not be used.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | Overridden. This property is not applicable to the text annotation type.
BackGradientStyle | Overridden. This property is not applicable to the text annotation type.
BackHatchStyle | Overridden. This property is not applicable to the text annotation type.
BackSecondaryColor | Overridden. This property is not applicable to the text annotation type.
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
Font | Overridden. Gets or sets the font for the annotation text.
ForeColor | Gets or sets the text color of an annotation. (inherited from Annotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsMultiline | Gets or sets a flag that indicates whether the annotation text is multiline.
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from Annotation )
LineColor | Overridden. This property is not applicable to the text annotation type.
LineDashStyle | Overridden. This property is not applicable to the text annotation type.
LineWidth | Overridden. This property is not applicable to the text annotation type.
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text of the annotation.
TextStyle | Gets or sets the text style of an annotation. (inherited from Annotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

TextAnnotation Class


TextAnnotation.AnnotationType Property

TextAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use, should not be used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Overrides ReadOnly Property AnnotationType As String
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override string AnnotationType { get; }
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.BackColor Property

TextAnnotation.BackColor Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackColor As Color
[BrowsableAttribute(false)]
public override Color BackColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public override function get BackColor () : Color

public override function set BackColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.BackGradientStyle Property

TextAnnotation.BackGradientStyle Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackGradientStyle As GradientStyle
[BrowsableAttribute(false)]
public override GradientStyle BackGradientStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property GradientStyle BackGradientStyle {
    GradientStyle get () override;
    void set (GradientStyle value) override;
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public override function get BackGradientStyle () : GradientStyle

public override function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.BackHatchStyle Property

TextAnnotation.BackHatchStyle Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackHatchStyle As ChartHatchStyle
[BrowsableAttribute(false)]
public override ChartHatchStyle BackHatchStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get () override;
    void set (ChartHatchStyle value) override;
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public override function get BackHatchStyle () : ChartHatchStyle

public override function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.BackSecondaryColor Property

TextAnnotation.BackSecondaryColor Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property BackSecondaryColor As Color
[BrowsableAttribute(false)]
public override Color BackSecondaryColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color BackSecondaryColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public override function get BackSecondaryColor () : Color

public override function set BackSecondaryColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.Font Property

TextAnnotation.Font Property |
 | See Also

Gets or sets the font for the annotation text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overrides Property Font As Font
public override Font Font { get; set; }
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public override function get Font () : Font

public override function set Font (value : Font)

Property Value

A Font object used as the font for the annotation text.

Remarks

To set this property, create a new Font object, and then assign it to this property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.IsMultiline Property

TextAnnotation.IsMultiline Property |
 | See Also

Gets or sets a flag that indicates whether the annotation text is multiline.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property IsMultiline As Boolean
public virtual bool IsMultiline { get; set; }
public:
virtual property bool IsMultiline {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsMultiline ()

/** @property */
public void set_IsMultiline (boolean value)

public function get IsMultiline () : boolean

public function set IsMultiline (value : boolean)

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.LineColor Property

TextAnnotation.LineColor Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineColor As Color
[BrowsableAttribute(false)]
public override Color LineColor { get; set; }
[BrowsableAttribute(false)]
public:
virtual property Color LineColor {
    Color get () override;
    void set (Color value) override;
}
/** @property */
public Color get_LineColor ()

/** @property */
public void set_LineColor (Color value)

public override function get LineColor () : Color

public override function set LineColor (value : Color)

Property Value

A Color value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.LineDashStyle Property

TextAnnotation.LineDashStyle Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineDashStyle As ChartDashStyle
[BrowsableAttribute(false)]
public override ChartDashStyle LineDashStyle { get; set; }
[BrowsableAttribute(false)]
public:
virtual property ChartDashStyle LineDashStyle {
    ChartDashStyle get () override;
    void set (ChartDashStyle value) override;
}
/** @property */
public ChartDashStyle get_LineDashStyle ()

/** @property */
public void set_LineDashStyle (ChartDashStyle value)

public override function get LineDashStyle () : ChartDashStyle

public override function set LineDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.LineWidth Property

TextAnnotation.LineWidth Property |
 | See Also

This property is not applicable to the text annotation type.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<BrowsableAttribute(False)> _
Public Overrides Property LineWidth As Integer
[BrowsableAttribute(false)]
public override int LineWidth { get; set; }
[BrowsableAttribute(false)]
public:
virtual property int LineWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_LineWidth ()

/** @property */
public void set_LineWidth (int value)

public override function get LineWidth () : int

public override function set LineWidth (value : int)

Property Value

An integer value.

Remarks

This property is not applicable to the text annotation type.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAnnotation.Text Property

TextAnnotation.Text Property |
 | See Also

Gets or sets the text of the annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Text As String
public virtual string Text { get; set; }
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TextAnnotation Class
TextAnnotation Members


TextAntiAliasingQuality Enumeration

TextAntiAliasingQuality Enumeration |
 | See Also

Specifies the level of anti-aliasing quality to be used with the TextAntiAliasingQuality&nbsp;property.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration TextAntiAliasingQuality
public enum TextAntiAliasingQuality
public enum class TextAntiAliasingQuality
public enum TextAntiAliasingQuality
public enum TextAntiAliasingQuality

Members

Member name | Description
High | High anti-aliasing quality.
Normal | Normal anti-aliasing quality.
SystemDefault | System default anti-aliasing quality.

Remarks

The TextAntiAliasingQuality enumeration represents a quality range&nbsp;for text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


TextOrientation Enumeration

TextOrientation Enumeration |
 | See Also

Specifies text orientation in a chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration TextOrientation
public enum TextOrientation
public enum class TextOrientation
public enum TextOrientation
public enum TextOrientation

Members

Member name | Description
Auto | Text orientation is automatically determined, based on the type of chart element in which the text appears.
Horizontal | Text is horizontal.
Rotated270 | Text is rotated 270 degrees and oriented from bottom to top.
Rotated90 | Text is rotated 90 degrees and oriented from top to bottom.
Stacked | Text characters are not rotated and are positioned one below the other.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


TextStyle Enumeration

TextStyle Enumeration |
 | See Also

Specifies text drawing styles.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration TextStyle
public enum TextStyle
public enum class TextStyle
public enum TextStyle
public enum TextStyle

Members

Member name | Description
Default | Default text drawing style.
Embed | Embedded text.
Emboss | Embossed text.
Frame | Framed text.
Shadow | Shadow text.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


TickMark Class

TickMark Class |
 | See Also Members

Represents the major and minor tick marks along an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class TickMark
    Inherits Grid
public class TickMark : Grid
public ref class TickMark : public Grid
public class TickMark extends Grid
public class TickMark extends Grid

Remarks

The TickMark class encapsulates the functionality for all chart tick marks.

The TickMark class is exposed as the MajorTickMark and MinorTickMark properties of Axis objects.

By default, major tick marks are displayed at the major grid lines, whereas minor tick marks must be explicitly displayed.

MajorTickMark.Interval is not set (Double.NaN) by default, and the tick marks are drawn according to Interval. MinorTickMark.Interval is set to Auto (0) by default, and the Chart control automatically determines the interval.

A developer can use this class to:

  • Enable or disable tick marks.

  • Set the color, width, length and line style of tick marks.

  • Specify a style that determines whether tick marks are displayed outside the axis, inside the axis or across the axis.

  • Specify the starting point—where the first tick mark is drawn—as well as the tick mark interval, which correlates to their frequency.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.Grid
System.Windows.Forms.DataVisualization.Charting.TickMark

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Members


TickMark Members

TickMark Members |
 | See Also Constructors Methods Properties

Represents the major and minor tick marks along an axis.

The following tables list the members exposed by the TickMark type.

Public Constructors

Name | Description
TickMark | Initializes a new instance of the TickMark class.
Top

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled. (inherited from Grid)
Interval | Gets or sets the interval between major or minor grid lines. (inherited from Grid)
IntervalOffset | Gets or sets the offset of grid lines. (inherited from Grid)
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines. (inherited from Grid)
IntervalType | Gets or sets the interval type for major or minor grid lines. (inherited from Grid)
LineColor | Gets or sets the line color of a grid. (inherited from Grid)
LineDashStyle | Gets or sets the line style of a grid. (inherited from Grid)
LineWidth | Gets or sets the line width of major and minor grid lines. (inherited from Grid)
Size | Gets or sets the length of tick marks. The length is measured in units that represent a percentage of the height or width of the chart image, depending on the axis.
TickMarkStyle | Gets or sets the tick mark style.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TickMark Class


TickMark Constructor

TickMark Constructor |
 | See Also

Initializes a new instance of the TickMark class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public TickMark ()
public:
TickMark ()
public TickMark ()
public function TickMark ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Class
TickMark Members


TickMark Methods

TickMark Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TickMark Class


TickMark Properties

TickMark Properties |
 | See Also

Public Properties

Name | Description
Enabled | Gets or sets a flag that determines whether major or minor grid lines are enabled. (inherited from Grid )
Interval | Gets or sets the interval between major or minor grid lines. (inherited from Grid )
IntervalOffset | Gets or sets the offset of grid lines. (inherited from Grid )
IntervalOffsetType | Gets or sets the interval offset type of major and minor grid lines. (inherited from Grid )
IntervalType | Gets or sets the interval type for major or minor grid lines. (inherited from Grid )
LineColor | Gets or sets the line color of a grid. (inherited from Grid )
LineDashStyle | Gets or sets the line style of a grid. (inherited from Grid )
LineWidth | Gets or sets the line width of major and minor grid lines. (inherited from Grid )
Size | Gets or sets the length of tick marks. The length is measured in units that represent a percentage of the height or width of the chart image, depending on the axis.
TickMarkStyle | Gets or sets the tick mark style.

See Also

Reference

TickMark Class


TickMark.Size Property

TickMark.Size Property |
 | See Also

Gets or sets the length of tick marks. The length is measured in units that represent a percentage of the height or width of the chart image, depending on the axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Size As Single
public float Size { get; set; }
public:
property float Size {
    float get ();
    void set (float value);
}
/** @property */
public float get_Size ()

/** @property */
public void set_Size (float value)

public function get Size () : float

public function set Size (value : float)

Property Value

A float value that represents the size, or length, of tick marks. The default value is 1.0 percent.

Remarks

The size of a tick mark determines the tick mark's length.

The Size property is measured in units that represent a percentage of the height or width of the chart image. If the tick mark is displayed along a vertical axis, the unit of measure is a percentage of the chart image's width. If the tick mark is displayed along a horizontal axis, the unit of measure is a percentage of the chart image's height.

A change in the width of the chart image will result in the resizing of all tick marks displayed along vertical axes, for all chart areas. Similarly, a change in the height of the chart image will result in the resizing of all tick marks displayed along horizontal axes, for all chart areas.

To display tick marks for three-dimensional (3D) charts, so that they are just drawn for the width of a wall, set the TickMarkStyle property to AcrossAxis and specify a tick mark size of zero (0) using the Size property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Class
TickMark Members


TickMark.TickMarkStyle Property

TickMark.TickMarkStyle Property |
 | See Also

Gets or sets the tick mark style.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TickMarkStyle As TickMarkStyle
public TickMarkStyle TickMarkStyle { get; set; }
public:
property TickMarkStyle TickMarkStyle {
    TickMarkStyle get ();
    void set (TickMarkStyle value);
}
/** @property */
public TickMarkStyle get_TickMarkStyle ()

/** @property */
public void set_TickMarkStyle (TickMarkStyle value)

public function get TickMarkStyle () : TickMarkStyle

public function set TickMarkStyle (value : TickMarkStyle)

Property Value

A TickMarkStyle enumeration value. The default value is OutsideArea.

Remarks

The TickMarkStyle property determines the style of tick marks.

Tick marks can be drawn inside the chart area, outside the chart area, across an axis line, or can be disabled.

To display tick marks for three-dimensional (3D) charts, so that they are just drawn for the width of a wall, set the TickMarkStyle property to AcrossAxis. Then specify a tick mark size of zero (0) using the Size property.

If the TickMarkStyle property is set to None, tick marks are not displayed. Tick marks can also be toggled on or off by setting the Enabled property to true or false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TickMark Class
TickMark Members


TickMarkStyle Enumeration

TickMarkStyle Enumeration |
 | See Also

Specifies a tick mark style when setting the TickMarkStyle property of a TickMark object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Enumeration TickMarkStyle
public enum TickMarkStyle
public enum class TickMarkStyle
public enum TickMarkStyle
public enum TickMarkStyle

Members

Member name | Description
AcrossAxis | Tick marks are drawn across the relevant axis line.
InsideArea | Tick marks are drawn inside the chart area.
None | Tick marks are disabled.
OutsideArea | Tick marks are drawn outside the chart area.

Remarks

The TickMarkStyle enumeration represents the styles for major and minor tick marks.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference


Title Class

Title Class |
 | See Also Members

Represents a title for the entire chart image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class Title
    Inherits ChartNamedElement
    Implements IDisposable
public class Title : ChartNamedElement, IDisposable
public ref class Title : public ChartNamedElement, IDisposable
public class Title extends ChartNamedElement implements IDisposable
public class Title extends ChartNamedElement implements IDisposable

Remarks

The Title class encapsulates all the functionality of a title for the Chart control. This class is exposed using the Titles collection property of the root Chart object.

There can be any number of titles for an entire chart image.

Titles are able to:

  • Be docked and aligned or custom-positioned.

  • Be displayed inside or outside the plotted chart areas.

  • Use a predefined TextStyle such as Embed or Shadow.

  • Use hatching, gradient colors and background images.

  • Be sized and positioned anywhere within the chart image.

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Title

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Members


Title Members

Title Members |
 | See Also Constructors Methods Properties

Represents a title for the entire chart image.

The following tables list the members exposed by the Title type.

Public Constructors

Name | Description
Title | Overloaded.
Top

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the title.
BackColor | Gets or sets the background color of the title.
BackGradientStyle | Gets or sets the orientation for the background gradient of a title. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style for the title.
BackImage | Gets or sets the background image of the title.
BackImageAlignment | Gets or sets the alignment of the title background image.
BackImageTransparentColor | Gets or sets a color that will be drawn as transparent when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the title.
BackSecondaryColor | Gets or sets the secondary color of the title background.
BorderColor | Gets or sets the border color of the title.
BorderDashStyle | Gets or sets the border style of the title.
BorderWidth | Gets or sets the border width of the title.
DockedToChartArea | Gets or sets the name of the ChartArea where the title will be docked.
Docking | Gets or sets a value that determines where the title is docked.
DockingOffset | Gets or sets the positive or negative offset of the docked title position.
Font | Gets or sets the font for the title.
ForeColor | Gets or sets the color of the title text.
IsDockedInsideChartArea | Gets or sets a flag that specifies whether the title should be docked within a ChartArea object.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement)
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the title.
ShadowColor | Gets or sets the shadow color for the title.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the title.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
Text | Gets or sets the text for the title.
TextOrientation | Gets or sets the orientation of the text in the title.
TextStyle | Gets or sets the style of the text for the title.
ToolTip | Gets or sets the tooltip for the title.
Visible | Gets or sets the visibility flag of the title.
Top

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Title Class


Title Constructor

Title Constructor |
 | See Also

Overload List

Name | Description
Title () | Initializes a new instance of the Title class.
Title (String) | Initializes a new instance of the Title class with the specified title text.
Title (String, Docking) | Initializes a new instance of the Title class with the specified title text and docking value.
Title (String, Docking, Font, Color) | Initializes a new instance of the Title class with the specified title text, docking value, font and color.

See Also

Reference

Title Class
Title Members


Title Constructor ()

Title Constructor () |
 | See Also

Initializes a new instance of the Title class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public Title ()
public:
Title ()
public Title ()
public function Title ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title Constructor (String)

Title Constructor (String) |
 | See Also

Initializes a new instance of the Title class with the specified title text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String _
)
public Title (
    string text
)
public:
Title (
    String^ text
)
public Title (
    String text
)
public function Title (
    text : String
)

Parameters

text

Text for the title.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title Constructor (String, Docking)

Title Constructor (String, Docking) |
 | See Also

Initializes a new instance of the Title class with the specified title text and docking value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String, _
    docking As Docking _
)
public Title (
    string text,
    Docking docking
)
public:
Title (
    String^ text,
    Docking docking
)
public Title (
    String text,
    Docking docking
)
public function Title (
    text : String,
    docking : Docking
)

Parameters

text

Text for the title.

docking

A Docking enumeration value that determines where the title will be docked on the chart.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title Constructor (String, Docking, Font, Color)

Title Constructor (String, Docking, Font, Color) |
 | See Also

Initializes a new instance of the Title class with the specified title text, docking value, font and color.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    text As String, _
    docking As Docking, _
    font As Font, _
    color As Color _
)
public Title (
    string text,
    Docking docking,
    Font font,
    Color color
)
public:
Title (
    String^ text,
    Docking docking,
    Font^ font,
    Color color
)
public Title (
    String text,
    Docking docking,
    Font font,
    Color color
)
public function Title (
    text : String,
    docking : Docking,
    font : Font,
    color : Color
)

Parameters

text

Text for the title.

docking

A Docking enumeration value that determines where the title will be docked on the chart.

font

Title font.

color

Title color.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title Methods

Title Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Dispose | Overloaded.
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Title Class


Title.Dispose Method

Title.Dispose Method |
 | See Also

Overload List

Name | Description
Title.Dispose () | (inherited from Dispose )
Title.Dispose (Boolean) |

See Also

Reference

Title Class
Title Members


Title.Dispose Method (Boolean)

Title.Dispose Method (Boolean) |
 | See Also

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title Properties

Title Properties |
 | See Also

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the title.
BackColor | Gets or sets the background color of the title.
BackGradientStyle | Gets or sets the orientation for the background gradient of a title. Also determines whether a gradient is used.
BackHatchStyle | Gets or sets the hatching style for the title.
BackImage | Gets or sets the background image of the title.
BackImageAlignment | Gets or sets the alignment of the title background image.
BackImageTransparentColor | Gets or sets a color that will be drawn as transparent when the background image is drawn.
BackImageWrapMode | Gets or sets the drawing mode for the background image of the title.
BackSecondaryColor | Gets or sets the secondary color of the title background.
BorderColor | Gets or sets the border color of the title.
BorderDashStyle | Gets or sets the border style of the title.
BorderWidth | Gets or sets the border width of the title.
DockedToChartArea | Gets or sets the name of the ChartArea where the title will be docked.
Docking | Gets or sets a value that determines where the title is docked.
DockingOffset | Gets or sets the positive or negative offset of the docked title position.
Font | Gets or sets the font for the title.
ForeColor | Gets or sets the color of the title text.
IsDockedInsideChartArea | Gets or sets a flag that specifies whether the title should be docked within a ChartArea object.
Name | Gets or sets the name of the chart element. (inherited from ChartNamedElement )
Position | Gets or sets an ElementPosition object, which can be used to get or set the position of the title.
ShadowColor | Gets or sets the shadow color for the title.
ShadowOffset | Gets or sets the shadow offset, in pixels, of the title.
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
Text | Gets or sets the text for the title.
TextOrientation | Gets or sets the orientation of the text in the title.
TextStyle | Gets or sets the style of the text for the title.
ToolTip | Gets or sets the tooltip for the title.
Visible | Gets or sets the visibility flag of the title.

See Also

Reference

Title Class


Title.Alignment Property

Title.Alignment Property |
 | See Also

Gets or sets the alignment of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Alignment As ContentAlignment
public ContentAlignment Alignment { get; set; }
public:
property ContentAlignment Alignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
/** @property */
public ContentAlignment get_Alignment ()

/** @property */
public void set_Alignment (ContentAlignment value)

public function get Alignment () : ContentAlignment

public function set Alignment (value : ContentAlignment)

Property Value

A ContentAlignment enumeration value that represents the title alignment within the text drawing region. The default value is MiddleCenter.

Remarks

The Alignment property has no effect on alignment if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackColor Property

Title.BackColor Property |
 | See Also

Gets or sets the background color of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackColor As Color
public Color BackColor { get; set; }
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackColor ()

/** @property */
public void set_BackColor (Color value)

public function get BackColor () : Color

public function set BackColor (value : Color)

Property Value

A Color value. The default color is White.

Remarks

You can set this property to any valid ARGB (alpha, red, green, blue) value.

The BackColor value will be the first color used if you have specified gradient colors for the background.

The alpha value controls the opacity of a color. If you set this color to "transparent"—that is, if you use an alpha value of 0—no color will be assigned to the background of the title. As a result, the background will be transparent.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackGradientStyle Property

Title.BackGradientStyle Property |
 | See Also

Gets or sets the orientation for the background gradient of a title. Also determines whether a gradient is used.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackGradientStyle As GradientStyle
public GradientStyle BackGradientStyle { get; set; }
public:
property GradientStyle BackGradientStyle {
    GradientStyle get ();
    void set (GradientStyle value);
}
/** @property */
public GradientStyle get_BackGradientStyle ()

/** @property */
public void set_BackGradientStyle (GradientStyle value)

public function get BackGradientStyle () : GradientStyle

public function set BackGradientStyle (value : GradientStyle)

Property Value

A GradientStyle enumeration. The default value is None.

Remarks

Use the BackGradientStyle property to determine whether a title will display a gradient, and to determine the orientation of the gradient if one is used.

For a listing of available patterns, refer to the GradientStyle enumeration.

To use gradient colors:

Set the primary color of the title background with the BackColor property.

Set the secondary color of the title background with the BackSecondaryColor property.

Set this BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackHatchStyle Property

Title.BackHatchStyle Property |
 | See Also

Gets or sets the hatching style for the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackHatchStyle As ChartHatchStyle
public ChartHatchStyle BackHatchStyle { get; set; }
public:
property ChartHatchStyle BackHatchStyle {
    ChartHatchStyle get ();
    void set (ChartHatchStyle value);
}
/** @property */
public ChartHatchStyle get_BackHatchStyle ()

/** @property */
public void set_BackHatchStyle (ChartHatchStyle value)

public function get BackHatchStyle () : ChartHatchStyle

public function set BackHatchStyle (value : ChartHatchStyle)

Property Value

A ChartHatchStyle enumeration. The default value is None.

Remarks

The ChartHatchStyle enumeration specifies the hatch pattern used by a brush of type HatchBrush. The hatch pattern consists of a solid background color and lines drawn over the background.

For a listing of available hatching styles, refer to the ChartHatchStyle enumeration.

Note The color of hatching lines is determined by the BackSecondaryColor property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackImage Property

Title.BackImage Property |
 | See Also

Gets or sets the background image of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImage As String
public string BackImage { get; set; }
public:
property String^ BackImage {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BackImage ()

/** @property */
public void set_BackImage (String value)

public function get BackImage () : String

public function set BackImage (value : String)

Property Value

A string value that represents the URL of an image file. The default is an empty string.

Remarks

This property defines a path to a background image for a Chart title, and can be an absolute or relative URL.

To position the image, use the BackImageAlignment and BackImageWrapMode properties.

You can also specify one of the colors displayed by the image as "transparent", by setting the BackImageTransparentColor property.

An image be any valid graphics file supported by .NET Framework, including icons.

Background images take precedence over other background properties such as gradient color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackImageAlignment Property

Title.BackImageAlignment Property |
 | See Also

Gets or sets the alignment of the title background image.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageAlignment As ChartImageAlignmentStyle
public ChartImageAlignmentStyle BackImageAlignment { get; set; }
public:
property ChartImageAlignmentStyle BackImageAlignment {
    ChartImageAlignmentStyle get ();
    void set (ChartImageAlignmentStyle value);
}
/** @property */
public ChartImageAlignmentStyle get_BackImageAlignment ()

/** @property */
public void set_BackImageAlignment (ChartImageAlignmentStyle value)

public function get BackImageAlignment () : ChartImageAlignmentStyle

public function set BackImageAlignment (value : ChartImageAlignmentStyle)

Property Value

A ChartImageAlignmentStyle enumeration value. The default value is TopLeft.

Remarks

This property is used when the BackImageWrapMode property is set to Unscaled.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackImageTransparentColor Property

Title.BackImageTransparentColor Property |
 | See Also

Gets or sets a color that will be drawn as transparent when the background image is drawn.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageTransparentColor As Color
public Color BackImageTransparentColor { get; set; }
public:
property Color BackImageTransparentColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackImageTransparentColor ()

/** @property */
public void set_BackImageTransparentColor (Color value)

public function get BackImageTransparentColor () : Color

public function set BackImageTransparentColor (value : Color)

Property Value

A Color value. The default value is Empty.

Remarks

This color will be displayed as transparent when the chart is rendered.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackImageWrapMode Property

Title.BackImageWrapMode Property |
 | See Also

Gets or sets the drawing mode for the background image of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackImageWrapMode As ChartImageWrapMode
public ChartImageWrapMode BackImageWrapMode { get; set; }
public:
property ChartImageWrapMode BackImageWrapMode {
    ChartImageWrapMode get ();
    void set (ChartImageWrapMode value);
}
/** @property */
public ChartImageWrapMode get_BackImageWrapMode ()

/** @property */
public void set_BackImageWrapMode (ChartImageWrapMode value)

public function get BackImageWrapMode () : ChartImageWrapMode

public function set BackImageWrapMode (value : ChartImageWrapMode)

Property Value

A ChartImageWrapMode enumeration value. The default value is Tile.

Remarks

The BackImageWrapMode property determines how the image is displayed; the image can be tiled, scaled, and so forth.

If an image is scaled, it will be stretched to fit within the bounds of the title. If the image is tiled, it is repeatedly drawn, starting from the top-left corner of the title.

For more information about the available wrapping modes, see the ChartImageWrapMode enumeration topic.

If the BackImageWrapMode property is set to Unscaled, the location where the image is drawn is determined by the BackImageAlignment property setting.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BackSecondaryColor Property

Title.BackSecondaryColor Property |
 | See Also

Gets or sets the secondary color of the title background.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BackSecondaryColor As Color
public Color BackSecondaryColor { get; set; }
public:
property Color BackSecondaryColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BackSecondaryColor ()

/** @property */
public void set_BackSecondaryColor (Color value)

public function get BackSecondaryColor () : Color

public function set BackSecondaryColor (value : Color)

Property Value

A Color value used for the secondary color of a background with hatching or gradient fill. The default value is Empty.

Remarks

This BackSecondaryColor property is one of several related properties that determine the secondary background color of Chart objects, and is used when gradient colors are being applied.

You can set BackSecondaryColor to any valid ARGB (alpha, red, green, blue) value.

If hatching is used, the BackSecondaryColor property determines the color of the hatching lines for the title.

To use gradient colors for the background of a title:

  • Set the primary color with the BackColor property.

  • Set the secondary color with the BackSecondaryColor property.

  • Set the BackGradientStyle property to the desired gradient style.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BorderColor Property

Title.BorderColor Property |
 | See Also

Gets or sets the border color of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderColor As Color
public Color BorderColor { get; set; }
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_BorderColor ()

/** @property */
public void set_BorderColor (Color value)

public function get BorderColor () : Color

public function set BorderColor (value : Color)

Property Value

A T:System.Drawing.Color value. The default color is Empty.

Remarks

You can set the BorderColor property to any valid ARGB (alpha, red, green, blue) value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BorderDashStyle Property

Title.BorderDashStyle Property |
 | See Also

Gets or sets the border style of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderDashStyle As ChartDashStyle
public ChartDashStyle BorderDashStyle { get; set; }
public:
property ChartDashStyle BorderDashStyle {
    ChartDashStyle get ();
    void set (ChartDashStyle value);
}
/** @property */
public ChartDashStyle get_BorderDashStyle ()

/** @property */
public void set_BorderDashStyle (ChartDashStyle value)

public function get BorderDashStyle () : ChartDashStyle

public function set BorderDashStyle (value : ChartDashStyle)

Property Value

A ChartDashStyle enumeration value that determines the border style of the title.

Remarks

The BorderDashStyle property determines the line style to use for a border. The line can be solid, dotted, and so forth.

For other border styles, see the ChartDashStyle enumeration topic.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.BorderWidth Property

Title.BorderWidth Property |
 | See Also

Gets or sets the border width of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property BorderWidth As Integer
public int BorderWidth { get; set; }
public:
property int BorderWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_BorderWidth ()

/** @property */
public void set_BorderWidth (int value)

public function get BorderWidth () : int

public function set BorderWidth (value : int)

Property Value

An integer value that determines the border width, in pixels, of the title.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.DockedToChartArea Property

Title.DockedToChartArea Property |
 | See Also

Gets or sets the name of the ChartArea where the title will be docked.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property DockedToChartArea As String
public string DockedToChartArea { get; set; }
public:
property String^ DockedToChartArea {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_DockedToChartArea ()

/** @property */
public void set_DockedToChartArea (String value)

public function get DockedToChartArea () : String

public function set DockedToChartArea (value : String)

Property Value

A string value that represents the name of the ChartArea where this title will be docked. The default value is the empty string.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.Docking Property

Title.Docking Property |
 | See Also

Gets or sets a value that determines where the title is docked.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Docking As Docking
public Docking Docking { get; set; }
public:
property Docking Docking {
    Docking get ();
    void set (Docking value);
}
/** @property */
public Docking get_Docking ()

/** @property */
public void set_Docking (Docking value)

public function get Docking () : Docking

public function set Docking (value : Docking)

Property Value

A Docking enumeration value. The default value is Top.

Remarks

The Title can be docked to the top, left, bottom or right of either the entire chart image, or the inside or outside of a chart area. If the IsDockedInsideChartArea property is set to false, docking applies to the entire chart image. If the IsDockedInsideChartArea property is set to true, docking applies to the ChartArea object specified by the DockedToChartArea property

This property has no effect if the Position property is not set to Auto.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.DockingOffset Property

Title.DockingOffset Property |
 | See Also

Gets or sets the positive or negative offset of the docked title position.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property DockingOffset As Integer
public int DockingOffset { get; set; }
public:
property int DockingOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_DockingOffset ()

/** @property */
public void set_DockingOffset (int value)

public function get DockingOffset () : int

public function set DockingOffset (value : int)

Property Value

An integer value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.Font Property

Title.Font Property |
 | See Also

Gets or sets the font for the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Font As Font
public Font Font { get; set; }
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
/** @property */
public Font get_Font ()

/** @property */
public void set_Font (Font value)

public function get Font () : Font

public function set Font (value : Font)

Property Value

A Font object. Defaults to "Microsoft Sans Serif, 8pt".

Remarks

Use a new Font object when setting this property. Assign the entire object to the property.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.ForeColor Property

Title.ForeColor Property |
 | See Also

Gets or sets the color of the title text.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ForeColor As Color
public Color ForeColor { get; set; }
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ForeColor ()

/** @property */
public void set_ForeColor (Color value)

public function get ForeColor () : Color

public function set ForeColor (value : Color)

Property Value

A Color value.

Remarks

The ForeColor property is used to set the title text color.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.IsDockedInsideChartArea Property

Title.IsDockedInsideChartArea Property |
 | See Also

Gets or sets a flag that specifies whether the title should be docked within a ChartArea object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property IsDockedInsideChartArea As Boolean
public bool IsDockedInsideChartArea { get; set; }
public:
property bool IsDockedInsideChartArea {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_IsDockedInsideChartArea ()

/** @property */
public void set_IsDockedInsideChartArea (boolean value)

public function get IsDockedInsideChartArea () : boolean

public function set IsDockedInsideChartArea (value : boolean)

Property Value

True if the title will be docked within a chart area, false if the title will be docked outside the chart area. The default value is false.

Remarks

If the IsDockedInsideChartArea property is set to false, the title is docked to the outside edge of the plotted chart areas; if this property is set to true, the title will be docked to the inside edge of the chart area. This property will have no effect if the name of a ChartArea object is not assigned to the DockedToChartArea property.

Note This behavior only applies if the Position property is set to Auto. If this is not the case, setting the IsDockedInsideChartArea property has no effect, because the position of the title is then determined by the Position property value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.Position Property

Title.Position Property |
 | See Also

Gets or sets an ElementPosition object, which can be used to get or set the position of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public Property Position As ElementPosition
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ElementPosition Position { get; set; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ElementPosition^ Position {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}
/** @property */
public ElementPosition get_Position ()

/** @property */
public void set_Position (ElementPosition value)

public function get Position () : ElementPosition

public function set Position (value : ElementPosition)

Property Value

An ElementPosition value that represents the position of the title. The default value is Auto.

Remarks

If the Position property is automatic (that is, Title.Position.Auto = true) the title position is calculated automatically by the Chart control, taking into account the Docking, Alignment and IsDockedInsideChartArea property settings.

If it is not automatic, the Docking, DockedToChartArea and IsDockedInsideChartArea properties are ignored, and the title position is solely determined by the value of the returned ElementPosition object.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.ShadowColor Property

Title.ShadowColor Property |
 | See Also

Gets or sets the shadow color for the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowColor As Color
public Color ShadowColor { get; set; }
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
/** @property */
public Color get_ShadowColor ()

/** @property */
public void set_ShadowColor (Color value)

public function get ShadowColor () : Color

public function set ShadowColor (value : Color)

Property Value

A Color value. The default color is Black.

Remarks

This property can be set to any valid ARGB (alpha, red, green, blue) value.

The alpha value can be used to achieve a "realistic" shadowing effect; try a color value of "128,0,0,0" for shadows.

To implement a shadow, set the ShadowOffset property to a value other than zero (0).

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.ShadowOffset Property

Title.ShadowOffset Property |
 | See Also

Gets or sets the shadow offset, in pixels, of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ShadowOffset As Integer
public int ShadowOffset { get; set; }
public:
property int ShadowOffset {
    int get ();
    void set (int value);
}
/** @property */
public int get_ShadowOffset ()

/** @property */
public void set_ShadowOffset (int value)

public function get ShadowOffset () : int

public function set ShadowOffset (value : int)

Property Value

An integer value that represents the shadow offset, in pixels, of the title.

Remarks

To implement shadowing, set this property to a value other than zero (0). A positive value will result in a shadow that shifts down and to the right; a negative value will result in a shadow that shifts up and to the left.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.Text Property

Title.Text Property |
 | See Also

Gets or sets the text for the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the text for the title.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.TextOrientation Property

Title.TextOrientation Property |
 | See Also

Gets or sets the orientation of the text in the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextOrientation As TextOrientation
public TextOrientation TextOrientation { get; set; }
public:
property TextOrientation TextOrientation {
    TextOrientation get ();
    void set (TextOrientation value);
}
/** @property */
public TextOrientation get_TextOrientation ()

/** @property */
public void set_TextOrientation (TextOrientation value)

public function get TextOrientation () : TextOrientation

public function set TextOrientation (value : TextOrientation)

Property Value

A TextOrientation enumeration value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.TextStyle Property

Title.TextStyle Property |
 | See Also

Gets or sets the style of the text for the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property TextStyle As TextStyle
public TextStyle TextStyle { get; set; }
public:
property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
/** @property */
public TextStyle get_TextStyle ()

/** @property */
public void set_TextStyle (TextStyle value)

public function get TextStyle () : TextStyle

public function set TextStyle (value : TextStyle)

Property Value

A TextStyle enumeration value that determines the style of the text for the title. The default value is Default.

Remarks

There are five possible styles for title text: Default, Shadow, Emboss, Embed, and Frame. Refer to the table below for a summary of these styles:

Style | Description
Default | Text is displayed using the desired font and color, with no additional effects.
Shadow | Text is displayed using the desired font and color with an added shadow effect on the text.
Emboss | Text is displayed using the desired font and color but drawn with an embossing effect.
Embed | Text is displayed using the desired font and color but drawn with an embedding effect.
Frame | Text is displayed using the desired font and color but drawn as an outline of the text, that is, with no fill.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.ToolTip Property

Title.ToolTip Property |
 | See Also

Gets or sets the tooltip for the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property ToolTip As String
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ToolTip ()

/** @property */
public void set_ToolTip (String value)

public function get ToolTip () : String

public function set ToolTip (value : String)

Property Value

A string value that represents the tooltip.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


Title.Visible Property

Title.Visible Property |
 | See Also

Gets or sets the visibility flag of the title.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Overridable Property Visible As Boolean
public virtual bool Visible { get; set; }
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_Visible ()

/** @property */
public void set_Visible (boolean value)

public function get Visible () : boolean

public function set Visible (value : boolean)

Property Value

True if visible, otherwise false.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

Title Class
Title Members


TitleCollection Class

TitleCollection Class |
 | See Also Members

Represents a collection of Title objects.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class TitleCollection
    Inherits ChartNamedElementCollection(Of Title)
public class TitleCollection : ChartNamedElementCollection<Title>
public ref class TitleCollection : public ChartNamedElementCollection<Title^>
public class TitleCollection extends ChartNamedElementCollection<Title>
public class TitleCollection extends ChartNamedElementCollection<Title>

Remarks

The TitleCollection class is implemented as the Titles collection property of the root Chart object.

Title objects can be appended, inserted or removed from the collection at design time and run time.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
System.Windows.Forms.DataVisualization.Charting.ChartElementCollection
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection
System.Windows.Forms.DataVisualization.Charting.TitleCollection

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TitleCollection Members


TitleCollection Members

TitleCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

Represents a collection of Title objects.

The following tables list the members exposed by the TitleCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )
Top

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection)
Top

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection)
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection)
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection)
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection)
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )
Top

See Also

Reference

TitleCollection Class


TitleCollection Methods

TitleCollection Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Add | Overloaded.
Clear | (inherited from Collection )
Contains | (inherited from Collection )
CopyTo | (inherited from Collection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Equals | Overloaded. (inherited from Object )
FindByName | (inherited from ChartNamedElementCollection )
GetEnumerator | (inherited from Collection )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Overloaded. (inherited from ChartNamedElementCollection )
Insert | (inherited from Collection )
Invalidate | Forces the invalidation of the parent chart element. (inherited from ChartElementCollection )
IsUniqueName | (inherited from ChartNamedElementCollection )
NextUniqueName | Finds the unique name for the new element to be added to the collection. (inherited from ChartNamedElementCollection )
ReferenceEquals | (inherited from Object )
Remove | (inherited from Collection )
RemoveAt | (inherited from Collection )
ResumeUpdates | Resumes the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
SuspendUpdates | Suspends the invalidation of a chart element in the collection. (inherited from ChartElementCollection )
ToString | (inherited from Object )

Protected Methods

Name | Description
ClearItems | Removes all elements from the Collection. (inherited from ChartElementCollection )
Dispose | Overloaded. (inherited from ChartElementCollection )
Finalize | (inherited from Object )
InsertItem | (inherited from ChartNamedElementCollection )
MemberwiseClone | (inherited from Object )
RemoveItem | (inherited from ChartNamedElementCollection )
SetItem | (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from Collection )
System.Collections.IEnumerable.GetEnumerator | (inherited from Collection )
System.Collections.IList.Add | (inherited from Collection )
System.Collections.IList.Contains | (inherited from Collection )
System.Collections.IList.IndexOf | (inherited from Collection )
System.Collections.IList.Insert | (inherited from Collection )
System.Collections.IList.Remove | (inherited from Collection )

See Also

Reference

TitleCollection Class


TitleCollection.Add Method

TitleCollection.Add Method |
 | See Also

Overload List

Name | Description
TitleCollection.Add (String) | Adds a Title object with the specified name to the end of the collection.
TitleCollection.Add (Title) | (inherited from Add )

See Also

Reference

TitleCollection Class
TitleCollection Members


TitleCollection.Add Method (String)

TitleCollection.Add Method (String) |
 | See Also

Adds a Title object with the specified name to the end of the collection.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Function Add ( _
    name As String _
) As Title
public Title Add (
    string name
)
public:
Title^ Add (
    String^ name
)
public Title Add (
    String name
)
public function Add (
    name : String
) : Title

Parameters

name

The name of the title to add to the collection.

Return Value

Index of the added object.

Remarks

A string value that represents the zero-based index of the added title.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TitleCollection Class
TitleCollection Members


TitleCollection Properties

TitleCollection Properties |
 | See Also

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from Collection )
Item | Overloaded. (inherited from ChartNamedElementCollection )

Protected Properties

Name | Description
Items | (inherited from Collection )
NamePrefix | Gets the name prefix that is used to create unique chart element names. (inherited from ChartNamedElementCollection )

Explicit Interface Implementations

Name | Description
System.Collections.Generic.ICollection.IsReadOnly | (inherited from Collection )
System.Collections.ICollection.IsSynchronized | (inherited from Collection )
System.Collections.ICollection.SyncRoot | (inherited from Collection )
System.Collections.IList.IsFixedSize | (inherited from Collection )
System.Collections.IList.IsReadOnly | (inherited from Collection )
System.Collections.IList.Item | (inherited from Collection )

See Also

Reference

TitleCollection Class


ToolTipEventArgs Class

ToolTipEventArgs Class |
 | See Also Members

Used as a parameter object in the GetToolTipText event of the root Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ToolTipEventArgs
    Inherits EventArgs
public class ToolTipEventArgs : EventArgs
public ref class ToolTipEventArgs : public EventArgs
public class ToolTipEventArgs extends EventArgs
public class ToolTipEventArgs extends EventArgs

Remarks

This class is exposed as the e parameter in the GetToolTipText event, and provides the mouse position, tooltip text, if any, and details about the chart element over which the mouse cursor is held when the event is raised.

The GetToolTipText event is raised several seconds after the mouse cursor is held over a relevant chart element.

The ToolTipEventArgs class contains the following properties:

  • The X and Y properties, which are used to get the mouse coordinates.

  • The Text property, which is used to get the tooltip for the chart element that the event is raised for. Note that many of the chart elements have a ToolTip, LegendToolTip, and/or LabelToolTip property that you can use to assign a tooltip. These elements include legends, annotations, data points, series, axes, titles, custom labels, and strip lines. This property can also be used to override the tooltip for a chart element, or to set a tooltip for a chart element that doesn't have a ToolTip property.

  • The HitTestResult property, which provides information on the chart element for which the event was raised.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.ToolTipEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ToolTipEventArgs Members


ToolTipEventArgs Members

ToolTipEventArgs Members |
 | See Also Constructors Methods Properties

Used as a parameter object in the GetToolTipText event of the root Chart object.

The following tables list the members exposed by the ToolTipEventArgs type.

Public Constructors

Name | Description
ToolTipEventArgs | Initializes a new instance of the ToolTipEventArgs class with the specified x, y, text and result parameters.
Top

Public Properties

Name | Description
HitTestResult | Gets a HitTestResult object, which provides information about the chart element that the GetToolTipText event was raised for.
Text | Gets or sets the tooltip, if any, of the chart element over which the mouse cursor is held. This property can also set a tooltip for this chart element.
X | Gets the X coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.
Y | Gets the Y coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ToolTipEventArgs Class


ToolTipEventArgs Constructor

ToolTipEventArgs Constructor |
 | See Also

Initializes a new instance of the ToolTipEventArgs class with the specified x, y, text and result parameters.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification:="X and Y are cartesian coordinates and well understood")> _
Public Sub New ( _
    x As Integer, _
    y As Integer, _
    text As String, _
    result As HitTestResult _
)
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")]
public ToolTipEventArgs (
    int x,
    int y,
    string text,
    HitTestResult result
)
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", Justification=L"X and Y are cartesian coordinates and well understood")]
public:
ToolTipEventArgs (
    int x,
    int y,
    String^ text,
    HitTestResult^ result
)
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood") */
public ToolTipEventArgs (
    int x,
    int y,
    String text,
    HitTestResult result
)
SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", Justification="X and Y are cartesian coordinates and well understood")
public function ToolTipEventArgs (
    x : int,
    y : int,
    text : String,
    result : HitTestResult
)

Parameters

x

X-coordinate of mouse.

y

Y-coordinate of mouse.

text

The tooltip text.

result

The HitTestResult object.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ToolTipEventArgs Class
ToolTipEventArgs Members


ToolTipEventArgs Methods

ToolTipEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ToolTipEventArgs Class


ToolTipEventArgs Properties

ToolTipEventArgs Properties |
 | See Also

Public Properties

Name | Description
HitTestResult | Gets a HitTestResult object, which provides information about the chart element that the GetToolTipText event was raised for.
Text | Gets or sets the tooltip, if any, of the chart element over which the mouse cursor is held. This property can also set a tooltip for this chart element.
X | Gets the X coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.
Y | Gets the Y coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.

See Also

Reference

ToolTipEventArgs Class


ToolTipEventArgs.HitTestResult Property

ToolTipEventArgs.HitTestResult Property |
 | See Also

Gets a HitTestResult object, which provides information about the chart element that the GetToolTipText event was raised for.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property HitTestResult As HitTestResult
public HitTestResult HitTestResult { get; }
public:
property HitTestResult^ HitTestResult {
    HitTestResult^ get ();
}
/** @property */
public HitTestResult get_HitTestResult ()

public function get HitTestResult () : HitTestResult

Property Value

A HitTestResult object that represents information for the element the GetToolTipText event was raised for.

Remarks

This property is exposed in the GetToolTipText event of the root Chart object.

The HitTestResult property can be used to get the object the event was raised for, the type of the chart element the event was raised for, and so forth. For further details, see the HitTestResult class overview.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ToolTipEventArgs Class
ToolTipEventArgs Members


ToolTipEventArgs.Text Property

ToolTipEventArgs.Text Property |
 | See Also

Gets or sets the tooltip, if any, of the chart element over which the mouse cursor is held. This property can also set a tooltip for this chart element.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property Text As String
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Text ()

/** @property */
public void set_Text (String value)

public function get Text () : String

public function set Text (value : String)

Property Value

A string value that represents the tooltip text of the element the GetToolTipText event was raised for.

Remarks

This property is exposed in the GetToolTipText event of the root Chart object.

  • The Text property, which is used to get the tooltip for the chart element that the event is raised for. Note that many of the chart elements have a ToolTip, LegendToolTip, and/or LabelToolTip property that you can use to assign a tooltip. These elements include legends, annotations, data points, series, axes, titles, custom labels, and strip lines.

  • If you get this property, it will always return a zero-length string for any chart element items that do not have a tooltip.

You can set this property to:

  • Override the tooltip for any of the chart elements capable of assigning tooltips.

  • Assign a tooltip to a chart element that does not support tooltips.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ToolTipEventArgs Class
ToolTipEventArgs Members


ToolTipEventArgs.X Property

ToolTipEventArgs.X Property |
 | See Also

Gets the X coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="X")> _
Public ReadOnly Property X As Integer
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="X")]
public int X { get; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"X")]
public:
property int X {
    int get ();
}
/** @property */
public int get_X ()

public function get X () : int

Property Value

An integer value that represents the X coordinate of the mouse cursor.

Remarks

This property is exposed in the GetToolTipText event of the root Chart object.

Use the X property to get the X screen coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.

Note that the X coordinate is measured in pixels; the point (0,0) corresponds to the top-left corner of the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ToolTipEventArgs Class
ToolTipEventArgs Members


ToolTipEventArgs.Y Property

ToolTipEventArgs.Y Property |
 | See Also

Gets the Y coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId:="Y")> _
Public ReadOnly Property Y As Integer
[SuppressMessageAttribute("Microsoft.Naming", "CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId="Y")]
public int Y { get; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1704:IdentifiersShouldBeSpelledCorrectly", MessageId=L"Y")]
public:
property int Y {
    int get ();
}
/** @property */
public int get_Y ()

public function get Y () : int

Property Value

An integer that represents the Y coordinate of the mouse cursor.

Remarks

This property is exposed in the GetToolTipText event of the root Chart object.

Use the Y property to get the Y screen coordinate of the point the mouse cursor is held over when the GetToolTipText event is raised.

Note that the Y coordinate is measured in pixels; the point (0,0) corresponds to the top-left corner of the chart.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ToolTipEventArgs Class
ToolTipEventArgs Members


TTestResult Class

TTestResult Class |
 | See Also Members

Stores the results of a T Test statistical formula.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class TTestResult
public class TTestResult
public ref class TTestResult
public class TTestResult
public class TTestResult

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.TTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Members


TTestResult Members

TTestResult Members |
 | See Also Constructors Methods Properties

Stores the results of a T Test statistical formula.

The following tables list the members exposed by the TTestResult type.

Public Constructors

Name | Description
TTestResult | Initializes a new instance of the TTestResult class.
Top

Public Properties

Name | Description
DegreeOfFreedom | Gets the degree of freedom.
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityTOneTail | Gets the Probability T one tail value.
ProbabilityTTwoTail | Gets the Probability T two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
TCriticalValueOneTail | Gets the Critical T one tail value.
TCriticalValueTwoTail | Gets the Critical T two tail value.
TValue | Gets the T value.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TTestResult Class


TTestResult Constructor

TTestResult Constructor |
 | See Also

Initializes a new instance of the TTestResult class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public TTestResult ()
public:
TTestResult ()
public TTestResult ()
public function TTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult Methods

TTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TTestResult Class


TTestResult Properties

TTestResult Properties |
 | See Also

Public Properties

Name | Description
DegreeOfFreedom | Gets the degree of freedom.
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityTOneTail | Gets the Probability T one tail value.
ProbabilityTTwoTail | Gets the Probability T two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
TCriticalValueOneTail | Gets the Critical T one tail value.
TCriticalValueTwoTail | Gets the Critical T two tail value.
TValue | Gets the T value.

See Also

Reference

TTestResult Class


TTestResult.DegreeOfFreedom Property

TTestResult.DegreeOfFreedom Property |
 | See Also

Gets the degree of freedom.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property DegreeOfFreedom As Double
public double DegreeOfFreedom { get; }
public:
property double DegreeOfFreedom {
    double get ();
}
/** @property */
public double get_DegreeOfFreedom ()

public function get DegreeOfFreedom () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.FirstSeriesMean Property

TTestResult.FirstSeriesMean Property |
 | See Also

Gets the mean of the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesMean As Double
public double FirstSeriesMean { get; }
public:
property double FirstSeriesMean {
    double get ();
}
/** @property */
public double get_FirstSeriesMean ()

public function get FirstSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.FirstSeriesVariance Property

TTestResult.FirstSeriesVariance Property |
 | See Also

Gets the variance of the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesVariance As Double
public double FirstSeriesVariance { get; }
public:
property double FirstSeriesVariance {
    double get ();
}
/** @property */
public double get_FirstSeriesVariance ()

public function get FirstSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.ProbabilityTOneTail Property

TTestResult.ProbabilityTOneTail Property |
 | See Also

Gets the Probability T one tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1702:CompoundWordsShouldBeCasedCorrectly", Justification:="T One Tail is a statistics term. 'Tone' is not the intended word here.")> _
Public ReadOnly Property ProbabilityTOneTail As Double
[SuppressMessageAttribute("Microsoft.Naming", "CA1702:CompoundWordsShouldBeCasedCorrectly", Justification="T One Tail is a statistics term. \'Tone\' is not the intended word here.")]
public double ProbabilityTOneTail { get; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1702:CompoundWordsShouldBeCasedCorrectly", Justification=L"T One Tail is a statistics term. \'Tone\' is not the intended word here.")]
public:
property double ProbabilityTOneTail {
    double get ();
}
/** @property */
public double get_ProbabilityTOneTail ()

public function get ProbabilityTOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.ProbabilityTTwoTail Property

TTestResult.ProbabilityTTwoTail Property |
 | See Also

Gets the Probability T two tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityTTwoTail As Double
public double ProbabilityTTwoTail { get; }
public:
property double ProbabilityTTwoTail {
    double get ();
}
/** @property */
public double get_ProbabilityTTwoTail ()

public function get ProbabilityTTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.SecondSeriesMean Property

TTestResult.SecondSeriesMean Property |
 | See Also

Gets the mean of the second series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesMean As Double
public double SecondSeriesMean { get; }
public:
property double SecondSeriesMean {
    double get ();
}
/** @property */
public double get_SecondSeriesMean ()

public function get SecondSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.SecondSeriesVariance Property

TTestResult.SecondSeriesVariance Property |
 | See Also

Gets the variance of the second series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesVariance As Double
public double SecondSeriesVariance { get; }
public:
property double SecondSeriesVariance {
    double get ();
}
/** @property */
public double get_SecondSeriesVariance ()

public function get SecondSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.TCriticalValueOneTail Property

TTestResult.TCriticalValueOneTail Property |
 | See Also

Gets the Critical T one tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property TCriticalValueOneTail As Double
public double TCriticalValueOneTail { get; }
public:
property double TCriticalValueOneTail {
    double get ();
}
/** @property */
public double get_TCriticalValueOneTail ()

public function get TCriticalValueOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.TCriticalValueTwoTail Property

TTestResult.TCriticalValueTwoTail Property |
 | See Also

Gets the Critical T two tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property TCriticalValueTwoTail As Double
public double TCriticalValueTwoTail { get; }
public:
property double TCriticalValueTwoTail {
    double get ();
}
/** @property */
public double get_TCriticalValueTwoTail ()

public function get TCriticalValueTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


TTestResult.TValue Property

TTestResult.TValue Property |
 | See Also

Gets the T value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property TValue As Double
public double TValue { get; }
public:
property double TValue {
    double get ();
}
/** @property */
public double get_TValue ()

public function get TValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

TTestResult Class
TTestResult Members


VerticalLineAnnotation Class

VerticalLineAnnotation Class |
 | See Also Members

Represents a vertical line annotation.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class VerticalLineAnnotation
    Inherits LineAnnotation
public class VerticalLineAnnotation : LineAnnotation
public ref class VerticalLineAnnotation : public LineAnnotation
public class VerticalLineAnnotation extends LineAnnotation
public class VerticalLineAnnotation extends LineAnnotation

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ChartElement
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement
System.Windows.Forms.DataVisualization.Charting.Annotation
System.Windows.Forms.DataVisualization.Charting.LineAnnotation
System.Windows.Forms.DataVisualization.Charting.VerticalLineAnnotation

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

VerticalLineAnnotation Members


VerticalLineAnnotation Members

VerticalLineAnnotation Members |
 | See Also Constructors Methods Properties

Represents a vertical line annotation.

The following tables list the members exposed by the VerticalLineAnnotation type.

Public Constructors

Name | Description
VerticalLineAnnotation | Initializes a new instance of the VerticalLineAnnotation class.
Top

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation)
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation)
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation)
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation)
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation)
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation)
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation)
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation)
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation)
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation)
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation)
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation)
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation)
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation)
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation)
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation)
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation)
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation)
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation)
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation)
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation)
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
Height | Gets or sets the height of an annotation. (inherited from Annotation)
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation)
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation)
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation)
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation)
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation)
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation)
Name | Gets or sets the unique name of an annotation. (inherited from Annotation)
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation)
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation)
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation)
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation)
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation)
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement)
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation)
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation)
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation)
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation)
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation)
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation)
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation)
Top

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation)
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation)
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation)
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement)
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation)
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation)
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement)
Top

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

VerticalLineAnnotation Class


VerticalLineAnnotation Constructor

VerticalLineAnnotation Constructor |
 | See Also

Initializes a new instance of the VerticalLineAnnotation class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public VerticalLineAnnotation ()
public:
VerticalLineAnnotation ()
public VerticalLineAnnotation ()
public function VerticalLineAnnotation ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

VerticalLineAnnotation Class
VerticalLineAnnotation Members


VerticalLineAnnotation Methods

VerticalLineAnnotation Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
BeginPlacement | Begins the end user placement of an annotation using the mouse. (inherited from Annotation )
BringToFront | Brings an annotation to the front of all annotations. (inherited from Annotation )
Dispose | Overloaded. (inherited from Annotation )
EndPlacement | Ends the end user placement of an annotation. (inherited from Annotation )
Equals | Overloaded. (inherited from ChartElement )
GetHashCode | Returns a hash function for a particular type. (inherited from ChartElement )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ResizeToContent | Resizes an annotation according to its content size. (inherited from Annotation )
SendToBack | Sends an annotation to the back of all the annotations. (inherited from Annotation )
SetAnchor | Overloaded. (inherited from Annotation )
ToString | Returns a string that represents the current Object. (inherited from ChartElement )

Protected Methods

Name | Description
Dispose | Overloaded. (inherited from Annotation )
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

VerticalLineAnnotation Class


VerticalLineAnnotation Properties

VerticalLineAnnotation Properties |
 | See Also

Public Properties

Name | Description
Alignment | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
AllowAnchorMoving | Gets or sets a flag that specifies whether the end user is allowed to move the annotation anchor using a mouse. (inherited from Annotation )
AllowMoving | Gets or sets a flag that specifies whether the end user is allowed to move an annotation using a mouse. (inherited from Annotation )
AllowPathEditing | Gets or sets a flag that specifies whether the end user is allowed to move the points of a polygon annotation using a mouse. (inherited from Annotation )
AllowResizing | Gets or sets a flag that specifies whether the end user is allowed to resize an annotation using a mouse. (inherited from Annotation )
AllowSelecting | Gets or sets a flag that specifies whether the end user is allowed to select an annotation using a mouse. (inherited from Annotation )
AllowTextEditing | Gets or sets a flag that specifies whether the text in an annotation may be edited when the end user double clicks the text. (inherited from Annotation )
AnchorAlignment | Gets or sets the position alignment of an annotation to the anchor point. (inherited from LineAnnotation )
AnchorDataPoint | Gets or sets the data point to which an annotation is anchored. (inherited from Annotation )
AnchorDataPointName | Gets or sets the name of a data point to which an annotation is anchored. For internal use only. (inherited from Annotation )
AnchorOffsetX | Gets or sets the offset from the anchor point for the X position of an annotation. (inherited from Annotation )
AnchorOffsetY | Gets or sets the offset from the anchor point for the Y position of an annotation. (inherited from Annotation )
AnchorX | Gets or sets the X coordinate to which the annotation is anchored. (inherited from Annotation )
AnchorY | Gets or sets the Y coordinate to which the annotation is anchored. (inherited from Annotation )
AnnotationGroup | Gets the group, if any, to which the annotation belongs. For internal use only. (inherited from Annotation )
AnnotationType | Overridden. Gets the annotation type. For internal use only.
AxisX | Gets or sets the X axis to which an annotation is attached. (inherited from Annotation )
AxisXName | Gets or sets the name of the X axis to which an annotation is attached. For internal use only. (inherited from Annotation )
AxisY | Gets or sets the Y axis to which an annotation is attached. (inherited from Annotation )
AxisYName | Gets or sets the name of the Y axis which an annotation is attached to. For internal use only. (inherited from Annotation )
BackColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackGradientStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackHatchStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
BackSecondaryColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Bottom | Gets or sets the bottom boundary of an annotation position. (inherited from Annotation )
ClipToChartArea | Gets or sets the name of the chart area to which an annotation is clipped. (inherited from Annotation )
EndCap | Gets or sets a style for the anchor cap at the end of the annotation line. (inherited from LineAnnotation )
Font | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ForeColor | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
Height | Gets or sets the height of an annotation. (inherited from Annotation )
IsInfinitive | Gets or sets a flag that indicates whether an infinite line should be drawn. (inherited from LineAnnotation )
IsSelected | Gets or sets a flag that determines if an annotation is selected. (inherited from Annotation )
IsSizeAlwaysRelative | Gets or sets a flag that specifies whether the size of an annotation is always defined in relative chart coordinates. (inherited from LineAnnotation )
LineColor | Gets or sets the line color of an annotation. (inherited from Annotation )
LineDashStyle | Gets or sets the line style of an annotation. (inherited from Annotation )
LineWidth | Gets or sets the line width of an annotation. (inherited from Annotation )
Name | Gets or sets the unique name of an annotation. (inherited from Annotation )
Right | Gets or sets the right boundary position of an annotation. (inherited from Annotation )
ShadowColor | Gets or sets the color of an annotation's shadow. (inherited from Annotation )
ShadowOffset | Gets or sets the size of an annotation's shadow. (inherited from Annotation )
SmartLabelStyle | Gets or sets the smart label style of an annotation. (inherited from Annotation )
StartCap | Gets or sets a style for the anchor cap at the start of an annotation line. (inherited from LineAnnotation )
Tag | Gets or sets an object associated with this chart element. (inherited from ChartElement )
TextStyle | This property is not applicable to the line annotation type. (inherited from LineAnnotation )
ToolTip | Gets or sets the tooltip text for an annotation. (inherited from Annotation )
Visible | Gets or sets a flag that specifies whether an annotation is visible. (inherited from Annotation )
Width | Gets or sets the width, in pixels, of an annotation. (inherited from Annotation )
X | Gets or sets the X coordinate of an annotation. (inherited from Annotation )
Y | Gets or sets the Y coordinate of the annotation. (inherited from Annotation )
YAxisName | Gets or sets the name of the Y axis to which an annotation is attached. For internal use only. (inherited from Annotation )

See Also

Reference

VerticalLineAnnotation Class


VerticalLineAnnotation.AnnotationType Property

VerticalLineAnnotation.AnnotationType Property |
 | See Also

This property supports the Microsoft Chart Controls infrastructure and is not intended to be used directly from your code.
Gets the annotation type. For internal use only.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public Overrides ReadOnly Property AnnotationType As String
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override string AnnotationType { get; }
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property String^ AnnotationType {
    String^ get () override;
}
/** @property */
public String get_AnnotationType ()

public override function get AnnotationType () : String

Remarks

For internal use, should not be used.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

VerticalLineAnnotation Class
VerticalLineAnnotation Members


ViewEventArgs Class

ViewEventArgs Class |
 | See Also Members

Used as a parameter object in the AxisViewChanged and AxisViewChanging events of the root Chart object.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ViewEventArgs
    Inherits EventArgs
public class ViewEventArgs : EventArgs
public ref class ViewEventArgs : public EventArgs
public class ViewEventArgs extends EventArgs
public class ViewEventArgs extends EventArgs

Remarks

This class is exposed as the e parameter in the AxisViewChanged and AxisViewChanging events. The AxisViewChanging event is raised just before a new view is displayed, as a result of the end-user clicking and dragging in a chart area. The AxisViewChanged event is raised just after the new view is created.

It is important to note that the position and size of a view cannot be set in the AxisViewChanged event because in this case the view is already created.

The ViewEventArgs class contains the following properties:

  • The ChartArea property, which is used to get the ChartArea object in which the view is being displayed. The Name property gets the name of the chart area. Other chart area properties can also be set.

  • The Axis property, which is used to get the Axis object with which the view is associated. To determine the type of axis, which can be X, Y, X2 or Y2, use the AxisName property. Other axis properties can also be set.

  • The NewPosition property, which represents the new position of a view.

  • The NewSize property, which represents the new size of a view.

  • The NewSizeType property, which represents the unit of measurement for the size of a view.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.DataVisualization.Charting.ViewEventArgs

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Members


ViewEventArgs Members

ViewEventArgs Members |
 | See Also Constructors Methods Properties

Used as a parameter object in the AxisViewChanged and AxisViewChanging events of the root Chart object.

The following tables list the members exposed by the ViewEventArgs type.

Public Constructors

Name | Description
ViewEventArgs | Overloaded.
Top

Public Properties

Name | Description
Axis | Gets the Axis object that a view belongs to.
ChartArea | Gets the ChartArea object that a view belongs to.
NewPosition | Gets the new position of a view along an axis.
NewSize | Gets or sets the size of a view.
NewSizeType | Gets the unit of measurement for the new size of a view.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ViewEventArgs Class


ViewEventArgs Constructor

ViewEventArgs Constructor |
 | See Also

Overload List

Name | Description
ViewEventArgs (Axis, Double) | Initializes a new instance of the ViewEventArgs class with the specified axis and newPosition parameters.
ViewEventArgs (Axis, Double, Double, DateTimeIntervalType) | Initializes a new instance of the ViewEventArgs class with the specified axis, newPosition, newSize and newSizeType parameters.

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs Constructor (Axis, Double)

ViewEventArgs Constructor (Axis, Double) |
 | See Also

Initializes a new instance of the ViewEventArgs class with the specified axis and newPosition parameters.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    axis As Axis, _
    newPosition As Double _
)
public ViewEventArgs (
    Axis axis,
    double newPosition
)
public:
ViewEventArgs (
    Axis^ axis,
    double newPosition
)
public ViewEventArgs (
    Axis axis,
    double newPosition
)
public function ViewEventArgs (
    axis : Axis,
    newPosition : double
)

Parameters

axis

The axis of the scale view.

newPosition

The start position of the new scale view.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs Constructor (Axis, Double, Double, DateTimeIntervalType)

ViewEventArgs Constructor (Axis, Double, Double, DateTimeIntervalType) |
 | See Also

Initializes a new instance of the ViewEventArgs class with the specified axis, newPosition, newSize and newSizeType parameters.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New ( _
    axis As Axis, _
    newPosition As Double, _
    newSize As Double, _
    newSizeType As DateTimeIntervalType _
)
public ViewEventArgs (
    Axis axis,
    double newPosition,
    double newSize,
    DateTimeIntervalType newSizeType
)
public:
ViewEventArgs (
    Axis^ axis,
    double newPosition,
    double newSize,
    DateTimeIntervalType newSizeType
)
public ViewEventArgs (
    Axis axis,
    double newPosition,
    double newSize,
    DateTimeIntervalType newSizeType
)
public function ViewEventArgs (
    axis : Axis,
    newPosition : double,
    newSize : double,
    newSizeType : DateTimeIntervalType
)

Parameters

axis

The axis of the scale view.

newPosition

The start position of the new scale view.

newSize

The new scale view size.

newSizeType

The unit of measurement for the size of the new scale view.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs Methods

ViewEventArgs Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ViewEventArgs Class


ViewEventArgs Properties

ViewEventArgs Properties |
 | See Also

Public Properties

Name | Description
Axis | Gets the Axis object that a view belongs to.
ChartArea | Gets the ChartArea object that a view belongs to.
NewPosition | Gets the new position of a view along an axis.
NewSize | Gets or sets the size of a view.
NewSizeType | Gets the unit of measurement for the new size of a view.

See Also

Reference

ViewEventArgs Class


ViewEventArgs.Axis Property

ViewEventArgs.Axis Property |
 | See Also

Gets the Axis object that a view belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property Axis As Axis
public Axis Axis { get; }
public:
property Axis^ Axis {
    Axis^ get ();
}
/** @property */
public Axis get_Axis ()

public function get Axis () : Axis

Property Value

An Axis object that represents the axis that a view belongs to.

Remarks

This property is exposed in the AxisViewChanged and AxisViewChanging events of the root Chart object.

This property can be used to:

  • Determine the type of axis—X, X2, Y or Y2—that the event is being raised for, using the AxisName property.

  • Get and set axis properties, such as LineColor.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs.ChartArea Property

ViewEventArgs.ChartArea Property |
 | See Also

Gets the ChartArea object that a view belongs to.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ChartArea As ChartArea
public ChartArea ChartArea { get; }
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
}
/** @property */
public ChartArea get_ChartArea ()

public function get ChartArea () : ChartArea

Property Value

A ChartArea object that represents the chart area a view belongs to.

Remarks

This property is exposed in the AxisViewChanged and AxisViewChanging events of the root Chart object.

The ChartArea property can be used to determine the chart area that the view belongs to, by accessing the Name property. This property can also be used to get and set chart area properties.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs.NewPosition Property

ViewEventArgs.NewPosition Property |
 | See Also

Gets the new position of a view along an axis.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewPosition As Double
public double NewPosition { get; set; }
public:
property double NewPosition {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewPosition ()

/** @property */
public void set_NewPosition (double value)

public function get NewPosition () : double

public function set NewPosition (value : double)

Property Value

A double value that represents the position of a view along an axis, which is the bottom of a vertical view or the left position of a horizontal view, respectively.

Remarks

This property is exposed in the AxisViewChanged and AxisViewChanging events of the root Chart object, and represents the new position of a view.

The NewPosition property can be set to a new value in the AxisViewChanging event, but cannot be set to a new value for the AxisViewChanged event because in this case the view is already created.

The NewPosition is always measured as an axis value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs.NewSize Property

ViewEventArgs.NewSize Property |
 | See Also

Gets or sets the size of a view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewSize As Double
public double NewSize { get; set; }
public:
property double NewSize {
    double get ();
    void set (double value);
}
/** @property */
public double get_NewSize ()

/** @property */
public void set_NewSize (double value)

public function get NewSize () : double

public function set NewSize (value : double)

Property Value

A double value that represents the size of a view along an axis. The size is the height of the vertical view or width of the horizontal view, respectively.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ViewEventArgs.NewSizeType Property

ViewEventArgs.NewSizeType Property |
 | See Also

Gets the unit of measurement for the new size of a view.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Property NewSizeType As DateTimeIntervalType
public DateTimeIntervalType NewSizeType { get; set; }
public:
property DateTimeIntervalType NewSizeType {
    DateTimeIntervalType get ();
    void set (DateTimeIntervalType value);
}
/** @property */
public DateTimeIntervalType get_NewSizeType ()

/** @property */
public void set_NewSizeType (DateTimeIntervalType value)

public function get NewSizeType () : DateTimeIntervalType

public function set NewSizeType (value : DateTimeIntervalType)

Property Value

A DateTimeIntervalType enumeration value that represents the unit of measurement for the NewSize property, which represents the width or height of a data view. The default value is Auto.

Remarks

When this property is set to Auto, the unit of measurement for the NewSize property is automatically determined by the :System.Windows.Forms.DataVisualization.Charting.Chart control, and will be either a number or a day.

Recall that the NewSize property is always measured as an axis value. Make sure that if you explicitly set the size type, the type matches the axis that the scrollbar belongs to. In other words, do not specify Minutes if the axis does not use DateTime values.

Note that the NewSize property can be set to a new value in the AxisViewChanging event, but cannot be set to a new value for the AxisViewChanged event because the view is already created.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ViewEventArgs Class
ViewEventArgs Members


ZTestResult Class

ZTestResult Class |
 | See Also Members

Stores the results of a Z Test statistical formula.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Class ZTestResult
public class ZTestResult
public ref class ZTestResult
public class ZTestResult
public class ZTestResult

Inheritance Hierarchy

System.Object
System.Windows.Forms.DataVisualization.Charting.ZTestResult

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Members


ZTestResult Members

ZTestResult Members |
 | See Also Constructors Methods Properties

Stores the results of a Z Test statistical formula.

The following tables list the members exposed by the ZTestResult type.

Public Constructors

Name | Description
ZTestResult | Initializes a new instance of the ZTestResult class.
Top

Public Properties

Name | Description
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityZOneTail | Gets the Probability Z one tail value.
ProbabilityZTwoTail | Gets the Probability Z two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
ZCriticalValueOneTail | Gets the Critical Z one tail value.
ZCriticalValueTwoTail | Gets the Critical Z two tail value.
ZValue | Gets the Z value.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ZTestResult Class


ZTestResult Constructor

ZTestResult Constructor |
 | See Also

Initializes a new instance of the ZTestResult class.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public Sub New
public ZTestResult ()
public:
ZTestResult ()
public ZTestResult ()
public function ZTestResult ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult Methods

ZTestResult Methods |
 | See Also

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ZTestResult Class


ZTestResult Properties

ZTestResult Properties |
 | See Also

Public Properties

Name | Description
FirstSeriesMean | Gets the mean of the first series.
FirstSeriesVariance | Gets the variance of the first series.
ProbabilityZOneTail | Gets the Probability Z one tail value.
ProbabilityZTwoTail | Gets the Probability Z two tail value.
SecondSeriesMean | Gets the mean of the second series.
SecondSeriesVariance | Gets the variance of the second series.
ZCriticalValueOneTail | Gets the Critical Z one tail value.
ZCriticalValueTwoTail | Gets the Critical Z two tail value.
ZValue | Gets the Z value.

See Also

Reference

ZTestResult Class


ZTestResult.FirstSeriesMean Property

ZTestResult.FirstSeriesMean Property |
 | See Also

Gets the mean of the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesMean As Double
public double FirstSeriesMean { get; }
public:
property double FirstSeriesMean {
    double get ();
}
/** @property */
public double get_FirstSeriesMean ()

public function get FirstSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.FirstSeriesVariance Property

ZTestResult.FirstSeriesVariance Property |
 | See Also

Gets the variance of the first series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property FirstSeriesVariance As Double
public double FirstSeriesVariance { get; }
public:
property double FirstSeriesVariance {
    double get ();
}
/** @property */
public double get_FirstSeriesVariance ()

public function get FirstSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.ProbabilityZOneTail Property

ZTestResult.ProbabilityZOneTail Property |
 | See Also

Gets the Probability Z one tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

<SuppressMessageAttribute("Microsoft.Naming", "CA1702:CompoundWordsShouldBeCasedCorrectly", Justification:="Z One Tail is a statistics term. 'Zone' is not the intended word here.")> _
Public ReadOnly Property ProbabilityZOneTail As Double
[SuppressMessageAttribute("Microsoft.Naming", "CA1702:CompoundWordsShouldBeCasedCorrectly", Justification="Z One Tail is a statistics term. \'Zone\' is not the intended word here.")]
public double ProbabilityZOneTail { get; }
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1702:CompoundWordsShouldBeCasedCorrectly", Justification=L"Z One Tail is a statistics term. \'Zone\' is not the intended word here.")]
public:
property double ProbabilityZOneTail {
    double get ();
}
/** @property */
public double get_ProbabilityZOneTail ()

public function get ProbabilityZOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.ProbabilityZTwoTail Property

ZTestResult.ProbabilityZTwoTail Property |
 | See Also

Gets the Probability Z two tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ProbabilityZTwoTail As Double
public double ProbabilityZTwoTail { get; }
public:
property double ProbabilityZTwoTail {
    double get ();
}
/** @property */
public double get_ProbabilityZTwoTail ()

public function get ProbabilityZTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.SecondSeriesMean Property

ZTestResult.SecondSeriesMean Property |
 | See Also

Gets the mean of the second series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesMean As Double
public double SecondSeriesMean { get; }
public:
property double SecondSeriesMean {
    double get ();
}
/** @property */
public double get_SecondSeriesMean ()

public function get SecondSeriesMean () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.SecondSeriesVariance Property

ZTestResult.SecondSeriesVariance Property |
 | See Also

Gets the variance of the second series.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property SecondSeriesVariance As Double
public double SecondSeriesVariance { get; }
public:
property double SecondSeriesVariance {
    double get ();
}
/** @property */
public double get_SecondSeriesVariance ()

public function get SecondSeriesVariance () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.ZCriticalValueOneTail Property

ZTestResult.ZCriticalValueOneTail Property |
 | See Also

Gets the Critical Z one tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ZCriticalValueOneTail As Double
public double ZCriticalValueOneTail { get; }
public:
property double ZCriticalValueOneTail {
    double get ();
}
/** @property */
public double get_ZCriticalValueOneTail ()

public function get ZCriticalValueOneTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.ZCriticalValueTwoTail Property

ZTestResult.ZCriticalValueTwoTail Property |
 | See Also

Gets the Critical Z two tail value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ZCriticalValueTwoTail As Double
public double ZCriticalValueTwoTail { get; }
public:
property double ZCriticalValueTwoTail {
    double get ();
}
/** @property */
public double get_ZCriticalValueTwoTail ()

public function get ZCriticalValueTwoTail () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ZTestResult.ZValue Property

ZTestResult.ZValue Property |
 | See Also

Gets the Z value.

Namespace: System.Windows.Forms.DataVisualization.Charting
Assembly: System.Windows.Forms.DataVisualization (in system.windows.forms.datavisualization.dll)

Syntax

Public ReadOnly Property ZValue As Double
public double ZValue { get; }
public:
property double ZValue {
    double get ();
}
/** @property */
public double get_ZValue ()

public function get ZValue () : double

Property Value

A double value.

Thread Safety

Any public static (Shared in Microsoft Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

For a list of the supported platforms, see Hardware and Software Requirements for Installing SQL Server 2005.

Target Platforms

See Also

Reference

ZTestResult Class
ZTestResult Members


ChartElement Hierarchy

ChartElement Hierarchy |
 | See Also

The following table lists the classes derived from System.Windows.Forms.DataVisualization.Charting.ChartElement .

Derived Classes

Class | Description
System.Windows.Forms.DataVisualization.Charting.AnnotationPathPoint |
System.Windows.Forms.DataVisualization.Charting.BorderSkin |
System.Windows.Forms.DataVisualization.Charting.ChartGraphics |
System.Windows.Forms.DataVisualization.Charting.ChartNamedElement |
System.Windows.Forms.DataVisualization.Charting.ElementPosition |
System.Windows.Forms.DataVisualization.Charting.LabelStyle |
System.Windows.Forms.DataVisualization.Charting.StripLine |

See Also

Reference

ChartElement Class
ChartElement Members


ChartNamedElement Hierarchy

ChartNamedElement Hierarchy |
 | See Also

The following table lists the classes derived from System.Windows.Forms.DataVisualization.Charting.ChartNamedElement .

Derived Classes

Class | Description
System.Windows.Forms.DataVisualization.Charting.Annotation |
System.Windows.Forms.DataVisualization.Charting.Axis |
System.Windows.Forms.DataVisualization.Charting.ChartArea |
System.Windows.Forms.DataVisualization.Charting.CustomLabel |
System.Windows.Forms.DataVisualization.Charting.DataPointCustomProperties |
System.Windows.Forms.DataVisualization.Charting.Legend |
System.Windows.Forms.DataVisualization.Charting.LegendCell |
System.Windows.Forms.DataVisualization.Charting.LegendCellColumn |
System.Windows.Forms.DataVisualization.Charting.LegendItem |
System.Windows.Forms.DataVisualization.Charting.NamedImage |
System.Windows.Forms.DataVisualization.Charting.Title |

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members


ChartNamedElementCollection<T> Hierarchy

ChartNamedElementCollection<T> Hierarchy |
 | See Also

The following table lists the classes derived from System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection .

Derived Classes

Class | Description
System.Windows.Forms.DataVisualization.Charting.AnnotationCollection |
System.Windows.Forms.DataVisualization.Charting.ChartAreaCollection |
System.Windows.Forms.DataVisualization.Charting.LegendCellCollection |
System.Windows.Forms.DataVisualization.Charting.LegendCellColumnCollection |
System.Windows.Forms.DataVisualization.Charting.LegendCollection |
System.Windows.Forms.DataVisualization.Charting.NamedImagesCollection |
System.Windows.Forms.DataVisualization.Charting.SeriesCollection |
System.Windows.Forms.DataVisualization.Charting.TitleCollection |

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members


ChartNamedElementCollection<T> Hierarchy

ChartNamedElementCollection<T> Hierarchy |
 | See Also

The following table lists the classes derived from System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection .

Derived Classes

Class | Description
System.Web.UI.DataVisualization.Charting.AnnotationCollection |
System.Web.UI.DataVisualization.Charting.ChartAreaCollection |
System.Web.UI.DataVisualization.Charting.LegendCellCollection |
System.Web.UI.DataVisualization.Charting.LegendCellColumnCollection |
System.Web.UI.DataVisualization.Charting.LegendCollection |
System.Web.UI.DataVisualization.Charting.NamedImagesCollection |
System.Web.UI.DataVisualization.Charting.SeriesCollection |
System.Web.UI.DataVisualization.Charting.TitleCollection |

See Also

Reference

ChartNamedElementCollection Class
ChartNamedElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace


ChartElement Hierarchy

ChartElement Hierarchy |
 | See Also

The following table lists the classes derived from System.Web.UI.DataVisualization.Charting.ChartElement .

Derived Classes

Class | Description
System.Web.UI.DataVisualization.Charting.AnnotationPathPoint |
System.Web.UI.DataVisualization.Charting.BorderSkin |
System.Web.UI.DataVisualization.Charting.ChartGraphics |
System.Web.UI.DataVisualization.Charting.ChartNamedElement |
System.Web.UI.DataVisualization.Charting.ElementPosition |
System.Web.UI.DataVisualization.Charting.LabelStyle |
System.Web.UI.DataVisualization.Charting.StripLine |

See Also

Reference

ChartElement Class
ChartElement Members
System.Web.UI.DataVisualization.Charting Namespace


ChartNamedElement Hierarchy

ChartNamedElement Hierarchy |
 | See Also

The following table lists the classes derived from System.Web.UI.DataVisualization.Charting.ChartNamedElement .

Derived Classes

Class | Description
System.Web.UI.DataVisualization.Charting.Annotation |
System.Web.UI.DataVisualization.Charting.Axis |
System.Web.UI.DataVisualization.Charting.ChartArea |
System.Web.UI.DataVisualization.Charting.CustomLabel |
System.Web.UI.DataVisualization.Charting.DataPointCustomProperties |
System.Web.UI.DataVisualization.Charting.Legend |
System.Web.UI.DataVisualization.Charting.LegendCell |
System.Web.UI.DataVisualization.Charting.LegendCellColumn |
System.Web.UI.DataVisualization.Charting.LegendItem |
System.Web.UI.DataVisualization.Charting.MapArea |
System.Web.UI.DataVisualization.Charting.NamedImage |
System.Web.UI.DataVisualization.Charting.Title |

See Also

Reference

ChartNamedElement Class
ChartNamedElement Members
System.Web.UI.DataVisualization.Charting Namespace


Annotation Hierarchy

Annotation Hierarchy |
 | See Also

The following table lists the classes derived from System.Windows.Forms.DataVisualization.Charting.Annotation .

Derived Classes

Class | Description
System.Windows.Forms.DataVisualization.Charting.AnnotationGroup |
System.Windows.Forms.DataVisualization.Charting.ArrowAnnotation |
System.Windows.Forms.DataVisualization.Charting.ImageAnnotation |
System.Windows.Forms.DataVisualization.Charting.LineAnnotation |
System.Windows.Forms.DataVisualization.Charting.PolylineAnnotation |
System.Windows.Forms.DataVisualization.Charting.TextAnnotation |

See Also

Reference

Annotation Class
Annotation Members


Annotation Hierarchy

Annotation Hierarchy |
 | See Also

The following table lists the classes derived from System.Web.UI.DataVisualization.Charting.Annotation .

Derived Classes

Class | Description
System.Web.UI.DataVisualization.Charting.AnnotationGroup |
System.Web.UI.DataVisualization.Charting.ArrowAnnotation |
System.Web.UI.DataVisualization.Charting.ImageAnnotation |
System.Web.UI.DataVisualization.Charting.LineAnnotation |
System.Web.UI.DataVisualization.Charting.PolylineAnnotation |
System.Web.UI.DataVisualization.Charting.TextAnnotation |

See Also

Reference

Annotation Class
Annotation Members
System.Web.UI.DataVisualization.Charting Namespace


Legal Notice for Documentation

Microsoft Chart Controls
Legal Notice for Documentation

Information in this documentation, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

This documentation, including sample applications herein, is provided for informational purposes only, and Microsoft and its suppliers make no warranties, either express or implied, in this documentation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2008 Microsoft Corporation. All rights reserved.

Microsoft, Windows, Windows Server, Active Directory, ActiveX, Excel, IntelliSense, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual InterDev, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows Server System, Windows Vista, and WinFX are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other trademarks are property of their respective owners.


ChartElementCollection<T> Hierarchy

ChartElementCollection<T> Hierarchy |
 | See Also

The following table lists the classes derived from System.Windows.Forms.DataVisualization.Charting.ChartElementCollection .

Derived Classes

Class | Description
System.Windows.Forms.DataVisualization.Charting.AnnotationPathPointCollection |
System.Windows.Forms.DataVisualization.Charting.ChartNamedElementCollection`1 |
System.Windows.Forms.DataVisualization.Charting.CustomLabelsCollection |
System.Windows.Forms.DataVisualization.Charting.DataPointCollection |
System.Windows.Forms.DataVisualization.Charting.LegendItemsCollection |
System.Windows.Forms.DataVisualization.Charting.StripLinesCollection |

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members


ChartElementCollection<T> Hierarchy

ChartElementCollection<T> Hierarchy |
 | See Also

The following table lists the classes derived from System.Web.UI.DataVisualization.Charting.ChartElementCollection .

Derived Classes

Class | Description
System.Web.UI.DataVisualization.Charting.AnnotationPathPointCollection |
System.Web.UI.DataVisualization.Charting.ChartNamedElementCollection`1 |
System.Web.UI.DataVisualization.Charting.CustomLabelsCollection |
System.Web.UI.DataVisualization.Charting.DataPointCollection |
System.Web.UI.DataVisualization.Charting.LegendItemsCollection |
System.Web.UI.DataVisualization.Charting.MapAreasCollection |
System.Web.UI.DataVisualization.Charting.StripLinesCollection |

See Also

Reference

ChartElementCollection Class
ChartElementCollection Members
System.Web.UI.DataVisualization.Charting Namespace