Ticket #1567 (closed defect: done)

Opened 3 years ago

Last modified 3 years ago

PSO sample produces different results on x86 and AnyCPU builds

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.5
Component: General Version: 3.3.5
Keywords: Cc:

Description


Change History

comment:1 Changed 3 years ago by gkronber

This problem also affects GP samples

Last edited 3 years ago by gkronber (previous) (diff)

comment:2 Changed 3 years ago by gkronber

  • Owner changed from mkofler to gkronber
  • Status changed from new to accepted

comment:3 Changed 3 years ago by gkronber

  • Component changed from Algorithms.ParticleSwarmOptimization to General
  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.5

This is mostly an issue for the unit tests (which are executed on an x64 machine using the Release/AnyCPU configuration).

comment:4 Changed 3 years ago by gkronber

r6499: changed project configuration of HeuristicLab.Test-3.3 to Release/x86 for the solution configuration Release/AnyCPU.

comment:5 Changed 3 years ago by gkronber

r6502: changed GP unit tests and reverted changeset r6499

comment:6 Changed 3 years ago by gkronber

r6504: updated test settings for unit tests executed locally and on the builder to execute the tests in an x64 process on x64 machines.

comment:7 Changed 3 years ago by gkronber

r6505: added assertions for the x64 results for PSO_Schwefel sample unit test.

comment:8 Changed 3 years ago by gkronber

  • Owner changed from gkronber to swagner
  • Status changed from accepted to reviewing

comment:9 Changed 3 years ago by swagner

  • Owner changed from swagner to gkronber
  • Status changed from reviewing to readytorelease

Thanks for fixing this.

comment:10 Changed 3 years ago by swagner

  • Status changed from readytorelease to closed
  • Version changed from 3.3.4 to 3.3.5
  • Resolution set to done
Note: See TracTickets for help on using tickets.