Opened 3 months ago

Closed 3 weeks ago

#2765 closed enhancement (done)

ScatterPlot should support tag objects

Reported by: mkommend Owned by: pfleck
Priority: medium Milestone: HeuristicLab 3.3.15
Component: Analysis.Views Version: 3.3.14
Keywords: Cc:

Description

It would be really useful to attach objects to the data points that are opened on double click.

Change History (10)

comment:1 Changed 3 months ago by mkommend

This ticket should be merged to stable after #2713.

comment:2 Changed 3 months ago by mkommend

  • Status changed from new to accepted

comment:3 Changed 3 months ago by mkommend

r14860: Implemented tags for data points in ScatterPlot.

comment:4 Changed 3 months ago by mkommend

r14861: Adapted multi-objective SymReg analyzer to add the solutions as tag to the data points.

The new feature can be tested using a NSGA-II for symbolic regression (multi-objective).

comment:5 Changed 3 months ago by mkommend

  • Owner changed from mkommend to swagner
  • Status changed from accepted to reviewing

comment:6 Changed 3 weeks ago by pfleck

  • Owner changed from swagner to pfleck

comment:7 Changed 3 weeks ago by pfleck

  • Status changed from reviewing to readytorelease

Reviewed r14860, r14861:

Looks good. This could also be a useful feature for the DataTable (e.g. DataRows of type Points and Columns).

comment:8 Changed 3 weeks ago by pfleck

Due to a svn-move operation of DataTable/ScatterPlotControl -> DataTable/ScatterPlotView (in r14982), changes of multiple tickets (#2713, #2715, #2765) were included in a single revision. Instead of a manually extracting the changes from that files, all three tickets will be merged and released simultaneously.

comment:9 Changed 3 weeks ago by pfleck

r15097: Merged to stable

  • 14435-14439,14493,14516,14519,14982,14987,14992,15042 (from #2713)
  • 14457-14458,14508,14582,14740,14984,15068,15095 (from #2715)
  • 14860-14861 (from #2765)

comment:10 Changed 3 weeks ago by pfleck

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.