Opened 4 months ago

Closed 7 weeks ago

#2761 closed feature request (done)

DataPreprocessing should show the TypeSelectorDialog for creating filters

Reported by: gkronber Owned by: pfleck
Priority: medium Milestone: HeuristicLab 3.3.15
Component: DataPreprocessing.Views Version: 3.3.14
Keywords: Cc:

Description


Change History (9)

comment:1 Changed 4 months ago by gkronber

  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 4 months ago by lkammere

r14817: using TypeSelectorDialog for creating filters

comment:3 Changed 4 months ago by lkammere

  • Owner changed from gkronber to pfleck
  • Status changed from accepted to reviewing

comment:4 Changed 4 months ago by pfleck

  • Owner changed from pfleck to lkammere
  • Status changed from reviewing to assigned

The base-call of addButton_Click already uses the TypeSelectorDialog, so I suggest you just delete the method in the CheckedFilterCollectionView.

comment:5 Changed 4 months ago by lkammere

  • Owner changed from lkammere to pfleck
  • Status changed from assigned to reviewing

r14819 Remove unnecessary override of event handler.

comment:6 Changed 2 months ago by pfleck

  • Owner changed from pfleck to lkammere
  • Status changed from reviewing to assigned

When adding a new Filter, it is shown as checked (default true in CheckedItemCollection.OnItemsAdded), but the Filter is actually not active.

The filter should indeed be disabled after it was added but the view should correctly display this (as it was done before we removed the Content.SetItemCheckState(filter, false) in r14819.

comment:7 Changed 7 weeks ago by lkammere

  • Owner changed from lkammere to pfleck
  • Status changed from assigned to reviewing

r15073 Readded removed method as it was after r14817. When adding filters, a TypeSelectorDialog opens and an added filter is not checked initially.

comment:8 Changed 7 weeks ago by pfleck

  • Status changed from reviewing to readytorelease

Reviewed r15073: thanks, works now as intended.

comment:9 Changed 7 weeks ago by pfleck

  • Resolution set to done
  • Status changed from readytorelease to closed

r15078: merged r14817, r14819, r15073 to stable

Note: See TracTickets for help on using tickets.