#2627 closed feature request (done)

Non-linear regression based on a given model structure

Reported by: gkronber Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.14
Component: Algorithms.DataAnalysis Version: 3.3.13
Keywords: Cc:

Description


Attachments (1)

Nonlinear Regression (NLR).hl (742.5 KB) - added by gkronber 14 months ago.
HL file for debugging the constants optimizer

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 months ago by gkronber

  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 14 months ago by gkronber

r14024: added first implementation of nonlinear regression algorithm + formatter and parser for infix expressions

comment:3 Changed 14 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

Please review the problem in the constants optimizer.

Changed 14 months ago by gkronber

HL file for debugging the constants optimizer

comment:4 Changed 14 months ago by gkronber

r14026: sealed parser and formatter for infix expressions

comment:5 Changed 13 months ago by mkommend

  • Owner changed from mkommend to gkronber

r14036: Fixed a bug in constant optimization of trees with unary subtraction symbols.

This bug has been introduced in r8823 ~4 years ago, but has never been discovered due to the reason that unary subtraction is never used in symbolic regression.

comment:6 Changed 13 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to readytorelease

Thanks for the bug fix.

Could you please release the new algorithm?

comment:7 Changed 13 months ago by mkommend

r14109: Adapted constant name for result and renamed the infix formatter / parser unit test.

comment:8 Changed 13 months ago by mkommend

Reviewed r14024, r14026, r14036 and r14109.

comment:9 Changed 13 months ago by mkommend

r14116: Merged r14024, r14026, r14036, r14109 into stable.

comment:10 Changed 13 months ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.