#2584 closed feature request (done)

ConstantOptimization should be configurable to ignore variable weights

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.14
Component: Problems.DataAnalysis.Symbolic.Regression Version: 3.3.13
Keywords: Cc:

Description

It is not always desirable to modify variable weights, when performing constant optimization. For example, it is possible to perform symbolic regression with constant variable weights of 1.0 and these weights should not be changed by constant optimization.

Change History (7)

comment:1 Changed 16 months ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 16 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

r13670: Added parameter in constant optimization that determines whether variable weights should be modified.

comment:3 Changed 14 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to assigned

Reviewed r13670:

  • I think it would be better to hide the new Boolean parameter in the evaluators
  • Thanks for changing order of parameters lowerEstimationLimits and upperEstimationLimits (note to self: check if all usages have been fixed)
  • The change in GEArtificialAntEvaluator is ok. But I think it should be merged to the stable branch in an individual changeset.

comment:4 Changed 14 months ago by mkommend

  • Summary changed from ConstantOptimization should be configurable to now change variable weights to ConstantOptimization should be configurable to ignore variable weights

comment:5 Changed 13 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from assigned to reviewing

r13916: Updated visibility (hidden attribute) for parameters of symbolic regression evaluators.

comment:6 Changed 12 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to readytorelease

Reviewed r13670 and r13916.

comment:7 Changed 12 months ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed

r14004: #2584: Merged r13670 and r13916 into stable. #2609: Merged r13869 and r13900 into stable.

These four changes had to be released together, because the ConstantOptimizationEvaluator is manipulated in both tickets.

Note: See TracTickets for help on using tickets.