Opened 14 months ago

Closed 9 months ago

#2572 closed feature request (done)

SymbolicRegressionSolutionsAnalyzer should also add training and test R² values to the scope so that they can be read by other analyzers

Reported by: gkronber Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.14
Component: Problems.DataAnalysis.Symbolic.Regression Version: 3.3.13
Keywords: Cc:

Description (last modified by gkronber)

It is currently not possible to track test R² (or other metrics for test quality) of symbolic regression solutions with the analyzers in HeuristicLab.Analysis because this value is not stored in the scope.

Change History (11)

comment:1 Changed 14 months ago by gkronber

  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 14 months ago by gkronber

r13582: added parameters to SymbolicRegressionSolutionsAnalyzer to write R² (training & test) for all solutions to the scope

comment:3 Changed 14 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:4 follow-up: Changed 13 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to assigned

Review comments:

  • What is the point of this ticket (hard to judge without a description)? It is hard for other analyzers to read the R² values, because they would have to know the solution names, because these are used as variable names.
  • Why are there always null checks before accessing parameters? Aren't these obsolete, because the parameter is never null?
Last edited 13 months ago by gkronber (previous) (diff)

comment:5 Changed 13 months ago by gkronber

  • Description modified (diff)

comment:6 in reply to: ↑ 4 Changed 13 months ago by gkronber

Replying to mkommend:

Review comments:

  • What is the point of this ticket (hard to judge without a description)? It is hard for other analyzers to read the R² values, because they would have to know the solution names, because these are used as variable names.

It is currently not possible to track test R² (or other metrics for test quality) of symbolic regression solutions with the analyzers in HeuristicLab.Analysis because this value is not stored in the scope. AFAIK, this was the reason why this analyzer was implemented originally. The analyzer also creates a chart of training and test R². This can also be achieved using the standard analyzers when the test quality values are stored in the scope.

comment:7 Changed 13 months ago by gkronber

r13660: removed null checks

comment:8 Changed 11 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from assigned to reviewing

comment:9 Changed 9 months ago by mkommend

Reviewed r13582 and r13660.

comment:10 Changed 9 months ago by mkommend

  • Status changed from reviewing to readytorelease

comment:11 Changed 9 months ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed

r13950: Merged r13582 and r13660 into stable.

Note: See TracTickets for help on using tickets.