#2532 closed defect (done)

PotvinPDExchangeSingleMoveGenerator throws ArgumentOutOfRangeException

Reported by: pfleck Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.14
Component: Problems.VehicleRouting Version: 3.3.13
Keywords: Cc:

Description

The PotvinPDExchangeSingleMoveGenerator throws an ArgumentOutOfRangeException when the current solution already uses the maximum allowed number of vehicles and tries to create a move that would add a new tour.

To reproduce the error, create a new TabuSearch, set VRP with the Solomon R101 instance and use the MultiVrpMoveGenerator with the default settings.

Change History (5)

comment:1 Changed 16 months ago by pfleck

r13420 Corrected the range of randomly selected tours for the PDExchange-move. Because the PDExchange-move swaps two cities from different tours, it makes no sense to select a new(empty) tour as there aren't any cities to swap.

comment:2 Changed 16 months ago by pfleck

  • Status changed from new to accepted

comment:3 Changed 16 months ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from accepted to reviewing

comment:4 Changed 16 months ago by abeham

  • Status changed from reviewing to readytorelease

ok

comment:5 Changed 16 months ago by abeham

  • Resolution set to done
  • Status changed from readytorelease to closed

r13457: merged r13420 to stable

Note: See TracTickets for help on using tickets.