#2490 closed defect (done)

Evaluation of GBT models is not thread-safe

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.13
Component: Algorithms.DataAnalysis Version: 3.3.12
Keywords: Cc:

Description (last modified by gkronber)

This occurs because of caching problems if GetEstimatedValues(IDataset ds, IEnumerable<int> rows) is called with two different Datasets in parallel.

Change History (9)

comment:1 Changed 17 months ago by gkronber

  • Description modified (diff)
  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 17 months ago by gkronber

  • Owner changed from gkronber to bburlacu
  • Status changed from accepted to reviewing

r13030: fixed problem with thread-safety in RegressionTreeModel using a different (local) caching tactic.

Thanks for the bug report!

comment:3 Changed 17 months ago by bburlacu

  • Owner changed from bburlacu to mkommend

Just tested and the problem seems to be fixed.

comment:4 Changed 17 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to assigned

Reviewed r13030.

Does this changeset has any impact on the evaluation performance? What about the TODO "seemingly it is bad (performance-wise) to persist tuples (tuples are used as keys in a dictionary)"? Is this related to another ticket? Will GBT be released with this TODO?

comment:5 Changed 17 months ago by gkronber

the mentioned comment is a note concerning performance of persistence and is not directly related to this ticket. In my point of view we can release this change with the TODO comment.

comment:6 Changed 17 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from assigned to reviewing

No significant impact on performance of the algorithm is visible (three unit test for GBT on the builder).

comment:7 Changed 17 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

comment:8 Changed 17 months ago by gkronber

Needs to be merged after #2450

comment:9 Changed 16 months ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed

r13185: merged r13030 from trunk to stable

Note: See TracTickets for help on using tickets.