Opened 2 years ago

Closed 21 months ago

#2453 closed defect (done)

Double precision artifacts cause exceptions in the phenotypic similarity calculator

Reported by: bburlacu Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.13
Component: Problems.DataAnalysis.Symbolic.Regression Version: 3.3.12
Keywords: Cc:

Description

Floating point precision artifacts in the OnlinePearsonsRCalculator can lead to correlation values slightly larger than 1 or lower than -1 (like -1.000000004). A bug was introduced in the code when the OnlinePearsonsRSquaredCalculator was replaced with the OnlinePearsonsRCalculator because it was only checked if the correlation value is greater than 1 (ignoring the -1 case).

Change History (8)

comment:1 Changed 2 years ago by bburlacu

r12839: Ensure similarity value is never greater than 1 in the SymbolicExpressionTreePhenotypicSimilarityCalculator.

comment:2 Changed 2 years ago by bburlacu

  • Status changed from new to accepted

comment:3 Changed 2 years ago by bburlacu

  • Owner changed from bburlacu to mkommend
  • Status changed from accepted to reviewing

comment:4 Changed 22 months ago by mkommend

  • Owner changed from mkommend to bburlacu
  • Status changed from reviewing to readytorelease

Reviewed r12839.

comment:5 Changed 21 months ago by mkommend

  • Owner changed from bburlacu to mkommend
  • Status changed from readytorelease to assigned

comment:6 Changed 21 months ago by mkommend

  • Status changed from assigned to reviewing

comment:7 Changed 21 months ago by mkommend

  • Status changed from reviewing to readytorelease

comment:8 Changed 21 months ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed

r13182: Merged r12839 into stable.

Note: See TracTickets for help on using tickets.