Opened 2 years ago

Closed 17 months ago

#2385 closed enhancement (done)

Boolean parameter for data-analysis algorithms to disable creation of a final solution

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.13
Component: Algorithms.DataAnalysis Version: 3.3.11
Keywords: Cc:

Description

For multiple data-analysis algorithms the creation (+evaluation) of the final solution takes a lot of time.

Especially, when cross-validation is used this is however not necessary and only slows down CV. Therefore, it would be useful to add a Boolean (hidden) parameter to those algorithms to turn of creation of solutions.

The following algorithms would benefit:

  • Random forest
  • Gaussian process
  • Support vector machine

Change History (11)

comment:1 Changed 22 months ago by ascheibe

  • Owner set to gkronber
  • Status changed from new to assigned

comment:2 Changed 22 months ago by gkronber

  • Milestone changed from HeuristicLab 3.3.12 to HeuristicLab 3.3.13

comment:3 Changed 20 months ago by gkronber

Related: #2450, #2465

comment:4 Changed 20 months ago by gkronber

  • Status changed from assigned to accepted

comment:5 Changed 20 months ago by gkronber

r12934: added a Boolean "CreateSolution" parameter for support vector machine algorithms and added model error/accuracy metrics as algorithm results (to allow grid search without creating solutions)

comment:6 Changed 17 months ago by gkronber

r13204: added CreateSolution flag to random forest

comment:7 Changed 17 months ago by gkronber

r13205: added CreateSolution flag to Gaussian process algorithms

In the case of Gaussian process regression, it would be possible to exchange the solution creator of the problem. However, this cannot be easily achieved in the current version because of backwards-compatibility reasons. Therefore, I decided to use the same way of implementing this as for the other algorithms.

comment:8 Changed 17 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

Please review the 3 changesets.

The flag has been added to

  • SVM regression & classification
  • RF regression & classification
  • Gaussian process regression & classification

The flag was already available for gradient boosted trees for regression.

comment:9 Changed 17 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

r13270: Removed wrong comment in SVM classification and regression.

comment:10 Changed 17 months ago by gkronber

r13283: merged r12934,r13204,r13205,r13270 from trunk to stable

comment:11 Changed 17 months ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.