Opened 2 years ago

Closed 22 months ago

#2374 closed enhancement (done)

Make RegressionSolution class non-abstract

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.12
Component: Problems.DataAnalysis Version: 3.3.11
Keywords: Cc:

Description

Why did we define RegressionSolution as abstract? It is often useful to simply wrap any IRegressionModel in a solution.

The same should be possible for classification.

Change History (7)

comment:1 Changed 2 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from new to assigned

Maybe the reasoning was to have typed access to the containing model. I had a quick glance at some derived classes and the only addition in the sub classes I saw, was the typed model property.

IMHO it is fine to remove the abstract keyword and make regression solutions instantiable.

comment:2 Changed 22 months ago by gkronber

  • Status changed from assigned to accepted

comment:3 Changed 22 months ago by gkronber

r12485: made RegressionSolution and ClassificationSolution non-abstract

comment:4 Changed 22 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:5 Changed 22 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

Reviewed r12485.

comment:6 Changed 22 months ago by gkronber

r12637: merged r12485 from trunk to stable

comment:7 Changed 22 months ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.