Opened 2 years ago

Closed 21 months ago

#2366 closed enhancement (done)

Utilize EnumValue-Parameters in the "Create Experiment"-Dialog.

Reported by: pfleck Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.12
Component: Optimizer Version: branch
Keywords: Cc:

Description

Currently, an EnumValue-Parameter is not recognized and utilized by the CreateExperimentDialog. An EnumValue should result in a multiple-choice selection, simmilar to a ConstrainedValueParameter.

Change History (15)

comment:1 Changed 2 years ago by pfleck

  • Status changed from new to accepted

comment:2 Changed 2 years ago by pfleck

r12250 Create branch. r12251 Copy Optimizer-Plugin.

comment:3 Changed 2 years ago by pfleck

r12252 Added solution-file and adapted references in project-file.

comment:4 Changed 2 years ago by pfleck

r12254 Added detection of EnumValues in the CreateExperimentDialog.

comment:5 Changed 2 years ago by pfleck

r12267 Use EnumValues in the parameter variations for the creation of the experiments.

comment:6 Changed 2 years ago by pfleck

r12268 Fixed variation of bool value-parameter.

comment:7 Changed 2 years ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from accepted to reviewing

comment:8 Changed 22 months ago by pfleck

  • Owner changed from abeham to pfleck
  • Status changed from reviewing to assigned

comment:9 Changed 22 months ago by pfleck

r12466 Merged trunk to fix compile errors caused by changes of the DefineArithmeticProgressionDialog from r12293.

comment:10 Changed 22 months ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from assigned to reviewing

comment:11 Changed 21 months ago by pfleck

  • Owner changed from abeham to pfleck
  • Status changed from reviewing to assigned

comment:12 Changed 21 months ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from assigned to reviewing

r12513 Merged trunk changes.

comment:13 Changed 21 months ago by abeham

r12678: merged trunk changes

comment:14 Changed 21 months ago by abeham

  • Status changed from reviewing to readytorelease

r12680: integrated into trunk r12681: removed branch

The changes look okay, tested the code.

r12680 needs to be merged to stable

comment:15 Changed 21 months ago by abeham

  • Resolution set to done
  • Status changed from readytorelease to closed

r12741: merged 12680 to stable

Note: See TracTickets for help on using tickets.