Opened 3 years ago

Closed 3 years ago

#2266 closed enhancement (duplicate)

Synchronous control methods in IExecutable

Reported by: abeham Owned by: swagner
Priority: medium Milestone: HeuristicLab 3.3.11
Component: Optimization Version: 3.3.10
Keywords: Cc:

Description

Currently, the Start method of an algorithm forwards to the Start method of the engine which is implemented asynchronously. The API would be more user friendly if we'd offer both synchronized and asynchronous methods and name them accordingly: Start, StartAsync, Pause, PauseAsync, Stop, and StopAsync.

This rename breaks the API, but avoids writing synchronization code when HL algorithms are started from code.

Change History (2)

comment:1 Changed 3 years ago by swagner

  • Owner set to swagner
  • Status changed from new to assigned
  • Type changed from task to enhancement

comment:2 Changed 3 years ago by swagner

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #2258.

Note: See TracTickets for help on using tickets.