Opened 2 years ago

Closed 2 years ago

#2256 closed defect (duplicate)

Scripting and Programmable Operator do not work on systems with new .NET versions

Reported by: ascheibe Owned by: jkarder
Priority: medium Milestone: HeuristicLab 3.3.11
Component: Scripting.Views Version: 3.3.10
Keywords: Cc:

Description

I have Windows 8.1 with only .NET 4/4.5/4.5.1 installed. When starting HL, the assemblies

  • HeuristicLab.Operators.Programmable.Views
  • HeuristicLab.Scripting.Views

are not loaded because HeuristicLab.CodeEditor 3.3 cannot be loaded. The reason therefore is that some assemblies have fixed coded versions of their dependencies which are from older .NET versions:

  • HeuristicLab.CodeEditor-3.3 -> System.Drawing, Version=2.0.0.0
  • ICSharpCode.NRefactory -> System, Version=2.0.0.0
  • ICSharpCode.SharpDevelop.Dom -> System, Version=2.0.0.0
  • ICSharpCode.TextEditor -> System.Drawing, Version=2.0.0.0
  • Mono.Cecil -> System, Version=2.0.0.0

Change History (4)

comment:1 Changed 2 years ago by ascheibe

This is also the reason for the bug report that we got. When trying to open a new C# script the message "InvalidOperationException: No View Available" is displayed.

comment:2 Changed 2 years ago by ascheibe

  • Owner set to jkarder
  • Status changed from new to assigned

We should consider switching to AvalonEdit http://avalonedit.net/ as this will be a lot of work either way.

comment:4 Changed 2 years ago by jkarder

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #2077

Note: See TracTickets for help on using tickets.