Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2134 closed feature request (done)

AverageRelativeErrorEvaluator for Symbolic Regression

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.10
Component: Problems.DataAnalysis.Symbolic.Regression Version: 3.3.9
Keywords: Cc:

Description

A new evaluator that calculates abs(y'-y) / (1 + abs(y)) should be implemented. The benefit is that this evaluator allows larger errors if the target value is larger.

Change History (8)

comment:1 Changed 3 years ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 3 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

r10355: Implemented evaluator for symbolic regression which calculates the mean relative error.

comment:3 Changed 3 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to assigned

Review comments:

  • Please change "avg(|y'-y| / |y|+1)" to avg( |y' - y| / (|y| + 1)) in the description
  • Remove the applyLinearScaling parameter from the static calculate method
  • Remove code to set and unset the execution context for the linear scaling parameter

comment:4 Changed 3 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from assigned to reviewing

r10432: Implemented review comments for the mean relative error evaluator.

comment:5 Changed 3 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to readytorelease

Reviewed r10432.

comment:6 Changed 3 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed

r10439: merged r10355 and r10432 from trunk to stable

comment:7 Changed 3 years ago by gkronber

Had to be pulled from release because of dependency on #2119. (r10441)

comment:8 Changed 3 years ago by mkommend

r10508: Merged r10355 and r10432 from trunk to stable.

Note: See TracTickets for help on using tickets.