Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2130 closed defect (worksforme)

Exception occurs in the JSSP decoder for a basic problem instance (1 job, 3 tasks on 3 different resources)

Reported by: gkronber Owned by: gkronber
Priority: high Milestone: HeuristicLab 3.3.10
Component: Problems.Scheduling Version: 3.3.9
Keywords: Cc:

Description

HeuristicLab version: 3.3.9.10037
OperatorExecutionException: An exception was thrown by the operator "JobSequenceMatrixDecoder" [C:\reps\HeuristicLab\trunk\sources\bin\HeuristicLab.Problems.Scheduling-3.3.dll: 3.3.9.10037]: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at HeuristicLab.SequentialEngine.SequentialEngine.Run(CancellationToken cancellationToken) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.SequentialEngine\3.3\SequentialEngine.cs:line 49
   at HeuristicLab.Core.Engine.Run(Object state) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.Core\3.3\Engine.cs:line 153
   at System.Threading.Tasks.Task.Execute()
-----
ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at HeuristicLab.Encodings.ScheduleEncoding.GTAlgorithmUtils.ComputeEarliestStartTime(Task t, Schedule schedule) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.Encodings.ScheduleEncoding\3.3\ScheduleEncoding\GTAlgorithmUtils.cs:line 66
   at HeuristicLab.Encodings.ScheduleEncoding.GTAlgorithmUtils.GetTaskWithMinimalEC(ItemList`1 earliestTasksList, Schedule schedule) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.Encodings.ScheduleEncoding\3.3\ScheduleEncoding\GTAlgorithmUtils.cs:line 45
   at HeuristicLab.Problems.Scheduling.JSMDecoder.CreateScheduleFromEncoding(JSMEncoding solution, ItemList`1 jobData) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.Problems.Scheduling\3.3\Decoders\JSMDecoder.cs:line 156
   at HeuristicLab.Problems.Scheduling.ScheduleDecoder.Apply() in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.Problems.Scheduling\3.3\Decoders\ScheduleDecoder.cs:line 53
   at HeuristicLab.Operators.Operator.Execute(IExecutionContext context, CancellationToken cancellationToken) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.Operators\3.3\Operator.cs:line 124
   at HeuristicLab.SequentialEngine.SequentialEngine.Run(CancellationToken cancellationToken) in c:\reps\HeuristicLab\trunk\sources\HeuristicLab.SequentialEngine\3.3\SequentialEngine.cs:line 60

Change History (3)

comment:1 Changed 3 years ago by gkronber

  • Owner changed from jhelm to gkronber
  • Status changed from new to accepted

comment:2 Changed 3 years ago by gkronber

  • Resolution set to worksforme
  • Status changed from accepted to closed

Cannot reproduce this problem. The problem parameter 'Jobs' has to be updated according to the number of jobs in the 'JobData' list.

comment:3 Changed 3 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.10
Note: See TracTickets for help on using tickets.