Opened 4 years ago

Closed 4 years ago

#2102 closed defect (done)

The "Data Analysis" menu should not be a top-level menu in the optimizer

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.9
Component: Problems.DataAnalysis Version: 3.3.8
Keywords: Cc:

Description (last modified by gkronber)

A separate "Data Analysis" top-level menu in the optimizer looks strange. The very specific functionality that is available through this view is too visible. These functions are probably not frequently used.

It would be better to create a sub-menu in the "Edit" top-level menu.

Additionally, the "Export to excel" functionality should not be hidden in this menu-item. Instead, the functionality should be available through the solution view.

Change History (12)

comment:1 Changed 4 years ago by gkronber

  • Description modified (diff)

comment:2 Changed 4 years ago by gkronber

  • Version changed from 3.3.9 to 3.3.8

comment:3 Changed 4 years ago by ascheibe

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.9

comment:4 Changed 4 years ago by gkronber

r9973:9975:

  • moved "shrink data analysis solutions" and "create ensemble" to a "data analysis" sub-menu in the "Edit" menu.
  • Added an export button to the views for data analysis solution
  • Exporters for solutions are automatically discovered using the "ISymbolicSolutionExporter"
  • The Excel exporter is now available through this interface instead of the menu.
Last edited 4 years ago by gkronber (previous) (diff)

comment:5 Changed 4 years ago by gkronber

  • Status changed from new to accepted

comment:6 Changed 4 years ago by gkronber

  • Owner changed from gkronber to ascheibe
  • Status changed from accepted to reviewing

comment:7 follow-up: Changed 4 years ago by ascheibe

  • Owner changed from ascheibe to gkronber
  • Status changed from reviewing to assigned

Reviewed and tested r9973:9975.

I have only one comment/question: I think the Excel export was originally designed for symbolic regression. The export button is now also shown for e.g. Linear Regression, as you added it to the DataAnalysisSolutionView which Linear Regression uses. I think that this is a bug as the exported Excel file does not contain a lot of meaningful output and the exporter is explicitly deactivated for e.g. time series prognosis.

If this is a bug, I think a possible fix would be to enhance IDataAnalysisSolutionExporter (and create a base class) so that the DataAnalysisSolutionView can query an exporter, give it the type of problem or solution and the exporter will then tell you if it can export the solution. And if there are no exporters for a solution, the button should be hidden. This would also mean that you don't have to implement the export button enabling/disabling in views that inherit from DataAnalysisSolutionView.

comment:8 in reply to: ↑ 7 Changed 4 years ago by gkronber

Replying to ascheibe:

Reviewed and tested r9973:9975.

I have only one comment/question: I think the Excel export was originally designed for symbolic regression. The export button is now also shown for e.g. Linear Regression, as you added it to the DataAnalysisSolutionView which Linear Regression uses. I think that this is a bug as the exported Excel file does not contain a lot of meaningful output and the exporter is explicitly deactivated for e.g. time series prognosis.

This is not a bug as the linear regression solution is actually a symbolic regression solution. However, the exporter does not handle cases correctly where the upper and lower estimation limits are very extreme (as in the case of the linear regression solution). I'm going to fix this for this ticket.

If this is a bug, I think a possible fix would be to enhance IDataAnalysisSolutionExporter (and create a base class) so that the DataAnalysisSolutionView can query an exporter, give it the type of problem or solution and the exporter will then tell you if it can export the solution. And if there are no exporters for a solution, the button should be hidden. This would also mean that you don't have to implement the export button enabling/disabling in views that inherit from DataAnalysisSolutionView.

The exporter already provides a method to query if a certain solution is supported. I don't think a change is necessary at this point as the excel exporter should be extended to support classification and time-series solutions in the future (see e.g. #2098)

comment:9 Changed 4 years ago by gkronber

r9994: handled estimation bounds in Excel exporter specifically to prevent writing extreme values that Excel can't handle (necessary to support export of linear regression solutions).

comment:10 Changed 4 years ago by gkronber

  • Owner changed from gkronber to ascheibe
  • Status changed from assigned to reviewing

comment:11 Changed 4 years ago by ascheibe

  • Owner changed from ascheibe to gkronber
  • Status changed from reviewing to readytorelease

Ok, thanks for the clarification. I have reviewed and tested r9994, the Linear Regression export works now.

comment:12 Changed 4 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed

r9999: merged r9973:9975 and r9994 from trunk to stable

Note: See TracTickets for help on using tickets.