Opened 4 years ago

Closed 3 years ago

#2090 closed defect (invalid)

HiveException: Invalid attempt to read when no data is present.

Reported by: bburlacu Owned by: ascheibe
Priority: medium Milestone: HeuristicLab 3.3.10
Component: Hive.Server Version: 3.3.8
Keywords: Cc:

Description

Server stack trace:
       at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
       at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)
     
    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at HeuristicLab.Clients.Hive.IHiveService.GetLightweightJobTasks(Guid jobId)
       at HeuristicLab.Clients.Hive.HiveServiceClient.GetLightweightJobTasks(Guid jobId) in c:\Users\P40913\Projects\HeuristicLab\trunk\sources\HeuristicLab.Clients.Hive\3.3\ServiceClients\HiveServiceClient.cs:line 2786
       at HeuristicLab.Clients.Hive.JobResultPoller.<FetchJobResults>b__0(IHiveService service) in c:\Users\P40913\Projects\HeuristicLab\trunk\sources\HeuristicLab.Clients.Hive\3.3\JobResultPoller.cs:line 113
       at HeuristicLab.Clients.Hive.HiveServiceLocator.CallHiveService[T](Func`2 call) in c:\Users\P40913\Projects\HeuristicLab\trunk\sources\HeuristicLab.Clients.Hive\3.3\HiveServiceLocator.cs:line 96
       at HeuristicLab.Clients.Hive.JobResultPoller.FetchJobResults() in c:\Users\P40913\Projects\HeuristicLab\trunk\sources\HeuristicLab.Clients.Hive\3.3\JobResultPoller.cs:line 111
       at HeuristicLab.Clients.Hive.JobResultPoller.RunPolling() in c:\Users\P40913\Projects\HeuristicLab\trunk\sources\HeuristicLab.Clients.Hive\3.3\JobResultPoller.cs:line 91

Change History (2)

comment:1 Changed 4 years ago by ascheibe

  • Milestone changed from HeuristicLab 3.3.9 to HeuristicLab 3.3.10

comment:2 Changed 3 years ago by ascheibe

  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce the problem so I'm closing this ticket now.

Note: See TracTickets for help on using tickets.