Opened 4 years ago

Closed 4 years ago

#2085 closed defect (done)

InvalidOperationException when refreshing in the Hive Job Manager

Reported by: ascheibe Owned by: ascheibe
Priority: medium Milestone: HeuristicLab 3.3.9
Component: Hive.Client Version: 3.3.8
Keywords: Cc:

Description

HeuristicLab version: 3.3.8.9462 InvalidOperationException: Cross-thread operation not valid: Control 'isPrivilegedCheckBox' accessed from a thread other than the thread it was created on.

Server stack trace:

at System.Windows.Forms.Control.get_Handle() at System.Windows.Forms.Control.SendMessage(Int32 msg, Int32 wparam, Int32 lparam) at System.Windows.Forms.CheckBox.set_CheckState(CheckState value) at System.Windows.Forms.CheckBox.set_Checked(Boolean value) at HeuristicLab.Clients.Hive.JobManager.Views.RefreshableHiveJobView.Content_Loaded(Object sender, EventArgs e) in c:\Users\bburlacu\Projects\HeuristicLab\Trunk\sources\HeuristicLab.Clients.Hive.JobManager\3.3\Views\RefreshableHiveJobView.cs:line 329 at HeuristicLab.Clients.Hive.RefreshableJob.OnLoaded() in c:\Users\bburlacu\Projects\HeuristicLab\Trunk\sources\HeuristicLab.Clients.Hive\3.3\RefreshableJob.cs:line 533 at HeuristicLab.Clients.Hive.HiveClient.LoadJob(RefreshableJob refreshableJob) in c:\Users\bburlacu\Projects\HeuristicLab\Trunk\sources\HeuristicLab.Clients.Hive\3.3\HiveClient.cs:line 468 at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase) at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData) at System.Action`1.EndInvoke(IAsyncResult result) at HeuristicLab.Clients.Hive.JobManager.Views.RefreshableHiveJobView.<>cDisplayClassf.<refreshButton_Click>bd(IAsyncResult ar) in c:\Users\bburlacu\Projects\HeuristicLab\Trunk\sources\HeuristicLab.Clients.Hive.JobManager\3.3\Views\RefreshableHiveJobView.cs:line 479

Change History (7)

comment:1 Changed 4 years ago by ascheibe

  • Status changed from new to accepted

comment:2 Changed 4 years ago by ascheibe

r9710 fixed InvalidOperationException in Hive Job Manager

comment:3 Changed 4 years ago by ascheibe

  • Owner changed from ascheibe to bburlacu
  • Status changed from accepted to reviewing

Please test the changes and let me know if it fixed the problem.

comment:4 Changed 4 years ago by bburlacu

  • Owner changed from bburlacu to ascheibe
  • Status changed from reviewing to assigned

I tested and couldn't reproduce the problem so I think it's fixed.

comment:5 Changed 4 years ago by ascheibe

  • Status changed from assigned to reviewing

Ok, thanks.

comment:6 Changed 4 years ago by ascheibe

  • Status changed from reviewing to readytorelease

comment:7 Changed 4 years ago by ascheibe

  • Resolution set to done
  • Status changed from readytorelease to closed

r9722 merged r9710 into stable branch

Note: See TracTickets for help on using tickets.