Opened 5 years ago

Closed 4 years ago

#1960 closed feature request (done)

Add AutoDiff to external libraries

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.8
Component: ExtLibs Version: 3.3.8
Keywords: Cc:

Description

http://autodiff.codeplex.com/

AutoDiff provides a simple and intuitive API for computing function gradients/derivatives along with a fast state-of-the-art algorithm for performing the computation. Such computations are mainly useful in numeric optimization scenarios.

Change History (9)

comment:1 Changed 5 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.8
  • Owner changed from mkommend to gkronber
  • Status changed from new to accepted
  • Type changed from defect to feature request

comment:2 Changed 5 years ago by gkronber

r8703 added HL wrapper plugin for AutoDiff

comment:3 Changed 5 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:4 Changed 5 years ago by gkronber

r8705: added x64/x86 build configurations

comment:5 Changed 5 years ago by gkronber

r8706: fixed assembly version (set revision number to AutoDiff repository revision)

comment:6 Changed 4 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

comment:7 Changed 4 years ago by ascheibe

I have just tried to compile AutoDiff with Mono on Linux. The compilation fails with the following error message:

CompiledDifferentiator.Compiler.cs(21,65): error CS0584: Internal compiler error: Collection is of a fixed size
CompiledDifferentiator.cs(28,31): error CS0584: Internal compiler error: Collection is of a fixed size
CompiledDifferentiator.cs(29,30): error CS0019: Operator `==' cannot be applied to operands of type `int' and `method group'
CompiledDifferentiator.cs(38,35): error CS0428: Cannot convert method group `Count' to non-delegate type `int'. Consider using parentheses to invoke the method 
CompiledDifferentiator.cs(39,25): error CS0584: Internal compiler error: Collection is of a fixed size

I will try to find out what exactly the problem is and file a bug report with Mono and AutoDiff.

comment:8 Changed 4 years ago by ascheibe

I have fixed the problem in the Mono compiler. I have sent the Mono team a pull request (https://github.com/mono/mono/pull/473) for the fix and hopefully this will be soon in their master branch.

comment:9 Changed 4 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.7 to 3.3.8
Note: See TracTickets for help on using tickets.