Opened 5 years ago

Closed 4 years ago

#1920 closed defect (done)

Models of an Ensemble may get a different problem data if loaded

Reported by: sforsten Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.8
Component: Problems.DataAnalysis Version: 3.3.8
Keywords: Cc:

Description

The AfterDeserialization method in *EnsembleSolution give the models in the ensemble only a copy of the problem data, which is a *EnsembleProblemData and behaves differently from a *ProblemData (especially the methods IsTrainingSample and IsTestSample). So the ensemble may become different after it is saved and loaded again.

Remark: Classification and Regression are meant with the * sign.

Also one of the constructors in *EnsembleSolution may give the models wrong problem data.

Change History (10)

comment:1 Changed 5 years ago by mkommend

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.8
  • Owner changed from sforsten to mkommend
  • Status changed from new to accepted

comment:2 Changed 5 years ago by mkommend

r8528: Changed CreateSolution method in all DataAnalysisModels to transform the handed IProblemData to the correct type.

comment:3 Changed 5 years ago by mkommend

  • Owner changed from mkommend to sforsten
  • Status changed from accepted to reviewing

comment:4 Changed 5 years ago by sforsten

  • Owner changed from sforsten to gkronber

r8533: corrected typo

comment:5 Changed 5 years ago by sforsten

r8857: changes made in r8528 have been extended to TimeSeriesPrognosis and to DiscriminantFunctionClassificationModel, which has been missed

comment:6 Changed 5 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to assigned

no review comments for r8533 and r8857. Reviewed r8528, which looks ok.

However, when testing I stumbled over a bug that I think is related to the changes of r8528: If you create a RegressionEnsembleSolution using cross validation, the ErrorCharacteristicCurveView will throw an exception because the estimated values enumerable produced by the ConstantRegressionSolution is empty (the TrainingIndices enumerable is empty).

Please fix this problem and assign the ticket back to me.

comment:7 Changed 5 years ago by mkommend

r8963: Corrected problem in RegressionSolutionErrorCharacteristicsCurveView regarding the constant model.

Last edited 5 years ago by gkronber (previous) (diff)

comment:8 Changed 5 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from assigned to reviewing

comment:9 Changed 5 years ago by gkronber

  • Status changed from reviewing to readytorelease

Reviewed r8963 and tested the ECC view again. Now everything works as expected.

comment:10 Changed 4 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.8
Note: See TracTickets for help on using tickets.