Opened 5 years ago

Closed 4 years ago

#1917 closed defect (done)

In the CrossValidationView the value for the samples end field is not updated when a new problem is loaded

Reported by: abeham Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.8
Component: Algorithms.DataAnalysis Version: 3.3.8
Keywords: Cc:

Description (last modified by abeham)

Samples Start and Samples End remain the same even though a new CSV was loaded in the problem.

Expected:

  • The sample range for cross validation adjusts to the new range of samples

Reproduce:

  1. Create a Cross Validation
  2. Create a new algorithm (e.g. LR)
  3. In the problem load a new CSV

Change History (11)

comment:1 Changed 4 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.8
  • Summary changed from Cross Validation doesn't recognize a changed problem to In the CrossValidationView the value for the samples end field is not updated when a new problem is loaded

comment:2 Changed 4 years ago by mkommend

  • Owner changed from gkronber to mkommend
  • Status changed from new to accepted

comment:3 Changed 4 years ago by mkommend

r8965: Added missing event registration in AfterDeserialization of CrossValidation and clean up code if a problem changes in the crossvalidation. Additionally, I removed explicit calls to OnReset in the Load methods of IDataAnalysisProblems the reset event is automatically fired when the problem data is changed.

comment:4 Changed 4 years ago by mkommend

  • Owner changed from mkommend to abeham
  • Status changed from accepted to reviewing

r8966: Reversed changes in OnlineMeanAndVarianceCalculator as this must be first discussed with gkronber and should be tracked in a separate ticket.

comment:5 Changed 4 years ago by gkronber

Even after r8965 the fields for samples start and end are not updated when the data set is changed (for instance by loading a new problem instance).

comment:6 Changed 4 years ago by abeham

  • Description modified (diff)
  • Owner changed from abeham to mkommend
  • Status changed from reviewing to assigned

comment:7 Changed 4 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from assigned to reviewing

r8969: Corrected event registration for problem changes in CrossValidation.

comment:8 Changed 4 years ago by gkronber

r8970: fixed formatting

comment:9 Changed 4 years ago by gkronber

Tested r8969:8970 and couldn't reproduce the problem. Thanks for fixing this!

comment:10 Changed 4 years ago by gkronber

  • Status changed from reviewing to readytorelease

comment:11 Changed 4 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.7 to 3.3.8
Note: See TracTickets for help on using tickets.