Opened 5 years ago

Closed 4 years ago

#1890 closed enhancement (done)

Code maintenance and minor changes

Reported by: swagner Owned by: swagner
Priority: low Milestone: HeuristicLab 3.3.8
Component: General Version: 3.3.8
Keywords: Cc:

Description

Use this ticket for minor changes and maintenance purposes that do not affect functionality such as fixing typos, improving readability or other small tasks.

Because this ticket will likely not be subject to review, you're urged to double check the changes you made.

Change History (63)

comment:1 Changed 5 years ago by ascheibe

r8341 clear runs when an optimizer is dropped on the Hive Job Manager

comment:2 Changed 5 years ago by mkommend

r8343: Improved symbol to opCode lookup in the GP interpreters.

comment:3 Changed 5 years ago by mkommend

r8344: Changed ActualName of child and parents parameter in SymbolicExpressionTreeCrossover.

comment:4 Changed 5 years ago by gkronber

r8367: set svn:ignore properties

comment:5 Changed 5 years ago by ascheibe

r8414 removed old ClientUserManagement and OKB branches

comment:6 Changed 5 years ago by gkronber

r8485: fixed a bug in the regression solution line chart that leads to an exception when the chart is shown which is however lost in the message queue. The bug has the effect that the empty point manipulation does not work correctly for instance in solutions produced through cross-validation

comment:7 Changed 5 years ago by mkommend

r8547: Added more meaningful assert message in 'InstatiateAllCreateables' unit test.

comment:8 Changed 5 years ago by abeham

r8553: Updated best known qualities of missing QAPLIB solutions

comment:9 Changed 5 years ago by gkronber

r8560: fixed a bug in the InstantiateAllCreatables unit test. Only a part of all assemblies has been by the unit test up to now as the assembly loading statement has been missing.

(also updated the project reference for alglib to version 3.6.0)

comment:10 Changed 5 years ago by gkronber

r8564:

  • added an extension to calculate the range of IEnumerable<double>
  • increased the buffer size for the heuristic determination of separator characters in the table file parser (to make it work with files that have more than 1024 bytes in the second line).

comment:11 Changed 5 years ago by abeham

r8575: Corrected estimation limits of simplified model

comment:12 Changed 5 years ago by gkronber

r8604: set svn:ignore properties

comment:13 Changed 5 years ago by gkronber

r8605: fixed a bug in the IEnumerable<double>.Range() extension.

comment:14 Changed 5 years ago by mkommend

r8634: Corrected copy & paste error in MeanAbsoluteErrorEvaluator.

comment:15 Changed 5 years ago by gkronber

r8659: set svn:ignore properties

comment:16 Changed 5 years ago by jkarder

r8691: fixed searchButton.Enabled state check in the Hive Job Manager

comment:17 Changed 5 years ago by mkommend

r8731: Added svn_ignore for .user and .suo files in some directories.

comment:18 Changed 5 years ago by gkronber

r8734: fixed a bug in the ValueGenerator for data analysis benchmark instances

comment:19 Changed 5 years ago by gkronber

r8735: added rounding to 3 digits for variable impacts. as it is not useful to show all digits.

comment:20 Changed 5 years ago by gkronber

r8741: updated solution configurations

comment:21 Changed 5 years ago by mkommend

r8756: Removed virtual property call in ResulCollectionView ctor to set ReadOnly=true;

comment:22 Changed 5 years ago by ascheibe

r8778 fixed a NullReferenceException when serializing a calculator that has not been assigned a formula

comment:23 Changed 5 years ago by ascheibe

r8806 added System.Drawing references so that HL compiles with Visual Studio 2012

comment:24 Changed 5 years ago by abeham

r8822: removed Problem_Reset event handling in RobustTabooSearch

comment:25 Changed 5 years ago by gkronber

r8825: renamed property InputVariables -> VariableNames for artificial data analysis instances as the value also contains the target variable.

comment:26 Changed 5 years ago by mkommend

r8843: Updated Symbolic expression Tree debugger visualizer to work with visual studio 2012.

comment:27 Changed 5 years ago by mkommend

r8876: Removed not used private class.

comment:28 Changed 5 years ago by mkommend

r8890: Removed timeseries modeling branch.

comment:29 Changed 5 years ago by bburlacu

r8924: Added License Information to files that didn't include it.

comment:30 Changed 5 years ago by bburlacu

r8925: Reverted erroneous commit for RunCollectionDataTableView.cs and RunCollectionDataTableView.Designer.cs.

comment:31 Changed 5 years ago by bburlacu

r8926: Reverted changes for HeuristicLab.Algorithms.RAPGA/3.3/DuplicatesSelector.cs.

comment:32 Changed 5 years ago by bburlacu

r8927: Reverted change in HeuristicLab.Optimization.Views-3.3.csproj as it was wrongly including a resx file.

comment:33 Changed 5 years ago by bburlacu

r8928: Removed license information from FastRandom.cs because this file has a separate license.

comment:34 Changed 5 years ago by mkommend

r8948: Reverted accidental conversion of HeuristicLab.sln from visual studio 2010 to 2012.

comment:35 Changed 5 years ago by ascheibe

r8983 fixed prebuild event of Scheduling instances

comment:36 Changed 5 years ago by jkarder

r8989: refactored DuplicatesSelector and ProgressiveOffspringPreserver

comment:37 Changed 5 years ago by jkarder

r8992: adapted unit test to take changes r8988:8989 into account

comment:38 Changed 5 years ago by mkommend

r9024: Correctd typo in DataAnalysisImportTypeDialog.

comment:39 Changed 5 years ago by ascheibe

r9036 enabled setting minutes for appointments in the Hive Administrator

comment:40 Changed 5 years ago by mkommend

r9049: Added interfaces for symbolic data analysis problems (single and multi objective).

comment:41 Changed 5 years ago by mkommend

r9072: Added parameter with default value for source count in RandomEnumerable.SampleRandomWithoutRepetition.

comment:42 Changed 5 years ago by mkommend

r9081: Removed obsolete branches, GP-Symbolis, ConstantOptimization, and RegressionBenchmarks.

comment:43 Changed 5 years ago by abeham

r9088: Fixed output path of ProtobufCS for platforms other than Any CPU, fixed some references

comment:44 Changed 4 years ago by abeham

r9101: removed comment

comment:45 Changed 4 years ago by mkommend

r9120: Added missing StorableClass attribute to ConstantRegressionModel.

comment:46 Changed 4 years ago by abeham

r9179: Moved HeuristicLab project to first place in solution (so that it's selected as default startup project in a fresh checkout)

comment:47 Changed 4 years ago by ascheibe

r9207 disabled parallel task uploading as this produces a lot of failed db transactions and aborted uploads and therefore does not speed up uploading

comment:48 Changed 4 years ago by mkommend

r9209: Corrected copy & paste error in SymbolicRegressionConstantOptimizationEvaluator.

comment:49 Changed 4 years ago by ascheibe

r9232 use transactions for retrieving jobs to avoid returning wrong statistics

comment:50 Changed 4 years ago by ascheibe

r9251 increased receive timeout on hive server and improved disposing of HiveTasks

comment:51 Changed 4 years ago by mkommend

r9322: Deactived performance related asserts in unit tests, due to build server problems.

comment:52 Changed 4 years ago by ascheibe

r9347 fixed 2 slave bugs:

  • catch the exception that is thrown if the slave communication service has already been started
  • fixed closing of the wait handle in the heartbeat manager

comment:53 Changed 4 years ago by mkommend

r9388: Fixed the NumberArray2XmlSerializerBase to allow the persistence of multidimensional arrarys with length components of size 0.

comment:54 Changed 4 years ago by ascheibe

r9390 fixed a bug in RefreshAutomatically where the event for receiving the results was deregistered to early

comment:55 Changed 4 years ago by mkommend

r9417: Removed osbolete code in Grammars.cs in the test project.

comment:56 Changed 4 years ago by ascheibe

r9442 fixed a bug that occurred when the Hive login failed and the Hive Job Manager was closed

comment:57 Changed 4 years ago by swagner

r9463: Adapted GPR sample test

comment:58 Changed 4 years ago by swagner

r9478: Removed unnecessary local variable

comment:59 Changed 4 years ago by swagner

r9479: Removed warnings

comment:60 Changed 4 years ago by swagner

  • Status changed from new to assigned

comment:61 Changed 4 years ago by swagner

  • Status changed from assigned to accepted

comment:62 Changed 4 years ago by swagner

  • Status changed from accepted to readytorelease

comment:63 Changed 4 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.7 to 3.3.8
Note: See TracTickets for help on using tickets.