Opened 5 years ago

Closed 5 years ago

#1885 closed defect (done)

Exception in SubroutineDeleter

Reported by: gkronber Owned by: gkronber
Priority: high Milestone: HeuristicLab 3.3.7
Component: Encodings.SymbolicExpressionTreeEncoding Version: 3.3.7
Keywords: Cc:

Description

To reproduce use 'RunGpLawnMowerSampleTest'.

An exception is thrown because the grammar does not allow any function as child of Defun when an invoke symbol is deleted together with it's definition.

Example:

(root 
  (start (...)) 
  (Defun ADF0 (Invoke ADF1) ...)
  (Defun ADF1 (...))
)

When ADF1 is deleted the node Invoke ADF1 has to be removed. However, according to the grammar no children are allowed below Defun ADF0.

Change History (6)

comment:1 Changed 5 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from new to assigned

comment:2 Changed 5 years ago by mkommend

  • Status changed from assigned to accepted

comment:3 Changed 5 years ago by mkommend

r8148: Corrected SubroutineCreator to adapt the grammar according to the new ADF.

comment:4 Changed 5 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

Ran all unit tests related to architecture manipulating operators and all passed, so I think the ticket is ready for review.

comment:5 Changed 5 years ago by gkronber

  • Status changed from reviewing to readytorelease

reviewed r8148: the change seems to be OK, however, I'm never 100% sure with these ADF special cases.

comment:6 Changed 5 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.