Opened 5 years ago

Closed 5 years ago

#1875 closed defect (done)

Race conditions in cross-validation.

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.7
Component: Algorithms.DataAnalysis Version: 3.3.7
Keywords: Cc:

Description

Steps to reproduce:

  • Create CV with Random-Forest
  • Set workers to 4 and folds to 8
  • Run
  • The solution of the last fold ist not correctly cloned into the final ensemble combining the solutions from all folds
  • (compare with only 1 worker)

Change History (7)

comment:1 Changed 5 years ago by gkronber

  • Status changed from new to accepted

comment:2 Changed 5 years ago by gkronber

The event handlers for cloned algorithms in the cross validation are not thread save (iterating over cloned algorithms and checking their state). The problem occurs because in algorithm the state is set to stopped before the run is generated. In the mean-time the cross-validation also stops and collects all results, however, the last algorithm might not be finished yet.

comment:3 Changed 5 years ago by gkronber

  • Summary changed from Race condition in cross-validation leads to a clone of an incomplete solution. to Race conditions in cross-validation.

comment:4 Changed 5 years ago by gkronber

r8155: set the ExecutionState to stopped only after all results have been generated. This mitigates the problem of the race condition in CrossValidation even though the underlying problem is not actually solved.

comment:5 Changed 5 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:6 Changed 5 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

comment:7 Changed 5 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.