Opened 5 years ago

Closed 5 years ago

#1830 closed enhancement (done)

Improve Memory Allocation for DataAnalysis Problems and Solutions

Reported by: sforsten Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.7
Component: Problems.DataAnalysis Version: 3.3.7
Keywords: Cc:

Description

Improving the memory allocation, especially for huge datasets.

Change History (12)

comment:1 Changed 5 years ago by sforsten

r7735:

  • set the size of the cache in the constructor of RegressionSolution
  • don't convert the IEnumerable in CalculateResults to arrays anymore

comment:2 Changed 5 years ago by sforsten

  • Status changed from new to accepted

r7736: the length of lists and dictionaries is set in the constructor

comment:3 Changed 5 years ago by sforsten

  • Owner changed from sforsten to mkommend
  • Status changed from accepted to reviewing

comment:4 Changed 5 years ago by sforsten

  • Summary changed from Memory Allocation Improvments to Memory Allocation Improvements

comment:5 Changed 5 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.7

comment:6 Changed 5 years ago by mkommend

  • Status changed from reviewing to readytorelease
  • Summary changed from Memory Allocation Improvements to Improve Memory Allocation for DataAnalysis Problems and Solutions

comment:7 Changed 5 years ago by gkronber

  • Owner changed from mkommend to gkronber
  • Status changed from readytorelease to reviewing

comment:8 Changed 5 years ago by gkronber

Interestingly the runtime of the SVM performance unit test doubled after the changes in this ticket. I'm investigating this...

comment:9 Changed 5 years ago by gkronber

  • Status changed from reviewing to assigned

comment:10 Changed 5 years ago by gkronber

  • Status changed from assigned to reviewing

Because of r7735 which removed additional caching the evaluation of ensemble solutions became slower because estimated values caching is not implemented for these solutions yet (see #1720). The SVM performance unit test runs a cross-validation which produces an regression ensemble solution.

comment:11 Changed 5 years ago by gkronber

  • Status changed from reviewing to readytorelease

comment:12 Changed 5 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.