Opened 5 years ago

Closed 4 years ago

#1747 closed enhancement (done)

Implement scrolling with the mouse wheel for the OperatorGraphVisualization

Reported by: ascheibe Owned by: jkarder
Priority: medium Milestone: HeuristicLab 3.3.8
Component: Operators.Views.OperatorGraphVisualization Version: 3.3.8
Keywords: Cc:

Description

It would be nice to be able to scroll in the OperatorGraphView with the mouse wheel or pan with the middle mouse button.

Change History (20)

comment:1 Changed 5 years ago by ascheibe

  • Milestone changed from HeuristicLab 3.3.7 to HeuristicLab 3.3.x Backlog

comment:2 Changed 5 years ago by ascheibe

  • Owner changed from ascheibe to jkarder
  • Status changed from new to assigned

comment:3 Changed 5 years ago by jkarder

r8000:

  • added support to pan with the middle mouse button
  • removed pan button

comment:4 Changed 5 years ago by jkarder

  • Owner changed from jkarder to ascheibe
  • Status changed from assigned to reviewing

comment:5 Changed 5 years ago by abeham

Congrats on making the 8000th commit!

comment:6 Changed 5 years ago by jkarder

Thanks!

comment:7 Changed 5 years ago by ascheibe

  • Owner changed from ascheibe to jkarder
  • Status changed from reviewing to assigned

Ooops, that one slipped through. I have reviewed the changes and have the following comments:

  • CustomPanTool.cs contains commented code in the MouseUp method. I assume this code is not needed so please remove it.
  • Also the code in MouseMove contains a little bit too much newlines.
  • The keybindings for space and esc do not work and also if you press them, switching back to the normal mouse cursor doesn't work.

comment:8 Changed 5 years ago by ascheibe

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.8

comment:9 Changed 5 years ago by jkarder

r8353:

comment:10 Changed 5 years ago by jkarder

  • Status changed from assigned to accepted

comment:11 Changed 5 years ago by jkarder

Thanks for the review. I have fixed and tested the key bindings and now everything works as intended. One can either pan with the middle mouse button or drag the view with the left mouse button while holding down the space key.

comment:12 Changed 5 years ago by jkarder

  • Owner changed from jkarder to ascheibe
  • Status changed from accepted to reviewing

comment:13 Changed 5 years ago by ascheibe

  • Owner changed from ascheibe to jkarder
  • Status changed from reviewing to readytorelease

Thanks for implementing this, I have no further comments.

comment:14 Changed 5 years ago by jkarder

I noticed that if one had selected a zoom tool prior to panning with the middle mouse button the zoom tool becomes active and gets executed immediately after releasing the button. This is unintended behavior.

comment:15 Changed 5 years ago by jkarder

  • Status changed from readytorelease to assigned

comment:16 Changed 5 years ago by jkarder

  • Status changed from assigned to accepted

comment:17 Changed 5 years ago by jkarder

r8860: fixed panning with the middle mouse button

comment:18 Changed 5 years ago by jkarder

  • Owner changed from jkarder to ascheibe
  • Status changed from accepted to reviewing

comment:19 Changed 5 years ago by ascheibe

  • Owner changed from ascheibe to jkarder
  • Status changed from reviewing to readytorelease

Ok, works for me, thanks!

comment:20 Changed 4 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.8
Note: See TracTickets for help on using tickets.