Opened 6 years ago

Closed 5 years ago

#1722 closed enhancement (done)

Code maintenance and minor changes

Reported by: swagner Owned by: swagner
Priority: low Milestone: HeuristicLab 3.3.7
Component: General Version: 3.3.7
Keywords: Cc:

Description

Use this ticket for minor changes and maintenance purposes that do not affect functionality such as fixing typos, improving readability or other small tasks.

Because this ticket will likely not be subject to review, you're urged to double check the changes you made.

Change History (65)

comment:1 Changed 6 years ago by abeham

r7271: updated parameter snippets to use interface type in property

comment:2 Changed 6 years ago by ascheibe

r7279: deleted old Hive branches

comment:3 Changed 6 years ago by mkommend

r7280: Corrected AfterDeserializationHook in SymbolicExpressionTreeLengthAnalyzer.

comment:4 Changed 6 years ago by abeham

r7313: changed year in license snippet

comment:5 Changed 6 years ago by ascheibe

r7341 switched the tab control in the Hive Job Manager to a DragOverTabControl

comment:6 Changed 6 years ago by abeham

r7351

  • fixed some problems that were identified with the first existing FxCop rules (duplicate storable hook in ExternalEvaluationProblem, multiple wrong names)
  • generally renamed AttachEventHandlers to RegisterEventHandlers to be consistent
  • fixed some backwards compatible regions to use the format from the snippet and the comment

comment:7 Changed 6 years ago by swagner

r7353: Fixed PluginInfrastructure unit tests as all plugins and products have been deleted in the deployment DB due to compatibility issues (automatic update from HL 3.3.5 to HL 3.3.6 fails).

comment:8 Changed 6 years ago by ascheibe

r7370 added a keyboard shortcut (Ctrl+H) for the Hive Job Manager

comment:9 Changed 6 years ago by ascheibe

r7434 When setting timed-out slaves offline the tasks on these slaves shouldn't be set to waiting as this leads to performance problems and deadlocks with big statelog tables. Setting tasks to waiting is done by another method of the cleanup process more efficiently.

comment:10 Changed 6 years ago by ascheibe

r7435 changed visibility of the Clients.Common settings to public as the access service client needs access to the username

comment:11 Changed 6 years ago by abeham

r7473: Updated event snippets to allow modifier to be set (in sealed classes you'll want to change it to private instead of protected virtual (which is the default). Also using "var" instead of the concrete class name as type for the handler variable and compacted code.

comment:12 Changed 5 years ago by ascheibe

r7525 fixed a NullReferenceException in the HiveTaskView which led to a failing ContentViewTests unit test

comment:13 Changed 5 years ago by ascheibe

r7542

  • added Hive and Benchmark assemblies
  • updated alglib and missing extlib assemblies
  • removed GP-3.3 assemblies

comment:14 Changed 5 years ago by mkommend

r7588: Corrected naming of the SymbolicRegressionSolution created by a LinearRegression algorithm to "Linear Regression Solution".

comment:15 Changed 5 years ago by abeham

r7594: changed build script to use Build instead of Rebuild (all of a sudden it didn't work anymore on two of my machines). I added an option if the solution should be cleaned before building.

comment:16 Changed 5 years ago by mkommend

r7657: Corrected builder test settings.

comment:17 Changed 5 years ago by mkommend

r7671: Minor configurations changes in variable condition symbol.

comment:18 Changed 5 years ago by ascheibe

r7723 minor improvement of the messages the hive server logs

comment:19 Changed 5 years ago by ascheibe

r7728 display statelog in the correct order and show slave id in tooltip

comment:20 Changed 5 years ago by epitzer

r7737 add missing Hits property in cloning constructor and clean up code

comment:21 Changed 5 years ago by gkronber

r7738: added an additional ctor for RegressionEnsembleSolution to simplify code.

Last edited 5 years ago by gkronber (previous) (diff)

comment:22 Changed 5 years ago by epitzer

r7745 follow-up of r5935: also rename CurrentIteration to Iterations in swarm updater

comment:23 Changed 5 years ago by abeham

r7768

  • Added a check before parameterizing operators if there are any in the collection

comment:24 Changed 5 years ago by abeham

r7769: corrected error in text

comment:25 Changed 5 years ago by ascheibe

r7782 fixed a NullReferenceException in Hive JobManager

comment:26 Changed 5 years ago by mkommend

r7797: Removed harmful check during the preparation of IOptimizers contained in an Experiment.

comment:27 Changed 5 years ago by mkommend

r7811: Removed unnecessary project references and plugin dependencies in HL.Operators.Programmable.Views and HL.Problems.QuadraticAssignment.Views.

comment:28 Changed 5 years ago by jkarder

r7814: fixed trigger creation in Prepare Hive Database.sql

comment:29 Changed 5 years ago by jkarder

r7847: added some integrity constraints in Initialize Hive Database.sql

comment:30 Changed 5 years ago by abeham

r7878:

  • In QAPExhaustiveSwap2LocalImprovement moved local search code to a static method
  • Otherwise minor changes to the QAP

comment:31 Changed 5 years ago by abeham

r7934: changed name of AfterDeserializationHook in some classes

comment:32 Changed 5 years ago by abeham

r7937: fixed plugin dependencies in LinearAssignment.Views

comment:33 Changed 5 years ago by ascheibe

r7943 added missing plugin dependency of DataAnalysis on LibSVM (needed for Hive)

comment:34 Changed 5 years ago by gkronber

r7955: removed unused file StartSymbolTreeNode

comment:35 Changed 5 years ago by gkronber

r7972: added static methods in OnePointShaker and SymbolicDataAnalysisAlleleFrequencyAnalyzer

comment:36 Changed 5 years ago by mkommend

r8008: Added size properties for range data types.

comment:37 Changed 5 years ago by mkommend

r8028: Removed commented code in HL.Tests.PluginLoader.

comment:38 Changed 5 years ago by ascheibe

r8029 fixed a small ui glitch in metaopt caused by the new problem view

comment:39 Changed 5 years ago by abeham

r8046: Added exception handling to DeepCloneableCloningTest (before it would terminate prematurely if some exception occurred during cloning of some IDeepCloneable).

Note that this does not fix the recent fail on the build server.

comment:40 Changed 5 years ago by ascheibe

r8050 fixed license information in services

comment:41 Changed 5 years ago by abeham

r8052: Fixed error message display when cloning fails

comment:42 Changed 5 years ago by ascheibe

r8053 fixed more licensing information and source formatting

comment:43 Changed 5 years ago by mkommend

r8061: Added svn:external to have a duplicate of the HL 3.3 test solution in the HeuristicLab.Tests directory, which is necessary for the builder.

comment:44 Changed 5 years ago by mkommend

r8062: Corrected external from https to http.

comment:45 Changed 5 years ago by mkommend

r8072: Removed external in HL.Tests.

comment:46 Changed 5 years ago by mkommend

r8073: corrected HL test lists.

comment:47 Changed 5 years ago by mkommend

r8077: Added builder.testsettings for branches.

comment:48 Changed 5 years ago by abeham

r8080: Fixed description of k-Means solution

comment:49 Changed 5 years ago by abeham

r8096: Added some missing dependencies to the "HeuristicLab-3.3" project (Clients, OKB, LawnMower)

comment:50 Changed 5 years ago by mkommend

r8106: Corrected behavior of SymbolicExpressionGrammarEditorView.

comment:51 Changed 5 years ago by jkarder

r8109: fixed creation and parsing of the resource string in the Hive Job Manager

comment:52 Changed 5 years ago by abeham

r8112: Created a default QAP instance when creating a new Robust Taboo Search

comment:53 Changed 5 years ago by gkronber

r8124: 'Hungarian Algorithm'

comment:54 Changed 5 years ago by mkommend

r8137: Added problem setter in IDataAnalsisAlgorithm.

comment:55 Changed 5 years ago by mkommend

r8139: Renamed indizes to indices in the whole trunk solution.

comment:56 Changed 5 years ago by ascheibe

r8140 fixed compiler warning

comment:57 Changed 5 years ago by sforsten

r8195: changed method name in test

comment:58 Changed 5 years ago by mkommend

r8202: Corrected output path of Problems.Instances.VehicleRouting.

comment:59 Changed 5 years ago by mkommend

r8209: Added necessary plugin dependency in HL.Problems.Instances.VehicleRouting.Views to HL.Mainform.WindowsForms.

comment:60 Changed 5 years ago by mkommend

r8222: Changed output path of HeuristicLab.Tests to .\bin for all configurations so that the test lists work correctly.

comment:61 Changed 5 years ago by mkommend

r8223: Corrected plugin dependencies in HeuristicLab.Problems.Instances.Views.

comment:62 Changed 5 years ago by gkronber

r8254: removed classification benchmark instance Iris because of bugs.

comment:63 Changed 5 years ago by swagner

  • Status changed from new to accepted

comment:64 Changed 5 years ago by swagner

  • Status changed from accepted to readytorelease

comment:65 Changed 5 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.