Opened 6 years ago

Closed 4 years ago

#1673 closed enhancement (done)

The Title of RunCollectionViews should be more specific

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.8
Component: Optimization.Views Version: 3.3.8
Keywords: Cc:

Description (last modified by mkommend)

Currently the title of all RunCollectionViews is built like 'RunCollection' + 'ViewName' and so two views of the same type are not distinguishable.

This can easily be changed by implementing INamedItem in RunCollections and synchronizing the name of the RunCollection with the name of the surrounding item (e.g., an algorithm or an experiment). The title of the view can then be built as 'RunCollection Name' + 'ViewType' (e.g. 'TestExperiment BubbleChart').

Change History (12)

comment:1 Changed 5 years ago by mkommend

  • Description modified (diff)

comment:2 Changed 5 years ago by mkommend

  • Milestone changed from HeuristicLab 3.3.7 to HeuristicLab 3.3.8

comment:3 Changed 5 years ago by jhelm

  • Owner changed from mkommend to jhelm
  • Status changed from new to accepted

comment:4 follow-up: Changed 5 years ago by jhelm

  • Owner changed from jhelm to swagner
  • Status changed from accepted to reviewing

r8738: Added new property AlgorithmName to the RunCollection and synced the property with the name of the surrounding IOptimizer. The AlgorithmName is used by the RunCollectionViews as prefix for its caption if it was set.

comment:5 in reply to: ↑ 4 Changed 5 years ago by mkommend

Replying to jhelm:

r8738: Added new property AlgorithmName to the RunCollection and synced the property with the name of the surrounding IOptimizer. The AlgorithmName is used by the RunCollectionViews as prefix for its caption if it was set.

The comments before were created by myself, but I was accidentally logged in as jhelm.

comment:6 Changed 5 years ago by mkommend

  • Owner changed from swagner to ascheibe

comment:7 Changed 5 years ago by ascheibe

r8930 set name of RunCollection in the BenchmarkAlgorithm

comment:8 follow-up: Changed 5 years ago by ascheibe

  • Owner changed from ascheibe to mkommend
  • Status changed from reviewing to assigned

Looks good, the only remark that I have is that AlgorithmName is maybe a bit misleading as this can also be the name of a BatchRun or Experiment. Maybe OptimizerName would be better?

comment:9 in reply to: ↑ 8 Changed 5 years ago by mkommend

Replying to ascheibe:

Looks good, the only remark that I have is that AlgorithmName is maybe a bit misleading as this can also be the name of a BatchRun or Experiment. Maybe OptimizerName would be better?

Yes you are right, OptimizerName fits much better. I will try if I can change the property without producing breaking the persistence.

comment:10 Changed 5 years ago by mkommend

  • Owner changed from mkommend to ascheibe
  • Status changed from assigned to reviewing

r8962: Added space in view caption between the optimizer name and the view name. Renamed AlgorithmName in RunCollection to OptimizerName as suggested by ascheibe.

comment:11 Changed 5 years ago by ascheibe

  • Owner changed from ascheibe to mkommend
  • Status changed from reviewing to readytorelease

Thanks very much! Looks good, I have additionally added a backwards compatibility region for AlgorithmName in r8967.

comment:12 Changed 4 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.5 to 3.3.8
Note: See TracTickets for help on using tickets.