Opened 6 years ago

Closed 6 years ago

#1657 closed defect (done)

PTC2 does not create evenly distributed trees according to the size constraints

Reported by: mkommend Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.6
Component: Encodings.SymbolicExpressionTreeEncoding Version: 3.3.6
Keywords: Cc:

Description

Currently the PTC2 does not respect the initial frequencies of the symbols and the created trees are not evenly distributed over all possible tree sizes. This may be related to the integration of the grammar editor and should be corrected.

Change History (11)

comment:1 Changed 6 years ago by mkommend

  • Owner changed from gkronber to mkommend
  • Status changed from new to accepted

comment:2 Changed 6 years ago by mkommend

r6911: Corrected and adapted implementation of !PTC2 to handle symbol frequencies correctly and to always create trees of the target size. Additionally the performance of the grammars have been improved and a unit test was added.

comment:3 Changed 6 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

comment:4 follow-up: Changed 6 years ago by gkronber

I observe exceptions from the ReplaceBranchManipulation operator when executing the symbolic classification sample.

comment:5 Changed 6 years ago by mkommend

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to assigned

Currently ADFs are not working correctly and the according operators must be adapted to the new changes.

comment:6 Changed 6 years ago by mkommend

  • Status changed from assigned to accepted

comment:7 Changed 6 years ago by mkommend

r6918: Corrected ADFs for GP and adapted and extended the specific unit test.

comment:8 in reply to: ↑ 4 Changed 6 years ago by mkommend

Replying to gkronber:

I observe exceptions from the ReplaceBranchManipulation operator when executing the symbolic classification sample.

I could not reproduce this issue on my machine. I ran the symbolic classification sample over 20 times with different random seeds and no exception occurred.

comment:9 Changed 6 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

comment:10 Changed 6 years ago by gkronber

  • Status changed from reviewing to readytorelease

Reviewed r6918 and r6911. Thanks for the additional unit test. The changes in PTC look good, and I tested the operator. LGTM.

comment:11 Changed 6 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.5 to 3.3.6
Note: See TracTickets for help on using tickets.