Opened 6 years ago

Closed 5 years ago

#1574 closed defect (done)

An experiment with batch runs containing SVM regression cannot be paused

Reported by: swinkler Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.6
Component: Optimization Version: 3.3.6
Keywords: Cc: vdorfer

Description

To reproduce this do the following: Create an experiment with batch runs, each containing a SVM solving a regression problem; press start; press pause, and then the execution is not paused.

Change History (7)

comment:1 Changed 6 years ago by mkommend

This issue is related to ticket #1573. The reason for this is that SVM algorithms cannot be pause and the execution state of batch runs is only paused if the nested optimizer is paused (the same holds for experiments). Therefore experiments and batch runs containing SVM algorithms are executed until they are finished.

comment:2 Changed 6 years ago by mkommend

  • Milestone changed from HeuristicLab 3.3.5 to HeuristicLab 3.3.6

comment:3 Changed 6 years ago by mkommend

  • Status changed from new to accepted

r6767: Decoupled execution states of Experiment and BatchRun with the nested optimizers.

comment:4 Changed 6 years ago by mkommend

  • Owner changed from mkommend to swinkler
  • Status changed from accepted to reviewing

comment:5 Changed 6 years ago by gkronber

reviewed r6767

comment:6 Changed 6 years ago by swinkler

  • Owner changed from swinkler to mkommend
  • Status changed from reviewing to readytorelease

comment:7 Changed 5 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.4 to 3.3.6
Note: See TracTickets for help on using tickets.